
Chapter 15

Complex Animation
 Learning Objectives 
After completing this chapter, you will be able to:
• Create dummy objects
• Use graph editor to add, copy, and position keys
• Create snapshot objects
• Hide objects during animation
• Animate and link camera
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INTRODUCTION
In this chapter, you will learn to animate objects using dummy objects. Dummy objects link the 
objects to control their movement. If several objects are linked to a dummy object, the dummy 
can be used to move all objects simultaneously. The objects linked to a dummy can also be moved 
individually without affecting the dummy object or any other object linked to the dummy object.

TUTORIAL
Before starting the tutorial, you need to download the c15_3dsmax_2020_tut.zip file from 
www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > 3ds 
Max > Autodesk 3ds Max 2020 for Beginners: A Tutorial Approach
	
Extract the contents of the zip file and save them in the Documents folder.

 Tutorial 1
In this tutorial,  you will create the animation of a steel manufacturing process. You will create 
dummy objects to assist in movement during animation, refer to Figure 15-1.	                	
								              (Expected time: 35 min)

Figure 15-1  Animation at different frames 

The following steps are required to complete this tutorial:

a.	 Create the project folder.
b.	 Open the file.
c.	 Create dummy objects.
d.	 Link the objects.
e.	 Set continuity value.
f.	 Animate the hook and cauldron.
g.	 Add a position key.
h.	 Create a snapshot.
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i.	 Hide the object during animation.
j.	 Hide the object using object properties.
k.	 Preview the animation.
l.	 Set the camera view.
m.	 Save and preview the animation.

Creating the Project Folder
Create the project folder with the name c15_tut1 in the 3dsmax 2020 folder, as discussed in 
earlier chapters.

Opening the File
1.	 Choose Open from the File menu; the Open File dialog box is displayed. In this dialog 

box, browse to the location \Documents\c15_3dsmax_2020_tut and select the c15_tut1_start.
max file from it. Choose the Open button to open the file, refer to Figure 15-2.

Figure 15-2  The c15_tut1_start.max file

2.	 Choose Save As from the File menu; the Save File As dialog box is displayed. Browse 
to the location \Documents\3dsmax 2020\c15_tut1\scenes. Save the file with the name 
c15tut1.max at this location.

Creating Dummy Objects
In this section, you will set the number of frames in the animation and create dummy objects.

1.	 Choose the Time Configuration button from the animation playback controls; the 
Time Configuration dialog box is displayed, as shown in Figure 15-3.

2.	 In the Animation area, set 150 in the Length spinner and choose the OK button; the total 
number of frames for the animation is set to 150.
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Figure 15-3  The Time Configuration dialog box

3.	 Choose Create > Helpers in the Command Panel. Next, invoke the Dummy tool 
from the Object Type rollout.

	
4.	 Restore the four viewports configuration and activate the Front viewport by clicking on it.
	
5.	 Click at a point below Cauldron and drag the mouse to create a small cube. Next, move the 

cube in the Left viewport to position it below Cauldron; a dummy object is created, as shown 
in Figure 15-4.

	 The size of the cube does not matter. This cube is the dummy object and will not be visible 
in the rendered animation. Resize the cube such that you can select it easily and it also does 
not interfere with the selection of other objects in the scene.

6.	 Enter Cal-Dummy in the Name and Color rollout.

7.	 Invoke the Dummy tool again from the Object Type rollout. In the Front viewport, click at 
a point below Base and drag the cursor to create another small cube. Adjust the position of 
the cube in the Left viewport to position it below Base, as shown in Figure 15-5.

	  
8.	 Enter Base-Dummy in the Name and Color rollout.
	
9.	 Activate the Top viewport. Next, use the Align tool from the Main Toolbar to center

Base-Dummy with the center of the Base object along the X and Y axes. Also, align the 
center of Cal-Dummy with the center of Cauldron along the X and Y axes.
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Figure 15-4  A dummy object created

Figure 15-5  Adjusting the position of the cube below Base
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Linking the Objects
In this section, you will link the objects in the scene. Linking more than one object to a dummy 
object simplifies the animation process and allows individual movement later in the animation.
	
1.	 Invoke the Select and Link tool from the Main Toolbar.    

2.	 Click Cauldron and drag the cursor to Cal-Dummy and then release the left mouse button, 
refer to Figure 15-6. Invoke the Select Object tool to exit the Select and Link tool.

Figure 15-6  Linking Cauldron with Cal-Dummy 

	 When the first object is selected, the link cursor appears. On dragging the mouse button 
and releasing it on the second object, the two objects will be linked. Cauldron becomes a 
child of Cal-Dummy and will follow its movement.

3.	 Choose the Select and Link tool. Next, click Hook, drag the cursor to Cal-Dummy, and release 
the left mouse button. Invoke the Select Object tool to exit the tool; Hook becomes a child 
of Cal-Dummy and follows its movement.

	
4.	 Choose the Select and Link tool. Next, click Base, drag the cursor to Base-Dummy, and 

release the left mouse button; Base becomes a child of Base-Dummy. Now, invoke the Select 
Object tool to exit the tool.

Setting Continuity Value
In this section, you will set the continuity value using the Set Controller Defaults dialog box. 
Continuity controls the movement of an object through animation keys and creates life-like or 
mechanical motion. 
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A continuity default value can be set before creating animation keys so that you need not adjust 
each key later.

1.	 Choose Customize > Preferences from the menu bar; the Preference Settings dialog box 
is displayed. Next, choose the Animation tab in the Preference Settings dialog box.

2.	 In the Controller Defaults area, choose the Set Defaults button; the Set Controller Defaults 
dialog box is displayed, as shown in Figure 15-7. 

3.	 In this dialog box, select TCB Float from the list and then choose the Set button; the TCB 
Default Key Values dialog box is displayed, as shown in Figure 15-8. 

Figure 15-7  The Set Controller Defaults 
dialog box

Figure 15-8  The TCB Default Key Values 
dialog box

4.	 In this dialog box, set the value 0 in the Continuity spinner and then choose the OK button.

5.	 Choose OK in the Set Controller Defaults dialog box. Next, choose OK in the Preference 
Settings dialog box.

Animating the Hook and Cauldron
In this section, you will animate Hook and Cauldron. To create an animation, a series of keys are 
defined. 
	
1.	 Choose the Toggle Auto Key Mode button to turn the animation mode on (red).     
  
	 When the Toggle Auto Key Mode button is chosen (red), any transformation creates an 

animation key on the current frame. If this button is off, the transformation is applied to 
frame 0 regardless of the current frame.

2.	 Drag the time slider to frame 25. Alternatively, you can set the value in the spinner at the 
left side of the Time Configuration button as 25. 

	
3.	 Activate the Front viewport and click Cal-Dummy. Next, right-click on the Select and Move 

tool; the Move Transform Type-In dialog box is displayed, refer to Figure 15-9. 
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4.	 Set the value 300 in the X spinner of the Offset:Screen area and press the ENTER key; 
Cauldron is now centered over Base.

	

Figure 15-9  The Move Transform Type-In dialog box 

5.	 Drag the time slider to frame 50.

6.	 Make sure Cal-Dummy is selected. In the Move Transform Type-In dialog box, set –300 in 
the Y spinner of the Offset:Screen area and press the ENTER key; Cauldron is placed on 
Base, refer to Figure 15-10.

Figure 15-10  The Cauldron placed on the circular Base

7.	 Close the Move Transform Type-In dialog box and exit the animation mode by choosing the 
Toggle Auto Key Mode button.

Adding a Position Key 
If the movement of Hook is animated, the movement would begin at frame 0 and would end at 
the active frame that was current when Hook was moved. As a result, Hook would gradually drift 
away from its parent object. To prevent this, Hook needs a position key added at frame 50. The 
position key locks the Hook’s position at frame 50. Any movement applied to Hook only affects 
the frames between frame 50 and the current frame. In this section, you will use different frame 
settings in the Track View - Dope Sheet window to create the position key.
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1.	 Select all objects in the viewport. Next, choose Graph Editors > Track View - Dope Sheet 
from the menu bar; the Track View - Dope Sheet window is displayed. 

2.	 In this window, click on the plus sign at the left of Hook and then click on the plus sign at the 
       left of Transform. Notice that currently there are no animation keys for Hook.

3.	 Choose the Add/Remove Key button on the upper left of the Track View - Dope Sheet 
window.      

                        
4.	 Click on the Position track for Hook at frame 50; a position key for Hook is created at frame 

50, refer to Figure 15-11. Next, close the Track View - Dope Sheet window.

Figure 15-11  The new key added to the Hook’s Position track

5.	 Drag the time slider to frame 55 and choose the Toggle Auto Key Mode button.

6.	 Select Hook in the Front viewport. Move Hook –60 units on the X axis and –60 units on the 
Y axis; Hook is detached from Cauldron.

7.	 Drag the time slider to frame 70. Next, move Hook 300 units on the Y axis.

8.	 Choose Graph Editors > Saved Track Views > Track View - Dope Sheet from the menu 
bar; the Track View-Dope Sheet window is displayed with the previous settings active.

9.	 Choose the Add/Remove Key button on the upper left of the Track View-Dope Sheet 
window. 

10.	 Zoom in the window and add a key in the Position track at frame 90 for Hook. Next, close 
the Track View-Dope Sheet window; the current position of Hook is recorded in a key at 
frame 90.

11.	 Choose the Absolute Mode Transform Type-In button; it is replaced by the Offset Mode 
Transform Type-In button.

12.	 Drag the time slider to frame 105. Next, in the Front viewport, move Hook –300 units on 
the Y axis.
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13.	 Drag the time slider to frame 110. Next, move Hook 60 units on the X axis and 60 units on 
the Y axis; Hook is reattached to Cauldron.

14.	 Choose Graph Editors > Saved Track Views > Track View-Dope Sheet from the menu bar; 
the Track View-Dope Sheet window is displayed. Next, select Cal-Dummy in the viewport 
and click on the plus sign on the left of Cal-Dummy and then click Transform in the Track 
View-Dope Sheet window.

15.	 Choose the Add/Remove Key button and add a key to the Position track at frame 110 for 
Cal-Dummy. Next, close the Track View-Dope Sheet window.

16.	 Drag the time slider to frame 130.

17.	 In the Front viewport, move Cal-Dummy 300 units on the Y axis; Cal-Dummy, Hook, and 
Cauldron move.

18.	 Drag the time slider to frame 150.
	
19.	 Move Cal-Dummy –300 units on the X axis.
	
20	 Choose the Toggle Auto Key Mode button to exit the animation mode. Next, drag the time 

slider to left and right to replay the animation. Alternatively, choose the Play Animation 
button to see the animation in the viewport.

	
Creating a Snapshot
The Snapshot tool duplicates an object in its current state, but unlike the Copy tool, it does 
not copy any animation keys associated with the object. The snapshot copy can then be used 
for complex animation sequences. In this section, you will create a snapshot of Cauldron and  
rotate it by 45 degrees.

1.	 Drag the time slider to frame 50. Next, select Cauldron.

2.	 Choose Tools > Snapshot from the menu bar; the Snapshot dialog box is displayed, as 
shown in Figure 15-12.

3.	 Make sure the Single radio button is selected in the Snapshot area. Also, select the Copy 
radio button in the Clone Method area, and then choose OK to close the dialog box.

	 A duplicate copy of Cauldron is created at the same location as the original. Therefore, the 
copy is to be moved to frame 50 and is named as Cauldron001.

Note
The Snapshot dialog box allows you to create multiple copies over a range of frames using the 
Range radio button or a single copy using the Single radio button.

4.	 Drag the time slider to frame 0.
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	 There are now two cauldrons in the scene: the original and the copy located at the original’s 
position at frame 50 when the snapshot was created.

	

Figure 15-12  The Snapshot dialog box

5.	 Invoke the Select and Link tool from the Main Toolbar.

6.	 Click and drag Cauldron001 to Base Dummy, as shown in Figure 15-13. Release the left mouse 
button and invoke the Select Object tool to exit the tool; Cauldron001 is now the child of 
Base Dummy and will follow its movement.

Figure 15-13  Linking Cauldron with Base-Dummy 

7.	 Select Base Dummy in the viewport.
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8.	 Choose Graph Editors > Saved Track Views > Track View-Dope Sheet from the menu 
bar; the Track View-Dope Sheet window is displayed. Next, click on the (+) plus sign at 
the left of Base-Dummy and Transform.

9.	 Make sure the Add/Remove Key button is activated and add a key to the Rotation 
track at frame 70 for Base Dummy. Next, close the Track View - Dope Sheet window.

10.	 Drag the time slider to frame 80. Choose the Toggle Auto Key Mode button to enter the 
animation mode. 

11.	 In the Front viewport, rotate Base Dummy object – 45 degrees on the Z axis, as shown in 
Figure 15-14.

Figure 15-14  Rotating Base-Dummy -45 degrees on the Z axis 

12.	 Drag the time slider to frame 90. In the Front viewport, rotate Base Dummy +45 degrees on 
the Z axis, as shown in Figure 15-15.

13.	 Choose the Toggle Auto Key Mode button to exit the animation mode. Next, drag the time 
slider left and right to replay the animation. 

Hiding the Object During Animation
All parts of the animation are now completed, but there are two cauldrons visible during the 
animation. You must turn off the visibility, or hide the cauldrons during different segments of 
the animation. In this section, you will hide object using the Track View - Dope Sheet window. 
There are two ways to do this. You can use the Track View - Dope Sheet window or modify the 
object’s properties.



Complex Animation	      15-13

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 15-15  Rotating Base-Dummy +45 degrees on the Z axis 

1.	 Select Cauldron in the viewport. Next, choose Graph Editors > Saved Track Views > Track 
View-Dope Sheet from the menu bar; the Track View - Dope Sheet window is displayed. 

2.	 Select Cauldron in the Track View - Dope Sheet window. Click on the (+) plus sign at the 
left of Cauldron.

3.	 Choose Edit > Visibility Tracks > Add from the menu bar in the Track View - Dope Sheet 
window; a visibility track is added for Cauldron.

4.	 Choose the Add/Remove Key button and add a key in the Visibility track at frame 0 for 
Cauldron, refer to Figure 15-16.

Figure 15-16  Adding a new key in the Visibility track at frame 0
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5.	 Right-click on the new key; the Cauldron\Visibility dialog box is displayed. In this dialog 
box, make sure 1.0 is set in the Value spinner. Also, set the square mechanical transition in 
the In and Out image tiles, as shown in Figure 15-17. Do not close the Cauldron\Visibility 
dialog box; Cauldron is fully visible at frame 0.

Figure 15-17  The Cauldron\Visibility dialog box

6.	 Add a key to the Visibility track at frame 50 for Cauldron.

7.	 In the Cauldron\Visibility dialog box, set the value 0 in the Value spinner. Also, set the In 
and Out image tiles to the square mechanical transition; Cauldron is invisible at frame 50. 
Close the Cauldron\Visibility dialog box.

8.	 Add a key in the Visibility track at frame 90 for Cauldron.

9.	 Right-click on the new key; the Cauldron\Visibility dialog box is displayed. In this dialog 
box, set the value 1.0 in the Value spinner. Also, set the In and Out image tiles to the square 
mechanical transition; Cauldron is fully visible at frame 0. Next, close the Cauldron\Visibility 
dialog box and the Track View-Dope Sheet window.

Hiding the Object Using Object Properties
In this section, you will hide the objects using the object properties.

1.	 Drag the time slider to frame 0. 

2.	 Select Cauldron001 in any viewport. Right-click in the viewport; the quad menu is displayed.  
Choose Object Properties from the lower-right quadrant of the quad menu; the 
Object Properties dialog box is displayed, as shown in Figure 15-18.
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Figure 15-18  The Object Properties dialog box

3.	 In this dialog box, make sure the By Object button is activated; the options in 
this area are activated. 

Note
If the By Layer button is displayed in the Object Properties dialog box, you need to click on this 
button so that the By Object button is displayed.                                                                                      

                                                                  
4.	 Set the value 0 in the Visibility spinner. Next, choose the OK button to close the 

Object Properties dialog box; Cauldron001 is invisible at this frame (frame 0). This also 
adds a visibility track in the Track View - Dope Sheet window.

5.	 Drag the time slider to frame 50 and then choose the Toggle Auto Key Mode button to 
enter the animation mode.  	
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6.	 Make sure Cauldron001 is selected. Next, right-click in the viewport; the quad menu is 
displayed. Next, choose Object Properties from the quad menu; the Object Properties 
dialog box is displayed. 

7.	 Set the value 1.0 in the Visibility spinner of the Object Properties dialog box.

	 You will notice that the corners of the spinner turn red indicating the parameter is animated. 

8.	 Choose the OK button to close the Object Properties dialog box; Cauldron001 becomes 
visible at frame 50.

9.	 Drag the time slider to frame 90. Make sure Cauldron001 is selected. Next, right-click in 
the viewport; the quad menu is displayed. Next, choose Object Properties from the quad 
menu. 

10.	 Set 0 in the Visibility spinner of the Object Properties dialog box. Next, choose the OK 
button to close the Object Properties dialog box; Cauldron001 is invisible at frame 90.

11.	 Choose the Toggle AutoKey Mode button to exit the animation mode. Drag the time slider 
left and right to replay the animation.

	 You will notice that Cauldron001 fades in and out. Therefore, you need to adjust the transition 
in the Track View - Dope Sheet window.

12.	 Choose Graph Editors > Saved Track Views > Track View-Dope Sheet from the menu 
bar; the Track View-Dope Sheet window is displayed. In this window, click on the plus sign 
on the left of Cauldron001 to expand the tree, if it is not already expanded.

	
13.	 Right-click on the first key in the Visibility track; the Cauldron001/Visibility dialog box 

is displayed. In this dialog box, set the In and Out image tiles to the square mechanical 
transition.

14.	 Repeat this for the visibility keys at frame 50 and frame 90. Close the Cauldron/Visibility 
dialog box and the Track View-Dope Sheet window.

15.	 Drag the time slider left and right to preview the animation or choose the Play Animation 
button.

	 Notice that Cauldron001 no longer fades in and out. The visibility changes for both cauldron 
objects are instantaneous which gives an illusion of only one cauldron in the scene.

Previewing the Animation
In this section, you will preview the animation. The preview animation is a low resolution/low 
color format used to quickly verify that the animation is working correctly.

1.	 Make sure the Camera-Lift viewport is activated.
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2.	 Choose Tools > Preview - Grab Viewport > Create Preview Animation from the menu 
bar; the Make Preview dialog box is displayed, as shown in Figure 15-19.

Figure 15-19  The Make Preview dialog box

3.	 In this dialog box, select the Frame Numbers check box in the Overlay area. Next, choose 
the Create button. If the Video Compression dialog box is displayed, choose OK to accept 
the default settings.

	 When the animation is completed, it is played in Windows Media Player. Notice that the 
invisible cauldrons will not appear clearly. This is just a representation in the preview 
rendering. In the final animation, the cauldrons are completely invisible.

Setting the Camera View
In this section, you will set the camera view such that all  objects are visible throughout the 
animation. 
	
1.	 Choose the Display tab in the Command Panel.     				           

2.	 In the Hide by Category rollout, clear the Cameras check box; the camera named Camera-Lift 
is displayed in the scene.

3.	 Invoke the Zoom Extents All tool; the scene is zoomed out in the viewports so that the 
camera and target fit on the screen.
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4.	 Set the Camera-Lift and Camera-Lift.Target in all viewports so that all objects in the scene 
are visible throughout the animation, refer to Figure 15-20.

Figure 15-20  Adjusting the Camera-Lift and Camera-Lift.Target in all viewports

	 Next, you will preview the animation to view the effect of moving the camera.
	
5.	 Make sure the Camera-Lift viewport is activated. Next, choose Tools > Preview - Grab 

Viewport > Create Preview Animation from the menu bar; the Make Preview dialog box 
is displayed.

6.	 In this dialog box, choose the Create button. If the Video Compression dialog box is 
displayed, choose the OK button to accept the default settings.

Saving and Previewing the Animation
In this section, you will create a quick preview of the updated animation to show the movement 
of  the camera target.
	
1.	 Change the background color of the scene to white by following the steps given in Tutorial 

1 of Chapter 2.

2.	 Choose Save from the File menu.

3.	 Make sure the Camera-Lift viewport is activated.

4.	 Choose Tools > Preview - Grab Viewport > Create Preview Animation from the menu 
bar; the Make Preview dialog box is displayed.
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5.	 Choose the Create button. If the Video Compression dialog box is displayed, choose the 
OK button to accept the default settings.

	 When the animation is completed, it is played in the Windows Media Player.

 Tutorial 2
In this tutorial, you will create a basket ball animation, as shown in Figure 15-21.     

(Expected time: 35 min)

Figure 15-21  Basketball animation at frame11

The following steps are required to complete this tutorial:

a.	 Create the project folder.
b. 	 Open the file.
c. 	 Animate the basketball.
d. 	 Fine-tune the animation.
e. 	 Save and render the animation.

Creating the Project Folder
Create the project folder with the name c15_tut2 in the 3dsmax 2020 folder, as discussed in 
earlier chapters.

Opening the File
1.	 Choose Open from the File menu; the Open File dialog box is displayed. In this dialog 

box, browse to the location \Documents\c15_3dsmax_2020_tut and select the c15_tut2_start.
max file from it. Choose the Open button to open the file, refer to Figure 15-22.
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Figure 15-22  The c15_tut2_start.max file

2.	 Choose Save As from the File menu; the Save File As dialog box is displayed. Browse 
to the location \Documents\3dsmax 2020\c15_tut2\scenes. Save the file with the name 
c15tut2.max at this location.

Animating the Basketball
In this section, you will set the number of frames in the animation and create keyframes.

1.	 Choose the Time Configuration button from the animation playback controls; the 
Time Configuration dialog box is displayed, as shown in Figure 15-23.

2.	 In the Animation area, set 120 in the Length spinner and choose the OK button; the total 
number of frames for the animation is set to 120.

	
3.	 Make sure the time slider is set at frame 0. Next, choose the Toggle Auto Key Mode button.

4.	 Drag the time slider to frame 5 and select basketball. Next, right-click on the Select and Move 
tool in the Main Toolbar; the Move Transform Type-In dialog box is displayed. In this 
dialog box, set  555, -132, and 880 in the X, Y, and Z spinners of the Absolute World area, 
refer to Figure 15-24; the basketball is positioned, as shown in Figure 15-25 and keyframes 
are created at frame 0 and 5. Do not close the Move Transform Type-In dialog box.

5.	 In the Command Panel, choose the Display tab. Next, scroll down and select the Motion 
Path check box from the Display Properties area. You will notice that motion path of 
basketball is visible now, refer to Figure 15-26.
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Figure 15-23  The Time Configuration dialog box

Figure 15-24  Values in the Move Transform Type-In dialog box

Figure 15-25  The basketball positioned at frame 5

6.	 Drag the time slider to frame 10. In the Move Transform Type-In dialog box, set 555, 147, 
and 859 in the X, Y, and Z spinners of the Absolute World area; keyframe is created at 
frame 10 and basketball is positioned, as shown in Figure 15-27.
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Figure 15-26  The basketball motion path displayed

Figure 15-27  The basketball positioned at frame 10

7.	 Similarly, drag the time slider to frames and set the values in the Move Transform Type-In 
dialog box as given in Table 15-1. Next, close this dialog box. Figure 15-28 shows basketball 
positioned at frame 120.

Table 15-1 The transformation values of basketball

Frames to be selected X Y Z
20 555 228.5 503
30 555 111 29
40 555 -134 368
50 555 -347 29
60 555 -508 251
70 555 -647 29
80 555 -780 159
90 555 -1011 29
120 555 -2448 29
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Figure 15-28  The basketball positioned at frame 120

8.	 Choose the Play Animation button to play the animation.

	 Next, you will rotate basketball. To do so, you will use the Track View Dope Sheet window.

9.	 Make sure basketball is selected. Next, choose Graph Editors > Track View - Dope Sheet 
from the menu bar; the Track View Dope Sheet window is displayed.

10.	 In this window, click on the plus sign at the left of basketball and then click on the plus sign at 
	 the left of Transform. Notice that currently position keys are assigned to basketball. 

11.	 Select the Rotation track from the list at the left in the Track View Dope Sheet window, 
refer to Figure 15-29.

12.	 Choose the Add/Remove Key button on the upper left of the Track View - Dope Sheet 
window and then click on the Rotation track for basketball at frame 0; a keyframe is created 
at frame 0. 

13.	 Right-click on the keyframe on the Rotation track at frame 0; the Basketball/Rotation dialog 
box is displayed. In this dialog box, make sure 0 is displayed in the Angle spinner and 1 is 
displayed in the X spinner, as shown in Figure 15-29.  Next, close this dialog box.

14.	 Make sure the Add/Remove Key button is chosen on the upper left of the Track 
View - Dope Sheet window and then click on the Rotation track for basketball at frame 30; 
a keyframe is created at frame 30. 

15.	 Right-click on the keyframe on the Rotation track at frame 30; the Basketball/Rotation 
dialog box is displayed. In this dialog box, set 180 in the Angle spinner and make sure 1 is 
displayed in the X spinner. Next, close this dialog box.

16.	 Select the keyframe on the Rotation track at frame 0. Next, press and hold the SHIFT key 
and drag the keyframe to frame 51, refer to Figure 15-30; keyframe at frame 0 is copied to 
frame 51. 
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Figure 15-29  The basketball/Rotation dialog box

Figure 15-30  Keyframe dragged to frame 51

17. 	Similarly, copy the keyframe on the Rotation track at frame 0 to frames 71 and 90. Next,  
copy the keyframe on the rotation track at frame 30 to frame 80.

18.	 Make sure the Add/Remove Key button is chosen on the upper left of the Track 
View - Dope Sheet window and then click on the Rotation track for basketball at frame 50; 
a keyframe is created at frame 50. 

19.	 Right-click on the keyframe on the Rotation track at frame 50; the Basketball/Rotation 
dialog box is displayed. In this dialog box, set 360 in the Angle spinner and make sure 1 
is displayed in the X spinner. Next, close this dialog box. Now, copy the keyframe on the 
Rotation track at frame 50 to frames 70 and 120. 

	 Next, you will create the squash and stretch effect on basketball when it touches Floor.

20.	 Select Scale from the list in the Track View Dope Sheet window. Next, choose the Add/
Remove Key button on the upper left of the Track View - Dope Sheet window and then  
click on the Scale track for basketball at frame 0; a keyframe is created at frame 0, refer to 
Figure 15-31. 

	 Next, you will copy the keyframe at frame 0 to frame 29 so that basketball is not scaled till it 
touches the floor.
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Figure 15-31  Keyframe created at frame 0

21. Choose the Move Keys button on the upper left of the Track View - Dope Sheet window. 
Next, select the keyframe on the Scale track at frame 0 and copy this keyframe to frame 29 
as discussed earlier.

22.	 Make sure the Add/Remove Key button is chosen on the upper left of the Track View - 
Dope Sheet window and then click on the Scale track for basketball at frame 30; a keyframe 
is created at frame 30. 

23.	 Similarly, create keyframes on the Scale track at frame 40.

24. Right-click on the keyframe on the Scale track at frame 30; the Basketball/Scale dialog box 
is displayed. Set 85 in the Z Value spinner, refer to Figure 15-32, and close the dialog box.

Figure 15-32  The basketball/Scale dialog box

25.	 Right-click on the keyframe on the Scale track at frame 40; the Basketball/Scale dialog box 
is displayed. Set 100 in the Z Value spinner and 85 in the Y Value spinner. Next, close the 
dialog box.

26.	 Choose the Move Keys button on the upper left of the Track View - Dope Sheet window.  
Next, select the keyframe on the Scale track at frame 30. Now, press and hold the SHIFT 
key and drag the keyframe to frame 50; the keyframe at frame 30 is copied to frame 50. 

27.	 Similarly, copy the keyframe on the Scale track at frame 30 to frames 70 and 90. Also, copy  
the keyframe on the Scale track at frame 40 to frames 60 and 80.
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28.	 Copy the keyframe on the Scale track at frame 0 to frame 120.

29.	 Choose the Play Animation button to play the animation.

Fine-tuning the Animation
In this section, you will fine tune the animation using the Track View - Dope Sheet window.
	
1.	 Make sure basketball is selected. Next, select the keyframe on the Position track at frame 30  

and right-click on it; the Basketball/Position dialog box is displayed. In this dialog box, set 
0 in the Continuity spinner, refer to Figure 15-33.

Figure 15-33  The basketball/Position dialog box

2. 	 Repeat step 1 for the keyframes on the Position track at frames 50, 70, and 90. As a result,  
weight will be added to basketball when it touches floor.

Saving and Rendering the Animation
In this section, you will render the animation and create an AVI file. Next, you will play the 
rendered animation.
	
1.	 Choose Save from the File menu.

2.	 Make sure the Camera viewport is activated and invoke the Render Setup tool; the Render 
Setup: Default Scanline Renderer dialog box is displayed.

3.	 In the Time Output area, select the Active Time Segment radio button.

4.	 In the Render Output area, choose the Files button; the Render Output File dialog box 
is displayed. As the project folder is already set, the renderoutput folder of this project is 
displayed in the Save in text box. Select AVI File (*.avi) from the Save as type drop-down 
list.

5.	 In the File name text box, enter c15tut2render and choose the Save button; the path of 
the file is displayed in the Render Output area of the Render Setup dialog box.
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	 If the AVI File Compression Setup dialog box is displayed, choose the OK button to close 
it.

6.	 Make sure that the Save File check box is selected in the Render Output area. Now, choose 
the Render button to render the animation and close the Render Setup dialog box.

	
	 It will take several minutes to render the animation frame by frame. After the rendering is 

complete, close the render window. 	

7.	 Browse to the renderoutput folder of the c15_tut2 project and double-click on the 
c15tut2render.avi file; the AVI file is played in the Windows Media Player. 

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:
	
1.	 Which of the following tools duplicates an object in its current state, but does not copy any 

animation key associated with the object?

		  (a) Copy				    (b) Dummy
		  (c) Snapshot				    (d) None of these

2.	 An object can be linked to a __________ object, and it will then follow the movement of the 
dummy object.

3.	 A dummy object will not be visible on __________.
	
4.	 The __________ window can be used to create a position key.

5.	 While adjusting the key information of a key in an object’s visibility track, the setting of 
__________ in the Value spinner will make the object completely visible.

	
6.	 An object can be made invisible by creating a visibility track in Track View - Dope Sheet 

window, or by adjusting the object’s __________.

7.	 When a camera is animated, both  __________ and __________ can be moved or rotated.

8.	 On selecting __________ in the Display Properties rollout of the Command Panel, camera’s 
path is displayed in the viewport.

9.	 Frames that have animation keys for the camera are indicated in the trajectory by white 
boxes. (T/F)
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 Review Questions 
Answer the following questions:

1.	 Which of the following dialog boxes is used to set total number of frames in an animation?
		
		  (a) Set Controller Defaults			   (b) Time Configuration
		  (c) Object Properties	 			   (d) None of these

2.	 The __________ objects are used to control the movement of other objects by linking them, 
but they are not visible in rendering.

3.	 The __________ tool is used to link one object with another.

4.	 The __________ button is used to add keys to Track View - Dope Sheet.

5.	 The __________ option verifies the current state of animation.	

6.	 The Snapshot tool is similar to the Copy command. (T/F)

EXERCISE
The rendered sequence of the scene used in the following exercise can be accessed by downloading 
the c15_3dsmax_2020_exr.zip from www.cadcim.com. The path of the file is as follows: Textbooks > 
Animation and Visual Effects > 3ds Max > Autodesk 3ds Max 2020 for Beginners: A Tutorial Approach

 Exercise 1
Extract the contents of the c15_3dsmax_2020_exr.zip and then open c15_exr01_start.max.  Next, 
animate the vise, refer to Figures 15-34 through 15-37. 		       (Expected time: 20 min)

   

Figure 15-34  Animation at frame 50 Figure 15-35  Animation at frame 75
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Figure 15-37  Animation at frame 150Figure 15-36  Animation at frame 125
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Answers to Self-Evaluation Test
1. c, 2. dummy, 3. rendering, 4. Track View - Dope Sheet, 5. 1.0, 6. properties, 7. camera, 
target, 8. Trajectory, 9. T


