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Learning Objectives

After completing this chapter, you will be able to:

* Understand the Autodesk 3ds Max interface components
* Use controls for creating or modifying objects

* Use and customize hotkeys in Autodesk 3ds Max

* Customize the colors of the scene elements
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INTRODUCTION TO Autodesk 3ds Max 2021

Welcome to the world of Autodesk 3ds Max, an advanced application that is used to create still
or animated 3D models and objects. With the help of this application, you can create realistic
scenes by modifying objects, applying maps and materials to a scene, assigning environment
to a scene, adding lights and cameras, and so on. Before working with Autodesk 3ds Max, you
should have the basic knowledge of various tools and commands available in this software. In
this chapter, you will learn the basic features of Autodesk 3ds Max.

GETTING STARTED WITH Autodesk 3ds Max

First, you need to install Autodesk 3ds Max 2021 on your computer. On installing the software,
the 3ds Max 2021 shortcut icon will be created automatically on the desktop. Double-click on
this icon to start Autodesk 3ds Max. Alternatively, you can start Autodesk 3ds Max from the
Start menu. To do so, click the Start button from the taskbar to display the Start menu and then
choose Autodesk > 3ds Max 2021, refer to Figure 1-1.

3ds Max 2021 Create

3ds Max 2021 - Brazilian Portuguese
Thursday

3ds Max 2021 - English 9

3ds Max 2021 - French
3ds Max 2021 - German

3ds Max 2021 - Japanese ‘k
3ds Max 2021 - Korean

3ds Max 2021 - Simplified Chinese

Explorer

3ds Max Interactive 2.5.0.0

A360 Desktop ﬁ

Autodesk Desktop App

)

Microsoft Store Microsoft Edge

Autodesk Download Manager Partly Sunny 0
Play music at

= home or on the
Change Graphics Mode 860 2? go. 9
Change Graphics Mode New Delhi Spotify =] Skype
License Transfer Utility - 3ds Max 2.

A

License Transfer Utility - 3ds Max 2... b

BEEN e

“ MaxFind &= Paint 3D

L Type here to search B

Figure 1-1 Starting Autodesk 3ds Max 2021 from the taskbar

When you start 3ds Max the first time, the Welcome Screen is displayed, as shown in Figure 1-2.
The Welcome Screen consists of a set of slides that contain information for new users to inspire
and get them started. If you do not want to see the Welcome Screen the next time you start 3ds
Max, clear the Show this Welcome Screen at startup check box located in the bottom-left corner
of the screen. You can bring back the Welcome Screen anytime by choosing Help > Welcome
Screen from the menubar.
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If you can dream it, you can build it in 3ds Max®, the 3D software for modeling,
animation, and rendering that allows you to create massive worlds in games and
stunning scenes for design visualization.

¥ Show this Welcome Screen at startup

Figure 1-2 The Welcome Screen

STARTING A NEW FILE IN Autodesk 3ds Max

To start a new file in Autodesk 3ds Max, choose the File > New from the menu bar; a new file
will be displayed in the 3ds Max interface. The new file will clear all the contents of the current
file. Alternatively, press the CTRL+N keys; the New Scene dialog box will be displayed, as
shown in Figure 1-3. By default, the New All radio button is selected in this dialog box. Choose
the OK button; a new file will be displayed.

You can also reuse the objects from the current scene in the new scene. Select the Keep Objects
radio button in the New Scene dialog box to keep only the objects from the current scene for
the new file. However, on selecting this radio button, all the animation keys and links between
the objects will be cleared. To keep the objects and the links between them, select the Keep
Objects and Hierarchy radio button. However, in this case, the animation keys will be deleted.

Before starting a new scene in Autodesk 3ds Max, it is recommended to reset Autodesk 3ds Max
and start afresh. By doing so, you will be able to reset all settings for the new scene. To reset
Autodesk 3ds Max, choose Reset from the File menu; the 3ds Max message box will be displayed,
as shown in Figure 1-4. The message box will ask if you really want to reset 3ds Max. Choose
the Yes button; the 3ds Max will be reset.

3 Mew Scene ? >
Options: 3 3ds Max ? *
@ ) Keep Objects and Hierarchy
@ Keep Objects @ Do you really want to reset?
® New Al
S o e

Figure 1-3 The New Scene dialog box Figure 1-4 The 3ds Max message box
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Autodesk 3ds Max INTERFACE COMPONENTS

The 3ds Max interface consists of different components, as shown in Figure 1-5.
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Figure 1-5 Different screen components of Autodesk 3ds Max interface

You can customize the interface in a variety of ways by adding toolbars, moving toolbars and
Command Panel, and so on. The interface in 3ds Max is high DPI aware that ensures that the
interface scales correctly to the latest high DPI displays.

You can easily customize the workspace by floating and docking elements of a scene such as
panels, windows, menu, and so on. You can dock or float any element that has the handle. A
handle is denoted by double dotted line. A handle can be on the top or left of the element,
refer to Figure 1-6.
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Figure 1-6 The handles marked with arrows

To float an element, click-drag the handle. As you drag around the element over the interface,
valid docking areas are highlighted in blue. If you want to dock the element, drop it on the blue
highlighted area. Keep in mind that the toolbars can only be docked on the outer edge of the
interface. When you move around the elements over the interface, not all elements will resize
automatically. Sometimes, manual adjustment might be required.
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The 3ds Max interface components are discussed next. T —
Render Shift+Q, Shift+F9
¥ Render in the Cloud
Menu Bar B Open Autodesk A360 Gallery
The menu bar is located just below the title bar, refer to | ¥%&ende .. B
. . . & Rendered Frame Window...
Figure 1-5 and contains various pull-down menus. Some of e e
the pull-down menus are standard window menus such as File, Camera Sequencer. .
Edit, Help, and so on while others are 3ds Max pull-down Scene Converter...
menus such as Create, Modifiers, Animation, Graph Editors, Exposure Control...

Environment... 8

Rendering, Customize, and so on. The title of each pull-down -

menu indicates the purpose of commands in the menu. When .

. A % Render to Texture...
you choose one of the menu titles, Autodesk 3ds Max displays Bake to Texture...
the corresponding pull-down menu. Each menu consists of | & Render Surfece Map...
a collection of commands. In a pull-down menu, the dots | _ "= '

. . . . . Material/Map Browser...
after a command indicate that a dialog box will be displayed | & yaera exorer...
on choosing that command. An arrow next to a command Video Post...
indicates that a cascading menu will be displayed on placing Panorama Exporter...
the cursor on that command. For some of the commands in s Renger
the pull-down menus, the keyboard shortcuts are displayed P ———

on their right side, as shown in Figure 1-7. Render Message Window...
Compare Media in RAM Player...

Print Size Assistant...

Workspaces Figure 1-7 The keyboard shortcuts
The workspace includes toolbars, menus, the ribbon, @ the Rendering pull-down menu
hotkeys, quad menus, and viewport layout presets. You can

switch between different workspaces by selecting the required option from the Workspaces
drop-down list located on the top-right corner of the interface, refer to Figure 1-5. To create a
new workspace, you need to change the interface setup as required and then choose the Manage
Workspaces option from the Workspaces drop-down list; the Manage Workspaces dialog box
will be displayed. In this dialog box, choose the Save as New Workspace button; the Create
New Workspace dialog box will be displayed. Enter the name for the workspace in the Name
text box in the New Workspace area and then choose the OK button to close the dialog box.
Next, close the Manage Workspaces dialog box. The newly created workspace will be active now.

Toolbars

In Autodesk 3ds Max, various commands can be invoked by using the buttons or tools in the
toolbars. By default, only the Main Toolbar will be displayed on Autodesk 3ds Max screen.
However, you can display other toolbars such as Snaps, Axis Constraints, Extras, MassFX
Toolbar, and so on in the 3ds Max interface. Also, you can move, resize, and undock them
based on your requirements. To display these toolbars, right-click in the blank area on the Main
Toolbar; a shortcut menu will be displayed with the names of all toolbars, as shown in Figure 1-8.
Next, choose the required toolbar; the chosen toolbar will be displayed on the screen. Also, you
can hide any of the displayed toolbars by choosing its label from the shortcut menu.

The Main Toolbar provides quick access to many tools and dialog boxes such as Select and Link,
Unlink Selection, Select Object, Material Editor, and so on. This toolbar is docked just below the
menu bar. You will learn more about the tools available in various toolbars in the later chapters.
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Command Panel

By default, the Command Panel is docked on the right in the 3ds Max screen. There are six
tabs in the Command Panel: Create, Modify, Hierarchy, Motion, Display, and Utilities, as
shown in Figure 1-9. Most of the 3ds Max modeling and animation tools are placed in these
tabs. The tools in the Command Panel are used to create, modify, and animate the objects. Each
tab has several rollouts that can be expanded or collapsed. The tabs in the Command Panel
are discussed next.
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Figure 1-8 The shortcut  Figure 1-9 The Command
menu displayed to view the  Panel
hidden toolbars

The Create tab is chosen by default. The tools in the Create tab are used to create objects,
cameras, lights, and so on.

The Modify tab is used to modify the selected objects by modifying their parameters,
applying various modifiers, and editing the mesh as well as polygonal and patch objects.

The Hierarchy tab is used to control the links in the hierarchy, joints, and inverse
kinematics.

The Motion tab is used to control the animation controllers and trajectories.
The Display tab is used to hide and unhide the objects in the viewports.

The Utilities tab is used to access various utility programs.

Scene Explorer

The Scene Explorer is used to view, select, filter, and sort objects. It is also used to rename,
delete, group, freeze, and hide objects. By default, the Scene Explorer is docked on the left in
the default workspace, refer to Figure 1-5. It is discussed in detail in Chapter 2.
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Viewports %
When you start Autodesk 3ds Max, the default interface screen appears. This interface @
consists of four equal sized viewports surrounded by tools and commands, refer to Figure 1-5.
These viewports are labeled as Top, Front, Left, and Perspective. The viewports in Autodesk 3ds
Max are used to create 3D scenes. Also, they enable you to view a scene from different angles.
When you create an object in the viewport, the Top, Front, and Left viewports will display the
top, front, and left orthographic views of the object, respectively.

You can loop between viewports to make a particular
viewport active by using the WINDOWS+SHIFT keys. [ Perspective] [Standard]
The active viewport in 3ds Max is highlighted with a yellow et e 2l
border. Only one viewport can remain active at a time. All
commands and actions in 3ds Max are performed in the
active viewport. You can switch between the viewports by
using the WINDOWS + SHIFT keys. However, if only one
viewport is maximized, then on repeatedly pressing the
WINDOWS + SHIFT keys, a window with available
viewports will be displayed, refer to Figure 1-10. When
the WINDOWS + SHIFT keys are released, the window
will disappear and the viewport you have chosen will
become active.

ng

You can modify the size of the viewports by dragging
the intersection of the viewports on the splitter bars. To
restore the original layout, right-click on the intersection
of the dividing lines; a shortcut menu will be displayed, Figure 1-10 Selecting a viewport to
as shown in Figure 1-11. Choose the Reset Layout option  make it active

from the shortcut menu; the viewports will be restored to

their default size.

On the bottom left corner of each viewport, there is a world-space tripod, as shown in Figure 1-12.
The world-space tripod has three axes, X, Y, and Z, which are displayed in red, green, and blue
colors, respectively. The tripod always refers to the world coordinate system, regardless of the
local coordinate system. ViewCube is placed at the top right corner of the viewport, refer to
Figure 1-12. The ViewCube provides visual feedback of the current orientation of the viewport.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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Figure 1-11 The Reset Layout option in the shortcut menu

[+ ] [Perspective ] [Standard ] [Defauk Shading ]

Grid ViewCube

Figure 1-12 The world space tripod, grid, and ViewCube in the Perspective viewport

« Note
\ " The ViewCube will not be visible in the camera and light viewports.

It is important to note that the Local coordinate system defines local position of an object in a
scene whereas the World coordinate system uses fixed axes to define the position of all the objects
in the world space. Each viewport has a grid placed in it, refer to Figure 1-12. It is like a graph
paper in which all the lines intersect each other at right angles. You can modify the spacing in
the grids. The grids in all viewports act as an aid to visualize the spacing and distance while
creating objects. Also, they are used as a construction plane to create and align the objects. You
can also use the grids as a reference system while using the snap tools to align the objects. You
can also hide the grid in the viewport. To do so, press the G key; the grid will disappear from
the viewport. To make the grid visible, press G again.
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At the top left corner of each viewport, there are four viewport labels: General viewport label,
Point of view (POV) viewport label, Settings viewport label, and Shading viewport label, refer
to Figure 1-13. When you click on any of the viewport labels, the corresponding flyout will be
displayed, as shown in Figure 1-14. The options in these shortcut menus are used to modify
various aspects of the active viewport.

When you click on the General viewport label, general options related to viewport are dis-
played in a flyout. In this flyout, the Float Viewport option is added as a new option in the list.
When you choose the Float Viewport option, a cascading menu will be displayed, as shown
in Figure 1-14 (a). The options in the cascading menu are used to make the current viewport a
floating viewport. These options do not remove the current viewport but simply make a copy of
the current viewport and make it floating. The floating viewports can be moved as needed and
still have the same viewport labels, refer to Figure 1-14 (b).

You can configure the active viewport by using the options in the General viewport label
menu. Choose the Configure Viewports option from this menu; the Viewport Configuration
dialog box will be displayed. Various options in this dialog box can be used to configure the
viewports. You already know that four equally sized viewports are displayed on the screen.
However, you can change the viewport configuration based on your requirement. To change
the basic configuration of the viewports, choose the Layout tab of the Viewport Configuration
dialog box, refer to Figure 1-15. In the Layout tab, you can specify the division method of the
viewports. There are 14 types of configurations displayed at the top in the tab. Select the required
configuration and then choose the OK button; the viewports will be displayed according to the
configuration that you have selected in the Viewport Configuration dialog box.
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Show Safe Frames Shift+F
Wiewport Clipping

@ Undo View Change Shift+Z
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Figure 1-13 The viewport labels in the Front Figure 1-14 The flyout displayed on clicking
viewport the POV viewport label
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Figure 1-14 (a) The cascading manu displayed Figure 1-14 (b) The Floating viewport
on choosing the Float Viewport option

Note
The viewport configuration specifies how the viewports will be arranged on the screen.

You can change the default viewport to any other viewport type available such as Bottom, Right,
and so on, by using the options in the POV viewport label menu. To do so, click on the POV
viewport label; a flyout will be displayed. Choose the viewport that you want to display. Using
the Settings viewport label, you can change the display quality in viewports as well as lighting,
shadows, and material settings. Different types of shading types that can be defined using the
Settings Viewport label are: Default shading, Facets, Flat color, Bounding Box, Clay, and so
on. However, some other shading types are available in the cascading menu of the Stylized
option, refer to Figure 1-16. These shading types are Graphite, Color Pencil, Ink, and so on.
You can choose any one of the options to change the shading.

3 Viewport Configuration ? x

lD\splayPerfnrmancElEackgmund Layout | Safe Frames | Regions | Statistics | ViewCube [ SteeringWheels

[DeF 2t Shading]
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= B8 B0 B8 6 =

Facets

Bounding Box

Flat Color

Hidden Line

Clay

Model Assist

Stylized 3
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— Edged Faces

'|—|T5|5|—|—|—|— Display Selected 4
Viewport Background 4
141 |
4 | Per-View Preference

Figure 1-15 The Layout tab of the Viewport Figure 1-16 The flyout displayed on clicking
Configuration dialog box the Shading viewport label
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Viewport Navigation Controls

There are various tools available at the bottom right corner of the Autodesk ol R
3ds Max screen, as shown in Figure 1-17. These tools are known as o T

viewport navigation controls and they are used to control the display -
and navigation of the viewport. The tools displayed in the viewport Figure1-17 Theviewport
navigation controls depend on the viewport selected. For example, if navigation controls

the Camera viewport is selected, its corresponding tools will be displayed

in the viewport navigation control. These tools are discussed in detail in

the later chapters.

Viewport Layout Tab Bar

The Viewport Layout tab bar enables you to store multiple viewport setups in a single scene. You
can switch between different viewport setups with a click. To display the viewport layout tab bar
if it is not displayed, right-click in the blank area on the Main Toolbar; a shortcut menu will be
displayed with the names of all toolbars. Next, choose the Viewport Layout Tabs option; the
Viewport Layout tab bar will be displayed on the screen. By default, there is a single tab at the
bottom of the bar that represents the startup layout. To add more layout tabs to the bar, click
on the arrow button on the bar; the Standard Viewport Layouts flyout will be displayed. Next,
choose the required option from the flyout; the chosen layout tab will be added to the bar. To
remove a tab from the bar, right-click on the tab; a shortcut menu will be displayed. Next, choose
Delete Tab from the shortcut menu.

Animation Playback Controls el b, e o
The tools in the animation playback controls are displayed on the left side _*~ L %
of the viewport na'Viga.tion'controls, 'refer.to Figure 1-18. These tools are used Figure 1-18 The
to control the animation in the active viewport. Also, you can set the total = .

o : . anmimation playback
number of frames, animation length, and other settings of the animation .
using these tools.

Animation Keying Controls

The tools in the animation keying controls are displayed on the -b. e S:med -
left side of the animation playback controls, refer to Figure 1-19. S 7,
These tools are used to enter or exit different animation modes. Figure 1-19 The animation

keying controls
Track Bar
The track bar lies between the time slider and the status bar, refer to Figure 1-20. It displays a
timeline along with the frame numbers.

F Time Slider r Track bar
= 100 |

o/ =
| i, mlI\III\||||||||||||\I\|\I\I\I\|\III\||||||\III\III\III\III\|||\III\III\||||||\III\I\I\I\I\I\I\I\I\II
: 1 20 30 40 S0 &0 m 80 20 190

Figure 1-20 The track bar and the time slider

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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Time Slider

The time slider displays the current frame and the total number of frames in the current time
segment, refer to Figure 1-20. You can view the animation at each frame by dragging the time
slider. The time segment is the total range of frames that you can access using the time slider.
By default, it ranges from 0 to 100. You can set the range using the Time Configuration dialog
box, about which you will learn in the later chapters.

Status Bar

There are various tools in the status bar that provide information about the scene and the active
command, as shown in Figure 1-21. The prompt line, which is located at the bottom of the screen,
displays information about the active command or tool. On top of the status bar, a text box known
as the status line is available. This status line displays the number of currently selected objects
(current selection set). The Selection Lock Toggle tool available on the right side of the status
bar is used to lock the selection set. The Coordinate display/transform type-in area displays the
X, Y, and Z coordinates of the cursor or the currently selected object. The Coordinate display/
transform type-in area can also be used to enter transform values while moving, scaling, or
rotating the selected object(s).

Absolute Mode Tranzform Type-In

Selection Lock Toggle — Coordinate display Adaptive
Status line |solate Selection Togale r Degradation
[ ] | |
None Selected :l: ﬂ B ¥ 7e- Grid = 010"~
Weloome o | ooy or dick-and-drag to select objects & Add Time Tag—‘

Time Tag area J J
Grid Setting display area

Figure 1-21 The status bar

The Grid setting display area is placed on the right of the Coordinate display area. It displays the
size of the grid. The Time tag area located below the Grid setting display area is used to assign
the text labels at any point of time in your animation. Click on the Time tag area; a flyout with
the Add Tag and Edit Tag options will be displayed. Use these options to add or edit the text
labels at any point of time in your animation.

The Adaptive Degradation button placed on the right of the prompt line is used to improve
the viewport performance in a complex scene by decreasing the visual fidelity of some of the
objects temporarily. This results in smoother viewport motions and object transformations in
such scenes. It also improves viewport quality incrementally, depending on the availability of
processing time. To activate this feature, right-click on the Adaptive Degradation button; the
Viewport Configuration dialog box will be displayed, as shown in Figure 1-22. The Display
Performance tab is chosen by default in this dialog box. Change the settings in the Display
Performance tab based on your requirement and choose the OK button.
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Figure 1-22 The Viewport Configuration dialog box

MAX CREATION GRAPH

Max Creation Graph uses node based Max Creation Graph Editor. Using this editor, you can
create customized tools which are used to create various geometrical shapes, create modifiers,
specify render settings, create utilities, and so on. To open Max Creation Graph Editor, choose
Scripting > Max Creation Graph Editor from the menu bar; the Max Creation Graph-Untitled
window will be displayed, as shown in Figure 1-23. This window has a menu bar at the top and
four panels: Operator Depot, Node Properties, View Navigator, Message Log, and active graph
view. All these panels in the Max Creation Graph-Untitled window can be resized, undocked,
and closed.

The Operator Depot panel consists of a number of nodes and operators under various categories.
These categories are 3ds Max, Array, Bitmap, and so on. Click on the arrow at the left of the
category name to expand it. The Node Properties panel provides detailed information of
selected operator/node.

The view panel is used to connect nodes and operators. You need to drag the nodes and
operators from the Operator Depot panel to the active view to create a graph. These nodes
and operators has input and/or output connector(s) to create a network of nodes and operators.
This network is then evaluated using the commands in the menu bar to create customized tools.
The Message Log panel displays messages for the network created in the Main Graph Window
panel once the networks are evaluated. On creating the network of nodes and operators, you
need to evaluate it and save it at the default location with desired name to use it as a customized
tool in 3ds Max interface.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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Figure 1-23 The Max Creation Graph - Untitled window

SNAPS SETTINGS

Snaps restrict the movement of the cursor to a specific part of an object or grid. There are four
buttons available for snap settings in the Main Toolbar: Snaps Toggle, Angle Snap Toggle,
Percent Snap Toggle, and Spinner Snap Toggle. If you right-click on the Snaps Toggle, Angle
Snap Toggle, or Percent Snap Toggle button, the Grid and Snap Settings dialog box will be
displayed, as shown in Figure 1-24. In this dialog box, you can select difterent parts of the objects
or grid where the cursor will snap to. You can turn the snap command on and oft by pressing
the S key or by choosing the Snaps Toggle tool. If you choose and hold the Snaps Toggle tool,
a flyout will be displayed. This flyout contains the 2D Snap, 2.5 Snap, and 3D Snap tools, which
can be chosen to snap the cursor.

3 Grid and Snap Settings - >

J Snaps l Options ] Home Grid ] User Grids ]

Standard | Cverride OFF
21 1 Grid Paints I 1 Grid Lines
A Pivot 1 ¥ Bounding Box
b Perpendicular O [ Tangent
i0 1 vertex [* = Endpaint
Og ¥ Edge/Segment A 1 Midpoint
A\ MFace %/ I Center Face
o il

Figure 1-24 The Grid and Snap Settings
dialog box

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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Snaps Toggle

Main Toolbar: Snaps Toggle
Menu bar: Tools > Grids and Snaps > Snaps Toggle
Keyboard: S

The Snaps Toggle tool is used to snap the objects on the grid. On invoking
the Snaps Toggle tool, a flyout will be displayed, as shown in Figure 1-25.
This flyout has three tools which are discussed next.

2D Snap Figure 1-25 The

If you choose the 2D Snap tool from the Snaps Toggle flyout, then Snaps Toggle flyout

the cursor snaps to the active grid in two dimensions, X and Y. The
Z-axis is not taken into consideration.

2.5D Snap
51 If you choose the 2.5D Snap tool from the Snaps Toggle flyout, then the cursor snaps
to the vertices and edges of the objects projected on the active grid.

3D Snap

=1 Ifyou choose the 3D Snap tool from the Snaps Toggle flyout, then the cursor snaps to
FY o ;

(o] any object in 3D space using the 3D Snap tool.

On moving the gizmo or snap handle, this axis center will act as the start snap point. This feature
also helps in increasing the accuracy of snaps.

Angle Snap Toggle

Main Toolbar: Angle Snap Toggle
Menu bar: Tools > Grids and Snaps > Angle Snap Toggle
Keyboard: A

%) The Angle Snap Toggle tool enables you to rotate an object in angular increments. The
B increment value is specified in the Angle spinner of the Grid and Snap Settings dialog
box. By default, the value in the Angle spinner is set to 5.0.

Percent Snap Toggle

Main Toolbar: Percent Snap Toggle
Menu bar: Tools > Grids and Snaps > Percent Snap Toggle
Keyboard: CTRL+SHIFT+P

The Percent Snap Toggle tool enables you to scale an object in percent increments. The
increment value can be specified in the Percent spinner of the Grid and Snap Settings
dialog box. By default, the value set in the Percent spinner is set to 10.0.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com



Evaluation Copy. Do not reproduce. For information visit www.cadcim.com

1-16 Autodesk 3ds Max 2021: A Comprehensive Guide

Spinner Snap Toggle
Main Toolbar: Spinner Snap Toggle

%) The Spinner Snap Toggle tool is used to set the single increment or decrement value
™ | forall the spinners in Autodesk 3ds Max. By default, the increment or decrement value

is set to 1. To set the increment value, right-click on the Spinner Snap Toggle tool; the
Preference Settings dialog box will be displayed. In this dialog box, choose the General tab, if
it is not already chosen. Now, in the Spinners area, set a value in the Snap spinner, refer to
Figure 1-26.

Spinners
Also, select the Use Snap check box and then choose the OK Precsion: 3 3 Decmals
button; the Spinner Snap Toggle tool in the Main Toolbar is Snap: (BOTTE W Use Snap
chosen. Now, when you use any spinner in 3ds Max, the value Wirap Cursor Near Spinner

will i'ncrea}se or decrease accordi‘ng to t'he value that you have g gure 1-26 The Spinners
specified in the Preference Settings dialog box.

UNITS SETUP

The units setup in 3ds Max is used to specify the units that help in measuring the geometry
in a scene. You can change the settings for units by using the Customize pull-down menu. To
do so, choose Customize > Units Setup from the menu bar; the Units Setup dialog box will
be displayed, as shown in Figure 1-27. By default, the Generic Units radio button is selected
in the Display Unit Scale area in this dialog box. You can select any other radio button as per
the requirement from the Display Unit Scale area of this dialog box and then choose the OK
button; the limits in all the spinners in 3ds Max will be modified accordingly.

area in the Preference Settings
dialog box

Setting Grid Spacing

To set the spacing between the visible grids in the viewports, choose Tools > Grids and Snaps >
Grid and Snap Settings from the menu bar; the Grid and Snap Settings dialog box will be
displayed. Choose the Home Grid tab in this dialog box, as shown in Figure 1-28. In the Grid
Dimensions area, set the value in the Grid Spacing spinner to specify the size of the smallest
square of the grid. The value in the spinners will be measured in the units that you specify in
the Units Setup dialog box. Set the value in the Major Lines every Nth Grid Line spinner to
specify the number of squares between the major lines in the grid. Set the value in the Perspective
View Grid Extent spinner to specify the size of the home grid in the Perspective viewport. Note
that the default grid displayed in the viewports on starting 3ds Max is known as the home grid.

In the Dynamic Update area, the Active Viewport radio button is selected by default. It is used
to update the active viewport according to the new values of the Grid and Snap Settings dialog
box. Select the All Viewports radio button to update all viewports simultaneously according to
the new values that you set in the spinners of the Grid and Snap Settings dialog box.
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'3 Units Setup

Figure 1-27 The Units Setup dialog box Figure 1-28 The Home Grid tab chosen
in the Grid and Snap Settings dialog box

UNDO AND REDO TOOLS

The Undo tool is used to revert the last actions performed while creating or modifying a model
in Autodesk 3ds Max. To undo an action, choose the Undo tool from the Main Toolbar or press
the CTRL+Z keys. You need to choose the Undo tool repeatedly till all the previously performed
actions are reversed. To reverse a number of actions at a time, right-click on the Undo tool in the
Main Toolbar; a shortcut menu will be displayed, refer to Figure 1-29. Move the cursor over the
number of actions that you want to reverse; the actions will be selected and then choose Undo.
By default, you can reverse your actions up to 20 times. If you want to change this number,
choose Customize > Preferences from the menu bar; the Preference Settings dialog box will
be displayed. By default, the General tab is chosen in this dialog box. In the Scene Undo area,
set the new value in the Levels spinner, as shown in Figure 1-30.

Figure 1-29 The list of actions displayed ~— Figure 1-30 The Scene Undo area
in the Preference Settings dialog box

Im.com
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The Redo tool is used to revert the last actions performed by the Undo tool. To redo an action,
choose the Redo tool from the Main Toolbar or press the CTRL+Y keys. You need to choose the
Redo tool repeatedly till you want to reverse the actions performed earlier. To reverse number
of actions at a time, right-click on the Redo tool in the Main Toolbar; a list of last actions will
be displayed in the shortcut menu. Move the cursor over the number of actions that you want
to reverse; the actions will be selected. Next, choose Redo; the selected action will be displayed.

HOLD AND FETCH TOOLS

Menu bar: Edit > Hold or Fetch
Keyboard: CTRL+H (Hold) or ALT+CTRL+F (Fetch)

Sometimes you may want to perform experiments on a scene. In such as a case you need to hold
the scene. The Hold tool is used to hold a scene and to save the work done in a temporary file
with the name maxhold.mx.

The file is saved at the location |\Documents\3dsmax\autoback. To perform an experiment in a scene,
choose the Hold tool from the Edit menu or press the CI'RL+H keys. Next, if you need to go back
to the previous command, choose the Fetch tool from the Edit menu or press ALT+CTRL+F;
the About to Fetch. OK? dialog box will be displayed, as shown in Figure 1-31. Choose the Yes
button; the scene with the previous command will be displayed. In this way, you can go back to
a series of commands using the Hold tool.

Note
When you use the Fetch tool in a scene, the history of the actions performed so far will be deleted.
As a result, you cannot undo or redo the actions performed before invoking this tool.

IMPORTING FILES Neyy,

In 3ds Max, you can import files from different formats. The Import command in the File menu
is used to import a 3D geometry from other softwares for photorealistic rendering and perfect
animation. To invoke this command, choose File > Import from the menubar; a cascading menu
will be displayed. The options in the cascading menu are: Import, Merge, Replace, Link Revit,
Link FBX, and Link AutoCAD. These options are discussed next.

Import

The Import option is used to load files that are in different file | 2 Aboutto Fetch. 0k2
formats. You can import FBX, DWG, DXF, OB]J, IGES (Initial

Graphics Exchange Specification), CATIA V4 (MODEL, DIV4,

DILV3, DLV, EXP, SESSION, MDL), SolidWorks file format e At et 402
(SLDPRT and SLDASM), and Autodesk Inventor (IPT and

IAM) file formats. You can also import Pro/ENGINEER filesin |

3ds Max to enhance and texture your model for final rendering. FERES Yes o
3ds Max can import advanced vector drawing files from Adobe

Illustrator software to design the 3D company logo. Figure 1-31 The About to Fetch.
Adobe Tllustrator is a vector-based graphics application. You OK? dialog box

can also import Virtual Reality file formats to create immersive
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and interactive architectural visualizations. You can import and export IGES (Initial Graphics
Exchange Specification) files from 3ds Max. The IGES file format is used for 3D printing.

Merge

The Merge option is used to combine two files in such a way that the resulting file has all the
objects from both the files. You can merge a file into your existing file. To do so, choose File >
Import >Merge from the menubar.

Replace
The Replace option is used to replace the objects in the current 3ds Max scene with objects from
an external file. To do so, choose File > Import > Replace from the menubar.

Link Revit, Link FBX, and Link AutoCAD

You can link 3ds max file with the files in other Autodesk software. The Link Revit, Link FBX,
and Link AutoCAD options are used to maintain a live link between two Autodesk softwares.
When you are using two or more Autodesk products, you can link the files using the File Link
Manager. To do so, choose File > Import > Link Revit/Link FBX/Link AutoCAD from the
menubar. You can also choose Utilities > More > File Link Manager from the Command Panel.

EXPORTING FILES ey

In 3ds Max, you can export files to different file formats. To do so, choose File > Export from
the menubar; a cascading menu will be displayed. The options in the cascading menu are:
Export, Export Selected, Publish to DWF, and Game Exporter. The Export option is used to
export the entire file. The Export Selected option is used to export selected 3D objects from
the scene to different file formats. By default, the Export Selected option is hidden. When you
select a 3D object in the scene then only this option will be enabled. The Publish to DWG
option is used to export all the AutoCAD drawing files. The Game Exporter option is used to
easily export models and animation clips in the game engine.

HOT KEYS

In 3ds Max, you can use the hot keys to choose some of the commonly used tools and commands.
These keys are known as the hot keys. You can work faster and more efficiently using the hot keys.
The major hot keys and their functions are listed next.

Main Toolbar

The hot keys that can be used to invoke the tools available in the Main Toolbar are given next:

H Invokes the Select From Scene dialog box
S Invokes the Snaps Toggle tool

A Invokes the Angle Snap Toggle tool
CTRL+SHIFT+P Invokes the Percent Snap Toggle tool

M Invokes the Material Editor dialog box
SHIFT+Q Invokes the Render Production tool

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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Viewport Navigation Controls

The hot keys that can be used to invoke the tools available in the viewport navigation controls

are given next:

ALT+CTRL+Z Performs the action of the Zoom Extents tool
ALT+W Invokes the Maximize Viewport Toggle tool
ALT+Z Invokes the Zoom tool

CTRL+W Invokes the Zoom Region tool

CTRL+P Invokes the Pan View tool

Scroll the middle mouse button Zooms in or out the active viewport

CTRL+R Invokes the Orbit tool

SHIFT+Z Used to undo the Zoom or Pan command actions

ALT+ press and hold the middle
mouse button and move the mouse

Performs the actions of the Orbit tool

The following hot keys are used to change the POV viewport labels:

\4 Invokes the viewport quad menu

T Invokes the Top viewport

F Invokes the Front viewport

L Invokes the Left viewport

P Invokes the Perspective viewport

B Invokes the Bottom viewport

U Invokes the Orthographic viewport

Animation Playback Controls

The hot keys that can be used to invoke the tools available in the animation playback controls

are given next:

N Invokes the Auto Key tool
Home Go to start frame

End Go to end frame

/ (backslash) Plays animation

ESC Stop the animation

, (comma) Go to previous frame

. (period) Go to next frame
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Customizing the Hot Keys

In 3ds Max, you can create your own keyboard shortcuts. To do so, choose Customize > Customize
User Interface from the menu bar; the Customize User Interface dialog box will be displayed,
as shown in Figure 1-32. In this dialog box, the Keyboard tab is chosen by default. Next, select a
command from the Group and Category drop-down lists each; the list of corresponding actions
will be displayed just below the Category drop-down list. Now, select one of the actions from
the list and then enter the key that you want to assign to the selected action in the Hotkey text
box. Next, choose the Assign button; the key is assigned to the selected action.

3 Customize User Interface 7 X
Keyboard | Mouse | Toolbars [ Quads | Menus | Colors
Group: | Main UT B g acive
Category: Al Commands v
ction sharta B wowey: [

1230
32D Pan Zoom Mode Assigned to:
3ds Max Facebook...
3ds Max Feedback...
3ds Max Help
3ds Max Home Pag...
3ds Max Security T...
A360 Cloud Rende...
&; About MassFX
Absolute
Activate Grid (Cont...
Activate Grid Object
Activate Home Grid
Activate HomeGrid ...
Active Viewport 1
Active Viewport 2
Active Viewport 3
Active Viewport 4 ¥ Overrides Active
i ActiveShade Floater
ActiveShade Mode
ActiveShade Quad

Assign Remove

Delay To Override: [0.25

Adaptive Degradati... O f Writa Keyboard Chart...
Adaptive Perspecti...

Add v Load... Save... Resat

Figure 1-32 The Customize User Interface dialog box

CUSTOMIZING THE COLORS OF THE USER INTERFACE

3ds Max allows you to modify the colors of the interface. You can modify the colors for almost
every element in the interface. To modify the colors, choose Customize > Customize User
Interface from the menu bar; the Customize User Interface dialog box will be displayed.
Choose the Colors tab from this dialog box, refer to Figure 1-32. Next, select the category of
the interface element from the Elements drop-down list; the list of the corresponding elements
will be displayed just below the Elements drop-down list. Now, select one of the elements from
the list and click on the Color swatch on the right of the Elements drop-down list; the Color
Selector dialog box will be displayed. Select a new color and choose the OK button to close the
Color Selector dialog box.

To reset the new color to the default one, click on the Reset button located next to the Color
color swatch. You can also reset all the changes you made to colors. To do so, choose the Reset
button at the bottom of the Customize User Interface dialog box; the Revert Color File message
box will be displayed, as shown in Figure 1-33. Choose the Yes button; the default colors will
be displayed in the color swatches.
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3 Revert Color File

If you continue, you will lose all changes you made to your menus since
! you started this session.

Continue?

Figure 1-33 The Revert Color File message box

HELP PREFERENCES

When you choose Help > Autodesk 3ds Max Help from the menu bar, the 3ds Max help
will be displayed. If you want to open help from a local drive, you need to download it from
http:/fwww.autodesk.com/3dsmax-helpdownload-enu and then install it on your system. Next,
choose Customize > Preferences from the menu bar; the Preference Settings dialog box will
be displayed. Choose the Help tab in this dialog box, refer to Figure 1-34. Select the Local
Computer/ Network radio button from the Help Location area and then choose the Browse
button; the Browse For Folder dialog box will be displayed. Select the path where you have saved
the file and then choose the OK button to exit the dialog box. Next, choose the OK button in
the Preference Settings dialog box; the dialog box will be closed. Now, you can access the help
from your local drive.

3 Preference Settings 7 X

[ General l Files l Viewports l Interaction Mode l Gamma and LUT ] Rendering ]
[ Radiosity I Animation l Inverse Kinematics l Gizmos l MAXScript ] Containers l Help l

Help Location

® Autodesk Web Site

Local ComputerNetwark

Download... Browse... Reset

Figure 1-34 The Help tab chosen in the Preference Settings dialog box

If you choose Help > Search 3ds Max Commands from the menu bar or press X, a search field
will be displayed, refer to Figure 1-35. Next, enter the initial characters of a command; a list of
command names that contain the specified characters will be displayed, refer to Figure 1-36.
Now, you can execute the desired command by choosing it from the list displayed.

Note

For the printing purpose, this textbook will follow the white background. However, for better
understanding and clear visualization, this textbook will follow other color schemes as well at
various places. In addition, the Default Shading shading type has been used throughout the
textbook in all screen captures. Moreover, at some places in figures, grids have been hidden for
better understanding and visualization.
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Figure 1-35 The search field Figure 1-36 List of commands displayed
on entering first few characters

TIPS AND TRICKS

In 3ds Max, there are many features for the new users which they need to get familiar with. W%‘
We have provided information of some of the features in the form of tips and tricks below.
This will help users to work efficiently.

To avoid crashing of system while working on complicated scenes, you can disable autobackup
(save often) option. To enable or disable autobackup, choose Customize > Preferences in
the menubar; the Preferences Settings dialog box will be displayed. In this dialog box,
choose the Files tab. In the Auto Backup area, select or clear the Enable check box. You
can save incrementally to keep a record of progress.

To make the selected object transparent, press ALT + X (toggle key).

To speed-up the workflow, choose the Bounding Box option from the Shading viewport
label flyout.

Press 7 to display the total polygons and vertex count in the viewport.

To increase scene undo levels, you can change the value in the Levels spinner of the General
tab in the Preference Settings dialog box.

Right-click on the Snap icon in the Main Toolbar to access the snap settings.

Press CTRL + C to insert camera in the Perspective view.
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Right-click on the Select, Rotate, and Scale icons in the Main Toolbar to input values for
transformation of an object.

While creating a spline, press BACKSPACE to remove the last created vertex.
Hold the CTRL key to pan quickly in the viewport.
Press I to get the cursor position at the center of the viewport.

Right-click on the Modifiers List drop-down list in the Command Panel to access new list
of hidden modifiers.

Use CTRL + L to deactivate active lights in viewports.
If you have problem with the display of your textures, it is probably because some of the
faces of your model are reversed. To ensure that the polygons have the proper orientation,

use the Normal modifier.

To create the project folders, navigate to File > Manage > Set Project Folder in the
menubar.

If the transform gizmo disappears, press X to bring it back.
Press ALT + W to maximize or minimize a viewport.

Use G to turn the Grid off and on.

To lock any object, select it and then press SPACEBAR.

To select an edge loop, pick one of the edges from it, hold SHIFT, and then select the
next edge.

Press the ALT + Q keys to isolate a selected object.
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Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this
chapter:

1.

10.

Which of the following buttons is used to improve the performance of a viewport in a complex
scene by temporarily decreasing the visual fidelity of some of the objects?

(a) Adaptive Degradation (b) Time Configuration
(c) Auto Key (d) All of these

Which of the following tabs should be chosen to control the animation controllers?

(a) Motion (b) Display
(c) Hierarchy (d) None of these

Which of the following dialog boxes is used to set the spacing in the grids displayed in the
viewports?

(a) Customize User Interface (b) Grid and Snap Settings
(c) Units Setup (d) All of these

The provides visual feedback of the current orientation of the viewport.

The is located at the bottom of the screen and displays the information about
the active command or tool.

The is used to float an element of the interface.

Most of the 3ds Max modeling and animation tools can be chosen from the tabs located in
the Command Panel. (T/F)

The default interface of 3ds Max consists of three equal sized viewports surrounded by tools
and commands. (T/F)

In 3ds Max, you can modify the colors of almost every element in the interface. (1/F)

The tools in the animation playback controls are used to control the display of a viewport.
(T/F)
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Review Questions

Answer the following questions:

1. Which of the following combinations of keys is used to choose the Pan tool?

(a) CTRL+P (b) SHIFT+7Z
(c) CTRL+A (d) CTRL+W
2. The is located between the time slider and the status bar.
3. The tool located on the right of the status bar is used to lock a selection set.

4. The Viewport Layout Tabs bar enables you to store multiple viewport setups in a single
scene. (T/F)

5. Snapping restricts the movement of the cursor to a specific part of an object or grid. (1/F)

6. The options in the General viewport label menu are used for defining the type of
shadings displayed in the viewport. (T/F)

Answers to Self-Evaluation Test
1. a, 2. a, 3. b, 4. ViewCube, 5. prompt line, 6. handle, 7. T, 8. F, 9. T, 10. F



