Chapter 2

Drawing Sketches for
Solid Models

Learning Objectives

After completing this chapter, you will be able to:
* Start NX and create a new file in it

* Invoke different NX environments

* Understand the need of datum planes

* Create three fixed datum planes

* Create sketches in the Modeling environment

* Create sketches in the Sketch in Task Environment
* Use various drawing display tools

* Understand different selection filters

* Select and deselect objects

* Use various sketching tools

* Use different snap point options

* Delete sketched entities

* Exit the sketching environment
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INTRODUCTION

Most designs created in NX consist of sketch-based and placed features. A sketch is a combination
of two-dimensional (2D) entities such as lines, arcs, circles, and so on. The features such as
extrude, revolve, and sweep created by using 2D sketches are known as sketch-based features.
The features such as fillet, chamfer, thread, and shell created without using a sketch are known
as placed features. In a design, the base feature or the first feature is always a sketch-based
feature. For example, the sketch shown in Figure 2-1 is used to create the solid model shown in
Figure 2-2. In this model, the fillets and the chamfers are the placed features.

Fillets

Sharp cormers

JAN

Chamfers

Figure 2-1 Profile for the sketch-based feature of ~ Figure 2-2  Solid model created using the
the solid model shown in Figure 2-2 sketch-based and placed features

As mentioned earlier, to create sketch-based features, you first need to create its sketch. In NX,
you can create a sketch by using two methods: Direct sketch and Sketch in Task Environment.

In the Direct sketch method, you can create sketch, as required, directly in the Modeling
environment by using the sketching tools such as Line, Arc/Circle, and Point from the Base
group of the Curve tab of the Ribbon. Once the sketch has been drawn, you can directly use
the solid modeling tools to convert the sketch into a sketch-based feature.

In the Sketch in Task Environment method, to create the sketch, you need to invoke the sketching
environment by using the Sketch tool from the Home tab of the Ribbon. You will learn more
about creating sketches by using these methods later in this chapter.

Unlike other solid modeling software packages where you need separate files for starting different
environments, NX uses only a single type of file to start different environments. In NX, files are
saved in the .pr¢ format and all the environments required to complete a design can be invoked in
the same .prt file. For example, you can draw sketches and convert them into features, assemble
other parts with the current part, and generate drawing views in a single .pr¢ file.

STARTING NX

You can start NX by double-clicking on its shortcut icon on the desktop of your computer. The
default initial interface of NX is shown in Figure 2-3 and it displays basic information about
NX. You can view more information by clicking on the buttons available in the Resource Bar
which is displayed on the left of the NX screen, refer to Figure 2-3.
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Figure 2-3 The default initial interface of NX

STARTING A NEW DOCUMENT IN NX

Ribbon: Home > Standard > New
Menu: File > New

To start a new file, choose the New tool from the Standard group of the Home tab in
[C?-) the Ribbon or choose Menu > File > New available at the left on the Top Border Bar;
New  the New dialog box will be displayed, as shown in Figure 2-4.

New X
A
Multi Axis Deposition Inspection Press Line Line Designer
Line Designer Workareas Model Drawing Additive Manufacturing Machining Line Planner Manufacturing
» Templates ¥ Preview
= Filters
Name Type Units Relationship Owner
> Model Modeling Millimeters  Stand-alone NT AUTHO...
# Assembly Assemblies Millimeters  Stand-alone NT AUTHO...
£7 Shape Studic Shape Studio Millimeters  5tand-alone MNT AUTHO..,
& Sheet Metal Sheet Metal Millimeters  Stand-alone NT AUTHO...
%35 Routing Logical Routing Logical ~ Millimeters Stand-alone MNT AUTHO..,
? Routing Mechanical Routing Mecha... Millimeters Stand-alone NT AUTHO...
4 Routing Electrical Routing Electrical Millimeters Stand-alone NT AUTHO... > Praperties
[ Blank Gateway Millimeters Stand-alone none Name: Model

Type: Modeling

Units: Millimeters

Last Modified: 08/03/2020 07:00 PM
Description: NX Example with datum CSY5

~ Mew File Name

Name | =]
Folder | CAProgram Files\Siemens\NXStudentEdition 1926\UG| \

= Dot 4n Defnennen

Figure 2-4 The New dialog box

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com



Evaluation Copy. Do not reproduce. For information visit www.cadcim.com

2-4 Siemens NX 2021 for Designers

’ Note

@ The Top Border Bar is not displayed by default in the initial screen of the new part file. To
make it visible, right-click in the Ribbon area; a shortcut menu will be displayed. Next, select the
Top Border Bar option from it.

The tabs and options in this dialog box are discussed next.

Templates Rollout

In the New dialog box, templates are grouped together under various environment types such
as Model, Drawing, Manufacturing, Inspection, Machining Line Planner, Press Line, Additive
Manufacturing, Multi Axis Deposition, Line Designer Workareas, and Line Designer. The
template files related to these environments are available in their respective tabs. These files
are used whenever you start a new file. These template files provide a predefined set of tools
with specified environment. This saves a lot of time in setting environment and displaying tools
according to your requirements.

Model Tab

By default, this tab will be chosen and the modeling templates will be displayed in the Templates
rollout. Some of the important modeling templates are discussed next.

Model

By default, the Model template is selected and it is used to start a new part file in the Modeling
environment for creating solid and surface models.

Assembly
The Assembly template is used to start a new assembly file in the Assembly environment for
assembling various parts of the assembly.

Shape Studio
The Shape Studio template is used to start a new part file in the Shape Studio environment for
creating advanced surface models.

Sheet Metal

The Sheet Metal template is used to start a new file in the Sheet Metal environment for creating
sheet metal models.

Routing Logical
This template contains tools capable of supporting different types of routing designs, for example,
piping, tubing, and HVAC.

Routing Mechanical

This template provides mechanical routed system design tools for tubing, piping, conduit, and
raceways. Mechanical routed system models are fully associative to NX assemblies which in turn
facilitate design changes.
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Routing Electrical
This template provides tools which offer a flexible interface to logical connectivity data and
rapid path creation between components.

Blank

This template is used to start a new file in the Gateway environment. The Gateway environment
allows you to examine the geometry and drawing views created. You cannot modify a model in
the Gateway environment. However, you can invoke any environment of NX from it.

Drawing Tab

This tab is used to specify a template for a drawing. These templates are contained in the
Templates rollout and are used to start a new drawing file in the Drafting environment for
generating the drawing views. These templates are arranged according to the sheet size
(A0, Al, A2, A3, and A4) in the Drawing tab.

Units

This drop-down list is available in the Filters sub-rollout of the Templates rollout and is used
to filter the templates as per the unit. The options in this drop-down list are discussed next.

Millimeters
If you select the Millimeters option, the templates only with the millimeters unit will be
displayed in the Templates rollout.

Inches
If you select the Inches option, the templates only with the inches units will be displayed in the
Templates rollout.

All
Select the All option to display all the templates (with both millimeters and inches units).

New File Name Rollout
This rollout is used to specify the name and location to save the file. The options in this rollout
are discussed next.

Name

Enter the name of the new file in the Name text box. Alternatively, choose the button on the
right side of the Name text box; the Choose New File Name dialog box will be displayed. Type
the name in the File name edit box. Also, to specify the location to save the new file, browse the
folder where you need to save the file and choose the OK button. However, there is a separate
option to specify the location, which is discussed next.

Folder

Specity the location to save the new file in the Folder text box. Alternatively, choose the button
on the right side of the Folder text box; the Choose Directory dialog box will be displayed.
Next, browse the folder where you want to save the file and choose the OK button.
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~~—~. Note

@ 1. It 1s recommended that you create a folder with the name NX in the primary drive of your

k computer and then create individual folder for each chapter within the NX folder. Now, you can
save the part files of all the chapters in their respective folders. This will enswre a better organization
of the panrt files created.

2. In this textbook, the Model template has been used for starting a new file for illustration purpose.
After specifying all the required options in the New dialog box, choose the OK button; the new

file will open in the specified environment. Figure 2-5 shows the initial screen of the new file
invoked by using the Model template.
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Figure 2-5 Initial screen of the new part file

Tip

1. To change the color of curves and dimensions, choose Menu > Preferences > Sketch from
the Top Border Bar; the Sketch Preferences dialog box will be displayed. Next, choose the
Part Settings tab if not already chosen to change the color of curves and dimensions.

INVOKING DIFFERENT NX ENVIRONMENTS

You can invoke different environments of NX by selecting their respective templates from
the New dialog box. In NX, you can also switch from one environment to another. To do so,
choose the File tab from the Ribbon; a menu will be displayed, refer to Figure 2-6. Next, hover
the cursor over the All Applications option from the Start area of the menu; a flyout will be
displayed. Now, you can invoke the desired environment by selecting the required option from
the flyout displayed.
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Figure 2-6 Menu showing different environments of NX

CREATING THREE FIXED DATUM PLANES (XC-YC, YC-ZC,
XC-ZC)

Ribbon: Home > Construction > Datum Drop-down > Datum Plane
Menu: Insert > Datum > Datum Plane

In NX, you can create the sketch of the base feature by selecting a reference plane of
the datum coordinate system as a sketching plane. Also, you can also create three fixed
datum planes (YC-ZC, XC-ZC, and XC-YC) and then use one of them as the sketching
plane for creating the sketch of the base feature. To create three fixed datum planes, choose
Menu > Insert > Datum > Datum Plane available at the left on the Top Border Bar. Alternatively,
choose the Datum Plane tool from the Construction group of the Ribbon; the Datum Plane
dialog box will be displayed, as shown in Figure 2-7. Next, select the YC-ZC Plane option from
the Type drop-down list; a preview of the plane will be displayed in the drawing window. Choose
the Apply button; the YC-ZC plane will be created. Similarly, select the XC-ZC Plane and XC-YC
Plane options from the Type drop-down list to create the XC-ZC and XC-YC planes, respectively
and then choose the OK button to exit the dialog box. Figure 2-8 shows the three fixed datum
planes created.

o =
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Figure 2-7 The Datum Plane dialog box Figure 2-8 Three fixed datum planes

X

Tip

By default, all the tools are not available in their respective groups. Therefore, you may need to

customize the groups to add those tools that are not available by default. To customize a group,

click on the down arrow at the bottom right corner of the group; a drop-down with a list of
tools/options will be displayed. Click on the tool to be added or removed from the group. Note
that a tick mark available on left of a tool name indicates that it is already added in the group.

~

Sumalarly, you can add or remove the groups from the Ribbon by using the Ribbon Options
arrow available at the bottom right corner of the Ribbon.

DISPLAYING THE WCS (WORK COORDINATE SYSTEM)

Ribbon: Tools > Utilities > More Gallery > WCS Gallery > Display WCS
(Customize to Add)

The display of WCS (Work Coordinate System) is important in selecting the planes for

drawing sketches. When you start a new file, by default, the display of WCS is turned off.
It is recommended to keep the display of WCS turned on while drawing sketches and
creating features.

If the display of WCS is turned off, then to turn it on, choose the e
Display WCS button from the WCS gallery of the More gallery in ve
the Utilities group of the Tools tab in the Ribbon; the WCS will be <

displayed at the origin of the drawing window. Note that the Display e

WCS button is a toggle button and is used to toggle the display of  Figure 2-9 The WCS (Work
WCS on/oft. Figure 2-9 shows the WCS with the datum coordinate Coordinate System)
system hidden for better visualization.

CREATING SKETCHES

In NX, you can create the sketch of a feature by two methods. In the first method, you need to
invoke the sketching environment by choosing the Sketch tool from the Construction group of
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the Home tab of the Ribbon. In the second method, you can create a sketch in the Modeling
environment directly by invoking the sketch tools available in the Base group of the Home tab
(Customize to Add). Both these methods are discussed next.

Creating Sketches in the Sketching Environment
Ribbon: Home > Construction > Sketch

/@; As mentioned earlier, the base feature or the first feature in a design is always a sketch-based
feature. The profiles of the sketch-based features are defined by using a sketch. Therefore,

KN to create the base feature, first you need to create a sketch.

In NX, you can create a sketch by using the datum coordinate system plane (XC-YC, YC-ZC, or

XC-ZC), any reference plane, or the existing face of the model.

To create a sketch in the sketching environment, choose the Sketch tool from the Construction
group of the Home tab; the Create Sketch dialog box will be displayed, as shown in
Figure 2-10. Also, you will be prompted to select objects to infer CSYS. The options in the various
rollouts of the Create Sketch dialog box are discussed next.

£} Create Sketch O ? X

‘-cca- On Plane P v ‘

* Sketch CSYS

Plane Method | Inferred - |
Reference Harizontal -
Origin Method Specify Point hd

Specify CSYS @ .

Figure 2-10 The Create Sketch dialog box

Type Drop-down List
The options in this drop-down list are used to specify whether you want to draw the sketch on
the existing plane or on a temporary plane defined on the path.

On Plane
By default, this option is selected in the drop-down list. It is used to specify the existing plane,
face, or datum coordinate system plane as the sketching plane.

On Path

Select this option from the drop-down list to specify the sketch plane on the existing path. The
temporary sketch plane will be created perpendicular to the path selected as the Normal to Path
option is selected by default in the Orientation drop-down list of the Plane Orientation rollout.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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Depending upon the option selected from the drop-down list, the Create Sketch dialog box will be
modified. The various rollouts in the modified dialog box for both the options are discussed next.

On Plane Options
By default, the rollouts related to the On Plane option will be displayed in the Create Sketch
dialog box, refer to Figure 2-10. These rollouts are discussed next.

Sketch CSYS Rollout
The options in this rollout are used to specify the sketch plane by different methods. The
options in this rollout are as follows:

Plane Method: This drop-down list provides two options to select the sketch plane, Inferred
and New Plane.

By default, the Inferred option is selected in the Plane Method drop-down list. It allows
you to select any existing plane or planar face as the sketch plane. The options displayed
in the dialog box on selecting this option are discussed next.

Reference: You can select the required option (Horizontal or Vertical) from the Reference
drop-down list to specify the reference for the sketch.

Origin Method: The options in this drop-down list are used to specify the origin point of the
sketch. This drop-down list provides two options, Specify Point and Use Work Part Origin.

The Specify Point option is used to select the origin point of the sketch plane. You can
select a point on the sketch plane to specify it as the origin of the sketch. You can also use
the CSYS Dialog button or the Inferred drop-down list available in the Specify CSYS area
to create or locate a point.

The Use Work Part Origin option is used to specify the origin of the sketch plane by selecting
a point location on the workpart.

The New Plane option is used to create a new datum plane which can be used as current
sketch plane. As you select this option, you will be prompted to select the objects to define a
plane. Also, the Specify Plane area will be highlighted in the Sketch Plane rollout. You can
specify the sketch plane by using the options available in this area. You can use the Plane
Dialog button to specify the sketch plane. Also, you can reverse the direction of the specified
sketch plane by using the Reverse Direction button available in this area.

The rollouts displayed in the dialog box on selecting the New Plane option from the Plane
Method drop-down are discussed next.

Sketch Orientation Rollout

The options in this rollout are used to specify horizontal or vertical reference for the sketch.
The sketch plane gets orientated according to the specified references. You can specify
the reference by using the Reference drop-down list of this rollout. Also, you can specify a
temporary vector direction using the Vector Dialog button or the Inferred Vector drop-down
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list of the Specify Vector area. You can reverse the direction of the specified reference using
the Reverse Direction button available in the Specify Vector area.

Sketch Origin Rollout
The options in this rollout are same as discussed above in the Origin Method drop-down
list of the Sketch CSYS rollout.

On Path Options
Select this option from the Sketch Type drop-down list
to create a sketching plane on the selected path; the
rollouts related to the On Path option will be displayed ‘9—(’ Lo M ‘
in the Create Sketch dialog box, as shown in Figure 2-11.
The options in these rollouts are discussed next.

v Path

¥ Select Path (0) @
Path Rollout

~  The Curve button in this rollout is used to  + Plane Location
{3 select the path. The path may be a curve
or an edge of an existing solid body.

Location |Ir’§ﬁ_ % Arc Length - ‘

* Plane Orientation

Plane Location Rollout

The options in this rollout are used to specify the
location of the sketch plane along the path in  Orentation |E’N°fma't0 Path  ~
terms of arc length or point. These options are  Reverse Plane Mormal
discussed next.

X

w Sketch Orientation

Location Method Automatic hd
This drop-down list contains different options to

specify the location of the sketch plane along the elect Horizontal Reference (0 ¥
path. These options are as follows: Reverse Direction
Arc Length: This option allows you to specify the

sketch plane distance from the start point of the
path. Enter the distance in the Arc Length editbox. Figure 2-11 Rollouts displayed when the
On Path option is selected
Note
The nearest endpoint of the selected path will be considered as the start point of the path.

% Arc Length: This option allows you to specify the distance of the sketch plane in terms
of the percentage of arc length from the start point of path. Enter the % value in the
% Arc Length edit box.

Through Point: This option allows you to specify the sketch plane by picking a point on
the path. You can use the Point Dialog button or Inferred Point drop-down list to create
or locate a point.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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Plane Orientation Rollout
The options in this rollout are used to specify the direction of the sketch plane with respect
to the selected path. These options are discussed next.

Orientation
This drop-down list contains different options to specity the direction of the sketch plane.
These options are discussed next.

Normal to Path: This option allows you to orient the sketch plane normal to the selected path.

Normal to Vector: This option allows you to orient the sketch plane normal to the specified
vector. You can use the Vector Dialog button or the Inferred Vector drop-down list to create
or specify the vector.

Parallel to Vector: This option allows you to specify the sketch plane parallel to the specified
vector. You can use the Vector Dialog button or the Inferred Vector drop-down list to create
or specify the vector.

Through Axis: This option aligns the sketch plane so that it passes through the specified
axis. Specify the axis using the Vector Dialog button or the Inferred Vector drop-down list.

Reverse Plane Normal
2| The Reverse Plane Normal button is used to reverse the direction of sketch plane.

Sketch Orientation Rollout
The options in the drop-down list of this rollout are used to specify the reference for a sketch.
The sketching plane will be oriented according to the specified reference. The options in
this rollout are discussed next.

Method
The options in this drop-down list are used to specify references for the orientation of a
sketch. These options are discussed next.

Automatic: The Automatic option is selected by default in this drop-down list. As a
result, the Select Horizontal Reference button available below this drop-down list gets activated.
You can specify the horizontal reference by using this button. Specify the horizontal reference
for the sketch; the sketching plane will be oriented based on the specified reference.

/ Note

@ After selecting the Automatic option, if you select an existing curve as the path, the sketch will be
oriented using the curve parameters and if you select an existing edge as the path, the sketch will
be oriented relative to the face.

Relative to Face: This option allows you to orient the sketch to a face which can be either
inferred or explicitly selected. The path location you select determines the direction of the
sketch plane.

Use Curve Parameters: This option allows you to orient the sketch using curve parameters,
even if the path selected is an edge, or is part of a feature that lies on a face.
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Reverse Direction
X The Reverse Direction button in this rollout is used to reverse the direction of the
specified reference.

All the options in the Create Sketch dialog box have already been discussed. For illustration
purpose, select the On Plane option from the drop-down list. By default, the XC-YC plane will be
selected. Next, choose the OK button from the Create Sketch dialog box; the selected reference
plane will be oriented normal to the viewing direction and the sketching environment will be
activated. Note that the Profile tool will be active by default whenever the sketching environment
is activated, refer to Figure 2-12. Now, you can create a sketch by using different sketching tools.
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Select the first point of the line or press and drag to begin arc creation

Figure 2-12 The screen appears with XC-YC plane oriented normal to the viewing direction

Tip

Q If the icons of the Ribbon appear large, you can reduce their size. 10 do so, right-click on
Ribbon to display a shortcut menu and then choose the Customize option; the Customize
dialog box will be displayed. Choose the Icons/Tooltips tab and then select the options from
the Ribbon Bar drop-down list available in the Icon Sizes area.

Creating Sketches in the Modeling Environment

In NX, you can create a sketch directly in the Modeling environment. You can use the tools
available in the Base group of the Curve tab of the Ribbon for creating a sketch directly in the
Modeling environment. However, by default, in the Modeling environment, all the sketching
tools are not available. To get full access of the sketching tools, follow the procedure of creating
sketches in the sketching environment which is already discussed in the previous section.

SKETCHING TOOLS

As discussed earlier, the tools required to draw a sketch are available in the Base group of the
Curve tab in the Modeling environment. Also, these tools are available in the Curve group of
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the Home tab in the sketching environment. The sketching tools in context of the Curve group
in the Home tab of the sketching environment are discussed next.

Note
In this textbook, all the sketching tools available in the Curve group of the Home tab are explained
afier invoking the sketching environment.

Drawing Sketches Using the Profile Tool

Ribbon: Home > Curve > Profile
Menu: Insert > Curve > Profile

| The Profile tool is the most commonly used tool to draw
G

sketches in NX. This tool allows you to draw continuous lines _
. . Ohbject Type | Input Mode
and tangent/normal arcs. To draw continuous lines and ralll &
tangent/normal arcs using this tool, choose the Profile tool from the : —
Curve group of the Home tab; the Profile dialog box will be

displayed, as shown in Figure 2-13. Figure 2-13 The Profile

dialog box

Also, the dynamic input boxes are displayed below the cursor and you will be prompted to select
the first point of the line or press and drag the left mouse button to begin the arc creation. The
dynamic input boxes allow you to enter the coordinates or the length and angle of the line. The
methods of creating lines and arcs using this tool are discussed next.

Drawing Lines
/ The option to draw straight lines is active by default when you invoke the Profile tool.
This is because the Line button is chosen by default in the Profile dialog box. NX allows
you to draw lines using two methods. These methods are discussed next.

Drawing Lines by Entering Values

In this method of drawing lines, you can enter the coordinate values or the length and
angle of the line in the dynamic input boxes displayed below the cursor when you invoke
the Profile tool. After you have entered the coordinates of the start point of the line, a
rubber-band line will be displayed between the cursor and the specified point. Also, you
will be prompted to select the second point of the line. On specifying the start point of the
line, the mode of the dynamic input boxes will changed, refer to Figure 2-14.

Horizontal constraint

Rubber-band symbol
line

S

\ A
Start point /
Length | FTI

Endpoint attached
to the cursor Angle |0

Dynamic Input _/

Boxes

Figure 2-14 Drawing a horizontal line
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This happens because the Parameter Mode button is automatically chosen in the Profile
dialog box. As you move the cursor in the drawing window, the length and angle of the
line gets modified, based on the relative position of the cursor with respect to the point
specified earlier in the dynamic input boxes. You can draw a line by specifying its length
and angle in these boxes.

/ Note

@ After specifying the start point of the line if you choose the Coordinate Mode button from the
Profile dialog box, the coordinate mode option for specifying the endpoint of the line will become
active and you will be prompted to enter the X and Y coordinate values of the end point with respect
to the current WCS or igin.

The line drawing process does not end after you specify the second point of the line.
Instead, another rubber-band line starts with its start point at the endpoint of the last line
and the endpoint attached to the cursor. You can repeat the above-mentioned process to
draw a chain of continuous lines.

After drawing a line, you will notice that it is dimensioned automatically. This happens
because the Continuous Auto Dimensioning tool is chosen by default in the Constraint
Tools Drop-down of the Constrain group of the Home tab. You will learn more about
dimensioning and constraints in the later chapters.

Tip

Q You can toggle between the two dynamic input boxes by pressing the TAB key. Note that once
you specify a value in one of the boxes and press the TAB key, second dynamic input box will
be activated. Specify the value in the second box and then press the ENTER key or the TAB
key to reguster the values and draw the line using these values.

Drawing Lines by Picking Points in the Drawing Window

This is the most convenient method of drawing lines and is extensively used in sketching.
The parametric nature of NX ensures that irrespective of the length of the line that is
drawn, you can modify it to the required values using dimensions. To draw lines using this
method, invoke the Profile tool and pick a point in the drawing window; a rubber-band
line appears. Specify the endpoint of the line by picking a point in the drawing window;
another rubber-band line will appear with the start point as the endpoint of the last line
and the endpoint attached to the cursor. You can continue specifying the endpoints of the
lines to draw a chain of continuous lines.

While drawing a line, you will notice that some symbols are displayed along with the
cursor. For example, after specifying the start point of the line, if you move the cursor
in the horizontal direction, an arrow pointing toward the right will be displayed, refer to
Figure 2-14. This arrow is the symbol of the Horizontal constraint that is applied to the
line. This constraint will ensure that the line you draw is horizontal. These constraints are
automatically applied to the sketch while drawing. You will learn more about the constraints
in the later chapters.
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Drawing Arcs

f/" The option to draw arcs can be activated by choosing the Arc button in the Profile dialog
box. Alternatively, you can press and hold the left mouse button and drag the cursor to
invoke the arc mode. Generally, the arcs that are drawn by using this tool are in continuation

with lines. Therefore, the start point of the arc is taken as the endpoint of the last line. As a

result, when you invoke the arc mode, you need to specify only the endpoint of the arc.

When you draw an arc in continuation with lines, you will notice that a circle with four quadrants
will be displayed at the start point of the arc, as shown in Figure 2-15. This symbol is called the
quadrant symbol and it helps you to define whether you need to draw a tangent arc or a normal
arc. This symbol also helps you in specifying the direction of the arc.

|

A |

Radius 14687
Sweep Angle| 180

Figure 2-15 Quadrant symbol displayed while drawing an arc
using the Profile tool

As evident from Figure 2-15, there are four quadrants in the quadrant symbol. The movement
of the cursor in these quadrants will determine whether the arc will be tangent to the line or
normal to the line. To draw a tangent arc, move the cursor to the start point of the arc and then
move it in the quadrants along the line through a small distance; the tangent arc appears. Now,
move the cursor to resize the arc, refer to Figure 2-15.

To draw a normal arc, move the cursor through a
small distance in the quadrant normal to the
line; a normal arc appears. Move the cursor to ;ﬂ;
resize the arc, as shown in Figure 2-16. As you ~le
invoke the arc mode, the current dynamic input
boxes change into the Radius and Sweep Angle
input boxes. These boxes allow you to specify
the radius and the sweep angle to draw the arc.

Radius m

Sweep Angle| 168.546

Figure 2-16 Drawing the normal arc

Tip
Q 1. To restart drawing lines using the Profile tool or to break the sequence of the continuous
lines, press the ESC key once.

2. Press the ESC key twice to exit the tool. Alternatively, right-click in the drawing area and
choose the OK option from the shortcut menu.
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Note
@ If you are not drawing the arc in continuation with a line or an arc, this tool will work similar to
the Arc by 3 Points tool which is discussed later in this chapter.

Using Help Lines to Locate Points

You will notice that when a sketching tool is active while drawing sketches, some dotted lines are
displayed from the keypoints of the existing entities. The keypoints include endpoints, midpoints,
center points, and so on. These dotted lines are called the help lines. If the help lines are not
displayed automatically, move the cursor to the keypoints and then move the cursor away; the
help lines will be displayed. The help lines are used to locate the points with reference to the
keypoints of the existing entities. Figure 2-17 shows the use of the help lines to locate the start
point of a new line. You can temporarily disable the help lines by pressing the ALT key.

Required point
-

R |
Help line orginating XC
from the endpoint of m
the vertical line ¥C| 2350

Help line orginating
from the endpoint of
the horizontal line

Figure 2-17 Using the help lines to locate a
point

Drawing Individual Lines

Ribbon: Home > Curve > Line
Menu: Insert > Curve > Line

/ NX also allows you to draw individual lines. This can be done by using the Line tool. The

working of this tool is similar to the working of the line mode of the Profile tool. The
only difference is that this tool allows you to draw only one line. As a result, after you
specity the endpoint of the line, no rubber-band line is displayed. Instead, you will be
prompted to specify the first point of the line. You can specify the first point and the second
point of the lines by picking points on the screen or by entering values in the dynamic input
boxes. You can use this tool to draw as many individual lines as required.

Line
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Drawing Arcs

Ribbon: Home > Curve > Arc
Menu: Insert > Curve > Arc

- NX allows you to draw arcs using two methods. You can select a method by choosing its
,/'_ respective button from the Arc dialog box that will be displayed when you invoke the

: Arc tool. The methods of drawing arcs are discussed next.

Drawing Arcs Using Three Points
In this method, you can draw an arc by specifying its start point, endpoint, and a point
f/o on the arc. When you invoke the Arc tool, this method is activated by default and you will
be prompted to specify the start point of the arc. You can specify the start point by clicking
in the drawing window or by entering the coordinates in the dynamic input boxes. After specifying
the start point of the arc, you will be prompted to specify the endpoint. You can also specify the
radius of the arc by entering its value in the dynamic input box.

Note that the next prompt will depend on how you specify the endpoint. If you specify the
endpoint of the arc by clicking a point in the drawing window, you will be prompted to select a
point on the arc and the Radius dynamic input box will be displayed. However, if you specify
the radius of the arc in the dynamic input box after specifying the start point, then you will be
prompted to specify the endpoint of the arc. You can click anywhere in the drawing window to
draw the arc. Figure 2-18 shows a three-point arc being drawn by specifying two endpoints and
a point on the arc.

Tip

Q While drawing an arc by specifying its three points, if the start point is at the endpoint of an
existing entity, the resultant arc can be drawn tangent to the selected entity. To do so, while
defining the point on the arc, move the cursor such that the resulting arc is tangent to the
selected entity.

Drawing an Arc by Specifying its Center Point and Endpoints

In this method, you can draw an arc by specifying its center point, start point, and endpoint.
[: To invoke this method, choose the Arc by Center and Endpoints button from the Arc

dialog box; you will be prompted to specify the center point of the arc. Specify the center
point of the arc by clicking in the drawing area or by entering coordinates in the dynamic input
boxes. On doing so, you will be prompted to specify the start point of the arc. After specifying
the start point of the arc, you will be prompted to specify the endpoint of the arc. Note that
when you specify the start point of the arc after specifying the center point, the radius of the
arc will automatically be defined. Therefore, the endpoint is used only to define the arc length.
Figure 2-19 shows an arc being drawn using this method.
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=
S
Radius
Specifying a point -%‘",%-
on the arc Specifying the
) end point of arc
Endpoint Radius 50]

Sweep Angle| 60

Start point
/ Start point /

L Center point

Figure 2-18 Drawing a three-point arc Figure 2-19 Drawing an arc by specifying its
center; start, and end points

Tip

Q After specifying the center point of the arc, you can also specify its radius and the sweep angle
i the dynamic input boxes. In this case, you will be prompted to specify the start point and
then the endpoint of the arc. The endpoint will define the direction of the arc.

Drawing Circles

Ribbon: Home > Curve > Circle
Menu: Insert > Curve > Circle

(y In NX, you can draw circles using two methods. These methods can be activated by
;r—ci choosing their respective buttons from the Circle dialog box that are displayed when you
invoke the Circle tool. The methods of drawing circles are discussed next.

Drawing a Circle by Specifying the Center Point and Diameter
This is the default and most widely used method

@ of drawing circles. In this method, you need to
specify the center point of a circle and a point on

the circumference of the circle. The point on the

circumference of the circle defines the radius or the

diameter of the circle. To draw a circle using this method,

choose the Circle by Center and Diameter button from Pt

the Circle dialog box; you will be prompted to specify ~I

the center point of the circle. Specify the center point of ;

the circle in the drawing window. Next, you will be Diameter| FIDEIFE

prompted to specify a point on the circle. Specify a point
to define the radius. Alternatively, you can enter the value
of the diameter in the dynamic input box. Figure 2-20
shows a circle being drawn by using this method.

Figure 2-20 A circle drawn using the
Curcle by Center and Diameter method
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Tip

O After specifying the center point of the circle if you specify the value of diameter in the dynamic
input box, the circle of the specified diameter will be created. Also, a preview of the circle of the
same diameter will be attached to the cursor. Now, you can place multiple copies of the circle
by specifying the center point.

Drawing a Circle by Specifying Three Points

In this method, the circle is drawn by specifying
O three points on circumference. To invoke this

method, choose the Circle by 3 Points Reference
button from the Circle dialog box; you will be circles -
prompted to specify the first point of the circle. %}?
This point is actually the first point on the
circumference of the circle. After specifying the first Diameter| FEEENE
point, you will be prompted to specify the second
point of the circle. On specifying these two points,
small reference circles will be displayed on these — Figure 2-21 Circle drawn by using the
two points, as shown in Figure 2-21. Now, specify 3 Points method
the third point, which is a point on the circle. You can also enter its diameter value in the
Diameter input box. If you enter the diameter of the circle in the Diameter input box, you need
to click in the drawing window to specify the placement point for the circle. This completes the
creation of the circle.

Drawing Rectangles

Ribbon: Home > Curve > Rectangle
Menu: Insert > Curve > Rectangle

In NX, you can draw rectangles by using three methods. These methods can be used
L] by choosing their respective buttons from the Rectangle dialog box. To invoke this
dialog box, choose the Rectangle tool from the Curve group. The three methods of
drawing rectangles are discussed next.

Rectangle

Drawing Rectangles by Specifying Corners

The By 2 Points method is used to draw a rectangle by specifying the diagonally opposite
] corners of rectangle. When you invoke the Rectangle tool, the By 2 Points button is

chosen by default in the Rectangle Method area of the Rectangle dialog box. Also, you
will be prompted to specify the first point of the rectangle. This point will work as one of the
corners of the rectangle. After specifying the first point, you will be prompted to specify the
point to create the rectangle. This point will be diagonally opposite to the point that you
have specified earlier. You can click anywhere on the screen to specify the second corner or enter
the width and height of the rectangle in the dynamic input boxes. Figure 2-22 shows a rectangle
being drawn by using the By 2 Points method.
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S

R |
Width
Height| 60

Figure 2-22 Rectangle being drawn by using the By 2 Points method

/ Tip

O If you specify the width and height of a rectangle in the dynamic input boxes afier specifying
the first point, a preview of the rectangle with the specified width and height will be attached
to the cursor. Now, you need to specify a point to define the direction of rectangle.

Drawing Three Points Rectangles

You can draw a three points rectangle by choosing the By 3 Points button from the
3 Rectangle dialog box. In this method, you can draw a rectangle using three points. The

first two points are used to define the length and angle of one of the sides of the rectangle
and the third point is used to define the height of the rectangle. When you invoke this tool, you
will be prompted to specify the first point of the rectangle. Once you specify the first point, you
will be prompted to specify the second point of the rectangle. Both these corners are along the
same direction. Therefore, these points define the length and orientation of the rectangle. Note
that if you specify the second point at a certain angle, the resulting rectangle will also be at an
angle. After specifying the second point, you will be prompted to specify a point to create the
rectangle. This point is used to define the height of the rectangle. After specifying the first point,
you can also specify the height, width, and the angle of the rectangle in the dynamic input boxes.
Figure 2-23 shows an inclined rectangle drawn by using the By 3 Points method.

Ell (I

-
Width
Height| 70
Angle | 23

Figure 2-23 Inclined rectangle drawn by using the By 3 Points method

Tip
O After specifying the first point of a rectangle, you can toggle between the By 2 Points and By
3 Points buttons by holding and dragging the lefi mouse button.

Drawing Centerpoint Rectangles
You can draw a centerpoint rectangle by choosing the From Center button in the Rectangle
[=3 dialog box. Using this method, you can draw a rectangle using three points. However,
the first point is taken as the center of the rectangle in this case. When you invoke this
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tool, you will be prompted to specify the center point of the rectangle. Once you specify the
center point, you will be prompted to specify the second point of the rectangle. Both these points
are along the same direction. Therefore, these points define the width of the rectangle. Note
that if you specify the second point at a certain angle, the resulting rectangle will also be created
at that specified angle. After specifying the second point, you will be prompted to specify a point
to create the rectangle. This point is used to define the height of the rectangle. Alternatively,
you can specify the height, width, and angle of the rectangle in the dynamic input boxes which
appear after you specify the first point for creating the rectangle.

Placing Points

Ribbon: Home > Curve > Point
Menu: Insert > Datum > Point

+ In NX, you can place points by clicking in the drawing window. To place a point, choose

the Point tool from the Curve group; the Sketch Point dialog box will be displayed, refer
to Figure 2-24, and you will be prompted to select a point. Click in the drawing window;
the point will be placed at the specified location. Also, the horizontal and vertical
dimensions between the point and the origin point of the sketch will be displayed. You can edit
these dimensions to change the location of the point.

Paint

Tip

Q If tools to be invoked are not visible by default in the Curve group of the Home tab, you need
to expand the Curve gallery of the Curve group. 1o expand the Curve gallery, click on the
Group Options down arrow available at the lower right corner in the Curve group.

You can also place a point by using the Point dialog box. To invoke this dialog box, choose the
Point Dialog button from the Sketch Point dialog box; the Point dialog box will be displayed,
refer to Figure 2-25 and you will be prompted to select the object to infer point. This dialog
box contains Type drop-down list at the top and three main rollouts, Point Location, Output
Coordinates, and Offset. The options in these rollouts are discussed next.
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‘ 4 Inferred Point - ‘
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Figure 2-24 The Sketch Point dialog box Figure 2-25 The Point dialog box

Type Drop-down List
Select an option from the drop-down list to specify the location for the resulting point. The
options are discussed next.

Inferred Point

This option is selected by default. This option allows you to place a point in the
drawing window. However, if there are some entities in the drawing window, then this
option helps you to select the keypoints of the entity. For example, if there are a few lines
in the drawing window, then this option helps you to select the endpoints or the midpoints
of the lines.

Cursor Location

This option allows you to place a point at a location where you will click the cursor in the
drawing window. If the Cursor Location option is selected, then the other entities in the
drawing window will not be considered.

Existing Point
This option allows you to select the points that are already placed in the drawing window.
As a result, you can place new point on top of the existing point.

End Point
This option allows you to place the point at the endpoint of the existing lines, arcs, or splines.

Control Point

This option allows you to place the point at the control point of the existing sketched entities.
The control points include the endpoints and midpoints of lines or arcs, center points of
circles, ellipses, control points of splines, and so on.
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Intersection Point

This option allows you to place the point at the intersection point of the two existing
sketched entities. To do so, select the Intersection Point option from the Type drop-down
list; you will be prompted to select the first and second intersecting entities. Specify the two
intersecting entities in the drawing area; a point will be placed at the intersection point of
the two existing entities.

Arc/Ellipse/Sphere Center
This option allows you to place the point at the center of an existing arc, circle, ellipse, or
sphere.

Angle on Arc/Ellipse

This option allows you to place the point on the circumference of the selected arc, circle, or
ellipse such that the resulting point is at the specified angle with respect to X-axis. When
you choose this option, the Point dialog box will be modified and you will be prompted
to select an arc or an ellipse. Select the arc or the ellipse in the drawing; the point will be
placed on the circumference of the selected entity. Next, enter the angle value for the point
in the Angle edit box of the Angle on Curve rollout.

Quadrant Point
This option allows you to place the point at the quadrant of a circle, arc, or an ellipse. The
point will be placed at the quadrant that is closest to the current location of the cursor.

Point on Curve/Edge

This option allows you to place the point on the selected curve or edge. The location of the
point is defined in terms of its curve parameter percentage from the start point of the curve.
When you select the Point on Curve/Edge option, the Point dialog box will be modified
and you will be prompted to select the curve to specify the point location. Click anywhere
on the curve or the edge; you will be prompted to specify the curve parameter percentage.
You can specify the curve parameter by using the Location drop-down list in the Location
on Curve rollout of the Point dialog box. You can also enter the distance of the point in the
Curve Length edit box of the Location on Curve rollout.

Point on Face

This option allows you to place the point on the selected face. The location of the point
is defined by specifying values in the U Parameter and V Parameter edit boxes. The
U Parameter edit box is used to specify the horizontal position of the point whereas the
V Parameter is used to specify the vertical position of the point. The values of these edit boxes
must lie between 0.0 and 1.0. As value of the U Parameter edit box increases, the position of
the point shifts from right to left; and if the value of the V Parameter edit box increases,
the position of the point shifts from bottom to top. Note that this option will be available
only when you invoke the Point dialog box by choosing Menu > Insert > Datum > Point
from the Top Border Bar in the Modeling environment.

Between Two Points

This option allows you to create a point between two existing points or between two keypoints
of an entity. When you select this option from the Type drop-down list, the Point dialog box
will be modified and you will be prompted to select object to infer point. Select the first
point from the drawing window; you will be prompted again to select object to infer point.
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Select the second point; a point will be created between the two selected points. You can
change the location of this point by entering the percentage value in the %Location edit
box of the Location Between Points rollout.

By Expression

This option allows you to specify a point expression by using the X, Y, and Z coordinates.
When you select this option from the Type drop-down list, the Point dialog box will be
modified with new rollouts such as Choose Expression, Output Coordinates, and Offset.
The Choose Expression rollout is used to display the point expression created already in
the part. To create a new expression, choose the Create Expression button; the Expressions
dialog box will be invoked displaying the Visibility and Actions rollouts. To create a new
expression, choose the New Expression button from the Actions rollout. Next, enter the
name of the point expression in the Name edit box and then edit the point formula as per
your requirement in the Formula edit box. Once you have edited the values of the X, Y,
and Z coordinates in the Formula edit box, choose the OK button from this dialog box; the
Point dialog box will be displayed. The newly created point expression will be listed in the
list box available in the Choose Expression rollout. Select the point expression from the
list and then choose the OK button from the Point dialog box; a point will be created with
the specified coordinates in the expression.

Point Location Rollout
This rollout is used to place a point in the drawing area and will not be available for the
Intersection Point, Angle on Arc/Ellipse, Point on Curve/Edge, and Point on Face options.

Output Coordinates Rollout

This rollout is used to enter the X, Y, and Z coordinates to specify the location of the point. Also,
you can specify or determine the 3D location of the points using this rollout. You can specify
the point relative to the Work Coordinate System (WCS) or Absolute Coordinate System by
selecting respective options from the Reference drop-down list in the Output Coordinates rollout.

Offset Rollout

This rollout is used to create a point at a specified distance from a pre-selected point. You can
select an option to specify the distance of the required point from the Offset Option drop-down
list in this rollout. The options in this drop-down list are discussed next.

Rectangular
This option allows you to create a point by specifying its X, Y, Z coordinates with respect to
the pre-selected point in the Delta X, Delta Y, and Delta Z edit boxes, respectively.

Cylindrical

This option allows you to create a point according to the cylindrical coordinate system with
respect to the pre-selected point by specifying the radius, angle, and Z direction coordinate
values in the Radius, Angle, and Delta Z edit boxes, respectively.

Spherical

This option allows you to create a point according to the spherical coordinate system with
respect to the pre-selected point by specifying the Radius, Angle 1, and Angle 2 in their
respective edit boxes.
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Along Vector
This option allows you to create a point along the specified vector direction at a distance
specified in the Distance edit box.

Along Curve

This option allows you to create a point along the specified curve. The distance of the
point along the arc can be specified by entering the Arc Length or Percentage value in the
respective edit box.

Drawing Ellipses or Elliptical Arcs

Ribbon: Home > Curve > More Gallery > Curve Gallery > Ellipse (Customize to Add)
Menu: Insert > Curve > Ellipse

(:_:} In NX, you can draw ellipses or elliptical arcs by

using the Ellipse tool. To invoke this tool, Conter N
choose Menu > Insert > Curve > Ellipse
option from the Top Border Bar; the Ellipse dialog box % Specify Point I (s
will be displayed, as shown in Figure 2-26. Also, you will

be prompted to select a point to specify the center point Major Radius ~
of the ellipse. Specify Point o [ 4
Major Radius 50| P -
Note
The Ellipse tool is available in the More gallery of ~ 'Viner Radius A
the Curve group in the Home tab of the sketching Specify Point 25l
environment. By default, the More gallery is not Minor Radiue » i
visible in the Curve group. 1o make it visible in the
Curve group, click on the Group Options down Limits A
arrow available on the right corner of this group; the Closed
Curve flyout will be displayed. Next, click on the More _
Gallery option in the flyout; it will become visible in Rotation »
the Curve group. Angle 0 : h
Preview Show Result )

Click anywhere on the screen. Choose the Point Dialog
button from the Center rollout; the Point dialog box
will be displayed, refer to Figure 2-25. Using the
Point dialog box, you can define the center point of . : . :

the ellipse. Alternatively, you can define the center Figure 2-26 The Ellipse dialog box
point of the ellipse by selecting the required option from the Inferred Point drop-down list
available in the Center rollout. After defining the center point by using the Point dialog box,
choose the OK button from it; the Ellipse dialog box will be displayed again. Also, a preview of
the ellipse will be displayed. Next, specify the major and the minor radii of the ellipse in the
Major Radius and Minor Radius edit boxes in the Ellipse dialog box, respectively. If you want
to draw an elliptical arc, clear the Closed check box in the Limits rollout; the Ellipse dialog
box will be modified and the Start Angle and End Angle edit boxes for the arc will appear in
it. You can specify the start and end angles in their respective edit boxes. Figure 2-27 shows the
parameters related to an ellipse and Figure 2-28 shows the parameters related to an elliptical arc.
If you want to retain the complement of the elliptical arc, choose the Complement button below
the End Angle edit box in the Limits rollout; the preview of the complement of the elliptical arc

Cancel
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will be displayed. Figure 2-29 shows an elliptical arc and Figure 2-30 shows the complement of
the elliptical arc. Note that Figure 2-27 shows an inclined ellipse. To create an inclined ellipse,
you need to enter rotation angle in the Angle edit box of the Rotation rollout. The specified
angle value will be measured with respect to X-axis in the counterclockwise direction.

) End

"\ Rotation angle
angle

f

Semiminor{ -~ - \ \

Semimajor
axis

Figure 2-27 Parameters related to an ellipse ~ Figure 2-28 Parameters related to an
elliptical arc

Figure 2-29 An elliptical arc Figure 2-30 Complement of the elliptical arc
shown in Figure 2-29

Drawing Conics

Ribbon: Home > Curve > More Gallery > Curve Gallery > Conic (Customize to Add)
Menu: Insert > Curve > Conic

.-"ﬁ"-. The Conic tool allows you to create a conic section in the sketching environment using
{ % three points. The first two points define the endpoints of the conic and the third point
' defines the apex of the conic. Also, you need to specify the projective discriminant value,
termed as rho value. To invoke the Conic tool, choose Menu > Insert > Curve > Conic from
the Top Border Bar; the Conic dialog box will be displayed, as shown in Figure 2-31. In this
dialog box, you can specify the start point and end point of the conic using the options in the
Limits rollout. After specifying the start point and the endpoint of the conic, you need to specify
the apex of the conic as the third point. Specity the apex of the conic by using the options in
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the Specify Control Point area of the Control Point rollout.

Next, enter the Rho value in the Value edit box.

This Rho value will define the exact shape of conics.

If 0 < Rho < 0.5, then conics of elliptical shape will be
created.
If Rho = 0.5, then conics of parabolic shape will be created.
If 0.5 < Rho < 1, then conics of hyperbolic shape will be
created.

Figure 2-32 shows conics with different Rho values.

SN

Rho=025 Rho=0.5

Limits A
¥ Specify Start Point . aﬁ M
3% Specify End Point L -I
Control Point A
¥ Specify Control Point . ef M
Rho A
Value

Preview Show Result L)

Cancel

Figure 2-31 The Conic dialog box

Rho =075

Figure 2-32 Conics with different Rho values

Tip
g Sometimes while placing points or drawing an ellipse, some red cross marks are displayed on
the screen. To remove them, refresh the screen by pressing the F5 key.

Drawing Studio Splines

Ribbon: Curve > Base > Studio Spline
Menu: Insert > Curve > Studio Spline

When you invoke this tool, the Studio Spline dialog box will be displayed, as shown in
Figure 2-33. The various rollouts in this dialog box are discussed next.

Note

/ The Studio Spline tool allows you to create studio splines for creating free form features.

The Studio Spline tool is available only in the Modeling environment.
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Type Drop-down List e 7 X
There are two options in the drop-down list for # Through Points -
drawing studio splines which are discussed next. . .
Paint Location A
Through Points * SeectyPomts 0 L%
This is the default option selected for drawing Parameterization A
splines. Here, you can specify continuous points in Degree :
the drawing area by clicking the left mouse button. L] Matched Knot Pesition
These points will act as the defining points of the [ Closed
spline. While drawing a spline, you can move these Drawing Plane A
points to change the shape of the spline, and then L] Censtrained to Plane
continue drawing the spline. Figure 2-34 shows a Bs By &Y <2
spline being drawn by using this method.
Maovement A
O wes ®) View (O Vector
By POleS (O Plane (O Normal

If you select this option,, the points that you
specify in the drawing window act as the poles
of the spline. Figure 2-35 shows a spline being
drawn by using this method. Remember that the
display of poles is automatically removed when
you finish drawing the spline.

=

Cancel

Figure 2-33 The Studio Spline dialog box

NV A

Figure 2-34 Drawing a spline by using the Figure 2-35 Drawing a spline by using the By

Through Points option Poles option

Point Location / Pole Location Rollout

The options in this rollout are used to specify the spline point or pole location. You can use the

Point Constructor button to create or locate a point.

Parameterization Rollout

The options in this rollout are used to specify the parameters of the spline.

Degree Spinner

The Degree spinner is used to specify the degree of a spline. Figures 2-36 and 2-37 show
splines of various degrees. Note that the degree of a spline cannot be more than the number

of poles used to draw it.
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Figure 2-36 Spline of degree 2 Figure 2-37 Spline of degree 4

Single Segment

This check box is available only when you select the By Poles option and is used to create a
single segment spline. However, you can specify as many numbers of poles as you require.
If you select this check box, the Closed check box will not be activated.

Matched Knot Position

This check box is available only when you select the Through Points option and is used to
create a spline by matching the position of the defining points with the knots. In this case,
the knots are placed only at the places where the defining points are specified. If you select
this check box, the Closed check box will not be activated.

Closed
This check box is available for both the methods and is used to create closed splines.
Figure 2-38 shows a closed spline.

Figure 2-38 A closed spline -

Filleting Sketched Entities

Ribbon: Home > Curve > Fillet
Menu: Insert > Curve > Fillet

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com

—,  Filleting is defined as the process of rounding the sharp corners of a profile to reduce
| the stress concentration. Fillets are created by removing the sharp corners and replacing
them with round corners. In NX, you can create a fillet between any two sketched entities.

You can also create a fillet using three sketched entities.
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To create fillets, invoke the Fillet tool; the Fillet dialog box will be displayed, as shown in
Figure 2-39. Also, you will be prompted to select or drag the cursor over curves to create a fillet.

The Radius dynamic input box will be displayed below the cursor. You do not need to
necessarily specify the fillet radius in advance. Instead, you can select the two entities to fillet
and then move the cursor to define the radius of the fillet. Figure 2-40 shows the preview of a
fillet being created between two lines. In this case, the radius value is not defined in advance.
As a result, as you move the cursor, the fillet radius is modified dynamically. The Fillet dialog
box is divided into two areas, Fillet Method and Options.

=
9 Pl I
1w
b2
ﬂ' Fillet x = Radius| Tj
Fillet Met... Optio... . — .

= 3
| { } EJ pd0=125,0

Figure 2-39 The Fillet dialog box Figure 2-40 Preview of a fillet being created
between two lines

Fillet Method Area

The first button in this area is the Trim button and is chosen by default. As a result, the sharp
corner will automatically be trimmed after filleting, as shown in Figure 2-41. If you choose the
Untrim button, the sharp corner will not be trimmed after filleting, as shown in Figure 2-42.

After

Before e Before After

Filleting Filleting Filleting Filleting
Figure 2-41 Sharp corner before and Figure 2-42 Sharp corner before and afier
after filleting using the Trim button filleting using the Untrim button

Tip
Q Ideally, the profiles created with the fillet may not give the desired result when used to create
featwres. Therefore, they should be avoided in the sketch.

Options Area

The Delete Third Curve button in this area is useful if you are creating a fillet by using three
entities. While using this option, the middle entity should be selected last. This button ensures that
if the fillet is tangent to the middle entity then the middle entity is automatically deleted, as
shown in Figure 2-43. If this button is deactivated, the middle entity will not be deleted, as
shown in Figure 2-44. The Create Alternate Fillet button in this area will show all the alternative
solutions for the fillet. It is recommended that this button should be turned off.
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Figure 2-43 The entity before and after Figure 2-44 The entity before and after filleting
filleting with the third curve deleted with the third curve retained

Tip

O 1. In NX, you can create fillets by simply dragging the cursor across the entities that you need
to fllet. For example, if you need to create a fillet between two lines, invoke the Fillet tool and
drag the cursor across them; the corner of these two lines will be filleted. The radius of the fillet
will depend on how far you dragged the mouse from the corner.

2. When you fillet two entities, if there is more than one solution for fillet, then the best solution
will be displayed by default. If you want to view the alternate solution, press the PAGE UP key.

THE DRAWING DISPLAY TOOLS

The drawing display tools are an integral part of any solid modeling tool. These tools enable
you to zoom, pan, and rotate the drawing so that you can view it clearly. The drawing display
tools in NX are located in the View tab in the Ribbon and the methods of using these tools are
discussed next.

Note
As most of the drawing display tools are transparent tools, you can use them at any time without
exiting the other tool you are working with.

Fitting Entities in the Current Display

Ribbon: View > Operation > Fit
Menu: View > Operation > Fit

—=  The Fit tool enables you to modify the drawing display area such that all entities in
FIit the drawing fit in the current display. You can also use the CTRL+F keys to fit the
entities in the current display.

Zooming an Area

Ribbon: View > Operation > Zoom
Menu: View > Operation > Zoom

—= The Zoom tool allows you to zoom into a particular area by defining a box around it. When
z~| you choose this tool, the default cursor is replaced by a magnifying glass cursor and you
will be prompted to drag the cursor to indicate the zoom rectangle. Specify a point on

the screen to define the first corner of the zoom area. Next, hold the left mouse button

and drag the cursor. Now, release the left mouse button to specify another point to define
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the opposite corner of the zoom area. The area defined et =T ? X
inside the rectangle will be zoomed and displayed on -

Scale 0.375¢
the screen.

Half Scale
You can also zoom in or out a drawing by specifying
a scale value. To do so, choose Menu > View >
Operation > Zoom from the Top Border Bar; the Reduce 10%
Zoom View dialog box will be displayed, as shown in
Figure 2-45. Specify a scale value in the Scale edit box.

Double Scale

Increase 10%

In addition, you can also use the Half Scale, Double Apply Cancel
Scale, Reduce 10%, and Increase 10% buttons to zoom
in or out of the drawing. Figure 2-45 The Zoom View dialog box

Dynamic Zooming

Ribbon: View > Operation > More Gallery > View Operation Gallery >
Zoom In/Out (Customize to Add)

¢ The Zoom In/Out tool enables you to dynamically zoom in or out of the drawing. When
=" you invoke this tool, the default cursor is changed into a magnifying glass cursor with a
‘+” and a -’ sign at the center of the cursor. To zoom in, press and hold the left mouse
button in the drawing window and then drag the cursor upward. Similarly, to zoom out, press
and hold the left mouse button and drag the cursor down.

Panning Drawings

Ribbon: View > Operation > Pan
Menu: View > Operation > Pan
—= The Pan tool allows you to dynamically pan drawings in the drawing window. When you
invoke this tool, the cursor is replaced by a hand cursor and you will be prompted to drag

the cursor to pan the view. Press and hold the left mouse button in the drawing window
and then drag the mouse to pan the drawing.

Tip
Q In NX, you can also display the Selection MiniBar and the View shortcut menu by right-clicking
i the drawing area. The Selection MiniBar is a compact version of the Selection Group.

Fitting View to Selection

Ribbon: View > Operation > More Gallery > View Operation Gallery > Fit View to
Selection (Customize to Add)
Menu: View > Operation > Fit View to Selection

@ The Fit View to Selection tool zooms the display such that the selected entity fits in the
current display area. This tool is available only when an entity is selected in the drawing
window.
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Restoring the Original Orientation of the Sketching Plane

Ribbon: View > Sketch Display > Orient to Sketch
Menu: View > Orient View to Sketch

Sometimes while using the drawing display tools, you may change the orientation of the

sketching plane. The Orient View to Sketch tool restores the original orientation that

Qemt®  was active when you invoked the Sketch in Task Environment. This tool is available only
in the Sketch in Task Environment.

SETTING SELECTION FILTERS IN THE SKETCH IN TASK
ENVIRONMENT

NX provides you with various object selection filters in the Sketch in Task Environment. These
filters allow you to define the types of entities you want to select. All these filters are available
in the Selection Group on the upper left corner in the Top Border Bar of the drawing window.
Some of these filters are discussed next.

Type Filter

The Type Filter drop-down list is used to specify the type of entity No Selection Filter =
to be selected as filter type. By default, the No Selection Filter N Selection Filter
option is selected, refer to Figure 2-46. This option allows you csvs
to select any entity from the drawing window. These entities EE:: Feature
include sketch, datums, curve, point, face, and so on. Select Datums
the required entity from the Type Filter drop-down list. Now, E:E:
you can select only the specified entity from the drawing window. Feature
Point
Sheet Body
- Sketch
Selection Scope Solid Body
ew

This drop-down list allows you to filter the selection from the
entire assembly, within the workpart and components, the Figure 2-46 The Type Filter
workpart only, or the active sketch only. Select the required drop-down list

option from the Selection Scope drop-down list.

General Selection Filters
— 'This flyout provides the detailed filter options. The options in the General Selection Filters
flyout, as shown in Figure 2-47, are discussed next.

Note

@ The General Selection Filters flyout is not available by default in the Top Border Bar of the
drawing window. You can click on the Ribbon Options down arrow available at the right in the
Top Border Bar and then choose Selection Group > General Selection Filters; the flyout will
be added to the Top Border Bar.
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Detailed Filtering -
This option is used to filter the selection using layers, type

of entity, display attributes, and detailed types of entity. Select *F? Dretailed Filtering...
ty, display yp y

the Detailed Filtering option in the General Selection @ color Filter
Filters flyout; the Detailed Filtering dialog box will be _
displayed. In this dialog box, you can specify layers, types Layer Filter |All v

of entity, details of the types of entity, and display attributes

that you need to filter. Figure 2-47 The General Selection

Filters flyout

Color Filter

This option allows you to filter the selection using a specific color. Only the entities in the
specified color will be selected.

Layer Filter

This drop-down list allows you to filter the selection using a specific layer. You need to select the
layer from the Layer Filter drop-down list and the entities in this layer can only be selected. By
default, the All option is selected, which allows to select the entities from all the layers.

Reset Filters
This tool is used to reset all the filtering options defined in the General Selection Filters
flyout and the Type Filter drop-down list to their default states.

Allow Selection of Hidden Wireframe
This tool allows you to select the hidden wireframe geometries such as curves and edges.
This tool is not available by default in the Top Border Bar of the drawing window. You
can click on the Ribbon Options down arrow available at the right in the Top Border Bar and
then choose Selection Group > Allow Selection of Hidden Wireframe; the tool will be added
to the Top Border Bar.

Deselect All

Hﬂj When you choose this tool, all the currently selected entities are deselected.

Find in Navigator
This tool is used to highlight the selected entities in the Part Navigator or Assembly
Navigator and will be activated only when you select an entity. Select the entities that you
want to highlight in the Part Navigator or Assembly Navigator and choose the Find in Navigator
tool in the Selection Bar. Next, choose the Part Navigator tab from the Resource Bar to view
the highlighted entities. Note that, this tool will not be available in the Sketch in Task
Environment.

SELECTING OBJECTS

After setting the selection filters, you can select objects in the drawing window of NX. When no
tool is active, the select mode will be invoked. In this mode, you can select individual sketched
entities from the drawing window by clicking on them. NX provides three methods for selection
of multiple entities. If you want to select multiple entities at once, you can use the tools available
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in the Multi-Select Gesture Drop-down of the Selection Group in the Top Border Bar. These
tools are discussed next.

Rectangle

%— If you choose this tool from the Multi-Select Gesture Drop-down of the Selection Group
in the Top Border Bar and drag the cursor in the drawing window, a temporary rectangle
will be created. Also, all the objects lying completely within the temporary rectangle will
get selected.

Lasso

. Ifyou choose this tool from the Multi-Select Gesture Drop-down of the Selection Group

4 in the Top Border Bar and drag the cursor in the drawing window, a temporary free form
curve will be created. Also, all the objects lying completely within the free form curve will
get selected.

Circle

" Ifyouchoose this tool from the Multi-Select Gesture Drop-down of the Selection Group

"B in'the Top Border Bar and drag the cursor in the drawing window, a temporary circle
will be created. Also, all the objects lying completely within the temporary circle will get
selected.

DESELECTING OBJECTS

By default, the selected objects are displayed in orange color. If you want to deselect
the individual entities from the selection, press and hold the SHIFT key and click on the particular
entity you want to exclude from the selection group; the entity will be deselected. If you want
to deselect all the selected entities, press the ESC key. Alternatively, press and hold the SHIFT
key and drag a box around the entities; all the entities that lie completely inside the box will
get deselected. Also, you can choose the Deselect All tool from the Selection Group in the Top
Border Bar to deselect all the selected entities.

USING SNAP POINT OPTIONS WHILE SKETCHING

While drawing a sketch, you will notice that the cursor automatically snaps to some keypoints
of the sketched entities. For example, if you are specifying the center point of a circle and you
move the cursor close to the endpoint of an existing line, the cursor snaps to the endpoint of
the line and changes into a snap cursor. Also, the endpoint snap symbol is displayed below the
cursor. This suggests that the endpoint of the line has been snapped and if you click now, the
center point of the circle will coincide with the endpoint of the line.

NX allows you to control these snap settings using the snap points options available in the
Snap Point flyout of the Selection Group in the Top Border Bar, as shown in Figure 2-48.
In this bar, some of the tools are chosen by default. You can choose more tools to turn on the
respective snapping option.
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Figure 2-48 The Snap Point flyout
used for snap settings

DELETING SKETCHED ENTITIES

Menu: Edit > Delete
You can delete the sketched entities by selecting
. Delete Sketch Oby X
X them and pressing the DELETE key. You can also = _ —— S
delete a sketched entity by choosing Menu >  Object to Delete A

Edit > Delete tool from the Top Border Bar. However,

. . . R ¥ Select Object (0]
if you choose this tool without selecting any sketched

entity, the Delete Sketch Object dialog box will be b

displayed, as shown in Figure 2-49. You can now select Cancel

the entities to be deleted and then choose the OK

button in this dialog box. Figure 2-49 The Delete Sketch Object
dialog box

EXITING THE SKETCH ENVIRONMENT

Ribbon: Home > Sketch > Finish

After drawing the sketch, you need to exit the sketching environment to convert the
[E sketch into a feature. To exit the sketching environment, choose the Finish tool from the
Finish  Sketch group of the Home tab in the Ribbon. Alternatively, right-click in the drawing

area and choose the Finish Sketch option from the shortcut menu. When you exit the
sketching environment, you can convert the sketch into a solid model by using the solid modeling
tools.
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TUTORIALS

As mentioned in the introduction, NX is parametric in nature. Therefore, you can draw a sketch
of any dimensions and then modify its size by changing the values of dimensions. However, in
this chapter, you will use the dynamic input boxes to draw the sketch of exact dimensions. This
will help you improve your sketching skills.

Tutorial 1

In this tutorial, you will draw a profile for the base feature of the model shown in Figure 2-50.
The profile to be drawn is shown in Figure 2-51. (Expected time: 30 min)

Figure 2-50 Model for Tutorial 1

30 10 —

10 !

10 ! 1?

80

Figure 2-51 Skelch for Tutorial 1

The following steps are required to complete this tutorial:
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Start a new file.

Select the XC-ZC plane as the sketching plane.

Draw the sketch of the model by using the Profile and Rectangle tools.
Finish the sketch and save the file.

Starting NX and Opening a New File

First, you need to start NX and then open a new file.
Double-click on NX shortcut icon on the desktop of your computer to start NX.

Choose the New button from the Standard group of the Home tab or choose
Menu > File > New from the Top Border Bar; the New dialog box is displayed.

Select the Model template from the Templates rollout.
Enter c02tutl as the name of the document in the Name text box of the dialog box.

Choose the button on the right of the Folder text box; the Choose Directory dialog n:l’-lé
box is displayed. :

It is recommended that you create a folder with the name NX in the hard drive of your
computer and then create separate folders for each chapter inside it for saving the tutorial
files of this textbook.

In this dialog box, browse to NX /c02 folder and then choose the OK button twice; a new
file is started in the Modeling environment.

Drawing the Sketch in the Sketching Environment

1.

The base sketch of this model will be created on the XC-ZC plane.

Choose the Sketch tool from the Construction group of the Home tab; the Create @
Sketch dialog box is displayed. sketch

Select the XC-ZC plane from the Datum Coordinate system in the drawing window if it is
not selected by default.

Choose the OK button from the Create Sketch dialog box; the sketching tools become
available and the sketching plane is oriented parallel to the screen. Also, the Profile tool is
active by default.

Drawing the Outer Profile of the Sketch

The outer profile of the sketch consists of lines and it can be drawn by using the Profile
tool.

Choose the Profile tool from the Curve group of the Home tab in the Ribbon, |

if it is not already activated; the Profile dialog box is displayed. By default, the 'El
Line button is active in this dialog box and the dynamic input boxes are displayed p
below the line cursor.
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2.

10.

11.

12.

13.

14.

15.

16.

Move the cursor close to the origin; the coordinates of the point are displayed as 0,0 in the
dynamic input boxes. Click to specify the start point of the line at this point.

As you move the cursor on the screen, the line stretches and its length and angle values are
modified dynamically in the dynamic input boxes.

Enter 80 in the Length dynamic input box and press the TAB key. Next, enter 0 in the Angle
dynamic input box and press the ENTER key.

Choose the Fit tool from the Operation group of the View tab to fit the sketch into the
drawing window.

Move the cursor away from the end point of the last line and then enter 10 as the length
and 90 as the angle in the Length and Angle dynamic input boxes, respectively. Next, press
the ENTER key.

Enter 15 as the length and 180 as the angle in the Length and Angle dynamic input boxes,
respectively. Next, press the ENTER key.

Enter 30 as the length and 90 as the angle in the Length and Angle dynamic input boxes,
respectively. Next, press the ENTER key.

Enter 15 as the length and 0 as the angle in the Length and Angle dynamic input boxes,
respectively. Next, press the ENTER key.

Enter 10 as the length and 90 as the angle in the Length and Angle dynamic input boxes,
respectively. Next, press the ENTER key.

Enter 80 as the length and 180 as the angle in the Length and Angle dynamic input boxes,
respectively. Next, press the ENTER key.

Enter 10 as the length and -90 or 270 as the angle in the Length and Angle dynamic input
boxes, respectively. Next, press the ENTER key.

Enter 15 as the length and 0 as the angle in the Length and Angle dynamic input boxes,
respectively. Next, press the ENTER key.

Enter 30 as the length and -90 or 270 as the angle in the Length and Angle dynamic input
boxes, respectively. Next, press the ENTER key.

Enter 15 as the length and 180 as the angle in the Length and Angle dynamic input boxes,
respectively. Next, press the ENTER key.

Enter 10 as the length and -90 or 270 as the angle in the Length and Angle dynamic input
boxes, respectively. Next, press the ENTER key.

Press the ESC key twice to exit the Profile tool. The outer profile of the sketch is shown in
Figure 2-52.
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Figure 2-52 Outer profile of the sketch

Drawing the Rectangle
Next, you need to draw the inner profile which is a rectangle. You can use the By 2 Points
option of the Rectangle tool to draw the rectangle.

1. Choose the Rectangle tool from the Curve group; the Rectangle dialog box is I:l
displayed and the By 2 Points button is chosen by default in this dialog box.

2. Enter 25 and 15 as the coordinates of the first point of the rectangle in the XC and YC
dynamic input boxes, respectively. Next, press the ENTER key.

3. Enter 30 and 20 as the width and height of the rectangle in the Width and Height dynamic
input boxes, respectively. Next, press the ENTER key; a preview of the rectangle is displayed.
As you move the cursor in the drawing window, the preview also moves.

4. Move the cursor close to the top right corner of the drawing window and then click to draw
the rectangle.

5. Press the ESC key to exit the tool. The final sketch for Tutorial 1 is shown in Figure 2-53.
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Figure 2-53 Final sketch for Tutorial 1
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Finishing the Sketch and Saving the File

NX allows you to save the sketch file in the Sketch environment.
1. Choose the Save button from the Quick Access toolbar. E'|
2. Next, choose the Finish tool from the Sketch group; the Modeling environment is invoked.

3. Choose Menu > File > Close > Selected Parts from the Top Border Bar; the Close Part
dialog box is displayed.

b

Select the name of the current file from the list area in the Part rollout and then choose the
OK button to close the current file.

Tutorial 2

In this tutorial, you will draw a sketch for the model shown in Figure 2-54. The sketch to be
drawn is shown in Figure 2-55. (Expected time: 30 min)

Figure 2-54 Model for Tutorial 2
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Figure 2-55 Sketch for Tutorial 2
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The following steps are required to complete this tutorial:

Start a new file.

Draw the sketch by using the XC-ZC plane as the sketching plane.
Draw the outer loop of the profile by using the Profile tool.

Fillet the sharp corners of the outer loop by using the Fillet tool.
Draw circles by using the centers of fillets to complete the profile.
Finish the sketch and save the file.

me A TR

Starting NX and Opening a New File

First, you need to start NX and then start a new file.
1. Double-click on NX shortcut icon on the desktop of your computer to start NX.

2. Choose the New button from the Standard group of the Home tab or choose
Menu > File > New from the Top Border Bar; the New dialog box is displayed.

3. Select the Model template from the Templates rollout.
4. Enter c02tut2 as the name of the document in the Name text box of the dialog box.

5. Choose the button on the right side of the Folder text box; the Choose Directory I_L:ﬁ)
dialog box is displayed.

6. In this dialog box, browse to NX/c02 folder and then choose the OK button twice; the new
file is started in the Modeling environment.

Drawing the Sketch in the Sketching Environment
The base sketch of this model will be created on the XC-ZC plane.

1. Choose the Sketch tool from the Construction group of the Home tab; the Create @
Sketch dialog box is displayed. Sketen

2. Select the XC-ZC plane from the Datum Coordinate system in the drawing window if it is
not selected by default.

3. Choose the OK button from the Create Sketch dialog box; the sketching tools become
available and the sketching plane is oriented parallel to the screen. Also, the Profile tool is
activated by default.

Drawing Lines of the Outer Loop
You will draw the lines of the outer loop by using the line mode of the Profile tool. The line
will start from the origin. In the current view, the origin is the intersection point of the two
planes displayed as the horizontal and vertical lines.

1. Choose the Profile tool from the Curve group of the Home tab in the Ribbon
if itis not already activated; the Profile dialog box is displayed. By default, the Line
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10.

button is active in this dialog box and the dynamic input boxes are displayed below the line
Cursor.

Move the cursor close to the origin; the coordinates of the point are displayed as 0,0 in the
dynamic input boxes. Next, click to specify the start point of the line.

The point you specified is selected as the start point of the line and the endpoint is attached
to the cursor. As you move the cursor on the screen, the line stretches and its length and angle
values are modified dynamically in the dynamic input boxes. Next, you need to specify the
endpoint of this line as well as the points to define the remaining lines. This can be done
by using the Length and Angle dynamic input boxes.

Enter 200 in the Length dynamic input box and press the TAB key. Next, enter 0 in the
Angle dynamic input box and press the ENTER key.

Choose the Fit tool from the View tab to fit the sketch into the drawing window. Since the
Profile tool is still active, therefore you are prompted to specify the second point of the line.

Enter 90 in the Length dynamic input box and press the TAB key. Next, enter 90 in the
Angle dynamic input box and press the ENTER key; a vertical line of 90 mm is drawn.

Choose the Fit tool again to fit the drawing into the current display.

Move the cursor away from the end point of the last line and then enter 40 in the Length
dynamic input box and press the TAB key. Next, enter -180 in the Angle dynamic input
box and press the ENTER key; a horizontal line of 40 mm is drawn.

Move the cursor away from the end point of the last line and then enter 40 in the Length
dynamic input box and press the TAB key. Next, enter -90 in the Angle dynamic input box
and press the ENTER key; a vertical line of 40 mm is drawn downward.

Move the cursor away from the end point of the last line and then enter 120 in the Length
dynamic input box and press the TAB key. Next, enter 180 in the Angle dynamic input box
and press the ENTER key; a horizontal line of 120 mm is drawn.

Move the cursor vertically upward until the horizontal help line is displayed from the top
endpoint of the vertical line of 40 mm. Note that at this point, the value of the length in
the Length dynamic input box is 40 and the value of the angle is 90. Click to specify the
endpoint of this line.

11. Move the cursor horizontally toward the left and make sure that the horizontal constraint

12.

symbol is displayed. Click to specify the endpoint of the line when the vertical help line is
displayed from the vertical plane. If the help line is not displayed, move the cursor once
on the vertical plane and then move it back.

Move the cursor vertically downward to the origin. If the first line is not highlighted
in yellow, move the cursor over it once and then move it back to the origin; the
cursor snaps to the endpoint of the first line.
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13. Click to specify the endpoint of the line when the 2400
vertical constraint symbol is displayed. Choose the Fit
tool to fit the sketch into the drawing window. pi=1200

40
p3=40,0

p1=80,0

14. Press the ESC key twice to exit the Profile tool. The
sketch after drawing the lines is shown in Figure 2-56. S

p0=200,0

Filleting Sharp Corners
In this section, you need to fillet sharp corners by
using the Fillet tool so that there are no sharp edges
in the final model.

Figure 2-56 Skelch afier drawing the
lines

1. Choose the Fillet tool from the Curve group of the Home tab; the Fillet dialogbox ™
is displayed. |

In this tutorial, the lower left and lower right corners are filleted with a radius of 15 mm and
the remaining corners are filleted with a radius of 10 mm.

2. Enter 15 in the Radius dynamic input box and press the ENTER key.

3. Move the cursor over the lower left corner of the sketch; the two lines comprising this corner
are highlighted in yellow. Click to select this corner; a fillet is created at the lower left corner.

4. Similarly, move the cursor over the lower right corner and click on it when the two lines
that form this corner are highlighted in yellow.

Next, you need to modify the fillet radius value and fillet the remaining corners.
5. Enter 10 in the Radius dynamic input box and press the ENTER key.
6. Select the remaining corners of the sketch one by one and fillet them with a radius of 10.

7. Right-click and then choose the OK option from the shortcut menu to exit the Fillet tool.
The fillets are created, refer to Figure 2-57.
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Figure 2-57 Sketch afier creating fillets
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Drawing Circles
Finally, you need to draw circles to complete the sketch. The circles will be drawn by using
the Circle tool. Use the center points of the fillets as the center points of the circles.

1. Choose the Circle tool from the Curve group of the Home tab; the Circle dialog =,
box is displayed. By default, the Circle by Center and Diameter button is chosen | '
S . A
in this dialog box. Also, you are prompted to select the center of the circle.

2. Move the cursor toward the center point of the lower left fillet; the cursor snaps to the center
point of the arc. Also, the center point snap symbol is displayed above the dynamic input
boxes.

3. Click when the cursor snaps to the center point of the fillet to specify the center point of
the circle.

4. Enter 15 in the Diameter dynamic input box and press the ENTER key; a circle of the
specified diameter is drawn at the specified center point. Also, another circle of 15 diameter
is attached to the cursor.

5. Move the cursor toward the center point of the lower right fillet; the cursor snaps to the
center point of the arc and the center point snap symbol is displayed above the dynamic
input box.

6. Click when the cursor snaps to the center point of the arc; the circle is drawn at the specified
location.

Note
@ If by mistake you select an incorrect point as the center point of the circle, you can remove the
unwanted circle by choosing the Undo button from the Quick Access toolbar.

7. Exit the Circle tool by pressing the ESC key twice.

This completes the sketch of the model for Tutorial 2. The final sketch for Tutorial 2 is
shown in Figure 2-58.
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Figure 2-58 Final sketch for Tutorial 2
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Finishing the Sketch and Saving the File

NX allows you to save the sketch file in the Sketch environment.
1. Choose the Fit tool to fit the sketch into the drawing window.
2. Choose the Save button from the Quick Access toolbar.
3. Next, choose the Finish tool from the Sketch group; the Modeling environment is invoked.

4. Choose Menu > File > Close > Selected Parts from the Top Border Bar; the Close Part
dialog box is displayed.

5. Select the name of the current file from the list area in the Part rollout and then choose the
OK button to close the current file.

y. Note
- For better visualization, you can set the background color of the graphics window in NX as per
your requirement. 1o set the background coloy; choose Menu > Preferences > Background from
the Top Border Bar; the Edit Background dialog box is displayed. Select the Plain radio button
from both the Shaded Views and Wireframe Views areas. Next, choose the Plain Color swatch;
the Colors dialog box is displayed. From this dialog box, select the required color and choose the
OK button twice to exit the Edit Background dialog box.

X
N

Tutorial 3

In this tutorial, you will draw the profile of the model shown in Figure 2-59. The profile to be
drawn is shown in Figure 2-60. (Expected time: 30 min)

Figure 2-59 Model for Tutorial 3
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aogw
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Figure 2-60 Sketch for Tutorial 3

The following steps are required to complete this tutorial:

Start a new file.

Select the YC-ZC plane as the sketching plane.

Draw the sketch of the model by using the Profile tool.
Finish the sketch and save the file.

Starting a New File

If you continue working after completing Tutorial 2, you do not need to open a new session
of NX. You can start a new part file by selecting the Model template from the New dialog
box.

Choose the New button from the Standard group of the Home tab or choose Menu > File >
New from the Top Border Bar; the New dialog box is displayed.

Select the Model template from the Templates rollout.

Choose the button on the right of the Name text box; the Choose New File Name n:r.lﬂ“'
dialog box is displayed. ;

In this dialog box, browse to NX/c02 and then enter c02tut3 in the File name edit box. Next,
choose the OK button twice; the new file is started in the Modeling environment.

Drawing the Sketch in the Sketching Environment

The base sketch of this model will be created on the YC-ZC plane. Therefore, you need to
draw the sketch using this plane.

Choose the Sketch tool from the Construction group of the Home tab; the Create Sketch
dialog box is displayed.
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2.

Select the YC-ZC plane from the drawing window. Note that the Z-axis direction of the
sketching plane points toward the front side of the sketching plane and the direction of
Y-axis is upward.

Choose the OK button from the Create Sketch dialog box to start the sketch.

Drawing the Sketch

The sketch that you need to draw consists of multiple lines and two arcs. All these entities
can be drawn by using the Line and Arc options of the Profile tool.

Choose the Profile tool from the Curve group if it is not already active; the Profile dialog
box is displayed. In this dialog box, the Line button is activated by default. Also, the dynamic
input boxes are displayed below the line cursor.

Move the cursor close to the origin; the coordinates of the point are displayed as 0,0 in the
dynamic input boxes. Click to specify the start point of the line at this point.

The point you specified is selected as the start point of the line and the endpoint is attached
to the cursor. As you move the cursor on the screen, the line stretches and its length and
angle values are modified dynamically in the dynamic input boxes.

Next, you need to specify the endpoint of this line. Also, you need to specify the points to
define the remaining lines of the sketch. This can be done by using the Length and Angle
dynamic input boxes.

Enter 12 in the Length dynamic input box and press the TAB key. Next, enter 0 in the Angle
dynamic input box and press the ENTER key. The first line is drawn and a rubber-band
line is displayed with the start point at the endpoint of the previous line and the endpoint
attached to the cursor.

Now, you need to invoke the arc mode because the next entity to be drawn is an arc.

Choose the Arc button from the Object Type area of the Profile dialog box to invoke the
arc mode.

A rubber-band arc is displayed with the start point fixed at the endpoint of the last line
and the endpoint attached to the cursor. Also, the quadrant symbol is displayed at the start
point of the arc.

Move the cursor to the start point of the arc and then move it vertically upward through a
small distance. Next, move the cursor toward the right; you will notice that a normal arc
starts from the endpoint of the last line.

Enter 12 in the Radius dynamic input box and press the TAB key. Next, enter 180 in the
Sweep Angle dynamic input box and press the ENTER key.

A preview of the resulting arc is displayed, but the arc is still not drawn. To draw the arc, you
need to specify a point on the screen with the values mentioned in the dynamic input boxes.
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7.

10.

11.

12.

13.

14.

15.

16.

17.

18.

Move the cursor horizontally toward the right and click when the preview of the required
arc is displayed. The arc is drawn and the line mode is invoked again.

Enter 12 as the length and 0 as the angle in the Length and Angle dynamic input boxes,
respectively, and then press the ENTER key. Choose the Fit tool from the Operation group
of the View tab to fit the sketch into the drawing window.

Enter 30 as the length and 90 as the angle in the Length and Angle dynamic input boxes,
respectively, and then press the ENTER key.

Move the cursor horizontally toward the left. Make sure that the horizontal constraint symbol
is displayed. Click to specify the endpoint of the line when the vertical help line is displayed
from the endpoint of the arc.

Next, you need to draw the arc by invoking the arc mode.

Choose the Arc button from the Profile dialog box to invoke the arc mode; a rubber-band
arc is displayed with its start point fixed at the endpoint of the last line.

Move the cursor to the start point of the arc and then move it vertically downward through
a small distance. When the normal arc appears, move the cursor toward the left.

Move the cursor over the lower arc once and then move it toward the left, refer to Figure 2-61.
A horizontal help line is displayed originating from the center of the arc being drawn. At
the point where the cursor is vertically in line with the start point of the lower arc, a vertical

help line appears from the start point of the lower arc, refer to Figure 2-61.

Click to define the endpoint of the arc when the horizontal and vertical help lines are
displayed. The arc is drawn and the line mode is invoked again.

Enter 12 as the radius and 180 as the angle in the Length and Angle dynamic input boxes,
respectively, and then press the ENTER key.

Move the cursor to the first line and then move it to the start point of this line; the cursor
snaps to the start point of the line.

Click to define the endpoint of this line when the cursor snaps to the start point of the first
line.

Press the ESC key twice to exit the Profile tool. The final sketch of the model is shown in
Figure 2-62.
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Figure 2-61 Horizontal and vertical help lines Figure 2-62 Final sketch for Tutorial 3
displayed to define the endpoint of the arc

Finishing the Sketch and Saving the File

NX allows you to save the sketch file in the Sketch environment.

m
Choose the Save button from the Quick access toolbar to save the sketch. rE'|
Next, choose the Finish tool from the Sketch group; the Modeling environment is invoked.

Choose Menu > File > Close > Selected Parts from the Top Border Bar; the Close Part
dialog box is displayed.

Select the name of the current file from the list area in the Part rollout and then choose the
OK button to close the current file.

Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this

chapter:

1. You can restore the original orientation of the sketching plane by using the tool.

2. You can invoke the arc mode within the Profile tool by choosing the button from
the Profile dialog box.

3. You can fillet corners in a sketch by using the tool.

4. You can draw an elliptical arc by using the tool.

5. If you choose the button from the Rectangle dialog box, it will enable you to

draw a centerpoint rectangle.

You can exit the sketching environment by choosing the tool from the Sketch
group of the Home tab.
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7. Most of the designs created in NX consist of sketch-based features and placed features. (T/F)

8. When you invoke the sketching environment from the Construction group, the Profile tool
is invoked by default. (T/F)

9. You can use the dynamic input boxes to specify the exact values of the sketched entities. (T/F)

10. You need to choose the Sketch tool to invoke the Sketching environment. (1/F)

Review Questions

Answer the following questions:

1. Which of the following dialog boxes is displayed when you choose the New button from the
File tab to start a new file?

(a) New Part File (b) New Item
(c) New (d) Part File

2. Which of the following tools in NX is used to create conics?

(a) General Conic (b) Conic
(c) Round (d) None

3. Which mode is automatically invoked from the Profile dialog box when you specify the start
point of a line?

(a) Coordinate Mode (b) Angle Mode
(c) Parameter Mode (d) None

4. In NX, how many methods are used to start a new file?

(a) 1 (b) 2
(©3 (d)5

5. Which of the following options is available in the Studio Spline dialog box along with the
By Poles option to draw splines?

(a) No Poles (b) From Poles
(c) From Points (d) Through Points
g

6. The files in NX are saved with .prt extension. (1/F)
7. You can select entities by dragging a box around them. (T/F)

8. You can set the selection mode to select only the sketched entities. (1/F)
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9. In NX, you can create fillets by simply dragging the cursor across the entities that you want
to fillet. (T/F)

10. In NX, you cannot draw a rectangle from its center. (T/F)

EXERCISES

Exercise 1

Draw a sketch for the base feature of the model shown in Figure 2-63. The sketch to be drawn
is shown in Figure 2-64. (Expected time: 30 min)

Figure 2-63 Model for Exercise 1

R30
@30
2X R4 W
- 4
20
150

Figure 2-64 Sketch for Exercise 1
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Exercise 2

Draw a sketch for the base feature of the model shown in Figure 2-65. The sketch to be drawn
is shown in Figure 2-66. (Expected time: 30 min)

Figure 2-65 Model for Exercise 2
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Figure 2-66 Sketch for Exercise 2

Answers to Self-Evaluation Test
1. Orient View to Sketch, 2. Arc, 3. Fillet, 4. Ellipse, 5. From Center, 6. Finish, 7. T, 8. T, 9. T,
10. T



