
Chapter 3
 

Adding Geometric and  
Dimensional 

Constraints to 
Sketches

  Learning Objectives 
After completing this chapter, you will be able to:
• Understand the concept of under-constrained, fully-constrained, and over-constrained       	
   sketches
• Understand different types of dimensions
• Measure the distance value between entities in a sketch
• Measure the angle between entities
• Understand different types of geometric constraints
• Configure settings for applying constraints automatically while sketching
• Force additional geometric constraints to sketches
• View and delete geometric constraints from sketches
• Animate a fully-constrained sketch
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CONSTRAINING SKETCHES
In the previous chapter, you learned to draw sketches. You must have noticed that the dimensions 
are applied automatically to the sketches when they are drawn but the dimensions are updated 
when you drag the sketched entities. Therefore, these dimensions do not constrain the sketch. 
In this chapter, you will learn to completely constrain the sketches to restrict their degrees of 
freedom and make them stable. The stability ensures that the size, shape, and location of the 
sketches do not change unexpectedly with respect to the surrounding. Therefore, it is always 
recommended to constrain the sketches. The geometrical constraints are applied first, some 
of which get automatically applied while drawing. After applying the remaining geometrical 
constraints, you need to add dimensional constraints using dimension tools. You will learn more 
about dimension tools later in this chapter.

CONCEPT OF CONSTRAINED SKETCHES
After drawing and applying the constraints, the sketch can attain any one of the following three 
stages:

1. Under-Constrain
2. Fully-Constrain
3. Over-Constrain

These stages are described next.

Under-Constrain
An under-constrained sketch is the one in which all the degrees of freedom of each entity 
are not completely defined using the geometric and dimensional constraints. The elements 
of the sketch that are displayed in light purple color are under-constrained. You need to 
apply additional constraints to them in order to constrain their degree of freedom. The 
under-constrained sketches tend to change their position, size, or shape unexpectedly. Therefore, it 
is necessary to fully define the sketched elements. Figure 3-1 shows an under-constrained sketch.

Fully-Constrain
The fully-constrained sketch is the one in which all degrees of freedom of each element are 
defined using the geometric and dimensional constraints. As a result, the sketch cannot change 
its position, shape, or size unexpectedly. These dimensions can change only if they are modified 
deliberately by the user. The elements of a fully-constrained sketch are displayed in dark green 
color. Figure 3-2 shows a fully-constrained sketch.

Over-Constrain
An over-constrained sketch is the one in which some additional constraints are applied. The 
over-constrained dimensions and constraints are displayed in red color. It is always recommended 
to delete additional constraints and make the sketch fully-constrained before exiting the sketching 
environment. Figure 3-3 shows an over-constrained sketch.
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omFigure 3-1  An under-constrained sketch Figure 3-2  A fully-constrained sketch

Figure 3-3  An over-constrained sketch

While applying the geometric and dimensional constraints, the status area in the Status Bar 
displays the number of constraints needed to fully constrain the sketch. After fully constraining the 
sketch, a message will be displayed in the status area of the Status Bar that the sketch is fully 
constrained. 

Also, if the sketch is over-constrained, you will be informed that the sketch contains over 
constrained geometry. In such a case, you need to remove the unwanted constraints.

DEGREES OF FREEDOM ARROWS
Degrees of Freedom can be defined as the number of independent variables or coordinates 
required to ascertain the position of any system or its components. In other words, you can say, it 
is the number of variables that are required to determine the position of a mechanism in space.
In NX, the degrees of freedom arrows are displayed on the points that are free to move 
(under-constrain), refer to Figure 3-4. Note that the degree of freedom arrows will be displayed 
only when you choose any constraining tool (geometrical or dimensional). These tools are 
discussed later in this chapter.

Figure 3-4  The degrees of freedom arrows displayed on points
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The direction of an arrow at a particular point indicates that you need to constrain the movement 
along that direction. When you constrain a point, NX will remove the degree of freedom arrows. The 
sketch will be fully-constrained only when all the arrows disappear. The horizontal and vertical arrows 
indicate that the point is free to move in the X and Y directions, respectively. Various geometric 
and dimensional constraint tools used to fully-constrain the sketch are discussed in this chapter.

DIMENSIONING SKETCHES                                     
After creating a sketch, you need to apply different types of dimensions (dimensional constraints) 
to it. The purpose of dimensioning is to control the size of the sketch and to place it with reference 
to some other entity. As discussed earlier, by default, sketched entities get dimensioned 
automatically while drawing a sketch. However, the automatically applied dimensions do not 
constrain the sketch. Therefore, you need to lock them to fully constrain the sketch. Also, 
sometimes you may need to add additional dimensions to the sketch to fully constrain it. In NX, 
you can apply the dimensions by using the tools grouped together in the Dimension group of 
the Home tab in the sketching environment. Note that all

Figure 3-5 The Dimension group

 
dimension tools are not visible in this group by default. You 
can click on the Group Options arrow at the bottom of the 
Dimension group to display a flyout and then choose the 
required tools to add them in the group.  Figure 3-5 shows 
the Dimension group after adding all the tools. The tools 
available in this group are listed below: 

1.	 Rapid Dimension
2.	 Linear Dimension
3.	 Angular Dimension
4.	 Radial Dimension
5.	 Perimeter Dimension

						    
Note
As the Continuous Auto Dimensioning tool is active by default in the Constraint Tools 
Drop-down of the Constrain group in the Home tab, the sketched entities will be dimensioned 
automatically in the sketching environment. If you do not want the sketch to be auto dimensioned, 
you can deactivate this tool by clicking on it. Also, you can control the display of auto dimensions by 
using the Display Auto Dimensions toggle button available in the Constraint Tools Drop-down 
of the Constrain group. 

The procedure of locking the automatically applied dimensions and applying various dimensions 
are discussed next.
  

Locking the Automatically Applied Dimensions
As discussed earlier, when you draw a sketch, some dimensions are automatically applied to it. 
However, these dimensions do not constrain the sketch as they get modified when you drag the 
sketched entities. To lock a dimension of the sketch, you need to double-click on it. On doing so, an 
edit box will be displayed. Also, a dialog box will be displayed for respective dimension. Enter the 
required value in the edit box and press ENTER; the dimension will be locked and displayed in blue 
color. Next, choose the Close button from the dialog box or press ESC key to exit the dialog box.
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Note
1. NX provides automatic and manual scale methods to scale sketches. When you add the first 
distance, radius, or diameter driving dimension, NX automatically scales the sketch to that value 
while maintaining the overall shape and inferred geometric constraints.

Note that the sketch is only scaled once and the next dimension you add or modify acts like any 
driving dimension.

2. You can dynamically edit and display the driving dimensions in a better manner to check the 
design intent. When you modify sketch geometry, NX moves the dimensions with the geometry. 
This behavior gives a neat look to the sketch by relocating the dimensions relative to the geometry.

Applying Dimensions by Using the Rapid Dimension Tool
 Ribbon:	 Home > Dimension > Rapid Dimension	  
 Menu:		  Insert > Dimensions > Rapid		

The Rapid Dimension tool is used to apply dimension depending upon the entity 
selected.  For example, if you select an arc, the radial dimension will be applied. Similarly, 
if you select a circle, the diameter dimension will be applied and on selecting a line, 
linear dimension will be applied. Note that if you select an inclined line and move the 

cursor parallel to that line; an aligned dimension will be applied. If you move the cursor vertically 
upward or downward, a horizontal dimension will be applied. Similarly, if you move the cursor 
horizontally (right or left), a vertical dimension will be 

Figure 3-6  The radial and linear 
dimensions created by using the Rapid 
Dimension tool

applied.

It is recommended that you use this tool to apply 
different type of dimensions as it saves the time required 
for selecting various dimensioning tools. To apply rapid 
dimensions, choose the Rapid Dimension tool from the 
Dimension group of the Home tab; the Rapid Dimension 
dialog box will be displayed and you will be prompted to 
select the object to be dimensioned. Now the dimension 
will be applied based on the selection procedure adopted 
while selecting objects. Figure 3-6 shows the radial and 
linear dimensions created by using the tool.

Applying Linear Dimensions                                           
 Ribbon:	 Home > Dimension > Linear Dimension (Customize to Add) 	  
 Menu:		  Insert > Dimensions > Linear		              			

The Linear Dimension tool is used to apply horizontal, vertical, or aligned 
dimension to a selected line or between two points. The points can be the endpoints of  line or 
arc, or the center points of two circles, arcs, ellipses, or parabola, or any set of points that can 

be identified. To apply linear dimension to a sketch, choose the Linear Dimension tool from 
the Dimension group of the Home tab, refer to Figure 3-5; the Linear Dimension dialog box 
will be displayed, as shown in Figure 3-7.  



3-6						      Siemens NX 2021 for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 3-7  The Linear Dimension 
dialog box

The options in this dialog box are discussed next.

References Rollout
The options in this rollout are used to select the object to be dimensioned. Using the options in 
this rollout, you can select points or linear entities for applying the dimension. 
 
Origin Rollout
This rollout is used to define the position of  the dimension text. You can place the dimension 
at the required location. Place the dimension above or below (in case of horizontal) and left 
or right (in case of vertical) of the selected object by clicking on the desired place inside the 
drawing window. As soon as you place the dimension, an edit box will be displayed. Enter the 
required value in this edit box and then press ENTER. Next, press ESC to exit the dialog box. 
Figure 3-8 shows the horizontal, vertical, and aligned dimensions applied to a line. The Place 
Automatically check box is used to place the dimension automatically according to the object.
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Figure 3-8 The linear dimension created for a 
horizontal line, vertical line, and an inclined line

Measurement Rollout
The options available in the Method drop-down list of this rollout are discussed next.

Inferred
The Inferred option is used to apply dimensions between entities based on the entities 
selected for dimensioning and the placement point. 

Horizontal
The Horizontal option is used to apply horizontal dimension between entities. Note that if 
you select an entity that has a slant angle, only horizontal dimension can be applied.

Vertical
The Vertical option is used to apply vertical dimension between entities. Even if you select 
an entity that has a slant angle, a vertical dimension will be applied.
       
Point-to-Point
The Point-to-Point option is used to apply dimension between two points. You can select 
a set of points or a linear entity for applying dimension by using this option. Note that on 
selecting a linear entity, the dimension between its ends points will be applied, depending 
upon the entity selected, refer to Figure 3-8.

Perpendicular
The Perpendicular option is used to create the perpendicular dimension between a linear 
object and a point. It is mandatory that any one of the objects selected is a linear object.

Cylindrical
The Cylindrical option is used to apply dimension between cylindrical sections of objects.

Driving Rollout
In the Driving rollout, the Reference check box is available. This check box is used to convert 
the dimension into a reference dimension instead of a driving dimension. 
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Note
If you create a redundant dimension, NX may inform you that the sketch is over-constrained. When 
you convert the dimension into a reference dimension, the sketch will no longer be over-constrained.

Settings Rollout
There are two buttons in this rollout and they are discussed next.

Settings
The Settings button is used to change the style of the dimensions that are being applied.

Inherit Dimension Settings
This button allows you to apply the style setting of an existing dimension to the dimensions 
being applied.

The Enable Dimension Scene Dialogs check box allows you to select access handles directly on 
different parts of the dimension to edit dimension settings.
 

Note
In the figures of this chapter, some of the dimension properties such as decimal places and labels 
have been modified for better display of dimensions. You can modify the dimension labels only when 
you are in the sketching environment. As discussed, you can invoke the sketching environment by 
using the Sketch tool. To modify the dimension label, choose Home > Construction > Sketch 
from the Ribbon; the Create Sketch dialog box will be displayed. Next, choose the OK button 
from this dialog box; the sketching environment will be invoked. Now, choose Menu >Task > 
Sketch Settings from the Top Border Bar; the Sketch Settings dialog box will be displayed. In 
this dialog box, select the Value option from the Dimension Label drop-down list. Next, choose 
the OK button; the dimensions labels will be modified.

Applying Radial Dimensions
 Ribbon:	 Home > Dimension > More Gallery > Dimension Gallery > Radial Dimension                                                                                                                                        
                        (Customize to Add)                                                                                                                                             
 Menu:		  Insert > Dimensions > Radial			               			                             

The Radial Dimension tool is used to apply the radial dimension to an arc or diametral 
dimension to a circle. To apply radial dimension, choose the Radial Dimension tool from 
the More Gallery of the Dimension group of the Home tab, refer to Figure 3-5; the Radial 
Dimension dialog box will be displayed and you will be prompted to select an arc or circle 

to be dimensioned. Select the object to be dimensioned and then place the dimension. As soon 
as you place the dimension, an edit box will be displayed. Enter the required value in this edit 
box, and then press ENTER. Next, press ESC to exit the dialog box. You can also select the 
type of dimension to be applied from the Method drop-down list in the Measurement rollout. 
In this drop-down list, the Radial option is used to define the radius and the Diametral option 
is used to define the diameter dimensions. However, if you select the Inferred option from 
the drop-down list, radius dimensions will be applied to arcs and diameter dimensions will be 
applied to circles automatically. Figure 3-9 shows the diametral dimension applied to a circle 
and Figure 3-10 shows the radial dimension applied to an arc. Rest of the options in the Radial 
Dimension dialog box are the same as those discussed in the Linear Dimension.
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Figure 3-10  The radial dimension 
applied to an arc

Figure 3-9  The diametral dimension 
applied to a circle

Applying Angular Dimensions
 Ribbon:	 Home > Dimension > Angular Dimension (Customize to Add)	  
 Menu:		  Insert > Dimensions > Angular					   

The Angular Dimension tool is used to apply angular dimension between entities. 
Whenever an angular dimension is applied using the Angular Dimension tool, the angle 
is always measured in the counterclockwise direction. 

Figure 3-11  Angular dimensions 
applied between the entities

To apply angular dimension, choose the  Angular 
Dimension tool from the Dimension group of the Home 
tab, refer to Figure 3-5; the Angular Dimension dialog box will 
be displayed and you will be prompted to select an object to be 
dimensioned. Select the entities between which the angular 
dimension needs to be applied and then place the dimension. 
Figure 3-11 shows different types of angular dimensions applied 
to a sketch. Rest of the options in the Angular Dimension dialog 
box are same as discussed earlier.

Applying Perimeter Dimensions
 Ribbon:   Home > Dimension > More Gallery > Dimension Gallery > Perimeter Dimension                                                                                                                                        
                (Customize to Add)								                    
 Menu:     Insert > Dimensions > Perimeter						                

The Perimeter Dimension tool is used to apply the circumferential or perimeter dimension. 
After applying the perimeter dimension, all the dimensions of the selected objects are 

locked. To apply the perimeter dimension, choose the Perimeter Dimension tool from the 
Dimension group of the Home tab; the Perimeter Dimension dialog box will be displayed. 
Select the object and then choose the OK button from this dialog box; the perimeter dimension 
will be applied to the selected object. Note that this dimension will not be displayed in the 
drawing window. 

You can also apply the perimeter dimension to a closed sketch. To do so, invoke the Perimeter 
Dimension dialog box and then select all the entities of the closed sketch one by one. Next, 
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choose the OK button from the Perimeter Dimension dialog box; the dimension will be applied 
to the sketch. Now, if you modify the dimension of any one of the entities, the dimension of 
other entities will also be modified such that the total perimeter of the sketch remains the same. 

Editing the Dimension Value and Other Parameters
To edit a dimension, double-click on the dimension to be edited; the respective dimension 
dialog box will be invoked. Also, edit boxes will be displayed in the graphics window. By using 
the options available in the Driving rollout of the dialog box, you can specify the new dimension 
value and control the display of expression. You can also specify the new dimension value in the 
edit box displayed in the graphic window. Once you have specified the new dimension value, 
press the ESC key to apply the change and exit the dialog box.

Animating a Fully-Constrained Sketch
 Ribbon:	 Home > Constrain > Constraint Tools Drop-down > Animate Dimension 	  
 Menu:		  Tools > Constraints > Animate Dimension				  

The Animate Dimension tool is used to animate a sketch by selecting any one of the 
dimensions as the driving dimension from the same sketch. Generally, this type of 

animation is used while creating basic mechanisms and links. When a dimension from a fully 
constrained sketch is animated, the whole sketch gets mechanized by the possible movements. 
The dimension selected from the sketch for animating is known as the driving dimension. To 
animate a fully constrained sketch, choose the Animate Dimension tool from the Constraint 
Tools Drop-down of the Constrain group of the Home tab; the Animate Dimension dialog box 
will be displayed, as shown in Figure 3-12, and you will be prompted to select a dimension to 
animate. The dimensions that are applied to the sketch are listed in the list box of the same 
dialog box. You can select the driving dimension directly from the sketch or from the list box. 
After selecting the driving dimension, enter the lower limit value for the dimension inside the 
Lower Limit edit box. Similarly, enter the upper limit value

Figure 3-12  The Animate Dimension 
dialog box 

 
for the dimension inside the Upper Limit edit box. The 
selected dimension will be animated between the lower 
and upper limits specified. You can also divide an 
animation cycle into a number of steps and then animate 
the design. The number of steps per cycle should be 
entered inside the Steps/Cycle edit box. To display the 
dimension applied during the animation, select the 
Display Dimensions check box. For example, a fully 
constrained sketch from which the driving dimension is 
selected is shown in Figure 3-13. Figure 3-14 shows the 
sketch while animating. Note that at an instance, only one 
dimension can be selected as the driving dimension. If 
the sketch is not fully constrained, an undesired animation 
may occur.
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Figure 3-14  The sketch being 
animated

Figure 3-13  Driving dimension selected 
from the sketch

Note
You can hide and show the auto dimensions whenever you want. To do so, use the Display Auto 
Dimensions toggle button available in the Constraint Tools Drop-down of the Constrain group 
of the Home tab to toggle on/off the auto dimensions.

GEOMETRIC CONSTRAINTS                                             
Geometric constraints are the logical operations that are performed on the sketched 
entities to relate them to the other sketched entities using the standard properties such as 
collinearity, concentricity, tangency, and so on. These constraints reduce the degrees of freedom of 
the sketched entities and make the sketch more stable so that it does not change its shape and 
location unexpectedly at any stage of the design. All geometric constraints have separate symbols 
associated with them. These symbols can be seen on the sketched entities when the constraints 
are applied to them. In the sketching environment of NX, you can add various types of geometric 
constraints. Some of these constraints are added automatically while sketching. Additionally, you 
can add more constraints to the sketch manually. These are explained next. 

Applying Additional Constraints Individually	
 Ribbon:	 Home >  Constrain > Geometric Constraints	  
 Menu:		  Insert > Geometric Constraints			 

In NX, you can apply additional constraints manually by using the Geometric Constraints 
tool available in the Constrain group of the Home tab. To apply constraints, invoke the 
Geometric Constraints tool; the Geometric Constraints message box will be displayed. 

Select the Don’t display this message again check box in it and then choose the OK button; 
the Geometric Constraints dialog box will be displayed, as shown in Figure 3-15. Select the 
required constraint from the Constraint rollout of the dialog box and then select the entities 
from the drawing area to apply the selected constraint.

Note
By default, only few constraints are available in the Constraint rollout of the Geometric 
Constraints dialog box. You can customize constraints to add or remove the constraints from the 
Constraint rollout. Select the check boxes next to the required constraints from the Settings rollout; 
the selected constraints will be displayed in the Constraint rollout.



3-12						      Siemens NX 2021 for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

In NX, you can also apply constraints directly without invoking the Geometric Constraints 
dialog box. To do so, select the entities from the drawing area; a contextual toolbar will be 
displayed with all possible constraints that can be applied to the selected entities, as shown in 
Figure 3-16. Select the required constraint from the contextual toolbar; the selected constraint 
will be applied to the selected entities. 

Figure 3-15  The Geometric Constraints dialog box Figure 3-16  The contextual toolbar

Various constraints that can be applied to the sketched entities in NX are discussed next.

Fixed Constraint
The Fixed constraint is used to fix some of the characteristics of the geometry. To apply 
this constraint, choose the Fixed button (Customize to add) from the Constraint rollout of 
the Geometric Constraints dialog box. Next, select the entity to be fixed from the drawing 

area; the selected entity will be fixed. Alternatively, you can apply the fixed constraint using the 
contextual toolbar. To do so, select an entity from the drawing area; the contextual toolbar will 
be displayed with the possible constraints that can be applied to the selected entity. Next, choose 
the Fixed option from the contextual toolbar, refer to Figure 3-17; the selected entity will be 
fixed.

Figure 3-17  Applying the Fixed constraint to an entity



Adding Geometric and Dimensional Constraints to Sketches			          3-13

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

The characteristics of the geometry after applying the Fixed constraint depend on the type of 
geometry selected. Following are some of the examples of Fixed constraint:

1.	 If you apply this constraint to a point, the point will be fixed and cannot be moved.

2.	 If you apply this constraint to a line, its angle will be fixed; however, you can move and 
stretch the line.

3.	 If you apply this constraint to the circumference of a circular arc or an elliptical arc, the 
radius of the arc and the location of the center point will be fixed. However, you can change 
the arc-length.

Fully Fixed Constraint
This constraint is same as the Fixed constraint with the only difference being that this 
constraint fixes all characteristics of a geometry. For example, if you apply this constraint 
to a line, the line will be fully-constrained and it cannot be moved or stretched. To apply 

this constraint, choose the Fully Fixed button (Customize to add) from the Constraint rollout and  
then select the entity; the selected entity will be fully fixed.

Coincident Constraint
The Coincident constraint forces two or more keypoints to share the same location. The 
keypoints that can be used to apply this constraint include the endpoints, center points, 
control points of splines, and so on. To apply this constraint, invoke the 

Geometric Constraints tool and then choose the Coincident button from the Constraint rollout. 
Next, select the keypoints of the sketched entities that are to be made coincident. Figure 3-18 
shows the endpoints of the two lines selected to be made coincident and Figure 3-19 shows the 
sketch after applying the constraint.

Figure 3-19  The sketch after applying the 
Coincident constraint

Figure 3-18  The endpoints of the first
and second entities selected

Horizontal Constraint
The Horizontal constraint forces the selected line segment to become horizontal, 
irrespective of its original orientation. To apply this constraint, choose the Horizontal 
button from the Geometric Constraints dialog box and then select the entity; the selected 
line segment will be forced to become horizontal.
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Vertical Constraint
The Vertical constraint is similar to the Horizontal constraint with the only difference 
that this constraint will force the selected line to become vertical.

Point on Curve Constraint
The Point on Curve constraint is used to place selected keypoints on selected curve or 
line. To apply this constraint, invoke the Geometric Constraints tool and then choose 
the Point on Curve button from the Constraint rollout; you will be prompted to select 

the entities to be constrained. First, select a point such as the endpoint or the center point. Next, 
select a curve; the point will be placed on the curve. Figure 3-20 shows a sketch before applying 
this constraint and Figure 3-21 shows a sketch after applying this constraint.

Figure 3-21  The sketch after applying the Point 
on Curve constraint

Figure 3-20  The reference elements selected from 
the entity to apply the Point on Curve constraint

Midpoint Constraint
NX provides you with an extension of the Point on Curve constraint, which is the Midpoint 
constraint. This constraint forces the selected point to be placed in line with the midpoint 
of the selected line or curve. Note that this constraint is available only when the selected 

curve is an open entity such as a line segment or an arc. Also, it is important to note that you 
need to select the curve anywhere other than at its endpoints.

Parallel Constraint
The Parallel constraint forces a set of selected line segments or ellipse axes to become 
parallel to each other. To apply this constraint, invoke the Geometric Constraints tool 
and then choose the Parallel button from the Constraint rollout; you will be prompted 

to select the objects to constrain. Select the set of line segments or ellipses; the selected line 
segments or axes of the ellipse will become parallel to each other. Figure 3-22 shows two line 
segments before and after applying this constraint.
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Perpendicular Constraint
The Perpendicular constraint forces a set of selected line segments or ellipse axes to 
become normal to each other. Figure 3-23 shows two line segments before and after 
applying this constraint.

Figure 3-22  Applying the Parallel 
constraint

Figure 3-23  Sketch before and after applying the 
Perpendicular constraint

Tangent Constraint
The Tangent constraint forces the selected line segment or curve to become tangent to 
another curve. To apply this constraint, invoke the Geometric Constraints tool and then 
choose the Tangent button from the Constraint rollout; you will be prompted to select 

the entities to be constrained. Select a line and a curve or select two curves; the selected line or 
curve will become tangent to the other selected curve. Figures 3-24 and 3-25 show the use of 
the Tangent constraint.

Figure 3-24  Sketch before and after applying 
the Tangent constraint

Figure 3-25  Sketch before and after applying 
the Tangent constraint

Note
By default, symbols of all the constraints are displayed in the sketch. You can turn on/off the display 
of constraints using the Display Constraints tool which is discussed later in this chapter.
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Equal Length Constraint
The Equal Length constraint forces the length of the selected line segments to become 
equal. To apply this constraint, invoke the Geometric Constraints tool and then choose 
the Equal Length button from the Constraint rollout. Next, select the line segments that 
you want to make equal in length; the selected line segments will become equal in length.

Equal Radius Constraint
The Equal Radius constraint forces the selected arcs or circles to become equal in radius. 
To apply this constraint, invoke the Geometric Constraints tool and then choose the 
Equal Radius button from the Constraint rollout. Next, select the arcs or circles that you 
want to make equal in radii; the selected arcs or circles will become equal in radii.

Concentric Constraint
This constraint is used to force two curves to share the same location of the center points. 
The curves that can be made concentric include arcs, circles, and ellipses. The ellipses 
can be made concentric with a circle or an arc also. Figure 3-26 shows two circles before 
and after adding this constraint.

Figure 3-26  Sketch before and after applying the Concentric constraint

Collinear Constraint
This constraint forces the selected line segments to lie along the same line.

Constant Length Constraint
The Constant Length constraint makes the length of the selected line segments constant. 
As a result, you will not be able to modify the length of the line by using the dimension 
constraints or by dragging. 

Constant Angle Constraint
The Constant Angle constraint makes the angle between the selected line segments 
constant. As a result, you will not be able to modify the angle between the lines by using 
the dimension constraints or by dragging. 
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Slope of Curve Constraint
The Slope of Curve constraint will force the slope of the spline at the selected control 
point to become equal to the slope of the selected line, arc, or spline segment.

Uniform Scale Constraint
The Uniform Scale constraint ensures that if you modify the distance between the 
endpoints of a spline, the entire spline will be scaled uniformly.

Non-Uniform Scale Constraint
The Non-Uniform Scale constraint ensures that if you modify the distance between the 
endpoints of a spline, it will be scaled non-uniformly and it appears to stretch. 

Point On String Constraint
The Point On String constraint is used to place selected keypoints on a projected curve 
or line. As a result, the selected point always lies on the projected curve. 

Horizontal Alignment Constraint                                                    
To apply this constraint, invoke the Geometric Constraints tool and then choose the 
Horizontal Alignment button from the Constraint rollout; you will be prompted to select 
the entities to be constrained. Select the points or midpoints of lines or curves you want 
to align; the aligned sketch will be displayed in the drawing area.

Vertical Alignment Constraint                                                        
To apply this constraint, invoke the Geometric Constraints tool and then choose the 
Vertical Alignment button from the Constraint rollout; you will be prompted to select 
the entities to be constrained. Next, select the points or midpoints of lines or curves you 
want to align; the aligned sketch will be displayed in the drawing area.

Perpendicular to String Constraint                                                
This constraint is used to create a perpendicular constraint between a sketch curve and 
a recipe curve. 

Tangent to String Constraint                                                          
This constraint is used to create a tangent constraint between a sketch curve and a recipe 
curve.

Note
The curves that are associatively projected to the sketch are called Recipe Curves.

Applying Symmetry Constraint
In NX, you can make two selected entities symmetric about a line by using the Make 
Symmetric tool. To make two entities symmetric, invoke the Make Symmetric tool from 
the Constrain group of the Home tab; the Make Symmetric dialog box will be displayed 

and you will be prompted to select the first object. Select the first object; you will be prompted 
to select the second object. Select the second object; you will be prompted to select a line or 
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plane as the centerline. After selecting the centerline, you will notice that the selected objects 
have become symmetric about the centerline. Also, the selected centerline has converted into 
a reference element. This is because the Make Reference check box is selected by default in the 
dialog box. Next, choose the Close button; the Make Symmetric dialog box will be closed.

Applying Automatic Constraints to a Sketch
 Ribbon:	 Home > Constrain > Constraint Tools Drop-down > Auto Constrain 	  
 Menu:		  Tools > Constraints > Auto Constrain					   

The Auto Constrain tool allows you to apply the possible constraints automatically to the 
entire sketch. This tool is mainly used when you import geometry from another CAD 
system. To apply automatic constraints, choose the Auto Constrain tool from the 

Constraint Tools Drop-down of the Constrain group; the Auto Constrain dialog box will be 
displayed, as shown in Figure 3-27. The options in this dialog box are discussed next.

Curves to Constrain Rollout
This rollout is used to select a line, a circle, or a curve to which

Figure 3-27  The Auto Constrain 
dialog box

constraints will be applied. Select the sketched entities to which 
the constraints are to be applied. As you select the sketched 
entities, the Apply and OK buttons of this dialog box will be 
enabled.

Constraints to Apply Rollout
This rollout consists of various check boxes for major geometric 
constraints in NX. You can select the check boxes of the 
constraints that should be applied to the sketch. After selecting 
all the required check boxes of the constraints, choose the 
Apply button and then exit from the dialog box by choosing 
the Cancel button. After you exit the Auto Constrain dialog 
box, all possible constraints from the selected constraints will 
be applied to the sketch. Also, this rollout contains the options 
to set and clear all the geometric constraint check boxes. These 
options are discussed next.

Set All
If you choose this button, the check boxes for all the 
constraints will be selected. As a result, all the possible 
constraints will be automatically applied to the sketch 
after you exit this dialog box.

Clear All
If you choose this button, the check boxes for all the constraints will be cleared.

Settings Rollout
This rollout provides the options to set the tolerance for applying the constraints. Note that this 
rollout is not expanded by default. Expand this rollout to display options in it. The options in 
this rollout are discussed next. 
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Distance Tolerance
In this edit box, you can specify the maximum distance between the endpoints of two entities 
to be considered for applying the Coincident constraint.

Angle Tolerance
In this edit box, you can specify the angle tolerance value that will define whether the 
Horizontal, Vertical, Parallel, and Perpendicular constraints should be applied to the lines 
in the sketch after you exit the Auto Constrain dialog box. For example, if the deviation of 
lines from the X and Y axes is more than the specified value in this edit box, the Horizontal 
and Vertical constraints will not be applied to them.

Apply Remote Constraints
This check box is selected to apply constraints between the objects that are separated by 
a distance or angle more than the value entered in the Distance Tolerance and Angle 
Tolerance edit boxes.

Controlling Inferred Constraints Settings
 Ribbon:	 Home > Constrain > Constraint Tools Drop-down > Inferred Constraints and 	
		  Dimensions								                                                                                                                                                         
 Menu:		  Tools > Constraints > Inferred Constraints and Dimensions        		              

As mentioned earlier, some of the constraints and

Figure 3-28  The Inferred Constraints 
and Dimensions dialog box

 
dimensions are automatically applied to the 
sketched entities while they are being sketched. 

These settings are controlled by the Inferred Constraints 
and Dimensions tool. When you choose this tool, the 
Inferred Constraints and Dimensions dialog box will be 
displayed, as shown in Figure 3-28.

This dialog box displays all the constraints that are available 
in NX. You can select the check box corresponding to those 
constraints that should be applied automatically to the 
sketch while the sketch is being drawn.

The Create Dimensions for Typed Values check box 
is selected by default, so the dimensions of the entities 
created by entering the values inside the input boxes will 
be displayed in the drawing area.

The Auto Dimensioning Rules area in the Dimensions 
Inferred while Sketching rollout displays rules for 
applying auto dimensions to the sketch. You can modify 
the order of these rules by using the Move Up and Move 
Down buttons.
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Showing All Constraints in a Sketch
 Ribbon:	 Home > Constrain > Constraint Tools Drop-down > Display Constraints		
 Menu:		  Tools > Constraints > Display Constraints					                 

By default, all the constraints that are applied to a sketch are displayed in the sketch. 
You can turn on/off the display of these constraints by using the Display Constraints 
button. This is a toggle button and when you turn it off, it remains off until you turn 
it on. With this button turned on, you can continue working with the other 
sketching tools.

Sketch Relations Browser                                                    
 Ribbon:	 Home > Constrain > Constraint Tools Drop-down > Constraints Browser	  
 Menu:		  Tools > Constraints > Sketch Constraints Browser			   	

You can use the Constraints Browser tool to interrogate sketched objects. To do so, 
choose the Constraints Browser tool from the Constraint Tools Drop-down in the 
Constrain group of the Home tab; the Sketch Constraints Browser dialog box will be 

displayed, refer to Figure 3-29. In this dialog box, you can view the constraints, dimensions, and 
external references associated to a part of the sketch or the entire sketch. Also, it enables you to 
view details of the sketched objects in an active sketch and to resolve their conflicting constraints. 
You can also delete dimensions and constraints using this dialog box.

Using this dialog box you can view:

1. Curves and their associated constraints
2. Constraints and their associated curves
3. Dimensions and their associated curves
4. External references attached to the sketch

Figure 3-29  The Sketch Constraints Browser dialog box

Object to Browse Rollout
The options in this rollout are discussed next:
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Scope
The options available in the Scope drop-down list allow you to select the objects to be 
analyzed. These options are discussed next:

All in Active Sketch: This option is selected by default. It displays all the curves and 
constraints in the sketch in the Browser rollout.

Single Object: When you select this option from the Scope drop-down list, it displays the 
curves associated with the selected constraint, or the constraints associated with the selected 
curve in the Browser rollout. When you select an object from the drawing area, the current 
selection is replaced.

Multiple Objects: When this option is selected, the curves associated with the selected 
constraints, or the constraints associated with the selected curves are displayed in the 
Browser rollout. 

Top-level Node Objects
This area of the dialog box contains two radio buttons, Curves and Constraints which are 
discussed next:

Curves: When you select this radio button, the curves are displayed as the top level nodes. 
Each curve node contains nodes of the constraints attached to it.

Constraints: When you select this radio button, the constraints are displayed as the top level 
nodes. Each constraint node contains nodes of the curves attached to it. 

Browser Rollout
This area of the dialog box contains a table with four columns. They are discussed next:

Object
This column displays the names of the curves and constraints contained in the sketch.

Status
This column displays the constraint status of the curves. For example, overconstrained 
curves are indicated. Hover the cursor over the icons in this column for more information.

Derived From
This column displays the icon of the command/tool used to create relationship.

External Reference
This column displays a message when a sketch curve has a reference to an object in another 
file or in the same file but outside the sketch.

Settings Rollout
This area contains the Display Degree-of-Freedom check box which toggles the degree-of-freedom 
arrows on the sketch curves.
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Converting a Sketch Entity or Dimension into a Reference 
Entity or Reference Dimension
 Ribbon:	 Home > Constrain > Constraint Tools Drop-down > Convert To/From 		
		  Reference							        		
 Menu:		  Tools > Convert To/From Reference			         	                     

The Convert To/From Reference tool is used to convert or retain the reference property 
of a sketched entity or a dimension. Generally, reference elements are created for 
assigning the axis of revolution or for applying dimensions with reference to an entity. 

To convert any of these sketched entities or dimensions into a reference element, choose the 
Convert To/From Reference tool from the Constraint Tools 

Figure 3-30 The Convert To/From 
Reference dialog box

Drop-down of the Constrain group; the Convert To/From 
Reference dialog box will be displayed, as shown in 
Figure 3-30. 

By default, the Reference Curve or Dimension  radio button 
is selected and therefore you are prompted to select 
the entity or dimension. Select one or more objects, or 
dimensions. Next, choose the OK button from the dialog 
box to convert the selected objects or dimensions into 
reference elements or dimensions.

To make the reference elements or dimensions active, select 
the Active Curve or Driving Dimension radio button 
from the dialog box and select the reference elements or 
dimensions. Next, choose the OK button.

Creating Alignment Constraints                                          
In NX, you can control the creation of alignment constraints (horizontal or vertical). In the 
releases prior to NX 12.0, if an entity was placed into the sketch after snapping the existing 
point of the sketched entity horizontally or vertically, the respective constraint would be applied 
between the entities by default. NX 12 onwards, these alignment constraints will not be applied 
by default. However, you can control the application of these alignment constraints before you 
start a file. To do so, choose Menu > File > Utilities > Customer Defaults from the Welcome 
screen of NX; the Customer Defaults dialog box will be displayed, refer to Figure 3-31.

Note
The Customer Defaults dialog box can be invoked only in the Modeling environment of NX.
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Figure 3-31  The Customer Defaults dialog box

In this dialog box, expand the Sketch node from the list box available at the left by clicking on 
it. Choose the Inferred Constraints and Dimensions (Legacy) sub-node; the options related 
it to it will be displayed on the right. Next, select the Create Alignment Constraints check box 
available under the Constraints tab. 

After selecting this check box, the alignment constraints will be applied between entities while 
sketching. Figure 3-32 shows a sketch in which the right circle is placed horizontally after snapping 
the mid point of the left circle; the horizontal alignment constraint is applied between the centers. 
Notice that no alignment constraint is applied as the Create Alignment Constraints (Legacy) 
check box is cleared in the Customer Defaults dialog box, refer to Figure 3-33. 

Figure 3-33  Sketch after selecting the 
Create Alignment Constraints check 
box is cleared

Figure 3-32  Sketch after selecting 
the Create Alignment Constraints 
check box

Note
To reflect the changes made in the Customer Defaults dialog box, you need to restart the NX session.
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TUTORIALS
From this chapter onward, you will use constraints and parametric dimensions to complete the 
model.

Tutorial 1
In this tutorial, you will draw the profile of the model shown in Figure 3-34. The profile is 
shown in Figure 3-35. The profile should be symmetric about the origin. Also, you will use the 
parametric dimensions to complete the sketch.		                     (Expected time: 30 min)                                                                                                 

Figure 3-34  Model for Tutorial 1

Figure 3-35  Sketch for Tutorial 1

	 The following steps are required to complete this tutorial:

a. 	 Start a new file.
b. 	 Draw the outer profile of the sketch using the Profile tool.
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c.	 Add the geometric constraints to the outer loop and modify its dimensional constraints.
d.	 Draw a rectangle inside the outer loop using the Rectangle tool.
e.	 Add dimensions to the rectangle to complete the sketch.
f.	 Save the sketch and close the file.

Starting a New File and Invoking the Sketch Environment
1.	 Start a new file by using the Model template. To do so, choose the New button from the  

File tab of the Ribbon; the New dialog box is displayed. Next, select the Model template 
from the Templates rollout, and then enter c03tut1 as the name of the document in the 
Name text box.

2. 	 Choose the button on the right of the Folder text box; the Choose Directory dialog box is 
displayed. Next, browse to C:\NX\c03 and then choose the OK button twice; the new file is 
started in the Modeling environment. 

3.	 Choose the Sketch tool from the Construction group; the Create Sketch dialog box is 
displayed. Select the XC-ZC plane as the sketching plane and choose the OK button from 
the dialog box. 

Drawing the Outer Loop and Adding Sketch Constraints
	 If the sketch consists of more than one closed loop, it is recommended that you first draw 

the outer loop and then add all the required constraints and dimensions to it. This makes 
it easier to draw and dimension the inner loops. Next, you need to draw the inner loop.

1.	 Choose the Profile tool from the Curve group of the Home tab; you are prompted to select 
the first point of the line or press and drag the left mouse button to begin with the arc 
creation. 

2.	 Draw the sketch around the origin following the sequence shown in Figure 3-36. The 
sketch is unsymmetrical at this stage. But after adding the constraints and modifying the 
dimensions, it will become symmetrical. You can use the help lines to draw the sketch. For 
your reference, the sequence in which the lines are needed to be drawn in the sketch are 
indicated by numbers.

Figure 3-36  The outer loop of the profile and the 
sequence in which lines have to be drawn



3-26						      Siemens NX 2021 for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Note
The dimensions shown in Figure 3-36 get automatically applied when sketch is drawn. However, 
those dimensions are not driving dimensions. They will change when you drag or move a sketched 
entity. In order to make them driving dimensions, you need to modify them. You will learn to modify 
these dimensions later in this tutorial.

	 Next, you need to apply the geometric constraints and modify dimensions. But before you 
do that, it is recommended that you turn on the display of constraints if not already on.

3.	 Choose the Display Constraints tool from the Constraint Tools Drop-down of the 
Constrain group of the Home tab to view the constraints applied to the sketch, if 
it is not chosen by default.

4.	 Choose the Geometric Constraints tool from the Constrain group of the Home tab;  
the Geometric Constraints dialog box is displayed and you are prompted to select 
curves to create constraints.

5. 	 Choose the Equal Length button from the Geometric Constraints dialog box and  
then select lines 1 and 7. The symbol for the equal length constraint is displayed 
on both the sketch members indicating that this constraint is applied between the two 
selected entities. Note that the Automatic Selection Progression check box should be 
selected in the Geometry to Constrain rollout to move to the succeeding points.

6.	 Similarly, apply the equal length constraint between lines 8 and 6, 6 and 2, 2 and 12, 12 
and 8, 3 and 11, 9 and 5, and 10 and 4. Next, exit the dialog box.

	 Now, you need to make this sketch symmetric about horizontal and vertical datum axes.

7.	 Choose the Make Symmetric tool from the Constrain group; the Make Symmetric dialog 
box is displayed and you are prompted to select the first object to apply symmetry.

8.	 Select line 2; you are prompted to select the second

Figure 3-37  The outer profile after adding 
constraints

 
object. Select line 12; you are prompted to select 
the centerline. 

9.	 Select the vertical axis as the centerline; lines 2 
and 12 become symmetric about vertical axis. 

10.	 Similarly, make lines 1 and 7 symmetric about the 
horizontal axis. Next, choose the Close button 
from the Make Symmetric dialog box to close it. 
The sketch after applying  constraints to all these 
entities is shown in Figure 3-37.
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Adding Dimensions to Sketch Members
	 Next, you need to add dimensions to the sketch. As mentioned earlier, when you add 

dimensions to a sketch, the sketch gets modified accordingly.

1.	 Choose the Rapid Dimension tool from the Dimension group of the Home tab; 
you are prompted to select an object to dimension or the dimension to edit.

2.	 Select line 1; the current dimension of line 1 is

Figure 3-38  The outer profile after 
adding required dimensions

attached to the cursor. Now, you need to place the 
dimension at the required location. Click below the 
line 1 to place the dimension, refer to Figure 3-38. 
As you place the dimension, an edit box is displayed. 
Enter 80 in the edit box and press ENTER. Next, 
choose the Fit tool from the Operation group of the 
View tab.

3.	 Select line 2 and place the dimensions on the left of 
the sketch. Enter 10 in the edit box displayed and 
press ENTER.

4.	 Select line 4 and place the dimension on the left of the sketch. Next, modify the dimension 
value to 30 and press ENTER.

5. 	 Select line 9 and place the dimension below the line. Next, modify the dimension value to 
15 and press ENTER.

	 When you place the dimensions, they generally scatter all around the sketch. It is a good 
practice to arrange them properly.

6.	 Exit the Rapid Dimension tool by pressing the ESC key and then drag the dimensions to 
place them properly around the sketch, refer to Figure 3-38.

Tip
Instead of adding dimensions to a sketch, you can also modify the existing dimension. To do 
so, double-click on the dimension; an edit box will be displayed. Enter the required value in the 
edit box and press ENTER; the dimensions will be locked and displayed in blue color.

Drawing the Inner Loop and Adding Dimensions
	 Next, you need to draw the rectangular profile inside the outer loop.

1.	 Choose the Rectangle tool from the Curve group of the Home tab; the Rectangle 
dialog box is displayed.

2.	 Choose the From Center button from the Rectangle dialog box; you are prompted to specify 
the center of the rectangle.
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3.	 Select origin as the center of the rectangle; you are prompted to specify the second point 
of the rectangle.

4.	 Move the cursor horizontally toward right and click to specify the second point; you are 
prompted to select the third point to create the rectangle.

5.	 Move the cursor vertically upward and click to specify the third point; the rectangle is created, 
refer to Figure 3-39. Press ESC to exit the tool.

6.	 Double-click on the horizontal dimension of the rectangle; a dynamic edit box is displayed. 
Modify the value of the dimension to 30 and press ENTER. Next, drag and place the 
dimension above the sketch.  

7.	 Similarly, double-click on the vertical dimension of the rectangle and modify the value of 
the dimension to 20. Next, press ESC. Next, place the dimension on the left of the sketch, 
refer to Figure 3-40.

Figure 3-39  The sketch after drawing the inner 
loop and turning on the display of constraints

Figure 3-40  The sketch after adding 
required dimensions and constraints

Saving and Closing the File
1.	 Exit the sketching environment by choosing the Finish tool from the Sketch group of the 

Home tab. Next, choose the Save button from the Quick Access toolbar to save the sketch. 
Note that the name and location of the document had already been specified when you 
started new file.

2.	 Choose Menu > File > Close > All Parts from the Top Border Bar to close the file.

Tutorial 2
In this tutorial, you will create the profile for the model shown in Figure 3-41. The profile is 
shown in Figure 3-42. You will use the geometric and dimensional constraints to complete this 
sketch.  						                             (Expected time: 30 min)
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Figure 3-41  Model for Tutorial 2

Figure 3-42  Sketch for Tutorial 2

	 The following steps are required to complete this tutorial:

a.	 Start a new file in NX and invoke the sketching environment.
b.	 Draw the sketch using the Profile tool.
c.	 Add the geometric and dimensional constraints to the sketch.
d.	 Save the sketch and close the file.

Starting a New File in NX and Invoking the Sketch Environment
1. 	 Start a new file with the name c03tut2.prt using the Model template and specify its location 

as C:\NX\c03.

2.	 Turn on the display of  WCS by choosing the Display WCS tool from Tools > Utilities > 
More Gallery > WCS Gallery in the Ribbon if not already displayed.

3.	 Invoke the Sketch environment by using the XC-YC plane as the sketching plane. 
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Drawing the Sketch
1.	 Choose the Profile tool from the Curve group. Draw the outer profile of the sketch, refer to 

Figure 3-43. You can draw the first line with exact dimension and then draw the remaining 
sketched entities with dimension values close to the required dimension values. Note that 
the start point of line1 is at the origin.

	 Note that after drawing the first line, you may need to modify the drawing display area by 
using the Fit tool from the Operation group of the View tab.

2.	 Next, choose the Circle tool from the Curve group. Move the cursor over the arc that is 
numbered 3 in Figure 3-43; the center point of the arc is highlighted.

Note
If the center of the arc is not highlighted, choose the Arc Center button from the Selection Group 
of the Top Border Bar.

3.	 Once the center point gets highlighted, move the cursor over

Figure 3-43  The sequence to be 
followed for drawing the sketch

 
it and press the left mouse button to specify the center point 
of the circle. Now, move the cursor away from the center 
point and specify the diameter of the circle by clicking the 
left mouse button or by entering the diameter value in the 
diameter input box. The circle is created, refer to Figure 3-43.

Adding Constraints to the Sketch
1.	 Choose the Geometric Constraints tool from the Constrain 

group; the Geometric Constraints dialog box is displayed.

2.	 Choose the Horizontal button from the Geometric 
Constraints dialog box and select line 1 to apply the Horizontal constraint if this constraint 
has not already been applied. Similarly, apply the Horizontal constraint to lines 5, 7, and 
9.

3.	 Similarly, apply the Vertical constraint to lines 6 and 10 if this constraint has not 
already been applied.

4.	 Choose the Concentric button from the Geometric Constraints dialog box. Next, 
select the circle and arc 3 from the drawing area to apply the Concentric constraint.

5.	 Choose the Equal Length button from the Geometric Constraints dialog box and  
select lines 1 and 5 to apply the Equal Length constraint.

6.	 Similarly, apply the Equal Length constraint between lines 2 and 4, 6 and 10, and 7 and 9. 

7.	 Choose the Tangent button from the Geometric Constraints dialog box and select Line 4 
and arc 3, and Line 2 and arc 3 to apply the Tangent constraint between them if not already 
applied. 

	 The sketch after applying all the constraints is shown in Figure 3-44. 
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Modifying Dimensions of the Sketch          

Figure 3-44  The sketch displayed after 
adding the required constraints

	 Next, you need to modify the dimensions of the sketch.   

1.	 Double-click on the dimension of line 7; a dynamic edit 
box is displayed. Modify the value of the dimension 
to 20 and press ENTER. Next, drag and place the 
dimension below the line, refer to Figure 3-45.  

2.	 Double-click on the dimension of the arc 8; a 
dynamic edit box is displayed. Modify the value of 
the dimension to 10 and press ENTER. 

3.	 Double-click on the dimension of the arc 3; a 
dynamic edit box is displayed. Modify the value of 
the dimension to 10 and press ENTER. 

	 Next, you need to add some dimensions which are not added automatically.

4.	 Choose the Rapid Dimension tool from the Dimension group.        

5.	 Select line 6 and the center point of the circle. Place the dimension above the sketch and 
modify the dimension value to 80. Press the ENTER key.

6.	 Select line 6 and place the dimension on the left of the sketch. Next, modify the dimension 
value to 20 and press ENTER.

7.	 Select the circle and place the dimension,

Figure 3-45  The final sketch after adding 
the required dimensions

refer to Figure 3-45. Next, modify the 
dimension value to 12 and press ENTER. 
Make sure that the dimension value assigned 
to Line 1 is 40.  

8.	 Choose the Fit tool from the View tab.

	 The final sketch after adding the required 
dimensions is shown in Figure 3-45.

Saving and Closing the File
1.	 Choose the Save button from the Quick 

Access toolbar to save the sketch. Note that the name and the location of the document 
has already been specified when you started the new file.

2.	 Exit the sketching environment and then choose Menu > File > Close > All Parts from 
the Top Border Bar to close the file.
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Tutorial 3
In this tutorial, you will create the profile of the revolved model shown in Figure 3-46. The profile 
is shown in Figure 3-47. You will use the geometric and dimensional constraints to complete this 
sketch.				    		                                  (Expected time: 30 min)

Figure 3-46  Model for Tutorial 3

	

Figure 3-47  Sketch for Tutorial 3

	 The following steps are required to complete this tutorial:

a.	 Start a new file in NX and invoke the sketching environment.
b.	 Draw the required profile of the sketch using the Profile tool.
c.	 Add the geometric and dimensional constraints to the sketch.
d.	 Save the sketch and close the file.
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Starting a New File in NX and Invoking the Sketch Environment
1. 	 Start a new file with the name c03tut3.prt using the Model template and specify its location 

as C:\NX\c03.

	 If required turn on the display of WCS by choosing the Display WCS tool from the Tools > 
Utilities > More Gallery > WCS Gallery in the Ribbon.

2.	 Invoke the Sketch environment using the XC-ZC plane as the sketching plane. 

Drawing the Sketch
	 It is recommended that you create the first sketch member of exact measurement by entering 

the value in the edit box displayed. After creating the first sketch member, you can create 
rest of the sketch members by taking the first entity as the reference. After creating the entire 
sketch, you can modify the values by using the dimensioning tools. 

1.	 Choose the Profile tool from the Curve group; you are prompted to specify the first point of 
the line. Specify the start point of the line at the origin. Next, move the cursor horizontally 
toward the right and enter 60 in the Length edit box and 0 in the Angle edit box. Next, 
press ENTER. 	

2.	 Follow the sequence given in Figure 3-48 for drawing the sketch. Draw the rest of the entities 
of the sketch. For better understanding, the sketch has been numbered and temporary 
dimensions have been hidden.

Adding Geometric Constraints to the Sketch
	 After completing the sketch, you need to apply constraints to it.

1.	 Choose the Geometric Constraints tool from the Constrain group of the Home tab; the 
Geometric Constraints dialog box is displayed. Choose the Vertical button from this dialog 
box and select line 8 to apply the vertical dimension if not applied automatically while the 
sketch is drawn.

2.	 Similarly, apply the horizontal constraint to lines 1, 3, and 7 if this constraint is not applied 
automatically.

3.	 Apply the vertical constraint to line 6 if not applied automatically.                 

4.	 After applying the constraints, choose the Display Constraints tool from the 
Constraints Tools Drop-down of the Constrain group, if not already chosen. The resulting 
sketch is shown in Figure 3-49.
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Figure 3-48 The sequence for 
drawing the profile

Figure 3-49  The resulting sketch displayed 
after adding the constraints

Modifying Dimensions of the Sketch
	 Next, you need to modify the dimensions of the sketch. 

1.	 Double-click on the dimension of line 6; a dynamic edit box is displayed. Modify the value 
of the dimension to 40 and press ENTER. Next, drag and place the dimension on the right 
of the sketch, refer to Figure 3-50. 

	 Next, you need to add some dimensions which are not added automatically.

2.	 Choose the Rapid Dimension tool from the Dimension group; the Rapid 
Dimension dialog box is displayed.

3.	 Select line 8 and then place the dimension on the left of the

Figure 3-50  The completed sketch 
displayed after adding required 
constraints and dimensions

sketch; an edit box with default value is displayed. Enter 
150 in this edit box and press the ENTER key; the 
dimension value is modified, refer to Figure 3-50.

4.	 Select line 5 and then place the dimension on the right of 
the sketch. Next, modify the dimension value to 30 and 
press the ENTER key, refer to Figure 3-50.

5.	 Select line 7 and place the dimension above the sketch. 
Next, modify the dimension value to 35 and press ENTER, 
refer to Figure 3-50.

6.	 Select line 2 and then line 1; an angular dimension gets 
attached to the cursor. Move the cursor outside the sketch 
towards right and click the left mouse button to place the 
dimension. Next, modify the dimension value to 117 and 
press ENTER, refer to Figure 3-50.

7.	 Select lines 3 and 4; an angular dimension is attached to the cursor. Move the cursor inside 
the sketch and place the dimension. Next, modify the dimension value to 77 and press 
ENTER, refer to Figure 3-50. 
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8.	 Select the lower endpoint of line 4 and then select line 8; the dimension value is attached 
to the cursor. Place the dimension value below the sketch and then modify this value to 40. 
Next, press ENTER.

9.	 Select line 2 and place the dimension on the right of the line. Next, modify the dimension 
value to 12 and press ENTER, refer to Figure 3-50. Press the ESC key.

10.	 Choose the Fit tool from the Operation group of the View tab. The resulting sketch after 
adding all the dimensions is shown in Figure 3-50.

Note
In Figure 3-50, the display of constraints is turned off to get a better display of dimensions. You 
can turn off the display of constraints by choosing the Display Constraints tool. 

Saving and Closing the File
1.	 Choose the Save button from the Quick Access toolbar to save the sketch. Note that the 

name and location of the document has already been specified when you started the new 
file.

2.	 Exit the sketching environment by choosing the Finish tool from the Sketch group of the 
Home tab and choose Menu > File > Close > All Parts from the Top Border Bar to close 
the file.

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 The __________ constraint is used to force two curves to share same center point. 

2.	 The __________ tool is used to dimension the radius of an arc. 

3.	 The __________ tool is used to animate a fully constrained sketch. 

4.	 The __________ tool is used to show all the constraints applied to a sketch.

5.	 In NX, you can add all types of geometric constraints by choosing the Geometric Constraints 
tool from the Constrain group of the Home tab. (T/F)

6.	 The Auto Constrain tool allows you to apply all possible geometric constraints automatically 
to an entire sketch. (T/F)

7.	 The Rapid Dimension tool in the Dimension group is used to add all possible dimension 
types. (T/F)

8.	 In NX, the Radial Dimension tool is used to add the diameter dimension to the sketch 
members. (T/F)
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 Review Questions 
Answer the following questions:

1.	 Which of the following tools is used to apply geometric constraints to a sketch?

		  (a)  Geometric Constraints		  (b) Automatic Constraints
		  (c)  Rapid Dimensions			   (d) None of these

2.	 Which of the following tools is used to add a radial dimension to a sketch?

		  (a)  Radial				    (b) Automatic Constraints
		  (c)  Rapid Dimension			   (d) None of these

3.	 Which of the following tools is used to make the endpoints of selected objects coincident?

		  (a)  Coincident  			   (b) Concentric
		  (c)  Horizontal		                            (d) None of these

4.	 Which of the following tools is used to apply the constant length constraint between sketch 
members?

		  (a)  Equal Length		              (b) Automatic Constraints
		  (c)  Vertical		                           (d) None of these

5.	 Which of the following tools is used to apply an angular dimension to a sketch member?

		  (a)  Angular				    (b) Constant Length
		  (c)  Rapid Dimensions			   (d) None of these

6.	 Which of the following tools is used to convert a sketch member into a reference element?

		  (a)  Convert To/From Reference          	 (b) Automatic Constraints
		  (c)  Geometric Constraints    		  (d) None of these

7.    In  NX, the degree of freedom arrows are displayed on the points that are free to move. (T/F)

8.	 The Construction group contains all the tools required to draw a sketch. (T/F)

9.	 The Sketch tool in the Home tab is chosen to switch to the sketching environment. (T/F)

10.	 The Finish tool in the Home tab is used to exit the Sketch environment. (T/F)
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EXERCISES
Exercise  1

Draw the base sketch of the model shown in Figure 3-51. The sketch to be drawn is shown in 
Figure 3-52. Use the geometric and dimensional constraints to complete this sketch.
                                                                                                                (Expected time: 15 min)

Figure 3-51  Model for Exercise 1

Figure 3-52  Sketch for Exercise 1
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Exercise  2
Draw the base sketch of the model shown in Figure 3-53. The sketch to be drawn is shown in 
Figure 3-54. Use the geometric and dimensional constraints to complete this sketch. 		
						       		        (Expected time: 15 min)

Figure 3-53  Model for Exercise 2

Figure 3-54  Sketch for Exercise 2

Answers to Self-Evaluation Test
1. Concentric, 2. Radial, 3. Animate Dimension, 4. Display Sketch Constraints, 5. T, 6. T,       
7. T, 8. T


