
NURBS Modeling
 Learning Objectives
After completing this chapter, you will be able to:
• Create NURBS curves
• Create NURBS surfaces
• Convert splines into NURBS curves
• Convert splines and extended splines into NURBS surfaces
• Convert primitives into NURBS surfaces
• Create NURBS models
• Understand NURBS sub-objects
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INTRODUCTION
The NURBS (Non-Uniform Rational Basis Splines) curves and surfaces are used to create complex 
3D models. The NURBS objects use the mathematical calculations to create accurate complex 
3D objects from 2D splines. In this chapter, you will learn to create smooth editable 3D models 
by using the NURBS curves and surfaces. 

NURBS CURVES
The NURBS curves are similar to the splines and are used to create complex surfaces for creating 
3D models. You can use the NURBS curves to create the 3D surfaces using the Lathe and Extrude 
modifiers. Also, you can loft the NURBS curves to create the loft objects. In 3ds Max, there are 
two types of NURBS curves, point curve and CV curve. These curves are discussed next.

Point Curve
  Menu bar:	 	 Create > NURBS > Point Curve		   
  Command Panel:	 Create > Shapes > NURBS Curves > 	  
			   Object Type rollout > Point Curve		

The point curves are the NURBS curves. These curves consist of points that are constrained 
to lie on them, refer to Figure 15-1. To create a point curve, choose Create > Shapes in the 
Command Panel; a drop-down list will be displayed below the Shapes button. Select the NURBS 
Curves option from the drop-down list; the tools to create the point curve and the CV curve will 
be displayed in the Object Type rollout, as shown in Figure 15-2. Activate the viewport in which 
you want to create the point curve. Now, choose the Point Curve tool from the Object Type 
rollout; the Name and Color, Rendering, Keyboard Entry, and Create Point Curve rollouts will 
be displayed. Next, click in the viewport to create the first point and then click again to create 
the second point; the first segment is created. Then, continue clicking in the viewport to add 
more points to the curve. Now, right-click to end the creation; a point curve will be created in 
the viewport, refer to Figure 15-1. The Create Point Curve rollout is discussed next.

Figure 15-1  A point curve Figure 15-2  The tools for creating  
NURBS curves

Tip
While creating a point curve, if you want to remove the last point that you have created, 
press the BACKSPACE key. 
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Note
The options in the Rendering and Keyboard Entry rollouts are the same as discussed in Chapter 5.
   

Create Point Curve Rollout
The options in the Interpolation area of this rollout are the same as those 

Figure 15-3  The Create 
Point Curve rollout

discussed in Chapter 5. The Draw In All Viewports check box is 
selected by default in this rollout, as shown in Figure 15-3. It is used to 
display a 3D curve in all the viewports simultaneously. For example, 
you can start by creating the first point in the Top viewport, continue 
creating the additional points in the Left viewport, and finish the 
creation of the point curve in the Front viewport.     

CV Curve
  Menu bar:	 	 Create > NURBS > CV Curve						       
  Command Panel:	 Create > Shapes > NURBS Curves > Object Type rollout > CV Curve	

The CV curves are the NURBS curves that are

Figure 15-4  A CV curve

 
controlled by the control vertices (CVs). The 
CVs are the points that lie outside the curve 
and control the shape of the CV curve. The CVs 
of a NURBS curve are connected with a lattice 
known as control lattice, which encloses the 
curve, refer to Figure 15-4. When you move the 
CVs in a CV curve, the control lattice gets 
changed, therefore, the shape of the CV curve 
also gets changed. 

To create a CV curve, choose Create > Shapes 
in the Command Panel; a drop-down list will be 
displayed. Select the NURBS Curves option from this drop-down list and activate the viewport 
in which you want to create the CV curve. Now, choose the CV Curve tool from the Object Type 
rollout; the Name and Color, Rendering, Keyboard Entry, and Create CV Curve rollouts will 
be displayed. Next, click and drag the cursor in the viewport to create the first point and the first 
segment and then continue clicking in the viewport to add more points in the curve; a CV curve 
will be created, as shown in Figure 15-4. Next, right-click in the viewport to end the creation.  

Note
The rollouts that are displayed on invoking the CV Curve tool are the same as those discussed in 
the point curve.  

NURBS SURFACES
The NURBS surfaces are the base of the NURBS model. The NURBS models can be created by 
modifying the NURBS surfaces at an advanced level. In 3ds Max, there are two types of NURBS 
surfaces, point surface and CV surface. These surfaces are discussed next.
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Point Surface  
  Menu bar:	 	 Create > NURBS > Point Surface		   
  Command Panel:	 Create > Geometry > NURBS Surfaces >	  
			   Object Type rollout > Point Surf			 

The point surfaces are the NURBS surfaces in which the points are constrained to lie on the 
surface, refer to Figure 15-5. To create a point surface, choose Create > Geometry in the 
Command Panel; a drop-down list will be displayed below the Geometry button. Select the 
NURBS Surfaces option from this drop-down list; the tools to create the NURBS surfaces will 
be displayed in the Object Type rollout, as shown in Figure 15-6. Activate the viewport in which 
you want to create the point surface. Now, choose the Point Surf tool from the Object Type 
rollout; the Name and Color, Keyboard Entry, and Create Parameters rollouts will be displayed. 
Next, press and hold the left mouse button on the upper left corner of the viewport and drag the 
cursor toward the lower right corner of the viewport to specify the length and width of the point 
surface. Release the left mouse button; a point surface will be created in the viewport, refer to 
Figure 15-5. The rollouts that are displayed on choosing the Point Surf tool are discussed next.

Figure 15-5  A point surface Figure 15-6  The tools displayed 
to create NURBS surfaces

Keyboard Entry Rollout
This rollout is used to create the point surface by entering the parameters using the keyboard. 
Set the values in the Length and Width spinners to specify the length and width of the point 
surface. Now, set the values in the Length Points and Width Points spinners to specify the 
number of points along the length and width of the point surface. Next, choose the Create 
button; a point surface will be created in the viewports.  

Create Parameters Rollout
The parameters in this rollout are used to modify the dimensions of the point surface, refer to 
Figure 15-7. Set the values in the Length and Width spinners to specify the length and width 
of the point surface. Set the values in the Length Points and Width Points spinners to specify 
the points along the length and width of the point surface. You can modify the geometry of the 
point surface by moving the points on it, as shown in Figure 15-8. To do so, select the point 
surface in the viewport and choose the Modify tab in the Command Panel. In the modifier 
stack, click on the plus sign on the left side of the NURBS Surface; the Surface and Point 
sub-object levels will be displayed. Select the Point sub-object level and then select the points 
in the viewport to modify them. 
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Figure 15-7  The Create 
Parameters rollout

Figure 15-8  The points in the point 
surface moved

CV Surface  
  Menu bar:	 	 Create > NURBS > CV Surface			    
  Command Panel:	 Create > Geometry > NURBS Surfaces >	  
			   Object Type rollout > CV Surf			 

The CV surfaces are the NURBS surfaces that are controlled by control vertices (CVs). The CVs 
are the points that lie outside the surface and control the shape of the CV surface. The CVs of 
a NURBS surface are connected with a lattice known as control lattice that encloses the surface, 
refer to Figure 15-9. To create a CV surface, choose Create > Geometry in the Command Panel; 
a drop-down list will be displayed. Select the NURBS Surfaces option from the drop-down list; 
the tools to create NURBS surfaces will be displayed in the Object Type rollout. Activate the 
viewport in which you want to create the CV surface. Now, choose the CV Surf tool from the 
Object Type rollout; the Name and Color, Keyboard Entry, and Create Parameters rollouts will 
be displayed. Next, click on the upper left corner of the viewport and move the cursor toward 
the lower right corner of the viewport to specify the length and width of the CV surface. Click 
again on the screen; a CV surface will be created in the viewport, as shown in Figure 15-9. The 
rollouts that are displayed on invoking the CV Surf tool are discussed next.

Figure 15-9  A CV surface

Keyboard Entry Rollout
You can also create a CV surface by entering the values in the spinners in this rollout. Set the 
values in the Length and Width spinners to specify the length and width of the CV surface. 
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Now, set the values in the Length CVs and Width CVs spinners to specify the control vertices 
along the length and width of the CV surface. Next, choose the Create button; a CV surface will 
be created in the viewports.  

Create Parameters Rollout
The parameters in this rollout are used to modify the dimensions 

Figure 15-10  The Create 
Parameters rollout

of the CV surface, refer to Figure 15-10. Set the values in the Length 
and Width spinners to specify the length and width of the CV surface. 
Set the values in the Length CVs and Width CVs spinners to 
specify the control vertices along the length and width, respectively 
of the CV surface. The Automatic Reparam. area has three radio 
buttons, namely None, Chord length, and Uniform. These radio 
buttons are used to edit parameters.

Note
If you deselect the NURBS surface objects in the viewport, then 
the Create Parameters rollout will not be displayed again. So, 
it is recommended to make all the changes before deselecting it.  

CONVERTING SPLINES AND EXTENDED SPLINES INTO 
NURBS SURFACES 
To create a NURBS model, you can also use the splines or the extended splines shapes instead of 
using the point curve or the CV curve. To do so, you need to convert them into NURBS surfaces.

First, choose Create > Shapes in the Command Panel; a drop-down list will be displayed with 
the Splines option selected by default. Next, choose one of the tools in the Object Type rollout 
and create a spline shape in the viewport. Now, you can convert the spline shape into NURBS 
surfaces using one of the following methods:

1.	 Select the spline shape in the viewport and right-click on it; a quad menu will be displayed. 
Choose the Convert To: option; a cascading menu will be displayed. Now, choose Convert 
to NURBS; the spline shape will be converted into NURBS surface.

2.	 Select the spline shape in the viewport and choose the Modify tab in the Command Panel; 
the modifier stack will be displayed. In the modifier stack, right-click on the name of the 
tool by which you have created the spline shape; a shortcut menu will be displayed. Now, 
choose the NURBS option; the spline shape will be converted into a NURBS surface. 

    

CONVERTING PRIMITIVES INTO NURBS SURFACES
To create a NURBS model, you can use the standard primitives. To do so, you need to convert 
them into NURBS surfaces. First, create an object that you want to convert into NURBS surface. 
Next, select it in the viewport and follow one of the methods that has been discussed for converting 
a spline into NURBS surfaces. 
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MODIFYING NURBS OBJECTS
You can modify a NURBS object using the options available in the Modify panel. To do so, select 
the NURBS object in the viewport and then choose the Modify tab in the Command Panel; 
various rollouts will be displayed in the Modify panel. The options in these rollouts are used to 
modify the NURBS objects. These rollouts are discussed next.

Note
1. Most of the rollouts are same for the NURBS curves and surfaces.

2. The options in the Rendering rollout are same as discussed earlier. 

General Rollout
This rollout will be available for all NURBS objects. The buttons on the top in the General rollout 
are used to add more objects to the selected NURBS object. The Display area is used to define 
the way in which the NURBS object will be displayed in the viewports, refer to Figure 15-11. 

The Attach button is used to add other objects to the selected NURBS 

Figure 15-11  The 
General rollout 

object in the viewport. Once the objects in the viewport are added to 
the selected NURBS object, they will be converted into NURBS objects, 
and will become the sub-object of the NURBS object. 

Also, the original parameters of the additional objects will be lost. 
Choose the Attach Multiple button to add more than one object to the 
selected NURBS object at the same time. The Reorient check box is 
used to orient the attached object to the NURBS object.  

The Import and Import Multiple buttons are also used to perform the 
same function as the Attach and Attach Multiple buttons. The only 
difference is that while using the Import and Import Multiple buttons, 
the original parameters of the objects are not lost.

Display Area
The check boxes in the Display area are used to define the way in which 
the NURBS object will be displayed in the viewports. In the NURBS curves objects, the Lattices, 
Curves, and Dependents check boxes are displayed in the Display area. But in the NURBS 
surfaces objects, three additional check boxes are displayed. These are Surfaces, Surface Trims, 
and Transform Degrade. You need to select the required check box to make the corresponding 
option available in the viewport.

Surface Display Area
This area is available only for the NURBS surface objects. By default, the Tessellated Mesh 
radio button is selected in this area. As a result, the selected NURBS object will be displayed as 
iso lines, mesh, or as both isolines and mesh in the viewport depending on the settings made in 
the Display Line Parameters rollout, refer to Figures 15-12 and 15-13. 
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Select the Shaded Lattice radio button to display the NURBS surface object as shaded lattices 
in the shaded viewports, as shown in Figure 15-14.    

Figure 15-13  The NURBS surface 
object displayed as iso lines  

Figure 15-12  The NURBS surface 
object displayed as a mesh object 

NURBS Creation Toolbox
This button is displayed on the right side of the Display area. When you choose this 
button, the NURBS toolbox will be displayed, as shown in Figure 15-15.  In this toolbox, 
buttons available in the Create Points, Create Curves, and Create Surfaces rollouts are 
available as icons. These buttons are discussed later in this chapter.

Figure 15-14  The NURBS surface 
object displayed as shaded lattices

Figure 15-15  The NURBS toolbox

Display Line Parameters Rollout 
This rollout is available only for the NURBS surface objects, refer to 

Figure 15-16  The Display 
Line Parameters rollout

Figure 15-16. The values in the U Lines and V Lines spinners define 
the number of iso lines that are used to create the wireframe of the 
NURBS surface object in the viewport. Select the Iso Only radio 
button to display only the iso lines of the NURBS surface object in 
all viewports. The Iso And Mesh radio button is selected by default. 
It is used to display the iso lines of the NURBS object in those 
viewports that are set to display the wireframes. Also, the shaded 
viewports display the shaded surface of the NURBS object. Select 
the Mesh Only radio button to display the NURBS object as a wire mesh in those viewports that 
are set to display the wireframes. Also, the shaded viewports display the shaded surface of the 
NURBS object.  
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Note
In the NURBS modeling, an iso line, similar to a contour line is known as a line of constant 
parameter value.

Tip
To set the viewport to display the wireframes, click on the Shaded viewport label; a quad 
menu will be displayed. Now, choose the Wireframe option in it. Alternatively, you can 
press the F3 key.

Before working with the other rollouts, you need to learn about the NURBS sub-objects. The 
buttons in the Create Points, Create Curves, and Create Surfaces rollouts are used to add the 
sub-objects to the NURBS curve and surface objects. These sub-objects can be dependent or 
independent. In other words, they can be child or parent sub-objects. For example, in the loft 
object shown in Figure 15-17, the surfaces are the dependent sub-objects as they are created 
from the curves. If you make any change in the curve, then the surface of the loft object will 
also be affected. But, the curves are the independent sub-objects because they are not created 
from any other object.  
                 

Create Points Rollout
The buttons in this rollout are used to add the point sub-objects to a NURBS object, refer to 
Figure 15-18. You can add the point sub-objects on the curve or surface as well as outside the 
curve or surface. These additional points help you to fit the curves or to trim the curves. To 
create different types of points, select the NURBS object in the viewport, choose the Modify 
tab, and then choose the corresponding button from the Create Points rollout. Alternatively, 
choose the Nurbs Creation Toolbox button from the General rollout; the NURBS toolbox will 
be displayed. The buttons in the Create Points rollout are discussed next.

Figure 15-17  The dependent and independent 
sub-objects in a loft object

Figure 15-18  The Create 
Points rollout

Point
If you want to add an independent point, then select the NURBS object in the viewport. Next, 
choose the Point button in the Create Points rollout. Now, when you move the cursor in the 
viewport, the shape of cursor will change, as shown in Figure 15-19. Now, click in the viewport to 
create a point and continue clicking to add more points. Next, right-click to exit the command. 
These points will be displayed as triangles in the viewport, as shown in Figure 15-20.
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Figure 15-20  The independent points 
created in the viewport

Figure 15-19  The cursor displayed to 
create independent points

Offset Point
An offset point is a dependent sub-object and lies at a specified distance from the parent point. 
To create an offset point, select the NURBS object in the viewport. Next, choose the Offset 
Point button in the Dependent Points area of the Create Points rollout; the Offset Point rollout 
will be displayed at the bottom in the Modify panel, as shown in Figure 15-21. Now, move the 
cursor over the existing point to be used as parent point in the viewport; the shape of cursor will 
change. Click on the existing point; a dependent offset point will be created as green asterisk 
in the viewport, as shown in Figure 15-22. Next, in the Modify panel, expand the Offset Point 
rollout and set the values in the X, Y, and Z spinners to offset the new point from the original 
position. As you set the values in these spinners, the distance between the offset point and its 
parent will be displayed as red line, as shown in Figure 15-23. If you do not want to change the 
position of the offset point, then select the At Point radio button in the Offset Point rollout. 

Figure 15-21  The Offset Point rollout Figure 15-22  The offset point displayed

Figure 15-23  The red line displayed between 
the parent point and the offset point



NURBS Modeling		         15-11

Note
The independent point sub-objects will be displayed as black triangles in the viewports. And, the 
dependent point sub-objects will be displayed as green asterisks in the viewports. 

Curve Point
A curve point is also a dependent sub-object and lies on a NURBS curve. To create a curve point, 
select the NURBS curve object in the viewport. Next, choose the Curve Point button in the 
Dependent Points area of the Create Points rollout; the Curve Point rollout will be displayed 
in the Modify panel, as shown in Figure 15-24. Now, move the cursor over the curve; the curve 
will turn blue. Also, a blue box along with the cursor will be displayed on the curve, as shown 
in Figure 15-25. Now, position the blue box on the curve at the location where you want to add 
a point and then click to add it. Next, you need to modify the parameters in the Curve Point 
rollout, which is discussed next.

Curve Point Rollout
Set the value in the U Position spinner to define the position of the point on the curve. The 
On Curve radio button is selected by default and is used to position the point on the curve.  
Select the Offset radio button to offset the points from the curve. Set the values in the X, 
Y, and Z spinners to define the location of the point in space. 

Figure 15-25  A blue box displayed along 
with the cursor 

Figure 15-24  The Curve Point rollout

Select the Normal radio button to offset the point along the curve’s normal at the U position. 
Set the value in the Distance spinner to specify the distance of the point from the curve’s 
normal. Select the Tangent radio button to offset the point along the tangent at the U 
position. Set the value in the U Tangent spinner to specify the distance of the point from 
the curve along the tangent. 

The options in the Trimming area are used to trim the curve. Select the Trim Curve check 
box to trim the curve according to the position of the curve point, refer to Figures 15-26 
and 15-27. Select the Flip Trim check box to trim the curve in the opposite direction, refer 
to Figure 15-28.   
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Figure 15-26  A curve point placed 
on the curve

Figure 15-27  The curve after selecting 
the Trim Curve check box

Figure 15-28  The curve after selecting 
the Flip Trim check box

Curve-Curve Point
The curve-curve point is a dependent point sub-object created at the intersection of two NURBS 
curve objects, refer to Figure 15-29. Note that to create a curve-curve point, the two NURBS 
curves should be attached to each other and there should be an intersection between the two 
NURBS curves. To create this point, choose the Curve-Curve button in the Dependent Points 
area of the Create Points rollout; the Curve-Curve Intersection rollout will be displayed in the 
Modify panel. 

Now, move the cursor over one of the NURBS curves; a blue box will be displayed along with the 
cursor and click on it. Next, drag the cursor from first curve to the second curve and click on it; 
an intersection point will be created at the nearest intersection between the two curves, refer to 
Figure 15-29. You can modify the curve-curve point by specifying the parameters in this rollout.    

Surf Point
A surface point is also a dependent sub-object and lies on a NURBS surface. To create a surface 
point, select the NURBS surface object in the viewport. Now, choose the Surf Point button in the 
Dependent Points area of the Create Points rollout; the Surface Point rollout will be displayed 
in the Modify panel. Now, move the cursor over the NURBS surface; a pair of intersecting blue 
lines will be displayed along with the cursor, as shown in Figure 15-30. 

Click on the surface where you want to add a point and then modify its parameters in the 
Surface Point rollout in the Modify panel. Next, right-click to exit the command. The options 
in the Surface Point rollout are the same as those discussed earlier in the Curve Point rollout.
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Figure 15-29  The intersection point created Figure 15-30  The blue lines displayed

Surf-Curve Point 
The surface-curve point is a dependent point sub-object 

Figure 15-31  A seed created on the 
NURBS curve

created at the intersection of a NURBS curve and a 
NURBS surface object, refer to Figure 15-31. Note that 
to create a surface-curve point, the NURBS curve and 
the NURBS surface should be attached to each other. To 
create this point, select the NURBS surface and then 
choose the Surf-Curve button in the Dependent Points 
area of the Create Points rollout; the Surface-Curve 
Intersection Point rollout will be displayed in the Modify 
panel. Now, move the cursor over the NURBS curve; a 
blue box will be displayed along with the cursor. Click on 
the curve to place the first seed. Next, move the cursor 
over the NURBS surface object and click on it to place 
the second seed; an intersection point will be created at the nearest intersection between the 
curve and the surface that is nearest to the seed point, refer to Figures 15-31, 15-32, and 15-33. 
You can modify the surface-curve point by specifying the parameters in the Surface-Curve 
Intersection Point rollout.  

Figure 15-32  A surface curve intersection 
point created in the Left viewport

Figure 15-33  A surface curve intersection 
point created in the Top viewport

Note
The buttons (tools) in the Create Points rollout are also available in the NURBS toolbox in the 
General rollout.
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Create Curves Rollout
The buttons in this rollout are used to add the curve sub-objects to a

Figure 15-34  The Create 
Curves rollout

 
NURBS object, refer to Figure 15-34. The curve sub-objects can be 
dependent or independent. The geometry of the dependent curves 
sub-objects depend on the curves, points, and surfaces of the NURBS 
object. The independent curve sub-objects can be added to an existing 
NURBS model. To create the curve sub-objects, select the NURBS 
object in the viewport, choose the Modify tab, and then choose the 
corresponding button from the Create Curves rollout. Some of the 
dependent and independent curves are discussed next. 

CV Curve
The CV curve sub-object is an independent curve sub-object. It is 
very much similar to the CV curve object. The only difference is that 
the CV curve sub-object does not provide the thickness on rendering. 
To create a CV curve sub-object, select the NURBS object in the viewport and then choose the 
Modify tab in the Command Panel. Now, choose the CV Curve button in the Create Curves 
rollout; the CV Curve rollout will be displayed in the Modify panel. Also, the shape of the cursor 
will change, as shown in Figure 15-35. Now, create a CV curve in the viewport and then right-
click to exit the command; the new CV curve will be added to the existing NURBS object, refer 
to Figures 15-36 and 15-37.

 

Figure 15-35  The changed shape of the 
cursor

Figure 15-36  The new CV curve 
created

Figure 15-37  The new CV curve 
attached to the NURBS object
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Point Curve   
The point curve sub-object is also an independent curve sub-object and is very similar to the point 
curve object. The only difference is that the point curve sub-object does not provide the thickness 
on rendering. To create a point curve sub-object, select the NURBS object in the viewport. Now, 
choose the Point Curve button from the Create Curves rollout; the Point Curve rollout will be 
displayed in the Modify panel. Now, create a point curve in the viewport and right-click to exit 
the command; the new point curve will be added to the existing NURBS object. 

Curve Fit
The fit curve is a dependent curve sub-object and is created between the existing points in a 
NURBS object. A fit curve can be created using any type of points such as curve points, surface 
points, independent points, and so on. To create a fit curve, select the NURBS object in the 
viewport and choose the Modify tab in the Command Panel. Next, choose the Curve Fit button 
in the Dependent Points area of the Create Curves rollout; the cursor will get changed. Also, the 
Point Curve rollout will be displayed in the Modify panel. Notice that there are no parameters 
in this rollout. Next, move the cursor over a point in the viewport and click to create the starting 
point of the curve fit. Now, drag the cursor to another point and click on it to continue the 
creation of the curve fit, refer to Figures 15-38 and 15-39. Next, right-click to exit the command. 

Figure 15-38  A NURBS curve object Figure 15-39  A fit curve created between the 
points in a NURBS curve object

Transform
The transform curve is a dependent curve sub-object. It is a duplicate of the original curve and 
can be modified to a different position, rotation, or scale. To create a transform curve, select 
the NURBS curve in the viewport and choose the Modify tab in the Command Panel. Next, 
choose the Transform button in the Dependent Points area of the Create Curves rollout; the 
cursor will get changed. Then, move the cursor over the NURBS curve; it will turn blue. Now, 
press and hold the left mouse button on the curve, drag the cursor to create the duplicate of 
the selected curve, and then release the left mouse button; a transform curve will be created, 
refer to Figures 15-40 and 15-41.

To rotate or scale the duplicate curve, select the Curve sub-object level in the modifier stack, 
and then select the duplicate curve in the viewport. Next, rotate or scale the duplicate curve 
without affecting the original curve. 
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Figure 15-40  A NURBS curve object Figure 15-41   A transform curve created

Chamfer
The chamfer curve is a dependent curve sub-object. It is a straight line between two intersecting 
parent curve sub-objects. To create a chamfer curve, select the NURBS object that has the 
intersecting and attached curve sub-objects, as shown in Figure 15-42. 

Figure 15-42  A NURBS curve to create a chamfer curve

Now, choose the Modify tab in the Command Panel. Then, choose the Chamfer button in the 
Dependent Points area of the Create Curves rollout; the shape of the cursor will change. Also, 
the Chamfer Curve rollout will be displayed in the Modify panel. Move the cursor over a curve 
in the NURBS object; the curve will turn blue. Also, a blue box will be displayed along with 
the cursor. Click on the curve to place the first seed to define the intersection to be chamfered. 
Then, move the cursor over another curve in the NURBS object and click to place another 
seed; a chamfer curve will be created, refer to Figures 15-43 and 15-44. You can modify the 
chamfer curve using the parameters in the Chamfer Curve rollout in the Modify panel and 
then right-click to exit the command.

Figure 15-43  The seeds placed on 
the curves

Figure 15-44  A chamfer curve 
created

Note
While creating a chamfer curve, one or both the curves of the NURBS object get trimmed. To 
avoid the trimming of the curves, you can modify their parameters in the Chamfer Curve rollout.      
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Surf Edge
The surf edge curve is also a dependent curve and it lies on the

Figure 15-45  A surface edge 
curve created

 
boundary of the surface. The edge can be an outside edge or 
a trim edge. To create a surf edge curve, select the NURBS 
surface. Next, choose the Modify tab in the Command Panel. 
Choose the Surf Edge button in the Dependent Points area of 
the Create Curves rollout; the cursor will change. Also, the 
Surface Edge Curve rollout will be displayed in the Modify 
panel. Move the cursor over an edge in the NURBS object; the 
edge will be highlighted. Now, click on the edge; the surface 
edge will be created. Also, a seed will be displayed on the edge, 
as shown in Figure 15-45.

Note
The buttons (tools) in the Create Curves rollout are also available in the NURBS toolbox in the 
General rollout.

 

Create Surfaces Rollout
The buttons in the Create Surfaces rollout are used to add surface

Figure 15-46  The Create 
Surfaces rollout

sub-objects to a NURBS object, as shown in Figure 15-46. The surface 
sub-objects can be dependent or independent. The geometry of the 
dependent surface sub-object depends on the curves and surfaces of 
another NURBS object. To create the surface sub-objects, select the 
NURBS object in the viewport, choose the Modify tab in the 
Command Panel, and then choose the corresponding button from 
the Create Surfaces rollout. Some of the dependent and independent 
surfaces are discussed next.

Note
The CV surface and point surface sub-objects are independent 
sub-objects. They can be added to the existing NURBS object using 
the CV Surf and Point Surf buttons in the Create Surfaces 
rollout.

Blend
A blend surface is a dependent surface sub-object that is used to connect two surfaces, two curves, 
or a curve to a surface. To create a blend surface, select the NURBS object in the viewport that 
contains two or more attached curves or surface sub-objects. Next, choose the Modify tab in 
the Command Panel and then choose the Blend button in the Dependent Points area of the 
Create Surfaces rollout; the Blend Surface rollout will be displayed. Next, move the cursor 
over the edge that you want to connect; the edge will turn blue. Click on the edge and move 
the cursor over the edge of another NURBS object, as shown in Figure 15-47. Now, click on the 
edge of another NURBS object; a blend surface will be created between the two NURBS objects, 
as shown in Figure 15-48. You can modify the blend surface using the parameters in the Blend 
Surface rollout in the Modify panel. Next, right-click to exit the command.
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Figure 15-47  The cursor placed over 
another edge

Figure 15-48  A blend surface created

Ruled 
A ruled surface is a dependent sub-object. It can be created between two curve sub-objects. To 
create a ruled surface, select the NURBS object in the viewport that contains two or more curves. 
Next, choose the Modify tab in the Command Panel and then choose the Ruled button in the 
Dependent Points area of the Create Surfaces rollout; the Ruled Surf rollout will be displayed. 
Next, move the cursor over the curve that you want to use to create the ruled surface; the curve 
will turn blue. Now, click on the curve and move the cursor over another curve, refer to Figure 
15-49. Now, click on another curve; a ruled surface will be created between the two NURBS 
curves, as shown in Figure 15-50. You can modify the ruled surface using the parameters in the 
Ruled Surf rollout in the Modify panel. Then, right-click to exit the command.

Figure 15-49  The cursor displayed to 
create the ruled surface

Figure 15-50  A ruled surface created

U Loft
A U loft surface is a dependent surface sub-object and it is created across multiple curve 
sub-objects. To get the best effect, the curves that are to be used for U lofting should have same 
number of CVs. To create a U loft surface, select one of the NURBS curves in the viewport. Choose 
the Modify tab in the Command Panel and then choose the U Loft button in the Dependent 
Points area of the Create Surfaces rollout; the U Loft Surface rollout will be displayed. Next, 
move the cursor over the first curve that you want to use for creating the U loft surface; it will 
turn blue. Now, click on it and then click on all curves one-by-one to add them into the U loft 
surface. When you click on the curves, their names will be displayed in the U Curves area of 
the U Loft Surface rollout. Also, while adding the curves to the U loft surface, green colored 
iso lines of the U loft surface will be displayed in the viewport, as shown in Figure 15-51. Next, 
right-click to end the command; a U loft surface will be created, as shown in Figure 15-52. Now, 
you can modify the U loft surface using the parameters in the U Loft Surface rollout. Next, 
right-click to exit the U loft command.
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Figure 15-52  A U loft surface createdFigure 15-51  The green iso lines of the U loft 
surface displayed     

1-Rail                 
The 1-rail sweep surface is a dependent sub-object. To create a 1-rail sweep surface, minimum 
two curves are required in the viewport. One curve is used to define the cross-section of the 
surface and another curve is used to define the edge of the surface, which is known as rail. Before 
creating a sweep surface, you need to make sure that the cross-section curve is intersecting the 
rail curve. If two cross section curves are used, the first cross-section curve should intersect the 
starting point of the rail and the last cross-section curve should intersect at the end point of the 
rail. Also, the curves that you are using to create the cross-section of the surface should have 
the same direction. 

Create the rail and cross-section curves, as shown in Figure 15-53. Select the rail curve and choose 
the Modify tab in the Command Panel.Next, choose the 1-Rail button in the Dependent Points 
area of the Create Surfaces rollout; the 1-Rail Sweep Surface rollout will be displayed. Next, 
move the cursor over the rail curve; the rail curve will turn blue. Click on it; the name of the rail 
curve will be displayed in the Rail Curve text box of the 1-Rail Sweep Surface rollout. Select 
the cross-section curve. When you click on the cross-section curve, its name will be displayed 
in the Section Curves area of the 1-Rail Sweep Surface rollout. Next, right-click to end the 
command; a 1-rail surface will be created, as shown in Figure 15-54. You can modify the 1-rail 
surface using the parameters in the 1-Rail Sweep Surface rollout. Now, right-click to exit the 
1-rail command.

Figure 15-53  The curves to create 
1-rail surface

Figure 15-54  The 1-rail surface created

Cap      
The cap surface is a dependent sub-object and is created to cap a closed curve or an edge of a 
closed surface. To create a cap surface, select the NURBS object that has either a closed curve 
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or an open-ended closed surface, as shown in Figure 15-55. Now, choose the Modify tab in 
the Command Panel and then choose the Cap button in the Dependent Points area of the 
Create Surfaces rollout; the Cap Surface rollout will be displayed. Next, move the cursor over 
the closed curve or the closed surface; it will be highlighted. Now, click on it; a cap surface will 
be created, as shown in Figure 15-56. Right-click to exit the cap command.

Figure 15-55  An open ended 
closed surface 

Figure 15-56  A cap created to cap the 
open end of the closed surface 

EDITING NURBS SUB-OBJECTS
After creating a NURBS model or an object, you can edit it at the sub-object level. To do so, 
select the NURBS object in the viewport and choose the Modify tab in the Command Panel; 
the rollouts will be displayed in the Modify panel to modify the NURBS object. You have already 
learned about modifying NURBS objects in the previous section. Now, to modify the NURBS 
object at the sub-object level, select the sub-object levels in the modifier stack. First, click on the 
arrow sign on the left side of NURBS Surface to display all the sub-object levels in the selected 
NURBS object, refer to Figure 15-57. Now, select a sub-object level in the modifier stack; it will 
turn yellow and gets activated. Also, various rollouts related to the selected sub-object level will 
be displayed below the modifier stack. Alternatively, right-click in the viewport; a quad menu 
will be displayed, as shown in Figure 15-58. 

Figure 15-57  The sub-object levels 
displayed in the modifier stack

Figure 15-58  The quad menu displayed
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Now, choose the sub-object level that you want to modify; it will also be activated in the modifier 
stack. Select the sub-object in the viewport and then modify it using the transforms or the 
rollouts displayed in the Modify panel.   

TUTORIALS
Before starting the tutorials, you need to download the c15_3dsmax_2022_tut.zip file 
from www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > 3ds 
Max > Autodesk 3ds Max 2022: A Comprehensive Guide 

Extract the contents of the zipped file and save them in the Documents folder.

Tutorial 1
In this tutorial, you will create a washbasin, as shown in Figure 15-59, using the NURBS tools. 	
						          	                   (Expected time: 60 min)

Figure 15-59  The model of a washbasin

The following steps are required to complete this tutorial:

a.	 Create the project folder.
b.	 Create the profile curve for washbasin.
c.	 Create the washbasin surface.
d.	 Create sieve and duct.
e.	 Create the slab.
f.	 Create washbasin taps.
g.	 Save and render the scene. 
	
Creating the Project Folder 	  	
Create a new project folder with the name c15_tut1 at \Documents\3dsmax2022 and then save the 
file with the name c15tut1, as discussed in Tutorial 1 of Chapter 2.
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Creating the Profile Curve for Washbasin 
In this section, you will create the profile curve for washbasin using the Ellipse tool.

1.	 Activate the Top viewport. Next, choose Create > Shapes in the Command Panel and then 
choose the Ellipse tool from the Object Type rollout. 

2.	 Expand the Keyboard Entry rollout and set the parameters as follows:

	 Length: 111.739		  Width: 202.96  

	 Choose the Create button; an ellipse is created with the name Ellipse001. 

3.	 Choose the Zoom Extents All tool. 

	 Next, you need to convert Ellipse001 to NURBS surface.

4.	 Select Ellipse001 in any viewport and right-click on it; a quad menu is displayed. Choose 
the Convert To option in the quad menu; a cascading menu is displayed. Now, choose the 
Convert to NURBS option; Ellipse001 is converted into NURBS surface. Next, you need to 
create multiple copies of Ellipse001 to create the outer surface of the washbasin.

Tip
You can also create an elliptical curve using the CV Curve tool from Create > Shapes > 
NURBS Curves > Object Type rollout in the Command Panel. In this case, you need not 
convert curve to NURBS curve.  

5.	 Choose the Select and Move tool. Next, select Ellipse001 in the Front viewport and move 
the cursor over its Y axis. Press and hold the SHIFT key and the left mouse button and then 
move Ellipse001 in the upward direction until the value of the Y spinner in the coordinates 
display becomes about 16. Now, release the left mouse button and the SHIFT key; the 
Clone Options dialog box is displayed. Set the value 3 in the Number of Copies spinner 
and choose the OK button; Ellipse001, Ellipse002, Ellipse003, and Ellipse004 are displayed 
in viewports, as shown in Figure 15-60.

	 Next, you need to create the ellipses for the inner surface of the washbasin. 

6.	 Make sure Ellipse004 (top ellipse) is selected in the Front viewport. Now, move the cursor 
over the vertical axis of Ellipse004. Press and hold the SHIFT key and the left mouse button 
and then move Ellipse004 in the downward direction until the value in the Y spinner in the 
coordinates display becomes about -8. Now, release the left mouse button and the SHIFT 
key; the Clone Options dialog box is displayed. Make sure the value 1 is displayed in the 
Number of Copies spinner and choose the OK button; Ellipse005 is displayed in viewports.

	
7.	 Modify the color of Ellipse005 in such a way that you can differentiate between the curves 

for the inner and the outer surfaces.

8.	 Make sure Ellipse005 is selected in the Front viewport and move the cursor over its vertical 
axis. Press and hold the SHIFT key and the left mouse button, and move Ellipse005 in the 
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downward direction until the value in the Y spinner in the coordinates display becomes about 
-16. Now, release the left mouse button and the SHIFT key; the Clone Options dialog box 
is displayed. Set the value 3 in the Number of Copies spinner and choose the OK button; 
Ellipse006, Ellipse007, and Ellipse008 are created in all viewports. Now, there are total eight 
NURBS curves in the viewports.

Figure 15-60  All ellipses displayed in viewports

	 Next, you need to scale ellipses in the Front viewport.

9.	 Choose the Select and Uniform Scale tool from the Main Toolbar and scale the NURBS 
curves uniformly in the Front viewport, as shown in Figure 15-61.

Figure 15-61  All NURBS curves scaled in the Front viewport

Creating the Washbasin Surface
In this section, you will create a surface between the NURBS curves to give it the desired shape 
by using the U Loft button.
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1.	 Select Ellipse008 in the Front viewport and choose the Modify tab, if it is not already chosen. 
The NURBS Surface is displayed in the modifier stack and all rollouts required to modify 
the NURBS object are displayed below the modifier stack.

2.	 Expand the Create Surfaces rollout and choose the U Loft button; the U Loft Surface 
rollout is displayed in the Modify panel. Next, move the cursor over Ellipse008; it turns blue. 
Now, click on Ellipse008 and then click one-by-one on Ellipse007, 006, 005, 004, 003, 002, 
and 001 to add them into the U loft surface. Note that you may need to switch to different 
viewports to select all ellipses. Right-click to exit the command. 

3.	 In the U Loft Surface rollout, select the Flip Normals check box. Next, right-click to exit 
the U loft command; a NURBS surface is created in the viewports. Choose the Zoom Extents 
All tool. Figure 15-62 shows NURBS surface in the viewports.

Figure 15-62  A NURBS surface created in viewports

4.	 Modify the name of the surface to washbasin.

	 Next, you need to modify the shape of washbasin.

5.	 Select washbasin in Front viewport and click on the arrow sign  on the left side of the NURBS 
Surface in the modifier stack; all the sub-object levels are displayed.

6.	 Select the Curve sub-object level and modify the shapes using the Select and Move and Select 
and Uniform Scale tools till you get a perfect shape of washbasin, refer to Figure 15-63. Note 
that you need to scale Ellipse008 to a circular shape to fit the sieve in it. 
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Figure 15-63  The washbasin modified at the Curve sub-object level

7.	 Again, select the Curve sub-object level in the modifier stack to exit the Curve sub-object 
level.

Creating Sieve and Duct
In this section, you will create a washbasin sieve and duct by using the Cylinder tool.

1.	 Choose the Cylinder tool from Create > Geometry > Standard Primitives in the Command 
Panel. Now, create a cylinder in the Top viewport at the center of washbasin. 

2.	 Change the name of the cylinder to sieve. Next, in the Parameters rollout, modify 
the radius of sieve to the same value as that of Ellipse008 by using the Select and Uniform 
Scale tool. Also, change the values of the following parameters:

	 Height: 1.0			  Height Segments: 20		  Sides: 30 
	 Cap Segments: 4

3.	 Hide washbasin to get more space to perform the boolean command and choose the Zoom 
Extents All tool.

4.	 Convert sieve into editable poly. Next, select the Polygon sub-object level and select outer 
polygons from all the viewports, as shown in Figure 15-64.

5.	 Choose the Select and Move tool and move the selected polygons upward and then scale 
them, as shown in Figure 15-65.
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Figure 15-64  Selected polygons of sieve

Figure 15-65  The selected polygons moved and scaled

6. 	 Select the Polygon sub-object level again to deactivate it. Next, choose the Cylinder tool 
from Create > Geometry > Standard Primitives in the Command Panel. 

7.	 Create a cylinder in the Top viewport at the center of sieve and set its radius to 0.8 and height 
to 10.0.



NURBS Modeling		         15-27

8.	 Create copies of the cylinder according to the radius of sieve and arrange them, as shown 
in Figure 15-66.

Figure 15-66  Cylinders created and aligned

9.	 Select sieve in the Top viewport and choose the ProBoolean tool from Create > Geometry > 
Compound Objects in the Command Panel. In the Pick Boolean rollout, choose the Start 
Picking button and click on the cylinders in any viewport one-by-one. Next, right-click to 
exit the command; a sieve is created, as shown in Figure 15-67. 

Figure 15-67  A sieve created in the Perspective viewport

10.	 Modify the color of sieve to light grey and then unhide washbasin in the viewports. Next,   
align sieve in the viewports, as shown in Figure 15-68.
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Figure 15-68  A sieve created and aligned in viewports

	 To create a duct, you need to choose the Hose tool from the Extended Primitives.

11.	 Create a hose in the Top viewport and set its height in the Height spinner in the Free Hose 
Parameters area according to washbasin size. Also, set the parameters in the Common Hose 
Parameters rollout as follows:

	
	 Segments: 80		  Cycles: 15	
	
	 Hose Shape Area

	 Make sure that the Round Hose radio button is selected. Next, set the diameter in the 
Diameter spinner and sides in the Sides spinner according to the radius of the sieve. 

12.	 Modify the name of the hose to duct and align it in viewports, as shown in Figure 15-69. 

13.	 Apply the Bend modifier to duct and set the values in the Parameters rollout as follows:
	
	 Bend Area
	 Angle: 40
	
	 Bend Axis Area
	 Make sure that the Z radio button is selected.

14.	 Rotate duct in the Top viewport and align it in viewports, as shown in Figure 15-70.
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Figure 15-69  A duct created and aligned in viewports

Figure 15-70  The duct geometry rotated and aligned in viewports

15. Convert duct into editable poly and select the Vertex sub-object level. Next, move and rotate 
its vertices to align with washbasin in the Left viewport, as shown in Figure 15-71.  
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Figure 15-71  The vertices of duct aligned in the Left 
viewport

Creating Slab
In this section, you will create a washbasin slab by using the Box tool.

1.	 Create a box in the Top viewport and set its parameters in the Parameters rollout as follows:

	 Length: 190.0		  Width: 300.0		  Height: 46.0
	 Length Segs: 15		  Width Segs: 15

2.	 Modify the name of the box to washbasin slab and align it, as shown in Figure 15-72. 

Figure 15-72  The washbasin slab created and aligned in viewports
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3.	 Convert washbasin slab into editable poly and select the Polygon sub-object level. 

4.	 Now, select the inner polygons of washbasin slab, as shown in Figure 15-73. Next, delete 
them, refer to Figure 15-74.

Figure 15-73  The inner polygons selected to 
be deleted 

Figure 15-74  The washbasin slab after 
deleting the polygons 

5.	 Select the Vertex sub-object level and modify the vertices of washbasin slab to view the inner 
portion of washbasin properly, as shown in Figure 15-75. 

Figure 15-75  The vertices moved to view the 
inner portion of washbasin

Creating Washbasin Taps
In this section, you will create washbasin taps by using the Cylinder tool.

1.	 Create a cylinder in the Top viewport and set its parameters in the Parameters rollout as 
follows:

	 Radius: 12.0		  Height: 3.0	

2.	 In the Front viewport, create four copies of the cylinder vertically in the downward direction. 
Now, set the radius of all four cylinders as 2.0, 3.0, 8.0, and 10.0 from top to bottom. Now, 
select the cylinders having radius 2.0 and 3.0, and set their height to 20.0.
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3.	 Align the cylinders using the Select and Move and Select and Rotate tools, as shown in 
Figure 15-76. Also, group all of them and name the group as tap01.

Figure 15-76  The tap01 geometry created and aligned in viewports

4.	 Align tap01 on the left side of washbasin. Also, create a copy of tap01, which is automatically 
named as tap002, and align it on the right side of washbasin.

	 Now, you need to create the main tap.

5.	 As discussed above, create the base of the main tap using three cylinders of radius 8.0, 10.0, 
and 12.0, and group and name it as base. Now, choose the Line tool and create a line spline 
in the Left viewport, as shown in Figure 15-77. 

Figure 15-77  The line spline created in 
the Left viewport
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6.	 Now, create a cylinder in the Top viewport and set its parameters in the Parameters rollout 
as follows:

	 Radius: 3.0		  Height: 20.0		  Height Segments: 30  
  
7.	 Make sure that the cylinder is selected in the viewport and apply the PathDeform modifier 

to it; the Parameters rollout is displayed in the Modify panel. 

8.	 In the Parameters rollout of the PathDeform modifier, choose the Pick Path button and 
then select the line spline in the viewport; a line is created at the center of the cylinder. Now, 
set the value in the Stretch spinner to get a shape similar to the tap. 

Note
The number of segments in the object should be high to get the smoothness on applying the 
PathDeform modifier.  

9.	 Group the line spline and the cylinder as upper tap and then align it with base in viewports 
using the Select and Move and Select and Rotate tools, as shown in Figure 15-78.

Figure 15-78  Alignment of upper tap and base 

10.	 Group base and upper tap as main tap and then align it, as shown in Figure 15-79. 

Figure 15-79  Alignment of the main tap in viewports 
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Saving the Scene
In this section, you will save the scene and then render it. You can also view the final rendered 
image of this model by downloading the c15_3dsmax_2022_rndr.zip file from www.cadcim.com. The 
path of the file is as follows:Textbooks > Animation and Visual Effects > 3ds Max > Autodesk 3ds Max  
2022: A Comprehensive Guide

1. 	 Change the background color of the scene to white, as discussed in Tutorial 1 of Chapter 2.

2.	 Activate the Perspective viewport. Next, choose Save from the File menu.

Tutorial 2
In this tutorial, you will create a hat, as shown in Figures 15-80 and 15-81, using the NURBS 
curves. 							          	       (Expected time: 30 min)

Figure 15-80  The model of hat (view 1) Figure 15-81  The model of hat (view 2)

The following steps are required to complete this tutorial:

a.	 Create the project folder.
b.	 Create NURBS curves using splines.
c.	 Create and modify the hat.
d.	 Assign the material.
e.	 Save the scene. 

Creating the Project Folder
1.	 Create a new project folder with the name c15_tut2 at \Documents\3dsmax2022 and then save 

the file with the name c15tut2, as discussed in Tutorial 1 of Chapter 2.

2.	 Open the Windows Explorer and then browse to the c15_3dsmax_2022_tut folder and copy 
the cloth.jpg file from this folder to \Documents\3dsmax2022\c15_tut2\sceneassets\images.
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Creating NURBS Curves Using Splines 
In this section, you will create the circular NURBS curves for the hat.

1.	 Choose Create > Shapes in the Command Panel and then choose the Circle tool from the 
Object Type rollout. 

2.	 Create a circle in the Top viewport; it is automatically named as Circle001. Next, set its radius 
to 45 in the Radius spinner of the Parameters rollout.

3.	 Make sure that Circle001 is selected in the Top viewport. Right-click on the Select and 
Uniform Scale tool from the Main Toolbar; the Scale Transform Type-In dialog box is 
displayed, as shown in Figure 15-82. Now, in the Absolute:Local area, set the value 111.0 
in the X spinner; Circle001 is scaled along the X-axis, as shown in Figure 15-83. Now, close 
this dialog box. 

Figure 15-83  The Circle001 spline 
scaled along the X-axis

Figure 15-82  The Scale Transform 
Type-In dialog box

4.	 Convert Circle001 into NURBS surface and choose the Zoom Extents All tool.

5.	 Click on the black arrow on the left of NURBS Surface in the 

Figure 15-84  The Rebuild CV 
Curve dialog box

modifier stack; all the sub-object levels are displayed.

6.	 Select the Curve sub-object level. Next, select the curve in the 
viewport. Now, choose the Rebuild button in the CV Curve 
rollout; the Rebuild CV Curve dialog box is displayed. Now, 
set 20 in the spinner next to the Number radio button, refer 
to Figure 15-84. Next, choose the OK button. Click on the 
Curve sub-object level to deactivate it.

	 Next, you need to create multiple copies of Circle001 to create the surface. 

7.	 Choose the Select and Move tool and select Circle001 in the Front viewport and move the 
cursor over its vertical axis. Press and hold the SHIFT key and the left mouse button, and then 
move Circle001 in the upward direction until the value in the Y spinner in the coordinates 
display becomes about 17. Now, release the left mouse button and the SHIFT key; the Clone 
Options dialog box is displayed. Set the value 4 in the Number of Copies spinner and choose 
the OK button; Circle002, Circle003, Circle004, and Circle005 are created in viewports.
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8.	 Choose the Zoom Extents All tool; the circular NURBS curves are displayed in the viewports, 
as shown in Figure 15-85.

Figure 15-85  The circular NURBS curves displayed in viewports

9.	 Select Circle001 that is placed at the bottom in the viewport and right-click on the Select 
and Move tool; the Move Transform Type-In dialog box is displayed. In the Offset:Screen 
area, set the value 13 in the Y spinner and press the ENTER key; Circle001 moves in the 
vertical direction, as shown in Figure 15-86.

10.	 Close the Move Transform Type-In dialog box. 

11.	 Select Circle001 and then by pressing CTRL key, select Circle002. Next, right-click on the 
Select and Uniform Scale tool; the Scale Transform Type-In dialog box is displayed. In the 
Offset:Screen area, set the value 119 in the % spinner and press the ENTER key; Circle001 
and Circle002 are scaled, as shown in Figure 15-87.

Figure 15-86  The Circle001 spline 
moved vertically

Figure 15-87  The Circle001 and Circle002 
splines scaled vertically
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12.	 Close the Scale Transform Type-In dialog box and choose the Zoom Extents All tool. 

Creating and Modifying Hat
In this section, you will create a surface between the NURBS curves in the viewport to give it a 
shape by using the U Loft button.

1.	 Select Circle001 placed at the bottom in the Front viewport. 

2.	 Choose the Modify tab, if it is not already chosen; the NURBS Surface is displayed in the 
modifier stack. All rollouts to modify the NURBS object are also displayed below the modifier 
stack.

3.	 Make sure the General rollout is expanded and choose the NURBS Creation Toolbox 
button; the NURBS toolbox is displayed. Now, choose the Create U Loft Surface button 
from the Surfaces section; the U Loft Surface rollout is displayed in the Modify panel. 
Next, move the cursor over Circle001; it turns blue. Now, click on it and then one-by-one 
click on Circle002, 003, 004, and 005 to add them into the U loft surface. Now, right-click 
to end the command. In the U Loft Surface rollout, select the Flip Normals check box. 
Next, right-click to exit the U loft command; a NURBS surface is created in the viewports, 
as shown in Figure 15-88.

Figure 15-88  A NURBS surface created

4.	 Now, choose the Create Cap Surface button from the Surfaces section in the NURBS 
toolbox; the Cap Surface rollout is displayed in the Modify panel. Now, move the cursor 
over Circle005, which is placed at the top in the Front viewport, and then click on it. Also, 
in the Cap Surface rollout, select the Flip Normals check box. The open surface is now 
capped at one end, as shown in Figure 15-89. Next, right-click to exit the Create Cap Surface 
command.
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Figure 15-89  The NURBS surface capped at one end

5.	 Modify the name of the surface to hat in the Name and Color rollout.

	 Next, you need to modify the hat geometry so that it resembles the shape of the hat.

6.	 Select hat in any viewport and click on the plus sign on the left side of NURBS Surface in 
the modifier stack; all the sub-object levels are displayed.

7.	 Select the Curve sub-object level. In the Front viewport, modify the NURBS curves using 
the Select and Move and Select and Uniform Scale tools, as shown in Figure 15-90.

8.	 Again, select the Curve sub-object level in the modifier stack to exit the command.

9.	 Select the Curve CV sub-object level; all control vertices are displayed in the viewport. Now, 
select the outer control vertices of the bottom curves, refer to Figure 15-91. Next, move 
them until the value in the Y spinner in the coordinate display becomes about 15, as shown 
in Figure 15-91.

10.	 Now, modify the surface using the control vertices and curves to get the required shape, as 
shown in Figure 15-92. 



NURBS Modeling		         15-39

Figure 15-90  The NURBS curves  
modified in the Front viewport

Figure 15-91  The outer control vertices  
moved vertically

Figure 15-92  The surface modified at the sub-object level

Assigning the Material
In this section, you will assign the material to the hat by using the Material Editor dialog box.

1.	 Select hat in the viewport and choose the Material Editor tool from the Main Toolbar; the 
Material Editor dialog box is displayed.

2.	 By default, the Standard material is selected in the Material Editor dialog box. Select the 
01-Default sample slot and modify its name to hat in the Material Name text box. 

3.	 Choose the Material Type button which is labeled as Standard from the Material Editor; the 
Material/Map Browser dialog box is displayed. Select the Double Sided material from the 
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Materials > Standard rollouts and choose the OK button; the Replace Material dialog 
box is displayed. Select the Discard old material radio button and choose the OK button. 
Notice that the Material Type button is labeled as Double Sided now. Also, the rollouts to 
modify the material are displayed. 

4.	 In the Double Sided Basic Parameters rollout, choose the Facing Material map button 
that is labeled as Material#X (Standard); the Standard material is displayed that is used 
to specify material for the outer surface of hat. 

5.	 Now, expand the Maps rollout, and choose the Diffuse Color map button that is labeled as 
None; the Material/Map Browser dialog box is displayed. Select the Bitmap map from the 
Maps > General rollout and choose the OK button; the Select Bitmap Image File dialog 
box is displayed. Now, select the file cloth.jpg and choose the Open button; the selected 
image is displayed in the sample slot. Make sure that the Use Real-World Scale check box 
is cleared in the Coordinates rollout. 

6.	 Choose the Go to Parent tool twice to go back to the Double Sided material. Now, choose 
the Back Material button that is labeled as Material#X (Standard); the Standard material 
is displayed that is used to specify material for the inner surface of hat. 

7.	 Expand the Maps rollout, and choose the Diffuse Color map button that is labeled as 
None; the Material/Map Browser dialog box is displayed. Select the Checker map from 
the Maps > General>Standard rollout and choose the OK button; the rollouts to modify 
the Checker map are displayed. 

8.	 In the Coordinates rollout, set the value 25 in both the U Tiling and V Tiling spinners and 
assign hat material to hat. Close the Material Editor dialog box.  	

Note
If you want to swap the materials on the geometry, assign the Normal modifier.

Saving and Rendering the Scene
In this section, you will save the scene and then render it. You can also view the final rendered 
image of this model by downloading the file c15_3dsmax_2022_rndr.zip from www.cadcim.com. 
The path of the file is as follows: Textbooks > Animation and Visual Effects > 3ds Max > Autodesk 
3ds Max  2022: A Comprehensive Guide.

1. 	 Change the background color of the scene to white, as discussed in Tutorial 1 of Chapter 2.

2.	 Choose Save from the File menu.

3.	 Activate the Perspective viewport and set the view using the Orbit tool to see the inner and 
outer surfaces of hat. 



NURBS Modeling		         15-41

4.	 Ensure the renderer is set to Scanline. Choose the Render Production tool in the Main 
Toolbar; the Rendered Frame window is displayed with the final output of the scene, refer 
to Figure 15-93.

5.	 Close this window.

Figure 15-93  The final output after rendering

                                    	
 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 In which of the following NURBS surfaces, the points are constrained to lie on the surface?

		  (a) Point Surface			   (b) CV Curve
		  (c) Point Curve				    (d) CV Surface

2.	 Which of the following buttons in the Create Points rollout is used to add the independent 
point sub-object to a NURBS object?

		  (a) Point				    (b) Surf-Curve
		  (c) Curve-Curve			   (d) Surf-Point

3.	 Which of the following buttons in the Create Surfaces rollout is used to add the dependent 
surface sub-object to a NURBS object?

		  (a) Transform		  		  (b) Extrude
		  (c) U Loft	 			   (d) All of these

4.	 Which of the following buttons in the Create Points rollout is used to add the dependent 
point sub-object to a NURBS object?

		  (a) Offset Point		 		  (b) Curve Point
		  (c) Curve-Curve			   (d) All of these

5.	 The NURBS curves are the shape objects and are used to create complex surfaces to create 
the 3D models. (T/F)	

6.	 The point curves are the NURBS curves in which the points lie outside the curve. (T/F)
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7.	 In the NURBS modeling, an iso line is known as a line of constant parameter value similar 
to a contour line. (T/F)

8.	 The CV curves are the NURBS curves that are controlled by __________.

9.	 The CVs are the points that lie __________ the surface and control the __________ of the 
CV surface.

10.	 While creating a point curve, if you want to remove the last point that you have created, 
then press the __________ key. 

 Review Questions 
Answer the following questions:

1.	 Which of the following buttons in the Create Curves rollout is used to add the dependent 
curve sub-object to a NURBS object?

		  (a) Transform		  		  (b) Blend
		  (c) Chamfer	 			   (d) All of these

2.	 Which of the following buttons in the Create Surfaces rollout is used to add the surface 
sub-object to a NURBS object?

		  (a) 1-Rail	 			   (b) 2-Rail
		  (c) Offset	 			   (d) All of these

3.	 Which of the following buttons in the Create Curves rollout is used to add the curve sub-object 
to a NURBS object?

		  (a) 1-Rail	 			   (b) U Loft
		  (c) Cap	 				    (d) None of these

4.	 You cannot convert the torus knot and prism from extended primitives into NURBS surface. 
(T/F)

5.	 To create a NURBS model, you can also use the splines or extended splines shapes instead 
of using the point curve or the CV curve. (T/F)

6.	 The buttons in the NURBS toolbox perform the same functions as the buttons in the Create 
Points, Create Curves, and Create Surfaces rollouts. (T/F)

7.	 The __________ check box is used to create a 3D curve in all viewports simultaneously. 

8.	 In the viewports, the dependent point sub-objects will be displayed as __________ and the 
independent point sub-objects will be displayed as __________.

9.	 The __________ button in the Create Surfaces rollout is used to create a surface sub-object 
between two curve sub-objects. 
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EXERCISE
The rendered output of the model used in the following exercise can be accessed by downloading 
the c15_3dsmax_2022_exr.zip file from www.cadcim.com. The path of the file is as follows: Textbooks > 
Animation and Visual Effects > 3ds Max > Autodesk 3ds Max 2022: A Comprehensive Guide

 Exercise 1                                                                
Start Autodesk 3ds Max 2022 and then perform the following operations:

1.	 Choose Create > Shapes in the Command Panel; a drop-down list will be displayed. 
Select the NURBS Curves option from the drop-down list. Now, activate the Top viewport 
and choose the Point Curve tool from the Object Type rollout. Next, create two or more 
point curves in the viewport. Finally, choose the Modify tab in the Command Panel and 
attach the NURBS curves in the viewport using the Attach Multiple tool.

2.	 Create a spline or a curve in the viewport from Create > Shapes > Splines in the Command 
Panel. Now, convert it into NURBS curve using the methods discussed in the chapter. 

3.	 Create a NURBS object in the viewport that contains two or more curves or surface 
sub-objects. Choose the Modify tab in the Command Panel and then choose the Blend 
button from the Create Surfaces rollout. Next, move the cursor over the edge; it turns blue. 
Now, click on the edge and move the cursor over the edge of another NURBS object, and 
click on it; a blend surface will be created between the two NURBS objects. Next, modify 
the blend surface using the parameters in the Blend Surface rollout in the modify panel 
and right-click to exit the command.

4.	 Create a NURBS curve in the viewport, as shown in Figure 15-94. Next, create a NURBS 
model, as shown in Figure 15-95, using the U Loft tool. Also, apply a material to it. 

Figure 15-94  The NURBS curve to create 
the model of heart

Figure 15-95  The model of heart
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Answers to Self-Evaluation Test
1. a, 2. a, 3. d, 4. d, 5. T, 6. F, 7. T, 8. control vertices (CVs), 9. outside; shape, 10. BACKSPACE  


