
Chapter 2

Editing in the Sketch
Mode

After completing this chapter you will be able to:
• Use different options to dimension a sketch.
• Use AutoDim for dimensioning.
• Use options to modify a sketch.
• Use geometric tools like Intersect, Divide, and Move Entity.
• Use different Advanced Geometry options.
• Modify text in a sketch.
• Use different options in SEC TOOLS submenu.
• Use the Resolve Sketch dialog box.

Learning Objectives
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DIMENSIONING THE SKETCH
In Chapter 1 you learned how to dimension a sketch using
the Normal option of the DIMENSION menu in the Menu
Manager. As mentioned in Chapter 1, the DIMENSION
submenu is available only when the Intent Manager is off.
In this chapter you will learn to dimension a sketch using
the remaining options available under the DIMENSION
submenu shown in Figure 2-1.

When the Intent Manager is on, choose Sketch > Dimension
from the menu bar. The cascading menu is displayed as shown
in Figure 2-2. The options that are available to
dimension a sketch when the Intent Manager is on
are shown in the figure.

Dimensioning a Sketch Using
the Perimeter Option
The Perimeter option specifies the perimeter of
the entities or a loop of entities selected. In this type
of dimensioning, a dimension is selected from a
dimensioned sketch that will vary with the change in the perimeter. If you modify the perimeter
value of the sketch the modification is reflected in the dimension of the entity selected to vary
and hence the sketch is also modified corresponding to the variable dimension. The following
steps explain the procedure to dimension a sketch using the Perimeter option:

1. Draw a sketch as shown in Figure 2-3 and dimension it using the Normal option.
After adding the dimensions, regenerate the sketch.

2. Now, choose SKETCHER > Dimension > Perimeter from the Menu Manager. You will
be prompted to select the entity that is one end of the desired chain or a part of the desired
loop. This will be the first entity of the chain. Using the left mouse button select entity (a)
as shown in Figure 2-3. The color of the selected entity changes from cyan to red.

3. You will be prompted to select the last entity of the chain or to choose Done Sel to select
the complete sketch. Select the last entity (c) for the chain using the left mouse button. The
color of all the entities forming a chain (lines (a), (b), and (c) in this case) changes to red
and the CHOOSE submenu is displayed.

The CHOOSE submenu is displayed because when you select the entities defining the
first and the last end of the chain, two chains of entities are created. The first one consists
of the entities in the clockwise direction and the second one consists of the entities in the
counterclockwise direction. By default, the entities that form a chain in the clockwise
direction is highlighted (lines (a), (b), and (c)).

4. Choose the Accept option to accept the highlighted chain of entities. You will be prompted
to select a dimension that will be driven by the perimeter dimension. Using the left mouse

Figure 2-2  Dimensioning options available
when the Intent Manager is on

Figure 2-1  The  different options
of the DIMENSION submenu
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Figure 2-4  The Perimeter optionFigure 2-3  The Perimeter option

button select the dimension of line (a) as the variable dimension, see Figure 2-3. Regenerate
the sketch.

5. Now, if you modify the perimeter value, the dimension selected to vary will be
proportionately modified after regeneration, thus altering the geometry of the sketch.
Remember that the dimension selected to vary cannot be modified using the Modify
option in the SKETCHER menu. Figure 2-4 shows the perimeter modified to 100 and
the consequent change in the variable dimension.

Note
If you delete the variable dimension then the perimeter dimension is also deleted.

Dimensioning a Sketch Using the Reference Option
The Reference option is used to create reference dimensions. These dimensions are used only
for information and are not used in manufacturing the part. These dimensions appear with
the suffix “REF”. The following steps explain the procedure to create reference dimensions.

1. Choose the Reference option from the DIMENSION submenu.

2. Select an entity in the sketch to dimension by using the left mouse button. The cyan color
of the entity changes to red. Place the dimension using the middle mouse button. The
dimension appears in symbolic form as rsd with the suffix “REF”. If the Intent Manager
is on, the dimension value appears.

If you select a reference dimension to modify, a message is displayed “Modifying extra or
reference dimension can only affect sketch via relations. Continue?”. Choose the Yes button,
the value of the reference dimension will be displayed in the Message Input Window. Enter a
new value of the reference dimension. The reference dimension will be displayed in white
color after specifying a new value. However, as you regenerate the sketch, the value of the
reference dimension will be restored to its original value. This is because the value of a
reference dimension is driven by the normal dimensions and therefore, you cannot modify
the value of a reference dimension. Therefore, if you make any change in the normal dimensions
of the sketch and regenerate it, the change is automatically reflected in the value of the reference
dimension.
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Dimensioning a Sketch Using the Known Option
The Known option is used to create dimensions of a sketch by adding relations using the
known dimensions of a part. This option is not available when you are sketching in the Sketch
mode and is available only in the sketcher environment of the Part mode. These known
dimensions are considered as the driving dimensions of the sketch.

Remember that when using relations in the Sketch mode, the dimension is denoted by the
symbol sd, and in Part mode by d; the reference dimension in the Sketch mode is denoted by
rsd and in Part mode by rd. You will come across these dimension symbols as you learn various
modes available in Pro/ENGINEER. The relations are discussed in Chapter 8. The following
steps explain the procedure to create known dimensions:

1. Retrieve a model to create a feature on it.

Although the sketch of the retrieved model does not have the dimensions displayed on it,
yet you can select any entity. The dimension of the selected entity is the known dimension
and that act as the driving dimension for the future dimensions to be drawn on the retrieved
section of the model. The dimensions of the sketched feature act as the driven dimensions.

2. Sketch the other feature you want to create. Dimension it using the Normal option. Now,
you can use the known dimensions of the retrieved model to determine the dimensions of
the sketched feature.

3. Choose the Known option from the DIMENSION submenu. Now, select an entity with
respect to which you have to dimension the sketched entity. The dimension of the selected
entity is displayed as kd#, where # is the number associated with the dimension and
varies from user to user. Then choose Relation from the SKETCHER menu. A
RELATIONS submenu appears on the screen. Choose Add from this submenu; the
Message Input Window appears to enter the relation.

4. Now, enter the relation of the sketch with respect to the known dimensions of the part and
press ENTER. Remember to use the appropriate dimension symbols while giving the
relations. After you are finished with entering all the relations, press ENTER and then
regenerate the sketch. The dimensions of the sketch will be changed according to the
relations added.

Dimensioning a Sketch Using the Baseline Option
In Pro/ENGINEER, the Baseline option of dimensioning is used to create dimensions in
terms of horizontal and vertical location values of an entity with respect to a specified baseline.
This type of dimensioning in a drawing is required for writing a CNC program to manufacture a
component. This option can be used to dimension lines, conics, arcs, and so on. The following

Tip: In a sketch, you can toggle between the symbolic dimensions and dimension
values by choosing Info > Switch Dimensions from the menu bar.
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1. Choose SKETCHER > Dimension > Baseline from the Menu Manager.

2. Select the entity that will act as the baseline (origin or reference). Using the middle mouse
button, place the dimension.

Depending upon the entity selected to act as the baseline, the horizontal or the vertical
dimension value of the location of the entity will be placed. For example, if you select a
vertical line, the vertical value of its location will be placed. Similarly, if you select a
horizontal line, the horizontal value of its location will be placed. However, for arcs, circles,
and splines there are two options to dimension using the Baseline option. A VERT HORIZ
submenu appears when you select a circle center or an arc for baseline dimensioning and
you are prompted to select the dimension orientation. The dimension is placed according
to the orientation selected. Note that since the location value of the baseline is taken as
the origin, the dimension value of the baseline entity will become 0.00 when regenerated.
The dimensions values of the other entities dimensioned with reference to the baseline
will be measured from this origin.

3. Next, choose the Normal option from the DIMENSION menu in the Menu Manager.
Select the baseline dimension that was placed earlier and then select the entity to dimension.
Now, using the middle mouse button, place the dimension.

Depending upon the baseline dimension and the entity selected, the dimension will be
placed. Figure 2-5 shows a regenerated sketch dimensioned using the above-mentioned
method. In this figure, the two baselines are dimensioned using the Baseline option.
Therefore, after regeneration, the dimensions of these lines are displayed as 0.00. The
remaining lines are dimensioned using the Normal option by first selecting the baseline
dimension and then the entity to dimension.

Figure 2-5  Baseline dimensioning of a sketch



2-6      Pro/ENGINEER for Designers
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

e
ch

n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
. 

F
. 

F
. 

F
. 

F
. 

F o
r 

o
nl

in
e

 t
ra

in
in

g
, 

co
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
o

r 
o

nl
in

e
 t

ra
in

in
g

, 
co

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

o
r 

o
nl

in
e

 t
ra

in
in

g
, 

co
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
o

r 
o

nl
in

e
 t

ra
in

in
g

, 
co

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

o
r 

o
nl

in
e

 t
ra

in
in

g
, 

co
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m

Figure 2-6  Options in the
MOD SKETCH submenu

Replacing the Dimensions of a Sketch Using the Replace
Option
The Replace option is used to replace a dimension from a sketch. To use this option you must
have a  dimensioned sketch. The following steps explain the procedure to dimension a sketch
using the Replace option:

1. Choose the Replace option from the DIMENSION submenu. When the Intent Manager
is on, choose Edit > Replace from the menu bar. You will be prompted to select a dimension
to be replaced.

2. Select the dimension to be replaced using the left mouse button. The selected dimension
is erased. Select the entity using the left mouse button to dimension and place the dimension
at the desired place. The previous dimension will be replaced by a new dimension.

AUTODIMENSIONING IN PRO/ENGINEER
Dimensioning a sketch is necessary in order to regenerate the sketch. If the Intent Manager is
on, the sketch is automatically dimensioned. But, if you are sketching without the Intent
Manager, you have an option that allows you to create the dimensions automatically. This
option is AutoDim. This option is available under the SKETCHER menu. The AutoDim
option is not available when the Intent Manager is on. The AutoDim option uses two reference
planes for dimensioning when you are in the Part mode. But, when you are sketching in the
Sketch mode and the AutoDim option is chosen, the sketch is automatically dimensioned
without any references. Also, note that the sketch is automatically regenerated when you select
this option.

MODIFYING A SKETCH
When the Intent Manager is off, a sketch is modified by using the
MOD SKETCH submenu. The MOD SKETCH submenu, shown in
Figure 2-6, is displayed when you choose the Modify option from
the SKETCHER menu in the Menu Manager.

The Mod Entity option was discussed in Chapter 1 and the rest of
the options are discussed next.

Scale
In case the section is complex and involves many dimensions, then the dimensions may conflict
when you modify them. Hence, the section will not be regenerated successfully. Using the
Scale option of the MOD SKETCH submenu, the overall scale of the sketch can be changed.
This option is available only when the section has been regenerated once. The following steps
explain the procedure to use the Scale option to modify the dimension values:

1. Choose SKETCHER > Modify > Scale from the Menu Manager.

2. You will be prompted to select a linear dimension. Select the dimension you want to set as
the driving dimension. The color of the selected dimension changes to red and the Message
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mInput Window appears. Enter the dimension in this window and press ENTER.

The dimension selected is called the driving dimension because when the driving dimension
is modified all the dimensions in the sketch are scaled proportionately.

3. Now, choose the Regenerate option from the SKETCHER menu. All the other dimensions
in the sketch are scaled to the same scale factor thus modifying the section. Remember
that the selected dimension will scale the other dimensions in the sketch proportionately
only once. If you again want to scale the dimension of the sketch in relation to a dimension,
you need to repeat step 2 and 3.

When the Intent Manager is on, you can scale a
sketch by using the Scale Rotate dialog box.
Choose the black arrow on the right of the Mirror

selected entities. button from the Right Toolchest to
display the flyout. From this flyout, choose the Scale and
rotate selected entities. button. The Scale Rotate dialog
box is displayed. This button is available only when an
entity or a complete sketch is selected. Select an entity or
a complete sketch and then choose this button, the Scale
Rotate dialog box is displayed as shown in Figure 2-7. You can dynamically scale or rotate the
sketch or the selected entity on the graphics screen. You can also use the Scale Rotate dialog
box to enter a value for rotating and scaling in the Scale and Rotate edit boxes.

Drag Dim Val
Using the Drag Dim Val option you can make minute changes in the value of the selected
dimension by varying the dimension and dynamically view the modification in the section
geometry. You can select up to five dimensions at a time to make alterations. This option is
available only when the sketch is regenerated once. The following steps explain the procedure
to use the Drag Dim Val option to modify the dimension values:

1. Choose SKETCHER > Modify > Drag Dim Val from the Menu Manager.

2. You will be prompted to select the dimensions to modify. Select the dimensions you want
to modify. You can select a maximum of five dimensions at a time. Choose Done Sel from
the GET SELECT submenu or press the middle mouse button. A thermotool appears
with all the dimensions selected to modify.

3. You can set sensitivity for modification in the dimension. At any time you can right-click
on the thermotool to automatically reset to the original values of the selected dimension.
Move the red pointer on the scale below each dimension in the thermotool to modify the
selected dimension. The changes in the dimension values will be automatically reflected
in the sketch.

4. To exit the thermotool, press the middle mouse button.

Figure 2-8 shows the section sketch and Figure 2-9 shows the thermotool for modifying all the

Figure 2-7  Scale Rotate dialog box
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dimensions of the sketch.

Drag Entity
The Drag Entity option is used to modify a selected dimension to change the shape of the
section sketch by selecting the dimension and moving the corresponding entity. Remember
that if the selected entity is constrained then you cannot modify it. You can only modify it by
first disabling the constraint. This option is available only when the section is regenerated.
The following steps explain the procedure to use the Drag Entity option to modify the
dimensions:

1. Choose SKETCHER > Modify > Drag Entity from the Menu Manager.

2. You will be prompted to select the dimension to modify. Select the dimension you want to
modify using the left mouse button.

3. You will now be prompted to select an entity for dragging or to select a new dimension.
Select an entity corresponding to the selected dimension and move it to modify the
dimension value accordingly. Note that you can move only one entity at a time to change
the dimension of the entity.

Drag Vertex
The Drag Vertex option is used to modify the section sketch by dragging the vertices. The
following steps explain the procedure to modify a sketch by using the Drag Vertex option.

1. Choose SKETCHER > Modify > Drag Vertex from the Menu Manager. You will be
prompted to select two dimensions to modify.

2. Select the two dimensions to modify and select a corresponding vertex to drag. The
dimensions are modified as you move the cursor and accordingly the sketch is also modified.

3. When you get the desired geometry of the sketch, accept the new values of the selected
dimensions using the left mouse button. You can abort the new value of the dimension
and restore the original one by using the middle mouse button.

Figure 2-8  The section sketch Figure 2-9  Modify Dims thermotool



Editing in the Sketch Mode                 2-9

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
. 

F
. 

F
. 

F
. 

F
. 

F o
r 

e
n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r v
ic

e
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

vi
ce

s,
 c

o
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
vi

ce
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

vi
ce

s,
 c

o
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
vi

ce
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
mSet Anchor

The Set Anchor is available only when you have dimensioned the sketch and regenerated it.
When you select this option the anchor point is stored with the sketch. The following steps
explain the procedure to modify the sketch using the Set Anchor option:

1. Choose Set Anchor from the MOD SKETCH submenu in the Menu Manager. You will be
prompted to select a vertex that should remain fixed while using the other options of the
MOD SKETCH submenu.

2. Select a vertex in the sketch that you want to be fixed using the left mouse button. Now,
you can modify the other sketch dimensions by using the other options of the MOD
SKETCH submenu. When you regenerate the sketch you will see that the sketch has been
modified without altering the position of the vertex selected as the anchor point.

GEOM TOOLS
The tools that help a designer to complete the section sketches
are available in the GEOM TOOLS submenu in the Menu
Manager. This submenu is available only when the Intent
Manager is off. Choose Geom Tools from the SKETCHER
menu. The GEOM TOOLS submenu appears with different
options as shown in Figure 2-10. Some of the options are not
displayed in this submenu because they are not needed in
the Sketch mode. The Trim and the Mirror options were
discussed in Chapter 1. The Intersect, Divide, and the Move
Entity options are discussed next.

Intersect
The Intersect option is used to intersect two entities and convert them into separate entities at
the point of intersection. You can delete the portion of the entity that is not required. The
following steps explain the procedure to use the Intersect option. Refer Figure 2-11 and
Figure 2-12:

1. Choose Intersect from the GEOM TOOLS submenu. You will be prompted to select two
entities.

2. Select any two entities individually using the left mouse button. The two selected entities
are broken at the intersecting point and are converted into four entities.

3. Continue step 2 until you have intersected all the desired entities. Figure 2-11 shows a
sketch with three lines extending beyond the intersection point and Figure 2-12 show the
lines after intersecting and deleting the extended lines.

Note
You can use the center lines and planes to intersect but they themselves are not converted into
two entities.

Figure 2-10  Figure showing
different GEOM TOOLS option
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Divide
The Divide option is used to divide an entity into any number of parts or entities by specifying
the points on the entity. Note that if you select a dimensioned entity to divide, you will be
prompted to first delete the dimension and then divide it.

When the Intent Manager is on, choose the Divide an entity at the point of selection.
button from the Right Toolchest. This button is available on the flyout that is displayed
when you choose the black arrow that is on the right side of the Dynamically trim

section entities button.

The following steps explain the procedure to divide an entity:

1. Choose Divide from the GEOM TOOLS submenu in the Menu Manager. You will be
prompted to select an entity to divide.

2. Using the left mouse button select the entity at the point where you want to divide it . The
entity is divided into two different entities. They can now be treated as two different entities.

3. Repeat step 2 until you divide the entities in the required number of points.

Move Entity
The Move Entity option is used to move the sketched entities
and the dimensions. Choose Move Entity from the GEOM
TOOLS submenu in the Menu Manager. The MOVE ENTITY
submenu appears with the options to move the sketcher entities
and dimensions. Figure 2-13 shows the options available in the
MOVE ENTITY submenu. The options in this submenu are
discussed next.

Drag Item
The Drag Item option is used to drag individual entities and dimensions of a sketch. The

Figure 2-13  Options in the
MOVE ENTITY submenu

Figure 2-12  The required sketchFigure 2-11  Three entities that split into nine
entities after intersecting
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1. Choose Drag Item from the MOVE ENTITY submenu in the Menu Manager. You are
prompted to select an entity or one of its vertices to drag.

2. Select the entity you want to drag using the left mouse button. The color of the entity
changes to red and the cursor is attached to the entity. You are prompted to select a new
location to place the entity or the vertex selected. Note that if you select a vertex of an
entity, it will not be moved, it will be stretched. Similarly, if you select an arc and move it to
a new location, the center of the arc will not change but its radius will be changed.

You can abort this option by using the middle mouse button at any time.

3. Move the cursor and place the selected entity using the left mouse button.

4. Repeat steps 2 and 3 until you drag all the required entities or dimensions. Use the middle
mouse button to abort the Drag Item option.

Drag Many
The Drag Many option is used to move many entities at a time to a new location. You cannot
drag the dimensions using this option. The following steps explain the procedure to drag
many entities at a time.

1. Choose the Drag Many option from the MOVE ENTITY submenu in the Menu Manager.
You will be prompted to select the entities to translate.

2. Select the entities you want to move. The color of the entities becomes red. Choose Done
Sel from the GET SELECT submenu to complete your selection.

3. You will be prompted to select a start point for dragging. Select a point on the graphics
screen. The selected entities will move with the cursor. Move the cursor at the desired
place on the graphics screen and using the left mouse button, select the new location of
the entities.

4. Repeat step 2 and 3 until you move all the required entities. Use the middle mouse button
to end this option.

Rotate 90
The Rotate 90 option is used to rotate a single or multiple entities in 90-degree increments.
The following steps explain the procedure to rotate entities.

1. Choose Rotate 90 from the MOVE ENTITY submenu in the Menu Manager. You will be
prompted to select the entities to rotate:

2. Select the entities you want to rotate. The color of the entities to be rotated turns red.
Choose Done Sel from the GET SELECT submenu to complete the selection. The Message
Input Window is displayed and you will be prompted to enter counterclockwise rotation
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angle in 90-degree increments in the Message Input Window.

3. Enter the required value in the multiples of 90-degree that will rotate the selected entity,
and then press ENTER.

4. You will now be prompted to select the center point of rotation about which the selected
entities will rotate. Specify the center point of rotation at the desired location on the
graphics screen. The selected entities are rotated about the specified center point.

5. Repeat step 2, 3, and 4 until you rotate all the required entities. Use the middle mouse
button to end this option.

Dimension
The Dimension option is used to move the dimensions of a sketch. Note that you can move
only one dimension at a time. The following steps explain the procedure to move dimensions
of a sketch:

1. Choose Dimension from the MOVE ENTITY submenu in the Menu Manager. You will
be prompted to select the dimension to be moved.

2. Select the dimension to be moved using the left mouse button. The dimension text is
replaced by a red colored box and is attached to the cursor. You are prompted to select a
new location to place the dimension.

3. Move the cursor on the graphics screen to move the dimension to the desired location.
Place it by using the left mouse button. The dimension text is redisplayed.

4. Repeat step 2 and 3 until you move all the dimensions at the desired place. Use the
middle mouse button to end this option.

When the Intent Manager is on, a dimension can be moved by pressing and holding the left
mouse button on the dimension and moving it. The dimension text is replaced by a red colored
box and the cursor is replaced by a hand. You can drag the dimension to the desired location
on the graphics screen and release the left mouse button to place the dimension at that point.

SKETCHING ADVANCED GEOMETRY
When the Intent Manager is off, you can sketch different
advanced geometries in the Sketch mode using the Adv
Geometry option . Choose Sketch from the SKETCHER menu
and Adv Geometry from the GEOMETRY submenu in the
Menu Manager. The ADV GEOMETRY submenu appears as
shown in Figure 2-14 with different options available to
create advanced geometries.

The different options in the ADV GEOMETRY submenu are
discussed next.

Figure 2-14  Options in the
ADV GEOMETRY submenu
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The Conic option is used to create conic splines. The following steps explain the procedure to
create a conic spline using the Conic option:

1. Choose SKETCHER > Sketch > Adv Geometry > Conic from the Menu Manager. You
will be prompted to select the first endpoint of the conic entity. Using the left mouse
button select a point on the graphics screen as the first endpoint of the conic entity.

2. You are now prompted to select the second endpoint of the conic entity. A red rubber-band
line appears with the cursor attached to one end. Move the mouse to select the second
endpoint of the conic entity at the desired place on the graphics screen using the left
mouse button.

3. A red rubber-band conic spline appears with the cursor attached to it. You are prompted
to select the shoulder point of the conic. Move the mouse to size the conic spline. Select
the shoulder point using the left mouse button at the desired point. A conic spline is
created. The red color of the conic spline is now changed to cyan.

4. Repeat step 1, 2 and 3 until you create all the conic splines required. To abort conic spline
creation before the spline is completed, press the middle mouse button.

Creating Coordinate System Using the Coord Sys Option
The Coord Sys option is used to create a coordinate system and add it to the sketch you create.
Unlike other CAD packages, Pro/ENGINEER does not use the Cartesian coordinate system.
In Pro/ENGINEER the user has to define a coordinate system where required. The coordinate
system acts as reference for dimensioning. You can dimension the splines using the coordinate
system. Thus, it provides you a flexibility to modify the spline points by specifying the different
coordinates with respect to the coordinate system. The coordinate system is used in blend
features to align different sections in a blend. It is also used in the Assembly mode and the
Manufacturing mode of Pro/ENGINEER. The following steps explain the procedure to create
a coordinate system:

1. Choose Adv Geometry from the GEOMETRY submenu and Coord Sys from the ADV
GEOMETRY submenu in the Menu Manager. You are prompted to select the location for
the coordinate system. Place the coordinate system at the desired points on the screen
using the left mouse button. The coordinate system will be placed at as many places as you
select on the graphics screen. You can end coordinate system creation by using the middle
mouse button.

When the Intent Manager is on, choose the Create reference coordinate system.
button from the Right Toolchest. This button is available on the flyout that is displayed
when you choose the black arrow on the right of the Create points. button. When you

choose this button, the reference coordinate system is attached to the cursor. You can place the
coordinate system at the desired points on the screen.
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Note
If you add a coordinate system to a sketch, it must be dimensioned unless the coordinate system is
placed at the endpoints of a line, an arc, a spline, or at the center of an arc or a circle. In other
words, a coordinate system must be referenced to an entity in a sketch.

Creating Elliptical Fillet Using the Elliptic Fillet Option
The Elliptic Fillet option is used to create elliptical fillets between any two entities. Elliptical
fillets are always created in elliptical shapes, that is, they have the properties of an ellipse.

When the Intent Manager is on, choose the Create an elliptical fillet between two
entities. button. This button is available on the flyout that is displayed when you
choose the black arrow on the right of the Create a circular fillet between two entities.

button.

The following steps explain the procedure to create elliptical fillets:

1. Choose SKETCHER > Sketch > Adv Geometry > Elliptic Fillet. You will be prompted
to select two entities.

2. Select the first entity using the left mouse button. The color of the entity changes to red.
Select the second entity. As soon as you select the second entity, the elliptical fillet is
created. The shape of the elliptical fillet depends upon the specified points. After the
current elliptical fillet is created, you will again be prompted to select two entities for
elliptical fillet.

3. Repeat step 2 until you have created all the fillets.

Creating Splines Using the Spline Option
Splines are curved entities that can pass through an infinite
number of intermediate points. Splines can be created in
many different ways.

Choose SKETCHER > Sketch > Adv Geometry > Spline.
The SPLINE MODE menu and TYPE submenu is displayed
with different options available to create the spline. The
SPLINE MODE menu is modal in nature, that is, each
button remains selected until you select another button.

Figure 2-15 shows you different SPLINE MODE menu and
TYPE submenu options available to create splines. The
options shown in Figure 2-15 are explained next.

Spline created using the Sketch Points option
The Sketch Points option creates a spline by picking the points on the screen. The spline
passes through all the selected points.

Figure 2-15  SPLINE MODE
submenu and TYPE submenu
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Using the Select Points option, the spline is created by selecting the predefined sketcher
points. These points are selected for the spline to pass through.

The options under the TYPE submenu are discussed next.

Thru Points
The Thru Points option is selected by default in the TYPE
submenu. The following steps explain the procedure to create a
spline using this option:

1. When you select this option, you will be prompted to create
points for the spline to pass through. Select a point on the
graphics screen as the start point of the spline.

2. A red rubber-band line appears from the start point. Select
different  points on the graphics screen for the spline to
pass through. After selecting the points use the middle mouse
button to complete spline creation. You can abort spline
creation using the right mouse button.

The modification of the spline is possible by using the options
of the MOD SPLINE submenu. The MOD SPLINE submenu
shown in Figure 2-16 can be invoked by choosing the Modify
option in the SKETCHER menu and then selecting a spline.

Control Poly
The Control Poly option is used to create a spline that is enclosed in a polygon such that
the endpoints of the spline are tangent to the control polygon. The control polygon of the
spline is considered as the parent of the spline. You can dimension the lines of the control
polygon as normal sketched entities to modify the shape of the spline. Note that if you delete
the control polygon, the spline is not deleted. You can use the MOD SPLINE submenu to
make some modifications in the shape of this spline.

Approx Chain
The Approx Chain option is used to create a spline approximately along the selected chain of
entities such as lines, arcs, and so on. The following steps explain the procedure to create
splines using the Approx Chain option:

1. Choose Approx Chain from the TYPE submenu. You will be prompted to select section
entities forming single continuous chain.

2. Select the entities such as lines, arcs, and so on using the left mouse button. The color of
the selected entities changes to red. A spline is created along the selected entities with a
control polygon when the middle mouse button is pressed.

Figure 2-16  The options in
the MOD SPLINE submenu
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Points to remember while deleting the Approx Chain splines.

1. When you delete the spline created by the Approx Chain option, the chained entities used
to create the spline are restored. You may need to use the Query Bin to delete the spline.

2. If you delete any entity of the chain, the entire chain will be deleted completely and the
spline will be left. This spline would behave like any other spline in the Sketch mode.

3. If you restore the deleted chain by choosing the Undelete Last option, the  entire chain is
restored. If the spline is modified before you restore the change, Pro/ENGINEER ignores
the modifications and the original chain as well as the spline is obtained.

When the Intent Manager is on, the splines are created using the Create spline curve
through several points. button from the Right Toolchest.

Creating Text Using the Text Option
You can use the Text option to enter text in your sketch. The following steps explain the
procedure to create text in the sketch:

1. Choose SKETCHER > Sketch > Adv Geometry > Text. The Message Input Window
appears in the Message area.

2. Enter text in the Message Input Window and press ENTER or choose the green check
mark button on the window. You will be prompted to specify a box on the graphics screen
to place the text. Specify a point on the graphics screen from where you want the text to
start. A red rubber-band rectangle appears as you move the cursor from the point selected.
Move it to the desired position and press the left mouse button. The text entered in the
Message Input Window will be placed at this point on the graphics screen. The Message
Input Window will appear again to place the other desired text. Remember, you can enter
a maximum of 79 characters  in a line.

3. Repeat step 2 until you write the required text for your sketch. To end text insertion, press
ENTER or select the green button. Now, you have exited the Message Input Window. If
you want to abort text placement, press the middle mouse button.

4. The text has to be dimensioned with reference to the sketch.

Note
By default, the font used in the text is font 3d. You can also modify the text by choosing Modify
from the SKETCHER menu and selecting the text using the left mouse button. The different
options to modify the text will be discussed in the next section of this chapter.

When the Intent Manager is on, you can choose the Create text as a part of a section.
button to create text. When you choose this button, the system prompts you to select a
start point to determine the text height. Using the left mouse button, specify the height

of the text by drawing a line. The Text dialog box is displayed. The default font of the text is
font 3d. You can change the font by using the Text dialog box.
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The Blend Vertex option is used to create blended features having unequal number of segments
in their sections. This option is discussed in detail in Chapter 7.

MODIFYING THE TEXT
The text that was written using the Text option can be modified and
edited. To modify a text, choose SKETCHER > Modify from the
Menu Manager and then select the text to modify. When you select
a text to modify, the text changes to red color and the MOD SEC
TEXT submenu is displayed as shown in Figure 2-17. The options
in this submenu are discussed next.

Text Line
When you choose the Text Line option, the Message
Input Window is displayed containing the text selected to
modify. In this window you can change the text string or
can edit it. After editing the text choose the green button
on the window or press ENTER.

Text Style
When you choose the Text Style option, the Sketcher Text
Style dialog box is displayed as shown in Figure 2-18. In
the Font drop-down list there are various fonts available
to choose from. The default font is font 3D. The different
edit boxes available in this dialog box are used to change
the properties of the text. After modifying the value in the
edit box, choose the Apply button to reflect the
modifications on the selected text.

SEC TOOLS
The Sec Tools (Section Tools) option is used to perform the operations
such as place a section, set sketcher environment options, toggle a section,
and so on. When you choose SKETCHER > Sec Tools, the SEC TOOLS
submenu is displayed. The options under the SEC TOOLS submenu are
shown in Figure 2-19. Some of these options are discussed next.

Copy Draw
The Copy Draw option copies the draft entities sketched in the Drawing
mode of Pro/ENGINEER to the current sketch. When you choose this
option, the Open dialog box is displayed. Select the drawing file from
where you want to copy the draft entities. The selected drawing is opened
in a sub-window. If no entity exists on the graphics screen of the current sketch window, the
SCALE submenu is displayed that is used to select the options for modifying the size of the
draft entities. After setting the size option, you will be prompted to select the entities to copy

Figure 2-17  MOD SEC
TEXT submenu

Figure 2-18  Sketcher Text Style
dialog box

Figure 2-19  SEC
TOOLS submenu
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from the sub-window. After selecting the entities, choose Done Sel from the GET SELECT
menu. If there are no entities in the current file, the section will be automatically placed in the
current file. However, if some entity exists on the graphics screen then you need to specify the
rotating angle and scale factor. The cursor is attached to the section after you specify the scale
factor. To place a section or an entity use the left mouse button.

When the Intent Manager is on, the draft entities from a drawing file can be copied by choosing
Sketch > Data from File from the menu bar.

Place Section
The Place Section option places a section saved in a sketch file (.sec) in the same working
directory or in a different directory. This option saves time in drawing the same or similar
section again.

When you choose this option the Open dialog box is displayed. Select the section you want to
place in the current sketch  from this dialog box. Choose the Open button to place the section.
If there are no entities in the sketcher environment, the selected sketch will be automatically
placed. If there are some entities, the sketch will be opened in a sub-window. The procedure to
place a section using this option is the same as discussed in the Copy Draw option.

The section copied using the Place Section option in the current sketch is an independent
copy. The copied section is no longer associated with the source section. The units, dimensions,
grid parameters, and the accuracy is acquired from the current sketch.

Sec Environ
The display of vertices of the section, the display of dimensions, and the display of constraints
can be turned on or off from the SEC ENVIRON submenu. This submenu is displayed when
you choose the Sec Environ option from the SEC TOOLS submenu. The accuracy of the
sketch, the number of decimal places dimensions will have, and the grid parameters can be set
from this submenu.

REGENERATION FAILED
As mentioned earlier, if the Intent Manager is off you need to regenerate the sketch after you
finish sketching. This is done because you need to check whether the design you have made is
correct and satisfies all constraints. Sometimes, the sketch may not regenerate successfully.
Some of the reasons for the sketch to not regenerate in the sketch mode are listed below.

1. The section is not fully dimensioned.

2. The section is overdimensioned. In this case, you are prompted to delete a dimension or
dimensions that appear in red. After deleting the extra dimensions you need to regenerate
the sketch again for successful regeneration.

3. Incompatible dimension values. This message is displayed when the dimensions assigned
are incompatible with the geometry of the sketch.
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SECTION FAIL submenu is displayed as shown in Figure 2-20. This
submenu is displayed as soon as you regenerate the sketch. The
options available under this submenu are discussed next.

RestoreDim
The RestoreDim option is selected when you want to restore the
original dimension values individually. As you select the dimensions
to restore, the selected dimension value is changed to the value that
was before regeneration.

RestoreAll
The RestoreAll option restores the state of the section sketch that was
before regeneration. When this option is selected, all the dimensions in the section sketch are
restored to their original values that were before regeneration.

RESOLVE SKETCH DIALOG BOX
When the Intent Manager is on, while applying
constraints or dimensions, the system may
sometimes prompt you to delete one or more
than one highlighted dimensions or
constraints. This is because while adding
dimensions or constraints some strong
dimensions or constraints conflict with the
added dimensions or constraint. As soon as the
conflict occurs the Resolve Sketch dialog box
is displayed as shown in Figure 2-21 and the
constraint or the dimension under conflict are
displayed in red. When you select a dimension
or constraint from the Resolve Sketch dialog
box, the dimension or constraint selected is
enclosed in a yellow box. The buttons available
in the Resolve Sketch dialog box are discussed
next.

Undo
When you choose the Undo button, the section is brought back to the state that was just before
the conflict occurred.

Delete
The Delete button is used to delete a selected dimension or constraint that is enclosed within
a yellow box. Select the highlighted dimension or the constraint to delete using the left mouse
button.

Figure 2-21  Resolve Sketch dialog box

Figure 2-20  The
SECTION FAIL menu
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Dim > Ref
When you choose the Dim > Ref button, the selected dimension is converted to a reference
dimension.

Explain
When you choose the Explain button, the system provides you with information about the
selected constraint or dimension. The information is displayed in the Message Area.

TUTORIALS

In this Tutorial you will place an existing sketch that you had drawn in Tutorial 3 of
Chapter 1. After placing the sketch, draw the keyway as shown in Figure 2-22. Do not use the
Intent Manager in this tutorial.    (Expected time: 15 min)

The following steps outline the procedure for completing this tutorial.

a. Start Pro/ENGINEER.

b. Set the working directory and create a new object file.

c. Exit the Intent Manager and place the section by using the Place Section option.

d. Draw the keyway and dimension it.

e. Modify the dimensions.

f. Regenerate the sketch and then save the sketch.

Tutorial 1

Figure 2-22  Sketch for Tutorial 1



Editing in the Sketch Mode                 2-21

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
. 

F
. 

F
. 

F
. 

F
. 

F o
r 

e
n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r v
ic

e
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

vi
ce

s,
 c

o
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
vi

ce
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

vi
ce

s,
 c

o
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
vi

ce
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
mStarting Pro/ENGINEER

1. Start Pro/ENGINEER by double-clicking on the Pro/ENGINEER icon on the desktop of
your computer or by using the Start menu.

Setting the Working Directory
When Pro/ENGINEER session is started, the first task is to set the working directory. As
mentioned earlier, working directory is a directory on your system where you can save the
work done in the current session of Pro/ENGINEER. You can set any directory existing on
your system as the working directory. Since this is the first tutorial of this chapter, you need to
create a folder named c02 in C:\ProE folder, if it does not exist.

1. Choose the Set Working Directory option from the File menu. The Select Working
Directory dialog box is displayed.

2. Browse and select C:\ProE.

3. Choose the New Directory button in the Select Working Directory dialog box.
The New Directory dialog box is displayed.

4. Type c02 in the New Directory edit box. Choose OK from the dialog box. You have
created a folder named c02 at C:\ProE.

5. Choose OK from the Select Working Directory dialog box. You have set the working
directory to C:\ProE\c02.

Creating New Object File
1. Choose the Create a new object button from the File toolbar. The New dialog box

is displayed. Select the Sketch radio button from the Type area of the New dialog box. A
default name of the sketch appears in the Name edit box.

2. Enter c02tut1 in the Name edit box. Choose the OK button.

You will enter the sketcher environment of the Sketch mode. When you enter the sketcher
environment, the Intent Manager is on by default. This is evident from the buttons available
on the Right Toolchest. You can reconfirm this from the check mark that is displayed on
the left of the Intent Manager option in the Sketch menu in the menu bar. Since you need
to complete this tutorial without the Intent Manager, you need to exit it.

3. To exit the Intent Manager, choose Sketch > Intent Manager from the menu bar to clear
the check mark. The Right Toolchest is no more displayed and the Menu Manager is
displayed on the right of the window. The Menu Manager contains all the sketcher options.

Placing the Section
1. Choose the Sec Tools option from the SKETCHER menu in the Menu Manager. The

SEC TOOLS submenu is displayed.
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2. Choose the Place Section option from this submenu. The Open dialog box is displayed
with the working directory as the current directory.

3. Choose the Up One Level button and then open the c01 directory. Select c01tut3-1.sec
and choose the Open button from the Open dialog box.

The sketch will be placed on the graphics screen as shown in Figure 2-23.

Drawing the Keyway
To create the keyway, you will sketch the keyway and then intersect the circle and the horizontal
lines of the keyway so that the portion of the circle that lies between the horizontal lines can be
removed.

1. Choose Sketch > Line from the SKETCHER menu in the Menu Manager. The LINE
TYPE submenu is displayed.

2. Select the Horizontal option from the LINE TYPE submenu and draw the keyway as
shown in Figure 2-24.

3. Choose the Geom Tools option from the SKETCHER menu in the Menu Manager. The
GEOM TOOLS submenu is displayed.

4. Choose the Trim option from this submenu. The DRAFT TRIM submenu is displayed.

5. Choose the Bound option from this submenu. You are prompted to select the bounding
entity.

6. Select the circle as the boundary. The circle turns red in color. Select the top horizontal
line of the keyway and then select the bottom horizontal line of the keyway. This is done to
make sure that the lines touch the circle.

Figure 2-23  Sketched placed in the current file
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m7. Choose the Geom Tools option from the SKETCHER menu in the Menu Manager. The

GEOM TOOLS submenu is displayed.

8. Choose the Intersect option from this submenu.

9. Select the circle close to the top horizontal line of the keyway and then select the top
horizontal line of the keyway. Similarly, select the circle close to the bottom horizontal line
and then select the bottom horizontal line of the keyway.

The lines and the circle intersect at the points where the lines meet the circle. The
intersection points are displayed in yellow color. The portion of the circle that lies between
the two horizontal lines of the keyway is separated from the circle.

10. Choose the Delete option from the SKETCHER menu and delete the part of the circle
that lies between the two intersection points.

Dimensioning the Keyway
The dimensions that will be applied to the keyway are shown in Figure 2-22.

1. Choose the Dimension option from the SKETCHER menu in the Menu Manager. The
DIMENSION submenu is displayed. The Normal option is chosen by default.

2. Dimension the keyway as shown in Figure 2-25.

Modifying the Dimensions
The dimensions of the keyway will be modified to the given dimension values.

1. Choose the Modify option from the SKETCHER menu in the Menu Manager. The MOD
SKETCH submenu is displayed and the Mod Entity option is selected by default.

2. Modify the dimensions of the keyway. For dimension values refer to Figure 2-22.

Figure 2-25  Sketch after dimensioning the
keyway

Figure 2-24  Sketch of the keyway
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Regenerating the Sketch
You need to regenerate the sketch because
the sketch is completed only when
Pro/ENGINEER accepts the sketch. If the
sketch drawn is complete and fully
dimensioned, and you choose the
Regenerate option from the SKETCHER
menu, the Section regenerated successfully.
message is displayed in the Message Area.

1. Choose the Regenerate option from the
SKETCHER menu in the Menu
Manager to regenerate the sketch. The
sketch after regeneration is shown in
Figure 2-26.

Saving the Sketch
You have to save the sketch because you may need the sketch later.

1. Choose the Save the active object button from the File toolbar. The Message Input Window
is displayed with the name of the sketch that you had entered earlier.

2. Press ENTER or choose the check mark button on the window. The sketch is saved.

3. Choose the Done option from the SKETCHER menu in the Menu Manager to exit the
Sketch mode.

Draw the sketch shown in Figure 2-27 using the Intent Manager.    (Expected time: 30 min)

Tutorial 2

Figure 2-26  Sketch after regeneration

Figure 2-27  Sketch for Tutorial 3
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mThe following steps outline the procedure for creating this sketch using the Intent Manager:

a. Set the working directory and create a new object file.

b. Draw the sketch using sketcher tool buttons.

c. Apply the required constraints and dimensions to the entities in the sketch.

d. Modify the dimensions of the sketch and then save the sketch.

Setting the Working Directory
The working directory was selected in Tutorial 1, therefore there is no need to select the
working directory again. But if you still want to select the working directory, choose the Set
Working Directory option from the File menu. The Select Working Directory dialog box is
displayed. Set the working directory to C:\ProE\c02.

Creating New Object File
1. Open a new object file in the Sketch mode. Name the file as c02tut2.

Drawing the Sketch
To draw the outer loop, you need to draw three circles and then draw lines tangent to the three
circles.

1. Choose the Create circle by picking the center and a point on the circle. button.
Draw the three circles as shown in Figure 2-28.

2. Choose the Create lines. button from the Right Toolchest. Draw the lines
connecting the three circles as shown in Figure 2-29. Later you will apply the
tangent constraint on these lines.

Figure 2-29  Lines joining the three circles
with weak dimensions

Figure 2-28  Three circles with weak dimensions
and constraints
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Applying Constraints
The lines in the sketch are tangent to the circles, therefore you need to apply the tangent
constraint to the lines and the circles.

1. Choose the Impose sketcher constraints on the section. button from the Right
Toolchest. The Constraints dialog box is displayed.

2. Choose the Make two entities tangent button from the Constraints dialog box.

3. Select the top left line and the left circle. You will notice that the tangent constraint symbol
T is applied. This indicates that the selected line is tangent to the selected circle. Similarly,
one by one select all the circles and lines to make them tangent. Figure 2-30 shows the
sketch after the tangent constraint is applied.

Trimming the Circles
The inner portions of the circles are not required. Therefore, you need to trim them.

1. Choose the Dynamically trim section entities. button from the Right Toolchest.

2. Bring the cursor close to the right portion of the left circle. The right part of the circle
turns magenta in color. Select the right portion of the circle using the left mouse button to
remove it.

3. Similarly, trim the part of the middle circle and the right circle. The sketch after trimming
the circles is shown in Figure 2-31.

Drawing the Circles
1. Choose the black arrow on the right of the Create circle by picking the center

and a point on the circle. button to display the flyout. From this flyout, choose
the Create concentric circle. button. You will be prompted to select an arc.

2. Using the left mouse button, select the left arc. You will notice that when you move the

Figure 2-31  Sketch after trimming the circlesFigure 2-30  Sketch with tangent constraints
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mmouse, a circle appears. Select a point inside the sketch to complete the circle. Press the

middle mouse button.

3. Using the left mouse button, select the top arc. You will notice that when you move the
mouse a circle appears. Select a point inside the sketch to complete the circle. Press the
middle mouse button to end circle creation.

4. Using the left mouse button, select the right arc. You will notice that when you move the
mouse a circle appears. When R2 symbol appears on the circle, use the left mouse button
to complete the circle. Press the middle mouse button to end circle creation.

The R2 symbol appears on both the left and the right circle indicating that their radius is
same. The constraint symbols like R1 or R2 varies from sketch to sketch.

Applying the Equal Radii Constraint
1. Choose the Impose sketcher constraints on the section. button from the Right

Toolchest. The Constraints dialog box is displayed.

2. Choose the Create Equal Lengths, Equal Radii, or Same Curvature constraint
button from the Constraints dialog box.

3. Select the left arc and then select the right arc to apply the equal radius constraint.

4. Select the left circle and the right circle to apply the equal radius constraint.

5. Use the CTRL+left mouse button to zoom in and now select the top arc and the bottom
arc to apply the equal radius constraint. If the constraint is already applied, the Resolve
Sketch dialog box is displayed. Choose the Undo button from this dialog box.

Dimensioning the Sketch
1. Choose Create defining dimensions. button from the Right Toolchest.

2. Select the center of right and left circles. The center of the circles turns red in color. Now,
using the middle mouse button, place the dimension below the sketch.

Modifying the Dimensions
All the constraints and dimensions are applied to the sketch and now dimensions will be
modified.

1. Select all the dimensions using CTRL+ALT+A.

2. Choose the Modify the values of dimensions, geometry of splines, or text
entities. button. The Modify Dimensions dialog box is displayed.

3. Clear the Regenerate check box and then modify the values of the dimensions. When you
clear the check box, the sketch does not regenerate as you modify the dimensions.
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The dimension that you edit in the
Modify Dimensions dialog box is
enclosed in a yellow box in the sketch.

4. Modify all the dimensions. Refer to
Figure 2-27 or Figure 2-32 for dimension
values.

5. After all the dimensions are
modified, choose the
Regenerate the section and
close the dialog button from the
Modify Dimensions dialog box. The
message Dimension modifications
successfully completed. is displayed in
the Message Area.

Saving the Sketch
1. Choose the Save the active object button from the File toolbar and save the sketch.

Exiting the Sketch Mode
1. Choose the Continue with the current section. button and exit the Sketch mode.

Draw the sketch shown in Figure 2-33 without using the Intent Manager.
   (Expected time: 30 min)

Figure 2-32  The required sketch with constraints
and dimensions

Tutorial 3

Figure 2-33  Sketch for Tutorial 3
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mThe following steps outline the procedure for creating this sketch without using the Intent

Manager:

a. Set the working directory and create a new object file.

b. Exit the Intent Manager and draw the sketch using sketcher options.

c. Autodimension the sketch.

d. Modify dimensions of the sketch and regenerate the sketch.

Setting the Working Directory
The working directory was selected in Tutorial 1, therefore there is no need to select the
working directory again. But if you still want to select the working directory, choose the Set
Working Directory option from the File menu. The Select Working Directory dialog box is
displayed. Set the working directory to C:\ProE\c02.

Creating New Object File
1. Open a new object file in the Sketch mode. Name the file as c02tut3.

2. Exit the Intent Manager by choosing the Intent Manager option from the Sketch menu
in the menu bar.

The Right Toolchest is no more displayed and the Menu Manager is displayed.

Drawing a Rectangle
1. Choose the Rectangle option from the GEOMETRY submenu in the Menu Manager.

Draw a rectangle as shown in Figure 2-34.

Dividing the Line
The rectangle drawn will be divided at two points on the top horizontal line. As mentioned
earlier, when an entity is divided, it is converted into separate entities.

1. Choose the Geom Tools option from the SKETCHER menu in the Menu Manager. The
GEOM TOOLS submenu is displayed.

2. Choose the Divide option from the GEOM TOOLS submenu. You are prompted to select
an entity to divide.

3. Select points on the top line as shown in Figure 2-34 to divide.

Deleting the Line
The line that is divided is now converted into three separate entities.

1. Choose SKETCHER > Delete from the Menu Manager. Select the line between the two
division points to delete the line segment as shown in Figure 2-35.
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Drawing the Upper Portion of the Sketch
The bottom portion of the sketch is drawn and now the top portion will be drawn. The top
portion of the sketch consists of two vertical lines, a tangent arc, and a concentric circle.

1. Choose SKETCHER > Sketch > Line > Geometry > Vertical from the Menu Manager.

Draw two vertical lines starting from the points where the line was divided as shown in
Figure 2-36.

2. Choose the Arc option from the GEOMETRY submenu. The ARC TYPE submenu is
displayed.

The Tangent End option is selected by default in the ARC TYPE submenu.

3. Select the endpoint of the left vertical line as the start point of the arc. Complete the arc at
the endpoint of the right vertical line.

4. Choose the Circle option from the GEOMETRY submenu in the Menu Manager. The
CIRCLE TYPE submenu is displayed. Choose the Concentric option. You will be prompted
to select an arc to which the circle to be drawn will be concentric.

5. Select the arc using the left mouse button. Now, using the left mouse button specify a
point on the graphics screen. A red rubber-band circle appears. Size the circle by moving
the cursor and use the left mouse button to complete it.

Note
Pro/ENGINEER does not have options like midpoint, endpoint, or center of. However if you
draw a sketch using the Intent Manager, these options in the form of weak constraints are
applied as you sketch. For example, endpoint of any entity snaps the cursor when a new entity is
to be drawn. The middle point constraint appears when you approximately bring the cursor near
to the middle point of the line to draw a line.

Figure 2-35  The part of the line to be deletedFigure 2-34  Points to be selected to divide
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1. Choose SKETCHER > Sketch > Arc > Fillet from the Menu Manager. You will be
prompted to select the two entities to fillet. The corners that you need to fillet are shown
in Figure 2-37.

2. Select the two entities one by one using the left mouse button. The corner of the selected
lines will be filleted. Fillet all the required corners shown in Figure 2-37.

The sketch after filleting is shown in Figure 2-38.

Autodimensioning the Sketch
When a sketch is autodimensioned, Pro/ENGINEER assigns some default dimension values to
the sketch. You can then modify these dimension values.

1. Choose the AutoDim option from the SKETCHER menu in the Menu Manager.

When you use the AutoDim option, the sketch is automatically regenerated and strong
constraints and dimensions are applied to the sketch, see Figure 2-39. Retain only the
dimensions shown in Figure 2-33 and delete the remaining dimensions. If some of the

Figure 2-39  Sketch after autodimensioningFigure 2-38  Sketch after filleting the corners

Figure 2-37  Fillet cornersFigure 2-36  Lines drawn using the Vertical option
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dimensions shown in Figure 2-33 are not displayed, create them manually by using the
Dimension option from the SKETCHER menu in the Menu Manager.

Modifying the Dimensions
1. Choose SKETCHER > Modify > Mod Entity from the Menu Manager. Select the

dimension to modify using the left mouse button. The selected dimension changes to red
color and the Message Input Window is displayed in the Message Area.

2. Enter the required dimension in this window. Similarly, modify all the dimensions as
required. See Figure 2-33 for dimension values.

Regenerating the Sketch
1. Choose the Regenerate option from the

SKETCHER menu in the Menu
Manager. The sketch is regenerated
successfully, see Figure 2-40.

Saving the Sketch
1. Choose the Save the active object button

from the File toolbar and save the sketch.

Exiting the Sketch Mode
1. Choose the Done option from the SKETCHER menu from the Menu Manager to exit the

Sketch mode.

Answer the following questions and then compare your answers to the answers given at
the end of this chapter.

1. The variable dimension created using the Perimeter option can be modified directly by
selecting it using the left mouse button. (T/F)

2. If the variable dimension is deleted then the perimeter dimension is also deleted. (T/F)

3. When you modify a weak dimension it becomes strong. (T/F)

4. You can dimension the length of a center line. (T/F)

Figure 2-40  Sketch after regeneration

Tip: In Figure 2-39 the dimensions are moved so that the clarity of the sketch is
improved. You can move the dimensions by choosing the Geom Tools option from the
SKETCHER menu and from the GEOM TOOLS submenu that appears, choose the
Move Entity option. You are prompted to select an entity. Select the dimension text,
the selected dimension turns red in color. Now, move the cursor and using the left
mouse button, place the dimension at the desired location on the graphics screen.

Self-Evaluation Test
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6. The splines created by using the __________ option can be dimensioned to the coordinate
system.

7. When you are using the Intent Manager, the __________ dialog box is used to modify
dimensions.

8. The display of dimensions and constraints can be turned on/off by choosing the __________
and __________ button respectively from the Sketcher toolbar.

9. The __________ button is used to rotate selected entities when the Intent Manager is on.

10. When the Intent Manager is on, you can delete the entities by selecting them and then
using the __________ key.

Answer the following questions:

1. Which of the following symbol represents the normal dimension in the Sketch mode?

(a) d (b) sd
(c) ref (d) kd

2. Using which submenu the display of vertices of the section, the display of dimensions,
and display of constraints can be made off or on?

(a) DIMENSION (b) SEC ENVIRON
(c) MOD SPLINE (d) GEOMETRY

3. When the Intent Manager is off, a sketch is modified by using the __________ submenu?

(a) GEOM TOOLS (b) GEOMETRY
(c) MOD SKETCH (d) None

4. Which of the following submenu has the Intersect option?

(a) GEOMETRY (b) DIMENSION
(c) MOD SKETCH (d) GEOM TOOLS

5. Which type of dimensioning uses relations?

(a) Normal (b) Perimeter
(c) Baseline (d) Known

Review Questions
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Exercises

Exercise 1

6. While placing a section in a new sketch, use the right mouse button to place the section.
(T/F)

7. There is only one method to  make the grids on or off, that is, using the Sketcher toolbar
button. (T/F)

8. The reference dimensions appear with the suffix REF. (T/F)

9. While using the Intent Manager, you can modify the dimensions dynamically. (T/F)

10. The modification of a spline is possible by using the Move Points and Control Poly options
of the MOD SPLINE menu. (T/F)

Create the sketch shown in Figure 2-41 and dimension it. Draw the sketch using the Intent
Manager.    (Expected time: 30 min)

Draw the sketch shown in Figure 2-42. Use the AutoDim option for dimensioning the sketch.
   (Expected time: 15 min)

Figure 2-41  Sketch for Exercise 1

Exercise 2
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Figure 2-42  Sketch for Exercise 2

Figure 2-43  Sketch for Exercise 3

Exercise 3
Draw the sketch shown in Figure 2-43. Use the AutoDim option to dimension the sketch.

   (Expected time: 30 min)

Answers to the Self-Evaluation Test
1 - F, 2 - T, 3 - T, 4 - F, 5 - F, 6 - Control Poly, 7 - Modify Dimensions, 8 - Toggle display of
dimensions on/off, Toggle display of constraints on/off, 9 - Scale and rotate selected entities,
10 - DELETE.


