
Chapter 8

Advanced Modeling
Tools-II

After completing this chapter you will be able to:

• Use different Advanced options for creating complex models.
• Create features using Var Sec Swp option.
• Create features using Swept Blend option.
• Create features using Helical Sweep option.
• Create features using Sect to Srfs option.
• Create features using Srfs to Srfs option.
• Create features using From File option.
• Use Relations.

Learning Objectives
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ADVANCED FEATURE OPTION
Pro/ENGINEER facilitates its users with some advanced
options to create complex features with greater ease. All
these options are available in the ADV FEAT OPT
submenu. The ADV FEAT OPT submenu is displayed
when you choose PART > Feature > Create > Solid >
Protrusion > Solid > Advanced > Solid > Done from
the Menu Manager. The options in the ADV FEAT OPT
submenu are also displayed when you choose Insert >
Protrusion from the menu bar.

Figure 8-1 shows you the different options available in
this submenu.

Var Sec Swp Option
The Var Sec Swp (Variable Section Sweep) option is used to create a sweep feature in which the
section of the sweep feature varies according to the trajectories. This feature is created using
more than one trajectory and the section that will be swept along the origin trajectory and the
variation of the section is controlled by the X-trajectory,
and other trajectories. You can sketch the sweep
trajectory using different sketcher tools. You can also
select a previously created longitudinal entity as the
trajectory for sweep. The Var Sec Swp option is
available for both protrusion and cut options. Choose
the Var Sec Swp option from the ADV FEAT OPT
submenu or choose Insert > Protrusion > Variable
Section Sweep from the menu bar; the SWEEP OPTS
submenu is displayed as shown in Figure 8-2.

NrmToOriginTraj option
The NrmToOriginTraj (Normal To Origin Trajectory) option is used to create a variational
section sweep feature in which the swept section is normal to the origin trajectory and the
variation in the section is controlled by the X-trajectory, and other trajectories. When you use
this option, you need to select or sketch an origin trajectory, an X-trajectory, and
other trajectories if required.

The following points should be remembered while creating a feature using the
NrmToOriginTraj option.

1. You should define the origin trajectory that is normal to the section.

2. After creating the origin trajectory you have to create an X-trajectory that defines the
horizontal vector of the section.

3. You can also define the additional trajectories to facilitate the creation of a complex profile.

Figure 8-1  ADV FEAT OPT menu

Figure 8-2  SWEEP OPTS submenu
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m4. When you draw the section for the variational section sweep feature, the section should be

aligned to the endpoints of the X-trajectory and the
other trajectories. If the section is not aligned then the
feature will be created without following the trajectory
path and will be similar to a feature created using the
Sweep option.

When you choose the Done option from the SWEEP OPTS
submenu the VAR SEC SWP menu is displayed as shown
in Figure 8-3. Using this menu you can select a trajectory
or you can sketch a trajectory. The selected or sketched
trajectory other than the origin trajectory, and the
X-trajectory can be deleted using the Remove Traj option
from the VAR SEC SWP menu.

Figure 8-4 shows the origin trajectory and the X trajectory. The two trajectories are used to
create the sweep feature shown in Figure 8-5. Now, in Figure 8-6, the X trajectory and the
origin trajectory are interchanged and the sweep feature that is obtained is shown in Figure 8-7.

Note the difference in the swept features. In Figure 8-5, the section is normal to the selected
origin trajectory and when the curve is selected as the origin trajectory, the section is normal
to it as shown in Figure 8-7.

Pivot Dir option
The Pivot Dir (Pivot Direction) option is used to create a variable section sweep in which the
section to be swept is normal to the selected plane, edge, curve, or axis. You are required to
select or create a plane, an edge, a curve, or an axis to define the pivot direction, an origin
trajectory, a section, and other trajectories if required. Figure 8-8 shows the origin trajectory
and the pivot plane to which the section will be perpendicular. Figure 8-9 shows the
corresponding swept feature.

Figure 8-5  Variable section sweep featureFigure 8-4  The two trajectories

Figure 8-3  VAR SEC SWP menu
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Norm To Traj option
When you use the Norm To Trj (Normal To Trajectory) option to create the variable sweep,
you have to define an origin trajectory, a normal trajectory, a section, and other trajectories if
required. The section is perpendicular to the normal trajectory and is swept along the origin
trajectory. Figure 8-10 shows the two trajectories that are used to create the swept feature
shown in Figure 8-11.

Swept Blend
The  Swept Blend feature is a combination of sweep and blend. To create a sweep feature you
need a trajectory along which the section is swept. You have an option of sketching or selecting
a previously created feature as the trajectory of the sweep. To create a parallel blend you need
to have more than one section to be blended. The combination of both these options is the
Swept Blend option.

In this option you can blend two or more than two sections having same number of entities
and the path of the transition of blending is defined by selecting or sketching a trajectory. You

Figure 8-9  Swept feature on the base featureFigure 8-8  Origin trajectory and the pivot plane

Figure 8-7  Resultant variable section sweep featureFigure 8-6  The two trajectories and section



Advanced Modeling Tools-II        8-5

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
. 

F
. 

F
. 

F
. 

F
. 

F o
r 

e
n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r v
ic

e
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

vi
ce

s,
 c

o
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
vi

ce
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

vi
ce

s,
 c

o
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
vi

ce
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

Figure 8-11  Resultant swept featureFigure 8-10  Trajectories and section

can invoke the  SWEPT BLEND option from the Menu
Manager or from the menu bar.

Choose Insert > Protrusion > Swept Blend from the
menu bar; the BLEND OPTS submenu is displayed.
From the Menu Manager, choose PART > Feature >
Create > Solid > Protrusion > Advanced > Solid >
Done. The ADV FEAT OPT submenu is displayed.
Choose the Swept Blend option and choose Done. The
BLEND OPTS submenu is displayed as shown in
Figure 8-12.

Figure 8-13 shows the three rectangular sections. The three sections are connected through a
trajectory by connecting their vertices. The shaded view of the model is shown in Figure 8-14.
The model is also shelled.

Figure 8-12  BLEND OPTS submenu

Figure 8-14  Shaded view of the featureFigure 8-13  Three sections in swept blend
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Helical Sweep
The Helical Sweep option is used to  create helical swept features.
You have to define a trajectory that will revolve along an axis, a
pitch value, and a cross-section to create a helical feature using
this option. The distance of the trajectory from the center line
defines the radius of the helical path and the length of the
trajectory defines the length of the swept feature. The main use
of this option is to create the helical springs and threads.

When you choose the Helical Sweep option from the Insert menu
in the menu bar or when you choose the Helical Swp option
from the ADV FEAT OPT submenu and choose Done, the
ATTRIBUTES menu is displayed as shown in Figure 8-15. The
options in this menu are discussed next. Figure 8-16 shows the
parameters to be defined for the helical sweep and Figure 8-17
shows the resultant helical sweep feature.

Constant
The Constant option is used to create a helical feature with constant pitch as shown in
Figure 8-18.

Variable
The Variable option is used to create a helical feature of varying pitch. While using this option
you have to define the start pitch and the end pitch, you can also define a pitch between the
start and the end point of the helix. The helical sweep feature with variable pitch is shown in
Figure 8-19.

Figure 8-15  ATTRIBUTES
menu

Figure 8-17  The resultant helical featureFigure 8-16  Sweep trajectory, sweep section, and
axis of rotation to create a helical feature
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Thru Axis
The Thru Axis option is used to create a helical feature around a axis.

Norm To Traj
The Norm To Traj option is used to create a helical feature perpendicular to the sketched
trajectory.

Right Handed
The Right Handed option is used to create a helical feature in which the section is swept in the
counterclockwise direction from the start sketch.

Left Handed
The Left Handed option is used to create a helical feature in which the section is swept in the
clockwise direction from the start sketch.

Sect to Srfs or Blend Section to Surfaces
The Sect to Srfs (Section to Surface) option is used to blend a selected set of tangential
surfaces with a sketched contour. You can invoke this options by choosing PART > Feature >
Create > Solid > Protrusion > Advanced > Solid > Done. The contour sketched to create
the feature using this option must be closed. This option can be used to create surface or a
solid feature. Figure 8-20 shows the section to be blended with the selected set of tangential
surfaces and Figure 8-21 shows the resultant blended feature.

Srfs to Srfs or Blend Between Surfaces
The Srfs to Srfs (Surface to Surface) option is used to create a blending between two curved
quilts, two curved solid surfaces, or the combination of the both. The curved surfaces may be
revolved features or spheres. You can invoke this option by choosing PART > Feature >
Create > Solid > Protrusion > Advanced > Solid > Done.  Figures 8-22 and 8-24 show the
two curved surfaces to be blended and Figures 8-23 and 80-25 show the resultant blended
feature using this option.

Figure 8-19  Helical sweep feature with variable
pitch

Figure 8-18  Helical sweep feature with constant
pitch
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Figure 8-20  Highlighted set of tangential
surfaces and the contour sketch.

Figure 8-21  Feature created using the Sect to
Srfs option

Figure 8-23  Feature created using the Srfs to
Srfs option

Figure 8-22  Two spheres to be blended

Figure 8-25  Feature created using the Srfs to
Srfs option

Figure 8-24  Two curved features to be blended
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The From File option in the ADV FEAT OPT submenu reads the data points from an ASCII
file for the creation of a blended feature. The type of blend and the cartesian coordinates of all
the points are defined by the data file while using this option. A single coordinate system is
used to locate the different blend points. You must import the data points for the curves
before creating the blended feature as the data points for the curves ensure the smoothness of
the blend created.

USING RELATIONS
Relations are user-defined equations that relate the dimension symbols or values. This option
is used to create relations between various dimensions of a model and to keep the design
intent of a model. For example, if it is required that the centre of the circle should lie at a
distance of 1/3 from the vertex of a triangle, then it can be achieved using the relations.
Relations can also be used to control the effect of modification on a model.

When you choose the PART > Relations from the Menu
Manager, the RELATIONS submenu is displayed as
shown in Figure 8-26.

Relations applied to a sketch can be modified and used
in the part or assembly mode also. In the Sketch mode,
the RELATIONS submenu can be invoked by choosing
Sketch > Relations from the menu bar. Relations are of
two types and are discussed next.

Equality Relations
The Equality relations are used to assign a value to a
parameter or to a symbolic dimension. The variable on
left of the equation is called driven and the variable on
right of the equation is called driver. Another way of
representing this is

driven=driver

For example,

d1=25
d2=d1+10
d5=d3*sin(d4)

In the above equations, symbol d represents the dimension created in the Part mode. Dimensions
in the Sketch mode are represented by symbol sd, where s represents the Sketch mode and d
the dimension.

In all of the above equations the expression on the right hand side of the equation determine
the value of the variable on the left.

Figure 8-26  RELATIONS submenu
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Comparison Relations
The Comparison relation compares the two sides of the equation. This type of relations are
used in two ways: by giving conditional statements or by defining constrains.

For example,

As conditional statements
If sd1>=10
sd2=20
else
sd2=30

As a constraint
sd1+sd2>sd3+10
sd3>sd2/2

Note
The assignment operator ‘=’ assigns a value to the driven that is on the left of the equation,
whereas in case of the comparison operator the driven is compared with the driver and the value
is returned as True or False. Hence, the assignment operator ‘=’ (equal to) is different from the
comparison operator ‘=’ (equal to). The comparison operator ‘=’ is always used with ‘IF’, ‘>’,
or ‘<‘.

For example, sd1>=10

If sd1 is greater than or equal to 10 then the value returned is True and if sd1 is less than or
equal to 10 then the value returned is False.

If you use the IF condition in the Message Input Window while entering relations, then you
can exit the Message Input Window only when you type ENDIF in the window. This means
that the IF and ENDIF statements form a loop. In case you use the IF condition and press
ENTER, the Message Input Window will again appear to let you enter the next relation. This
will continue until you enter ENDIF in the window.

For example, IF sd1>=10
    sd2=20
ELSE
    sd2=30
ENDIF

Add
When you invoke the Add option of the RELATION submenu, you are prompted to enter the
relation in the message box. Remember to use the appropriate dimension symbols while giving
relations. The relations you enter are saved in rel.ptd file.

1. Choose RELATION from the SKETCHER menu. The dimensions are displayed in a
symbolic form.
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m2. Choose Add from the RELATIONS submenu. You will be prompted to enter the relation.

3. The relations are added using the sketcher dimension symbols or the known dimension
symbols. Press ENTER after adding all the relations. Regenerate the sketch. The changes
will appear in the sketch as per the relations added.

Note
When the Intent Manager is off, the relations are not evaluated by Pro/ENGINEER until you
regenerate the sketch.

Edit Rel
The Edit Rel (Edit Relations) option of the RELATIONS submenu allows you to edit the
relations you have entered or the relations associated with the current sketch.

When you choose this option, the rel.ptd file is opened in the system editor and you can edit
the relations there. If the relation contains an error you can rectify it. If before rectifying the
errors you close the notepad window, a message box prompts you if you want to leave the
relation as it is or if you want to correct it. If you choose YES, then the same file is again
opened and now you can make the corrections. You can also write new relations in this file in
lieu of using the Add option in the RELATIONS submenu.

The obsolete relations are not automatically deleted by Pro/ENGINEER but have to be
deleted manually. This can be done using the Edit Rel option. After you make changes to the
rel.ptd file and close it, you are prompted to save the changes you made to the file.

Note
Although you can add relations using the Edit Rel option but this method is not recommended,
the reason being that relations added using the Edit Rel option are not checked for errors
instantaneously.

Show Rel
You can view the relations of a sketch by choosing the Show Rel (Show Relations) option of the
RELATIONS submenu. When you choose this option, all the relations associated with the
current sketch are displayed with their values in the Information Window. This option behaves
different with different modes of Pro/ENGINEER.

Evaluate
The Evaluate option gives you the value of any dimensional symbol used in a relation. When
you choose this option in the RELATIONS submenu, the Message Input Window appears.
Enter in this window the dimensional symbol whose value you want to evaluate.

Sort Rel
The Sort Rel (Sort Relations) option of the RELATIONS submenu sorts the relations in an
order. The relations are ordered so that a relation that depends on the value of another relation
is evaluated after this relation.
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Tutorial 1

For example, consider relations

sd0=sd1+sd2*2
sd2=sd3 - 2*sd4

Now when you choose the Sort Rel option, the relation will be ordered as shown below.

sd2=sd3 - 2*sd4
sd0=sd1+sd2*2

Note
The conditional relations are not sorted using the Sort Rel option.

Switch Dim
The Switch Dim (Switch Dimensions) option of the RELATIONS submenu toggles between
the symbols and the value mode of the dimensions. You can choose this option to display the
dimensions as values or as symbols.

User Prog
The User Prog (User Program) option of the RELATIONS submenu allows you to link
a C program module with the sketch. When you choose this option the USER PROG
submenu displays three options: Edit, Link, and Run. Pro/ENGINEER provides a template C
file that helps you to read and use the C programming environment.

TUTORIALS

In this tutorial you will create the model shown in Figure 8-27. This figure also shows the
sectioned top, front, right-side, and isometric views of the model.       (Expected time: 45 min)

The following steps outline the procedure for creating this model:

a. First examine the model and then determine the number of features in it. The model is
composed of three features, see Figure 8-27.

b. The base feature is a swept feature with variable section, see Figure 8-34. First, the origin
trajectory will be sketched, see Figure 8-28, and then the X trajectory will be sketched, see
Figure 8-29. Two additional trajectories will be sketched that will sweep the section along
their paths, see Figure 8-30 and Figure 8-31. Then the section that will vary with the shape
of the trajectories will be sketched, see Figure 8-33.

c. The second feature is a round, see Figure 8-36.

d. The third feature is a shell of thickness 2, see Figure 8-38.
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After understanding the procedure for creating the model, you are now ready to create it.
When Pro/ENGINEER session is started, the first task is to set the working directory. Since this
is the first tutorial of this chapter, you need to create a directory named c08, if it does not exist.
Choose the New Directory button in the Select Working Directory dialog box and create a
directory named c08 at C:\ProE.

Creating New Object File
1. Open a new part file and name it c08tut1. The three default datum planes will be displayed

on the graphics screen. The Model Tree is also displayed on the graphics screen. Exit the
Model Tree by choosing the Model Tree on/off button from the Model Display toolbar.

Creating the Base Feature
To create the sketch for the base feature, you first need to select the sketching plane to draw
the origin trajectory. After selecting the sketching plane, draw the sketch for the origin trajectory
and dimension it. Then you need to select the sketching plane for the X trajectory, draw the
sketch for the X trajectory, and dimension it. The X trajectory defines the horizontal vector of
a section. If the section is aligned with the X trajectory, the section varies along the path of the
X trajectory. Similarly, two additional trajectories will be drawn to guide the section throughout
the sweep. To create the base feature, you need to draw the origin trajectory on the FRONT
datum plane.

Figure 8-27  Sectioned-top, front, right-side, and isometric views of the model
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1. Choose Insert > Protrusion > Variable Section Sweep from the menu bar.

You can also invoke the Variable Section Sweep option from the ADV FEAT OPT submenu
that is displayed when you choose PART > Feature > Create > Protrusion > Advanced
> Solid > Done from the Menu Manager. The Var Sec Swp option is selected by default
in the ADV FEAT OPT submenu. Choose Done.

The SWEEP OPTS submenu is displayed. The NrmToOriginTraj option is selected by
default. You will use this option because the transition of the sections is along the origin
trajectory and the section is normal to the origin trajectory.

2. Choose Done from the SWEEP OPTS submenu. The VAR SEC SWP menu is displayed
and you are prompted to specify the trajectory that defines the origin of the section.

3. Choose the Sketch Traj option from the VAR SEC SWP menu. You need to sketch the
origin trajectory. The SETUP PLANE submenu is displayed and you are prompted to
select the sketching plane.

4. Select the FRONT datum plane from the graphics screen. The DIRECTION submenu is
displayed. Choose Okay. The SKET VIEW submenu is displayed.

5. Select the Top option from this submenu and choose the TOP datum plane from the
graphics screen.

6. Once you enter the sketcher environment, create the sketch of the origin trajectory. The
origin trajectory is a straight line segment aligned to the RIGHT datum plane and the
start point is aligned to the TOP datum plane. The sketch of the origin trajectory is shown
in Figure 8-28.

Note
The start point of all the trajectories should be noted before exiting the sketcher environment for
each trajectory. In the sketcher environment, you can change the start point by selecting the
point where you want the start point. When the point turns red in color, press and hold down the
right mouse button to invoke the shortcut menu and choose the Start Point option from the
shortcut menu.

7. After the sketch is complete, choose the Continue with the current section. button to exit
the sketcher environment.

The VAR SEC SWP menu is displayed and you are prompted to specify the trajectory that
defines the section horizontal vector.

8. Choose the Sketch Traj option from the VAR SEC SWP menu. You need to sketch the
X- trajectory. The SETUP PLANE submenu is displayed and you are prompted to select
the sketching plane.

9. Select the FRONT datum plane from the graphics screen. The DIRECTION submenu is
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mdisplayed. Choose Okay. The SKET VIEW submenu is displayed.

10. Select the Top option from this submenu and choose the TOP datum plane from the
graphics screen.

11. Once you enter the sketcher environment, create the sketch of the of the X trajectory. The
X trajectory is drawn using three arcs. It is recommended that you start the sketch from
the top arc and then change the start point. To change the start point, select the point, it
turns red in color. Press and hold the right mouse button and select Start Point option
from the shortcut menu. The sketch of the X trajectory is shown in Figure 8-29.

As evident from the sketch of the X trajectory, the center points of the bottom and the
second arcs are aligned horizontally.

12. After the sketch is complete, choose the Continue with the current section. button to exit
the sketcher environment.

The VAR SEC SWP menu is displayed and you are prompted to specify another trajectory
or choose Done.

13. Choose the Sketch Traj option from the VAR SEC SWP menu. You need to sketch a
additional trajectory. This trajectory will guide the section along its path. The SETUP
PLANE submenu is displayed and you are prompted to select the sketching plane.

14. Select the FRONT datum plane from the graphics screen. The DIRECTION submenu is
displayed. Choose Okay. The SKET VIEW submenu is displayed.

15. Select the Top option from this submenu and choose the TOP datum plane from the
graphics screen.

16. Once you enter the sketcher environment, create the sketch of the trajectory as shown in
Figure 8-30. This trajectory is created using a single arc. If the start point is on the upper

Figure 8-29  Sketch with dimensions of the X
trajectory

Figure 8-28  Sketch with dimension of the origin
trajectory
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endpoint, change it to the lower endpoint by selecting the lower endpoint. When the
point turns red in color, right-click to invoke the shortcut menu, and choose the Start
Point option from the shortcut menu.

17. After the sketch is complete, choose the Continue with the current section button to exit
the sketcher environment.

The VAR SEC SWP menu is displayed and you are prompted to specify another trajectory
or choose Done.

18. Similarly, create another trajectory on the RIGHT datum plane and keep the TOP datum
plane at the left. The sketch of the trajectory is shown in Figure 8-31.

19. After the sketch is complete, choose the Continue with the current section. button to exit
the sketcher environment.

The VAR SEC SWP menu is displayed and you are prompted to specify another trajectory
or choose Done.

20. Choose the Default option from the Saved view list button in the Top Toolbar to view the
trajectories you have created, shown in Figure 8-32. This view gives a better view of
trajectories in 3D space.

21. Choose Done from the VAR SEC SWP menu. The system takes you to the sketcher
environment.

22. Draw the closed sketch of the section and apply the dimensions as shown in Figure 8-33.
Note that the section is aligned to all the start points of the trajectories that are displayed
by crosses. The cursor will automatically snap to these points as you move it close to these
points. In order to vary the section with the trajectories, it is necessary to align the section
with the trajectories.

Figure 8-31  Sketch with dimensions of the additional
trajectory

Figure 8-30  Sketch with dimensions of the
additional trajectory
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23. After the sketch is complete, choose the Continue with the current section. button to exit
the sketcher environment.

24. Choose OK from the PROTRUSION dialog box. The variable section sweep feature is
completed and is shown in Figure 8-34. You can use CTRL+middle mouse button to view
the feature as shown in the figure.

Creating the Round Feature
You will create round on the edges of the base feature. The edges you need to round are shown
in Figure 8-35 .

1. Choose Insert > Round from the menu bar. The ROUND TYPE menu is displayed.

2. Choose Simple > Done. The RND SET ATTR menu is displayed. The Constant > Edge
Chain options are selected by default. Choose Done. The CHAIN menu is displayed.

3. The Tangnt Chain option is selected by default. Select the edges shown in Figure 8-35.

Figure 8-33  Sketch of the section with
dimensions

Figure 8-32  Default view of the four trajectories

Figure 8-35 Edges to be selected to roundFigure 8-34  Variable section swept feature
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4. Choose Done from the CHAIN menu. The Message Input Window is displayed.

5. Enter 20 in the Message Input Window and press ENTER. Choose OK from the ROUND
dialog box. The base feature after creating the round is shown in Figure 8-36.

Creating the Shell
Now, you need to create the shell and remove the front planar and bottom planar surfaces of
the base feature.

1. Choose Insert > Shell from the menu bar. You are prompted to select the surfaces to be
removed.

2. Select the surfaces shown in Figure 8-37 to remove.

3. Choose Done Sel from the GET SELECT submenu and choose Done Refs from the
FEATURE REFS menu. The Message Input Window is displayed.

4. Enter 2 in the Message Input Window and press ENTER. Choose OK from the SHELL
dialog box. The model after creating the shell feature is shown in Figure 8-38.

Saving the Model
You have to save the model because you may need it later.

1. Choose the Save the active object button from the File toolbar and save the model.

The order of feature creation can be seen from the Model Tree shown in Figure 8-39.

Figure 8-36  Model after creating round Figure 8-37  Surfaces to be selected to remove
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In this tutorial you will create the model shown in Figure 8-40 . This model is a Upper Housing
of a motor blower assembly. Figure 8-41 shows the left-side view of the top view, top view, front
view, and the sectioned left-side view of the model.        (Expected time: 1 hr)

The following steps outline the procedure for creating this model:

a. First examine the model and then determine the number of features in it. The model is
composed of ten features, see Figure 8-40.

b. The base feature is an extruded feature, see Figure 8-41. Select the sketching plane for the
base feature, draw the sketch using the sketcher tools, and apply dimensions, see Figure 8-42.

Figure 8-38  Final model after shelling Figure 8-39  Model Tree for Tutorial 1

Tutorial 2

Figure 8-40  Solid model of the Upper Housing
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c. The second feature is a swept blend feature in which the section is normal to the origin
trajectory, see Figure 8-49. First the sketch for the origin trajectory will be drawn and
dimensioned and then three sections will be defined along the origin trajectory.

d. The third feature is a round of radius 1.5, see Figure 8-50.

e. The fourth feature is a round of radius 0.5, see Figure 8-52.

f. The fifth feature is a shell of thickness 0.25 that will be created on the front planar surface
of the swept blend feature and on the bottom planar surface of the base feature, see
Figure 8-53.

g. The sixth feature is an extruded cut, see Figure 8-55. Select the sketching plane for the cut
feature, draw the sketch using sketching tools, and apply the dimensions, see Figure 8-54.

h. The seventh feature is also an extruded cut, see Figure 8-57. Select the sketching plane for
the cut feature, draw the sketch using sketching tools, and apply the dimensions, see
Figure 8-56.

Figure 8-41  Left-side view of the top view, top view, front view, and the sectioned left-side view of the
model
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mi. The eighth feature is an extruded feature, see Figure 8-59. Select the sketching plane for

the extruded feature, draw the sketch, and apply constraints and dimensions, see
Figure 8-58.

j. The ninth feature is a copy of the eighth feature, see Figure 8-60.

k. The tenth feature is a hole, see Figure 8-61, and this hole will be patterned. After you
pattern the hole, the hole and the pattern feature will be combined in a single feature.

After understanding the procedure for creating the model, you are now ready to create it. The
working directory is already selected in Tutorial 1 and therefore you do not need to select it
again. However, if you want to change the working directory, choose File > Set Working
Directory and then select c08 in the Select Working Directory dialog box.

Creating New Object File
1. Open a new part file and name it c08tut2. The three default datum planes and the Model

Tree are displayed on the graphics screen. Exit the Model Tree. The Model Tree will not
appear if it was previously turned off.

Creating the Base Feature
To create the sketch for the base feature, you first need to select the sketching plane for the
base feature. In this model, you need to draw the base feature on the RIGHT datum plane.

1. Choose Insert > Protrusion > Extrude from the menu bar. The ATTRIBUTES menu is
displayed. Choose Both Sides > Done from this menu.

2. Select the RIGHT datum plane as the sketching plane. The DIRECTION submenu is
displayed.

3. Choose Okay from this submenu. The SKET VIEW submenu is displayed.

4. Select the Top option from this submenu and choose the TOP datum plane from the
graphics screen.

5. Once you enter the sketcher environment, create the sketch of the base feature and apply
dimensions as shown in Figure 8-42.

6. After the sketch is complete, choose the Continue with the current section. button to exit
the sketcher environment. The SPEC FROM menu is displayed and you are prompted to
specify the depth of extrusion.

7. The Blind option is selected by default in the SPEC FROM menu; choose Done.

8. Enter a depth of 8 in the Message Input Window that appears and press ENTER. Choose
OK from the PROTRUSION dialog box.

The base feature is completed and the default trimetric view is shown in Figure 8-43.
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Creating the Swept Blend
The second feature is a swept blend. You will sketch the trajectory for the blend on the RIGHT
datum plane. Note that the trajectory is tangent to the curve of the base feature and the start
point of the trajectory is aligned with the TOP datum plane.

1. Choose Insert > Protrusion > Swept Blend from the menu bar. The BLEND OPTS
submenu is displayed. The Sketch Sec and the NrmToOriginTraj options are selected by
default.

2. Choose Done from the BLEND OPTS submenu. The SWEEP TRAJ menu is displayed.

3. Choose the Sketch Traj option from the SWEEP TRAJ menu. You are prompted to select
a sketching plane.

4. Select the RIGHT datum plane from the graphics screen. The DIRECTION menu is
displayed. Choose Okay. The SKET VIEW submenu is displayed.

5. Select the Top option from the submenu and choose the TOP datum plane.

6. Once you enter the sketcher environment, draw the sketch of the trajectory and add
constraints and dimensions as shown in Figure 8-44.

As evident from Figure 8-44, the start point of the trajectory is aligned with the TOP
datum plane and the trajectory is tangent to the curve of the base feature.

7. After the sketch is complete, choose the Continue with the current section. button to exit
the sketcher environment.

The CONFIRM SEL menu is displayed. Note that on the origin trajectory one red, one
white, and two green points are displayed. The green points indicate that these are fixed
points for defining the sections. The location for red point can be changed by using the

Figure 8-43  Default trimetric view of the base featureFigure 8-42  Sketch for the base feature
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Note
The two green points are fixed at the start point and at the endpoint of the trajectory, indicating
that it is necessary to draw sections at these points in order to complete the swept blend feature.
This is because swept blend is created by blending the sections along the trajectory. There can be
any number of sections that can be possible between the start and the endpoint of the trajectory.

8. Choose Next from the CONFIRM SEL menu to shift the position of the red point. You
need to shift the position of the red point because the section of the swept blend feature
(SECTION X-X) that is given in Figure 8-44 is at the point where the red point is shifted
now. Hence, now you will need to define three sections at three points.

9. Choose the Accept option from the CONFIRM SEL menu. The Message Input Window
is displayed and you are prompted to enter the z-axis rotation angle for section 1. Section
1 is at the start point of the origin trajectory.

10. The value 0 is entered by default in the Message Input Window; press ENTER.

The system takes you to the sketcher environment. Now, you need to sketch the first section
of the blend at the start point of the trajectory. You will notice a coordinate system is
placed at the start point of the trajectory. You need to align the sketch of the section to this
coordinate system.

11. Use CTRL+middle mouse button to spin the view of the sketch as shown in Figure 8-45 to
have a better understanding of the sketch in 3D space.

12. Choose the Orient the sketching plane parallel to the screen button from the
Top Toolchest. The sketching plane reorients parallel to the graphics screen.

Figure 8-45  Spined view of the sketch showing
the origin trajectory, base feature, and the
default coordinate system

Figure 8-44  Sketch of the origin trajectory
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13. Draw the sketch of the first section and add dimensions as shown in Figure 8-46.

14. After the sketch is complete, choose the Continue with the current section. button to exit
the sketcher environment. The Message Input Window is displayed and you are prompted
to enter the z-axis rotation angle for section 2.

15. The value 0 is entered by default in the Message Input Window; press ENTER.

16. Draw the sketch of the second section and add dimensions as shown in Figure 8-47. This
section is at the point between the first and the third section and in Figure 8-41, this
section is named as X-X.

17. After the sketch is complete, choose the Continue with the current section. button to exit
the sketcher environment. The Message Input Window is displayed and you are prompted
to enter the z-axis rotation angle for section 3.

16. The value 0 is entered by default in the Message Input Window; press ENTER.

17. Draw the sketch of the third section and add dimensions as shown in Figure 8-48. This is
the last section on the origin trajectory. Remember to align the section to the coordinate
system.

18. After the sketch is complete, choose the Continue with the current section. button to exit
the sketcher environment.

19. Choose OK from the PROTRUSION dialog box. The default trimetric view of the swept
blend feature with the base feature is shown in Figure 8-49.

Creating the Round Features
The two round features are created before shelling because the rounds are also to be shelled
with other surfaces. The third feature in the model is a round of radius 1.5 and the fourth

Figure 8-47  Sketch for second section with
dimensions

Figure 8-46  Sketch for first section with
dimensions



Advanced Modeling Tools-II        8-25

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
. 

F
. 

F
. 

F
. 

F
. 

F o
r 

e
n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r v
ic

e
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

vi
ce

s,
 c

o
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
vi

ce
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

vi
ce

s,
 c

o
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
vi

ce
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

feature is a round of radius 0.5.

1. Choose Insert > Round from the menu bar. The ROUND TYPE menu is displayed.

2. Choose Simple > Done. The RND SET ATTR (Round Set Attributes) menu is displayed.
The Constant and Edge Chain options are selected by default.

3. Choose Done from the RND SET ATTR menu. The CHAIN menu is displayed. The
Tangnt Chain option is selected by default and you are prompted to select the edges to
round.

4. Select all the four longer edges of the swept feature shown in Figure 8-50 and choose
Done from the CHAIN menu. The Message Input Window is displayed with a default
value of radius.

5. Enter 1.5 in the Message Input Window and press ENTER.

6. Choose OK from the ROUND dialog box. The default view after creating the round is
shown in Figure 8-51.

The third feature of the model is completed and now you will create the fourth feature,
that is, a round of radius 0.5.

7. Choose Insert > Round from the menu bar. The ROUND TYPE menu is displayed.

8. Choose Simple > Done. The RND SET ATTR menu is displayed. The Constant and
Edge Chain options are selected by default.

9. Choose Done front the RND SET ATTR menu. The CHAIN menu is displayed. The
Tangnt Chain option is selected by default and you are prompted to select the edges to
round.

Figure 8-49  Default view of the swept blendFigure 8-48  Sketch of the third section with
dimensions
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10. Select the edge where the base feature
and the swept feature joins as shown in
Figure 8-52.

The Message Input Window is displayed
with a default value of radius.

11. Enter a value of 0.5 in the Message Input
Window and press ENTER.

12. Choose OK from the ROUND dialog
box. The round feature is shown in
Figure 8-53. You can use the
CTRL+middle mouse button to orient
the model as shown in Figure 8-53.

Creating the Shell
You need to create a shell of thickness 0.25 on the swept blend feature.

1. Choose Insert > Shell from the menu bar. You are prompted to select the surface to
remove.

2. Select the front planar surface of the swept blend feature and bottom planar surface of the
base feature. Choose Done Sel from the GET SELECT submenu or use the middle mouse
button to confirm the selection.

3. Choose the Done Refs option from the FEATURE REFS menu. The Message Input
Window is displayed and you are prompted to enter the thickness of shell.

4. Enter a value of 0.25 in the Message Input Window and press ENTER.

Figure 8-50  Edges to round Figure 8-51  Default view of the model after
creating a round feature of radius 1.5.

Figure 8-52  Figure showing a solid model
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Figure 8-54  Default trimetric view after shellingFigure 8-53  Model after creating a round
feature of radius 0.5

5. Choose OK from the SHELL dialog box. The shell feature is completed and is shown
in Figure 8-54.

Creating the Extruded Cut
The extruded cut is the sixth feature of this model. You need to create the cut on the front
planar surface of the base feature.

1. Choose Insert > Cut > Extrude. The ATTRIBUTES menu is displayed.

2. Choose One Side > Done. Select the front planar surface of the base feature as the sketching
plane and choose Okay from the DIRECTION submenu.

3. Select the Top option from the SKET VIEW submenu and choose the TOP datum plane.

4. Draw the sketch of the cut feature and apply dimensions as shown in Figure 8-55. You can
use the Create concentric arc button from the Right Toolchest to draw the sketch.

5. After the sketch is complete, choose the Continue with the current section. button to exit
the sketcher environment. The DIRECTION menu is displayed. Choose Okay. The SPEC
TO menu is displayed.

6. Select the Thru Next option from the SPEC TO menu and choose Done.

7. Choose OK from the CUT dialog box. The cut feature is shown in Figure 8-56.

Similarly, create the next extruded cut feature at the back planar surface of the base feature.
Select the sketching plane, draw the sketch, apply dimensions, and extrude the sketch
using the Thru Next option. The sketch for the cut feature is shown in Figure 8-57.

The seventh feature of the model, that is, cut feature is shown in Figure 8-58.
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Creating the Extruded Feature
The eighth feature of the model is an extruded feature and will be created on the front planar
surface of the base feature.

1. Select the front planar surface of the base feature as the sketching plane for the extruded
feature. Once you enter the sketcher environment, draw the sketch and apply constraints
and dimensions as shown in Figure 8-59.

2. After the sketch is complete, choose the Continue with the current section. button to exit
the sketcher environment.

3. From the SPEC TO menu, select the UpTo Surface option and choose Done. You are
prompted to select a surface to extrude upto.

4. Select the back surface of the base feature. Choose OK from the PROTRUSION dialog
box; the extruded feature is completed and is shown in Figure 8-60.

Figure 8-56  Model with cut featureFigure 8-55  Sketch with dimension for cut feature

Figure 8-58  Model with the cut featureFigure 8-57  Sketch with dimension for cut feature
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Creating the Copy of the Eighth Feature
You need to create a mirror copy of the extruded feature as shown in Figure 8-61 and this will
be the ninth feature of the model. The extruded feature will be mirrored about the FRONT
datum plane.

1. Choose PART > Feature > Copy from the Menu Manager. The COPY FEATURE
submenu is displayed.

2. Choose Mirror > Select > Dependent > Done from the COPY FEATURE submenu.
The SELECT FEAT submenu is displayed and you are prompted to select the features to
be mirrored.

3. Select the previous extruded feature from the graphics screen and choose Done from
the SELECT FEAT submenu. You are prompted to select a plane or create a datum plane
to mirror about.

4. Select the FRONT datum plane as the mirror plane. The protrusion feature is mirrored
about the FRONT datum plane as shown in Figure 8-61.

Creating the Tenth Feature
The tenth feature is a through hole and will be created using the HOLE dialog box.

1. Choose Insert > Hole from the menu bar. The HOLE dialog box is displayed. The Straight
hole radio button in the Hole Type area is selected by default.

Create the hole as shown in Figure 8-62 by specifying the placement parameters. The
placement parameters can be referred from Figure 8-41.

Creating a Pattern of the Hole Feature
As evident from Figure 8-41, you need to create eight instances of the hole. The first instance

Figure 8-60  Model after creating the extrude
feature

Figure 8-59  Sketch for the extruded feature
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is created by using the HOLE dialog box and you can use the Pattern option to create the
remaining seven instances. You will create a rectangular pattern of the hole feature. You can
also create all the holes using the HOLE dialog box and specifying the placement parameters
for each of them. But to save time, you will create a pattern of the hole.

1. Choose PART > Feature > Pattern from the Menu Manager. You are prompted to select
the feature to be patterned.

2. Select the hole that is on the base feature. The PAT OPTIONS submenu is displayed.

3. Select the General option from the PAT OPTIONS submenu and choose Done. The
placement dimensions are displayed on the hole feature.

4. Select the dimension value 1 from the graphics screen. After you select the dimension in
the first direction, the Message Input Window is displayed and you are prompted to
specify the increment in dimension.

5. Enter a value of 2 in the Message Input Window and press ENTER. You are prompted to
select a dimension in the same direction or choose Done.

6. Choose Done from the EXIT submenu. The Message Input Window is displayed and
you are prompted to enter the total number of instances in that direction including the
original.

7. Enter 4 in the Message Input Window and press ENTER. Now, you are prompted to
enter dimension increment in the second direction.

8. Select the dimension value 0.75 from the graphics screen. After you select the dimension
in the second direction, the Message Input Window is displayed and you are prompted to
specify the increment in dimension value.

Figure 8-61  Model after mirroring the extruded
feature

Figure 8-62  Model after creating the hole
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m9. Enter a value of 13.5 in the Message Input Window and press ENTER. You are prompted

to select another dimension in the same direction or choose Done.

10. Choose Done from the EXIT submenu. The Message Input Window is displayed and you
are prompted to enter the total number of instances in that direction including the original.

11. Enter 2 in the Message Input Window and press ENTER. The rectangular pattern of
holes will be displayed as shown in Figure 8-58. You can use CTRL+middle mouse button
to spin the model and to display the model as shown in Figure 8-63.

Saving the Model
You have to save the model because you may need it later.

1. Choose the Save the active object button from the File toolbar and save the model. The
order of feature creation can be seen from the Model Tree shown in Figure 8-64.

In this tutorial you will create the model shown in Figure 8-65. This model is a wheel of a car.
Figure 8-66 shows the top view, sectioned front view, sectioned right view, detail view, and two
blend sections with dimensions.    (Expected time: 45 min)

The following steps outline the procedure for creating this model:

a. First examine the model and then determine the number of features in it. The model is

Figure 8-64  Model Tree for Tutorial 2Figure 8-63  Completed model

Tutorial 3
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Figure 8-66  Top view, sectioned front view, sectioned right view, detail view, and two blend sections with
dimensions

Figure 8-65  Solid model of the wheel

composed of five features, see Figure 8-65.

b. The base feature is a revolved feature, see Figure 8-68. Select the sketching plane for the
base feature, draw the sketch using the sketcher tools, and apply constraints and dimensions,
see Figure 8-67.

c. The second feature is a swept blend feature in which the section is normal to the origin
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mtrajectory, see Figure 8-72. First the sketch for the origin trajectory will be drawn and

dimensioned and then two sections at the start and endpoints will be defined along the
origin trajectory. Then this feature will be patterned, see Figure 8-73.

d. The third feature is a round of radius 30 and the fourth feature is a round of radius 10, see
Figure 8-75 and Figure 8-76 respectively.

e. The fifth feature is a revolved cut, see Figure 8-78. First you will draw the sketch of the cut
feature on the sketching plane, apply constraint and dimensions, and revolve the sketch
to 360-degree.

After understanding the procedure for creating the model, you are now ready to create it. The
working directory is already selected in Tutorial 1 and therefore you do not need to select it
again. However, if you want to change the working directory, choose File > Set Working
Directory and then select c08 in the Select Working Directory dialog box.

Creating New Object File
1. Open a new part file and name it c08tut3. The three default datum planes and the Model

Tree are displayed on the graphics screen. Exit the Model Tree. The Model Tree will not
appear if it has been previously turned off.

Creating the Base Feature
To create the sketch for the base feature, you first need to select the sketching plane. In this
model, you need to draw the base feature on the FRONT datum plane.

1. Choose Insert > Protrusion > Revolve from the menu bar. The ATTRIBUTES menu is
displayed. Choose One Side > Done from this menu.

2. Select the FRONT datum plane as the sketching plane. The DIRECTION submenu is
displayed.

3. Choose Okay from this submenu. The SKET VIEW submenu is displayed.

4. Select the Top option from this submenu and choose the TOP datum plane from the
graphics screen.

5. Once you enter the sketcher environment, create the sketch of the base feature and apply
constraints and dimensions as shown in Figure 8-67. The sections must be closed.

6. After the sketch is complete, choose the Continue with the current section. button to exit
the sketcher environment.

The REV TO menu is displayed and you are prompted to specify the angle of revolution.

7. Select the 360 option from the REV TO menu and choose Done.

8. Choose OK from the PROTRUSION dialog box.
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The base feature is completed and the default trimetric view is shown in Figure 8-68.

Creating the Swept Blend
The second feature of the model is a swept blend. You need to create a datum plane that is at
an angle of 90-degree from the RIGHT datum plane. This is because later in the tutorial, you
will create a rotational pattern of the swept blend feature. The 90-degree angle value will be
used for the dimensional increment for creating the rotational pattern.

1. Choose Insert > Protrusion > Swept Blend from the menu bar. The BLEND OPTS
submenu is displayed. The Sketch Sec and the NrmToOriginTraj options are selected by
default.

2. Choose Done from the BLEND OPTS submenu. The SWEEP TRAJ menu is displayed.

3. Choose the Sketch Traj option from the SWEEP TRAJ menu. You are prompted to select
a sketching plane or create a datum plane.

4. Choose Make Datum option from the SETUP PLANE submenu. The DATUM PLANE
submenu is displayed.

5. Choose the Through option from the DATUM PLANE submenu and select the axis named
A_1 from the graphics screen. The A_1 axis is the axis of revolution of the base feature.

6. Choose the Angle option from the DATUM PLANE submenu and select the RIGHT
datum plane.

7. Choose Done from the DATUM PLANE submenu. The OFFSET submenu is displayed.

8. Choose the Enter Value option from the OFFSET submenu. The Message Input Window
is displayed.

Figure 8-68  Default trimetric view of the
base feature

Figure 8-67  Sketch with dimensions for the base
feature
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m9. Enter 90 in the Message Input Window and press ENTER. The DIRECTION menu is

displayed. Choose Okay. The SKET VIEW submenu is displayed.

10. Select the Top option from the submenu and choose the TOP datum plane.

11. Once you enter the sketcher environment, first you need to specify two references to
dimension. Select the TOP and RIGHT datum planes.

12. Draw the sketch of the trajectory and add constraints and dimensions as shown in
Figure 8-69. In Figure 8-69, the hidden lines are also shown because in this case the
display of the sketch is more clear while drawing the sketch with display of hidden lines.
The curve is drawn using the spline. The spline has only four control points: one start
point, one endpoint, and two intermediate point. The dimensions shown in Figure 8-69
are enough to define the sketch.

Note
The shape of the spline will differ from user to user, and so the shape of the protrusion feature
may vary.

13. After the sketch is complete, choose the Continue with the current section. button to exit
the sketcher environment.

The CONFIRM SEL menu is displayed. Note that on the origin trajectory two green
points are displayed. The green points indicate that they are fixed points for defining the
sections.

14. Choose the Next option twice from the CONFIRM SEL menu. The Message Input
Window is displayed and you are prompted to enter the z-axis rotation angle for section
1. Section 1 is at the start point of the origin trajectory.

15. The value 0 is entered by default in the Message Input Window; press ENTER.

The system takes you to the sketcher environment. Now, you need to sketch the first section
of the blend at the start point of the trajectory. You will notice a coordinate system is
placed at the start point of the trajectory. You need to align the sketch of the section to this
coordinate system.

16. Draw the sketch of the first section and add dimensions as shown in Figure 8-70.

17. After the sketch is complete, choose the Continue with the current section. button to exit
the sketcher environment. The Message Input Window is displayed and you are prompted
to enter the z-axis rotation angle for section 2.

18. The value 0 is entered by default in the Message Input Window; press ENTER.

19. Draw the sketch of the second section and add dimensions as shown in Figure 8-71. The
second section is also elliptical in shape, and therefore an ellipse is drawn in the sketch.
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The dimensions for this section are shown in Figure 8-66.

20. After the sketch is complete, choose the Continue with the current section. button to exit
the sketcher environment.

21. Choose OK from the PROTRUSION dialog box. The default trimetric view of the swept
blend feature with the base feature is shown in Figure 8-72.

Creating the Rotational Pattern of the Swept Blend
Creating the swept blend features individually on the base feature will consume a lot of
time. Therefore, you need to create a rotational pattern of the hole feature.

1. Choose PART > Feature > Pattern from the Menu Manager. You are prompted to select
the feature to be patterned.

Figure 8-71  Sketch for section 2 with
dimensions

Figure 8-72  Model after creating the swept blend

Figure 8-69  Sketch with dimensions for the origin
trajectory

Figure 8-70  Sketch for section 1 with dimensions
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m2. Select the swept blend feature from the graphics screen. The PAT OPTIONS submenu

is displayed.

3. The General option is selected by default in the PAT OPTIONS submenu; choose Done.

4. The dimensions of the swept blend feature are displayed on the graphics screen. Select
the angular dimension 90. The Message Input Window is displayed.

Note
You may need to zoom in the display of the model to select the 90 angular dimension value.

5. Enter 120 in the Message Input Window and press ENTER. You have entered a value of
120 because there are three instances of the swept blend feature on a circular feature. You
know that a circle makes an angle of 360-degree at the center; therefore when 360 is
divided by 3 it is equal to 120.

6. Choose Done from the EXIT submenu. The Message Input Window is displayed and
prompts you to specify the number of instances of the hole feature in the pattern.

7. Enter 3 in the Message Input Window and press ENTER. Choose Done from the EXIT
submenu. The rotational pattern is created as shown in Figure 8-73.

Creating the Round Feature
The third feature is a round of radius 30.

1. Choose Insert > Round from the menu bar. The ROUND TYPE menu is displayed. The
Simple option is selected by default; choose Done from this menu.

The RND SET ATTR menu is displayed.

2. The Constant > Edge Chain options are selected by default. Choose Done from this
menu. The CHAIN menu is displayed.

3. The Tangnt Chain option is selected by default and you are prompted to select an edge.

4. Select the edges shown in Figure 8-74 to round. You may need to spin the model to select
the inner edges of the swept blend feature.

5. After selecting the edges, choose the Done option from the CHAIN menu. The Message
Input Window is displayed and you are prompted to specify the radius of round.

6. Enter a value of 30 in the Message Input Window and press ENTER.

7. Choose OK from the ROUND dialog box.

The round feature is completed. The default trimetric view of the round feature is shown
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in Figure 8-75. Using the same options create a round feature of radius 10 highlighted in
Figure 8-76.

Creating the Revolve Cut Feature
You need to first select a sketching plane to draw the sketch of the cut feature and then specify
the angle of revolution.

1. Choose Insert > Cut > Revolve from the menu bar. The ATTRIBUTES menu is displayed.

2. Choose One Side > Done from the ATTRIBUTES menu. You are prompted to select a
sketching plane.

3. Select the FRONT datum plane. The DIRECTION submenu is displayed. Choose Okay.
The SKET VIEW submenu is displayed.

4. Select the Bottom option and choose the TOP datum plane from the graphics screen.

Figure 8-73  Model after creating pattern Figure 8-74  Edges to round

Figure 8-75  Model after creating a round of
radius 30

Figure 8-76  Model highlighting the round feature
of radius 10
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m5. Once you enter the sketcher environment, draw a center line aligned to the RIGHT datum

plane. Draw the sketch of the revolved cut feature and add dimensions and constraints as
shown in Figure 8-77.

6. After the sketch is complete, choose the Continue with the current section. button from
the Right Toolchest.

The REV TO menu is displayed and you are prompted to specify the angle of revolution.

7. Select the 360 option from the REV TO menu and choose Done.

8. Choose OK from the CUT dialog box. The revolve cut feature is shown in Figure 8-78.

The model is completed and the isometric view of the model is shown in Figure 8-79.

Saving the Model
You have to save the model because you may need it later.

1. Choose the Save the active object button from the File toolbar and save the model.

The order of feature creation can be seen from the Model Tree shown in Figure 8-80.
The feature id numbers displayed in the Model Tree may be different when you create the
features.

Figure 8-78  Model after creating the revolve
cut feature

Figure 8-77  Sketch for the revolve cut feature
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Tutorial 4

Figure 8-80  Model Tree for Tutorial 3Figure 8-79  Isometric view of the model

Figure 8-81  Isometric view of the spring Figure 8-82  Front view of the spring with
dimensions

In this tutorial you will create the spring shown in Figure 8-81. Figure 8-82 shows the front
view with dimensions of the spring.    (Expected time: 20 min)

The following steps outline the procedure for creating the constant pitch spring:

a. First examine the spring and then determine the specifications of the spring. The spring
is right-handed, constant pitch, and is created by revolving through axis.

b. Select the sketching plane, draw the trajectory using the sketcher tools, and apply
dimensions, see Figure 8-83.

c. Specify the pitch of the spring.
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md. Draw the section of the spring using the sketcher tools and dimension it, see Figure 8-84.

After understanding the procedure for creating the model, you are now ready to draw it. The
working directory is already selected in Tutorial 1 and therefore you do not need to select it
again. However, if you want to change the working directory, choose File > Set Working
Directory and then select c08 in the Select Working Directory dialog box.

Creating New Object File
1. Open a new part file and name it c08tut4. The three default datum planes and the Model

Tree are displayed on the graphics screen. Exit the Model Tree. The Model Tree will not
appear if it has been previously turned off.

Creating the Helical Sweep
The spring that you have to create is a right-handed spring of constant pitch.

1. Choose Insert > Protrusion > Helical Sweep from the menu bar. The ATTRIBUTES
menu is displayed. The Constant > Thru Axis > Right Handed options are selected by
default.

2. Choose Done from the ATTRIBUTES menu. You are prompted to select a sketching
plane.

3. Select the FRONT datum plane from the graphics screen. The DIRECTION submenu is
displayed. Choose Okay. The SKET VIEW submenu is displayed.

4. Select the Top option from the SKET VIEW submenu and choose the TOP datum plane.

5. Once you enter the sketcher environment, draw the sketch of the trajectory and dimension
it as shown in Figure 8-83. As evident from Figure 8-83, the endpoint of the trajectory is
aligned to the TOP datum plane.

You need to draw a center line in the sketch about which the spring will be rotated. This is
the axis of the spring and is the first trajectory that is drawn in the sketch.

6. After you complete the sketch of the trajectory, choose the Continue with the current
section. button from the Right Toolchest. The Message Input Window is displayed and
you are prompted to specify the pitch of the spring.

7. Enter 10 in the Message Input Window and press ENTER.

Now, you enter the sketcher environment to draw the section of the spring. You will notice
that a blue cross of infinite length appears on the screen. This cross consists of two
perpendicular lines of infinite length. The intersection point of these lines is the start
point of the trajectory.

8. Draw the section of the spring such that the center of the circle coincides with the
intersection of the two perpendicular lines and dimension it as shown in Figure 8-84.
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Figure 8-84  Sketch of the section with dimensionsFigure 8-83  Sketch of the trajectory with
dimensions

9. After completing the sketch, choose the Continue with the current section. button to exit
the sketcher environment.

10. Choose the OK button from the PROTRUSION dialog box.

The spring is created and is shown in Figure 8-85.

Saving the Model

1. Choose the Save the active object button from the File toolbar and save the model.

The order of feature creation can be seen from the Model Tree shown in Figure 8-86.

8-86  Model Tree for Tutorial 4Figure 8-85  Isometric view of the spring
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Answer the following questions and then compare your answers with the answers given at
the end of this chapter.

1. You can create Constant pitch as well as Variable pitch helical sweep features. (T/F)

2. The Helical Sweep option is used to create cut as well as the protrusion features. (T/F)

3. You can create a helical feature having 40 units pitch and 50 units as the diameter of the
circle as the cross-section. (T/F)

4. The Shoulder Crv and the Tangent Crv options in the BNDRS OPTS submenu while
using the Boundaries option are not available by default. (T/F)

5. The Var Sec Sweep option is available for both protrusion and cut options. (T/F)

6. While using the Var Sec Sweep option, the contour of the sweep feature depends on the
shape of the __________.

7. While using the Var Sec Sweep option, when you draw the section for the sweep feature,
the section should be __________ to the endpoints of the trajectories.

8. When you choose the Done option from the SWEEP OPTS submenu the __________
menu is displayed.

9. When you use the Norm To Trj option to create the variable sweep you are prompted to
define an origin trajectory, a normal trajectory, and a __________.

10. The  Swept Blend option is used to create a model that is a combination of __________
and __________.

Answer the following questions:

1. Which of the following menus is displayed when you choose the Helical Sweep option
from the Insert menu in the menu bar?

(a) ADV FEAT OPT (b) ATTRIBUTES
(c) SWEEP OPTS (d) None

Review Questions

Self Evaluation Test
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Exercise

Exercise 1

2. Which of the following options is used to create a helical feature with constant pitch
throughout the sweep?

(a) Right Handed (b) Constant
(c) Thru Axis (d) None

3. Which of the following options in the SWEEP OPTS is used to create a sweep in which the
swept section is normal to the trajectory defined as the origin trajectory?

(a) Pivot Dir (b) NrmToOriginTraj
(c) Norm To Traj (d) None

4. Which of the following options in the RELATIONS submenu is used to delete relations?

(a) Add (b) Edit Rel
(c) Show Dim (d) Show Rel

5. Which of the following options is used to create a variable section sweep in which you
need to select a plane, edge, curve, or axis to which the section to be swept is perpendicular?

(a) Pivot Dir (b) Nrm To Traj
(c) NrmToOriginTraj (d) None

6. The Var Sec Swp option is used to create a sweep in which the section of the sweep is
constant throughout the sweep. (T/F)

7. The trajectory called X trajectory is used to guide the section of the sweep feature along it.
(T/F)

8. When you choose the Edit Rel option the relations are not checked for errors. (T/F)

9. The Switch Dim option of the RELATIONS submenu is used to toggle the dimension
value mode and the symbols. (T/F)

10. Helical Sweep option is also used to create a cut. (T/F)

Create the model shown in Figure 8-87. The front view is shown in Figure 8-88.
    (Expected time: 20 min)
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Figure 8-88  Front view of the springFigure 8-87  Isometric view of the spring

Answers to the Self-Evaluation Test
1 - T, 2 - T, 3 - F, 4 - T, 5 - T, 6 - X trajectory, 7- aligned, 8 - VAR SEC SWP, 9 - section,
10 - sweep, blend.


