
Chapter 2

Editing and Modifying
the Sketches

After completing this chapter you will be able to:
• Edit the sketches using various editing tools.
• Create the rectangular patterns of the sketched entities.
• Create the circular patterns of the sketched entities.
• Modify the sketch entities.
• Modify the sketches by dynamically dragging the sketched entities.

Learning Objectives
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EDITING THE SKETCHED ENTITIES
SolidWorks provides you with a number of tools that can be used to edit the sketched entities.
These options include trimming the sketched entities, extending the sketched entities, offsetting
the sketched entities, mirroring the sketched entities, copying/moving the sketched
entities, modifying and copying the sketched entities by dynamically dragging, and so on.

Trimming the Sketched Entities

The Sketch Trim tool is used to trim the unwanted entities in a sketch. The Sketch Trim
option is used to trim a line, arc, ellipse, parabola, circle,  spline, or center line that is
intersecting a line, arc, circle, ellipse, parabola, spline, or center line. To use the trim

option, choose the Trim option from the Sketch Tools toolbar. The cursor will be replaced by
the trim cursor; move the trim cursor near to the portion of the sketched entity to be removed. If
the entity will be completely deleted using then trim option then that entity will be highlighted
in red and if a portion of the entity will be deleted then that entity will be highlighted in black.
Now, choose the left mouse button to remove the entity. Figures 2-1 and 2-2 show the sketch
before and after trimming the entities.

Using the Trim Option to Extend a Sketched Entity
Choose the Sketch Trim button from the Sketch Tools toolbar and move the trim cursor to the
entity to be extended. When the sketched entity turns red or black in color, drag the cursor to
the entity upto which the selected entity is to be extended. You can notice the preview of the
extended entity in yellow color. Release the left mouse button when you notice the preview of the
extended entity in yellow.

Toolbar: Sketch Tools > Sketch Trim
Menu: Tools > Sketch Tools > Trim

Figure 2-1  Entities to be selected for trimming Figure 2-2  Sketch after trimming the entities
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Extending the Sketched Entities

The Sketch Extend tool is used to extend the sketched entity to intersect the next
available entity. The Extend option is used to extend a line, arc, ellipse, parabola,
circle,  spline, or center line to intersect a line, arc, circle, ellipse, parabola, spline, or

center line. The sketched entity is extended up to its intersection with another sketched entity or
a model edge. Choose the Sketch Extend button from the Sketch Tools toolbar and move the
extend cursor near to the portion of the sketched entity to be extended. The entity to be extended
is displayed in black and the preview of the extended portion of the entity is displayed in yellow.
Choose the left mouse button to complete the extend operation. Figure 2-3 shows the sketched
entities before extending and Figure 2-4 shows the sketched entities after extending.

Tip. In SolidWorks all the buttons are not displayed by default in the toolbars.
Therefore, you have to customize the toolbars according to your need and specifications.
The next topic that is going to be discussed is Extending the Sketched Entities. The
tool button for the Extend option is not available in the Sketch Tools toolbar. To
insert the Sketch Extend button in the Sketch Tools toolbar you have to follow the
procedure given as under:

1. Choose Tools > Customize from the menu bar to display the Customize dialog
box.
2. Choose the Commands tab from the Customize dialog box.
3. Choose Sketch Tools from the Categories area of the Customize dialog box.
4. Press and hold down the left mouse button to select the Sketch Extend
button from the Buttons area of the Customize dialog box. You can view
the description of the Sketch Extend button in the Description area.
5. Drag the mouse to the Sketch Tools toolbar and release the left mouse button to
place the Sketch Extend button on the Sketch Tools toolbar.
6. Choose OK from the Customize dialog box.

You can insert the other tool buttons in the Sketch Tools toolbar or any other
toolbar by following the same procedure. To remove the tool button from any of the
toolbar you have to invoke the Customize dialog box and using the left mouse
button select the tool button that you want to remove from the toolbar and drop the
button in the graphics area. You can also move the tool buttons from one toolbar to
the other toolbar. You can also copy the buttons and place them in more than one
toolbar.

Toolbar: Sketch Tools >  Sketch Extend (Customize to Add)

Menu: Tools > Sketch Tools > Extend

Tip. If the preview of the sketched entity to be extended is shown in the wrong
direction, move your extend cursor to a position on the other half of the entity and
observe the new preview. Click the sketched entity to accept the new preview line or
arc.
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Filleting the Sketched Entities

Fillet creates an arc tangent at the intersection of two sketched entities. It trims or extends
the entities to be filleted depending on the geometry of the sketched entity. You can
apply fillet between two nonparallel lines, between two arcs, between two splines, between

an arc and a line, between a spline and a line, and between a spline and an arc. The fillet
between two arcs, or between an arc and a line depends upon the compatibility of the geometry
to be extended or filleted along a given radius. Hold down the CTRL key and using the left
mouse button select two entities to create fillet. Now, choose the Sketch Fillet button to display
the Sketch Fillet PropertyManager as shown in Figure 2-5. Set the value of the Fillet Radius

Toolbar: Sketch Tools > Sketch Fillet
Menu: Tools > Sketch Tools > Fillet

Figure 2-4  Sketched entities after extendingFigure 2-3  Sketched entities before extending

Tip. If you are using the trim or extend tool, then using the right mouse button in
the drawing area invoke the shortcut menu. You can toggle between the trim and
extend tools using this shortcut menu.

Figure 2-5  Sketch Fillet PropertyManager
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spinner and press ENTER or choose the Apply button from the Sketch Fillet dialog box. You
can also select the sketched entities after invoking the Sketch Fillet PropertyManager. You can
also select the nonintersecting entities for creating fillet. While filleting the nonintersecting
entities the selected entities will be extended to form a fillet. If the Keep constrained corners
check box is selected, the dimension and geometric relations applied to the sketch will not be
deleted. If you unselect the Keep constrained corners check box then you will be prompted to
delete the relations applied to the corners of the sketched entities to be filleted. The Undo
button is displayed in the Sketch Fillet PropertyManager, when you create at least one sketch
fillet. Figures 2-6 and 2-7 show the sketched entities before and after applying the radius.

Note
The fillet creation between two splines, between a spline and a line, and between a spline and an
arc depends upon the compatibility of the spline to be trimmed or extended.

The other method of creating a sketched fillet between two entities is to choose the Sketch Fillet
button. The Sketch Fillet PropertyManager is invoked. Set the fillet radius spinner to the
required value. Using the left mouse button drag the cursor to create a window such that the
entities to be filleted are enclosed inside the window. As soon as you release the left mouse
button the fillet will be created between the two selected entities. The Keep Visible button is
used to pin the Sketch Fillet PropertyManager to create more than one sketch fillets of same
radius or different radius. You can also pin the dialog box using the shortcut menu; use the right
mouse button in the drawing area to invoke the shortcut menu as shown in Figure 2-8. Choose
the Pin Dialog option from the shortcut menu to create more than one sketch fillets. The
consecutive fillets with the same radius are not dimensioned individually; an automatic equal
radii relation is applied to all the fillets. The Close button is available only when you have
created at least one sketched fillet. The Close button is used to close the dialog box.

Figure 2-6  Sketched entities before and after
creating fillet.

Figure 2-7  Sketched entities before and after
creating fillet.
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Chamfering the Sketched Entities

The Sketch Chamfer tool is used to apply a chamfer to adjacent sketch entities.  The
chamfer can be specified by either angle-distance or distance-distance options. You can
apply chamfer between two nonparallel lines; the lines may be intersecting lines or

nonintersecting lines. The creation of chamfer between two nonintersecting lines depends upon
the length of the lines and the chamfer distance. To create chamfer hold down the CTRL key
and select two entities using the left mouse button. You can select two entities to create chamfer
by dragging the left mouse button and creating a window to select the sketched entities. Next,
choose the Sketch Chamfer button from the Sketch Tools toolbar. You can also select the two
entities after invoking the Chamfer tool. When you choose the Chamfer button, the Sketch
Chamfer PropertyManager shown in Figure 2-9, is displayed on the left of the drawing area.
The options available in the Sketch Chamfer PropertyManager are discussed next.

Toolbar: Sketch Tools > Sketch Chamfer
Menu: Tools > Sketch Tools > Chamfer

Figure 2-9  Sketch Chamfer Property Manager

Figure 2-8  Shortcut menu
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Chamfer Parameters Area
Various parameters that are used to create the sketch chamfer are available in the Chamfer
Parameters area. The various parameters that are used to create the sketched chamfer are discussed
next.

Angle-distance
The Angle-distance radio button is selected to create the sketched chamfer by specifying
the angle and the distance. The Distance-distance radio button is selected
by default and therefore, to create a sketched chamfer using the Angle-distance option you
have to select the Angle-distance radio button using the left mouse button. When you select
the Angle-distance radio button the Direction 1 Angle spinner is also displayed below the
Distance 1 spinner. The Distance 1 spinner is used to specify the distance and the Direction
1 Angle spinner is used to specify the angle.

Distance-distance
The Distance-distance radio button is selected to create the sketched chamfer by specifying
the distances in two directions. When you invoke the Sketch Chamfer button, the
Distance-distance radio button and the Equal check box are selected by default in the
Sketch Chamfer PropertyManager. You are provided with the Distance 1 spinner to set the
value of chamfer distance.

Equal distance
The Equal distance check box is selected to specify an equal distance in both the directions
for creating the sketched chamfer. This check box is selected by default when you choose the
Sketch Chamfer button. If you clear this check box then you can apply two different distances
to the selected entities for creating the sketched chamfer. When you clear this check box the
Distance 2 spinner is displayed below the Distance 1 spinner to set the value of distance in
the second direction.

You can also use the shortcut menu shown in Figure 2-10, which is invoked using the right
mouse button in the drawing area, to toggle between the various options that are used to
create the sketched chamfer such as Angle-distance, Distance-distance, and Equal distance.

Figure 2-10  Shortcut menu
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Note
If you apply a sketch chamfer to the entities that are constrained using some relations or dimensions
then the SolidWorks warning message window will be displayed. This warning message will
prompt you that At least one sketch constraint is about to be lost, Chamfer anyway? Choose
the Yes button from this warning message box. You will learn more about the relations and
dimensions that constrain the sketch later in this chapter.

The sketched chamfers using various options is shown in Figure 2-11.

Offsetting the Sketched Entities

Offsetting is one of the easiest methods of drawing parallel lines or concentric arcs, and
circles. You can select the entire chain of the entities as a single entity or select an
individual entity to offset. You can offset selected sketched entities, edges, loops, faces,

curves. When you choose the Offset Entities button from the Sketch Tools toolbar the Offset
Entities PropertyManager is displayed as shown in Figure 2-12. The various options available
in the Offset Entities PropertyManager are discussed next.

Parameters area
The Parameters area of the Offset Entities PropertyManager is used to specify the various

Toolbar: Sketch Tools > Offset Entities
Menu: Tools > Sketch Tools > Offset Entities

Figure 2-11  Various types of chamfers using the Angle-Distance,
Equal distance, and Distance-distance options

Tip. You can add a sketch fillet or a sketch chamfer by invoking the relative
PropertyManager and setting the value of sketch fillet or sketch chamfer to be
created. Select the vertex at the intersection of the entities.

c02-solidworks-2003.p65 5/12/2003, 9:30 AM8



Editing and Modifying the Sketches        2-9

parameters for creating an offset entity. The parameters that are used to offset an entity are
discussed next.

Offset Distance
The Offset Distance spinner is used to set the offset distance between the selected entity to
be offset and the entity to be created using the offset tool at a specified distance. You can set
the value of the offset distance manually or you can set the spinner value by dragging the
offset entity in the drawing area using the left mouse button.

Reverse
The Reverse check box is selected to change the direction of the offset. The Reverse check
box is available only if you set the value of the offset distance using the Offset Distance
spinner. If you set the value of the offset distance by dragging the entity using the left mouse
button, the Reverse check box will not be activated.

Select Chain
The Select Chain check box is selected to select the entire chain of continuous sketched
entities. When you invoke the offset tool, the Select Chain check box is selected by default.
If you clear this check box, then only the selected sketched entity will get offset.

Bi-directional
The Bi-directional radio button is selected to create offset entities in two directions. If the
Bi-directional check box is selected then the Reverse check box will not be available in the
Parameters area of the Offset Entities PropertyManager.

Figure 2-13 shows a new chain of entities created by offsetting the chain of entities. Figure 2-14
shows the offsetting of a single entity.

Figure 2-12  The Offset Entities PropertyManager
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Mirroring the Sketched Entities

The Mirror tool is used to create the mirror image of the selected entities. The entities
are mirrored about a center line. When you create the mirrored entity, SolidWorks
applies a symmetric relation between the sketched entities. If you change a mirrored

entity, its mirror image will also change. There are two methods to create the mirrored image of
a sketched entity. The two methods to create a mirrored entity are discussed next.

Mirroring the Existing Items
Create the sketch of the entities to be mirrored using the normal sketch tools in the sketching
environment. Choose the Centerline button from the Sketch Tools toolbar and create a centerline
along which the sketched entities will be mirrored. Now, hold down the CTRL key and using the
left mouse button select the entities to be mirrored and select the centerline along which the
entities will be mirrored. You can also select the entities by creating a window around the sketched
entities and the centerline. Choose Tools > Sketch Tools > Mirror from the menu bar or
choose the Sketch Mirror button from the Sketch Tools toolbar. The sketched entities are
mirrored along the centerline. If you modify the sketch of the sketched entity the same will be
reflected on the mirror image. Figure 2-15 shows the sketched entities with the centerline and
Figure 2-16 shows the resultant mirror image of the sketched entities.

Mirroring Items While Sketching (Automatic Mirroring)
Create a centerline along which the sketched entities will be mirrored. Select the centerline and
choose the Sketch Mirror button from the Sketch Tools toolbar or choose Tools > Sketch Tools
> Mirror from the menu bar. The symmetry symbols appear at both ends of the centerline to
indicate that automatic mirroring is activated as shown in Figure 2-17. Now, start creating the
sketch. The sketched entity that you create on one side of the centerline will automatically be
created on the other side of the mirror line (centerline). In Figure 2-18 the entities are mirroring
automatically while sketching. Figure 2-19 shows the complete sketch with automatic mirroring.

Figure 2-13  Offsetting a chain of entities Figure 2-14  Offsetting a single entity

Toolbar: Sketch Tools > Sketch Mirror (Customize to Add)

Menu: Tools > Sketch Tools > Mirror
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Figure 2-15  Selecting the sketched entities and the
centerline

Figure 2-16  Sketch after mirroring the geometry

Figure 2-17  Showing the centerline and the symmetry symbols that
indicate that automatic mirroring is activated

Figure 2-18  Sketching using automatic mirroring active

c02-solidworks-2003.p65 5/12/2003, 9:30 AM11



2-12                                                             SolidWorks for Designers

Note
As discussed earlier you create a mirror line to invoke the automatic mirroring option. After
invoking the automatic mirroring option you create the sketch on one side of the mirror line, and
the same sketch is also created on the other side of the mirror line. After completing the sketch if
you have to deactivate the automatic mirroring option, select the mirror line and choose the
Sketch Mirror button from the Sketch Tools toolbar to delete the mirror line.

Move/Copy the Sketch Entities Using PropertyManager
The Move/Copy option in the PropertyManager of the FeatureManager design tree is used to
move, rotate, or copy one or more unconstrained sketched entities. To activate the Move/Copy
PropertyManager select one or more than one sketched entity. The PropertyManger of that
particular entity is displayed. Choose the Move/Copy button from the PropertyManager. The
Move/Copy PropertyManager is displayed as shown in Figure 2-20. The various options available
in the Move/Copy PropertyManager are discussed next.

Transformation
The options available in the Transformation area are used to translate or rotate the selected
entity.

Translate
The Translate option is provided with two spin boxes. The first spin box is named as Delta
spinner and this is used to provide the increment value in the X axis and second spin box
is named as Delta Y and this spin box is used to provide the increment value in the Y axis.
Using these spin boxes you can specify the incremental value to move or copy the
selected entities.

Rotate
The Rotate option is used to specify the incremental angular value to the selected entity for
its rotation along a specified centerpoint. The Angle spinner is used to specify the incremental
angular value to the selected entity. Two spin boxes are provided under the Rotate spinner.

Figure 2-19  Complete sketch with automatic mirroring
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These spin boxes are used to specify the position of the centerpoint along which the selected
entity will be rotated.

Move Selected Point
The Move Selected Point area is used to specify the incremental value in the X and Y
directions for a particular selected point. Two spin boxes are provided in this area. The first
spin box is named as X Point Position spinner. This spin box is used to specify the value of
the selected point in the X axis. The second spin box is named as Y Point
Position spinner. This spin box is used to specify the value of the selected point in the Y axis.

Solve move
The Solve move radio button is selected when you need to move or rotate the selected entity,
entities, or point and solves the dimensions or relations, if possible.

Figure 2-20  Move/Copy PropertyManager

c02-solidworks-2003.p65 5/12/2003, 9:30 AM13



2-14                                                             SolidWorks for Designers

No solve move
The No solve move option is used when you have to move he sketched entities without
solving the dimensions and relations in the sketch.

Copy
The Copy option is used to copy the selected entity and create the new entity at the location
you define using the values in the Translate and Rotate boxes.

CREATING PATTERNS
While sketching the base feature of a model, sometimes you may need to place the sketched
entities in a particular arrangement such as along linear edges or around a circle. For example,
refer to Figures 2-21 and 2-22. These figures show base features with the slots inside. These slots
are created with the help of the linear and circular patterns of the sketched entities. The tools
that are used to create linear and circular patterns of the sketched entities are discussed next.

Creating Linear Pattern of the Sketched Entities

In SolidWorks, the linear pattern of the sketched entities is created using the Linear
Sketch Step and Repeat tool. To create the linear pattern, select the sketched entities
using the Select tool and then choose this button from the Sketch Tools toolbar. The

Linear Sketch Step and Repeat dialog box will be displayed as shown in Figure 2-23 and the
preview of the linear pattern will be shown on the screen in the background. Also, the arrow
cursor is replaced by the linear pattern cursor. Note that if you have not selected the sketched
entities to pattern before invoking this tool, you will have to select them one by one using the
linear pattern cursor. You cannot define a window to select more than one entity using the linear
pattern cursor.

Figure 2-21  Base feature with slots created about linear edges

Menu: Tools > Sketch Tools > Linear Sketch Step and Repeat
Toolbar: Sketch Tools > Linear Sketch Step and Repeat
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Figure 2-23  Linear Sketch Step and Repeat dialog box

The options available in this dialog box are discussed next.

Direction 1 Area
By default, the first direction of a linear pattern is taken along the positive X axis direction. The
options under this area are used to set the number of instances, spacing, and the angle along the
first direction. These options are discussed next.

Figure 2-22  Base feature with slots created around a circle
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Number
The Number spinner is used to specify the number of instances in the linear pattern along
the first direction. As you increase or decrease the value of this spinner, the number of
instances in the preview of the pattern displayed on the screen will also be modified. The
default value of this spinner is 3.

Spacing
The Spacing spinner is used to specify the spacing between each instance along the first
direction. Remember that the spacing is measured from the center of the entities selected
for creating the pattern. Figure 2-24 shows the preview of the linear pattern that is displayed
in the background. As evident in the figure, the number of instances along direction 1 is
three and the distance is measured between the center of two consecutive entities.

Angle
The Angle spinner is used to specify the angle of the linear pattern along the first direction.
Remember that the orientation of the entities selected to be patterned will not change as you
enter an angle value for the first direction. The default value of the angle is 0°. Figure 2-25
shows a linear pattern at an angle of 30°.

Reverse Direction 1
The Reverse Direction 1 button is available on the right of the Angle spinner. This
button is chosen to reverse direction 1.

Fixed
The Fixed check box is available below the Spacing spinner. If this check box is selected,
the incremental spacing between the instances along direction 1 will be placed as a dimension
between the first two instances along this direction after you create the pattern. Also, a
center line will be drawn between the first two instances. Note that this dimension will not
be placed from center to center. It will be displayed from the first entity in the first instance
in the pattern to the first entity in the second instance.

Direction 2 Area
By default, the second direction of a linear pattern is taken along the positive Y axis direction.

Figure 2-24  Preview of the linear pattern with 3 instances along direction
1 and 1 along direction 2
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The options under this area are used to set the number of instances, spacing, and the angle
along the second direction. These options are discussed next.

Number
The Number spinner is used to specify the number of instances in the linear pattern along
the second direction. The default value of this spinner is 1. This is the reason the other
options in the Direction 2 area are not available. However, as soon as you set the value of
this spinner to more than 1, the other options in this area will be available.

Spacing
The Spacing spinner is used to specify the spacing between each instance along the second
direction. As mentioned earlier, the spacing is measured from the center of the entities
selected for creating the pattern.

Angle
The Angle spinner is used to specify the angle of the linear pattern along the second
direction. This value will always be measured from the positive X axis direction.
As mentioned earlier, the orientation of the entities selected to be patterned will not change
as you enter an angle value for the pattern. The default value of the angle is 90°. Figure 2-26
shows a linear pattern with the angle of direction 1 as 0° and the angle of direction 2 as 60°.

Reverse Direction 2
The Reverse Direction 2 button is available on the right of the Angle spinner. This
button is chosen to reverse direction 2.

Figure 2-25  Preview of the linear pattern at an angle of 30° along
direction 1

Tip. You can also specify the spacing and angle value dynamically in the preview of
the linear pattern. To do this, press the left mouse button on the control points
displayed at the end of the arrow in the preview of the pattern and drag it. After
placing the arrow at the desired location, release the left mouse button. The new
spacing and angle value will be displayed in their respective spinners.

c02-solidworks-2003.p65 5/12/2003, 9:30 AM17



2-18                                                             SolidWorks for Designers

Fixed
The Fixed check box is available below the Spacing spinner. If this check box is selected,
the incremental spacing between the instances along direction 2 will be placed as a dimension
between the first two instances along this direction after you create the pattern. Also, a
center line will be drawn between the first two instances. As mentioned earlier, this dimension
will be placed from the first entity in the first instance in the pattern to the first entity in the
second instance and not between the centers of the two instances.

Constrain angle between axes
The Constrain angle between axes check box will be available only if you set the value of the
Number spinner in the Direction 2 area to more than 1. This check box is selected by default.
If this check box is selected, the angle between the two directions of the linear pattern will be
constrained and will be placed as the dimension value when you create the pattern. However, if
this check box is cleared, the angle between the two directions will not be displayed and will not
be related to each other.

Items to repeat
The Items to repeat box displays all the entities selected to pattern. If you want to remove an
entity from the selection set, select that entity from this box. The background color of the box
will be changed to a reddish color and the entity will be highlighted in blue. Now, press the
DELETE key from the keyboard. The removed entity will no more be displayed in the preview of
the pattern and will not be selected in the original entities.

Instances
The Instances list box displays all the instances of the linear pattern except the original instance.
The instances are displayed in a matrix format with the first number indicating the instances
along direction 1 and the second number indicating the instances along direction 2. Note that
the matrix [1,1] is not displayed since it is the original instance. If you want to remove an
instance from the pattern, select it in the Instances list box and then press the DELETE key

Figure 2-26  Preview of the linear pattern at an angle of 0° along direction 1
and 60° along direction 2
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from the keyboard. You will notice that the deleted instance is no more displayed in the preview
of the pattern. Remember that this instance will not be deleted from the memory of the pattern.
It will be displayed in the Instances deleted box.

Instances deleted
The Instances deleted list box displays all the instances that are deleted from the linear pattern.
As mentioned earlier, the deleted instances are not removed from the memory of the pattern.
They are stored in this list box. If you want to restore the deleted instance, select it in this box
and then press the DELETE key. You will notice that the selected instance is again displayed in
the preview and also in the Instances list box.

Undo
The Undo button is chosen to undo the operations performed in the Linear Step Sketch and
Repeat dialog box. All the operations will be undone one by one if you keep choosing this
button and the original parameters will be restored. After everything is undone, this button will
not be available.

Creating Circular Pattern of the Sketched Entities

In SolidWorks, the circular pattern of the sketched entities is created using the Circular
Sketch Step and Repeat tool. To create the circular pattern, select the sketched entities
using the Select tool and then choose this button from the Sketch Tools toolbar. The

Circular Sketch Step and Repeat dialog box will be displayed as shown in Figure 2-27 and the
preview of the circular pattern will be shown on the screen in the background. Also, the arrow
cursor is replaced by the circular pattern cursor.

The options provided in the Circular Sketch Step and Repeat dialog box are discussed next.

Arc Area
The options under the Arc area are used to specify the radius and angle of the imaginary circle
around the circumference of which the instances will be arranged. These options are discussed
next.

Radius
The Radius spinner is used to specify the radius of the imaginary circle around
the circumference of which the instances of the circular pattern are arranged. As you modify
this value, the centerpoint of the imaginary circle will also change.

Menu: Tools > Sketch Tools > Circular Sketch Step and Repeat
Toolbar: Sketch Tools > Circular Sketch Step and Repeat

Tip. You can also add entities in the current selection set or remove them from the
current selection set by selecting them using the linear pattern cursor. As you add or
remove the instances, the effect can be seen dynamically in the preview of the pattern.
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Angle
As you invoke the Circular Sketch Step and Repeat tool, a reference circle is drawn with
dashed lines around which the instances of the circular pattern will be arranged. Also, a
reference line is drawn from the center of the entities selected to pattern and the center of
the reference circle. The Angle spinner is used to modify the angle of this reference line
drawn between the center of entities and the center of the reference circle. As you modify the
value of this spinner, the center of the reference circle will also modify accordingly.

Fixed
If you select the Fixed check box, the radius of the reference circle will be placed as a linear
dimension value after you create the circular pattern.

Center Area
There are two spinners that are available in the Center area. They are the X spinner and the Y
spinner. These two spinners are used to specify the X and Y coordinates of the centerpoint of
the reference circle around which the instances of the circular pattern will be arranged. By
default, the center of the reference circle is coincident with the origin. Therefore, the value of
both these spinners will be 0.00mm, 0.00mm. You will notice that an arrow is displayed at the
centerpoint of the reference circle and the tip of the arrow coincides with the origin. You can
define the new coordinates of the center of the reference circle in these spinners. You can also
define the center of the reference circle by pressing the left mouse button on the control point
provided on the tip of the arrow and dragging the arrow to the desired location. The values of

Figure 2-27  Circular Sketch Step and Repeat dialog box
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the Radius and the Angle spinner in the Arc area and the X and Y spinners in the Center area
will modify accordingly.

Note
Dragging the arrow at the center of the reference circle is the recommended method of defining the
center of the circular pattern.

Step Area
The options in the Step area are used to specify the parameters such as the number of instances
in the pattern, the angle between the instances, and so on. These options are discussed next.

Number
The Number spinner is used to specify the number of instances in the circular pattern. The
default value of this spinner is 4.

Total angle
The Total angle spinner is used to specify the total angle between all the instances of the
circular pattern. The default value of this spinner is 360°. You can enter the desired value of
the angle in this spinner.

Reverse Rotation
The Reverse Rotation button is chosen to reverse the direction of the pattern. By default,
the instances of the circular pattern are arranged in the counterclockwise direction. When
you choose this button, the direction is reversed to clockwise direction. To restore the
counterclockwise direction, choose this button again. Figure 2-28 shows the preview of the
circular pattern with 4 instances arranged in the counterclockwise direction.

Equal
The Equal check box is selected to specify the total angle between all the instances of the
circular pattern. If you clear this check box, the Total angle spinner is replaced by the
Spacing spinner. You can specify the incremental spacing between two successive instances
of the circular pattern in this spinner. Figure 2-29 shows the preview of the circular pattern
with 70° incremental spacing between two successive instances.

Constrain spacing
The Constrain spacing check box is selected to constrain the incremental spacing between
the individual instances of the circular pattern. If this check box is selected, the incremental
spacing will be placed as an angular dimension when you create the pattern. Figure 2-30
shows a circular pattern with the angle and the radius values placed in the pattern.

Tip. You can modify the total angle between the instances by pressing the left mouse
button on the tip of the direction arrow and dragging it.
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Figure 2-29  Creating circular pattern by defining incremental angle
between individual instances

Figure 2-28  Parameters associated with the circular pattern

Note
The other options in this dialog box are similar to those discussed in the linear pattern.

EDITING PATTERNS
You can edit the patterns of the sketched entities by using the shortcut menu that is displayed
when you right-click any instance of the pattern. Based on whether you right-clicked the instance
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Figure 2-30  Radius and angle values placed in the circular pattern

of the linear or the circular pattern, the Edit Linear Step and Repeat or the Edit Circular Step
and Repeat option will be available in the shortcut menu. Figure 2-31 shows the shortcut menu
that is displayed when you right-click one of the instances of a linear pattern.

Figure 2-31  Shortcut menu displayed upon right-clicking an instance
of a linear pattern
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Depending upon whether you choose the option to edit a linear pattern or a circular pattern, the
Linear Sketch Step and Repeat or the Circular Sketch Step and Repeat dialog box will be
displayed. The options that can be edited will be available. Note that the options that cannot be
edited will not be available in these dialog boxes.

MODIFYING SKETCHED ENTITIES
In previous chapters you have learned about drawing the sketched entities. In this chapter you
will learn how to modify them. Modification of various sketched entities is discussed next.

Modifying a Sketched Line
You can modify the sketched lines by using the Line PropertyManager that is displayed when
you select a sketched line using the Select tool. Note that if the selected line is a part of a
rectangle, polygon, or a parallelogram then the entire object will be modified as you modify the
line. This is because the relations are applied to all the lines of a rectangle, polygon, and a
parallelogram.

Similarly, you can also modify the center lines using the Line PropertyManager that is displayed
when you select a center line.

Modifying a Sketched Circle
To modify a sketched circle, select it using the Select tool to display the Sketched Circle
PropertyManager. The coordinate values of the centerpoint of the circle and the value of the
radius will be displayed. You can modify the values that you want.

Modifying a Sketched Arc
To modify a sketched arc, select it using the Select tool. The Arc PropertyManager will be
displayed with the coordinate values of the centerpoint, the startpoint, and the endpoint. The
values of the radius and the included angle will also be displayed. You can modify the values that
you want.

Modifying a Sketched Polygon
To modify a sketched polygon, right-click any one edge of the polygon to display the shortcut
menu. Choose the Edit polygon option from the shortcut menu. The Polygon PropertyManager
will be displayed. You can modify the selected polygon using the options in the Polygon
PropertyManager or draw a new polygon.

Note
If you right-click the reference circle that is automatically drawn when you draw a polygon, the
Edit polygon option will not be available in the shortcut menu.

Tip. The status of the sketched entity that you select for modification is displayed in
the PropertyManager that is displayed. For example, if the selected sketched entity
is fully defined, it will be displayed in the PropertyManager and if the entity is
under defined, the PropertyManager will display that the entity is under defined.
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Modifying a Spline
You can perform four types of modifications on a spline. The first one is the modification of the
coordinates of the selected control point. The second one is adding more control points on the
spline. The third one is modifying the spline using the moving frame. The fourth one is adding
more moving frames. These modifications are discussed next.

Modifying the Coordinates of Control Points
To modify the control points of a spline, select it using the Select tool. The Spline
PropertyManager will be displayed. As mentioned in Chapter-1, the options in the Spline
PropertyManager will be displayed only when you select it after drawing. All the control points
of the spline will be displayed and the current control point will be displayed with a filled
square. The number and the coordinates of the current handle will be displayed in the Spline
PropertyManager. You can select any other handle by using the Spline Control Point spinner.

Adding Control Points
To add control points to the spline, choose Tools > Sketch Tools > Insert Splint Point from
the menu bar or select the spline using the select tool and right-click to invoke the shortcut
menu and choose the Insert Spline Point option from the shortcut menu. Now, select the
points on the spline where you want to add the control points. A box will be displayed at the
point specified on the spline. You can add as many control points as you want to the spline.
After adding the required number of control points, invoke the Select tool and then select the
spline again. You will notice that the boxes of control points will be displayed on all the points
you specified on the spline. You can display the coordinates of a control point using the Spline
Control Point spinner available in the Spline PropertyManager.

Modifying the Spline Using the Moving Frames
To modify a spline using the moving frame select a particular control point of the spline using
the Select tool. The moving frame will be displayed at the selected point. Three handles are
provided on the moving frame to modify the spline. Select one of the handles and drag the
mouse. The spline will be modified dynamically as you drag the cursor. You can also move the
moving frame by dragging the frame point along the spline.

Adding the Moving Frames
To add the moving frame on the spline, select the spline where you want to add the moving
frame using the Select tool and right-click to invoke the shortcut menu. Choose the Moving
Frame option from the shortcut menu. A moving frame will be displayed at the selected point.
You can add as many moving frames as you want to the spline. When a moving frame is not
selected it is displayed as a triangle. As you select a moving frame the Frame Point
PropertyManager is displayed. The Frame Point PropertyManager is used to display the
values of X Coordinate, Y Coordinate, Curvature, and Tangency of the selected moving
frame. Choose the moving frame and press the DELETE key from the keyboard to delete the moving frame.

Simplifying Splines
To simply a spline, select the spline using the select tool and right-click to invoke the shortcut
menu. Choose the Simplify Spline option from the shortcut menu. The Simplify Spline dialog
box is invoked as shown in Figure 2-32. Using this option you can simplify a spline by reducing
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the control points of the spline. Consider a model in which the features are created using the
complex spline curves. You can increase the performance of the model or simplify the complex
sketch using this option. To simplify a spline after invoking the Simplify Spline dialog box,
choose the Smooth button to decrease the number of control points. The value of tolerance will
decrease automatically in the Tolerance spinner when you delete the control points using the
Smooth button. You can also simplify the spline by specifying the tolerance value in the Tolerance
spinner. As you decrease the number of control points the system adjusts the tolerance and
creates a new curve with fewer points. The original spline is displayed in the drawing area and
the preview in the new smooth curve is also displayed. The number of control points of the
original curve and the number of control points in the simplified curve is displayed in the
Number of spline points area.

Converting a Sketched Entity into a Spline
To convert a sketched entity into a spline, create a sketched entity using normal sketching
tools. Choose the Tools > Sketch Tools > Fit Spline option from the menu bar to invoke
the Fit Spline PropertyManager. You can also invoke the Fit Spline PropertyManager

using the Fit Spline button from the Sketch Tools toolbar added after customize. The Fit Spline
PropertyManager is shown in Figure 2-33. Now, select the entities to be converted into a spline

Figure 2-32  The Simplify Spline dialog box

Tip. You can also delete the control points of a spline by selecting the spline and the
control point by using the left mouse button. After you have selected the control
point to be deleted, press the DELETE key. However, note that the control points at
the start and the endpoint of the spline cannot be deleted. Also, you cannot delete
the last intermediate control point in the spline.

You can display the minimum radius of the spline using the Show Minimum
Radius option. Using the Select tool select the spline and right-click to invoke the
shortcut menu. Choose the Show Minimum Radius option from the shortcut menu.
When you modify the spline the minimum radius will also be modified.

You can also display the inflection points of a spline. The inflection points are the
points that are displayed at the position where the concavity of the spline changes.
To display the inflection points select the spline using the Select tool and right-click
to invoke the shortcut menu. Choose the Show Inflection Points option from the
shortcut menu. The symbol of the inflection points is displayed as two arrows pointing
toward each other.
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using the select tool.  Specify the tolerance using the Tolerance spinner. As you specify the
tolerance the value of actual deviation is displayed in the Actual Deviation display box below the
Tolerance spinner. The preview of the spline created is displayed in the drawing area. If you
select the Delete geometry check box then the original sketched entity will be deleted, otherwise
the original sketch will be displayed as a construction geometry. Choose OK from the Fit
Spline PropertyManager or choose the OK icon from the confirmation corner. Now, select the
newly created spline using the select tool and right-click to invoke the shortcut menu. Choose
the Simplify Spline option from the shortcut menu to invoke the Simplify Spline dialog box.
Choose OK from this dialog box to display all the control points of the newly created spline.
Figure 2-34 shows the sketched entities. Figure 2-35 shows the spline created using the Fit
Spline option.

Modifying a Sketched Point
To modify a sketched point, select it using the Select tool. The Sketched Point PropertyManager
will be displayed. You can modify the coordinates of the sketched point using this
PropertyManager.

Figure 2-33  The Fit Spline PropertyManager

Figure 2-34  Sketched entities to be converted into
a spline

Figure 2-35  Spline created using the Fit Spline
option
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Modifying an Ellipse or an Elliptical Arc
To modify an ellipse or an elliptical arc, select it using the Select tool. The Ellipse
PropertyManager will be displayed. If you select an ellipse, the parameters that will be available
for modification are the coordinates of the centerpoint and the radius of the two axes. However,
if you select an elliptical arc, all the options in the Ellipse PropertyManager will be available
such as the coordinates of the startpoint, endpoint, and centerpoint of the arc, radius of the two
axes, and so on.

Modifying a Parabola
To modify a parabola, select it using the Select tool. The Parabola PropertyManager will be
displayed. You can modify the parameters of a parabola from this PropertyManager.

Dynamically Modifying and Copying the Sketched
Entities
In the sketcher environment of SolidWorks you can modify or copy the sketched entities by
dynamically dragging them using the left mouse button. For example, consider a case where you
create a sketch of a rectangle and you want to increase the size of the rectangle. You simply have
to choose the Select button from the Sketch Tools toolbar to deactivate the rectangle command.
Using the left mouse button select any of the line of the rectangle or select any of the vertex of
rectangle and hold down the left mouse button to drag the mouse. Drag the sketch according to
your requirement and then release the left mouse button. If you choose Tools > Sketch Setting
> Detach Segment on Drag from the menu bar (you can confirm whether the detachment is
active by choosing Tools > Sketch Tools; you will notice a check mark in front of the Detach
Segment on Drag option) then if you select a line of the rectangle to drag, and when you release
the left mouse button after dragging, the line segment will be detached from the rectangle. To
deactivate the detachment of the line segment again choose Tools > Sketch Tools > Detach
Segment on Drag from the menu bar (you can confirm whether the detachment is deactivated by
choosing Tools > Sketch Tools; you will notice that the check mark is not available in front of
the Detach Segment on Drag option).

You can also copy the sketched entities dynamically. Select the sketched entity or entities to be
copied using the left mouse button or by creating a window around the entities to be copied.
Press and hold down the CTRL key on the keyboard and hold down the left mouse button and
drag the selected entity or entities to be copied. Release the left mouse button to place the new
entity. Again hold down the left mouse button and drag the selected entity and release the left
mouse button where you want to place the entities. Repeat the same procedure if you want more
copies of the same entity. After you complete the copying operation release the CTRL key from
the keyboard.

Splitting the Sketched Entity

Using the Split Curve option you can split a sketched entity into two or more than two
entities by specifying the split points. To split a curve choose the Split Curve button

Menu: Tools > Sketch Tools > Split Curve    (Customize to Add)

Toolbar: Sketch Tools > Split Curve
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from the Sketch Tools toolbar; the current cursor will be replaced by the split curve cursor. Move
the cursor to an appropriate location where you have to split the sketched entity. When the
cursor snaps the entity, use the left mouse button to add a split point. Now right click to display
the shortcut menu and choose the select option from the shortcut menu. Using the select cursor
select the sketched entity. You will notice that the sketched entity is divided in two entities
because a split point is added between the two sketched entities. You can add as many split
points as you need. You can also delete the split points to convert the split entity into a single
entity. To delete the split point, use the left mouse button to select the split point and press the
DELETE key from the keyboard or right-click to display the shortcut menu and choose the
Delete option from the shortcut menu.

NOTE
It is recommended that you should use two split points to split a circle, a full ellipse, or a closed
spline.

Modifying the Entire Sketch

The Modify Sketch option is used to move, rotate, or scale the entire sketch. The
Modify Sketch button is available in the Sketch toolbar and this button is active only
when you have created at least one sketched entity. When you choose the Modify

Sketch button from the Sketch toolbar, the Modify Sketch dialog box is displayed and the
current cursor is replaced by the Modify Sketch cursor. You will notice that a moveable origin is
also displayed in the drawing area along with the sketch origin and the document origin. The
Modify Sketch dialog box is displayed in Figure 2-36. The various options available in the
Modify Sketch dialog box are discussed next.

Note
You will learn more about the document origin in the later chapters.

Scale About
The Scale About area of the Modify Sketch dialog box is used to scale the sketch. The options
in this area are used to select the origin along which you have to scale the sketch by specifying

Figure 2-36  The Modify Sketch dialog box

Menu: Tools > Sketch > Modify Sketch (Customize to Add)

Toolbar: Sketch > Modify Sketch
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the scale factor. The options available in this area of the Modify Sketch dialog box are discussed next.

Sketch origin
The Sketch Origin radio button is selected to scale the sketch with respect to the sketch
origin. The sketch origin is displayed when you enter the sketching environment.

Moveable origin
The Moveable origin radio button is selected to scale the sketch with respect to the moveable
origin. The moveable origin is displayed when you invoke the Modify Sketch dialog box.
The moveable origin can be moved by dragging using the left mouse button.

Factor
The Factor edit box is used to specify the scale factor. The sketch will be scaled using the
scale factor provided in the Factor edit box. Enter a value of scale factor in the Factor edit
box and press ENTER.

Note
You cannot scale a sketch if it is having a reference with some external entity or element. You will
learn more about referring the external entities in the later chapters.

Translate
The options available in the Translate area are used to move the sketch geometry by specifying
the incremental values. The options available in the Translate area of the Modify Sketch dialog
box that are used to translate the sketch are discussed next.

X value
The X value edit box is used to specify the incremental value in the x direction for translating
the sketch in the x direction. To translate the sketch in the x direction, enter a value in the
X value edit box and press ENTER.

Y value
The Y value edit box is used to specify the incremental value in the y direction for translat-
ing the sketch in the y direction. To translate the sketch in the y direction, enter a value in
the y value edit box and press ENTER.

If you want to translate a sketch in both the x direction and the y direction simultaneously
then enter the incremental value in the X value edit box and the Y value edit box and then
press ENTER.

Position selected point
The Position selected point check box is selected to translate a specified point of the sketch
to a specific location. Select the Position selected point check box and the Modify Sketch

Tip. If you want to move the moveable origin, move the cursor near the moveable
origin that is displayed in black color. When the cursor snaps the moveable origin
press and hold down the left mouse button and drag the cursor to a location where
you have to place the origin and release the left mouse button to place the moveable
origin.
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cursor is replaced by the select cursor. By default the sketch origin is selected and you can
confirm it by observing a green rectangle at the origin. Using the left mouse button select
the point in the sketch that you want to move. Now specify the incremental values in the X
value edit box and the Y value edit box and press ENTER.

Note
The Modify Sketch option translates or moves the entire sketch including the sketch origin. The
sketch geometry does not move relative to the origin of the sketch, which is known as sketch
origin.

You can also translate or move the entire sketch using the left mouse button. After
invoking the Modify Sketch dialog box the cursor will be replaced by the modify sketch
cursor. The move symbol will be displayed on the left mouse button of the modify sketch

cursor. Press and hold the left mouse button anywhere on the drawing area, and drag the
cursor to move or translate  the sketch. Release the left mouse button where you have to place
the sketch.

Rotate
The Rotate area is used to rotate the entire sketch with moveable origin as the centerpoint for the
rotation of the sketch. For rotating a sketch, enter a value in the Rotate edit box and press
ENTER. To change the centerpoint for the rotation of the sketch, move the moveable origin as
discussed earlier. The entire sketch will be rotated along with the sketch origin.

You can also rotate the sketch dynamically. Invoke the Modify Sketch dialog box. The
cursor will be replaced by the modify sketch cursor. The rotate symbol will be displayed
on the right mouse button of the modify sketch cursor. Press and hold the right mouse

button anywhere on the screen. A rubber-band line will be attached to the cursor and the other
end of the same line will be attached to the moveable origin. Drag the cursor in the clockwise
direction or the counterclockwise direction to rotate the sketch about the moveable origin.

Note
You cannot move the sketch if the sketch is having multiple external references. The cursor will
show a ? symbol on the left of the cursor. If you press the left mouse button when this symbol
appears the SolidWorks warning message window will be displayed. This warning message
window will prompt you that you cannot translate the sketch. But you can rotate the referenced
sketched entity.

Flipping the Sketch
You can flip the sketch using the mouse with respect to the moveable origin. The various options
for flipping the sketches using the mouse are discussed next.

Moving the Moveable Origin and Flipping the Sketch Diagonally
When you invoke the Modify Sketch dialog box, the cursor will be replaced by the
modify sketch cursor. When you move the cursor to the origin of the moveable origin,
the cursor with a point symbol will be displayed on the left mouse button of the modify

sketch cursor. The point symbol is used to move the moveable origin. A diagonal flip
symbol will be displayed on the right mouse button of the modify sketch cursor. You can flip
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the sketch diagonally using the right mouse button with respect to the moveable origin.
When you flip the sketch using this option the entire sketch will be flipped diagonally along
with the sketch origin.

Moving the Sketch and Flipping the Sketch Horizontally
Move the modify sketch cursor to the black square near the horizontal arrow of the
moveable origin. The move symbol will be displayed on the left mouse button of the
modify sketch cursor. Using the left mouse button you can move the entire sketch along

with the moveable origin and the sketch origin. The horizontal flip symbol will be displayed
on the right mouse button of the modify sketch cursor. You can flip the entire sketch
horizontally along with the moveable origin using the right mouse button.

Moving the Sketch and Flipping the Sketch Vertically
Move the modify sketch cursor to the black square near the vertical arrow of the moveable
origin. The move symbol will be displayed on the left mouse button of the modify sketch
cursor. As discussed earlier, using the left mouse button you can move the entire sketch

along with the moveable origin and the sketch origin. The vertical flip symbol will be
displayed on the right mouse button of the modify sketch cursor. You can flip the entire
sketch vertically along with the moveable origin using the right mouse button.

TUTORIALS

Tutorial 1
In this tutorial you will create the base sketch of the model shown in Figure 2-37. The sketch of
the model is shown in Figure 2-38. You will have to create the sketch of the base feature using the
normal sketch tools and then modify and edit the sketch using various sketch modifying options.

    (Expected time: 30 min)

Figure 2-37  Solid Model for Tutorial 1
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The steps that will be followed to complete this tutorial are listed next;

a. Start SolidWorks and then open a new part file.
b. Maximize the part file document and then switch to the sketching environment.
c. Draw the outer loop of the sketch of the given model, refer to Figures 2-39 and 2-40.
d. Create the inner cavity using the Centerpoint Arc and the Tangent arc tools, refer to Figure

2-41.
e. Use the Circular Sketch Step and Repeat tool to create a circular pattern of the inner

cavity, refer to Figure 2-42.
f. Complete the sketch by creating the circles that define the hole in the outer loop.
d. Modify and edit the sketch using the Circular Sketch Step and Repeat tools, refer Figure 2-43.

Starting SolidWorks and Opening a New SolidWorks Document
1. Start SolidWorks by choosing Start > Programs > SolidWorks 2003 > SolidWorks 2003

or by double-clicking the shortcut icon of SolidWorks available on the desktop of your
computer.

The Welcome to SolidWorks window and the Tip of the Day dialog box will be displayed.
The Tip of the Day dialog box is overlapping this window. As mentioned earlier, the tips
that are displayed in this dialog box are very useful in making the best use of SolidWorks.

2. Close the Tip of the Day dialog box by choosing the Close button.

Figure 2-38  The sketch of the base feature
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3. Choose the New Document option from the Welcome to SolidWorks window.

The New SolidWorks Document dialog box will be displayed.

4. The Part option is selected by default in the New SolidWorks Document dialog box.
Choose the OK button from this dialog box.

A new SolidWorks part document will be opened. But the part document window will not be
maximized in the SolidWorks window.

5. Choose the Maximize button available on the upper right corner of the part document
window to maximize the document window.

By default, when you open a new part document, the part modeling environment is active.
However, since you need to draw the sketch of the feature, you need to invoke the
sketching environment.

6. Choose the Sketch button from the Sketch toolbar to invoke the sketching
environment.

You will notice that the sketch origin is also displayed along with the document origin
shown in gray color. This red color origin indicates that the sketching environment is
activated.

Modifying the Snap and Grid Settings and the Dimensioning Units
Before you proceed with drawing the sketch, you need to modify the grid and snap settings so
that you can make the cursor jump through a distance of 10mm instead of 25mm, which is the
default value.

1. Choose the Grid button from the Sketch toolbar. The Document Properties -
Grid/Snap dialog box is displayed.

2.  Set the value of the Minor-lines per major spinner to 10.

Since by default the Snap to points option is not selected, therefore, you need to select this
option manually.

3. Select the Snap to points check box from the Snap area of the Document Properties -
Grid/Snap dialog box.

The coordinates displayed close to the lower left corner of the SolidWorks window will show
an increment of 10mm instead of the default increment of 25mm when you exit the dialog
box.

If by default the grid is displayed when you invoke the sketching environment, you can
remove the display of grid. To remove the grid clear the Display grid check box from the
Grid area of Document Properties - Grid/Snap dialog box.
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If you selected units other than millimeter to measure the length while installing SolidWorks,
you need to select the units for the current drawing.

4. Select the Units option from the area on the left of the Document Properties - Grid/Snap
dialog box.

5. Select Millimeter from the drop-down list available in the Linear units area and Degrees
from the drop-down list available in the Angular units area.

6. Choose the OK button after making the necessary settings.

Creating the Outer Loop of the Sketch
First, you will create the outer loop of the sketch. As evident from Figure 2-38, the sketch consists
of the outer loop and inner cavities. It is recommended that for complex sketches, you should
first create the outer loop of the sketch. Then you can proceed with the inner cavities.

The origin of the sketcher environment is placed in the middle of the drawing area and you
have to create the sketch in the first quadrant. Therefore, it is recommended that you modify the
drawing area. This can be done using the Pan tool.

1. Choose the Pan button from the View toolbar to invoke the pan tool.

The select cursor is replaced by the pan cursor.

2. Press and hold down the left mouse button near the sketch origin.

3. Drag the cursor to the lower left corner of the drawing area.

You will notice that the sketch origin moves near the lower left corner of the drawing area.

4. Choose the Circle button from the Sketch Tools toolbar. The pan cursor will be
replaced by the circle cursor.

5. Move the cursor to a location where the value of the coordinates is 70mm 70mm 0mm.

6. Using the left mouse button, specify the centerpoint of the circle at this location and move
the cursor horizontally toward the right. When the radius above the circle cursor shows a
value of 50, press the left mouse button.

7. Choose the Zoom to Area button from the View toolbar. Using the left mouse button, create
a window such that the sketched circle and the sketch origin are placed in the window.

When you release the left mouse button the display area of the sketch will be increased.

Tip. You can also pan without using the pan tool. Choose CTRL+middle mouse
button to pan or move the sketch origin.
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8. Choose the Center line button from the Sketch Tools toolbar to draw a horizontal
center line from the center of the circle toward the right, see Figure 2-39.

9. Choose the Circle button from the Sketch Tools toolbar to invoke the circle tool.

10. Move the cursor at the intersection of the center line and the bigger circle.

11. Using the left mouse button, specify the centerpoint of the circle at this location and move
the cursor horizontally toward the right. When the value of the radius above the circle cursor
shows a value of 10, press the left mouse button.

12. Choose the Sketch Trim button from the Sketch Tools toolbar to invoke the trim
tool.

13. Trim the part of the sketch so that the sketch looks similar to the one shown in Figure 2-39.

14. Choose the Circular Sketch Step and Repeat button from the Sketch Tools toolbar.

The Circular Sketch Step and Repeat dialog box is displayed and the cursor is replaced by
the circular pattern cursor.

15. Using the circular pattern cursor, select the smaller trimmed circle. The preview of the
circular pattern with default setting is displayed in the drawing area.

You will notice that the center of the circular pattern, which is displayed with an arrow, is
placed at the origin. However, since the origin is not the actual center of the circular pattern,
you need to modify the centerpoint of the circular pattern. You can modify the center of the

Figure 2-39  Sketch after trimming the unwanted entities
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circular pattern by entering the coordinates of the point in the X and Y spinners available
in the Center area of this dialog box. But, the recommended method of modifying the
center of the circular pattern is by dragging the arrow that is displayed at the center of the
pattern.

16. Move the circular pattern cursor at the control point available at the end of the arrow that is
displayed at the origin.

The circular pattern cursor will turn yellow in color.

17. Press and hold the left mouse button down at the control point and drag it to the center of
the outer trimmed circle in the sketch. Release the left mouse button when the cursor turns
yellow in color.

You will notice that the X and the Y spinners in the Center area show 70 mm as the values.
This is because the center of the outer trimmed circle is located at a distance of 70 mm along
the X and Y axis directions.

The default value of the number of items in the pattern is 4. But since you need 6 items in
the pattern, you need to modify this value.

18. Set the value of the Number spinner in the Step area to 6. Accept all the other default values
and choose the OK button to create the pattern.

19. Trim the unwanted portion of the outer trimmed circle using the Sketch Trim tool. Now, the
outer loop of the sketch is complete. The sketch should look similar to the one shown in
Figure 2-40.

Figure 2-40  Outer loop of the sketch
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Drawing the Sketch of the Inner Cavity
Now, you need to draw the sketch of the inner cavities. You will draw the sketch of one of the
cavities. Next, you will create circular pattern of this cavity. The number of items in the
circular pattern will be 3.

Before creating the sketch of the inner cavity, you need to create a centerline that will act as
a reference for creating the sketch of the inner cavity.

1. Choose the Centerline button from the Sketch Tools toolbar.

2. Move the cursor close to the center of the outer circle. When the cursor changes to yellow
color, specify the startpoint using the left mouse button. Hold the CTRL key down and
move the cursor to a location where the angle of the line is shown close to 30-degree and the
length is 35. Using the left mouse button, specify the endpoint of the line.

3. Exit the Centerline tool and select the centerline. The Line PropertyManager is displayed.
Set the value of the Length spinner to 35 and the Angle spinner to 30.

4. Choose the Circle button from the Sketch Tools toolbar.

5. Move the cursor to the upper endpoint of the inclined centerline. When the cursor turns
yellow in color, use the left mouse button to specify the centerpoint of the circle. Move the
cursor horizontally toward the right. When the value of the radius is shown close to 5 above
the circle cursor, use the left mouse button to complete the creation of the circle.

6. Set the value of the radius of the circle to 5 in the Radius spinner of the Circle
PropertyManager.

7. Choose the Circular Sketch Step and Repeat button from the Sketch Tools toolbar.

The Circular Sketch Step and Repeat dialog box is displayed and the cursor is replaced by
the circular pattern cursor. You will notice that the center of the circular pattern, which is
displayed with an arrow, is placed at the origin. Since the origin is not the actual center of
the circular pattern, you need to modify the centerpoint of the circular pattern. You can
modify the center of the circular pattern by entering the coordinates of the point in the X
and Y spinners available in the Center area of this dialog box. However, the recommended
method of modifying the center of the circular pattern is by dragging the arrow that is
displayed at the center of the pattern.

8. Move the circular pattern cursor at the control point available at the end of the arrow that is
displayed at the origin.

9. The circular pattern cursor is displayed in yellow color. Now, press and hold down the left
mouse button at the centerpoint and drag the cursor to the centerpoint of the outer trimmed
circle. Release the left mouse when the circular pattern cursor turns yellow.

10. Set the value of the Number spinner to 2.
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11. Set the value of the Total angle spinner to 45 deg and choose the Reverse Rotation
button.

12. Choose OK from the Circular Sketch Step and Repeat dialog box.

13. Choose the Centerpoint Arc button from the Sketch Tools toolbar.

14. Move the cursor to the centerpoint of the outer trimmed circle. Use the left mouse button to
specify the centerpoint of the arc. Now, move the cursor to the intersection of the center line
and circle. Specify the startpoint of the arc when the intersection symbol appears.

15. Move the cursor in the counterclockwise direction. When the value of the angle above the
arc cursor shows a value of 45-degree, press the left mouse button to specify the endpoint of
the arc.

Next, you will offset the arc created in the previous step to an offset distance of 10. You will
use the offset tool to offset the arc.

The arc created earlier is displayed in green. This means that the arc is already selected. If
the arc is not selected, select the arc using the left mouse button before invoking the offset
tool.

16. Choose the Offset Entities button from the Sketch Tools toolbar. The Offset Entities
PropertyManager is displayed.

17. Set the value of the Offset Distance spinner to 10 and clear the Reverse check box if
selected. Choose the OK button from the Offset Entities PropertyManager.

18. Choose the Sketch Trim button from the Sketch Tools toolbar to invoke the trim
tool.

19. Trim the unwanted portion of the inner cavity using the Trim tool. The sketch after completing
the inner cavity is shown in Figure 2-41.

Creating the Pattern of the Inner Cavity
Next, you will create the pattern of the inner cavity using the Circular Sketch Step and
Repeat tool. The pattern of the inner cavity consists of three instances. The centerpoint of
the pattern lies at the centerpoint of the outer trimmed circle.

Before invoking this option, press the CTRL key from the keyboard and using the left
mouse button, select all the entities of the inner cavity.

1. Choose the Circular Sketch Step and Repeat button from the Sketch Tools toolbar
to invoke the Circular Sketch Step and Repeat dialog box.

The Circular Sketch Step and Repeat dialog box is displayed and the cursor will be replaced
by the circular pattern cursor. You will notice that the center of the circular pattern, which is
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displayed with an arrow, is placed at the origin. Since the origin is not the actual center of
the circular pattern, you need to modify the centerpoint of the circular pattern.

2. Press and hold the left mouse button down at the control point of the arrow that is displayed
at the origin. Drag it to the center of the outer trimmed circle in the sketch. Release the left
mouse button when the cursor turns yellow in color.

You will notice that the X and the Y spinners in the Center area show 70 mm as the values.

The default value of the number of items in the pattern is 4. But since you need 3 items in
the pattern, you need to modify this value.

3. Set the value of the Number spinner in the Step area to 3. Accept all the other default values
and choose the OK button to create the pattern.

The sketch after creating the pattern of the inner cavity is shown in Figure 2-42.

Sketching the Holes
Next, you need to create the sketch of the holes. The centerpoint of the circle is located at
the centerpoint of the outer trimmed arc. As evident from Figure 2-38, you need to create a
total of six circles. After creating the first circle, you will create the other five circles by
creating a circular pattern of the parent circle.

1. Choose the Circle button from the Sketch Tools toolbar.

2. Move the cursor to the centerpoint of the right trimmed arc.

3. When the circle cursor turns yellow in color, use the left mouse button to specify the centerpoint

Figure 2-41  The sketch of the outer loop and the inner cavity
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of the circle. Press the CTRL key from the keyboard and move the cursor toward the right.
When the value of the radius above the circle cursor shows a close of 5, press the left mouse
button.

4. Set the value of the Radius spinner to 5 in the Circle PropertyManager.

5. Choose the Circular Sketch Step and Repeat button from the Sketch Tools toolbar to
invoke the Circular Sketch Step and Repeat dialog box.

6. Move the circular pattern cursor to the control point of the arrow displayed at the origin.
When the cursor turns yellow in color, press and hold the left mouse button and drag the
cursor to the centerpoint of the outer trimmed circle. Release the left mouse button when the
cursor turns yellow in color.

7. Set the value of the Number spinner to 6 in the Step area of the Circular Sketch Step and
Repeat dialog box. Accept all the other default values and choose OK in this dialog box.

The final sketch of Tutorial 1 is shown in Figure 2-43.

Saving the Sketch
As mentioned earlier, it is recommended that you create a separate directory for saving the
tutorial files of each chapter. When you invoke the option to save the document, the default
directory that is displayed is /My Documents. As you have already created a directory called
SolidWorks in this directory, it will be displayed along with other directories. Double-click
the SolidWorks directory. Now, you will create another directory inside the SolidWorks directory
and save the document.

Figure 2-42  Sketch after creating the pattern of the inner cavity
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1. Choose the Save button from the Standard toolbar to invoke the Save As dialog
box.

2. Choose the  Create New Folder button from the Save As dialog box. Enter the name of the
folder as c02 and press ENTER.

3. Enter the name of the document as c02-tut01.sldprt in the File name edit box and choose the
Save button.

The document will be saved in the /My Documents/SolidWorks/c02 directory.

4. Close the file by choosing File > Close from the menu bar.

Tutorial 2
In this tutorial you will create the base sketch of the model shown in Figure 2-44. The sketch of
the model is shown in Figure 2-45. You will create the sketch with mirror line and mirror tool.
After creating the sketch, you will modify it by dragging the sketched entities.

    (Expected time: 30 min)

The steps that will be followed to complete this tutorial are listed below;

a. Open a new part file.
b. Maximize the part file document and then switch to the sketching environment.
c. Creating the center lines and create a mirror line using one of the center line and the mirror

tool.
d. Create the sketch in the third quadrant; the sketch will automatically mirrored to other side,

refer to Figure 2-46
e. Mirror the entire sketch along the second mirror line, refer to Figure 2-47.

Figure 2-43  Final sketch
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f. Modify the sketch by dragging the sketched entities, refer to Figure 2-48.

Opening a New File
1. Choose the New button from the Standard toolbar to invoke the New

SolidWorks Document dialog box.

2. Select the Part option and then choose the OK button from the New SolidWorks Document
dialog box

A new SolidWorks part document will be opened. But the part document window will not be
maximized in the SolidWorks window.

Figure 2-44  Solid model for Tutorial 2

Figure 2-45  Sketch of the model
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3. Choose the Maximize button available on the upper right corner of the part document
window to maximize the document window.

As mentioned earlier, when you open a new part document, the part modeling environment
is active by default. However, since you first need to drag the sketch of the revolved model,
you need to invoke the sketching environment.

4. Choose the Sketch button from the Sketch toolbar to invoke the sketching
environment.

The origin will turn red in color and the Sketch Tools toolbar will be displayed below the
Sketch toolbar, suggesting that the sketching environment is activated.

Since the default settings of the snap and grid are not the same as required, therefore, you
need to modify the snap and grid settings.

5. Invoke the Document Properties - Grid/Snap dialog box and clear the Display grid check
box, if selected. Set the value of the Minor-lines per Major spinner to 10. Select the Snap
to points check box to activate the snap option.

It is assumed that you have selected the unit of measuring as millimeter while installing
SolidWorks. However, if you have selected any other unit while installation then you need to
change the units.

6. Select the Units option available below the Grid/Snap option in the area provided at the left
of the Document Properties -Grid/Snap dialog box.

7. Select the Units option from the drop-down list available in the Linear units area. Select
the Degrees option from the drop-down list available in the Angular units area. Choose
OK to exit the dialog box.

Creating the Center Lines and a Mirror Line
In this tutorial you will create the sketch of the given model with the help of a mirror line.
The sketches that are symmetrical along any axis are recommended to be drawn using the
mirror line. The design intent is captured in the sketches drawn using the mirror line or a
mirror tool because a symmetric relation is established between the parent entity and the
mirrored image. The mirror line is created using the Centerline and Mirror tools. After
creating a mirror line, when you draw the entities on one side of the mirror line, the same
entities will be created automatically on the other side of the mirror line. The entities
created on the other side are the mirror image of the entities you draw. A symmetrical
relation is applied to the entities on both sides of the mirror line. Therefore, if you modify
an entity on one side of the mirror line, then the same modification will be applied to the
mirrored entity and vice versa. First, you need to create a mirror line.

1. Choose the Centerline button from the Sketch Tools toolbar.

The select cursor will be replaced by the line cursor.
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2. Move the line cursor to a location where the value of the coordinates is 0mm 100mm 0mm.

3. Use the left mouse button to specify the startpoint of the center line and move the cursor
vertically downwards. Use the left mouse button to specify the endpoint of the center line
when the length of the line cursor shows a value of 200.

4. Now, double-click anywhere on the screen to end the line creation or press the right mouse
button anywhere on the drawing area to invoke the shortcut menu. Choose the End chain
option from the shortcut menu.

5. Move the line cursor to a location where the value of the coordinates is -100mm 0mm 0mm.

6. Use the left mouse button to specify the startpoint of the center line and move the cursor
horizontally toward the right. Use the left mouse button to specify the endpoint of the
center line when the length of the line cursor shows a value of 200.

7. Right-click to invoke the shortcut menu and choose the Select option. The line cursor will
be replaced by the select cursor.

8. Select the vertical center line. The selected center line will be displayed in green color.

9. Choose Tools > Sketch Tools > Mirror from the menu bar or choose the Sketch
Mirror button from the Sketch Tools toolbar to create the mirror line and activate
the automatic mirror option.

You can confirm the creation of the mirror line and the activation of the automatic mirror
option by observing the symmetrical symbol applied to both the ends of the centerline.  The
line cursor is changed to the select cursor as soon as you convert a center line into a mirror
line.

Drawing the Sketch
Next, you will create the sketch of the base feature. You will create the sketch in the third
quadrant, which is on one side of the mirror line. The same sketch will be created automatically
on the other side of the mirror line. The symmetrical relation is applied between the parent
entity and the mirrored entity.

1. Choose the Line button from the Sketch Tools toolbar to invoke the line tool. The
select cursor will be replaced by the line cursor.

2. Move the line cursor to a location where the value of the coordinates is 0mm -100mm 0mm.

3. Use the left mouse button at this location to specify the startpoint of the line and move the
cursor horizontally toward the left.

4. Use the left mouse button to specify the endpoint of the line when the value of the length of
the line above the line cursor shows a value of 90.
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You will notice that as soon as you specify the endpoint of the line, a mirror image is
automatically created on the other side of the mirror line. This line created as the mirror
image is merged with the line drawn on the left. Therefore, the entire line becomes a single
entity. Note that the lines will merge only if one of the endpoints of the line you draw is
coincident with the mirror line.

A rubber-band line is attached to the cursor with its startpoint attached to the endpoint of
the previous line.

5. Move the cursor vertically upwards. Use the left mouse button to specify the endpoint of the
line when the value of the length of the line above the line cursor shows a value of 30.

You will notice that as soon as you specify the endpoint of a line, a mirror image is automatically
created on the other side of the mirror line.

The rubber-band line is still attached to the cursor. The startpoint of the rubber-band line is
attached to the endpoint of the previous line.

6. Move the line cursor toward the right. Use the left mouse button to specify the endpoint of
the line when the length of the line above the line cursor shows a value of 30.

A mirror image is automatically created on the other side of the mirror line.

7. Move the line cursor vertically upwards. Use the left mouse button to specify the endpoint of
the line when the line cursor snaps the horizontal center line. Exit the Line tool.

The sketch after creating the lines is shown in Figure 2-46.

Figure 2-46  Sketch after creating the lines
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Mirroring the Entire Sketch
After creating one half of the sketch, you need to mirror the entire sketch about the horizontal
center line. Before mirroring the sketch, you need to disable automatic mirroring.

1. As evident from the Sketch Tools toolbar the Sketch Mirror button is activated.
Choose the Sketch Mirror button to disable automatic mirroring.

Now, the vertical center line will not work as a mirror line.

2. Use the CTRL key from the keyboard and the left mouse button to select all the lines
sketched earlier and the horizontal center line.

3. Choose the Sketch Mirror button from the Sketch Tools toolbar.

As soon as you select the Sketch Mirror button, the entire sketch will be mirrored along the
horizontal center line. The sketch after mirroring is shown in Figure 2-47.

Modifying the Sketch by Dragging
Next, you will modify the sketch by dragging the sketched entities using the left mouse
button. While dragging the entities, you will observe that the corresponding mirrored entity
will also be modified.

1. Select the lower right vertical line. The Line PropertyManager will be displayed on the left
of the drawing area.

You will notice that the value of the length in the Length spinner shows a value of 30. But
the length of this line should be 20. Therefore, you need to edit this sketch. In this tutorial,
you will edit the sketch by dragging. You will observe that when you drag one line, all the
dependent lines are also modified.

Figure 2-47  Sketch after mirroring the sketched entities
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2. Select the top horizontal line and drag the cursor vertically downward. Release the left
mouse button when the value of the Start Y Coordinate spinner and End Y Coordinate
spinner decreases by 10.

You will observe that all the sketched entities that are related to the dragged entity are also
modified because of the symmetric relations applied to them. This is because they are
created using the Mirror tool. If you create an entity using the mirror tool and modify it, the
other entities associated to it will be modified accordingly.

3. Select the lower left vertical line and drag the cursor horizontally toward the right. Release
the left mouse button when the value of the Start X Coordinate spinner and the End Y
Coordinate spinner decreases by 10.

4. Select the middle left vertical line and drag the cursor horizontally toward right. Release the
left mouse button when the value of the Start X Coordinate spinner and the End X
Coordinate spinner shows a value of -10.

The final sketch after modifying the sketched entities by dragging is shown in Figure 2-48.

Saving the Sketch
1. Choose the Save button from the Standard toolbar to invoke the Save As dialog

box.

2. Enter the name of the document as c02-tut02.sldprt in the File name edit box and choose the
Save button.

The document will be saved in the /My Documents/SolidWorks/c02 directory.

3. Close the file by choosing File > Close from the menu bar.

Figure 2-48  Final sketch for Tutorial 2
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Tutorial 3
In this tutorial you will create the basic sketch of the model shown in Figure 2-49. The sketch is
shown in Figure 2-50. You will create the sketch using the various sketching tools. After creating
the sketch, you will edit the sketch using the sketch mirror, sketch offset, sketch extend, and
sketch trim options. The solid model is given only for your reference. (Expected Time: 30 min.)

The steps that will be followed to complete this tutorial are listed below:

a. Open a new part file.
b. Maximize the part file document and then switch to the sketching environment.

Figure 2-49  Solid model for Tutorial 3

Figure 2-50  Sketch for Tutorial 3
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c. Create a centerline, which will be used for reference.
d. Draw the sketch and edit the sketch using the sketch mirror tool, and the sketch trim tool,

refer to Figure 2-51.
e. Offset the entire sketch, refer to Figure 2-52
f. Complete the final editing of the sketch using the sketch extend and sketch trim tools, refer

Figures 2-52 and 2-54.

Opening a New File
1. Choose the New button from the Standard toolbar to invoke the New SolidWorks

Document dialog box.

2. Select the Part option and then choose the OK button from the New SolidWorks Document
dialog box.

A new SolidWorks part document will be opened. However, as mentioned earlier, the part
document will not be maximized in the SolidWorks window.

3. Choose the Maximize button available on the upper right corner of the part document
window to maximize the document window.

4. Choose the Sketch button from the Sketch toolbar to invoke the sketching
environment.

The origin will turn red in color and the Sketch Tools toolbar will be displayed below the
Sketch toolbar, suggesting that the sketching environment is activated.

5. Using the Document Properties - Grid/Snap dialog box, set the value of the Minor-lines
per major spinner to 10. Also, select the Snap to Point check box.

Creating the Center Line
Before creating the sketch, you need to create a center line  that  will act as a reference for the
other sketch entities. This center lines will be used for mirroring.

1. Choose the Center Line button from the Sketch Tools toolbar. The arrow cursor
will be replaced by the line cursor.

2. Move the cursor to a location where the value of the coordinates is -70mm 0mm 0mm.

3. Specify the startpoint of the center line at this location and move the cursor horizontally
toward the right.

4. Specify the endpoint of the centerline when the value of the length of the centerline above
the line cursor shows a value of 140.

5. Double-click anywhere in the drawing area to end line creation.
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Drawing the Outer Loop of the Sketch
After creating the center line, you will create the outer loop of the sketch using the sketch
tools. As evident from Figure 2-50, the sketch is drawn using the Circle and the Line tools.

1. Choose the Circle button from the Sketch Tools toolbar. The line cursor will be
replaced by the circle cursor.

2. Move the circle cursor to the origin and when the cursor turns yellow in color, press the left
mouse button to specify the centerpoint of the circle.

3. Move the cursor horizontally toward the right and press the left mouse button when the
radius of circle above the circle cursor shows a value of 50.

4. Choose the Zoom to Fit button from the View toolbar to increase the display of the
sketch.

5. Choose the Line button from the Sketch Tools toolbar.

6. Move the cursor to a location where the value of the coordinates is -60mm 10mm 0mm.
Specify the startpoint of the line at this location.

7. Move the cursor horizontally toward the right and press the left mouse button to specify the
endpoint of the line when the line cursor snaps the circle. Right-click to invoke the shortcut
menu and choose Select to invoke the select cursor.

8. Press the CTRL key from the keyboard and using the left mouse button, select the horizontal
line created in the last step and the horizontal center line. Both the selected entities will be
displayed in green color.

9. Choose the Sketch Mirror button from the Sketch Tools toolbar. The mirror image
of the left horizontal line will be created on the other side of the center line.

10. Choose the Line button from the Sketch Tools toolbar.

11. Move the cursor to the left endpoint of the upper horizontal line. Specify the startpoint of
the line when the cursor turns yellow in color.

12. Move the cursor vertically downwards. Specify the endpoint of the line when the cursor
snaps the endpoint of the lower horizontal line.

13. Double-click anywhere in the drawing area to end line creation.

14. Choose the Sketch Trim button from the Sketch Tools toolbar. The line cursor will
be replaced by the trim cursor. Trim the unwanted portion of the circle.

The sketch of the outer loop after trimming the unwanted portion of the sketch is shown in
the Figure 2-51.
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Offsetting the Entities
After creating the outer loop of the sketch, you will create the inner cavity. The first step in
creating the inner cavity of the sketch will be offsetting the entire sketch inwards.

1. Choose the Sketch Offset button from the Sketch Tools toolbar; the trim cursor will
be replaced by the select cursor. The Offset Entities PropertyManager is displayed
on the left of the drawing area.

2. Set the value of the Offset Distance spinner to 4. Select any one of the entity of the sketch
of the outer loop.

When you select the sketch, the preview of the offset sketch is displayed in the drawing area.
But the direction of the offset is outside the sketch. The required direction of offset is inside
the sketch. Therefore, you need to flip the direction.

3. Move the cursor inside the sketch and press the left mouse button to create the offset sketch
with reverse direction. A dimension with a value of 4 is displayed with the sketch.

The sketch after offsetting the outer loop is shown in Figure 2-52.

4. Choose the Sketch Extend button from the Sketch Tools toolbar.

If the Sketch Extend button is not available in the Sketch Tools toolbar, then you can
invoke the extend option from Tools > Sketch Tools > Extend. As discussed earlier, you
can insert the Sketch Extend button in the Sketch Tools toolbar using the Customize
dialog box.

The select cursor will be replaced by the extend cursor.

Figure 2-51  Sketch of the outer loop
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5. Move the cursor close to the left end of the lower horizontal line of the inner sketch. You can
preview the extended line in magenta color. (The preview of the extended entity will be
displayed in magenta if you are working on Windows XP platform. If you are working on
Windows 2000 then the preview will be displayed in yellow.) Move the cursor a little bit
toward the left if the preview of the extended line appears  to the right. Use the left mouse
button to extend the line.

6. Similarly, extend the upper horizontal line of the inner sketch. The sketch after extending
the lines is shown in Figure 2-53.

Figure 2-53  Sketch after extending the lines

Figure 2-52  Sketch after offsetting the outer loop
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7. Choose the Sketch Trim button from the Sketch Tools toolbar and the extend
cursor will be replaced by the trim cursor.

8. Using the left mouse button trim the unwanted entities. Refer to Figure 2-54.

The final sketch is shown in Figure 2-54.

Saving the Sketch
1. Choose the Save button from the Standard toolbar to invoke the Save As dialog

box.

Figure 2-54  Final sketch for Tutorial 3

Tip. Setting the snap and grid parameters for each document is a very tedious and
time-consuming process. To overcome this problem you can create a template in
which all the snap, grid, and units are set. Whenever you have to create a part
document you just have to choose that template from the Template tab of the New
SolidWorks Document dialog box. To create and save a template, create a new
document in the Part mode and set the parameters of units, snap, and grid from the
Document Properties dialog box. Choose the Save button from the Standard
toolbar or choose File > Save from the menu bar. The Save As dialog box will be
displayed. Browse X:/Program Files/SolidWorks/data/Templates location to save
the file. X: is the drive in which you have installed SolidWorks. Select the Part
Templates (*.prtdot) option from the Save as type drop-down list. Enter the name
of the template file in the File name text area. Choose the Save button from the
Save As dialog box. Next time when you create a new part document, select this
template from the Template tab of the New SolidWorks Document dialog box.
Using the same procedure, you can also create the user-defined templates for drawing
and assembly documents. You will learn more about drawing and assembly documents
in later chapters.
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2. Enter the name of the document as c02-tut03.sldprt in the File name edit box and choose the
Save button. Close the file by choosing File > Close from the menu bar.

SELF-EVALUATION TEST
Answer the following questions and then compare your answers with the answers given at
the end of this chapter.

1. The Trim option is also used to extend the sketched entities. (T/F)

2. In the sketching environment you can apply fillets to two parallel lines. (T/F)

3. You can apply a fillet to two nonparallel and nonintersecting entities. (T/F)

4. You cannot offset a single entity; you have to select a chain of entities to create an entity
using the offset tool. (T/F)

5. Choose Insert > Customize from the menu bar to display the Customize dialog box. (T/F)

6. The design intent is not captured in the sketch created using the mirror line. (T/F)

7. The __________ tool is used to create a linear pattern in the sketcher environment of
SolidWorks.

8. The __________ tool is used to create a circular pattern in the sketcher environment of
SolidWorks.

9. To modify a sketched circle, select it using the __________ tool to display the __________
PropertyManager.

10. The __________ origin is displayed when you invoke the Modify Sketch dialog box.

REVIEW QUESTIONS
Answer the following questions:

1. You cannot extend the sketched entity using the trim tool. (T/F)

2. The preview of the entity to be extended is displayed in red color. (T/F)

3. You cannot apply a sketch fillet to two nonintersecting entities. (T/F)

4. The sketched entities can be mirrored without using a centerline (T/F)

5. The Fixed check box in the Linear Sketch Step and Repeat dialog box is selected to
specify the dimension between the first two instances along a specified direction after you
create the pattern. (T/F)
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6. Which PropertyManager is displayed when you choose the Sketch Fillet button from the
Sketch Tools toolbar?

(a) Sketch Fillet (b) Fillet
(c) Surface Fillet (d) Sketching Fillet

7. When you choose Tools > Sketch Tools > Chamfer from the menu bar to invoke the
chamfer tools, which PropertyManager is displayed on the left of the drawing area.

(a) Sketch Chamfer (b) Sketcher Chamfer
(c) Sketching Chamfer (d) Chamfer

8. Which dialog box is used for editing the entire sketch?

(a) Edit Sketch (b) Modify Entity
(c) Modify Sketch (d) None

9. Which tool is used to break a sketched entity in two or more than two entities?

(a) Split Curve (b) Trim Sketch
(c) Break Curve (d) Trim Curve

10. Along which origin the sketch is rotated using the Modify Sketch dialog box.

(a) Sketch origin (b) Document origin
(c) Moveable origin (d) None

EXERCISES

Exercise 1
Create the sketch of the model shown in Figure 2-55. The sketch is shown in Figure 2-56. The
solid model and dimensions are given only for reference. Create the sketch on one side and
then mirror it on the other side. Make sure you do not use the mirror line option to draw this
sketch. This is because if you draw the sketch using the mirror line, some relations are applied to
the sketch. These relations interfere while creating fillets.     (Expected time: 30 min)
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Figure 2-55  Solid model for Exercise 1

Figure 2-56  Sketch for Exercise 1

Exercise 2
Create the sketch of the model shown in Figure 2-57. The sketch is shown in Figure 2-58. The
solid model and dimensions are given only for reference. Create the sketch using the sketching
tools and then edit the sketch using the circular pattern tool and the trim tool.

                 (Expected time: 30 min)
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Figure 2-58  Sketch for Exercise 2

Exercise 3
Create the sketch of the model shown in Figure 2-59. The sketch is shown in Figure 2-60. This
model is created using a revolved feature; therefore, you will create the sketch on one side of the
centerline. The solid model and dimensions are given only for reference.

    (Expected time: 30 min)

Figure 2-57  Solid model for Exercise 2
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Figure 2-59  Solid model for Exercise 3

Figure 2-60  Sketch for Exercise 3

Exercise 4
Create the sketch of the model shown in Figure 2-61. The sketch is shown in Figure 2-62. This
model is created using a revolved feature; therefore, you will create the sketch on one side of the
centerline. The solid model and dimensions are given only for reference.

    (Expected time: 30 min)
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Figure 2-62  Sketch for Exercise 4

Figure 2-61  Solid model for Exercise 4

Answers to Self-Evaluation Test
1. T, 2. F, 3. T, 4. F, 5. F, 6. F, 7. Linear Sketch Step and Repeat, 8. Circular Sketch Step and
Repeat, 9. Select, Circle, 10. Moveable
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