Chapter 4

Advance Dimensioning
and
Base Feature Options

Learning Objectives

After completing this chapter you will be able to:

* Dimension the sketch using the autodimension sketch tool.
* Dimension the sketch using the ordinate dimensioning.

* Dimension the true length of arc.

* Measure Distances and View Section Properties

* Create solid base extruded features.

* Create thin base extruded features.

* Create solid base revolved features.

* Create thin base revolved features.

* Dynamically rotate the view to display the model from all directions.
* Modify the orientation of the view.

* Change the display modes of the solid model.
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ADVANCE DIMENSIONING TECHNIQUES

In this chapter, you will learn about some of the advance dimensioning techniques used in
dimensioning the sketches in SolidWorks. With this release of SolidWorks, you are able to apply
all the possible dimensions to a sketch using a single option. This option is known as
Autodimension Sketch. The other dimensions options discussed in this chapter are
horizontal dimensioning, vertical dimensioning, ordinate dimensioning, and dimensioning
true length of an arc. The advanced dimensioning techniques are discussed next.

Autodimension the Sketches

Toolbar: Sketch Relations > Autodimension Sketch (Customize to Add)
Menu: Tools > Dimensions > Autodimension Sketch

@ The Autodimension Sketch option is used to automatically apply the dimensions to the

sketch. You can apply the absolute dimension, incremental dimension, and ordinate

dimension using this option. To apply autodimensions to a sketch, create the sketch

using standard sketching tools and then apply the required relations to the sketch. Now, choose

Tools > Dimensions > Autodimension Sketch from the menu bar. The Autodimension

sketch PropertyManager is displayed as shown in Figure 4-1. The various options available in
the Autodimension Sketch PropertyManager are discussed next.

Entities to Dimension

The Entities to Dimension rollout is used to specify the entities on which the dimension has to
be applied. The All entities in sketch radio button is selected to apply the dimension to all the
entities drawn in the current sketching environment. This radio button is selected by default if
you do not select any entity before invoking the Autodimension sketch PropertyManager. The
Selected entities radio button is selected if you have to dimension only the selected entities.
When you select this radio button, the Selected Entities to Dimension display area is displayed
in the Entities to Dimension rollout. Select the entities to dimension using the select cursor.
The name of the selected entities is displayed in the Selected Entities to Dimension display
area. If you select any entity or entities before invoking the Autodimension sketch
PropertyManager, then the Selected entities radio button is selected by default and the name
of the selected entities will be displayed in the Selected Entities to Dimension display area.

Horizontal Dimensions

The Horizontal Dimensions rollout is used to specify the type of horizontal dimension, reference
for the horizontal dimension, and the dimension placement. The various options available in
the Horizontal Dimensions rollout are discussed next.

Scheme

The Scheme area is used to specify the type of dimension to be applied to the sketch. The
various types of dimensioning schemes available in the Horizontal Dimensioning Scheme
drop-down list are discussed next.

Chain
The Chain option is used for the relative or incremental horizontal dimensioning of
the sketch. When you invoke the Autodimension sketch PropertyManager and select
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Figure 4-1 The Autodimension sketch PropertyManager

this scheme, a point or a vertical line is selected as the reference entity. This reference
entity is used as a datum for the generation of dimension. The name of selected reference
entity is displayed in the Point or Vertical Line on Baseline display area and the
reference entity is displayed in red color in the drawing area. You can also specify a
user-defined reference entity.

Note
Chain dimensioning should be avoided if the tolerances relative to a common datum are required
mn the part.

Baseline

The Baseline option is used for absolute or datum vertical dimensioning of the sketch.
In this dimensioning method, the dimensions are applied to the sketch with respect to
the common datum. When you invoke the Autodimension sketch PropertyManager
and select this option, a point or a vertical line is selected as the reference entity, which
is used as a datum for the generation of dimension. The name of selected reference
entity is displayed in the Point or Vertical Line on Baseline display area and the
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reference entity is displayed in red color in the drawing area. You can also specify a user
defined reference entity.

Ordinate

The Ordinate option is used for the ordinate dimensioning of the sketch. When you
invoke the Autodimension Sketch PropertyManager and select this option, a point or
avertical line is selected as the reference entity, which is used as a datum for the generation
of dimension. The name of selected reference entity is displayed in the Point or Vertical
Line on Ordinate Datum display area and the reference entity is displayed in red color
in the drawing area. You can also specity a user defined reference entity.

Dimension placement

The Dimension Placement area of the Horizontal Dimensions rollout is used to define the
position where the generated dimensions will be placed. Tiwo radio buttons are available in
this area. The first radio button is the Above sketch radio button and is selected by default.
If you use this option, the horizontal dimensions generated using the Autodimension Sketch
tool will be placed above the sketch. If you select the Below sketch radio button, the generated
dimensions will be placed below the sketch.

Vertical Dimensions

The Vertical Dimensions rollout is used to specify the type of vertical dimension, reference for
the vertical dimension, and the dimension placement. The various options available in the
Scheme area are similar to those discussed under the Horizontal Dimensions rollout. The
remaining options are discussed next.

Dimension placement

The Dimension Placement area of the Vertical Dimensions rollout is used to define the
position where the generated dimensions will be placed. The Left of the Sketch radio
button is selected to place the dimensions on the left of the sketch. The Right of the Sketch
radio button is selected to place the dimensions on the right of the sketch. The Right of the
Sketch radio button is selected by default.

After specifying all the parameters in the Autodimension Sketch PropertyManager, choose the
OK button or choose the OK icon from the Confirmation Corner. The dimension will be
created with the selected dimension scheme. Figure 4-2 shows the autodimension created using
the Chain scheme. Figure 4-3 shows the autodimension created using the Baseline scheme.
Figure 4-4 shows the autodimension created using the Ordinate scheme.

Note
. d As evident in Figures 4-2 through 4-4, the dimensions added using the Autodim option are not
' properly arranged. You need to manually place them at their proper location.
Ordinate Dimensioning of Sketches
Menu: Tools > Dimensions > Ordinate

The Ordinate option of dimensioning is extensively used in industry for the dimensioning of
shop floor drawings. This is because this type of drawing interprets the drawing in the coordinate
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Figure 4-2 Chain dimension created using autodimension option
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Figure 4-3 Baseline dimension created using autodimension option

form and the coordinates are required as input for the NC and CNC machines. In the ordinate
dimensioning you have to define a zero (datum); and all the dimensions will be created with
respect to that zero.

Note

If you want ordinate dimensions in the drawing views then you have to create the ordinate
dimensions in the sketch itself, because the dimensions created in the sketches and in part mode are
generated in drawing mode when you opt for generative dimensioning.
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Figure 4-4 Ordinate dimension created using autodimension option

Tip. Choose Tools > Dimensions > Parallel from the menu bar to create the
parallel dimension. Using this option you can create the horizontal as well as the
vertical dimensions. But you cannot create a aligned dimension using the parallel
option.

Choose Tools > Dimensions > Horizontal from the menu bar to create the horizontal
dimension. Using this option you can create only the horizontal dimensions. Generally,
this option is used to create a horizontal dimension of an aligned line or a horizontal
dimension between two points.

Choose Tools > Dimensions > Vertical from the menu bar to create the vertical
dimension. Using this option you can create only the vertical dimensions. Generally,
this option is used to create a vertical dimension of an aligned line or a vertical
dimension between two points.

After creating the sketch and applying the required relations to the sketch, choose Tools >
Dimensions > Ordinate from the menu bar. The select cursor is replaced by the ordinate
dimension cursor. For creating the horizontal ordinate dimension, select a vertical line or a
point where you have to define the zero or datum. As soon as you select the line or a point, a
dimension is attached to the cursor. Now, move the cursor and place the dimension. This datum
dimension is a reference dimension; therefore, you cannot change the value of this dimension.
Now, select the line or point using the ordinate dimension cursor; the dimension is automatically
placed. Continue selecting points or lines to place ordinate dimensions. After creating all the
horizontal ordinate dimensions, choose the Select button. Now, again choose Tools > Dimensions
> Ordinate from the menu bar to create the vertical ordinate dimensions. Select a point or a
horizontal line to define the zero and then apply the ordinate dimensions to the sketch. Figure 4-5
shows a sketch with ordinate dimensions.
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Figure 4-5 Ordinate dimension of a sketch

%;JO /;/}' Tip. Using Tools > Dimensions > Ordinate you can create either horizontal or
\g vertical ordinate dimensions. If you want to create only horizontal ordinate
Q/ dvmensions then choose Tools > Dimensions > Horizontal Ordinate. 10 create
vertical ordinate dimensions choose Tools > Dimensions > Vertical Ordinate.

When you are in the selection mode, right-click in the drawing area to invoke the
shortcut menu and choose the Dimension option from the shortcut menw to invoke
the dimension tool. Now, again right-click to invoke the shortcut menu and choose
the Ordinate Dimension option from the shortcut menu to invoke the ordinate
dimension tool. You can choose the Horizontal Ordinate, Vertical Ordinate,
Horizontal Dimension, and Vertical Dimension tools from the same shortcut

Dimensioning of the True Length of an Arc

In SolidWorks you can also create the dimension of the true length of an arc, which is one of the
advantages of the sketching environment of SolidWorks. To create the dimension of the true
length, invoke the dimension tools and select the arc using the dimension cursor. A
radial dimension is attached to the cursor. Move the cursor to any of the endpoints of the arc.
When the cursor snaps the endpoint, use the left mouse to specify the first endpoint of the arc.
Alinear dimension is attached to the cursor; move the cursor to the second endpoint of the arc
and when the cursor snaps the endpoint, select it. A dimension is attached to the cursor. Move
the cursor to an appropriate place to place the dimension. The dimension of the true length of
the arc is shown in Figure 4-6.

MEASURING DISTANCES AND VIEWING SECTION
PROPERTIES

SolidWorks allows you to measure the distance of the entities and also view the section properties.
These tools are discussed next.
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L

Figure 4-6 Dimensioning the true length of an arc

Measuring Distances

Toolbar: Tools > Measure
Menu: Tools > Measure

M The measure tools is used to measure perimeter, angle, radius, and distance between
lines, points, surfaces, and planes in sketches, 3D models, assemblies, or drawings. To
use the measure tools, you have to invoke the Measure dialog box by choosing Tools >
Measure from the menu bar or by choosing the Measure button from the Tools toolbar. When
you choose the Measure button, the Measure dialog box is displayed. The name of the document
in which you are working is displayed at the top of the Measure dialog box. The Measure
dialog box is displayed in Figure 4-7. The current cursor is replaced by the measure cursor.
Using the measure cursor select the entity or entities to measure. The various options in the
Measure dialog box are discussed next.

Output coordinate system drop-down list

In the Measure dialog box you are provided with an Output coordinate system drop-down list.
Using this drop-down list you can specify in reference to which coordinate system you want to
measure the selected entities. By default, the default option is selected in the drop-down list. If
you create a coordinate system, then you can also select that coordinate system from this drop-down
list. Creation of the coordinate system is discussed in the later chapters.

Select items Area

The Select items area consists of a display box that displays the entities that are selected using
the measure cursor. When you select the entities using the measure cursor, the name of the
selected entity is displayed in the Select items area. You can remove all the entities from the
selection set, and select one of the entity from the Select items display area. Select the
Clear Selections option from the shortcut menu. If you select the Delete option from the
shortcut menu then only the selected entity is removed from the selection set.

‘ c04-solidworks-2003.p65 8 5/12/2003, 9:48 AM



Advance Dimensioning and Base Feature Options 4-9
5 WMeasure - Partl !E E
Cloze | Options... | Help |
DOutput coordinate zysten: I default - j
Selected items——— — Projection an

I * Screen

" Plane/Face I

v Show output coordinate system in cormer of window

Meazurements:

4] 2

Figure 4-7 The Measure dialog box

Projection on

The Projection on area is used to specify where the selected entity should be projected. You can
project the selected entity either on the screen or on the specific plane. Then the system will
calculate the measurement of the true projection. This area is provided with two radio buttons;
the first radio button is the Screen radio button and the second radio button is the Plane/Face
radio button. You will learn more about planes in the later chapters.

Show output coordinate system in corner of window

The Show output coordinate system in corner of window check box is selected to display the
coordinate system at the corner of the screen. This check box is selected by default; if you clear
this check box then you will notice that the coordinate system is placed at the origin in the
drawing area.

Measurements Area

After selecting the entity or entities to be measured using the measure cursor, you are provided
with the appropriate values of the length, angle, perimeter, and so on displayed in the
Measurements area. New measurements update dynamically when you change the selection of
entities. If the combination of selected entities is not appropriate for the measure function, then
amessage is displayed in the Measurements area. This message prompts you that the selection
is invalid. If two selected entities are intersecting lines then you are provided the value of the
angle between the intersecting entities and the message prompts you that the selected items
intersect.

‘ c04-solidworks-2003.p65 9 5/12/2003, 9:48 AM



4-10

SolidWorks for Designers

Options

The Options button is used to invoke the Measurement Options dialog box. In this dialog box
you can specify the units for linear measurement, units for angular measurement, material
properties, and the accuracy level. The Measurement Options dialog box is shown in Figure 4-8.

The options in the Measurement Options dialog box are discussed next.

Units Area

The Units area of the Measurement Options dialog box is used to set the linear and the
angular units for measurement. By default, the linear units are selected as millimeters with
decimal upto two places, and the angular units are selected as with decimal upto two decimal.
The various options in the Units area are discussed next.

‘ c04-solidworks-2003.p65

Length unit Area

The Length unit area is used to set the units and options of linear dimensions for
measuring the entities. The Unit drop-down list is provided at the top right corner of
the Length unit area. In this drop-down list you can select any type of unit such as
Angstroms, Nanometers, Microns, Millimeters, Centimeters, Meters, Microinches,
Miles, Inches, Feet, and Feet and Inches. By default, the units selected in the
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Figure 4-8 The Measurement Options dialog box
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drop-down list are Millimeters because during installation you had selected millimeters
as the default units. A Decimal places spin box is provided to control the decimal
places. The other options in the Length unit area are discussed next.

Decimal. The Decimal radio button is available only when you choose the units as
Microinches, Miles, Inches, or Feets and Inches from the Unit drop-down list.
This radio button is selected to display the dimension in the decimal form. You can
also specify the decimal places using the Decimal places spin box provided at the
right of the Decimal radio button.

Fractions. The Fractions radio button is available only when you choose the units
as Microinches, Miles, Inches, or Feets and Inches from the Units drop-down
list. This radio button is selected to display the dimension in the fraction form. You
can also set the value of the denominator using the Denominator spin box provided
at the right of the Fractions radio button.

Round to nearest fraction. The Round to nearest fraction check box is selected to
display the value in fractions by rounding the value to the nearest fraction.

Scientific notation. The Scientific notation check box is selected to display the
value in the scientific notation units.

Angular unit Area

The Angular unit area is used to set the angular units for measurement. The Angular
unit area is provided with a drop-down list to specify the angular measurement unit
such as Degrees, Deg/Min, Deg/Min/Sec, and Radians. A Decimal places spin box is
also provided under the drop-down list to specify the decimal places.

Mass Properties

View measurement settings

The View measurement settings radio button is selected to activate a temporary system
of units. After selecting this radio button if you change the units, it will not affect the
units specified for the document, or the default units of the system for new documents.

View global settings

The View global settings radio button is selected to display the units specified for the
active document. If you change the unit setting in the Length unit and Angular unit
areas and choose the View global settings radio button then the units will be reset to the
default units of the active document.

View system defaults

The View system defaults radio button is selected to displays the default units of the
system for new documents. If you change the unit setting in the Length unit and
Angular unit areas and choose the View system defaults radio button then the units
will be reset to the default units of the system and when you create a new document the
default units will be displayed.
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Material Properties area

In the Material Properties area you can change the density of the material for the
current document. You can enter the density value using any units. For example, if the units
of the part are grams and millimeters, you can enter a density value using pounds and
inches. The SolidWorks converts the value to the document’s units when you choose OK
from the Measurement Options dialog box.

Accuracy level

The Accuracy level area of the Measurement Options dialog box is used to specify the
accuracy level provided by SolidWorks for the measurement. The Default mass/section
property precision radio button is selected by default; this option calculates faster but the
precision is not very high. The Maximum property precision (Slower) radio button is
selected to increase the accuracy and precision for measuring. This option when used slows
the working of the computer but gives a very precise output result.

Section Properties

The Section Properties tool enables you to calculate the section properties of the sketch in the
sketching environment or of selected planar face in the part mode and assembly mode. The
section properties include the area, centroid relative to sketch origin, centroid relative to part
origin, moment of inertia, polar moment of inertia, angle between the principle axes and sketch
axes, and principle moment of inertia. To calculate the section properties, create the sketch. The
sketch must be a closed loop. Choose Tools > Section Properties. The Section Properties
dialog box is displayed as shown in Figure 4-9.

% W Section Properties !EI
Frint... | LCopy | Cloze | Dptions. .. | Recalculate |
Output coordinate zpstem: I default - j

Selected ltems:

¥ Show output coordinate system in comer af window

Section properties of Sketchl of Part] -
Area = 36846.13 square milimeters

Centroid relative to zketch orgine [ millimeters |

=733

Y =7.54
Centroid relative to part ongin: [ millimeters |

X=733

Y =754 =
« | 4

Figure 4-9 The Section Properties dialog box

‘ c04-solidworks-2003.p65 12 5/12/2003, 9:48 AM



Advance Dimensioning and Base Feature Options 4-13

When you invoke the Section Properties dialog box a red 3D triad is placed at the centroid of
the sketch. The mass properties of the sketch are displayed in the Section Properties dialog
box. The Output coordinate system drop-down list is used to select the coordinate system
along which you want to calculate the section properties. By default, the calculation is done with
respect to the default coordinate system. The Selected Items display box is used to display the
name of the selected planar face whose section properties are to be calculated. When you are in
the part mode select the face to calculate the section properties, and choose the Recalculate
button to display the properties. If you want to calculate the section properties of some other
face, clear the previously selected face from the selection set and select the new face and choose
the Recalculate button. The Print button available in the Section Properties dialog box is used
to print the section properties. Using the Options button you can invoke the Measurement
Options dialog box. This dialog box is used to set the units, density, and accuracy level. This
dialog box was discussed previously. The Show output coordinate system in the corner of
window check box is selected to display the coordinate system at the corner of the drawing area;
if you clear this check box then the coordinate system will shift to the origin.

CREATING BASE FEATURES BY EXTRUDING THE
SKETCHES

Toolbar: Features > Extruded Boss/Base
Menu: Insert > Base > Extrude

a The sketches that you have drawn until now can be converted into base features by
extruding using the Extruded Boss/Base tool. This tool is available in the Features
toolbar. After drawing the sketch, as you choose this tool, you will notice that the sketching
environment is closed and the part modeling environment is invoked and the confirmation
corner is displayed. Based on the options and the sketch selected for extruding, the resultant
feature can be a solid feature or a thin feature. If the sketch is closed, it can be converted into a
solid feature or a thin feature. However, if the sketch is open, it can be converted into a thin
teature only. The solid and thin features are discussed next.

Creating Solid Extruded Features

After you have completed drawing and dimensioning the closed sketch and converted it into a
tully defined sketch, choose the Extrude Boss/Base button from the Features toolbar. You will
notice that the view is automatically changed to a 3D view, the confirmation corner appears on
the top right of the drawing area, and the Extrude PropertyManager is displayed as shown in
Figure 4-10.

You will notice that the preview of the base feature will be displayed in temporary graphics and
an arrow will appear on the sketch. The arrow appears on the front of the sketch and is transparent.
Figure 4-11 shows the preview of the sketch being extruded. Note that if the sketch consists of
some closed loops inside the outer loop, they will be automatically subtracted from the outer
loop while extruding. The various options available in the Base-Extrude PropertyManager are
discussed next.
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Figure 4-11 Preview of the feature being extruded using the Extrude-Base PropertyManager

Direction 1

The Direction 1 rollout is used to specify the end condition for extruding the sketch in one
direction from the sketch plane. The various options available in the Direction 1 drop-down list
are discussed next.
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End Condition

The End Condition drop-down list provides the options to define the termination of the
extruded feature. Note that since this is the first feature, some of the options available in this
drop-down list will not be used at this stage. Also, some additional options will be available
later in this drop-down list. The options that are available to define the termination of the
base feature are discussed next.

Blind

The Blind option is selected by default and this option is used to define the termination
of the extruded base feature by specifying the depth of extrusion. The depth of extrusion
can be specified in the Depth spinner that is displayed below this drop-down list when
you select the Blind option. Since the Blind option is selected by default, the Depth
spinner is also displayed by default. You can reverse the extrusion by selecting the
Reverse Direction button provided on the left of this drop-down list. Figure 4-12
shows the preview of the feature being created by extruding the sketch using the Blind
option.

Figure 4-12 Preview of the feature being extruded

You can also extrude a sketch to a blind depth by dynamically dragging the feature
using the mouse. Invoke the Extrude-Base PropertyManager and move the mouse to
the transparent arrow and when the color of the arrow changes to red use the left mouse
button. Move the cursor to specify the depth of extrusion and when you specify the
depth of extrusion use the left mouse button to specity the termination of extruded
teature. The preview of the sketch being dragged is shown in Figure 4-13. The select
cursor will be replaced by the mouse cursor. Use the right mouse button to complete the
teature creation or choose the OK button from the Base-Extrude PropertyManager.

Mid Plane
The Mid Plane option is used to create the base feature by extruding the base sketch
equally in both the directions of the plane on which the sketch is drawn. For example,
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Figure 4-13 Preview of the feature being extruded by dynamically dragging

Tip. You can also extrude an under defined or an over defined sketch. However; if
Q / you extrude an under defined sketch, a - sign is displayed on the left of the sketch in
the Feature Manager. Similarly, if you extrude an over defined sketch, you will
find a + sign on the left of the sketch in the Feature Manager. To check these
signs, click the + sign available on the left of Base-Extrude in the Feature
Manager. The sketch will be displayed and you can see the + or the - signs.

if the total depth of the extruded feature is 30mm, it will be extruded 15mm toward the
front of the plane and 15mm toward the back. The depth of the feature can be defined
in the Depth spinner that is displayed below this drop-down list.

Figure 4-14 shows the preview of the feature being created by extruding the sketch using
the Mid Plane option.

Tip. Right-click in the drawing area to display the shortcut menu. Using the left
mouse button choose the Mid Plane option from the shortcut menu. Move the

W mouse and use the left mouse button to spectfy the depth of extrusion.

Draft On/Off

The Draft On/Off button is used to specify a draft angle while extruding the sketch. Applying
the draft angle will taper the resultant feature. This button is not chosen by default. Therefore,
the resultant base feature will not have any taper. However, if you want to add a draft angle
to the feature, choose this button. The Draft Angle spinner and the Draft outward check
box will be available. You can enter the draft angle for the feature in the Draft Angle spinner.
By default, the feature will be tapered inward as shown in Figure 4-15. If you want to taper
the feature outward, select the Draft outward check box that is displayed below the Draft
Angle spinner. The feature created with outward taper is shown in Figure 4-16.

c04-solidworks-2003.p65 16 5/12/2003, 9:48 AM



Advance Dimensioning and Base Feature Options 4-17

Figure 4-14 Preview of the feature being extruded using the Mid Plane option

Note
& The Selection Contours rollout is discussed in the later chapters of this book.

Figure 4-15 Feature created with outward draft

Direction 2

The Direction 2 check box is selected to invoke the Direction 2 rollout and this rollout is used
to extrude the sketch with diftferent values in the second direction of the sketching plane. This
check box will not be available if you select the Mid Plane termination type. Unlike the Mid
Plane termination option, the depth of extrusion and other parameters in both the directions
can be different. For example, you can extrude the sketch to a blind depth of 10mm and an
inward draft of 35° in front of the sketching plane and to a blind depth of 15mm and an outward
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Figure 4-16 Feature created with inward drafi

draft of 0° behind the sketching plane as shown in Figure 4-17. When you select the Direction
2 check box the Direction 2 rollout is activated. Using the various options available in the
Direction 2 rollout you can specify the termination condition for extrusion in the second direction.
When you invoke this rollout the preview of direction 2 is displayed on the screen with the
default values. After setting the values for both the directions, choose the OK button or choose
the OK icon from the confirmation corner. The feature will be created with different values in
both the directions.

Figure 4-17 Feature created in both directions with different values

Note
ai The draft will not be displayed in the preview of the featwre that is displayed when you invoke the
Base-Extrude PropertyManager unless you extrude the sketch by dynamically dragging.
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Tip. Select the direction 2 arrow from the drawing area and move the cursor to
specify the depth of extrusion in the second direction and use the left mouse button
to complete the feature creation.

Creating Thin Extruded Features

The thin extruded features can be created using a closed or an open sketch. If the sketch is
closed, it will be offsetted inside or outside to create a cavity inside the feature as shown in
Figure 4-18.

Figure 4-18 Thin feature created using a closed loop

If the sketch is open, as shown in Figure 4-19, the resultant feature will be as shown in Figure 4-20.
Note that you can also apply fillets at all the sharp corners of the open loop while creating thin
features.

To convert a closed sketch into a thin feature, choose the Thin Feature checkbox to invoke the
Thin Feature rollout. The Thin Feature rollout, shown in Figure 4-21, is used to create a thin
feature. However, if the sketch to be extruded is open, then the Thin Feature rollout will be
displayed when you invoke Base-Extrude PropertyManager.

The options under the Thin Feature rollout of the Extrude PropertyManager are discussed
next.

Type
The options provided in the Type drop-down list are used to select the method to define the
thickness of the thin feature. These options are discussed next.

One-Direction
The One-Direction option is used to add the thickness on one side of the sketch. The
thickness can be specified in the Thickness spinner provided below this drop-down list.
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Figure 4-19 Open loop to be converted into thin featwre

Figure 4-20 Resultant thin feature created with fillets at sharp corners

[ Thin Feature A~

Reverse Directiun—@lﬂne-Directim ﬂ Type
*E’% I'I-':'E'”'"'“ :I Thickness

[ Capends

Figure 4-21 The Thin Feature rollout
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For the closed sketches, the direction can be inside or outside the sketch. Similarly, for open
sketches, the direction can be below or above the sketch. You can reverse the direction of
thickness using the Reverse check button available on the right of this drop-down list. This
check box will be available only when you select the One-Direction option from this
drop-down list.

Mid-Plane

The Mid-Plane option is used to add the thickness equally on both the sides of the sketch.
The value of the thickness of the thin feature can be specified in the Thickness spinner
provided below this drop-down list.

Two-Direction

The Two-Direction option is used to create a thin feature by adding different thickness on
both the sides of the sketch. The thickness values in direction 1 and direction 2 can be
specified in the Direction 1 Thickness spinner and the Direction 2 Thickness spinner
respectively. These spinners are displayed below the Type drop-down list automatically
when you select the Two-Direction option from this drop-down list.

Cap Ends

The Cap Ends check box is displayed only when the sketch selected to convert into a thin
teature is closed. This check box is selected to cap the two ends of the thin extruded feature.
Both the ends will be capped with a face of the thickness you specify. When you select this check
box, the Cap Thickness spinner is displayed on the right of this check box. The thickness of
the end caps can be specified using this spinner.

Auto-fillet corners

The Auto-fillet corners check box is displayed only when you select an open sketch to convert
into a thin feature. If you select this check box, all the sharp vertices in the sketch will be
automatically filleted while converting into a thin feature. The radius of the fillet can be specified
in the Fillet Radius spinner that is displayed below the Auto-fillet corners check box when you
select this check box.

Figure 4-22 shows the thin feature created by extruding an open sketch in both the directions.
Notice that a draft angle is applied to the feature while extruding in the front direction and the
Auto Fillet option is selected while creating this thin feature.

Note
©9 . . . . . ~
%d Only the corners of the thin featwres that can accommodate the given radius will be filleted; other
g corners that do not accommodate the given radius will not be filleted.

CREATING BASE FEATURES BY REVOLVING THE
SKETCHES

The sketches that you have drawn until now can also be converted into base features by revolving
using the Revolved Boss/Base tool. This tool is available in the Features toolbar. However, note
that a sketch can be revolved only if you draw a centerline in the sketch around which the sketch
will be revolved. Also, the sketch must be drawn on one side of the centerline. The Revolved
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Figure 4-22 Thin feature created in both the directions

Boss/Base tool will be available only after you draw the centerline in the sketch. Note that the
centerline around which you want to revolve the sketch should not cross the sketch.

After drawing the sketch, as you choose this tool, you will notice that the sketching environment
is closed and the part modeling environment is invoked. Similar to extruding the sketches, the
resultant feature can be a solid feature or a thin feature based on the sketch and the options
selected to revolve. If the sketch is closed, it can be converted into a solid feature or a thin
teature. However, if the sketch is open, it can be converted into a thin feature only. The solid and
thin features are discussed next.

Creating Solid Revolved Features

Toolbar: Features > Revolved Boss/Base
Menu: Insert > Base > Revolve

: After you have completed drawing and dimensioning the closed sketch and converted it
ﬂ into a fully defined sketch, choose the Revolve Boss/Base button from the Features
toolbar. You will notice that the view is automatically changed to a 3D view, the
Revolve PropertyManager will be displayed as shown in Figure 4-23, and the confirmation
corner will also be displayed. Also, the preview of the base feature, as it will be created using the
default options, will be displayed in temporary shaded graphics. The direction arrow will also
be displayed in gray color. The various options available in the Revolve Parameters rollout of
the Revolve PropertyManager are discussed next.

Revolve Type

The Revolve Type drop-down list provides the options to define the termination of the
revolved feature. The options that are available in this drop-down list to terminate the revolved
teature are discussed next.
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Figure 4-23 The Revolve PropertyManager
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Tip. If the preview of the revolved feature is not complete in the cwrrent display of
the screen, choose the Zoom to Fit button from the View toolbar or choose the F key
[from the keyboard. The display will be modified such that the preview is displayed in
the current view.

i
\f %

One-Direction

The One-Direction option is used to revolve the sketch on one side of the plane on which
it is sketched. The angle of revolution can be specified in the Angle spinner displayed
below this drop-down list. The default value of the Angle spinner is 360deg. Therefore, if
you revolve the sketch using this value, a complete round feature will be created. You can
also reverse the direction of revolution of the sketch by choosing the Reverse Direction
button that is displayed when you select this option. Figure 4-24 shows the sketch and the
centerline used to revolve the sketch and Figure 4-25 shows the piston created by revolving
the sketch through an angle of 360°.

Figure 4-26 shows a piston created by revolving the same sketch through an angle of 270°.

Mid-Plane

The Mid-Plane option is used to revolve the sketch equally on both the sides of the plane on
which it is sketched. The angle of revolution can be specified in the Angle spinner. When
you choose this option the Reverse Direction button will be unavailable.

Two-Direction

The Two-Direction option is used to create a revolve feature by revolving the sketch using
difterent values on both the sides of the plane on which it is sketched. The angle values in
direction 1 and direction 2 can be specified in the Direction 1 Angle spinner and the
Direction 2 Angle spinner respectively. These spinners are displayed below the Revolve
Type drop-down list automatically when you select the Two-Direction option from this
drop-down list.
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Figure 4-24 Sketch to be revolved and the centerline around which
the sketch will be revolved

Figure 4-25 Feature created by revolving the sketch through an angle
of 360°

Note
If you create the centerline of the sketch feature for creating a revolve feature from right to lefi,

the sketch will be revolved in the clockwise direction when you create the revolve feature. If you
create the centerline of the sketch featwre from left to right, then the resultant revolve feature will

revolve in counterclockwise direction.
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Figure 4-26 Feature created by revolving the sketch through an angle
of 270°

Creating Thin Revolved Features

Similar to the thin extruded features, the thin revolved features can be created using a closed or
an open sketch. If the sketch is closed, it will be offsetted inside or outside to create a cavity
inside the feature as shown in Figure 4-27. In this figure, the sketch is revolved through an angle
of 180°.

Figure 4-27 Thin feature created by revolving the sketch through an
angle of 180°
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Tip. You can dynamically specify the angle in a revolve feature by dragging the
direction arrows. You can also use the right mouse button to display the shortcut
menu; all the options available in the PropertyManager are also available in the
shortcut menu.

If the sketch is open, as shown in Figure 4-28, the resultant feature will be as shown in Figure 4-29.

Figure 4-28 The open sketch to be revolved and the centerline to revolve the sketch

Figure 4-29 Thin feature created by revolving the open sketch through
an angle of 180°

To convert a closed sketch into a thin feature, select the Thin Feature check box from
Base-Revolve PropertyManager to invoke the Thin Feature rollout. However, if the sketch to
be revolved is open and you invoke the Revolve Boss/Base tool, then the SolidWorks information
box will be displayed and you will be informed that the sketch is currently open and a nonthin
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Tip. While defining the wall thickness of a thin revolved feature, remember that the
wall thickness should be added such that the centerline does not intersect with the

Q‘/ sketch. If the centerline intersects with the sketch, the sketch will not be revolved.

revolve feature requires a closed sketch. You will be given an option of automatically closing the
sketch. If you choose Yes from this dialog box, a line segment will be automatically drawn
between the first and the last segment of the sketch and the Base-Revolve PropertyManager
will be displayed. However, if you choose No from this dialog box, the Base-Revolve
PropertyManager will be displayed and the Thin Feature rollout will be displayed automatically.
The options under the Thin Feature rollout of the Base-Revolve PropertyManager, shown in
Figure 4-30, are discussed next.

[w| Thin Feature N

Reverse Directinn—@ IDne-DirectiDn j—Type

i [1-00mm =} Direction 1 Thickness

Figure 4-30 The Thin Feature rollout

Type
The options provided in the Type drop-down list are used to select the method to define the
thickness of the thin feature. These options are discussed next.

One-Direction

The One-Direction option is used to add the thickness on one side of the sketch. The
thickness can be specified in the Direction 1 Thickness spinner provided below this
drop-down list. For the closed sketches, the direction can be inside or outside the sketch.
Similarly, for open sketches, the direction can be below or above the sketch. You can reverse
the direction of thickness using the Reverse Direction button available on the right of this
drop-down list. This button will be available only when you select the One-Direction option
from this drop-down list.

Mid-Plane

The Mid-Plane option is used to add the thickness equally on both the sides of the sketch.
The value of the thickness of the thin feature can be specified in the Direction 1 Thickness
spinner provided below this drop-down list.

Two-Direction

The Two-Direction option is used to create a thin feature by adding different thickness on
both the sides of the sketch. The thickness values in direction 1 and direction 2 can be
specified in the Direction 1 Thickness spinner and the Direction 2 Thickness spinner
respectively. These spinners are displayed below the Type drop-down list automatically
when you select the Two-Direction option from this drop-down list.
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DYNAMICALLY ROTATING THE VIEW OF THE MODEL

SolidWorks allows you to dynamically rotate the view in the 3D space so that the solid models in
the current file can be viewed from all directions. This allows you to visually maneuver around
the model so that all the features in the model can be clearly viewed. This tool can be invoked
even when you are inside some other tool. For example, you can invoke this tool when the
Extrude Feature dialog box is displayed. You can freely rotate the model in the 3D space or
rotate it around a selected vertex, edge, or face. Both the methods of rotating the model are
discussed next.

Rotating the View Freely in 3D Space

Toolbar: View > Rotate View
Menu: View > Modify > Rotate

/| Torotate the view freely in 3D space, choose the Rotate View button from the View
ﬂ toolbar. You can also invoke this tool by choosing the Rotate View option from the

shortcut menu that is displayed when you right-click in the drawing window. When you
are inside some other tool use the right mouse button in the drawing area and choose the View
> Rotate View option from the shortcut menu to invoke the rotate view tool. When you invoke
this tool, the cursor will be replaced by the rotate view cursor. Now, press the left mouse button
and drag the cursor to rotate the view. Figure 4-31 shows a model being viewed from difterent

directions by rotating the view.

Figure 4-31 Rotating the view to display the model from different
directions

Rotating the View Around a Selected Vertex, Edge, or Face

To rotate the view around a selected vertex, edge, or face, invoke this tool and move the rotate
view cursor close to the vertex, edge, or the face around which you want to rotate the view. When
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Tip. 10 resume rotating the view freely after you have completed rotating it around
a selected vertex, edge, or face, double-click anywhere in the drawing area. Now
when you drag the cursor; you will notice that the view is rotated freely in 3D space.

If a 3 button mouse is configured to your system, you can press and drag the middle
mouse button to rotate the model freely in 3D space. Note that in this case the rotate
view cursor will not be displayed.

it is highlighted, select it using the left mouse button. Next, drag the cursor to rotate the view
around the selected vertex, edge, or face.

MODIFYING THE VIEW ORIENTATION

As mentioned earlier, when you invoke the Extrude Boss/Base tool or the Revolve Boss/Base
tool, the view is automatically changed to a 3D view and the preview of the model is displayed.
SolidWorks allows you to manually change the view orientation using some predefined standard
views or user-defined views. The standard views are available in the Standard View toolbar
shown in Figure 4-32. The various tools available in this toolbar are discussed next.

Standard Wiews
PRREBBR S
antJ LNorrnal To
Back lsornetric
Left—— L Bottom
Right Top

Figure 4-32 Standard View toolbar

Front
The Front button is chosen to reorient the view to the front view. This is the default view that is
current when you open a new file. The hotkey for the front view is CTRL+1.

Back

The Back button is chosen to reorient the view to the back view. The hotkey for the back view is
CTRL+2.

Left

The Left button is chosen to reorient the view to the left view. The hotkey for the left view is
CTRL+3.

Right
The Right button is chosen to reorient the view to the right view. The hotkey for the right view
is CTRL+4.
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Top
The Top button is chosen to reorient the view to the top view. The hotkey for the top view is
CTRLA+5.

Bottom

The Bottom button is chosen to reorient the view to the bottom view. The hotkey for the bottom
view is CTRL+6.

Isometric

The Isometric button is chosen to reorient the view to the isometric view. You can view the
model with all three axes in this view. The hotkey for the isometric view is CTRL+7.

Normal To

The Normal To button is chosen to reorient the view normal to a selected face or plane. This
button will be available only in the sketching environment or when you select a planar face or a
plane.

View Orientation

qab You can also invoke these standard views using the Orientation dialog box. This dialog

box is invoked by choosing the View Orientation button from the View toolbar. This

dialog box can also be invoked by pressing the SPACEBAR from the keyboard. Note

that when you invoke this dialog box by pressing the SPACEBAR, the dialog box will be displayed

at the location where the cursor is placed currently. The Orientation dialog box is shown in
Figure 4-33.

Orientotion B3|
| (2238

*Mormal To

“Back
“Left
“Right
*Top
“Battam
*| zometric
*Trimetric
“Dimetnic

Figure 4-33 Orientation dialog box

You can invoke the view from this dialog box by double-clicking it. You will notice that in
addition to the standard views, two more additional views are displayed. These are the trimetric
view and the dimetric view. These options can be used to change the current view to trimetric or
dimetric. The buttons that are available on top of this dialog box are discussed next.
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Push-Pin
You will notice that the Orientation dialog box is automatically closed when you select
a view, select a point somewhere on the screen, or invoke a tool. If you want that this
dialog box should be retained on the screen, you can pin it at a location by choosing the
Push-Pin button. This is the first button on top of this dialog box. Move the dialog box to the
desired location and then choose this button. The dialog box will be pinned to that location
and will not close when you perform any operation.

New View
% The New View button is chosen to create a user-defined view and save it in the list of the
views in the Orientation dialog box. Using the various drawing display tools and the
Rotate View tool, modify the current view and then choose this button. When you
choose this button, the Named View dialog box will be displayed. Enter the name of the view in
the View Name edit box and then choose the OK button. You will notice that a user-defined
view is created and it is saved in the list available in the Orientation dialog box.

Update Standard Views

The Update Standard Views button is chosen to modify the orientation of the standard
El views. For example, if you want that the view that is displayed when you invoke the Back

option from this dialog box should be the front view, then change the current view to
the back view by double-clicking it in the Orientation dialog box. Now, select the Front option
from the list of the views available in the Orientation dialog box and then choose the Update
Standard Views button. The SolidWorks warning box will be displayed and you will be informed
that if you change the standard view, all the other named views in the model will also be changed.
If you make the change using the Yes button then the current view that was originally the back
view will become the front view. Also, all the other views will be modified automatically.

Reset Standard Views
The Reset Standard Views button is chosen to reset the standard settings of all the
@ standard views in the current drawing. When you choose this button, the SolidWorks
warning box will be displayed and you will be prompted to confirm whether you want to
reset all the standard views to their original settings or not. If you choose Yes, all the standard
views will be reset to their default settings.

Previous View

% The Previous View option is used to display the previous orientation of the model. You
can undo upto last 10 views. This option is used only when you change the view of the
model or a drawing or a sketch one or more than one time.

DISPLAY MODES OF THE MODEL

SolidWorks provides you with various predefined modes to display the model. You can select
any of these display modes from the View toolbar. These modes are discussed next.
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Shaded

The Shaded mode is the default mode in which the model is displayed. When you open
% | anew file and create a base feature, you will notice that it is automatically shaded. This
is because the Shaded button is chosen by default in the View toolbar.

Fast HLR/HLV

@ Sometimes when you rotate the view of a large assembly, or a model with large number of

teatures with Shaded or the Hidden Lines Removed shading modes, the regeneration

of the model takes a lot of time. This can be avoided by choosing the Fast HLR/HLG

button in combination with the other shading modes. Choosing this button speeds up the

regeneration time and you can easily rotate the view. This is a toggle mode and is turned on

when you choose this button. This button is chosen in combination with any of the other display
modes.

Hidden Lines Removed

® When you choose the Hidden Lines Removed button, the hidden lines in the model
will not be displayed. Only those edges will be displayed that should be displayed in
the current view.

Hidden Lines Visible

@ When you choose the Hidden Lines Visible button, the model is displayed in the
wireframe and the hidden lines in the model will be displayed as dashed lines.

Wireframe

When you choose the Wireframe button, all the hidden lines will be displayed along
% with the visible lines in the model. If you set this display mode for complex models,
sometimes it becomes difficult to recognize the visible lines and the hidden lines.

Perspective

ﬁ You can display the perspective view of a model using the Perspective button from the

View toolbar. You can create the perspective view of any type of view such as Shaded,

Wireframe, Hidden In Gray, or Hidden Lines Removed. You can also save the perspective

view as a named view. Choose View > Modify > Perspective from the menu bar to invoke the

Perspective View PropertyManager. Using this PropertyManager you can modify the observer
position using the Object Sizes Away spinner. Figure 4-34 shows a perspective view.

Tip. When you rotate the view with the current display mode set to Hidden Lines
Removed, the hidden lines in the model are automatically displayed while the view
is being rotated. If you do not want to display the hidden lines, choose the Fast
HLR/HLY button in combination with the Hidden Lines Removed button in the
View toolbar and then rotate the view. You will notice that the hidden lines are no
more displayed in the model.
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Figure 4-34 Perspective view of a model

Display HLR Edges In Shaded Mode

% This button is not available in the View toolbar by default. You will have to add this

button to the View toolbar using the Customize dialog box. You can also invoke this

display mode by choosing View > Display > HLR Edges In Shaded Mode from the

menu bar. If this button is chosen, the model will be displayed in shaded mode and the visible
edges of the model are also highlighted.

Shadows In Shaded Mode

@ The Shadows In Shaded Mode button is used to display the shadow of the model. A
light appears from the top of the model to display the shadow in the current view. When
you activate the shadow in the shaded mode then the performance of the system is
affected during the dynamic orientation. The position of the shadow is not changed when you
rotate the model in the 3D space. To change the placement of shadow first remove the shadow in
the shaded model using the Shadow in Shaded Mode button and rotate the model; after rotating
the model use the same button to activate the shadow in the shaded mode. Figure 4-35 shows a
model with shadow in the shaded mode.
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Figure 4-35 Shadow in active shaded mode

TUTORIALS

Tutorial 1

In this tutorial you will open the sketch drawn in Tutorial 2 of Chapter- 3. You will then convert
this sketch into an extruded model by extruding it in two directions as shown in Figure 4-36.
The parameters for extruding the sketch are given next.

N

Figure 4-36 Model for Tutorial 1
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Direction 1
Depth = 10mm
Draft angle = 35°

Direction 2
Depth = 15mm
Draft angle = 0°

After creating the model, you will rotate the view using the Rotate View tool and then modify
the standard views such that the front view of the model becomes the top view. You will then save
the model with the current settings. (Expected time: 30 min)

o®

€.

The steps that will be followed to complete this tutorial are given next:

Open the file of Tutorial 2 of Chapter- 3, refer to Figure 4-37.

Save this file in the ¢04 directory with a new name.

Invoke the Extrude Boss/Base tool and convert the sketch into a model, refer to Figures 4-38
and 4-39.

Rotate the view using the Rotate View tool to view the model from all the directions, refer to
Figure 4-40.

Invoke the Orientation dialog box and then modity the standard view, refer to Figure 4-41.

Opening the File of Tutorial 2 of Chapter- 3

Since the file that you require is saved in the \My Documents\SolidWorks\cO3 directory, you
will have to select this directory and then open the c03-tut2.SLDPRT file.

Start SolidWorks by double-clicking its shortcut icon at the desktop of your computer. Close
the Tip of the Day dialog box.

Choose the Open Document option from the Welcome to SolidWorks 2003 window.
Select the \My Documents\SolidWorks\cO3 directory.

All the files that were created in Chapter 3 will be displayed in this directory.

Select the c03-tut02.SLDPRT file and then choose the Open button.

Since the sketch was saved in the sketching environment in Chapter 3, it will open in the
sketching environment.

Saving the File in the c04 Directory

‘ c04-solidworks-2003.p65

It is recommended that when you open a file of some other chapter, you should save it in the
directory of the current chapter with some other name before you proceed with modifying
the file. This is because if you save the file in the current directory, the original file of the
other chapter will not be modified.

Choose File > Save As from the menu bar to display the Save As dialog box.
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Since the ¢03 directory was selected last to open the file, it will be the current directory.

Choose the Up One Level button available on the right of the Save in drop-down
list to move to the \SolidWorks directory. =

Create a new directory with the name ¢04 using the Create New Folder button. ﬁ

Make the ¢04 directory current by double-clicking it.

Enter the new name of the drawing as ¢c04-tut01.SLDPRT in the File name edit box and
then choose the Save button to save the document.

The file will be saved with the new name and the new file will now be opened on the screen.
The sketch that will be displayed on the screen is shown in Figure 4-37.

Figure 4-37 Sketch that will be opened on the screen

Extruding the Sketch

Next, you will invoke the Extrude Boss/Base tool and extrude the sketch using the parameters
given in the tutorial description.

Choose the Extrude Boss/Base button from the Features toolbar to invoke the a |
Extrude PropertyManager as shown in Figure 4-38.

Since the sketch is closed, therefore, only the Direction 1 rollout will be displayed in the
Extrude PropertyManager. You will notice that the view is automatically changed to a 3D
view. The preview of the feature, in the temporary shaded graphics with the default values,
is shown in the drawing area.

Choose the Draft On/Off button from the Direction 1 rollout and then set the value of the
Draft Angle spinner to 35.
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Figure 4-38 Extrude Feature dialog box

These are the settings in direction 1. Now, you need to specity the settings for direction 2.
3. Select the Direction 2 check box to invoke the Direction 2 rollout.

You will notice that the default values in this rollout are the same as you specified in the
Direction 1 rollout.

Since the Draft On/Off button is selected when you invoke the Direction 2 rollout, therefore,
you need to turn this button off. This is because you do not require the draft angle in the
second direction.

4. Choose the Draft On/Off button from the Direction 2 rollout. Set the value of the Depth
spinner to 15 since the depth in the second direction is 15mm.

This completes all the settings for the model in both the directions.

5. Choose the OK button to create the feature or choose the OK icon from the confirmation
corner.

It is recommended that you change the view to isometric view after creating the feature so
that you can properly view the feature.

6. Choose the Isometric button from the Standard Views toolbar. The isometric view @
of the resultant solid model is shown in Figure 4-39.

Rotating the View

As mentioned earlier, you can rotate the view so that you can view the model from all the
directions.

‘ c04-solidworks-2003.p65 37 5/12/2003, 9:49 AM



4-38 SolidWorks for Designers

<

Figure 4-39 Isomelric view of the solid model

1. Choose the Rotate View button from the View toolbar.
The arrow cursor will be replaced by the rotate view cursor.

2. Press and hold down the left mouse button and drag the cursor on the screen to rotate the
view as shown in Figure 4-40.

Figure 4-40 Rotating the view to display the model from different divections

You will notice that the model is being displayed from different directions. Note that when
you rotate the view, the model is not being rotated. The camera that is used to view the
model is being rotated around the model.
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3. After viewing the model from all the directions, choose the Isometric button again E‘-‘I_-‘Ej

from the Standard Views toolbar to change the current view to the isometric view.

Modifying the Standard Views

As mentioned in the tutorial description, you need to modify the standard views such that
the front view of the model becomes the top view. This is done using the Orientation dialog
box.

Press the SPACEBAR on the keyboard to invoke the Orientation dialog box.

The orientation dialog box is automatically closed as soon as you perform any other operation.
Therefore, you will have to pin this dialog box so that it is not closed automatically.

Hold the Orientation dialog box by selecting it on the blue bar at top of this dialog box and
then drag it to the top right corner of the drawing window.

Choose the Push Pin button to pin this dialog box at the top right corner of the | g |
drawing window. Pinning the dialog box ensures that the dialog box is not
automatically closed when you perform any other operation.

Double-click the Front option in the list box of the Orientation dialog box.

The current view will be automatically changed to the front view and the model will now be
displayed from the front.

Select the Top option from the list box by selecting it once.

Make sure you do not double-click this option. This is because if you double-click this
option, the model will be displayed from the top.

Now, choose the Update Standard Views button to update the standard views. %3?

The SolidWorks warning box will be displayed and you will be warned that moditying the
standard views will change the orientation of any named view in the drawing.

Choose Yes from this dialog box to modify the standard views.

Now, double-click the Isometric option provided in the list box of the Orientation dialog
box. You will notice that the isometric view is different now, see Figure 4-41.

Choose the Push Pin button in the Orientation dialog box again and pick a _Wl
point anywhere in the drawing area to close the dialog box.

Saving the Model

Since the name of the document was specified at the beginning, you just have to choose the
save button now to save the file.
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Figure 4-41 Model displayed from modified isometric view
1. Choose the Save button from the Standard toolbar to save the model. n

The model will be saved with the name \My Documents\SolidWorks\cO4\c04-tut01.SLDPRT.

2. Choose File > Close from the menu bar to close the file.

Tutorial 2

In this tutorial you will open the sketch drawn in Exercise 1 of Chapter- 3. You will then create
a thin feature by revolving the sketch through an angle of 270-degree as shown in Figure 4-42.
You will offset the sketch outwards while creating the thin feature.

-

Figure 4-42 Revolved model for Tutorial 2
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After creating the model you will set the display type to Hidden Lines Removed and will rotate
the view to display the model from all the directions. (Expected time: 30 min)

o®

The steps that will be followed to complete this tutorial are given next:

Open the sketch of Exercise 1 of Chapter- 3, refer to Figure 4-43.

Save it in the current directory.

Invoke the Revolve Boss/Base tool and revolve the sketch through an angle of 270-degree,
refer to Figure 4-45.

Change the current view to isometric view and then change the display type to Hidden
Lines Removed, refer to Figure 4-46.

Rotate the view using the Rotate View tool to display the model from different directions,
refer to Figure 4-47.

Opening the file of Exercise 1 of Chapter- 3

Since the file that you require is saved in the \My Documents\SolidWorks\cO3 directory, you
will have to select this directory and then open the ¢03-exr1.SLDPRT file.

Choose the Open button from the Standard dialog box to display the Open dialog =3
box.

The c04 directory will be current in this dialog box.

Select the \My Documents\SolidWorks\cO3 directory.

All the files that were created in Chapter 3 will be displayed in this directory.

Select the c03-exr01.SLDPRT file and then choose the Open button.

The file will be opened in the sketching environment. Also, you will notice that the file is

maximized in the SolidWorks window. This is because in the previous tutorial you selected
the option to maximize the files when opened.

Saving the File in the c04 Directory
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As mentioned earlier, it is recommended that you save the file with a new name so that the
original file is not modified.

Choose File > Save As from the menu bar to display the Save As dialog box.
Since the ¢03 directory was selected last to open the file, it will be the current directory.

Choose the Up One Level button available on the right of the Save in drop-down list to
move to the \SolidWorks directory.

Make the ¢04 directory current by double-clicking it.
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Enter the name of the document in the File name edit box as c04-tut02.SLDPRT. Choose

the Save button to save the file. The sketch that will be displayed on the screen is shown in
Figure 4-43.

k!

108
360

Figure 4-43 Skelch for the revolved model

Revolving the Sketch

The sketch consists of two centerlines. The first centerline was used to mirror the sketched
entities and the other one was drawn to revolve the sketch. However, if you choose the
Revolve Boss/Base button, the Revolve PropertyManager will not be displayed. Instead,
the SolidWorks warning box will be displayed and you will be informed that the sketch
should have either a single centerline or you should select a centerline before invoking this
tool. Therefore, to revolve the sketches that have more than one centerlines, you need to
first select the centerline and then invoke the Revolve Boss/Base tool.

Select the horizontal centerline and choose the Revolve Boss/Base button from the .ﬂ.
Features toolbar. :

The current view will be changed to a 3D view and the Revolve PropertyManager will be
displayed. The confirmation corner will also be displayed. Since the sketch is closed, therefore,
only the Revolve Parameters rollout will be displayed in this PropertyManager. The
preview of a complete revolved feature in temporary shaded graphics will be displayed on
the screen. Since the preview of the model is not displayed properly in the current view,
therefore, you have to use the zoom to fit option. Also, since you need to create a thin
teature, you need to select the Thin Feature check box from the Revolve PropertyManager.

Choose the Zoom to Fit button from the View toolbar or press the F key from the @ |
keyboard.

Set the value of the Angle spinner to 270.
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The preview of the revolved model will also be modified accordingly. Note that if the
horizontal centerline was drawn from left to right, then the direction of revolution has to be
reversed.

4. Select the Thin Feature check box to invoke the Thin Feature rollout as shown in Figure 4-44.

¥ Thin Feature FS

@ IDne-Directinn j
&1 [1-00mm :I

Figure 4-44 Thin Feature rollout

5. Set the value of the Wall Thickness spinner to 5.
You will notice that the preview of the thin feature is shown outside the original sketch.

6. Choose the OK button to create the revolved feature or choose the OK icon from the
confirmation corner.

You will notice that the revolved feature is created. As evident from the model, the thin
features are hollowed inside and have some wall thickness.

7. Choose the Isometric button from the Standard Views toolbar to change the view [fﬁj
to isometric view. The revolved feature is shown in Figure 4-45.

=

Figure 4-45 Model created by revolving the sketch

Note
If you are working on Windows XP operating system, the shadow will be automatically displayed.
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Changing the Display Type
As mentioned in the tutorial description, you need to change the display type to Hidden
Lines Removed. In this type of display mode, the model will be shown with hidden lines
removed. You can set this display type by choosing its button available in the View toolbar.

1. Choose the Hidden Lines Removed button from the View toolbar. ® |

You will notice that the model is no more shaded. However, at the same time the hidden
lines in the model will be suppressed and will not be displayed. The model with this display
type is shown in Figure 4-46.

Figure 4-46 Model displayed in Hidden Lines Removed mode

Rotating the View

Next, you need to rotate the view so that you can view the model from all the directions. As
mentioned earlier, the view can be rotated using the Rotate View tool.

1. Choose the Rotate View button from the View toolbar.
=)
The arrow cursor will be replaced by the rotate view cursor.

2. Press the left mouse button and drag the cursor on the screen to rotate the view. Figure 4-47
shows the model being rotated with hidden lines removed.

». Note
©9

<= | Ifthe hidden lines are displayed while rotating the model, you need to set the hidden line display

g option. Choose View > Display > Use Fast HLR/HLV from the menu bar.

3. Choose the Isometric button from the Standard Views toolbar to change the current [ffj
view to isometric view.
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Figure 4-47 Rotating the model with hidden lines suppressed

Saving the Sketch

2.

Since the name of the document was specified at the beginning, you just have to choose the
save button now to save the file.

Choose the Save button from the Standard toolbar to save the model. E |
The model will be saved with a name \My Documents\SolidWorks\cO4\c04-tut02.SLDPRT .

Choose File > Close from the menu bar to close the file.

Tutorial 3

In this tutorial you will create the model shown in Figure 4-48. The dimensions of the model are
shown in Figure 4-49. The extrusion depth of the model is 20mm. After creating the model,
rotate the view and then change the view back to isometric view before saving the model.
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(Expected time: 45 min)
The steps that will be used to complete this tutorial are given next:

Open a new part file and then switch to the sketching environment.

Draw the outer loop of the sketch and then draw the sketch of three inner cavities. Finally,
draw the six circles inside the outer loop, refer to Figures 4-50 through 4-54.

Invoke the Extrude Boss/Base tool and extrude the sketch through a distance of 20mm,
refer to Figure 4-55.

Rotate the view using the Rotate View tool.

Change the current view to isometric view and then save the model.
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Figure 4-49 Dimensions of the model for Tutorial 3

Opening a New Part File
1. Choose the New button from the Standard toolbar and open a new part file using M
the New SolidWorks Document dialog box. —

2. Choose the Sketch button from the Sketch toolbar to switch to the sketching L‘:?
environment for drawing the sketch. —_—

Drawing the Outer Loop
When the sketch consists of more than one closed loop, it is recommended that you add
relations and dimensions to the outer loop first so that it is fully defined. Next, draw the
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‘ c04-solidworks-2003.p65

inner loops one by one and add relations and dimensions to them. Therefore, you will first
draw the outer loop first and then add the relations and dimensions to it.

Draw a circle in the first quadrant and then dimension it so that it is forced to a diameter of
100mm.

Locate the center of the circle at a distance of 70mm along X and Y directions from @ |
the origin by adding dimensions in both the directions. Choose the Zoom to Fit

button to fit the display on the screen.

Draw a horizontal centerline from the center of the circle.

Draw a circle at the intersection of the centerline and the bigger circle.

Trim the part of the sketch so that the sketch looks similar to the one shown in Figure 4-50.

0

70

)
¥

Figure 4-50 Skelch after trimming the unwanted portion

Dimension the smaller arc so that it is forced to a radius of 10mm.

Add the Coincident relation to the centerpoint of the smaller arc and the circumference of
the outer arc.

You will notice that as you add the dimension and relations to the sketch, it turns black in
color. This suggests that the sketch is fully defined.

Next, you will create a circular pattern of the smaller arc. The total number of instances in
the pattern is 6 and the total angle is 360-degree.
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8. Select the smaller arc using the Select tool and then choose the Circular Sketch |/ =
Step and Repeat button from the Sketch Tools toolbar. =
The Circular Sketch Step and Repeat dialog box will be displayed and the cursor will be
replaced by the circular pattern cursor.

9. Move the circular pattern cursor at the control point available at the end of the arrow that is
displayed at the origin.

The circular pattern cursor will turn yellow in color.

10. Press and hold the left mouse button down at the control point and then drag it to the
center of the outer arc in the sketch. Release the left mouse button when the cursor turns
yellow in color.

11. Set the value of the Number spinner in the Step area to 6. Accept all the other default values
and choose the OK button to create the pattern.

You will notice that all the instances of the pattern are black in color. This is because you
have already applied the dimensions and relations to the original instance and so the other
instances are also fully defined.

12. Trim the unwanted portion of the outer arc using the Sketch Trim tool. This completes the
outer loop. The sketch at this stage should look similar to the one shown in Figure 4-51.

S

70

70

A

Figure 4-51 Ouler loop of the sketch

Drawing the Sketch of the Inner Slots

Now, you need to draw the sketch of the inner cavities. You will draw the sketch of one of the
cavities and then add the required relations and dimensions to it. Next, you will create a
circular pattern of this cavity. The number of instances in the circular pattern will be 3.
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1.
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Using the Centerpoint Arc tool, draw an arc with the center at the centerpoint of the outer
arc of 100mm diameter.

Dimension this arc such that it is forced to a radius of 30mm. Also, add the angular dimensions
to the arc, refer to Figure 4-52. The arc will turn black in color, suggesting that it is fully
defined.

Offset the last arc outward through a distance of 10mm using the Offset Entities tool.

The new arc created using the Offset tool is also black in color. Also, a dimension with the
value 10mm will be created between the two arcs.

Close the two ends of the arc using the Tangent Arc tool. This completes the sketch of one

of the inner cavities. All the entities in the sketch at this stage should be displayed in black
color as shown in Figure 4-52.

Lo
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70
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70
Figure 4-52 Sketch afier drawing the sketch of the inner cavity

Next, you will create a circular pattern of the inner slot. This is done using the Circular
Sketch Step and Repeat tool.

Select all the entities in the sketch of the inner slot and then choose the Circular | .=,
Sketch Step and Repeat button from the Sketch Tools toolbar. s

The Circular Sketch Step and Repeat dialog box will be displayed and the center of the
circular pattern is again placed at the origin.

Hold the left mouse button down at the control point provided at the end of the arrow
displayed at the origin and drag it to the center of the outer arc in the sketch.
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7. Set the value of the Number spinner in the Step area to 3 and then choose the OK button
to create the circular pattern.

This completes the sketch of the inner cavities. The sketch after creating the circular pattern
of the inner cavities is shown in Figure 4-53.

O
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Figure 4-53 Sketch after creating the circular pattern

Drawing the Sketch for the Holes
Next, you need to draw the sketch for the holes. You will draw one of the circles and then
add dimension to it. Then you will create a circular pattern of the circle.

1. Taking the centerpoint of one of the arcs on the outer arc of 100mm diameter, draw a circle
and then dimension it to force it to a diameter of 10mm.

The circle will turn black in color when you dimension it.

2. Select the circle using the Select tool and then choose the Circular Sketch Step | &®a
and Repeat button from the Sketch Tools toolbar. =2

3. Drag the center of the circular pattern to the center of the outer arc.

4. Setthevalue of the Number spinner in the Step area to 6. Choose OK to create the pattern.
All the instances in the pattern will be displayed in black color.

This completes the sketch of the model. The final sketch of the model is shown in Figure 4-54.

Extruding the Sketch
The next step after drawing the sketch is to extrude it. The sketch will be extruded using the
Extrude Boss/Base tool.
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Figure 4-54 Final sketch of the model

1. Choose the Extrude Boss/Base button from the Features toolbar to invoke the a |

Extrude PropertyManager.

The current view will be changed to a 3D view and the Extrude PropertyManager will be
displayed. Also, the preview of the model as it will be created using the default values will be

displayed on the screen.

2. Set the value of the Depth spinner to 20 and then choose the OK button to extrude the

sketch.

3. Choose the Isometric button from the Standard Views toolbar to change the view Eﬁl
to isometric view. The completed model for Tutorial 3 is shown in Figure 4-55.

Rotating the View

1. Choose the Rotate View button from the View toolbar. r::,

The arrow cursor will be replaced by the rotate view cursor.

2. Press the left mouse button and drag the cursor on the screen to rotate the view.

3. Choose the Isometric button from the Standard Views toolbar. @

Saving the Sketch

Since the document has not been saved even once until now, therefore, when you choose the
Save button from the Standard toolbar, the Save As dialog box will be displayed. You can

enter the name of the document in this dialog box.

‘ c04-solidworks-2003.p65 51

5/12/2003, 9:49 AM



4-52 SolidWorks for Designers

Figure 4-55 Final model for Tutorial 3

Choose the Save button from the Standard toolbar and save the model with the E |
name given below:

\My Documents\SolidWorks\cO4\cO4-tut03.SLDPRT.

Choose File > Close from the menu bar to close the file.

SELF-EVALUATION TEST

Answer the following questions and then compare your answers with the answers given at
the end of this chapter.

1.

2.

In SolidWorks, a sketch is revolved using the Base-Extrude PropertyManager. (T/F)

You can also specity the depth of extrusion dynamically in the preview of the extruded
feature. (T/F)

You can invoke the drawing display tools such as Zoom to Fit while the preview of a model
is displayed on the screen. (T/F)

When you rotate the view with the current display mode set to Hidden Lines Removed, the
hidden lines in the model are automatically displayed while the view is being rotated. (T/F)

tool is used to display the perspective view of a model.

The Cap Ends check box is displayed in the Extrude Thin Feature dialog box only when
the sketch selected to create a thin feature is
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7. The check box is used to create a feature with different values in both the
directions of the sketching plane.

8. The check box is used to apply the automatic fillets while creating a thin
feature.

9. The button is used to display the shadow in the shaded mode.

10. To resume rotating the view freely after you have completed rotating it around a selected

vertex, edge, or face, any where in the drawing area.

REVIEW QUESTIONS

Answer the following questions:

1.
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You can also invoke the Rotate View tool by choosing the Rotate View option from the
that is displayed when you right-click in the drawing window.

When you choose the Wireframe button, all the lines will be displayed along
with the visible lines in the model.

You can also modity the parallel view to perspective view by choosing from the
menu bar.

When you invoke the Extrude Boss/Base tool or the Revolve Boss/Base tool, the view is
automatically changed to a

The thin revolved features can be created using a or an sketch.

Which one of the following buttons is chosen to modify the orientation of the standard
views?

(a) Update Standard Views (b) Reset Standard Views
(c) None (d) Both

Which one of the following buttons is not available in the View toolbar by default?

(a) Hidden Lines Removed (b) Hidden In Gray
(c) Shaded (d) Display HLR Edges In Shaded Mode

Which one of the following parameters will not be displayed in the preview of the model?

(a) Depth (b) Draft angle
(c) None (d) Both
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9. Ifthe sketch is open, it can be converted into

(a) Thin feature (b) Solid feature
(c) None (d) Both
10. In SolidWorks, the circular pattern of the sketched entities is created using which one of the
following tools?
(a) Circular Pattern (b) Circular Sketch Step and Repeat
(c) None (d) Both

EXERCISES

Exercise 1

Create the model shown in Figure 4-56. The sketch of the model is shown in Figure 4-57. Create
the sketch and dimension the sketch using the autodimension option. The extrusion depth of
the model is 15mm. After creating the model, rotate the view. (Expected time: 30 min)

Figure 4-56 Model for Exercise 1
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Figure 4-57 Sketch of the model for Exercise 1

Exercise 2

Create the model shown in Figure 4-58. The sketch of the model is shown in Figure 4-59. Create
the sketch and dimension the sketch using the autodimension tool. The extrusion depth of the
model is 25mm. Modify the standard view such that the current front view of the model should
be displayed when you invoke the top view. (Expected time: 30 min)

Figure 4-58 Model for Exercise 2
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Figure 4-59 Sketch of the model for Exercise 2

Answers to Self-Evaluation Test
1. F, 2. T, 3. T, 4. T, 5. Perspective, 6. closed, 7. Both Directions, 8. Instance deleted, 9.
shortcut menu, 10. double-click

‘ c04-solidworks-2003.p65 56 5/12/2003, 9:49 AM ‘



