
Chapter 3

Starting with the
Advanced Sketching

After completing this chapter, you will be able to:
• Draw arcs using various options.
• Draw rectangles, ellipses, and elliptical arcs.
• Draw polygons such as hexagons and pentagons.
• Draw traces, polylines, and donuts.
• Draw points and change point style and point size.
• Draw infinite lines and create simple text.

Learning Objectives
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DRAWING ARCS

An arc is defined as a part of a circle. In AutoCAD
LT, it can be drawn, using the ARC command
(Figure 3-1).

An arc can be drawn in 11 distinct ways, using the
options listed in the Arc menu (Figure 3-2). The
default method for drawing an arc is the 3 Points
option. Other options can be invoked by entering
the appropriate letter to select an option. The
last parameter to be specified in any arc generation
is automatically dragged into the relevant location.
This is dependent on the DRAGMODE variable,
which should be set to Auto (default).

The 3 Points Option
When you choose the Arc button from the Draw toolbar, or enter ARC at the Command
prompt, you automatically enter the 3 Points option. This option requires you to specify
the start point, second point, and endpoint of the arc, see Figure 3-3. The arc can be

drawn in a clockwise or counterclockwise direction by dragging the arc with the cursor. The
following is the prompt sequence to draw an arc with a start point at (2,2), second point at (3,3),
and an endpoint at (3,4). (You can also specify the points, by moving the cursor and then
specifying them on the screen.)

Command: Choose the Arc button from the Draw toolbar (3 Points is the default option).
Specify start point of arc or [Center]: 2,2 �
Specify second point of arc or [Center/End]: 3,3 �
Specify end point of arc: 3,4 �

Toolbar: Draw > 3 Points
Tool Palettes: Command Tools > Line > Arc
Menu: Draw > Arc
Command: ARC or A

Figure 3-1   Invoking the ARC command
from the Draw toolbar

Figure 3-2  The Arc menu showing the
options for drawing an arc
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Draw several arcs using the 3 Points option. The points can be selected by entering coordinates
or by specifying points on the screen. Also, try to create a circle by drawing two separate arcs and
a single arc. Notice the limitations of the ARC command.

The Start, Center, End Option
This option is slightly different from the 3 Points option. In this option, instead of entering the
second point, you need to enter the center of the arc. Choose this option, when you know the
start point, endpoint, and center point of the arc. The arc is drawn in a counterclockwise
direction from the start point to the endpoint around the specified center. The endpoint
specified need not be on the arc and is used only to calculate the angle at which the arc ends.
The radius of the arc, is determined by the distance between the center point and start point.
The prompt  sequence for drawing an arc, shown
in Figure 3-4, with a start point at (3,2), center
point at (2,2), and endpoint at  (2,3.5) is given
next.

Command: ARC �
Specify start point of arc or [Center]: 3,2 �
Specify second point of arc or [Center/End]:
C �
Specify center point of arc: 2,2 �
Specify end point of the arc or [Angle/chord
Length]: 2,3.5 �

Exercise 1 General

 Figure 3-3  Drawing an arc using the 3 Points option

 Figure 3-4  Drawing an arc using the Start,
Center, End option
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 Figure 3-5  Drawing an arc using the Start,
Center, Angle option

Figure 3-6  Drawing an arc using a negative angle
in the Start, Center, Angle option

Note
If you choose the Start, Center, End option from the Draw > Arc menu, after entering the start
point, the center option is automatically invoked. This way you bypass the prompt Specify
second point of arc or [Center/End]. You need to simply specify the center point.

The Start, Center, Angle Option
This option is the best choice, if you know the included angle of the arc. The included angle is
the angle formed by the start and endpoint of the arc with the specified center. This option
draws an arc in a counterclockwise direction with the specified center and start point spanning
the indicated angle, see Figure 3-5. If the specified angle is negative, the arc is drawn in a
clockwise direction, see Figure 3-6.

The prompt sequence for drawing an arc with center at (2,2), start point at (3,2), and an
included angle of 60-degree, as shown in Figure 3-5, is given next.

Command: ARC �
Specify start point of arc or [Center]: 3,2 �
Specify second point of arc or [Center/End]: C �
Specify center point of arc: 2,2 �
Specify end point of the arc or [Angle/chord Length]: A �
Specify included angle: 60 �

You can draw arcs with negative angle values in the Start, Center, Included Angle (St,C,Ang)
option by entering “-” (negative sign), followed by the required angle at the Specify included
angle prompt (Figure 3-6). The following prompt sequence is displayed, when you invoke the
ARC command:

Specify start point of arc or [Center]: 4,3 �
Specify second point of arc or [Center/End]: C �
Specify center point of arc: 3,3 �
Specify end point of the arc or [Angle/ chord Length]: A �
Specify included angle: -180 �
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Note
If you choose this option from the Draw menu, the center and the angle options are invoked and
you simply have to specify the start point, center point, and angle.

To invoke the rest of the options, you will use the Draw menu.

a. Draw an arc using the St,C,Ang option. The start point is (6,3), the center point is (3,3), and
the angle is 240-degree.

b. Make the drawing shown in Figure 3-7. The distance between the dotted lines is 1.0 unit.
Create the radii, by using the arc command options indicated in the drawing.

The Start, Center, Length Option
In this option you are required to specify the start point, center point, and length of the chord.
A chord is defined as the straight line connecting the start point and endpoint of an arc. The
chord length needs to be specified so that AutoCAD LT can calculate the ending angle. Identical
start, center, and chord length specifications can be used to define four different arcs. AutoCAD LT
always draws this type of arc counterclockwise from the start point. Therefore, a positive chord
length gives the smallest possible arc with that length. This arc is known as the minor arc. The
minor arc is less than 180-degree. A negative value for the chord length results in the largest
possible arc, also known as the major arc. The chord length can be determined, by using the
standard chord length tables or the mathematical relation (L = 2*Sqrt [h(2r-h)]). For example,
an arc of radius 1 unit, with an included angle of 30-degree, has a chord length of 0.51764
units. The prompt sequence for drawing an arc, shown in Figure 3-8 that has a start point (3,1),
center (2,2), and the chord length of 2 units is given next.

Exercise 2 Mechanical

Figure 3-7  Drawing for Exercise 2(b)
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Exercise 3 General

Figure 3-8  Drawing an arc using the Start,
Center, Length option

Figure 3-9  Drawing an arc using a negative chord
length in the Start, Center, Length option

Command: Choose the Start, Center, Length option from the Draw > Arc menu.
Specify start point of arc or [Center]: 3,1 �
Specify second point of arc or [Center/End]: _c Specify center point of arc: 2,2 �
Specify end point of the arc or [Angle/ chord Length]: _l Specify length of chord: 2 �

You can draw the major arc by defining the length of the chord as negative, see Figure 3-9. In
this case, the arc with a start point at (3,1), center point at (2,2), and a negative chord length of
-2, is drawn with the following prompt sequence.

Command: Choose the Start, Center, Length option from the Draw > Arc menu.
Specify start point of arc or [Center]: 3,1 �
Specify second point of arc or [Center/End]: _c Specify center point of arc: 2,2 �
Specify end point of the arc or [Angle/ chord Length]: _l Specify length of chord: -2 �

Note
The points that you have specified for drawing the arcs using different options are quite close to
each other and therefore the arcs created might overlap each other. You can use the ERASE
command to erase some of the previously drawn arcs and gain space to draw new arcs.

Draw a minor arc with the center point at (3,4), start point at (4,2), and chord length of 4 units.

The Start, End, Angle Option
With this option, you can draw an arc by specifying the start point of the arc, endpoint, and the
included angle. A positive included angle value draws an arc in a counterclockwise direction
from the start point to the endpoint, spanning the included angle; a negative included angle
value draws the arc in a clockwise direction. The prompt sequence for drawing an arc with a start
point at (3,2), endpoint at (2,4), and included angle of 120-degree (Figure 3-10) is given next.
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Command: Choose the Start, End, Angle option
from the Draw > Arc menu.
Specify start point of arc or [Center]: 3,2 �
Specify second point of arc or [Center/End]:
_e Specify end point of arc: 2,4 �
Specify center point of arc or [Angle/
Direction/Radius]: _a Specify included
angle: 120 �

The Start, End, Direction
Option
In this option, you can draw an arc by specifying
the start point, endpoint, and starting direction
of the arc, in degrees. In other words, the arc
starts in the direction you specify (the start of the
arc is established tangent to the direction you
specify). This option can be used to draw a major
or minor arc, in a clockwise or counterclockwise
direction, whose size and position are determined
by the distance between the start point and
endpoint and the direction specified. To illustrate
the positive direction option shown in
Figure 3-11, the prompt sequence for an arc with
a start point at (4,3), endpoint at (3,5), and
direction of 90-degree is given next.

Command: Choose the Start, End, Direction
option from the Draw > Arc menu.
Specify start point of arc or [Center]: 4,3 �
Specify second point of arc or [Center/End]:
_e Specify end point of arc: 3,5 �
Specify center point of arc or [Angle/Direction/Radius]: _d Specify tangent direction for the
start point of arc: 90 �

To illustrate the option of using a negative direction degree specification, shown in Figure 3-12,
the prompt sequence for an arc with a start point at (4,3), endpoint at (3,4), and direction of
-90-degree, is given next.

Command: Choose the Start, End, Direction option from the Draw > Arc menu.
Specify start point of arc or [Center]: 4,3 �
Specify second point of arc or [Center/End]: _e Specify end point of arc: 3,4 �
Specify center point of arc or [Angle/Direction/Radius]: _d Specify tangent direction for the
start point of arc: -90 �

Figure 3-10  Drawing an arc using the Start,
End, Angle option

 Figure 3-11  Drawing an arc using the Start,
End, Direction option
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Figure 3-13  Drawing for Exercise 4(b)

Note
With the Start, End, Direction option, if you do not specify a start point but just press ENTER
at the Specify start point of arc or [Center] prompt, the start point and direction of the arc will
be taken from the endpoint and ending direction of the previous line or arc drawn on the
current screen. You are then required to specify only the endpoint of the arc.

a. Specify the directions and coordinates of two arcs in such a way that they form a circular
figure.

b. Make the drawing shown in Figure 3-13. Create the curves using the Arc command. The
distance between the dotted lines is 1.0 unit and the diameter of the circles is 1 unit.

Exercise 4 Mechanical

 Figure 3-12  Drawing an arc using a negative direction
in the Start, End, Direction option
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The Start, End, Radius Option
This option is used when you know the start point,
endpoint, and radius of the arc. The same values
for the three variables (start point, endpoint, and
radius) can result in four different arcs.
AutoCAD LT resolves this by always drawing this
type of arc in a counterclockwise direction from
the start point. Therefore, a negative radius value
results in a major arc (the largest arc between
two endpoints), Figure 3-14(a), while a positive
radius value results in a minor arc (smallest arc
between the start point and endpoint),
Figure 3-14(b). The prompt sequence to draw a
major arc with a start point at (3,3), endpoint at
(2,5), and radius of -2, Figure 3-14(a), is given next.

Command: Choose the Start, End, Radius option from the Draw > Arc menu.
Specify start point of arc or [Center]: 3,3 �
Specify second point of arc or [Center/End]: _e Specify end point of arc: 2,5 �
Specify center point of arc or [Angle/Direction/Radius]: _r Specify radius of arc: -2 �

The prompt sequence to draw a minor arc with its start point at (3,3), endpoint at (2,5), and
radius as 2 as shown in Figure 3-14(b) is given next.

Command: Choose the Start, End, Radius option from the Draw/Arc menu.
Specify start point of arc or [Center]: 3,3 �
Specify second point of arc or [Center/End]: _e Specify end point of arc: 2,5 �
Specify center point of arc or [Angle/Direction/Radius]: _r Specify radius of arc: 2 �

The Center, Start, End Option
The Center, Start, End option is a modification
of the Start, Center, End option. Use this
option, whenever it is easier to start drawing an
arc by establishing the center first. Here the arc
is always drawn in a counterclockwise direction
from the start point to the endpoint, around
the specified center. The prompt sequence for
drawing the arc, shown in Figure 3-15, that has
a center point at (3,3), start point at (5,3), and
endpoint at (3,5) is given next.

Command: Choose the Center, Start, End
option from the Draw > Arc menu.
Specify start point of arc or [Center]: _c
Specify center point of arc: 3,3 �

Figure 3-14  Drawing an arc using the Start,
End, Radius option

 Figure 3-15  Drawing an arc using the Center,
Start, End option
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Specify start point of arc: 5,3 �
Specify end point of arc or [Angle/chord Length]: 3,5 �

The Center, Start, Angle Option
This option is a variation of the Start, Center,
Angle option. Use this option, whenever it is
easier to draw an arc by giving the center first.
The prompt sequence for drawing the arc, shown
in Figure 3-16, that has a center point at (4,5),
start point at (5,4), and included angle of
120-degree is given next.

Command: Choose the Center, Start, Angle
option from the Draw > Arc menu.
Specify start point of arc or [Center]: _c
Specify center point of arc: 4,5 �
Specify start point of arc: 5,4 �
Specify end point of arc or [Angle/chord
Length]: _a Specify included angle: 120
�

The Center, Start, Length Option
The Center, Start, Length option is a
modification of the Start, Center, Length
option. This option is used, whenever it is
easier to draw an arc by establishing the center
first. The prompt sequence for drawing the arc,
shown in Figure 3-17, that has a center point
at (2,2), start point at (4,3), and length of chord
of 3 is given next.

Command: Choose the Center, Start, Angle
option from the Draw > Arc menu.
Specify start point of arc or [Center]: _c
Specify center point of arc: 2,2 �
Specify start point of arc: 4,3 �
Specify end point of arc or [Angle/chord
Length]: _l  Specify length of chord: 3 �

Continue Option
With this option, you can continue drawing an arc from a previously drawn arc or line. When
you select the Continue option (Draw menu), the start point and direction of the arc will be
taken from the endpoint and ending direction of the previous line or arc drawn on the current
screen. When this option is used to draw arcs, each successive arc will be tangent to the previous

Figure 3-16  Drawing an arc using the Center,
Start, Angle option

 Figure 3-17  Drawing an arc using the Center,
 Start, Length option
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one. Most often, this option is used to draw
arcs tangent to a previously drawn line. The
prompt sequence to draw the arc shown in
Figure 3-18, which is tangent to an earlier
drawn line, using the Continue option, is
given next.

Command: LINE �
Specify first point: 2,2 �
Specify next point or [Undo]: 4,3 �
Specify next point or [Undo]: �

Command: Choose the Continue option from
the Draw > Arc menu.
Specify endpoint of arc: 4,5 �

The prompt sequence to draw an arc
continued from a previously drawn arc, as
shown in Figure 3-19, is given next.

Command: ARC �
Specify start point of arc or [Center]: 2,2
�
Specify second point of arc or [Center/
End]: E �
Specify endpoint of arc : 3,4 �
Specify center point of arc or [Angle/
Direction/Radius]: R �
Specify radius of arc: 2  �

Command: Choose the Continue option
from the Draw > Arc menu.
Specify end point of arc: 5,4  �

Tip
The Continue option can also be invoked by pressing ENTER at the Specify start point of
arc or [Center] prompt after entering ARC at the Command prompt. Even when you select
any option of the ARC command from the Draw > Arc menu, pressing ENTER at the
Specify start point of arc or [Center] prompt invokes the Continue option by terminating
the selected option. Here you are asked to specify the endpoint to complete the arc.

Continue (LineCont:) Option
This option is used when you want to continue drawing a line from the endpoint of a previously
drawn arc. When you use this option, the start point and direction of the line will be taken from
the endpoint and ending direction of the previous arc. In other words, the line will be tangent

Figure 3-18  Drawing an arc using the Continue
option

Figure 3-19  Drawing an arc using the Continue
option
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Figure 3-21  Drawing for Exercise 5(a)

Exercise 5 General

to the arc drawn on the current screen. This option is invoked when you press ENTER at the
Specify first point prompt of the LINE command. The prompt sequence to draw a line, tangent
to an earlier drawn arc, as shown in Figure 3-20, is given next.

Command: ARC  �
Specify start point of arc or [Center]: 4,3
�
Specify second point of arc or [Center/
End]: E �
Specify end point of arc : 3.37,3.92 �
Specify center point of arc or [Angle/
Direction/Radius]: Specify the center point.

Command: LINE �
Specify first point: �
Length of line: Enter a value or pick a
point.

a. Use the Center, Start, Angle and Continue options to draw the figures shown in Figure 3-21.
b. Make the drawing shown in Figure 3-22. The distance between the dotted lines is 1.0 units.

Create the radii as indicated in the drawing, by using the ARC command options.

Figure 3-20  Drawing a line from the endpoint of
an arc
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Figure 3-22  Drawing for Exercise 5(b)

DRAWING RECTANGLES*

A rectangle can be drawn using the RECTANG
command, see Figure 3-23. In AutoCAD LT, you can
draw rectangles by specifying two opposite corners of
the rectangle, by specifying the area and the size of one of the sides, or by specifying the
dimensions of the rectangle. All these methods of drawing rectangles are discussed next.

Drawing Rectangles Using Two Opposite Corners
On invoking the RECTANG command, you are
prompted to specify the first corner of the
rectangle. Here, you can enter the coordinates of
the first corner or specify the desired point  with
the pointing device. The first corner can be any
one of the four corners. Next, you are prompted
to specify the other corner. This corner is taken
as the corner diagonally opposite the first corner.
You can specify the coordinates for the other
corner or simply move the cursor to specify it.
The prompt sequence for drawing a rectangle with
(3,3) as its lower left corner coordinate and (6,5)
as its upper right corner (Figure 3-24), is given
next.

Toolbar: Draw > Rectangle
Menu: Draw > Rectangle
Command: RECTANG

Figure 3-24  Drawing a rectangle by specifying
two opposite corners

Figure 3-23  Invoking the RECTANG
command from the Draw toolbar
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Command: RECTANG �
Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: 3,3 � (Lower left
corner location.)
Specify other corner point or [Area/Dimensions/Rotation]: 6,5 � (Upper right corner location.)

Drawing Rectangles by Specifying the Area and One Side
This option allows you to draw the rectangle, by specifying its area and the value of one of the
sides. This can be done by entering A at the Specify other corner point or [Area/Dimensions/
Rotation] prompt. The following is the prompt sequence to use this option:

Command: RECTANG �
Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: 3,3 �
Specify other corner point or [Area/Dimensions/Rotation]: A �
Enter area of rectangle in current units <100.000>: 15 �
Calculate rectangle dimensions based on [Length/Width] <Length>: L �
Enter rectangle length <10.0000>: 5 �

In the above case, the area and length of the rectangle were entered. The system automatically
calculates its width using the following formula:

      Area of rectangle = Length X Width
      Width = Area of rectangle/Length
      Width =15/5
      Width =3 units

Drawing Rectangles by Specifying its Dimensions
You can also specify the dimensions of the rectangle to draw it. This is possible by entering D at
the Specify other corner point or [Area/Dimensions/Rotation] prompt, which then allows you
to enter the length and width of the rectangle. The prompt sequence for drawing a rectangle
with a length of 5 units and width of 3 units is given next.

Command: RECTANG �
Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: 3,3 �
Specify other corner point or [Area/Dimensions/Rotation]: D �
Specify length for rectangles <0.0000>: 5 �
Specify width for rectangles <0.0000>: 3 �

Here, you are allowed to choose any one of the four locations for placing the rectangle. You can
move the cursor to see the four locations. Depending on the location of the cursor, the specified
first corner point holds the position of either the lower left corner, the lower right corner, the
upper right corner, or the upper left corner. After deciding the position, you can then click to
place the rectangle.

Drawing the Rectangle at an Angle
One of the enhancements of this release of AutoCAD LT is its ability to draw rectangle at an
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angle. This can be done  by entering R at the Specify other corner point or [Area/Dimensions/
Rotation] prompt, which then allows you to enter the rotation angle. After entering the rotation
angle, you can continue sizing the rectangle using any of the methods.  Once you have specified
the rotation angle, next time whenever you draw the rectangle, it will be drawn at an angle. Set
the rotation angle to Zero, if you do not want to draw the rectangle at an angle. The prompt
sequence for drawing the rectangle at a rotation of 45 degree is:

Command: RECTANG �
Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: Select a point as
lower left corner location.
Specify other corner point or [Area/Dimensions/Rotation]: R �
Specify rotation angle or [Pick points]
<current>: 45 �
Specify other corner point or [Area/
Dimensions/Rotation]: Select a point as upper
right corner location.

While specifying the other corner point, you can
place the rectangle in any of the four quadrants.
Move the cursor in the different quadrants and
select a point in the quadrant, in which you need
to draw the rectangle. Figure 3-25 shows a
rectangle drawn at an angle of 45-degree.

The remaining options of the RECTANG
command are discussed next.

Chamfer
The Chamfer option creates a chamfer, which
is an angled corner, by specifying the chamfer
distances, see Figure 3-26. The chamfer is
created at all the four corners. You can give
two different chamfer values to create an
unequal chamfer.

Command: RECTANG �
Specify first corner point or [Chamfer/
Elevation/Fillet/Thickness/Width]: C �
Specify first chamfer distance for rectangles
<0.0000>: Enter a value.
Specify second chamfer distance for
rectangles <0.0000>: Enter a value.
Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: Select a point as
lower left corner location.
Specify other corner point or [Area/Dimensions/Rotation]: Select a point as upper right corner
location.

 Figure 3-25  Drawing a rectangle at an angle

 Figure 3-26  Drawing a rectangle with chamfers
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Note
The first corner point that you specify need not be the lower left corner location. While selecting
the other corner, you can select a location such that the first corner point becomes the lower right
corner, or the upper left corner, or the upper right corner.

Fillet
The Fillet option allows you to create a filleted
rectangle, see Figure 3-27. You can specify the
required fillet radius. The following is the prompt
sequence for specifying the fillet.

Specify first corner point or [Chamfer/
Elevation/Fillet/Thickness/Width]: F �
Specify fillet radius for rectangles <0.0000>:
Enter a value.

Note that the rectangle will be filleted only if the
length and width of the rectangle are equal to or
greater than twice the value of the specified fillet.
Otherwise, AutoCAD LT will draw a rectangle without fillets.

Note
You can draw a rectangle either with chamfers or with fillets. If you specify the chamfer distances
first and then specify the fillet radius in the same RECTANG command, the rectangle will be
drawn with fillets only.

Width
The Width option allows you to create a rectangle whose line segments have some specified
width, as shown in Figure 3-28.

Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: W �
Specify line width for rectangles <0.0000>: Enter a value.

Thickness
The Thickness option allows you to draw a rectangle that is extruded in the Z direction by the
specified value of thickness. For example, if you draw a rectangle with thickness of 2 units, you
will get a rectangular box whose height is 2 units, see Figure 3-29. To view the box, choose
View > 3D Views > SE Isometric from the menu bar. You will have to restore the view back to
the plan view, by choosing View > 3D Views > Top from the menu bar.

Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: T �
Specify thickness for rectangles <0.0000>: Enter a value.

Figure 3-27 Drawing a rectangle with fillets
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Elevation
The Elevation option allows you to draw a rectangle at a specified distance from the XY plane,
along the Z axis. For example, if the elevation is 2 units, the rectangle will be drawn two units
above the XY plane. If the thickness of the rectangle is 1 unit, you will get a rectangular box of
1 unit height located 2 units above the XY plane, see Figure 3-29.

Chamfer/Elevation/Fillet/Thickness/Width/<First corner>: E �
Specify elevation for rectangles <0.0000>: Enter a value.

To view the objects in 3D space, change the viewpoint by choosing View > 3D Views > SE
Isometric from the menu bar.

Note
The value you enter for fillet, width, elevation, and thickness becomes the current value for the
subsequent RECTANG command. Therefore, you must reset the values, if they are different from
the current values. The thickness of a rectangle is always controlled by its thickness settings.

The rectangle generated on the screen is treated as a single object. Therefore, the individual sides
can be edited only after the rectangle has been exploded using the EXPLODE command.

Tip
You can combine the different options in one RECTANG command and then draw the rectangle
with the specified characteristics. When you invoke the RECTANG command again, the previously
set options and their values are displayed before the first prompt. This allows you to change the
settings according to the new specifications.

Draw a rectangle 4 units long, 3 units wide, and with its first corner at (1,1). Draw another
rectangle of length 2 units and width 1 unit, with its first corner at 1.5,1.5, and at an angle of
65-degree.

Figure 3-29  Drawing rectangles with thickness and
elevation specified

Figure 3-28  Drawing a rectangle with a specified
width

Exercise 6 General
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DRAWING ELLIPSES

If a circle is observed from an angle, the shape seen
is called an ellipse, which can be created in
AutoCAD LT using the ELLIPSE command
(Figure 3-30). An ellipse can be created using
options listed within the ELLIPSE command.
AutoCAD LT creates a true ellipse, also known as a
NURBS-based (Non-Uniform Rational Bezier
Spline) ellipse. The true ellipse has a center and
quadrant points. If you select it, the grips (small
blue squares) will be displayed at the center and
quadrant points of the ellipse. If you move one of
the grips located on the perimeter of the ellipse,
the major or minor axis will change, which changes
the size of the ellipse, as shown in Figure 3-31(d).
The creation of a true ellipse is dependent on the
PELLIPSE system variable, which has a default
value of 0.

Note
Until Release 12, ellipses were based on polylines. They were made of multiple polyarcs and as a
result, it was difficult to edit an ellipse. For example, if you select a polyline-based ellipse, the
grips will be displayed at the endpoints of each polyarc. On moving a vertex point, you get the
shape shown in Figure 3-31(b). Also, you cannot snap to the center or quadrant points of a
polyline-based ellipse. In AutoCAD LT 2006, you can still draw the polyline-based ellipse by
setting the value of the PELLIPSE system variable to 1, which is 0 (true ellipse) by default.

Once you invoke the ELLIPSE command, AutoCAD LT will acknowledge with the prompt
Specify axis endpoint of ellipse or [Arc/Center] or Specify axis endpoint of ellipse or
[Arc/Center/Isocircle] (if isometric snap is on). The response to this prompt depends on the
option you  choose. The various options are explained next.

Note
The Isocircle option is not available by default in the ELLIPSE command. To display this
option, you have to select the Isometric snap radio button in the Snap and Grid tab of the
Drafting Settings dialog box.

The Arc option is not available, if you set the value of the PELLIPSE system variable to 1 for
drawing the polyline-based ellipse.

Toolbar: Draw >Ellipse
Tool Palettes: Command Tools > Line > Ellipse
Menu: Draw > Ellipse
Command: ELLIPSE

Figure 3-31  Drawing polyline and NURBS-
based ellipses

Figure 3-30  Invoking the ELLIPSE
command from the Draw toolbar
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Drawing an Ellipse Using the Axis and Endpoint Option
In this option, you draw an ellipse by specifying one of its axes and the endpoint of the other
axis. To use this option, acknowledge the Specify axis endpoint of ellipse or [Arc/Center]
prompt by specifying a point, either by using a pointing device or by entering its coordinates.
This is the first endpoint of one axis of the ellipse. AutoCAD LT will then respond with the
prompt Specify other endpoint of axis. Here, specify the other endpoint of the axis. The angle
at which the ellipse is drawn depends on the angle made by these two axis endpoints. Your
response to the next prompt determines whether the axis is the major axis or the minor axis.

The next prompt is Specify distance to other axis or [Rotation]. If you specify a distance, it is
presumed as half the length of the second axis. You can also specify a point. The distance from
this point to the midpoint of the first axis is again taken as half the length of this axis. The
ellipse will pass through the selected point only if it is perpendicular to the midpoint of the first
axis. To visually analyze the distance between the selected point and the midpoint of the first
axis, AutoCAD LT appends an elastic line to the crosshairs, with one end fixed at the midpoint
of the first axis. You can also drag the point, dynamically specifying half of the other axis
distance. This helps you to visualize the ellipse. The prompt sequence for drawing an ellipse
with one axis endpoint located at (3,3), the other at (6,3), and the distance of the other axis
being 1 (Figure 3-32) is given next.

Command: ELLIPSE �
Specify axis endpoint of ellipse or [Arc/Center]: 3,3  �
Specify other endpoint of axis : 6,3  �
Specify distance to other axis or [Rotation]: 1  �

Another example for drawing an ellipse (Figure 3-33), using this option, is illustrated by the
following prompt sequence.

Command: ELLIPSE �
Specify axis endpoint of ellipse or [Arc/Center]: 3,3  �

Figure 3-32  Drawing an ellipse using the Axis
and Endpoint option

Figure 3-33  Drawing an ellipse using the Axis
and Endpoint option
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Specify other endpoint of axis : 4,2 �
Specify distance to other axis or [Rotation]: 2 �

If you enter Rotation or R at the Specify distance to other axis or [Rotation] prompt, the first
axis specified is automatically taken as the major axis of the ellipse. The next prompt is Specify
rotation around major axis. The major axis is taken as the diameter line of the circle, and the
rotation takes place around this diameter line into the third dimension. The ellipse is formed,
when AutoCAD LT projects this rotated circle into the drawing plane. You can enter the rotation
angle value in the range of 0 to 89.4-degree only, because an angle value greater than 89.4-degree
changes the circle into a line. Instead of entering a definite angle value at the Specify rotation
around major axis prompt, you can specify a point relative to the midpoint of the major axis.
This point can be dragged to specify the ellipse dynamically. The following is the prompt
sequence for a rotation of 0-degree around the major axis, as shown in Figure 3-34(a):

Command: ELLIPSE �
Specify axis endpoint of ellipse or [Arc/Center]: Select point (P1).
Specify other endpoint of axis : Select another point (P2).
Specify distance to other axis or [Rotation]: R �
Specify rotation around major axis: 0 �

Figure 3-33 also shows rotations of 45-degree, 60-degree, and 89.4-degree.

Draw an ellipse whose major axis is 4 units and the rotation around this axis is 60-degree. Draw
another ellipse, whose rotation around the major axis is 15-degree.

   Figure 3-34  Rotation about the major axis

Exercise 7 General
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Drawing Ellipse Using the Center and Two Axes Option
In this option, you can construct an ellipse by specifying the center point, endpoint of one axis,
and length of the other axis. The only difference between this method and the ellipse by axis
and endpoint method is that instead of specifying the second endpoint of the first axis, the
center of the ellipse is specified. The center of an ellipse is defined as the point of intersection
of the major and minor axes. In this option, the first axis need not be the major axis. For
example, to draw an ellipse with center at (4,4), axis endpoint at (6,4), and length of the other
axis as 2 units (Figure 3-35), the prompt sequence is given next.

Command: ELLIPSE  �
Specify axis endpoint of ellipse or [Arc/
Center]: C �
Specify center of ellipse: 4,4  �
Specify endpoint of axis: 6,4  �
Specify distance to other axis or
[Rotation]: 1 �

Instead of entering the distance, you can enter
Rotation or R at the Specify distance to other
axis [Rotation] prompt. This takes the first
axis specified as the major axis. The next
prompt, Specify rotation around major axis,
prompts you to enter the rotation angle value.
The rotation takes place around the major axis, which is taken as the diameter line of the circle.
The rotation angle values should range from 0 to 89.4-degree.

Drawing Elliptical Arcs

AutoCAD LT allows you to draw elliptical arcs using the Ellipse Arc button in the Draw
toolbar. When you choose this button, the ELLIPSE command is invoked, with the Arc
option selected and you will prompt you to enter information about the geometry of the

ellipse and the arc limits. You can define the arc limits by using the following options:

1.  Start and End angle of the arc.
2.  Start and Included angle of the arc.
3.  Start and End parameters.

The angles are measured from the first point and in counterclockwise direction, if AutoCAD
LT’s default setup is not changed. The following example illustrates the use of these three
options.

Figure 3-35  Drawing an ellipse using the Center
option

Toolbar: Draw > Ellipse Arc
Menu: Draw > Ellipse > Arc
Command: ELLIPSE > Arc
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Draw the following elliptical arcs, as shown in Figures 3-36 and 3-37.
a. Start angle = -45, end angle = 135
b. Start angle = -45, included angle = 225
c. Start parameter = @1,0, end parameter = @1<225

Specifying Start and End Angle of the Arc [Figure 3-35(a)]

Command: Choose the Ellipse Arc button from the Draw toolbar.
Specify axis endpoint of ellipse or [Arc/Center]: _a
Specify axis endpoint of elliptical arc or [Center]: Select the first endpoint.
Specify other endpoint of axis : Select the second point to the left of the first point.
Specify distance to other axis or [Rotation]: Select a point or enter a distance.
Specify start angle or [Parameter]: -45 �
Specify end angle or [Parameter/Included angle]:  135 �  (Angle where arc ends.)

Specifying Start and Included Angle of the Arc [Figure 3-35(b)]

Command: Choose the Ellipse Arc button from the Draw toolbar.
Specify axis endpoint of ellipse or [Arc/Center]: _a
Specify axis endpoint of elliptical arc or [Center]: Select the first endpoint.
Specify other endpoint of axis : Select the second point.
Specify distance to other axis or [Rotation]: Select a point or enter a distance.
Specify start angle or [Parameter]: -45 �
Specify end angle or [Parameter/Included angle]: I �
Specify included angle for arc<current>: 225 ��(Included angle.)

Example 1 General

   Figure 3-36  Drawing elliptical arcs
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Specifying Start and End Parameters (Figure 3-37):

Command: Choose the Ellipse Arc button from the Draw toolbar.
Specify axis endpoint of ellipse or [Arc/Center]: _a
Specify axis endpoint of elliptical arc or [Center]: Select the first endpoint.
Specify other endpoint of axis: Select the second endpoint.
Specify distance to other axis or [Rotation]: Select a point or enter a distance.
Specify start angle or [Parameter]: P
Specify start parameter or [Angle]: @1,0
Specify end parameter or [Angle/ Included angle]: @1<225

Calculating Parameters for an Elliptical Arc
The start and end parameters of an elliptical arc are determined, by specifying a point on the
circle whose diameter is equal to the major diameter of the ellipse, as shown in Figure 3-36. In
this drawing, the major axis of the ellipse is 2.0 and the minor axis is 1.0. The diameter of the
circle is 2.0. To determine the start and end parameters of the elliptical arc, you must specify the
points on the circle. In the example, the start parameter is @1,0 and the end parameter is
@1<225. Once you specify the points on the circle, AutoCAD LT will project these points on
the major axis and determine the endpoint of the elliptical arc. In Figure 3-37, Q is the end
parameter of the elliptical arc. AutoCAD LT projects point Q on the major axis and locates
the intersection point P, which is the endpoint of the elliptical arc. The coordinates of point P
can be calculated, by using the following equations.

The equation of an ellipse with the center as origin is
x^2/a^2 + y^2/b^2 = 1

In parametric form x = a * cos(u)
y = b * sin(u)

Figure 3-37  Drawing an elliptical arc by specifying the start and end
parameters
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For the example a = 1
b = 0.5

Therefore x = 1 * cos(225) = -0.707
y = 0.5 * sin(225) = -0.353

The coordinates of point P are (-0.707, -0.353) with respect to the center of the ellipse.
Note: v = atan(b/a*tan(u)) = end angle

v = atan(0.5/1*tan(225)) = 206.56o
Also e = 1-b^2/a^2)^.5 = eccentricity

e = 1-.5^2/1^2)^.5 = .866
r = x^2 + y^2)^.5
r = .707^2 + .353^2)^.5 = 0.790

or using the polar equation r = b/(1 - e^2 * cos(v)^2)^.5
r = .5/(1 - .866^2 * cos(206.56)^2)^.5
r = 0.790

a. Construct an ellipse with center at (2,3), axis endpoint at (4,6), and the  other axis endpoint
a distance of 0.75 units from the midpoint of the first axis.

b. Make the drawing as shown in Figure 3-38. The distance between the dotted lines is 1.0
unit. Create the elliptical arcs using the ELLIPSE command options.

Exercise 8 General

Figure 3-38  Drawing for Exercise 8(b)
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DRAWING REGULAR POLYGONS

A regular polygon is a closed geometric figure with equal
sides and equal angles. The number of sides varies from
3 to 1024. For example, a triangle is a three-sided
polygon and a pentagon is a five-sided polygon. In AutoCAD LT, the POLYGON command
(Figure 3-39) is used to draw regular 2D polygons. The characteristics of a polygon drawn in
AutoCAD LT are those of a closed polyline having a 0 width. You can change the width of the
polyline forming the polygon. The prompt sequence is given next.

Command: POLYGON  �
Enter number of sides <4>:

Once you invoke the POLYGON command, it prompts you to enter the number of sides. The
number of sides determines the type of polygon (for example, six sides define a hexagon). The
default value for the number of sides is 4. You can change the number of sides to your requirement
and then the new value becomes the default value. You can also set a different default value for
the number of sides, by using the POLYSIDES system variable.

The Center of Polygon Option
After you specify the number of sides, the next prompt is Specify center of polygon or [Edge],
where the default option prompts you to select a point that is taken as the center point of the
polygon. The next prompt is Enter an option [Inscribed in circle/Circumscribed about
circle]<I>. A polygon is said to be inscribed when it is drawn inside an imaginary circle and
its vertices (corners) touch the circle, see Figure 3-40. Likewise, a polygon is circumscribed
when it is drawn outside the imaginary circle and the sides of the polygon are tangent to the
circle (midpoint of each side of the polygon will lie on the circle), see Figure 3-41. If you want to
have an inscribed polygon, enter I at the prompt. The next prompt issued is Specify radius of
circle. Here, you are required to specify the radius of the circle on which all the vertices of the
polygon will lie. Once you specify it, a polygon will be generated. If you want to select the
circumscribed option, enter C at the prompt Enter an option[Inscribed in circle/Circumscribed
about circle]<I>. You can also select these options from the selection preview. After this, enter
the radius of the circle. The inscribed or circumscribed circle is not drawn on the screen. The
radius of the circle can be dynamically dragged instead of a numerical value being entered. The
prompt sequence for drawing an inscribed octagon shown in Figure 3-40, with the center at (4,4)
and the radius of 1.5 units, is given next.

Command: POLYGON �
Enter number of sides<4>: 8 �
Specify center of polygon or [Edge]: 4,4 �
Enter an option[Inscribed in circle/Circumscribed about circle ]<I>: I �
Specify radius of circle: 1.5 �

Toolbar: Draw > Polygon
Menu: Draw > Polygon
Command: POLYGON

Figure 3-39  Invoking the POLYGON
command from the Draw toolbar
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The prompt sequence for drawing a circumscribed pentagon shown in Figure 3-41 with center at
(4,4) and a radius of 1.5 units, is given next.

Command: POLYGON �
Enter number of sides<4>: 5 �
Specify center of polygon or [Edge]: 4,4 �
Enter an option[Inscribed in circle/Circumscribed about circle ]<I>: C �
Specify radius of circle: 1.5 �

Note
If you select a point to specify the radius of an inscribed polygon, one of the vertices is positioned
on the selected point. In the case of circumscribed polygons, the midpoint of an edge is placed on
the point you have specified. In this manner, you can specify the size and rotation of the polygon.

In case of the numerical specification of the radius, the bottom edge of the polygon is rotated by
the prevalent snap rotation angle.

Draw a circumscribed polygon of eight sides. The polygon should be drawn by the Center of
Polygon method.

The Edge Option
The other method for drawing a polygon is to select the Edge option. This can be done by
entering E at the Specify center of polygon or [Edge] prompt. The next two prompts issued are
Specify first endpoint of edge and Specify second endpoint of edge. Here, you need to
specify the two endpoints of an edge of the polygon. The polygon is drawn in a
counterclockwise direction, with the two entered points defining its first edge. To draw a
hexagon (six-sided polygon), shown in Figure 3-42, using the Edge option, with the first
endpoint of the edge at (2,4) and the second endpoint of the edge at (2,2.5), the prompt
sequence is given next.

Figure 3-40  Drawing an inscribed polygon using
the Center of Polygon option

Figure 3-41  Drawing a circumscribed polygon
using the Center of Polygon option

Exercise 9 General
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Command: POLYGON �
Enter number of sides<4>: 6 �
Specify center of polygon or [Edge]: E
�
Specify first endpoint of edge: 2,4 �
Specify second endpoint of edge:
2,2.5 �

Draw a polygon with ten sides using the Edge option and an elliptical arc, as shown in Figure 3-43.
Let the first endpoint of the edge be at (7,1) and the second endpoint be at (8,2).

DRAWING POLYLINES

A polyline, created using the PLINE command,
(Figure 3-44) is a line that can have different characteristics.
The term POLYLINE can be broken into two parts: POLY
and LINE. POLY means “many”. This signifies that a polyline can have many features. Some of
these features are listed next.

Figure 3-42  Drawing a polygon (hexagon)
using the Edge option

Figure 3-43  Polygon and elliptical arc for Exercise 10

Toolbar: Draw > Polyline
Tool Palettes: Command Tools > Line > Polyline
Menu: Draw > Polyline
Command: PLINE (or PL)

Figure 3-44  Invoking the POLYLINE
command from the Draw toolbar

Exercise 10 General
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1. Polylines can be thick lines with a desired width. They are very flexible and can be used to
draw any shape, such as a filled circle or a doughnut.

2. Polylines can be used to draw objects in any linetype (for example, hidden linetype).
3. Advanced editing commands can be used to edit them (for example, the PEDIT command).
4. A single polyline object can be formed by joining polylines and polyarcs of different

thicknesses.
5. It is easy to determine the area or perimeter of a polyline feature. Also, it is easy to offset

when drawing walls.

The PLINE command functions fundamentally like the LINE command, except that additional
options are provided and all the segments of the polyline form a single object. After invoking
the PLINE command, the following prompt is displayed:

Specify start point: Specify the starting point or enter its coordinates.
Current line width is nn.nnnn.

Current line width is nn.nnnn is displayed automatically, which indicates that the polyline
drawn will have nn.nnnn width. If you want a different width, invoke the Width option at the
next prompt and set it. Next, the following prompt is displayed.

Specify next point or [Arc/Halfwidth/Length/Undo/Width]: Specify the next point or enter an
option.

Depending on your requirements, the options that can be invoked at this prompt are as follows.

Next Point of Line
This option is maintained as the default option and is used to specify the next point of the
current polyline segment. If additional polyline segments are added to the first polyline,
AutoCAD LT automatically makes the endpoint of the previous polyline segment the start point
of the next polyline segment. The prompt sequence is given next.

Command: PLINE �
Specify start point: Specify the starting point of the polyline.
Current line width is 0.0000.
Specify next point or [Arc/Halfwidth/Length/Undo/Width]: Specify the endpoint of the first
polyline segment.
Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: Specify the endpoint of the
second polyline segment, or press ENTER to exit the command.

Width
You can change the current polyline width by entering W (width option) at the last prompt.  You
can also right-click and choose the Width option from the shortcut menu. Next, you are prompted
for the starting and ending width of the polyline.

Specify next point or [Arc/Halfwidth/Length/Undo/Width]: W �
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Specify starting width <current>: Specify the starting width.
Specify ending width <starting width>: Specify the ending width.

The starting width value is taken as the default value for the ending width. Therefore, to have a
uniform polyline, you need to press ENTER at the Specify ending width <> prompt. As in the
case of traces, the start and endpoint of the polyline are located at the center of the line width.
To draw a uniform polyline, shown in Figure 3-45, with a width of 0.25 units, start point at (4,5),
endpoint at (5,5), and the next endpoint at (3,3), use the following prompt sequence.

Command: PLINE �
Specify start point: 4,5 �
Current line-width is 0.0000
Specify next point or [Arc/Halfwidth/Length/Undo/Width]: W �
Specify starting width <current>: 0.25 �
Specify ending width <0.25>: �
Specify next point or [Arc/Halfwidth/Length/Undo/Width]: 5,5 �
Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: 3,3 �
Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: �

You can get a tapered polyline, by entering two different values at the starting width and the
ending width prompts. To draw a tapered polyline, shown in Figure 3-46, with a starting width
of 0.5 units and an ending width of 0.15 units, a start point at (2,4), and an endpoint at (5,4),
use the following prompt sequence.

Command: PLINE �
Specify start point: 2,4 �
Current line-width is 0.0000
Specify next point or [Arc/Halfwidth/Length/Undo/Width]: W �
Specify starting width <0.0000>: 0.50 �
Specify ending width <0.50>: 0.15 �
Specify next point or [Arc/Halfwidth/Length/Undo/Width]: 5,4 �
Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: �

Figure 3-45  Drawing a uniform polyline using
the PLINE command

Figure 3-46  Drawing a tapered polyline using
the PLINE command
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Halfwidth
With this option, you can specify the starting and ending halfwidth of a polyline. This halfwidth
distance is equal to half of the actual width of the polyline. This option can be invoked by
entering H or choosing Halfwidth from the shortcut menu at the following prompt.

Specify next point or [Arc/Halfwidth/Length/Undo/Width]: H �
Specify starting half-width <0.0000>: 0.12 � (Specify desired starting halfwidth.)
Specify ending half-width <0.1200>: 0.05 � (Specify desired ending halfwidth.)

Length
This option prompts you to enter the length of a new polyline segment. The new polyline
segment will be the length you have entered. It will be drawn at the same angle as the last
polyline segment or tangent to the previous polyarc segment. This option can be invoked by
entering L at the following prompt or by choosing Length from the shortcut menu.

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: L �
Specify length of line: Specify the desired length of the Pline.

Undo
This option erases the most recently drawn polyline segment. It can be invoked by entering U at
the following prompt.

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: U �

You can use this option repeatedly until you reach the start point of the first polyline segment.
Further use of Undo option evokes the message All segments already undone.

Close
This option is available when at least one segment of the polyline is drawn. It closes the polyline
by drawing a polyline segment from the most recent endpoint to the initial start point. At the
same time, it exits from the PLINE command. The width of the closing segment can be changed
by using the Width/Halfwidth option, before invoking the Close option.

Arc
This option is used to switch from drawing polylines to drawing polyarcs, and provides you the
options associated with drawing polyarcs. The prompt sequence is given next.

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: A �
Specify endpoint of arc or [Angle/CEnter/Direction/Halfwidth/Line/Radius/Second pt/Undo/
Width]: Enter an option.

By default, the arc segment is drawn tangent to the previous segment of the polyline. The
direction of the previous line, arc, or polyline segment is the default direction for the polyarc.



Starting with the Advanced Sketching                                                                            3-31

©
 C

A
D

C
IM

 T
ec

hn
ol

og
ie

s,
 U

S
A

. F
or

 e
ng

in
ee

ri
ng

 s
er

vi
ce

s,
 c

on
ta

ct
 s

al
es

@
ca

dc
im

.c
om

The preceding prompt contains options associated with the PLINE Arc. The detailed explanation
of each of these options follows.

Angle
This option prompts you to enter the included angle for the arc. If you enter a positive angle,
the arc is drawn in a counterclockwise direction from the start point to the endpoint. If the angle
specified is negative, the arc is drawn in a clockwise direction. The prompts are given next.

Specify included angle: Specify the included angle.
Specify endpoint of arc or [Center/Radius]:

Center refers to the center of the arc segment, Radius refers to the radius of the arc, and
Endpoint draws the arc.

CEnter
This option prompts you to specify the center of the arc to be drawn. As mentioned before,
usually the arc segment is drawn such that it is tangent to the previous polyline segment; in such
cases AutoCAD LT determines the center of the arc automatically. Therefore, the CEnter option
provides the freedom to choose the center of the arc segment. This option can be invoked by
entering CE at the Specify end point of arc or [Angle/CEnter/Direction/Halfwidth/Line/Radius/
Second pt/Undo/Width] prompt. Once you specify the center point, AutoCAD LT issues the
following prompt.

Specify endpoint of arc or [Angle/Length]:

Angle refers to the included angle, Length refers to the length of the chord, and Endpoint
refers to the endpoint of the arc.

Direction
Usually, the arc drawn, with the PLINE command, is tangent to the previous polyline segment.
In other words, the starting direction of the arc is the ending direction of the previous segment.
The Direction option allows you to specify the tangent direction of your choice for the arc
segment to be drawn. You can specify the direction by specifying a point. The  prompts are given
next.

Specify tangent direction for the start point of arc: Specify the direction.
Specify endpoint of arc: Specify the endpoint of arc.

Halfwidth
This option is the same as for the PLine and prompts you to specify the starting and ending
halfwidth of the arc segment.

Line
This option takes you back to the Line mode. You can draw polylines only in this mode.
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Radius
This option prompts you to specify the radius of the arc segment. The prompt sequence is given next.

Specify radius of arc: Specify the radius of the arc segment.
Specify endpoint of arc or [Angle]:

If you specify a point, the arc segment is drawn. If you enter an angle, you will have to specify the
angle and the direction of the chord at the Specify included angle and Specify direction of
chord for arc<current> prompts, respectively.

Second pt
This option selects the second point of an arc in the three-point arc option. The prompt
sequence is given next.

Specify second point of arc: Specify the second point on the arc.
Specify endpoint of arc: Specify the third point on the arc.

Undo
This option reverses the changes made in the previously drawn segment.

Width
This option prompts you to enter the width of the arc segment. To draw a tapered arc segment,
you can enter different values at the starting width and ending width prompts. The prompt
sequence is identical to that for the polyline. Also, a specified point on a polyline refers to the
midpoint on its width.

Endpoint of Arc
This option is maintained as the default and
prompts you to specify the endpoint of the current
arc segment. The following is the prompt sequence
for drawing an arc, shown in Figure 3-47, with start
point at (3,3), endpoint at (3,5), starting width of
0.50 units, and ending width of 0.15 units.

Command: PLINE �
Specify start point: 3,3 �
Current line-width is 0.0000
Specify next point or [Arc/Halfwidth/Length/
Undo/Width]: A �
Specify endpoint of arc or [Angle/CEnter/CLose/
Direction/Halfwidth/Line/Radius/Second pt/Undo/Width]: W �
Specify starting width <current>: 0.50 �
Specify ending width <0.50>: 0.15 �
Specify endpoint of arc or [Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/
Undo/Width]: 3,5 �

 Figure 3-47  Drawing a polyarc
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Specify endpoint of arc or [Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/
Undo/Width]: �

Tip
After invoking the PLINE command and specifying the start point, you can right-click to
display the shortcut menu. You can choose any of the options under the PLINE command.
Directly from the shortcut menu, instead of entering the appropriate letters at the Command
prompt. Similarly, after invoking the Arc option of the PLINE command, you can right-click
to display the shortcut menu and choose any polyarc option.

Note
If FILL is on or if FILLMODE is 1, the polylines are drawn filled. If you change FILL to off
or FILLMODE to 0, only the outlines are drawn for the new plines and previously drawn plines
are also changed from filled to no-fill. However, note that the change is effective on regeneration.
Similarly, it works in reverse also.

Also, the PLINEGEN system variable controls the linetype pattern between the vertex points of a 2D
polyline. A value of 0 centers the linetype for each polyline segment and 1 makes it continuous.

Draw the objects shown in Figures 3-48 and 3-49. Approximate the width of different polylines.

DRAWING DONUTS

In AutoCAD LT, the DONUT or DOUGHNUT command is issued to draw an object that looks
like a filled circle ring called a donut. Actually, AutoCAD LT’s donuts are made of two semicircular
polyarcs with a certain width. Therefore, the DONUT command allows you to draw a thick
circle. The donuts can have any inside and outside diameters. If FILLMODE is off, the donuts
look like circles (if the inside diameter is zero) or concentric circles (if the inside diameter is not

 Figure 3-49  Drawing for Exercise 11 Figure 3-48  Drawing for Exercise 11

Exercise 11 General

Menu: Draw > Donut
Command: DONUT
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zero). After specifying the two diameters, the donut gets attached to the crosshairs. You can
select a point for the center of the donut anywhere on the screen with the help of a pointing
device, and then place the donut. You can place it by clicking your pointing device. The prompt
sequence for drawing donuts is given next.

Command: DONUT �
Specify inside diameter of donut <current>: Specify the inner diameter of the donut.
Specify outside diameter of donut <current>: Specify the outer diameter of the donut.
Specify center of donut or <exit>: Specify the center of the donut.
Specify center of donut or <exit>: Specify the center of the donut to draw more donuts of
previous specifications or give a null response to exit.

The defaults for the inside and outside diameters are the respective diameters of the most recent
donut drawn. The values for the inside and outside diameters are saved in the DONUTID and
DONUTOD system variables. A solid-filled circle is drawn by specifying the inside diameter as
zero (FILLMODE is on). Once the diameter specification is completed, the donuts are formed
at the crosshairs and can be placed anywhere on the screen. For the location, you can enter the
coordinates of the point or specify the point by dragging the center point. Once you have
specified the center of the donut, AutoCAD LT repeats the Specify center of donut or <exit>
prompt. As you go on specifying the locations for the center point, donuts with the specified
diameters are drawn at specified locations. To end the DONUT command, give a null response
to this prompt by pressing ENTER. Since donuts are circular polylines, the donut can be edited
with the PEDIT command or any other editing command that can be used to edit polylines.

You will draw an unfilled donut shown in Figure 3-50 with an inside diameter of 0.75 units, an
outside diameter of 2.0 units, and centered at (2,2). You will also draw a filled donut and a
solid-filled donut with the given specifications.

The following is the prompt sequence to draw an unfilled donut shown in Figure 3-50.

Command: FILLMODE �
New value for FILLMODE <1>: 0 �
Command: DONUT �
Specify inside diameter of donut<0.5000>: 0.75 �
Specify outside diameter of donut <1.000>: 2 �
Specify center of donut or <exit>: 2,2 �
Specify center of donut or <exit>: �

The following is the prompt sequence for drawing a filled donut, shown in Figure 3-51, with an
inside diameter of 0.5 units, outside diameter of 2.0 units, centered at a specified point.

Command: FILLMODE �
Enter new value for FILLMODE <0>: 1 �
Command: DONUT �

Example 2 General



Starting with the Advanced Sketching                                                                            3-35

©
 C

A
D

C
IM

 T
ec

hn
ol

og
ie

s,
 U

S
A

. F
or

 e
ng

in
ee

ri
ng

 s
er

vi
ce

s,
 c

on
ta

ct
 s

al
es

@
ca

dc
im

.c
om

Specify inside diameter of donut<0.5000>: 0.50 �
Specify outside diameter of donut <1.000>: 2 �
Specify center of donut or <exit>: Specify a point.
Specify center of donut or <exit>: �

To draw a solid-filled donut, shown in
Figure 3-52, with an outside diameter of 2.0
units, use the following prompt sequence.

Command: DONUT �
Specify inside diameter of donut <0.50>:
0 �
Specify outside diameter of donut <1.0>:
2 �
Specify center of donut or <exit>: Specify a
point.
Specify center of donut or <exit>: �

DRAWING POINTS

The point is the basic drawing object. Points are invaluable
in building a drawing file. To draw a point anywhere on
the screen, AutoCAD LT provides the POINT command (Figure 3-53).

Command: POINT �
Current point modes: PDMODE=n PDSIZE=n.nnnn
Specify a point: Specify the location where you want to place the point.

 Figure 3-50  Drawing an unfilled donut using
the DONUT command

Figure 3-51  Drawing a filled doughnut using
the DONUT command

 Figure 3-52  Solid-filled donut

Toolbar: Draw > Point
Menu: Draw > Point
Command: POINT

Figure 3-53  Invoking the POINT
command from the Draw toolbar
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If you invoke the POINT command from the toolbar or the menu (Multiple Point option), you
can draw as many points as you desire in a single command. In this case, you can exit  from the
POINT command by pressing ESC. If you invoke this command by entering POINT at the
Command prompt or use the Single Point option from the menu, you can draw only one point
in a single point command.

Note
It is possible to have a temporary construction marker for the point known as blip. A mark
appears on the screen where you place the point. This blip mark can then be cleared, once the
screen is redrawn using the REDRAW command, and the point is left on the screen. The visibility
of a blip can be controlled using the BLIPMODE system variable.

Changing the Point Type

The point type can be set from the Point Style dialog box shown in Figure 3-54. There are
twenty combinations of point types. The Point Style dialog box can be accessed from the Format
menu (choose Format > Point Style). You can choose a point style in this dialog box, which is
indicated by highlighting that particular point style. Next, choose the OK button. Now all the
points will be drawn in the selected style, until you change it to a new style. The type of point
drawn is stored in the PDMODE (Point Display MODE) system variable. You can change the
point style, by entering a numeric value in the PDMODE variable.

The PDMODE values for different point types area as follows.

1. A value of zero is the default value for the PDMODE variable and generates a dot at the
specified point.

Menu: Format > Point Style
Command: DDPTYPE

Figure 3-54  The Point Style dialog box
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2. A value of 1 for the PDMODE variable generates nothing at the specified point.
3. A value of 2 for the PDMODE variable generates a plus sign (+) at the specified point.
4. A value of 3 for the PDMODE variable generates a cross mark (X) at the specified point
5. A value of 4 for the PDMODE variable generates a vertical line in the upward direction from

the specified point.
6. When you add 32 to the PDMODE values of 0 to 4, a circle is generated around the symbol

obtained from the original PDMODE value. For example, to draw a point having a cross
mark and a circle around it, the value of the PDMODE variable will be 3 + 32 = 35.
Similarly, you can generate a square around the symbol with the PDMODE of value 0 to 4 by
adding 64 to the original PDMODE value. For example, to draw a point having a plus sign
and a square around it, the value of the PDMODE variable will be 2 + 64 = 66. You can also
generate a square and a circle around the symbol with the PDMODE of value 0 to 4 by
adding 96 to the original PDMODE value. For example, to draw a point having a dot mark
and a circle and a square around it, the value of the PDMODE variable will be 0 + 96 = 96.

Figure 3-55 shows the PDMODE values for different point types area

Check what types of points are drawn for each value of the PDMODE variable.

Changing the Point Size

The size of a point can be set from the Point Style dialog box (Figure 3-54) by entering the
desired point size in the Point Size edit box. You can generate the point at a specified percentage
of the graphics area height or define an absolute size for the point. An absolute size for the point

Figure 3-55  Different point style for PDMODE values

Exercise 12 General

Menu: Format > Point Style
Command: DDPTYPE
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can be specified by selecting the Set Size in
Absolute Units radio button in the Point Style
dialog box and then entering a value in the
Point Size edit box. The point size can also be
set by changing the value of PDSIZE
(Figure 3-56). The variable PDSIZE governs
the size of the point (except for the PDMODE
values of 0 and 1). You can set the size in
absolute units by specifying a positive value for
the PDSIZE variable. If the Set Size Relative
to Screen radio button is selected in the Point
Style dialog box, the size is taken as a
percentage of the viewport size. This can also
be set by entering a negative value for the PDSIZE variable. For example, a setting of 5 makes
the point 5 units high; a setting of -5 makes the point 5 percent of the current drawing area.

a. Try various combinations of the PDMODE and PDSIZE variables.
b. Check the difference between the points generated from negative values of PDSIZE and the

points generated from positive values of PDSIZE.

DRAWING INFINITE LINES
The XLINE and RAY commands can be used to draw construction or projection lines. These
are lines that aid in construction or projection and are drawn very lightly, when drafting manually.
An xline (construction line) is a 3D line that extends to infinity at both ends. As the line is
infinite in length, it does not have any endpoints. A ray is a 3D line that extends to infinity at
only one end. The other end of the ray has a finite endpoint. The xlines and rays have zero
extents. This means that the extents of the drawing will not change, if you use the commands
that change the drawing extents, such as the ZOOM command with the All option. Most of the
object snap modes work with both xlines and rays, with some limitations: You cannot use the
Endpoint object snap with the xline because, by definition an xline does not have any endpoints.
However, for rays you can use the Endpoint snap on one end only. Also, xlines and rays take the
properties of the layer, in which they are drawn.

Tip
Xlines and rays plot like any other objects in a drawing and so may create confusion. It is,
therefore, a good idea to create the construction lines in a different layer altogether, such that
you can recognize them easily. You will learn about layers in later chapters.

Figure 3-56  Changing the point size using the
PDSIZE variable

Exercise 13 General
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XLINE Command

When you invoke the XLINE command (Figure 3-57),
the prompt sequence is as follows.

Command: XLINE �
Specify a point or [Hor/Ver/Ang/Bsect/Offset]:
Specify an option or select a point through which the
xline will pass.

The various options of the command are discussed next.

Point
If you use the default option, AutoCAD LT
will prompt you to select two points through
which the xline shall pass at the Specify a
point and the Specify through point
prompts. After you select the first point,
AutoCAD LT will dynamically rotate the xline
through the specified point, as you move the
cursor. When you select the second point, an
xline will be created that passes through the
first and second points (Figure 3-58).

Command: XLINE �
Specify a point or [Hor/Ver/Ang/Bisect/
Offset]: Specify a point.
Specify through point: Specify the second point.

You can continue to select more points to create more xlines. All these xlines will pass through
the first point you had selected at the Specify a point prompt. This point is also called the root
point. Right-click or press ENTER to end the command.

Horizontal
This option will create horizontal xlines of infinite length that pass through the selected points.
The xlines will be parallel to the X axis of the current UCS, see Figure 3-59. As you invoke this
option, the horizontal xline gets attached to the cursor. You are prompted to select only one
point through which the horizontal xline passes. You can continue selecting points to draw
horizontal xlines and right-click or press ENTER to end the command.

Toolbar: Draw > Construction Line
Tool Palettes: Command Tools > Line > Construction Line
Menu: Draw > Construction Line
Command: XLINE

Figure 3-58  Drawing xlines

Figure 3-57  Choosing the Construction
Line button from the Draw toolbar
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Vertical
This option will create vertical xlines of infinite
length that pass through the selected points.
The xlines will be parallel to the Y axis of the
current UCS, see Figure 3-59. As you invoke
this option, the vertical xline gets attached to
the cursor. You are prompted to select only
one point through which the vertical xline
passes. You can continue selecting points to
draw vertical xlines and right-click or press
ENTER to end the command.

Angular
This option will create xlines of infinite length that pass through the selected point at a specified
angle (in Figure 3-60, the angle specified is 38-degree). The angle can be specified by entering
a value at the keyboard. You can also use the reference option by selecting an object and then
specifying an angle relative to it. The
Reference option is useful, when the actual
angle is not known but the angle relative to
an existing object can be specified.

Command: XLINE �
Specify a point or [Hor/Ver/Ang/Bisect/
Offset]: A �
Enter angle of xline (0) or [Reference]: R
�� (Here you use the Reference method
for specifying the angle.)
Select a line object: Select a line.
Enter angle of xline <0>: Enter angle (the
angle will be measured counterclockwise with
respect to the selected line.)
Specify through point: Specify the second
point.

Bisect
This option will create an xline that passes
through the angle vertex and bisects the angle
you specify by selecting two points. The xline
created using this option will lie in the
plane defined by the selected points. You can
use the object snaps to select the points on
the existing objects. The following is the
prompt sequence for this option (Figure 3-61).

Command: XLINE �

Figure 3-59  Horizontal and vertical xlines

Figure 3-60  Angular xlines

Figure 3-61  Using the Bisect option to draw
xlines
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Specify a point or [Hor/Ver/Ang/Bisect/Offset]: B �
Specify angle vertex point: Enter a point (P1).
Specify angle start point: Enter a point (P2).
Specify angle end point: Enter a point (P3).
Specify angle end point: Select more points or press ENTER or right-click to end command.

Offset
The Offset option creates xlines that are parallel to the selected line/xline at a specified offset
distance. You can specify the offset distance by entering a numerical value or by selecting two
points on the screen. If you select the Through option, the offset line will pass through the
selected point. This option works like the OFFSET editing command. The prompts at the
command line are as follows.

Command: XLINE �
Specify a point or [Hor/Ver/Ang/Bisect/Offset]: O �
Specify offset distance or [Through] <Through>: Press ENTER to accept the Through
option or specify a distance from the selected line object at which the xline shall be drawn.
Select a line object: Select the object to which the xline is drawn parallel at a specified distance.
Specify through point: Select a point through which the xline should pass.

If you specify the offset distance, and after you have selected a line object, you are prompted to
specify the direction in which the xline is to be offset. You can continue drawing xlines or
right-click or press ENTER to end the command.

RAY Command

A ray is a 3D line similar to the xline construction line, with the difference being that it extends
to infinity only in one direction. It starts from a point you specify and extends to infinity
through the specified point. The prompt sequence is give next.

Command: RAY �
Specify start point: Select the starting point for the ray.
Specify through point: Specify the second point.

Press ENTER or right-click to exit the command.

Note
When you trim an xline, it gets converted into a ray and when a ray, is trimmed at the end that
is infinite, it gets converted into a line object.

Menu: Draw > Ray
Command: RAY



3-42                                                                                              AutoCAD LT 2006 for Designers
©

 C
A

D
C

IM
 T

ec
hn

ol
og

ie
s,

 U
S

A
. F

or
 o

nl
in

e 
tr

ai
ni

ng
, c

on
ta

ct
 s

al
es

@
ca

dc
im

.c
om

WRITING A SINGLE LINE TEXT

The TEXT command lets you write a single line text in the drawing. Although you can
write more than one lines of text using this command, but each line will be a separate
text entity. After invoking this command, you need to specify the start point for the text.

Then you need to specify the text height and also the rotation angle. The characters appear on
the screen, as you enter them. When you press ENTER, after typing a line, the cursor automatically
places itself at the start of the next line and repeats the prompt for entering another line. You
can end the command by pressing the ENTER key. You can use the BACKSPACE key to edit the
text on the screen while you are writing it. The prompt sequence is given next.

Command: TEXT �
Current text style: “current” Text height: current
Specify start point of text or [Justify/Style]: Specify the starting point of the text.
Specify height<current>: Enter the text height.
Specify rotation angle of text <0>: �
Enter text: Enter first line of text.
Enter text: Enter the second line of text.
Enter text: �

Note
The other commands to enter text are discussed in detail in Chapter 7.

To move the objects, use the MOVE command and then select the objects, specify the base point,
and the second point of displacement. The MOVE command is discussed in detail in Chapter 5.

Toolbar: Text > Single Line Text
Menu: Draw > Text > Single Line Text
Command: TEXT



Starting with the Advanced Sketching                                                                            3-43

©
 C

A
D

C
IM

 T
ec

hn
ol

og
ie

s,
 U

S
A

. F
or

 e
ng

in
ee

ri
ng

 s
er

vi
ce

s,
 c

on
ta

ct
 s

al
es

@
ca

dc
im

.c
om

Answer the following questions and then compare your answers to those given at the end of
this chapter.

1. A negative value for a chord length in the Start, Center, Length option of the ARC command
results in the largest possible arc, also known as the major arc. (T/F)

2. In the ARC command, if you do not specify a start point but just press ENTER or choose
the Continue option, the start point and direction of the arc is taken from the endpoint and
ending direction of the previous line or arc drawn on the current screen. (T/F)

3. If the PELLIPSE is set to 1, AutoCAD LT creates a true ellipse, also known as NURBS-based
(Non-Uniform Rational Bezier Spline) ellipse. (T/F)

4. The start and end parameters of an elliptical arc are determined by specifying a point on
the circle whose diameter is equal to the minor diameter of the ellipse. (T/F)

5. The ________ option of the RECTANG command allows you to draw a rectangle at a
specified distance from the XY plane along the Z axis.

6. If the FILLMODE is off, only the trace ________ is drawn.

7. You can get a ________ polyline by entering two different values at the starting width and
the ending width prompts.

8. In case of a(n) ___________ polyline, the vertices are not stored as separate entities, but as
a single object with an array of information.

9. If you invoke the POINT command from the ___________, you can draw as many points as
you desire in a single command.

10. The size of a point is taken as a percentage of the viewport size, if you enter a ___________
value for the PDSIZE variable.

Answer the following questions.

1. Using the Start, End, Angle option of the ARC command, a negative included angle value
draws the arc in a clockwise direction. (T/F)

2. When the Continue option of the ARC command is used to draw arcs, each successive arc
is perpendicular to the previous one. (T/F)

Self-Evaluation Test

Review Questions
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3. If you specify the chamfer distances first and then specify the fillet radius in the same
RECTANG command, the rectangle will be drawn with chamfers only. (T/F)

4. Using the RECTANG command, the rectangle drawn is treated as a combination of different
objects; therefore individual sides can be edited independently. (T/F)

5. Using the Start, Center, Length option of the ARC command, a positive chord length
generates the smallest possible arc (minor arc) with this length, and the arc is always less
than

(a) 90-degree (b) 180-degree
(c) 270-degree (d) 360-degree

6. Which one of the following options of the RECTANG command allows you to draw a
rectangle that is extruded in the Z direction by the specified value?

(a) Elevation (b) Thickness
(c) Extrude (d) Width

7. Which of the following commands draws a line anywhere in 3D space, which starts from a
point that you specify and with the other end extending to infinity?

(a) PLINE (b) RAY
(c) XLINE (d) MLINE

8. If the old 2D polylines should not get converted to lightweight polylines, when opening the
drawings in AutoCAD LT 2004, and also the new polylines drawn should be 2D polylines,
the PLINETYPE variable should be set to which of the following values?

(a) 0 (b) 1
(c) 2 (d) 3

9. Which of the following values should be assigned to the PDMODE variable such that a cross
mark (X) is generated through the specified point?

(a) 1 (b) 3
(c) 5 (d) 7

10. A polygon is said to be __________ , when it is drawn inside an imaginary circle and its
vertices (corners) touch the circle.

11. If additional polyline segments are added to the first polyline, AutoCAD LT automatically
makes the __________ of the first polyline segment the start point of the next polyline
segment.
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Exercises

Exercise 14 Mechanical

12. The drawing of each segment of a trace is __________, until you specify the next segment or
you end the trace by pressing ENTER.

13. With the DONUT command, a solid-filled circle is drawn by specifying the inside diameter
as __________ and FILLMODE is on.

14. The visibility of blips can be controlled using the __________ system variable.

15. An absolute size for the point can be specified by entering a __________ value for PDSIZE
variable.

16. The __________ option of the XLINE command creates xlines of infinite length that are
parallel to the Y axis of the current UCS.

17. You can use the __________ key to edit the text on the screen, while you are writing it using
the TEXT command.

Draw the sketch shown in Figure 3-62. The distance between the dotted lines is 1.0 unit. Create
the radii, using appropriate ARC command options.

Figure 3-62  Drawing for Exercise 14
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Exercise 15 Graphics

Figure 3-63  Drawing for Exercise 15

Exercise 16 Mechanical

Figure 3-64  Drawing for Exercise 16

Draw the sketch shown in Figure 3-63. The distance between the dotted lines is 1.0 unit. Create
the arcs, using appropriate ARC command options.

Draw the sketch shown in Figure 3-64. The distance between the dotted lines is 0.5 unit. Create
the ellipses, using the ELLIPSE command.
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Exercise 18 Mechanical

Figure 3-66  Drawing for Exercise 18

Figure 3-65  Drawing for Exercise 17

Exercise 17 Mechanical

Draw Figure 3-65 using the LINE, CIRCLE, and ARC  commands. The distance between the
dotted lines is 1.0 unit and the diameter of the circles is 1.0 units.

Draw Figure 3-66 using the LINE, CIRCLE, and ARC commands or their options. The distance
between the grid lines is 1.0 unit and the diameter of the circle is 1.0 unit.
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Problem Solving Exercise 1 Mechanical

Figure 3-67  Drawing for Problem Solving Exercise 1

Problem Solving Exercise 2 Mechanical

Figure 3-68  Drawing for Problem Solving Exercise 2

Draw the sketch shown in Figure 3-67. Create the radii by using the arc command options
indicated in the drawing. (Use the @ symbol to snap to the previous point. Example: Specify
start point of arc or [Center]: @)

Draw the sketch shown in Figure 3-68. Create the radii by using the arc command options. The
distance between the dotted lines is 0.5 units.



Starting with the Advanced Sketching                                                                            3-49

©
 C

A
D

C
IM

 T
ec

hn
ol

og
ie

s,
 U

S
A

. F
or

 e
ng

in
ee

ri
ng

 s
er

vi
ce

s,
 c

on
ta

ct
 s

al
es

@
ca

dc
im

.c
om

Problem Solving Exercise 4 Mechanical

Figure 3-70  Drawing for Problem Solving Exercise 4

Problem Solving Exercise 3 Mechanical

Figure 3-69  Drawing for Problem Solving Exercise 3

Draw the sketch shown in Figure 3-69. Create the radii by using the ARC command options.
The distance between the dotted lines is 1.0 unit.

Draw the sketch shown in Figure 3-70 using the POLYGON, CIRCLE, and LINE commands.
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Problem Solving Exercise 5 Mechanical

Figure 3-71  Drawing for Problem Solving Exercise 5

Draw the sketch shown in Figure 3-71 using the draw commands. Note, Sin30=0.5, Sin60=0.866.
The distance between the dotted lines is 1 unit.

Answers to Self-Evaluation Test
1 - T, 2 - T, 3 - F, 4 - F, 5 - Elevation, 6 - outline, 7 - tapered, 8 - optimized, 9 - toolbar,
10 -negative


