
Chapter 19

Working with Data
Exchange and Object

Linking and Embedding

After completing this chapter, you will be able to:
• Import and export .dxf files using the SAVEAS and OPEN commands.
• Convert scanned drawings into the drawing editor using the DXB file format.
• Attach raster images to the current drawing.
• Manage raster images.
• Edit raster images.
• Understand the embedding and linking functions of the OLE feature of Windows.

Learning Objectives
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UNDERSTANDING THE CONCEPT OF DATA EXCHANGE
IN AutoCAD LT
Different companies have developed different software for applications such as CAD, desktop
publishing, and rendering. This non-standardization of software has led to the development of
various data exchange formats that enable transfer (translation) of data from one data processing
software to another. This chapter will cover various data exchange formats provided in AutoCAD LT.
AutoCAD LT uses the .dwg format to store drawing files. This format is not recognized by most
other CAD software such as Intergraph, CADKEY, and MicroStation. To eliminate this problem
so that files created in AutoCAD LT can be transferred to other CAD software for further use,
AutoCAD LT provides you with the data exchange formats such as DXF (data interchange file).

CREATING DATA INTERCHANGE (DXF) FILES
The DXF file format generates a text file in ASCII code from the original drawing. This
allows any computer system to manipulate (read/write) data in a DXF file. Usually, DXF
format is used for CAD packages based on microcomputers. For example, packages like
SmartCAM use DXF files. Some desktop publishing packages, such as PageMaker and Ventura
Publisher, also use DXF files.

Creating a Data Interchange File
The SAVE, SAVEAS or -WBLOCK commands are used to create an ASCII file with a .dxf
extension from an AutoCAD LT drawing file. Once you invoke any of these commands, the
Save Drawing As dialog box is displayed. You can enter the name of the file in the File name
edit box and select AutoCAD LT 2004 DXF [*.dxf] from the File of type drop-down list
(Figure 19-1). By default, the DXF file to be created assumes the name of the drawing file
from which it will be created. However, you can specify a file name of your choice for the DXF
file by typing it in the File name edit box.

Choose the Tools button to display the flyout. From the flyout, choose Options to display the
Saveas Options dialog box. In this dialog box, choose the DXF Options tab and enter the
degree of accuracy for the numeric values, see Figure 19-2. The default value for the degree
of accuracy is sixteen decimal places. You can enter a value between 0 and 16 decimal places.

In this dialog box, you can also select the Select objects check box, which allows you to
specify objects you want to include in the DXF file. In this case, the definitions of named
objects such as block definitions, text styles, and so on, are not exported. Selecting the Save
thumbnail preview image check box saves a preview image with the file that can be previewed
in the Preview window of the Select File dialog box.

Select the ASCII radio button. Choose OK to return to the Save Drawing As dialog box.
Choose the Save button here. Now an ASCII file with a .dxf extension has been created, which
can be accessed by other CAD systems. This file contains data on the objects specified. By
default, DXF files are created in ASCII format. However, you can also create binary format files
by selecting the BINARY radio button in the Saveas Options dialog box. Binary DXF files are
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more efficient and occupy only 75 percent of the ASCII DXF file. You can access a file in binary
format more quickly than the same file in ASCII format.

Information in a DXF File
The DXF file contains data on the objects specified using the Select objects option in the Save
Drawing As dialog box. You can change the data in this file to your requirement. To examine the
data in this file, load the ASCII file in the word processing software. A DXF file is composed of
the following parts.

Figure 19-1 The Save Drawing As dialog box

Figure 19-2 The Saveas Options dialog box
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Header
In this part of the drawing database, all the variables in the drawing and their values are dis-
played.

Classes
This section deals with the internal database.

Tables
All the named objects such as linetypes, layers, blocks, text styles, dimension styles, and views
are listed in this part.

Blocks
The objects that define blocks and their respective values are displayed in this part.

Entities
All the entities in the drawing, such as lines, circles, and so on, are listed in this part.

Objects
Objects in the drawing are listed in this part.

Converting DXF Files into Drawing Files
You can import a DXF file into a new AutoCAD LT drawing file with the OPEN command.
After you invoke the OPEN command, the Select File dialog box (Figure 19-3) is displayed.
From the Files of type drop-down list, select DXF [*.dxf]. In the File name edit box, enter
the name of the file you want to import into AutoCAD LT or select the file from the list.
Choose the Open button. Once this is done, the specified DXF file is converted into a standard
DWG file, regeneration is carried out, and the file is inserted into the new drawing. Now you
can perform different operations on this file just as with the other drawing files.

Tip
A data interchange file (DXF) can also be inserted in the current drawing using the INSERT
command.

OTHER DATA EXCHANGE FORMATS
The other formats that can be used to exchange the data from one data processing format to the
other are discussed next.

Creating and Using a Windows Metafile

The Windows Metafile format (WMF) file contains screen vector and raster graphics format. In
the Export Data dialog box or the Create WMF File dialog box, enter the file name. Select the

Menu: File > Export
Command: EXPORT, WMFOUT
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objects you want to save in this file format. Select Metafile [*.wmf] from the Files of type
drop-down list in the Export Data dialog box. The extension .wmf is appended to the file name.

The WMFIN command displays the Import WMF dialog box. Window metafiles are imported
as blocks in AutoCAD LT. Select the .wmf file you want to import and choose the Open button.
Specify an insertion point, rotation angle, and scale factor. Specify scaling by entering a scale
factor, using the corner option to specify an imaginary box whose dimensions correspond to
the scale factor or entering xyz to specify 3D scale factors. You can also invoke the WMFIN
command by choosing Windows Metafile from the Insert menu.

Creating a BMP File

This is used to create bitmap images of the objects in your drawing. In the Create Raster File
dialog box, enter the name of the file and then select the objects you wish to save as bitmap and
press ENTER. Entering BMPOUT displays the Create Raster File dialog box. Enter the file
name and choose Save. Select the objects to be saved as bitmap. The file extension .bmp is
appended to the file name.

Figure 19-3 The Select File dialog box

Command: BMPOUT
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Toolbar: Reference > Image
Command: IMAGE

RASTER IMAGES
A raster image consists of small square-shaped dots known as pixels. In a colored image, the
color is determined by the color of pixels. The raster images can be moved, copied, or clipped,
and used as a cutting edge with the TRIM command. They can also be modified by using grips.
You can also control the image contrast, transparency, and quality of the image. AutoCAD LT
stores images in a special temporary image swap file whose default location is the Windows
Temp directory. You can change the location of this file by modifying it under Temporary
Drawing File Location in the Files tab of the Options dialog box.

The images can be 8-bit gray, 8-bit color, 24-bit color, or bitonal. When image transparency is
set to On, the image file formats with transparent pixels is recognized by AutoCAD LT and
transparency is allowed. The transparent images can be in color or grayscale. AutoCAD LT
supports the following file formats.

Image Type File Extension Description

BMP .bmp, .dib, .rle Windows and OS/2 Bitmap Format
CALS-I .gp4, .mil, .rst Mil-R-Raster I
FLIC .flc, .fli Flic Autodesk Animator Animation
GEOSPOT .bil GeoSPOT (BIL files must be accompanied

with HDR and PAL files with connection
data in the same directory.)

IG4 .ig4 Image Systems group 4
IGS .igs Image Systems Grayscale
JFIF or JPEG .jpg, jpeg Joint Photographics Expert group
PCX .pcx Picture PC Paintbrush Picture
PICT .pct Picture Macintosh Picture
PNG .png Portable Network Graphic
RLC .rlc Run-length Compressed
TARGA .tga True Vision Raster based Data format
TIFF/LZW .tif Tagged image file format

When you store images as Tiled Images, that is, in the Tagged Image File Format (TIFF), you
can edit or modify any portion of the image; only the modified portion is regenerated thus
saving time. Tiled images load much faster as compared to nontiled images.

Managing Raster Images (Image Manager Dialog Box)))))

Sometimes, you may need to open some AutoCAD drawings that have some images
inserted in them. AutoCAD LT allows you to manage those images using the Image
Manager dialog box (Figure 19-4). You can invoke the Image Manager dialog box using
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Choosing Image > Image Manager from the shortcut menu also displays this dialog box.

You can view image information either as a list or as a tree view by choosing the respective
buttons located at the upper left corner of the Image Manager dialog box. The List View (F3)
displays the names of all the images in the drawing, its loading status, size, date last modified
on, and its search path. The Tree View (F4) displays the images in a hierarchy which shows its
nesting levels within blocks and Xrefs. The tree view does not display the status, size, or any
other information about the image file. You can rename an image file in this dialog box. The
various options in the Image Manager dialog box are as follows.

Reload
Reload simply reloads an image. The changes made to the image since the last insert will be
loaded on the screen. You can change the status of the image file in the Image Manager dialog
box by double-clicking on the current status. It changes from Unload to Reload and vice versa.

Unload
The Unload option unloads an image. An image is unloaded when it is not needed in the
current drawing session. When you unload an image, AutoCAD LT retains information about
the location and size of the image in the database of the current file. Unloading a file does not
unlink the file from the drawing and the image frame is displayed. If you reload the image, the
image will appear at the same point and in the same size as it was before unloading. Unloading
the raster images enhances AutoCAD LT performance. Also, the unloaded images are not plotted.
If multiple images are to be loaded and the memory is insufficient, AutoCAD LT automatically
unloads them.

Figure 19-4 The Image Manager dialog box
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Details
Details displays the Image File Details box as shown in Figure 19-5. This dialog box lists
information about the image such as file name, saved path, file creation date, file size, file type,
color and color path, pixel width and height, resolution, and default size. It also displays the
image in the preview box.

Image found at Area
The edit box in this area displays the path of the selected image. You can edit this path and
choose the Save Path button to save the new path. If you have changed the path of an image,
choose the Browse button to display the Select Image File dialog box. In this dialog box, locate
the image file and then choose the Open button. The new path is displayed in this edit box.
Choose the Save Path button to save this new path. This path is also displayed in the Saved Path
column of the dialog box.

Browse
This option displays the Select Image File dialog box to select the image file.

Save Path
This option saves the current path of the image.

Tip
You can also use the Command line for managing the image files using the -IMAGE command.
All the options of the Image Manager dialog box will be available in the Command line.

EDITING RASTER IMAGE FILES
Controlling the Display of Image Frames

Toolbar: Reference > Image Frame
Menu: Modify > Object > Image Frame
Command: IMAGEFRAME

Figure 19-5 The Image File Details dialog box
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image boundary is off, the image cannot be selected with the pointing device, and
therefore, cannot be accidentally moved or modified.

Changing the Display Order

The DRAWORDER command is used to change the display order of images and other
objects. When you invoke this command, you will be prompted to select the object. The
prompt sequence that will follow when you select the object is as follows.

Enter object ordering option [Above object/Under object/Front/Back] <Back>:

If you specify Above object, the selected object will be moved above the referenced object. If you
select the Under object, the selected object will be moved under the referenced object. If you
select Front, the selected object will be moved to the top of the draworder. If you select Back, the
selected object will be moved to the bottom of the draworder. Figure 19-6 shows two raster
images, one is a building and the other one is a tower. In this figure, the building is behind the
tower. You can use the DRAWORDER command to bring the building in front, as shown in
Figure 19-7.

Other Editing Operations
You can also perform other editing operations such as copy, move, and stretch to edit the raster
image. Remember that you can also use the image as the trimming edge for trimming objects.
However, you cannot trim an image. You can insert the raster image several times or make
multiple copies of it. Each copy can have a different clipping boundary. You can also edit the
image using grips. You can use the PROPERTIES palette to change the image layer, boundary
linetype, lineweight, linetype scale, and color.

Toolbar: Modify II > Draworder
Menu: Tools > Display Order
Command: DRAWORDER

Figure 19-7  Building in front of the towerFigure 19-6  Building behind the tower
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Command: PSOUT

Scaling Raster Images
The scale of the inserted image is determined by the actual size of the image and the unit of
measurement (inches, feet, and so on). For example, if the image is 1" X 1.26" and you insert this
image with a scale factor of 1, the size of the image on the screen will be 1 AutoCAD LT unit by
1.26 AutoCAD LT units. If the scale factor is 5, the image will be five times larger. The image that
you want to insert must contain the resolution information (DPI). If the image does not contain
this information, AutoCAD LT treats the width of the image as one unit.

POSTSCRIPT FILES
PostScript is a page description language developed by Adobe Systems. It is used mostly in DTP
(desktop publishing) applications. AutoCAD LT allows you to work with PostScript files. You can
create and export PostScript files from AutoCAD LT so that these files can be used for DTP
applications. PostScript images have a higher resolution than raster images. The extension for
these files is .eps (Encapsulated PostScript).

Creating the PostScript Files

As just mentioned, any AutoCAD LT drawing file can be converted into a PostScript file. This
can be accomplished with the PSOUT command. When you invoke this command, the Create
PostScript File dialog box is displayed, as shown in Figure 19-8.

Figure 19-8 The Create PostScript File dialog box
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choose the Save button to accept the default setting and create the PostScript file. You can also
choose the Tools > Options in this dialog box to change the settings through the PostScript
Out Options dialog box, see Figure 19-9. The PostScript Out Options dialog box provides
the following options.

Prolog Section Name
In this edit box, you can assign a name for a prolog section to be read from the aclt.psf file.

What to plot Area
The What to plot area of the dialog box has the following options.

Display. If you specify this option when you are in model space, the display in the current
viewport is saved in the specified EPS file. Similarly, if you are in layouts, the current view is
saved in the specified EPS file.

Extents. If you use this option, the PostScript file created will contain the section of the
AutoCAD LT drawing that currently holds objects. In this way, this option is similar to the
ZOOM Extents option. If you add objects to the drawing, they are also included in the PostScript
file to be created because the extents of the drawing are also altered. If you reduce the drawing
extents by erasing, moving, or scaling objects, then you must use the ZOOM Extents or ZOOM
All option. Only then does the Extents option of the PSOUT command understand the extents
of the drawing to be exported. If you are in model space, the PostScript file is created in relation
to the model space extents; if you are in paper space, the PostScript file is created in relation to
the paper space extents.

Figure 19-9 The PostScript Out Options dialog box
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Limits. With this option, you can export the whole area specified by the drawing limits. If the
current view is not the plan view [viewpoint (0,0,1)], the Limits option exports the area just as
the Extents option would.

View. Any view created with the VIEW command can be exported with this option. This option
will be available only when you have created a view using the VIEW command. Choose the View
button to display the View Name dialog box from where you can select the view.

Window. In this option, you need to specify the area to be exported with the help of a window.
When this radio button is selected, the Window button is also available. Choose the Window
button to display the Window Selection dialog box where you can select the Pick button and
then specify the two corners of the window on the screen. You can also enter the coordinates of
the two corners in the Window Selection dialog box.

Preview Area
The Preview area of the dialog box has two types of formats for preview images: EPSI and TIFF.
If you want a preview image with no format, select the None radio button. If you select TIFF or
EPSI, you are required to enter the pixel resolution of the screen preview in the Pixels area. You
can select a preview image size of 128 X 128, 256 X 256, or 512 X 512.

Size Units Area
In this area, you can set the paper size units to Inches or Millimeters by selecting their
corresponding radio buttons.

Scale Area
In this area, you can set an explicit scale by specifying how many drawing units are to be output
per unit. You can select the Fit to paper check box so that the view to be exported is made as
large as possible for the specified paper size.

Paper Size Area
You can select a size from the list or enter a new size in the Width and Height edit boxes to
specify a paper size for the exported PostScript image.

OBJECT LINKING AND EMBEDDING (OLE)
With Windows, it is possible to work with different Windows-based applications by transferring
information between them. You can edit and modify the information in the original Windows
application, and then update this information in other applications. This is made possible by
creating links between different applications and then updating those links, which in turn
updates or modifies the information in the corresponding applications. This linking is a function
of the OLE feature of Microsoft Windows. The OLE feature can also join together separate
pieces of information from different applications into a single document. AutoCAD LT and
other Windows-based applications such as Microsoft Word, Notepad, and Windows WordPad
support the Windows OLE feature.
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form of a drawing or a document. This document is created in an application called a server
application. AutoCAD LT for Windows and Paintbrush can be used as server applications. Now
this source document is to be linked to (or embedded in) the compound (destination) document,
which is created in a different application, known as the container application. AutoCAD LT
for Windows, Microsoft Word, and Windows WordPad can be used as container applications.

Clipboard
The transfer of a drawing from one Windows application to another is performed by copying
the drawing or the document from the server application to the Clipboard. The drawing or
document is then pasted in the container application from the Clipboard. Hence, a Clipboard
is used as a medium for storing the documents while transferring them from one Windows
application to another. The drawing or the document on the Clipboard stays there until you
copy a new drawing, which overwrites the previous one, or until you exit Windows. You can
save the information present on the Clipboard with the .clp extension.

Object Embedding
You can use the embedding function of the OLE feature when you want to ensure that there is no
effect on the source document even if the destination document has been changed through the
server application. Once a document is embedded, it has no connection with the source. Although
editing is always done in the server application, the source document remains unchanged.
Embedding can be accomplished by means of the following steps. In this example, AutoCAD
LT for Windows is the server application and MS Word is the container application.

1. Create a drawing in the server application (AutoCAD LT).

2. Open MS Word (container application) by double-clicking on its shortcut icon at the desktop
of the computer.

3. It is preferable to arrange both the container and the server windows so that both are
visible as shown in Figure 19-10.

4. In the AutoCAD LT graphics screen, choose the Copy to Clipboard (CTRL+C) button
from the Standard toolbar to invoke the COPYCLIP command. This command can be
used in AutoCAD LT for embedding the drawings. This command can also be invoked from
the Edit menu (Choose Copy), or by entering COPYCLIP at the command line. The next
prompt, Select objects, allows you to select the entities you want to transfer. You can either
select the full drawing by entering ALL or select some of the entities by selecting them. You
can use any of the object selection methods for selecting the objects. With this command the
selected objects are automatically copied to the Windows Clipboard.
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5. After the objects are copied to the Clipboard, make the MS Word window active. To get the
drawing from the Clipboard to the MS Word application (client), select the Paste in the
Word application. Choose Paste from the Edit menu in MS Word (Figure 19-11). You can
also use Paste Special from the Edit menu, which will display the Paste Special dialog box
(Figure 19-12). In this dialog box, select the Paste radio button (default) for embedding,
and then choose OK. The drawing is now embedded in the MS Word window.

6. Your drawing is now displayed in the MS Word window, but it may not be displayed at the
proper position. You can get the drawing in the current viewport by moving the scroll bar up
or down in the MS Word window. You can also save your embedded drawing by choosing the
Save button. It displays a Save As dialog box where you can enter a file name. You can now
exit AutoCAD LT.

7. You can now edit your embedded drawing. Editing is performed in the server application,
which in this case is AutoCAD LT for Windows. You can get the embedded drawing into the
server application (AutoCAD LT) directly from the container application (MS Word) by
double-clicking on the drawing in MS Word. The other method is by choosing
Edit > Drawing Object in the Edit menu after selecting the drawing. (This menu item
has replaced Object, which was present before pasting the drawing.)

Figure 19-10  AutoCAD LT graphics screen with the MS Word window
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8. Now you are in AutoCAD LT, with your embedded drawing displayed on the screen, but as
a temporary file with a file name such as [Drawing in Document1]. Here you can edit the
drawing by changing the color and linetype or by adding and deleting text, entities, and so
on. In Figure 19-13, the cup and plate have been hatched and the drawing is moved to the
center of the drawing window.

Figure 19-11  Pasting a drawing to the MS Word application

Figure 19-12 The Paste Special dialog box



19-16                                                                                            AutoCAD LT 2006 for Designers
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

e
ch

n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
. F. F. 
F

. F . 
F o

r 
o

nl
in

e
 t

ra
in

in
g

, c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

o
r 

o
nl

in
e

 t
ra

in
in

g
, c

o
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
o

r 
o

nl
in

e
 t

ra
in

in
g

, c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

o
r 

o
nl

in
e

 t
ra

in
in

g
, c

o
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
o

r 
o

nl
in

e
 t

ra
in

in
g

, c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

9. After you have finished modifying your drawing, choose Update Microsoft Word from the
File menu in the server (AutoCAD LT). This menu item has replaced the previous Save
menu item. When you choose Update Microsoft Word, AutoCAD LT automatically updates
the drawing in MS Word (container application). Now, you can exit this temporary file in
AutoCAD LT.

Note
Do not zoom or pan the drawing in the temporary file. If you do so, this will be included in the
updating and the new file will display only that portion of the drawing that lies inside the
original area.

10. This completes the embedding function, so you can exit the container application. While
exiting, a dialog box that asks whether or not to save changes in MS Word is displayed.

Linking Objects
The linking function of OLE is similar to the embedding function. The only difference is that
here a link is created between the source document and the destination document. If you edit
the source, you can simply update the link, which automatically updates the client. This allows
you to place the same document in a number of applications, and if you make a change in the

Figure 19-13  Updating the drawing in AutoCAD LT
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msource document, the clients will also change by simply updating the corresponding links.

Consider AutoCAD LT for Windows to be the server application and MS Word to be the container
application. Linking can be performed by means of the following.

1. Open a drawing in the server application (AutoCAD LT). If you have created a new drawing,
then you must save the drawing before you can link it with the container application.

2. Open MS Word (container application) by double-clicking on its shortcut icon at the desktop
of the computer.

3. It is preferable to arrange both the container and the server windows so that both are visible.

4. In the AutoCAD LT graphics screen, choose Copy Link from the Edit menu to invoke the
COPYLINK command. This command can be used in AutoCAD LT for linking the drawing.
This command copies all the objects that are displayed in the current viewport directly to
the Clipboard. Here, you cannot select the objects for linking. If you want only a portion of
the drawing to be linked, you can zoom into that view so that it is displayed in the current
viewport prior to invoking the COPYLINK command. This command also creates a new
view of the drawing having a name OLE1.

5. Make the MS Word window active. To get the drawing from the Clipboard to the Write
(container) application, choose Paste Special from the Edit menu. This will display the
Paste Special dialog box. In this dialog box, select the Paste Link radio button for linking.
Choose OK. Note that the Paste link radio button in the Paste Special dialog box will not
be available if you have not saved the drawing.

6. The drawing is now displayed in the MS Word window and is linked to the original drawing.
You can also save your linked drawing by choosing Save from the File menu. It displays a
Save As dialog box where you can enter a file name.

7. You can now edit your original drawing. Editing can be performed in the server application,
which in this case is AutoCAD LT for Windows. You can edit the drawing by changing the
color and linetype or by adding and deleting text, entities, and so on. Then save your
drawing in AutoCAD LT by using the QSAVE command. You can now exit AutoCAD LT.

8. You will notice that the drawing is automatically updated, and the changes made in the
source drawing are present in the destination drawing also. This automatic updating is
dependent on the selection of the Automatic radio button (default) in the Links dialog box
(Figure 19-14). The Links dialog box can be invoked by choosing Links from the Edit
menu. For updating manually, you can select the Manual radio button in the dialog box. In
the manual case, after making changes in the source document and saving it, you need to
invoke the Links dialog box and then choose the Update Now button. This will update the
drawing in the container application and display the updated drawing in the MS Word
document.

9. Exit the container application after saving the updated file.
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Linking Information into AutoCAD LT
Similarly, you can also embed and link information from a server application into an AutoCAD LT
drawing. You can also drag selected OLE objects from another application into AutoCAD LT,
provided this application supports Microsoft Activex and the application is running and visible
on the screen. Dragging and dropping is like cutting and pasting. If you press the CTRL key
while you drag the object, it is copied to AutoCAD LT. Dragging and dropping an OLE object
into AutoCAD LT embeds it into AutoCAD LT.

Linking Objects into AutoCAD LT
Start any server application such as the MS Word and open a document in it. Select the information
you wish to use in AutoCAD LT with your pointing device and choose the Copy button to copy
this data to the Clipboard. Open the AutoCAD LT drawing you wish to link this data to. Choose
Paste Special from the Edit menu or use the PASTESPEC command. The Paste Special dialog
box is displayed (Figure 19-15). In the As list box, select the data format you wish to use. For

Figure 19-14 The Links dialog box

Figure 19-15 The Paste Special dialog box
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mexample, for a MS Word document, select Microsoft Word Document. Picture format uses a

Metafile format. Select the Paste Link radio button to paste the contents of the Clipboard to the
current drawing. If you select the Paste radio button, the data is embedded and not linked.
Choose OK to exit the dialog box. The data is displayed in the drawing and can be positioned
as needed.

You can also use the INSERTOBJ command by entering INSERTOBJ at the Command prompt,
by choosing OLE Object from the Insert menu, or by choosing the OLE Object button in the
Insert toolbar. This command links an entire file to a drawing from within AutoCAD LT. Using
this command displays the Insert Object dialog box, as shown in Figure 19-16.

Select the Create from File radio button. Also select the Link check box. Choosing the Browse
button, displays the Browse dialog box. Select a file you want to link from the list box or enter
a name in the File name edit box and choose the Open button. The path of the file is displayed
in the File edit box of the Insert Object dialog box. If you select the Display As Icon check
box, an icon is also displayed in the dialog box. Choose OK to exit the dialog box; the selected
file is linked to the AutoCAD LT drawing.

AutoCAD LT updates the links automatically by default, whenever the server document changes,
but you can use the OLELINKS command to display the Links dialog box (Figure 19-17) where
you can change these settings. This dialog box can also be displayed by choosing OLE Links
from the Edit menu. In the Links dialog box, select the link you want to update and then
choose the Update Now button. Then choose the Close button. If the server file location changes
or if it is renamed, you can choose the Change Source button in the Links dialog box to display
the Change Source dialog box. In this dialog box, locate the server file name and location and
choose the Open button. You can also choose the Break Link button in the Links dialog box to
disconnect the inserted information from the server application. This is done when the linking
between the two is no longer required.

Figure 19-16 The Insert Object dialog box
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Embedding Objects into AutoCAD LT
Open the server application and select the data you want to embed into the AutoCAD LT
drawing. Copy this data to the Clipboard by choosing the Copy button in the toolbar or choosing
Copy from the Edit menu. Open the AutoCAD LT drawing and choose Paste from the
AutoCAD LT Edit menu. You can use the PASTECLIP command also. The selected information
is embedded into the AutoCAD LT drawing.

You can also create and embed an object into an AutoCAD LT drawing starting from AutoCAD LT
itself using the INSERTOBJ command. You can choose OLE Object from the Insert menu or
choose the OLE Object button from the Insert toolbar, and the Insert Object dialog box is
displayed as shown in Figure 19-18.

Figure 19-17 The Links dialog box

Figure 19-18 The Insert Object dialog box
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mIn this dialog box, select the Create New radio button and select the application you wish to use

from the Object Type list box. Choose OK. The selected application opens. Now, you can create
the information you wish to insert in the AutoCAD LT drawing and save it before closing the
application. The OLE Properties dialog box is displayed (Figure 19-19) where you can resize
and rescale the inserted objects. This dialog box is displayed by default. If you do not want to
display this dialog box, clear the Display dialog when pasting new OLE objects check box in
the OLE Properties dialog box. You can also clear the Display OLE properties dialog check
box in the System tab of the Options dialog box. You can edit information embedded in the
AutoCAD LT drawing by opening the server application by double-clicking on the inserted
OLE object. You can also select the object and right-click to display a shortcut menu. Choose
Object > Edit. After editing the data in the server application, choose Update from the File
menu to reflect the modifications in the AutoCAD LT drawing.

Working with OLE Objects
Select an OLE object and right-click to display a shortcut menu; choose Properties. The OLE
Properties dialog box is displayed. You can also select the OLE object and use the OLESCALE
command. Specify a new height and a new width in the Height and Width edit boxes in the Size
area or under Scale. Enter a value in percentage of the current values in the Height and Width
edit boxes. Here, if you select the Lock Aspect Ratio check box, whenever you change either the
height or the width under Scale or Size, the respective width or height changes automatically to
maintain the aspect ratio. If you want to change only the height or only the width, clear this
check box. Choose OK to apply the changes.

Choosing the Reset button restores the selected OLE objects to their original size, that is, the
size they were when inserted. If the AutoCAD LT drawing contains an OLE object with text with
different fonts and you wish to select and modify specific text, you can select a particular font

Figure 19-19 The OLE Properties dialog box
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and point size from the drop-down lists under the Text size area and enter the value in drawing
units in the box after the equal (=) sign. For example, if you wish to select text in the Times
Roman font, of point size 10 and modify it to size 0.5 drawing units, select Times Roman and 10
point size from the drop-down lists and in the text box after the equal (=) sign enter .5. The text
that was in Times Roman and was of point size 10 will change to 0.5 drawing units in height.

The pointing device can also be used to modify and scale an OLE object in the AutoCAD LT
drawing.  Selecting the object displays the object frame and the move cursor. The move cursor
allows you to select and drag the object to a new location. The middle handles allows you to
select the frame and stretch it. It does not scale objects proportionately. The corner handles
scale the objects proportionately.

Select an OLE object and right-click to display the shortcut menu. Choosing Cut removes the
object from the drawing and pastes it on the Clipboard, Copy places a copy of the selected
object on the clipboard and Clear removes the object from the drawing and does not place it on
the clipboard. Choosing Object displays the Convert, Open, and Edit options. Choosing Convert
displays the Convert dialog box where you can convert objects from one type to another and
Edit opens the object in the Server application where you can edit it and update it in the current
drawing. Undo cancels the last action. Bring to Front and Send to Back options place the OLE
objects in the front of or back of the AutoCAD LT objects. The Selectable option turns the
selection of the OLE object on or off. If the Selectable option is on, the object frame is visible
and the object is selected.

If you want to change the layer of an OLE object, select the object and right-click to display the
shortcut menu; choose Cut. The selected object is placed on the clipboard. Change the current
layer to the one you want to change the OLE object’s layer to using the Layer Properties
Manager dialog box. Now, choose Paste from the Edit menu to paste the contents of the clipboard
in the AutoCAD LT drawing. The OLE object is pasted in the new layer, in its original size.

The OLEHIDE system variable controls the display of OLE objects in AutoCAD LT. The default
value is 0, that is, all the OLE objects are visible. The different values and their effects are as
follows.

0 All OLE objects are visible
1 OLE objects are visible in paper space only
2 OLE objects are visible in model space only
3 No OLE objects are visible

The OLEHIDE system variable affects both screen display and printing.
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Answer the following questions and then compare your answers to those given at the end of
this chapter.

1. The DXF file format generates a text file in ASCII code. (T/F)

2. You can directly open a DXF file in AutoCAD LT using the OPEN command. (T/F)

3. An image attached to AutoCAD LT cannot be detached. (T/F)

4. The file in the container application is automatically modified only when a link is maintained
between the server application and the container application. (T/F)

5. The __________ command is used in AutoCAD LT to embed the drawing.

6. The __________  system variable controls the display of OLE objects in AutoCAD LT.

7. You can modify the text size and font of the linked object using the __________ dialog box.

8. The __________ is used as a medium for storing the documents while transferring them
from one Windows application to another.

9. You can get an embedded drawing into the server application directly from the container
application by __________ on the drawing.

10. The COPYLINK command copies a drawing in the __________ to the Clipboard.

Answer the following questions.

1. The Image Manager dialog box can also be used to attach the image in AutoCAD LT
drawing. (T/F)

2. An AutoCAD LT drawing can be saved in the DXF format using the Save Drawing As
dialog box. (T/F)

3. You can export an AutoCAD LT drawing into 3D Studio MAX. (T/F)

4. You can modify the brightness of the raster images using the Image Manager dialog box.
(T/F)

Review Questions

Self-Evaluation Test
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5. Which command can be used to open a DXF format file?

(a) OPEN (b) NEW
(c) START (d) None

6. Which command is used to unload an attached image file?

(a) IMAGE (b) IMAGEATTACH
(c) IMAGECLIP (d) IMAGEADJUST

7. Which dialog box can be used to specify whether the DXF file will be in ACSII format or the
BINARY format?

(a) Options (b) Save As
(c) Saveas Options (d) None

8. Which command is used to modify the order of display of the images?

(a) DRAWORDER (b) IMAGEATTACH
(c) IMAGECLIP (d) IMAGEADJUST

9. Which command is used to control the display of the frames of the images?

(a) DRAWORDER (b) IMAGEATTACH
(c) IMAGEFRAME (d) IMAGEADJUST

10. The __________ command is used to create an ASCII format file with the .dxf extension
from AutoCAD LT drawing files.

11. Binary DXF files are __________ efficient and occupy only 75 percent of the ASCII DXF
file.

12. File access for files in binary format is __________ than for the same file in ASCII format.

13. In a __________ file, information is stored in the form of a dot pattern on the screen. This
bit pattern is also known as __________ .

14. The __________ dialog box can be used to modify the method of updating the linked file
from automatic to manual.

15. You can choose __________ from the Create PostScript File dialog box to display the
PostScript Out Options dialog box.
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In this exercise, you will create a cup and a plate as shown in Figure 19-10. Below this cup and
plate, write the text in MS Word and then using OLE, paste it in the current drawing. The text
to be written is given below.

These objects are drawn in AutoCAD LT 2006.

Answers to Self-Evaluation Test
1 - T, 2 - T, 3 - F, 4 - T, 5 - COPYLINK, 6 - OLEHIDE, 7 - OLE Properties, 8 - Clipboard,
9 - double-clicking, 10 - current display

Exercises

Exercise 1 General
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