
Chapter 1

Exploring CINEMA 4D 
R19 Studio Interface

 Learning Objectives 
After completing this chapter, you will be able to:
• Work with Viewport Navigation Tools in CINEMA 4D
• Understand various terms related to CINEMA 4D interface
• Work with tools in CINEMA 4D
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Figure 1-1  Starting MAXON CINEMA 
4D R19 Studio from the Start menu

Figure 1-2  The default interface of CINEMA 4D R19 Studio
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               Figure 1-3  Various components of CINEMA 4D R19 Studio interface

Figure 1-4  The flyout displayed
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Figure 1-5  The rendering options 
displayed in the flyout

Figure 1-6  The tools to create the parametric objects displayed in 
the flyout
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Figure 1-7  The spline modeling tools displayed in the flyout

Figure 1-8  The generators displayed in the flyout

Figure 1-9  The special modeling tools displayed in the flyout

Figure 1-10  Various deforming tools displayed in the flyout
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Figure 1-11  Various tools displayed in the flyout

Figure 1-13   Various light tools 
displayed in the flyout

Figure 1-12  Various camera tools 
displayed in the flyout

Figure 1-14  Various options 
displayed in the flyout
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Figure 1-15  Flyout displayed on choosing 
the Locked Workplane tool

Figure 1-16   Flyout displayed on choosing 
the Planar Workplane tool

Figure 1-17  The Animation toolbar

 

 Figure 1-19  The Material Manager Figure 1-18  The  flyout displayed 
on choosing the Project button
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  Figure 1-21  The Object Manager  Figure 1-20  The Coordinate Manager

  Figure 1-22  The Attribute Manager  Figure 1-23  The Layers Manager 

Figure 1-24  The flyout displayed 
on choosing the View menu
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Figure 1-25  The flyout displayed on 
choosing the Cameras menu

Figure 1-26  The cascading menu displayed on choosing the 
Navigation option from the Cameras menu

Figure 1-27 The cascading menu displayed 
on choosing the Use Camera option
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Figure 1-28 The perspective camera 
projection mode

Figure 1-29  The parallel camera projection 
mode

  Figure 1-30  The left camera projection    Figure 1-31  The right camera projection

Figure 1-32  The front camera projection Figure 1-33  The back camera projection
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Figure 1-35  The bottom camera projectionFigure 1-34  The top camera projection

Figure 1-36  The cascading menu 
displayed on choosing the Axonometric 
option from the Cameras menu

 Figure 1-37  The isometric camera projection Figure 1-38  The dimetric camera projection
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Figure 1-39  The military camera projection

  Figure 1-41  The bird camera projectionFigure 1-40  The gentleman camera 
projection

Figure 1-42  The frog camera projection Figure 1-43  The flyout displayed on choosing 
the Display menu
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Figure 1-44  The object displayed in 
the viewport on choosing the Gouraud 
Shading option

Figure 1-45 The object displayed in the 
viewport on choosing the Gouraud Shading 
(Lines) option

Figure 1-46  The object displayed in the 
viewport on choosing the Quick Shading 
option

Figure 1-47  The object displayed in the 
viewport on choosing the Quick Shading 
(Lines) option

Figure 1-48  The object displayed in 
the viewport on choosing the Constant 
Shading option

Figure 1-49  The object displayed in 
the viewport on choosing the Constant 
Shading (Lines) option
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Figure 1-50  The object displayed in the 
viewport on choosing the Hidden Line 
option

Figure 1-51  The object displayed in 
the viewport on choosing the Lines 
option

Figure 1-52  The object displayed in 
the Wireframe and Quick Shading 
(Lines) shading modes
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Figure 1-54  The cascading menu displayed on 
placing the cursor on the Level of Detail option

Figure 1-53  The partial view of the flyout 
displayed on choosing the Options menu

Figure 1-55  The object displayed with the Backface Culling option on and off 

 Figure 1-56  The object displayed with the Isoline Editing option on and off 
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Figure 1-57  The color of the objects displayed same as 
the color of layers on choosing the Layer Color option

Figure 1-58  Displaying the normals 
of the selected polygons

Figure 1-59  The Default 
Light window
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Figure 1-61 The Layout 
drop-down list

Figure 1-60  The flyout displayed 
on choosing the Panel menu



Chapter 2

 Working with Splines

 Learning Objectives 
After completing this chapter, you will be able to:
• Work with spline primitives
• Understand spline modeling techniques
• Create geometries using Generators



2-2			                     MAXON CINEMA 4D R19 Studio: A Tutorial Approach

in)

Figure 2-1  The model of door lock system

Figure 2-2 Choosing the Front option from the 
Menu in editor view

Figure 2-3  Choosing the 
Configure option from 
the Menu in editor view
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Figure 2-4  Choosing the browse button next to the Image text box

Figure 2-5  Choosing 
Rectangle from the 
Create menu
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Figure 2-6  Setting the width and height of the rectangle

Figure 2-8  Extrude added to the Object 
Manager

Figure 2-7  Choosing Extrude from the flyout
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Figure 2-9 Rectangle extruded in 
the Perspective viewport

Figure 2-10  Choosing Pen from 
the main menu

Figure 2-12  Shape of the keyholeFigure 2-11  The changed shape of the cursor



2-6			                     MAXON CINEMA 4D R19 Studio: A Tutorial Approach

Figure 2-13  Spline renamed as keyhole

Figure 2-14  Choosing Extrude from the flyout

Figure 2-15  keyhole extruded in the Perspective viewport

Figure 2-16  Choosing Boole from the flyout
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Figure 2-17  Extrude connected to Boole

  Figure 2-18  The hole created in the Perspective viewport

Figure 2-19  Handle placed 
in the front viewport
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Figure 2-20  Handle extruded in the Perspective viewport

                                                   

Figure 2-21 Choosing Circle 
from the main menu
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Figure 2-22  The position of Joint and 
Joint.1 displayed in the Perspective 
viewport

Figure 2-23  Joint and Joint.1 lofted to create a surface  
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Figure 2-25  Choosing the Background 
option from the main menu

Figure 2-24  Choosing Group Objects 
from the Objects menu

Figure 2-27  The Display Color 
parameter activated

Figure 2-26  The Background Object 
selected in the Object Manager
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 Figure 2-28  The Picture Viewer window

Figure 2-29  Choosing the Save as option from the File menu
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Figure 2-30  The Save dialog box

Figure 2-31  The model of a 
hand bag
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Figure 2-32  Rectangle placed in the 
Perspective viewport

Figure 2-33  Rectangle.1 added to the Object 
Manager

Figure 2-34  Rectangle.1 placed in 
the Perspective viewport

  Figure 2-35  Rectangle.2 added to the Object Manager
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Figure 2-36  Rectangle.2 placed in the Perspective viewport

Figure 2-38  Rectangle.3 placed in 
the Perspective viewport

Figure 2-37  Rectangle.3 added to the Object 
Manager

Figure 2-39  Choosing Loft from the flyout
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Figure 2-40  Rectangle.2 connected to Loft in the Object Manager

Figure 2-42  All rectangles lofted in 
the Perspective viewport

Figure 2-41   Rectangle, Rectangle.1, and Rectangle.3 
connected to Loft

Figure 2-43  Choosing Lathe from the flyout

Figure 2-44  Circle connected to Lathe in the Object Manager
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Figure 2-45   The handle of the 
hand bag created

Figure 2-46  The changed shape of the cursor 
in the Object Manager

Figure 2-47  The text placed in the 
Perspective viewport
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Figure 2-48  Text connected to Extrude in 
the Object Manager

Figure 2-49  The extruded text on the 
hand bag

Figure 2-50  The model of the cigar pipe

Figure 2-51  Ellipse displayed in the 
Front viewport

Figure 2-52  Ellipse.1 displayed in the 
Front viewport
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Figure 2-53  Circle displayed in the Front viewport

Figure 2-54  The profile of the pipe displayed
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Figure 2-55  The splines connected with Loft

Figure 2-56  The shape of the pipe displayed
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Figure 2-57  The pipe with the fillet caps displayed

 Figure 2-58  The model of a chair  Figure 2-59  The model of a table clock



Chapter 3

 Introduction to 
Polygon Modeling

 Learning Objectives 
After completing this chapter, you will be able to:
• Create polygon primitives
• Work with various polygon modeling tools
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Figure 3-1  The model of a computer mouse

Figure 3-2  Cube created in the Perspective viewport

Figure 3-4  Scaling the selected points of 
Computer mouse

Figure 3-3  The corner points of Computer mouse 
to be selected
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Figure 3-6  Scaling the selected points 
of Computer mouse

Figure 3-5  The points to be selected

Figure 3-7  The center points to be selected Figure 3-8  Scaling the selected 
points of Computer mouse
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Figure 3-9  The selected points of Computer 
mouse

Figure 3-10  Scaling the selected 
points of Computer mouse

Figure 3-11  The top and bottom center points 
of Computer mouse selected

Figure 3-12  Scaling the selected points of 
Computer mouse
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Figure 3-13  The points to be selected

 Figure 3-14  Moving the selected points of Computer mouse

Figure 3-15   The selected points of Computer mouse

Figure 3-16  Moving the selected points of Computer mouse
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Figure 3-17  The top center points of Computer mouse selected

  Figure 3-18  Moving the selected points of Computer mouse

Figure 3-19  The points to be selected
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Figure 3-20  Rotating the selected points of Computer mouse

Figure 3-21  The points to be selected

	

Figure 3-22  Rotating the selected points of Computer mouse
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Figure 3-23  The points to be selected

Figure 3-24  Moving the selected points upward

Figure 3-25  The selected points of Computer 
mouse

Figure 3-26  Moving the selected 
points of Computer mouse
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Figure 3-27  The points to be selected Figure 3-28  Moving the selected points of 
Computer mouse

Figure 3-29   The selected edges in the Perspective viewport
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Figure 3-30  Scaling down the edges of Computer mouse in 
the Perspective viewport

Figure 3-31  The points to be selected Figure 3-32  Moving the selected points of 
Computer mouse

Figure 3-33  The points to be selected
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Figure 3-34  Scaling and moving the points 
of Computer mouse

Figure 3-35  The points of Computer mouse to be 
selected

Figure 3-36  Scaling the points of  
Computer mouse 

Figure 3-37 Moving the selected points in the Right 
viewport

Figure 3-38  Scaling the points of Computer mouse
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Figure 3-39  Clicking on the right of the 
middle edge loop

Figure 3-40  A new edge loop added to the 
Computer mouse

Figure 3-41 The slider displayed at the 
top of the viewport

Figure 3-42  A new edge added 
to Computer mouse
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Figure 3-43  A new edge added to Computer 
mouse

Figure 3-44  The polygons selected

Figure 3-45  The extruded polygons
of Computer mouse

Figure 3-47  An edge loop added to Computer 
mouse

Figure 3-46  An edge loop added to Computer 
mouse

Figure 3-49  The edges added to Computer 
mouse

Figure 3-48 An edge loop added to Computer 
mouse
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Figure 3-50  The smoothened Computer mouse

Figure 3-51  The Scroll wheel 
placed on Computer mouse

Figure 3-52 The selected polygons 
of Computer mouse

Figure 3-53  Spline created in the 
Top viewport
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Figure 3-54  Cube placed in 
the Top viewport

Figure 3-55  The edges to be 
selected in the Top viewport

Figure 3-56  The points to be selected Figure 3-57  Scaling the selected points

Figure 3-58  The edges selected Figure 3-59  Scaling the selected edges
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Figure 3-60  The polygons to be selected Figure 3-61  The extruded edge loop

Figure 3-62  The edges to be added

Figure 3-63  The polygons to be selected
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Figure 3-64  The selected polygons

Figure 3-65  The deleted polygons

Figure 3-66  The model of computer table

   



3-18			                     MAXON CINEMA 4D R19 Studio: A Tutorial Approach

Figure 3-67  The Computer table in the Perspective viewport

Figure 3-68  Adding an edge loop

 

Figure 3-69  The edge loops added 
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Figure 3-70  The selected polygons of Computer table

 

Figure 3-71  The selected polygons extruded in the Perspective viewport

Figure 3-72  Clicking on edge to create a new edge loop
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Figure 3-73  The selected polygons of Computer table

Figure 3-74  The selected polygons extruded in the Perspective viewport
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Figure 3-75  Cube aligned in the Perspective viewport

Figure 3-76  Cube.1 positioned in the Perspective viewport
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Figure 3-77  Left side positioned in the Perspective viewport

Figure 3-78  Boole connected to Computer table
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Figure 3-79  The holes created in the side support of the Computer table

Figure 3-80  Creating an edge using the Plane Cut tool
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Figure 3-81  Four new edge loops added to the Computer table

Figure 3-82  The selected polygons of Computer table
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Figure 3-83  The selected polygons extruded in the Perspective viewport

      

Figure 3-84  The Keyboard support of Computer table
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Figure 3-85  New edge loop created

Figure 3-86  Another edge loop added to Computer table
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Figure 3-87  The selected polygons of Computer table

Figure 3-88  The selected polygons extruded in the Perspective viewport
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Figure 3-89  The selected polygons of Computer table

Figure 3-90  The selected polygons extruded in the Perspective viewport
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Figure 3-91  The selected polygons of Computer table

Figure 3-92  The selected polygons extruded in the Perspective viewport
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Figure 3-93  Clicking on edge to create a new edge loop

Figure 3-94  Two new edge loops added to the Computer table
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Figure 3-95  The selected polygons of Computer table

Figure 3-96  The selected polygons extruded in the Perspective viewport
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Figure 3-97  The selected polygons of Computer table

Figure 3-98  The selected polygons extruded in the Perspective viewport



Introduction to Polygon Modeling	 3-33

Figure 3-99  Clicking on edge to create a new edge loop

Figure 3-100  The new edge loop added to the Computer table



3-34			                     MAXON CINEMA 4D R19 Studio: A Tutorial Approach

Figure 3-101 The selected polygons of Computer table

Figure 3-102 The selected polygons extruded in the Perspective viewport
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Figure 3-103  Shelf1 positioned in the Perspective viewport

Figure 3-104  Shelf1.1 positioned in the Perspective viewport
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Figure 3-105  Choosing the Polygon Pen tool from the Modeling Tool Palette

Figure 3-106  The highlighted polygon
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Figure 3-107  Dragging the highlighted polygon 

 

Figure 3-108  The highlighted polygon of magazine stand
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Figure 3-109  Dragging the highlighted polygon

Figure 3-110  Highlighted polygon
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Figure 3-111  Dragging the highlighted polygon

Figure 3-112 Clicking on an edge
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Figure 3-113  Clicking on second edge to create a new edge

Figure 3-114  Three new edges added to the magazine stand
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Figure 3-115  Highlighted polygon

Figure 3-116  Dragging the highlighted polygon downward

Figure 3-117   Clicking on the corner point



3-42			                     MAXON CINEMA 4D R19 Studio: A Tutorial Approach

Figure 3-118   The new edge created

Figure 3-119  The edge converted to an arc shape
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Figure 3-120  Highlighted polygon

Figure 3-121  The extruded polygon

Figure 3-122  The model of a chair

 												             

												          
				    					   
				    			 



Chapter 4

Sculpting
 Learning Objectives 
After completing this chapter, you will be able to:
• Use various sculpting tools and brushes
• Sculpt polygon objects
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Figure 4-1  The model of a candle

Figure 4-2  The polygons to be selected

Figure 4-3  Moving the polygons of the Candle downward
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Figure 4-4  Scaling down the polygons of Candle

Figure 4-5  Selecting Sculpt from the Layout drop-down list
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Figure 4-6  The Sculpt layout

Figure 4-7  The Sculpt Expression [Sculpt] tag added to the Object Manager
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Figure 4-8  The strokes added Figure 4-9  The Invert check box selected in the Settings 
area in the Attribute Manager

Figure 4-10  Strokes added to 
the Candle

Figure 4-11  Strokes added 
on the top of Candle
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Figure 4-12 Adding strokes to the 
bottom of the Candle

Figure 4-13  More strokes added 
to the bottom of the Candle 

Figure 4-14 Adding strokes to the 
top of Candle

Figure 4-15  The smoothened surface 
of Candle

Figure 4-16  The Wick of the Candle
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Figure 4-17  The ice cream cone

	

Figure 4-18  The Cone displayed in the Perspective viewport
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Figure 4-19  Choosing the Subdivide tool from the Sculpting menu

Figure 4-21  The strokes addedFigure 4-20  Applying strokes on the 
top of the Cone
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Figure 4-22  Cone smoothened 
using the Smooth tool

Figure 4-23  Creating a pattern on 
Cone in the Perspective viewport

Figure 4-24  Creating a pattern on 
Cone using the Inflate tool

Figure 4-25  The pattern 
displayed on Cone
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Figure 4-26  Smoothening the surface 
of Cone using the Smooth tool

Figure 4-27  The Scoop displayed 
in the Perspective viewport

Figure 4-28  Adding strokes on the Scoop 
in the Perspective viewport

Figure 4-29   Adding stroke 
on Scoop using the Pull tool
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Figure 4-30   Creating the  pattern 
on Scoop in the Perspective viewport

Figure 4-31 The peak of Scoop 
created

						    
                                         

Figure 4-32  The smooth peak of the 
Scoop in the Perspective viewport
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Figure 4-33  A barrel with cracks

 

												          
											         

												          
												          
												          
												          
												          
												          
												          
												          
				    					   
				    					   
										        



Chapter 5

Texturing
 Learning Objectives 
After completing this chapter, you will be able to:
• Work with the Material Manager
• Use shaders
• Apply textures and colors to the objects



5-2			                     MAXON CINEMA 4D R19 Studio: A Tutorial Approach

Figure 5-1  The textured model of a dice

Figure 5-2  The c05_tut1_start.c4d file



Texturing	 5-3

 

Figure 5-3  Choosing New Material from the Material Manager menu 

Figure 5-4  Displaying the material slot in the Material Manager

Figure 5-5  The Reflectance check box selected
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Figure 5-6  The matDice material 
applied to Cube

Figure 5-7  The Dot material applied to dots of the Cube
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  Figure 5-8  Choosing the browse button

Figure 5-9  The matFloor applied to Floor
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  Figure 5-10  The textured dining table set

Figure 5-11  The c05_tut2_start.c4d file
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Figure 5-12  The Wood_Texture.jpg added to the Color area of Attribute Manager

Figure 5-13  The matChair applied to the chairs



5-8			                     MAXON CINEMA 4D R19 Studio: A Tutorial Approach

Figure 5-14  The Texture Tag “matChair” in 
the Object Manager

 

Figure 5-15  Choosing the Visualize folder in the Content Browser
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Figure 5-16  The Texture Tag “Marble 03” selected in 
the Object Manager

Figure 5-17  The Marble 03 texture uniformly projected on the Floor



5-10			                     MAXON CINEMA 4D R19 Studio: A Tutorial Approach

Figure 5-18  The matGlass material applied to the Glasses

Figure 5-19  The matCover material 
applied to the material slot
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Figure 5-20  The Texture Tag “matCover” selected 
in the Object Manager

Figure 5-21  The matCover material applied to Table cover
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Figure 5-22  The matTableMats material applied to the Table mat group

Figure 5-23 The flyout displayed 
on choosing the triangle button 
next to the Texture parameter 

Figure 5-24  The Shader Properties area of Gradient 
in the Attribute Manager
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Figure 5-25  The Color Picker dialog 
box

 Figure 5-26  The matWine material applied to Wine bottle
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Figure 5-27  The matLabel texture displayed 
in the Color area of Material Manager

Figure 5-28  The matLabel texture applied to Wine bottle 



Texturing	 5-15

	

Figure 5-29  Selecting the Texture Tag “matLabel” 
in the Object Manager

Figure 5-30  The matLabel material 
projected properly on the wine bottle 
in the Perspective viewport

Figure 5-31  The matCap material 
applied to the Wine bottle cap
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Figure 5-32  The matPlates 
Material applied to Plate.1

									           

Figure 5-33  The camera model Figure 5-34  The final output



Chapter 6

 Lighting

 Learning Objectives 
After completing this chapter, you will be able to:
• Add lights to a scene
• Illuminate a scene
• Add Physical Sky to a scene
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Figure 6-1  The torchlight

Figure 6-2  The c06_tut1_start.c4d file

Figure 6-3  The flyout displayed 
with various tools
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Figure 6-4  The rendered view of the Perspective viewport 

		

Figure 6-5  Light.1 displayed in the Perspective viewport
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Figure 6-6  The illuminated night scene

			   Figure 6-7  The c06_tut2_start.c4d file



Lighting	    6-5

Figure 6-8  Light positioned in the scene

	

Figure 6-9  Light.1 positioned in the scene
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Figure 6-10  Lights positioned in the Perspective viewport

Figure 6-11  Light.8 created in 
the Top viewport
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Figure 6-12  Light.8 positioned in the scene

								          

Figure 6-13  The light house 
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Figure 6-14  The c06_tut3_start.c4d file

Figure 6-15  The spot light positioned in the Perspective viewport
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Figure 6-16  The Area lights positioned in the Perspective viewport

Figure 6-17  Choosing Physical 
Sky from the main menu
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Figure 6-18  Physical Sky added to the Object Manager

Figure 6-19  The Time and Location area
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      Figure 6-20  The living room scene

							     
                                                                                                                                                 

	                                                  	

Figure 6-21  The scene after adding lights to it

 



Chapter 7

 Rigging

 Learning Objectives 
After completing this chapter, you will be able to:
• Understand the concept of rigging
• Apply constraints
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Figure 7-1 The rig of the hand

Figure 7-2  The c07_tut1_start file



Rigging	    7-3

 Figure 7-3  Clicking on the shoulder joint of the hand

 Figure 7-4 Bone structure created 
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 Figure 7-5  All joints aligned in the Front viewport

Figure 7-6  Choosing the Create 
IK Chain from the main menu



Rigging	    7-5

Figure 7-7  The IK chain created in the Perspective viewport

Figure 7-8  The changed icon of wrist_joint.Goal
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Figure 7-9 The shoulder control in the Perspective viewport

       Figure 7-10  Displaying the controllers of hand
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Figure 7-11  The changed icon of shoulder_joint.Pole

Figure 7-12  Hierarchy for controls in the 
Object Manager
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Figure 7-13  Choosing Constraint from the 
shortcut menu

             

Figure 7-14  All joints and controls rotating along with 
shoulder control in the Perspective viewport
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Figure 7-15  The wrist_joint and end_joint rotating along with wrist control

Figure 7-16  Position of shoulder_joint.Pole changed 
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Figure 7-17  Elbow movement controlled by wrist_joint.Goal 

Figure 7-18  Elbow rotation controlled by 
shoulder_joint.Pole 
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Figure 7-19  Skin added in the Object Manager

Figure 7-20  Rig for a table lamp
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Figure 7-21  The c07_tut2_start file

Figure 7-22  The main control in the Top viewport
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Figure 7-23  The support control in the 
Perspective viewport

Figure 7-24  The center control in the 
Perspective viewport

Figure 7-25  The lamp control in the 
Perspective viewport

Figure 7-26  All controls connected in the Object Manager
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Figure 7-27  The table lamp moving 
along with main control

Figure 7-28  Supports and lamp shade 
rotating along with support control

Figure 7-29 The support2 and lamp 
shade rotating  along with center control

Figure 7-30  The lamp shade rotating  
along with lamp control
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Figure 7-31 Rig for a human leg



Chapter 8

Animation

 Learning Objectives 
After completing this chapter, you will be able to:
• Create key animation
• Create path animation
• Work with the Timeline panel
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Figure 8-1  The animated logo at frame 109

Figure 8-2  The c08_tut1_start.c4d file

Figure 8-3  Choosing the Add Keyframe option from the shortcut menu
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Figure 8-4  Timeslider set to frame 20

	 Next, you will animate the text.

5.	 Make sure that CADCIM is selected in the Object Manager. In the Object Properties area, 
enter 274 in the Horizontal Spacing spinner; the horizontal space between the text increases 
in the Perspective viewport, as shown in Figure 8-5.

	 The Horizontal Spacing spinner is used to increase or decrease space between the characters.

6.	 In the Animation toolbar, move the timeslider to frame 40. Alternatively, enter 40 in the 
Current Time spinner; the timeslider is set to frame 40.Figure 8-5  The space added between the text

7.	 Make sure that CADCIM is selected in the Object Manager. In the Object Properties area, 
enter 0 in the Horizontal Spacing spinner; the horizontal space between the text decreases 
in the Perspective viewport.

8.	 In the Animation toolbar, move the timeslider to frame 45. 

9.	 Make sure that CADCIM is selected in the Object Manager. In the Object Properties area, 
enter 8 in the Horizontal Spacing spinner; the horizontal space between the text increases 
slightly in the Perspective viewport.

10.	 In the Animation toolbar, move the timeslider to frame 48. 

11.	 Make sure that CADCIM is selected in the Object Manager. In the Object Properties area, 
enter 0 in the Horizontal Spacing spinner; the horizontal space between the text increases 
in the Perspective viewport.

	 Next, you will animate the height of the text, CADCIM.
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12.	 Make sure that CADCIM is selected in the Object Manager. In the Object Properties area, 
right-click on the Height option; a shortcut menu is displayed. From this shortcut menu, 
choose Animation > Add Keyframe, refer to Figure 8-3; a keyframe is added and the circle 
located at the left of the Height option turns red.

	 The Height spinner is used to modify the height of the text.

13.	 In the Animation toolbar, move the timeslider to frame 65. Make sure that CADCIM is 
selected in the Object Manager. In the Object Properties area, enter 345 in the Height 
spinner; the height of the text increases in the Perspective viewport, refer to Figure 8-6.

14.	 In the Animation toolbar, move the timeslider to frame 75. Make sure that CADCIM is selected 
in the Object Manager. In the Object Properties area, enter 166 in the Height spinner; the 
height of the text decreases in the Perspective viewport, as shown in Figure 8-7.

Figure 8-6  The CADCIM text at frame 65

 Figure 8-7  The CADCIM text at frame 75
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15.	 In the Animation toolbar, move the timeslider to frame 83. Make sure that CADCIM is 
selected in the Object Manager. In the Object Properties area, enter 226 in the Height 
spinner; the height of the text increases in the Perspective viewport.

16.	 In the Animation toolbar, move the timeslider to frame 90. Make sure that CADCIM is 
selected in the Object Manager. In the Object Properties area, enter 187 in the Height 
spinner; the height of the text decreases.

	 Next, you will animate the text, Technologies.
17.	 Select Technologies in the Object Manager; the Text Object [Technologies] settings are 

displayed in the Attribute Manager.

18.	 In the Animation toolbar, move the timeslider to frame 100. In the Object Properties area, 
enter 0 in the Height spinner and then right-click on the Height option; a shortcut menu 
is displayed. Choose Animation > Add Keyframe from the shortcut menu.

19.	 In the Animation toolbar, move the timeslider to frame 120. Make sure that Technologies 
is selected in the Object Manager. In the Object Properties area, enter 200 in the Height 
spinner; the height of the text increases in the Perspective viewport.

	 Next, you will animate the rotation of the text, Technologies.

20.	 Choose the Coord button in the Attribute Manager; the Coordinates area is displayed. In 
the Coordinates area, right-click on the R . H option; a shortcut menu is displayed. Choose 
Animation > Add Keyframe from the shortcut menu; a keyframe is added to the timeslider 
and the circle on the left of the R . H option turns red.

21.	 In the Animation toolbar, move the timeslider to frame 200. Make sure that Technologies is 
selected in the Object Manager. In the Coordinates area, enter 360 in the R . H spinner; a 
keyframe is added at frame 200.

Fine-Tuning the Animation
In this section, you will fine-tune the animation in the Timeline window.

1.	 Select CADCIM in the Object Manager and right-click on it; a shortcut menu is displayed. 
Choose Show FCurves from the shortcut menu, as shown in Figure 8-8; the Timeline win-
dow is displayed, as shown in Figure 8-9.

	 The Show FCurves option is used to display the Timeline window with the F-Curve 
Mode activated. 

	 The Timeline window is the most essential part of animation in CINEMA 4D. It is used 
to control and edit the animation. The Timeline window has three modes: Key Mode, 
F-Curve Mode, and Motion Mode.

Figure 8-9  The Timeline window

2.	 In the Timeline window, make sure that the F-Curve Mode button is chosen. Next, press 
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CTRL+A to select all the keys in the Timeline window, as shown in Figure 8-10.

Figure 8-10  Selecting all the keys in the Timeline window

	 The F-Curve Mode is used to modify the interpolation of the keyframes.
3.	 In the Timeline window, choose the Linear button; all the curves are set to linear, as 

shown in Figure 8-11. Now, close the Timeline window.

Figure 8-11  Displaying the linear shape of curves
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	 The Linear button is used to set a linear interpolation between the selected keyframes. 

Saving and Rendering the Animation
In this section, you will save and render the animation. You can also view the final render sequence 
by downloading the file c08_cinema4d_r19_rndr.zip from www.cadcim.com. The path of the file is 
mentioned at the beginning of the chapter.

1.	 Choose the Edit Render Settings tool from the Command Palette; the Render Settings 
window is displayed. In this window, make sure that the Output option is selected in the list 
displayed at the left side of the window. In the Output area, make sure that the To spinner 
is set to 200.

	
2.	 Select the Save option from the list displayed on the left in the Render Settings window; 

the Regular Image area is displayed. In this area, make 
sure that the Save check box is selected. Next, choose 
the browse button located next to the File spinner; the 
Save File dialog box is displayed.

	 The Save check box is selected by default. It is used to 
render the image or sequence automatically on choos-
ing the Render to Picture Viewer tool. 

3.	 In the Save File dialog box, browse to \Documents\
c4dr19\c08 and enter c08tut1 in the File name text 
box. Next, choose the Save button.

4.	 Make sure that the AVI Movie option is selected in the 
Format drop-down list. Next, close the Render Settings 
window.

5.	 Choose the Render to Picture Viewer tool from the 
Command Palette; the Picture Viewer window is dis-
played and the rendering begins. The file is automati-
cally saved at the specified location.

 Tutorial 2                                                                             
In this tutorial, you will create a basket ball animation, as 
shown in Figure 8-12. 
								      
     (Expected time: 35 min)

Figure 8-12  The basket ball at frame 66

Figure 8-8  Choosing Show FCurves 
from the shortcut menu
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The following steps are required to complete this tutorial:

a.   	Open the file.
b.  	 Animate the basketball.
c.	 Fine-tune the animation.
d.	 Save and render the animation.

Opening the File
In this section, you will open the file.

1.	 Choose File > Open from the main menu; the Open File dialog box is displayed.

2.	 In the Open File dialog box, browse to \Documents\c4dr19\c08\c08_tut2_start.c4d and then 
choose the Open button; the c08_tut2_start.c4d file is opened, as shown in Figure 8-13.

Animating the Basketball
In this section, you will animate the basketball by adding the keyframes.

1. 	 Press F3; the Right viewport is maximized. In the Animation toolbar, choose the Autokeying 
button and make sure that the timeslider is set to frame 0. 

Figure 8-13  The c08_tut2_start.c4d file

2.	 Select basketball in the Object Manager and then choose the Coord button in the Attribute 
Manager, if not already chosen; the Coordinates area is displayed. In the Coordinates area, 
right-click on the circle located on the left of the P . X spinner; a shortcut menu is displayed. 
Choose Animation > Add Keyframe from the shortcut menu; the circle located on the left 
of P . X,  P . Y, and P . Z turns red.

3.	 In the Coordinates area, set the parameters as follows:

	 P . X: -40.84		  P . Y:  464.471	     		  P . Z:  -815.996	

	 Figure 8-14 displays basketball at frame 0.

Figure 8-14  The basketball at frame 0
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4.	 In the Animation toolbar, move the timeslider to frame 10. Alternatively, enter 10 in the 
Current Time spinner; the timeslider is set to frame 10.

5.	 Make sure basketball is selected in the Object Manager. In the Coordinates area, set the 
parameters as follows:

	 P . Y: 796.753	       	 P . Z: -455.277	

	 Figure 8-15 displays basketball at frame 10.

Figure 8-15  The basketball at frame 10

6.	 In the Animation toolbar, move the timeslider to frame 20. 

7.	 Make sure basketball is selected in the Object Manager. In the Coordinates area, set the 
parameters as follows:

	 P . Y: 954.44	       	 P . Z: 28.102	

	 Figure 8-16 displays basketball at frame 20.

Figure 8-16  The basketball at frame 20
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8.	 In the Animation toolbar, move the timeslider to frame 30. 	

9.	 Make sure basketball is selected in the Object Manager. In the Coordinates area, set the 
parameters as follows:

	 P . Y: 739.71	       P . Z: 248.523	
	
Figure 8-17 displays basketball at frame 30.

Figure 8-17  The basketball at frame 30

10.	 In the Animation toolbar, move the timeslider to frame 34. 

11.	 Make sure basketball is selected in the Object Manager. In the Coordinates area, set the 
parameters as follows:

	 P . Y: 567.025	       	 P . Z: 235.442

	 Figure 8-18 displays basketball at frame 34.

12.	 Similarly, move the timeslider to frames and set the values in the Attribute Manager as given 
in Table 8-1.

Table 8-1  The transformation values of basketball

Frame to be selected P . Y P . Z

40 29.429 18.251

50 332.391 -95.207

64 30.581 -229.294

73 227.576 -322.123

84 31.041 -435.581
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91 141.612 -507.782

100 32.92 -609.611

150 32.92 -1061.761

Figure 8-18  The basketball at frame 34

	 Figure 8-19 displays basketball at frame 150. 

Figure 8-19  The basketball at frame 150

13.	 Choose the Play Forwards button from the Animation toolbar to view the animation of 
basketball.
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	 Next, you will rotate basketball.
14.	 Make sure basketball is selected in the Object Manager. Next, move the timeslider to frame 0. 

In the Coordinates area, right-click on the circle located on the left of the R . H spinner; a 
shortcut menu is displayed. From this shortcut menu, choose Animation > Add Keyframe; 
the circle located at the left of the R . H, R . P, and R . B spinners turn red.

15.	 Move the timeslider to frames and set the values in the Attribute Manager as given in 
Table 8-2.

Table 8-2  The rotation values of basketball

Frame to be selected R . P

40 90

64 180

84 270

100 360

150 520

	 Next, you will create the squash and stretch effect on basketball when it touches Floor.

16.	 Move the timeslider to frame 39. In the Coordinates area, right-click on the circle located 
on the left of the S . X spinner; a shortcut menu is displayed. From this shortcut menu, 
choose Animation > Add Keyframe; the circle located at the left of the S . X, S . Y, and 
S . Z spinners turns red.

	 Next, you need to copy the keyframe created at frame 39 to other frames.

17.	 Make sure basketball is selected in the Object Manager and right-click on it; a shortcut menu is 
displayed. Choose Show FCurves from the shortcut menu, refer to Figure 8-8; the Timeline 
window is displayed.

18.	 Select Scale . X, Scale . Y, and Scale . Z, from the list displayed on the left pane of the 
Timeline window. Next, select the keyframe at frame 39 by using the rectangular marquee 
selection, as shown in Figure 8-20. Next, press CTRL+C. Now, move the timeslider to frame 
43 and press CTRL+V; the selected keyframe is copied to frame 43. 

 Note
Choose F-Curve > Show All Tracks from the Timeline window menu bar to display only the 
selected curves in the window.

19. 	Similarly copy the selected keyframe at frames 67 and 87. Next, minimize the Timeline 
window.

20. Move the timeslider to frame 40. Select basketball in the Object Manager again. In the 
Coordinates area, enter the value 0.87 in the S . Z spinner; basketball is squashed and a 
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keyframe is created at this frame, refer to Figure 8-21.Figure 8-20   Selecting the keyframe from the Timeline window

Figure 8-21   Squashed basketball at frame 40

21. Move the timeslider to frame 64. In the Coordinates area, enter the value 0.87 in the 
S . Y spinner; basketball is squashed and a keyframe is created at this frame.

22. Move the timeslider to frame 84. In the Coordinates area, enter the value 0.87 in the S . X
	 spinner; basketball is squashed and a keyframe is created at this frame.

23.	 Choose the Play Forwards button from the Animation toolbar to view the animation of 
basketball.

Fine-Tuning the Animation
In this section, you will fine-tune the animation using the Timeline window.

1.	 In the Animation toolbar, move the timeslider to frame 40. Next, maximize the Timeline 
window. Select Position Y from the list displayed on the left pane of the Timeline window. 
Select the keyframe at frame 40 by using the rectangular marquee selection, refer to 
Figure 8-22. 

Figure 8-22   Selecting the keyframe from the Timeline window
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2.	 Choose the Break Tangents button from the Timeline window and then move the
tangents using the Move tool to add weight to basketball when it touches Floor, refer to 
Figure 8-23. 

3.	 Similarly, select the keyframes at frame 64, 84, and 100, one by one, by using the rectangular 
marquee selection and then move their tangents, as shown in Figure 8-24 as done in previous 
steps.

4.	 Select the keyframes at frames 50, 73, and 91 one by one from the Timeline window and 
then choose the Ease Ease button.

5.	 Choose the Play Forwards button from the Animation toolbar to view the animation of 
basketball. Figure 8-23   Moving the tangents in the Timeline window

Figure 8-24   Moving the tangents at other frames 

Saving and Rendering the Animation
In this section, you will save and render the animation. You can also view the final render sequence 
by downloading the file c08_cinema4d_r19_rndr.zip from www.cadcim.com. The path of the file is 
mentioned at the beginning of the chapter.

1.	 Choose the Edit Render Settings tool from the Command Palette; the Render Settings 
window is displayed. In this window, choose the Output button; the Output area is displayed. 
In this area, enter 150 in the To spinner; the Frames option gets updated to 151 (from 0 
to 150).

2.	 Choose the Save button from the list displayed on the left in the Render Settings window; 
the Regular Image area is displayed. In this area, make sure that the Save check box is 
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selected. Next, choose the browse button located next to the File text box; the Save File 
dialog box is displayed. 

3.	 In the Save File dialog box, browse to the location \Documents\c4dr19\c08 and enter c08tut2 
in the File name text box. Next, choose the Save button.

4.	 Select the AVI Movie option from the Format drop-down list. Next, close the Render Settings 
window.

5.	 Choose the Render to Picture Viewer tool from the Command Palette; the Picture Viewer 
window is displayed and the rendering begins. The file is automatically saved at the specified 
location.

 Tutorial 3  
In this tutorial, you will animate the cart using the path animation and key animation,  refer to 
Figure 8-25.                                                                                           (Expected time: 25 min)

The following steps are required to complete this tutorial:

a.   	Open the file.
b.	 Align the cart along a spline path.
c. 	 Move the cart.	
d.	 Rotate the wheels of the cart.
e.	 Save and render the scene. 

Figure 8-25  Moving cart at frame 45

Opening the File
In this section, you will open the file.
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1.	 Choose File > Open from the main menu; the Open File dialog box is displayed.

2.	 In the Open File dialog box, browse to \Documents\ c4dr19\c08\c08_tut3_start.c4d and then 
choose the Open button; the c08_tut3_start file is opened, as shown in Figure 8-26.

Figure 8-26  The c08_tut3_start file

Aligning the Cart along a Spline Path
In this section, you will align the cart along a spline path using a CINEMA 4D tag.

1.	 Select cart in the Object Manager. Next, right-click on it; a shortcut menu is displayed. Choose 
CINEMA 4D Tags > Align to Spline from the shortcut menu, as shown in Figure 8-27; the 
Align to Spline Expression [Align to Spline] tag is added to the Object Manager, as shown 
in Figure 8-28.

Figure 8-27  Choosing Align to Spline from 
the shortcut menu

Figure 8-28  The Align to Spline Expression 
[Align to Spline] tag in the Object Manager
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2.	 Expand Road in the Object Manager. Also, make sure the Align to Spline Expression [Align 
to Spline] tag is selected in the Object Manager.

3.	 In the Attribute Manager, make sure the Tag button is chosen. Next, choose the Arrow button 
located next to the Spline Path option in the Tag Properties area; the shape of the cursor 
is changed. Next, select Spline from the Object Manager; Spline is displayed in the Spline 
Path edit box in the Attribute Manager, refer to Figure 8-29. Maximize the Perspective 
viewport. You will notice that cart is aligned with Road in the Perspective viewport, as shown 
in Figure 8-30. 

Figure 8-29  Spline displayed in the Spline 
Path edit box

Figure 8-30  cart aligned with Road

Moving the Cart
In this section, you will move cart by setting the keyframe for the Position spinner of the Align 
to Spline Expression [Align to Spline] tag.

1.	 Make sure the timeslider is at frame 0. In the Attribute Manager, right-click on the circle 
located at the left of the Position spinner in the Tag Properties area; a shortcut menu is 
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displayed. Choose Animation > Add Keyframe from it; the circle turns red and a keyframe 
is added at frame 0.

2. 	 Move the time slider to frame 101. Next, in the Attribute Manager, enter 100 in the Position 
spinner. 

3.	 Right-click on the circle located at the left of the Position spinner; a shortcut menu is 
displayed. Choose Animation > Add Keyframe from it; the circle turns red and a keyframe 
is added at frame 101. Also, cart is moved to the end of Road. 

4.	 Choose the Play Forwards button from the Animation toolbar. You will notice that cart is not 
moving exactly along Road on its curved stretch, refer to Figure 8-31. To overcome it, select 
the Tangential check box located above the Position spinner in the Attribute Manager.

Figure 8-31  cart at frame 50

5.	 Choose the Play Forwards button from the Animation toolbar again. Now, you will notice 
that cart is moving exactly along Road.

Rotating the Wheels of the Cart
In this section, you will rotate the wheels of cart by setting keyframes at different frames to get 
a realistic look. You will also use the Timeline panel in the Animation layout to copy and paste 
the repetitive keyframes. 	

1.	 In the Object Manager, select Sphere1. In the Animation toolbar, choose the Autokeying 
button and make sure that the timeslider is set to frame 0. 

2.	 In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. Next, 
right-click on the circle located at the left of the R . H spinner and choose Animation > 
Add Keyframe from the shortcut menu displayed; a keyframe is added for Sphere1 at frame 
0.

3.	 Similarly, move the timeslider to the frames mentioned in Table 8-3 and add keyframes  by 
setting the rotation values in the Attribute Manager as given in Table 8-3. 

Table 8-3  Rotation values for Sphere1
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Frame to be selected R . H

5 -90

10 -180

15 -270

20 -360

21 0

	 You will notice that one round of rotation of wheel1 is

Figure 8-32  Selecting Animate from 
the Layout drop-down list

 
completed by setting the keyframes mentioned 
above. 

	 Next, you need to copy these keyframes to repeat 
the rotation of wheel1. To copy the keyframes, 
you will use the Timeline panel in the Animate 
layout.

4.	 Select Animate from the Layout drop-down list 
located at the top right corner of the interface, 
as shown in Figure 8-32; the Animation layout 
is displayed, as shown in Figure 8-33.

5.	 In the Animate layout, enlarge the Timeline panel 
and zoom in the newly keyframes created using 
the navigation tools in it, refer to Figure 8-34. 
Figure 8-34 shows the modified size of the 
Timeline panel. 

Figure 8-33  The Animate layout displayed
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Figure 8-34  The modified size of the Timeline panel

6.	 Select five keyframes (excluding the keyframe

Figure 8-35  Selecting all keyframes

 
at frame 0) in the Timeline panel by using the 
rectangular marquee selection, as shown in 
Figure 8-35.

7.	 Choose Edit > Copy from the Timeline 
menu, as shown in Figure 8-36.

8.	 Move the timeslider to frame 25. Next, choose 
Edit > Paste from the Timeline menu; the 
keyframes are copied, refer to Figure 8-37.

Figure 8-36  Choosing Copy from the Edit menu

Figure 8-37  Copied keyframes
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9.	 Move the timeslider to frame 45. Next, choose Edit > Paste from the Timeline menu; the 
keyframes are copied.

10.	 Move the timeslider to frame 65. Next, choose Edit > Paste from the Timeline menu; the 
keyframes are copied. 

11.	 Move the timeslider to frame 85. Next, choose Edit > Paste from the Timeline menu; the 
keyframes are copied. Figure 8-38 shows all keyframes for Sphere1.

Figure 8-38  All keyframes for Sphere1

12.	 Move the timeslider to frame 0. In the Object Manager, select Sphere2. 

13.	 In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. Next, 
right-click on the circle located at the left of the R . H spinner and choose Animation > 
Add Keyframe from the shortcut menu displayed; a keyframe is added for Sphere2 at frame 
0.

14.	 Choose the Dope Sheet button and then select Sphere1. Next, select all keyframes from the 
Timeline panel using the rectangular marquee selection.

15.	 Choose Edit > Copy from the Timeline menu. Next, select Sphere2 and make sure the 
timeslider is at frame 0. Now, choose Edit > Paste from the Timeline menu; all keyframes 
of Sphere1 are copied to Sphere2. 

16.	 Repeat the steps 13 through 15 for Sphere3 and Sphere4 in the Object Manager to set keyframes 
for them.

Saving and Rendering the Animation
In this section, you will save and render the animation. You can also view the final render sequence 
by downloading the file c08_cinema4d_r19rndr.zip from www.cadcim.com. The path of the file is 
mentioned at the beginning of the chapter.

1.	 Choose the Edit Render Settings tool from the Command Palette; the Render Settings 
window is displayed. In this window, choose the Output button; the Output area is displayed. 
In this area, enter 101 in the To spinner; the Frames option gets updated to 102 (from 0 
to 101).
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2.	 Choose the Save button from the list displayed on the left in the Render Settings window; 
the Regular Image area is displayed. In this area, make sure that the Save check box is 
selected. Next, choose the browse button located next to the File text box; the Save File 
dialog box is displayed. 

3.	 In the Save File dialog box, browse to the location \Documents\c4dr19\c08 and enter c08tut3 
in the File name text box. Next, choose the Save button. Select the AVI Movie option from 
the Format drop-down list. Next, close the Render Settings window.

 Self-Evaluation Test 

Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following buttons is used to set the keys automatically for the changes made 
in the animation? 

		  (a) Autokeying		   	 (b) Play Forwards   		
		  (c) Edit Render Settings	 (d) Show FCurves

2.	 Which of the following options is used to add a keyframe to a selected frame?
	
		  (a) Render to Picture Viewer	  (b)  Create Preview	
		  (c) Add Keyframe		   (d)  None of these

3.	 Which of the following combination of shortcut keys is used to add a keyframe?
	
		  (a) SHIFT+LMB	  	 (b)  CTRL+LMB	
		  (c) CTRL+Click		  (d)  SHIFT+Click

4.	  __________ is an act of giving life to a 3D object or character.

5.	 The __________ check box in the Attribute Manager is used to move an object exactly along 
the path.

 Review Questions 
Answer the following questions:

1.	 Which of the following buttons in Animation toolbar is used to play an animation?



Animation	 8-23

		  (a) Play Forwards		  (b) Autokeying   		
		  (c) Keyframe Selection		  (d) None of these

2.	 The __________ panel in the Animation layout is used to copy and paste repetitive keyframes.
 
3.	 The __________ button in the Timeline window is used to set linear interpolation between 

the selected keyframes. 
4.	 The ___________ spinner is used to manually enter the starting frame of the animation
	 to be rendered.

EXERCISE 
The rendered video sequence of the animation in the exercise can be accessed by downloading 
the c08_cinema4d_r19_exr.zip file from www.cadcim.com. The path of the file is as follows: 
Textbooks > Animation and Visual Effects > MAXON CINEMA 4D > MAXON CINEMA 4D R19 Studio: 
A Tutorial Approach

 Exercise 1                                                                     
Open the model shown in Figure 8-39 and then animate the keys falling from the table. Also, 
fine-tune the animation.     			                                   (Expected time: 35 min)

Figure 8-39  The c08_exr01_start file
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Answers to Self-Evaluation Test
1. a, 2. c, 3. c, 4. Animation, 5. Tangential
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Chapter 9

Introduction to
 UV Mapping

 Learning Objectives 
After completing this chapter, you will be able to:
• Work in different UV layouts
• Unwrap 3D models
• Paint texture on 3D models
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Figure 9-1  The final output 

Figure 9-2  The c09_tut1_start.c4d file
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Figure 9-4  The Layout 
drop-down list

Figure 9-3  The material applied to Pencil

Figure 9-5  The BP UV Edit layout
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Figure 9-6  Choosing the Paint Setup Wizard tool 
from the Command Palette

Figure 9-7 The BodyPaint 3D 
Setup Wizard  dialog box

Figure 9-8  The STEP 2: UV Setup area
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Figure 9-9  The Material Options area in the BodyPaint 
3D Setup Wizard dialog box

 

Figure 9-10  The UV Mesh of Pencil

Figure 9-11  The matPencil_Color.tif option chosen from the Textures menu



9-6			                     MAXON CINEMA 4D R19 Studio: A Tutorial Approach

Figure 9-12  The selected polygons of Pencil

Figure 9-13  The mirrored polygons

Figure 9-14  The outlined polygons
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Figure 9-15  The yellow color in the selected area of the canvas

Figure 9-16  The black color in the selected area of the canvas

Figure 9-17  Color filled in the remaining parts of pencil

Figure 9-18  Choosing the browse button in the Attribute Manager
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Figure 9-19  The texture applied to Pencil

Figure 9-20  The top polygon of the Eraser selected
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Figure 9-21  The top polygon aligned in the Texture View

Figure 9-22  The text placed inside the white outline
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Figure 9-23  The texture applied to Eraser

 

Figure 9-24  The final 
output

	



Chapter 10

Compositing 3D 
Objects

 Learning Objectives 
After completing this chapter, you will be able to:
• Composite objects in a scene
• Work with the Camera Calibrator tag
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Figure 10-1  The final composition

Figure 10-3  The Camera Calibrator tag added 
to the Object Manager

Figure 10-2   Choosing Camera Calibrator  
from the shortcut menu
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Figure 10-4  The line created in the Perspective viewport

. 

	

Figure 10-5  The position of first line in the Perspective viewport
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Figure 10-6  The position of second line in the Perspective viewport

 

Figure 10-7  The two red lines representing the X-axis
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Figure 10-8  The focal length of the camera solved

Figure 10-9  The pin snapped to the fourth line in the scene

Figure 10-10  The Camera View button
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Figure 10-11  The plane positioned in the scene

Figure 10-12  The MoText displayed in the scene
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Figure 10-13  The rendered scene

Figure 10-14  All objects in the Perspective viewport
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Figure 10-15  All objects in the Object Manager

Figure 10-16  The lines and pin in the scene
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Figure 10-17  The 3D elements composited in the scene



Chapter 11

Rendering

 Learning Objectives 
After completing this chapter, you will be able to:
• Understand Global Illumination
• Create render passes
• Create the caustic patterns
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Figure 11-1  The final rendered table clock

Figure 11-2  The c11_tut1_start.c4d file
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Figure 11-3  Displaying the rendered view

Figure 11-4  The flyout displayed on choosing the Effect button 
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Figure 11-5  The Global Illumination area

Figure 11-6  The rendered clock

	

Figure 11-7  The rendered clock
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 Figure 11-8  The flyout displayed on choosing the Multi-Pass button

Figure 11-9  Selecting the Alpha Channel check box in the Render Settings window
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Figure 11-10  The rendering process in the Picture Viewer window

 Figure 11-11  The render passes displayed in the Picture Viewer window
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 Figure 11-12  Displaying the Alpha 
pass in the Picture Viewer window

 Figure 11-13  The Ambient Occlusion pass 
displayed in the Picture Viewer window

Figure 11-14  The Reflection pass displayed 
in the Picture Viewer window

Figure 11-15  The Global Illumination pass 
displayed in the Picture Viewer window

Figure 11-16  The Shadow pass displayed 
in the Picture Viewer window

Figure 11-17 The Diffuse pass displayed 
in the Picture Viewer window
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Figure 11-18  The render of the beer mug

 Figure 11-19  The c11_tut2_start.c4d file
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Figure 11-20  The floor texture applied

Figure 11-21  The Caustics area in the Render Settings window
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Figure 11-22 The Illumination area displayed in the Material Editor window

 								         

Figure 11-23  Scene after rendering

 



Chapter 12

MoGraph

 Learning Objectives 
After completing this chapter, you will be able to:
• Create clones
• Add MoGraph effectors
• Create the shatter effect using PolyFX
• Work with the MoSpline object
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Figure 12-1  The abstract model to be created

Figure 12-2  Cube positioned in the 
Perspective viewport

Figure 12-3 Cloner displayed in the 
Perspective viewport

Figure 12-4  Cloner.1 displayed in the Perspective viewport



MoGraph	        12-3

Figure 12-5  The disco light effect at frame 60

Figure 12-6  The c12_tut2_start.c4d file
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Figure 12-7  Selecting Radial from the Mode drop-down list

          

Figure 12-8  Selecting Random from the Clones drop-down list

       

Figure 12-9 The clones of Light displayed in the Perspective viewport
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Figure 12-10  Choosing Random from the cascading menu

Figure 12-11  Selecting the User Defined option from the 
Color Mode drop-down list
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Figure 12-12  Selecting the Add option from the Blending 
Mode drop-down list

Figure 12-13  The rendered view at the current frame
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Figure 12-14  The shattering effect at frame 81

 

Figure 12-15  The c12_tut3_start.c4d file
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Figure 12-16  Choosing PolyFX 
from the main menu

Figure 12-17  The fragmented Kettle in the 
Perspective viewport

Figure 12-19 The Random effector 
displayed in the Perspective viewport

Figure 12-18  The Falloff area

Figure 12-20  Random effector at 
frame 0

Figure 12-21 The target camera created in 
the Perspective viewport
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 Figure 12-22  Choosing Align to Spline from 
the cascading menu

Figure 12-23  Arc added to the Spline Path text box
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Figure 12-24  The rendered view at a frame

Figure 12-25  The abstract animation at frame 0
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Figure 12-26  The MoSpline displayed in the Perspective viewport

 

Figure 12-27  The clones displayed in the Perspective viewport

Figure 12-28  The clones displayed in the viewport
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Figure 12-29  The rendered image at frame 48

Figure 12-30  The objects in the Object Manager

Figure 12-32  The model at frame 20Figure 12-31  The guitar model
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MoGraph	        12-15
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MoGraph	        12-17
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MoGraph	        12-19
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MoGraph	        12-21
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MoGraph	        12-23
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Chapter 13

Working with XPresso

 Learning Objectives 
After completing this chapter, you will be able to:
• Work with the XPresso Editor
• Create and connect nodes
• Modify settings of nodes
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Figure 13-1  The traffic signal with the red light on

Figure 13-2  The c13_tut1_start.c4d file
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Figure 13-3  Choosing Add User Data from the menu in the Attribute Manager

	

Figure 13-4  The Manage User Data dialog box
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Figure 13-5  Selecting Float Slider from the Interface drop-down list

	

Figure 13-6  The Red spinner added to the User Data 
area in the Attribute Manager

Figure 13-7  The Yellow spinner added to the User Data area in 
the Attribute Manager
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Figure 13-8  The Green spinner added to the User Data area in the 
Attribute Manager

 Figure 13-9  Choosing XPresso from the shortcut menu
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Figure 13-10  The XPresso Editor

Figure 13-11  Choosing Object from the shortcut menu



Working with XPresso	        13-7

Figure 13-12  Choosing Red from the flyout in the XPresso Editor

Figure 13-13  The Red, Yellow, and Green output ports added to the Traffic-Lights node
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Figure 13-14  Choosing the Compare option from the shortcut menu in the XPresso Editor

Figure 13-15  Choosing the Condition option from the shortcut menu in the XPresso Editor
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Figure 13-16   Selecting Color from the Data Type drop-down 
list in the Node Properties area
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Figure 13-17  The Red-Glass, Yellow-Glass, and Green-Glass nodes added 
in the XPresso Editor

Figure 13-18  Connection established between the Red output port of the Traffic-Lights 
and Compare 1 nodes
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Figure 13-19  Connection established between the Compare 1 and Condition 1 nodes

Figure 13-20  Choosing Display Color from the flyout in the XPresso Editor



13-12			                      MAXON CINEMA 4D R19 Studio: A Tutorial Approach

Figure 13-21  The red light activated in the Perspective viewport

Figure 13-22  Connection established between the Yellow output port of the 
Traffic -Lights and Compare 2 nodes
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Figure 13-23  Connection established between the Compare 2 and Condition 2 nodes

Figure 13-24  Choosing Display Color from the flyout in the XPresso Editor
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Figure 13-25  The yellow light activated in the Perspective viewport

Figure 13-26  The green light activated in the Perspective viewport
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Figure 13-27  The shortcut menu displayed on right-clicking in the User 
Data area

Figure 13-28  The deformed object
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Figure 13-29  The c13_tut2_start.c4d file

Figure 13-30  The Gift node added in the XPresso Editor
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Figure 13-31  The Expand spinner in the Attribute Manager

Figure 13-32  The Fillet spinner added to the Attribute Manager

Figure 13-33  The Cube_Length and Cube_Width spinners added 
to the Attribute Manager
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Figure 13-34  Choosing Expand from the flyout in the XGroup area

Figure 13-35  The Fillet output port added to the Gift node
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Figure 13-36  The Bulge node in the XGroup area

Figure 13-37  Connection established between the Gift and Bulge nodes
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Figure 13-38  Gift expanded in the Perspective viewport

Figure 13-39  The deformation of the Gift softened in the Perspective viewport
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Figure 13-40  The two Gift nodes connected with each other

Figure 13-41  The Gift scaled in the Perspective viewport

Figure 13-42  The logo 
at frame 49


