
Chapter 1

Introduction to 
Creo Parametric 5.0

  Learning Objectives  
After completing this chapter, you will be able to:
• Understand the advantages of using Creo Parametric
• Know the system requirements of Creo Parametric
• Get familiar with important terms and definitions in Creo Parametric
• Understand important options in the File menu
• Understand the importance of Model Tree
• Understand the functions of mouse buttons
• Use the options of default toolbars
• Customize the Ribbon
• Understand the functions of browser
• Understand the use of Appearance Gallery
• Render stages in Creo Parametric
• Change the color scheme of the background in Creo Parametric
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INTRODUCTION TO Creo Parametric 5.0
Creo Parametric is a powerful software used to create complex designs with great precision. The 
design intent of a three-dimensional (3D) model or an assembly is defined by its specification 
and its use. You can use the powerful tools of Creo Parametric to capture the design intent 
of a complex model by incorporating intelligence into the design. Once you understand the 
feature-based, associative, and parametric nature of Creo Parametric, you can appreciate its 
power as a solid modeling tool.

To make the designing process simple and quick, the designing process have been divided into 
different modules in this software package. This means each step of the designing is completed 
in a different module. For example, generally a design process consists of the following steps:

• Sketching using the basic sketch entities
• Converting the sketch into features and parts
• Assembling different parts and analyzing them
• Documenting parts and the assembly in terms of drawing views
• Manufacturing the final part and assembly

All these steps are divided into different modes of Creo Parametric namely, the Sketch mode, 
Part mode, Assembly mode, Drawing mode, and Manufacturing mode. 

Despite making various modifications in a design, the parametric nature of this software helps 
preserve the design intent of a model with tremendous ease. Creo Parametric allows you to work 
in a 3D environment and calculates the mass properties directly from the created geometry. You 
can also switch to various display modes like wireframe, shaded, hidden, and no hidden at any 
time with ease as it does not affect the model but only changes its appearance. 

FEATURES OF CREO PARAMETRIC
Different features of the software are discussed next.

Feature-Based Nature
Creo Parametric is a feature-based solid modeling tool. A feature is defined as the smallest 
building block and a solid model created in Creo Parametric is an integration of a number of 
these building blocks. Each feature can be edited individually to bring in the desired change 
in the solid model. The use of feature-based property provides greater flexibility to the parts 
created. For example, consider the part shown in Figure 1-1. It consists of one counterbore hole 
at the center and six counterbore holes around the Bolt Circle Diameter (BCD). 

Now, consider a case where you need to change all the outer counterbore holes to drill holes 
keeping the central counterbore hole and the BCD for the outer holes same. Also, you need 
to change the number of holes from six to eight. In a non feature-based software package, you 
will have to delete the entire part and then create a new part based on the new specifications. 
Whereas, Creo Parametric allows you to make this modification by just modifying some values 
in the same part, see Figure 1-2. This shows that the solid parts created in Creo Parametric are 
a combination of various features that can be modified individually at any time.
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Figure 1-1  Model with the counterbore holes Figure 1-2  Model after making the modifications

Bidirectional Associative Property
There is a bidirectional associativity between all modes of Creo Parametric. The bidirectional 
associative nature of a software package is defined as its ability to ensure that if any modifications 
are made in a particular model in one mode, then those modifications are also reflected in the 
same model in other modes. For example, if you make any change in a model in the Part mode and 
regenerate it, the changes will also be highlighted in the Assembly mode. Similarly, if you make 
a change in a part in the Assembly mode, after regeneration, the change will also be highlighted 
in the Part mode. This bidirectional associativity also correlates the two-dimensional (2D) 
drawing views generated in the Drawing mode and the solid model created in the Part mode 
of Creo Parametric. This means that if you modify the dimensions of the 2D drawing views in 
the Drawing  mode, the change will be automatically reflected in the solid model and also in 
the assembly after regeneration. Likewise, if you modify the solid model in the Part mode, the 
changes will also be seen in the 2D drawing views of that model in the Drawing mode. Thus, 
bidirectional associativity means that if a modification is made to one mode, it changes the 
output of all the other modes related to the model. This bidirectional associative nature relates 
various modes in Creo Parametric.

Figure 1-3 shows the drawing views of the part shown in Figure 1-1 generated in the Drawing 
mode. The views show that the part consists of a counterbore hole at the center and six 
counterbore holes around it.

Now, when the part is modified in the Part mode, the modifications are automatically reflected in 
the Drawing mode, as shown in Figure 1-4. The views in this figure show that all outer counterbore 
holes are converted into drilled holes and the number of holes is increased from six to eight. 
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Figure 1-3  Drawing views of the model before modifications

Figure 1-4  Drawing views of the model after modifications
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Figure 1-5 shows the Crosshead assembly. It is clear from the assembly that the diameter of the 
hole is more than what is required (shown using dotted lines). In an ideal case, the diameter of 
the hole should be equal to the diameter of the bolt.

Figure 1-5  Crosshead assembly illustrating difference 
in diameter of the hole and the bolt

The diameter of the hole can be changed easily by opening the file in the Part mode and making 
the necessary modifications in the part. This modification is reflected in the assembly, as shown 
in Figure 1-6. This is due to the bidirectional associative nature of Creo Parametric. 

Since all modes of Creo Parametric are interrelated, it becomes very easy to modify your model 
at any time.

Parametric Nature
Creo Parametric is parametric in nature, which means that the features of a part become interrelated 
if they are drawn by taking the reference of each other. You can redefine the dimensions or 
the attributes of a feature at any time. The changes will propagate automatically throughout 
the model. Thus, they develop a relationship among themselves. This relationship is known as 
the parent-child relationship. So if you want to change the placement of the child feature, you 
can make alterations in the dimensions of the references and hence change the design as per 
your requirement. The parent-child relationship will be discussed in detail while discussing the 
datums in later chapters.
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Figure 1-6  Assembly after modifying the diameter of the hole

 

SYSTEM REQUIREMENTS
The system requirements for Creo Parametric are given below.

1.	 Operating System: Windows 7 64-bit Edition (Professional, Ultimate, and Enterprise), 
Windows 8.1 64-bit Edition or Windows 8.1 Pro 64-bit Edition, Windows 10 64-bit Edition 
(Professional, Enterprise).

2.	 Monitor: 1280 x 1024 (or higher) resolution support with 32-bit color.

3.	 Processor: 2.5 GHz minimum (Core i5 or higher). 

4.	 Memory: 4 GB or higher.

5.	 Hard disk space: 5 GB minimum.

6.	 Microsoft TCP/IP Ethernet Network Adapter.

7.	 Microsoft approved 3-button mouse.

8.	 Microsoft Internet Explorer 6.0 or later.

9.	 A certified and supported graphics card.

GETTING STARTED WITH Creo Parametric
Install the Creo Parametric on your system; the shortcut icon of Creo Parametric will automatically 
be created on the desktop. You can start it by double-clicking on its shortcut icon on the desktop. 

Figure 1-7 shows the initial screen and Figure 1-8 shows the Resource Centre window of Creo 
Parametric. Both windows appear when you start Creo Parametric.
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Figure 1-7  Initial screen appearance of starting Creo Parametric

Figure 1-8  The Resource Center window dissplayed on starting Creo Parametric

IMPORTANT TERMS AND DEFINITIONS
Some important terms that will be used in this book while working with Creo Parametric are 
discussed next.
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Entity
An element of the section geometry is called an entity. The entity can be an arc, line, circle, 
point, conic, coordinate system, and so on. When one entity is divided at a point, then the total 
number of entities are said to be two.

Dimension
It is the measurement of one or more entities.

Constraint
Constraints are logical operations that are performed on the selected geometry to make it more 
accurate in defining its position and size with respect to the other geometry.

Parameter
It is defined as a numeric value or a word that defines a feature. For example, all dimensions in 
a sketch are parameters. The parameters can be modified at any time.

Relation
A relation is an equation that relates two entities. 

Weak Dimensions and Weak Constraints
Weak dimensions and weak constraints are temporary dimensions or constraints that appear 
in light blue color. These are automatically applied to the sketch. They are removed from the 
sketch without any confirmation from the user. The weak dimensions or the weak constraints 
should be changed to strong dimensions or constraints if they seem to be useful for the sketch. 
This only saves an extra step of dimensioning the sketch or applying constraints to it.

Strong Dimensions and Strong Constraints
Strong dimensions and strong constraints appear in dark blue color. These dimensions and 
constraints are not removed automatically. All dimensions added manually to a sketch are strong 
dimensions.

Tip
When several strong dimensions or constraints conflict, Creo Parametric makes the constraints 
and dimensions appear in blue box, and prompts you to delete one or more of them.

File MENU OPTIONS
The options that are displayed when you choose File from the menu bar are discussed next.

Select Working Directory
A working directory is a directory on your system where you can save the work done in the current 
session of Creo Parametric. You can set any directory existing on your system as the working 
directory. Before starting the work in Creo Parametric, it is important to specify the working 
directory. If the working directory is not selected before saving an object file, then the object 
file will be saved in a default directory. This default directory is set at the time of installing Creo 
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Parametric. If the working directory is selected before saving the object files that you create, 
it becomes easy to organize them. In Creo Parametric, the working directory can be set in the 
following two ways:

Using the Navigator
When you start a Creo Parametric session, the navigator is displayed

Figure 1-9  Shortcut menu

 
on the left of the drawing area. This navigator can be used to select 
a folder and set it as the working directory. To do so, click on the 
Folder Tree node displayed at the bottom of the navigator; the 
expanded Folder Tree area will be displayed. Browse to the required 
location using the nodes available next to the folders and then select 
the desired folder. The selected folder will become the working 
directory for the current session. Alternatively, right-click on the 
folder that you need to set as the working directory; a shortcut menu 
will be displayed, as shown in Figure 1-9. Choose the Set Working 
Directory option from this shortcut menu to set the selected folder 
as the working directory. To make a new folder, choose the New Folder 
option from the shortcut menu.

Using the Select Working Directory Dialog Box
To specify a working directory, choose File > Manage Session > Select Working Directory from 
the menu bar; the Select Working Directory dialog box will be displayed, as shown in Figure 1-10. 
Using this dialog box, you can set any directory as the working directory. 

Figure 1-10  The Select Working Directory dialog box  
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Choose the arrow at the upper left corner of the Select Working

Figure 1-11  The flyout displayed

Directory dialog box; a flyout will be displayed, as shown in 
Figure 1-11. This flyout displays some of the drives present 
on your computer along with the Favorites folder. The 
Favorites folder contains all directories that you saved as 
favorites. The procedure to save the favorite directories will 
be discussed later. When the Select Working Directory dialog 
box is invoked by default, it displays the contents of the default 
directory. However, you can change the default directory that appears every time you open this 
dialog box. Various options in the Select Working Directory dialog box are discussed next.

	 File name
	 The File name edit box displays the name of the directory selected in the Select Working 

Directory dialog box. You can select a directory using the flyout, as discussed earlier or by 
entering the path of any existing directory in this edit box.

	 Type
	 The Type drop-down list has two options, Directories and All Files (*). If you select the 

Directories option, all directories present get listed, and if you select the All Files (*) option, 
then all files along with the directories are listed in the dialog box.

	 Organize
	 When you choose the Organize button from the Select Working

Figure 1-12  The Organize 
flyout

 
Directory dialog box, a flyout will be displayed. The options in 
this flyout are used to create a new directory or rename an 
existing directory. You can also cut, copy, paste, and delete the 
existing folders using the options in the flyout. Moreover, you 
can add any existing folder in the Common Folders by using 
the Add to common folders option in this flyout, refer to 
Figure 1-12.

	 Views						    
	 When you choose the Views button from the Select Working 

Directory dialog box, a flyout will be displayed. The options in 
this flyout are discussed next.

 
List: The List radio button is used to view the contents of the current folder or drive. 
These include files and folders in the form of a list.

Details: The Details radio button is used to view the contents of the current folder or 
drive in the form of a table, which displays the name, size, and date on which it was 
last modified.

Tip
The Select Working Directory dialog box has some of the properties of the Microsoft Windows 
operating system. You can set the working directory using this dialog box by browsing through 
directories and folders. You can also rename a file, directory, or a folder in this dialog box. 
Also, you can create a new directory using this dialog box.
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	 Tools
	 When you choose the Tools button from the Select

Figure 1-13  The Tools flyout

Working Directory dialog box, a flyout will be 
displayed, as shown in Figure 1-13. The options in 
this flyout are discussed next.

Address Default: When you choose this 
option, the ‘Look In’ Default dialog box will 
be displayed. Figure 1-14 shows this dialog 
box with the options in the drop-down list. If 
you select the Default option from the drop-down list and then invoke the File Open 
dialog box, it will display the directory that is set as default. If you select the Working 
Directory option from the drop-down list and then invoke the File Open dialog box, 
it will display the working directory that is set. If you select the In Session option and 
then invoke the File Open dialog box, the File Open dialog box will open with the In 
Session folder selected by default. Similarly, you can set the Pro/Library as the working 
directory.

Up One Level: The Up One Level option allows you to move one level up in the 
directory. Choose this option; a directory that is one level above the current directory 
will be displayed. Alternatively, press ALT+UP arrow keys or BACKSPACE key to move 
one level up. You can also choose the arrow button on the left of the required directory 
in the address bar to display all folders in it. 

Figure 1-14  The ‘Look In’ Default dialog box with 
options in the drop-down list

Add to Favorites: The Add to Favorites option allows you to add the folders in the 
Favorites folder.

Remove from Favorites: The Remove from Favorites option allows you to remove 
the folders from the Favorites folder. This option is not enabled by default. To enable 
this option, you first need to add the folder in the Favorites folder using the Add to 
Favorites option. 

Sort By: In the Select Working Directory dialog box, the Directories option in the 
Type drop-down list is displayed by default. From this drop-down list, if you select the 
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All Files option and then choose the Tools button, a flyout will be displayed with the 
Sort By option.

The Sort By option is used to list all files in the directory in an order to facilitate the 
process of searching a file. When you choose the Sort By option, a cascading menu 
is displayed. In the cascading menu, there are two radio buttons, Model Name and 
Markup/Instance Name. If you select the Model Name radio button, the file list will 
be sorted out alphabetically by the model name in the Select Working Directory dialog 
box. The Markup/Instance Name radio button sorts out the file list by specific markups 
or instance names in the Select Working Directory dialog box. 

	 Common Folders and Folder Tree
	 The Common Folders and Folder Tree tabs are available on the left of the Select Working 

Directory dialog box. The Common Folders contains folders such as Desktop, My Documents, 
Computer, Working Directory, and Favorites. You can add more folders in the Common 
Folders by using the Add to common folders option available in the Organize flyout. 

	 The Folder Tree contains all the drives available on your computer along with their contents. 
You can also set the working directory by using the Folder Tree. By default, the Folder Tree 
is in the collapsed state. To expand it, you need to click on the node that is available on 
the left of the Folder Tree. The Working Directory and Favorites folders available in the 
Common Folders are discussed next.

Working Directory: This folder is used when you have already set the working directory. 
You may browse through the directories in the Select Working Directory dialog box, but 
when you choose this folder, the directory selected previously as the working directory 
is displayed in the list box.

Favorites: This folder is used to save the location of the directories that are to be used 
frequently. You just need to specify the working directory to be used frequently and save 
its location by selecting the Favorites folder.

If you want to select one of the favorite working directories, then select the Favorites 
folder from the Common Folders; the list of all directories that were saved as favorites 
will be displayed in the list box. Select the required favorite directory and choose the 
OK button; the selected favorite directory will be set as the current working directory. 

Note
In Creo Parametric, an object can be created in different modes such as Part, Drawing, Sketch, 
and then saved as a file.

New 
To create a new object, choose the New tool from the Data group of the Home tab in the 
Ribbon or choose the New tool from the Quick Access toolbar; the New dialog box will 
be displayed, as shown in Figure 1-15. This dialog box displays various modes available 
in Creo Parametric. In this dialog box, by default, the Part mode radio button is selected 
and the default name of the object file is displayed in the Name edit box. You can also 
enter a new name for the object file. Note that the name must not contain a special character.
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When you select the Part, Assembly, or Manufacturing radio button in this dialog box, the 
subtypes of the respective modes will be displayed under the Sub-type area of this dialog box.

Accept the default settings in the New dialog box by choosing the OK button; the default 
template will be loaded. To load a template other than the default one, clear the Use default 
template check box and then choose the OK button; the New File Options dialog box will be 
displayed, as shown in Figure 1-16. Using this dialog box, you can select the predefined templates 
or create a user-defined template. You can also open an empty template provided in the New 
File Options dialog box. In this case, you need to create the datum planes and the coordinate 
systems manually. 

If the measuring units for creating models is millimeters, select mmns_part_solid or solid_part_mmks 
from the list in the Template area and then choose the OK button from the New File Options 
dialog box. On doing so, the three default datum planes and a coordinate system will be displayed 
in the drawing area. Also, the Model Tree will appear on the left of the screen, as shown in 
Figure 1-17. 

Figure 1-15  The New dialog box Figure 1-16  The New File Options dialog box
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Figure 1-17  The initial screen appearance in Part mode

Open
The Open button is used to open an existing object file. When you choose the Open 
option from the File menu or choose the Open button from the Quick Access toolbar, 
the File Open dialog box will be displayed, as shown in Figure 1-18. The selected working 
directory will be displayed in it. Note that the Preview area is not displayed by default. 

To view the Preview area, choose the Preview button. Most of the options in this dialog box are 
same as discussed in the Select Working Directory dialog box. The rest of the options in this 
dialog box are discussed next.

Note
In Creo Parametric, the name of the tools in some of the workbenches will be displayed with them 
only when the system screen is set to high resolution, such as 1900x1200 or 2880x1800 and so 
on. Otherwise only the tool icon will be displayed.
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Figure 1-18  The File Open dialog box

Tools
On choosing this button, a flyout will be displayed. The options available in this flyout are same 
as the options discussed in the Tools button of the Select Working Directory dialog box, except 
the All Versions and Show Instances options. These two options are discussed next. 
	
	 All Versions

This option, when chosen, displays all versions of an object file. In Creo Parametric, once 
a file is saved, its new version is generated with an extension that is incremented by 1. An 
object file is not copied on another object file but a new version of it is created. Therefore, 
every time you save an object using the Save option, a new version of it is created on the 
disk in the current working directory.

	
	 Show Instances
	 The Show Instances option, when chosen, displays all instances of the object file. Select 

the required file and then choose the Show Instances option from the Tools flyout; all the 
instances of the selected file will be displayed.

File name
In the File name edit box, you can enter the name of the existing object file that you want to open.

Type
The Type drop-down list contains the file formats of various modes available in 
Creo Parametric. It also contains many other file formats that can be imported in Creo Parametric. 
These file formats include IGES, SET, STEP, DWG/DWF, Medusa, Inventor, Parasolid, Rhino, 
and so on. 
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By default, the Creo Files option is selected in this drop-down list. As a result, you can open 
the files created in any mode of Creo Parametric. However, if you select a specific mode from 
this drop-down list, only the files of the corresponding mode will be displayed. For example, 
if you select Part from the drop-down list, then only the .prt files will be displayed. This makes 
the selection and opening of the files easy.

Preview
The Preview button is used to preview the model before opening it. On choosing this button, you 
can preview the selected model in the File Open dialog box. You can zoom, pan, and rotate the 
model in the preview. Also, you can change the appearance (shaded, wireframe, no hidden, and 
hidden line) of the model, switch the model between the orthographic and perspective views, 
change the orientation type (dynamic, anchored, delayed, velocity, fly through, and standard) 
of the model, set the number of frames per second, and refit the preview in the preview screen.

Note
Assembly files with the file extension .asm can also be previewed by using the Preview button. If you 
are not able to see preview of the assembly files in the Preview area, then choose the Refresh button 
on the upper right of the File Open dialog box to resize the assembly according to the Preview area.

There is no Command prompt in Creo Parametric. However, you are provided with prompts in the 
message area. Whenever you have to enter a numerical value or text, a message input window 
will be displayed in the message area. 

In Session
The In Session folder is available in the Common Folders on the upper left of the File Open 
dialog box. When you choose the In Session folder, all the object files that are in the current 
session will be displayed in the display area. The object files that you open in Creo Parametric 
in the current session are stored in its temporary memory. This temporary memory is stored 
in a folder named In Session. Once you exit Creo Parametric, the contents of this folder are 
deleted automatically. However, the original files are not removed from their actual location.

Erase
As discussed earlier, all files opened in a session of Creo Parametric are saved in the temporary 
memory. There are three options to erase objects in the temporary memory: Erase Current, 
Erase Not Displayed, and Erase Unused Model Reps. These options are available in the Manage 
Session flyout in the File menu. The options that are displayed in this flyout are discussed next.

Tip
Suppose you open an assembly that has a component named Nut. Close the assembly and now 
open another assembly that also has a component named Nut. Now, there are chances that the 
second assembly you choose to open may open with the Nut that was present in the previous 
assembly. This is because the component with the file named Nut was already present in the 
memory of Creo Parametric (in session).

To avoid such type of errors, you should erase the files in the current session of Creo Parametric 
before opening the next assembly.
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Erase Current					      
The Erase Current option is used to erase the file opened and displayed in the drawing area. 
On choosing this option, the Erase Confirm message box will be displayed, prompting you to 
confirm the erasing of the file, as shown in Figure 1-19.

Erase Not Displayed
The Erase option is used to delete the files stored in the temporary memory. To do so, choose 
File > Manage Session > Erase Not Displayed from the menu bar; the Erase Not Displayed 
dialog box will be displayed, as shown in Figure 1-20. The files that are not open in the current 
session will be displayed in this dialog box. Choose the OK button from this dialog box to 
remove these files.

Figure 1-19  The Erase Confirm 
message box

Figure 1-20  The Erase Not Displayed 
dialog box

Erase Unused Model Reps
This option is used to remove the unused simplified representations from the In Session folder. 
When you choose this option from the File menu, a message box will be displayed with the 
message that all the objects which were not displayed have been erased.

Delete
There are two options to delete files permanently from the hard disk. These options are available 
in the Manage File flyout in the File menu. The options in this flyout are discussed next.

Delete Old Versions
This option is used to delete all old versions of the current file. When you choose the Delete 
Old Versions option, the Delete Old Versions message box is displayed confirming to delete 
all old versions files. Choose Yes from the message box. All versions of that file will be deleted 
from the hard disk except the latest version.

Delete All Versions
This option is used to delete all versions including the current file from the hard disk. When 
you choose the All Versions option, a warning is displayed stating that performing this function 
can result in the loss of data. This option is chosen when the file is opened and is displayed in 
the drawing area.
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Note
If there are simplified representations in the memory, then OBJ ERASE menu will be displayed. 
Choose the Current Obj option if you want to delete object files only or you can choose the Simpfld 
Reps option if you want to delete the representations only.

Play Trail File
The Play Trail File option is used to recover data in case of a program crash or if you exit 
the session without saving the data. While working in Creo Parametric, a file called trail.txt is 
created in its default working directory (for example, C:\Users\Public\Documents). The file trail.
txt contains all the working steps used in the last session. 

Trail files are editable text (.txt) files. To retrieve the data, open the file trail.txt in Notepad, refer 
to Figure 1-21. If there is more than one such file in the directory, open the latest one and save 
this file by choosing File > Save As with another name like crash.txt and exit. 

Figure 1-21  The trail.txt file modified in Notepad

Now, restart Creo Parametric and choose the Play Trail File option from Manage Session. Select 
the file crash.txt from the Open dialog box and then choose the Open button; Creo Parametric 
will repeat every step you made in the last session and restore the data.

Save
The Save option is used to save the objects present in the In Session folder or an object 
in the drawing area. When you choose the Save option from the File menu or the Save 

button from the Quick Access toolbar, the Save Object dialog box will be displayed. Also, the 
name of the current object will be displayed in the Model Name edit box. Choose the OK button 
from the Save Object dialog box to save the object.

Save a Copy
The Save a Copy option is used to save a copy of the current object in the same working 
directory or in some other directory. When you choose this option from File > Save As, the 
Save a Copy dialog box will be displayed. Now, you need to specify the new name of the object 
file to be saved as a copy and the name of the target directory in the Save a Copy dialog box. 
You can browse through the directories and select the target directory. The file will be saved in 
the selected directory.
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Using this option, you can also export a file in other file formats such as Inventor file, pdf, ACIS, 
Wavefront file, and so on. After specifying the name of the new file and the target directory, 
choose the file format in which you want to export the file from the Type drop-down in the 
Save a Copy dialog box.

Save a Backup
The Save a Backup option in the Save As flyout is used to create a backup copy of an object 
file in the memory. When you choose this option, the Backup dialog box will be displayed, as 
shown in Figure 1-22. 

Figure 1-22  The Backup dialog box
In the Model Name edit box of the Backup dialog box, the name of the file for which you want 
to create a backup is displayed. In the Backup To edit box, the name of the directory is specified 
where the object will be saved as a backup. If you create the backup of an assembly or a drawing 
object, Creo Parametric will save all its dependent files in the specified directory. If you create 
the backup of a drawing file in a different directory, then the part file of the drawing will also be 
created automatically in the same directory where backup of the drawing file is created.

Rename				     	
The Rename option in the Manage File flyout of the File menu is used to rename the currently 
active object on the screen. To rename an object, choose this option; the Rename dialog box will 
be displayed, as shown in Figure 1-23. Specify the new name of the object in the New file name 
edit box and choose the OK button.	

Figure 1-23  The Rename dialog box
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MANAGING FILES
As discussed earlier, a new file is generated whenever you save an object. The number of files 
generated are directly proportional to the number of times you save that object. So, these files 
occupy a lot of disk space. The latest version of the file which is currently being used should 
be stored. Latest version refers to the highest number that is suffixed with the file name of that 
object. The rest of the files are old versions and should be deleted from the hard disk, if they 
are not required. 

Note
To save disk space, you should keep deleting the old versions of a file. This can be done by using 
the File > Manage File > Delete Old Versions option from the menu bar. 

MENU MANAGER
The Menu Manager consist of a cascading menu in which a set of menus and submenus are 
embedded. The display of the menus depends on the task chosen.

While using the Menu Manager, you need to choose the Done or Done Sel option to execute 
and complete the selected option. This is important when you are in the Drawing mode of Creo 
Parametric. If you are directly selecting one option after another, then it is easy to lose track of 
commands or options in the Menu Manager.

MODEL TREE					      
The Model Tree stores and displays all features in a chronicle. You can select any desired feature 
of a model or an assembly from the Model Tree and apply different operations on the selected 
feature. You can also select the feature by right-clicking on it; a shortcut menu will be displayed. 
Move the cursor on the shortcut menu and choose the required option from it by using the left 
mouse button.

When you create a new object file, the Model Tree appears and is

Figure 1-24  Partial view 
of the Model Tree 

attached to the drawing area by default, as shown in Figure 1-24. 
Therefore, the drawing area becomes small. You can hide the Model 
Tree by choosing the Show Navigator button available below the Model 
Tree. The Model Tree can slide in or slide out, thus increasing or 
decreasing the drawing area. It can also be stretched horizontally to 
cover the drawing area. 

Note
In Creo Parametric, most of the features are created using the 
Dashboard. The Dashboard is displayed below the Quick Access 
toolbar and it contains all the options to complete the related operations 
on the model.

Tip
Looking at the Model Tree, you can understand the method and approach used to create the 
model. Using the Model Tree, you can modify the features of a model. Generally, when you 
import a model in a different file format in Creo Parametric, the features of the model are not 
displayed in the Model Tree and therefore, you will not be able to modify it.
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UNDERSTANDING THE FUNCTIONS OF THE MOUSE 
BUTTONS
While working with Creo Parametric, it is important to understand the function of the three 
buttons of the mouse to make an efficient use of this device. The various combinations of the 
keys and three buttons of the mouse are listed below:

1.	 Figure 1-25 shows the functions of the left mouse button. The left mouse button is used to 
make a selection. Using CTRL+left mouse button, you can add or remove items from the 
selection set. 

2.	 Figure 1-26 shows the functions of the right mouse button. The right mouse button is used 
to invoke the shortcut menus and to query select the items. When you bring the cursor on 
an item, it is highlighted in green color. Now, if you hold the right mouse button, a shortcut 
menu is displayed. Choose the Pick From List option from the shortcut menu; the Pick 
From List dialog box will be displayed. You can make selections from this dialog box.

3.	 Figure 1-27 shows the functions of the middle mouse button in the 3D mode. The middle 
mouse button is used to spin the model in the drawing area and view it from different 
directions.

	 The CTRL+middle mouse button is used to dynamically zoom in and out the view. When 
you press and hold the CTRL+middle mouse button and move the cursor up, the view is 
reduced and you zoom out. When the mouse is moved down, the view is enlarged and you 
zoom in.

Figure 1-26  Functions of the right mouse buttonFigure 1-25  Functions of the left mouse button

	 When you use CTRL+middle mouse button and move the mouse horizontally, the model 
is rotated about a point that is specified as center.

	 The SHIFT+middle mouse button is used to pan the object on the screen.

4.	 Figure 1-28 shows the functions of the middle mouse button in the 2D mode (sketcher 
environment and Drawing mode). It is used to place dimensions in the drawing area. It is 
also used to confirm an option or to abort the creation of an entity. 
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Figure 1-27  Functions of the middle mouse 
button in the 3D mode

Figure 1-28  Functions of the middle mouse 
button in the Sketch mode

	 The middle mouse button is used to pan view in the Sketch mode and the Drawing mode.

Note
When you spin the model with the Spin Center button turned on, the model rotates about the spin 
center origin. If this button is turned off, then the model rotates about the specified point.

RIBBON
Before you start working on Creo Parametric, it is very important for you to understand the default 
Ribbon and tools in the main window. Figure 1-28 shows various default interface components 
in Creo Parametric. The Ribbon is composed of a series of groups, which are organized into 
tabs depending on their functionality. The groups in the Ribbon that initially appear on the 
screen are shown in Figure 1-29. You will notice that all the tools in the groups are not enabled. 
These tools will be enabled only after you create a part or open an existing file. However, the 
tools that are required for the current session are already enabled. As you proceed to enter one 
of the modes provided by Creo Parametric, you will notice that the tools required by that mode 
are enabled. Additionally, to make the designing easy and user-friendly, this software package 
provides you with a number of groups. Different modes of Creo Parametric display different 
groups. Some of the frequently used groups are shown in Figure 1-29.

Figure 1-29  Default interface components 
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TOOLBARS
In Creo Parametric, there are two toolbars, Quick Access and Graphics. The toolbar on the 
top of the window is called the Quick Access toolbar and the toolbar on the top of the drawing 
area is called the Graphics toolbar. 

Graphics Toolbar
The Graphics toolbar, shown in Figure 1-30, has twelve buttons by default. The first button 
is Refit, which is used to fit a model on the screen. The other buttons are Zoom In and Zoom 
Out, which are used to enlarge or diminish the model view, respectively. The Repaint button 
is used for repainting the screen, which helps in removing any temporary information from 
the drawing area. You can change the display style by using the Display Style drop-down.The 
Perspective View button toggles perspective view.  Using the Named Views drop-down, you 
can change the view.

Figure 1-30  The Graphics toolbar

The next drop-down is Datum Display Filters. Using the options in this drop-down, you can 
toggle the display of datums to on/off. You can toggle the display of annotations to on/off using 
the Annotation Display button. The last button in this toolbar is Spin Center, which is used to 
toggle the visibility of the spin center to on/off. 

File Menu
The File menu contains options shown in Figure 1-31. These options are used to create a new 
file, save a file, print the current file, or open an existing file. Various other options are also 
available in the menu to manage the current session and files. The Options tool is also available 
in the File menu. When you choose this tool, the Creo Parametric Options dialog box will be 
displayed. Using this dialog box, you can configure various parameters of Creo Parametric. You 
can also customize the Ribbon interface.

Customizing the Ribbon
To customize the Ribbon, choose Options from the File menu; the Creo Parametric Options 
dialog box will be displayed. Select the Customize > Ribbon option from the left area of 
the dialog box; the dialog box will be modified. Choose the New Group or New Tab option, 
depending on your requirement, from the New drop-down list; the new group or tab will be 
added in the list box on the right side of the dialog box. Now, choose the button to be added 
in the new group from the list box on the left side of dialog box and then choose the Adds 
selected item to the Ribbon option from the dialog box; the selected button will be added to 
the group, refer to Figure 1-32.
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Figure 1-31  The File menu

Figure 1-32  Customizing the Ribbon
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Creo Parametric Help
When you choose the Creo Parametric Help button, you are directed to support.ptc.com and 
the online Help page is displayed in your default browser. In this page, you can search for any 
help topic on Creo. The help database is accessible only to the users who have customer account 
with PTC.

Command Search 	  
The Command Search button is available at

Figure 1-33  The command search box

 
the top right corner of the program window. 

When you choose this button, the search box is 
displayed, refer to Figure 1-33. You need to enter 
the first few letters of the command to be searched 
in the box. When you enter the first letter in the 
search box, a list of commands starting from that 
letter will be displayed. You can invoke any command by selecting it from the list, or you can 
enter the next letter to refine your search. On moving the cursor on any of the commands in 
the list, the command will get highlighted in the application window, as shown in Figure 1-34. 
Also, the path of the command will be displayed below the cursor.

Figure 1-34  Command Search function 

PTC Learning Connector Button
The PTC Learning Connector button is used to access video tutorials provided by PTC. When 
you choose this button, the PTC Learning Connector separate window will be displayed, as 
shown in Figure 1-35. When you invoke any tool from the Ribbon, the corresponding tutorial 
will be displayed in the PTC Learning Connector window.
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Figure 1-35  Creo Parametric 5.0 screen with the PTC Learning Connector window

Note
If you want to change the predefined unit system, choose File > Prepare > Model Properties 
from the menu bar to display the Model Properties dialog box. In this dialog box, click on the 
change on the right of the Units option in the Materials head; the Units Manager dialog box 
will be displayed with the System of Units tab chosen. Next, select the desired unit system from the 
list box and then choose the Set button; the Changing Model Units message box will be displayed. 
Choose the OK button from the message box; the new unit system will be set and displayed with 
the red arrow on the left.

NAVIGATOR 			 
The navigator is present on the left of the drawing area and can slide

Figure 1-36  Partial view 
of the navigator

 
in or out of the drawing area. To make the navigator slide in or out, 
you need to select the Show Navigator button on the bottom left corner 
of the program window. A partial view of the navigator is shown in 
Figure 1-36. It has the following functions:

1.	 When you browse files using the navigator, the browser expands 
and the files in the selected folder are displayed in the browser.

2.	 When you open a model, the Model Tree is displayed in the 
navigation area. 

3.	 The buttons on the top of the navigator are used to display 
different items in the navigation area. The Model Tree button is 
used to display the Model Tree in the navigation area. This button 
is available only when a model is opened. The Folder Browser 
button is used to display the folders that are in the local system. 
The Favorites button is used to display the contents of the Personal 
Favorites folder. 

4.	 Any other location, if available on your system, can also be accessed 
by using the navigator.



Introduction to Creo Parametric 5.0                      		   1-27

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Creo Parametric BROWSER
The Creo Parametric browser is present on the right of the navigator. You can also stretch the 
browser window horizontally. When the Creo Parametric session starts, the browser is displayed 
on the screen. The browser has two tabs. The homepage is linked to ptc.partcommunity.com, by 
default, and the other tab is linked to www.3dmodelspace.com/ptc. You can add more tabs in it, 
switch between tabs, and view the browsing history similar to any other internet explorer. The 
main advantage of using this browser is that you can work on the Creo Parametric files and 
navigate through the browser, simultaneously. Figure 1-37 shows the browser with some part 
files displayed in it. You can also browse to the required folder, change the display of files to 
thumbnails for previewing the file, dynamically view the models in a pop-up window, or drag 
and drop the selected file into the Creo Parametric window. 

Figure 1-37  Creo Parametric browser 

The functions of the browser are listed next. 

1.	 It is used to preview the Creo Parametric files and browse the file system.

2.	 A Creo Parametric file can be opened by using the browser on double-clicking on it or 
by dragging it to the drawing area. When you open a file using the browser, the model is 
displayed on the screen and the browser is closed automatically.
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3.	 You can access the Creo Parametric user community site using the browser.

4.	 You can connect to your client’s computer and jointly work with them using the browser.

APPEARANCE GALLERY
A new library of appearances and real world materials has been added in Creo Parametric. You 
can also add shadows and reflections to the background of the model by using the appearance 
gallery. This is useful while rendering with a background image. This gives a realistic view to 
the model.

The Appearance Gallery button is available in the

Figure 1-38  Appearance Gallery

Appearance group of the View tab in the Ribbon. It is 
used to assign different colors to the model and change 
its appearances. To change the appearance of the model, 
click on the down arrow beside the Appearance Gallery 
button; a palette will be displayed, as shown in Figure 1-38. 
Select the required appearance from the palette; the Select 
box will be displayed. Select the entities from the drawing 
area whose appearance you want to change; the appearance 
of the entities will change. You can assign a desired 
appearance to the entire model or to the individual face 
of the model, or entire assembly or individual component 
of an assembly. Various areas and options in the palette 
are discussed next.

Search				     
This option is used for searching a specific appearance 
you need. To search an appearance, type a keyword related 
to the appearance to be searched in the Search text box 
and press ENTER; all the appearances matching with the 
keyword will be searched from all the system libraries and 
they will be displayed in the palette. For example, if you 
type glass in the text box, then ptc-glass will be displayed 
in the My Appearances area and the Glass library is 
displayed in the Library area.

View Options				     
You can set the display of the appearance icons in the palette by using the View Options flyout. 
These options will be available when you click on the button at the top-right corner of the palette. 
The icons can be displayed as small thumbnails, large thumbnails, names and thumbnails, or 
only names. To do so, invoke the View Options flyout and then choose the required option 
from it. Choose Rendered Samples from the flyout to view the rendered icons of appearances. 
In this flyout, the Show Tooltips check box is selected by default. As a result, tooltips are always 
displayed for appearances.
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Clear Appearance
This option is used to remove the selected appearance from the model. To do so, select the 
appearance and then choose this option. Alternatively, first choose this option and then select 
the appearance to be removed from the model.

To remove all appearances assigned to a model, click on the black arrow displayed besides the 
Clear Appearance button; a flyout will be displayed. Next, choose the Clear All Appearances 
option from this flyout.

My Appearance
The My Appearance area displays all appearances stored in the startup directory. You can 
also add new appearances to the palette, edit the existing appearance, or delete the selected 
appearance in the Appearance area. To do so, right-click on the appearance icon and then 
choose the required option from the shortcut menu displayed. Note that you cannot delete the 
active appearance.

Model
The Model area consists of the appearances stored and

Figure 1-39  The Appearance Editor

used in an active model. You can edit the selected 
appearance, add new appearances, or select the objects to 
apply the selected appearance by using the shortcut menu 
as discussed in the My Appearance area.

Library					            
This area displays the predefined appearances in the 
current library. The library contains appearances from 
the System library and the Photolux library. Appearances 
in the library are grouped in various classes such as 
metals, glass, wood, and so on, based on their similar 
characteristics. The name of the current library is displayed 
on the right of the Library head. To assign appearances 
from other libraries, click on the library name; a flyout 
will be displayed with a tree list of classes and libraries. 
Browse through the tree and select the required library; all 
appearances in the selected library will be listed. From the 
list displayed, you can assign an appearance to the model 
as well as create a new appearance, as discussed earlier.

More Appearances		
Choose the More Appearances button from the 
Appearance Gallery; the Appearance Editor will be 
displayed, as shown in Figure 1-39. The Appearance 
Editor provides options for editing the appearance as well 
as for advanced rendering, thereby providing much more 
realistic images. 
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Using the Appearance Editor, you can edit the name, description, and keywords of the selected 
appearance, except the default one. The advanced options are given under the tabs of this dialog 
box. The Properties tab provides various classes and sub-classes of appearances. By default, 
Generic is selected in the Class drop-down list. However, you can select the required class 
and their sub-classes. Also, the properties related to selected class such as color, illumination, 
reflection, transparency, glossiness, and so on are displayed in the Properties area. These 
properties can be modified by adjusting the sliders given next to them. 

You can use the Texture tab to define and apply texture such as wood, fabrics, metals, and so 
on to the model. You can preview the changes made to the model on changing the settings in 
the Appearance Editor.

Edit Model Appearances
On choosing the Edit Model Appearances button; the Model Appearance Editor will be 
displayed. In this editor, all appearances used in the model will be displayed along with their 
properties. The Model Appearance Editor is same as the Appearances Editor. Using this editor, 
you can modify the properties such as color, texture, shine, and gloss of the model. 

Appearances Manager
Choose this button to display the Appearances Manager window. The Appearances Manager 
window displays two panels. The left panel displays the palette with appearances and libraries 
and the right panel displays the editor with the properties of the active appearance. You can 
set the required values in the Appearances palette and the Appearances Editor. Also, you can 
open an existing library file and add and save your own textured file. 

RENDERING IN Creo Parametric
Rendering is a process of generating two-dimensional image of a three-dimensional scene or an 
object to make it more realistic. A rendered image makes it easier to visualize the shape and size 
of 3D object as compared to a wireframe or a shaded image. Rendering also helps you express 
your design intent to other people. You need to alter environments, lights, textures, and so on to 
get a high quality rendered image. Generally, the rendering process includes the following stages:

Loading a File
The first step is to load the solid model or the assembly to be rendered.

Applying Appearances 
Next step is to apply the appearances to the model. You can do so by using the Appearance 
Gallery, which has already been discussed.

Applying Scenes 
After applying the appearances, you need to apply scenes to the model. Scenes are predefined 
render settings that include lights, rooms, and environmental effects. To set scenes, choose 
the Photo-Realistic Rendering tool from the Rendering group of the Applications tab; the 
Photo-Realistic Render tab will be invoked. Next, choose the Scene tool from the Project group 
of the Photo-Realistic Render tab; the Scenes slide-down panel will be displayed. In the panel, 
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choose the Edit Scene option to invoke the Scene Editor dialog box, as shown in Figure 1-40. 
Using this window, you can apply the predefined settings, edit the current settings, create new 
scenes, copy a scene, and save the scenes for future use. To apply a scene to the model, double-click 
on the required scene from the Gallery area of the Scene Editor dialog box.

Figure 1-40  The Scene Editor dialog box

Modifying the Scene Environment
The environment of a scene can be modified using the options available in the Environment 
tab of the Scene Editor dialog box. You can also apply shadows and reflections to the model 
by selecting the Shadows and Reflection check boxes in the Ground Effects area of the Scene 
Editor dialog box.

Applying Lights
The next step is to apply the lighting effects on the model. By adding lights to the model, you 
can illuminate the scene from various angles. To add lights, choose the Lights tab from the 
Scenes Editor dialog box. You can create a light source as well as position it by using the options 
in the Lights tab. 
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Shadows are enabled as soon as you add lights to the model. The direction of shadows cast by a 
light bulb, spot light, skylight, or environment type of lights is towards the center of the room.

Adding Effects
Finally, you can add the surrounding effects such as ray bounces, indirect bounces, shadow 
quality, caustics, illumination, and self shadows. To do so, choose the Real-Time Settings option 
from the Real-Time drop-down of the Photo-Realistic Render tab; the Real-Time Rendering 
Settings dialog box will be displayed. Using the options available in this dialog box, you can 
add desired effects to the model. 

Setting the Perspective View
You can set the perspective view of the model that can be used for rendering the model. To do so, 
choose the Perspective view button from the Project group in the Photo-Realistic Render tab. 

To modify the settings of the perspective view, invoke the View dialog box by choosing the 
Reorient tool from the Saved Orientations flyout of the Graphics toolbar. Next, choose the 
Perspective tab in the dialog box and specify the settings for the perspective view. 

Rendering the Model
The last step is to render the model. To render the model, choose the Render to File button 
from the Render Output group in the Photo-Realistic Render tab; the Render dialog box will 
be displayed. Set the required rendering options in this window and choose the Render button 
to start the rendering process. If required, you can modify the render settings and render the 
model again. 

Note
You can toggle between the display of the rendering effects on the model by choosing the Real-Time 
Rendering button from the Real-Time group of the Photo-Realistic Render tab. 

COLOR SCHEME USED IN THIS BOOK
Creo Parametric allows you to use various color schemes for the background screen color and 
for displaying the entities on the screen. This textbook will follow the white background of 
Creo Parametric environment for the purpose of printing. However, for better understanding 
and clear visualization at various places, you can follow other color schemes too. To change 
the color scheme of the background screen, choose File > Options from the menu bar; the 
Creo Parametric Options dialog box will be displayed. Select the System Appearance category 
from the left pane of this window. Next, choose the Light (Previous Creo Default) option from 
the System Colors drop-down list; different object names will be displayed with color drop-downs 
adjacent to them, refer to Figure 1-41. Next, choose the OK button to apply the color scheme. 
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Figure 1-41  The System Colors category in the Creo Parametric Options dialog box

Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.    Which one is the default theme of Creo Parametric?

        a) Light (Previous Creo Default)        b) Default
        c) Black on White                               d) White on Black

2.    For which of the following purposes is the Play Trail File option is used?

        a) Recover Data                                  b) Play Tutorial Video
        c) Browse Files                                    c) None of the above

3.	 You can change the system appearance from the__________ dialog box.

4.	 The __________ stores and display all features of a current model.

5.	 There is a bidirectional associativity between all modes of Creo Parametric. (T/F)

6.	 In Creo Parametric, you can use the SHIFT+middle mouse button to pan the object on the 
screen. (T/F)
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Answers to Self-Evaluation Test
1. b, 2. a, 3. Creo Parametric Options, 4. Model Tree, 5. T, 6. T


