
Chapter 1

Introduction to 
AutoCAD Plant 3D

 Learning Objectives 
After completing this chapter, you will be able to:
• Start AutoCAD Plant 3D
•	Work with the components of the initial screen of AutoCAD Plant 3D
•	Work with the PROJECT MANAGER
•	Invoke AutoCAD commands from the keyboard, menus, shortcut menus, TOOL PALETTES, 

and Ribbon
•	Work with the components of dialog boxes in AutoCAD Plant 3D
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INTRODUCTION TO AutoCAD Plant 3D 2020
AutoCAD Plant 3D is a purpose-built plant design software. This software is used to design 
and document process plants. AutoCAD Plant 3D contains various predefined shapes of plant 
components. These predefined shapes, which are solid models, carry the intelligence of AutoCAD 
Plant 3D drawings. While installing AutoCAD Plant 3D, the standard specifications and part 
catalogs related to piping are also installed.

AutoCAD Plant 3D comes along with AutoCAD P&ID which is used to create piping and 
instrumentation drawings. AutoCAD P&ID contains various piping and instrumentation symbols. 
These symbols, most of which are AutoCAD blocks with attributes, carry the intelligence of 
AutoCAD P&ID drawings.

STARTING AutoCAD Plant 3D				       
When you install AutoCAD Plant 3D 2020, its icon is created and displayed on the desktop. You 
can launch the application by double-clicking on that icon. The interface screen of AutoCAD 
Plant 3D is shown in Figure 1-1.

Start Tab									              
In the initial interface of Plant 3D, the Start tab remains chosen by default, refer to Figure 1-1. 
This tab consists of three pages, CREATE, GET STARTED, and LEARN which contain options 
to access drawing template files, recently opened drawings, sheet sets, and various other learning 
options. These pages and their respective options are discussed next.

Figure 1-1  The interface of AutoCAD Plant 3D 2020

CREATE
This page is displayed by default whenever you launch AutoCAD Plant 3D. It contains four 
areas that are discussed next.
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Project Area
This area of the CREATE page contains two buttons, Open and New. You can open any 
existing project using the Open button and start a new project by using the New button. 
When you choose the Open button, the Open dialog box will be displayed. You can either 
specify the name of the project that you want to open in the File Name edit box or simply 
select it from the list displayed under the Name area. 

When you choose the New button, the Project Setup Wizard will be displayed. This wizard 
contains six pages that guide you towards starting a new project.

Get Started With Area
This area contains two panes, P&ID and Plant 3D, refer to Figure 1-1. When you click on 
the P&ID pane, you will move to the GET STARTED page. In the GET STARTED page, 
you can choose the Learn More button to access the learning options related to P&ID. On 
choosing the Learn More button, you will be directed to the AutoCAD P&ID page where 
you can access the learning resources provided by Autodesk.

Similarly, you can access the learning resources related to Plant 3D by clicking on the Plant 
3D pane and then choosing the Learn More button from the GET STARTED page.

Recent Documents 
This area of the CREATE page lists the project files that you have recently worked on. You 
can access these files by simply clicking on the file name displayed in this area.  

Connect 
This area provides you with the options to connect with the Autodesk community. Note that 
you should be logged into your A360 account to access the options in this area.

GET STARTED
This page is displayed by clicking on GET STARTED in the Start tab. This page provides 
information about various features of AutoCAD Plant 3D, refer to Figure 1-2.

Figure 1-2  The GET STARTED page selected
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LEARN 
This page is displayed by clicking on LEARN in the Start tab and it has four areas namely What’s 
New, Getting Started Videos, Learning Tips, and Online Resources, refer to Figure 1-2(a). 
In the What’s New area, you can watch a video to know about the key enhancements in this 
new release. In the Getting Started Videos area, you can watch the videos that will help you in 
getting started with the software. You can also get the learning tips and other online resources 
by using the options under Learning Tips, and Online Resources areas.

Figure 1-2(a)  The LEARN page selected

WORKING ON A PROJECT
A piping design project includes the drawing and other forms of data. These data sources are 
inter-related in a project. The drawing data includes P&IDs, 3D models, Isometric drawings, 
and Orthographic drawings. The other data forms include catalogs and specs for piping, process 
data, and so on. Figure 1-3 shows a project flow diagram. 
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Figure 1-3  A project flow diagram

AutoCAD Plant 3D USER INTERFACE
The AutoCAD Plant 3D interface consists of the drawing area, command window, PROJECT 
MANAGER, menu bar, toolbars, Status Bar, and so on, refer to Figure 1-4. These components 
are discussed next.

Figure 1-4  Interface screen of AutoCAD Plant 3D
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Drawing Area
The drawing area covers the major portion of the screen. In this area, you can draw objects 
and use the commands. To draw objects, you need to define the coordinate points which can be 
done by using the pointing device. The position of the pointing device is represented on the 
screen by the cursor. The drawing area also has the standard Windows buttons such as Close, 
Minimize, and Restore Down at the top right corner. These buttons have the same functions 
as in other standard window.

Command Window
The command window located at the bottom of the drawing area has the command prompt 
where you can enter the commands. It also displays the subsequent prompt sequences and the 
messages. You can change the size of the window by placing the cursor on the top edge (double 
line bar known as the grab bar) and then dragging it. This way you can increase its size to see 
all the previous commands you have used.

PROJECT MANAGER
  Ribbon:  Project > Project Manager drop-down > Project Manager	  
  Command:  PROJECTMANAGER						   

PROJECT MANAGER is used to access and manage all the drawings in a project. In 
addition to that, you can configure project settings, and export and import data from 
the PROJECT MANAGER. Figure 1-5 shows the PROJECT MANAGER. When you 

launch AutoCAD Plant 3D for the first time, the PROJECT MANAGER is displayed on the left 
in the interface, refer to Figure 1-4. There are three tabs in the PROJECT MANAGER: Source 
Files, Orthographic DWG, and Isometric DWG. You can create and access the P&ID and Plant 
3D drawing files using the Source Files tab. The other two tabs can be used to create and access 
the orthographic and isometric drawings.
						    
The areas in the PROJECT MANAGER and the options available

Figure 1-5  The PROJECT 
MANAGER

 
in them are discussed next.

Current Project Area
When you open the PROJECT MANAGER for the first time, the 
Source Files tab is chosen by default and the Default Project is 
displayed in this area, refer to Figure 1-5. Using the options in the 
drop-down list in the Current Project area, you can open existing 
projects, collaboration projects, access files from Vault, start a new 
project, and access the sample project. The Publish button in this 
area enables you to publish the drawing set to a DWF, DWFx, or 
PDF format. The Reports drop-down next to the Publish button 
is used for displaying a list of reports that you can run. Using the 
options in this drop-down, you can view, modify, import, and export 
data related to a project.  

Project Area
All the drawing files related to a project are organized under their 
respective nodes in this area.  For instance, if you create a project 
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with the name CADCIM, a node named CADCIM will be created as a project node along with 
four sub-nodes: P&ID Drawings, Plant 3D Drawings, Pipe Specs, and Related Files. These 
sub-nodes contain respective project files. For example, any P&ID file related to the CADCIM 
project will be displayed under the P&ID Drawings sub-node of the CADCIM node in the 
Project area. The piping specifications which are being used in the project will be displayed 
under the Pipe Specs sub-node of the CADCIM node. 

The toolbar available in this area contains four buttons which are discussed next.

Hide/Show search box
This toggle button is used to show or hide a search box below the Project Area. This search 
box can be used to search a drawing in the project. To search a drawing, type its name in 
the search box to display the results under the linked node.

New Drawing
When you choose this button, the New DWG dialog box will be displayed. Using this dialog 
box you can create a new drawing and add it to the project tree.

Copy Drawing to Project 
When you choose this button, the Select Drawings to Copy to Project dialog box will be 
displayed. Using this dialog box, you can select one or more files to copy in the project.

Refresh DWG Status 
This button enables you to know if any of the drawings or the files in the project are being 
edited by the other user.

Details Area
This area lists all the information related to the project such as project path, project name and 
its description.

The data used in a project is arranged in folders that are created while creating a project. For 
example, if you create a project with the name CADCIM, a folder named CADCIM will be created 
as the project folder. Also, a series of the sub-folders will be created in the project folder that 
contains data related to the project, refer to Figure 1-6.   

DATA MANAGER
  Ribbon:  Project > Data Manager	  
  Command:  DATAMANAGER		

When you create a P&ID or a Plant 3D model, each and every part of the drawing is 
assigned with some properties. These properties can be accessed through the DATA 
MANAGER. Using the DATA MANAGER, you can view, import, export, and create 
reports from the project data. Choose the Data Manager button from the Project panel 
to display the DATA MANAGER. Figure 1-7 shows a partial view of the DATA 
MANAGER.
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Figure 1-6  Sub-folders of the project folder Figure 1-7  Partial view of the DATA MANAGER

Navigation Bar
The Navigation Bar is displayed in the drawing area and contains various

Figure 1-8  The tools in 
the Navigation Bar

navigation tools which are grouped together, refer to Figure 1-8. You 
can toggle on/off the visibility of this bar by using the Navigation Bar 
toggle button available in the Viewport Tools palette of the View tab 
of the Ribbon. These tools are discussed next.

SteeringWheels						    
The SteeringWheels allow you to access different 2D and 3D navigation 
tools. SteeringWheels are divided into different sections known as 
wedges. Each wedge on a wheel represents a single navigation tool. You 
can pan, zoom, or rewind the current view of a scene in different ways 
using the SteeringWheels.

Pan Tool
This tool allows you to adjust the viewpoint of a drawing. To adjust the viewpoint, choose this 
tool, press and hold the left mouse button, and then drag it in the drawing area. You can exit 
this command by pressing ESC.

Zoom Tools
The zoom tools are used to adjust the view of the drawing on the screen without affecting the 
actual size of the object.

Orbit Tools
The orbit tools are used to rotate the view in the 3D space.

ShowMotion Tool
This tool is used to capture different views in a sequence and animate them when required.

ViewCube
ViewCube is available at the top right corner of the drawing area and is used to switch between 
the standard and isometric views or roll back to the current view. 
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In-canvas Viewport Controls
In-canvas Viewport Controls are available at the top left corner of the drawing screen. It enables 
you to change the view, the visual style, as well as the viewport.

Status Bar
The bar displayed at the bottom of the screen is called Status Bar. It contains useful information 
and buttons, refer to Figure 1-9, which makes it easy to change the status of some of the AutoCAD 
functions. You can toggle between the on and off states of most of these functions by clicking 
on them.

 Figure 1-9  The Status Bar

Tray Settings
You can control the display of icons and notifications in the tray at the right end of the Status 
Bar by making appropriate settings in the Tray Settings dialog box. To invoke the Tray Settings 
dialog box, enter TRAYSETTINGS in the command prompt and press ENTER. The Tray 
Settings dialog box is shown in Figure 1-10.

Figure 1-10  The Tray Settings dialog box

Clean Screen
The Clean Screen button is available at the lower right corner of the screen. This button, when 
chosen, displays an expanded view of the drawing area by hiding all the toolbars except the 
command window, Status Bar, and menu bar. The expanded view of the drawing area can also 
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be displayed by choosing View > Clean Screen from the menu bar or by using the CTRL+0 
keys. You can choose the Clean Screen button again to restore the previous display state.

Customization
You can hide the display of some of the buttons in the Status Bar. To do so, click on the 
Customization button available at the lower right corner of the screen; a menu will be displayed. 
In this menu, clear the check mark next to the names of the buttons you need to hide.

Plot/Publish Details Report Available 
This icon is displayed when some plotting or publishing activity is performed in the 
background. When you click on this icon, the Plot and Publish Details dialog box, which 
provides the details about the plotting and publishing activities, will be displayed. You 

can copy this report to the clipboard by choosing the Copy to Clipboard button from the dialog 
box.

Manage Xrefs
The Manage Xrefs icon is displayed whenever an external reference drawing is attached 
to the selected drawing. This icon displays an alert message whenever the external referenced 

drawing needs to be reloaded. To find detailed information regarding the status of each Xref 
in the drawing and the relation between various Xrefs, click on the Manage Xrefs icon; the 
EXTERNAL REFERENCES palette will be displayed. 

PROPERTIES Palette
The PROPERTIES palette is used to set the current properties and to change the general 
properties of the selected objects. The PROPERTIES palette is displayed on right-clicking on 
an object and then choosing the Properties option from the shortcut menu displayed. If you 
right-click on the PROPERTIES palette, a shortcut menu will be displayed. You can choose 
Allow Docking from this menu to dock or hide the palette. 

In AutoCAD Plant 3D, the PROPERTIES palette displays an additional section for the properties 
specific to the selected object, refer to Figure 1-11. For example, if you select a Plant 3D object, 
the Plant 3D section will be displayed in the PROPERTIES palette with the 3D properties of 
the object. The list of properties displayed varies depending on the object selected. For example, 
if you select pipe support, the dimensions of the selected geometry will be displayed in the Part 
Geometry section, refer to Figure 1-12. In this section, you can edit the geometry of the selected 
pipe support. Similarly, if you select a valve from a Plant 3D model, properties of the valve will 
be displayed. You can change the valve actuator using the PROPERTIES palette.
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Figure 1-11  The additional section 
displayed for a Plant 3D object

Figure 1-12  The dimensions of the pipe support 
displayed in the PROPERTIES palette

DIFFERENT WORKSPACES IN AutoCAD PLANT 3D
A workspace is defined as a customized arrangement of Ribbon, toolbars, menus, and window 
palettes in the AutoCAD environment. In AutoCAD Plant 3D, there are different workspaces to 
create a P&ID and Plant 3D model. Some of them are 3D Piping, P&ID PIP, P&ID ISO, P&ID 
ISA, P&ID DIN, and P&ID JIS-ISO.

You will notice that there are different workspaces for creating a P&ID. These workspaces are 
based on different standards. When you invoke a P&ID workspace of a particular standard, the 
tool palette will display the symbols related to that standard.

You can select any of the predefined workspaces from the Workspace drop-down list available 
in the title bar located next to the Quick Access Toolbar, refer to Figure 1-13. This drop-down 
list does not appear by default in the title bar. To make this drop-down list available, click on 
the down arrow in the title bar, a flyout will be displayed. Next, choose the Workspace option 
from the flyout displayed. You can also set the workspace from the flyout displayed on choosing 
the Workspace Switching button in the Status Bar, refer to Figure 1-14.
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Figure 1-13  The predefined 
workspaces

Figure 1-14  The flyout displayed on choosing 
the Workspace Switching button

GRIPS 
Grips provide a convenient and quick means of editing objects. Grips are displayed on the key 
points of an object when the object is selected. There are different grips available in AutoCAD 
Plant 3D. The following table shows the grip symbols, their names, and their usage.

Grip Symbol Grip Name Usage

Continuation grip It is used to start or continue routing a 
pipe.

Substitution grip It is used to substitute a component.

Add Nozzle grip You can add a nozzle to an equipment 
using this grip.

Elevation grip
You can change the elevation of a pipe 
using this grip.

Edit nozzle grip It is used to modify a nozzle.

Rotation grip It is used to rotate a valve or fitting.

Flip grip It is used to flip a valve or a fitting.
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Connection grip
It is displayed when a schematic line 
is connected to a component or an 
equipment.

Stretch grip
It is displayed at the midpoint of a 
schematic line. You can move the 
schematic line using this grip.

Endline grip It is used to increase or decrease the 
length of a schematic line.

Flip grip (in P&ID) It is used to change the direction of the 
schematic line.

Gap grip
It is displayed when a gap is added on 
the schematic line. You can increase or 
decrease the gap using this grip.

INVOKING COMMANDS IN AutoCAD Plant 3D
When you are in the drawing area, you need to invoke AutoCAD Plant 3D commands to perform 
any operation. For example, to draw a line, first you need to invoke the LINE command and 
then define the start point and the endpoint of the line. Similarly, if you want to erase objects, 
you must invoke the ERASE command and then select the objects for erasing.  In AutoCAD 
Plant 3D, you can invoke the commands using different methods which are discussed next.

Invoking Commands Using Command Prompt
You can invoke any AutoCAD Plant 3D command using the keyboard by typing the command 
name at the command prompt and then pressing the ENTER key. As you type the first letter of 
a command, AutoCAD Plant 3D displays all available commands starting with the letter typed. 
You can also use the Dynamic Input button to directly enter the command in the Pointer Input 
box. The Pointer Input box is a small box displayed on the right of the cursor, as shown in 
Figure 1-15. However, if the cursor is currently placed on any toolbar

Figure 1-15  The Pointer 
Input box displayed when the 
Dynamic Input is on

or menu bar, or if the Dynamic Input is turned off, the command 
can be entered only through the command prompt. The following 
example shows how to invoke the LINE command using the 
keyboard:

Command: LINE or L    (L is command alias) 

Invoking Commands Using Ribbon
In AutoCAD Plant 3D, you can also invoke a tool from the Ribbon. 
In the Ribbon, the tools for creating pipes, equipment, supports, and the other Plant 3D 
components are available in different panels instead of being spread out in the entire drawing 
area in different toolbars and menus, refer to Figure 1-16. 
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Figure 1-16  The Ribbon for the 3D Piping workspace

In AutoCAD Plant 3D, there are different tabs and panels for performing different tasks such as 
creating a P&ID, isometric drawings, orthographic drawing, and so on. These are discussed next.

Home Tab of the P&ID Workspace
The Home tab of the P&ID workspace contains tools that are used to create a P&ID. The Home 
tab of P&ID workspace is shown in Figure 1-17.

Figure 1-17  The Home tab of the P&ID workspace

Home Tab of the 3D Piping Workspace
This is one of the most important tabs provided in the 3D Piping workspace. This tab provides 
all the tools which are used to create 3D pipings, equipments, and pipe supports. The Home 
tab of the 3D Piping workspace is shown in Figure 1-18.

Figure 1-18  The Home tab of the 3D Piping workspace

Isos Tab
The tools in the Isos tab are used to generate isometric drawings. The Isos tab is shown in 
Figure 1-19.

Figure 1-19  The Isos tab

Structure Tab
The tools in the Structure tab are used to create and modify structures. The Structure tab is 
shown in Figure 1-20.

Figure 1-20  The Structure tab
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Ortho View Tab
The tools in the Ortho View tab are used to annotate and dimension a view. Also, you can create 
adjacent views and locate the view components in a 3D Model. The Ortho View tab is shown in 
Figure 1-21. Note that the Ortho View tab will be displayed only when you create orthographic 
drawings. The method of creating orthographic drawings will be discussed in later chapters.

Figure 1-21  The Ortho View tab

Ortho Editor Tab
The tools in the Ortho Editor tab are used to create orthographic views. The Ortho Editor tab 
is shown in Figure 1-22. You will learn more about Ortho Editor tab in later chapters.

Figure 1-22  The Ortho Editor tab

TOOL PALETTES
AutoCAD Plant 3D has provided different tool palettes as an easy and convenient way of placing 
symbols and 3D parts in the current drawing. The TOOL PALETTES display items based on the 
workspace in which you are currently working. The TOOL PALETTES in different workspaces 
are discussed next.

TOOL PALETTES in P&ID PIP Workspace
The TOOL PALETTE - P&ID PIP contains various tabs such as Lines, Equipment, Valves 
and so on, refer to Figure 1-23. The symbols in each tab are grouped into different areas. You 
can also create more custom symbols and add them to the TOOL PALETTES. You can change 
the Tool Palette by choosing the Properties button and then selecting the required Tool Palette 
from the flyout displayed.

TOOL PALETTES in 3D Piping Workspace
In the 3D Piping workspace, the TOOL PALETTES contains three tabs: Dynamic Pipe Spec, 
Pipe Supports Spec, and Instrumentation Spec, refer to Figure 1-24. The Dynamic Pipe Spec tab 
contains the piping components from the selected specification. You can add more components 
to the Dynamic Pipe Spec tab by invoking the Spec Viewer. You will learn more about the Spec 
Viewer in the later chapters. In addition, you can add a customized part to the Tool Palettes. 
Also, you can change the components displayed in this tab by selecting a different specification. 
The Pipe Supports Spec tab contains pipe supports. In this tab, you can dynamically select a 
support and place it in the 3D model. The Instrumentation Spec tab contains various measuring 
instruments which can be installed on the pipings as per the requirement.
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Figure 1-23  P&ID Tool Palettes Figure 1-24  3D Piping Tool Palettes

Application Menu
The Application Menu is available at the top left corner of the AutoCAD Plant 3D window. It 
contains some of the tools that are available in the Standard toolbar. Click on the Application Menu 
to display the tools, as shown in Figure 1-25. 

Figure 1-25  The Application Menu



Introduction to AutoCAD Plant 3D                                                                                                             1-17

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

You can search a command using the search field on the top of the Application Menu. To search 
a tool, enter the complete or partial name of the command in the search field; the possible 
tool list will be displayed. If you click on a tool from the list, the corresponding command will 
get activated. By default, the Recent Documents button is chosen in the Application Menu. 
Therefore, the recently opened drawings will be listed. If you have opened multiple drawing 
files, choose the Open Documents button; the documents that are opened will be listed in the 
Application Menu. To set the preferences of the file, choose the Options button available at 
the bottom of the Application Menu. To exit AutoCAD Plant 3D, choose the Exit Autodesk 
AutoCAD Plant 3D 2020 button next to the Options button. 

Menu Bar
You can also invoke commands from the Menu bar. Menu bar is not displayed by default in 
AutoCAD Plant 3D. To display the Menu bar, click on the down arrow in the Quick Access 
Toolbar; a flyout will be displayed. Choose the Show Menu Bar option from it; the Menu bar 
will be displayed. As you move the cursor over the Menu bar, different titles get highlighted. You 
can click on the desired item to display a menu. Now, you can invoke a command by left-clicking 
on it in the menu. An arrow displayed on the right side of some of the menu items indicates 
that they have a cascading menu. The cascading menu provides various options to execute the 
same AutoCAD Plant 3D command.

Shortcut Menu
AutoCAD Plant 3D provides shortcut menus to invoke the recently used tools easily. These 
shortcut menus are context-specific which means that the tools available in them are 
dependent on the place/object for which they are displayed. A shortcut menu is invoked by 
right-clicking in the drawing area. It generally contains an option to select the previously invoked 
tool again apart from the commonly used tools, refer to Figure 1-26.

Figure 1-26  Partial view of the shortcut menu with the recently used commands

If you right-click in the drawing area while a command is active, a shortcut menu with the options 
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of that particular command will be displayed. Figure 1-27 shows the shortcut menu when the 
Route Pipe tool is active.				  

You can also right-click on the command window to display the shortcut

Figure 1-27  Shortcut 
menu when the Route 
Pipe tool is active

 
menu. This menu displays the input setting options and also some 
of the Windows options such as Copy and Paste, refer to Figure 1-28. 
The commands and their prompt entries are displayed in the History 
window (previous command lines not visible) and can be selected, 
copied, and pasted in the command line using the shortcut menu. 
As you press the up arrow key, the previously entered commands 
are displayed in the command window. Once the desired command 
is displayed at the command prompt, you can execute it by simply 
pressing the ENTER key. 

You can also copy and edit any previously invoked command by locating 
it in the History window and then selecting the lines. After selecting 
the desired command lines from the History window, right-click to 
display a shortcut menu. Choose Copy from the menu and then paste 
the selected lines at the end of the command line.

You can right-click on the coordinate display area of the Status Bar to 
display the shortcut menu. This menu contains the options to modify the 
display of coordinates, as shown in Figure 1-29. You can also right-click 
on any of the toolbars to display the shortcut menu from where you 
can choose any toolbar to be displayed. 

Figure 1-29  Shortcut menu displayed by 
right-clicking on coordinate display area

Figure 1-28  Shortcut menu displayed by right-clicking 
on command window

AutoCAD Plant 3D DIALOG BOXES
On invoking certain commands in AutoCAD Plant 3D, the related dialog boxes are 
displayed. When you choose an item in the Menu bar which displays three dots along with its 
name [...], a dialog box is displayed. For example, when Options... option is chosen from the 
Tools menu, the Options dialog box is displayed. A dialog box contains a number of components 
like the dialog label, radio buttons, text or edit boxes, check boxes, slider, image boxes, and 
command buttons. Some of the components in a dialog box are shown in Figure 1-30.
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Figure 1-30  Components of a dialog box

The title bar displays the name of the dialog box. The tabs have different sections that contain 
various groups of related options under them. The check boxes are toggle options for making 
a particular option available or unavailable. When you click on an option which has a down 
arrow attached to its icon and a list of options is displayed, then it is termed as drop-down list. 
You can select options using the radio buttons. Note that only one button can be selected at a 
time from a section. The text box is an area where you can enter a text such as a file name. It is 
also called an edit box, because you can make any change to the text entered. In some dialog 
boxes, you will find the [...] button, which displays another related dialog box. There are certain 
buttons such as the OK, Cancel, and Help buttons that are also displayed at the bottom of the 
dialog box. The button with a dark border is the default button.

CREATING BACKUP FILES
If the drawing file already exists and you use Save or Save As tool to update the current drawing, 
AutoCAD Plant 3D creates a backup file. AutoCAD Plant 3D takes the previous copy of the drawing 
and changes it from the file type .dwg to .bak, and the updated drawing is saved as a drawing file 
with the .dwg extension. For example, if the name of the drawing is myproj.dwg, AutoCAD Plant 
3D will change it to myproj.bak and save the current drawing as myproj.dwg.

Converting Auto-saved and Backup Files into AutoCAD Format 
Sometimes, you may need to convert the auto-saved and backup files to AutoCAD format. To change 
the backup file into an AutoCAD format, open the folder in which you have saved the backup or 
the auto-saved drawing. Now, choose Options from the View tab; the Folder Options dialog box 
will be displayed. In this dialog box, choose the View tab and uncheck the Hide extensions for 
known file types check box under the Advanced settings area. Next, choose the OK button to 
exit the dialog box. Rename the auto-saved drawing or the backup file with a different name 
and also change the extension of the drawing from .sv$ or .bak to .dwg. After you rename the 
drawing, you will notice that the icon of the auto-saved drawing or the backup file is replaced 
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by the AutoCAD icon. This indicates that the auto-saved drawing or the backup file is converted 
to an AutoCAD Plant 3D drawing.

Using the Drawing Recovery Manager to Recover Files
The files that are saved automatically can also be retrieved by using the DRAWING RECOVERY 
MANAGER. You can open the DRAWING RECOVERY MANAGER by choosing Drawing 
Utilities > Open the Drawing Recovery Manager from the Application Menu or by entering 
DRAWINGRECOVERY at the command prompt.

If the automatic save operation is performed on a drawing and the system crashes accidentally, 
then next time when you run AutoCAD Plant 3D, the Drawing Recovery message box will be 
displayed, as shown in Figure 1-31. The message box informs you that the program unexpectedly 
crashed and you can open the most relevant backup file created by AutoCAD Plant 3D. Choose 
the Close button from the Drawing Recovery message box; the DRAWING RECOVERY 
MANAGER is displayed on the left in the drawing area, as shown in Figure 1-32. 

Figure 1-31  The Drawing Recovery message box Figure 1-32  The DRAWING 
RECOVERY MANAGER

The Backup Files rollout lists the original files, the backup files, and the automatically saved 
files. Select a file; its preview will be displayed in the Preview rollout. Also, the information 
corresponding to the selected file will be displayed in the Details rollout. To open a backup file, 
double-click on its name in the Backup Files rollout. Alternatively, right-click on the file name 
and then choose Open from the shortcut menu. It is recommended that you save the backup 
file at the desired location before you start working on it.

CLOSING A DRAWING
You can use the CLOSE command to close the current drawing file without actually quitting 
AutoCAD Plant 3D. If you choose Close > Current Drawing from the Application Menu or enter 
CLOSE at the command prompt, the current drawing file will be closed. If multiple drawing 
files are opened, choose Close > All Drawings from the Application Menu. If you have not 
saved the drawing after making the last changes to it and you invoke the CLOSE command, 
AutoCAD Plant 3D displays a message box that allows you to save the drawing before closing. 
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This dialog box gives you an option to discard the current drawing or the changes made to it. 
It also gives you an option to cancel the command. After closing the drawing, you are still in 
AutoCAD Plant 3D from where you can open a new or an already saved drawing file. You can 
also use the close button (X) corresponding to the drawing area to close the drawing. 

Note
You can close a drawing even if a command is active. 

OPENING A PROJECT DRAWING
You can open an existing drawing file that has been saved previously in a project. The drawings are 
located under the P&ID Drawings and Plant 3D Drawings nodes in the PROJECT MANAGER. 
To open a drawing, expand the respective drawings node and right-click to display a shortcut 
menu. Next, choose the Open option from the shortcut menu, refer to Figure 1-33; the drawing 
will open. Alternatively, double-click on the drawing in the PROJECT MANAGER to open it.

Figure 1-33  Opening a drawing from the PROJECT 
MANAGER

To view a drawing without altering it, you must choose the Open Read-Only option from the 
shortcut menu. In other words, choosing the read-only option protects the drawing file from 
being changed. AutoCAD Plant 3D does not prevent you from editing the drawing. But if you 
try to save the opened drawing with the original file name, AutoCAD Plant 3D warns you that 
the drawing file is write-protected. However, you can save the edited drawing to a file with a 
different file name using the SAVEAS command. This way you can preserve your drawing.

OPENING A DRAWING THAT IS NOT IN THE PROJECT
  Application Menu: Open > Drawing	 Quick Access Toolbar:  Open	  
  Menu Bar:  File > Open		  Command:   OPEN		

You can open a drawing file that does not exist in the currently opened project using the 
Select File dialog box. This dialog box is discussed next.
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Opening an Existing Drawing Using the Select File Dialog Box
If you are already in the drawing editor and you want to open a drawing file, choose the Open 
tool from the Quick Access Toolbar; the Select File dialog box will be displayed. Alternatively, 
invoke the OPEN command to display the Select File dialog box by using the command prompt, 
as shown in Figure 1-34. You can select the drawing to be opened using this dialog box. This 
dialog box is similar to the standard dialog boxes. You can choose the file you want to open 
from the folder in which it is stored. You can access the required folder by using the Look in 
drop-down list. You can then select the name of the drawing from the list box or you can enter 
the name of the drawing file you want to open in the File name edit box. After selecting the 
drawing file, you can choose the Open button to open the file.

Figure 1-34  The Select File dialog box

When you select a file name, the preview of the selected drawing file is displayed in the Preview 
box. If you are not sure about the file name of a particular drawing but know the contents, you 
can still select the file and look for that drawing in the Preview box. You can also change the 
file type by selecting it in the Files of type drop-down list. Apart from the .dwg files, you can 
open the .dwt (template) files, .dws files or the .dxf files. The Open button also has a 
drop-down list, as shown in Figure 1-35. You can choose any of the 

Figure 1-35  The Open 
drop-down list

methods given in this list for opening the file. 

Note that you cannot make any changes to the drawing file that is 
not in the current project. If you do so, the Alert message box will 
be displayed, as shown in Figure 1-36. This message box warns you 
that the object can only be inserted into a project drawing, and 
if you want to add this drawing to the current project, choose the 
Yes button; the message box will be closed and the drawing will 
be added to the currently opened project.       
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Figure 1-36  The Alert message box

Alternatively, to add files to the current drawing, right-click on the P&ID Drawings or Plant 
3D Drawings node and choose the Copy Drawing to Project option from the shortcut menu 
displayed, refer to Figure 1-37; the Select Drawings to Copy to Project dialog box will be 
displayed, refer to Figure 1-38. Browse to the file location and double-click on the drawing file 
to be added to the project; the drawing file will be added to the current project. 

Figure 1-37  Copying a drawing 
to project

Figure 1-38  The Select Drawings to Copy to Project dialog box
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QUITTING AutoCAD Plant 3D
You can exit the AutoCAD Plant 3D program by using the EXIT or QUIT command. Even 
if a command is active, you can choose Exit Autodesk AutoCAD Plant 3D 2020 from the 
Application Menu to close the AutoCAD Plant 3D program. In case the drawing has not been 
saved, it allows you to first save the work through a dialog box. Note that if you choose No in 
this dialog box, all the changes made in the current file till the last save will be lost. You can 
also use the Close button (X) of the main AutoCAD Plant 3D window (present in the title bar) 
to end the AutoCAD Plant 3D session. 

AutoCAD Plant 3D HELP
  Titlebar:  ? > Help	 Shortcut Key: F1		  Command:  HELP or ?  

You can get online help and documentation on the working of AutoCAD Plant 3D 2020 
commands from the Help menu in the InfoCenter located on the right in the title bar, 
refer to Figure 1-39. You can also access the Help menu by pressing the F1 function key. 
Some important options in the Help menu are discussed next.

 Figure 1-39  The Help menu in the InfoCenter

Figure 1-40 shows the Autodesk AutoCAD Plant 3D 2020 - Help page after choosing the Help 
button from the InfoCenter bar.

Figure 1-40  The Autodesk AutoCAD Plant 3D 2020 - Help page
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Customer Involvement Program
This option is used to share your software and system configuration information with Autodesk. 
The collected information is used by Autodesk for the improvement of Autodesk software.

About Autodesk AutoCAD Plant 3D 2020
This option gives you information about the release, serial number, licensed to, and also the 
legal description about AutoCAD Plant 3D.

Autodesk App Store
Autodesk App Store helps you to download various applications of AutoCAD, get connected 
to the AutoCAD network, share information and designs, and so on. On choosing the 
Autodesk App Store button from the title bar, the AUTODESK APP STORE page will 
open in the default browser, as shown in Figure 1-41. 

You can download various Autodesk apps such as PlantDataManager, Rename Project, and so on 
from this page. Some of them are free of cost. You can also publish your own Autodesk products 
for other users of Autodesk products. 

Also, you can download applications for software other than AutoCAD family such as Autodesk 
Alias, Revit, Simulation, and so on. You can also search for the applications by entering the name 
of the app in the Search Apps text box. 

Figure 1-41  The AUTODESK APP STORE page

ADDITIONAL HELP RESOURCES
•	 You can get help for a command while working in AutoCAD Plant 3D by pressing the F1 key. 

If you press the F1 key when a command is active, the HELP window containing information 
about that command will be displayed. After using the help, you can exit the window and 
continue with the current project.

•	 You can get help about a dialog box by choosing the Help button from that dialog box.

•	 Autodesk provides several resources that can be used to get assistance on Plant 3D tools and 
functions. These resources can be accessed by visiting the following links:
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	 a.	 Autodesk community forum website https://forums.autodesk.com/
	 b. 	 AutoCAD Plant 3D Technical Assistance website https://knowledge.autodesk.com/support/                                                                                                                                         

       autocad-plant-3d#?sort=score

•	 You can also get help by contacting the author, Prof. Sham Tickoo, at stickoo@pnw.edu and 
tickoo525@gmail.com.

•	 You can download AutoCAD Plant 3D drawings, programs, and special topics by registering 
yourself at the website by visiting: https://cadcim.com/Registration.aspx

 Self-Evaluation Test	    
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 The items in the ________ tab in the TOOL PALETTES contain the piping components 
from the selected specification.

2.	 The _________ grip is used to modify a nozzle.

3.	 If you want to work on a drawing without altering the original drawing, you must select the 
__________ option.

4.	 The __________ is used to start or continue routing a pipe.

5.	 The___________ palette displays an additional section for the properties specific to the 
selected item.

6.	 You can use the __________ command to close the current drawing file without actually 
quitting AutoCAD Plant 3D.

7.	 You can press F3 key to invoke the AutoCAD text window which displays the previously used 
commands and prompts. (T/F)

8.	 If you do not have an internet connection, you cannot access the Help files. (T/F)

9.	 You can close a drawing in AutoCAD Plant 3D 2020 even if a command is active. (T/F)

10.	 If the current drawing is unnamed and you save the drawing for the first time, you will be 
prompted to specify the file name in the Save Drawing As dialog box. (T/F) 
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 Review Questions     
Answer the following questions:

1.	 Which of the following combination of keys should be pressed to turn on or off the display 
of the TOOL PALETTES window?

		  (a) CTRL+3			   (b) CTRL+0
		  (c) CTRL+5			   (d) CTRL+2

2.	 Which of the following commands is used to exit the AutoCAD Plant 3D program? 

		  (a) QUIT			   (b) END
		  (c) CLOSE			   (d) None of these

3.	 Which of the following commands is invoked when you choose the Save option from the 
File menu or choose the Save tool in the Quick Access Toolbar?

		  (a) SAVE			   (b) LSAVE
		  (c) QSAVE			   (d) SAVEAS

4.	 By default, the angles are positive if measured in the __________ direction.

5.	 You can get help for a command while working in AutoCAD Plant 3D by pressing the 
__________ key.

6.	 The shortcut menu invoked by right-clicking in the command window displays the most 
recently used commands and some of the commonly used options such as Copy, Paste, and 
so on. (T/F)

7.	 Flip grip is used to flip a valve or a fitting. (T/F)

8.	 The TOOL PALETTES display items based on the workspace in which you are currently 
working. (T/F)

9.	 You cannot make any changes in the drawing file which is not in the current project. (T/F)

10.	 The file name that you enter to save a drawing in the Save Drawing As dialog box can be 
255 characters long but cannot contain spaces and punctuation marks. (T/F)
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Answers to Self-Evaluation Test
1. Dynamic Pipe Spec, 2. Edit Nozzle, 3. Open Read-only, 4. Continuation grip, 5. PROPERTIES, 
6. CLOSE, 7. F, 8. T, 9. T, 10. T 


