Chapter 1

Introduction to AutoCAD
Electrical 2020

Learning Objectives

After completing this chapter, you will be able to:

* Install and configure AutoCAD Electrical 2020

* Start AutoCAD Electrical

* Understand components of the initial AutoCAD Electrical screen
* Invoke AutoCAD Electrical commands

* Use various commands to save a file

* Exit AutoCAD Electrical

* Create and manage workspaces

* Use various options in AutoCAD Electrical help
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INTRODUCTION

AutoCAD Electrical is a purpose-built controls design software. This software is used to
create electrical schematic drawings and panel drawings. AutoCAD Electrical contains
various schematic and panel symbols. These symbols, which are mostly the AutoCAD blocks with
attributes, carry the intelligence of AutoCAD Electrical drawings. The standard symbol libraries
such as JIC, IEC, JIS, and GB, which contain these symbols also get installed with the installation
of AutoCAD Electrical. Besides all tools of AutoCAD software, AutoCAD Electrical also contains
other electrical tools. You can use these tools for designing control systems speedily, economically,
and accurately. As AutoCAD Electrical is compatible with AutoCAD, it is recommended to use the
AutoCAD Electrical tools instead of AutoCAD tools when designing electrical circuits. However,
AutoCAD Electrical drawings can be edited by using AutoCAD LT or AutoCAD. The all-inclusive
symbol libraries and mechanized tasks help in increasing productivity and removing errors, and
in providing exact information to the users.

INSTALLING AND CONFIGURING AutoCAD Electrical
2020

To install AutoCAD Electrical 2020, execute its setup; the Setup Initialization window will
be displayed, as shown in Figure 1-1. After the setup is initialized, the Autodesk AutoCAD
Electrical 2020 wizard will be displayed. Next, perform the following steps to install AutoCAD
Electrical 2020:

i Setup Initiskzation

AUTODESK' AUTOCAD ELECTRICAL 2020 {\ AUTODESK.

-

Initializing &

Figure 1-1 The Setup Initialization window
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1.

Choose Install from the Autodesk AutoCAD Electrical 2020 wizard, refer to Figure 1-2;
the LICENSE AGREEMENT page will be displayed.

|8\] Autodesk® AutoCAD® Electrical 2020 = X

AUTODESK" AUTOCAD' ELECTRICAL 2020 {\ AUTODESK.

é. Install

Install on this computer

# Install Tools & Utilities

nstallation Help | System Requirements | Release Notes Exit

Figure 1-2 The Autodesk AutoCAD Electrical 2020 wizard

Select the I Accept radio button to accept the license agreement and choose the Next button;
the Product Information page will be displayed and you will be prompted to specify the
product and user information.

Specify the information in the Product Information page of the Autodesk AutoCAD
Electrical 2020 wizard. Next, choose the Next button; the Configure Installation page will
be displayed.

Move the cursor below the Autodesk AutoCAD Electrical 2020 text in this page, refer to
Figure 1-3; the text below Autodesk AutoCAD Electrical 2020 changes to Click to open
and configure text, as shown in Figure 1-4.

Click on the down arrow on the left of the Click to open and configure text; a list of all
manufacturers will be displayed and you will be prompted to select the manufacturer content
to install.

Choose the Select All button to select entire manufacturer content from this list. Ensure
that entire manufacturer contents are installed, so that you do not face any problems while
working on tutorials and exercises given in this textbook.
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@ Autodesk® AutoCAD® Electrical 2020

AUTODESK AUTOCAD ELECTRICAL 2020

Install > Configure Installation

« Autodesk® AutoCAD® Electrical 2020

Create and modify electrical control systems with AutoCAD® software for controls
designers and engineers.

Installation path: [ C:\Program Files\Autodesk\

| [ srowse..

Installation Help | System Requirements | Release Notes

= x

{\ AUTODESK.

Disk space: 10.8 GB required / 109 GB available

| Bak || mstal | [ Concer |

Figure 1-3 The Configure Installation page of the Autodesk AutoCAD Electrical 2020 wizard

[A\] Autodesk® AutoCAD® Electrical 2020

AUTODESK AUTOCAD' ELECTRICAL 2020

Install > Configure Installation
“ Autodesk® AutoCAD® Electrical 2020

@ Click to open and configure

Installation path: | C:\Program Files\Autodesk\

| [ Browse..

nstallation Help | System Requirements | Release Notes

= X

{\ AUTODESK. ‘

Disk space: 10.8 GB required / 109 GB available

[ Back | [ mstal | [ Conce |

Figure 1-4 The text changed below Autodesk AutoCAD Electrical

2020 in the Configure Installation page
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7. Next, click on the upward arrow on the left of the Click to close and return to product list
to go back to the main page of the Configure Installation page, refer to Figure 1-5; the
Configure Installation page will be modified, as shown in Figure 1-6.

[A\] Autodesk® AutoCAD® Electrical 2020 = X

AUTODESK AUTOCAD' ELECTRICAL 2020 {\ AUTODESK.

Install > Configure Installation

« Autodesk® AutoCAD® Electrical 2020

Click to close and retumn to product list ﬂ 7 r( W‘

Please select Manufacturer content to instal.

Manufacturer &
(%]

B8

[ anpaer

[4 aromaT

4 AUTOMATIONDIRECT

[ secxHorF

[ seLoen

4 surkuN

4 Bussmann

4 peLxa

(4 eaton v

(Notrecommended) | selectAl |

For a faster installabon and better performance, select only.
the manufacturers you need. Unselect Al

C:\Program Files\Autodesk\ Disk space: 10.8 GB required / 109 GB available

[ Back | [ msal | [ conca |

Figure 1-5 Clicking on the arrow on the left of the Click to close and
return to product list text

[A] Autodesk® AutoCAD® Electrical 2020 = X

AUTODESK AUTOCAD' ELECTRICAL 2020 {\ AUTODESK.

Install > Configure Installation

[ Autodesk® AutoCAD® Electrical 2020

Create and modify electrical control systems with AutoCAD® software for controls
designers and engineers

!

Installation path: | C:\Program Files\Autodesk\ Browse... Disk space: 11.7 GB required / 109 GB available

tallation Help | System Requirements | Release Notes Back \ﬁau Cancel

Figure 1-6 The modified Configure Installation page of the Autodesk
AutoCAD Electrical 2020 wizard

8. Choose the Install button in this page; the Installation Progress page will be displayed and
AutoCAD Electrical 2020 will start installing components, as shown in Figure 1-7.
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] Autodesk® AutoCAD® Electrical 2020 = X

AUTODESK AUTOCAD' ELECTRICAL 2020 {\ AUTODESK.

Install > Installation Progress

DirectX Runtime Installing... CHNEEEEE—

s

e — .

Overall progress... € 17 of 18 remainin q

Pause Download Cancel

Figure 1-7 The Installation Progress page in the AutoCAD
Electrical 2020 wizard

9. Once the installation of components is finished, the Installation Complete page will be
displayed showing you the products that are installed. Choose the Finish button in it to
finish the installation process.

Note
It is recommended that you install entire manufacturer content so that you can easily create tutorials
and exercises discussed in the forthcoming chapters in this textbook.

GETTING STARTED WITH AutoCAD Electrical 2020

You can start AutoCAD Electrical by double-clicking on its shortcut icon on the desktop of your
computer. You can also load AutoCAD Electrical from the Windows taskbar by using the Start
button at the bottom left corner of the screen (default position). To do so, choose the Start button
to display a menu. Next, choose AutoCAD Electrical 2020 - English > AutoCAD Electrical
2020 - English, as shown in Figure 1-8; the AutoCAD Electrical 2020 interface along with the
Startup dialog box will be displayed. In the dialog box, you can select the required drawing
template. The startup interface of AutoCAD Electrical 2020 appears as per the template selected.

AutoCAD Electrical INTERFACE COMPONENTS

There are various components in the interface of AutoCAD Electrical including the drawing area,
Command window, Ribbon, Application Menu, menu bar, Tool Palettes, PROJECT MANAGER,
Model and Layout tabs, Application Status Bar, several toolbars, and so on, refer to Figure 1-9.
A title bar containing AutoCAD Electrical symbol and the current drawing name is displayed
on top of the screen. Also, the screen has the standard window buttons such as close, minimize,
and maximize on the top right corner. These buttons have the same functions as any other
standard window.
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Figure 1-8 Starting AutoCAD Electrical 2020
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Figure 1-9 AutoCAD Electrical interface components

The Start tab is displayed in the AutoCAD Electrical environment when you close all the drawing
templates or when there are no drawings open. The Start tab contains two sliding frames,
CREATE and LEARN, refer to Figure 1-10. These frames are discussed next.
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LEARN

Figure 1-10 The Start tab in AutoCAD Electrical 2020 interface

CREATE

When you click on the CREATE sliding frame, the CREATE page will be displayed. In the
CREATE page, you can access sample files, recent files, and templates. Using the links available
on this page, you can connect with the online communities. The CREATE page is divided into
three columns: Get Started, Recent Documents, and Connect.

LEARN

When you click on the LEARN sliding frame, the LEARN page will be displayed. The LEARN
page provides tools to help you learn AutoCAD Electrical 2020. It is divided into three columns:
What’s New, Essential Skills Videos, Learning Tips, and Online Resources.

Drawing Area

The drawing area covers the major portion of the screen. In this area, you can draw objects and
use commands. To draw objects, you need to define the coordinate points that can be selected
by using the pointing device. The position of the pointing device is represented on the screen
by the cursor. There is a coordinate system icon at the lower left corner of the drawing area.

Tip

Q You can hide all screen components such as toolbars, PROJECT MANAGER, and Ribbon
displayed on the screen by pressing the CTRL+0 keys or by choosing the Clean Screen option
[from the View menu. 1o turn on the display of the above mentioned screen components again,
press the CTRL+0 keys. Note that the O key on the numeric keypad of the keyboard cannot
be used for the Clear Screen option.

Command Window

The command window at the bottom of the drawing area has the Command prompt where you
can enter the required commands. It also displays subsequent prompt sequences and messages.
You can change the size of the window and also view all the previously used commands by placing
the cursor on the top edge (double line bar known as the grab bar) and then dragging it. You
can also press the F2 key to display AutoCAD Text Window which displays the previously used
commands and prompts.
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AutoCorrect the Command Name

If you type a wrong command name at the Command prompt, a suggestion list with most
relevant commands will be displayed, refer to Figure 1-11. You can invoke the desired command
by selecting the respective option from this list.

AutoComplete the Command Name

When you start typing a command name at the Command prompt, the complete name of
the command will be displayed automatically. Also, a list of corresponding commands will be
displayed, as shown in Figure 1-12. The commands that have not been used for a long time will
be grouped in folders at the bottom of the list.

* AEWIRE AEWIRE
AEWIRENO AEWIRENO
AEWIREGAP # AEWIRETYPE
% AERETAG £ AEWBCIRCUIT
% AEWIRECONN AEWIREGAP
# AEWIRETYPE . AEWIRECOLORLABEL
4= AEPREV ¥ AEWIREANNOTATION
~ AEWre ~ AEWIREANNOTATION
Figure 1-11 Suggestion list with Figure 1-12 Command line displaying complete
relevant commands command name

Internet Search

You can get more information about a command by using the Search in Help and Search
on Internet buttons available adjacent to the command name in the Command line, refer
to Figure 1-13. If you choose the Search in Help button, the AutoCAD Electrical 2020 - Help
window will be displayed. In this window, you can find information about the command. By using
the Search on Internet button, you can find information about the command on the internet.

Search on Internet
Search in Help

E aemuLTIBUS

T AEMOVECTRCUIT
- AEMOVEWIRENO
B} AEMENLMWIZ

* AEMOVE

8 AEMULTI

B AEmOVEPIN

[>_| = AEMULTIBUS

Figure 1-13 The Search in Help and Search on
Internet buttons displayed in the suggestion list
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Input Search Options

In AutoCAD Electrical, you can enable or disable the functions such as AutoComplete and
AutoCorrect by using the options available in the Input Search Options dialog box. To invoke
this dialog box, right-click on the Command prompt; a shortcut menu will be displayed. Next,
choose Input Search Options from the shortcut menu; the Input Search Options dialog box
will be displayed, refer to Figure 1-14. Now, you can enable or disable the required functions
by using this dialog box.

A Input Search Options X
AutoComplete Search content at command line
Enable AutoComplete
Enable Mid-string search Content Type |Z|
Sort suggestions Block Iz‘
® According to frequency of usage Layer
O Alphabetically
Hatch
AutoCorrect Text Style
Enable AutoCorrect Dim Style
Remember corrections after |3 mistypes Visual Style
Search system variables
Separate commands and system variables
Suggestion list delay time 300 milliseconds
| oK | ‘ Cancel | | Help

Figure 1-14 The Input Search Options dialog box
Application Status Bar

The Application Status Bar is displayed at the bottom of the screen, refer to Figure 1-15. It
contains some useful information and buttons that help in changing the status of some AutoCAD
and AutoCAD Electrical functions easily. You can toggle between on and off states of most of
these buttons by choosing them. Some of these buttons are not available by default. To display/
hide buttons in the Application Status Bar, choose the Customization button at the extreme
bottom right corner of the Application Status Bar; a flyout will be displayed. Next, choose the
desired options from this flyout. The most commonly used buttons in the Application Status
Bar are discussed next.

3D Object Snap AlowDisalow Dynamic
Hide Tr Show annotation objects
Hide Lineweight Add scales to annotative obiects when
obeds the annotation scale changes
ject Snay
! i Annotation scale of the current view
Object Snap Tracking Vvorkspace switching
I tri ¢ Drafti
semetnc Drating Annotation Monitor
Polar Tracking
Quick Properties
Ortho Mode
Hardware A
Dynamic Input
Snap Mode Project Database Sewvice
Grid Display Isolate Objects
Model or Paper Space Clean Screen
Drawing Coordinates —‘ ’7 Customization
47.7658,-10.6046,00000 MODEL i 3 v tu L G- N\~ A - E-ER -V R LA U- 8-+ 0 @@P =

Figure 1-15 The Application Status Bar
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Drawing Coordinates

The coordinate information is displayed on the left corner of the Application Status Bar. You
can also choose the Customization button and then choose the Coordinates option from the
flyout displayed to turn the coordinate display on and off.

Snap Mode

... The snap mode allows you to move the cursor in fixed increments. If the snap mode is on,
the Snap Mode button will be chosen in the Application Status Bar; otherwise, it will be

deactivated. You can also use the F9 function key as a toggle key to turn the snap off or on.

Grid Display
iﬁi The grid lines are used as reference lines to draw objects in AutoCAD Electrical. Choose
" the Grid Display button to display the grid lines on the screen. The F7 function key can
be used to turn the grid display on or off.

Ortho Mode
. If the Ortho Mode button is chosen in the Application Status Bar, you can draw lines at
right angles only. You can use the F8 function key to turn the ortho mode on or off.

Polar Tracking

If you turn the polar tracking on, the movement of the cursor will be restricted along a
path based on the angle set in the polar angle settings. Choosing the Polar Tracking button
in the Application Status Bar turns the polar tracking on or off. You can also use the F10

function key to turn the polar tracking on or off. Note that turning the polar tracking on

automatically turns off the ortho mode.

Object Snap
@ The Object Snap button is a toggle button and is used to turn object snap on or off. You
can also use the I3 function key to turn the object snap on or off.

3D Object Snap
ta The 3D Object Snap button is a toggle button and is used to turn 3D object snap on or
off. You can also use the F4 function key to turn the 3D object snap on or off.

Object Snap Tracking
. This button is used to turn the object snap tracking on or off. You can also use the F11
function key to turn the object snap tracking on or off.

Allow/Disallow Dynamic UCS
This button enables you to use the dynamic UCS. You can also use the F6 function key or
CTRL + D keys to turn the dynamic UCS on or off.

b

Dynamic Input

EI The Dynamic Input button is used to turn the Dynamic Input mode on or off. You can
also use the F12 function key to turn this mode on or off. Turning it on facilitates the
heads-up design approach because all commands, prompts, and dimensional inputs will

now be displayed in the drawing area and you do not need to look at the Command prompt all

the time. This saves the design time and also increases the efficiency of the user. If the Dynamic
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Input mode is turned on, you can enter commands through the Pointer Input boxes, and
numerical values through the Dimensional Input boxes. Also, you can select the command
options with the help of Dynamic Prompt options in the graphics window.

Show/Hide Lineweight
. This button is used to turn the display of lineweights on or off in the drawing. If this button
is not chosen, the display of lineweight will be turned off.

Show/Hide Transparency
E‘ This button is used to turn on or off the transparency of layers and objects.

Quick Properties
If you select a sketched entity and choose the Quick Properties button in the Application
Status Bar, the properties of the selected entity will be displayed in a panel.

Model or Paper Space

This button is used to toggle between model space and paper space. The model space
is used to work in a drawing area. Paper space is used to prepare your drawing for

printing.

Show annotation objects
Jo  This button is used to control the visibility of the annotative objects that do not support
the current annotation scale in the drawing area.

Add Scales to annotative objects when the annotative scale changes
R This button, if chosen, automatically adds all the annotation scales that are set current to
all the annotative objects present in the drawing.

Annotation Scale of the current view
A 1:1 = 'Thisbutton controls the size and display of the annotative objects in the model space.

Workspace Switching

When you choose the Workspace Switching button, a flyout is displayed. This flyout
contains predefined workspaces and options such as Workspace Settings, Customize,
and so on. The options in this flyout will be discussed later in detail.

-

Customization
— The Customization button is available at the lower right corner of the Application Status
Bar and is used to add or remove buttons from the Application Status Bar.

Navigation Bar
In AutoCAD Electrical, the navigation tools are grouped together and are available in the drawing
area, as shown in Figure 1-16. The tools in the Navigation Bar are discussed next.
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Full Navigation Wheel
The Full Navigation Wheel has a set of navigation tools that can @— Full Navigation Whee!
be used for panning, zooming, and so on. -
h~4+——Pan
'T\_‘.
Pan I_l—— Zoom Extents
This tool allows you to view the portion of the drawing that is .
outside the current display area. To do so, choose this button in ';Tﬁ\rb__ofb-,t
the Application Status Bar, press and hold the left mouse button -
. . . ood
and then drag the drawing area. Press ESC to exit this command. [» ] —— ShowMtion

Zoom Extents

Choose one of the tools from the group to zoom the view of the
drawing on the screen as per your requirement without affecting
the actual size of the objects.

Figure 1-16 ools in the
Navigation Bar

Orbit

This set of tools is used to rotate the view in 3D space.

ShowMotion
Choose this button to capture different views in a sequence and animate them when required.

Project Database Service

5% The Project Database Service (PDS) updates the scratch project database automatically. It
= s also used to save all non-AutoCAD Electrical attributes from block files into the project.
Also, if the drawing files of a project are not found in the respective folder, an error message
will be displayed in the Project Database Service message box.

Units
[ Decimal This button is used to display and control the units of drawing. It has a flyout that
displays all the unit systems available for drawing.

Lock Ul

e} This button is used to dock/undock the toolbars, panels, and windows.

Clean Screen
The Clean Screen button is located at the lower right corner of the screen. When you
choose this button, all displayed toolbars, except the command window, Application Status
Bar, and menu bar, disappear and the expanded view of the drawing is displayed. The expanded
view of the drawing area can also be displayed by choosing View > Clean Screen from the Menu
Bar or by using the CTRL+0 keys. Choose the Clean Screen button again to restore the previous
display state.
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INVOKING COMMANDS IN AutoCAD Electrical

When AutoCAD Electrical is started, you can invoke AutoCAD Electrical commands to perform any
operation. For example, to draw a wire, first you need to invoke the AEWIRE command and
then define the start point and endpoint of the wire. Similarly, if you want to trim wires, you
must invoke the AETRIM command and then select wires for trimming. AutoCAD Electrical
provides the following options to invoke a command:

Keyboard Ribbon Application Menu Toolbar
Marking Menu Shortcut menu Menu Bar Tool Palettes
Keyboard
You can invoke any AutoCAD Electrical command from the
keyboard by entering the name of the command at the Command (;I;r;i};r ot
prompt and then pressing the ENTER key. If the Dynamic Input .

mode is on and the cursor is in the drawing area, by default the

command will be entered through the Pointer Input box. The  Figure 1-17 The Pointer
Pointer Input box is a small box displayed on the right of the — Input box displayed
cursor, as shown in Figure 1-17.

However, if the cursor is currently placed on any toolbar or menu bar, or if the Dynamic Input
mode is turned off, the command will be entered through the Command prompt. Before you
enter a command, the Command prompt is displayed as the last line in the command window
area. If it is not displayed, you must cancel the existing command by pressing the ESC key. The
following example shows how to invoke the AEWIRE command using the keyboard:

Command: AEWIRE ]

Ribbon

Most of the commands used for creating, modifying, and annotating components are available
in the Ribbon, as shown in Figure 1-18.

/_D @ [/D. o Move () Rotate -+ & g [PE-H [ - Hv@%
Line Polyine Crde  tee o‘?f Copy  dp Miror (- 480 Lager 2% et 707 et B ate)
M N - [Astetcn Gl BE - & Popeties £ B £ 5 & T OE T W Prope

Draw v Modify v Layers v Annotation v | Block ¥

Figure 1-18 The Ribbon for the ACADE & 2D Drafting & Annotation workspace

When you start AutoCAD Electrical session for the first time, by default the Ribbon is displayed
horizontally below the Quick Access Toolbar. The Ribbon consists of various tabs. These tabs
have different panels, which in turn, have tools arranged in rows. Some of the panels and tools
have a small black down arrow. This indicates that the corresponding panels and tools have some
more buttons in the form of drop-down. Click on this down arrow to access the hidden tools.
If you choose a tool from the drop-down, the corresponding command will be invoked and the
tool chosen will be displayed in the panel. For example, to move components using the Move
Component option, click on the down arrow next to the Scoot tool in the Edit Components
panel of the Schematic tab; a drop-down will be displayed. Choose the Move Component tool
from the drop-down and move components. Choose the down arrow to expand the panel. You
will notice that a push pin is available at the left end of the panel. Click on the push pin to keep
the panel in the expanded state.
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You can reorder panels in a tab. To do so, press and hold the left mouse button on the panel to
be moved and then drag it to the required position. To undock the Ribbon, right-click on the
blank space in the Ribbon and choose the Undock option from the shortcut menu displayed.
You can move, resize, anchor, and auto-hide the Ribbon using the shortcut menu that will be
displayed when you right-click on the heading strip. To anchor the floating Ribbon vertically
to the left or right of the drawing area, right-click on its heading strip; a shortcut menu will be
displayed. Choose the corresponding option from this shortcut menu. The Auto-hide toggle
button on the right of the Express Tools tab will hide the Ribbon into the heading strip and
will display it only when you move the cursor over this strip.

You can customize the display of tabs and panels in the Ribbon. To do so, right-click on any
one of the buttons in the Ribbon; a shortcut menu will be displayed. On moving the cursor
over one of the options in the shortcut menu, a cascading menu will be displayed with a tick
mark before all options indicating that the corresponding tab or panel will be displayed in the
Ribbon. Select/clear the appropriate option to display/hide a particular tab or panel.

Application Menu

You can invoke various commands from the Application Menu. To do so, choose the Application
button available at the top left corner of the AutoCAD Electrical window; the Application Menu
will be displayed, refer to Figure 1-19.

."HBEIB&E%- =

Search Commands Q

E (Sj Recent Documents
N
B DEMOD4.DWG =

/] Open » B pemooz.ows =

E Save
B Save As 3
'
- Import ]
Export 3
-

=
/—7 Publish ’

Print 3

Drawing
/' Utilities
g

Close 3

‘ Options | | Exit AutoCAD Electrical 2020

Figure 1-19 The Application Menu
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You can search for a command using the search field on the top of the Application Menu. To
search for a command, enter the complete or partial name of the command in the search field;
a list displaying all possible commands will be displayed. If you click on a command from the
list, the corresponding command will get activated.

By default, the Recent Documents button is chosen in the Application Menu. As a —,
result, the recently opened drawings will be listed. If you have opened multiple drawing
files, choose the Open Documents button; the documents that are opened will be listed in the
Application Menu. To set the preferences of the file, choose the Options button available at
the bottom of the Application Menu. 'To exit AutoCAD Electrical, choose the Exit AutoCAD
Electrical button next to the Options button.

Menu Bar

You can also select commands from the menu bar. Menu bar is not displayed by default. To invoke
the menu bar, choose the down arrow in the Quick Access Toolbar; a flyout will be displayed.
Choose the Show Menu Bar option from the flyout; the menu bar will be displayed. As you move
the cursor over the menu bar, different titles will be highlighted. You can choose the desired
item from the menu bar by clicking on it. Once the item is chosen, the corresponding menu will
be displayed directly under the title. Some of the menu items display an arrow on their right
indicating that they have a cascading menu. The cascading menu provides various options to
execute AutoCAD Electrical commands. You can display the cascading menu by choosing the
menu item or by moving the arrow pointer to the right of that item. You can then choose any
item from the cascading menu by clicking on it. For example, to insert a ladder, choose Wires
from the menu bar and then choose the Ladders option; a cascading menu will be displayed,
as shown in Figure 1-20. From the cascading menu, choose the Insert Ladder option.

Wires Panel Layout Window Help Express

2 Insert Wire
44, Trm Wire
= Multiple Wire Bus
B, AddRung
Angle Wire 3

Change/Convert Wire Types
Create/Edit Wire Type
Stretch Wire

Bend Wire

ke Ny

Wire Miscellaneous 3

Ladders 3 91 Insert Ladder
P .

Insert Wire Mumbers ';“a Ml

Edit Wire Number i Renumber Ladder Reference

B, ConvertLadder

¥ .0

Figure 1-20 The cascading menu

Toolbar

‘Toolbars are not displayed by default. To display a toolbar, first invoke the menu bar and then
choose Tools > Toolbars > ELECTRICAL from it; the list of toolbars will be displayed. Select the
required toolbar. In a toolbar, a set of tools representing various AutoCAD Electrical commands
are grouped together. When you move the cursor over a tool in a toolbar, the tool will be lifted.
The tooltip (name of the tool) and a brief description related to that tool will also be displayed
below the tool. Once you locate the desired tool, the command associated with it can be invoked
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by choosing it. For example, you can invoke the AEWIRE command by choosing the Insert
Wire tool from the ACE:Main Electrical toolbar.

Some of the tools in a toolbar have a small triangular arrow at
its lower right corner. This arrow indicates that the tool has a
flyout attached to it. If you hold cursor on the triangular arrow
button, a flyout containing the options for the command will
be displayed, as shown in Figure 1-21. Choose the desired
option from the toolbar; a command will be displayed in the Figure 1-21 The flyout
command window. The ACE:Main Electrical and ACE:Panel

Layout toolbars are shown in Figures 1-22 and 1-23, respectively.
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Figure 1-22 The ACE:Main Electrical toolbar
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Panel Configuration

Insert Panel Assembly

Insert Footprint

(lcon menu)
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Edit Footprint Wire Annotation of
Insert Balloon — 1 Panel Footprint

Figure 1-23 The ACE:Panel Layout toolbar

Moving and Resizing Toolbars

Toolbars can be moved anywhere on the screen by placing the cursor on the strip and then
dragging it to the desired location. You must hold the cursor down while dragging. While moving
toolbars, you can dock them to the top or sides of the screen by dropping them in the docking
area. You can prevent docking toolbars, as and when needed, by holding the CTRL key while
moving the toolbar to a desired location. You can also change the size of toolbars by placing the
cursor anywhere on the border of the toolbar where it takes the shape of a double-sided arrow,
as shown in Figure 1-24, and then pulling it in the required direction, as shown in Figure 1-25.
You can also customize toolbars to meet your requirements.

%% %5005,
%%‘E’. u‘?:-u-:'-o-l
EEEEAD ELGBER® %A H kL, H. &l 2+ T B B R
Figure 1-24 Resizing the ACE:Main Electrical toolbar Figure 1-25 The ACE:Main

Electrical toolbar resized
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Marking Menu

AutoCAD Electrical provides you with marking menus which are displayed on right-clicking on an
AutoCAD Electrical Object. By using the marking menus, you can easily invoke the commands, if
the toolbar is not displayed in the drawing area. These marking menus are context-sensitive, which
means that the commands or tools in this menu will be displayed based on the object selected.
Figure 1-26 shows a marking menu that is displayed on right-clicking on a component and
Figure 1-27 shows a marking menu that is displayed on right-clicking on a wire. Figure 1-28
shows a marking menu that is displayed on right-clicking on a footprint. There are two basic
modes for command selection: Menu mode and Mark mode. These modes are discussed next.

.\3 Change/Convert Wire Type_)

(O Edit Component | [ Bend Wire ] ) (o} TimWire )
| o W= ) ——— =
|, Move Component -C_Ix-' )P o ¥ {; Delete Component | w. \.w.)—
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| _nlign gh) — — | Surfer —_ —
(_Scoot .E;.) .\.g Retag.ﬂ..lpdane_) '\2 Insert Wire )
| . Insert Component [ 3
.\{3 Copy Component J Source Destination &
|- “opy Tompanen
Attributes (3 Trace Wire
% Reverse/Flip Component Wire Mumbers 3
72 2 Insert Wire . Wl.re Sequence »
% Insert 45 Degres Wire § Exit
= g LS G
Figure 1-26 The marking menu displayed — Figure 1-27 The marking menu displayed
on right-clicking on a component on right-clicking on a wire
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Figure 1-28 The marking menu displayed on
right-clicking on a footprint

Menu Mode

You can invoke the Menu mode by right-clicking on an object. When you invoke this mode, a
marking menu will be displayed, showing the commands related to that object. Move the cursor
over the command to be executed and click on it; the selected command will be executed. To
exit the marking menu, click at the center of the menu or click anywhere outside the menu. If
you press the ESC key, the command in progress will be cancelled.

Mark Mode

Mark mode is similar to Menu mode. The only difference between them is that in this mode,
you need to immediately move the cursor along the direction of the desired command after
right-clicking on the component. On doing so, a rubber band line connected with the cursor is
displayed. Release the mouse button on the command to be executed.



Introduction to AutoCAD Electrical 2020 1-19

Shortcut Menu

If you right-click in the drawing area, the AutoCAD shortcut menu will be displayed. This
shortcut menu contains the commonly used commands of Windows and an option to select the
previously invoked commands again, as shown in Figure 1-29. If you right-click in the drawing
area while a command is active, a shortcut menu will be displayed containing the options of
that particular command. Figure 1-30 shows the shortcut menu displayed while the AEWIRE
command is active.

Repeat AEWIRE i
Recent Input 3 AEWIRE I}
Clipboard 5 WD _REACT_EDPSYM
AEFOOTPRINT
Fsolate ' AEFOOTPRINTSCH
L] Undo (lisp expression) ACENAY
= Redo Ctel+Y COMMANDLINE
5 Pan RIBEOMN
CDQ Zoom
@ SteeringWheels
Action Recorder 2
Subobject Selection Filter 3
[¥ Quick Select...
QuickCale
1 G Find...
[ Options...

Figure 1-29 The shortcut menu showing
the recently used commands

When you right-click on the command window, a shortcut menu will be displayed. This shortcut
menu displays the six most recently used commands and some of the window options like Copy
and Paste, as shown in Figure 1-31.

Enter
Cancel Recent Cormmands 4
Recent Input 4

. Input Settings r
wireType

. Input Search Options...
X=chow connections

Cut

Snap Overrides » Copy
3 Pan Copy History
(‘_‘t‘-q Zoom Paste
@ SteeringWheels Paste to CommandLine
QuickCalc Options...

Figure 1-30 The shortcut menu displayed Figure 1-31 Command
on right-clicking in the drawing area with window shortcut menu
the AEWIRE command active
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The commands and their prompt entries are displayed in the History window (previous command
lines not visible) and can be selected, copied, and pasted in the command line using the shortcut
menu. As you press the up arrow key, the previously entered commands will be displayed in the
command window. Once the desired command is displayed at the Command prompt, you can
execute it by simply pressing the ENTER key.

When you right-click in the coordinate display area of the Status Bar, a Relative
shortcut menu will be displayed. This shortcut menu contains options to fbselute
modify the display of coordinates, refer to Figure 1-32. You can also right-click
on any of the toolbars to display a shortcut menu from where you can choose

Geographic
Specific

any toolbar to be displayed. Figure 1-32 The
shortcut menu
Tool Palettes displayed

The Tool Palettes, as shown in Figure 1-33, is an easy and convenient way of placing
components in the current drawing. By default, the Tool Palettes is not displayed. To invoke
the Tool Palettes, choose Tools > Palettes > Tool Palettes from the menu bar or choose the
CTRL+ 3 keys to display the Tool Palettes as a window on the left of the drawing area. You can
resize the Tool Palettes by using the resizing cursor that is displayed when you place the cursor
on the top or bottom of the Tool Palettes. The Tool Palettes contains different commands for
inserting components in Imperial and Metric units. When you move the Tool Palettes in the
drawing area and right-click on its title bar, a shortcut menu is displayed, as shown in Figure 1-34.
Using this shortcut menu, you can turn on or oft the Tool Palettes. Also, you can move, change
size, close, auto-hide, and dock the Tool Palettes. Also, you can create new palette, rename it,
and customize palettes and commands by choosing the desired option from the shortcut menu.
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Figure 1-33 The Tool Palettes  Figure 1-34 Shoricut menu displayed on right-clicking
on the title bar of the Tool Palettes
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File Tabs

The File Tabs button is available in the Interface panel of the View tab. It is used to
|.'_r| toggle the display of the File tab bar which displays all opened files. You can easily
[ switch between multiple opened drawings by clicking on them.

> Note
@ The View tab is not displayed by default in the AutoCAD Electrical interface. To display it,
\ right-click on the Ribbon; a shortcut menw will be displayed. Next, choose Show Tabs > View
from the shortcut menu.

You can also create a new drawing file by clicking on the (+) sign available at the end of the file
tabs. Figure 1-35 shows the File Tabs button chosen in the Ribbon and the File tab bar displayed
at the bottom of the Ribbon.

View
. B H 8 e S == A
S % g omit - | Bottom = @-O%- &- B8 Join = g = o
View Viewport Tool Properties SheetSet - Switch | File |Layout UCS | View Navigation
%, Extents - | (Left =| Manager Configuration ™ [ Restore | Palettes Manager ™y | Windows | Tabs | Tabs | |[Icon | Cube  Bar

Mavigate | Views Visual Styles = | Model Viewports Palettes + Interface u|  Viewport Tools +

Figure 1-35 The File Tabs button chosen in the Ribbon and File tab bar displayed at the
bottom of the Ribbon

In the File tab bar, all the added tabs get arranged in a sequence in which the respective drawings
are created. You can change the sequence of the tabs in the File tab bar by using the left mouse
button. To do so, press and hold the left mouse button on any tab and drag it to the desired
location. If a large number of files are opened, some of the files will not be visible in the File
tab bar and therefore an overflow symbol will be displayed on the right end of the File tab bar,
refer to Figure 1-36. To open a tab which is not visible in the File tab bar, click on the overflow
symbol; the names of all the tabs will be displayed in a flyout, refer to Figure 1-36. Also, when
you move the cursor on a tab name, previews of the Model and Layouts will be displayed, refer
to Figure 1-36. You can open the desired environment by clicking on its preview.
w DEHBL - &3 AUtaCAD Electrical 2020 - NOT FOR RESALE  Drawing2.dwg [T p— 88 8 sionin WA @ - O x
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Figure 1-36 Flyout with file tab names and preview of their respective drawings
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If you move the cursor over a file tab, the preview of the model and layout will be displayed.
When you move the cursor over any preview in the file tab, the corresponding preview will be
displayed in an enlarged form in the drawing area, refer to Figure 1-37.
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Figure 1-37 Previews of model and layout

There are two buttons available on the top of the preview window: Plot and Publish. By using
Plot, you can plot the drawing and by using Publish, you can publish the drawing. When you
right-click on a file tab, a shortcut menu containing various options such as New, Open, Save,
Save As, Close, and so on will be displayed, refer to Figure 1-38. You can choose the option
from the shortcut menu as per your requirement.

)\ Y i i
MNew...

Open...

Mopli2D Wireframe]

Save

Save As...
Sawve All

Close
Close All
J Close All Except This Tab

Copy Full File Path
Open File Location

T

Figure 1-38 Shortcut menu displayed on right-clicking on the File tab bar

There are two icons displayed on the file tab: Asterisk and Lock. The Asterisk icon indicates
that the file is modified but not saved. The Lock icon indicates that the file is locked and the
changes cannot be saved with the original file name, although you can use the SaveAs tool to
create another copy.

To open a drawing as a locked file, first choose the Open option from the shortcut menu displayed
on right-clicking over the file tab; the Select File dialog box will be displayed. Select the desired
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file and then select the Open Read-Only option from the Open drop-down list. On doing so,
the file will be opened as a locked file in the drawing area. You can also open the file as a locked
file by using the Open button from the Quick Access Bar.

PROJECT MANAGER

. - . X 2. ~
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Electrical DIALOG BOXES S
In AutoCAD Electrical, there are certain commands, which when
invoked, display a dialog box. When you choose an item with
ellipses [...] from the menu bar, a dialog box will be displayed.
For example, when you choose Options from the Tools menu,
the Options dialog box will be displayed.

Title 1: Sample Project - Schematics
and Panel Layout

> PROJECT MANAGER

Figure 1-39 The PROJECT
MANAGER

A dialog box contains a number of parts like dialog label, radio buttons, text or edit boxes, check
boxes, slider bars, image boxes, and command buttons. These components are also referred to
as tiles. Some of the components of a dialog box are shown in Figure 1-40.
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Figure 1-40 Components of a dialog box
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The title bar displays the name of the dialog box. The tabs specify various sections with a group
of related options under them. The check boxes are toggle buttons for making a particular option
available or unavailable. The drop-down list displays an item and an arrow on the right which
when selected displays a list of items to choose from. You can also select a radio button to activate
the option corresponding to it. Only one radio button can be selected at a time. The text box
is an area where you can enter a text like a file name. It is also called an edit box because you
can make any change to the text entered. In some dialog boxes, there is the [...] button, which
displays another related dialog box. There are certain command buttons (OK, Cancel, Help)
at the bottom of the dialog box. The dialog box has a Help button for getting help on various
features of the dialog box.

SAVING THE WORK

Command: QSAVE, SAVEAS, SAVE

E In AutoCAD Electrical, you need to save your work before you exit from the drawing

editor or turn off the system. Also, it is recommended that you save your drawings after
regular time intervals, so that in the event of a power failure or an editing error, all work
done by you is not lost and only the unsaved part is affected.

AutoCAD Electrical has provided the QSAVE, SAVEAS, and SAVE commands that allow you
to save your work on the hard disk of a computer. These commands allow you to save your
drawing by writing it to a permanent storage device such as a hard drive, or a diskette in any
removable drive.

When you choose Save from the Quick Access Toolbar or Application Menu, the QSAVE
command is invoked. If the current drawing is unnamed and you save the drawing for the first
time in the present session, the QSAVE command will prompt you to enter the file name in
the Save Drawing As dialog box. You can enter a name for the drawing and then choose the
Save button. If you have saved a drawing file once and then edited it, you can use the QSAVE
command to save it. This allows you to do a quick save.

When you invoke the SAVEAS command, the Save Drawing As dialog box will be displayed, refer
to Figure 1-41. Even if the drawing has been saved with a file name, this command provides you
with an option to save it with a different file name. In addition to saving the drawing, it allows
you to set a new name for the drawing, which is displayed in the title bar.

This command is used when you want to save a previously saved drawing under a different file
name. You can also use this command when you make certain changes to a template and want
to save the changed template drawing without changing the original template.

The SAVE command is the most rarely used command and can be invoked only from the
command line by entering SAVE at the Command prompt. This command is similar to the
SAVEAS command and displays the Save Drawing As dialog box when invoked. With this
command, you can save a previously saved drawing under a different file name.
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Figure 1-41 The Save Drawing As dialog box

Save Drawing As Dialog Box
The Save Drawing As dialog box displays the information related to drawing files on your
system. Various options in this dialog box are described next.

Places List

A column of icons is displayed on the left in the dialog box. These icons contain shortcuts to the
folders that are frequently used. You can quickly save your drawings in one of these folders. The
History folder displays the list of the most recently saved drawings. The FTP folder displays
the list of various FTP sites available for saving a drawing. By default, no FTP sites are shown in
the dialog box. To add a FTP site to the dialog box, choose the Tools button at the upper-right
corner of the dialog box to display a shortcut menu and select Add/Modify FTP Locations. The
Desktop folder displays the list of contents on the desktop. The Buzzsaw icons connect you to
their respective pages on a Web.

File name
To save your work, enter the name of the drawing in the File name edit box by typing the file
name or selecting it from the drop-down list.

Files of type
The Files of type drop-down list, as shown in Figure 1-42, is used to specify a drawing format in

which you want to save a file. For example, to save a file as an AutoCAD 2004 drawing file, select
AutoCAD 2004/LT 2004 Drawing (*.dwg) from this drop-down list.

Files of pe: (A t0CAD 2018 Drawing (".dwa) >
| AutoCAD 2018 Drawing (*dwg)

#AutoCAD 2013/LT2013 Drawing (-dwg)

AutoCAD 2010/LT2010 Drawing (“dwg)
AutoCAD 2007/LT2007 Drawing (*cwg)
AutoCAD 2004/LT2004 Drawing (" dwg)
AutaCAD 2000/LT2000 Drawing (*dwg)
AutoCAD R14/LTI8/LTS7 Drawing (" dwg)
AutoCAD Drawing Standards (~cws)
AtoCAD Drawing Template "dwt)
AutoCAD 2018 DXF (" dd)
AutoCAD 2013/LT2013 DXF (*cd)
AutoCAD 2010/LT2010 DXF [*d)
AutoCAD 2007/LT2007 DXF (*d)
AutoCAD 2004/LT2004 DXF (")
AutoCAD 2000/LT2000 DXF [*)
,AutoCAD R12/LT2 DXF (".cbd)

Figure 1-42 The Files of type drop-down list
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Save in

The active project is listed in the Save in drop-down list. AutoCAD Electrical initially saves the
drawing in the folder of the active project. But if you want to save the drawing in a different folder,
you need to specify the path.

Views

Views =
The options in the Views flyout are used to specify how the list of files N
will be displayed in the Save Drawing As dialog box, refer to Figure 1-43. v breien

These options are discussed next. Figure 1-43 The

List, Details, and Thumbnails Options Views flyout

The Files list box displays the drawing files of a project. If you choose the Details option, it will
display the detailed information about files (size, type, date, and time of modification) in the
Files list box. In the detailed information, if you click on the Name label, the files will be listed
with names in alphabetical order. If you again click on the Name label, the files will be listed in
the reversed order. Similarly, if you click on the Size label, the files will be listed according to
their size in ascending order. Double-clicking on the Size label will list the files in descending
order of their size. Similarly, you can click on the Type label or the Modified label to list the files
accordingly. If you choose the List option from the Views flyout, all files in the current folder
will be listed in the File list box.

Tip

Q The file name you enter to save a drawing should match its contents. This helps you to
remember drawing details and makes it easier to refer to them later. Also, the file name can
be 255 characters long and can contain spaces and punctuation marks.

Create New Folder
E—| If you choose the Create New Folder button, AutoCAD Electrical will create a new
+ folder with the name New Folder. The new folder is displayed in the File list box. You
can accept the name or change it as per your requirement. Alternatively, press ALT+5
to create a new folder.

Up one level
I':"| The Up one level button is used to display the folders that are up by one level.
& Alternatively, press ALT+2 to display the folder.

Search the Web

[E On choosing this button, the Browse the Web - Save dialog box will be displayed. This
dialog box enables you to access and store AutoCAD Electrical files on Internet. You can
also use the ALT+3 keys to access and store files on the Internet when this dialog box

is available on the screen.

Tools

The Tools flyout has an option for adding or modifying the FTP sites, refer to Figure 1-44. These
sites can then be browsed from the FTP shortcut in the Places list. The Add Current Folder to
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Places and Add to Favorites options are used to add the folder displayed in the Save in edit
box to the Places list or to the Favorites folder.

The Options button, when chosen, displays the Saveas Options = Add mlm dify FTP Locations
dialog box where you can save the proxy images of custom T P
objects. This dialog box has the DWG Options and DXF Add to Favorites >
Options tabs. The Display Signatures button displays the
Security Options dialog box that is used to configure the security
options of a drawing.

AUTO SAVE

AutoCAD Electrical allows you to save your work automatically at specific intervals. To change
the time intervals, you can enter the interval’s duration in minutes in the Minutes between
saves text box in the File Safety Precautions area of the Options dialog box (Open and Save
tab). This dialog box can be invoked from the Tools menu. Depending on the power supply,
hardware, and type of drawings, you should decide on an appropriate time and assign it to this
variable. AutoCAD Electrical saves the drawing with the file extension .sv$. You can also change
the time interval by using the SAVETIME system variable.

Options...

Digital Signatures...

Figure 1-44 The Tools flyout

Tip

O Although the automatic save option saves your drawing afler a certain time interval, you
should not completely depend on it because the procedure for converting the sv$ file into a
drawing file is cumbersome. Therefore, it is recommended that you save your files regularly
by using the QSAVE or SAVEAS command.

CREATING BACKUP FILES

If a drawing file already exists and you use the SAVE or SAVEAS command to update the current
drawing, AutoCAD Electrical will create a backup file. AutoCAD Electrical takes the previous copy
of the drawing and changes it from a file type .dwg to .bak, and the updated drawing is saved
as a drawing file with the .dwg extension. For example, if the name of a drawing is myproj.dwg,
AutoCAD Electrical will change the name to myproj.bak and save the current drawing as myproj.dwg.

Using the Drawing Recovery Manager to Recover Files

The automatically saved files can also be retrieved using the Drawing Recovery Manager. If
the system crashes accidently and the automatic save operation is performed on a drawing, the
Drawing Recovery dialog box will be displayed when AutoCAD Electrical is run the next time,
as shown in Figure 1-45.

The dialog box informs you that the program unexpectedly failed and you can open the most
suitable file from the backup files created by AutoCAD Electrical. To open the most suitable
file among the backup files, choose the Close button from the Drawing Recovery dialog box;
the Drawing Recovery Manager will be displayed on the left of the drawing area, as shown in
Figure 1-46. The Backup Files rollout lists the original files, backup files, and automatically
saved files. Select the required file; the preview of the file will be displayed in the Preview rollout.
Also, the information corresponding to the selected file will be displayed in the Details rollout.
To open the backup file, double-click on its name in the Backup Files rollout. Alternatively,
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right-click on the file name, and then choose Open from the shortcut menu. It is recommended
that you save the backup file at the desired location before you start working on it.

% || Backup Files -
M & & DEmonz -
¥ | o = DEMOD3 A
- [= DEMO04 3
[+-{[== DEMO05
+-[= DEMO06
+-{== DEMOOT -
Details =
[=
]
L]
=
=
<
=
" Drawing Recovery * E
]
In your previous work session, the program %
terminated unexpectedly. You can restore unsaved ot Pr e -
changes from a backup file by using the Drawing =5
Recovery Manager. %
© Show detais e
[7] Do not show me this message again i'l

Figure 1-45 The Drawing Recovery dialog box Figure 1-46 The Drawing Recovery
Manager

CLOSING A DRAWING

You can close the current drawing file without actually quitting AutoCAD Electrical by using the
CLOSE command. If multiple drawing files are opened, choose Close > All Drawings from the
Application Menu; the drawings will be closed. If you have not saved the drawing after making
the last change to it and you invoke the CLOSE command, AutoCAD Electrical will display a
dialog box that allows you to save the drawing before closing it. This box provides you with an
option to discard the current drawing or the changes made to it. It also provides you with an
option to cancel the command. After closing the drawing, you are still in AutoCAD Electrical
from where you can open a new or an already saved drawing file. You can also use the close
button (X) to close the drawing.

Note
You can close a drawing even if a command is active.
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QUITTING AutoCAD Electrical

You can exit the AutoCAD Electrical program by using the EXIT or QUIT command. Even if you
have an active command, you can choose Exit AutoCAD Electrical from the Application Menu
to quit the AutoCAD Electrical program. In case the drawing has not been saved, the AutoCAD
message box will be displayed. Note that if you choose No in this message box, all changes
made in the current drawings, till they were last saved, will be lost. You can also use the close
button (X) of the main AutoCAD Electrical window (present in the title bar) to end the AutoCAD
Electrical session.

Tip

O You can open the Drawing Recovery Manager again by choosing Drawing
Utilities > Open the Drawing Recovery Manager from the Application Menu or by
entering DRAWINGRECOVERY at the Command prompt.

DYNAMIC INPUT MODE

As mentioned earlier, turning the Dynamic Input mode on allows you to enter commands
through the pointer input and dimensions using the dimensional input. When this mode is
turned on, all prompts will be available at the tooltip as dynamic prompts. The settings for the
Dynamic Input mode are made through the Dynamic Input tab of the Drafting Settings dialog
box. To invoke the Drafting Settings dialog box, right-click on the Dynamic Input button in the
Status Bar; a shortcut menu will be displayed. Choose the Dynamic Input Settings option from
the shortcut menu; the Drafting Settings dialog box will be displayed, as shown in Figure 1-47.
Alternatively, enter DSETTINGS at the Command prompt to display the Drawing Settings
dialog box. The options in the Dynamic Input tab of the Drafting Settings dialog box are
discussed next.

Enable Pointer Input

With the Enable Pointer Input check box selected, you can enter commands through the pointer
input. Figure 1-48 shows the AEWIRE command entered through the pointer input. If this check
box is cleared, the Dynamic Input will be turned off and the commands will be entered through
the Command prompt in a way similar to the old releases of AutoCAD Electrical.

On choosing the Settings button from the Pointer Input area, the Pointer Input Settings dialog
box will be displayed, as shown in Figure 1-49. The radio buttons in the Format area of this dialog
box are used to set the default settings for specifying other points, after specifying the first point.
By default, the Polar format and Relative coordinates radio buttons are selected. As a result,
coordinates will be specified in the polar form, with respect to the relative coordinates system. You
can select the Cartesian format radio button to enter coordinates in the cartesian form. Likewise,
if you select the Absolute coordinates radio button, numerical entries will be measured with
respect to the absolute coordinate system.
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A Drafting Settings
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Figure 1-47 The Dynamic Input tab of the Drafting Settings dialog box

Pointer Input
AEWIRE

Figure 1-48 Entering a command
using the pointer input

A Pointer Input Settings ped
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(@ When a command asks for a point

() Always - even when not in command

Figure 1-49 The Pointer Input
Settings dialog box

The Visibility area in the Pointer Input Settings dialog box is used to set the visibility of tool
tips of coordinates. By default, the When a command ask for a point radio button is selected.
You can select the other radio buttons to modify this display.



Introduction to AutoCAD Electrical 2020 1-31

CREATING AND MANAGING WORKSPACES

Aworkspace is defined as a customized arrangement of toolbars, menus, and window palettes in
the AutoCAD Electrical environment. Workspaces are required when you need to customize the
AutoCAD Electrical environment for a specific use, in which you need only a certain set of
toolbars and menus. For such requirements, you can create your own workspaces in which
only the specified toolbars, menus, and palettes will be available. By default, the ACADE &
2D Drafting & Annotation workspace is set as the current workspace when you start AutoCAD
Electrical. You can choose any other predefined workspace from the shortcut menu that will
be displayed on choosing the Workspace Switching button in the Status Bar or by choosing
the required workspace from Tools > Workspaces in the menu bar. You can also choose the
workspace using the Workspaces toolbar.

Creating a New Workspace

To create a new workspace, invoke the toolbars and window palettes that you want to display in
the new workspace. Next, choose Tools > Workspaces > Save Current As from the menu bar;
the Save Workspace dialog box will be displayed, as shown in Figure 1-50. Enter the name of
the new workspace in the Name edit box and choose the Save button from the dialog box.

A Save Workspace 4

Name: v‘ | Save |

Cancel

Figure 1-50 The Save Workspace dialog box

The new workspace will now be the current workspace in the shortcut menu that is displayed
on choosing the Workspace Switching button on the Status Bar. Likewise, you can create
workspaces as per your requirement and can switch from one workspace to the other by selecting
the required name of the workspace from the drop-down list in the Workspaces toolbar.

Modifying Workspace Settings

AutoCAD Electrical allows you to modify workspace settings. To do so, choose the Workspace
Switching button from the Status Bar; a flyout will be displayed. Choose the Workspace Settings
option from the flyout; the Workspace Settings dialog box will be displayed, as shown in
Figure 1-51. All workspaces that are created are listed in the My Workspace drop-down list. You
can make any of the workspaces as My Workspace by selecting it in the My Workspace drop-down
list. You can also choose the My Workspace tool from the Workspace Switching toolbar to
change the current workspace to the one that was set as My Workspace in the Workspace
Settings dialog box. The other options in this toolbar are discussed next.

Menu Display and Order Area

The options in this area are used to set the order of the display of workspaces in the drop-down
list of the Workspaces toolbar. By default, workspaces are listed in the sequence of their creation.
To change the order, select the workspace and choose the Move Up or Move Down button.
You can also add a separator between workspaces by choosing the Add Separator button. A
separator is a line that is placed between two workspaces in the shortcut menu that is displayed
on choosing the Workspace Switching tool in the Status Bar.
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A Workspace Settings X
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[/]ACADE & 3D Modeling
[/]2D Dratting & Annotation
3D Modeling
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Add Separator
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(@) Do not save changes to workspace

O Automatically save workspace changes

Figure 1-51 The Workspace Settings dialog box

When Switching Workspaces Area

By default, the Do not save changes to workspace radio button is selected in this area. As a
result, while switching workspaces, the changes made in the current workspace will not be saved.
If you select the Automatically save workspace changes radio button, the changes made in the
current workspace will automatically be saved when you switch to the other workspace.

WD_M BLOCK

Most of the settings of a drawing used by AutoCAD Electrical are saved in a smart block on the
drawing, called WD_M.dwg. Every drawing of AutoCAD Electrical should consist of non-visible
WD_M block to make the drawing compatible with AutoCAD Electrical. The drawing should
consist of only one copy of WD_M block. The WD_M.dwg block is situated in the default symbol
library. The WD_M.dwg consists of various attributes that define layer names, default settings,
and so on. If the WD_M block is not present in the existing or new drawing and if you want to
insert any electrical component or want to edit drawing properties, then the Alert message box
will be displayed, as shown in Figure 1-52. Choose the OK button in this message box to insert
the WD_M block at 0,0 location. By default, the Force this drawing’s configuration settings
to match the project settings check box is selected. As a result, the drawing settings will be
matched to the project settings.

Note
For inserting panel layout symbols in the drawing, you need to insert the WD_PNLM block, which
will be discussed in Chapter 8.
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Alert *

Special block "WD_M" needs to be
added to this drawing for full "WO_M® @ 0,0
compatibility with the AutoCAD Electrical

application software and utilities. i

Force this drawing's configuration seftings to match the project setings

Okay to insert this non-visible block now?

MNofCancel Help

Figure 1-52 The Alert message box

AutoCAD Electrical HELP

You can get online help and documentation about the working of AutoCAD Electrical 2020
commands from the Help menu in the menu bar, refer to Figure 1-53. You can access the Help
menu for a particular tool. To do so, place the cursor on the particular tool and then press the
F1 key; the AutoCAD Electrical 2020 - Help window will be displayed. This window displays
the detailed description related to that particular tool. The menu bar also contains InfoCenter
bar, as shown in Figure 1-54. This bar helps you search information by using certain keywords.
The options in the Help menu and the InfoCenter bar are discussed next.

[7] Help

‘» [1vpe a keyword or phrase [88 2 signin S B @ -

3
Learning Tools Textbox 44‘]»
Search

Additional Resources 3 Autodesk 360
Autodesk App
Store

Customer Invelvement Pragram... Stay

Connected
About AutoCAD Electrical Help

Figure 1-53 The Help menu Figure 1-54 The InfoCenter bar

Help Menu

Electrical Help Topics
On choosing the Help option, the AutoCAD Electrical 2020 - Help window will be displayed.
Figure 1-55 shows partial view of the AutoCAD Electrical 2020 - Help window.

You can use this window to access help on different topics and commands. If you are in the middle
of a command and require help regarding it, choose the Help button to display information
about that particular command in the dialog box.

In this window, you can choose the Help Home button to explore new features in AutoCAD
Electrical 2020. Also, you can browse videos, tutorials, and documentation for beginners and
advanced users in the Essential Skills Videos and Resources sections. You can download sample
files and offline help database from the Downloads section. You can also connect to other users
of Autodesk community and discussion groups using the Connect section.
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Figure 1-55 Partial view of the AutoCAD Electrical 2020 - Help window

Click on the + sign at the left of these sections to display the list of topics under them. Next,
select a topic from the list; contents of the selected topic will be displayed at the right side of
the AutoCAD Electrical 2020 - Help window.

Search Field
When you type any word in the Search edit box and then choose the Search button, a list of
topics related to the typed word will be displayed below the Search button. You can select

the desired topic from the list; the information related to that topic will be displayed in the
AutoCAD Electrical 2020 - Help window.

Learning Resources

Choose Help > Learning Tools > Learning Resources from the menu bar; the AutoCAD
Electrical 2020 - Help window will be displayed. Using this window, you can access information
about topics such as user interface, AutoCAD Electrical Quick Reference Guide, AutoCAD
Electrical 2020 Toolset New Feature Summary, and so on. When you choose a topic, the
description of the feature improvements will be displayed in a window.

Additional Resources

This utility connects you to the Support Knowledge Base, Online Training Resources, Online
Developer Center, Developer Help, API Help, and Autodesk User Group International web
pages. The Developer Help option provides a detailed help on customizing AutoCAD Electrical
in a separate window. You can click on any link on the right of this window.

About AutoCAD Electrical

This option gives you information about the Release, Serial number, Licensed to, and also the
legal description about AutoCAD Electrical.
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InfoCenter Bar

InfoCenter

InfoCenter is an easy way to get the desired help documentation. Enter the keywords to be
searched in the textbox and choose the Search button; the result will be displayed as a link
in the AutoCAD Electrical 2020 - Help window, refer to Figure 1-56. To display the required
information in this window, click on any one of the search topics from the list, the information

related to the search topic will be displayed at the right of the window.
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Figure 1-56 The search results displayed using InfoCenter

Autodesk App Store

Autodesk App Store helps you to download various applications for AutoCAD Electrical, get
connected to the AutoCAD network, share information and designs, and so on. On choosing
the Autodesk App Store button from the InfoCenter bar, the AUTODESK APP STORE
window will be opened, refer to Figure 1-57.

O @ 8 Aedesk e U5] g/ appravtodeskcom x =L oe

{\ AUTODESK C Engisn+

g
Free Autodesk Subscription Benefit Apps For Educational Usgis!
crption Benefit Apps are now froefor Studonts, Educatoraand Educational

AUOCAD Electical~ [ - |

Featured Apps

@
Ao B 8

Most Popular Apps

Figure 1-57 The AUTODESK APP STORE window

You can download various Autodesk apps from this page. Some of them are free of cost. You can
also search for the apps by entering the name of the app in the Search Apps text box. You can
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download the AutoCAD apps from the Featured Apps panel of the Featured Apps tab in the
Ribbon, refer to Figure 1-58. To download the AutoCAD apps, choose the required apps from
the Featured Apps panel of the Feature Apps tab; the default browser will open with the icons
of the apps to be downloaded. Now, you can download the app.

Home Project Schematic Panel Reports Import/Export Data  Electromechanical ~ Conversion Tools ~ Add-ins  Collaborate  Featured Apps =~ (2~
“ e " - & 3
i =™
—* Scatter PlOtDWG

CAD Studio

- ®

d Poly " FdPoly > M,
3dPolyFillet 3dPolyfillet O

Select

Mode

App Store Featured Apps Touch

Figure 1-58 The Featured Apps panel of the Feature Apps tab in the Ribbon

S, | J1BCAD
Connec tto [N S omaton
App Store

You can also download apps other than the apps available in the Featured Apps panel. To do
so, choose the Connect to App Store button from the App Store panel of the Featured Apps
tab; the AUTODESK APP STORE window will be displayed, refer to Figure 1-57. Next, choose
Show All from the AUTODESK APP STORE window. Now, you can download the required
apps from the window. You can also search apps by entering the name of the required app in
the Search Apps text box. Some of the apps are paid and some of them are free to download.

The downloaded and installed apps will be available in the Add-Ins tab. You can choose the
required app to work with and can manage it by choosing the Exchange App Manager button
available in the App Manager panel of the Add-Ins tab. To manage the app, choose the App
Manager button from the App Manager panel in the Add-ins tab; the Autodesk App Manager
dialog box with all the installed apps will be displayed. To manage a particular app, right-click
on it; a shortcut menu will be displayed, as shown in Figure 1-59. Now, you can choose the
required option to manage the app.

& Autodesk App Manager X
=
Name Version Product Company Date Installed Size Status Help
= Autodesk App D Autodesk 4/16/2019 1926 MB  Unknown App (7]
7] Autodesk Fea Help D Autodesk 41672018 1688 MB  Unknown App
Update
Uninstall
Rate this App
e Launch the Autodesk App Store website Cancel

Figure 1-59 The Autodesk App Manager dialog box
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Stay Connected
“A. . When you choose this button, a flyout is displayed, as shown in Figure 1-60. The options
in this flyout provide you quick access to the subscription center and social media.

Connect with Autodesk
Autodesk Account

Autodesk Certified Hardware

AutoCAD on the web
AutoCAD Blog
YouTube
Facebook

Twitter

Figure 1-60 The flyout
displayed

SAVE TO WEB & MOBILE
Command: SAVETOWEBMOBILE

Using the Save to Web & Mobile tool, you can save copy of your drawings in your Autodesk

web & mobile account from any remote location in the world using any device such as
desktop or mobile having internet access. You can access this tool from the Quick Access Toolbar
or Application Menu. When you choose this tool for the first time, you will be prompted to
install the Save to AutoCAD Web and Mobile Plug-in.

Choose the Save to Web & Mobile tool from the Quick Access Toolbar; the Install Save to
AutoCAD Web & Mobile window will be displayed, refer to Figure 1-61.

A Install Save to AutoCAD Web & Mobile X

,! This feature requires the installation of the Save to
* AutoCAD Web & Mobile Plug-in

‘When installed, this feature allows you to save files so they can be viewed
and edited on AutoCAD Mobile and AutoCAD Web applications.

[11 have read and agree to the App Store End User License Agreement

Learn more about Save to AutoCAD Web & Mabile.

Install
Figure 1-61 The Install Save to AutoCAD Web & Mobile window

Select the I have read and agree to the App Store End User License Agreement check box
from this window; the Install button will be activated. Next, choose the Install button. Once
the installation process is complete, the Save in AutoCAD Web & Mobile dialog box will be
displayed, refer to Figure 1-62.

Enter the name of the file to be saved in the File name edit box. Next, choose the Save button.
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A Save to AutoCAD Web & Mobile: X

Savein AutoCAD Web & Mobile

Name Date modified Size

File name: | Drawing1

Figure 1-62 The Save in AutoCAD Web & Mobile dialog box

Note
1. The name of the saved files appear in the Name column of the list box available in the Save
in AutoCAD Web & Mobile dialog box when you invoke this dialog box again.

o

2. You need to first sign in to your Autodesk account to use this tool. If you are not signed in and
choose this tool, the Autodesk sign-in window will appear and will prompt you to sign in first.

3. The drawing files saved in your web and mobile account are saved to the cloud and utilise
the cloud space. You can save them to your device by using the Save As tool.

4. You can also shave the saved files with any of the co-workers or clients across the world. They
can review or edit the drawing files depending upon the permissions you grant them.

After saving the file to your web and mobile account, you can access it from anywhere across the
world using any device (mobile, tablet, etc) having Wi-fi or internet connection.

Note
You can access the saved web and mobile files using the Open from Web & Mobile tool available
in the Quick Access Toolbar.

ADDITIONAL HELP RESOURCES

1. You can get help for a command by pressing the F1 key. On doing so, the AutoCAD Electrical
2020 - Help window containing information about the command will be displayed. You can
exit the dialog box and continue working with the command.

2. You can get help about a dialog box by choosing the Help button in that dialog box.

3. Autodesk has provided several resources that can be used to seek assistance for your
AutoCAD Electrical questions. The following is a list of some of the resources:

a. Autodesk website: hitps://www.autodesk.com
b. AutoCAD Electrical Technical Assistance website: https://knowledge.autodesk.com
c.  AutoCAD Electrical Discussion Groups website
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4. CADCIM Technologies provides technical support for the study material discussed in our
textbooks. Send us an email at techsupport@cadcim.com to seek technical assistance.

Note
For the printing purpose, this textbook will follow the white background.

Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this
chapter:

1. Which of the following combinations of keys should be pressed to turn the display of the
Tool Palettes window on or off?

(a) CTRL+3 (b) CTRL+0
(c) CTRL+5 (d) CTRL+2

2. If WD_M block is not present in a drawing and you insert a component in it, then the
message box will be displayed.

3. The option in the Workspace Switching flyout is used to save the current
workspace settings as a new workspace.

4. You can use the command to close the current drawing file without actually
quitting AutoCAD Electrical.

5. You can retrieve the automatically saved files by using the

6. The button in the Application Status Bar is used to display the expanded view
of the drawing.

7. You can press the F3 key to display the AutoCAD Electrical text window that displays
previously used commands and prompts. (1/F)

8. You cannot create a new drawing using the PROJECT MANAGER. (1/F)

9. AutoCAD Electrical marking menu will be displayed when you right-click on the AutoCAD
Electrical object such as component, wire, and so on. (1/F)

10. You can press the F1 key to display the AutoCAD Electrical 2020 - Help window. ('1/F)
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Review Questions

Answer the following questions:

1. Which of the following combinations of keys needs to be pressed to toggle display of all
toolbars displayed on the screen?

(a) CTRL+3 (b) CTRL+0
(c) CTRL+5 (d) CTRL+2

2. Which of the following commands is used to exit the AutoCAD FElectrical program?

(a) QUIT (b) END
(c) CLOSE (d) EXIT

3. Which of the following commands is invoked when you choose Save from the File menu or
choose the Save button in the Quick Access Toolbar?

(a) SAVE (b) LSAVE
(c) QSAVE (d) SAVEAS
4. The button is used to add or remove buttons in the Application Status Bar.
5. The button is used to toggle the display of the File tab bar which displays all
opened files.
6. The contains different commands for inserting components in Imperial and

Metric units.

7. The shortcut menu invoked by right-clicking in the command window displays the most

recently used commands and some of the window options such as Copy, Paste, and so on.
(T/F)

8. The F12 function key is used to toggle the Dynamic Input mode. (T/F)

Answers to Self-Evaluation Test
1.CTRL+3,2. Alert, 3. Save Current As, 4. CLOSE, 5. Drawing Recovery Manager, 6. Clean Screen,
7.F,8.F9.7,10. T



