Chapter 1

Introduction to
Solid Edge 2020

Learning Objectives

After completing this chapter, you will be able to:

* Understand the basic properties and different environments of Solid Edge
* Know the system requirements for installing Solid Edge 2020

* Get familiar with important terms and definitions

* Understand the user interface

* Save Solid Edge designs automatically after regular intervals
* Modify the color scheme
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INTRODUCTION TO Solid Edge 2020

Welcome to the world of Solid Edge 2020, a product of SIEMENS. If you are a new user of this
software, you will join hands with thousands of users of this high-end CAD tool worldwide.
This software helps the users to improve their design skills. Also, in this software, the user
interaction has been taken to a new level, thus making Solid Edge one of the easiest and
popular mechanical CAD products.

Solid Edge is a powerful software that is used to create complex designs with great ease. The
design intent of any three-dimensional (3D) model or an assembly is defined by its specification
and use. You can use the powerful tools of Solid Edge to capture the design intent of any complex
model by incorporating intelligence into the design. With Synchronous Technology, Solid Edge
redefines the rules of 3D modeling. It combines the speed and flexibility of modeling with
precise control of dimension-driven design, thereby generating tremendous productivity gains
over traditional methods.

In Solid Edge, the synchronous and traditional (now called Ordered) modeling environments
are combined into a single modeling environment. This means you do not need two separate
environments to work with synchronous and traditional modeling technologies. The most
interesting feature is that you can switch between the Synchronous Part and Ordered Part
environments and can convert a particular Ordered feature into a Synchronous feature.

To make the design process simple and efficient, this software package divides the steps of
designing into different environments. This means each step of the design process is completed
in a different environment. Generally, a design process involves the following steps:

*  Sketching by using the basic sketch entities and converting them into features or parts.
* These parts can be sheet metal parts, surface parts, or solid parts.

* Assembling different parts and analyzing them.

*  Generating drawing views of the parts and assembly.

All these steps are performed in different environments of Solid Edge, namely Synchronous
Part/Ordered Part, Assembly, Synchronous Sheet Metal/Ordered Sheet Metal, and Draft.

Solid Edge provides Software Development Kit (SDK) that helps you customize Solid Edge
according to your requirement. Solid Edge also provides assistance, tutorials, and technical
support to the users. The tutorials can be browsed from the welcome screen. You can view as well
as work on the models simultaneously. Solid Edge helps you find commands quickly by using
the Command Finder. The enhanced tooltip in Solid Edge provides you complete information
of a tool such as its name and description as well as the shortcut keys to invoke the tool.

Solid Edge supports data migration from various CAD packages such as AutoCAD, SOLIDWORKS,
Pro/E, Inventor, CATIA, and NX. As a result, you can convert all the files and documents created
in these software into a Solid Edge document. You can also view or change the settings of a file
while importing it. Solid Edge allows you to evolve a 3D model from a 2D drawing created in
the Draft environment of Solid Edge or imported from any other software.
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Solid Edge 2020 is a synchronous, parametric, and feature-based solid modeling software. The
bidirectional associative nature of this solid modeling software makes the design process very
simple and less time-consuming. The synchronous, parametric, feature-based, and bidirectional
properties of this software are explained next.

Synchronous Technology

The Synchronous Technology and the new commands and workflow concepts of Solid Edge has
made modeling in this software much easier, faster, and accurate than in any other parametric
modeling software package. This is because the synchronous technology enables you to create
sketches as well as to develop features in the same environment. Note that the features created
in the Synchronous Part environment do not depend on the order of their creation. Therefore,
the editing of the model becomes a lot easier. This state-of-the-art technology makes Solid Edge
2020 a completely feature-based 2D/3D CAD software package.

Parametric Nature

Parametric nature of a solid modeling package means that the sketch is driven by dimensions, or
in other words, the geometry of a model is controlled by its dimensions. For example, to model a
rectangular plate of 100X80 units, you can draw a rectangle of any dimension and then modify
its dimensions to the required dimensions of the plate. You will notice that the dimensions drive
the geometry of the sketch.

Therefore, using this parametric property, any modification in the design of a product can be
accomplished at any stage of the product development. This makes the design flexible.

Feature-based Modeling

A feature is defined as the smallest building block of a model. Any solid model created in
Solid Edge is an integration of a number of features. Each feature can be edited individually to
make any change in the solid model. As a result, the feature-based property provides greater
flexibility to the created parts.

The advantage of dividing a model into a number of features is that it becomes easy to modify
the model by modifying the features individually. For example, Figure 1-1 shows a model with
four simple holes near the corners of the plate.

Figure 1-1 Model with simple holes
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Now, consider a case where you need to change all outer holes to counterbore holes. In a
non-feature based modeling package, you need to delete all the holes and then create the
counterbore holes. However, in Solid Edge, you can modify some parameters of the holes in the
same part and convert the simple holes into counterbore holes, see Figure 1-2.

Figure 1-2 Model with counterbore holes
Bidirectional Associativity

The bidirectional associativity of a software package is defined as its ability to ensure that any
modification made in a particular model in one environment is also reflected in the same
model in the other environments. For example, if you make any changes in a model in the Part
environment, the changes will reflect in the same model in the Assembly environment and
vice-versa.

Consider the assembly shown in Figure 1-3. The piston is connected to the connecting rod through
a pin. Itis clear from the assembly that the diameter of the hole is more than what is required. In
an ideal case, the diameter of the hole on the piston should be equal to the diameter of the pin.

Figure 1-3 Piston, connecting rod, and pin assembly

Now, when you open the piston in the Part environment and modify the diameter of the hole on
it, the same modification is also reflected in the Assembly environment, as shown in Figure 1-4.
This is due to the bidirectional associative nature of Solid Edge.
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Figure 1-4 Assembly after modifying the diameter of the hole on the piston

Similarly, if the modification is made in the Assembly environment, the piston, when opened
in the Part environment, is also modified automatically. This shows that the Part and Assembly
environments of Solid Edge are associative by nature.

Now, consider the model shown in Figure 1-1. Its top and the sectioned front views are shown in
Figure 1-5. Now, when you open the model in the Part environment and modify the simple holes
near the corners of the plate, refer to Figure 1-1, into the counterbore holes, refer to Figure 1-2.
The same modification will not reflect automatically in the drawing views of the model in the
Draft environment. To reflect the modifications in the Draft environment, you need to update
them manually using the Drawing View Tracker or Update Views tool. These tools will be
discussed in Chapter 12. After updating the views using the Drawing View Tracker or Update
Views tool, the drawing will be displayed, as shown in Figure 1-6.

Figure 1-5 Drawing views of the model before modification

.~ Note
@ ' The modifications done in the views in the Draft environment do not reflect in other environments.
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Figure 1-6 Drawing views of the model after modification

Solid Edge ENVIRONMENTS

To reduce the complexity of a design, this software package provides you with various design
environments. You can capture the design intent easily by individually incorporating the
intelligence of each design environment into the design. The design environments available in
Solid Edge are discussed next.

Part Environment

This environment of Solid Edge 2020 is used to create solid as well as surface models. The Part
environment consists of two environments namely Synchronous Part and Ordered Part. You
can switch between these environments and create a model which consists of both synchronous
and ordered features. To invoke this environment, start Solid Edge 2020 by double-clicking
on its shortcut icon on the desktop of your computer. After Solid Edge 2020 starts, the theme
selection window will be displayed. In the theme selection window, select the required user
interface theme and then choose the OK button; the Solid Edge 2020 window along with
the welcome screen will be displayed. From this screen, choose the New command from the
Quick Access toolbar; the New dialog box will be displayed. Choose the iso metric part
option from this New dialog box; the Part environment gets started with ISO units. By default,
the Synchronous Part environment is invoked. However, you can switch to the Ordered Part
environment by choosing the Ordered radio button from the Model group of the Tools tab.

Note
1. The theme selection window will only be displayed when you start Solid Edge for the first time
after installation.

2. In this textbook, the Balanced (Solid Edge Default) theme is used as the user interface theme.

Synchronous Part

Solid Edge 2020 with the Synchronous Technology makes it a complete feature-based 2D/3D
CAD system. This technology combines the speed and flexibility of direct modeling with precise
control of dimension-driven design. In this environment, there is no separate environment to
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draw sketches; rather the sketching tools are available in the Synchronous Part environment
itself. It includes direct model creation and modification through precision sketching, region
selection, face selection, and handle selection.

Ordered Part

The Ordered Part environment of Solid Edge 2020 is used to create parametric and feature-based
solids as well as surface models. You can draw sketches of models or features by invoking the
sketching environment. Once the sketch is drawn, you can convert it into a solid model using
simple but highly effective modeling tools. One of the major advantages of using Solid Edge is
the availability of Command bar. The Command bar is displayed in the drawing window. In this
environment, you can create a feature step by step by using the Command bar. You can also use
the Command bar to easily go one or more steps backward to modify a parameter. You can also
convert the features created in this environment to the synchronous features for editing them
directly. The models created in the part environment can also be used in other environments of
Solid Edge to complete the model’s life cycle, also known as the Product Life Cycle.

Assembly Environment

This environment of Solid Edge is used to create an assembly by assembling the components
that were created in the Synchronous/Ordered Part environment. Both the synchronous
and ordered tools are combined in this environment. This environment supports animation,
rendering, piping, and wiring. Other visualization and presentation tools are also available in
this environment. In addition to that, you can apply a relation between the faces of two different
synchronous components in an assembly. For example, you can make the selected face of a
component tangent with the target face of another component.

Draft Environment

This environment is used for the documentation of the parts or the assemblies in the form of
drawing views. The drawing views can be generated or created. All the dimensions added to the
component in the part environment during its creation can be displayed in the drawing views
in this environment.

Sheet Metal Environment

This environment is used to create sheet metal components. If you are familiar with the part
environment, then modeling in this environment becomes easy. This is because in addition to the
sheet metal modeling tools, this environment works in a way similar to the part environment. To
invoke this environment, start Solid Edge 2020; a welcome screen will be displayed. Choose the
New command from the Quick Access toolbar; the New dialog box will be displayed. Choose
the iso metric sheet metal option from the New dialog box; the Sheet Metal environment gets
started with the ISO units. By default, the Synchronous Sheet Metal environment is invoked.
However, you can switch to the Ordered Sheet Metal environment by selecting the Ordered
radio button from the Tools tab.

Synchronous Sheet Metal

The Synchronous Sheet Metal environment is used to create and edit sheet metal components
in a history-free approach. The procedure of selection of faces introduced in this environment
allows you to model sheet metals directly. You can create a dimension-driven design of the sheet
metal components in Solid Edge.
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Ordered Sheet Metal
The Ordered Sheet Metal environment is used to create parametric and feature-based sheet
metal components.

SYSTEM REQUIREMENTS FOR INSTALLING Solid Edge
2020

The system requirements for Solid Edge 2020 are as follows:

Windows 10 Enterprise or Professional (64-bit only) version 1709 or later.
Internet Explorer 11(Internet Explorer is not required to be the default browser)
4GB RAM minimum

Disk space for installation = 6 GB

Screen Resolution: 1280 x 1024 or higher

65K colors

Microsoft Office Professional 2016 or Microsoft Office 365 Business

N OOt 00N =

IMPORTANT TERMS AND DEFINITIONS

Some important terms that are used in this textbook are discussed next.

Relationships

Relationships are the logical operations that are performed on a selected geometry to make it
more accurate by defining its position and size with respect to the other geometry. There are
two types of relationships available in Solid Edge and they are discussed next.

Geometry Relationships

These logical operations are performed on the basic sketched entities to relate them to the
standard properties such as collinearity, concentricity, perpendicularity, and so on. Although Solid
Edge automatically applies these relationships to the sketched entities at the time of drawing,
you can also apply them manually. You can apply different types of geometry relationships,
which are discussed next.

Connect
This relationship connects a point to another point or entity.

Concentric
This relationship forces two selected curves to share the same center point. The curves that
can be made concentric are circles, arcs, and ellipses.

Horizontal/Vertical
This relationship forces the selected line segment or two points to become horizontal or
vertical.

Collinear
This relationship forces two line segments to lie on the same line.
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Parallel
This relationship is used to make two line segments parallel.

Perpendicular
This relationship makes a line segment perpendicular to another line segment or series of
line segments.

Lock
This relationship is used to fix an element or a dimension such that it cannot be modified.

Tangent
This relationship is used to make the selected line segment or curve tangent to the selected
line or curve.

Equal
This relationship forces the selected line segments to be of equal length. It also forces two
curves to be of equal radius.

Symmetric
This relationship is used to force the selected sketched entities to become symmetrical about
a sketched line segment, which may or may not be a center line.

Rigid Set
This relationship is used to group the selected sketched entities into a rigid set so that they
behave as a single unit.

Feature Relationships (Only in Synchronous Part Environment)

The feature relationships are the relationships that are applied on a selected face to make it
geometrically related to the target face. These relationships are used to modify the parts created
in the Synchronous Part environment. These relationships are available in the Face Relate group
of the Home tab in the Ribbon in the Synchronous Part environment. The following types of
feature relationships can be applied between faces:

Concentric
This relationship makes the selected faces concentric with the target face.

Coplanar
This relationship makes the selected faces coplanar with the target face.

Parallel
This relationship enables you to make the selected faces parallel to the target face.

Perpendicular
This relationship helps you to make the selected faces perpendicular to the target face.

Tangent
This relationship makes the selected faces tangent with the target face.
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Rigid

This relationship is used to make all the faces in the selection set rigid with respect to each
other. This means, if either of the face is moved or rotated, then all the related faces will
also move or rotate, thereby maintaining the distance and orientation between them.

Ground
This relationship grounds or constrains the selected face in the model space. As a result,
the grounded faces can be neither moved nor rotated.

Symmetry
This relationship makes a selected face symmetric to a target face about a symmetry plane.

Equal
This relationship makes the radius of a selected cylindrical face equal to the radius of a
target cylindrical face.

Aligned Holes
This relationship is used to make the axes of multiple cylindrical faces coplanar.

Offset
This relationship is used to offset a face with respect to another face.

Horizontal/Vertical
This relationship forces a horizontal/vertical face or keypoint to align with another horizontal/
vertical face or keypoint.

Assembly Relationships

The assembly relationships are the logical operations that are performed on the components
to assemble them at their respective working positions in an assembly. These relationships are
applied to reduce the degrees of freedom of the components.

FlashFit
This relationship minimizes the efforts of applying various relationships like: Mate, Planar
Align, and so on by automatically positioning the component wherever required.

Mate
This relationship is used to make the selected faces of difterent components coplanar. You
can also specify some offset distance between the selected faces.

Planar Align
This relationship enables you to align a planar face with the other planar face.

Axial Align
This relationship enables you to make a cylindrical surface coaxial with the other cylindrical
surface.
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Insert
This relationship is used to mate the faces of two components that are axially symmetric
and also to make their axes coaxial.

Connect
This relationship enables you to connect two keypoints, line, or a face on two different parts.

Angle
This relationship is used to place the selected faces of different components at some angle
with respect to each other.

Tangent
This relationship is used to make the selected face of a component tangent to the cylindrical,
circular, or conical faces of the other component.

Cam
This relationship applies the cam-follower relationship between a closed loop of tangent
face and the follower face.

Parallel
The Parallel relationship is used to force two edges, axes, or an edge and an axis parallel
to each other.

Gear
The Gear relationship allows you to apply rotation-rotation, rotation-linear, or a linear-linear
relationship between two components.

Center-Plane
This relationship is used to align a component at an equal distance between the two faces
of other component, planes, or key points.

Path
This relationship is used to apply a mate such that the part moves along a path.

Match Coordinate Systems
This relationship is used to match the coordinate system of one component/part with the
coordinate system of another component/part.

Rigid Set
This relationship is used between two or more components to fix them such that they become
rigid with respect to each other.

Ground
This relationship is used to fix a component at a specified location and orientation. Solid
Edge automatically applies a ground relationship to the first part placed in an assembly.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com



Evaluation Copy. Do not reproduce. For information visit www.cadcim.com

1-12 Solid Edge 2020 for Designers

Entity

An element of a geometry is called an entity. An entity can be an arc, line, circle, point, and so on.

Concept of a Profile and a Sketch

In Solid Edge, there are two methods of drawing a sketch. The first method is to draw a sketch
in the sketching environment by invoking the Sketch tool from the Home tab. The second
method is to invoke a feature creation tool such as Extrude, Revolve, and so on and then draw
the sketch for the feature. The sketch drawn using the first method is called a Sketch and the
sketch drawn using the second method is called a Profile. You will learn more about this in the
later chapters of this book.

Note
@ 1. If you are working in the Synchronous Part environment, you cannot invoke a feature creation
tool such as Extrude and Revolve if you do not have a sketch.

2. In the Synchronous Part environment, you can select the sketching tools without switching to
another environment.

Intent Zone

The intent zone is defined by a circular area that is divided into four quadrants. It is used
while drawing an arc or a circle from a line or vice-versa. The quadrants define whether the
element is perpendicular, tangent, or at some other orientation from the other element. This
zone enables you to draw or modify various elements of a geometry within the same tool. For
example, while drawing a line tangent to an arc, you can draw a tangent arc or a perpendicular
arc by moving the cursor in the intent zone. The movement of the cursor in the intent zone
determines the creation of a tangent or a perpendicular arc. The intent zone while drawing a
tangent arc and a three point arc is shown in Figures 1-7 and 1-8, respectively.

I

-

Intent zone

Intent zone’

Figure 1-7 Intent zone displayed while Figure 1-8 Intent zone displayed while
drawing a tangent arc drawing a three point arc

GETTING STARTED WITH Solid Edge 2020

After you have installed Solid Edge on your computer, double-click on the shortcut icon of
Solid Edge 2020 on the desktop of your computer; the welcome screen will be displayed. In
this screen, links for various environments will be displayed after you select the New command
from the Quick Access toolbar. You can start a new document in the desired environment by
clicking on the corresponding link in this area. As discussed earlier, the designing steps in Solid
Edge are performed in different environment.
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You can open the existing documents by choosing the Browse button from the Open area. The
links for the recently used files are displayed in the Recent Files area. You can click on the link
of the required document in this area to open that document. The welcome screen also displays
the link for the step-by-step tutorials in the Learn Solid Edge area. The Links area contains
the links for the home page and the components catalog page of Solid Edge. However, you
can add or remove links by using the Edit button available at the top-right corner of the Links
area. Choose the ISO Metric Part from the New area of the welcome screen; a new Solid Edge
document in the Synchronous Part environment will be displayed, as shown in Figure 1-9.
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Figure 1-9 New document in the Synchronous Part environment

USER INTERFACE OF Solid Edge

Solid Edge provides you a Ribbon with different tabs and groups. There are different tabs
and groups for different working environments. Every environment has the PathFinder and
the prompt line that assist you in creating the design. Various components of the interface are
discussed next.

Prompt Line
If you invoke a tool, the prompt line is displayed in the prompt ==

S . : : @ Part0
bar. This line is very useful for creating a model because it provides & Base

you with the prompt sequences to use a tool. Material (None]
= | Base Reference Planes
- £ Top ()
PathFinder ] Right (yz]
The PathFinder, as shown in Figure 1-10, is on the left in the L] Frant fa)
| Synchronous

drawing area. It lists all the occurrences of features and sketches
of a model in a chronicle sequence. Figure 1-10 The PathFinder
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Docking Window

The docking window is available on the left and right of the screen and it remains collapsed by
default. These tabs can be used to activate the feature library, family of parts, and so on. The
docking window expands when you move the cursor over the left or right pane of the screen. In
case, any tab is missing in it, choose the Panes button from the Show group in the View tab; a
flyout will be displayed with various options. Choose the required option; the tab corresponding
to that option will be added to the docking window. The options available in the docking window
are discussed later in this textbook.

Note
Remember that though the profiles of the features are not displayed in the PathFinder but the sketches
are displayed. You will learn about the difference between sketches and profiles later in this textbook.

Application Button

The Application Button is available on the top left corner of the Solid Edge window. It is present
in all environments. On choosing this button, the Application menu containing the options for
creating, opening, saving, and managing documents will be displayed.

Quick Access Toolbar

The Quick Access toolbar is available on the top-left of the title bar of the Solid Edge window,
refer to Figure 1-11. It provides you an access to the frequently used commands such as New,
Open, Undo, Redo, Save, and Print. However, by default, only the Save, Undo, and Redo
options are displayed in the Quick Access toolbar. To add commands such as New, Open, and
so on, choose the black arrow on the right of the Quick Access toolbar; the Customize flyout
will be displayed. Choose the required command from the flyout; the Save Theme As dialog
box will be displayed if you have chosen the command to add for the first time. Enter the theme
name in the New theme name edit box and the selected command will be added to the Quick
Access toolbar. You can also deselect a command name from flyout to remove it from the Quick
Access toolbar.

D-2e dR-E 01 v @

Figure 1-11 The Quick Access toolbar

You can also customize the Quick Access toolbar to add more commands to it. To do so, invoke
the Customize flyout again and then choose the Customize option from it; the Customize dialog
box will be displayed. Choose the Quick Access tab, if not chosen. In this dialog box, select the
required option from the Choose commands from drop-down list; the corresponding menus
will be available in a list box displayed below it. Invoke the required tool from the list box and
then choose the Add button to add the tool to the Quick Access toolbar. Similarly, you can also
remove commands by using the Customize dialog box. To do so, select the required command
from the list box at the right in this dialog box; the Remove button will be activated. Choose
the Remove button; the selected command will be removed from the Quick Access toolbar.
Choose the Close button from the Customize dialog box; the Customize message box will be
displayed. Choose the Yes button from the message box; the Save Theme As dialog box will be
displayed. Enter the name of the theme in the New theme name edit box in the Save Theme
As dialog box and choose the OK button.
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To remove any tool directly from the Quick Access toolbar, right-click on the required tool; a
shortcut menu will be displayed. Choose the Remove from Quick Access Toolbar option from
the shortcut menu; the corresponding tool will be removed from the toolbar.

Ribbon

The Ribbon is available at the top of the Solid Edge window and contains all application tools.
It is a collection of tabs. Each tab has different groups and each group is a collection of similar
tools. You can increase the drawing area by minimizing the Ribbon. To do so, right-click on a tab
in the Ribbon and choose the Minimize the Ribbon option from the shortcut menu displayed.

You can also add commands in a group of the tab in the Ribbon. To do so, invoke the
Customize dialog box and choose the Ribbon tab from it. Select the All Commands option from
the Choose commands from drop-down list; the corresponding tools will be displayed in the
left list box below it. Invoke the required tool from the list box and then click on the required
group of the tab (where you want to add the command) in the list box at the right side in the
Customize dialog box. After selecting the required group in the tab, the Add button will be
activated. Choose the Add button; the selected command will be added to the selected group in
the tab of the Ribbon. Choose the Close button from the Customize dialog box; the Customize
message box will be displayed. Choose the Yes button from the message box; the Save Theme
As dialog box will be displayed. Enter the name of the theme in the New theme name edit box
of the Save Theme As dialog box and choose the OK button.

Status Bar

The status bar is available at the bottom of the Solid Edge window. It enables you to quickly access
all the view controls like Zoom Area, Zoom, Fit, Pan, Rotate, Sketch View, View Orientation,
and View Styles. A slider on the right of the Status Bar controls the amount of zooming. Most
importantly, it consists of the Command Finder that helps you to locate the required command.

Record Record Video
In Solid Edge, you can use the Record button (located  recrding controks:
. . . Duration
at the bottom right corner) to record a video while [@] @ SIS

creating models, assemblies, drawings, and so on. On  shf=Fs shisrio

choosing this button, the Record Video dialog box will be  [ride tis delog whie recorcing

displayed, as shown in Figure 1-12. The options in this dialog

box can be used to specify various settings such as area to

record, audio settings, video compression settings, and so e po ey s
on. After specifying the required settings, choose the Record  record audi:

button or press SHIFT+F9 to record a video. To stop  [Mophone Resltek igh Definiton Audio) °
recording the video, choose the Stop button or press TS FICTEITE -
SHIFT+F10; the recorded video will be played in the default = || == Upload Help
video player. To save the video, switch back to the Solid Edge
window, and choose the Save button from the Record Video
dialog box; the Save Video dialog box will be displayed.
Specify the name and location of the file and choose the
Save button in the Save Video dialog box. To play the recorded video, choose the Play button
from the Record Video dialog box. Alternatively, you can play the video from the location where
it is saved.

Figure 1-12 The Record Video
dialog box
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Upload to YouTube
4 This button is available at the bottom right corner of the drawing window and is used to
upload a recorded video to YouTube. On choosing this button, the Upload to YouTube
dialog box will be displayed, as shown in Figure 1-13. In the dialog box, you can sign in a You'lube
account using the Sign in button. You can select the video to be uploaded by using the Browse
button. The other options in the Video Information area of this dialog box are the same as
those available in the Youlube upload page. After entering all the details, choose the Upload
button to upload the video.

L] Upload to YouTube
Login
You
RI—
Select Video for Upload
File name®; s @

Video Information
Title™:

Description:
Tags:

Tags

Selecta Tag W Add Tag

Privacy
(®) Public (anyone can search and view)

(_) Private (only specific YouTube users can view)

() Unlisted (can only be accessed by direct link)

[[] Copy YouTube URL to dipboard
[[]1 acknowledge that content uploaded to YouTube will be viewable to other
users and I will not upload any content that I do not want displayed publicly.

= = required fields Upload Cancel Help

Figure 1-13 The Upload to YouTube dialog box
Command bar

The Command bar provides the command options for the active tool. It enables you to switch
back and forth while creating a model, an assembly, or a drawing. It is available in all the
environments of Solid Edge and contains different buttons/steps. The Command bar that is
available for the Extrude tool is shown in Figure 1-14. However, the buttons displayed in the
Command bar depend upon the tool invoked from the Part environment. For example, on
invoking the Extrude tool, the buttons/steps displayed will have different options.

o= ER[§]RHE- 21 - md

Figure 1-14 The Extrude Command bar
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QuickPick

This tool enables you to select elements from the drawing window. This tool is used when the
elements or the components are overlapping and you need to make a selection. The following
steps explain the procedure of using this tool:

1. Bring the cursor near the element or the component that you QuickPick ]

need to select. Now, pause the cursor, and when three dots
appear close to it, right-click on the screen. On doing so, the  Plane (Protrusion 1)

. . . . . : [] Plane (Protrusion 1)
QulckPlck dialog qu w%ll appear with an entry of each possible )
selection, as shown in Figure 1-15. < Design Body_1

Partl =

2. Inthe QuickPick dialog box, each entry represents an element. o
As you move the cursor over the elements in this list, the Figure I-15 The QuickPick
corresponding components will get highlighted in the drawing dialog box
window.

3. lo exit the QuickPick dialog box, simply click on the screen.

Tip

Q You can use the Options button available at the bottom right corner in the QuickPick dialog
box to invoke the QuickPick Options dialog box. You can use the options in this dialog box
to modify the QuickPick options.

Part Environment Tabs
There are several tabs in the Ribbon that can be invoked in the Part environment. The tabs
that are extensively used during the designing process in this environment are discussed next.

The View Tab
This tab is available in all the environments of Solid Edge. The View tab of the Ribbon is shown
in Figure 1-16.

D-2eEB HAW-o 59 - ot e 0o o
Home  Sketching  3DSketching  Sufadng  PMI  Simulation  GenerativeDesign  ReverseEngineering  3DPint  Inspect  Tools | View | DataManagement SIEMENS S5H-5x
. N @ aem el QD 7 @ - 8 Color Manager %4 Styles q l:l E ]
o [ B @ . L EOo@ 3 @ - i view Overrides | Defoutt - =]
L el e e om gy @ B Drarpainte CEE@EL 1 e ronge
Shaw aiip Views Orient styie Configuratiors Window

Figure 1-16 The View tab in the Part environment

The Home Tab

This tab consists of the modeling tools that are used to convert a sketch into a solid model. The
Home tab along with all its tools is shown in Figure 1-17.

D-ReEB B AW & £Q - B —— s s ox
dome | Skechng  DSeetning  Sufacma M Simiaton  GenertueDesion Revsefnoneerng S0Pt imped  Toos  vew  osavinsoemet SIEMENS S FH -8 x
o LG Y% oJ /)6 2H rz00 8 gy 4 @ g @ @G TOMEY g
@0 BoCa mE robag D1 SR O E P St
W= Sy 0 N5 M- G- oo Btruse Rewole Hole oy g | g 4 O
Clipboar! Select | Planes Draw Relate Solick FaceRelate | Pattern

Figure 1-17 The Home tab in the Part environment
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The Surfacing Tab

This tab contains the modeling tools that are used to create surface models. This tab is available
only when you are in the Part environment. The Surfacing tab along with all its tools is shown
in Figure 1-18.

O-@Fe H&- ey -¢- 579 - Solid Edge 2020 - Synchronous Part - [Part1] - 5 x
X Home  Skefching 3D Skeiching | Sufacing | PMI  Simulation  Generative Design Reverse Engineering 3D Print  Insped  Tools  View  DataManagement SIEMENS S5H-#x
Y oo (B intersection 45 (% Derived tfisection Sketches % g; ® @ swept  pgoriset Ba 9‘ & @ - q 5- B "/,.‘
@ O Bleroject - 8 Contour - > o copy 2 W Steiena @ parting spit -
Select 1y Kemoint S eicsl Cume S isoctine X ntersecion Point Blugsurt Bounded Redefine S Ruled Replace 7 spiit e e eon

- ion -
Select | Planes Curves Surfaces Moy Surfages Section | Pattern Dimension

Figure 1-18 The Surfacing tab in the Part environment

Assembly Environment Tabs
There are several tabs that can be invoked to create and manage assemblies in the Assembly
environment of Solid Edge. One of these tabs is discussed next.

The Assemble Group

The Assemble group is available in the Home tab of the Ribbon. The tools in this tab are used
to create and manage assemblies. The Home tab in the Assembly environment is shown in
Figure 1-19.

D-Re¢ Q- B A0 W9 ~ ol Edge 202 Asembly- ] - s x
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%E & ot 20 sgbed ool @ |7 g_=ew ao a ®@
8ot n & S b @@ W & = Soi < el £
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. e Py et prbth S e —— oo

Figure 1-19 The Home tab in the Assembly environment
Draft Environment Tab

The Ribbon in the Draft environment provides you with various tools to generate and create
drawing views. Various drafting tools available in the Home tab are shown in Figure 1-20.

O-2e HG- R R R Solid Edge 2020 - Draft - [Draft3]
Hom

e Sketching  Diagram  Inspect  Tools  View  Dats Management

x| principal ¢ § [EABraken-Out G 2
[E & % = E gAuxmam Eﬁcmmg Plane E ’./

Paste Select View Update Parts mart
. Wikntg et @vetai Bsection Lst~  Dimensio
Clipboard | Select Drawing Vievs Tables

W M Y W Avsea @
it A O | B convertal @
Ak ZmFl @ [E]

Annotation PropertyText | Edges

Figure 1-20 The Home tab in the Draft environment

Radial Menu

The Radial Menu has a set of tools arranged radially, as Q

shown in Figure 1-21. To invoke a tool from the Radial Menu, g 3]
press the right mouse button and drag the cursor; the Radial B ) =
Menu will be displayed. Keeping the right mouse button ; ;
pressed, move the cursor over the tool to be invoked and then > (A A0
release the mouse button; the tool will be invoked. You can i i
add or remove the tools from the Radial Menu. To do so, 2 /7 B
right-click on the Ribbon and choose the Customize the L 12
Ribbon option from the shortcut menu displayed; the F )
Customize dialog box will be displayed. Choose the Radial
Menu tab. Next, select the category that contains the tool
that you want to add to the Radial Menu from the
Choose commands from drop-down list. On doing so, the

Figure 1-21 The Radial Menu
in the Part environment
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categories and the commands are displayed in the list box. Next, drag and place the tool onto
the Radial Menu image in the dialog box; the tool will be displayed in the Radial Menu. To
remove a tool from the Radial Menu, click on the tool in the Radial Menu image and drag it
into the white space. Next, choose the Close button; the Customize message box will be displayed.
Choose the Yes button from it to exit the Customize dialog box.

SIMULATION EXPRESS

Solid Edge provides you an analysis tool called Simulation Express. This tool is used to execute
the linear static analysis and to calculate the displacement, strain, and stresses applied on a
component with respect to the material, loading, and restraint conditions applied to a model.
A component fails when the stress applied to it reaches a certain permissible limit. The Static
Nodal displacement plot of the Master rod of the engine designed and analyzed by using the
Simulation Express tool is shown in the Figure 1-22. Both the Femap and industry standard
NX Nastran solvers are used in Solid Edge’s Simulation Express tool.

Part2, Static Study 1, Steel

Stress - Elemental

Contour: Von Mises Stress

Deformation: Total Translation

Date: Friday, December 13, 2019 10:03 AM

MegaPa

5.17e+03
4.74e+03 -
4.31e+03 -
3.88e+03 -
3.45e+03 4
3.02e+03 .
2.59e+03
2.16e+03

1.73e+03
130403
864

434

279

‘5‘7 A Yield Stress: 262~

Figure 1-22 The Master Rod analyzed using the Simulation Express tool

USING INTELLISKETCH

The IntelliSketch is a dynamic drawing tool that allows you to draw a sketch with accuracy by
specifying various relations like endpoint, midpoint, perpendicular, parallel, tangent, horizontal,
vertical, and so on. The IntelliSketch shows the dynamic display of the relation while drawing a
sketch. Moreover, while sketching a relationship indicator will be displayed at the cursor. Click
when the indicator is displayed to apply the respective relation to the drawing. You can also
apply a relation after drawing the sketch. Additionally, these relationships are maintained even
when you modify the sketch. In the Sketch environment of the Ordered Part environment, the
relations will be available in the IntelliSketch group of the Home tab whereas in the Synchronous
Part environment, the relations will be available in the IntelliSketch group of the Sketching tab.

AUTOMATIC SAVING OPTION

In Solid Edge, you can set the option for saving the files automatically after a regular interval
of time. While working on a design project, if the system crashes, you may lose the unsaved
design data. If the option of automatic saving is on, your data is saved automatically after regular
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intervals. To set this option, choose Application Button > Settings > Options; the Solid Edge
Options dialog box will be displayed. Choose the Save tab and select the Automatically preserve
documents by check box. You can also select the Prompting me to save all documents every
radio button and set the minutes in the spinner. You can also select the Creating uniquely named
backup copies of unsaved documents every radio button to save uniquely named copies of the
documents at a specified location. By default, the files will be saved in the default folder. You can
change the default backup folder location by choosing the File Locations tab from the dialog box.

COLOR SCHEME IN Solid Edge

In Solid Edge, you can use various color schemes as the background color of the drawing
window and for displaying the entities in it. Note that this book uses white as the background
color. To change the background color, choose Application Button > Settings > Options; the
Solid Edge Options dialog box will be displayed. Choose the Colors tab from this dialog box
to display various colors, as shown in Figure 1-23.

To change the background color, choose the Background/View Overrides button from the
dialog box; the View Overrides dialog box will be displayed with the Background tab chosen,
as shown in Figure 1-24. Select the White color from the Color 1 drop-down list; the background
color will change to white. Next, choose the OK button from the View Overrides dialog box
and then from the Solid Edge Options dialog box.

To set background color to default, invoke the View Overrides dialog box from the Solid Edge
Options dialog box or you can also invoke the View Overrides dialog box by choosing the
View Overrides tool from the Style group of the View tab; the View Overrides dialog box will
be displayed. Choose the Background tab and select Default from the Color 1 drop-down list.
Choose the OK button to exit this dialog box; the background color will change to default color.

Solid Edge Options

~
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View
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Colors
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Selected: | @ Default
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File Locations
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Guide path: | @ Default
Sketch: | @ Default
Plane: () Default

Plane edges: @ Default

Parent feature: | (@) Default

<< c

User Profile
General bedy: | @ Default

Sketch Relationship Colors

Inter-Part

Manage
Fuly-defined: | @) Default

Under-defined: . Default

Units

Dimension Style
Over-defined: | (@ Default

Helpers
Inconsistent: @) Default

<|<lle] <

Child feature: @) Default
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Handle 3: | @ Default
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Figure 1-23 The Colors tab of the Solid Edge Options dialog box
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View Overrides

Rendering | Lights | Backaround | Reflection Bax Preview

®) Solid () Default v
() Gradient

() Image

Description
"Default” + Lights

Cancel Save As Help

Figure 1-24 The View Overrides dialog box

Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this

chapter:

1. The dialog box is used to change the background color of the drawing window
in Solid Edge.

2. The relation forces two selected arcs, circles, a point and an arc, a point and a
circle, or an arc and a circle to share the same center point.

3. The relation is used to make two points, a point and a line, or a point and an
arc coincident.

4. The relation forces two selected lines to become equal in length.

5. The lists all occurrences of features and sketches of a model in a chronological
sequence.

6. The relationship is used between two or more components to fix them such that
they become rigid with respect to each other.

7. The Ordered Part environment of Solid Edge is a feature-based parametric environment
in which you can create solid models. (T/F)

8. Any solid model created in Solid Edge is an integration of a number of features. (T/F)

9. The welcome screen of Solid Edge displays the link for step-by-step tutorials in the
Learn Solid Edge area. (1/F)

10. In Solid Edge, the solid models that are not created by integrating a number of building

blocks are called features. (T/F)
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Answers to Self-Evaluation Test
1. View Overrides, 2. Concentric, 3. Coincident, 4. Equal, 5. PathFinder, 6. Rigid Set, 7. T,
8.1,9.T,10. F



