
Chapter 2

Working with Points
Learning Objectives

After completing this chapter, you will be able to:
• Understand the concept of points in Civil 3D
• Create points using different methods
• Create point styles
• Create point label styles
• Understand file formats
• Edit points
• Understand description keys
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POINT OBJECT
A point object represents a location in 3D space, and is defined by its X, Y, and Z coordinates. 
Each civil engineering project starts with data collection. This data is imported into Civil 
3D workspace as points by using a suitable coordinate system. Generally, points specify the 
location of different features on the site such as trees, road geometry points, property corners, 
edge of pavements, and so on. However, Civil 3D points offer you more than just specifying the 
location of different objects on the site. In Civil 3D, each point represents an individual object 
with different information and has a unique point number. The information displayed by a Civil 
3D point object depends upon the point settings, which will be discussed later in the chapter.

                            
Components of Point Object
In AutoCAD Civil 3D a point object has two major Components, marker and label. Marker rep-
resent the location of point object whereas label displays information about that point object. 
The display of point marker is controlled by point style and the display of  the point label style. 
Figure 2-1 shows a point with number, elevation, and description.

 

Figure 2-1  A point with number, elevation, and description   

The properties of an individual Civil 3D point can be viewed in the PROPERTIES palette, 
refer to Figure 2-2. You can modify the properties of the selected point(s) such as color, layer, 
linetype, and point elevation. 

Creating Points 
In AutoCAD Civil 3D, you can create points using various methods. These methods of point 
creation involve conversion of AutoCAD points into Civil 3D points, importing points from 
external point files, and creation of points using input parameters specified by the user.

These methods for point creation have been broadly classified into six categories which are 
discussed next.
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Figure 2-2  Partial view of the PROPERTIES palette 
showing different point properties

The Miscellaneous Category
Ribbon:		 Home > Create Ground Data > Points drop-down > 
                        Create Points-Miscellaneous 

  

The tools in the Miscellaneous category are used to create points by manually specifying the 
point location in the drawing. The tools in the Miscellaneous category are the most commonly 
used tools to create points. To access these tools, choose the Create Points-Miscellaneous option 
from the Create Ground Data panel; a flyout will be displayed with different tools, as shown in 
Figure 2-3. Some of the tools in this category are discussed next.

Manual
       Ribbon:		 Home > Create Ground Data > Points drop-down >	

                        Create Points- Miscellaneous > Manual
Command:	 CREATEPOINTMANUAL
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The Manual tool is used to manually create points. To create points using this tool, 
invoke this tool from the Create Ground Data panel; the Create Points toolbar will 

be displayed and you will be prompted to specify the location of the point. Click in the 
drawing to specify the location.  

Figure 2-3  The tools in the Miscellaneous category 

Next, enter description of the point in the command line or in the dynamic input edit box 
and right-click; you will be prompted to specify the elevation of the point. Now, specify the 
elevation of the point and right-click again to continue or press ENTER to terminate the 
command.

Geodetic Direct

Ribbon:		 Home > Create Ground Data > Points drop-down >     	
	             Create Points- Miscellaneous > Geodetic Direct
Command:	 CREATEPTGEODETICDIR

The Geodetic Direct tool is used to create points by using geodetic direction and 
azimuth. Before using this tool, you need to assign a coordinate system and a zone to 

the current drawing. To do so, choose the Settings tab in the TOOLSPACE palette. In the 
Settings tab, right-click on the current drawing name; a shortcut menu will be displayed. 

Choose the Edit Drawing Settings option from the shortcut menu; the Drawing Settings 
<drawing name> dialog box will be displayed. In the dialog box, choose the Units and 
Zone tab. Next, in the Zone area of this tab, select the required geographic zone from 
the Categories drop-down list. Also, select the coordinate system within the selected zone 
category from the Available coordinate systems drop-down list. Choose the Apply button 
and then the OK button to close the dialog box. 

Once the coordinate system has been assigned, choose the Geodetic Direct tool from the  
Create Ground Data panel; you will be prompted to specify the start point. Click in the 
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drawing to specify the start point; you will be prompted to specify the azimuth. Azimuth is 
the angle measured with respect to the true north. Specify azimuth; you will be prompted 
to specify the geodetic distance. The geodetic distance is the shortest path between two 
points along the ellipsoid of the earth at sea level. Specify distance; you will be prompted 
to enter description. Enter the point description. Next, specify elevation for the point. Press 
ENTER to terminate the command.

Note  
1. The Geodetic Direct tool is also known as the Geodetic Direction and Distance tool when 
accessed through the Create Points toolbar.
 
2. If the coordinate system is not assigned to the drawing and you invoke the Geodetic Direct 
tool to create points then an AutoCAD Civil 3D 2020 warning message will be displayed. 

Automatic

Ribbon:		 Home > Create Ground Data > Points drop-down > 	
		  Create Points- Miscellaneous > Automatic
Command:	 CREATEPOINTAUTOMATIC 

    

The Automatic tool is used to create points automatically at the endpoints of single 
or multiple lines, feature lines, or lot lines. In case of an arc, a point is also created at 

the center. To create points using this tool, choose the Automatic tool from the Create 
Ground Data panel. Next, select the required entity and press ENTER; you will be prompted 
to specify the description and elevation for the points to be generated. Enter the point 
description and elevation at the Command prompt. You will notice that points are displayed 
at endpoints, center of arc, and vertices of the selected entity. Next, press ENTER to exit 
the command.   

Polyline Vertices - Manual

Ribbon:		 Home > Create Ground Data > Points drop-down > 	             	
		  Create Points- Miscellaneous > Polyline Vertices - Manual
Command:	 CREATEPTPLYLINECTRVERTMAN

The Polyline Vertices - Manual tool is used to create points at each vertex of a 
polyline at the specified elevation. To do so, choose the Polyline Vertices - Manual 

tool from the Create Ground Data panel; you will be prompted to specify the default elevation 
of all points to be created. Enter the elevation at the command prompt; you will be prompted 
to select polyline. Next, select the required polyline; you will be prompted to enter a 
description. Enter a description for the point either at the Command prompt or in the 
dynamic input edit box and press ENTER; a point will be created at the first vertex of the 
polyline. Similarly, enter description for other points on the polyline and then press ESC 
to exit the command.

Polyline Vertices - Automatic

Ribbon:		 Home > Create Ground Data > Points drop-down >     		
           	            Create Points- Miscellaneous > Polyline Vertices - Automatic
Command:	 CREATEPTPLYLNCTRVERTAUTO
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The Polyline Vertices - Automatic tool is used to create points automatically at each 
vertex of a polyline. To do so, choose the Polyline Vertices - Automatic tool and select 

the required polyline. Next, enter a point description in the command line. Press ENTER 
to end the command or continue it by specifying the description of all points on the polyline. 
On doing so, points will be created at vertices of the selected polyline and the elevation of 
the generated points will be the same as that of the selected polyline. 

Tip
Remember that on pressing the ENTER, the continuing command will exit only once you have 
created the points on all vertices.

The Intersections Category
Ribbon:           Home > Create Ground Data > Points drop-down >
                       Create Points-Intersections 

The tools in the Intersections category are used to create points at the intersection of 
direction lines of two points, intersection of distances of two points, intersection of two alignments, 
and so on. To access tools in the Intersections category, choose the Create Points - Intersections 
option from the Create Ground Data panel; a flyout will be displayed with different tools, as 
shown in Figure 2-4. Some of the tools in this category are discussed next.

Figure 2-4  The tools in the Intersections categories

Direction/Diretion 

Ribbon:		 Home > Create Ground Data > Points drop-down > 	
		  Create Points - Intersections > Direction/Direction
Command:	 CREATEPOINTDIRECTIONDIR

The Direction/Direction tool is used to create points at specified offset distance from 
the point where the direction lines meet, refer to Figure 2-5.
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Figure 2-5  The point created at the specified offset distance from the 
intersection of direction lines of two points

To create points using this tool, choose the Direction/Direction tool from the Create Ground 
Data panel; you will be prompted to specify the start point in the drawing. Specify the point 
by clicking in the drawing. On doing so, you will be prompted to specify the direction at 
the start point. You can specify direction using the Bearing or Azimuth option. You can 
use the Bearing option to specify the direction with reference to a particular quadrant, or 
the Azimuth option to specify the direction with reference to the North meridian. Enter B 
to select Bearing or Z to select Azimuth. If you select the Bearing option, a quadrant will 
be displayed at the specified point. Move the cursor in the required quadrant and click to 
select the quadrant. 

Next, click again to specify the bearing by clicking in the drawing or by entering the 
bearing in the command line; you will be prompted to specify the offset from the point of 
intersection. Enter the offset distance in the command line or specify the distance by picking 
points from the drawing. 

Specify the second point by following same procedure. Once you specified the offset for 
the second point, you will be prompted to specify the point description and elevation. 
Enter the description and elevation of the point. On doing so, you will notice that a point 
is displayed at the specified offset distance from the intersection of direction lines of points, 
refer to Figure 2-5. 

Distance/Distance

Ribbon:           Home > Create Ground Data > Points drop-down >                                        	
	            Create Points-Intersections > Distance/Distance
Command:      CREATEPOINTDISTANCEDIST

The Distance/Distance tool is used to create a point at the intersection of arcs of  
given radial distances from specified points. On choosing this tool, you will be 

prompted to specify the location of the radial point. Click in the drawing to specify the 
location; you will be prompted to specify the radius. Enter the radius in the command line 
using the dynamic input or pick points in the drawing to specify the radius. Similarly, specify 
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the location of the second point and enter a radius; two cross marks indicating two points 
at the apparent intersection of arcs will be displayed. Click near the intersection, where you 
want to create point or press ENTER to accept the default ALL option to enable you to 
create points at both intersections. Next, follow the prompts and specify the point description 
and elevation. On doing so, the point(s) will be created at the intersection of the arcs, refer 
to Figure 2-6. Press ESC to exit the command.  

Figure 2-6  Points created at the intersection of arcs of specified 
radial distances defined from two points

Note  
Cross-marks, indicating the intersections of two points, will not be displayed if the radii are 
non-intersecting. 

Direction/Perpendicular

Ribbon:		 Home > Create Ground Data > Points drop-down >     		
		  Create Points-Intersections > Direction/Perpendicular
Command:	 CREATEPOINTDIRECTIONPERP

The Distance/Perpendicular tool is used to create a point at the intersection of the 
direction line and the perpendicular line that passes through the specified location. 

Choose this tool from the Create Ground Data panel; you will be prompted to specify the 
start point. Click in the drawing to specify the start point; you will be prompted to specify 
the direction at the start point. Specify the direction by specifying bearing or azimuth. On 
doing so, you will be prompted to specify the offset distance. Specify the offset distance from 
the direction line or press ENTER to accept the default value 0. Next, specify the location 
of the perpendicular point; a cross mark will be displayed perpendicular to the specified 
point. Follow the prompts and specify the point description and elevation; a point coinciding 
with the cross mark will be created, as shown in Figure 2-7.
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Distance/Object
Ribbon:		 Home > Create Ground Data > Points drop-down >    	
	             Create Points-Intersections > Distance/Object
Command:	 CREATEPOINTDISTANCEOBJECT

Figure 2-7  The point created in the specified direction
at a perpendicular distance from the specified point

The Distance/Object tool is used to create a point at the intersection of an object such 
as line, arc, feature line, polyline, or plot line and an arc of specified radial distance 

of given point. To create a point using this tool, choose the Distance/Object tool from the 
Create Ground Data panel; you will be prompted to select the specified line, arcs, or any 
other objects from the drawing. Select the object from the drawing. 

Next, specify an offset distance of the point from the selected object by entering a suitable 
value in the command line. Alternatively, you can specify the distance by picking points 
from the drawing. If no offset is required, enter 0 as the offset value. On doing so, you will 
be prompted to specify the radial point. Click at the required location in the drawing to 
specify the radial point. Next, specify the radial distance by entering the required value 
in the command line or by picking points from the drawing; you will notice that two cross 
marks are displayed at the apparent intersection of the object and the arc of specified radial 
distance. Click near the cross-mark where you want to add a point or press ENTER to accept 
the default All option to add points at all intersections. Enter a description and elevations 
for the points and then press ENTER to end the command. Figure 2-8 shows the points 
created at 0 offset distance from the arc object.
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Figure 2-8  Point created at the intersection of the
 arc object and the radial distance from a point

The Alignments Category
Ribbon:           Home > Create Ground Data > Points drop-down >
                       Create Points - Alignments  

The tools in the Alignments category are used to create points on or along the horizontal 
alignment at a given offset distance. To access tools in the Alignments category, choose the 
Create Points - Alignments option from the Create Ground Data panel; a flyout will be displayed 
with different tools, as shown in Figure 2-9. Some of the tools in this category are discussed next.

Figure 2-9  Flyout displaying tools in the Alignments category 

Station/Offset

Ribbon:           Home > Create Ground Data > Points drop-down >     	
	            Create Points - Alignments > Station/Offset
Command:      CREATEPOINTSTATIONOFFSET
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The Station/Offset tool is used to create a point at a given offset from the point station 
selected on the alignment. To create a point, invoke this tool from the Create Ground 

Data panel; you will be prompted to select an alignment. Next, click on a station on the 
alignment and then specify an offset distance. Also, specify the description and elevation 
of the point when prompted; a point will be created and displayed at the specified offset 
distance from the station that was selected on the alignment. This tool is useful for creating 
points for right of way, lanes, and shoulders.

Divide Alignment

Ribbon:           Home > Create Ground Data > Points drop-down >     	
	            Create Points - Alignments > Divide Alignment
Command:      CREATEPOINTDIVIDEALIGN

The Divide Alignment tool is used to create points at equal divisions of an alignment. 
Using this tool, you can create points at vertex or endpoints of each segment. Choose 

the Divide Alignment tool from the Create Ground Data panel; you will be prompted to 
select the required alignment from the drawing. Select the alignment from the drawing; 
you will be prompted to specify the number of segments. Specify the number of segments; 
you will be prompted to specify the offset distance. Specify the offset distance or enter 0 if 
the points are not required to be created at an offset; you will be prompted to specify the 
description and elevation for all the points that will be created at the vertex of each segment. 
Enter the description and elevation; the points will be created, as shown in Figure 2-10.

Figure 2-10  Points created at 0 offset distance at each vertex of all five segments

Measure Alignment

Ribbon:           Home > Create Ground Data > Points drop-down >     	
	            Create Points - Alignments > Measure Alignment
Command:      CREATEPOINTMEASUREALIG

The Measure Alignment tool is used to create points at fixed intervals along an 
alignment. To create points using this tool, you need to specify an interval and an 

offset distance from the alignment at which the points will be created. Choose the 
Measure Alignment tool from the Create Ground Data panel and select the required 
alignment. Next, specify the starting station from where you want to start creating points 
or press ENTER to accept the default option. Similarly, specify the end station.
 

Note  
To enter a user-specified station through command bar, type station value in the xx+xx.xx format. 
For example, to enter a station value of 1024.75, use 10+24.75 as input value.
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Note  
You can specify the start and end station values manually to replace the default values.

On doing so, you will be prompted to specify the offset from the alignment. Next, enter 
the offset distance in the command line or press ENTER to create points on the alignment. 
Similarly, specify the interval at which you want to create these points. Now, enter the 
point description and elevation; points will be created at specified interval along the entire 
alignment. Note that once you specify the description and elevation for points, they will be 
created and displayed automatically. 
At Alignment Geometry 

Ribbon:           Home > Create Ground Data > Points drop-down >     	
	            Create Points - Alignments > At Alignment Geometry 
Command:      CREATEPOINTATPTPCSCETC

The At Alignment Geometry tool is used to create points at each geometry point such 
as start and end points of alignment (EP, BO), spiral tangents (TS, ST), spiral curves 

(SC, CS) as well as point of intersections (PI), point of Curvature (PC), and so on. This tool 
is named as At Geometry Points in the Create Points toolbar. To create points, choose the 
At Alignment Geometry tool from the Create Ground Data panel. Next, select the required 
alignment from the drawing. Next, specify the starting station from where you want to start 
creating points. Similarly, specify the second station and end station and press ENTER. On 
doing so, you will be prompted to enter a point description. Specify the point description 
and elevation till all the points are created. Next, press ENTER to terminate the command.
 

Tip
You can automatically extract the point description such as alignment and surfaces from any 
of the Civil 3D objects. To do so, select the Automatic - Object option in the Prompt for 
Description drop-down list displayed under the Points Creation head in the Create Points 
toolbar.

Import from File

Ribbon:           Home > Create Ground Data > Points drop-down >     	
	            Create Points - Alignments > Import from File
Command:      CREATEPOINTIMPORTFROMFILE

The Import From File tool is used to create points from the text file (.txt) 
containing information about the station, offset, and elevation of an alignment. To 

create points using this tool, choose the Import from File tool from the Create Ground 
Data panel; the Import Alignment Station and Offset File dialog box will be displayed. 
Browse to the required location and open the required file. On doing so, the Enter file 
format dynamic input prompt will be displayed, as shown in Figure 2-11.
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Figure 2-11 The Enter file format dynamic input 
prompt

Note 
The station value in the text file should have a xxxx.xx format. For example, station 4+57.28 in 
a text file should be written as 457.28. 

Also, six different file formats in the prompt will be displayed. Specify the required format 
by entering the corresponding number of the format starting from 1 to 6 in the text box, 
as shown in Figure 2-11. For example, if the text file consists of the Station and Offset 
information, enter 1 in the text box. Next, specify delimiter type of the text file using 1 for 
space delimiter and 2 for comma delimiter. After specifying the delimiter, specify the invalid 
indicator for elevation, station, or offset. Next, select the required alignment along which 
points will be created using the text file; Civil 3D will import points from the selected file 
and create points along the alignment.

Note 
To get the dynamic input, ensure that the Dynamic Input in the status bar is selected and turned on.

The Surface Category
Ribbon:           Home > Create Ground Data > Points drop-down > 	
                       Create Points - Surface             

The tools in the Surface category are used to create points on the horizontal alignment 
or at a certain offset distance from it. To access tools in the Surface category, choose the 
Create Points - Surface option from the Create Ground Data panel; a flyout will be displayed 
with different tools, as shown in Figure 2-12. Some of the tools in this category are discussed next.
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Figure 2-12 Partial view of flyout displaying tools in the Surface category

Random Points
Ribbon:           Home > Create Ground Data > Points drop-down >     	
	           Create Points - Surface > Random Points 
Command:      CREATEPOINTRANDOMPOINTS

The Random Points tool is used to add points anywhere on the surface. The points 
that are added acquire their elevation from the surface itself. You can invoke the 

Random Points tool from the Points drop-down. On doing so, you will be prompted to 
specify a location for the new point. Next, click at the required location inside the surface 
and specify the description of the point. Continue adding these points or press ENTER to 
end the command.

Note 
AutoCAD Civil 3D calculates the elevation for a point using the surface and assigns it to the point.

On Grid

Ribbon:           Home > Create Ground Data > Points drop-down>  
                       Create Points - Surface > On Grid
Command:      CREATEPOINTONGRID

The On Grid tool is used to create points on a surface by specifying the spacing along 
the X and Y axes of the grid. To do so, choose the On Grid tool from the Points 

drop-down; you will be prompted to specify a grid base point. Now, click on the surface to 
specify the base point of the grid; you will be prompted to specify the rotation of the grid 
in the command line. Press ENTER to accept the default value. Now, specify the spacing 
between each point in the X direction in the command line or pick the points on the screen. 
Similarly, specify the spacing along the Y direction. Now, specify the upper right corner of 
the grid; a single boundary of the grid will be displayed. Also, you will be prompted to 
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change the spacing or the rotation of the grid. Press ENTER to accept the default option 
No. Follow the prompts and enter description for points. As you continue to enter description 
in the command line, you will notice that points will be displayed in a grid. These points 
will be added at the surface elevation, as shown in Figure 2-13.
 

Figure 2-13 The points added at the surface elevation 

 

Along Polyline/Contour 

Ribbon:           Home > Create Ground Data > Points drop-down > 
	            Create Points - Surface > Along Polyline/Contour
Command:      CREATEPTALONGPOLYCONTOUR

The Along Polyline/Contour tool is used to create points along a polyline or a contour 
on a surface. To create points using this tool, choose the Along Polyline/Contour tool 

from the Create Ground Data panel and select the required surface. Next, specify the 
distance between the points in the command line. Now, select the required polyline or 
contours in the surface; you will be prompted to specify the point description. Specify the 
description for the points and then press ENTER. The point will be created and you will 
be again prompted to enter description for the next point. Continue doing this until you 
are prompted to select a new polyline or contour. Press ESC to exit the command.

The Slope Category
Ribbon:            Home > Create Ground Data > Points drop-down > 	
		  Create Points - Slope      

The tools in the Slope category are used to create points based on the slope, grade intersections, 
elevations, or distances. To access tools in the Slope category, choose the Create Points - Slope 
option from the Create Ground Data panel; a flyout will be displayed with different tools, as 
shown in Figure 2-14. Some of the tools in this category are discussed next.
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Figure 2-14 Partial view of flyout displaying tools in the Slope 
category

High/Low Point

Ribbon:            Home > Create Ground Data > Points drop-down > 
		  Create Points - Slope > High/Low Point
Command:       CREATEPOINTHIGHLOWPOINT

The High/Low Point tool is used to create a high or low elevation point by specifying 
the slope or grade of two points. These points are created at a location where the 

slopes or grades of two points intersect. Choose this tool from the Create Ground Data 
panel and click in the drawing to specify the first point. Click again to specify the second 
point. Next, you need to specify the required slope or grade for the first point in the drawing 
area by entering a value in the command line or by using the dynamic input. To do so, 
enter S in the command line to specify the slope (in ratio) or enter G to specify the grade 
(percent) and press ENTER. Similarly, specify the required slope or grade for the second 
point; a cross mark will be displayed. Now, press ENTER to accept the default option Yes 
after being prompted to add a point at the intersection. Next, enter the point description; 
a new point will be added at the intersection of the forward slope/grade of the first point 
and the back slope from the second point, as shown in Figure 2-15.

Figure 2-15  Point created at the intersection of slopes 
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Slope/Grade-Distance

Ribbon:            Home > Create Ground Data > Points drop-down >  
                        Create Points - Slope > Slope/Grade - Distance
Command:       CREATEPOINTSLOPEGRADEDIST

The Slope/Grade-Distance tool is used to create specified number of points at a 
desired slope or grade from a given point at the specified direction and distance. To 

do so, choose the Slope/Grade-Distance tool from the Create Ground Data panel and click 
in the drawing to specify the start point. Next, click in the required direction again to specify 
the direction of intermediate points. Now, specify the required slope or grade at that point. 
Next, enter the distance at which you want to create multiple points in the command line. 
Enter the number of points in the command line and press ENTER. Specify the offset 
distance or press ENTER to accept the default value. Optionally, press ENTER to add the 
endpoint. Follow the prompts and enter the point description or continue pressing ENTER 
to skip description. As you continue pressing ENTER, points will be displayed in the drawing 
in the specified direction.

Slope/Grade Elevation

Ribbon:            Home > Create Ground Data > Points drop-down >     	
		  Create Points - Slope > Slope/Grade - Elevation
Command:       CREATEPOINTSLOPEGRADEELEV

The Slope/Grade-Elevation tool is used to create multiple points in a specific direction 
by specifying grade/slope at a specified distance and elevation. Choose the 

Slope/Grade - Elevation tool from the Create Ground Data panel and click in the drawing 
to specify the start point. Click again to specify the direction in which points will be created. 
Next, specify the required grade or slope in the command line and press ENTER. Specify 
the end elevation in the command line and press ENTER. Now, enter the number of points 
to be created. Optionally, specify the offset distance in the command line and press ENTER. 
Again, press ENTER to add the endpoint, if required. Follow the prompts and enter the 
description for all the points. As you enter the description, points will be created and 
displayed.

The Interpolate Category
Ribbon:           Home > Create Ground Data > Points drop-down >  
                       Create Points - Interpolate

The tools in the Interpolate category are used to add points to the drawing by interpolation. 
To access tools in this category, choose the Create Points - Interpolate option from the Create 
Ground Data panel; a flyout will be displayed with different tools, as shown in Figure 2-16. Some 
of the tools in this category are discussed next.
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Figure 2-16 The flyout displaying tools in the Interpolate category

Interpolate

Ribbon:           Home > Create Ground Data > Points drop-down >     	
	            Create Points - Interpolate > Interpolate
Command:      CREATEPOINTINTERPOLATE

The Interpolate tool is used to create specified number of points between two existing 
points by interpolation. To create points using the Interpolate tool, choose the 

Interpolate tool from the Create Ground Data panel; you will be prompted to select the 
object. Select the first point; you will be prompted to specify the second point. Specify the 
second point. Next, specify the number of points that you want to create in the command 
line and press ENTER. Then, specify the offset and press ENTER. Now, enter the description 
for each point and press ENTER; the points will be created between the two points through 
interpolation and will be added to the drawing between these two points. 

	
By Relative Location

Ribbon:		 Home > Create Ground Data > Points drop-down > 
                        Create Points - Interpolate > By Relative Location
Command:	 CREATEPOINTBYRELLOCATION

The By Relative Location tool is used to create a point by interpolating a point 
between two given points based on the distance specified. To create points, choose 

the By Relative Location tool from the Create Ground Data panel and click in the drawing 
to specify the first control point. Next, specify the elevation of the point in the command 
line and press ENTER. Similarly, specify the second control point; you will be prompted to 
specify the distance at which you want to create the point. You can specify the distance either 
by entering the required value in the command line or by using the dynamic input. Next, 
specify the offset distance of the point from the arbitrary line or the arc joining two control 
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points. Now, specify the point description in the command line and press ENTER; the point 
will be created and displayed at the specified distance from the first control point and at the 
specified offset distance from the arbitrary line joining two control points. Press ENTER to 
end the command. 

Intersection

Ribbon:            Home > Create Ground Data > Points drop-down >  
	             Create Points - Interpolate > Intersection
Command:       CREATEPTINTERPOLINTERSEC

The Intersection tool is used to create points by interpolation at the intersection of 
two existing entities such as arc or line. If there are no existing entities in the drawing, 

you can create arbitrary regions for two entities by picking points from the drawing. To  
create points, choose the Intersection tool from the Create Ground Data panel. Next, click 
in the drawing at the required location to specify the first point for the first region. The first 
control point of the first entity will be created. Next, specify the elevation for the first control 
point in the command line or press ENTER to skip the elevation; you will be prompted to 
specify the second point. Click to specify the second point; you will be prompted to specify 
elevation. To specify the elevation of the second point using the elevation difference between 
the first and second point, enter D in the command line, enter S to specify the slope between 
the two points, or enter G to specify the grade between two points. This is called the second 
control point of the first entity. Thus, you have created an arbitrary region for the first entity. 
Next, specify the offset distance of the point to be created from the entity. To do so, follow the 
prompts and specify two more control points for the second entity. On doing so, green 
colored cross marks indicating the intersection of two points will be displayed and you will 
be prompted to specify the description for the point. If the entities intersect only at one 
point, one cross-mark will be displayed and if the entities intersect at two points, two cross 
marks will be displayed. Specify the description or press ENTER to skip the description; a 
point will be interpolated and displayed on the cross mark. Press ENTER to end the 
command. Figure 2-17 shows the interpolated points created at the intersection.  

To create a point from the existing entities, choose the Intersection tool from the Create 
Points toolbar. Next, enter E in the command line and press ENTER; you will be prompted 
to select the existing line, arc, lot line, feature line, or polyline entity. Select the required 
existing entities and follow the prompts to create points by the intersection of two entities.

Figure 2-17  The interpolated points created at the intersection
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Import Points   
Ribbon:            Insert > Import > Points from File 
Command:       IMPORTPOINTS

 

The Points from File tool is used to create points by using the point data contained in 
the imported files. The point data is generally imported from the ASCII (.txt) or Microsoft 

Access (.mdb) files. Creating points using the point data collected by the data collector or 
surveyor is the most convenient way to create points. Before importing points, you need to 
specify the file format according to the point data in the file. 

To import the point data file, choose the Points from File tool from the Import panel; the 
Import Points dialog box will be displayed, as shown in Figure 2-18. In this dialog box, you can 
select a file format and specify other necessary options prior to importing points. The options 
in this dialog box are discussed next. 

Selected Files
The Selected Files list box displays the name and path of the selected file to be imported 
as points. To add a source file, choose the button on the right of the Selected Files list 
box; the Select Source File dialog box will be displayed. Browse to the required 
folder and then select the file to be imported. Also, select the file type from the Files of type 
drop-down list and choose the Open button to open the file; the name and path of the file 
will be displayed in the Selected Files list box.

Specify point file format
The Point File Formats dialog box displays various file formats supported by Civil 3D. A 
file format describes the sequence or arrangement of point data in the file to be imported. 
It is important to select file format similar to point file before importing, exporting, or 
transferring points. For example, if the point file consists of the northing, easting, and 
elevation information of points, you need to select the NEZ file format. 

There are two main types of file formats, User point Database and User Point File. The 
User Point Database format is used to specify the arrangement of point data in the Microsoft 
Access database file and the User Point File is used to specify the arrangement in the .txt 
file. You can use the in-built file formats depending upon the type of file used or create 
your own formats. The methods of creating new formats are discussed later in this chapter.
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Figure 2-18  The Import Points dialog box

Add Points to Point Group 
Select the Add Points to Point Group check box to add the points of the selected file to an 
existing point group. You can select a point group from the drop-down list located below 
the Add Points to Point Group check box, if the drawing consists of any predefined point 
groups. If the drawing does not consist of a point group, you can create a point  group. To 
create a point group, choose the button on the right of the drop-down list; the Point 
File Formats - Create Group dialog box will be displayed. Enter the name of the point 
group that you want to create in the edit box and choose the OK button; the point group 
will be created and the points will be added to the point group.  

Advanced options
Selecting the Do elevation adjustment if possible check box from the Advanced options 
area enables the elevation adjustment of the points being imported. For adjusting elevation 
data using this option, the point file format must contain Z+, Z-, or thickness columns.

Here, the value in the Z+ column will be added to the value in the Elevation column. The 
value in the Z- column for a point will be subtracted from the value in the Elevation column. 
This results in new elevation values for the points when they are imported or transferred. 
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The Thickness column is used to store data for layer thickness and thickness value will be 
subtracted from the value in the Elevation column for the points. 

Selecting the Do coordinate transformation if possible check box enables the coordinate 
transformation for the imported point file. This option is applicable only if the imported 
point file and the drawing in which the point file is imported has a defined coordinate system. 
The imported points are transformed to match the coordinate system of the current drawing. 

After specifying the file format and other options in the Import Points dialog box, choose 
the OK button; the dialog box will be closed and points will be imported. The appearance 
of the imported points will depend on the point settings.

Tip
You can also create points using the Create Points toolbar, refer to Figure 2-19. To invoke 
the toolbar, choose the Points Creation Tools tool from Home > Create Ground Data > 
Points drop-down.  Alternatively, invoke the Create Points toolbar by right-clicking on the 
Points node in the Prospector tab in the TOOLSPACE palette and then choose Create from 
the shortcut menu displayed. 

Figure 2-19  The Create Points toolbar

Note 
If you do not specify a point group, the points created or imported in the drawing will be added 
to the default _All Point point group. The _All Point group is displayed in the Prospector tab 
of the TOOLSPACE palette. 

 

POINT SETTINGS AND STYLES
AutoCAD Civil 3D has some in-built point styles that control the visibility and appearance of 
Civil 3D points. Besides controlling the visibility and display of points, these styles help you 
manage the workability of points. Point styles can be assigned after the points are imported or 
created. Alternatively, you can use a drawing template with the required point settings and then 
import or create points according to industry standards. Civil 3D has some default settings for 
points. These settings control display, elevation, layer, visibility, size, dimension, and so on. You 
can view and edit these default settings as per your requirement. To edit these settings, choose 
the Settings tab in the TOOLSPACE palette and right-click on the Point node; a shortcut 
menu will be displayed. Choose the Edit Feature Settings option from the shortcut menu, as 
shown in Figure 2-20; the Edit Feature Settings - Point dialog box will be displayed, as shown 
in Figure 2-21. 
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Figure 2-20  Choosing the Edit Feature Settings  
option from the shortcut menu

Figure 2-21  The Edit Feature Settings - Point dialog box 

This dialog box is used to edit the settings of points. Every Civil 3D object has some default 
settings that can be viewed and modified using the Edit Feature Settings - Point dialog box. 
You can expand various categories in the dialog box and click in the Value field of properties 
to modify values. 

For example, expand the Default Styles node and then click in the Value field of the Point 
Style property; The Browse button will be displayed. Choose the Browse button to display 
the Point Style dialog box. Select the required option from the drop-down list, as shown in 
Figure 2-22. Next, choose the OK button; the dialog box will be closed and the default point 
style will be modified. Now, when you create or import points in the drawing or template, the 
selected point style will be assigned automatically to points. 
Similarly, you can modify the other default values related to the point object in this dialog box
and choose the OK button to close the dialog box.
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Figure 2-22  Selecting a point style from the drop-down list

Note
The drop-down list displayed in the Point Style dialog box will be based on the type of drawing 
template selected while creating the drawing file.

Point Styles
Point styles control the shape, size, color, and location of the point marker. It also controls 
the visibility of the point label. Point styles are created and assigned before or after points are 
created in the drawing. As discussed earlier, AutoCAD Civil 3D provides you with some in-built 
point styles. However, you can create your own point styles as per the project requirements 
and use them in the drawing. Point styles are created and managed in the Settings tab of the 
TOOLSPACE palette. 

Creating a Point Style
You can create a point style by using the options in the

Figure 2-23  Choosing the New option from 
the shortcut menu

Point Style - New Point Style dialog box. To invoke 
the Point Style - New Point Style dialog box, choose 
the Settings tab in the TOOLSPACE palette and 
expand the Point node. Next, right-click on Point 
Styles and then choose the New option from the 
shortcut menu displayed, as shown in Figure 2-23. On 
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doing so, the Point Style - New Point Style dialog box will be displayed with the Information 
tab chosen, as shown in Figure 2-24. The options in different tabs of this dialog box are discussed 
next.

Figure 2-24  Partial view of the Information tab of the Point Style - New Point Style dialog box

Information Tab
This tab is chosen by default and is used to specify name for a point style. Enter a name 
for the new point style in the Name edit box. If no name is specified, the point style will be 
created with the default name New Point Style. You can also enter a description about the 
point style in the Description text box. 

Marker Tab
The Marker tab, as shown in Figure 2-25, is used to specify the appearance of the marker point 
in the drawing. Using this tab, you can specify the point marker as that of the AutoCAD point 
style or you can use the AutoCAD blocks to represent them in the drawing. In this tab, you 
can also use the custom defined point markers to represent as a point marker in the drawing. 
Various options in the Marker tab are discussed next. 

In the Marker tab, you can specify the marker point using the current AutoCAD point 
symbol, which can be specified by the AutoCAD PDMODE and PDSIZE system variables. To 
do so, select the Use AutoCAD POINT for marker radio button and see its preview in the 
Preview area. In this tab, you can also use a specified symbol to represent a point marker 
in the drawing. To do so, select the Use custom marker radio button. On selecting this 
radio button, different symbols to represent the point marker will be displayed as buttons 
in the Custom marker style area. You can choose any one of the five buttons on the left 
to be used as a base symbol and then choose either sixth or seventh button or both. The 
last two buttons that are chosen individually or in combination superimposes over the base 
symbol to form a combined symbol. As you choose these buttons, you can preview them in 
the Preview area of the Marker tab.
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Figure 2-25 The Marker tab in the Point Style - New Point Style dialog box

You can also display the point marker in the drawing using a block reference of an AutoCAD 
block. To do so, select the Use AutoCAD BLOCK symbol for marker radio button; the list 
of blocks defined in the drawing are listed in the text box below the radio button. Choose 
any of the blocks from the list and preview it in the Preview area.

   
After selecting the marker style, specify the size of the marker in the Size area. You can set 
the size of the markers using four different options available in the Options drop-down 
list. Select the Use drawing scale option to specify the size of the marker by multiplying a 
specified value with the current drawing scale. Enter the required value in the inches edit 
box. You can select the Use Fixed Scale option from the drop-down list to set the size of 
the point marker by specifying the fixed scale values in the X, Y, and Z edit boxes. Enter a 
suitable value in these edit boxes to assign a fixed display scale to the marker.

You can also select the Use size in absolute units option from the Options drop-down list 
to set the marker size in an absolute value, based on the units displayed. Enter the required 
value for the size in the edit box next to the drop-down list. The Use size relative to screen 
option in the Options drop-down list is used to set the size of the marker as percentage of 
the drawing screen size. Enter the percentage in the percent edit box.

Optionally, specify the marker rotation in the Marker rotation angle edit box or choose 
the button on the right to specify the rotation by picking points from the drawing. Also, 
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specify the orientation of the marker by selecting the option from the Orientation Reference 
drop-down list. If you select the World Coordinate System option, it ensures that the marker 
rotation angle will be relative to the world coordinate system. If the Object option is selected 
from the drop-down list then the marker rotation angle will be relative to the object it is 
attached to. If you select the View option from the Orientation Reference drop-down list, 
the marker rotation angle will be relative to the current AutoCAD view direction.

3D Geometry Tab
This tab is used to specify the display of points in the Model view or 3D views. The Point 
Display Mode property specifies the display of point in 3D view. Click in the Value field of 
this property and select any of the three display modes from the drop-down list. Select the 
Use Point Elevation mode to display points at their actual elevation. The Flatten Points To 
Elevation mode is used to flatten or project points to the specified elevation. On selecting 
this option, the Point Elevation property will be enabled. You can specify the required 
elevation in the Value field of this property. The Exaggerate Points by Scale Factor mode 
is used to raise or exaggerate the elevation of point by a specified scale factor. On selecting 
this option, the Scale Factor property will be available and you can enter the required scale 
factor in the Value field of this property.

Display Tab
This tab is used to set the visibility and display of the point marker and label. Using this 
tab, you can set different display settings for points in different views such as plan view (2D), 
model (3D), section, or profile view. You can select the required view from the View Direction 
drop-down list. To do so, select the required view from the View Direction drop-down list 
and then set the display settings in the Component display area.

The Component display area is used to display the point component and different 
display settings in different columns. The Component Type column in this area lists 
the components of point object. The number of components in the Component Type 
column varies according to the types of object present in the drawing. The Visible column 
specifies the visibility of component. Click on the light bulb icon in this column to control 
the visibility. The bulb in yellow color indicates that the component is visible. Click on the 
bulb to turn it off; the select component will now become invisible in the drawing. 

The Layer column specifies the layer assigned to the component. Click on the default layer 
value to display the Layer Selection dialog box. You can use this dialog box to specify the 
required layer for the component and choose OK to exit the dialog box. The Color column 
specifies the color of the component. Click on the default value in the Color column to display 
the Select Color dialog box. You can use this dialog box to select a color for the component.

The Linetype column specifies the linetype for the component. Click on the default value 
in this column to display the Select Linetype dialog box. Select the required linetype from 
the dialog box. Note that the Show Linetypes in Drawing radio button is selected by default 
in this dialog box. As a result, the linetypes loaded in the current drawing are displayed. To 
view more linetypes, select the Show Linetypes in File radio button.

The LT Scale column specifies the linetype scale for the component. Click on the default 
value and enter the scale in the LT Scale column. 
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The Lineweight column specifies the lineweight for the component. Click on the default 
Value in this column to display the Lineweight dialog box. Select the required lineweight 
from this dialog box and choose the OK button; the specified lineweight will be applied on 
the component. The Plot Style column specifies the plot style of the component. You can 
edit the value for the plot style.

The Summary Tab
This tab is used to review or edit the values of properties, if required. After you have specified 
settings in the point style, choose the OK button; the Point Style dialog box will be closed 
and the point style will be added in the Point Styles node in the Settings tab.

POINT LABEL STYLES
Point label styles control the behavior and appearance of point labels. Point labels provide 
information about points. Like point styles, point label styles are created and managed in the 
Settings tab of the TOOLSPACE palette. 

Creating a Point Label Style
Civil 3D provides you with some in-built label styles such as the point styles. But you can create 
your own point label styles and use them in the drawing. To create a new point label, choose 
the Settings tab and expand Point and select Label Styles to view the in-built label styles. 
Right-click on the Label Styles option; a shortcut menu will be displayed. Choose New from 
the shortcut menu; the Label Style Composer dialog box - New Point Label Style dialog box 
will be displayed. The options in this dialog box are discussed next.

Information Tab  
This tab displays information about point label style such as name, date of creation, and so on. 
Enter a name for the required point label style in the Name edit box in this tab.

General Tab
The General tab is used to specify if label is displayed as label or tag. In addition, it specifies the 
visibility, orientation reference, and so on for the label. The properties in this tab are listed in 
the Property column under three different categories: Label, Behavior, and Plan Readability. 
The default values of properties are listed in the Value column. The Preview pane in this tab 
displays the preview of the point and point label style. You can use the ViewCube tool in this 
pane to view the point style and point label style in different directions. Various properties 
displayed under these three categories are discussed next.

Text Style
The Text Style property is used to specify the default text style for the label text. Click in 
the Value field of this property; The Browse button will be displayed. Choose the Browse 
button to display the Select Text Style dialog box. Select the required style from this dialog 
box and then choose the OK button to apply the specified style. 

Label Visibility
This property is used to control the visibility of the entire label. By default, the value of this 
property is set to True. As a result, the label will be visible in the drawing. To hide the point 
label in the drawing, set the value of this property to False.
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Layer
The Layer property is used to specify the default layer for all label components. To modify 
the layer, click in the Value field and choose the browse button available on the right of this 
field; the Layer Selection dialog box will be displayed. You can use this dialog box to select 
or create the required layer.

Orientation Reference
This property is used to specify the orientation for the point label. By default, orientation 
is set to Object, which indicates that the label will be oriented according to object such as 
line or arc. To change the orientation of the point label, click in the Value field and select 
the required options from the drop-down list. The options have been explained earlier in 
this chapter.

Forced Insertion
This property is used to specify the position for a point label relative to an object such as line 
or arc segment. This property will be active only when the Orientation Reference property 
is set to Object. To specify the value for the Forced Insertion property, click in its Value 
field; a drop-down list will be displayed. You can select any of the following three options 
from the drop-down list: None, Bottom, and Top. The None option is selected by default. 
As a result, the point label is placed at its original location. You can select the Bottom or 
Top option to add the label at the bottom or top of the object.

Plan Readable 
This property is used to specify whether to rotate the label text to make it easily readable 
in the plan view. By default, the value of this property is set to True, which indicates that 
the label will be rotated in the plan view to make it easily readable. If you set the value of 
this property to False then the Readability Bias and Flip Anchors with Text properties 
will not be highlighted

Layout Tab
The options in the Layout tab, as shown in Figure 2-26, are used to specify the layout of the 
point label by creating and editing label components. The options in this tab are discussed next.

Component name
The Component name drop-down list is used to display the components of point label. By 
default, the point label has three components Point Number, Point Elevation, and Point 
Description. Select the required label component from the Component name drop-down list 
to view its properties in the Property column. Different label properties in this tab are 
discussed next.
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Figure 2-26  The options in the Layout tab

Name
This property of the General category is used to specify the name of the selected label 
component. Click in the Value field of this property and specify the name of the newly 
created component or the existing label components. Note that you cannot change the 
name of Point Elevation.

Visibility 
This property is used to specify whether the component is visible or not. By default, the 
value of this property is set to True. As a result, the component will be visible in the drawing. 
Click in the Value field of this property and select False from the drop-down list to hide 
the selected component.

Anchor Component
This property is used to specify a reference for positioning the component. There are 
three options available for Anchor Component: Feature, Point Description, and Point 
elevation. Click in the Value field of this property and select the required component from 
the drop-down list to use it as an anchor for the label. The default option <Feature> helps 
you anchor the label to a feature. A point is called a feature, if a label style is created for it.

Anchor Point 
This property is used to specify the location where the text of the label style will be attached 
on the component. To assign a value to this property, click in its Value field and select any 
of the options from the drop-down list displayed. The options available in the drop-down 
list are: Top Left, Top Center, and so on. For example, if you select Feature as the anchor 
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component for the Point Description component and Top Left as the anchor point, the 
Point Description will be placed at top left corner of the existing feature (point). 

Contents
This property of the Text category is used to specify the content of label component. Click 
in the Value field of this property and choose the Browse button; the Text Component 
Editor - Content dialog box will be displayed. You can use this dialog box to create label 
text. The procedure to add text to the label is discussed later in this chapter.

Text Height 
This property is used to specify height of the text in the label. Click in the Value field of the 
Text Height property and specify the required text height.

Rotation Angle 
This property is used to specify the angle of rotation or inclination of the text component. 
Click in the Value field of this property and enter value of rotation. Alternatively, choose 
the button displayed on the right to specify the rotation by picking points from the drawing. 
The positive angle direction is always counter clockwise.
Attachment
This property is used to specify the attachment point for the label component attached to 
the anchor point. Click in the Value field and select the required attachment point from 
the drop-down list that is displayed.

X Offset 
This property is used to specify the offset distance of the component from anchor point in 
the X direction. Click in the Value field of this property and enter the offset value to adjust 
label, if required.

Y Offset 
This property is used to specify the offset distance of the component from anchor point in 
the Y direction. Click in the Value field of this property and enter the offset value to adjust 
the label, if required. 

Color 
This property is used to specify the default color of the label component. To change the 
default color, click on the value, and choose the Browse button; the Select Color dialog box 
will be displayed. Select the required color from this dialog box and choose the OK button.

Lineweight
This property is used to specify the lineweight of the text. Click in the Value field of 
Lineweight and choose the button displayed on the right; the Lineweight dialog box 
will be displayed. Select the required lineweight from the dialog box and choose OK; the 
Lineweight dialog box will be closed.

Visibility 
This property of the Border category is used to specify whether the label component text 
will be displayed with a border or not. By default, the value of this property is set to False. 
As a result, the border will be invisible. To display label in a border, click in the Value field 



2-32 			                    	                            Exploring AutoCAD Civil 3D 2020
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

of this property and select True from the drop-down list to make the border visible. You can 
view the border in the Preview window.

Type
This property is used to specify the shape of the border. The Rectangular is the default 
border type. To select a border shape, click in the Value field of the Type property and select 
the required shape for the border from the drop-down list. You can view the shape of the 
border in the Preview panel after setting the visibility of the border to True.

Background Mask
This property is used to specify whether or not a background mask will be applied to the 
label. Click in the Value field of this property and select True from the drop-down list to 
apply the background mask. If you apply the background mask to the component, the 
background of the label, such as surface contours, will be hidden by mask.

Gap
This property is used to specify the distance between label component and border. Click in 
the Value field of this property and specify the distance between label and border.
Color
This property is used to specify the color of the border. The default value of this property 
is By Layer, which indicates that the current color assigned to the label is controlled by the 
layer property of the border. 

Linetype
This property is used to specify the linetype of the border. The default value of the Linetype 
property is By Block.

Lineweight
This property specifies the lineweight of the border.

Create component
To create a new label component, choose the required option from the Component 
name drop-down; a flyout will be displayed. You can choose the required component 

to be added from the flyout. You can add a new text component, a line component, or a 
block component and then set its properties as required.

Copy component
Choose the Copy component button to create a copy of the selected component. 
Specify a name in the Value column for the copied component; the component will 

be added in the Component name drop-down list.

Delete component
Choose the Delete component button to delete the selected label component from 
the Component name drop-down list.

Component draw order
Choose the Component draw order button; the Component Draw Order dialog box 
will be displayed, as shown in Figure 2-27.
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Figure 2-27  The Component Draw Order dialog box

You can use this dialog box to specify the order in which label components will be displayed 
in the multicomponent label. Select the required component from the Component area and 
choose the Top or Bottom button to move the selected component to the top or bottom 
in the label. Note that the component at the top of the dialog box is the last component 
displayed in the label.

Dragged State Tab
This tab is used to specify the properties and display of label when it is dragged from its insertion 
point. You may drag the label from its original insertion point due to the lack of space in the 
drawing. When you drag label to a different position, it is followed by a leader with an arrow 
head. The properties of this tab are listed under two categories, Leader and Dragged State 
Components. The Leader category contains leader properties where as the Dragged State 
Components category contains label properties. Some of the properties of this tab are discussed 
next.

Arrow Head Style
This property of the Leader category is used to specify the default arrow head style for the 
leader attached to the dragged label. Click in the Value field of this property and select the 
required style from the drop-down list. The None option is used to create a leader without 
arrow head.

Arrow Head Size
This property is used to specify the default arrow head size of the leader. Click in the Value 
field and change the size, if required.

Visibility
The Visibility property controls the visibility of the leader. By default, the value is set to True. 
If you do not want the leader to be displayed when the label is dragged, set the visibility of 
the leader to False..
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Type
This property is used to specify the type of leader that will be drawn after dragging the 
label. Click in the Value field of this property and then select the Straight Leader or Spline 
Leader type from the Value field of this property.

Display
This property of the Dragged State Components category is used to control the display of 
label after it is dragged. There are two options to display the dragged label: As Composed 
and Stacked Text. Select the As Composed option to display the label the way it is originally 
composed and oriented. On selecting this option, all other properties in the Dragged State 
Components category will disappear. Select the Stacked Text option to display the label 
based on the settings of the properties specified in the Dragged State Components category. 
On selecting this option, label components will be stacked or arranged vertically in the order 
they are defined in the label style.

Leader Attachment
This property is used to specify the attachment location of the leader with reference to the 
label content. Click in the Value field of this property and select the required option to 
attach the leader from the drop-down list. 
Leader Justification
This property specifies whether the label text is justified according to the leader or not. Set 
the value of this property to True to enable the left justification of the text if the leader is 
on the left and vice versa. If the leader justification is set to False, the text will always be 
left-justified, irrespective of the leader position. 

Summary Tab
This tab is used to review and edit the properties of all the components of a label. Expand the 
categories in this tab to view properties and values. 

After you have specified the settings of the label style, choose the OK button to close the Label 
Style Composer - New Point Label Style dialog box. The label style will be added in the Label 
Styles node of the Settings tab.

Adding the Text Component to the Label
To add a new text component to a label, choose the Layout tab from the Label Style 
Composer - New dialog box and then choose the default Create Text component button available 
on the right of the Component name drop-down; the component with the default name Text.1 
will be added to the Component name drop-down list and its properties will be displayed in the 
Property column. Next, click in the Value field of the Contents property. In the Text category, 
choose the browse button displayed in the Value field, as shown in Figure 2-28. On doing so, 
the Text Component Editor - Contents dialog box will be displayed, as shown in Figure 2-29.
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Figure 2-28  Choosing the browse button displayed 
in the Value field of the Contents property

In this dialog box, the Properties tab is chosen by default. In this tab, click in the 
Properties drop-down list and then select the property to be added to the label text; the property 
modifiers and their respective values will be displayed in the Modifier and Value columns, 
respectively. Change the property modifier value if required and then choose the right-arrow 
button next to the Properties drop-down list to add the selected property in the Text Component 
Editor window.

Figure 2-29  The Text Component Editor - Contents  dialog box

Note
You can edit the modifier values of a property after it has been added to the right pane of the Text 
Component Editor - Contents dialog box. To do so, select the text for the property to be edited in 
the right pane; the property corresponding to the selected text is displayed in the left pane. Now, 
edit the required modifier value in the left pane. 
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To format the text, choose the Format tab. Select the text in the Editor window in the right pane 
of the Text Component Editor - Contents dialog box and choose the options in the Formatable 
to format the text as required. After you have formatted the text, choose the OK button from 
the Text Editor Component - Contents dialog box; the dialog box will be closed and you can 
preview the label content in the Preview window. 

To view and edit the default settings of point label styles, expand the Point node and 
right-click on the Label Styles sub-node in the Settings tab; a shortcut menu will be 
displayed. Choose the Edit Label Style Defaults option from the shortcut menu; the 
Edit Label Style Defaults - Point Label Style dialog box will be displayed, as shown in Figure 2-30. 
Expand the categories in this dialog box to view and edit the default values of label properties. 
You can assign point style or point label style to a group of points. The point groups are discussed 
later in this chapter.

Figure 2-30  The Edit Label Style Defaults - Point Label Style dialog box 

EDITING POINTS
Ribbon:           Modify > Ground Data > Points
Command:      EDITPOINTS

You can edit the properties of a point. There are various tools that can be used to edit the 
properties of a point. To edit a property, choose the Points tool from the Ground Data panel 
of the Modify tab; the COGO Point contextual tab will be displayed in the Ribbon, as shown 
in Figure 2-31.
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Figure 2-31  The COGO Point contextual tab 

This tab contains various editing tools. These tools are discussed next.

Renumbering a Point
Ribbon:           COGO Point > Modify > Renumber
Command:      SELECTANDEDITPOINTNUMBERS

To renumber a point, choose the Renumber tool from the Modify panel; you will be prompted 
to specify a method for selecting points. Press ENTER to accept the default <All> option to
renumber all the points. Enter N in the command line to specify the required point number 
to renumber, G to select the point group to renumber points in the point group, or S to 
renumber the selected points from the drawing. Alternatively, you can renumber a point in the 
PANORAMA window. To do so, right-click on the required point number in the Point Number 
column of this window and then choose the Renumber option from the shortcut menu; you 
will be prompted to enter an additive factor. Enter an integer value in the command line and 
press ENTER; the point will be renumbered according to the integer value specified. The value 
(additive factor) specified will be added to the existing point number to renumber it. 

Changing the Elevation of the Point
Ribbon:           COGO Point > Modify > Datum
Command:      EDITPOINTDATUM

You can change the elevation of a point(s) with respect to a specified datum. To do so, 
choose the Datum tool from the Modify panel; you will be prompted to enter a new 
elevation or select a reference. Enter the required elevation in the command line or R in the 
command line to select the Reference option and then press ENTER. The elevation of the 
selected point will be modified in the Point Elevation column. If you select the Reference option, 
you need to specify the reference elevation and then the new elevation. The elevation of the 
selected point will be modified on the basis of difference between the two elevations.

Tip
You can also change the elevation of a point by changing the datum. To change elevation 
using datum, select the point and right-click on it; a shortcut menu will be displayed. Choose 
Datum from the shortcut menu. Then, choose change in Elevation or Reference option and
press ENTER. 

Changing the Point Elevation with Respect to a Surface
Ribbon:           COGO Point > Modify > Elevation from Surface
Command:      EDITPOINTSURFACEELEVS
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You can change the point elevation based on the surface elevation. To do so, select the required 
point number(s) and choose the Elevations from Surface tool from the Modify panel; the Select 
surface dialog box will be displayed. Select the required surface from the dialog box and choose 
the OK button to close the dialog box. The Point Elevation column will display the elevation 
from the surface. After selecting the required surface, you will be prompted to specify the points 
to be edited. Choose the required points and press ENTER. Note that Civil 3D will display a 
message if there is no surface in the drawing. Alternatively, right-click on the point number(s) 
and then choose the Elevation from Surface option from the shortcut menu displayed; the 
Select surface dialog box will be displayed. Select the desired surface from the drop-down list
 and then choose the OK button to close the dialog box. The Point Elevation column will display 
the elevation from the surface. 

Deleting a Point 
To delete a point from the drawing, right-click on the point number to be deleted in the item 
view of TOOLSPACE; a shortcut menu will be displayed. Choose the Delete option from the 
shortcut menu; the Autodesk AutoCAD Civil 3D 2020 message box will be displayed. Choose 
the Yes button to delete the required point(s). Alternatively, select the point object and press 
DELETE to delete.

Zooming to a Point
To zoom to a point(s), select it in the item view of the TOOLSPACE and then right-click; a 
shortcut menu will be displayed. Choose the Zoom to option from the shortcut menu to zoom 
to the selected point(s). 

Locking/Unlocking Points 
Ribbon:           COGO Point > Modify > Lock Points/Unlock Points 
Command:      LOCK POINTS / UNLOCK POINTS

Locking the points prevents you from changing the properties of points. You cannot delete,
move, edit, or even change the point style and the point label style of the locked points. To 
lock points, right-click on the required point numbers from the Point Number column of the 
Point Editor; a shortcut menu will be displayed. Choose Lock from the shortcut menu; the 
selected point will be locked and a red colored symbol will be displayed next to the selected 
point in the Point Editor tab, as shown in Figure 2-32.

Similarly, you can choose Unlock from the shortcut menu to unlock points to edit. The locked 
points will be displayed in the Point Editor as well as in the Prospector List view. Alternatively, 
the points can be locked or unlocked using the Lock Points or Unlock Points tools that are 
available in the Modify panel of the COGO Point tab.
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Figure 2-32  A red colored symbol displayed next to the selected point in the 
Point Editor tab 

Using the Geodetic Calculator
Ribbon:           COGO Point > Analyze > Geodetic Calculator
Command:      SHOWGEODETICCALCULATOR

You can use the Geodetic Calculator tool to calculate geodetic information about points. To do 
so, the drawing must have a defined coordinate system. Civil 3D will display a warning message 
if no coordinate zone is assigned to the drawing. To calculate geodetic information, choose the 
Geodetic Calculator tool from the Analyze panel; the Geodetic Calculator dialog box will be 
displayed, as shown in Figure 2-33. Choose the Specify point button at top left corner of the 
dialog box and click in the drawing to specify the point; the geodetic information of the point 
will be displayed in the dialog box. Alternatively, enter the point number in the Value column.
You can also specify the required geodetic information such as Latitude, Longitudes or Grid 
Easting or Grid Northing and create the point with specified geodetic information. To do so, 
specify the geodetic information and choose the Create Points button from top right corner of 
the dialog box; you will be prompted to specify the point description. Enter the point description 
in the command line and press ENTER; the point with the specified geodetic information will 
be created.

Figure 2-33  The Geodetic Calculator dialog box
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Editing Points Using the PANORAMA Window
You can edit individual points either graphically in the drawing or by using the Point Editor 
tab in the PANORAMA window. To edit points using the Point Editor tab, choose the Edit/List 
Points tool from the Modify panel of the COGO Point tab; the PANORAMA window with the 
Point Editor tab will be displayed, as shown in Figure 2-34. 

Figure 2-34  The PANORAMA window with the Point Editor tab

The Point Editor tab in the PANORAMA window is used to display information about points 
such as its Elevation, Northing, Easting, Number, and others that are relevant to it. Click in the 
required cell and edit a new value of the point property. For example, to change the elevation 
of point number 1, click in the corresponding cell of the Point Elevation column and enter 
a new value for this number. Similarly, you can change the Easting, Northing, Elevation and 
other properties of individual points. You can also use different point editing commands in the 
Point Editor tab. To do so, right-click on any point number in the Point Number column of the 
Point Editor tab; a shortcut menu will be displayed. You can also use the AutoCAD commands 
such as rotate, copy, move, and erase to edit points graphically.

Note
To change the properties of multiple points, press and hold the CTRL key and then select the          
required number of points in the Point Number column.

Tip
You can also invoke the PANAROMA window from the TOOLSPACE. To do so, right-click 
on the Points node in the Prospector tab and then choose the Edit Points option from the 
shortcut menu.

Importing/Exporting/Transferring Points 
Civil 3D allows you to import, export, and even transfer points from one file to another. Points 
can be imported and exported in the ASCII (.txt) format or in the Microsoft Access database 
(.mdb) format. Importing points is the easiest method to create and add points in the drawing. 
The surveyor collects the point data and then imports it to Civil 3D as an ASCII file. 

Importing Points
Ribbon:           COGO Point > COGO Point Tools> Import Points
Command:      IMPORTPOINTS

To import points in the AutoCAD Civil 3D workspace, choose the Import Points tool 
from the COGO Point Tools panel; the Import Points dialog box will be displayed. While 
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importing, exporting, and transferring points, you need to select the right type of file format. 
AutoCAD Civil 3D will display a check mark next to the path of the file if the file format 
selected is correct. Select the required file format from the Specify point file format list box in 
the Import Points dialog box and then import the required point file. You can also create your 
own file format. The method of creating file format is discussed later in this chapter. 
Exporting Points

Ribbon:           COGO Point > COGO Point Tools > Export Points
Command:      EXPORTPOINTS

You can export specific points from AutoCAD Civil 3D to ASCII file or a Microsoft Access database. 
Before exporting points, you need to select the appropriate file format depending upon the 
point data and then export points. To export Civil 3D points, choose the Export Points tool 
from the COGO Point Tools panel; the Export Points dialog box will be displayed, as shown in 
Figure 2-35. Note that the default file format selected is Autodesk Uploadable File.

Next, select the required file format from the Format drop-down list in the dialog box. You can 
also create your own file format, which will be discussed later in this chapter. Next, enter the 
name and path of the file to which points will be exported or choose the button on the right of 
the Destination File text box; the Select Destination File dialog box will be displayed. Browse 
to the required location where the file is saved. Select the file and then choose the Open button; 
the file name and path will be displayed in the Destination File text box. You can export files 
by using any of the two file format options: Columnated or Delimited. These options are 
discussed later in this chapter.

Figure 2-35  The Export Points dialog box

Next, in the Export Points dialog box, you can also select the Limit to Points in Point Group 
check box; the drop-down list will be activated. Select the required point group from the 
drop-down list below it. On doing so, points will be added to the required point group. Now, 
choose the OK button; the dialog box will be closed and points will be exported.
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Tip
You can also invoke the Export Points dialog box from the TOOLSPACE palette. To do so, 
right-click on the Points node in the Prospector tab; a shortcut menu will be displayed. Choose 
the Export option from the menu; the Export Points dialog box will be displayed.

Transferring Points

Ribbon:           COGO Point > COGO Point Tools > Transfer Points
Command:      TRANSFERPOINTS

AutoCAD Civil 3D allows you to transfer points from the source file to the destination file. 
A source file is a file from which points are transferred and destination file is a file to which 
points will be transferred. The source and destination files can be .txt files or .mdb files. Before 
transferring points, ensure that the file format of both the files are same. Before transferring 
points, you need to create two types of file formats for both the source and destination files to 
specify the layout or arrangement of the point data in files. 

After you have created the file formats for both the files, choose the Transfer Points tool in 
the COGO Points Tools panel; the Transfer Points dialog box will be displayed, as shown in 
Figure 2-36.

Figure 2-36  The Transfer Points dialog box
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In the Source area of the dialog box, select the required file format of the source file from the 
Format drop-down list. Choose the (+) sign button on the right of the text box of this area to 
display the Select Source File dialog box. Select the required file from this dialog box and choose 
the OK button to close it. Similarly, select the required file format and select the destination file 
from the Destination area. 

Tip
You can also invoke the Transfer Points dialog box from the TOOLSPACE palette. To do 
so, right-click on Points in the Prospector tab and then choose the Transfer option from the 
shortcut menu.

Now, select the required check boxes from the Advanced options area to enable the elevation, 
coordinate adjustment, or data expansion of the point data while transferring point from the 
source file to the destination file. Note that you can create a new file format by choosing the 
Manage button in the Transfer Points dialog box. After selecting the file formats and the files, 
choose the OK button; the Transfer Points dialog box will be closed and the point will be 
transferred to the destination file. The method of creating a new file format is discussed next.

Creating a New File Format
A file format defines the structure of file in which it holds (encodes) data. For example, the point 
properties in the source point file are arranged in the order, point number, easting, elevation, 
and description. To import or export the point to or from this file, the file format to which 
points are imported or exported should have the same format. If the order of properties in the 
destination file is easting, elevation, and description, the point numbers of the source file will 
not be transferred to the destination file. 

Civil 3D has some in-built file formats that can be used before importing, exporting, or 
transferring the points. However, you can also create your own file formats as per the requirement. 
The new file formats are created by using the Point File Formats dialog box that can be accessed 
by choosing the button on the right of the Format edit box either in the Import Points or Export 
Points dialog box. 

To create a new point file format, choose the Settings tab in the TOOLSPACE palette and 
expand the Point collection. Next, right-click on the Point File Formats node and the choose 
New from the shortcut menu displayed; the Point File Formats - Select Format Type dialog 
box will be displayed, as shown in Figure 2-37.

Figure 2-37  The Point File Formats - Select  
Format Type dialog box
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You can select any of the two file format types from the dialog box. The User Point Database 
format type is used to describe the arrangement of points in the Microsoft Access database 
file (.mdb) and the User Point File option is used to describe the arrangement of points in the 
ASCII or Text(.txt) file. The methods of creating file formats using these two format types are 
discussed next.

Creating the User Point Database File Format
To create the user point database point file format, right-click on the Point File Format node in 
the Settings tab; a shortcut menu will be displayed. Choose the New option from it; the Point File 
Formats - Select File Format Type dialog box will be displayed. Choose the User Point Database 
option from this dialog box and then choose the OK button; the User Point Database Format 
dialog box will be displayed, as shown in Figure 2-38. This dialog box is used to view or edit 
the properties space of the user point database format used to import points from .mdb files or 
export points from .mdb files. In the Format name edit box, enter a name of the file format; 
the name of the file format will be displayed in the Point File Format node in the Settings tab. 
Select the required table from the Table name drop-down list. Note that if the table name is not 
available in the drop-down list, choose the Load button and load the required .mdb file from 
the Select Source Database dialog box displayed. You can browse to the location where you 
have saved the .mdb file and choose the Open button from this dialog box to load the file. On 
doing so, the table name will be displayed in the Table name drop-down list and the data will 
be displayed in columns. You can refer it for creating format.

Figure 2-38  The User Point Database Format 
dialog box

Optionally, select the check box in the Coordinate Zone Transform area to assign a 
coordinate zone to the file format. Choose the button on the right of the Zone edit box and 
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then select the required zone from the Select Coordinate Zone dialog box. Next, you need to 
format the column names. To do so, click on the default unused column in the dialog box; the 
Point File Formats - Select Column Name dialog box will be displayed. Select the required option 
according to the point data from the Column name drop-down list, as shown in Figure 2-39.
If you do not want any data to be imported and exported, accept the default <unused> option 
from the drop-down list and choose the OK button. Similarly, select the name for all columns 
in the dialog box. To change the order of columns, simply click and drag the column to the 
required position. Next, choose the OK button; the User Point Database Format dialog box 
will be closed and the name of format will be added in the Point File Format node of the Points 
collection in the Settings tab.

Figure 2-39  Selecting the column name from the 
Column name drop-down list

Creating the User Point File Format
To create the user point file format, right-click on the Point File Formats sub-node in the Point 
node of the Settings tab; a shortcut menu will be displayed. In the dialog box, choose the New 
option from it; the Point File Formats - Select Format Type dialog box will be displayed. Choose 
the User Point File option from the text box and then choose the OK button; the Point File 
Format dialog box will be displayed, as shown in Figure 2-40. 

Enter the format name in the Format name edit box. In the Default file extension drop-down 
list of this dialog box, select the required file extension of the point data file. You can select any 
of the following extensions from the drop-down list:

.auf: Autodesk Uploadable File, comma delimited. Required values in the file are point 
number, northing, easting, elevation, and description (in the order).

.csv: Comma Separated Value file; ASCII (text) file comma-delimited

.nez: Northing, Easting, and Elevation data 

.pnt: Point file

.prn: Formatted text, space delimited 
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.txt: Delimited ASCII (text) file 

.xyz: Coordinates X, Y, and Z

Figure 2-40  The Point File Format dialog box

After selecting the default extension, choose the Load button; the Select Source File dialog box 
will be displayed. Select the point file from this dialog box and load the point data. You can refer 
the point data in the file while creating the format. Optionally, assign a coordinate zone to the 
file format, as explained earlier. Now, in the Format options area, select the required format 
option. There are two types of format options: Columnated and Delimited by. By default, the 
Columnated radio button is selected. As a result, the imported point data will be arranged in 
columns and rows, separated by tabs. If you select the Delimited by radio button, the point 
data will be separated by a delimiter such as comma(,) or a space. Figures 2-41 and 2-42 show 
a typical comma separated value file and a space delimited point file, respectively. 

Figure 2-42  Typical space delimited 
file format

Figure 2-41  Typical comma separated 
file format
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To specify the maximum number of points to be imported or exported, select the Read no 
more than check box and enter a value in the points edit box next to it. Civil 3D imports or 
exports only the specified number of points. For example, if you enter 1000 in the points edit 
box, only 1000 points will be imported or exported from the file. Similarly, to sample the point 
data with the specified number and import or export the points accordingly; select the Sample 
every check box and enter a number in the points edit box next to it. For example, if you enter 
a value of 50, every 50th point will be imported or exported from the file.

Adding Point Tables
Ribbon:           COGO Point > Labels & Tables > Add Tables
Command:      ADDPOINTTABLE

Point tables help you view point information in tabular form. You can create different point 
table styles and use them to create tables. To add point tables, choose the Add Tables tool from 
the Labels & Tables panel; the Point Table Creation dialog box will be displayed, as shown in 
Figure 2-43.

Figure 2-43  The Point Table Creation dialog box
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From the Table style drop-down list, select the required table style. The Table layer option is 
used to display the default layer on which the table will be created. To modify the default layer, 
choose the button on the right of this option; the Object Layer dialog box will be displayed. 
You can use this dialog box to select or create a new layer for the table.

The options in the Selection area are used to select the points to be labeled. The Selection area 
displays the list of existing point label styles in the Label Style Name column. To select the 
required point label style, select the corresponding check box in the Apply column. The label 
content of the selected point label style will be used to create point table. 

Now, choose the Select Point Groups button to display the Point Groups dialog box. Select 
the required point group from the dialog box and choose the OK button; the points of 
the selected point group will be added in the table and the total number of point group(s) 
will be displayed next to the Select Point Groups button. You can choose the Pick On-Screen 
button and select the required points from the drawing by using any window selection method 
and then press ENTER; the selected points will be added in the table and displayed next to the 
Pick On-Screen button. 
Optionally, choose the options in the Split table to format the table and choose the OK button; 
the Point Table Creation dialog box will be closed and you will be prompted to specify the upper 
left corner of the table. Click at the required location in the drawing area; the point table will 
added in the drawing. 

POINT GROUPS
As mentioned earlier, a point group is a collection of similar points. Point groups help you 
control, organize, and manage a point easily. Like points, point groups also have their own 
styles and label styles. You can assign different point styles and point label styles to each point 
group and control the appearance of points of a point group. It helps you quickly identify and 
modify point styles or point label styles of the required points of any point group. For example, 
you can group surface points that are used for creating surface in a group and assign a point 
style to them. Also, you can create another point group containing points of the centerline of an 
alignment and assign them a different point style and label style. Now, you can easily identify 
and distinguish the surface creation points from the centerline points in the drawing. These 
points can then be easily edited or managed in the drawing as required.

Creating Point Groups 
Ribbon:           Home > Create Ground Data > Points drop-down > Create Point Group
Command:      CREATEPOINTGROUP

Point groups are created based on point properties. You can group points based on their point 
numbers, elevation, description, and so on. To create a point group, choose the Create Point Group 
tool from the Create Ground Data panel; the Point Group Properties - Point Group - (1) dialog 
box will be displayed, as shown in Figure 2-44. The options in the dialog box are discussed next.
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Figure 2-44  The Point Group Properties - Point Group - (1) dialog box

Information Tab
The Information tab in this dialog is chosen by default. Enter a name of the point group in the 
Name edit box. Optionally, enter a short description about the point group in the Description 
text box. Next, in the Default styles area, select the point style from the Point style drop-down 
list for the points included in the point group. Similarly, select a point label style from the Point 
label style drop-down list to label the points included in the point group. On selecting the Object 
locked check box, the Name and Description areas will become inactive.

Tip
You can also create your own Point Style and Point Label Style by selecting Create 
New from the drop-down lists available on the right of the Point Style and Point 
Label Style drop-down lists.

Point Groups Tab
This tab is used to list the existing point groups in the drawing. To select a particular point 
group from the list, select the check box on the left of the point group name in the Point Group 
column. The _All Points point group is the default point group.

Raw Desc Matching Tab
This tab is used to list the codes that are used for description keys in the drawing. You can use this 
tab to include the points whose raw description match with the description key codes displayed in 
this tab. You can select the required description key code by selecting the check box next to it. 
The points whose raw description matches with the selected codes will be included in the point 
group. Note that codes will be displayed in this only if the drawing contains description keys. 
The description keys and their functions are discussed later in this chapter.
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Include Tab
This tab is used to specify the criteria to include points based on their point numbers, elevations, 
names, raw description, full description either in the respective edit boxes or by selecting them 
from the drawing. The options are discussed next.

With numbers matching
Select the With numbers matching check box to include points based on specified point 
numbers. You can enter point numbers in the edit box next to the check box. The point 
numbers should be separated by comma. You can also enter a point number range separated 
by hyphen. For example, you can enter point numbers like, 100, 150, 200. On doing so, 
the points with the point numbers matching to 100, 150, 200 will be included in the point 
group. Enter the point range as 50-500; all the points with point numbers starting from 50 
to 500 will be included in the drawing. Alternatively, choose the Selection Set in Drawing 
button and select the required points from the drawing using the window selection method 
and press ENTER; the point numbers or the ranges will be displayed in the edit box after 
the selection.

With elevations matching
Select this check box to include points in the point group based on their elevations. You can 
enter elevations of points in different ways in your drawing. First, you can enter the elevation 
by using a comma separated values. For example, if you enter 100, 500, 1000 these points 
will be included in the point group. Second, you can also use the greater than symbol (>) 
followed by the elevation value to include points whose elevation value is greater than the 
specified value. For example, if you enter >-500, the points having elevation greater than -500 
will be included in the point group. Third, you can use the (<) less than symbol to include 
points having elevation less than the specified elevation. For example, if you enter <1000>, 
all points having elevation less than 1000 will be included in the point group. Fourth, you 
can also use range for specifying the points to be included in the point group. For example, 
100-1000 will include points having elevation varying from 10 to 1000. 

With names matching
Select this check box to include points based on name. Enter point names in the edit box 
next to this check box. The point names should be separated by a comma.

With raw descriptions matching
Select this check box to include points in the point group based on their raw description. 
Enter the comma separated description in the edit box next to the With raw descriptions 
matching check box; for example, GRND, STN, BLDG. The raw descriptions are not 
case-sensitive. You can also use wild cards after the raw description, for example, STN*.

With full description matching
Select this check box to include those points that match with the specified full description 
of points. Enter the required full description in the edit box next to the With full 
description matching check box.

Include all points
Select the Include all points check box to include all the points of the drawing in the point 
group. On selecting this check box, all other options are disabled.
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Exclude Tab
This tab is used to specify the criteria for excluding points from point groups. The options in 
this tab are the same as discussed in the Include tab.

Query Builder Tab
This tab is used to create point groups using a set of query. Query is a set of combined logical 
expressions that use logical operators such as OR, NOT, AND and so on, using the query builder.

Overrides Tab
The Overrides tab is used to display the existing properties of points in a point group and allows 
you to override the properties of points in a point group that is required. Select the check box 
on the left of the property that you want to override. To modify Raw Description, select the 
check box in the Property column. Next, click in the Overrides column and enter a new value 
in the column. Similarly, enter a new value in the Overrides column for the Point Elevation 
property. To override the Point Style or Point Label Style properties, select the corresponding 
check boxes in the Property column and double-click in the Overrides column; the Point Style 
or Point Label Style dialog box will be displayed. Select the required style from the dialog box 
and choose the OK button.

Point List Tab
This tab is used to display the list of all points and their properties in the point group. You 
cannot edit any information in this tab. You can change the sequence of columns by dragging 
column heads to the desired position.

Summary Tab
This tab is used to review information about point group properties and also lists point group 
query. After you have specified the point style, point label style, included the points, and specified 
other properties in the dialog box, choose the OK button; the Point Group Properties - Point 
Group (1) dialog box will be closed and the point group name will be added to the Point Group 
collection in the Prospector tab of the TOOLSPACE palette.

Editing Point Groups
To edit point group properties, right-click on the point group in the Point Group node in the 
Prospector tab and choose the Properties option from the shortcut menu; the Point Group 
Properties - <point group name> dialog box will be displayed. In the Information tab of the 
dialog box, you can modify the point group name, point style, point label style of points included 
in the point group. Choose the Include or Exclude tab from the dialog box to include and exclude 
points. Choose the Apply button to apply the changes and choose OK to close the dialog box.

Tip
You can also open the Point Group Properties - <point group name> dialog box from the 
drawing. To do so, select any point of the point group in the drawing and then right-click to 
display a shortcut menu. Choose the Point Group Properties option from the shortcut menu.

The options discussed earlier for editing points are used to edit points of any point group. 
To access the editing options, expand the Point Groups collection in the Prospector tab and 
right-click on the required point group to display a shortcut menu, as shown in Figure 2-46. 
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You can choose the required options from the shortcut menu and edit the points of the point 
group as discussed earlier. 

Out of Date Points Groups
A point group is called out of date if you add or delete points, or modify properties such as 
elevation or description of points included in the point group. The out of date point groups are 
indicated by a yellow symbol displayed in the Prospector tab on the left of the point group  
name, as shown in Figure 2-45. The Point Group - (1) is out of date as indicated by the 
symbol on the left. This shows that some changes have been made in the point group. 

To view changes made in the point group, choose the Show Point Group Differences button 
in the Point Groups dialog box; the Point Group Changes dialog box will be displayed. This 
dialog box is used to list the changes made in the points of a point group. To update the point 
group, choose the Update Point Group button in the Point Group Changes or the Point 
Groups dialog box; the point group will be updated and the out of date symbol will disappear. 
Alternatively, right-click in the Prospector tab and choose the Show Changes option to view 
the changes made in a point group or choose the Update option to update the point group 
from the shortcut menu. The various editing options in Point Groups are shown in Figure 2-46.

Figure 2-46  The Point Groups editing options 

Figure 2-45  The symbol corresponding to the 
Point Groups indicating the out of date point 
group

Description Keys
This key is used to control the visibility and appearance of points. Unlike point groups, the 
description keys cannot be used for controlling and appearance of the existing points. You can 
use these keys for creating and importing new points in the drawing or converting points in 
the drawing. The point groups are used to control the style and label of all points in a point 
group but the description keys are applied to individual points as an override. On importing 
or creating new points, the points are assigned the styles based on the raw description of points 
matching with the code and format of description keys.
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Creating Description Keys
To create a description key, choose the Settings tab of the TOOLSPACE palette and expand 
the Point node. Next, right-click on Description Key Sets sub-node; a shortcut menu will be 
displayed. Next, choose the New option from the shortcut menu; the Description Key Set - New 
DescKey Set dialog box will be displayed. Enter a description key set name in the Name edit 
box. Optionally, enter a short description about the key set in the Description text box and then 
choose the OK button; the dialog box will be closed and a name for the description key set will 
be added in the Description Key Sets node of the Settings tab. After creating and naming a 
description key set, you will create a description key to the description key set. To do so, expand 
the Description Key Sets node, right-click on New desckey set that you have created and then 
choose Edit Keys from the shortcut menu, as shown in Figure 2-47.

Figure 2-47  Choosing the Edit Keys option

On doing so, the PANORAMA window with the DescKey Editor tab will be displayed, as shown 
in Figure 2-48. In the DescKey Editor PANORAMA window, you will add the raw descriptions 
that will match the description keys. The columns used for creating description keys in the 
DescKey Editor PANORAMA window are discussed next.

Figure 2-48  The PANORAMA window with DescKey Editor tab

Code
This column specifies the raw description of points. A raw description is a code that is used for 
points by a person who has created points from the site or field. To enter a code, double-click 
in the Code field to activate it and enter the required code in the Code column. You can 
also use the wild cards characters within the codes. These characters are used to expand the 
matching capabilities of description keys. Some of the common wild card characters used 
are *(asterisk), # (pound), and so on. For example, the MH raw description for the Manhole 
points can have raw descriptions as MHole, MH-1, MH-2, and so on. Thus, if you want to 
assign the same points style, label style and description to all the manhole points, you can 
use wild card characters with code such as MH*. Adding this wild character (*) means that 
code MH * will match with all raw description that match with MH such as MH-1, MH-2, 
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MHole, and so on. Thus, all manhole points when imported into drawing will be identified 
automatically and assigned the same style and label styles.

You can specify the description in the Code column. Unlike the raw description of points 
in a point group, the description keys to be matched are case sensitive. This means the raw 
description MHole will not match with the description key code, MHOLE. Some of the 
wild cards used are; ? for specifying number, # for single digit, @ for single alphabetical 
character only, . for non- alphanumeric character, [ ] for a list, and so on. Note that wild 
cards characters are always added after the description key code.

Point Style
This column specifies the default point style to be assigned to points matching with 
description key codes. To modify the point style, select the check box in the Point Style 
column field and click on the Point Style field; the Point Style dialog box will be displayed. 
You can use this dialog box to select the required point style or create a new point style using 
the options in the dialog box. 

Point label Style
To specify the required point label style, select the check box in the Point label Style field 
and click in the Point Label Style field; the Point Label Style dialog box will be displayed. 
The Point Label Style dialog box displays the default point label style to be assigned to 
the points matching with the description key code. Select the required point label style or 
create a new point label style using this dialog box.

Format
This column specifies the format used for translating the raw description of points matching 
the description key into full description. As a result, you can make the raw description 
more meaningful and comprehensive. As discussed earlier, raw descriptions refer to the 
point description that is specified by the surveyor on the field and may not give the proper 
description of points. So, to create a full description of points, you can use the Format code 
of description keys. 

The raw description of a point can be translated into full description in three ways. The first 
way is to keep the full description same as that of the raw description. For example, GRND 
is both the full description and raw description of ground points. To do so, enter $* in the 
Format field to accept the raw description as full description.

The second way is to change the raw description into full description. For example, the 
IP raw description will be replaced by Iron Pin. The third way is to change the order and 
adding information or parameters to the full description. For example, a point has a raw 
description TREE OAK 5 in which OAK is a parameter of the raw description. This raw 
description matches with a description key code Tree in the key set. Assume that the format 
for the key is $2”$1tree. Now, this format will help you create a full description in a specified 
order. The full description of the point will be 5”OAK tree.

During the description key match, the raw description TREE OAK 5 will match the 
description key having the code TREE and format code, $2”$1tree. This format code will 
translate the raw description into full description, 5”OAK tree. $2 refers to the second 
parameter in the raw description, 5, whereas $1 refers to the first parameter, OAK. The 
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added information in the format code is ” and tree. Thus, the full description is created 
by replacing the values of $2 to 5” and $1 to OAK to create the 5”OAK tree as the full 
description.

To create new description keys in the description key set, right-click in any of the fields and 
choose New from the shortcut menu; a new key will be added to the Code column of the DescKey 
Editor PANORAMA window, as shown in Figure 2-49. After you have specified the code, point 
style, point label styles, and format, choose the green colored button at top right corner of the 
PANORAMA window to close it. Figure 2-50 shows an example of a description key set having 
different keys.

Figure 2-49  Choosing the New option from the shortcut menu

Figure 2-50  The Desckey Editor tab in the PANORAMA window showing different keys of a 
description key set

Activating the Description Key Matching
To activate the process of description key matching, choose the Settings tab from the 
TOOLSPACE palette and expand the Commands sub-node of the Points node in the Settings 
tab. Next, right-click on Create Points and choose the Edit Command Settings option from 
the shortcut menu; the Edit Command Settings - Create Points dialog box will be displayed. 
Expand the Point Creation category and ensure that the Disable Description Keys property is 
set to False, as shown in Figure 2-51. Choose the OK button to exit the dialog box.

Alternatively, choose the Point Creation Tools option from the Points drop-down in 
Create Ground Data panel from the Home tab; the Create Points toolbar will be displayed. 
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Expand the toolbar and then expand the Points Creation category in it. Next, ensure that the 
Disable Description Keys property is set to False. 

Figure 2-51  The Disable Description Keys property set to False

TUTORIALS
Before starting the tutorial, you need to download and save the tutorial files on your computer. 
To do so, follow the steps given below:

1.   Log on to www.cadcim.com and browse to Textbooks > Civil/GIS > AutoCAD Civil 3D > 
     Exploring AutoCAD Civil 3D 2020. Next, select c02_c3d_2020_tut.zip file from the Tutorial 

Files drop-down list. Choose the corresponding Download button to download the data file.   
    
2.	 Now, save and extract the downloaded folder to the following location: 
       
        C:\c3d_2020

Note
While opening the tutorial file, the PANORAMA window may appear with an error message. 
Close this window to proceed further.
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Tutorial 1						          Creating Points I
In this tutorial, you will create points using various tools that are available in the Create Points 
toolbar, as shown in Figure 2-52.				                       (Expected time: 20 min)

	 The following steps are required to complete this tutorial:

a.	 Open the file.
b.	 Create points using different options in the Points drop-down.
c.	 Save the file.

Figure 2-52  Points created by using various tools in the Create Points toolbar

Opening the File
1. 	 Choose Open > Drawing from the Application Menu; the Select File dialog box is displayed.

2.	 In this dialog box, browse to the location C:\c3d_2020\c02_c3d_2020_tut.

3.	 Select the file c02_c3d_2020_tut01.dwg and then choose the Open button to open the file. 

The opened drawing file consists of an alignment and two lines on both sides.

Creating Points Using the Options in the Alignment Category 
1.	 Choose the Create Points - Alignments option from Home > Create Ground Data > Points 

drop-down; a flyout is displayed.

2.	 Choose the Station/Offset tool from the flyout to create points at some offset distance from 
the stations on an alignment; the Create Points toolbar is displayed and you are prompted 
to select the alignment. 

3.	 Select the Centreline alignment in the drawing; you are prompted to specify the station 
along the baseline.

4.	 As you move the cursor over the alignment, a tooltip showing the first stations is displayed, 
as shown in Figure 2-53. Zoom in to view the alignment and click on 0+00 at the start of 
the alignment. Now you are prompted to specify the offset distance.
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Figure 2-53  A tooltip showing the first station

Tip
You can also create a point at the start of an alignment by specifying 0.00 in the command 
line and then press ENTER.

5.	 Press ENTER to accept the default offset value; you are prompted to enter the point 
description.

6.	 Next, enter CL as the point description in the command line and press ENTER; you are 
prompted to specify elevation.

7.	 Specify the point elevation value as 100 in the command line, and press ENTER; a blue 
colored point is displayed at the first station of the alignment. Also, you are prompted to 
specify another station in the command line. 

8.	 Pan to the next station 30+00 on the alignment and click on it.

9.     Press ENTER to accept the default offset value; you are prompted to specify the description.

10.	 Repeat the procedure followed in steps 6 and 7 and add a new point at station 30+00. On 
creating the point, you are again prompted to specify the next station.

Continue creating points till you reach the other end of the alignment, as shown in Figure 2-54.

11.  Press ESC to terminate the command.

 In this way, you have created points from the alignment.

Tip
In case, the points do not appear in the drawing you can set the point type by entering the 
DDPTYPE command in the commandbar. As a result, the Point Style dialog box is displayed. 
In this dialog box, select the required type of point and then choose the OK button; the points 
are displayed in the drawing. 
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Figure 2-54  Points created at each selected station

Creating Points Using the Options in the Miscellaneous Category 
1.	 Choose the Create Points - Miscellaneous option from Home > Create Ground Data > 

Points drop-down; a flyout is displayed. 

2.	 Choose the Divide Object tool from the flyout; the Create Points toolbar is displayed and 
you are prompted to select an arc, line, polyline, lot line, or feature line.

3.	 Select the line above the alignment; you are prompted to enter the number of segments.

4.	 Enter 12 in the command line and press ENTER; you are prompted to specify the offset.

5.	 Press ENTER to accept the default offset value; you are prompted to specify the point 
description.

6.	 Enter OSP and press ENTER; you are prompted to specify the point elevation.

7.	 Enter 100 and press ENTER; a blue colored point is displayed at the endpoint of the selected 
line; you are prompted to specify the description and elevation.

8.	 Repeat the procedure given in steps 6 and 7 and keep on specifying the point description 
and elevation till you are prompted to select an arc, line, polyline, or feature line.

9.	 Next, select the arc object above the alignment; you are prompted to specify the number 
of segments. Enter 6 in the command line and press ENTER; you are prompted to specify 
the offset.

10.	 Enter 5 as the offset distance in the command line and press ENTER; you are prompted to 
specify the point description.

11.	 Enter OSP in the command line and press ENTER; you are prompted to specify the point 
elevation.

12.	 Enter 100 in the command line and press ENTER; you are prompted to specify the point 
description.
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13. Repeat the procedure given in steps 11 and 12 to create points at an offset along the selected 
arc.

14.	 Press ESC to terminate the command.

Figure 2-55 shows points created from the line and arc objects by dividing these objects into 
specified segments. 

Figure 2-55  Points created from the line and arc objects 

Creating Points Using the Options in the Intersection Category
1.	 Choose the Create Points-Intersections option from Home > Create Ground Data > Points 

drop-down; a flyout is displayed

2.	 Choose the Direction/Perpendicular tool from the flyout; you are prompted to specify the 
start point.

3.	 Click at the start point of the alignment to specify as the first point, refer to Figure 2-56; 
you are prompted to specify the direction.

4.	 Drag the cursor vertically downward and click on the line just below the point on alignment; 
an arrow showing the direction is displayed and you are prompted to specify the offset.

5.	 Press ENTER to accept the default offset value; you are prompted to specify the location 
for the perpendicular point.

6.	 Click on the line object just below the first point on the alignment; a green cross-mark 
indicating the position of the point is displayed on the screen. Also, you are prompted to 
specify the point description.

Note
Ensure that the OSNAP or ORTHO command is activated to specify the perpendicular point.  
You can also use the transparent commands to specify the perpendicular points.

7.	 Enter PP (perpendicular point) and press ENTER; you are prompted to specify the elevation.
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8.	 Enter 100 in the command line and press ENTER; a point is displayed on the line and you 
are prompted again to specify the start point.

9.	 Now, click at the second point on the alignment; you are prompted to specify the direction.

10.	 Again, drag the cursor downward and click on the line just below the selected point; an 
arrow is displayed and you are prompted to specify the offset.

11.	 Press ENTER to accept the default offset distance; you are prompted to specify the location 
of the perpendicular point.

12.	 Click on the line just below the second point; you are prompted to specify the point 
description.

13.	 Specify the description and the elevation as specified in steps 7 and 8; a point is displayed 
on the line, refer to Figure 2-56.

Figure 2-56  Cross-marks indicating the location of the point 

14.	 Using the procedure followed in steps 3 to 8, create points in the perpendicular direction 
of the alignment points.

	
     Figure 2-57 shows the points created at the intersection of the direction specified from  

alignment points and the perpendicular points specified on the line.

Figure 2-57 Points created by intersection
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15.	 Choose the Create Points - Miscellaneous option from Home > Create Ground Data > 
Points drop-down; a flyout is displayed. 

16.	 Choose the Measure Object tool from the flyout; you are prompted to select an arc, line, 
polyline, lot line, or feature line. Select the arc below the alignment; you are prompted to 
specify the starting station.

17.	 Press ENTER to accept the default value <0.000>. On doing so, the ending station is 
displayed in the command line.

18.	 Next, press ENTER; you are prompted to specify the offset distance.

19. 	Again, press ENTER; the default value is accepted as offset and you are prompted to specify 
the interval.

20.	 Enter 1000 in the command line and press ENTER; you are prompted to specify the point 
description.

21.	 Enter OSP in the command line and press ENTER; you are prompted to specify the elevation.

22.	 Enter 100 in the command line and press ENTER; you are again prompted to specify the 
description and elevation.	

23.	 Repeat steps 21 and 22 till you are prompted to select an arc again. Thus, Civil 3D creates 
the point first by measuring the arc object by identifying the start and end stations of the arc 
and then divides the arc at specified intervals. Points are created at the end of each interval 
including the start and end stations of the arc, refer to Figure 2-58.

Figure 2-58  Points created along the arc object below the alignment

  

Saving the File
1.	 Choose Save As from the Application Menu; the Save Drawing As dialog box is displayed. 

2.	 In this dialog box, browse to the following location:

		   C:\c3d_2020\c02_c3d_2020_tut    
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3.	 In the File name edit box, enter c02_tut01.

4.	 Choose the Save button; the file is saved with the name c02_tut01.dwg at the specified 
location.

Tutorial 2					                     Importing Points  
In this tutorial, you will import points into a drawing, create a point group, create a new point 
style, and a point label style for points, as shown in Figure 2-59.         (Expected time: 30 min)

The following steps are required to complete this tutorial:

a.	 Open a new template.
b.	 Import points from the point file.
c.	 Create a point group.
d.	 Create a new point style.
e.	 Create a new label style.
f.	 Assign point style and label style to Point Group.
g.	 Save the drawing.	
	                

Figure 2-59  Points created with a new point style and point label style

Opening the New Template
1.	 Choose New from the Application Menu; the Select template dialog box is displayed.

2.	 Select the _AutoCAD Civil 3D (Imperial) NCS.dwt template file and choose the Open button 
to open the template file.

Importing Points 
1.	 Choose the Point Creation Tools tool from Home > Create Ground Data > Points 

drop-down; the Create Points toolbar is displayed.
 
2.	 Choose the Import Points button from the Create Points toolbar; the Import Points  

dialog box is displayed.

3.	 Select the PENZD (space delimited) option from the Specify point file format (filtering 
OFF) list box. 
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Note
By selecting the PENZD (space delimited) option, the points will be arranged in the order of 
the point number, easting, northing, elevation, and description. The points will be separated by 
a space delimiter.  

4.	 Choose the Add files button on the right of the Selected Files list box; the Select  
Source File dialog box is displayed. Browse to C:\c3d_2020\ c02_c3d_2020_tut location.

5.	 Select the c02_c3d_2020_tut02.txt file and choose the Open button; the dialog box is closed 
and the path of the selected file is displayed in the Import Points dialog box.

6.	 Next, choose the OK button in the Import Points dialog box; the dialog box is closed and 
the points are imported.

7.	 Choose the Prospector tab in the TOOLSPACE

Figure 2-60  The symbol indicating 
points addition

 
palette and notice a black colored symbol on the left 
of the Points node, refer to Figure 2-60. This 
indicates that the points have been added in the 
drawing.

8.	 Enter ZE in the command line and press ENTER; the points are displayed in the drawing. 
Next, close the Create Points toolbar. 

9.	 Expand the Point Groups node. You will notice that all the points are added to the default 
_All Points group.

Creating a Point Group
1.	 Choose the Points tool from the Ground Data panel of the Modify tab; the COGO Point 

tab is displayed in the Ribbon.

2.	 Choose the Edit/List Points tool from the Modify panel of the COGO Point tab; the 
PANORAMA window with the Point Editor tab is displayed. 

3.	 Scroll the bar in the PANORAMA window to view the description of points. On scrolling the 
bar, you will notice that some of the points have GRND as the point description. Now, you 
need to create a new point group that will include all the points with GRND as the description.

4.	 Close the PANORAMA window after viewing the point description of all the points that 
you have imported.

5.	 Now, right-click on Point Groups in the Prospector tab of the TOOLSPACE palette; a 
shortcut menu is displayed. Choose the New option from the shortcut menu; the Point 
Group Properties - Point Group - (1) dialog box is displayed.

6.	 In the Information tab, enter Ground Points in the Name edit box. 

7. 	 Choose the Include tab and then select the With raw descriptions matching check box. 
Enter GRND in the corresponding edit box.
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8.   Next, choose the OK button; the dialog box is closed. All the points with GRND as the raw 
description are added to the Ground Points point group in the Point Groups node.

9.	 Expand the Point Groups node and select the Ground Points point group; all the ground 
points are displayed in the TOOLSPACE list view. 	

Creating a Point Style
1. 	 Choose the Settings tab of the TOOLSPACE 

Figure 2-61  The triangular symbol displayed 
on the left of the Basic point style

palette and expand Point > Point Styles; a 
triangular symbol on the left of the style name is 
displayed, as shown in Figure 2-61. This symbol 
indicates that the style being used is an existing 
style named Basic. 

2.	 Right-click on the Point Styles node and then 
choose the New option from the shortcut menu; 
the Point Style - New Point Style dialog box is 
displayed.

3.	 Accept the default point group name in the Name edit box and choose the Marker tab from 
the dialog box.

4. 	 Ensure that the Use custom marker radio button is selected and then choose the third 
button from the Custom marker style options.

5.	 Select the Use size relative to screen option from the Options drop-down list in the Size 
area.

6.	 Enter 4 in the percent edit box. 

7.	 Now, choose the Display tab and make sure that the Plan option is selected in the 
View Direction drop-down list.

8.	 In the Component display region, click on the color of the Marker component; the Select 
Color dialog box is displayed.

9.	 Select the blue color from the dialog box and choose the OK button to exit the dialog box.

10.	 Now, choose Apply and then OK from the Point Style - New Point Style dialog box; the 
dialog box is closed and the point style name is added to the Point Styles node in the 
Settings tab. 

Creating a Point Label Style
1.	 Choose the Settings tab of the TOOLSPACE palette and expand Point > Label Styles in 

the tab. You will notice that Point#-Elevation-Description is the current point label style.

2.	 Right-click on Label Styles and then choose the New option from the shortcut menu 
displayed; the Label Style Composer - New Point Label Style dialog box is displayed.
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3.	 In the Label Style Composer - New Point Label Style dialog box, accept the default label 
style name displayed in the Name edit box and choose the Layout tab from this dialog box.

4.	 Now, choose the Create Text component button on the right of the Component
name drop-down list; a new component Text.1 is created and added to the 
Component name drop-down list.

5.	 Click in the Value field of the Name property and enter Northing as the name of the 
component. 

6.	 Click in the Value field of the Anchor Component property and select the Point Description 
option from the drop-down list. Note the position of the component in the Preview window.

  
7.	 Similarly, set the value of the Anchor Point property to Bottom Center. Note the position of 

the component.

8.	 Set the values of the X Offset and Y Offset properties in the Text category to 0.1500” 
and -0.0700”, respectively. Again, note the position of the component in the Preview window.

9.	 Now, click in the Value field of the Contents property; a browse button is displayed.

10.	 Choose the browse button; the Text Component Editor - Contents dialog box is displayed.

11.	 In the Text Component Editor - Contents dialog box, select Northing from the Properties 
drop-down list and set the value of the Precision modifier to 0.01.

12.	 Select Label Text in the Text Editor.

13.	 Choose the button next to the Properties drop-down list; the selected property is 
added to the Text Editor window available on the right pane of the Text Component 
Editor - Contents dialog box, refer to Figure 2-62.

Figure 2-62  Partial view of the Text Component Editor - Contents dialog box showing 
the northing label text

14.	 Next, choose the OK button to close the Text Component Editor - Contents dialog box.

15.	 Again, choose the OK button to close the Label Style Composer - New Point Label Style 
dialog box. 
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Assigning Point Style and Point Label Style to the Point Group
1.	 Choose the Prospector tab of the TOOLSPACE palette and expand the Point Groups node.

2.	 Right-click on the Ground Points group; a shortcut menu is displayed. Choose the Properties 
option from the shortcut menu; the Point Group Properties - Ground Points dialog box is 
displayed.

3.	 In the Information tab, select the New Point Style option from the Point style drop-down 
list in the Default styles area, as shown in Figure 2-63.

Figure 2-63  Selecting the New Point Style option from 
the Point style drop-down list

4.	 Choose the Apply button from the Point Group Properties - Ground Points dialog box; you 
will notice that all the ground points are displayed in blue color with the selected marker 
style.

5.	 Similarly, select the New Point Label Style option from the Point label style drop-down 
list.

6.	 Next, choose the OK button; the Point Group Properties - Ground Points dialog box is 
closed. The ground points are displayed with a new point style and label style. Note that the 
point label displays the point number, elevation, description, and northing of each point, 
as shown in Figure 2-64.
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Figure 2-64  Ground points displaying the point number, 
elevation, description, and northing of each point

Saving the File
1.	 Choose Save As from the Application Menu; the Save Drawing As dialog box is displayed. 

2.	 In this dialog box, browse to the following location:

		   C:\c3d_2020\c02_c3d_2020_tut

3.	 In the File name edit box, enter c02_tut02.

4.	 Choose the Save button; the file is saved with the name c02_tut02.dwg at the specified 
location.

Tutorial 3					                Creating Points II
 

In this tutorial, you will verify the drawing settings, create points manually using the coordinate 
data in latitude and longitude format, and create points using the Slope/Grade - Elevation tool, 
refer to Figure 2-65. 					                        (Expected time: 40 min)
                                    
	 The following steps are required to complete this tutorial:

a.	 Open the drawing and specify its drawing settings.
b.	 Create points manually using the coordinate data specified in latitude and longitude.
c.	 Apply point style and label style.
d.	 Create points using the Slope/Grade - Elevation method.
e.	 Save the drawing file.
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Figure 2-65  Points created using the Slope/Grade - Elevation tool

Opening the Drawing File and Specifying its Drawing Settings
In this tutorial, you first need to specify the drawing settings for the project.

1. 	 Choose Open > Drawing from the Application Menu; the Select File dialog box is displayed.

2.	 In this dialog box, browse to the location C:\c3d_2020\c02_c3d_2020_tut.

3.	 Select the file c02_c3d_2020_tut03.dwg and choose the Open button to open the file. 

4. 	 Choose the Settings tab in the TOOLSPACE palette. Right-click on the drawing name 
c02_c3d_2020_tut03 in the TOOLSPACE palette; a shortcut menu is displayed. Choose the 
Edit Drawing Settings option from the shortcut menu; the Drawing Settings - <drawing 
name> dialog box is displayed.

 
5.	 In the Units and Zone tab of the Drawing Settings dialog box, refer to Figure 2-66, ensure 

the settings as follows:

	 Drawing units: Meters
	 Imperial to Metric Conversion: International Foot (1 Foot = 0.3048 Meters)
	 Angular units: Degrees
	 Categories: UTM, NAD83 Datum
	 Available coordinate systems: UTM with NAD83 datum, Zone 11, Meter; Central Meridian 

117d W
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Figure 2-66  The Units and Zone tab of the Drawing Settings dialog box

6.	 In the Ambient Settings tab of the Drawing Settings dialog box, expand the Coordinate 
node. By default, the value for Unit is set to meter. If it is not so, click on the corresponding 
Value cell of the Unit property and choose the meter option from the drop-down list 
displayed.

7.	 Ensure that the value of the Unit property in the Elevation node is set to meter. 

8.	 In the Lat Long node, set the value of Unit and Format as degree and decimal, respectively, 
if they are not so.

9.	 Choose the OK button to save and exit the Drawing Settings dialog box.

Note
If the options in the Drawing Settings dialog box are not configured as mentioned in step 5 to 
8, you need to set the values as specified in these steps.

Creating Points Manually Using Point Coordinates
1.	 Invoke the Create Points toolbar by choosing the Point Creation Tools tool from Home > 

Create Ground Data > Points drop-down. 
 
2.	 Choose the Manual button from the Create Points toolbar; you are prompted to  specify 

a location for the new point. 

3.	 Enter command ‘LL in the command line; the current lat/long unit and input 
format information are displayed and you are prompted to enter the value for latitude.
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Tip
Nested commands is assigning the commands within the command. In this tutorial, nested 
commands are being used widely, so assign the commands carefully.

Note
The points can also be created with the Northing and Easting coordinate values. To create points 
using these values, choose the Manual tool from the Create Points toolbar and then enter ‘NE 
at the Command prompt.

4.	 Specify N33.229010 in the command line and press ENTER; you are prompted to enter 
the value for longitude.

5.	 Specify E-116.758552 in the command line and press ENTER; you are prompted to specify 
the point description.

6.	 Enter a as the point description; you are prompted to specify the point elevation. 

7.	 Enter 849.13 in the command line and press ENTER.

8.	 Create points b, c, d, and e by using the procedure followed in steps 4 to 6 and the data 
given in the following table: 

Point Latitude Longitude Elevation

b N 33.228168 E -116.758706 860.70

c N 33.226149 E -116.757575 875.79

d N 33.224642 E -116.755833 869.28

e N 33.224198 E -116.753949 849.99

Tip
E- or W as prefix in the value of longitude indicates the location of the point to the west of 
prime meridian.

9.   Press ESC twice to exit the Create Points command.

Applying the Point Style and Point Label Style 
1.	 Select the Points node in the Prospector tab of the TOOLSPACE; a list of points in the 

drawing is displayed in the TOOLSPACE item view.

2.	 Right-click the first point in the TOOLSPACE item view; a shortcut menu is displayed. 
Choose the Select option from the shortcut menu; the selected point is displayed with the 
grip editor markers in the drawing area.
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3.	 Keeping the point selected, right-click in the drawing area; a shortcut menu is displayed. 
Choose the Point Group Properties option from the shortcut menu; the Point Group 
Properties- _All Points dialog box is displayed.

4.	 In the Information tab of the dialog box, select the Tutorial3-Point Style option from the 
Point style drop-down list and the Description Only option from the Point label style 
drop-down list.

5.	 Choose OK to apply the selected settings and exit the dialog box. The surface with the 
COGO points is displayed, as shown in Figure 2-67.

	

Figure 2-67  Surface with COGO points

6.	 Hover the mouse over the first COGO point; the information of the point is displayed in 
the tooltip, as shown in Figure 2-68.

Figure 2-68  Information of the COGO point 
displayed in tooltip

Creating Points Using the Slope/Grade - Elevation Tool
1.	 Turn on the Object Snap with the Node option selected. 
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Note
You can toggle the options for snapping in the Object Snap tab of the Drafting Settings dialog 
box. To invoke the dialog box, enter OSNAP in the command bar.

Tip
Final image can vary according to the scale of drawing. 

2.	 Choose the Slope/Grade - Elevation tool from the Slope: High/Low Point drop-down  
in the Create Points toolbar; you are prompted to specify the start point.

3. 	 Select point a; you are prompted to specify a point to define the direction of the intermediate 
points. Select point b; you are prompted to specify slope/grade between points a and b. The 
points created will be along the line joining points a and b.

4.	 Specify -8.13334 as slope in the command line and press ENTER; you are prompted to 
specify the ending elevation. 

	 The slope is negative as the point b (860.70m) is on a higher level than point a (849.13m). 

5.	 Enter 860.70 as the ending station elevation; you are prompted to specify the number of 
intermediate points.

6.	 Enter 2 as the number of intermediate points and press ENTER; you are prompted to specify 
offset.  

7.	 Accept the default value of 0.00; you are prompted to add the end point. 

8.	 Enter NO in the command line; you are prompted to enter point description for the first 
point.

9.	 Specify ab1 as the point description and press ENTER; you are prompted to specify 
description for the point. 

10.	 Enter ab2 as the description of the second point; you are prompted to specify the point for 
defining the direction.

11.	 Use ESC to terminate the create points command.

12.	 Using the procedure followed in steps 2 to 10, create points between points b and c, points 
c and d, and points d and e based on the data given in the following table:

Points between Start point Slope End elevation Point description

bc b -16.48 875.79 bc1, bc2

cd c 27.39 867.28 cd1, cd2

de d 10.57 849.99 de1, de2

Figure 2-69 shows the final result for the points created using the provided data.
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Figure 2-69  COGO points created using the Slope/Grade - Elevation tool

 Saving the File
1.	 Choose Save As from the Application Menu; the Save Drawing As dialog box is displayed. 

2.	 In this dialog box, browse to the following location:

		   C:\c3d_2020\c02_c3d_2020_tut

3.	 In the File name edit box, enter c02_tut03.

4.	 Choose the Save button; the file is saved with the name c02_tut03.dwg at the specified 
location.

Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following tools is used to create points by specifying the distances along the 
X and Y axes of the grid?

		  a) Along Polyline/Contour	 	 b) Direction/Direction	
		  c) On Grid			   	 d) None of these
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2.	 Which of the following properties is used to specify the orientation of the point label?

		  a) Plan Readable	 		  b) Orientation Reference	
		  c) Forced Insertion			   d) None of these

3.	 Which of the following properties is used to specify a reference to position the component 
of the point label?

		  a) Anchor Component	 		  b) Anchor Point	
		  c) Attachment				    d) None of these

4.	 Which of the following categories is used to create points by selecting the point location 
manually in the drawing?

		  a) Create Point - Miscellaneous		 b) Create Point - Intersections	
		  c) Create Point - Alignments	 	 d) None of these

5.	 Which of the following tools is used to create a point at the intersection of two grades or 
slopes?

  
		  a) High/Low Point	 		  b) By Relative Location	
		  c) Slope/Grade Distance	 	 d) Direction/Direction 1.	

6.    Points specify the __________of different features.

7.	 The two main components of a Civil 3D point are __________ and __________.

8.	 The __________ category has the most commonly used options for creating points.
 
9.	 Besides controlling the visibility and display of points, _________ help you manage the 

workability of points.

10.	 Point styles control the shape, size, color, location of the point marker as well as the __________ 
of the point label. 

11.	 To calculate geodetic information, choose the __________ tool from the Analyze panel in 
the COGO Points contextual tab. 

12.	 To import points to AutoCAD Civil 3D, choose the _________ tool from the COGO Point 
Tools panel in the COGO Points contextual tab. 

13.	 Points are the building blocks of all civil engineering projects and designs. (T/F)

14.	 For creating points, you need to invoke the Create Points toolbar from Home > Create 
Ground Data > Points drop-down. (T/F)

15.	 For editing a point in a drawing, you need to invoke the Edit/List Points tool from the 
COGO Points panel in the Modify tab. (T/F)
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Review Questions
Answer the following questions:

1.	 The __________ option is used to create points by using the point data contained in point 
files.

2.	 The __________ dialog box displays various file formats supported by Civil 3D. 

3.	 There are two main types of file formats, __________ and User Point File. 

4.	 The __________ window displays all points in the drawing and is also used to edit them.

5.	 The __________ dialog box is used to export points from AutoCAD Civil 3D.

6.	 The __________ tab is used to specify criteria to include points in a point group based on 
their properties.

7.	 You cannot import points from file. (T/F)

8.	 In Civil 3D, each point is an individual object with different information. (T/F) 

9.	 You cannot convert AutoCAD points into Civil 3D points. (T/F)

10.	 Locking the points prevents you from changing the point style of the points. (T/F)

EXERCISES
Before starting the exercises, you need to download and save the exercise files on your computer. 
To do so, follow the steps given below:

1.   Log on to www.cadcim.com and browse to Textbooks > Civil/GIS > Civil 3D > Exploring 
AutoCAD Civil 3D 2020. Next, select c02_c3d_2020_exer.zip file from the Exercise Files 
drop-down list. Choose the corresponding Download button to download the data file.

2.	 Now, save and extract the downloaded folder to the following location: 

        C:\c3d_2020

Note
While opening the exercise files, the PANORAMA window may appear with an error message. 
Close this window to proceed further.
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Exercise 1 
Open the c02_c3d_2020_ex01.dwg file and create a point style and label style for points. Next, 
assign these styles to points using the following parameters: 	          (Expected time: 30 min)   

Point Style name: New Style
Marker Style: default
Marker Color: blue
Point Label Style Name: New Label Style
Color of all the label components: blue
Save the file as c02_ex01a.dwg.

Exercise 2
Using the c02_ex01a.dwg file, create a point group and edit the points in the point group using 
the Point Editor. Use the following parameters:                                  (Expected time: 30 min)

                        
Point Group Name: Tower points
Raw Description to include Points: Tower
Edit the elevation of the first five points, as shown in Figure 2-70
Save the file as c02_ex02a.dwg.

Figure 2-70  The Point Editor window showing the edited elevations
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Answers to Self-Evaluation Test
1. c, 2. b, 3. a, 4. a, 5. a, 6. location, 7. marker, label, 8. Miscellaneous, 9. point styles, 10. visibility, 
11. Geodetic Calculator, 12. Import Points, 13. T, 14. T, 15. T


