
Chapter 2

Polygon Modeling

 Learning Objectives 
After completing this chapter, you will be able to:
• Create polygon primitives
• Edit polygon primitives
• Modify the components of polygon primitives
• Create models using polygon primitives
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INTRODUCTION
In this chapter, you will learn to create and edit polygon shapes using polygon modeling 
techniques. A polygon is made up of different closed planar shapes having straight sides. The 
most commonly used shapes in 3D polygons are triangles and quadrilaterals. These shapes are 
formed by vertices, edges, and faces. An edge is a straight line formed by joining two vertices. 
In a polygon, three vertices join to each other by three edges to form a triangle and four vertices 
join to each other by four edges to form a quadrilateral. By modifying faces, edges, and vertices 
of an object, you can create a polygon model as per your requirement.

Note
If you want to create polygon objects using click-drag operations, you need to turn on the Interactive 
Creation option available in the menubar. To do so, choose Create > Objects > Polygon 
Primitives > Interactive Creation from the menubar. The Interactive Creation option works 
with all primitives. There are certain parameters that  cannot be controlled via interactive creation. 
These parameters can only be changed from the settings window of the tool. 

This option also affects how Maya shows the tool settings. For example, if the Interactive Creation 
option is selected and you choose Create > Objects > Polygon Primitives > Sphere > Option 
Box from the menubar, the Tool Settings (Polygon Sphere Tool) panel will be displayed. In 
this panel, you can set non-interactive attributes such as Axis divisions and Height divisions 
and then click-drag in the viewport to interactively define the radius of the sphere. If you want to 
create a sphere with the current settings specified in the panel, just click on the viewport instead 
of clicking and dragging. You can reset the settings by choosing the Reset Tool button available 
at the top-right corner of the panel.

If the Interactive Creation option is not selected, the Polygon Sphere Options window will be 
displayed. In this window, specify the attributes and then choose the Create button to create sphere 
with specified settings.

POLYGON PRIMITIVES
In Maya, polygon primitives are classified into various objects. These objects are grouped under 
Polygon Primitives in the menubar. The method of creating different polygon primitives is 
discussed next. 

Creating a Sphere
Menubar: Create > Objects > Polygon Primitives > Sphere   
Shelf:  Polygons > Polygon Sphere 

A sphere is a solid object in which every point on its surface is 

Figure 2-1  A polygon sphere

equidistant from its center, as shown in Figure 2-1. The sphere can 
be created interactively or by entering the values using the 
keyboard. Both the methods are discussed next.

Creating a Sphere Interactively
To create a sphere interactively, first turn on the Interactive 
Creation option and then choose Create > Objects > Polygon 
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Primitives > Sphere from the menubar; you will be prompted to drag the cursor on the grid 
to draw sphere in the viewport. Press and hold the left mouse button, and drag the cursor up or 
down to define the radius of the sphere. Now, release the left mouse button to get the desired 
radius; the sphere will be created and will become visible in the Smooth Shade All mode. 

Note
By default, polygon primitives are displayed in the Smooth Shade All mode. Press 4 to change 
the display to the Wireframe mode.  Alternatively, choose Shading > Wireframe from the Panel 
menu. You can also switch back to the Smooth Shade All mode by pressing 5 or by choosing 
Shading > Smooth Shade All from the Panel menu.

Creating a Sphere by Using the Keyboard
To create a sphere by using the keyboard, choose Create > Objects > Polygon Primitives > 
Sphere > Option Box from the menubar; the Tool Settings (Polygon Sphere Tool) panel will 
be displayed, as shown in Figure 2-2. In this panel, set the properties of the sphere using the 
keyboard and then click in the viewport; a sphere will be created. Choose Reset Tool at the top 
of the Tool Settings (Polygon Sphere Tool) panel to reset the default values of the sphere. It is 
recommended that you reset the values while creating a new polygon primitive.  

Figure 2-2  The Tool Settings (Polygon Sphere Tool) panel

Modifying the Name and other Parameters of a Sphere
You can modify the name and other parameters of a sphere. To do so, select the sphere; the 
Channel Box / Layer Editor is displayed on the right of the viewport, refer to Figure 2-3. If the 
Attribute Editor is displayed on the right of the viewport, press Ctrl+A to switch to the Channel 
Box / Layer Editor. Now, click on the pSphere1 label in the Channel Box / Layer Editor; the 
pSphere1 label is converted into an edit box. Next, enter the desired name in the edit box and 
press ENTER. To modify the properties of the sphere, expand the polySphere1 node in the 
INPUTS area; various options will be displayed. Enter the required values in the edit boxes; 
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the changes will be dynamically reflected on the sphere in the viewport. Alternatively, select the 
label of the parameter of the sphere that you want to change; the

Figure 2-3  The Channel 
Box / Layer Editor

 
corresponding label of the parameter will be highlighted in the 
Channel Box / Layer Editor. Now, press and hold the middle mouse 
button and drag the cursor horizontally in the viewport to change 
that particular value of the corresponding parameter. 

Creating a Cube
Menubar: Create > Objects > Polygon Primitives > Cube
Shelf:  Poly Modeling > Polygon Cube 

A cube is a three-dimensional shape with six sides or rectangular faces, 
as shown in Figure 2-4. To create a cube interactively, choose 
Create > Objects > Polygon Primitives > Cube from the menubar; 
you will be prompted to drag the cursor on the grid to draw the 
cube in the viewport. 

Press and hold the left mouse button, and drag the cursor on the 
grid to define the base of the cube. Next, release the left mouse 
button to get the desired base. Now, press and hold the left mouse 
button again and drag the cursor up to set the height of the cube 
and then release the left mouse button; the cube will be created.

Figure 2-4  A polygon cube

Creating a Prism
Menubar: Create > Objects > Polygon  
  Primitives > Prism

A prism is a polyhedron that has two polygonal faces lying in parallel 
planes as bases and the other faces as parallelograms, as shown in

Figure 2-5  A polygon prism

Figure 2-5. To create a prism interactively, choose Create > 
Objects > Polygon Primitives > Prism from the menubar; you 
will be prompted to drag the cursor on the grid to draw the prism 
in the viewport. Press and hold the left mouse button and drag the 
cursor; the base of the prism is created. Now, release the left mouse 
button to get the desired base. Again, press and hold the left mouse 
button and drag the cursor up to set the height of the prism. Next, 
release the left mouse button; the polygon prism will be created.

Creating a Pyramid
Menubar: Create > Objects > Polygon Primitives > Pyramid
Shelf:        Poly Modeling > Polygon Pyramid 

A pyramid is a geometric shape with a polygonal base and a point called

Figure 2-6  A polygon 
pyramid

 
apex. The base and the apex are connected through triangular faces, as 
shown in Figure 2-6. To  create  a  pyramid  interactively,  choose  Create  > 
Objects > Polygon Primitives > Pyramid from the menubar; you will 
be prompted to drag the cursor on the grid to draw the pyramid in the 
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viewport. Press and hold the left mouse button, and drag the cursor up or down to define the 
shape of the pyramid, and then release the left mouse button; the pyramid will be created. 

Creating a Pipe
Menubar: Create > Objects > Polygon Primitives > Pipe
 

Figure 2-7  A polygon pipe

A pipe is similar to a cylinder polygonal shape with thickness, as  
shown in Figure 2-7. To create a pipe interactively, choose Create > 
Objects > Polygon Primitives > Pipe from the menubar; you will 
be prompted to drag the cursor on the grid to draw the pipe in 
the viewport. Press and hold the left mouse button and drag the 
cursor; the base of the pipe is created. Next, release the left mouse button to get the desired 
base. Now, press and hold the left mouse button and drag the cursor up to set the height of the 
pipe. Next, release the left mouse button. Again, press and hold the left mouse button to set 
the thickness of the polygon pipe; a polygon pipe will be created. 

Creating a Helix
Menubar: Create > Objects > Helix

A helix is a geometry in three dimensional space that lies on a

Figure 2-8  A polygon helix

 
cylinder and subtends a constant angle to a plane perpendicular 
to its axis, as shown in Figure 2-8. To create a helix interactively, 
choose Create > Objects > Polygon Primitives > Helix from 
the menubar; you will be prompted to drag the cursor on the 
grid. Press and hold the left mouse button and drag the cursor 
on the grid to define the diameter of the helix and then release 
the left mouse button. Again, press and hold the left mouse button 
and drag the cursor up to set the height of the helix, and then 
release the left mouse button. Next, press and hold the left mouse 
button and drag the cursor to set the number of coils in the 
helix and then release the left mouse button. Again, press and hold the left mouse button and 
drag the cursor to set the section radius; the helix will be created.

Creating a Soccer Ball
Menubar: Create > Objects >  Polygon Primitives >  
  Soccer ball 

A soccer ball polygon primitive created in Maya is very much similar 

Figure 2-9  A soccer ball

to a real-world soccer ball, as shown in Figure 2-9. A soccer ball is 
formed by an alternate arrangement of hexagons and pentagons. 
It has total thirty two faces. To create a soccer ball interactively, 
choose Create > Objects > Polygon Primitives > Soccer Ball 
from the menubar; you will be prompted to drag the cursor on 
the grid to draw the soccer ball in the viewport. Press and hold 
the left mouse button and drag the cursor on the grid; the soccer ball will be created. 
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Creating a Platonic Solid                         
Menubar: Create > Objects > Polygon   
  Primitives > Platonic Solid

In Maya, you can create various types of platonic solids such as 

Figure 2-10  A platonic solid

tetrahedron, octahedron, dodecahedron, and icosehedron. 
Platonic solids have identical faces and their all sides are equal, 
refer to Figure 2-10. To create a platonic solid, choose Create > 
Objects > Polygon Primitives > Platonic Solid from the 
menubar; a platonic solid will be created in the viewport. To change 
the solid type, expand the INPUTS > polyPlatonic# area in the 
Channel Box / Layer Editor and then select the desired option 
using the Primitive attribute.

Creating a Type Tool Mesh      
Menubar: Create > Objects > Type
Shelf:       Poly Modeling > Polygon Type

The Polygon Type tool is used to create polygon 3D text in the viewport. To create 3D text, 
choose Create > Type from the menubar; the text 3D Type will be displayed in the viewport, 
as shown in Figure 2-11. 

To change the appearance of the text, choose the type1 tab in the Attribute Editor, refer to 
Figure 2-12. Using the options in this tab, you can change text, font, font size, and so on. You 
can apply various operations, such as Extrude and Bevel, on the text using the typeExtrude1 
tab of the Attribute Editor. 

Figure 2-12  The type1 tab in Attribute EditorFigure 2-11  The text 3D Type displayed
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Creating an SVG Mesh                                                    
Menubar:       Create > Objects > SVG
Shelf:  Poly Modeling > SVG

This tool is used to create polygon text from an SVG file. To create an SVG mesh, make sure 
you have an SVG file or SVG content copied to the clipboard. Choose Create > SVG from the 
menubar; the default SVG mesh with the name svg1 is displayed in the viewport, as shown in 
Figure 2-13. Now, in the svg1 tab of the Attribute Editor, choose the Import button; the Open 
dialog box will be displayed. Navigate to the location where you saved the SVG file, select it, 
and then choose the Open button; the SVG mesh will be displayed in the viewport, refer to 
Figure 2-14. 

Figure 2-13  The default SVG mesh displayed Figure 2-14  The SVG mesh displayed

Now, you can manipulate the shape as per the paths of the embedded SVG file. For example, if 
you want to offset the meshes, select the desired path from the Path list of the Manipulations 
area and then use the Position Z Offset attribute to offset the mesh, refer to Figure 2-15. 
Figure 2-16 shows the arrow shaped SVG file used in the example.

Figure 2-15  The separated SVG mesh Figure 2-16  The arrow shaped SVG file

Creating a Disc          
Menubar: Create > Objects > Polygon Primitives > Disc
Shelf:        Poly Modeling > Polygon Disc 

                      

The Disc tool is used to create a circular disc with varying edge patterns. To create a disc, choose 
Create > Objects > Polygon Primitives > Disc from the menubar; a disc will be created in the 
viewport. To change the edge pattern, expand the INPUTS > polyDisc# area in the Channel 
Box / Layer Editor and then select the desired option using the Subdivision Mode attribute. 
Figure 2-17 shows geometries created using the Disc tool.
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Figure 2-17  The objects created using the Disc tool

Creating a Gear          
Menubar: Create > Objects > Polygon Primitives > Gear

                      

The Gear tool is used to create gear shaped geometries by generating teeth patterns around the 
pipe shape. To create a gear, choose, Create > Objects > Polygon Primitives > Gear from the 
menubar; a gear will be created in the viewport. To change the settings, expand the INPUTS > 
polyGear# area in the Channel Box / Layer Editor and then change the value of the attributes. 
Figure 2-18 shows the geometries created using the Gear tool.

Figure 2-18  The objects created using the Gear tool

Creating Super Shapes         
Menubar: Create > Objects > Polygon Primitives > Super    
             Shapes > Super Ellipse / Spherical Harmonics / Ultra Shape

                      

The tools under the super shape category in the Polygon Primitives menu are used to create 
complex shapes. These shapes are highly complex in nature and use complex algorithm. To 
create an ultra shape, choose Create > Objects > Polygon Primitives > Super Shapes >  Super 
Ellipse/Spherical Harmonics/Ultra Shape from the menubar; a basic shape with default values 
will be created in the viewport. 

Once you create the shape, polySuperShape# node will be displayed in the Attribute Editor. 
To change the algorithm of the basic shape, select Spherical Harmonics, Super Ellipse, or 
Ultra from the Shape drop-down list in the Poly Super Shape History area. Now, you can use 



Polygon Modeling        2-9

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

the Random button available in the Poly Super Shape History area to create different shapes. 
Figure 2-19 shows the shapes created using the Spherical Harmonics, Super Ellipse, or Ultra 
option, respectively.

Figure 2-19  Some super shapes created

POLYGON EDITING TOOLS
In Maya 2020, the tools are grouped according to the function

Figure 2-20  The Mesh menu

 
they perform. For example, the Boolean, Combine, and Separate 
tools are combined in the Combine group, refer to Figure 2-20. 
The polygon editing tools are used to perform different 
operations on the polygon objects. These editing tools are 
available in the Mesh, Edit Mesh, and Mesh Tools menus of the 
Modeling menu set. Figure 2-20 displays different tools in the 
Mesh menu. The most commonly used tools under this menu 
are discussed next. 

Booleans
Menubar: Mesh > Combine > Booleans

The booleans tools are used to combine the polygon objects to 
create a new object. Using these tools, you can perform three 
different operations to modify the shape of the new object. The 
booleans tools are shown in Figure 2-21. The three options of 
this tool are discussed next.

Figure 2-21  The Booleans tools
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Union
Menubar: Mesh > Combine > Booleans > Union

The Union tool is used to combine the volume of two polygon meshes. To understand the 
function of this tool, consider a sphere and a torus placed in the viewport, as shown in Figure 2-22. 
Using the SHIFT key, select the torus and then the sphere. Next, choose Mesh > Combine > 
Booleans > Union from the menubar; both the objects will get merged and the intersecting 
geometry between them will be deleted, refer to Figure 2-23.

 
Difference

Menubar: Mesh > Combine > Booleans > Difference

The Difference tool is used to subtract the last selected geometry from the geometry that was 
selected first. To understand the function of this tool, consider a sphere and a torus placed in 
the viewport, refer to Figure 2-22. Using the SHIFT key, select the torus and then the sphere. 
Next, choose Mesh > Combine > Booleans > Difference from the menubar; the geometry 
will be deleted, as shown in Figure 2-24.

Figure 2-22  A torus and a sphere placed in the viewports

Figure 2-23  The Union operation 
carried out on the torus and the sphere

Figure 2-24  The Difference operation 
carried out on the torus and the sphere
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Intersection
Menubar: Mesh > Combine > Booleans > Intersection

The Intersection tool is used to keep the intersecting

Figure 2-25  The Intersection operation 
carried out on the torus and the sphere

 
geometry between two objects and delete the remaining 
geometry. To understand the function of this tool, 
consider a sphere and a torus placed in the viewport, 
refer to Figure 2-22. 

Using the SHIFT key, select the torus and the sphere. Next, 
choose Mesh > Combine > Booleans > Intersection 
from the menubar; the intersecting geometry will be 
displayed and the remaining parts will be deleted, as 
shown in Figure 2-25.

Note
When you choose any boolean operation, the polyCBoolOp# In-View Editor will be displayed 
in the viewport. You can change any applied operation by choosing an option from the Operation 
flyout.  

Combine
Menubar: Mesh > Combine > Combine

The Combine tool is used to group two or more polygon objects into a single polygon object. 
To do so, select the polygon objects to be combined in the viewport and then choose Mesh > 
Combine > Combine from the menubar; the selected polygon objects are combined into a 
single polygon object.

Separate 
Menubar: Mesh > Combine > Separate

The Separate tool is used to ungroup the combined

Figure 2-26  The selected face separated 
from the polygon object

 
polygon objects into separate polygon objects. To do 
so, select the group in the viewport and then choose 
Mesh > Combine > Separate from the menubar; the 
selected group of polygon objects are separated, refer 
to Figure 2-26.

Conform
Menubar: Mesh > Remesh > Conform

The Conform tool is used to wrap the vertices of an object onto the surface of another object. 
To understand the function of this tool, you need at least two wrap polygon objects, refer to 
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Figure 2-27. Next, select the object on which you want to wrap the vertices and then choose 
Modify > Objects > Make Live from the menubar to make the selected object live. Now, 
select the geometry that you want to wrap and then choose Mesh > Remesh > Conform from 
the menubar; the wrapper mesh will automatically wrap around the target geometry, refer to 
Figure 2-28.

Figure 2-27  The polygon objects Figure 2-28  The plane wrapped onto the 
polygon sphere

Fill Hole
Menubar: Mesh > Remesh > Fill Hole

The Fill Hole tool is used to fill a hole in an object by adding a face to it. To understand the 
function of this tool, press and hold the right mouse button over an object with a hole; a marking 
menu will be displayed. Next, choose Edge from the marking menu. Now, select the boundary 
edges, refer to Figure 2-29. Next, choose Mesh > Remesh > Fill Hole from the menubar; the 
empty space will be filled, as shown in Figure 2-30. 

Figure 2-29  Edges of the deleted face selected Figure 2-30  Filled hole of the cube

 Tip 
1.  You can use the shortcut keys for displaying or activating various components of an object. 
For example, press F8 for object mode, F9 for vertices, F10 for edges, and F11 for faces. 

2.  To select four surrounding edges of a deleted face, choose one of the edges and then press 
the right arrow key on your keyboard; all the four edges will be selected.
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Reduce
Menubar: Mesh > Remesh > Reduce  

The Reduce tool is particularly useful in reducing the number of polygons in a particular area 
of the mesh. You can also use the UVs or vertex colors to select an area on the mesh. To reduce 
polygons, select an area and then choose Mesh > Remesh > Reduce from the menubar; the 
polyReduce1 In-View Editor will be displayed in the viewport. Enter the value in the Percentage 
edit box. You can change reduction method by clicking on the Reduction Method attribute. 
The other two methods are Vertex Count and Triangle Count.  

Remesh                        
Menubar: Mesh > Remesh > Remesh                                        

The Remesh tool is used to create a uniformly tessellate triangular mesh or add details to specific 
regions of the mesh surface. To do so, create a polygonal object in the viewport, as shown in 
Figure 2-31 and then choose Mesh > Remesh > Remesh from the menubar; the polyRemesh1 
In-View Editor will be displayed in the viewport and triangulated mesh is displayed in the polygon 
object, as shown in Figure 2-32.

Figure 2-31  The polygon object Figure 2-32  Triangulated mesh of a polygon object

Retopologize                                                                   
Menubar: Mesh > Remesh > Retopologize  

The Retopologize tool is used to generate smooth surface features of a selected mesh while 
ensuring all the faces are quads. To do so, create a polygonal object in the viewport, as shown in 
Figure 2-33 and then choose Mesh > Remesh > Retopologize from the menubar; the polygonal
object is smoothened and quad surfaces are created, as shown in Figure 2-34.

Smooth
Menubar: Mesh > Remesh > Smooth

The Smooth tool is used to make a polygon object smooth by adding divisions to it. To do so, 
create a polygonal object in the viewport and then choose Mesh > Remesh > Smooth from the 
menubar; the polySmoothFace1 In-View Editor will be displayed in the viewport. Set the desired 
smoothing level by entering a value in the Divisions edit box. The default subdivision level is 1.  
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Figure 2-33  The polygon object Figure 2-34  The smooth polygon object

Triangulate
Menubar: Mesh > Remesh > Triangulate

The Triangulate tool is used to convert polygon faces into triangles.

Quadrangulate
Menubar: Mesh > Remesh > Quadrangulate

The Quadrangulate tool is used to convert the polygon faces into quadrangles.

Mirror                                                                              
Menubar: Mesh > Mirror > Mirror

The Mirror tool is used to create duplicate of a selected object across an invisible mirror plane. 
To create a mirror object, select the object that you want to mirror and then choose Mesh > 
Mirror > Mirror from the menubar; the polyMirror1 In-View Editor will be displayed in the 
viewport. Select the desired mirror axis using the Axis attribute. Now, use the Offset attribute 
to adjust the spacing between the objects.

EDITING THE POLYGON COMPONENTS
In the previous section, you learned to modify simple polygon primitives. In this section, you 
will learn to edit the components of polygon primitives to create complex objects from it. To 
do so, select a polygon object in the viewport and then press and hold the right mouse button 
over it; the marking menu of the corresponding object will display various components of the 
object such as vertex, edge, face, and UV, refer to Figures 2-35 to 2-38. To access various tools 
for editing the polygon primitives, select Modeling from the Menuset drop-down list in Status 
Line. Next, choose the Edit Mesh menu from the menubar. The most commonly used component 
editing tools are discussed next.
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Figure 2-36  Edges of the sphereFigure 2-35  Vertices of the sphere

Figure 2-38  UVs of the sphereFigure 2-37  Faces of the sphere

Note
1. The face selection mode in the marking menu allows you to select the faces of the active object. 
When you move the cursor on a face, the face will be highlighted in red. Next, when you click 
on the highlighted face, it will turn green indicating that it is now selected. In this way, you can 
identify the selected and unselected faces.

2. The Multi option allows you to select all components at a time without switching between the 
components. To select all components, press and hold the right mouse button on the already selected 
component, and then choose the Multi option from the marking menu. Next, select a face on the 
object, press and hold the SHIFT key, and then select the next required component.

Add Divisions
Menubar: Edit Mesh > Components > Add                                      
                        Divisions

     

The Add Divisions tool is used to subdivide the edges or faces of a polygon object to smaller 
components. To add divisions, select the edges or faces that you want to divide and then choose 
Edit Mesh > Components > Add Divisions > Option Box from the menubar; the Add Divisions 
to Face Options panel will be displayed. 

Set the required attributes in this panel and then choose the Add Divisions button to subdivide 
the selected area. You can also change the number of divisions by using the Divisions attribute 
in the polySubFace1 In-View Editor.   
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Bevel
Menubar: Edit Mesh > Components > Bevel

The Bevel tool is used to expand the vertex or the face of a polygon object. This adds smoothness 
to a sharp object by adding fillets on the edges. The bevel operation adds fillet to the edges 
by creating new faces on the selected polygon object. To do so, create a polygon object in the 
viewport and select it. Next, choose Edit Mesh > Components > Bevel from the menubar; the 
selected polygon object will be beveled, as shown in Figure 2-39. The Bevel tool is also used to 
bevel the components such as face, vertex, and edge of a polygon object individually. Create a 
polygon object in the viewport and right-click on it; the marking menu will be displayed. Next, 
choose Edge from the marking menu; the edge selection mode will be activated. Now, select 
any edge of the object and then choose Edit Mesh > Components > Bevel from the menubar; 
the selected edge will be beveled, refer to Figure 2-40. 

Figure 2-39  Selected polygon object beveled Figure 2-40  Selected edge beveled

To adjust the bevel parameters, select the object in

Figure 2-41  Various bevel attributes in the 
Attribute Editor

 
the viewport; the Channel Box / Layer Editor is 
displayed on the right of the viewport. Next, expand 
polyBevel1 in the INPUTS area of the Channel 
Box / Layer Editor and then set the bevel parameters; 
the changes will be reflected on the selected object in 
the viewport.  

You can also change the bevel parameters from 
the Attribute Editor. Press CTRL+A to open the 
Attribute Editor and then choose the polyBevel1 tab 
from the Attribute Editor; the bevel parameters will 
be displayed in the Attribute Editor, as shown 
in Figure 2-41. Set the parameters as per your 
requirement.

Bridge
The Bridge tool is used to construct faces between 
pair of the border edges. The connection between 
the edges or faces can be straight or curved, depending on the options you choose from the 
Bridge Options window.
 
To create a bridge between the border edges of an object, select the edges and then choose Edit 
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Mesh > Components > Bridge > Option Box from the menubar; the Bridge Options window 
will be displayed. In this window, choose the type of bridge you want to create by selecting the 
radio button corresponding to the Bridge type attribute and then choose the Bridge or Apply 
button; a bridge will be created, as shown in Figure 2-42.

Figure 2-42  The Bridge connection between the two edges

Note
To create a bridge between two separate objects, you need to combine the two objects by choosing 
Mesh > Combine > Combine from the menubar.

Circularize                           
Menubar: Edit Mesh > Components >  Circularize                           

The Circularize tool allows you to organize the vertices of a selected component into a circular 
shape. To understand working of this tool, consider a polygon plane object with Subdivision 
Width and Subdivision Height set to 10 each. Switch to the Vertex selection mode and then 
select some vertices, refer to the Figure 2-43(a). Now, choose Edit Mesh > Components > 
Circularize from the menubar; the selected vertices will be arranged in a circular shape and 
the polyCircularize1 In-View Editor will be displayed, refer to Figure 2-43(b). You can add 
divisions to the selection by using the Add Divisions attribute of the In-View Editor to make a 
perfect round shape.

Figure 2-43(b)  A circular shape created using 
the Circularize command

Figure 2-43(a)  Selected vertices
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Collapse
Menubar: Edit Mesh > Components > Collapse

The Collapse tool is used to collapse edges and then it merges the associated vertices for each 
collapsed edge separately. To collapse the edges of an object, select the required edges and then 
choose Edit Mesh > Components > Collapse from the menubar; the selected edges will be 
collapsed and their vertices will be merged.

Note
This tool also works on faces. But it generates unpredictable results. If  you want to merge the faces, 
use the Merge to Center option which is available in the Edit Mesh menu.

Connect              
Menubar: Edit Mesh > Components > Connect

The Connect tool is used to connect selected vertices or faces via edges. To use this tool, select 
faces or edges on an object and then choose Edit Mesh > Components > Connect from the 
menu bar to connect the selected component, refer to Figure 2-44.

Figure 2-44  The connected edge displayed

Detach
Menubar: Edit Mesh > Components > Detach

The Detach tool is used to split a vertex into multiple

Figure 2-45  Selected vertex gets split into 
multiple vertices

 
vertices. To understand working of this tool, consider 
a polygon object in the viewport and press and hold the 
right mouse button over it; a marking menu will be 
displayed. Choose Vertex from the marking menu; the 
vertex selection mode will be activated. Select a vertex 
of the object that needs to be split. Next, choose 
Edit Mesh > Components > Detach from the menubar; 
the selected vertex gets split into multiple vertices, refer 
to Figure 2-45. This tool also detaches the faces. When 
faces of an object are selected and you use this tool, it 
detaches the face selection along its perimeter edges.
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Extrude
Menubar: Edit Mesh > Components > Extrude

The Extrude tool is used to extrude various components such as vertex, face, or an edge of a 
polygon object inward or outward. To extrude a vertex, select the vertex that needs to be extruded. 
Next, choose Edit Mesh > Components > Extrude from the menubar; the selected vertex will 
be extruded and the polyExtendedVertex# In-View Editor will be displayed. You can change 
the width, length, and, division of the extruded vertex by entering the values in the Width, 
Length, and Divisions edit boxes, as shown in Figure 2-46. To extrude an edge, select it and 
then choose Edit Mesh > Components > Extrude from the menubar; the polyExtendedEdge# 
In-View Editor will be displayed. Enter the desired value in the Thickness edit box of the 
polyExtendedEdge# In-View Editor, refer to Figure 2-47. If the value in the edit box is negative, 
the face will be extruded inward and for a positive value, it will be extruded outward.

Figure 2-46  The extruded vertex Figure 2-47  The polyExtrudedEdge# 
In-View Editor

To extrude a face, select it and then choose Edit Mesh > Components > Extrude from the 
menubar; the polyExtrudeFace# In-View Editor will be displayed. Enter the desired value in 
the Thickness edit box of the polyExtrudeFace# In-View Editor. If the value in the edit box is 
negative, the face will be extruded inward and for a positive value, it will be extruded outward, 
as shown in Figure 2-48.

Merge
Menubar: Edit Mesh > Components > Merge

The Merge tool is used to merge two vertices. To merge two vertices, select a object in the 
viewport and press and hold the right mouse button over it; a marking menu will be displayed. 
Choose Vertex from the marking menu; the vertex selection mode will be activated. Now, select 
four vertices of top polygon and then choose Edit Mesh > Components > Merge > Option 
Box from the menubar; the Merge Vertices Options window will be activated. Set the value for 
the Threshold attribute and then choose Merge from the window; the selected vertices will be 
merged, refer to Figure 2-49. 
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Figure 2-48  The extruded face Figure 2-49  Top vertices to be merged

You can also use the Merge to Center tool for merging the selected vertices. To do so, choose 
Edit Mesh > Components > Merge to Center; the vertices will be merged to the center of the 
two vertices, refer to Figure 2-50.

Figure 2-50  Center vertices to be merged

Average Vertices
Menubar: Edit Mesh > Vertex > Average Vertices

The Average Vertices tool is used to control the level of smoothing applied to the selection, 
refer to Figure 2-51. You can set the amount of smoothing in the Iternation edit box of the 
polyAverageVertex1 In-View Editor.

Figure 2-51  Smoothing applied to the selection
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Chamfer Vertices
Menubar: Edit Mesh > Vertex > Chamfer Vertices

The Chamfer Vertices tool is used to replace a vertex to

Figure 2-52  A new polygon face created 
using the Chamfer Vertices tool

 
create a chamfered corner. To use this tool, consider a 
polygon object in the viewport and press and hold the right 
mouse button over it; a marking menu will be displayed. 

Choose Vertex from the marking menu; the vertex selection 
mode will be activated. Select a vertex (or vertices) of the 
object. Next, choose Edit Mesh > Vertex > Chamfer 
Vertices from the menubar; a new polygon face will be 
created, refer to Figure 2-52.

Delete Edge/Vertex
Menubar: Edit Mesh > Edge > Delete Edge/Vertex

The Delete Edge/Vertex tool is used to delete the selected edges or vertices of a polygon object. 
To do so, select vertices of an object that you want to delete and then choose Edit Mesh > Edge > 
Delete Edge/Vertex from the menubar; the selected vertices will be deleted. Similarly, using the 
Delete Edge/Vertex tool, you can delete the selected edges of the polygon object.

Tip
You can also delete the selection using the DEL key. However, you cannot delete a vertex 
when it shares more than two edges. 

Edit Edge Flow
Menubar: Edit Mesh > Edge > Edit Edge Flow

The Edit Edge Flow tool is used to modify the position of edges along the curve of the surrounding 
mesh. To do so, select the two non-adjacent edges of an object and choose Edit Mesh > Edge > 
Edit Edge Flow from the menubar; the edges move along the curvature of the object.  

Duplicate
Menubar: Edit Mesh > Face > Duplicate

The Duplicate tool is used to create the duplicate copies of the selected faces. To use this tool, 
consider a cube in the viewport. Select the polygon cube created and then press and hold the 
right mouse button on it; a marking menu will be displayed. Next, choose Face from the marking 
menu; the face selection mode will be activated. Choose Move Tool from the Tool Box. Next, 
select a face on the polygon cube and choose Edit Mesh > Face > Duplicate from the menubar; 
a duplicate copy of the selected face will be created in the viewport. Now, to see the duplicate 
face, move it away from the centre using the Move Tool.
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EDITING THE POLYGON COMPONENTS USING 
MESH TOOLS
In the previous section, you learned to modify simple polygon primitives. In this section, you will 
learn to edit the polygon objects using the polygon components such as face, vertex, and edge. 
To access various tools for editing the polygon components, select Modeling from the Menuset 
drop-down list in the Status Line. Next, choose the Mesh Tools menu from the menubar. The 
most commonly used tools under this menu are discussed next.

Create Polygon
Menubar: Mesh Tools > Tools > Create Polygon

The Create Polygon tool is used to create polygons by placing vertices in the viewport. To do 
so, choose Mesh Tools > Tools > Create Polygon tool from the menubar. Next, click in the 
viewport; a vertex point will be created in the viewport. 

Next, depending on the shape required, keep on clicking in the viewport to connect the points 
and then press ENTER; a shape will be created, refer to Figure 2-53. 

Figure 2-53  A shape created using the 
Create Polygon tool

Insert Edge Loop
Menubar: Mesh Tools > Tools > Insert Edge Loop

The Insert Edge Loop tool is used to add segments to the selected object. The segment created 
by using this tool ends at the same point from where it starts, thus forming a loop. To use this 
tool, consider a polygon object in the viewport and choose Mesh Tools > Tools > Insert Edge 
Loop tool from the menubar; the edges of the object will turn blue. Next, click on an edge; a 
new segment will be created on the selected object, as shown in Figure 2-54. Note that the Insert 
Edge Loop tool works only with objects that have quads (quads are faces with four sides). If the 
sides of a face are more or less than four, then this tool will not work. To set the properties of 
this tool, choose Mesh Tools > Tools > Insert Edge Loop > Option Box from the menubar; 
the Tool Settings (Insert Edge Loop tool) panel will be displayed, refer to Figure 2-55.
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Figure 2-54  A new segment created 
using the Insert Edge Loop

Figure 2-55  The Tool Settings (Insert 
Edge Loop tool) panel

Multi-Cut                                                               
Menubar: Mesh Tools > Tools > Multi-Cut

The Multi-Cut tool is used to manually add segments between two edges of an object. To add 
segments between two edges, select the polygon object and then choose Mesh Tools > Tools > 
Multi-Cut from the menubar. 

Click on the edge to choose the starting point of the

Figure 2-56  Segments added using the 
Multi-Cut tool

 
segment. Next, click on the edge where you want to end 
the segment and press ENTER; a segment will be added 
between the two edges, refer to Figure 2-56.

You can also make a cut in loop by using the Multi-Cut 
tool. To do so, choose the Multi-Cut tool from the Mesh 
Tools menubar, press the CTRL key and then click on 
edge; a new segment will be created on the selected object.

Offset Edge Loop
Menubar: Mesh Tools > Tools > Offset Edge Loop

The Offset Edge Loop tool works similar to the Insert

Figure 2-57  New segments created using 
the Offset Edge Loop tool

 
Edge Loop tool with the only difference that it creates 
segments on both sides of the selected edges. 

To use this tool, create a polygon object in the viewport 
and choose Mesh Tools > Tools > Offset Edge Loop 
tool from the menubar. Next, click and drag the cursor 
to the already existing edges to create new segments 
on both sides of the selected object, as shown in 
Figure 2-57.
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TUTORIALS
 Tutorial 1                                                                                     
In this tutorial, you will create model of a coffee mug shown in Figure 2-58 using the polygon 
modeling techniques.                                                                            (Expected time: 20 min)

Figure 2-58  The model of a coffee mug

The following steps are required to complete this tutorial:

a. Create a project folder.                         
b. Create the basic shape of the mug.
c. Create the handle of the mug.
d. Change the background color of the scene.
e. Save and render the scene.

Creating a Project Folder
Before starting a new scene, it is recommended that you create a project folder. It helps you 
keep all the files of a project in an organized manner. Open Windows Explorer and browse to 
the Documents folder. In this folder, create a new folder with the name maya2020. The maya2020 
folder will be the main folder and it will contain all the projects folders that you will create 
while doing tutorials of this textbook. Now, you will create a project folder for Tutorial 1 of this 
chapter. To do so, you need to follow the steps given next.

1.  Start Autodesk Maya 2020 by double-clicking on its icon on the desktop.

2. Choose File > Project > Project Window from the menubar; the Project Window is 
displayed. Choose the New button; the Current Project and Location text boxes are enabled. 
Now, enter c02_tut1 in the Current Project text box. 

3. Click on the folder icon next to the Location text box; the Select Location dialog box is 
displayed. In this dialog box, browse to the \Documents\maya2020 folder and choose the 
Select button to close the dialog box. Next, choose the Accept button in the Project Window 
dialog box; the \Documents\maya2020\c02_tut1 folder will become the current project folder.

4. Choose Save Scene from the File menu; the Save File As dialog box is displayed. 
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Note
The scenes created in Maya are saved with the .ma or .mb extension. As the project folder is already 
created, the path \Documents\maya2020\c02_tut1\scenes is displayed in the Look in drop-down 
list of the Save As dialog box. 

Tip
After setting the project folder, when you open or save a scene, Maya uses the scenes folder 
inside the project folder by default.

5. Enter c02tut1 in the File name edit box and then choose the Save As button to close the 
dialog box.

Note
It is recommended that you frequently save the file while you are working on it by pressing the 
CTRL+S keys.

Creating the Basic Shape of the Mug
In this section, you will use the Cylinder polygon primitive to create the basic shape of the mug.

1. Choose Create > Objects > Polygon Primitives > Cylinder > Option Box from the 
menubar; the Tool Settings (Polygon Cylinder Tool) panel is displayed in the viewport. 
Enter the values in the Tool Settings (Polygon Cylinder Tool) panel, as shown in Figure 2-59.

2. Click in the persp viewport; a cylinder is created, refer to Figure 2-60. Close the Tool Settings 
(Polygon Cylinder Tool) panel.

Figure 2-60  Cylinder created in the 
viewport

Figure 2-59   The Tool Settings (Polygon Cylinder 
Tool) panel
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3. In the Channel Box / Layer Editor, click on the pCylinder1 tab; a text box is activated. 
Next, type mug in the text box and press ENTER; the pCylinder1 tab is renamed as mug.

4.  Hover the cursor in the persp viewport and press SPACEBAR;

Figure 2-61  Bottom vertices 
of the cylinder selected

 
the four viewports are displayed. Next, hover the cursor on the 
front-Z viewport and press SPACEBAR; the front-Z viewport is 
maximized. 

 Select mug if not selected and then press and hold the right 
mouse button; a marking menu is displayed. 

 
5. Choose Vertex from the marking menu; the vertex selection 

mode is activated.

6. Select the vertices at the bottom of mug, refer to Figure 2-61. 
Next, invoke the Scale Tool by pressing the R key.

7.  Scale down the selected vertices of mug inward uniformly, as shown in Figure 2-62. Similarly, 
select the other loops of vertices and scale them to form the shape of a mug, refer to 
Figure 2-63. 

Figure 2-63 Basic shape of the mug 
created 

Figure 2-62  Bottom vertices of the 
cylinder scaled

 Next, you need to add segments at the top and bottom. 

8. Make sure the Modeling menuset is selected in the Menuset drop-down list. Choose Mesh 
Tools > Tools > Insert Edge Loop from the menubar. Next, click at the top and bottom 
region of mug; two edges are inserted, refer to Figure 2-64. Deactivate the Insert Edge Loop 
tool by pressing the W key.

9. Maximize the persp viewport. Make sure mug is selected and then press and hold the right 
mouse button; a marking menu is displayed. Choose Face from the marking menu; the face 
selection mode is activated. Now, select the top faces of mug using the SHIFT key, refer to 
Figure 2-65. Next, choose Edit Mesh > Components > Extrude from the menubar. 
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Figure 2-64  Two edges inserted at the top and
bottom of the cylinder

Figure 2-65  Top faces of the cylinder 
selected

10.  Invoke the Scale Tool and scale down the selected faces uniformly, refer to Figure 2-66. 

11. Again, choose Edit Mesh > Components > Extrude from the menubar; the 
polyExtrudeFace# In-View Editor is displayed in the viewport, refer to Figure 2-67. Enter 
-0.3 in the Thickness edit box of the polyExtrudeFace# In-View Editor, refer to Figure 2-67; 
the shaded faces are extruded. 

12. Press the G key to invoke the Extrude tool again and enter the value -1.6 in the Thickness 
edit box; the top faces of mug are extruded downward.

Figure 2-66  The top selected faces of 
the mug scaled down using the Scale 
Tool

Figure 2-67 The polyExtrudeFace# In-View 
Editor displayed

Note
The G key is used to repeat the last performed action in Maya.
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13.  Press G again to invoke the Extrude tool, and enter the value -2 in the Thickness edit box. 
Next, enter 0.8 in the Offset edit box; the selected polygon is extruded inward. Deactivate 
the Extrude tool.

14.  Maximize the top-Y viewport such that you can view the inner area of mug. Press 3 to view 
the object in the smooth mode. To rectify the distortion in the geometry, you need to add 
edges. Press 1 and choose Mesh Tools > Tools > Insert Edge Loop tool; the shape of the 
cursor changes and then insert two edges inside the mug, refer to Figure 2-68. Deactivate the 
Insert Edge Loop tool by pressing W.

Figure 2-68  Two edge loops added inside the mug

Creating the Handle of the Mug
In this section, you need to create the handle of the mug.

1. Maximize the side-X viewport. Move the cursor over mug and then press and hold the right 
mouse button; a marking menu is displayed. Choose Edge from the marking menu; the 
edge selection mode is activated.

2. Select two edges of mug, refer to Figure 2-69. Next, choose Edit Mesh > Components > 
Bevel > Option Box; the Bevel Options window is displayed. Now, enter 1 in the Width edit 
box and choose the Bevel button; the selected edges will be beveled, as shown in Figure 2-70. 

Figure 2-69  Two edges of mug selected Figure 2-70  Selected edges beveled
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3. Move the cursor over mug and then press and hold the right mouse button; a marking menu 
is displayed. Choose Face from the marking menu; the face selection mode is activated. 
Next, select a face of mug, as shown in Figure 2-71. 

4. Choose Edit Mesh > Components > Extrude from the menubar. Next, invoke the Scale 
Tool by pressing the R key and scale down the selected face of mug uniformly upto 70%. 
You can check the scale size in the status line, as shown in Figure 2-72. 

Figure 2-71  A face of mug selected Figure 2-72  Face of the mug scaled down

5. Select the face of mug, as shown in Figure 2-73. Repeat the procedure as done in Step 4 to 
scale down the face, refer to Figure 2-74.

6. Maximize the persp viewport. Make sure that both the scaled faces are selected, and then 
invoke the Extrude tool by pressing the G key. Next, enter the value 0.8 in the Thickness 
edit box of the polyExtrudeFace# In-View Editor.

Figure 2-73  A face of the mug selected Figure 2-74  A face of the mug scaled down

7. Deactivate the Extrude tool by pressing the W key. Make sure the two extruded faces are 
selected. Next, choose Edit Mesh > Components > Bridge > Option Box from the 
menubar; the Bridge Options window is displayed. Enter values in the Bridge Options 
window, as shown in Figure 2-75. Next, choose the Apply button and close the window; the 
extruded faces are connected to each other.
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Figure 2-75  The Bridge Options window

8. Make sure mug is selected and then press and hold the right mouse button on it; a 
marking menu is displayed. Next, choose Object Mode from the marking menu; the 
object selection mode is activated.

9.    Select mug and then choose Mesh > Remesh > Smooth from the menubar; the mesh of 
mug is smoothened. Press SPACEBAR; the four viewports display the mug after applying 
Smooth Tool, as shown in Figure 2-76.

Figure 2-76  The mug displayed in all viewports
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Changing the Background Color of the Scene
In this section, you will change the background color of the scene.
                       
1. Choose Windows > Editors > Outliner from the menubar; the Outliner window is displayed. 

Select the persp camera in the Outliner window; the perspShape tab is displayed in Attribute 
Editor. 

2. In the perspShape tab, expand the Environment node and drag the Background Color 
slider bar toward right to change the background color to white. 

Saving and Rendering the Scene
In this section, you will save the scene that you have created and then render it. You can view 
the final rendered image of the scene by downloading the c02_maya_2020_rndr.zip file from 
www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > Maya > 
Autodesk Maya 2020: A Comprehensive Guide

1. Choose File > Save Scene from the menubar.

2. Maximize the persp viewport if not already maximized. Choose the Display render setting 
button from the Status Line; the Render Settings window is displayed. In this window, change 
renderer to Maya Software and then close the window. Choose the Render the current 
frame button from the Status Line to render the scene,  refer to Figure 2-58.

 Tutorial 2             
In this tutorial, you will create the model of a skateboard, as shown in Figure 2-77, using the 
polygon modeling techniques.                                                              (Expected time: 30 min)

Figure 2-77  The model of a skateboard

The following steps are required to complete this tutorial:

a. Create a project folder.
b. Create the deck.
c. Create the base.
d. Create the wheels.
e. Change the background color of the scene.
f. Save and render the scene.
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Creating a Project Folder
Create a new project folder with the name c02_tut2 at \Documents\maya2020 and then save the 
file with the name c02tut2, as discussed in Tutorial 1. 

Creating the Deck 
In this section, you need to create the deck of the skateboard using the Cube tool.

1. Maximize the top-Y viewport. Choose Create > Objects > Polygon Primitives > 
Cube > Option Box from the menubar; the Tool Settings (Polygon Cube Tool) panel 
is displayed on the left of the viewport. Enter the required values in the Tool Settings 
(Polygon Cube Tool) panel, as shown in Figure 2-78. Next, click in the top-Y viewport; 
a cube is created in the top-Y viewport, as shown in Figure 2-79. Close the Tool Settings 
(Polygon Cube Tool) panel.

Figure 2-79  A cube createdFigure 2-78  The Tool Settings (Polygon Cube 
Tool) panel

2. In the Channel Box / Layer Editor, click on pCube1. Next, enter deck in the text box and 
press ENTER; the pCube1 is renamed as deck.

3. In the top-Y viewport, press and hold the right mouse button on deck; a marking menu is 
displayed. Choose Vertex from the marking menu; the vertex selection mode is activated. 
Next, select the vertices, as shown in Figure 2-80. Next, choose the Scale Tool by pressing 
the R key and scale the vertices uniformly, refer to Figure 2-81.

4. Similarly, scale the other vertices to create the basic shape of deck, as shown in Figure 2-82.

5. Press and hold the right mouse button on deck; a marking menu is displayed. Next, choose 
Object Mode from the marking menu; the object selection mode is activated. Select deck 
and maximize the front-Z viewport. 
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Figure 2-81  The 
selected vertices scaled

Figure 2-80 The vertices selected Figure 2-82   The 
basic shape of the deck

6. Make sure the Modeling menuset is selected from the Menuset drop-down list in the Status 
Line. Next, choose Mesh Tools > Tools > Insert Edge Loop tool from the menubar; the 
shape of the cursor changes. Click on the top and bottom vertical edge and create two new 
segments on deck, as shown in Figure 2-83.

7.  Maximize the top-Y viewport and repeat the previous step to create two segments on deck, 
as shown in Figure 2-84. Choose the Select Tool to deactivate the Insert Edge Loop tool.

Figure 2-83  Two new segments created in the front-Z 
viewport

Figure 2-84  Two segments 
created in the top-Y viewport

8. Press and hold the right mouse button on deck; a marking menu is displayed. Choose Object 
Mode from the marking menu; the object selection mode is activated.

9. Make sure deck is selected and choose Mesh > Remesh > Smooth > Option Box from the 
menubar; the Smooth Options window is displayed. In the Smooth Options window, make 
sure the Division levels value is set to 1. Now, choose the Smooth button; the geometry of 
deck is smoothened.
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Creating the Base
In this section, you need to create the base of the skateboard using the Cube polygon primitive.

1. Maximize the front-Z viewport. Choose Create > Objects > Polygon Primitives > Cube > 
Option Box from the menubar; the Tool Settings (Polygon Cube Tool) panel is displayed 
in the viewport. Enter the required values in the Tool Settings (Polygon Cube Tool) panel, 
as shown in Figure 2-85. Next, click in the front-Z viewport; a cube is created in the front-Z 
viewport, as shown in Figure 2-86.

Figure 2-86  The cube createdFigure 2-85  The Tool Settings (Polygon 
Cube Tool) window

2. In the Channel Box / Layer Editor, click on pCube1 tab. Next, enter base in the text box 
and press ENTER; pCube1 tab is renamed as base.

3. In the front-Z viewport, press and hold the right mouse button on base; a marking menu is 
displayed. Choose Vertex from the marking menu; the vertex selection mode is activated. 
Next, select the two bottom center vertices and then choose the Move Tool from the Tool 
Box. Now, adjust the vertices on base to get the result shown in Figure 2-87.

4. Maximize the side-X viewport. Select the left most vertices in the side-X viewport and then 
drag them along the -Z axis to reduce the size of base, as shown in Figure 2-88.

Figure 2-88  Dragging the selected vertices 
along the -Z axis

Figure 2-87  The adjusted vertices of 
the base
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5. Press and hold the right mouse button on base; a marking menu is displayed. Next, choose 
Object Mode from the marking menu; the object selection mode is activated.

6. Select base and maximize the front-Z viewport. Next, choose Mesh Tools > Tools > Insert 
Edge Loop tool from the menubar. Using this tool, insert four new segments, as shown in 
Figure 2-89. Choose the Select Tool to deactivate the Insert Edge Loop tool.

Figure 2-89  Four new segments inserted in 
the front-Z viewport

7. Press and hold the right mouse button on base; a marking menu is displayed. Choose Object 
Mode from the marking menu; the object selection mode is activated.

 
8. Select base and choose Mesh > Remesh > Smooth from the menubar; the geometry of base 

is smoothened. 

 Next, you need to create the bolts.

9. Choose Create > Objects > Polygon Primitives > Cylinder > Option box from the 
menubar; the Tool Settings (Polygon Cylinder Tool) panel is displayed. Enter the required 
values in the Tool Settings (Polygon Cylinder Tool) panel, as shown in Figure 2-90. Click 
in the front-Z viewport; a cylinder is created. 

Figure 2-90  The Tool Settings (Polygon Cylinder Tool) panel
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10. In the Channel Box / Layer Editor, click on pCylinder1. Next, enter bolt in the text box 
and press ENTER; pCylinder is renamed as bolt.

11. Choose Move Tool from the Tool Box and align bolt with base in all viewports. Next, choose 
the Rotate Tool from the Tool Box to rotate and align it with both front-Z and side-X 
viewports, as shown in Figures 2-91 and 2-92.

Figure 2-91  The cylinder rotated and 
aligned in the front-Z viewport

Figure 2-92  The cylinder rotated 
and aligned in the side-X viewport

12. Activate the side-X viewport. Make sure bolt is selected and press CTRL+D; a duplicate copy 
of bolt is created with the name bolt1. Set the following parameters in the Channel Box / 
Layer Editor of bolt1:

      Rotate X: 90  Rotate Z: 0 

13. Choose the Scale Tool from the Tool Box and scale bolt1 uniformly. Next, choose the Move 
Tool from the Tool Box and align it in all viewports, as shown in Figure 2-93.

Figure 2-93  Aligning bolt1 in all viewports

 Next, you need to create truck.
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14. Maximize the front-Z viewport. Choose Create > Objects > Polygon Primitives > 
Cylinder > Option box from the menubar; the Tool Settings (Polygon Cylinder Tool) 
panel is displayed in the viewport. In the Tool Settings (Polygon Cylinder Tool) panel, set 
the parameters as follows:

 Radius: 0.25  Height: 1    Axis: Z
 Axis divisions: 10   Height divisions: 3   Cap Divisions: 10

 Next, click in the viewport; the cylinder is created .

15. In the Channel Box / Layer Editor, click on pCylinder1. Next, enter truck in the text box 
and press ENTER; the pCylinder1 is renamed as truck.

16. Maximize the persp viewport. Press and hold the right mouse button over truck and choose 
Face from the marking menu displayed; the face selection mode is activated. Select the 
faces 1 and 5 of truck, refer to Figure 2-94. Next, choose Edit Mesh > Components > 
Extrude from the menubar; the polyExtrudeFace2 In-View Editor is displayed. Enter 1 in 
the Thickness edit box; the faces of truck are extruded, as shown in Figure 2-95. 

Figure 2-95 The cylinder after 
extrusion in the persp viewport

Figure 2-94  The cylinder after 
extrusion in the persp viewport

17. Maximize the front-Z viewport. Choose the Mesh Tools > Tools > Insert Edge Loop tool 
from the menubar and add new segments to truck, as shown in Figure 2-96. Choose Select 
Tool to deactivate the Insert Edge Loop tool.

18. Press and hold the right mouse button on truck; a marking menu is displayed. Choose 
Object Mode from it; the object selection mode is activated. Next, select truck and choose 
Mesh > Remesh > Smooth > Option Box from the menubar; the Smooth Options window 
is displayed.

19. In the window, enter 2 in the Division levels edit box and then choose the Smooth 
button; the geometry of truck is smoothened. Next, align truck, base, bolt and bolt1 in all 
viewports using Move Tool, Rotate Tool, and Scale Tool uniformly, refer to Figure 2-97. 

20. Press and hold the SHIFT key and select base, truck, bolt, and bolt1 in the persp viewport. Next, 
choose Mesh > Combine > Combine from the menubar; the selected parts are combined 
and a group with the name base1 is created.
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Figure 2-96   New segments added to truck Figure 2-97  The parts aligned 
with base in the front-Z viewport

21.  In the base1 area of the Channel Box / Layer Editor, enter 90 in the Rotate Y edit box and 
then press the ENTER key.

22. Align base1 in all viewports using the Move Tool and the Scale Tool from the Tool Box to 
make it proportional with the deck, as shown in Figure 2-98.

Figure 2-98  The base1 aligned in all viewports

Creating Wheels
In this section, you need to create wheels for the skateboard using the Torus polygon primitive.

1. Choose Create > Objects >  Polygon Primitives > Torus from the menubar. Next, click 
in the top-Y viewport to create a torus.

2.  In the INPUTS area of the Channel Box / Layer Editor, expand the polyTorus1 node and 
set the following parameters:

 Radius:  0.1  Section Radius:  0.1 



Polygon Modeling        2-39

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

3. In the pTorus1 area of the Channel Box/Layer Editor, enter 90 in the Rotate Z edit box.

4. In the Channel Box / Layer Editor, rename pTorus1 as wheel, as done earlier. 

5. Scale and align wheel with bolt1 in all viewports using the Move Tool from the Tool Box, as 
shown in Figure 2-99.

Figure 2-99  The wheel aligned with bolt1 in all viewports

6. Maximize the front-Z viewport. Make sure wheel is selected and then press CTRL+D;  a 
duplicate copy of wheel is created with the name wheel1. Next, move wheel1 in a direction  
opposite to wheel, as shown in Figure 2-100. 

7. Maximize the persp viewport. Select base1, wheel, and wheel1 by using the SHIFT key and then 
choose Mesh > Combine > Combine from the menubar; the selected parts are combined 
to form a single polygon object with the name base2.

8.  Choose Modify > Pivot > Center Pivot from the menubar; the pivot point of the combined 
base2 is set to center. Next, press CTRL+D; a duplicate copy of the selected mesh is created 
in the viewport.

9. Maximize the side-X viewport. Next, move base3 along the Z axis to align with deck and 
also enter 180 in the Rotate Y edit box to rotate base3, refer to Figure 2-101.
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Figure 2-100  The wheel1 moved to 
opposite direction of wheel

Figure 2-101  The base3 moved and rotated

10. Select deck. Press and hold the right mouse button on deck; a marking menu is displayed. 
Choose Vertex from the marking menu; the vertex selection mode is activated. Next, select 
the vertices and move up along the Y axis using Move Tool, as shown in Figure 2-102.

Figure 2-102  Moving the selected vertices up along the Y axis

11. Press and hold the right mouse button on deck; a marking menu is displayed. Choose Object 
Mode from the marking menu; the object selection mode is activated.

12. Maximize the persp viewport and select all parts of the skateboard in the persp viewport. 
Next, choose Mesh > Combine > Combine from the menubar; the selected parts are 
combined.

Changing the Background Color of the Scene
In this section, you will change the background color of the scene.

1. Choose Windows > Editors > Outliner from the menubar; the Outliner window is displayed. 
Select the persp camera in the Outliner window; the perspShape tab is displayed in the 
Attribute Editor. 

Note
If the Attribute Editor is not visible in the interface, press CTRL + A to make it visible.

2. In the perspShape tab, expand the Environment area and drag the Background Color 
slider bar toward right to change the background color to white.

Saving and Rendering the Scene
In this section, you will save the scene that you have created and then render it. You can view 
the final rendered image of the model by downloading the c02_maya_2020_rndr.zip file from 
www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > Maya 
> Autodesk Maya 2020: A Comprehensive Guide.



Polygon Modeling        2-41

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

1. Choose File > Save Scene from the menubar.

2. Maximize the persp viewport if not already maximized. Choose the Display render setting 
button from the Status Line; the Render Settings window is displayed. In this window, change 
renderer to Maya Software and then close the window. Choose the Render the current 
frame button from the Status Line to render the scene,  refer to Figure 2-77.

 Tutorial 3             
In this tutorial, you will create the model of a hand, as shown in Figure 2-103, using the 
polygon modeling techniques.                                                    (Expected time: 40 min)

Figure 2-103  The model of a hand
The following steps are required to complete this tutorial:

a. Create a project folder.
b Create the structure of a hand.
c. Create Fingers.
d. Create the nails.
e. Add the edges for hand.
f. Change the background color of the scene.
g. Save and render the scene.

Creating a Project Folder
Create a new project folder with the name c02_tut3 at \Documents\maya2020 and then save the 
file with the name c02tut3, as discussed in Tutorial 1. 

Creating the Structure of a Hand
In this section, you need to create a structure of hand using the Cube Tool.

1. Choose Create > Objects >  Polygon Primitives > Cube from the menubar: the cube is 
created in the Viewport.

2. In the Channel Box / Layer Editor, click on pCube1. Next, enter hand in the text box and 
press ENTER; the pCube1 is renamed as hand.
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3.  In the INPUTS area of the Channel Box / Layer Editor, expand the polyCube1 node and 
set the following parameters:

 Width: 4   Height: 1     Depth: 4

4. In the top-Y viewport, press and hold the right mouse button on hand; a marking menu is 
displayed. Choose Vertex from the marking menu, as shown in Figure 2-104; the vertex 
selection mode is activated. Next, select the vertices and scale them uniformly using the 
Scale Tool by pressing the R key, refer to Figure 2-105.

Figure 2-104  Choosing Vertex from marking menu

Figure 2-105  Scaling selected vertices uniformly

5. Align the other vertices to create the basic shape of hand, as shown in Figure 2-106.
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Figure 2-106  Aligning the vertices

6. Maximize the persp viewport. Again check and align the vertices of hand. In the persp 
viewport, press and hold the right mouse button on hand; a marking menu is displayed. 
Choose Face from the marking menu; the face selection mode is activated. Next, select the 
faces of the wrist side and delete them, refer to Figure 2-107.

Figure 2-107 Selected  faces of wrist side

Creating Fingers
In this section, you need to create the fingers of a hand.

1. Press SPACEBAR to maximize all viewports. Make sure the Modeling menuset is selected 
in the Menuset drop-down list. In the persp viewport, select the middle face, refer to 
Figure 2-108.

2. Choose Edit Mesh > Components > Extrude from the menubar; the polyExtrudeFace1 
In-View Editor is displayed. Enter the value in In-View Editor, as shown in Figure 2-109; the 
face of middle finger is extruded. Click on the empty area of viewport; the polyExtrudeFace1 
In-View Editor is closed.
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Figure 2-108  The face selected

Figure 2-109  The selected face extruded

3. Make sure all viewports are maximized. Select the faces of the middle finger in the persp 
viewport, refer to Figure 2-110. Press E to activate the Rotate Tool and slightly rotate the 
selected faces in the side-X viewport. Similarly, select the top faces of middle finger in the 
side-X viewport and rotate slightly, as shown in Figure 2-111. 

Figure 2-110  The selected faces rotated
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Figure 2-111  The selected faces rotated

4. Press and hold the right mouse button on hand; a marking menu is displayed. Choose Object 
from the marking menu; the object selection mode is activated. Press W to activate the Move 
Tool. Next, choose Mesh Tools > Tools > Insert Edge Loop tool from the menubar, as 
shown in Figure 2-112. Using this tool, insert one new edge, as shown in Figure 2-113. Choose 
Select Tool to deactivate the Insert Edge Loop tool.

Figure 2-112  Choosing Insert Edge Loop from the menubar 

5. Press and hold the right mouse button on hand; a marking menu is displayed. Choose Face 
from the marking menu; the face selection mode is activated. Select the faces of all fingers 
using the SHIFT key, as shown in Figure 2-114. 
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Figure 2-113  New edge added to the hand

Figure 2-114  Faces selected 

6. Choose Edit Mesh > Components > Extrude from the menubar; the polyExtrudeFace2 
In-View Editor is displayed. Enter 2.1 and 3 in the Thickness and Division edit box,  
respectively. Next, click in the Keep Faces Together edit box so that it displays off. Next, 
enter 0.2 in the Offset edit box. The selected faces are extruded, as shown in Figure 2-115. 
Click in the empty area of viewport; the polyExtrudeFace2 In-View Editor is closed.
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Figure 2-115  Selected faces extruded 
7. Press and hold the right mouse button on hand; a marking menu is displayed. Choose 

Vertex from the marking menu; the vertex selection mode is activated. Next, align vertices 
of all the fingers using Scale, Move, and Rotate tools to get the shape of hand, as shown in 
Figures 2-116 through 2-118.

Figure 2-116  Aligning the vertices of fingers using the Scale tool



2-48                         Autodesk Maya 2020: A Comprehensive Guide
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 2-117  Aligning the vertices of fingers using the Move tool

Figure 2-118 Aligning the vertices of fingers using the Rotate tool

8. Maximize the persp viewport and press 3 for preview of the smooth hand, as shown in 
Figure 2-119. Press 1 to turn off the smoothening of the object.

9.  Make sure the persp viewport is maximized. Also make sure hand is selected. Next, choose 
Mesh Tools > Tools > Insert Edge Loop tool from the menubar. Using this tool, insert two 
new edges, refer to Figure 2-120. Choose Select Tool to deactivate the Insert Edge Loop 
tool.
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Figure 2-119  Preview of the smooth hand

Creating the Nails
In this section, you need to create the nails.

1. Press and hold the right mouse button on hand; a marking menu is displayed. Choose Face 
from the marking menu; the face selection mode is activated. Select the top faces of the nail 
area of all fingers using the SHIFT key, as shown in Figure 2-120. 

Figure 2-120  Top faces of the nail area selected
2. Choose Edit Mesh > Components > Extrude from the menubar; the polyExtrudeFace3 

In-View Editor is displayed. Enter the required values, as shown in Figure 2-121. Also, slightly 
rotate the extruded faces. Click on the empty area of viewport; the polyExtrudeFace3 
In-View Editor is closed.
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Figure 2-121  The values set in the polyExtrudeFace3 In-View Editor 

3. Similarly select the faces of nail tip using the SHIFT key. Next, choose Edit Mesh > 
Components > Extrude from the menubar; the polyExtrudeFace4 In-View Editor is 
displayed. Enter the value, as shown in Figure 2-122. Now, click on the empty area of 
viewport; the polyExtrudeFace4 In-View Editor is closed.

Figure 2-122  The values set in the polyExtrudeFace4 In-View Editor 

4. Press and hold the right mouse button on hand; a marking menu is displayed. Choose 
Object from the marking menu; the object selection mode is activated. Press 3 for preview 
of the smooth hand, as shown in Figure 2-123.  Press 1 for turning off smoothness preview.
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Figure 2-123  Preview of the hand

Adding the Edges
In this section, you need to add the edges to give the perfect shape to hand.

1. Make sure the persp viewport is maximized. Also, make sure hand is selected. Next, choose 
Mesh Tools > Tools > Insert Edge Loop tool from the menubar. Using this tool, insert two 
new edge loops in the wrist area, as shown in Figure 2-124. Choose Select Tool to deactivate 
the Insert Edge Loop tool.

Figure 2-124  Two new edge loops added
2. Select the edge and then press W to activate Move Tool and then move the edge, as shown 

in Figure 125. Now, adjust both the edges using Move Tool.  



2-52                         Autodesk Maya 2020: A Comprehensive Guide
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

 

Figure 2-125  Moving the selected edge upward

3. Select the last edge of the wrist and move it using Move Tool, as shown in Figure 2-126. 
Next, choose Mesh Tools > Tools > Insert Edge Loop tool from the menubar. Using this 
tool, insert edges, as shown in Figure 2-127.

Figure 2-126  Moving the selected edge

4. Adjust all edges using Move Tool, Scale Tool, and Rotate Tool for perfect shape. Press 3 
for preview of the smooth hand, as shown in Figure 2-128. 
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Figure 2-127  Added edges for perfect shape

5. Make sure Modeling is selected in the Menuset drop-down list. Next, select the hand and 
then choose Mesh>Retopologize from the menubar; the hand is smoothened.

Figure 2-128  The preview of the smooth hand

Changing the Background Color of the Scene
In this section, you will change the background color of the scene.

1. Choose Windows > Editors > Outliner from the menubar; the Outliner window is displayed. 
Select the persp camera in the Outliner window; the perspShape tab is displayed in the 
Attribute Editor. 

2. In the perspShape tab, expand the Environment area and drag the Background Color 
slider bar toward right to change the background color to white.
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Saving and Rendering the Scene
In this section, you will save the scene that you have created and then render it. You can view 
the final rendered image of the model by downloading the c02_maya_2020_rndr.zip file from 
www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > Maya 
> Autodesk Maya 2020: A Comprehensive Guide

1. Choose File > Save Scene from the menubar.

2. Maximize the persp viewport if it is not already maximized. Choose the Display render 
setting button from the Status Line; the Render Settings window is displayed. In this 
window, change renderer to Maya Software and then close the window. Choose the Render 
the current frame button from the Status Line to render the scene, refer to Figure 2-103.

 Self-Evaluation Test  
Answer the following questions and then compare them to those given at the end of this 
chapter:

1. Which of the following geometric shapes is formed by connecting a polygonal base and an 
apex?

  (a) Prism   (b) Pyramid
  (c) Sphere   (d) Cube

2.  Which of the following shortcuts can be used to display an object in the object selection mode?
 
  (a) F8    (b) F9
  (c) F10    (d) F11

3. The __________ is used to merge two vertices together.

4. The __________ option is used to subtract the last selected geometry from the geometry 
that was selected first.

5. A __________ is a curve in three dimensional space such that its angle to a plane perpendicular 
to the axis is constant.

6.  The __________ solids are those primitives in which all sides and angles are equal and all 
faces are identical.

7. The __________ tool is used to reduce the number of polygons in the selected region of an 
object.

8.  The Insert Edge Loop Tool is used to create beveled transition surfaces on a profile curve. 
(T/F)
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9.  The Chamfer tool is used to merge the selected edges and vertices that are within a 
numerically specified threshold distance from each other. (T/F)

10.  The Bridge tool is used to connect two edges or two faces of a polygon object. (T/F)
 

 Review Questions 
Answer the following questions:

1. Which of the following tools is used to add smoothness to a sharp edge?

  (a) Extrude   (b) Duplicate face
  (c) Bevel   (d) Merge to Center

2.  Which of the following primitives is formed by an alternate arrangement of hexagons and 
pentagons?

  
  (a) Prism   (b) Helix
  (c) Soccer ball   (d) Sphere

3. The __________ option is used to create a duplicate copy of a selected face.

4. The __________ tool is used to add segments on both the sides of a selected edge.

5. The __________ tool is used to ungroup the combined polygon objects into separate polygon 
objects.

6.  The __________ tool is used to make a polygon object smooth by adding divisions to it. 

7. The __________ operation is used to merge two intersecting objects by deleting the 
intersecting geometry between them. 

8.  The Combine tool is used to group two or more polygon meshes into a single polygon 
object. (T/F)

9.  The Multi-Cut tool is used to manually add segments between two edges of an object. (T/F)

10. The Detach tool is used to split a vertex into multiple vertices. (T/F)

EXERCISES 
The rendered output of the models used in the following exercises can be accessed by downloading 
the file c02_maya_2020_exr.zip from www.cadcim.com. The path of the file is as follows: Textbooks > 
Animation and Visual Effects > Maya > Autodesk Maya 2020: A Comprehensive Guide



2-56                         Autodesk Maya 2020: A Comprehensive Guide
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

 Exercise 1                                                                      
Using various polygon modeling techniques, create the model of a USB cable, as shown in 
Figure 2-129.                                        (Expected time: 30 min)

Figure 2-129  Model to be created in Exercise 1

 Exercise 2                                                                   
Using various polygon modeling techniques, create a scene, as shown in Figure 2-130.  
                                                                                                   (Expected time: 30 min)

Figure 2-130  Scene to be created in Exercise 2

 Exercise 3                                                                      
Using polygon primitive modeling techniques, create a scene, as shown in Figure 2-131.                                                        
              (Expected time: 30 min)
                                                        
  

Figure 2-131  Scene to be created in Exercise 3

 

Answers to Self-Evaluation Test
1. b, 2. a, 3. Merge Tool, 4. Difference, 5. helix, 6. platonic, 7. Reduce, 8. F, 9. F, 10. T


