Chapter 1

Introduction to NX

Learning Objectives

After completing this chapter, you will be able to:

* Understand different environments in NX

* Understand the system requirements for NX

* Start a new file in NX

* Understand the important terms and definitions used in NX
* Understand functions of the mouse buttons

* Understand the use of various hot keys

* Modify the color scheme in NX
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INTRODUCTION TO NX

Welcome to NX. As a new user of this software package, you will join hands with thousands of
users of this high-end CAD/CAM/CAE/PLM tool. If you are already familiar with the previous
releases, you can upgrade your designing skills with tremendous improvement in this latest
release.

NX provides improved capabilities for convergent modeling, CAD design, drafting, tooling
design, automation, design simulation, programming, data translation, validation, mold design,
and much more. Active workspace in NX is built based on these items to provide seamless access
to PLM capabilities right within NX.

NX, a product of SIEMENS Corp., is a completely re-engineered, next-generation family
of CAD/CAM/CAE/PLM software solutions for Product Life Cycle Management. Through
its exceptionally easy-to-use and state-of-the-art user interface, NX delivers innovative
technologies for maximum productivity and creativity from the basic concept to the final
product. NX reduces the learning curve by allowing flexibility in the use of feature-based and
parametric designs.

The subject of interpretability offered by NX includes receiving legacy data from other CAD
systems and even between its own product data management modules. The real benefit is that
the links remain associative. As a result, any changes made to this external data are notified to
you and the model can be updated quickly.

When you open an old file or start a new file in NX, you will enter the Gateway
environment. It allows you to examine the geometry and drawing views that have been created.
In the Gateway environment, you can invoke any environment of NX.

NX serves the basic design tasks by providing different environments. An environment is defined
as a specific area, consisting of a set of tools which allows the user to perform specific design
tasks in that particular area. You need to start the required environment after starting a new
part file. As a result, you can invoke any environment of NX in the same working part file. The
basic environments in NX are the Modeling environment, Shape Studio environment, Drafting
environment, Assembly environment, and the Sheet Metal environment. These environments
are discussed next.

Modeling Environment

The Modeling environment is a parametric and feature-based environment in which you can
create solid models. The basic requirement for creating solid models in this environment is a
sketch. In NX, you can create a sketch by using two methods: Direct sketch and Sketch in Task
Environment. In the Direct sketch method, you can create a sketch, as required, directly in the
Modeling environment by invoking the sketching tools such as Line, Arc/Circle, Point and so
on from the Base group of the Curve tab of the Ribbon. The sketch can also be drawn in the
Sketch in Task Environment or sketching environment. To create the sketch in this environment,
you need to invoke the sketching environment by using the Sketch tool from the Home tab
of the Ribbon. While drawing a sketch, various applicable constraints and dimensions are
automatically applied to it. Additional constraints and dimensions can also be applied manually.
After drawing the sketch, you need to convert the sketch into a feature using the tools available
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in the Modeling environment. You can create placed features such as fillets, chamfers, taper,
and so on and can also assign materials to the models in this environment.

Shape Studio Environment

The Shape Studio environment is also a parametric and feature-based environment in which you
can create surface models. The tools in this environment are similar to those in the Modeling
environment. The only difference is that the tools in this environment are used to create basic
and advanced surfaces. You are also provided with the surface editing tools which are used to
manipulate the surfaces to obtain the required shape. This environment is useful for conceptual
and industrial design.

Assembly Environment

The Assembly environment is used to assemble the components using the assembly constraints
available in this environment. There are two types of assembly design approaches in NX,
Bottom-up and Top-down.

In the bottom-up approach of the assembly, the previously created components are
assembled together to maintain their design intent and in the top-down approach, components
are created in the Assembly environment.

In the Assembly environment, you can also assemble an existing assembly with the current
assembly. The Perform Analysis tool provides the facility to check the interference and clearance
between the components in an assembly.

Drafting Environment

The Drafting environment is used for the documentation of the parts or assemblies created
earlier in the form of drawing views and their detailing. There are two types of drafting
techniques: generative drafting and interactive drafting.

The generative drafting technique is used to automatically generate the drawing views of the
parts and assemblies. The parametric dimensions added to the component in the Modeling
environment during its creation can also be generated and displayed automatically in the
drawing views. The generative drafting is bidirectionally associative in nature. If you modify the
dimensions in the Drafting environment, the model will automatically update in the Modeling
environment and vice-versa. You can also generate the Bill of Material (BOM) and balloons in
the drawing views.

In interactive drafting, you need to create the drawing views by sketching them using the normal
sketching tools and then adding the dimensions.

Sheet Metal Environment

The Sheet Metal application provides an environment for the design of sheet metal parts used
in machinery, enclosures, brackets, and other parts normally manufactured with a brake press.
The Sheet Metal application is intended mainly for designing parts with cylindrical bend regions
but conical and curved bend regions are also possible. Generally, the sheet metal components
are created to generate the flat pattern of a sheet, study the design of the dies and punches,
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study the process plan for designing, and the tools needed for manufacturing the sheet metal
components.

SYSTEM REQUIREMENTS

System requirements that ensure the smooth running of NX are as follows:

*  64-bit - Windows 10 Operating System.

*  8GB of RAM is the minimum requirement but it is recommended to have 16GB or more
RAM for all the applications to run smoothly.

* Javaversion - 1.8.0 or higher

*  True Color (32-bit) or 16 million colors (24-bit)

* Screen Resolution: 1280 x 1024 or higher, widescreen format.

GETTING STARTED WITH NX

Install NX on your system and then start it by double-clicking on its shortcut icon on the desktop
of your computer. After the system has loaded all the required files to start NX, the initial
interface will be displayed, as shown in Figure 1-1.

< Note
\@ When you install NX, by default its shortcut icon is not created on the desktop of your computer.
~ So to create the shortcut icon, click start to display a menu. Drag NX icon from the Siemens NX
folder to the desktop.
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Figure 1-1 The initial interface that appears after starting NX

Create or open a file
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Tip

Q 1. In this release, by default, the user interface theme is set to Light. But, you can change
the interface theme as per your requirement. 1o do so, choose Menu > Preferences > User
Interface from the Top Border Bar; the User Interface Preferences dialog box will be
displayed. Next, select the required option from the Type drop-down list available in the NX
Theme group of the Theme node and choose the OK button.

2. To change the Default Presentation of Dialog Content of any dialog box, choose
Menu > Preferences > User interface from the Top Border Bar; the User Interface
Preferences dialog box will be displayed. Next, select the Options node available on the
left in the dialog box; the Dialog Boxes group will be displayed. Now, select the More radio
button in the Default Presentation of Dialog Content area and choose the OK button.

Choose File > New from the Ribbon; the New dialog box will be displayed as shown in Figure 1-2.
Make sure that Model template is selected in the Templates rollout of the dialog box. Next,
enter the name of the file in the Name edit box and choose the OK button; the Modeling
environment will be displayed on the screen, refer to Figure 1-3.

New O X
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Figure 1-2 The New dialog box
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Figure 1-3 The Modeling environment of NX displayed on screen

IMPORTANT TERMS AND DEFINITIONS

Some important terms and definitions of NX are discussed next.

Feature-based Modeling

A teature is defined as the smallest building block that can be modified individually. A model
created in NX is a combination of a number of individual features and each feature is related to
the other directly or indirectly. If a proper design intent is maintained while creating the model,
then these features automatically adjust their values to any change in their surroundings. This
provides a great flexibility to the design.

Parametric Modeling

The parametric nature of a software package is defined as its ability to use the standard
properties or parameters in defining the shape and size of a geometry. The main function of
this property is to derive the selected geometry to a new size or shape without considering its
original dimensions. You can change or modify the shape and size of any feature at any stage
of the designing process. This property makes the designing process an easy task. For example,
consider the design of the body of a pipe housing, as shown in Figure 1-4.

To change the design by modifying the diameter of the holes and their number on the front,
top, and bottom face, you need to select the feature and change the diameter and the number
of instances in the pattern. The modified design is shown in Figure 1-5.
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Figure 1-4 Body of a pipe housing Figure 1-5 Modified body of the pipe housing

Bidirectional Associativity

As mentioned earlier, NX has different environments such as the Modeling environment, the
Assembly environment, and the Drafting environment. The bidirectional associativity that exists
between all these environments ensures that any modification made in the model in any of
the environments of NX is automatically reflected in the other environments immediately. For
example, if you modify the dimension of a part in the Modeling environment, the change will
be reflected in the Assembly and the Drafting environments as well. Similarly, if you modify the
dimensions of a part in the drawing views generated in the Drafting environment, the changes
will be reflected in the Modeling and Assembly environments. Consider the drawing views of the
pipe housing shown in Figure 1-6. When you modify the model in the Modeling environment,
the changes will be reflected in the Drafting environment automatically. Figure 1-7 shows the
drawing views of the pipe housing after increasing the diameter and the number of holes.

Figure 1-6 The drawing views of a pipe housing

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com



Evaluation Copy. Do not reproduce. For information visit www.cadcim.com

1-8 Siemens NX 2021 for Designers

Figure 1-7 The drawing views of pipe housing afler making the modifications
prt

prt is a file extension associated with all files that are created in the Modeling, Shape Studio,
Assembly, Sheet Metal, and Drafting environments of NX.

Resource Bar

The Resource Bar combines all the navigator windows, the history palette, and the integrated
web browser at one common place for a better user interface. By default, the Resource Bar is
located on the left side of the NX window.

Roles

Roles are sets of system customized tools and toolbars used for different applications. In NX, you
have different roles for different industrial applications. The Roles tab in the Resource Bar is
used to activate the required role. In this book, the Essentials role has been used, as it contains
all the required tools. To activate this role, choose the Roles tab from the Resource Bar and
click on the Content option; a flyout will be displayed. Click on the Essentials icon to activate
that role; the Load Role message box will be displayed. Next, choose the OK button to close
the dialog box. Figure 1-8 shows the Roles navigator that appears when you choose the Roles
tab in the Resource Bar.

Part Navigator

The Part Navigator keeps a track of all the operations that are carried out on the part.
Figure 1-9 shows the Part Navigator that appears when you choose the Part Navigator tab in
the Resource Bar.
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Figure 1-8 The Roles navigator Figure 1-9 The Part Navigator
Constraints

Constraints are the logical operations that are performed on an element to define its
size and location with respect to the other elements or reference geometries. There are
three types of constraints in NX: Geometric, Dimensional, and Assembly. The geometric
and dimensional constraints available in the sketching environment are used to precisely define
the size and position of the sketched elements with respect to the surroundings. The assembly
constraints are available in the Assembly environment and are used to define the precise position
of the components in the assembly. These constraints are discussed next.

Geometric Constraints

These are the logical operations performed on the sketched elements to define their size and
position with respect to other elements. Geometric constraints are applied using two methods:
automatic constraining and manual constraining. While drawing the sketch, some constraints
are automatically applied to it. You will learn more about applying constraints to the sketch in
later chapters of this book.

Dimensional Constraints
After creating the sketch, you need to apply different types of dimensional constraints to it.
Various types of dimensions in NX are:

Linear Dimension
Radial Dimension
Angular Dimension
Perimeter Dimension

0o —
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NX is a parametric software and therefore, you can modify the dimensions of a sketch at any
time. You will learn more about modifying dimensions of the sketch in later chapters.

Assembly Constraints

The constraints in the Assembly environment are the logical operations performed to restrict the
degrees of freedom of the component and to define its precise location and position with respect
to other components of the assembly.

Solid Body

The solid body contains all the features such as extrude, revolve, hole, and so on.

Sheet Body or Surfaces

Surfaces are geometric features that have zero thickness and mass. They are used to create
complex shapes which are difficult to be created using the solid features. After creating the surface,
you can assign a thickness to it in order to convert it into a solid body. Surfaces are created in
the Modeling environment. No separate environment is required to create the surfaces. You can
also invoke the Surface environment by choosing the Shape Studio option from the Templates
rollout of the New dialog box.

Features
A feature is defined as a basic building block of a solid model. The combination of various
features results in a solid body. In the Modeling environment of NX, the features are of two types:

1. Sketch-based features
2. Placed-features

The sketch-based features require a sketch for their creation and the placed-features do not
require a sketch for their creation.

WCS (Work Coordinate System)

The WCS is a local coordinate system and can be repositioned to a convenient location while
making a model. The XC-YC plane of the WCS is used to perform many operations. When you
create a new file, by default the WCS is positioned at origin of the Datum Coordinate System,
which is (0,0,0). By default, the display of WCS is turned off. To turn on the display of WCS,
choose the following path; Menu > Format > WCS > Display; the WCS will be displayed in
the drawing window. Note that Display button is a toggle button.

UNDERSTANDING THE FUNCTIONS OF THE MOUSE
BUTTONS

To work in the NX environment, it is necessary that you understand the functions of the mouse
buttons. The efficient use of the three buttons of the mouse along with the CTRL key can reduce
the time required to complete the design task. The different combinations of the CTRL key and
the mouse buttons are listed below:
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1. The left mouse button is used to make a selection by simply selecting a face, surface, sketch,
or an object from the geometry area or from the Part Navigator. For multiple selections,
select the entities by dragging the left mouse button.

2. The right mouse button is used to invoke the shortcut menu which has different options
such as Zoom, Fit, Rotate, Pan, and so on.

3. Press and hold the middle and the right mouse buttons to invoke the Pan tool. Next, drag
the mouse to pan the model. You can also invoke the Pan tool by first pressing and holding
the SHIFT key and then the middle mouse button. Figure 1-10 shows the use of a three
button mouse in performing the pan functions.

4. Press and hold the middle mouse button to invoke the Rotate tool. Next, drag the mouse
to dynamically rotate the view of the model in the geometry area and view it from different
directions. Figure 1-10 shows the use of the three button mouse in performing the rotate
operation.

5. Press and hold the CTRL key and then the middle mouse button to invoke the Zoom tool.
Alternatively, press and hold the left mouse button and then the middle mouse button to
invoke the Zoom tool. Next, drag the mouse dynamically to zoom in or out the model in
the geometry area. Figure 1-10 shows the use of the three mouse buttons in performing the
zoom functions.

MME Wheel Scroll MMB + Drag

Zoom In/Out Rotate

LMB + MMB + Drag MME + RMB + Drag

Zoom Pan

LME = Select RMB = Shortcut menu

Figure 1-10 Functions of the mouse buttons

Various screen components of NX are discussed next.

QUICK ACCESS TOOLBAR

This toolbar is common to all the environments of NX. Figure 1-11 shows the Quick Access
toolbar. The buttons in this toolbar are used to start a new file, open an existing file, save a file
of the current document, cut and place the selection on a temporary clipboard, copy a selection,
paste the content from the clipboard to a selected location, undo, redo, Touch Mode, search a
tool, and invoke the help topics.
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In NX, when you have a session running in which several parts are open, you can switch between
the running parts using the Switch Window button. This button is available next to the Touch
Mode button in the Quick Access toolbar, refer to Figure 1-11.

NX @ M A 42 EEWindnw':

Figure 1-11 Partial view of the Quick Access toolbar

Note

1. You can use the CTRL+TAB keys to open the panel to show all files that are currently open.
You can also move from item to item using the TAB key or hold the CTRL key and use the mouse
wheel to scroll through them. You can also select an item to open it.

2. The Switch Window button located next to the Touch Mode button allows you to open the
panel manually. By using this button, you will be able to navigate through the displayed parts
using the left and right arrowkeys on your keyboard.

Using Multiple Windows in NX

NX allows you to use multiple windows while sketching. You can view multiple parts at once in
separate tabbed windows. The Window drop-down list available in the Quick Access toolbar
contains the options which allow you to view the same part or different parts in two or more
separate windows. Figure 1-12 shows the Window drop-down list.

@ HNew Window...

@ Reset Layout
m Window Layout 3

v 1. modell.prt

2. Welcome Page
[ switch windowr...

& Change Displayed Part...

Figure 1-12 The Window drop-down list
The options available in this drop-down list are discussed next.

New Window

When you choose this option, a new file tab will be added below the Top Border Bar, refer to
Figure 1-13. You can switch between the tabs by clicking on the respective tab. An active tab is
displayed in light blue color.

|EntireAssemny v| @ M- ﬁ M M
{7} Welcome Page & modell.prt: 1 5 m—

Figure 1-13 File tab added on choosing the New Window option
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Window Layout
When you hover the cursor over this option, a cascading window will be displayed, refer to
Figure 1-14.

] window ~ |
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m Windmn*yuut 3 -
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Figure 1-14 Cascading window displaying
Window Layout options

You can choose the required layout option from the cascading window. Figure 1-15 shows two
tabbed windows displaying the same model. These tabbed windows will appear when you choose
the 2 Tabbed Groups option (second option in the first row) from the cascading window.

- modellprt:2 B X @ modellprt: 1 & X

=

Figure 1-15 Model displayed in two tabbed windows

/ . Note

@‘ The options in the Window Layout cascading window will become active depending upon the
~ number of windows that are active during a session. For instance, if you have a model or sketch open
in one window and you choose the New Window option from the Window drop-down list, a new
file tab will be added below the Top Border Bar. Now, you will notice that the first three options in
the cascading window become active. Likewise, if you have three or more separate windows having
three or more different models, then all the options in the cascading window will become active.

Reset Layout
When you choose this option, all the non-active tabbed windows will close and only the active
window will remain open on the screen.
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RIBBON

NX offers a user-friendly design interface by providing the Ribbon. The Ribbon comprises
a series of tabs. In tabs, the various tools and options are grouped together based on their
functionality in different groups and galleries. The display of these tabs and their groups depends
upon the environment invoked. The NX Ribbon gives you the ability to customize the interface
for a truly optimized experience. NX-specific extensions such as border bars allow you to add
additional commands around the perimeter of the graphics window. The different environments
and some of their respective tabs and groups are discussed next.

Modeling Environment

The Modeling environment can be invoked by selecting the Model template from the New dialog
box. You can also invoke the Modeling environment from any other opened environment. To
do so, choose Application > Design > Modeling from the Ribbon. Some of the tabs of the
Modeling environment are discussed next.

Home Tab
The Home tab consists of a series of groups and galleries and they are discussed next.

Construction Group
It is one of the most important groups of the Home tab. The tools available in this group are
used to draw and edit sketches, create datum planes, datum axis, datum coordinate system,
and so on. Figure 1-16 shows the Construction group. Figure 1-17 shows the expanded
Construction group.

< ’@’

Datum  Sketch
Plane =

Construction

File Home Construction
v

Datum Drop-down ¥

v 15 Sketch
<> 15 sketd
IJ:, Profile z

Datum  Sketch [ Recangle R
Plane = () circe o
Construction ™ ] Reset Group
Figure 1-16 The Construction group Figure 1-17 Expanded Construction
group

Note that some of the tools such as Fillet, Chamfer, Trim, and Extend are still not available in
the expanded Construction group. To access all these tools, choose the Sketch tool available
in the Construction group; the Create Sketch dialog box will be displayed. The options
available in this dialog box are discussed in later chapters. Select the required sketching
plane and then choose the OK button. The sketching environment will become active and
you will notice that this environment contains all the sketching tools including dimensioning
and geometric constraints arranged in the respective groups, refer to Figure 1-18.
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Figure 1-18 Sketching environment with tools arranged in respective groups

Base Group

The tools in this group are shown in Figure 1-19 and are used to convert a sketch drawn in
the sketching environment into a feature. This group contains sketch-based feature tools
and placed-feature tools. You can create extrude features, revolved features, rib features,
holes, and so on using the tools in this group.

HBYIPIT NG P OO G

Extrude Revolve Hole Unite Subtract Edge Chamfer Draft Shell %MirrorFeature
Blend

Base -

Figure 1-19 The Base group

Synchronous Modeling Group

The Synchronous modeling technology is one of the significant technologies in NX. This
technology is used to modify the parts even if the modeling history is not available. The tools
available in the Synchronous Modeling group are used to modify and improve an existing
design in less time. Figure 1-20 shows the Synchronous Modeling group.

2 E B B
Move Delete Replace Resize Blend

-

Synchronous Modeling
Figure 1-20 The Synchronous Modeling group

Curve Tab

The Curve tab comprises a series of groups and galleries. You can invoke the sketching
environment by using the Sketch tool of this tab. Note that you need to customize the group to
add the Sketch tool to it. Figure 1-21 shows the Curve tab.

Home Curve Surface Assemblies Analy View Selection Render Tools Application
_|_ / A @ @ @ Offset Curve
Point Studio Text Project Intersection » Bridge
Spline Curve Curve
Base T Derived T

Figure 1-21 The Curve tab
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Surface Tab

You can create surface designs in the Modeling environment as well as in the Shape Studio
environment. The Surface tab has the tools to create the surface design. Figure 1-22 shows the
Surface tab.

Home Curve Surface Assemblies Analysis View Selection Render Tools Application
@ O @ @ @ @ @OffsetSurrace ‘& _&S’: ‘@ WTnmandExtend
Extrude Swept Through Through Edge Face @Thicken Combine Trim Extend Sew
Curves  Curve Mesh Blend Blend

Sheet Sheet
Base M Combine T

Figure 1-22 The Surface tab

Tip

Q 1. Some of the tabs are, by default, available in their respective environments. However, you
can add more tabs to an environment. 1o do so, right-click on the Ribbon; a shortcut menu
will be displayed. You will observe that the tools that are not available in the graphics window
are not selected in the shortcut menw. Select any unselected option; it will become available as
a tab in the Ribbon.

2. By default, all tools are not available in a group. Therefore, you may need to customize the
group to add those tools. To customize a group, click on the down arrow at the bottom right
corner of the group; a drop-down will be displayed. Click on the tool to be added or removed
[from the group. Note that a tick mark available on the left of a tool indicates that it is already
added to the group.

Similarly, you can add or remove groups from the Ribbon by using Ribbon Options arrow
available at the bottom right corner of the Ribbon.

Some of the tabs that are available in the Modeling environment and are common to other
environments of NX are discussed next.

Application Tab
Using the Application tab, you can invoke any other environment from the currently invoked
environment. Figure 1-23 shows the Application tab.

Home Curve Surface Assemblies Analysis View Selection Render Tools Application
S XKHd 4 ®
%) 50 -’ n
& 5] s
Modeling Sheet Shape Toolbox More Drafting Toolbox  manufacturing Additive More Electrical Mechanical Toolbox  Gateway Teolbox More
Metal Studio T - T Manufacturing - T T T
Design T Document M Manufacture T Route M Gateway M

Figure 1-23 The Application tab

View Tab

The tools in the View tab, as shown in Figure 1-24, are used for manipulating the views of the
model. The View tab is available in all the environments. Some of the tools in the View tab are
not available in the Drafting environment.
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Figure 1-24 The View tab

Assembly Environment

In NX, you can invoke the assembly environment within the Modeling environment and create
assemblies by using different assembly tools. The tools for assembling components are available
in the Assemblies tab and are discussed next.

Assemblies Tab

The tools that are used to create an assembly are grouped together in the Assemblies tab. The
tools of the Base group available in this tab are used to insert an existing part or assembly in
the current assembly file. You can also create a new component in the assembly file using the
tools in this group. Figure 1-25 shows the tools in this group.

® ® o

Add Mew Mew Parent
Component Component Assembly
Base M

Figure 1-25 The Base group

Drafting Environment

To invoke the Drafting environment, choose Application > Document > Drafting from the
Ribbon. Alternatively, this environment can be invoked by choosing the Drafting button from
the File menu. You can also invoke this environment by using the templates available in the
Drawing tab of the New dialog box. The groups in the Drafting environment are discussed next.

View Group

This group is displayed in the Home tab after invoking the Drafting environment. The tools in
the View group are used to create a new view, generate an orthographic view, section view, and
detail view for a solid part or an assembly. Figure 1-26 shows the View group.

Home

@9 <§§>G Eﬁ} fEh section Line

Base Projected Detail - Section View Ypdate
View View View Views =
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View

Figure 1-26 The View group
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Dimension Group
The tools in the Dimension group are used to generate various dimensions in the drawing views.
Figure 1-27 shows the Dimension group.
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Figure 1-27 The Dimension group
Annotation Group

The tools in the Annotation group are used to generate the GDT parameters, annotations,
symbols, and so on. Figure 1-28 shows the Annotation group.
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Figure 1-28 The Annotation group

Sheet Metal Environment

The tools in the Sheet Metal environment are used to create a sheet metal component.
Figure 1-29 shows the groups and tools of Sheet Metal environment.
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Figure 1-29 ‘lools in the Sheet Metal environment

STATUS BAR

The Status Bar appears at the bottom of the drawing window and comprises of two areas, as
shown in Figure 1-30. These areas are discussed next.

Cue Line Area Status Area

Drag cursor to rotate view about X-Y Rotating view about X-Y

Figure 1-30 The Status Bar

Cue Line Area

The cue line area is the prompt area. In this area, you will be prompted to select the entities
for completing the tool task.
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Status Area

This area displays information about the operations that can be carried out.

HOT KEYS

NX is more popularly known for its icon driven structure. However, you can still use the keys
on the keyboard to invoke some tools. These keys are called hot keys. The hot keys along with
their functions are listed in the table given next.

Hot Key Function

CTRL+Z Invokes the Undo tool

CTRL+Y Invokes the Repeat tool

CTRL+S Saves the current document

F5 Refreshes the Drawing window

F1 Invokes the NX Help tool

F6 Invokes the Zoom tool

F7 Invokes the Rotate tool

CIRL+M Invokes the Modeling environment

CTRL+SHIFT+D Invokes the Drafting environment

COLOR SCHEME

NX allows you to use various color schemes as the background screen color and also for
displaying solid bodies on the screen. To change the background color scheme, choose
Menu > Preferences > Background from the Top Border Bar; the Edit Background dialog
box will be displayed.

Select the Plain radio button from the Shaded Views and Wireframe Views areas. Next, choose
the color swatch available on the right side of the Plain Color option; the Color dialog box
will be displayed. Select the White color swatch from the Color dialog box and choose the OK
button twice to apply the new color scheme to the NX environment.

DIALOG BOXES IN NX )

To create any feature, you need to follow certain steps in an order. These steps are placed in a
top-down order in the dialog boxes. This layout of dialog boxes will help you throughout the
feature creation operation, refer to Figure 1-31.
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Figure 1-31 The layout of the Extrude dialog box

In a dialog box, the current selection step will be highlighted in orange. The required steps are
marked with red asterisks and the completed steps are marked with green check marks. The
advanced options are collapsed and hidden in the rollouts. The button highlighted in green
indicates next default action.

The Reset button is used to reset the dialog box to its initial settings. The Help button provides
you information about the functions of various options listed in the dialog box. The Hide
Collapsed Groups option from the Dialog Options button is used to hide all the collapsed
rollouts to simplify the dialog box. To view all the collapsed rollouts, choose the Show Collapsed
Groups option from the Dialog Options button, which will be available only after choosing the
Hide Collapsed Groups option from the Dialog Options button. The Close button is used to
exit the dialog box.

SELECTING OBJECTS

When no tool is invoked in the current environment, the select mode will be activated. You can
ensure that the select mode is active by pressing the ESC key. In this mode, you can select a wide
range of objects from different environments such as individual features, part bodies, surface
bodies, planar and non-planar faces, sketched entities, sketch and assembly constraints, and
so on by clicking on them. Alternatively, press and hold the left mouse button and drag a box
around the objects; all objects that lie completely inside the box are selected.
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DESELECTING OBJECTS

By default, the selected objects are displayed in orange color. If you want to deselect
any specific object from the selection, press and hold the SHIFT key and click on it; the
object will be deselected. If you want to deselect all the selected entities, press the ESC key.
Alternatively, press and hold the SHIFT key and drag a box around the entities; all the entities
that lie completely inside the box are deselected. Also, you can choose the Deselect All button
from the Selection Group to deselect all the selected entities.

SELECTING OBJECTS USING THE QuickPick DIALOG
BOX

If objects are close to each other, then it may be difficult to select the required object. In such
cases, move the cursor over the object to be selected and wait for two seconds; the cursor will be
changed to ‘+’ sign with three dots. Next, press the left mouse button; the QuickPick dialog box
will be displayed. This dialog box will list all the objects near the selected object in the drawing
window. Move the cursor over the objects listed; the corresponding objects will be highlighted
in the drawing window. Select the required object from the QuickPick dialog box; the specified
object will get selected.

Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this
chapter:

1. The that exists between the environments of NX ensures that any modification
made in the model in one environment is automatically reflected in other environments
immediately.

2. The is a file extension associated with all the files that are created in different

environments of NX.
3. The keeps a track of all the operations that are carried out on the part.

4. The constraint is used to fix a selected entity in terms of its position with respect
to the coordinate system of the current sketch.

5. You can invoke the tool by pressing and holding the middle mouse button.
6. The group is used to generate the GDT parameters, annotations, and symbols.
7. The Modeling environment of NX is a parametric and feature-based environment. (T/F)

8. You can modify an existing design quickly using the Synchronous Modeling tools. (T/F)
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9. The generative drafting technique is used to automatically generate the drawing views of
parts and assemblies. (T/F)

10. By default, the Resource Bar is located on the left side of the NX window. (T/F)

Answers to Self-Evaluation Test
1. bidirectional associativity, 2. prt, 3. Part Navigator, 4. Fixed, 5. Rotate, 6. Annotation, 7. T,
8.1,9.T,10. T



