
Chapter 1

Introduction 

 Learning Objectives 
After completing this chapter, you will be able to:
• Understand different modules of Autodesk Inventor
• Understand how to open a new part file in Autodesk Inventor
• Understand various terms used in Sketching environment
• Understand the usage of various hotkeys
• Customize hotkeys
• Modify the color scheme in Autodesk Inventor
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INTRODUCTION TO Autodesk Inventor 2023
Welcome to the world of Autodesk Inventor. If you are new to the world of three-dimensional 
(3D) design, then you have joined hands with thousands of people worldwide who are already 
working with 3D designs. If you are already using any other solid modeling tool, you will find 
this solid modeling tool more adaptive to your use. You will find a tremendous reduction in the 
time taken to complete a design using this solid modeling tool.

Autodesk Inventor is a parametric and feature-based solid modeling tool. It allows you to convert 
basic two-dimensional (2D) sketch into a solid model using very simple but highly effective 
modeling options. This solid modeling tool does not restrict its capabilities to the 3D solid output 
but also extends them to the bidirectional associative drafting. This means that you only need 
to create the solid model. Its documentation, in the form of the drawing views, is easily done 
by this software package itself. You just need to specify the required view. This solid modeling 
tool can be specially used at places where the concept of “collaborative engineering” is brought 
into use. Collaborative engineering is a concept that allows more than one user to work on the 
same design at the same time. This solid modeling package allows more than one user to work 
simultaneously on the same design.

As a product of Autodesk, this software package allows you to directly open the drawings of 
the other Autodesk software like AutoCAD, Mechanical Desktop, AutoCAD LT, and so on. This 
interface is not restricted to the Autodesk software only. You can easily import and export the 
drawings from this software package to any other software package and vice versa.

To reduce the complicacies of design, this software package provides various design environments. 
This helps you capture the design intent easily by individually incorporating the intelligence of 
each of the design environments into the design. The design environments that are available 
in this solid modeling tool are discussed next.

Part Module
This is a parametric and feature-based solid modeling environment and is used to create 
solid models. The sketches for the models are also drawn in this environment. All applicable 
constraints are automatically applied to a sketch while drawing. You do not need to invoke an 
extra command to apply them. Once the basic sketches are drawn, you can convert them into 
solid models using simple but highly effective modeling options. One of the major advantages 
of using Autodesk Inventor is the availability of the Design Doctor. The Design Doctor is used 
to calculate and describe errors, if any, in the design. You are also provided with remedy for 
removing errors such that the sketches can be converted into features. The complicated features 
can be captured from this module and can later be used in other parts. This reduces the time 
taken to create the designer model. These features can be created using the same principles as 
those for creating solid models.

Assembly Module
This module helps you create the assemblies by assembling multiple components using 
assembly constraints. This module supports both the bottom-up approach as well as the 
top-down approach of creating assemblies. This means that you can insert external components 
into the Assembly module or create the components in the Assembly module itself. You are 
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allowed to assemble the components using the smart assembly constraints and joints. All the 
assembly constraints and joints can be added using a single dialog box. You can even preview the 
components before they are actually assembled. This solid modeling tool supports the concept 
of making a part or a feature in the part adaptive. An adaptive feature or a part is the one that 
can change its actual dimensions based upon the need of the environment.

Presentation Module
A major drawback of most solid modeling tools is their limitation in displaying the working of 
an assembly. The most important question asked by customers in today’s world is how to show 
the working of any assembly. Most of the solid modeling tools do not have an answer to this 
question. This is because they do not have proper tools to display an assembly in motion. As a 
result, the designers cannot show the working of the assemblies to their clients or they have to 
take the help of some other animation software packages. However, this software package provides 
a module called the Presentation module using which you can animate the assemblies created 
in the Assembly module and view their working. You can also view any interference during the 
operation of the assembly. The assemblies can be animated using easy steps.
	

Drawing Module
This module is used for the documentation of the parts or assemblies in the form of drawing 
views. You can also create drawing views of the presentation created in the Presentation module. 
All parametric dimensions added to the components in the Part module during the creation of 
the parts are displayed in the drawing views in this module.

Sheet Metal Module
This module is used to create a sheet metal component. You can draw the sketch of the base 
sheet in this Sketching environment and then proceed to the sheet metal module to convert it 
into a sheet metal component.

Mold Design Module
This module is used to create mold design by integrated mold functionality and content libraries 
using the intelligent tools and catalogs provided in mold design module. In this module, you 
can quickly generate accurate mold design directly from digital prototypes. 

GETTING STARTED WITH Autodesk Inventor           
Install Autodesk Inventor on your system; a shortcut icon of Autodesk Inventor Professional 2023 
will automatically be created on the desktop. Double-click on this icon; the initial interface of 
Autodesk Inventor Professional 2023 will be displayed, as shown in Figure 1-1. 
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Figure 1-1  Initial interface of Autodesk Inventor Professional 2023

By using the tools available in the initial interface of Autodesk Inventor, you can view the recent 
enhancements and information related to Autodesk Inventor 2023, start new file, open an 
existing file, set a project, and so on. To view the enhancements and related information, choose 
the What’s New button available in the left pane of the initial interface of the Inventor. You will 
learn more about the Ribbon and respective tabs and tools available in it later in this chapter. 

To start a new file, choose the New button from the left pane of the initial interface of the 
Inventor; the Create New File dialog box will be displayed, as shown in Figure 1-2. This dialog 
box is used to start a new file of Autodesk Inventor. Choose the Metric tab from the Create New 
File dialog box and then double-click on the Standard (mm).ipt template to open the default 
metric template. As a result, a new part file with the default name, Part1.ipt, will be opened, refer 
to Figure 1-3 and you can start working in this file. The figure also displays various components 
of the interface. 
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Figure 1-2  The Create New File dialog box

It is evident from Figure 1-3 that the interface of Autodesk Inventor is quite user-friendly. Apart 
from the components shown in Figure 1-3, you are also provided with various shortcut menus 
which are displayed on right-clicking in the drawing area. The type of the shortcut menu and 
its options depend on where or when you are trying to access the menu. For example, when you 
are inside any command, the options displayed in the shortcut menu will be different from the 
options displayed when you are not inside any command. The different types of shortcut menus 
will be discussed when they are used in the textbook.

Figure 1-3   Components of Autodesk Inventor interface
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Quick Access Toolbar
This toolbar is common to all the design environments of Autodesk Inventor. However, some of 
these options will not be available when you start Autodesk Inventor for the first time. You need 
to add them using the down arrow given on the right of the Quick Access Toolbar, as shown 
in Figure 1-4. Some of the important options in this toolbar are discussed next.

Figure 1-4  The Quick Access Toolbar

Select
Select tools are used to set the selection priority. If you  click on the

Figure 1-5  The Selection 
drop-down list

 
down arrow on the right of the active select tool, a selection 
drop-down list will be displayed, refer to Figure 1-5. The Select 
Bodies tool is chosen to set the selection priority for bodies. If this 
tool is chosen, you can select any individual body in the model. If 
you choose the Select Features tool, you can select any feature in 
the model. The Select Faces and Edges tool is chosen to set the 
priority for faces and edges. The Select Sketch Features tool is chosen 
to set the priority for the sketched entities. The Select Groups and 
Select Wires tools will be activated in their respective environments 
when the different groups and wires become available.

Return
This tool is activated in the sketching environment and is used to exit from the sketching 
environment. Once you have finished drawing a sketch, choose this tool to proceed to the Part 
module. In the Part module, you can convert the sketch into a feature using the required tools. 

Note
If the Return tool is not available in the Quick Access Toolbar, you can add it. To do so, click 
on the down arrow on the right of the Quick Access Toolbar; a flyout is displayed. Next, choose 
the Return option from the flyout.

Update/Local Update
This tool is chosen to update a design after modifying.
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Appearance
You can use this drop-down list to apply different types of colors or styles to the selected features 
or component to improve its appearance. It is much easier to identify different components, 
parts, and assemblies when proper color codes are applied to them.

Material Drop-down List
You can use the options in this drop-down list to apply different types of materials to the selected 
features or component.

RIBBON AND TABS
You might have noticed that there is no command prompt in Autodesk Inventor. The complete 
designing process is carried out by invoking the commands from the tabs in the Ribbon. The 
Ribbon is a long bar available below the Quick Access Toolbar. You can change the appearance 
of the Ribbon as per your need. To do so, right-click on it; a shortcut menu will be displayed. 
Choose Ribbon Appearance from this shortcut menu to invoke a cascading menu. Next, choose 
the required option from the cascading menu. 

Autodesk Inventor provides you with different tabs while working with various design 
environments. This means that the tabs available in the Ribbon while working with the Part, 
Assembly, Drawing, Sheet Metal, and Presentation environments will be different.

In addition to the default tools available in a tab, you can also customize the tab by adding 
more tools. To do so, choose the Customize button from the Options panel of the Tools tab in 
the Ribbon; the Customize dialog box will be displayed. Make sure that the Ribbon tab of the 
dialog box is chosen. Next, select the All Commands option from the Choose commands from 
drop-down list, if not selected by default; a list of all the commands/tools will be displayed on 
the left hand side in the dialog box. Next, select the required tool to be added from the list and 
then from the Choose tab to add custom panel to drop-down list, select the required tab to which 
the selected tool is to be added. Next, choose the Add button which is represented as double 
arrows and then choose the Apply button to add the tool. Similarly, you can add multiple tools 
to the required tab of the Ribbon. Once you are done, close the OK button to exit the dialog box.

Tip
In Autodesk Inventor, the messages and prompts are displayed at the Status Bar which is 
available at the lower left corner of the Autodesk Inventor window.

    

Sketch Tab
This is one of the most important tabs in the Ribbon. All the tools for creating the sketches of 
the parts are available in this tab.  Most of the tools of the tab will be available on invoking the 
sketching environment. The Sketch tab is shown in Figure 1-6.

Figure 1-6  The Sketch tab
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Inventor Precise Input Toolbar
Inventor provides you with the Inventor Precise Input toolbar to enter precise values for 
the coordinates of the sketch entities. This toolbar is also available in the Drawing and 
Assembly modules. The Inventor Precise Input toolbar is shown in Figure 1-7. Note that this 
toolbar is not available by default. You will learn more about this toolbar in Chapter 2.

Figure 1-7  The Inventor Precise Input toolbar

3D Model Tab
This is the second most important tab provided in the Part module. Once the sketch is completed, 
you need to convert it into a feature using the modeling commands. This tab  provides all the 
modeling tools that can be used to convert a sketch into a feature. The tools in the 3D Model 
tab are shown in Figure 1-8. 

Figure 1-8  The 3D Model tab

The Start 2D Sketch button in the Sketch panel of the 3D Model tab is used to invoke the 
sketching environment to draw 2D sketch. As the first feature in most of the designs is a sketched 
feature, therefore you first need to create the sketch of the feature to be created. Once you have 
completed a sketch, you can choose either the Finish Sketch button from the Exit panel of the 
Sketch tab in the Ribbon or the Return button from the Quick Access Toolbar. 

Sheet Metal Tab
This tab provides the tools that are used to create sheet metal parts. This toolbar will be available 
only when you are in the sheet metal environment. You can switch from the Modeling environment 
to the Sheet Metal environment by choosing the Convert to Sheet Metal tool from the Convert 
panel of the 3D Model tab in the Ribbon. If the Convert panel is not available in the 3D Model 
tab, you need to customize to add it. You will learn more about customizing later in this book. 
The tools in the Sheet Metal tab are shown in Figure 1-9.

Figure 1-9  The Sheet Metal tab
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Assemble Tab
This tab will be available only when you open any assembly template (with extension .iam) from the 
Create New File dialog box. This tab provides you all the tools that are required for assembling 
components. The tools in the Assemble tab are shown in Figure 1-10.

Figure 1-10  The Assemble tab

Place Views Tab
This tab provides the tools that are used to create different drawing views of the components. 
This tab will be available only when you are in the Drafting environment. The tools in the Place 
Views tab are shown in Figure 1-11. 

Figure 1-11  The Place Views tab

Presentation Tab
This tab provides the tools that are used to create different presentation views of the components. 
This tab will be available only when you open any presentation template (with extension .ipn) 
in the Create New File dialog box. The tools in the Presentation tab are shown in Figure 1-12.

Figure 1-12  The Presentation tab

Tools Tab
This tab contains tools that are mainly used for setting the preferences and customizing the 
Autodesk Inventor interface. This tab is available in almost all the environments. The tools in 
the Tools tab are shown in Figure 1-13.

Figure 1-13  The Tools tab

View Tab
The tools in this tab enable you to control the view, orientation, appearance, and visibility of 
objects and view windows. This tab is available in almost all the environments. The tools in the 
View tab are shown in Figure 1-14.

Figure 1-14  The View tab



1-10	             		                           Autodesk Inventor Professional 2023 for Designers
  
  
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

The tools of a particular tab are arranged in different panels in the Ribbon. Some of the panels 
and tools have an arrow on the right, refer to Figure 1-15. These arrows are called down arrows. 
When you choose these down arrows, some more tools will be displayed in the drop-downs, see 
Figure 1-15.

Figure 1-15  More tools displayed on choosing the down arrow on the right of a tool in the 
Ribbon

Navigation Bar
The Navigation Bar is located on the right of the graphics 

Figure 1-16  The Navigation Bar

window and contains tools that are used to navigate the 
model in order to make the designing process easier and 
quicker. The navigation tools also help you to control the 
view and orientation of the components in the drawing 
window. The Navigation Bar is shown in Figure 1-16.

Browser Bar
The Browser Bar is available below the Ribbon, on the 
left in the drawing window. It displays all the operations 
performed during the designing process in a sequence. All 
these operations are displayed in the form of a tree view. 
You can undock the Browser Bar by dragging it. The contents of the Browser Bar are different 
for different environments of Autodesk Inventor. For example, in the Part module, it displays 
various operations that were used in creating the part. Similarly, in the Assembly module, it 
displays all the components along with the constraints that were used to assemble them.

Search Tool
The Search tool is available at the top of the Browser Bar,

Figure 1-17  The Search tool

refer to Figure 1-17. This tool is used to search fields such as 
Features, File nodes (both collapsed and expanded), Parts, 
Constraints, and so on.
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UNITS FOR DIMENSIONS
In Autodesk Inventor, you can set units at any time by using the Document Settings dialog 
box. You can invoke this dialog box by choosing the Document Settings tool from the Options 
panel in the Tools tab. After invoking this dialog box, choose the Units tab in the dialog box; 
various areas related to the units will be displayed. The options in the Units area are used to 
set the units. To set the unit for linear dimension, select the required unit from the Length 
drop-down. Similarly, to set the unit for angular dimension, select the required unit from the 
Angle drop-down. Next, choose the OK button to apply the specified settings and close the 
dialog box. If you want to apply the specified settings without closing the dialog box, choose 
the Apply button. If you choose the Apply button, the OK button is replaced by Close. Now, 
you can choose the Close button to close the dialog box.

IMPORTANT TERMS AND THEIR DEFINITIONS
Before you proceed with in Autodesk Inventor, it is very important for you to understand the 
following terms widely used in this book.

Feature-based Modeling
A feature is defined as the smallest building block that can be modified individually. In Autodesk 
Inventor, the solid models are created by integrating a number of building blocks. Therefore, 
the models in Autodesk Inventor are a combination of a number of individual features. These 
features understand their fit and function properly. As a result, these can be modified whenever 
required. Generally, these features automatically adjust their values if there is any change in 
their surroundings.  

Parametric Modeling
The parametric nature of a software package is its ability to use the standard properties or 
parameters to define the shape and size of a geometry. The main function of this property is 
to derive the selected geometry to a new size or shape without considering its original size or 
shape. For example, a line of 20 mm that was initially drawn at an angle of 45 degrees can be 
derived to a line of 50 mm and its orientation can be changed to 90°. This property makes the 
designing process very easy as now you can draw a sketch with some relative dimensions and 
then can use this solid modeling tool to drive to the required actual values.

Bidirectional Associativity
As mentioned earlier, this solid modeling tool does not restrict its capabilities to the 3D solid 
output. It is also capable of highly effective assembly modeling, drafting, and presentations. 
There exists a bidirectional associativity between all these environments of Autodesk Inventor.  
This link ensures that if any modification is made in the model in any of the environments, it 
is automatically reflected in the other environments as well.

Adaptive
This is a highly effective property that is included in the designing process of this solid 
modeling tool. In any design, there are a number of components that can be used in various 
places with a small change in their shape and size. This property makes the part or the feature 
adapt to its environment. It also ensures that the adaptive part changes its shape and size as 
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soon as it is constrained to other parts. This considerably reduces the time and effort required 
in creating similar parts in the design.

Design Doctor
The Design Doctor is one of the most important parts of the designing process used in the 
Autodesk Inventor software. It is a highly effective tool to ensure that the entire design process 
is error free. The main purpose of the Design Doctor is to make you aware of any problem in 
the design. The Design Doctor works in the following three steps:

Selecting the Model and Errors in the Model
In this step, the Design Doctor selects the sketch, part, assembly, and so on and determines the 
errors in it.

Examining Errors
In this step, it examines the errors in the selected design. Each of the errors is individually 
examined.

Providing Solutions for Errors
This is the last step of the working of the Design Doctor. Once it has individually examined each 
of the errors, it suggests solutions for them. It provides you with a list of methods that can be 
utilized to remove the errors from the design.

Constraints
These are the logical operations that are performed on the selected design to make it more 
accurate or to define its position with respect to some other design. There are four types of 
constraints in Autodesk Inventor. All these types are explained next.

Geometric Constraints
These logical operations are performed on the basic sketch entities to relate them to the standard 
properties like collinearity, concentricity, perpendicularity, and so on. Autodesk Inventor 
automatically applies these geometric constraints to the sketch entities at the time of their 
creation. You do not have to use an extra command to apply these constraints on to the sketch 
entities. However, you can also manually apply these geometric constraints on to the sketch 
entities. There are twelve types of geometric constraints.

Perpendicular Constraint
This constraint is used to make the selected line segment normal to another line segment.

Parallel Constraint
This constraint is used to make the selected line segments parallel.

Coincident Constraint
This constraint is used to make two points or a point and a curve coincident.



Introduction								                 1-13

  
  
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Concentric Constraint
This constraint forces two selected curves to share the same center point. The curves that 
can be made concentric are arcs, circles, or ellipses.

Collinear Constraint
This constraint forces two selected line segments or ellipse axes to be placed in the same line.

Horizontal Constraint
This constraint forces the selected line segment to become horizontal.

Vertical Constraint
This constraint forces the selected line segment to become vertical.

Tangent 
This constraint is used to make the selected line segment or curve tangent to another curve.

Equal
This constraint forces the selected line segments to become equal in length. It can also be 
used to force two curves to become equal in radius.

Smooth
This constraint adds a smooth constraint between a spline and another entity so that at the 
point of connection, the line is tangent to the spline.

Fix
This constraint fixes the selected point or curve to a particular location with respect to the 
coordinate system of the current sketch.

Symmetric
This constraint forces the selected sketched entities to become symmetrical about a sketched 
line segment which may or may not be a center line.

Assembly Constraints
The assembly constraints are logical operations performed on the components in order to bind 
them together to create an assembly. These constraints are applied to reduce the degrees of 
freedom of the components. There are five types of assembly constraints which are discussed next.

Mate
This assembly constraint is used to make selected faces of different components coplanar. 
The model can be placed facing the same direction or the opposite direction. You can also 
specify some offset distance between the selected faces.

Angle
This assembly constraint is used to place the selected faces of different components at some 
angle with respect to each other.
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Tangent
This assembly constraint is used to make the selected face of a component tangent to the 
cylindrical, circular, or conical faces of the other component.

Insert
This assembly constraint forces two different circular components to share the orientation 
of the central axis. It also makes the selected faces of the circular components coplanar.

Symmetry
This assembly constraint is used to make two selected components symmetric to each other 
about a symmetric plane so that both components remain equidistant from the plane.

Assembly Joints
The assembly joints are the logical operations performed on the components in order to join them 
together to create an assembly. These joints allow motion between the connected components 
or in the assembly. There are seven types of assembly joints which are discussed next.

Automatic
The Automatic joint is used to automatically apply best suitable type of joints between the 
connecting components of the assembly. The type of joint to be applied automatically will 
depend upon the selected geometry.

Rigid
The Rigid joint removes all the degrees of freedom from the component. As a result, the 
components after applying rigid joints can not move in any direction. The Rigid joint is 
used to fix two parts rigidly. All the DOFs between the selected parts get eliminated and act 
as a single component when any motion will be applied to any of the direction.

Rotational
The Rotational joint allows the rotational motion of a component along the axis of a 
cylindrical component.  

Slider 
The Slider joint allows the movement of a component along a specified path. The component 
will be joined to translate in one direction only. You can specify only one translation degree 
of freedom in slider joint. Slider joint are used to simulate the motion in linear direction.

Cylindrical
The Cylindrical joint allows a component to translate along the axis of a cylindrical 
component as well as rotate about the axis. You can specify one translation degree of freedom 
and one rotational degree of freedom in the Cylindrical joint.  

Planar
The Planar joint is used to connect the planar faces of two components. The components 
can slide or rotate on the plane with two translation and one rotational degree of freedom.
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Ball
The Ball joint is used to create a joint between two components such that both the components 
remain in touch with each other and at the same time the movable component can freely 
rotate in any direction. To create a ball joint between two components, you need to specify 
one point from each component. The joints thus created will generate three undefined 
rotational DOFs and restrict the other three DOFs at a common point.

Motion Constraints
The motion constraints are the logical operations performed on the components that are 
assembled using the assembly constraints. There are two types of motion constraints that are 
discussed next. 

Rotation
The Rotation constraint is used to rotate one component of the assembly in relation to the 
other component. 

Rotation-Translation
The Rotation-Translation constraint is used to rotate the first component with respect to 
the translation of the second component.

Transitional Constraints
The transitional constraints are also applied on the assembled components and are used to 
ensure that the selected face of the cylindrical component maintains contact with the selected 
faces of the other component when you slide the cylindrical component.

UCS to UCS Constraint
This constraint is used to constrain two components together by their UCSs.
 

Consumed Sketch
A consumed sketch is a sketch that is utilized in creating a feature using tools such as Extrude, 
Revolve, Sweep, Loft, and so on.

STRESS ANALYSIS ENVIRONMENT
In Autodesk Inventor Professional, you are provided with stress analysis environment which is an 
analysis tool to execute the static and model stress analysis. You can calculate the displacement 
and stresses developed in a component with the effect of material and various loading conditions 
applied on a model. A component fails when the stress applied on it goes beyond a permissible 
limit. Figure 1-18 shows the Displacement plot of leaf spring designed in Autodesk Inventor 
and analyzed using the analysis tools.



1-16	             		                           Autodesk Inventor Professional 2023 for Designers
  
  
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 1-18  The resultant model with displacement

 

SELECT OTHER BEHAVIOR 
While working on the complicated models, sometimes

Figure 1-19  Selecting the entities from 
the Select Other flyout	

 
you may need to select the entities that are not visible in 
the current view or are hidden behind other entities. To 
do so, Autodesk Inventor  provides you with the Select 
Other feature automatically displayed when you hover 
the cursor at a point where more than one entity is 
available. To select any entity, click on the down arrow; a 
flyout will be displayed. Select the desired entity from the 
flyout; the selected entity will be displayed in blue. 
Figure 1-19 shows the Select Other flyout displayed in 
the modelling environment. You can use this tool in all 
the modes and environments of Autodesk Inventor.

HOTKEYS
As mentioned earlier, there is no command prompt in Autodesk Inventor. However, you can 
use the keys on the keyboard to invoke some tools. The keys that can be used to invoke the tools 
are called hotkeys. Remember that the working of the hotkeys will be different for different 
environments. The use of hotkeys in different environments is given next.

Part Module
The hotkeys that can be used in the Part module and their functions are given next.

Hotkey Function

E Invokes the Extrude tool

R  Invokes the Revolve tool
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H Invokes the Hole tool

CTRL+SHIFT+L Invokes the Loft tool

CTRL+SHIFT+S Invokes the Sweep tool

F Invokes the Fillet tool

CTRL+SHIFT+K Invokes the Chamfer tool

CTRL+SHIFT+M Invokes the Mirror tool

CTRL+SHIFT+R Invokes the Rectangular Pattern tool

CTRL+SHIFT+O Invokes the Circular Pattern tool

F6 Invokes the Home view

] Invokes the Work Plane tool

/ Invokes the Work Axis tool

. Invokes the Work Point tool

CTRL+W Invokes the SteeringWheels
          
The following hotkeys are used in the Sketching environment:

Hotkey Function

L  Invokes the Line tool

D Invokes the Dimension tool

X Invokes the Trim tool

F7 Invokes the Slice Graphics tool

F8 Displays all constraints

F9 Hides all constraints
                     

Assembly Module
In addition to the hotkeys of the part modeling tool, the following hot keys can also be used in 
the Assembly module:

Hotkey Function

P  Invokes the Place tool

N Invokes the Create tool

C  Invokes the Constrain tool

V Invokes the Free Move tool

G Invokes the Free Rotate tool
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Drawing Module
The hotkeys that can be used in the Drawing module are given next.

Hotkey Function

B Invokes the Balloon tool

D Invokes the Dimension tool

O Invokes the Ordinate Set tool

F Invokes the Feature Control Frame tool

In addition to these keys, you can also use some other keys for the ease of designing. Note that 
you will have to hold some of these keys down and use them in combination with the pointing 
device. These hotkeys are given next.

Hotkey Function

F1 Invokes the Help command

F2 Invokes the Pan tool

F3 Invokes the Zoom tool

F4 Invokes the Free Orbit tool

F5 Displays the previous view

SHIFT+F5 Displays the next view 

ESC Aborts the current command

SPACEBAR Invokes the recently used tool

T (In Presentation module) Invokes the Tweak Components tool

Customizing Hotkeys
You can customize the settings of hotkeys. To do so, choose the Customize tool from the Options 
panel of the Tools tab in the Ribbon; the Customize dialog box will be displayed. Next, choose 
the Keyboard tab; a list of all the available commands will be displayed, as shown in Figure 1-20. 
The options corresponding to the Keyboard tab are discussed next.
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Figure 1-20  The Customize dialog box displaying various commands in the Keyboard tab

Categories
Select the required category of command from this drop-down list; the commands related to 
the selected category will be listed in the list box.

Filter
You can further shortlist the displayed commands from this drop-down list. If you select the 
All option, all the commands related to the selected category will be displayed. If you select 
the Assigned option, then the commands to which the hotkeys are assigned will be displayed. 
Similarly, if you select the Unassigned option, then the commands to which the hotkeys are 
not assigned will be displayed.

List Box
The list box has four columns: Keys, Command Name, Type, and Category. The Key column 
displays the hotkeys assigned to the commands. The name of the command, its type, and 
category will be listed in the Command Name, Type, and Category columns, respectively. To 
assign hotkeys to a tool, click in the Keys column that is associated to the command; an edit 
box will be displayed. In this edit box, enter the shortcut key that you want to assign. To accept 
the settings, press the Enter key. Else, click on the cross-mark provided next to the tick-mark.

Reset All Keys
The Reset All Keys button is used to remove all the customized hotkeys and restore the default 
hotkeys.
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Copy to Clipboard
Choose this button to copy the contents of the Keyboard tab and paste them to other document.  

Import
Choose this button to restore the customized settings from the .xml format. Note that before 
importing the file, all the Autodesk Inventor files must be closed. 

Export 
Choose this button to save the customized settings in the .xml format. Make sure that all the 
Autodesk Inventor files are closed before choosing this button.
  
Close
Choose this button to close the Customize dialog box.  

CREATING THE SKETCH
After starting Autodesk Inventor, you can start creating model

Figure 1-21  Tools in the Sketch 
drop-down

 
in the Part environment. But before creating the model, you 
need to create its sketch in the Sketching environment. To do 
so, choose the Start 2D Sketch tool from the Sketch drop-down 
in the Sketch panel of the 3D Model tab, see Figure 1-21. On 
choosing this tool, the Sketching environment is invoked and 
you can create 2D sketches. If you choose the Start 3D sketch 
tool from the Sketch panel, you can create 3D sketches.	

MARKING MENU 	
Marking menu is a type of menu that consists of tools and options which are commonly used in 
Autodesk Inventor software in different environments. Marking menu replaces the conventional 
right-click context menu. The Marking menu consists of different tools in different environments. 
For example, in the Sketching environment, the Marking menu consists of commonly used tools 
such as Create Line, Two Point Rectangle, Done [ESC], Trim, General Dimensions, and so 
on. In the Modeling environment, it consists of tools and options such as Extrude, Fillet, Hole, 
New Sketch, and so on.
 
You can invoke a tool in Marking menu by using two modes: Marking mode and Menu mode. To 
invoke the Marking menu using the Menu mode, right-click anywhere in the graphic window; all 
the menu items surrounding the cursor will be displayed. After invoking the Marking menu, you 
can choose the desired tool or option from it. To do so, move the cursor toward the desired tool; 
the tool is highlighted along with a marker ray. Next, choose the highlighted tool to invoke it. 

The other mode, Marking mode, is also known as gesture behavior. It helps you to mark a trail 
and choose the desired tool. To choose a tool in the Marking mode, right-click and drag the 
cursor immediately in the direction of the desired tool.

Figure 1-22 shows a Marking menu invoked in the Sketching environment and Figure 1-23 shows 
a Marking menu which is invoked in the Modeling environment.
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Figure 1-22  Marking menu available 
in the Sketching environment

Figure 1-23  Marking menu available in the 
Modeling environment

Tip
You can modify the tools listed in the Marking menu. You can also turn the Marking menu 
feature on or off  using the options in the User Interface flyout in the Windows panel of the 
View tab in the Ribbon.

COLOR SCHEME
Autodesk Inventor allows you to use various color schemes to set the background color of the 
screen and for displaying the entities on the screen. Note that this book uses the Presentation 
color scheme with a single color background. To change the color scheme, choose the Application 
Options tool from the Options panel of the Tools tab in the Ribbon; the Application Options 
dialog box will be displayed. Choose the Colors tab to display the predefined colors. Next, select 
the Presentation option from the In-canvas Color Scheme list box in the Colors tab. Select 1 
Color from the drop-down list in the Background area, refer to Figure 1-24. Choose Apply to 
apply the color scheme to the Autodesk Inventor environment, and then choose Close. Note 
that all the files you open henceforth will use this color scheme.
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Figure 1-24  The Application Options dialog box with the required 
options set in the Colors tab

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 You can invoke the Line tool by using the __________ hotkey.

2.	 Press __________ to invoke the recently used tool.

3.	 Choose the __________ button from the Customize dialog box to restore the customized 
settings in the .xml format.

4.	 When you start a new session of Autodesk Inventor Professional 2023, only the Start a new 
file button will be available in the Quick Launch area of the Open dialog box. (T/F)

5.	 The Inventor Precise Input toolbar is used to specify the precise values for the coordinates 
of the sketch entities. (T/F) 

6.	 The tools in the 3D Model tab enable you to control the view, orientation, appearance, and 
visibility of objects and view windows. (T/F)
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 Review Questions  
Answer the following questions:

1.	 You can use the __________ drop-down list to apply different types of colors or styles to the 
selected feature or component to improve its appearance. 	

2.	 You can invoke the Analyze Interference tool from the Assembly module by pressing the 
__________ key. 

3.	 You change the color scheme by choosing the __________tool from the Options panel of 
the Tools tab in the Ribbon.

4.	 There are twelve types of geometric constraints in Autodesk Inventor. (T/F)

5.	 Design Doctor works in five steps. (T/F)

6.	 You can invoke the Trim tool by pressing the X key. (T/F)
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Answers to Self-Evaluation Test
1. L, 2. SPACEBAR, 3. Import, 4. T, 5. F, 6. F


