
Chapter 2

Sketching, 
Dimensioning, and 

Creating Base Features 
and Drawings

 Learning Objectives 
After completing this chapter, you will be able to:
• Start a new template file to draw sketches
• Set up the sketching environment
• Use various drawing display tools
• Understand the sketcher environment in the Part module
• Get acquainted with sketcher entities
• Specify the position of entities by using dynamic input
• Draw sketches by using various sketcher entities
• Delete sketched entities
• Dimension a sketch
• Extrude a sketch
• Generate drawing views
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THE SKETCHING ENVIRONMENT
Most of the designs created in Autodesk Inventor consist of sketched and placed features. A 
sketch is a combination of a number of two-dimensional (2D) entities such as lines, arcs, circles, 
and so on. The features such as extrude, revolve, and sweep that are created by using 2D sketches 
are known as sketched features. The features such as fillet, chamfer, thread, and shell that are 
created without using a sketch are known as placed features. In a design, the base feature or the 
first feature is always a sketched feature. For example, the sketch shown in Figure 2-1 is used 
to create the solid model shown in Figure 2-2. In this figure, the fillets and chamfers are the 
placed features.

Figure 2-1  The basic sketch for the solid model Figure 2-2  A solid model created using 
the sketched and 3D model features

Once you have drawn the basic sketch, refer to Figure 2-1, you need to convert it into a solid 
model using solid modeling tools.

You can create sketches in the Sketching environment. This environment of Autodesk Inventor 
can be invoked any time in the Part or Assembly module. Unlike other solid modeling programs, 
here you just need to invoke the Start 2D Sketch tool and specify the plane to draw sketch, the 
Sketching environment will be invoked. You can draw a sketch in this environment and then 
proceed to the part modeling environment for converting the sketch into a solid model. The 
options in the Sketching environment will be discussed later in this chapter.

Initial Interface of Autodesk Inventor
When you start Autodesk Inventor, the initial interface is displayed with the Tools tab chosen 
by default, as shown in Figure 2-3. The Options panel in this tab contains options such as 
Application Options, Document Settings, Migrate Settings, Autodesk App Manager, Highlights 
New, Customize, Add-Ins, and so on. The Application Options option is used to customize 
the Inventor interface and options by specifying different settings in the Application Options 
dialog box displayed on choosing this option. The Document Settings option is used to set 
the document parameters such as active styles, measurement units, and sketch and modeling 
preferences. Autodesk App Manager is used to view and update the installed Autodesk app. 
The Highlight New option is used to display badges over those commands in the Ribbon that 
have been added or updated in the current release. The Customize option is used to customize 
the Ribbon, Marking menu, and hot keys. By choosing the Content Center Editor option, 
you can customize the standard content copied to the user library or edit the user-published 
content. The Batch Publish option is used to publish a set of parts to the user content library 
in batches. The Supplier Content option is used to connect to the Autodesk Manufacturing 
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Community Supplier Content Center. Click on the Inventor Ideas option to connect to the 
Inventor ideas discussion group where you can share your ideas to improve the product quality 
with developer. The i Logic Design Copy option is used to copy the design containing i 
Logic rules. The Team Web option allows you to connect to a website or HTML file for easy 
access. You need to specify the respective website or HTML file link in the Team WEB area of  
the File tab in the Application Options dialog box. 

Figure 2-3  The initial interface of Autodesk Inventor Professional 2023

Starting a New File 
 In Autodesk Inventor, you can start a new file by choosing the New button from the left 
pane of the initial interface. On choosing this button, the Create New File dialog box 

will be displayed, refer to Figure 2-4. Alternatively, you can start a new file by choosing the New 
tool from the Quick Access Toolbar or by choosing the Start a new file button from the Open 
dialog box. You will learn more about the Open dialog box later in this chapter.
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Figure 2-4  The Create New File dialog box with the Metric node selected

The options in the Create New File dialog box are used to select a template file for starting a 
design. You can select a template of English, Metric, or Mold Design standard. To start a new 
metric part file, select the Metric option that is available under the Templates node of the 
dialog box, refer to Figure 2-4. The templates that are available on selecting the Metric option 
are discussed next. 

.ipt Templates 
Select any .ipt template to start a new part file for creating a solid model or a sheet metal 
component. 

.iam Templates
Select a .iam template to start a new assembly file for assembling various parts. Note that if you 
select the Weldment.iam template, the Weldment module of Autodesk Inventor will be started. 

.ipn Templates
Select a .ipn template to start a new presentation file for animating the assembly. The 
Presentation module marks the basic difference between the Autodesk Inventor and other design 
tools. This module allows you to animate the assemblies created in the Assembly module. For 
example, you can create a presentation in the Presentation module that shows a Drill Press Vice 
assembly in motion. 

.idw Templates
Select a .idw template to start a new drawing file for generating the drawing views. You can use 
the drawing templates of various standards that are provided in this tab, such as ANSI, ISO, 
DIN, GB, JIS, GOST, and BSI.
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.dwg Templates
Select a .dwg template for creating AutoCAD drawing files. You can use the drawing templates of 
standards such as JIS, ISO, GB, DIN, BSI, and ANSI.

The Project File drop-down list in the Create New File dialog box displays the active project 
in which the new file has been started. The Projects dialog box can be invoked by choosing the 
Projects button from the Create New File dialog box.

The Open Dialog Box
The Open dialog box is used to open an existing file. To invoke this dialog box, choose the Open 
button from the left pane of the initial interface. The Open dialog box is shown in Figure 2-5. 

Figure 2-5  The Open dialog box

The options in the Open dialog box are used to open existing files. You can browse and 
select the file that you want to open. A preview of the selected file is displayed in the preview 
window located at the lower left portion in this dialog box, as shown in Figure 2-6. By default, 
you can open any file created in Autodesk Inventor as the Autodesk Inventor Files (*.iam; 
*.dwg, *.idw,*.ipt, *.ipn, and *.ide) option is selected in the Files of type drop-down list. 
You can also open the files created in other solid modeling programs such as AutoCAD, 
Pro/ENGINEER and Creo Parametric, Alias, CATIA V5, SOLIDWORKS, NX, and so on by 
selecting the respective options from the Files of type drop-down list. 
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Figure 2-6  The Open dialog box showing the preview of the selected file

In addition to open an existing file, you can also start new files and setup a project by using the 
Open dialog box. To create a new file, choose the Start a new file button from this dialog box. On 
choosing this button; the Create New File dialog box will be displayed, as shown in Figure 2-7. 

Figure 2-7  The Create New File dialog box

By using the Open dialog box, you can also invoke the Projects dialog box to setup a new 
project. To invoke the Projects dialog box, choose the Projects button available on the right 
of the Project File drop-down list in the Open dialog box. You will learn more about setting a 
project later in this chapter.
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Setting a New Project 
In Autodesk Inventor, a project defines all the files related to a design project you are working 
on. To create a new project or retrieve an existing project, choose the Projects and Settings  
button in the left pane of initial interface and then click on  the Settings option from the menu 
displayed. On doing so, the Projects dialog box will be displayed, as shown in Figure 2-8. In 
this dialog box, all the project folders will be displayed in the upper half of the dialog box and 
the options regarding the selected project folder will be displayed in the lower half of the dialog 
box. To add another project folder to this list, choose the New button; the Inventor project 
wizard dialog box will be displayed. The New Single User Project radio button is selected by 
default in this dialog box. Choose the Next button from the Inventor project wizard dialog 
box. Specify the name of the project in the Name text box and the location in the Project 
(Workspace) Folder text box. You can also choose the Browse for project location button to 
specify the location of the project. Next, choose the Finish button. Once you have specified the 
project folder, it will be added to the upper part of the Projects dialog box and its location will 
be displayed. When you select a project, the options related to it will be shown in the lower part 
of the dialog box. The Projects dialog box with various projects is shown in Figure 2-8. Choose 
the Done button to close the Projects dialog box.

Figure 2-8  The Projects dialog box

To view help topics, press F1; the Autodesk Inventor 2023 Help window will be displayed. 
In this window, you will find help topics explaining how to use a particular tool or option of 
Autodesk Inventor.
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Import DWG
In Autodesk Inventor, you can import the AutoCAD files. To do so, choose Open > 
Import DWG from the File menu; the Import dialog box will be displayed. Browse to 
the desired folder and import the required AutoCAD file. 

INVOKING THE SKETCHING ENVIRONMENT
To invoke the Sketching environment, choose the Start 2D Sketch tool from the Sketch panel 
in the 3D Model tab; three different planes namely XY Plane, YZ Plane, and XZ Plane will be 
displayed in the graphics window, as shown in Figure 2-9. Select the required plane from the 
graphics window to invoke the Sketching environment.

Figure 2-9  Three different planes displayed in the graphics window

INTRODUCTION TO THE SKETCHING ENVIRONMENT
The initial interface appearance in the Sketching environment of a Standard (mm).ipt file after 
selecting the XY Plane as the sketching plane is shown in Figure 2-10. By default, the Ribbon 
is placed at the top of the graphics window, refer to Figure 2-10. You can move this Ribbon 
anywhere in the graphics window. To do so, right-click on the Ribbon; a shortcut menu will 
be displayed. Choose the Undock Ribbon option from the shortcut menu; the Ribbon will be 
undocked. Now, you can drag the Ribbon anywhere in the graphics window. It is recommended 
to place (dock) the Ribbon at the top of the graphics window so that you can use the space 
efficiently. To do so, right-click on the Ribbon and choose Dock to Top from the shortcut menu.
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Figure 2-10  Initial interface appearance in the Sketching environment

SETTING UP THE SKETCHING ENVIRONMENT
It is very important to first set up the Sketching environment. This has to be done before you 
start drawing a sketch. Setting up the Sketching environment includes modifying the grids of a 
drawing. It is unlikely that the designs that you want to create consist of small dimensions. You 
will come across a number of designs that are large. Therefore, before starting a drawing, you 
need to modify the grid settings. These settings will depend on the dimensions of the design. 
The process of modifying the grid settings of a drawing is discussed next.

Modifying the Document Settings of a Sketch
Before sketching, you may need to modify the settings of the Sketching environment according 
to your requirement. You can change the snapping distance, grid spacing, and various attributes 
related to line display of the Sketching environment. To display the grid lines in the Sketching 
environment, choose the Application Options tool from the Options panel of the Tools tab; 
the Application Options dialog box will be invoked. Now, select the Grid lines check box from 
the Display area of the Sketch tab and choose the OK button. You will notice that the graphics 
window in the Sketching environment consists of a number of light and dark lines that are 
normal to each other. These normal lines are called Grid lines. The Grid lines help you locate 
an entity thereby helping you to draw a sketch correctly or modify an existing sketch precisely. 

You can also modify the document settings of a sketch. To do so, choose the Document Settings 
tool from the Options panel of the Tools tab; the Part1 Document Settings dialog box will be 
displayed. In this dialog box, choose the Sketch tab to display the options related to the Sketching 
environment, refer to Figure 2-11. The options under this tab are discussed next.
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Figure 2-11  The Part1 Document Settings dialog box with the Sketch 
tab chosen

Snap Spacing
The options under this area are used to specify the snap distances.

X Edit
This edit box is used to specify the snap spacing in the X direction. 

Y Edit
This edit box is used to specify the snap spacing in the Y direction. 

Grid Display
The options in this area are used to control the number of major and minor lines. The minor 
lines are the light lines that are displayed inside the dark gray lines. The dark gray lines are 
called the major lines. 

Snaps per minor
This spinner is used to specify the number of snap points between each minor line.

Major every minor lines
This spinner is used to specify the number of minor lines between two major lines.
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Line Weight Display Options
The options in the Line Weight Display Options area allow you to control the line weight in the 
Sketching environment. The Display Line Weights check box is selected by default and displays 
the sketches with the set line weights. If this check box is cleared, then the differences in the 
line weights will not be displayed in the sketch. The Display True Line Weights radio button 
is used to display the line weights on screen as they would appear on paper when printed. The 
Display Line Weights by Range (millimeter) radio button, if selected, displays the line weights 
according to the values entered.

Tip
You can also turn off the display of the major and minor grid lines and the axes. To turn off the 
display of the grid line and the axes, choose the Application Options tool from the Options 
panel; the Application Options dialog box will be displayed. Next, choose the Sketch tab 
and clear the Grid lines, Minor grid lines, and Axes check boxes from the Display area.

SKETCHING ENTITIES
Getting acquainted with the sketching entities is an important part of learning Autodesk Inventor. 
The major part of a design is created using the sketch entities. Therefore, this section can be 
considered as one of the most important sections of the book. In Autodesk Inventor, the sketched 
entities are of two types: Normal and Construction. The normal entities are used to create a 
feature and become a part of it, but the construction entities are drawn just for reference and 
support, and cannot become a part of the feature. By default, all the drawn entities are normal 
entities. To draw construction entities, choose the Construction tool from the Format panel of the 
Sketch tab. All the entities drawn after choosing the Construction tool will be the construction 
entities. Deselect this tool by choosing it again to draw normal entities.

POSITIONING ENTITIES BY USING DYNAMIC INPUT
In Autodesk Inventor, you can specify the position of sketching entities by using the Dynamic 
Input which consists of two components: Pointer Input and the Dimension Input. The 
Pointer Input is displayed when you invoke the sketching tools such as Line, Rectangle, Arc, 
and it displays the coordinates of the current location of the cursor. As you move the cursor, 
the coordinates change dynamically. When you specify the first point, the Pointer Input is 
displayed. The Pointer Input is displayed in the form of Cartesian Coordinates (X and Y). If 
you specify the second point or the subsequent points of entities, the Dimension Input will be 
displayed. The Dimension Input is displayed in the form of polar coordinates (Length and Angle).  
To specify the position of sketching entities dynamically, invoke the required sketching tool and 
then move the cursor in the graphics window; the location of the cursor will be displayed in the 
Cartesian coordinate in the Pointer Input. Press the Tab key and enter the X and Y coordinate 
values in the Pointer Input to specify the first point; you will be prompted to specify the endpoint 
or second point of the entity. Alternatively, you can specify the first point of the entity by clicking 
in the graphics window. On doing so, the Pointer Input will be modified to the Dimension Input 
and the polar coordinate input fields will be displayed. To specify the endpoint or second point 
of the entity, enter the length and angle values in the input fields. To toggle between the length 
and angle input fields, use the Tab key. If you specify input values by using the Dimension Input 
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and then use the Tab key, lock icons will be displayed on the right of the input fields. The lock 
icons indicate that the values defined are constrained. Figure 2-12 shows the Pointer Input of a 
line and Figure 2-13 shows the Dimension Input of the endpoint of a line of length 20 mm at 
an angle of 45 degrees. 

Figure 2-13  Dimension Input of the endpoint 
of a line of length 20 mm at 45 degrees 

Figure 2-12  Pointer Input of a line

If there are some sketched entities already exist in the graphics window and you start creating 
more entities in the graphics window, an appropriate constraint symbol will be displayed near 
the cursor. You can control the display of the Pointer Input and Dimension Input by using the 
Application Options dialog box. This dialog box can be invoked by choosing the Application 
Options tool from the Options panel of the Tools tab. To control the display of Pointer Input 
and Dimension Input, choose the Sketch tab in the Application Options dialog box. Clear the 
Enable Heads-Up Display (HUD) check box from the Sketch tab and choose the OK button 
from this dialog box. As a result, the display of Pointer Input and Dimension Input will be turned 
off and now you cannot enter the input values of the entities dynamically. 

The sketcher entities in Autodesk Inventor are discussed next.

Drawing Lines
 Ribbon:	 Sketch > Create > Line/Spline drop-down > Line  

Lines are basic and one of the most important entities in the sketching environment. 
As mentioned earlier, you can draw either normal lines or construction lines. A line is 
defined as the shortest distance between two points. The two points are the start point 
and the endpoint of the line. Therefore, to draw a line, you need to define these two 

points. The parametric nature of Autodesk Inventor allows you to draw the initial line of any 
length or at any angle by just picking the points on the screen. After drawing the line, you can 
drive it to a new length or angle by using parametric dimensions. You can also create the line 
of actual length and angle directly by using the Inventor Precise Input toolbar. Both the methods 
of drawing the lines are discussed next.	

Drawing a Line by Picking Points in the Graphics Window
This is a very convenient method to draw lines and is used extensively while sketching. When 
you invoke the Line tool from the Create panel, the cursor (which was initially an arrow) is 
replaced by crosshairs with a yellow circle at the intersection. Alternatively, you can choose the 
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Create Line tool from the Marking menu which is displayed when you right-click anywhere in 
the graphics window. On doing so, you are prompted to select the start point of the line. In 
addition, the coordinates of the current location of the cursor are displayed in the Pointer Input 
and also at the lower right corner of the Autodesk Inventor window. The point of intersection of 
the X and Y axes (black lines among grid lines) is the origin point. If you move the cursor close 
to the origin, it will snap to the origin automatically. To draw a line, specify a point anywhere 
in the graphics window; the Pointer Input will display both length and angle values as zero. 
Move the cursor; a rubber-band line will start from the specified point and the length and angle 
values will change accordingly in the Pointer Input. One end of this rubber-band line is fixed at 
the point specified in the graphics window and the other end is attached to the yellow circle in 
crosshairs. As you move the cursor after specifying the start point of the line, the Pointer Input 
will display the length and angle of the current location of the line. Click at the required position 
in the graphics window. Alternatively, enter the required length and angle values in the Pointer 
Input to specify the endpoint of the line. You can use the Tab key to toggle between the length 
and angle values in the Pointer Input. 

After specifying the endpoint of the line, a line is drawn and a new rubber-band line starts. The start 
point of the new rubber-band line is the endpoint of the last line and you are again prompted to 
specify the endpoint of the line. You can continue specifying the endpoints to draw continuous lines. 

When you draw entities in Autodesk Inventor, valid constraints are applied automatically to the 
entities. Therefore, when you draw continuous lines, the horizontal, vertical, perpendicular, and 
parallel constraints are automatically applied to them. The symbol of the applied constraint 
is displayed on the line while drawing it. You can exit the Line tool by pressing the ESC key. 
Alternatively, you can exit the Line tool by right-clicking anywhere in the graphics window; a 
Marking menu will be displayed. Next, choose OK from the Marking menu. Figures 2-14 and 
2-15 display the Perpendicular Constraint and Parallel Constraint, respectively being applied 
to the lines while they are being drawn. 

 

Figure 2-14  Drawing a line using the 
Perpendicular constraint

Figure 2-15  Drawing a line using 
the Parallel constraint

Note
The default screen appearance in the Sketching environment can be modified for clarity. To do so, 
choose the Application Options tool from the Options panel of the Tools tab; the Application 
Options dialog box will be displayed. In the dialog box, choose the Colors tab and then select the 
Presentation option from the In-canvas Color Scheme list box. Next, select 1 Color from the 
Background drop-down list, and then choose the Apply button from the Application Options 
dialog box. The default appearance of the screen is changed in the Sketching environment.
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In Inventor, you can close a sketch that has two or more than two lines. To do so, if you have 
drawn two or more than two continuous lines in the drawing area then on selecting the Close 
option from the Marking menu; a line joining the endpoint of the current line and the start 
point of the first line will be created and the sketch will be closed. Figure 2-16 shows the Close 
option being chosen from the Marking menu to close the sketch and Figure 2-17 shows the 
closed sketch created. Note that the Close option will not be displayed in the Marking menu 
once you terminate the creation of continuous lines. 
 

Figure 2-17  Closed sketch createdFigure 2-16  Choosing the Close option from 
the Marking menu 

Drawing a Line by using the Inventor Precise Input Toolbar
This is another method of drawing lines in Autodesk Inventor. In this method, you use the 
Inventor Precise Input toolbar to define the coordinates of the start point and the endpoint of 
lines. To display the Inventor Precise Input toolbar for the line, first invoke the Line tool. Next, 
click on the down arrow displayed at bottom of the Create panel in the Sketch tab; the Create 
panel will expand. Choose the Precise Input tool from this panel. As mentioned earlier, the 
origin of the drawing lies at the intersection of the X and Y axes. The X and Y coordinates of 
this point are 0, 0. You can take the reference of this point to draw lines. There are two methods 
to define the coordinates using this toolbar. Both the methods are discussed next.

Specifying Coordinates with respect to the Origin
The system that define the coordinates with respect to the origin of the drawing is termed 
as the absolute coordinate system. By default, the origin lies at the intersection of the X 
and Y axes. All the points in this system are defined with respect to this origin. To define 
the points, you can use the following four methods.

Defining the Absolute X and Y Coordinates: In this method, you will define the X and 
Y coordinates of the new point with respect to the origin. To invoke this method, select 
the Indicate a point location by typing X and Y values option from the drop-down 
list in the Inventor Precise Input toolbar. The exact X and Y coordinates of the point 
can be entered in the X and Y edit boxes provided in this toolbar.

Defining the Absolute X Coordinate and the Angle from the X Axis: In this method, 
you will define the absolute X coordinate of a point with respect to the origin and the 
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angle that this line makes with the positive X axis. The angle will be measured in the 
counterclockwise direction from the positive X axis. To invoke this method, select the 
Specify a point using X coordinate and angle from X axis option from the drop-down 
list. The X coordinate of the new point and the angle can be defined in the respective 
edit boxes in the Inventor Precise Input toolbar.

Defining the Absolute Y Coordinate and the Angle from the X Axis: In this method, you 
will define the absolute Y coordinate of a point with respect to the origin and the angle 
that this line makes with the positive X axis. To invoke this method, select the Specify 
a point using Y coordinate and angle from X axis option from the drop-down list. 
The Y coordinate of the new point and the angle can be defined in the respective edit 
boxes in the Inventor Precise Input toolbar.

Specifying the Distance from the Origin and the Angle from the X Axis: In this 
method, you will define the distance of the point from the origin and the angle that 
this line makes with the X axis. To invoke this method, select the Specify a point using 
distance from the origin and angle from X axis option from the drop-down list. The 
distance and the angle can be defined in the respective edit boxes.

Specifying Coordinates with respect to the Last Point
This system of specifying the coordinates with respect to the previous point is termed as the 
relative coordinate system. Note that this system of defining the points cannot be used for 
specifying the first point (the start point of the line). All absolute coordinate methods for 
specifying a point with respect to the origin can also be used with respect to the last specified 
point by choosing the Precise Delta button along with the respective method. This button 
will be available only after you specify the start point of the first line. The Reset To Origin 
button moves the triad to the origin of the sketch (0,0,0). The Precise Redefine button is 
used to enter a point relative to the coordinate origin.

Note
1. While drawing continuous lines, when you move the cursor close to the start point of the first 
line, the color of yellow circle changes to green and the cursor snaps to the start point. On selecting 
the point at this stage, the loop will be closed and you will exit the current line chain.

2. To draw center lines, first choose the Centerline tool from the Format panel and then create 
lines. Alternatively, select the required entities from the graphics window and then choose the 
Centerline tool from the Marking menu; the selected entities will become center lines.  

Restarting a Line
To restart a line, right-click in the graphics window and choose Restart from the Marking menu; 
the start point of the line is cancelled and you are prompted to select the start point of the line.

Drawing Circles
In Autodesk Inventor, you can draw circles by using two methods. You can draw a circle by 
defining the center and the radius of the circle or by drawing a circle that is tangent to three 
specified lines. Both these methods of drawing the circle are discussed next.
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Drawing a Circle by Specifying the Center Point and Radius
 Ribbon:	 Sketch > Create > Circle drop-down > Circle Center Point    

This is the default method of drawing circles. In this 

Figure 2-18  Tools in 
the Circle drop-down

method, you need to define the center point and radius of 
a circle. To draw a circle using this method, choose the 

Circle Center Point tool from the Create panel, refer to Figure 2-18; you 
will be prompted to select the center of the circle. Specify the center point 
of the circle in the graphics window; you will be prompted to specify a point 
on the circle. Click at the required location in the drawing window to 
specify a point on the circumference of the circle. This point will define 
the radius of the circle. Alternatively, enter the required value in the 
Pointer Input to specify the diameter of the circle. Figure 2-19 shows a 
circle drawn by using the center and the radius.

Drawing a Circle by Specifying Three Tangent Lines
 Ribbon:	 Sketch > Create > Circle drop-down > Circle Tangent    

The second method of drawing circles is used to draw it tangent to three selected 
lines. To draw a circle using this method, choose the Circle Tangent tool from 
the Create panel, refer to Figure 2-18; you will be prompted to select the first, 

second, and third line, sequentially. As soon as you specify the third line, a circle tangent to all 
the three specified lines will be drawn, as shown in Figure 2-20.

Figure 2-19  Circle drawn using the center 
point and radius

Figure 2-20  Circle drawn using three tangent 
lines

Drawing Ellipses
 Ribbon:	 Sketch > Create > Circle drop-down > Ellipse    

To draw an ellipse, choose the Ellipse tool from the Create panel; you will be 
prompted to specify the center of the ellipse. Select a point to specify the center 
of the ellipse; you will be prompted to specify the first axis point. Specify a point 

to define the first axis of the ellipse; you will be prompted to select a point on the ellipse. Select 
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a point on the ellipse; the ellipse will be created. You can also 

Figure 2-21  An ellipse drawn in 
the Sketching environment

specify these points using the Inventor Precise Input  
toolbar. However, remember that you cannot use the 
relative options for defining the points of the ellipse. 
Therefore, if you use the Inventor Precise Input toolbar 
for drawing the ellipse, all the values will be specified 
from the origin. Figure 2-21 shows an ellipse drawn in 
the Sketching environment. 

Drawing Arcs
Autodesk Inventor provides three methods for drawing arcs. These methods are discussed 
next.

Drawing an Arc by Specifying Three Points
 Ribbon:	 Sketch > Create > Arc drop-down > Arc Three Point    

This is the default method of drawing arcs. To create

Figure 2-22  Tools in the Arc 
drop-down

 
an arc with three points, choose the Arc Three 

Point tool from the Create panel, see Figure 2-22, and then 
specify three points. The first point is the start point of the arc, 
the second point is the endpoint of the arc, and the third point is 
a point on the arc. You can define these points by specifying them 
in the graphics window or by using the Inventor Precise Input 
toolbar. You can also use the Pointer Input for specifying the second 
and the third point of the arc. Figure 2-23 shows an arc drawn 
using this method.

Drawing an Arc Tangent to an Existing Entity
 Ribbon:	 Sketch > Create > Arc drop-down > Arc Tangent    

This method is used to draw an arc that is tangent to an existing open entity. The 
open entity can be an arc or a line. To draw an arc using this method, choose the 

Arc Tangent tool (see Figure 2-22) from the Create panel; you will be prompted to select the 
start point of the arc. The start point of the arc must be the start point or endpoint of an existing 
open entity. Once you specify the start point, a rubber-band arc will start from it. Note that this 
arc is tangent to the selected entity. Now, you will be prompted to specify the endpoint of the 
arc. Click on the graphics window to specify the endpoint of the arc. Alternatively, enter the 
radius and the angle values in the Pointer Input to specify the endpoint of the arc. Here, it is 
very important to mention that the Inventor Precise Input toolbar or the Pointer Input cannot 
be used to select the start point of this arc. However, you can use this toolbar to specify the 
endpoint of this arc. Figure 2-24 shows an arc drawn tangent to the line.
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Figure 2-24  Drawing the tangent arcFigure 2-23  Drawing the three points arc

Drawing a Tangent/Normal Arcs by Using the Line Tool
You can also draw a tangent or a normal arc when the Line tool is activated. At least a line or 
an arc should be drawn before drawing an arc using this method. To do so, draw a line or an 
arc and then invoke the Line tool; you are prompted to select the start point of the line. Move 
the cursor close to the point from where you want to start the tangent or normal arc, the yellow 
circle in the cursor turns green. Select the point at this stage; the green circle in the cursor turns 
gray. Press the left mouse button and drag the mouse; four construction lines appear at the start 
point displaying the normal and tangent directions. If you drag along the tangent direction, a 
tangent arc is drawn. But if you drag along the normal direction, an arc normal to the selected 
entity is drawn.

Drawing an Arc by Specifying the Center, Start, and End Points
 Ribbon:	 Sketch > Create > Arc drop-down > Arc Center Point    

This method is used to draw an arc by specifying the center point, start point, 
and endpoint of the arc. To draw an arc using this method, choose the Arc Center 

Point tool from the Create panel (see Figure 2-22). On doing so, you will be prompted to specify 
the center point of the arc. Once you specify the center point of the arc, you will be prompted 
to specify the start point and then the endpoint of the arc, refer to Figure 2-25. You can also 
specify the start point and endpoint of the arc by using the Pointer Input. In case of start point, 
you need to specify the radius and angle of the arc from the center point. Whereas, in case of 
endpoint, you need to specify the arc length in terms of angle value. You can use the Tab key to 
toggle between the input values of the Pointer Input. As you define the center point and the 
start point, the radius of the arc will be defined automatically. So, the third point is just used to 
define the arc length. An imaginary line is drawn from the cursor to the center of the arc. The 
point at which the arc intersects the imaginary line will then be taken as the endpoint of the arc, 
see Figure 2-26. You can also use the Inventor Precise Input toolbar to specify these three points 
of the arc. 



Sketching, Dimensioning, and Creating Base Features and Drawings	                          2-19	

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 2-25  The arc created by specifying 
the center, start, and end points

Figure 2-26  The imaginary line created 
while drawing the center point arc

Drawing Rectangles							     
In Autodesk Inventor, rectangles can be drawn by using various methods that are discussed next.

Drawing a Rectangle by Specifying Two Opposite Corners
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Rectangle Two Point    

This is the default method used to draw a rectangle by specifying its two 
opposite corners. To draw a rectangle by using this method, choose the Rectangle 

Two Point tool from the Create panel, see Figure 2-27; you will be prompted to specify the first 
corner of the rectangle and the Pointer Input will be displayed. Click at the required location 
to specify the first corner of the rectangle. Once you specify the first corner, you will be prompted 
to specify the opposite corner of the rectangle and the Pointer Input will be modified. Click to 
specify the second corner or enter the length and height of the rectangle in the Pointer Input. 
Figure 2-28 shows a rectangle drawn using the Rectangle Two Point tool.

Drawing a Rectangle by Specifying Three Points on a Rectangle
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Rectangle Three Point    

You can draw a rectangle by specifying its three points. In this method, the first two 
points are used to define the length and angle of one of the sides of the rectangle 

and the third point is used to define the length of the other side. To create a rectangle by using 
this method, choose the Rectangle Three Point tool from the Rectangle/Slot drop-down of the 



2-20	             		 Autodesk Inventor Professional 2023 for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Create panel of the Sketch tab, see Figure 2-27; you will be 

Figure 2-27  Tools in the Rectangle/
Slot drop-down

prompted to specify the first corner of the rectangle. Once 
you specify it, you will be prompted to specify the second 
corner of the rectangle. Both these corners are along the 
same direction. As a result, you can use these points to define 
the length of one side of the rectangle. After specifying the 
second corner, you will be prompted to specify the third 
corner. This corner is used to define the length of the other 
side of the rectangle. Note that if you specify the second 
corner at a certain angle, then the resultant rectangle will 
also be inclined. You can also specify the first, second, and 
third points of the rectangle by using the Pointer Input. In 
case of second point, you need to specify the length and 
angle of rectangle in the input value fields of the Pointer 
Input. Whereas, in case of endpoint, you need to specify the 
height of the rectangle. You can use the Tab key to toggle 
between the input values of the Pointer Input. You can also 
specify the three points for drawing the rectangle using the 
Inventor Precise Input toolbar. Figure 2-29 shows an 
inclined rectangle drawn by using the Three Point Rectangle 
tool.

Figure 2-28  Drawing a rectangle using two points Figure 2-29 A rectangle drawn using the 
Three Point tool

Drawing a Rectangle by Specifying its Two Points
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Rectangle Two Point Center   

You can also draw a rectangle by specifying its two points. In this method, the 
first point is used to define the center of the rectangle and the second point is 

used to define the length and width of the rectangle. To create a rectangle by using this method, 
choose the Rectangle Two Point Center tool from the Rectangle/Slot drop-down of the Create 
panel in the Sketch tab, refer to Figure 2-27; you will be prompted to specify the center of the 
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rectangle. Click in the graphics window to specify it and move the cursor toward left or right; 
the Pointer Input will be displayed. Enter the length and width of the rectangle in the Pointer 
Input. Figure 2-30 shows a rectangle drawn using the Rectangle Two Point Center tool.

Drawing a Rectangle by Specifying Three Different Points on 
a Rectangle
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Rectangle Three Point Center 

You can also draw a rectangle by specifying its three points. In this method, the 
first point is used to define the center of the rectangle, the second point is used 

to define the length and orientation of the rectangle, and the third point is used to define the 
width of the rectangle. To create a rectangle by this method, choose the Rectangle Three Point 
Center tool from the Rectangle/Slot drop-down in the Create panel of the Sketch tab, refer to 
Figure 2-27; you will be prompted to specify the center of the rectangle. Click at the required 
location to specify the center; Pointer Input will be displayed. Now, move the cursor and click 
to specify the first corner point and orientation of the rectangle. Again, move the cursor to 
specify the second corner point of the rectangle. Figure 2-31 shows a rectangle drawn using the 
Rectangle Three Point Center tool.

Figure 2-30  Drawing a rectangle by using the 
Rectangle Two Point Center tool

Figure 2-31  Drawing a rectangle by using 
the Rectangle Three Point Center tool

Drawing Polygons
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Polygon    

The polygons drawn in Autodesk Inventor are regular

Figure 2-32  The Polygon 
dialog box

 
polygons. A regular polygon is a multi-sided geometric 

figure in which the length of all sides and the angle between them 
are same. In Autodesk Inventor, you can draw a polygon with the 
number of sides ranging from 3 to 120. When you invoke the Polygon 
tool, the Polygon dialog box will be displayed, as shown in Figure 2-32, 
and you will be prompted to select the center of the polygon. The 
options in this dialog box are discussed next.	
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Inscribed
This is the first button in the Polygon dialog box and is chosen by default. This option is 
used to draw an inscribed polygon. An inscribed polygon is the one that is drawn inside 

an imaginary circle such that its vertices touch the circle. Once you have specified the polygon 
center, you will be prompted to specify a point on the polygon. In case of an inscribed polygon, 
the point on the polygon specifies one of its vertices, see Figure 2-33.

Circumscribed
This is the second button in the Polygon dialog box and is used to draw a circumscribed 
polygon. A circumscribed polygon is the one that is drawn outside an imaginary circle such 

that its edges are tangent to the imaginary circle. In case of a circumscribed polygon, the point 
on the polygon is the midpoint of one of the polygon edges, see Figure 2-34.

Number of Sides
This edit box is used to specify the number of sides of the polygon. The default value is 6. You 
can enter any value ranging from 3 to 120 in this edit box.

Note
The rectangles and polygons are a combination of individual lines. All the lines can be separately 
selected or deleted. However, when you select one of the lines and drag, the entire rectangle or 
polygon will be considered as a single entity. As a result, the entire object will be moved or stretched.

Figure 2-34  Drawing a five-sided circumscribed 
polygon

Figure 2-33  Drawing a six-sided inscribed 
polygon

Drawing Slots                                             	        
In Autodesk Inventor, you can draw linear or arched slots by using the Slot tools available in the 
Rectangle/Slot drop-down of the Create panel in the Ribbon, refer to Figure 2-35. The methods 
of drawing slots are discussed next.

Drawing a Center to Center Slot
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Slot Center to Center   

To create a Center to Center slot, choose the Slot Center to Center tool from 
the Rectangle/Slot drop-down; you will be prompted to specify the start center 
point. Click in the graphics window to specify the start center point, you will 
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be prompted to specify the end center point. Now, you can specify the end point by specifying 
distance in dynamic input or by clicking in the graphics window. Specify the end center point; 
you will be prompted to specify the point on the slot to specify the  diameter or width of the 
slot. Specify the width or diameter in the dynamic input; the slot will be created. This type of 
slot is called the center to center linear slot. Figure 2-36 shows a Center to Center slot created.

Figure 2-35  The Rectangle/Slot 
drop-down

Figure 2-36  Center to Center slot 

Drawing an Overall Slot
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Slot Overall    

To create an Overall slot, choose the Slot Overall tool from the Rectangle/Slot 
drop-down; you will be prompted to specify the start point. Click in the graphics 
window to specify the start point; you will be prompted to specify the end point. 

Now, you can specify the end point by specifying the

             Figure 2-37  Overall slot

 
distance in dynamic input or clicking in the graphics 
window. Specify the end point; you will be prompted 
to specify the point on the slot to specify the diameter 
or width of the slot. Specify the width or diameter 
in the dynamic input; the slot will be created. This 
type of slot is also called the linear slot. Figure 2-37 
shows an Overall slot created.
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Drawing a Center Point Slot
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Slot Center Point   

To create a Center Point slot, choose the Slot Center Point tool from the 
Rectangle/Slot drop-down; you will be prompted to specify the center point of 

the slot. Click in the graphics window to specify the center point of the slot; you will be prompted 
to specify the second point. You can specify the distance of the second point either by using the 
dynamic input or clicking in the graphics window. Specify the second point; you will be prompted 
to specify the point on the slot to specify the diameter or width of the slot. Specify the width or 
diameter in the dynamic input; the slot will be created. This type of slot is also called a linear 
slot. Figure 2-38 shows a Center Point slot created.

Drawing a Three Point Arc Slot 
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Slot Three Point Arc   

To  create  a Three  Point  Arc  slot,  choose  the Slot Three Point Arc tool from 
the Rectangle/Slot drop-down; you will be prompted to specify the start point 

of the center arc. Click in the graphics window to specify the start point of center arc; you will 
be prompted to specify the end point. Now you can specify the end point either by specifying 
length in the dynamic input or by clicking in the graphics window; you will be prompted to 
specify the third point of the center arc. Specify the third point; you will be prompted to specify 
the diameter or width of the slot. Specify the width or diameter in the dynamic input; the slot 
will be created. This type of slot is called an arc slot. Figure 2-39 shows a Three Point Arc slot 
created.

Figure 2-38  Center Point slot created Figure 2-39 Three Point Arc slot created

Drawing a Center Point Arc Slot
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Slot Center Point Arc   

To create a Center Point Arc slot, choose the Slot Center Point Arc tool from 
the Rectangle/Slot drop-down; you will be prompted to specify the center of 
the Center Point Arc. Specify the center; you will be prompted to specify the 

start point of the arc. Specify the start point by entering

Figure 2-40  Center Point Arc slot created

 
angle value in the dynamic input; you will be 
prompted to specify the end point. Specify the end 
point by entering angle value in the dynamic input; 
you will be prompted to specify the diameter or width 
of the slot. Specify the width or diameter in the 
dynamic prompt; the slot will be created. This type 
of slot is also called an arc slot. Figure 2-40 shows a 
Center Point Arc slot created.
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Placing Points
 Ribbon:	 Sketch > Create > Point    

In Autodesk Inventor, you can place the sketched points in a sketch by using the Point 
tool. To place a point, choose the Point tool from the Create panel of the Sketch tab; 

you will be prompted to select the center point. Specify the center point; a point will be placed. 
You can specify the location of a point in the sketch by picking a point from the graphics window 
or by entering the value in the Inventor Precise Input toolbar.

Creating Fillets
 Ribbon:	 Sketch > Create > Fillet/Chamfer drop-down > Fillet   

Filleting is defined as the process of rounding the 
sharp corners of a sketch. This is done to reduce the 

stress concentration in the model and for smooth handling. 
Using the Fillet tool, you can round the corners of the sketch 
by creating an arc tangent to both the selected entities. The 
portions of the selected entities that comprise the sharp corners 
are trimmed when the fillet is created. When you invoke this 
tool from the Fillet/Chamfer drop-down, refer to Figure 2-41, 
the 2D Fillet dialog box will be displayed with default fillet 
radius, as shown in Figure 2-42, and you will be prompted to 
select the lines or the arcs to be filleted. If you have already 
created some fillets, their radius values will be stored as preset 
values. You can select these preset values from the list that is 
displayed when you choose the arrow provided on the right of 
the edit box.

You can create any number of fillets of similar or dissimilar radii. If the Equal button in the 2D 
Fillet dialog box is chosen, the dimension of the fillet will be placed only on the first fillet and 
not on the other fillets created by using the same sequence, see Figure 2-43. On modifying the 
dimension of the first fillet, all instances of fillet will get modified by default. To create fillets of 
independent radii values, deselect the Equal button before creating fillets. The fillets thus created 
will show individual dimensions, see Figure 2-44. As a result, you can modify the dimension of one 
fillet without affecting the other. You can fillet two parallel or perpendicular lines, intersecting 
lines or arcs, non-intersecting lines or arcs, and a line and an arc.

Figure 2-43  Rectangle filleted using the same 
radius with the Equal button chosen

Figure 2-44  Rectangle filleted using different 
radii with the Equal button deactivated

Figure 2-41  Tools in the Fillet/
Chamfer drop-down

Figure 2-42  The 2D 
Fillet dialog box



2-26	             		 Autodesk Inventor Professional 2023 for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Creating Chamfers
 Ribbon:	 Sketch > Create > Fillet/Chamfer drop-down > Chamfer   

Chamfering is defined as the process of beveling 
the sharp corners of a sketch. This is the second 

method of reducing stress concentration. To chamfer sketched 
entities, choose the Chamfer tool from the Create panel 
(see Figure 2-41); the 2D Chamfer dialog box will be displayed, 
as shown in Figure 2-45. Also, you will be prompted to select 
the lines to be chamfered. Select the lines; the chamfer will 
be created. The options in the 2D Chamfer dialog box are 
discussed next.

Create Dimensions
The Create Dimensions button is chosen to show the dimensions of the chamfer on the 
sketch. When you chamfer two lines, the dimensions of the chamfer are shown in the 
sketch. If you choose this button again, the chamfer dimensions will not be displayed in 
the sketch when you create another chamfer.

Equal to Parameters
The Equal to parameters button is chosen to create multiple chamfers with the same 
parameters. This button is active only when the Create Dimensions button is chosen.

Equal Distance	          		       	
The Equal Distance button is chosen to create 

Figure 2-46  Chamfer with dimension values

an equal distance chamfer. The distance of 
the vertex along the two selected edges is the 

same. As a result, a 45-degree chamfer is created 
using this method. The distance value is specified in 
the Distance edit box. If the Create Dimension 
button is chosen, two dimensions of the same value 
will be shown in the sketch, as shown in Figure 2-46.

Unequal Distance
The Unequal Distance button is chosen to create a chamfer with two different distances. 
The distance values are specified in the Distance1 and Distance2 edit boxes. The distance 
value specified in the Distance1 edit box is measured along the edge selected first. 

Similarly, the value in the Distance2 edit box is measured along the edge selected next. 
Figure 2-47 shows a chamfer created by using the Unequal Distance button.

Distance and Angle
The Distance and Angle button is chosen to create a chamfer by specifying a distance 
and an angle. On choosing this button, the distance needs to be specified in the Distance 
edit box and the angle in the Angle edit box. The specified angle is measured from the 
first edge selected to chamfer, see Figure 2-48.

Figure 2-45  The 2D Chamfer 
dialog box
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Figure 2-48  The chamfer created using the 
Distance and Angle button

Figure 2-47  The chamfer created using the 
Unequal Distance button

Tip
1. If multiple chamfers of same values are created, the dimension value is displayed only at 
the first instance. For the remaining chamfers, the dimension will be displayed as the function 
of the original value.

2. You can also select a vertex to create a fillet or chamfer. The two entities forming the selected 
vertex will be filleted or chamfered using the current parameters.

Drawing Splines
Autodesk Inventor provides various methods for drawing splines. These methods are discussed 
next.

Drawing a Spline by Using the Spline Interpolation Tool
 Ribbon:	 Sketch > Create > Line/Spline drop-down > Spline Interpolation   

To draw a spline, choose the Spline Interpolation tool from the Line/Spline drop-down 
of the Create panel, refer to Figure 2-49; you will be 

prompted to specify the first point of the spline. Specify the first 
point; you will be prompted to specify the next point of the spline. 
This process will continue until you terminate the spline creation. 
To end the spline at the current point, double-click in the 
drawing window or right-click to display the Marking menu and 
choose Create. Note that if you choose Cancel(ESC) from the 
Marking menu, the spline will not be drawn. You can also end the 
spline creation by pressing the Enter key. Note that after creating a 
spline, the square and diamond points will be displayed on the spline 
along with the tangent handles, as shown in Figure 2-50. You can 
drag these square and diamond points to modify the shape of the 
spline. To exit the command, press the ESC key or choose 
Cancel(ESC)  from the Marking menu.

You can undo the last drawn spline segment while drawing a spline. 
Figure 2-49  Tools in the 
Line/Spline drop-down
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This can be done by choosing the Back option from the Marking menu which is displayed 
when you right-click anywhere in the graphics window. You can also draw a spline tangent to an 
existing entity. To draw the tangent spline, select the point where the spline should be tangent. 
Next, hold the left mouse button and drag it; a construction line will be drawn, displaying the 
possible tangent directions for the spline. Drag the mouse in the required direction to draw the 
tangent spline and release the left mouse button. Figure 2-51 shows a spline drawn tangent to 
an existing line.

	

Figure 2-51  A spline drawn tangent to a lineFigure 2-50  A spline drawn by specifying different 
points

Tip
Autodesk Inventor allows you to invoke the last used tool by choosing the Repeat (name of the last 
used tool) option from the Marking menu displayed on right-clicking anywhere in the graphics 
window. For example, the Repeat Line option will be available in the Marking menu, if the line tool 
was the last used tool. Alternatively, you can press the SPACEBAR key to invoke the last used tool.

Drawing a Spline by Specifying Control Vertices
 Ribbon:	 Sketch > Create > Line/Spline drop-down > Spline Control Vertex    

To draw a spline, choose the Spline Control Vertex

Figure 2-52  Spline Control 
Vertex tool to be chosen in the 
Line/Spline drop-down

 
tool from the Line/Spline drop-down in the Create 

panel, see Figure 2-52; you will be prompted to specify the first point 
of the spline. Specify the start point; you will be prompted to 
specify the next point of the spline. This process will continue until 
you terminate the spline creation. To end the spline at the current 
point, double-click in the drawing window or right-click to display 
the Marking menu and choose Create. Note that if you choose 
Cancel (ESC) from the Marking menu, the spline will not be drawn. 
You can also end the spline creation by pressing the Enter key. Note 
that after creating a spline, the control vertices will be displayed on 
the spline along with the tangent handles, as shown in Figure 2-53. 
You can drag these control vertices to modify the shape of the spline. 
These control vertices act as poles for controlling the shape of the 
splines. Figure 2-54 shows a spline drawn tangent to a line. To exit 
the command, press the ESC key on the keyboard or choose OK 
from the Marking menu.
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Figure 2-54  A spline drawn tangent to a lineFigure 2-53  A spline drawn by specifying different 
control vertices

Creating a Smooth Curve between the Two Existing Curves
 Ribbon:	 Sketch > Create > Line/Spline drop-down > Bridge Curve  

In Autodesk Inventor, you can create a smooth (G2) continuous curve between 
two existing curves. The existing curves can be arcs, lines, splines, or projected 
curves. To create a smooth curve, choose the Bridge Curve tool from the Line/

Spline drop-down in the Create panel of the Sketch tab, refer to Figure 2-52; you will be 
prompted to select the curves one after the other. Select the two curves; a smooth G2 continuous 
curve, known as bridge curve, will be created between the selected curves. The profile of the 
bridge curve depends on the position of the points selected on the existing curves. Figure 2-55 
shows two points selected on the two curves and the resulting bridge curve. Figure 2-56 shows 
two different points selected on the curves shown in Figure 2-55 and the resulting bridge 
curve.	
 
 

Figure 2-56  Bridge curve created between two 
different points on the curves shown in Figure 2-55 

Figure 2-55  Bridge curve created between two  
points selected on two curves

DELETING SKETCHED ENTITIES
To delete a sketched entity, first ensure that no drawing tool is active. If any of them is active, 
press the ESC key for deactivating. Now, select the entity you want to delete using the left mouse 
button and then right-click to display the Marking menu. Choose the Delete option from this 
Marking menu. You can also press the DELETE key to delete the selected entities. To delete 
more than one entity, you can use a window or a crossing as discussed next.
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Deleting Entities by Using a Window
A window is defined as a box created by pressing and holding the left mouse button and dragging 
the cursor from left to right in the drawing window. The window has a property that all the 
entities that lie completely inside the window will be selected. The box defined by the window 
consists of continuous lines. All the selected entities will be displayed in cyan color. After selecting 
the entities, right-click and choose Delete from the Marking menu or press the DELETE key 
to delete all the selected entities.
 

Deleting Entities by Using a Crossing
A crossing is defined as a box created by pressing and holding down the left mouse button and 
dragging the cursor from right to left in the drawing window. The crossing has a property that all 
entities that lie completely or partially inside the crossing or the entities that touch the crossing 
will be selected. The box defined by the crossing consists of dashed lines. Once the entities are 
selected, right-click and choose Delete from the Marking menu. 

Tip
You can add or remove an entity from the selection set by pressing the SHIFT or the CTRL 
key and then selecting the entity by using the left mouse button. If the entity is already in the 
current selection set, it will be removed from the selection set. If not, it will be added to the set.

FINISHING A SKETCH
After creating the required sketch, you need to save it. But before you save the sketch, you 
need to finish the sketch and exit the Sketching environment. To do so, choose the Finish 
Sketch tool from the Exit panel of the Sketch tab; the sketch will be finished and you will 
switch to the Home view. You can also exit the Sketching environment by choosing the 
Finish 2D Sketch option from the Marking menu. The Home view enables you to change the 
orientation of current view to isometric views. After exiting the Sketching environment, you can 
easily save the document.

UNDERSTANDING THE DRAWING DISPLAY TOOLS
The drawing display tools or navigation tools are an integral part of any design software. These 
tools are extensively used during the design process. These tools are available in the Navigation 
Bar located on the right in the graphics window and in the Navigate panel of the View tab. Some 
of the drawing display tools in Autodesk Inventor are discussed next. The rest of these tools will 
be discussed in the later chapters.

Zoom All
 Ribbon:	     View > Navigate > Zoom drop-down > Zoom All	  
 Navigation Bar:    Zoom flyout > Zoom All	 			 

The Zoom All tool is used to increase the drawing display area to display all the sketched 
entities in the current display.
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Zoom
 Ribbon:	     View > Navigate > Zoom drop-down > Zoom	  
 Navigation Bar:    Zoom flyout > Zoom				  

The Zoom tool is used to interactively zoom in and out of the drawing view. When you 
choose this tool, the default cursor is replaced by a zoom cursor. You can zoom in the 

drawing by pressing the left mouse button and dragging the cursor down. Similarly, you can 
zoom out the drawing by pressing the left mouse button and then dragging the cursor up. You 
can exit this tool by choosing another tool or by pressing ESC. You can also choose Done [Esc] 
from the Marking menu which is displayed on right-clicking. You can also zoom in the drawing 
by rolling the scroll wheel of the mouse in the downward direction. Similarly, you can zoom out 
the drawing by rolling the scroll wheel in the upward direction.

Zoom Window
 Ribbon:		  View > Navigate > Zoom drop-down > Zoom Window	  
 Navigation Bar:	 Zoom flyout > Zoom Window				  

The Zoom Window tool is used to define an area to be magnified and viewed in the current 
drawing. The area is defined using two diagonal points of a box in the drawing window. 
The area inscribed in the window will be magnified and displayed on the screen.

Tip
1. The size of the dimension text always remains constant even if you magnify the area that 
includes some dimensions. 

2. To switch to the previous view, right-click in the drawing window and then choose Previous 
View from the shortcut menu or press the F5 key. You can restore nine previous views in the 
current sketching environment by using this option.

Zoom Selected
 Ribbon:		  View > Navigate > Zoom drop-down > Zoom Selected	  
 Navigation Bar:	 Zoom flyout > Zoom Selected	 			 

When you choose the Zoom Selected tool, you will be prompted to select an entity to 
zoom. Select an entity from the drawing area; it will be magnified to the maximum extent 
and will be placed at the center of the drawing window. This tool can also be invoked by 
pressing the END key.

Pan
 Ribbon:		  View > Navigate > Pan	  
 Navigation Bar:	 Pan	 		

The Pan tool is used to drag the current view in the drawing window. This option is 
generally used to display the contents of the drawing that are outside the display area 

without actually changing the magnification of the current drawing. It is similar to holding the 
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drawing and dragging it across the drawing window. You can also invoke the Pan tool by pressing 
and holding the middle scroll wheel of the mouse. 

Orbit
 Ribbon:		  View > Navigate > Orbit drop-down > Orbit	  
 Navigation Bar:	 Orbit flyout > Orbit	 			 

The Orbit tool is used to rotate a model freely about any axis. It is useful when you want 
to rotate a model to any position. It is a transparent tool as it can be invoked inside any 

other command. You can invoke this tool by choosing the Orbit tool from the Navigate panel 
in the View tab. On doing so, an arcball will be displayed. This arcball is a circle with four small 
lines placed such that they divide the arcball into quadrants. The orbit axis is parallel to the 
screen and if you rotate an object by dragging the mouse pointer outside the arcball, the object 
will rotate about the orbit axis. Figure 2-57 shows the model to be rotated and Figure 2-58 shows 
the same model rotated about the vertical axis by using the Orbit tool.

  

Figure 2-58  Position 2: Model rotated about 
the vertical axis

Figure 2-57  Position 1: Default view of the 
model

Constrained Orbit	
 Ribbon:		  View > Navigate > Orbit drop-down > Constrained Orbit	  
 Navigation Bar:	 Orbit flyout > Constrained Orbit	 			 

The Constrained Orbit tool is used to visually maneuver around the 3D objects to 
obtain different views. This is one of the most important tool used for advanced 3D viewing. 

Figures 2-59 and 2-60 show the default view of the model, and the view after one complete 
rotation, respectively. When the Constrained Orbit tool is invoked, the cursor gets modified and 
looks like a sphere encircled by two arc-shaped arrows. This cursor is known as the Orbit mode 
cursor. You can click and drag the mouse to rotate the model freely. You can move the Orbit 
mode cursor horizontally, vertically, and diagonally. In this case, the axis is normal to the top 
and bottom faces of the ViewCube. This is also a transparent tool as it can be invoked inside any 
other tool.
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Tip
1. Press and hold the SHIFT key and the middle mouse button to temporarily enter the 
Constrained Orbit mode. 

2. While working with the Orbit tool, you can adjust the viewport for better visibility and 
understanding by clicking inside the arcball. 

Figure 2-59  Position 1: Default view of the 
model

Figure 2-60  Position 2: Model after a complete 
rotation 

ADDING DIMENSIONS TO SKETCHES
 Ribbon:	 Sketch > Constrain > Dimension	  

After drawing a sketch and adding constraints to it, dimensioning is the next most 
important step in creating a design. As mentioned earlier, Autodesk Inventor is a 
parametric solid modeling package. The parametric property ensures that irrespective 

of its original size, the selected entity is driven by the specified dimension value. Therefore, 
whenever you modify or apply dimension to an entity, it is forced to change its size with respect 
to the specified dimension value. The type of dimension to be applied varies according to the 
type of entity selected. For example, if you select a line segment, linear dimensions will be 
applied and if you select a circle, diameter dimensions will be applied. Note that all these types 
of dimensions can be applied using the same dimensioning tool. To edit the dimension, 
double-click on the dimension; the Edit Dimension edit box will be displayed, refer to 
Figure 2-61. Enter the desired value in the edit box to modify the dimensions. The selected 
entity will be driven to the dimension value defined in this edit box. You can enter a new value 
for the dimension or choose the OK button on the right of this edit box to accept the default 
value.

If you do not want to edit the dimensions after they have been placed, invoke the Dimension tool 
and then right-click to display the Marking menu, refer to Figure 2-62. Clear the check mark on 
the left of the Edit Dimension option by choosing it again. When you place a dimension now, 
the Edit Dimension edit box will not be displayed. To edit the dimension value in this case, click 
on it after placing, if the Dimension tool is still active. If the tool is not active, double-click on 
the dimension; the Edit Dimension edit box will be displayed. Enter the new dimension value 
in this edit box. The dimensioning techniques available in Autodesk Inventor are discussed next.
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Figure 2-61  The Edit Dimension edit 
box

Figure 2-62  Choosing Edit Dimension 
from the Marking menu

Linear Dimensioning
The linear dimensions are defined as the

Figure 2-63  Marking menu displaying 
various options to dimension two points

dimensions that specify the shortest distance 
between two points. You can apply linear 
dimensions directly to a line or select two points 
or entities to apply the linear dimension between 
them. The points that you can select include the 
endpoints of lines, splines, or arcs, or the center 
points of circles, arcs, or ellipses. You can 
dimension a vertical or a horizontal line by directly 
selecting it. As soon as you select it, the dimension 
will be attached to the cursor. You can place the 
dimension at any desired location. To place the 
dimension between two points, select the points 
one by one. After selecting the second point, 
right-click to display the Marking menu, as shown 
in Figure 2-63. You can choose the dimension type 
from this menu as per your requirement.

If you choose Horizontal, the horizontal dimension will be placed between the two selected 
points. If you choose Vertical, the vertical dimension will be placed between the two selected 
points. If you choose Aligned, the aligned dimension will be placed between the two selected 
points. Figure 2-64 shows the linear dimensioning of lines and Figure 2-65 shows the linear 
dimensioning of two points.
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Figure 2-65  Linear dimensioning of two pointsFigure 2-64  Linear dimensioning of lines

You can also apply a horizontal or vertical dimension to an inclined line, see Figure 2-66. To 
apply these dimensions, select the inclined line and then right-click; a Marking menu similar 
to the one shown in Figure 2-66 will be displayed. In this menu, choose Horizontal to place 
the horizontal dimension and Vertical to place the vertical dimension or drag the mouse in 
horizontal and vertical directions to place the respective dimension.

Figure 2-66  Linear dimensioning of an inclined line

Aligned Dimensioning
The aligned dimensions are used to dimension the lines that are not parallel to the X or Y-axis. 
This type of dimension measures the actual distance of the aligned lines or the lines drawn at 
a certain angle. To apply the aligned dimension, select the inclined line and then right-click; 
a Marking Menu will be displayed, refer to Figure 2-63. Choose the Aligned option from the 
Marking Menu; the aligned dimension of the selected line will be attached to the cursor. Next, 
click in the graphics window to specify the location of the aligned dimension. You can also apply 
the aligned dimension between two points. The points include the endpoints of lines, splines, 
or arcs or the center points of arcs, circles, or ellipses. To apply the aligned dimension between 
two points, invoke the Dimension tool. Next, select the two points and right-click; a Marking 
Menu will be displayed. Choose the Aligned option from the Marking Menu. Figures 2-67 and 
2-68 show the aligned dimensions applied to various objects.



2-36	             		 Autodesk Inventor Professional 2023 for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Tip
Alternatively, to apply the aligned dimension, choose the Dimension tool from the Ribbon 
and then select the aligned entity to be dimensioned. Next, move the cursor away from the 
line and then click again on the same line. Now, click on the drawing window to place the 
aligned dimension. 

Figure 2-68  Aligned dimension between two pointsFigure 2-67  Aligned dimension of a line

Angular Dimensioning
The angular dimensions are used to dimension angles. You can select two line segments or 
use three points to apply the angular dimensions. You can also use angular dimensioning to 
dimension an arc. All these options of angular dimensioning are discussed next.

Angular Dimensioning Using Two Line Segments 
You can directly select two line segments to apply angular dimensions. To do so, invoke the 
Dimension tool of the Constrain panel of the Sketch tab. You can also invoke the General 
Dimension tool from the Marking Menu and then select a line segment using the left mouse 
button. Instead of placing the dimension, select the second line segment. Next, place the 
dimension to measure the angle between the two lines. While placing the dimension, you need 
to be careful about the point where you place the dimension. This is because depending on the 
location of the placement of dimension with respect to the lines, the vertically opposite angles 
will be displayed. Figure 2-69 shows the angular dimension between two lines and Figure 2-70 
shows the dimension of the vertically opposite angle between two lines. Also, depending on the 
location of the dimension, the major or minor angle value will be displayed. Figure 2-71 shows 
the major angle dimension between two lines and Figure 2-72 shows the minor angle dimension 
between the same set of lines.
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Figure 2-69  Angular dimensioning between 
two lines

Figure 2-70  Dimension of the vertically opposite 	
angle between two lines

Figure 2-72  Minor angle dimensionFigure 2-71  Major angle dimension

Angular Dimensioning Using Three Points
You can also apply angular dimensions using three points. Remember that the three points 
should be selected in clockwise or counterclockwise sequence. The points that can be used to 
apply the angular dimensions include the endpoints of lines or arcs, or the center points of 
arcs, circles, and ellipses. Figure 2-73 shows angular dimensioning applied using three points.
 
Angular Dimensioning of an Arc
You can use angular dimensions to dimension an arc. In case of arcs, the three points are 
the endpoints and the center point of the arc. Note that the points should be selected in the 
clockwise or counterclockwise sequence, but the center point should always be the second 
selection point. Figure 2-74 shows the angular dimensioning of an arc. In Autodesk Inventor, 
you can also assign arc-length to an arc by using the Marking menu. To do so, invoke the 
Dimension tool. Then, select the arc and right-click; a Marking menu will be displayed. 
Choose Dimension Type from the Marking menu; a cascading menu will be displayed. Choose 
Arc Length from the cascading menu before placing the dimension on the graphics window, refer 
to Figure 2-75. Figure 2-76 shows the angular dimensioning of an arc using the Marking menu. 
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Figure 2-74  Angular dimensioning of an arcFigure 2-73  Angular dimensioning applied 
using three points

Figure 2-76  Arc length of an arc defined using 
the Marking menu

Figure 2-75  Arc length being defined using 
the Marking menu

Diameter Dimensioning
Diameter dimensions are applied to dimension a circle or an 

Figure 2-77  Marking menu to apply 
a diameter dimension to an arc

arc to specify its diameter. In Autodesk Inventor, when you 
select a circle to dimension, the diameter dimension is 
applied to it by default. If you select an arc to dimension it, 
the radius dimension will be applied to it. You can also apply 
the diameter dimension to an arc. To do so, invoke the 
Dimension tool and then select the arc. Next, right-click to 
display the Marking menu, as shown in Figure 2-77. From 
the Marking menu, choose Dimension Type; a cascading 
menu is displayed. Choose Diameter from this menu to 
apply the diameter dimension. Figure 2-78 shows a circle 
and an arc with diameter dimensions.
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Figure 2-78  Diameter dimensioning of a circle and an arc

Radius Dimensioning
Radius dimensions are applied to dimension an arc or

Figure 2-79  Marking menu to apply a 
radius dimension to an arc

 
a circle to specify its radius. As mentioned earlier, by 
default, circles are assigned diameter dimensions and 
arcs are assigned radius dimensions. However, you can 
also apply the radius dimension to a circle. To do so, 
invoke the Dimension tool and then select the circle. 
Next, right-click to display the Marking menu, as 
shown in Figure 2-79. From the Marking menu, choose 
Dimension Type; a cascading menu is displayed. 
Choose Radius from this menu to apply the radius 
dimension. Figure 2-80 shows an arc and a circle with 
radius dimensions.

Figure 2-80  Radius dimensioning of a circle and an arc
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Linear Diameter Dimensioning
Linear diameter dimensioning is used to dimension the sketches of the revolved components. The 
sketch for a revolved component is drawn using simple sketcher entities. For example, if you draw 
a rectangle and revolve, it will result in a cylinder. Now, if you dimension the rectangle using the 
linear dimensions, the same dimensions will be displayed when you generate the drawing views 
of the cylinder. Also, the same dimensions will be used while manufacturing the component. But 
these linear dimensions will result in a confusing situation in manufacturing. This is because while 
manufacturing a revolved component, the dimensions have to be specified as the diameter of the 
revolved component. The linear dimensions will not be acceptable in manufacturing a revolved 
component. To resolve this problem, the sketches for the revolved features are dimensioned 
using the linear diameter dimensions. These dimensions display the distance between the two 
selected line segments as a diameter, that is, double the original length. For example, if the 
original dimension between two entities is 10 mm, the linear diameter dimension will display 
it as 20 mm. This is because when you revolve a rectangle with 10 mm width, the diameter of 
the resultant cylinder will be 20 mm. In this type of dimension, if you select two lines, the line 
selected first will act as the axis of revolution for the sketch and the line selected last will result 
in the outer surface of the revolved feature. It means the line selected last will be the one that 
will be dimensioned. But, if one of these lines is a centerline drawn by choosing the Centerline 
tool from the Format panel, the centerline will be considered as the axis of revolution.

To apply linear diameter dimensions, invoke the Dimension tool; you 

Figure 2-81  The Linear 
Diameter option 

will be prompted to select the geometry to dimension. Select the 
first line and then the second line with reference to which you 
want to apply the linear diameter dimensions. If the center line 
is selected as a reference, the linear diameter dimension will be 
displayed. Otherwise, right-click and then choose Linear Diameter 
from the Marking menu, see Figure 2-81. You will notice that the 
distance between the two lines is displayed as twice the distance. 
Also, the dimension value is preceded by the Ø symbol, indicating 
that it is a linear diameter dimension. Figures 2-82 and 2-83 show 
the use of linear diameter dimensioning.

Figure 2-82  Selecting elements for linear
diameter dimension

Figure 2-83  The linear diameter dimension
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Tip
 After invoking the Dimension tool, as you move the cursor close to the sketched entities, a small 
symbol will be displayed close to the cursor. This symbol displays the type of dimension that will 
be applied. For example, if you select a line, the linear dimensioning or aligned dimensioning 
symbol will be displayed. If you move the cursor close to another line after selecting the first, 
the symbol of angular dimensioning will be displayed. These symbols help you in determining 
the type of dimensions that will be applied.

In Autodesk Inventor, the ellipses are dimensioned as half of the major and minor axes distances. 
To dimension an ellipse, invoke the Dimension tool and then select the ellipse. Now, if you move 
the cursor in a vertical direction, the axis of the ellipse along the X-axis will be dimensioned in 
terms of its half length. Similarly, if you move the cursor in a horizontal direction, the axis of 
the ellipse along the Y axis will be dimensioned equal to its half-length.

To distinguish whether the dimension applied to an arc or a circle is a radius or a diameter, try to 
locate the number of arrowheads in the dimension. If there are two arrowheads in the dimension 
and the dimension line is placed inside the circle or the arc, it is a diameter dimension. The 
radius dimension has one arrowhead and the dimension line is placed outside the circle or the arc.

EXTRUDING THE SKETCHES		                            
 Ribbon:	 3D Model > Create > Extrude  

The Extrude tool is one of the most extensively 

Figure 2-84  The Properties-Extrusion 
dialog box 

used tools for creating a design. Extrusion is a 
process of adding or removing material defined 

by a sketch, normal to the current sketching plane. If 
you create the first feature, the options available to you 
will be used for adding the material and not for removing 
it. This is because there is no existing feature from which 
you can remove the material. When you invoke this tool 
f rom the Create  panel  in  the Ribbon ,  the 
Properties-Extrusion dialog box will be displayed, as 
shown in Figure 2-84. Alternatively, choose the 
Extrude tool from the Marking menu that is displayed 
on right-clicking in the graphics window. In addition to 
this dialog box, a mini toolbar will be displayed in the 
drawing window. The mini toolbar is a new user interface 
that provides you with different options to control the 
extrusion process. 

Note
Detailed description about extruding a sketch is provided in Chapter 4.
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GENERATING DRAWING VIEWS
After creating a solid model or an assembly, you need to generate its drawing views. Drawing 
views are the two-dimensional (2D) representations of a solid model or an assembly. Autodesk 
Inventor provides you with a specialized environment for generating drawing views. This 
specialized environment is called the Drawing module and has only those tools that are related 
to drawing views. All modules of Autodesk Inventor are bidirectionally associative. This property 
ensures that the changes made in a part or an assembly reflect in drawing views. Also, changes 
made in the dimensions of a component or an assembly in the Drawing module reflect in the part 
or assembly file. You can invoke the Drawing module for generating drawing views by using any 
.idw format file from the Metric tab of the Create New File dialog box. Autodesk Inventor has 
various .idw files with predefined drafting standards such as ISO standard, BIS standard, and 
DIN standard. You can use the required standard file and proceed to the Drawing module for 
generating drawing views. 

Note
Detailed description about generating drawing views is provided in Chapter 11.

TUTORIALS
Although Autodesk Inventor is parametric in nature, yet in this chapter, you will use the Dynamic 
Input method to draw objects. This is to ensure that you are comfortable working with all 
drawing options in Autodesk Inventor. In the later chapters, you will use the parametric feature 
of Autodesk Inventor to resize or draw the entities as per the desired dimension values.

Tutorial 1
Draw the sketch shown in Figure 2-85. Extrude the sketch by 5 units and then generate a drawing 
with the orthographic and isometric views of the model. The isometric view of the model is 
shown in Figure 2-86. You do not need to dimension the drawing.
								             (Expected time: 30 min)	
		       							                            		
	  				       

Figure 2-85  Sketch of the model Figure 2-86  Model for Tutorial 1
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The following steps are required to complete this tutorial: 

a.	 Start a new Autodesk Inventor session and then start a new English part file.
b.	 Invoke the Sketching environment. Next, draw the sketch by using the Line tool and 

specifying the coordinates of the points in the Dynamic Input mode.
c.	 Extrude the sketch upto a distance of 5 inch using the Extrude tool.
d.	 Save the model with the name Tutorial 1 and then generate its drawing views.

Starting Autodesk Inventor
1.	 Start Autodesk Inventor by double-clicking on its shortcut icon on the desktop of your 

computer; a new session of Autodesk Inventor starts.

2.	 Choose the New button from the left pane of the initial interface; the Create New File 
dialog box is displayed. 

3.	 Choose the English template and then double-click on the Standard (in).ipt icon; a new 
English standard part file starts.

4.	 Choose the Start 2D Sketch tool from the Sketch panel of the 3D Model tab; the default 
planes are displayed and you are prompted to select the sketching plane.

5.	 Now, select the XY plane (Front Plane) as the sketching plane from the graphics 
window; the Sketching environment is invoked and the XY plane (Front Plane) 
becomes parallel to the screen. 

Note
1. If by default, the grid lines are not displayed in the Sketching environment, choose the 
Application Options tool from the Options panel of the Tools tab; the Application Options dialog 
box will be invoked. Now, select the Grid lines check box from the Display area of the Sketch tab.

2. For the purpose of accuracy, grid lines are turned on in all the tutorials.

Drawing the Sketch	
	 As mentioned earlier, Autodesk Inventor is parametric in nature. Therefore, you can draw 

the sketch from any point in the drawing window. In this tutorial, you will start the sketch 
from the midpoint of the line at the bottom, as shown in Figure 2-87. Also, in this tutorial, 
Dynamic Input has been used to draw the sketch.

Specify the Start Point
	 Choose the Line tool, press Tab>0>Tab>0>Enter.		
	 (Choose the Line tool from the Create panel in the Sketch tab; you are prompted to select the first point 

of the line to be created. Press Tab and enter 0 in the X coordinate field of the Dynamic Input. Next, 
press Tab, enter 0 in the Y coordinate field, and press Enter). 

Draw Line 1
	 Move the cursor right, enter 2>Tab>0>Enter.
	 (Move the cursor toward right, enter 2 in the length input field, press Tab, enter 0 in the angle input 

field of the Dynamic Input, and press Enter).  Line 1 is drawn, as shown in Figure 2-87.
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Figure 2-87  Sketch for Tutorial 1

Draw Line 2
	 Move the cursor down, enter 0.25>Tab>90>Enter.
	 (Move the cursor down in the graphics window. Next, enter 0.25 in the length input field, press Tab, 

enter 90 in the angle input field, and press Enter). Line 2 is drawn, refer to Figure 2-87. 

Draw Line 3
	 Move the cursor right, enter 0.50>Tab>90>Enter.
	 (Move the cursor right in the graphics window. Next, enter 0.50 in the length input field, press Tab, 

enter 90 in the angle input field, and press Enter). Line 3 is drawn, refer to  Figure 2-87. 

Draw Line 4
	 Move the cursor upward, enter 0.75>Tab>90>Enter.
	 (Move the cursor upward in the graphics window. Next, enter 0.75 in the length input field, press Tab, 

enter 90 in the angle input field, and press Enter). Line 4 is drawn, refer to Figure 2-87. 

Draw Line 5
	 Move the cursor right, enter 3.0>Tab>90>Enter.

Draw Line 6
	 Move the cursor upward, enter 1.0>Tab>90>Enter.

Draw Line 7
	 Move the cursor left, enter 2.0>Tab>90>Enter.

Draw Line 8
	 Move the cursor upward, enter 3.0>Tab>90>Enter.

Draw Line 9
	 Move the cursor left, enter 7.0>Tab>90>Enter.
	

Draw Line 10
	 Move the cursor down, enter 3.0>Tab>90>Enter.
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Draw Line 11
	 Move the cursor left, enter 2.0>Tab>90>Enter.

Draw Line 12
	 Move the cursor down, enter 1.0>Tab>90>Enter.

Draw Line 13
	 Move the cursor right, enter 3.0>Tab>90>Enter.

Draw Line 14
	 Move the cursor down, enter 0.75>Tab>90>Enter.

Draw Line 15
	 Move the cursor right, enter 0.50>Tab>90>Enter.

Draw Line 16
	 Move the cursor upward, enter 0.25>Tab>90>Enter.

Draw Line 17
	 Move the cursor right, enter 2.0>Tab>90>Enter.

Exit the Sketching Environment
	 Right-click in the graphics window and then choose the Finish 2D Sketch button from the 

Marking menu displayed; the Sketching environment is closed and you switch to the Part 
modeling environment. 

Extruding the Sketch
	 Next, you need to extrude the sketch. 

1.	 Choose the Extrude tool from the Create panel of the 3D Model tab; the Properties-Extrusion 
dialog box is invoked and the sketch gets selected by default.

2.	 Enter 5 in the Distance A edit box available in the Behavior node. Alternatively, drag the 
extrude manipulator to specify the extrusion depth.  

 
3.	 Choose OK from the dialog box to create the model and exit the Properties-Extrusion 

tool. The extruded model is shown in Figure 2-88. 
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Figure 2-88  The model created on extruding the 
sketch

Saving the Model
	 Next, you need to save the model. 

1.	 Choose Save > Save from the File menu to save the model.

Generating Drawing Views of Model
1.	 Choose the New tool from the Quick Access Toolbar; the Create New File dialog box is 

displayed. 

2.	 In this dialog box, choose the English template and then double-click on the ANSI (in).
idw option; the default ANSI mm standard drawing sheet is displayed. 

3.	 Choose the Base View tool from the Create panel; the Drawing View dialog box is displayed 
along with front view of the model.

4.	 Next, move the cursor upward and generate the top view. 

5.	 Similarly, taking the front view as the parent view, generate the drawing of right-side view 
and the isometric view, as shown in Figure 2-89.

6.	 Choose the OK button from the Drawing View dialog box.



Sketching, Dimensioning, and Creating Base Features and Drawings	                           2-47	

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 2-89  Drawing sheet after generating the drawing views

Tutorial 2
Draw the sketch shown in Figure 2-90. Extrude the sketch by 10 units and then generate a 
drawing with the orthographic and isometric views of the model. The isometric view of the 
model is shown in Figure 2-91. You do not need to dimension the drawing.			 
                                               			                                   (Expected time: 30 min)

Figure 2-91  Model for Tutorial 2Figure 2-90  Sketch for Tutorial 2
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	 The following steps are required to complete this tutorial:

a.	 Start a new metric standard part file and invoke the Sketching environment.
b.	 Draw the sketch by using the Arc and Line tools, refer to Figure 2-90.
c.	 Extrude the sketch upto a distance of 10 mm using the Extrude tool.
d.	 Save the model with the name Tutorial2 and then generate its drawing views.

Starting a New File
1.	 Choose the New button from the left pane of the initial interface; the Create New File 

dialog box is displayed. 

2.	 Choose the Metric template and then double-click on the Standard (mm).ipt icon; a new 
Metric standard part file starts.

3.	 Choose the Start 2D Sketch tool from the Sketch panel of the 3D Model tab; the default 
planes are displayed and you are prompted to select the sketching plane.

4.	 Now, select the YZ Plane (Right plane) as the sketching plane from the graphics window; 
the Sketching environment is invoked and the YZ Plane (Right Plane) becomes parallel to 
the screen. 

Drawing the Sketch
	 The upper arc of the sketch can be drawn by specifying its center, start, and end points. 

Therefore, you need to use the Arc Center Point tool to draw it.

1.	 Choose the Arc Center Point tool from the Sketch > Create > Arc drop-down; you are 
prompted to specify the center of the arc. 

2.	 Press the Tab key and enter 0 in the X coordinate edit field of the Dynamic Input. Again, 
press Tab and enter 0 in the Y coordinate edit field. Next, press Enter to specify the center 
of the arc; the center of the arc (Point 1) is created, as shown in Figure 2-92, and you are 
prompted to specify the start point of the arc.

Figure 2-92  Sketch showing different points
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Note
In Figure 2-92, the major and minor grid lines, and the triad have not been displayed for better 
display of the sketch and the imaginary lines.

3.	 Enter 12 in the length input field, press Tab, enter 90 in the angle input field of the Dynamic 
Input, and press Enter; the first point (Point 2) on the arc is defined, refer to Figure 2-92.
Now, you need to specify the endpoint of the arc.

4.	 Move the mouse cursor anticlockwise and enter 180 in the angle input field and press Enter; 
the upper arc is drawn, as shown in Figure 2-93.

Figure 2-93  Sketch showing upper arc

	 Next, you need to draw lines in the sketch.

5.	 Choose the Line tool from the Create panel; you are prompted to specify the start 
point of the line. 

6.	 Move the cursor close to the start point of the arc; the yellow circle snaps to the start point 
of the arc and turns green indicating that the cursor has snapped to the start point of the 
arc. Press the left mouse button to select this point as the start point of the line.

7.	 Move the cursor left, enter 12>Tab>90>Enter.

8.	 Move the cursor downward, enter 30>Tab>90>Enter.

9.	 Move the cursor right, enter 12>Tab> 90>Enter. Figure 2-92 shows the different points of 
sketch for Tutorial 2.

	 Now, you need to draw the lower arc of the sketch. You can use the Three Point Arc tool to 
draw the arc.

10.	 Choose the Three Point Arc tool and click on the end point of the last line. 

11.	 Enter 24 in the length input field, press Tab, enter 90 in the angle input field in the 
Dynamic Input, and press Enter; the endpoint (Point 7) on the lower arc is defined, refer 
to Figure 2-92. Now, you need to specify the center point of the arc.
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12.	 Move the cursor upward, enter 12 in the length input field and press Enter; the lower arc 
is created, as shown in Figure 2-93.

Figure 2-93  Sketch showing lower arc

	 Next, you need to draw the remaining lines of the sketch using the Line tool.

13.	 Choose the Line tool from the Create panel and click on the end point (point 7) of the lower 
	 arc.

14.	 Move the cursor right, enter 12>Tab>90>Enter.

15.	 Move the cursor upward, enter 30>Tab>90>Enter.

16.	 Move the cursor left, enter 12>Tab>90>Enter.

17.	 Exit the Line tool. The final sketch for Tutorial 2 is shown in Figure 2-94.

18.	 Right-click in the graphics window and then choose the Finish 2D Sketch button from the 
Marking menu displayed; the Sketching environment is closed and you switch to the Part 
modeling environment. 
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Figure 2-94  Final sketch for Tutorial 2

Extruding the Sketch
	 Next, you need to extrude the sketch. 

1.	 Choose the Extrude tool from the Create panel of the 3D Model tab; the Properties-Extrusion 
dialog box is displayed and the sketch gets selected by default.

2.	 Enter 20 in the Distance A edit box available in the Behavior node. You can also use the 
extrude manipulator to specify the extrusion depth.   

3.	 Choose OK from the dialog box to create the model and exit the Properties-Extrusion 
tool. The extruded model is shown in Figure 2-95. 

Figure 2-95  The model created on extruding the 
sketch
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Saving the Model
	 Next, you need to save the model. 

1.	 Choose Save > Save from the File menu to save the model.

Generating Drawing Views of Model
1.	 Choose the New tool from the Quick Access Toolbar; the Create New File dialog box is 

displayed. 

2.	 In this dialog box, choose the Metric template and then double-click on the ANSI (mm).
idw  option; the default ANSI mm standard drawing sheet is displayed. 

3.	 Choose the Base View tool from the Create panel; the Drawing View dialog box is displayed 
along with front view of the model.

4.	 Next, move the cursor upward and generate the top view. 

5.	 Similarly, taking the front view as the parent view, generate the drawing of right-side view 
and the isometric view, as shown in Figure 2-96.

6.	 Choose the OK button from the Drawing View dialog box.

Figure 2-96  Drawing sheet after generating the drawing views

Tutorial 3
Draw the sketch shown in Figure 2-97. Extrude the sketch by 10 units and then generate a 
drawing with the orthographic and isometric views of the model.  The isometric view of the 
model is shown in Figure 2-98. You do not need to dimension the drawing.
		                                                                                                    (Expected time: 30 min)
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Figure 2-97  Dimensioned sketch for Tutorial 3
			   				  
	    
			     		      

Figure 2-98  Model for Tutorial 3

	 The following steps are required to complete this tutorial:

a.	 Start a new metric standard part file and invoke the Sketching environment.
b.	 Draw the initial sketch by using the Line and Two point rectangle tools.
c.	 Dimension the sketch.
d.	 Extrude the sketch upto a distance of 10 mm using the Extrude tool.
e.	 Save the model with the name Tutorial3 and then generate its drawing views.

Starting a New File and Invoking the Sketching Environment
	 Start Autodesk Inventor and then invoke the Sketching environment by selecting the 

sketching plane.

1.	 Start Autodesk Inventor by double-clicking on its shortcut icon on the desktop of your 
computer or by using the Start menu.
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2.	 Choose the Metric template and then double-click on the Standard (mm).ipt icon; a new 
Metric standard part file starts.

3.	 Choose the Start 2D Sketch tool from the Sketch panel of the 3D Model tab; the default 
planes are displayed and you are prompted to select the sketching plane.

4.	 Choose the Start 2D Sketch button from the Sketch panel of the 3D Model tab; the default 
planes are displayed and you are prompted to select the sketching plane.

5.	 Select the XY Plane (Front Plane) as the sketching plane from the graphics window; the 
Sketching environment is invoked and the XY Plane (Front Plane) becomes parallel to the 
screen.

Drawing and Dimensioning the Sketch
1.	 Draw line 1 and line 2 of any length as shown in Figure 2-99(a). Make sure the line 1 is 

horizontal and line 2 is vertical.

2. 	 Choose the Dimension tool from the Constrain panel of the Sketch tab. Alternatively, 
right-click anywhere in the graphics window and then choose General Dimension from the 
Marking menu displayed. Next, select line 1, refer to Figure 2-99(b).

3.	 Place the dimension below line 1; the Edit Dimension edit box is displayed. Enter 40 as 
the length of line 1 in this edit box and then click on the check mark on the right of this 
edit box. 

4.	 As the Dimension tool is still active, you are prompted again to select the geometry to 
dimension. Select line 2 and place the dimension on the left of this line, as shown in 
Figure 2-99(b); the Edit Dimension edit box is displayed. Change the length of this line to 
10 in this edit box and press Enter.

Figure 2-99(a)  Sketch drawn using the 
sketching tools 

Figure 2-99(b)  Dimensioning the sketch 

5. 	 Draw lines 3, 4, 5, 6, and 7, as shown in Figure 2-99(c). Make sure the lines are horizontal 
and vertical.

6.	 Dimension the lines, as shown in Figure 2-99(d).
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Figure 2-99(c)  Sketch drawn using the 
sketching tools 

Figure 2-99(d)  Dimensioning the sketch 

7.	 Draw the remaining lines, as shown in Figure 2-99(e).

8.	 Dimension the lines, as shown in Figure 2-99(f).

Figure 2-99(f)  Dimensioning the sketch Figure 2-99(e)  Sketch drawn using the 
sketching tools 

9. 	 Draw a rectangle using the Two-Point Rectangle tool, as shown in Figure 2-99(g).

10.	 Dimension the rectangle, as shown in Figure 2-99(h).

11.	 Right-click in the graphics window and then choose the Finish 2D Sketch button from the 
Marking menu displayed; the Sketching environment is closed and you switch to the Part 
modeling environment. 
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Figure 2-99(h)  Dimensioning the rectangleFigure 2-99(g)  Rectangle drawn using 
2-Point Rectangle tool 

Extruding the Sketch
	 Next, you need to extrude the sketch. 

1.	 Choose the Extrude tool from the Create panel of the 3D Model tab to invoke the  
Properties-Extrusion dialog box. 

	 As the sketch consists of two loops, the sketch is not automatically selected. Therefore, you 
need to select the profile to be extruded. 

2.	 Move the cursor outside the inner loop but inside the outer loop; the profile is highlighted.

3.	 Click anywhere in the highlighted area; a preview of the extruded model is displayed in the 
drawing window.

4.	 Enter 10 in the Distance A edit box available in the Behavior node. You can also use the 
extrude manipulator to specify the extrusion depth.  

5.	 Choose OK from the dialog box to create the model and exit the Properties-Extrusion 
tool. The extruded model is shown in Figure 2-100. 

Figure 2-100  The model created on extruding 
the sketch
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Saving the Model
	 Next, you need to save the model. 

1.	 Choose Save > Save from the File menu to save the model.

Generating Drawing Views of Model
1.	 Choose the New tool from the Quick Access Toolbar; the Create New File dialog box is 

displayed. 

2.	 In this dialog box, choose the Metric tab and then double-click on the ANSI (mm).idw  
option; the default ANSI mm standard drawing sheet is displayed. 

3.	 Choose the Base View tool from the Create panel; the Drawing View dialog box is displayed 
along with front view of the model.

4.	 Next, move the cursor upward and generate the top view. 

5.	 Similarly, taking the front view as the parent view, generate the drawing of right-side view 
and the isometric view, as shown in Figure 2-101.

6.	 Choose the OK button from the Drawing View dialog box.

Figure 2-101  Drawing sheet after generating the drawing views
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Tutorial 4
Draw the sketch shown in Figure 2-102. Revolve the sketch and then generate a drawing with the 
orthographic and isometric views of the model. The isometric view of the model is shown in 
Figure 2-103. You do not need to dimension the drawing. Use Dynamic Input to draw the 
feature. 							            (Expected time: 30 min)
         		       		        							         	
		                                              
	 The following steps are required to complete this tutorial:

a.	 Start a new metric standard part file and invoke the Sketching environment.
b.	 Draw the sketch with the help of Dynamic Input by using the Line tool.
c.	 Draw fillets. 
d.	 Revolve the sketch.
e.	 Save the model with the name Tutorial4 and then generate its drawing views.

Figure 2-103  Revolved model for
Tutorial 4

Figure 2-102  Sketch for the revolved model

Starting a New File
1.	 Choose the New button from the left pane of the initial interface; the Create New File 

dialog box is displayed. 
	
2.	 Choose  Metric to display the standard metric templates. Double-click on Standard (mm).ipt 

to start a new metric part file.

3.	 Choose the Start 2D Sketch tool from the Sketch panel of the 3D Model tab; the default 
planes are displayed and you are prompted to select the sketching plane.

4.	 Now, select the YZ Plane (Right Plane) as the sketching plane from the graphics window; 
the Sketching environment is invoked and the YZ Plane (Right Plane) becomes parallel to 
the screen. 
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Drawing the Sketch
1.	 Choose the Line tool, press Tab>0>Tab>0>Enter.
	 (Choose the Line tool from the Create panel in the Sketch tab; you are prompted to select the 

first point of the line to be created. Press Tab and enter 0 in the X co-ordinate field of the 
Dynamic Input. Next, press Tab, enter 0 in the Y coordinate field, and press Enter). 

2.	 Move the cursor left, enter 22>Tab>90>Enter. 
	 (Move the cursor toward left, enter 22 in the length input field, enter 90 in the angle input field of 

the Dynamic Input, and press Enter). Line 1 is drawn, as shown in Figure 2-104.

3.	 Move the cursor upward, enter 4>Tab>90>Enter.
	 (Move the cursor upward in the graphics window. Next, enter 4 in the length input field, press Tab, 

enter 90 in the angle input field, and press Enter). Line 2 is drawn, as shown in Figure 2-104.

Figure 2-104  Sketch after drawing the lines

4.	 Move the cursor left, enter 14>Tab>90>Enter.
	 (Move the cursor toward left in the graphics window. Next, enter 14 in the length input field, press 

Tab, enter 90 in the angle input field in the Dynamic Input, and press Enter). Line 3 is drawn, refer 
to Figure 2-104. 

5.	 Move the cursor upward, enter 6>Tab>90>Enter.

6.	 Move the cursor left, enter 8>Tab>90>Enter.

7.	 Move the cursor upward, enter 6>Tab>90>Enter.

8.	 Move the cursor right, enter 40>Tab>90>Enter.

9.	 Move the cursor upward, enter 9>Tab>90>Enter.

10.	 Move the cursor left, enter 16>Tab>90>Enter.

11.	 Move the cursor upward, enter 5>Tab>90>Enter.
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12.	 Move the cursor right, enter 20>Tab>90>Enter.

13.	 Move the cursor downward, enter 30>Tab>90>Enter.

14.	 The initial sketch is drawn. Exit the Line tool by choosing OK from the Marking menu.
 
Drawing Fillets
1.	 Choose the Fillet tool from the Sketch > Create > Fillet/Chamfer drop-down;  

the 2D Fillet dialog box is displayed. Enter 1.5 in the Radius edit box of this 
dialog box. Do not press Enter.

2.	 Select the line 8 and then line 9, refer to Figure 2-104; a fillet is created between these lines 
and the radius of the fillet is displayed in the sketch.

3.	 Similarly, select lines 7 and 8 and then lines 4 and 5 to create a fillet between these lines. 
Next, right-click, and choose OK from the Marking menu to exit the Fillet tool after creating 
all fillets. 

	 As all the lines are filleted with the same radius value, the radius of the fillet is not 
displayed on other fillets. This completes the sketch. The final sketch for this tutorial after 
filleting all the sketches is shown in Figure 2-105.

Note
In Figure 2-93, the display of the dimensions, axes and grids have been turned off for better 
visibility of the lines of the sketch.

Figure 2-105  Final sketch after filleting

4.	 Right-click in the graphics window and then choose the Finish 2D Sketch button from the 
Marking menu displayed; the Sketching environment is closed and you switch to the Part 
modeling environment. 

Revolving the Sketch
	 Next, you need to revolve the sketch. 

1.	 Choose the Revolve tool from the Create panel of the 3D Model tab to invoke the  
Properties-Revolution dialog box. 
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2.	 Select the bottom horizontal line measuring 22 mm as the axis of revolution; the selected line 
gets displayed in the Axis display box.

	 When you move the cursor close to this line, it is highlighted. On selecting this line, a  
preview of the revolved model is displayed in the drawing window. 

 3.	 Accept the default values and choose the OK button from the Properties-Revolution dialog 
box.  The revolved model is shown in Figure 2-106.

Figure 2-106  The model created on revolving 
the sketch

Saving the Model
	 Next, you need to save the model. 

1.	 Choose Save > Save from the File menu to save the model.

Generating Drawing Views of Model
1.	 Choose the New tool from the Quick Access Toolbar; the Create New File dialog box is 

displayed. 

2.	 In this dialog box, choose the Metric tab and then double-click on the ANSI (mm).idw  
option; the default ANSI mm standard drawing sheet is displayed. 

3.	 Choose the Base View tool from the Create panel; the Drawing View dialog box is displayed 
along with front view of the model.

4.	 Next, move the cursor upward and generate the top view. 

5.	 Similarly, taking the front view as the parent view, generate the drawing of right-side view 
and the isometric view, as shown in Figure 2-107.
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6.	 Choose the OK button from the Drawing View dialog box.

Figure 2-107  Drawing sheet after generating the drawing views

 SELF-EVALUATION TEST 
Answer the following questions and then compare them to those given at the end of 
this chapter:

1.	 In Autodesk Inventor, the two types of sketching entities that can be drawn are __________ 
and __________.

2.	 In the Sketching environment, the __________ tool is used to place a sketch point or a center 
point.

3.	 Filleting is defined as the process of __________ the sharp corners and sharp edges of models.

4.	 You can toggle between the length and angle input fields by using the _____________ key.

5.	 You can use the  _____________ toolbar to precisely enter coordinates of the points in the 
graphics window.

6.	 You can also delete the sketched entities by pressing the __________ key.

7.	 In Autodesk Inventor, rectangles are drawn as a combination of __________ entities.

8.	 You can undo the last drawn spline segment when you are still inside the spline drawing 
option by choosing __________ from the Marking menu displayed.
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9.	 You can exit the Line tool by pressing the _____________ key or by choosing ___________ 
from the ________________ menu.

10.	 Most of the designs created in Autodesk Inventor are a combination of sketched features 
and placed features. (T/F)

11.	 Whenever you start a new file in the Part module, the Sketching environment is invoked by 
default. (T/F)

12.	 You cannot turn off the display of grid lines. (T/F)

13.	 You cannot draw an arc while the Line tool is active. (T/F)

 REVIEW QUESTIONS 
Answer the following questions: 

1.	 Which of the following tools in the Tools tab is used to invoke additional toolbars?

		  (a) Application Options		 (b) Customize
		  (c) Document Setting		  (d) None of these

2.	 Which of the following drawing display options is used to interactively zoom in and out a 
drawing?

		  (a) Zoom All			   (b) Pan
		  (c) Zoom			   (d) Zoom Window

3.	 Which of the following keys is used to restore the previous view?

		  (a) F5	 			   (b) F6
		  (c) F7	 			   (d) F4

4.	 Which of the following drawing display options prompts you to select an entity whose 
magnification has to be increased?

		  (a) Zoom			   (b) Pan
		  (c) Zoom Selected		  (d) None of these

5.	 In most of the designs, generally the first feature or the base feature is the placed feature. 
(T/F)

6.	 You can invoke the options related to sheet metal parts from the .ipt file. (T/F)

7.	 You can change the current project directory and the project files by choosing Projects 
button from the Open dialog box. (T/F)
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8.	 You can specify the position of entities dynamically by using the Dynamic Input. (T/F)

9.	 In Autodesk Inventor, you can save a file in the Sketching environment. (T/F)

10.	 In Autodesk Inventor, you can start a new file by using the Open dialog box. (T/F) 

EXERCISES
Exercise 1
Draw the sketch shown in Figure 2-108. Extrude the sketch by 10 units and then generate a 
drawing with the orthographic and isometric views of the model. The isometric view of the 
model is shown in Figure 2-109. You do not need to dimension the drawing. 
								             (Expected time: 30 min)	
	  				                             		      			       	
	     					                                    	       

Figure 2-108  Sketch for Exercise 1 Figure 2-109  Model for Exercise 1

Ex- e r -
cise 2
Draw the sketch shown in Figure 2-110. Extrude the sketch by 10 units and then generate a 
drawing with the orthographic and isometric views of the model. The isometric view of the model 
is shown in Figure 2-111. You do not need to dimension the drawing.	      		     	
				        	       			       (Expected time: 30 min)
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Figure 2-110  Sketch for Exercise 2 Figure 2-111  Model for Exercise 2

Exercise 3
Draw the sketch shown in Figure 2-112. Extrude the sketch by 20 units and then generate a 
drawing with the orthographic and isometric views of the model. The isometric view of the  
model is shown in  Figure 2-113. You do not need to dimension the drawing.
 	   	                                                                                                  (Expected time: 45 min)

Figure 2-112  Sketch for Exercise 3 Figure 2-113  Model for Exercise 3
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Exercise 4
Draw the sketch shown in Figure 2-114. Extrude the sketch by 20 units and then generate a 
drawing with the orthographic and isometric views of the model. The isometric view of the  
model is shown in  Figure 2-115. You do not need to dimension the drawing.
 	   	                                                                                                  (Expected time: 45 min)

Figure 2-115  Model for Exercise 4Figure 2-114  Sketch for Exercise 4

Answers to Self-Evaluation Test
1. normal, construction, 2. Point, 3. rounding, 4. Tab, 5. Inventor Precise Input, 6. DELETE, 
7. individual, 8. Back, 9. ESC, Cancel (ESC), Marking menu, 10. T, 11. F, 12. F, 13. F


