
Chapter 3

Adding Constraints to 
Sketches 

 Learning Objectives 
After completing this chapter, you will be able to:
• Add geometric constraints to a sketch
• Control the constraint inference
• View and delete constraints from a sketch
• Measure distances, angles, loops, and areas in a sketch
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ADDING GEOMETRIC CONSTRAINTS TO A SKETCH 
Constraints are applied to the sketched entities to define their size and position with respect to 
other elements. Also, they are useful for capturing the design intent. As mentioned in Chapter 1, 
there are twelve types of geometric constraints that can be applied to the sketched entities. These 
constraints restrict their degrees of freedom and make them stable. Most of these constraints get 
automatically applied to the entities while drawing. However, sometimes you may need to apply 
some additional constraints to the sketched entities. These constraints are discussed next.

Perpendicular Constraint
 Ribbon:		 Sketch > Constrain > Perpendicular Constraint 	  

The Perpendicular constraint forces the selected entity to become perpendicular to the 
specified entity. The entities to which the constraints can be applied are lines and ellipse 
axes. To apply this constraint, choose the Perpendicular Constraint tool from the 

Constrain panel of the Sketch tab; you will be prompted to select the first line or an ellipse axis. 
After selecting the first entity, you will be prompted to select the second line or ellipse axis. On 
selecting the second entity, the selected entities will become perpendicular. Figure 3-1 shows 
two lines before and after adding this constraint. Similarly, you can also apply the Perpendicular 
constraint between two arcs.

Parallel Constraint
 Ribbon:		 Sketch > Constrain > Parallel Constraint	    

The Parallel constraint forces the selected entity to become parallel to the specified 
entity. The entities to which this constraint can be applied are lines and ellipse axes. To 
apply this constraint, choose the Parallel Constraint tool from the Constrain panel of 

the Sketch tab; you will be prompted to select the first line or an ellipse axis. After you select 
an entity, you will be prompted to select the second line or an ellipse axis. On selecting the 
second entity, the two entities will become parallel. Figure 3-2 shows two lines before and after 
adding this constraint.

Figure 3-1  Lines before and after applying 
the Perpendicular constraint

Figure 3-2  Lines before and after applying the 
Parallel constraint
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Tangent Constraint
 Ribbon:		 Sketch > Constrain > Tangent 	

The Tangent constraint forces the selected line segment or curve to become tangent to 
another curve. To apply this constraint, choose the Tangent tool from the Constrain 
panel of the Sketch tab; you will be prompted to select the first curve. After you select 

the first curve, you will be prompted to select the second curve. The curves that can be selected 
are lines, circles, ellipses, or arcs. Figures 3-3 and 3-4 show the Tangent constraint applied 
between a line and a circle, and between an ellipse and arc, respectively.

Figure 3-3  The Tangent constraint applied 
between a line and a circle

Figure 3-4 The Tangent constraint 
applied between an ellipse and an arc

Coincident Constraint
 Ribbon:		 Sketch > Constrain > Coincident Constraint  

The Coincident constraint forces two points or a point and a curve to become coincident. 
To apply this constraint, choose the Coincident Constraint tool from the Constrain 
panel of the Sketch tab; you will be prompted to select the first curve or point. After 

you select the first curve or point, you will be prompted to select the second curve or point. Note 
that either the first or the second entity selected should be a point. The points include sketch 
points, endpoints of a line or an arc, or center points of circles, arcs, or ellipses.

Concentric Constraint
 Ribbon:		 Sketch > Constrain > Concentric Constraint  

The Concentric constraint forces two curves to share the same location of center points. 
The curves that can be made concentric include arcs, circles, and ellipses. When you 
invoke this constraint, you will be prompted to select the first arc, circle, or ellipse. After 

making the first selection, you will be prompted to select the second arc, circle, or ellipse. Select 
the second entity to be made concentric with the first entity.
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Note
If you apply a constraint that over-constrains a sketch, the Autodesk Inventor Professional - Create 
Constraint message box will be displayed informing that adding this constraint will over-constrain 
the sketch, refer to Figure 3-5. A sketch is said to be over-constrained if the number of dimensions 
or constraints in it exceeds the number that can be applied to the sketch.

Figure 3-5  The Autodesk Inventor Professional - Create Constraint message box 

Collinear Constraint
 Ribbon:		 Sketch > Constrain > Collinear Constraint  

The Collinear constraint forces the selected line segments or ellipse axes to be placed 
in the same line. When you invoke this constraint, you will be prompted to select the 
first line or ellipse axis. After making the first selection, you will be prompted to select 
the second line or ellipse axis. Select the entity to be made collinear with the first entity.

Tip
To select an ellipse axis, move the cursor close to the ellipse. The minor or the major axis, 
whichever the cursor is close to, will get highlighted. When the required axis is highlighted, 
select it using the left mouse button.

Horizontal Constraint
 Ribbon:		 Sketch > Constrain > Horizontal Constraint  

The Horizontal constraint forces the selected line segment, ellipse axis, or two points 
to become horizontal, irrespective of their original orientation. When you invoke this 
constraint, you will be prompted to select a line, an ellipse axis, or the first point. If you 

select a line or an ellipse axis, it will become horizontal. If you select a point, you will be 
prompted to select the second point. The points, in this case, can also include the center points 
of arcs, circles, or ellipses.

Vertical Constraint
 Ribbon:		 Sketch > Constrain > Vertical Constraint  

The Vertical constraint is similar to the Horizontal constraint with the only difference 
that this constraint forces the selected entities to become vertical.
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Tip
You can use the Horizontal or Vertical constraint to line up arcs, circles, or ellipses in the 
horizontal or vertical direction by selecting their center points.

Equal Constraint
 Ribbon:	 Sketch > Constrain > Equal   

The Equal constraint can be used for line segments or curves. If you select two line 
segments, this constraint will force the length of one of the selected line segments to 
become equal to the length of the other selected line segment. In case of curves, this 

constraint will force the radius of one of the selected curves to become equal to that of the 
other selected curve. Note that if the first selection is a line, the second selection will also be a 
line. Similarly, if the first selection is a curve, the second selection also needs to be a curve.

	

Fix Constraint
 Ribbon:		 Sketch > Constrain > Fix   

The Fix constraint is used to fix the orientation or location of the selected curve or 
point with respect to the coordinate system of the current drawing. If you apply this 
constraint to a line or an arc, you cannot move them from their current locations. 

However, you can change their length by selecting one of their endpoints and then dragging 
them. If you apply this constraint to a circle or an ellipse, you cannot edit either of these entities 
by dragging. Once you apply this constraint to an entity, its color changes. 

Symmetric Constraint
 Ribbon:		 Sketch > Constrain > Symmetric   

This constraint is used to force two selected sketched entities to become symmetrical 
about a single sketched line segment. On invoking this constraint, you will be prompted 
to select the first sketched element. Note that you can select only one entity at a time 

to apply this constraint. Once you have selected the first sketched entity, you will be prompted 
to select the second sketched element. Select the second sketched entity; you will be prompted 
to select the symmetry line. Select the symmetry axis (an axis about which the selected 
entities need to be symmetric); the second selected entity will become symmetric to the first 
entity. After you have applied this constraint to one set of entities, you will again be prompted 
to select the first and second sketched entities. However, this time you will not be prompted to 
select the line of symmetry. The last line of symmetry will be automatically selected to add this 
constraint. Similarly, you can apply this constraint to other entities. 

If the line of symmetry is different for applying the symmetric constraint to different entities in 
the sketch, you will have to restart the process of applying this constraint by right-clicking and 
then choosing the Restart option from the Marking Menu. This is because the first symmetry line 
is used to apply this constraint to all sets of entities you select. However, if you restart applying 
this constraint, you will be prompted to select the line of symmetry again.
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Smooth Constraint
 Ribbon:	 Sketch > Constrain > Smooth (G2)  

This constraint is used to apply curvature continuity between a spline and an entity 
connected to it. The entities that can be selected to apply this constraint include a line, 
arc, or another spline. Note that these entities should be connected to the spline.

Note
In Autodesk Inventor, you can apply the Perpendicular, Tangent, and Smooth (G2) constraints 
between different types of splines. 

VIEWING THE CONSTRAINTS APPLIED TO A SKETCHED 
ENTITY
 Ribbon:	 Sketch > Constrain > Show Constraints  

You can view all the constraints that are applied to

Figure 3-6  Constraints applied 
to the sketch entities

 
the entities of a sketch by choosing the Show 
Constraints tool from the Constrain panel. When 

you invoke this tool and move the cursor close to a sketched 
entity, it will be highlighted and constraints will be displayed 
after a pause. These constraints show the symbols of all the 
constraints that are applied to the entity. Figure 3-6 shows 
the constraints applied to the lines. You can move a constraint 
by selecting and dragging it. In the case of Coincident 
constraint, the constraint applied on a point is highlighted 
in yellow. To view symbols, move the cursor over the 
highlighted yellow point; the color of the point will change,  
refer to Figure 3-6.

If you move the cursor close to a constraint, it will be highlighted and the entities to which 
the constraint is applied is also highlighted. For example, if you take the cursor close to a 
perpendicular constraint, the vertical line will also be highlighted along with the horizontal 
line, suggesting that the two lines are perpendicular to each other.

Tip
You can display all the constrains applied to the entities. To do so, choose the Show All 
Constraints button from the status bar which is available at the bottom of the graphics window; 
separate symbols will be displayed showing the constraints on all entities. Similarly, to hide all 
constraints, choose the Hide All Constraints button from the status bar.
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CONTROLLING CONSTRAINTS AND APPLYING THEM 
AUTOMATICALLY WHILE SKETCHING
 Ribbon:		 Sketch > Constrain > Constraint Settings	    

You can control and select the constraints that need to be applied automatically as well 
as select the geometry to which they will be applied. You can do so by using the 
Constraint Settings dialog box. To invoke this dialog box, choose the Constraints 
Settings tool from the Constrain panel of the Sketch tab. This dialog box is discussed 
next.

Constraint Settings Dialog box
While drawing the sketch, by default, all the possible constraints get automatically applied to 
the sketching entities. However, you can also specify the constraints that need to be applied 
automatically and the geometry to which they will be applied while sketching. To do so, choose 
the Constraint Settings tool from the Constrain panel of the Sketch tab; the Constraint Settings 
dialog box will be displayed, as shown in Figure 3-7. The options in this dialog box are discussed 
next.

Figure 3-7  The Constraint Settings dialog box

General
The General tab is chosen by default. The options in this tab are discussed next.

Constraint
Three check boxes are available in this area. The Display constraints on creation check 
box allows you to display the constraints applied during the creation of sketch. The Show 
constraints for selected objects check box allows you to show the constraints applied on  
the selected object. If you select the Display Coincident constraints in Sketch check box, 
Autodesk Inventor allows you to display the coincident constraints applied to the sketch. 
By default, this check box is clear.
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Dimension
This area is used to apply the Dimensions constraints to the sketch. In this area, two check 
boxes are available. These check boxes are used to apply dimensions during the creation 
of sketch.

Over-constrained Dimensions
This area is used to control the over defined dimensions applied to the sketch. In this area, 
two radio buttons are available. If you select the Apply driven dimension radio button, you 
will be able to apply the over defined dimension to the sketch. In this case, over defined 
dimension is considered as the reference dimension. The Warn of overconstrained condition 
radio button is selected by default in this area. Therefore, you will not be able to apply the 
over defined dimensions to the sketch. In this case, a warning message will be displayed.

Inference
In the Inference tab, two areas are available. The options in this tab are discussed next.

Constraint Inference Priority
This area is used to set up the inference priority of the constraints. You need to select the 
appropriate radio button to set up the priority.

Selection for Constraint Inference
In this area, nine check boxes corresponding to nine constraints are available. All check boxes 
are selected by default. However, if you need to clear all the constraints, choose the Clear 
All button. You can manually select or clear the required constraint by selecting the 
corresponding check box provided on the right of the constraint symbols. The selected 
constraints will be applied automatically to the geometry while sketching. 

Relax Mode
In this tab, the Enable Relax Mode check box is available. If you select this check box, you will 
be able to remove the constraints from the geometry while dragging the sketch. In this case, 
you can remove only that constraint whose respective check box is selected in the Constraints 
to remove in relax dragging area.

Scope of Constraint Inference 
 Ribbon:		 Sketch > Constrain > Constraint Inference Scope	  

The Constraint Inference Scope tool is used to set the geometry to which the constraint 
is applied while drawing. You can invoke this tool from the Constrain panel of the Sketch 
tab. On invoking this tool, the Constraint Inference Scope dialog box will be displayed. 

In this dialog box, the Geometry in current command radio button is selected by default. As a 
result, the constraint is applied to the current geometry. If you select the Select radio button, 
the Select button will be enabled automatically. You can use this button to select the geometry 
to which the constraints will be applied. If you select the All Geometry radio button, the constraint 
will be applied to all the active sketches.
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DELETING GEOMETRIC CONSTRAINTS
Autodesk Inventor allows you to delete the constraints applied to

Figure 3-8  Choosing the Delete   
option from the Marking menu

 
the selected entities. To delete constraints, first you need to show 
the constraint of entities by using the Show Constraints tool. 
Once the constraints are displayed, exit the Show Constraints 
tool by pressing the ESC key. Next, move the cursor over the 
constraint that you want to delete; it will be highlighted in red. 
Click the left mouse button to select the constraint. Next, move 
the cursor away and right-click, and then choose Delete from 
the Marking menu, see Figure 3-8. The selected constraint will 
be deleted. Similarly, you can delete all unwanted constraints 
from the sketch.

Note
The total number of constraints and dimensions required to fully constraint a sketch is displayed 
at the lower right corner of the graphics window.

Tip
When you move the cursor close to a constraint, its references will be highlighted in the sketch. 
For example, if you move the cursor over the Perpendicular constraint, the lines on which 
this constraint is applied will be highlighted indicating that the constraint selected is correct. 

SETTING THE SCALE OF A SKETCH
In Autodesk Inventor, if you change the current length of an entity by changing its dimension 
value, all the other entities of the sketch get modified proportionally or scaled accordingly. Note 
that this will be applicable only if no other dimension is applied to the sketch. As you apply the 
second dimension to the sketch, the sketch will not be scaled proportionally, on changing the 
dimension value. Figure 3-9 shows the sketch without any dimension and Figure 3-10 shows the 
sketch scaled automatically after applying the first dimension to it.

Figure 3-9  Sketch on the graphics screen Figure 3-10  Sketch resized after editing the  
first dimension 
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CREATING DRIVEN DIMENSIONS
 Ribbon:	 Sketch > Format > Driven Dimension    

This toggle button is used to switch between the driven dimension and the sketch (driving) 
dimension. A dimension is called as a sketch (driving) dimension, if it forces an entity 
to change its length and orientation. A driven dimension is the one whose value depends 

on the value of the sketch (driving) dimension. The driven dimensions are enclosed within 
parenthesis and display the current value of the sketched geometry. This value cannot be 
modified. If you change the value of the sketch (driving) dimension, the value of the driven 
dimension will change automatically, as shown in Figures 3-11 and 3-12. All dimensions applied 
after choosing the Driven Dimension button will be the driven dimensions. To convert sketch 
(driving) dimensions into driven dimensions, select the required sketch (driving) dimension and 
choose the Driven Dimension button from the Format panel.  

Figure 3-12  Modified driving dimension and 
dynamically updated driven dimension 

Figure 3-11  Driving dimension and driven 
dimension in a sketch

UNDERSTANDING THE CONCEPT OF FULLY-CONSTRAINED
SKETCHES
A fully-constrained sketch is one whose entities are all completely constrained to their 
surroundings using constraints and dimensions. In a fully-constrained sketch, all degrees 
of freedom of the sketch are constrained. A fully-constrained sketch cannot change its size, 
location, or orientation unexpectedly. Whenever you draw a sketched entity, it will turn green 
in color. However, the entity will turn blue if you add required dimensions to a sketch to make 
it fully constrained. There is one more method to understand whether the sketched entities 
are fully-constrained or not. In this method, you need to right-click on the sketched entity and 
choose the Display Degrees of Freedom option from the Marking Menu displayed; the entities 
will display the available degrees of freedom such as horizontal, vertical, angular, or rotational. 
Alternatively, click on the Show All Degrees of Freedom toggle button available at the bottom of 
the graphics window to display the degrees of freedom. Note that while creating the base sketch 
in Autodesk Inventor, you need to dimension it with respect to a fixed point to fully constrain it. 
To do so, you can fix the sketch with the origin, which is already fixed by default. You can control 
the visibility of this origin. To hide this point, choose the Application Options button from 
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the Tools tab; the Application Options dialog box will be invoked. Choose the Sketch tab and 
then clear the Autoproject part origin on sketch create check box. Next, close the dialog box.

Tip
In Autodesk Inventor, when you switch into the Part module; a fully-constrained sketch gets 
denoted by the  symbol in the Browser Bar.

MEASURING SKETCHED ENTITIES                          
 Ribbon:		 Inspect > Measure > Measure   

Autodesk Inventor allows you to measure various parameters of the sketched entities. The 
parameters that you can measure are distances, angles, loops, and area. All these parameters 
can be measured by using the Measure tool from the Measure panel of the Inspect tab. Various 
methods of measuring these parameters are discussed next.

Measuring Distances
You can measure the distance between various entities by using the Measure tool. The methods 
of measuring distances between various entities are discussed next.

Tip
To restart measuring the distances, right-click in the graphics window to display a shortcut 
menu and then choose Repeat Measure; you will be prompted to select the first element to 
be measured. 

Measuring the Length of a Line Segment
When you invoke the Measure tool, the Measure dialog box will be displayed and you will be 
prompted to select the first entity. Select a line segment; the length of the selected line segment 
will be displayed in this dialog box, see Figure 3-13.	

Figure 3-13  The Measure dialog box displaying the 
length of a line segment 

Measuring the Distance between a Point and a Line Segment
To measure the distance between a point and a line segment, invoke the Measure tool and then 
select the point. The Measure dialog box will display the X, Y, and Z coordinates of the point 
under the Position rollout, and you will be prompted to select the next entity. Select the line; 
the dialog box will display the minimum and maximum distance between the point and the 
line, and the length of the line, see Figure 3-14.
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Figure 3-14  The Measure dialog box displaying 
the distance between a point and line

Measuring the Coordinates of a Point
To measure the coordinates of a point with respect to the current coordinate system, invoke 
the Measure tool; you will be prompted to select the first element. Select the point whose 
coordinates you want to know; the coordinates of the selected point will be displayed in the 
Measure dialog box under the Position rollout, see Figure 3-15. The selectable points include 
the endpoints of lines, arcs, or splines, center point of arcs, circles, or ellipses, or hole centers.

Measuring the Distance between Two Points
To measure the distance between two points, invoke the Measure tool and then select the first 
point; the coordinates of the selected point will be displayed in the Measure dialog box. You 
will be prompted to select the second element. Select the second point; the distance between 
the two points will be displayed in the Measure dialog box. This dialog box will also display the 
coordinates of both the points. You will also notice the X Distance, Y Distance, and Z Distance 
values in the Delta rollout of this dialog box, see Figure 3-16. These values are the distances 
between the two selected points along the X, Y, and Z axes.

Figure 3-16  The Measure dialog box 
displaying distance between two points

Figure 3-15  The Measure dialog box displaying 
the coordinates of a point
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Measuring the Radius of an Arc or the Diameter of a Circle
You can also measure the radius of an arc or the diameter of a circle by using the Measure 
tool. To do so, invoke the Measure tool, the Measure dialog box will be displayed and you will 
be prompted to select the first item. Select an arc or a circle. On selecting the first item, the 
radius of the arc or the diameter of the circle will be displayed with some information of the 
selected entity, such as the angle of arc, its length, and the coordinates of the center point, see 
Figure 3-17 and Figure 3-18.

Figure 3-17  The Measure dialog box 
displaying the radius of the arc 

Figure 3-18  The Measure dialog box 
displaying the diameter of the circle

Measuring Angles
You can also measure the angle between two line segments by using the Measure tool. The 
methods of measuring angle between various entities are discussed next. 

Measuring the Angle between Two Lines
To measure the angle between two lines, invoke the Measure

Figure 3-19  The Measure dialog box 
displaying the angle between two lines

 
tool; the Measure dialog box will be displayed and you will 
be prompted to select the first item. Select the first line; 
you will be prompted to select the second line. Select the 
second line; the angle between the selected line segments will 
be displayed with various other measurements in the 
Measure dialog box, refer to Figure 3-19.

Measuring the Angle Using Three Points
You can also measure the angle using three points. When 
you invoke the Measure tool, you will be prompted to select 
the first point. Select the first point; you will be prompted to select the next point. After you 
select the second point, you will again be prompted to select the next point. Select the third 
point by pressing and holding the SHIFT key. Once you have selected the three points, Autodesk 
Inventor draws reference lines between the first and second points as well as between the second 
and third points, as shown in Figures 3-20 and 3-21. The angle between these two reference 
lines will be measured and displayed in the dialog box.

Measuring the Angle Between Two Faces
You can also measure angle between two faces. When you invoke the Measure tool, you will be 
prompted to select the first item. Select the first face or plane; you will be prompted to select the 
next point. Select the second face or plane. The angle between these two faces will be measured 
and displayed in the dialog box and in the graphics window.
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Figure 3-21  Angle between reference linesFigure 3-20  Selecting three points

Measuring Loops
You can also measure a loop by using the Measure tool. To measure a close loop, invoke the 
Measure tool, the Measure dialog box will be displayed; you will be prompted to select a face or 
a loop. On selecting a face or a loop, the total length of the loop will be displayed in this dialog 
box. Figure 3-22 shows the Measure dialog box with the measurement of a loop.

Measuring the Area
You can also measure the area of a closed loops by using the Measure tool. To measure the area 
of a closed loops, invoke the Measure tool; the Measure dialog box will be displayed and you 
will be prompted to select a face or a loop. Select the closed loop to measure the area; the area 
of the loop or the face will be displayed in the dialog box. Figure 3-23 shows the Measure dialog 
box with the area of a closed loop.

Figure 3-23  The Measure dialog box 
displaying the area of a face or loop

Figure 3-22  The Measure dialog box 
displaying the loop length

Tip
You can also measure the loop or the area defined by the face of an existing feature. You will 
learn more about these features in the later chapters.

Evaluating Region Properties
 Ribbon:	 Inspect > Measure > Region Properties   

This tool is used to evaluate the properties of the closed loop sketch such as area, perimeter, 
and also display the region properties of the sketch such as Area and Polar Moment of Inertia by 
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taking measurements from the sketch coordinate system. To invoke this tool, choose the Region 
Properties tool from the Measure panel of the Inspect tab; the Region Properties dialog box 
will be displayed, as shown in Figure 3-24. The options in this dialog box are discussed next.

Figure 3-24  The Region Properties dialog box

Note
The Region Property tool can only be invoked in the 2D sketching mode.

Selections
When you invoke the Region Properties dialog box, this area is chosen by default; you will be 
prompted to select one or more closed sketch loops. Select one or more closed sketch loops from 
the drawing window. The selected loop will be displayed under this area.

Dual Units
You can select the required unit of measurement from this drop-down list to display the results 
of measurements in the selected unit.

Calculate
This button is used to calculate the result. To calculate the result, select the sketch loop. After 
selecting the sketch loop, choose the Calculate button; the results will be displayed in the display 
box. In case you add or remove a closed loop from the Selections area or change the unit in the 
Dual Units drop-down list, the recalculation will occur and the updated results will be displayed 
in the display box on again selecting the Calculate button.

TUTORIALS
From this chapter onward, you will use the parametric feature of Autodesk Inventor for 
drawing and dimensioning the sketches. The following tutorials will explain the method of 
drawing sketches with some arbitrary dimensions and then driving them to the dimension values 
required in the model.
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Tutorial 1
In this tutorial, you will draw the sketch for the model shown in Figure 3-25. After drawing the 
sketch, you will add the required constraints to it and then dimension it. The dimensioned sketch 
required for this model is shown in Figure 3-26. The solid model shown in Figure 3-25 is only 
for reference.					           	   

The sketch shown in Figure 3-26 is the combination of multiple closed loops: the outer loop 
and inner circles. As the numbers of loops increase, so does the complexity of the sketch. This 
is because the numbers of constraints and dimensions in a sketch increase in case of multiple 
loops. Now, to draw sketches without using the Dynamic Input, it is recommended that you first 
draw the outer loop of the sketch and then add constraints and dimensions to it. This is because 
once the outer loop has been constrained and dimensioned, the inner circles can be constrained 
and dimensioned easily with reference to the outer loop. 
								              (Expected time: 30 min)

Figure 3-25  Model for Tutorial 1 Figure 3-26  Dimensioned sketch of the model

	 The following steps are required to complete this tutorial:

a.	 Start a new metric template and draw the outer loop of the sketch.
b.	 Add required dimensions and constraints to the outer loop.
c.	 Draw inner circles and add constraints and dimensions to them.
d.	 Save the sketch with the name Tutorial1.ipt and close the file.

Starting a New File and Invoking the Sketching Environment
1.	 Choose the New button from the Quick Access Toolbar and start a new metric standard 

part file using the Metric tab of the Create New File dialog box.

2.	 Choose the Start 2D Sketch button from the Sketch panel of the 3D Model tab; the default 
planes are displayed and you are prompted to select the sketching plane.
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3.	 Select the XY Plane (Front Plane) as the sketching plane from the graphics window; the 
Sketching environment is invoked and the XY Plane (Front Plane) becomes parallel to the 
screen.

Drawing the Outer Loop
1.	 Invoke the Line tool from the Create panel in the Sketch tab, refer to Figure 3-27. 

Figure 3-27  Profile with geometries 
numbered

	 You can also draw the tangent arcs while using the Line tool. This can be done by invoking 
the Line tool and by pressing the left mouse button and then dragging it in the required 
direction. Move the cursor close to the endpoint of the last line until the yellow circle snaps 
to that point. When the yellow circle snaps to the endpoint, it turns gray.  Next, press and 
hold the left mouse button and drag the mouse through a small distance in the upward 
direction. 

	 For your reference, all the geometries in the sketch are numbered. You will draw inner holes 
in the sketch after dimensioning the outer loop.

Note
The outer loop that you created in the previous step might be different from the one shown in 
Figure 3-27. You can find the missing constraints by following the next step and applying constraints 
accordingly.

Adding Constraints to Sketched Entities
	 As evident from Figure 3-27, some of the constraints such as tangent and equal are missing in 

the sketch. The sketch shown in Figure 3-27 may not be symmetrical and all the lines in the 
sketch may not be tangent to the arcs. Therefore, you need to add these missing constraints 
manually to the sketch to complete it. You can choose the Show Constraint option from the 
Marking menu that is displayed when you right-click on an entity.  
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1.	 In Figure 3-27, the Tangent constraint is missing between line 1 and arc 10. To add this 
constraint between the line and the arc, choose the Tangent tool from the Constrain panel 
of the Sketch tab; you are prompted to select the first curve. Select arc 10 as the first curve; 
you are prompted to select the second curve. Select line 1 as the second curve. Similarly, 
add this constraint to all the places in the sketch wherever it is missing.

	 The geometries 5 and 7, and 3 and 9 are the lines that must be of equal length. Also, the 
geometries 2 and 10, and 4 and 8 are the arcs that must be of equal radii. Therefore, you 
need to add the Equal constraint between the respective pairs of all these geometries. 

2.	 Choose the Equal tool from the Constrain panel of the Sketch tab.		     

3.	 Select line 5 as the first line and then line 7 as the second line to apply the Equal constraint 
to them; you are prompted again to select the first entity. 

4.	 Select line 3 and then line 9 to apply the Equal constraint to them; you are prompted to 
select the first entity again.

5.	 Select arc 2 and then arc 10 to apply the Equal constraint to them. Applying this constraint 
to arcs or circles forces their radii or diameters to be equal.

6.	 Similarly, apply the Equal constraint to arc 4 and arc 8. 

7.	 Apply the Coincident constraint between the center point of arc 4 and line 5, and the center 
point of arc 8 and line 7 if not automatically applied. 

8.    Choose the Symmetric tool from the Constrain panel of the Sketch tab to apply Symmetric 
constraint between line 3 and line 9. To apply a symmetric constraint, you need to draw a 
vertical line of symmetry through the origin. 

9.	 Choose the Coincident Constraint tool from the Constrain panel; you are prompted to 
select the first curve or point.

10.	 Select the origin; you are prompted to select the second curve or point.

11.	 Select the center point of arc 6; the entire sketch moves to make the origin coincident with the 
center point of the arc. The sketch after applying all the constraints is shown in Figure 3-28.

Note
The shape of the sketch that you have drawn may be a little different from the final sketch at this 
stage because of the difference in specifying points while drawing the sketch. However, once all 
the dimensions are applied, the shape of the sketch will be the same as of the final sketch. Also, you 
may need to add vertical constraint to lines 5 and 7 and horizontal constraint to line 1 to fully 
constrain the sketch.
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Figure 3-28  The sketch after applying all 
constraints

Dimensioning the Sketch
1.	 Choose the Dimension tool from the Constrain panel of the Sketch tab. Next, right-click 

to display the Marking menu. From the Marking menu, choose Edit Dimension if the 
check mark is not available on the left of the Edit Dimension option. If it shows the check 
mark, press the ESC key once to exit the Marking Menu. On doing so, you are prompted 
to select the geometry to be dimensioned. Select line 1 and place the dimension below the 
sketch. Modify the value of this dimension in the Edit Dimension edit box to 20.	

2.	 Select arc 4 and place the dimension on the left of the sketch; the radius dimension of the 
sketch is placed. Modify the dimension value in the Edit Dimension edit box to 7.5. The size 
of arc 8 is also modified because the Equal constraint is applied between these two entities.

Note
As discussed in the previous tutorial, you may need to use the combination of hot keys to zoom 
or pan the model.

3.	 Select arc 2 and place the radius dimension on the left of the sketch. Modify the dimension 
value in the Edit Dimension edit box to 10 and press Enter. The size of arc 10 is also modi-
fied because of the Equal constraint applied between these two entities.

4.	 Select line 5 and then line 7, and then place the dimension above the sketch. Modify the 
value of this dimension in the Edit Dimension edit box to 15 and press Enter.

5.	 Select line 7 and place the dimension on the right of the sketch. Modify the value of this 
dimension in the Edit Dimension edit box to 20 and press Enter.

6.	 Select the upper endpoint of line 7 and select line 1, and then place the dimension on the 
right of the previous dimension. Modify the value of this dimension to 40 and press Enter. 
Next, exit the Dimension tool.
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	 With this step, all the dimensions have been applied to the sketch, refer to Figure 3-29, 
except the horizontal dimension between the center points of arcs 4 and 6 or arcs 8 and 6. 
The need of these dimensions depends on the constraints and dimensions assumed while 
drawing the sketch. If the sketch gets over-constrained, the Autodesk Inventor Professional 
message box is displayed. Choose Cancel from the message box. In this case, the dimension 
has already  been assumed.

Drawing Circles	
	 Once all the required dimensions and constraints have been applied to the sketch, you need 

to draw circles. Figure 3-26 indicates that circles are concentric with arcs 2 and 10. 

1.	 Choose the Center Point Circle tool from the Create panel; you are prompted to select the 
center of the circle. Move the cursor close to the center of arc 2. Specify the center point 
when the cursor snaps to the center point of arc 2 and turns green. Next, move the cursor 
away from the center and specify a point to size the circle.

2.	 Similarly, draw the other circle taking the reference of the center of arc 10. 

Adding Constraints to Circles	
	 As both the circles have the same diameter, you can apply the Equal constraint 

to them. On applying the dimension to one of the circles, the other circle will 
automatically be forced to be created as per the specified diameter value as the Equal 
constraint has been applied on it.

1.	 Invoke the Equal constraint tool from the Constrain panel. Select the first circle and then 
the second circle to apply the Equal constraint.	

Dimensioning Circles
1.	 Choose the Dimension tool from the Constrain panel and select the left circle. Place 

the dimension on the left of the sketch. In the Edit Dimension edit box, change the 
value of the diameter of the circle to 8 and press Enter. 

	 Notice that because of the Equal constraint, the size of the right circle is automatically 
modified to match the dimension of the left circle. The final sketch for Tutorial 3 after 
drawing and dimensioning circles is shown in Figure 3-30.
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Figure 3-29  Dimensioned sketch for Tutorial 1 Figure 3-30  The final dimensioned sketch 
for Tutorial 1

Saving the Sketch
1.	 Choose the Return tool from the Quick Access Toolbar to exit the Sketching 

environment. Save this sketch with the name Tutorial1 at the location given below:
	 C:\Inventor_2023/c03

Note
If the Return tool is not available in Quick Access Toolbar, you need to add this tool to the toolbar. 
To do so, choose the down arrow on the right of Quick Access Toolbar; a flyout is displayed. Next, 
choose the Return option from the flyout.

2.	 Choose Close > Close from the File menu to close the file.

Tutorial 2
In this tutorial, you will draw the sketch of the model shown in Figure 3-31. The dimensions of the 
sketch are shown in Figure 3-32. After drawing the sketch, add constraints and then dimension 
it. The solid model is given for reference only.	    		       (Expected time: 30 min)

	 The following steps are required to complete this tutorial:

a.	 Start a new metric standard part file and invoke the Sketching environment.
b.	 Draw the outer loop of the sketch.
c.	 Add the required dimensions and constraints to the sketch.
d.	 Add the inner circle to the sketch and dimension it.
e.	 Save the sketch with the name Tutorial2.ipt and close the file.
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Figure 3-32  The final dimensioned sketch for 
Tutorial 2

Figure 3-31  Model for the sketch of 
Tutorial 2

Starting a New File and Invoking the Sketching Environment
1.	 Choose the New tool from the Quick Access Toolbar to display the Create New File dialog 

box. Start a new metric standard part file from the Metric tab of this dialog box.
 
2.	 Choose the Start 2D Sketch tool from the Sketch panel of the 3D Model tab; the default 

planes are displayed and you are prompted to select the sketching plane.

3.	 Select the XY Plane (Front Plane) as the sketching plane from the graphics window; the 
Sketching environment is invoked and the XY Plane (Front Plane) becomes parallel to the 
screen. 

Drawing the Outer Loop
1.	 Choose the Line tool from the Create panel of the Sketch tab to draw the outer loop, as 

shown in Figure 3-33. As mentioned earlier, you should draw the inner loop after drawing 
and dimensioning the outer loop. This is because once the outer loop is dimensioned, you 
can draw the inner loop by taking the reference of the outer loop. 

      You can draw the arc while the Line tool is active. You can also use the temporary tracking 
option to draw this sketch. For your reference, the geometries in the sketch are numbered, 
see Figure 3-33.
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Figure 3-33  Initial sketch with the geometries numbered

Adding Constraints to the Outer Loop
1.	 Add the Equal constraint to lines 1 and 9, 2 and 8, 3 and 5, 5 and 7, and 4 and 6. 

2.	 Add the Perpendicular constraint to lines 2 and 3 and 7 and 8.

3.	 Add the Horizontal constraint to the lower endpoints of lines 4 and 6. 

4.	 Add the Tangent constraint to lines 1 and 9 with arc 10, if it is missing.

Dimensioning the Outer Loop
1.	 Choose the Dimension tool from the Constrain panel of the Sketch tab; you are 

prompted to select the geometry to dimension. Select line 9 and place the dimension 
on the left of the sketch. Modify the dimension value in the Edit Dimension edit 
box to 25 and press Enter.

2.	 Select the center of the arc and then the lower endpoint of line 6. Place the dimension on 
the left of the previous dimension. Modify the dimension value in the Edit Dimension edit 
box to 60 and press Enter.

3.	 Select line 3 and then right-click to display the Marking menu. Choose Aligned from the 
Marking menu and then place the dimension below the sketch. Modify the dimension value 
in the Edit Dimension edit box to 12.5 and press Enter. 

	 Notice that the length of lines 5 and 7 are also modified because of the Equal constraint.

4.	 Select lines 1 and 2 and then place the angular dimension on the right of the sketch. Modify 
the value of the angular dimension in the Edit Dimension edit box to 135 and press Enter.

5.	 Select arc 10 and then place the radius dimension above the sketch. Modify the value of the 
radius of the arc in the Edit Dimension edit box to 15 and press Enter. 
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	 With this, the required dimensions have been applied to the outer loop. Even after adding 
all dimensions, the color of entities in the sketch remains green. 

	 Now, you can use the origin to fully constrain the initial sketch.

6.	 Choose the Coincident Constraint tool from the Constrain panel; you are prompted to 
select the first curve or point.

7.	 Select the center of the arc; you are prompted to select the second curve or point.

8.	 Select the origin. The entire sketch shifts itself such that the center of arc of the sketch is at 
the origin. After the sketch is shifted to a new place, it may not be visible completely in the 
drawing window.

9.	 Choose the Zoom All tool from the Navigation Bar > Zoom flyout to fit the sketch into the 
drawing window. You will notice that all the entities in the sketch turn purple, indicating that 
the sketch is fully constrained. Press the ESC key to exit the Coincident Constraint tool. 

Drawing the Circle
1.	 Choose Center Point Circle from the Create panel of the Sketch tab; you are prompted to 

select the center of the circle. 

2.	 Move the cursor close to the center of the arc; the cursor snaps to the center point and turns 
green. Select this point as the center of the circle and then move the cursor away from the 
center to size the circle. Specify a point to give it an approximate size.

Dimensioning the Circle
1.	 Choose Dimension from the Constrain panel of the Sketch tab and select the circle. Place 

the diameter dimension below the arc dimension. Enter 20 in the Edit Dimension edit 
box and then press Enter. This completes the sketch for Tutorial 4. The final dimensioned 
sketch is shown in Figure 3-34.

Figure 3-34  The final dimensioned sketch for Tutorial 2
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Saving the Sketch
1.	 Choose the Finish Sketch option from the Exit panel of the Sketch tab to exit the sketching 

environment. Alternatively, choose the Finish 2D Sketch option from the Marking menu 
to exit the sketching environment 

	
2.	 Save the sketch with the name Tutorial2 at the location given below:
	
	 C:\Inventor_2023\c03

3.	 Choose Close > Close from the File menu to close the file.

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 The __________ nature of Autodesk Inventor ensures that a selected entity is driven to a 
specified dimension value irrespective of its original size.

2.	 When you select a circle to be dimensioned, the __________ dimension is applied to it by 
default.

3.	 The __________ dimension has one arrowhead and is placed outside a circle or an arc.

4.	 The __________ dimension displays the distance between two selected line segments in 
terms of diameter and the distance shown is twice the original length.

5.	 The __________ tool is used to measure the radius of an arc.

6.	 A ___________ constrained sketch is the one whose entities are completely constrained to 
their surroundings using constraints and dimensions.

7.	 The Perpendicular constraint forces a selected entity to become perpendicular to a specified 
entity. (T/F)

8.	 The Coincident constraint can be applied to two line segments. (T/F)

9.	 The Collinear constraint can only be applied to line segments. (T/F)

10.	 If an unnecessary constraint is applied to a sketch, Autodesk Inventor displays a message 
box informing that adding this constraint will over-constrain the sketch. (T/F)
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 Review Questions 
Answer the following questions:

1.	 Which of the following tools is invoked to measure distance between two edges?

		  (a) Length			   (b) Distance
		  (c) Minimum		               (d) Measure

2.	 Which of the following dimensions is applied by default to an arc whenever it is dimensioned?

		  (a) Radius			   (b) Diameter
		  (c) Linear	 		  (d) Linear Diameter

3.	 In addition to lines, which of the following entities can be selected to apply the Collinear 
constraint?

		  (a) Arc				    (b) Circle
		  (c) Ellipse			   (d) Ellipse axis

4.	 Which of the following combinations of entities cannot be used to apply the Tangent 
constraint?

		  (a) Line, line			   (b) Line, arc
		  (c) Circle, circle			  (d) Arc, circle

5.	 You cannot apply the Concentric constraint between a point and a circle. (T/F)

6.	 You can use the Horizontal constraint or the Vertical constraint to line up arcs, circles, or 
ellipses in the respective  horizontal or vertical direction. (T/F)

7.	 You can view all or some of the constraints applied to a sketch. (T/F)

8.	 There are twelve types of geometrical constraints that can be applied to the sketched entities. 
(T/F)

9.	 The linear dimensions are the dimensions that define the shortest distance between two 
points. (T/F)

10.	 A sketch in which the number of dimensions or constraints exceeds the required numbers 
is called as Over-constrained sketch. (T/F)
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EXERCISES
Exercise 1

Draw the sketch of the model shown in Figure 3-35. The sketch to be drawn is shown in 
Figure 3-36. After drawing the sketch, add the required constraints to it and then dimension 
it.								              (Expected time: 30 min)

Figure 3-35  Model for Exercise 1 Figure 3-36  Sketch for Exercise 1

 Exercise 2
Draw the sketch of the model shown in Figure 3-37. The sketch to be drawn is shown in 
Figure 3-38. After drawing the sketch, add the required constraints to it and then dimension it.
								              (Expected time: 30 min)

Figure 3-37  Model for Exercise 2 Figure 3-38  Sketch for Exercise 2
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Exercise 3
Draw the sketch of the model shown in Figure 3-39. The sketch to be drawn is shown in 
Figure 3-40. After drawing the sketch, add the required constraints to it and then dimension it.                                                                                                        
                                                                                                                   (Expected time: 30 min)

Figure 3-39  Model for Exercise 3 Figure 3-40  Sketch for Exercise 3

Exercise 4
Draw the sketch of the model shown in Figure 3-41. The sketch to be drawn is shown in 
Figure 3-42. After drawing the sketch, add required constraints to it and then dimension it.
								              (Expected time: 30 min)

Figure 3-41  Model for Exercise 4 Figure 3-42  Sketch for Exercise 4

Answers to Self-Evaluation Test
1. parametric, 2. diameter, 3. radius, 4. linear diameter, 5. Measure, 6. fully, 7. T, 8. F, 9. F, 10. T


