
Chapter 2

Working with Blocks
  Learning Objectives 
After completing this chapter, you will be able to:
• Use tools in the Blocks toolbar
• Save a sketch as a block in the Design Library
• Create mechanisms by using blocks
• Create parts from blocks
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INTRODUCTION TO BLOCKS
A block is a set of entities grouped together as a single entity. The blocks are used to create 
complex mechanisms using sketches and check their functioning before developing them into 
a complex 3D model. You can create a block from a single entity or from a combination of 
multiple sketched entities. To create a block, first you need to draw an object and then convert it 
into a block by using the tools available in the Blocks toolbar. Tools available in this toolbar are 
also used to perform other operations such as edit, save, explode, rebuild, and so on. You can 
convert a block into a part in the Layout environment. In this chapter, you will learn to create 
a part and an assembly from the blocks.  

Blocks Toolbar
The Blocks toolbar, as shown in Figure 2-1, is used to control the sketched entities of the blocks. 
You can perform different operations related to blocks such as create, edit, insert, save, and so 
on by using the Blocks toolbar. The tools in this toolbar are discussed next.

Figure 2-1  The Blocks toolbar

Make Block
The Make Block tool is used to convert the sketch entities

Figure 2-2  The Make Block 
PropertyManager

 
into a block. Using this tool, you can make each entity of 

a sketch as a separate block that can be moved with respect to 
one another. In such a case, there will be a motion between the 
sketched entities. This tool will be available only when you invoke 
the Sketching environment. To create a block, select an entity 
from the sketch. Next, choose the Make Block button from the 
Blocks toolbar or choose Tools > Blocks > Make from the 
SOLIDWORKS menus; the Make Block PropertyManager will 
be displayed, as shown in Figure 2-2, and the name of the 
selected entity will be displayed in the selection box of the Block 
Entities rollout. The Insertion Point rollout of the Make Block PropertyManager is used to 
specify the location of the insertion point of the resulting block. When you insert a block later 
in a sketch, the cursor will snap the block at the specified insertion point. To specify the insertion 
point, expand the Insertion Point rollout; a manipulator will be displayed in the drawing area. 
Drag the manipulator and place it at the location where the insertion point is to be specified. 
When you move the manipulator to specify the insertion point in the drawing area, it will snap 
to the sketched entity and relations will be added between the insertion point and the sketched 
entity. Finally, choose the OK button; the sketched entity will be converted into a block. Similarly, 
convert other entities of the sketch into blocks.
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Note 
Although you can convert all entities of a sketch into a block, it is recommended to create each 
entity of the sketch as a separate block; else, there will be no motion between the sketched entities.

Save Block
The Save Block tool is used to save the current sketch as a block. In this case, the motion 
between the sketched entities will be frozen. To save a sketch as a block, draw a sketch and 

then save it by choosing the Save  Block button from the Blocks toolbar. Alternatively, choose 
Tools > Blocks > Save from the SOLIDWORKS menus; the sketch will be saved as a block. The 
file extension of a block file is .Sldblk . 

Insert Block
The Insert Block tool is used to insert the blocks into an

Figure 2-3  The Edit Sketch 
PropertyManager

 
active sketch. To insert a block after exiting from an active 

sketch, choose the Insert Block button from the Blocks toolbar; 
the Edit Sketch PropertyManager will be displayed, as shown in 
Figure 2-3. Also, you will be prompted to select a sketching plane 
or an existing sketch. Select the sketching plane from the drawing 
area or from the FeatureManager Design Tree; the Insert Block 
PropertyManager will be displayed, as shown in Figure 2-4. Note 
that if you are in the sketching environment, the Insert Block 
PropertyManager will be displayed directly. The options available 
in this PropertyManager are discussed next. 

Blocks to Insert
The existing blocks of an active sketch are listed in the Block

Figure 2-4  The Insert Block 
PropertyManager

 
List selection box of the Blocks to Insert rollout. You can 
insert multiple copies of the existing blocks into an active 
sketch. To do so, select a block from the Block List selection 
box in the Blocks to Insert rollout; the selected block will 
be attached to the cursor. Next, click in the drawing area to 
insert it into the current sketch. Note that the block will still 
be attached to the cursor, which implies that you can insert 
multiple copies of that block by clicking repeatedly in the 
drawing area. You can also browse to the blocks by choosing 
the Browse button from the Blocks to Insert rollout. When 
you insert a block by browsing it from its location, the Link 
to file check box gets activated. Select this check box to link 
the block file to all the blocks that you have to place. The 
changes made in the original block will get reflected in all 
the blocks placed. Choose the OK button from the Insert 
Block PropertyManager to exit from it.  

Parameters 
In this rollout, the Block Scale and Block Rotation spinners 
are available. By default, 1 is displayed as the scale value in 
the Block Scale spinner. It indicates that the current scale 
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factor of the entity is 1. You can change the scale value of the block by using this spinner 
or by entering the scale value using the keyboard. The Block Rotation spinner is used to 
rotate the block by an angle or adjust the orientation of the block. The default angle value 
in the Block Rotation spinner is 0. You can change the default rotational angle value by 
using this spinner. 

Edit Block
The Edit Block tool is used to add, remove, or modify the block entities, as well as change 
the existing relations and dimensions of the block entities. This tool is enabled in the 

Blocks toolbar only when you select a block from the drawing area. To edit a block, first ensure 
that the Sketching environment is activated. Then, click on the  sign available on the left of 
Sketch in the FeatureManager Design Tree to expand the node and display the blocks, if they 
are not already displayed. Next, select the required block from the design tree and right-click; 
a shortcut menu will be displayed. Choose the Edit Block option from the shortcut menu. 
Alternatively, you can choose the Edit Block button from the Blocks toolbar. Now, you can edit 
the selected block as per your requirement. Once the changes are made, click on the block 
confirmation corner on the top right corner of the drawing area to exit from it.  

Add/Remove
The Add/Remove tool is used to add or remove the sketch

Figure 2-5  The Add/Remove 
Entities PropertyManager

 
entities from a block. To add the sketch entities to a block 

by using the Add/Remove tool, select the required block from 
the drawing area or from the FeatureManager Design Tree and 
right-click; a shortcut menu will be displayed. Next, choose the 
Edit Block option from the shortcut menu; the Add/Remove 
button will be enabled in the Blocks toolbar. Choose the Add/
Remove button to add or remove the sketched entities from the 
block; the Add/Remove Entities PropertyManager will be 
displayed, as shown in Figure 2-5. The names of the entities of 
the selected block will be displayed in the selection box of the 
Block Entities rollout. Select the required sketched entities from 
the drawing area to add them to the block. Note that the selected sketch entities will also be 
added to the selection box of the Block Entities rollout. Choose the OK button from the 
Add/Remove Entities PropertyManager; the selected sketch entities will be added to the block. 
To remove an entity from the selected block, invoke the Add/Remove Entities PropertyManager 
and then select the entity from the selection box of the Block Entities rollout. Next, press the 
DELETE key.
     
Rebuild

The Rebuild tool enables you to refresh or update the parent sketches after editing a 
block. If you have edited the position of a block by using the Edit Block tool, you will 

notice that the block no longer maintains relations with the other entities. To re-establish the 
relations, you need to choose the Rebuild button from the Blocks toolbar. Alternatively, choose 
Tools > Blocks > Rebuild from the SOLIDWORKS menus to re-establish or update the sketched 
entities. 
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Explode Block
The Explode Block tool is used to explode a selected block and dissolve it into the sketch 
entity. To explode a block, select the block from the FeatureManager Design Tree; the 

Explode Block button will be enabled in the Blocks toolbar. Choose the Explode Block button 
from the Blocks toolbar or choose Tools > Blocks > Explode from the SOLIDWORKS menus; 
the selected block will dissolve into the sketch. After dissolving a block, you can again turn it 
into a block by using the Make Block button, but a new name will be assigned to it. 

Belt/Chain 
The Belt/Chain tool is used to insert a belt between pulleys.

Figure 2-6  The Belt/Chain 
PropertyManager

 
This tool helps you to create the mechanisms such as 

multiple gear sets, cable and belt pulleys, chain sprocket system, 
and so on. A belt automatically creates the link motion of the 
pulleys based on their diameters. To add a belt/chain between 
pulleys, create sketches of the two or more pulleys in the drawing 
area and then convert them into separate blocks. The sketch of 
a pulley should be a circle or an arc only. Choose the Belt/Chain 
button from the Blocks toolbar or choose Tools > Sketch Entities > 
Belt/Chain from the SOLIDWORKS menus; the Belt/Chain 
PropertyManager will be displayed, as shown in Figure 2-6, and 
you will be prompted to select a circle or an arc to define the belt 
members around which the belt will pass. The options available 
in this PropertyManager are discussed next. 

Belt Members
The Belt Members rollout is used to display the name of 
the blocks that are selected to define belt members. Select 
the circular blocks from the drawing area to define the belt 
members. The selected blocks will be displayed in the Pulley 
components selection box of this rollout and the preview of 
the belt/chain mechanism will be displayed in the drawing 
area. You can also remove a selected block from the Pulley 
components selection box. To do so, select a block from the 
Pulley components selection box and invoke the shortcut menu. Next, choose the Delete 
option from the shortcut menu; the selected block will be removed from the selection box.  
Figure 2-7 shows the preview of the belt/chain mechanism after selecting the belt members.

The Move Up and Move Down buttons available on the left of the Belt Members rollout 
are used to change the order of the belt members. To move a particular block up in the 
selection area, select it and then choose the Move Up button. Similarly, the Move Down 
button is used to move the selected belt member down in the order. Using these buttons, 
you can arrange the sequence of the belt members in the selection area of the Belt Members 
rollout. You can also flip the side of the selected belt member on which the belt is placed, 
by choosing the Flip belt side button available in this rollout. Alternatively, you can flip 
the side of the belt member by clicking on the arrow of the belt member from the drawing 
area. Figure 2-8 shows the belt member whose side has to be flipped and Figure 2-9 shows 
the belt member after flipping the side.
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Figure 2-7  Preview of the belt/chain mechanism

Figure 2-8  The block entity before 
flipping the side

Figure 2-9  The block entity after 
flipping the side

Properties 
By default, the Driving check box is clear in this rollout, and therefore, the driving length 
of the belt will be calculated automatically. Select the Driving check box to define the length 
of the belt as per your requirement; the length spinner will be activated. You can specify the 
driving length of the belt by using this spinner. To specify the thickness of the belt, select the 
Use belt thickness check box; the Belt thickness spinner will be displayed. You can specify 
the thickness of the belt in this spinner. The Engage belt check box is used to engage or 
disengage the belt mechanism. By default, this check box is selected and is used to engage 
the belt mechanism. To disengage the belt mechanism, clear this check box. Figure 2-10 
shows the mechanism without specifying the belt thickness and Figure 2-11 shows the same 
mechanism after specifying the belt thickness.

Tip
If you draw spoke lines in the pulley, you can easily visualize the rotation of the pulley. 
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Figure 2-10  Mechanism without specifying 
the belt thickness

Figure 2-11  Mechanism after specifying 
the belt thickness

SAVING A SKETCH AS A BLOCK IN THE DESIGN LIBRARY
In SOLIDWORKS, you can directly save a sketch as a block in

Figure 2-12  Partial view of the 
Add to Library PropertyManager

 
the Design Library. To do so, select the sketch from the 
FeatureManager Design Tree and then choose the Design 
Library tab from the task pane; the Design Library task pane 
will be invoked. Next, choose the Add to Library button from 
the Design Library task pane; the Add to Library 
PropertyManager will be displayed, as shown in Figure 2-12, 
and the name of the selected sketch will be displayed in the 
selection box available in the Items to Add rollout of the 
PropertyManager. Enter the file name in the File name edit 
box in the Save To rollout of the PropertyManager. Next, select 
the folder in which you want to save this file from the Design 
Library folder area. You can also create a new folder in the 
Design Library folder area by choosing the Create New Folder 
button from the Design Library task pane. The Options rollout 
in the Add to Library PropertyManager is used to view the 
file type or the extension of the file. Select the file type 
SOLIDWORKS Blocks (*.sldblk) from the File type 
drop-down list, if it is not selected. The Enter Description edit box in this rollout is used to 
enter the description of the block. This description will be displayed as a tooltip. After setting 
all the required parameters in the rollout, choose the OK button from the Add to Library 
PropertyManager to exit. 

CREATING MECHANISMS BY USING BLOCKS
In SOLIDWORKS, you can create simple mechanisms by adding a suitable relation between 
the blocks. For example, the Traction relation is used to create mechanisms such as gear trains, 
rack and pinion, and so on. Similarly, you can create the cam and follower mechanism using the 
Make Path relation. The procedures to create these mechanisms are discussed next. 
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Creating the Rack and Pinion Mechanism 
In SOLIDWORKS, you can create a rack and pinion mechanism by using the Traction relation. 
To do so, create two sketches, as shown in Figure 2-13, and convert them into two separate 
blocks. Next, select the circular block and then the vertical line of the other block by pressing 
the CTRL key; the Properties PropertyManager will be displayed, as shown in Figure 2-14. 
Note that the Traction button is available in the Add Relations rollout of the Properties 
PropertyManager. Choose this button and then click anywhere in the drawing area to exit from 
this PropertyManager. Similarly, apply other suitable constraints. Figure 2-15 shows the blocks 
before applying the Traction relation and Figure 2-16 shows the resultant blocks after applying 
the Traction relation. To check the linkage between these blocks, click on the vertical line of 
the block and drag it up or down in the drawing area. You will notice that the linear translation 
of one part results in a circular motion of the other part and vice-versa.

Figure 2-13  Sketches to create blocks Figure 2-14  The Properties PropertyManager

Figure 2-15  The blocks before 
applying the Traction relation

Figure 2-16  The resultant blocks 
after applying the Traction relation
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Creating the Cam and Follower Mechanism
A cam is a rotating machine element which gives reciprocating or oscillating motion to another 
element known as follower. In SOLIDWORKS, you can create a cam and follower mechanism 
between two blocks by using the Make Path tool. To create a cam and follower mechanism, first 
you need to convert a cam profile into a single path by using the Make Path tool and then apply 
tangent relation between the cam and follower profiles. Note that the sketched entities of the 
cam profile to be converted as path should coincide with each other and form a single chain. 
The procedure to create a cam and follower mechanism is given below.

Create two sketches that represent a cam and a follower, as shown in Figure 2-17. Next, you need 
to convert the cam profile into a single path by using the Make Path tool. To do so, select the 
lower arc of the cam, as shown in Figure 2-18, and then choose Tools > Sketch Tools > Make 
Path from the SOLIDWORKS menus; the Path Properties PropertyManager will be displayed, 
as shown in Figure 2-19. In this PropertyManager, the selection box of the Existing Relations 
rollout displays the relations between the sketched entities that make up the path and the sketched 
entities with which the path interacts. Choose the Edit Path button from the Definition rollout 
of this PropertyManager; the Path PropertyManager will be displayed, as shown in Figure 2-20, 
and you will be prompted to select the entities that are coincident end to end and form a single 
chain. Note that the selected arc of the cam will be displayed in the Selected Entities rollout of 
the Path PropertyManager. Now, select the remaining sketched entities of the cam that have a 
tangent relation with each other from the drawing area to make a path. Choose the OK button 
to exit from the PropertyManager and then convert the sketches of cam and follower into 
separate blocks. Next, apply the relations, as shown in Figure 2-21. Figure 2-22 shows the cam 
and follower mechanism after applying the relations. To check the motion between the cam and 
the follower, click on the cam and drag it clockwise in the drawing area.

Figure 2-17  Sketches of cam and follower Figure 2-18  The arc of the cam to be selected
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Figure 2-19  The Path Properties 
PropertyManager

Figure 2-20  The Path 
PropertyManager

Figure 2-21  Entities to be 
selected for adding relations 

Figure 2-22  Cam and follower 
after applying the relation

APPLYING MOTION TO BLOCKS 
In SOLIDWORKS, you can animate the mechanism created using blocks by applying motion 
to it. To do so, you need to create all the entities of the mechanism individually and then save 
them as separate blocks. Next, start a new SOLIDWORKS Assembly document by choosing the 
Assembly button from the New SOLIDWORKS Document dialog box; a new assembly session 
will be started and the Begin Assembly PropertyManager along with the Open dialog box will be 
invoked. Close the Open dialog box and then Choose the Create Layout button from the Begin 
Assembly PropertyManager; the Layout environment will be invoked. Insert all the blocks one 
by one in the drawing area by choosing the Insert Block button from the Blocks toolbar and 
apply the required relations between the blocks of the mechanism. After applying the required 
relation, choose the Layout button from the Layout CommandManager to exit from it. To add 
a motor, choose the Motion Study 1 tab available at the lower left corner of the drawing area. 
Next, expand the Expand MotionManager rollout by clicking on the arrow at the lower-right 
corner of the drawing area if it is not expanded. In this MotionManager, the Animation option 
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is selected by default in the Type of Study drop-down list. Choose the Motor button from the 
MotionManager toolbar; the Motor PropertyManager will be displayed. Select the required 
motor from the Motor Type rollout and then specify the location of the motor in the Motor 
Location selection box of the Component/Direction rollout. After specifying all the required 
parameters, choose the OK button from the Motor PropertyManager to exit. To calculate the 
motion, choose the Calculate button from the MotionManager toolbar. Now, you can view the 
motion of the mechanism by choosing the Play button from the MotionManager toolbar.

To understand the process of applying motion to the blocks, consider the example of pulleys. 
In this example, in order to create a driver driven mechanism between three pulleys having 
diameters 10, 20, and 30, as well as to animate it, you need to draw three circles of diameters 
10, 20, and 30 respectively in separate sketching environments and save them as block files. 
Make sure that you draw a centerline inside the circles to view the motion clearly. Next, open 
the Layout environment by choosing the Create Layout button from the Begin Assembly 
PropertyManager. Now, insert the circles which are saved as blocks, one by one into the drawing 
area by choosing the Insert Block button from the Blocks toolbar, as shown in Figure 2-23. 
Next, select the bigger and medium sized circles from the drawing area by pressing the CTRL 
key; the Properties PropertyManager will be displayed. Choose the Traction button from the 
Add Relations rollout of the PropertyManager to apply the Traction relation. Similarly, select 
the bigger and smaller circles from the drawing area and apply the Traction relation on them. 
Figure 2-24 shows the circles after applying the Traction relation on them. Finally, choose the 
Layout button from the Layout CommandManager to exit. 

Figure 2-23  Circles inserted in the 
drawing area

Figure 2-24  Circles after applying 
the Traction relation

Now, to animate these circles, choose the Motion Study 1 tab, the MotionManager will be 
displayed. In the MotionManager, the Animation option is selected by default in the Type of 
Study drop-down list. Choose the Motor button from the MotionManager toolbar; the Motor 
PropertyManager will be displayed. By default, the Rotary Motor button is chosen in the Motor 
Type rollout of the PropertyManager. Now, you need to select the direction and location of the 
motor. Select any one of the circles to specify the location and direction of the motor from the 
drawing area. Choose the OK button from the PropertyManager to exit. To calculate the motion, 
choose the Calculate button from the MotionManager toolbar. Next, choose the Play button to 
view the motion between the three circles after applying the Traction relation. 
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Note
You can also create the sketches of the mechanism and convert them into separate blocks in the 
Layout environment itself. 

CREATING PARTS FROM BLOCKS
As discussed earlier, you can create parts from the blocks.

Figure 2-25  The Make Part 
From Block PropertyManager

 
To create a part from a block, choose the Make Part from 

Block button from the Layout CommandManager; the Make 
Part From Block PropertyManager will be displayed, as shown 
in Figure 2-25. The options in this PropertyManager are discussed 
next. 

Selected Blocks
This rollout lists the blocks that will be selected for creating parts 
from the drawing area. Select a block from the drawing area; the 
selected block will be displayed in the selection box of Selected 
Blocks rollout. You can select more than one block from the 
drawing area.

Block to Part Constraint
In this rollout, there are two buttons: Project and On Block. These buttons are used to create 
parts from blocks. By default, the On Block button is chosen in this rollout. On choosing the 
Project button from the Block to Part Constraint rollout, you can create a part from the block. 
This part will be projected on the plane of the block in the Layout environment. You can drag 
this part in the drawing area, normal to the plane of the block and it will not be constrained 
to be coplanar  with the plane of the block in the layout environment, but the part created by 
choosing the On Block button will be constrained to be coplanar with the plane of the block in 
the layout environment.

Select a block from the drawing area of the Layout environment; the selected block will be 
displayed in the selection box of the Selected Blocks rollout. Choose the OK button from the 
PropertyManager to confirm the selection. The selected block will be displayed as a part in the 
FeatureManager Design Tree. The part name will be the same as the block name. Note that 
the name of the part in the design tree will be covered by a square bracket, indicating that it is 
a virtual component. The virtual components are saved internally in the assembly file in which 
they are created. You can save these components into external files later on. Next, right-click 
on the part name or virtual component in the design tree; a shortcut menu will be displayed. 
Choose the Open Part button from the shortcut menu; the selected part will open in the Part 
environment. Now, you can convert it into a solid feature using the tools available in the Features 
CommandManager. Next, open the layout environment again by choosing Window > name of 
the layout assembly from the SOLIDWORKS menus.
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TUTORIALS
Tutorial 1

In this tutorial, you will create a reciprocating mechanism by assembling different blocks, as 
shown in Figure 2-26. You will also convert the blocks of the reciprocating mechanism into parts. 
The final assembly of the mechanism after converting blocks into parts is shown in Figure 2-27. 
Figures 2-28 through 2-30 show different views of the parts of the mechanism with the required 
dimensions.				    	       		         (Expected time: 45 min)
	

Figure 2-26  Reciprocating mechanism created 
by assembling the blocks

Figure 2-27  Reciprocating mechanism after 
converting the blocks into parts

Figure 2-28  The front and right views of the crank
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Figure 2-29  The front and side views 
of the piston rod

Figure 2-30  The front and side views 
of the piston tank

The following steps are required to complete this tutorial:

a.	 Create the sketches of the mechanism by using the sketch tools. 
b.	 Save sketches as different block files.
c.	 Insert blocks into the Layout environment.
d.	 Apply relations between blocks.
e.	 Convert blocks into parts.
f.	 Save and close the document.

Creating the First Sketch of the Mechanism
1.	 Start a new SOLIDWORKS part document using the New SOLIDWORKS Document dialog 

box and invoke the sketching environment.

2.	 Draw the front view of the crank, refer to Figure 2-28, by using the tools in the Sketch 
CommandManager. 

Saving the Sketch as a Block File		   	
You need to save the sketch of the crank as a block file.

1.	 Choose the Save Sketch as Block button from the Blocks toolbar; the Save As dialog box 
is displayed. Enter Crank as the name of the sketch in the File name edit box. Browse to 
the required location and then choose the Save button to exit from it. Alternatively, choose 
Tools > Blocks > Save from the SOLIDWORKS menus to save the sketch as a block file.

2.	 Close the current sketching environment by choosing File > Close from the SOLIDWORKS 
menus; the SOLIDWORKS message window is displayed. Choose the Don’t Save button from it. 
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Creating the other Sketches of the Mechanism and Saving them as 
Block Files

You need to create other sketches of the mechanism in different sketching environments 
and then save them as separate block files.

1.	 Start a new SOLIDWORKS part document by using the New SOLIDWORKS Document 
dialog box and invoke the sketching environment. 

2.	 Draw the sketch of the front view of the piston rod, refer to Figure 2-29.

3.	 Select the sketch and save it as a block file by choosing the Save Sketch as Block button 
from the Blocks toolbar. Enter Piston_rod in the File name edit box of the Save As dialog 
box and then choose the Save button.

 
4.	 Similarly, draw the sketch of the piston tank, refer to Figure 2-30, and then save the sketch 

as a separate block file with the name Piston_tank.
   
Inserting Blocks in the Layout Environment 

You need to insert blocks in the layout environment and then apply the required relation 
between them.

1.	 Start a new SOLIDWORKS Assembly environment by using the New SOLIDWORKS 
Document dialog box. Close the Open dialog box and then choose the Create Layout 
button from the Begin Assembly PropertyManager; the layout environment is invoked.

2.	 Choose the Insert Block button from the Blocks toolbar; the Insert Block PropertyManager 
is displayed.

3.	 Choose the Browse button from the Blocks to Insert rollout of the Insert Block 
PropertyManager; the Open dialog box is displayed.

4.	 Select Crank from the Open dialog box and then choose the Open button; the selected 
block is attached to the cursor. 

5.	 Click anywhere in the drawing area to place the block and then right-click to display the 
shortcut menu. Choose OK from the shortcut menu.

6.	 Similarly, insert the Piston_rod and Piston_tank blocks in this layout environment. To change 
the current view orientation normal to the screen, choose the View Orientation button from 
the View (Heads-Up) toolbar; a flyout is displayed. Choose the Normal To button from the 
flyout. Figure 2-31 shows the blocks inserted in the layout environment.

Applying Relations to the Blocks 
You need to apply relations to the blocks to assemble them and to view the motion of the 
mechanism.
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1.	 Press and hold the CTRL key, and then select the center of the lower circle of the Crank 
and the origin, as shown in Figure 2-32; the Properties PropertyManager is displayed.

2.	 Choose the Coincident button from the Add Relations rollout of the Properties 
PropertyManager; the Coincident relation is applied between the selected points. Click 
anywhere in the drawing area to exit the Properties PropertyManager. 

Figure 2-31  Blocks after they are 
inserted in the layout environment

Figure 2-32  Points to be selected to 
apply the relation

3.	 Next, apply the relations, as shown in Figure 2-33. Figure 2-34 shows the blocks after applying 
the required relations. Now, the blocks act as a reciprocating mechanism. 

Figure 2-33  Points selected to apply the relations Figure 2-34  Blocks after applying the 
required relations

4.	 To view the motion of the mechanism, press and hold the left mouse button on the point, 
as shown in Figure 2-35, and then rotate the cursor in the clockwise direction.
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Figure 2-35  Point selected to view the motion of the mechanism

Converting Blocks into Parts 
Now, you need to convert the blocks into parts to create a 3D mechanism.

1.	 Choose the Make Part from Block button from the Layout CommandManager; the Make 
Part From Block PropertyManager is displayed.

2.	 Select all the blocks from the drawing area; the names of the selected blocks are displayed in 
the Selected Blocks rollout of the PropertyManager. Make sure that the On Block button is 
chosen in the Block to Part Constraint rollout of Make Part From Block PropertyManager. 
Choose the OK button; all the blocks are displayed as parts in the FeatureManager Design 
Tree with the part symbol on their left.

3.	 Choose the Rebuild button from the Menu Bar to update the change. 

4.	 Select the Crank block from the FeatureManager Design Tree; a pop-up toolbar is displayed. 
Choose the Edit Part button from the pop-up toolbar; the Part environment is invoked. 
Choose the Features tab from the CommandManager.

5.	 Next, choose the Extruded Boss/Base button from the Feature CommandManager; the 
Extrude PropertyManager is displayed and you are prompted to select a sketching plane 
or an existing sketch. Select the sketch of the crank from the drawing area or from the 
FeatureManager Design Tree; its preview is displayed in the drawing area.

6.	 In the Direction 1 rollout of the PropertyManager, the Blind option is selected by 
default in the End Condition drop-down list. Enter 10 mm in the Depth spinner of the 
Direction 1 rollout and choose the Reverse Direction button to flip the direction of the 
extrusion. Make sure the Thin Feature rollout is not activated. Choose the OK button to 
exit the PropertyManager.

	 Next, you need to extrude the upper hole of the Crank, refer to Figure 2-28. 
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7.	 Select the sketch of the previously extruded feature from the FeatureManager Design Tree 
and then choose the Extruded Boss/Base button from the Features CommandManager; 
the Boss-Extrude PropertyManager is displayed.

8.	 Expand the Selected Contours rollout in this PropertyManager. Move the cursor toward the 
upper hole of the Crank and then select it when it highlights in a different color, as shown 
in Figure 2-36. 

Figure 2-36  Hole of the crank to be selected

9.	 Enter 5 mm in the Depth spinner of the Direction 1 rollout. Expand the Direction 2 rollout 
and enter 10 mm in the Depth spinner. Choose the OK button to exit from it; the crank 
feature is displayed in the drawing area. 

10.	 Click on the confirmation corner in the upper right of the drawing area. If the rebuild icon 
is available on the left of the Crank in the design tree. Choose the Rebuild button from the 
Menu Bar to rebuild the part. 

11.	 Select the Piston_rod block from the FeatureManager Design Tree; a pop-up toolbar is 
displayed.

12.	 Choose the Edit Part button from the pop-up toolbar to invoke the Part environment. 
Choose the Features tab, if it is not already invoked.

13.	 Invoke the Extrude PropertyManager, select the sketch of the Piston_rod from the drawing 
area or from the FeatureManager Design Tree and enter 5 mm in the Depth spinner in the 
Direction 1 rollout of the PropertyManager. Choose the OK button to exit from it. 

14.	 Next, click on the confirmation corner in the upper right of the drawing area and then 
choose the Rebuild button from the Menu Bar. 

15.	 Similarly, select the Piston_tank block from the FeatureManager Design Tree and invoke 
the Part environment.
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16.	 Invoke the Extrude PropertyManager and select the sketch of the piston tank from the 
drawing area or from the FeatureManager Design Tree; its preview is displayed.

17.	 Enter 10 mm in the Depth spinner of the Direction 1 rollout.

18.	 Choose the Reverse Direction button from the Direction 1 rollout of the PropertyManager 
and  then choose OK.

	 Next, you need to create the shaft for the Piston_tank, refer to Figure 2-30.  

19.	 Select the sketch of the Piston_tank from the FeatureManager Design Tree and then invoke 
the Extrude PropertyManager.

20.	 Expand the Selected Contours rollout of the PropertyManager and move the cursor 
toward the hole of the Piston_tank. Next, select it by using the left mouse button when it is 
highlighted in a different color.

21.	 Enter 5 mm in the Depth spinner of the Direction 1 rollout. Next, expand the Direction 
2 rollout and enter 10 mm in the Depth spinner of this rollout. Now, choose OK from this 
PropertyManager and then exit by clicking on the confirmation corner available at the upper 
right of the drawing area.

22.	 Choose the Rebuild button from the Menu Bar to rebuild the

Figure 2-37  Reciprocating 
mechanism after hiding the 
sketches

 
part. Next, choose the Visibility Off button from the View 
(Heads-Up) toolbar; a flyout is displayed. Choose the View 
Sketches option to hide the sketches. Figure 2-37 shows the 
mechanism after hiding the sketches of the parts.

Saving the Model
You can see that the name of the components in the 
FeatureManager Design Tree is enclosed in parenthesis. This 
indicates that these are virtual components and will be saved 
internally, if you choose the Save button. So, first you need to 
make them regular components and save externally.

1. 	 Right-click on the Crank block and choose the Save Part (in 
External File) option from the shortcut menu displayed; the 
Save As dialog box will be displayed.

2.	 Choose the Specify Path button and browse to the location.

3.	 Similarly, save other components.

4.	 Choose the Save button from the Menu Bar and save the mechanism with the name c02_tut01 
at the location given below:

	 \Documents\SOLIDWORKS\c02\

5.	 Close the document by choosing File > Close from the SOLIDWORKS menus.
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Tutorial 2
In this tutorial, you will convert 2D blocks into parts in the Layout environment and then 
assemble them to create a mechanism, as shown in Figure 2-38. Also, you will animate the 
mechanism by applying the rotary motor. Figures 2-39 through 2-42 show different views of 
the parts of the mechanism with required dimensions.                    (Expected time: 45 min)

Figure 2-38  Mechanism created by assembling the parts

Figure 2-39  The front and side views of the Shaft

Figure 2-40  The front view of the Wheel
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Figure 2-41  The front view of the Connecting rod

Figure 2-42  The front and side views of the Slider

	 The following steps are required to complete this tutorial:

a.	 Create the sketches of the mechanism by using the sketch tools and save them as different 
block files. 

b.	 Insert blocks into the layout environment. 
c.	 Convert blocks into parts.
d.	 Assemble parts.
e.	 Animate the mechanism by applying the rotary motor. 
f.	 Save the mechanism and then close the document.

Creating the Sketches of the Mechanism and Saving them as Block 
Files
1.	 Start a new SOLIDWORKS part document by using the New SOLIDWORKS Document 

dialog box and invoke the sketching environment.

2.	 Draw the sketch of the front view of the Shaft by using the tools in the Sketch 
CommandManager. For dimensions of the shaft, refer to Figure 2-39. Save the sketch of 
the Shaft as a block file in the c02 folder by choosing the Save Block button in the Blocks 
toolbar.
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3.	 Similarly, create the sketches of the Wheel, Connecting rod, and Slider in a separate sketching 
environment. For dimensions of the sketches, refer to Figures 2-40 through 2-42. Save all 
the sketches as separate block files in the c02 folder.

Inserting all Blocks in the Layout Environment		   	
After you have saved all sketches as separate block files, you need to place these blocks one 
by one in the layout environment to convert them into parts. 

1.	 Start a new Assembly document by choosing the Assembly button from the New 
SOLIDWORKS Document dialog box. Close the Open dialog box and then choose the 
Create Layout button from the Begin Assembly PropertyManager; the layout environment 
is invoked.

2.	 Choose the View Orientation button from the View (Heads-Up) toolbar; a flyout is displayed. 
Choose the Normal To button from the flyout to change the orientation of the plane normal 
to the screen.

3.	 Choose the Insert Block button from the Blocks toolbar and insert the Shaft, Wheel, 
Connecting rod, and Slider in the layout environment, as shown in Figure 2-43.  

Figure 2-43  The blocks inserted in the Layout environment

Converting Blocks into Parts  
Now, you need to convert all the blocks into parts to create a 3D mechanism.

1.	 Choose the Make Part from Block button from the Layout CommandManager; the Make 
Part From Block PropertyManager is displayed.  

2.	 Select all the blocks from the drawing area or from the FeatureManager Design Tree; the 
names of the selected blocks are displayed in the Selected Blocks selection box. Choose 
the OK button from the PropertyManager; all blocks are displayed with the part symbol on 
the left in the FeatureManager Design Tree. 

	
3.	 Choose the Rebuild button from the Menu Bar to update the change. 
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4.	 Select Shaft from the FeatureManager Design Tree and right-click; a pop-up toolbar is 
displayed. Choose the Edit Part button from this toolbar; the Part environment is invoked.

5.	 Choose the Features tab from the CommandManager.

6.	 Choose the Extruded Boss/Base button from the Features CommandManager; the Extrude 
PropertyManager is displayed and you are prompted to select the sketch. 

7.	 Select the sketch of the Shaft from the drawing area; the preview of the shaft is displayed.

8.	 Enter 10 mm in the Depth spinner of the Direction 1 rollout and then choose the Reverse 
Direction button. Next, choose the OK button to exit from the PropertyManager.

9.	 Click on the confirmation corner available in the upper right corner of the screen.

10.	 Similarly, select the Wheel from the FeatureManager Design Tree and right-click; a pop-up 
toolbar is displayed. Invoke the Part environment by choosing the Edit Part button from 
the pop-up toolbar. 

 
11.	 Invoke the Extrude PropertyManager by choosing the Extruded Boss/Base button from 

the Feature CommandManager.  

12.	 Select the sketch of Wheel from the drawing area or from the FeatureManager Design Tree; 
its preview is displayed. Enter 5 mm in the Depth spinner and choose the Reverse Direction 
button in the Direction 1 rollout of the PropertyManager. Choose the OK button.  

13.	 Click on the  sign available on the left of the Boss-Extrude feature of the Wheel in the 
FeatureManager Design Tree; the sketch of the extrude feature is displayed.

14.	 Select the sketch of the extrude feature from the FeatureManager Design Tree and invoke 
the Boss-Extrude PropertyManager.

15.	 Expand the Selected Contours rollout in the PropertyManager. Zoom the wheel feature 
and select the area of the Wheel to be extruded, as shown in Figure 2-44.

Figure 2-44  The area selected to be extruded



2-24  					     Advanced SOLIDWORKS 2022 for Designers 
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

16.	 Enter 10 mm in the Depth spinner of the Direction 1 rollout and extrude it by using the 
Mid Plane option. Click on the confirmation corner to exit from it.  

17.	 Select the Connecting rod from the FeatureManager Design Tree  and right-click; a pop-up 
toolbar is displayed. Invoke the Part environment by choosing the Edit Part button from 
the pop-up toolbar.

18.	 Invoke the Extrude PropertyManager and select the sketch of the Connecting rod from the 
design tree. Enter 5 mm in the Depth spinner of the Direction 1 rollout and then choose 
the OK button to from the Boss-Extrude PropertyManager. Next, click on the confirmation 
corner.

19.	 Select the Slider from the FeatureManager Design Tree and invoke the Part environment 
by choosing the Edit Part button from the pop-up toolbar displayed.

20.	 Invoke the Extrude PropertyManager and select the sketch of the slider from the drawing 
area; its preview is displayed.

21.	 Enter 5 mm in the Depth spinner of the Direction 1 rollout and choose the Reverse Direction 
button in the PropertyManager. Next, choose the OK button to exit.  

22.	 Click on the  sign available on the left of the Boss-Extrude feature of the slider in the 
design tree; the sketch of the extrude feature is displayed. 

23.	 Select the sketch of the extrude feature from the design tree and invoke the Boss-Extrude 
PropertyManager. Next, expand the Selected Contours rollout and select the area enclosed 
by the hole of diameter 3 mm in the Slider; its preview is displayed.

24.	 Enter 10 mm in the Depth spinner of the Direction 1 rollout and extrude it using the Mid 
Plane option. Finally, choose the OK button to exit from the PropertyManager. 

25.	 Click on the confirmation corner to exit from the Part environment. Figure 2-45 shows the 
blocks after they have been converted into parts.

Figure 2-45  Blocks after being converted into parts
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Assembling the Parts 
	 Once all parts have been created, you need to assemble them in the Assembly environment 

using the mate relations.

1.	 Choose the Assembly tab from the CommandManager; the Assembly CommandManager 
is displayed.

	 First, you need to assemble the Wheel with the Shaft. Therefore, you need to fix the Shaft. 

2.	 Select the Shaft from the drawing area and right-click; a shortcut menu is displayed. Choose 
the Fix option from the shortcut menu; the Shaft gets fixed. Now, you cannot move or rotate 
it.

3.	 Invoke the Mate PropertyManager and apply the Concentric mate between the innermost 
circular face of the Wheel and the Shaft, refer to Figure 2-46. Choose the Add/Finish Mate 
button from the Mate pop-up toolbar. 

4.	 Apply the Concentric mate between the left-most inner circular face of the Connecting 
rod and the cylindrical face of the handle on the Wheel, refer to Figure 2-46. Choose the 
Add/Finish Mate button from the Mate pop-up toolbar. 

5.	 Similarly, apply the Concentric mate between the cylindrical face of the handle on the 
Slider and the other circular face of the Connecting rod, refer to Figure 2-46. Choose the 
Add/Finish Mate button from the Mate pop-up toolbar. 

Figure 2-46  Parts faces selected to apply the mates 

6.	 Next, apply the Coincident mate between the horizontal planes of the Shaft and the Slider, 
refer to Figure 2-47. Next, exit from the Mate PropertyManager. Figure 2-48 shows the 
final assembly of the mechanism.
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Figure 2-47  The planes to be selected Figure 2-48  The final mechanism

Applying Motion to the Mechanism
Next, you need to apply motion to the mechanism to check its working.

1.	 Choose the Motion Study 1 tab available at the lower left corner of the drawing area; the 
MotionManager is displayed.

2.	 Choose the Motor button from the MotionManager toolbar; the Motor PropertyManager 
is displayed.

3.	 The Rotary Motor is selected by default in this PropertyManager. Select the front face of the 
Wheel as reference for specifying the direction of rotation; the selected face is displayed in the 
Motor Direction selection box of the Component / Direction rollout of the PropertyManager. 
You can flip the direction of the rotation of the motor, if required, by choosing the Reverse 
Direction button from the Component / Direction rollout.  

4.	 Choose the OK button from the Motor PropertyManager to exit. 

5.	 Choose the Calculate button from the MotionManager toolbar to calculate the motion of 
the mechanism. 

6.	 Choose the Play button from the MotionManager toolbar to view the motion of the 
mechanism and then choose the Stop button to stop the motion of the mechanism. 

7.	 Finally, choose the Rebuild button from the Menu Bar. 

Saving the Model
1.	 Choose the Save button from the Menu Bar; the Save Modified Documents dialog box is 

displayed.

2.	 Ensure that all the check boxes in the file name column are selected. Next, choose the Save 
All button; the Save As dialog box is displayed.
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3.	 Browse to the location, enter c02_tut02 as the file name and choose the Save button; the 
SOLIDWORKS message box is displayed.

4.	 Choose the OK button from this message box; the Save As dialog box is displayed again.

5.	 Select the Save externally (specify paths) radio button and choose the OK button; the 
assembly is saved.

6.	 Close the document by choosing File > Close from the SOLIDWORKS menus.

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 In SOLIDWORKS, the __________ button in the Blocks toolbar is used to make each entity 
of a sketch as a separate block. 

2.	 The __________ check box in the Belt/Chain PropertyManager is selected to specify the 
thickness of the belt.

3.	 Choose the ________ button in the Definition rollout of the Path Properties PropertyManager 
to invoke the Path PropertyManager.

4.	 The __________ button in the Blocks toolbar is used to edit a block.

5.	 The __________ button in the Belt Members rollout of the Belt/Chain PropertyManager 
is used to flip the side of a selected belt member. 

6.	 The Traction relation is used to create a driver-driven mechanism. (T/F)

7.	 In SOLIDWORKS, you can save a sketch directly as a block in the Design Library. (T/F)

8.	 In SOLIDWORKS, you cannot animate a mechanism created out of blocks by applying 
motor to it. (T/F)

9.	 You cannot change the order of the belt members that are selected in the selection area of 
the Belt Members rollout. (T/F)

10.	 The Insert Block tool is used to insert the blocks into an active sketch. (T/F)
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 Review Questions 
Answer the following questions:

1.	 Which of the following buttons in the Blocks toolbar is used to add or remove the sketch 
entities?

		  (a) Edit Block				    (b) Make Block
		  (c) Add/Remove			   (d) Explode Block

2.	 Which of the following tools is used to make each entity of a sketch as a separate block?

		  (a) Save Blocks				    (b) Make Block
		  (c) Edit Block				    (d) Add/Remove

3.	 Which of the following tools is used to dissolve a block into a sketched entity?

		  (a) Belt/Chain				    (b) Rebuild
		  (c) Add/Remove			   (d) Explode Block

4.	 The __________ tool helps you to create a path of sketched entities that are coincident end 
to end and form a single chain.

5.	 The __________ button in the Make Part From Block PropertyManager is used to create a 
part that is constrained to be coplanar with the plane of the block in the Layout environment.

6.	 The __________ button is used to invoke the Make Part From Block PropertyManager.

7.	 While inserting a block in an active sketch, you can change its scale value by using the  
__________ spinner.

8.	 To refresh or update the sketches, choose the __________ button from the Blocks toolbar.

9.	 To create a part from the block, you need to invoke the __________ PropertyManager.

10.	 The Belt/Chain tool is used to insert a belt between__________.

EXERCISE
Exercise 1

Create a mechanism by assembling the blocks, as shown in Figure 2-49, and then convert the 
blocks of the mechanism into parts. Figure 2-50 shows the mechanism after converting blocks 
into parts. Figures 2-51 through 2-54 show different views of parts of the mechanism with 
required dimensions.                                                                            (Expected time: 45 min)
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Figure 2-49  Mechanism created by 
assembling the blocks

Figure 2-50  Mechanism after converting 
the blocks into parts

Figure 2-51  The front and side views of the Wheel Figure 2-52  The front view of 
the Connecting rod1



2-30  					     Advanced SOLIDWORKS 2022 for Designers 
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 2-53  The front and side views of the Connecting rod2

Figure 2-54  The top view of the Ram

Answers to Self-Evaluation Test
1. Make Block, 2. Use belt thickness, 3. Edit Path, 4. Edit Block, 5. Flip belt side, 6. T, 7. T, 
8. F, 9. F, 10. T    


