
Chapter 6

Milling Cycles-I

Learning Objectives

After completing this chapter, you will be able to:
• Create a stock.
• Generate the Facemill toolpath.
• Generate the Roughing toolpath.
• Generate the Profiling toolpath.
• Generate the Flat Land Finishing toolpath.
• Generate the Slot toolpath.
• Generate the Text toolpath.
• Edit the toolpaths.
• Simulate the toolpath.
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THE MANUFACTURE MODE
The Manufacture mode in EdgeCAM provides a wide range of tools for carrying out various
milling and turning operations. You can also generate the NC code file in this mode. The file
is transferred to the CNC machines for performing operations on a workpiece to transform it
into a component. You can use a wireframe geometry or a model imported from other CAD
packages to generate various toolpaths. These toolpaths provide a visual feedback of the tool
movements while performing any machining operation. The Toolstore window provides a
large number of predefined tools. In addition to this, you can also create new tools based on
specific requirements. The Simulator window is used to verify the toolpaths so that the
roughing and other machining errors are eliminated before the file is transferred to the
CNC machine.

After creating the wireframe geometry or importing a model in the Design mode, the
Manufacture mode can be invoked by choosing Options > Manufacture from the menu bar
or by choosing the Switch to Manufacture Mode button on the top right corner of the
EdgeCAM screen. On doing so, the Machining Sequence dialog box will be displayed. You
will learn more about this dialog box later in this chapter.

IMPORTANT TERMS AND DEFINITIONS
Some important terms and definitions used in the Manufacture mode are explained next.

Stock/Fixture
It refers to the workpiece on which various machining operations are performed to produce
the final component. The options for creating a stock in EdgeCAM are Box, Cylinder, Profile,
and Digitise. In case of the Box and Cylinder options, the stock is created by specifying
the offset distance from the existing profile. In case of the Profile option, you can select an
existing geometry to create a stock with the shape of the profile. In the Digitise option, the
stock shape will be extracted from the solid imported into the EdgeCAM environment.

Machine Datum
Machine datum, also called the program zero point, represents the origin point on the
machine. It is used for calculating the coordinates of the tool movement points for generating
various toolpaths. This coordinate system can be made Absolute or Incremental. In case of
an absolute coordinate system, all toolpaths and the tool movement coordinates are
calculated from the machine datum whereas in case of an incremental coordinate system, all
the toolpaths and the tool movement coordinates are calculated with respect to the current
tool position.

Initial CPL
While defining a machining sequence, the initial CPL defines the orientation of the cutting
tool. The cutting tool will be oriented normal to the selected initial CPL.
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Clearance Plane
The clearance plane is an imaginary plane up to which the tool moves from the home position
at a rapid feed rate.

Retract Plane
The retract plane is an imaginary plane that represents the height to which the tool will move
without contacting a workpiece or a stock.

Depth
For any machining cycle, the Depth parameter specifies the total thickness of the
material that is  to be removed.

Cut Increment
The cut increment parameter specifies the thickness of the material to be removed in each
tool pass. The value of this parameter is based on the stock material to be machined and the
type and material of the cutting tool used. The cut increments are calculated incrementally
from the specified level.

Level
The level defines the plane from which the machining of the stock will begin. If the level
value is specified as 0, the cut increments will be calculated from the initial CPL. Also, the
level must be below the clearance plane.

Speed
The speed parameter specifies the spindle speed in revolutions per minute (RPM). The
value of this parameter depends on the stock material to be machined, the cutting tool used,
and the depth of the cut.

Plunge Feed
The plunge feed specifies the rate of the tool movement for non-machining moves. For
example, when the tool moves from the clearance plane to the retract plane at the start of the
cycle or while moving from the end of one cycle to the start of the next cycle. Plunge feed is
expressed in millimeters/inches per minute. Normally, this is the maximum speed supported
by the CNC machine.

Feed Rate
The feedrate specifies the rate of the material removal in millimeters/inches per minute.
The feed rate parameter depends on the diameter of the cutting tool used and the surface
finish required.

Containment Boundary
The containment boundary represents the limits within which the tool movements are
confined.
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CREATING STOCKS AND FIXTURES

The stock represents the workpiece on which various machining operations will be
performed to create the final component. To create a stock, invoke the
Stock/Fixture tool from the Geometry menu bar; the Stock dialog box will be

displayed, as shown in Figure 6-1. Select the Automatic Stock check box and select the shape
of the stock as box shaped or cylindrical from the Shape drop-down list. Depending on the
shape selected for the stock, the Box Offset or the Cylinder Offset area will be displayed in
the Stock dialog box. In the Box Offset area, the Min and Max edit boxes for the X, Y, and
Z axes are used to specify the offset distances along the negative and positive directions,
respectively, for creating the bounding box. In the Cylinder Offset area, the Start Extension,
End Extension, and the Radius Extension edit boxes are used to specify the distance by
which the cylindrical wireframe geometry will be offset to create the cylindrical stock. The
resulting stock will be created as a wireframe geometry. To display the stock in the shaded
mode, choose the Toggle Stock button from the Display toolbar; the translucent stock will
be created, as shown in Figure 6-2.

To manually create a stock or fixture, clear the Automatic Stock check box and select the
Stock or Fixture option from the Type drop-down list. From the Shape drop-down list, select
an option to define the shape for the stock or the fixture. The Depth drop-down list will be
displayed, if you select the Box or Profile option from the Shape drop-down list.

Menu: Geometry > Stock/Fixture
Toolbar: Design > Stock/Fixture

Figure 6-1  The Stock dialog box Figure 6-2  Box shaped translucent stock
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If you select the Box option from the Shape drop-down list, you will need to specify the
depth and select the two diagonal points from the drawing area for defining the length and
the width of the fixture. On selecting the Cylinder option, specify the radius and select the
centerpoint of the two circles that define the axis and also the orientation of the cylinder
from the drawing area. On selecting the Profile option, specify the depth and select the
profile from the drawing area. The Digitise option creates the stock or fixture geometry by
extracting the edges of a solid model. This option is used if you import the model from the
other CAD packages. The layer on which the stock has to be created is specified by selecting
an option in the Layers drop-down list. Else, the stock will be placed on the default layer
Stock.

GENERATING A NEW SEQUENCE
A sequence is defined as a set of operations that are performed on the workpiece
for a job set up. If a part geometry entails a different setup, then a new sequence
will be defined. When you enter the Manufacture mode for the first time, the Machining
Sequence dialog box will be displayed, as shown in Figure 6-3. Specify the parameters and
choose the OK button. A new sequence will be added in the Sequence window. Similar to the
Model window in the EdgeCAM Part Modeler, the Sequence window keeps a track of all the
machining operations performed on the model. To add a new sequence in the Manufacture
mode, choose File > New Sequence from the menu bar.

Enter a name for the machining sequence in the Sequence Name edit box. If a name is not
specified, EdgeCAM will allocate the sequence names as Sequence 1, Sequence 2, and so on.
The Discipline drop-down list is used to select the appropriate manufacturing methodology.
The options in this drop-down list are Any, Mill, Turn, and Wire. The Machine Tool edit
box is used to specify the post-processor that will be used to convert the NC files generated
into the machining instructions appropriate for the selected machining discipline. The options

Figure 6-3  The Machining Sequence dialog box
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in this drop-down list are filtered according to the machining discipline selected in the
Discipline drop-down list. The options in the Component and Machine Setup area are used
to align the component and the machine tool. This area will be available when the Discipline
selected is Mill and the code generator selected in the Machine Tool drop-down list is
supported with  machine graphics. For example, select the solid vertical ac unit.mcp option
in the Machine Tool drop-down list.  The options in the Mating Location drop-down list are
used to locate the component on the machine. Select the Primary Component Location
option to locate the point within the machine. If the None option, is selected the location
point is decided according to the code generator selected. The CPL of the plane whose
origin has to be aligned to the component is specified in the mating CPL drop-down list. If
you select the None option, the CPL is selected  according to the code generator selected.
The tool will be oriented perpendicular to the CPL selected in the Initial CPL drop-down
list. Select the Machine Datum check box to locate the origin point on the machine to calculate
the coordinate values for the current machining sequence. If this check box is not selected,
the origin of the selected initial plane will be taken as the machine datum. The options
Absolute or Incremental in the Datum Type area are used to select the coordinate type for
the machine coordinate system. In case of Absolute, all the coordinate values will be calculated
from the specified machine origin. In case of Incremental, all the coordinate values will be
calculated with respect to the current tool position.

Note
The options in the Lathe Setup tab will be available when you select the Turn option from the
Discipline drop-down list.

TOOL SELECTION

To generate the toolpath, define the
NC code generator and select the
appropriate cutting tool. As discussed
earlier, the code generator is specified
in the Machine Tool edit box in the
Machining Sequence dialog box. The
cutting tools in the Manufacture mode
depend on whether you need to create
milling, turning, or wire toolpaths.
Cutting tools for the milling operations
are selected from the tools in the Mill
Tools toolbar. Alternatively, you can
choose Tooling > Milling Cutter from
the menu bar.

When you choose a cutting tool from
the Mill Tools toolbar, the Milling
Cutter dialog box will be displayed, as
shown in Figure 6-4. Select a radio
button from the Tool Type area to Figure 6-4  The Milling Cutter dialog box

Menu: Tooling > Milling Cutter
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change the cutting tool after invoking the dialog box. Choose the Find button to display the
predefined tools in the selected tooltype. The Toolstore window for selecting a cutting tool is
shown in Figure 6-5. You can also create a tool based on your requirements. For this, specify
the tool parameters by choosing the Create button from the tool selection dialog box. Instead
of selecting a tool from the tool store, you can also specify the  tool dimension in the appropriate
edit boxes that will be available when you select a radio button.

MILLING CYCLES
Milling is the process of removing metal by feeding the work against a rotating multipoint
cutter. The milling operation is performed to create flat surfaces, contoured surfaces, complex
and irregular areas, slotting, external and internal threads, gear cutting, and so on.
EdgeCAM provides a set of machining cycles that can be used. After selecting the required
tool, invoke these cycles by selecting the options in the Mill toolbar. Alternatively, choose
the appropriate option in Mill Cycles in the menu bar. The milling cycles used to create the
toolpaths are discussed next.

Generating the Face Milling Toolpath

Face milling is used to machine surfaces that are perpendicular to the tool axis. The
process is carried out by the end mill tools that have cutting edges both on the periphery
and the end of the milling cutter. Face milling is used to remove any irregularities in the

Figure 6-5  The Toolstore window

Menu: Mill Cycles > Face Milling
Toolbar: Mill > Face Milling
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surface. To perform a face milling cycle, select the cutting tool and then choose the Face milling
tool from the Mill toolbar; the Face Milling dialog box will be displayed, as shown in Figure 6-6.
Set the machining parameters and choose the OK button; the cursor will change to the select
cursor. Select the edges of the containment boundary and right-click; the toolpath will be
generated. The tabs in the dialog box are discussed next.

General Tab
The options in the General tab are used to define the cutting parameters and are discussed
next.

Mill Type Area
The Mill Type area defines the milling method used to machine the workpiece. If the
Climb radio button is selected, the workpiece is moved in the same direction as the tool
rotation. This option can be used for milling softer materials such as aluminium. If the
Conventional radio button is selected, the workpiece is moved in the direction opposite
to the rotation of the cutter. This option should be used for harder materials. When the
Optimised radio button is selected, the material is removed from the work piece in both
directions. This reduces the cycle time.

% Stepover
This edit box is used to specify the distance between two successive tool passes in terms
of the percentage of the tool diameter. Usually, the value is between 70 to 80 percent of
the tool diameter.

Figure 6-6  The Face Milling dialog box
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Angle
The Angle edit box is used to specify the angle made by the toolpath to the horizontal
axis.

Step Direction
This drop-down list will be available if you select the Optimised radio button from the
Mill Type area. The options in this drop-down list are Left and Right. Select the option
to specify the cutting direction.

Stock Offset
This edit box is used to move the cutting tool at an offset distance from the selected
boundary. A positive value moves the tool outside the boundary and a negative value
moves the tool inside the boundary.

Feed Area
The edit boxes in this area are used to specify the feedrate, plunge feed, and the speed.

Boundary Control Area
The options in the Boundary Control area are used to control the movement of the tool
with respect to the containment boundary selected. Select the Tool Centre radio button
to move the tool in such a way that the centre of the tool lies inside the boundary. Select
the Tool Inside radio button to move the tool inside the boundary. The Tool Outside
radio button is selected to move the tool outside the boundary equal to half the tool
diameter value.

Figure 6-7 shows the face milling toolpath generated with no angular value specified in the
General tab. Figure 6-8 shows the face milling toolpath with the angular value specified in
the Angle edit box in the General tab.

Depth Tab
The options in the Depth tab define the tool movement during the face milling cycle. The
Clearance edit box is used to specify the position of the clearance plane. Specify the absolute

Figure 6-8 Facemill toolpath with an angle valueFigure 6-7  Facemill toolpath without an angle value
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level from which the machining should start in the Level edit box. The depth up to which
the material has to be removed is specified in the Depth drop-down list. The Cut Increment
edit box is used to specify the material to be removed for each tool pass.

Note
If you select the Digitise option in these drop-down lists, you will be prompted to select the
position after specifying the direction of the cut from the drawing area.

Lead Tab
Lead can be defined as the non-machining moves before and after the cut. The options in
this tab allow you to specify the tool movement before the start and after the end of the cut.
To create the lead moves in the form of straight lines, enter a value in the Lead Length edit
box. To move the tool in an arc, specify the arc radius in the Radius edit box. If you select the
Equal Lead Moves check box, the values entered in the Lead In area will be used for both
the lead moves. The Percentage Feed edit box is used to specify the rate of tool travel during
the lead moves. It is calculated as the percentage of the feedrate specified in the General tab.

Links Tab
Choose the Links tab to join the lead in and lead out moves when the tool has to move in
various Z levels. The endpoint of the one machining segment is the joined start point of the
other segment depending on the options selected in this tab.

Generating the Roughing Toolpath

Rough milling is used to remove a huge amount of material in less time. To create a
rough milling, choose Mill Cycles > Roughing from the menu bar or choose the
Roughing button from the Mill toolbar. The Roughing dialog box that will be

displayed after invoking the tool is shown in Figure 6-9. Specify the parameters and choose
the OK button; you will be prompted to select the profile. Select a closed profile in the
drawing area and right-click; you will be prompted to select the containment boundary. Select
the edges of the stock and right-click to generate the toolpath.

The options in this dialog box are discussed next.

General Tab
The options in the General tab are used to define the cutting parameters. These options are
discussed next.

Model Type Area
The option selected in this area decides whether a wireframe, surface, or a solid model is
used to generate the toolpath. When a solid is imported from the other software, the
Solid radio button will be available.

Menu: Mill Cycles > Roughing
Toolbar: Mill > Roughing
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Mill Type Area
The options in this area are used to specify the milling method required to remove the
material. The options in this area are Climb, Conventional, and Optimised.

Rest Rough
The Rest Rough check box is selected to remove the material left by the previous roughing
cycle. For example, if you have removed the material using the Minimum Radius value,
then the corners will not be machined to the exact radius value.

Digitise Roughing
Select this check box to generate a new roughing cycle by selecting the toolpath generated
in the previous cycle.

Strategy Area
The Strategy area is used to specify the tool movement required to remove the material.
If you select the Concentric and Spiral radio buttons, the material will be removed in
concentric passes. When you select the Lace radio button, first the material will be removed
from the sides and then the peripheral material will be removed. On selecting the Lace

Figure 6-9  The Roughing dialog box
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option, you can enter an angular value in the Lace Angle edit box to move the tool at a
specified angle.

Offset, XY Offset, and Z Offset
These edit boxes are used to move the tool at the specified offset distance from the
profile along the X, Y, and Z axes. The offset distance along both the X and Y directions
from the profile is specified in the XY Offset edit box. Similarly, the Z Offset edit box is
used to specify the offset distance along the Z direction from the profile. When you
specify a value in this edit box, the component produced will be oversized. A finishing
cycle has to be carried out to bring it to the required size.

% Stepover
The distance between two successive tool passes in terms of the percentage of the tool
diameter is entered in this edit box.

High Speed Cornering
Select this check box to make the tool move in a radius in sharp corners.

Cut by Region
Select this check box to machine a region completely and then move to the next region.
If this check box is not selected, multiple regions will be machined simultaneously based
on their level.

Close Open Pockets
This check box will be available when you  select the Concentric radio button in the
Strategy area. Select this to move the tool from inside the profile to outside the profile.
If this check box is not selected, the tool will move from outside to inside the profile.

Clean Up % Stepover
This edit box is used to remove the material left due to the approximation of % Stepover.
Usually the value has to be less than that of the % stepover value. Also, when you select
the Lace strategy, the value will be less than 20%.

Stock Area
The options in this area are used to select the type of stock used. Select the type of stock
used from the Stock type drop-down list. If you need the tool to move at an offset distance,
specify it in the Stock Offset edit box.

Minimum Radius
The Minimum Radius edit box is used to specify the radius of the corners. Corners with
a radius less than the specified value will not be machined. Such corners can later be
machined using a tool of a lesser radius and selecting the Rest Rough check box.

Feed Area
The Feed area is used to specify the rate at which the material will be removed. Specify
the feedrate, speed, and plunge feedrate in the respective edit boxes.
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Depth Tab
The options in the Depth tab are used to specify the extent up to which the material has to be
removed. The functions of the Clearance, Level, Depth, and Cut Increment edit boxes are
the same as those explained in the previous machining cycle.

Intermediate Slices Area
The options in the Intermediate Slices area are used to define the machining parameters
for removing the intermediate steps left by the roughing toolpath while machining from
the top to the bottom of a drafted pocket. The material removal for the steps is always
carried out from the bottom to the top. You can specify parameters such as the percentage
stepover, cut increment, and percentage feed.

Contouring Tab
The options in this tab allow you to define a pocket without creating it in the model. To create
toolpaths for drafted pockets, specify the draft angle in the Draft Angle edit box. Also, to
create fillets at the upper and lower ends of the pocket, enter the radius value in the Upper
Radius and Lower Radius edit boxes, respectively. Alternatively, you can select the profile of
the drafted filleted pocket from the graphics area by choosing the Digitise Contour Walls
check box. The Round and Sharp radio buttons in the Corner Type area are used to specify
the shape of the corners to be created in the pocket.

Figure 6-10 shows the profile and the toolpath generated in the top view for creating a
pocket using the roughing toolpath. Figure 6-11 shows the resultant component in the
isometric view.

Generating the Profiling Toolpath

The profiling cycle is used to remove the material along a profile. The profile can be
closed or open. To create the toolpath along a profile, select the tool and choose Mill
Cycles > Profiling from the menu bar or choose the Profiling button from the Mill

Menu: Mill Cycles > Profiling
Toolbar: Mill > Profiling

Figure 6-11  The pocket createdFigure 6-10  The profile and the Roughing toolpath
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toolbar; the Profiling dialog box will be displayed, as shown in Figure 6-12. Set the parameters
for the cycle and choose OK; you will be prompted to select the profile. Select the profile
from the drawing area and right-click. You will notice an arrow inside the profile. This
arrow defines the direction of the tool movement. Click outside the profile to remove the
material outside the selected profile or else right-click. You will be prompted to select the
containment boundary. Select the edges of the stock created and right-click; the toolpath will
be generated. For the solids imported from the other CAD packages, you need to extract the
edges to use them as profiles. This will be explained in the next chapter.

The tabs and their options in the dialog box are discussed next.

General Tab
The options in this tab are similar to those discussed in the earlier machining cycles. The
options that are different are discussed next.

Figure 6-12  The Profiling dialog box
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Model Type
The Model Type area is used to define whether a surface or wireframe geometry has
been used to generate the toolpath. When a solid is imported from the other software,
the Solid radio button will be displayed and it will be selected by default.

3D Profiling
This  check box will be available if the Wireframe radio button is selected in the Mill
Type area. Select this check box if you have 3D wireframe sketches.

Prismatic Geometry
This check box will be available if the Solids radio button is selected in the Mill Type
area. Select this check box to identify the prismatic solids and to create toolpaths as lines
and arcs.

Undercut
This check box will be available if you select the T-Slot cutting tool. Select this check box
to machine undercuts of a specified depth.

Multiple Passes Area
The options in the Multiple Passes area are used if the material along the profile cannot
be removed in a single pass, as shown in Figure 6-13. The Start Offset edit box is used to
specify the maximum distance between the profile and the stock from where the milling
tool will start removing the material. The Offset Increment edit box is used to specify
the thickness of the material to be removed in successive tool passes. Figure 6-14 shows
the profiling toolpath with multiple passes.

Feed Area
The options in the Feed area are used to specify the cutting parameters such as feed,
spindle speed, and plunge feed.

CRC Area
The options in the CRC area are used to apply the cutter radius compensation. This area
will be available when you select Wireframe from the Model Type area and Climb or
Conventional from the Mill Type area. The cutter radius compensation is used by the
controller to calculate the toolpath at an offset equal to the radius of the cutter from the

Figure 6-14  Profiling toolpath with multipleFigure 6-13  Profiling toolpath with single pass
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profile to be machined. When the None option is selected, the toolpath is generated for
the tool centre. When the Centre Line option is selected, the offset is calculated for the
centre point of the tool whereas when the Geometry is selected, the offset is calculated
for the periphery of the tool. In both the Centre Line and Geometry options, the output
codes are generated in the NC code file depending on whether the Left or the Right
compensation is selected.

Depth Tab
The options in this tab are used to specify the position of the clearance plane, cut increment,
and the absolute level from which the material removal will start.

Helical
Select this check box if the profile is closed and to move the tool in a continuous pass
without going to the retract plane.

Cusp Height
The depth up to which the material should not be cut is specified in this edit box.

Finish At Area
The options in this area are used to specify the cutter location at the end of the cycle. The
options are Depth, Retract, and Clearance.

Detect Flat Land
Select this check box to remove the material from all the flat regions. This will be useful
to remove the material from the pockets.

Control Tab
The options in this tab are used to control the tool movement. Few options will not  be
available if you select the 3D Profiling check box in the General tab. Contact Angle is the
angle between the surface to be machined and the tool axis. The maximum and the minimum
values are specified in the corresponding edit boxes. The other options are discussed next.

Finish Shallow Areas Area
The options in this area are used to create a smooth finish, which are generated because
of the given cusp height.

Optimisation Area
The options in the Optimisation area are used to control the machining of the pocket.
Select the Cut by Region check box to machine the pockets by region. If this check box
is not selected, the pockets will be machined simultaneously. Select the Bottom to Up
check box to machine the region from the lowest level to upwards. Select the Nearest
Neighbour check box to machine the region of the same height simultaneously.

Corners Area
The end surface that the tool has to create when it moves around the intersecting surfaces
is specified by selecting the options in the Corners area. The schematic representation
for the tool movement for each option is given below.
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Round
After machining the horizontal surface, the tool moves in a round to machine the
vertical surface, as shown in Figure 6-15.

Sharp
After machining the horizontal surface, the tool moves a distance horizontally before
it machines the vertical surface, as shown in Figure 6-16.

Twizzle
After machining the horizontal surface, the tool moves in a twizzle to machine the
vertical surface, as shown in Figure 6-17. The radius the tool has to move in the
twizzle is entered in the Twizzle Radius edit box.

High Speed
After machining the horizontal surface, the tool moves in a round equal to the 50%
of the tool radius to machine the vertical surface, as shown in Figure 6-18.

Figure 6-16  The Sharp StrategyFigure 6-15  The Round Strategy

Figure 6-18  The High Speed StrategyFigure 6-17  The Twizzle Strategy
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Use Check Surface
Select this check box to prevent a surface from machining.

Check offset
This edit box is used to specify the offset distance from the surface selected as the check
surface.

Boundary Control Area
Select the Tool Contact radio button to keep the tool always in contact with the workpiece.
The other options are similar to those discussed in the Face Milling cycle.

Start/End Tab
The options in this tab are used to define the tool entry and exit on the workpiece. The
options will be available based on the previously selected options.

Plunge Point
The options in this drop-down list will be used to define the tool entry point. If the
Automatic option is selected, the system automatically selects the entry point. Select the
Digitise option to locate the entry point. The Centre of Area option will be selected to
start the cut from the centre of the profile.

Retract Point
The options in this drop-down list are used to define the tool exit after the machining. If
you select the Plunge Point option, the tool exit will be from the point where the tool
entered.

Default Side
As mentioned earlier, the profiling cycle is a process of removing material along a profile.
The side from where the material has to be removed is specified in the Default Side
drop-down list. On selecting the None option, you will be prompted to digitize the side
to be machined after selecting the profile.

Note
The Default Side drop-down list will be available if you select the Wireframe option in the
General tab.

Start/End Point Preference Area
The options in this area are used to specify the tool entry and exit position.

Digitise
Select this radio button to select the position from the drawing area.

Min/Max
Select this radio button to position the entry and exit point of the tool along the X
and Y coordinates. Also, specify the maximum or minimum x or y position by choosing
the corresponding options from the Min/Max drop-down list.
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Longest Side
Select the Longest Side radio button to start and end the cycle from the midpoint of
a line or an arc in the profile. This is specified by selecting the suitable options from
the Long Side drop-down list. If you need to start or end the cycle from a
particular distance from the start point along the profile, it is specified in the
Proportional Distance edit box. The distance can be entered in terms of percentage
or as a fraction from the start point. If you enter a  number from 1 to 100, it is
considered as percentage. If you enter a value between 0 to 1, it is considered as a
fraction.

Sharp Corner
Select this radio button to start and end the cycle from a corner.

Near Plunge/Retract
This radio button is selected to start and end the cycle from the plunge or retract
point.

Profile Extension Area
The options in the Profile Extension area are used to start or end the cut from a distance
along the profile. The distance is specified in the Start or End edit boxes. If a overlap of
start and end point is required, it is specified in the Overlap edit box.

Note
1. The Overlap edit box will not be available if the Helical check box is checked in the Depth
tab.
2. Do not give an overlap distance if the Sharp Corner radio button is selected in the Start/
End Point Preference area.

Lead Tab
Choose the Lead tab to set the non-machining moves. The manner in which the tool enters
and leaves is set in this tab. The type of lead move required is specified by selecting the radio
buttons in the Type area. The Percentage Feed edit box is used to specify the rate the tool
has to move in the non-machining moves. The feedrate is given in terms of percentage of the
feedrate specified in the General tab. The lead move can be a straight line or an arc. The
length or the radius is specified in the corresponding edit boxes in the Lead In or Lead Out
areas.

Links Tab
Choose the Links tab to join the lead in and lead out moves when the tool has to move in
various Z levels. The endpoint of one machining segment is joined to the start point of the
other segment according to the options selected in this tab.

Rest Profiling
Choose this tab to machine the region that is not machined by the previous profiling cycle.
Specify the details of the tool used in the corresponding edit boxes. These edit boxes will not
be available if you select Undercut in the General tab.
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Contouring Tab
Choose this tab to machine a tapered wall using the 2D wireframe profile. The options are
similar to those explained in the Roughing cycle.

Figure 6-19 shows the profile and the profiling toolpath created with multiple passes.
Figure  6-20 shows the resultant component.

Generating the Drilling Toolpath

In EdgeCAM, you can generate the toolpath for drilling operations such as simple
holes, boring, and reaming. Before creating the toolpath, the hole location has to be
specified by points. Select the appropriate tool from the Mill Tools toolbar and choose

the Hole button from the Mill toolbar; the Hole Cycle dialog box will be displayed, as shown
in Figure 6-21. Set the parameters in the tab and choose the OK button; you will be prompted

Figure 6-20  The resulting componentFigure 6-19  Roughing toolpath with multiple
passes

Menu: Mill Cycles > Hole
Toolbar: Mill > Hole

Figure 6-21  The Hole Cycle dialog box
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to select the hole locations. Select the location from the drawing area and right-click; the
toolpath will be generated.

General Tab
The options in the Strategy drop-down list in the General tab are used to select the type of
drill cycle to be executed. The options include Drill, Bore, Ream, and Chipbreak. Specify
the plunge feed and the spindle speed in the respective edit boxes. The options in the
Optimise Path drop-down list are used to define the route to be followed by the drill tool to
perform the operation. Depending on the pattern of the holes to be drilled, different paths
can be selected to minimize the tool travel time and reduce the non-machining time. The
options in this drop-down list are X Lace, Y Lace, Return To Start, X One Way, Y One Way
and Closest Neighbour. Figure 6-22 shows the drill toolpath generated by selecting the X
Lace option and Figure 6-23 shows the drill toolpath generated by selecting the Y Lace
option from the Optimise Path drop-down list.

Depth Tab
The options in this tab are used to define the position of the clearance plane and retract
plane. Specify the level from which the drilling operation will start in the Level edit box.
Also,  specify the total depth of the hole to be machined in the Depth edit box. Note that the
depth value entered should be a negative value.

Step Tab
The options in this tab are used to specify the tool movement in each pecking. The Cut
Increment edit box is used to specify the depth of the hole that has to be drilled in each
peck. Specify the amount by which the cut increment value is reduced for each successive
depth in the Degression edit box. The Safe Distance edit box is used to specify the distance
through which the tool has to move upward before each peck.

Generating the Text Toolpath

The Text toolpath is used for engraving purposes. To generate the Text toolpath, create the
text in the Design mode using the Text tool. In the Manufacture mode, choose the
Mill Cycles > Text from the menu bar; the Text Mill dialog box will be displayed, as shown
in Figure 6-24. Specify the parameters in the respective edit boxes and choose OK; you will

Figure 6-23  Drill toolpath generated using
the Y Lace option

Figure 6-22  Drill toolpath generated using the
X Lace option

Menu: Mill Cycles > Text
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be prompted to select the text. Select it from the drawing area and right-click; the toolpath
will be generated, as shown in Figure 6-25. Note that you need to enter a negative value in
the Depth tab.

Note
The options in the General tab and the Depth tab are similar to the ones that have been
discussed earlier.

Generating the Slot Toolpath

The Slot mill cycle is used to a create a slot. The slot will be created in a single pass of
the tool. To generate a slot toolpath, create a profile passing through the midpoint of
the slot. The profile created will be followed by the tool. Select a tool for the slot

milling and invoke the Slot tool by choosing the Slot button from the Mill toolbar; the Slot
Milling dialog box will be displayed, as shown in Figure 6-26.

General Tab
The options in the Strategy area define the strategy used by the slotting tool. Select the 2D
radio button, if the slot tool has to follow a planar profile. If you select the 3D radio button,
the slot tool will follow the curve and 3D continuous entities. The options in the Link
Control drop-down list are used to control the tool movements between the end of one slot
to the start of the second slot when multiple slots are to be machined. The options in the
drop-down list are Shortest and Retract. Specify the other parameters such as feedrate,
speed, and the plunge feedrate in the respective edit boxes.

Menu: Mill Cycles > Slot
Toolbar: Mill > Slot

Figure 6-25   The Text toolpathFigure 6-24  The Text Mill dialog box
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Depth Tab
Specify the locations of the clearance plane, retract plane, the depth of cut, and the level
from which the machining will start. The Relative Depth and Cut Increment drop-down lists
will be displayed only when you select the 3D radio button from the Strategy area. Specify
the total depth of the cut in the Relative Depth edit box. In the Cut Increment edit box,
specify the depth to which the tool has to move in each pass.

Specify the parameters in the corresponding edit boxes and choose the OK button; you will
be prompted to select the profile. Select it from the drawing area and right-click. You will
notice an arrow at one end of the profile, defining the start point of the cut. Click at the other
end to change the start point, else right-click. You will notice a star at the other end denoting
the endpoint of the cut. Click and move the cursor to alter the start point and endpoint of
the cut. Else, right-click to generate the toolpath. For an imported solid, extract the edges
using the Geometry From Edges tool and offset such that it passes through the midpoint of
the slot. This will be dealt later in this text book. Figure 6-27 shows the model in the wireframe
mode and the line, which the tool has to follow, and the toolpath generated.

Figure 6-26  The Slot Milling dialog box

Figure 6-27  Slot toolpath generated
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EDITING A TOOLPATH
To edit a toolpath, select it from the Sequence window and right-click; a shortcut menu will
be displayed. Select the Edit option from the shortcut menu; the dialog box of the
corresponding toolpath will be displayed. Change the values, if required, and choose OK.
You can also double-click the toolpath to invoke the particular dialog box. To change the
profile or the containment boundary, select the Coordinate Input check box and choose
OK. Some dialog boxes will have the Coord Input area with the inputs selected previously.
Select the inputs to be changed and choose OK. You will be prompted to select the inputs;
select them from the drawing area.

SIMULATING THE TOOLPATHS

In EdgeCAM, you can simulate the toolpath generated and visualize the tool
movement. Simulation is used to verify the toolpaths generated by different cycles.
It helps in identifying the interference between the tool and the workpiece. It also

helps in optimizing the cutting process. Simulation can be performed in the current
manufacture mode or by invoking a new window. After generating the toolpath, select the
machining cycle from the Sequence window and right-click. Choose the Simulate option
from the shortcut menu; the tool will trace the toolpath generated. You can adjust the speed
of the tool movement using the slider in the Simulator window.

You can also choose the Simulate Machining button from the Main toolbar. If you have more
than one sequence, the Select Sequences dialog box will be displayed. Select the sequences
to be simulated and choose OK; the Simulator window will be displayed, as shown in
Figure 6-28. The options for viewing the simulation are in the toolbar at the top of the
simulator. The Start button is used to start the simulation and the Stop button is used to halt
the simulation at any point of time. Choose the Fast Forward button to run the simulation at
a rapid rate and view the final model. The Rewind button allows you to restart the simulation
from the beginning. The workpiece, tool, and fixtures can be displayed in the wireframe,
translucent, or solid modes.

The speed of the simulation can be varied by choosing the Toggle Speed Control button
from the Main toolbar. A speed control slider will be displayed. When you move the slider to
the left, the speed decreases. When you move the slider to the right, the speed increases. You
can also stop the tool at the time of collision, indexing, at a specific cut, and so on. To do so,
choose the Stop Options button from the toolbar; the Stop Options dialog box will be
displayed. Select the required radio button to define the stop position and choose OK. The
Display toolbar is used to display the stock, tool, and the tool holder in the predefined
display modes. The predefined display modes in the simulator window are Solid, Translucent,
and Edges.

In the Simulator window, the collision between the tool or the tool holder with the stock
is displayed in red color. Also, the number of collisions detected will be displayed in the
Output window in terms of the number of faults. To view the location of collision, choose

Menu: View > Simulate Machining
Toolbar: Main > Simulate Machining
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Figure 6-28  The Simulator window

the Warnings tab and select an option; the location will be displayed in the simulation
window.

TUTORIALS

In this tutorial, you will generate the toolpaths for machining the model, as shown in
Figure 6-29. The dimensions of the model are shown in Figure 6-30.

    (Expected Time: 2 hrs)

The following steps are required to complete this tutorial:

a. Start a new EdgeCAM file.
b. Draw the sketch of the model in the sketching environment.
c. Create the stock.
d. Draw a line that will represent the slot.
e. Generate the toolpaths using the facemill, roughing, profiling, slot, and hole cycles.
f. Run the EdgeCAM Simulator.
g. Save the file.

Starting a New EdgeCAM Session
1. Start a new EdgeCAM environment. EdgeCAM starts in the Design mode in the XY

environment.

2. Draw the inner and outer profile of the model by choosing Geometry > Slot from the
menu bar. Refer to Figure 6-30 for dimensions. You do not need to specify the depth.

Tutorial 1
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3. Delete the vertical lines at the center and then draw the line passing through the origin
and parallel to the horizontal axis representing the slot in the model.

4. Invoke the Point tool and locate the center point of the holes. The profile, after creating
a line for the slot and the center point of the holes, is shown in Figure 6-31.

5. To create the stock, offset the outer profile to a distance of 4 mm. Figure 6-32 shows the
profile after offsetting.

Creating the Stock
1. Choose Stock/Fixture from the Design toolbar; the Stock dialog box is displayed.

2. Clear the Automatic Stock check box. Select Profile from the Shape drop-down list.

3. Select the Stock option from the Type drop-down list.

Figure 6-30   Dimensions for Tutorial 1Figure 6-29  Model for Tutorial 1

Figure 6-32  Profile after offsetting the outer
profile

Figure 6-31  Sketch after drawing the lines, arcs
and points



Milling Cycles-I        6-27

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r .

 D
o

 n
o

t 
co

p
y

. 
D

o
 n

o
t 

co
p

y
. 

D
o

 n
o

t 
co

p
y

. 
D

o
 n

o
t 

co
p

y
. 

D
o

 n
o

t 
co

p
y .

 V. 
V

. 
V

. 
V

. 
V i

si
t 

w
w

w
is

it
 w

w
w

is
it

 w
w

w
is

it
 w

w
w

is
it

 w
w

w
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s

4. Enter -20 in the Depth drop-down list and choose the OK button.

5. Select the offset profile in the counterclockwise direction close to the start point of each
entity and right-click; a wireframe stock will be created around the model. The isometric
view of the model, after creating the stock, is shown in Figure 6-33.

Invoking the Manufacture Mode
1. Choose the Switch to Manufacture Mode button on the top right corner of the EdgeCAM

window; the Machining Sequence dialog box is displayed.

2. Enter the sequence name as c06tut01. Select Mill from the Discipline drop-down list.
Select fanuc3x.mcp from the Machine Tool drop-down list. From the Initial CPL
drop-down list, select the Top option. Clear the Machine Datum check box, select the
Absolute radio button, and choose the OK button; the Manufacture mode is invoked.

Generating the Facemill Toolpath
The first operation in the machining sequence is to machine the extra material in the Z
direction using the Facemill cycle.

1. Choose Tooling > Milling Cutter from the menu bar; the Milling Cutter dialog box is
displayed. Select the End mill radio button from the Tool Type area and choose the
Find button; the Toolstore window is displayed. Select the 8mm Endmill - short series
tool and choose the Select button. Choose the OK button from the Milling Cutter dialog
box.

2. Choose Mill Cycles > Face Milling from the menu bar; the Face Milling dialog
box is displayed.

3. Set the following parameters in the General tab:

Mill Type: Optimised % Stepover: 65 Angle: 0
Step Direction: Left Tolerance: 0.01 Stock Offset: 0
Feedrate (mm/min): 400 Plunge Feed (mm/min): 1200 Speed(RPM): 2500

Figure 6-33  Isometric view of the stock created
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4. Choose the Depth tab and set the following parameters:

Clearance: 10 Level: 0
Depth: 5 Cut Increment: 1

5. Choose the Lead tab and set the following parameters:

Percentage Feed: 100 Apply To: First And Last Cut
Equal Lead Moves: Select the check box Angle: 45 Lead Length: 5
Lead Radius: Clear the edit box

6. Choose the Links tab and set the following parameters:

Short Link Distance: 5

Short Links Area
Type: Straight Percentage Feed: 100

Long Links Area
Type: Optimised Safe Distance: 5

7. Choose the OK button. You are prompted to select the closed profiles to machine.

8. Choose the down arrow on the right of the Tool Display button on the Display toolbar
and choose Hide from the flyout.

9. Orient the profile to the top view and select the outer profile. Right-click to end the
selection. The resulting facemill toolpath is shown in Figure 6-34.

Generating the Profiling Toolpath
Next, you will generate the toolpath to remove the material outside the profile using the
Profiling tool.

Figure 6-34  Model after generating the facemill toolpath
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1. Invoke the Layers window by choosing the Layers tab below the Sequence window.
Double-click on Yes next to 8mm Endmill to hide the toolpath.

2. Right-click in the Layers window and choose the New option. Enter Profiling as the new
name for the layer and choose OK.

3. Invoke the Endmill tool from the Mill Tools toolbar; the Milling Cutter dialog box is
displayed with the End mill radio button selected in the Tool Type area. Choose the
Find button; the Toolstore window is displayed. Select the 8mm Endmill - long series
tool and choose the Select button.

4. Choose the More tab and select the Racing Green option from the Colour drop-down
list. Select the Profiling option from the Layer drop-down list. Choose the OK button.

5. Choose Profiling from the Mill toolbar; the Profiling dialog box is displayed.

6. In the General tab, set the parameters as follows:

Model Type: Wireframe Mill Type: Conventional
NC Output Smoothing: Line Arc Tolerance: 0.01
Feedrate (mm/min): 400 Plunge Feed (mm/min): 1200
Speed(RPM): 2500 Clear all the other check boxes and edit boxes.

7. Choose the Depth tab and set the parameters as follows:

Clearance: 10 Level: -5 Depth: 10 Cut Increment: 1

Helical: Select the check box Detect Flat Land: Clear the check box
Finish At Area: Select the Clearance radio button
Clear all the other check boxes and edit boxes.

8. Choose the Control tab and set the parameters as follows:

Corners Area: Select the Round radio button from the Strategy area.

Boundary Control Area: Select the Tool Outside radio button from the Tool Control area.
Offset: 0

9. Choose the Start/End tab and set the parameters as follows:

Plunge Point: Automatic Retract Point: Automatic
Default Side: Outside

Start/End Point Preference Area
Select the Longest Side radio button from the Type area
Longest Side: Straight Proportional Distance: 0.5
Clear the Start and the End edit boxes.
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10. Choose the Lead tab and set the parameters as follows:

Type Area: Select the Tangential radio button
Percentage Feed: 100 Equal Lead Moves: Select the check box

Lead In Area
Angle: 45 Length: 0 Lead Radius: 4

11. Choose the Links tab and set the parameters as follows:

Short Link Distance: 5 Approach Clearance: Select the check box

Short Links Area
Type: Straight Percentage Feed: 100

Long Links Area
Type: Optimised Safe Distance: 5

12. Choose OK; you will be prompted to select the profile. Set the view to the top and select
the outer profile of the model, as shown in Figure 6-35, and right-click.

13. You will notice an arrow pointing outside the profile. Right-click to accept that line to
locate the start point of the cut.

14. You are prompted to select the containment boundary. Invoke the Layers window and
double-click on Yes next to the Stock layer; the stock will be hidden.

15. Select the outermost profile as the containment boundary and right-click to end the
selection.

16. EdgeCAM starts generating the toolpath and displays the progress bar at the bottom of
the EdgeCAM screen. Invoke the Layers window and double-click on No next to the
Stock layer; the stock is displayed. The isometric view of the model, after creating the
profiling toolpath, is shown in Figure 6-36. In this figure, the previous toolpath is hidden
by double-clicking on Yes next to the 8mm Endmill layer.

Figure 6-36  Profiling toolpath generatedFigure 6-35  The profile to be selected
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17. Select the Profiling node from the Sequence window and press F2. Enter the name as
Outer Profile and click in the drawing area.

Generating the Roughing Toolpath
In this section, you will create a new layer in the Layers window and hide the previous
toolpath. Next, you will generate the toolpath for machining the pockets.

1. Invoke the Layers window by choosing the Layers tab below the Sequence window.
Double-click on Yes next to Profiling to hide the toolpath.

2. Create a new layer with the name Pocket.

3. Choose the Endmill button in the Mill Tools toolbar; the Milling Cutter dialog box is
displayed with the End mill radio button selected in the Tool Type area. Choose the
Find button. In the Toolstore window, select the 6mm Endmill - short series tool and
choose the Select button.

4. Choose the More tab and select the Pocket option from the Layer drop-down list. Choose
the OK button.

5. Choose Mill Cycles > Roughing from the menu bar; the Roughing dialog box
is displayed.

6. In the General tab, set the parameters as follows:

Model type: Wireframe Mill Type: Optimised Strategy: Concentric
NC Output Smoothing: Line Arc % Stepover: 70
Close Open Pockets: Select the check box Stock Type: None
Feedrate (mm/min): 400 Plunge Feed (mm/min): 1200 Speed (RPM): 2500

7. Choose the Depth tab and set the parameters as follows:

Clearance: 10 Level: -5 Depth: 10
Cut Increment: 2 Clear all the other check boxes and edit boxes.

8. Choose the Approach tab and set the parameters as follows:

Approach Type: Ramp Ramp Angle: 45 Percentage Feed: 100
Link Method: Optimised Safe Distance: 5 Cut Increment Stand Off: 1
XY Stand Off: 1

9. Choose the OK button; you are prompted to select the profile to be machined. Select the
inner profile of the model in the drawing area and then right-click.

10. You are prompted to select the containment boundary. Select the offset profile as the
containment boundary as you selected for the Profiling cycle. Right-click to end the
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selection; the toolpath is generated. The isometric view of the model, after creating the
roughing toolpath, is shown in Figure 6-37.

11. Select the Roughing node from the Sequence window and press F2. Enter the name
Pocket and click in the graphics area.

Generating the Slot Toolpath
1. Invoke the Layers window by choosing the Layers tab below the Sequence window.

Double-click on Yes next to Pocket to hide the toolpath.

2. Create a new layer in the Layers window, as described earlier. Name it as Slot.

3. Invoke the T-Slot tool from the Mill Tools toolbar; the Milling Cutter dialog
box is displayed with the T-Slot radio button selected in the Tool Type area.
Choose the Find button; the Toolstore window is displayed. Select the 25.5mm
x 6 thick T-Slot-13A F30M tool and choose the Select button.

4. Enter 10 in the Diameter edit box. Choose the More tab and select the Slot option in the
Layer drop-down list. Choose the OK button in the Milling Cutter dialog box.

5. Invoke the Slot tool in the Mill toolbar; the Slot Milling dialog box is displayed.

6. In the General tab, set the parameters as follows:

Strategy: 2D Link Control: Shortest
Feedrate (mm/min): 300 Plunge Feed (mm/min): 1200 Speed (RPM): 2500

7. Choose the Depth tab and set the parameters as follows:

Clearance: 10 Retract: 5 Level: -5 Depth: -5
Finish At Area: Select the Clearance radio button

8. Choose the OK button; you will be prompted to select the profile. Select the horizontal
line passing through the origin and right-click.

Figure 6-37  Roughing toolpath created for the pocket
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9. Observe an arrow at the end of the line. It indicates the start point of the operation.
Right-click to accept it.

10. Next, a star is displayed at the other end of the line. It indicates the endpoint of the
operation. Right-click to accept it; the slot toolpath is generated. The isometric view of
the model, after generating the slot toolpath, is shown in Figure 6-38.

11. Select the Slot Milling node from the Sequence window and press F2. Enter a new name
as Slot and click in the graphics area.

Generating the Hole Toolpath
In this section, you will create a new layer in the Layers window and hide the previous
toolpath. The Hole toolpath will be generated in two steps. In the first step, the centre
drill will be used to mark the hole locations. Next, the drilling tool of the size of the holes
will be used to drill the final holes.

1. Invoke the Layers window by choosing the Layers tab below the Sequence window.
Double-click on Yes next to Slot to hide the toolpath.

2. Create a new layer with the name Drill.

3. Invoke the Drill tool in the Mill Tools toolbar. The Milling Cutter dialog box
is displayed with the Drill radio button selected in the Tool Type area. Choose
Find; the Toolstore window is displayed. Choose the Centre Drill button at the
bottom and select the 3mm x 60 Centredrill - 13A F30M tool. Choose the Select
button to return to the previous dialog box.

4. Enter 3 in the Diameter edit box. Choose the More tab, select the Drill option from the
Layer drop-down list, and choose OK.

5. Choose the Hole button in the Mill toolbar; the Hole Cycle dialog box is
displayed.

Figure 6-38  Model after generating the slot toolpath
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6. In the General tab, set the parameters as follows:

Strategy: Drill Plunge Feed (mm/min): 1200 Speed (RPM): 2500
Optimise Path: Closest Neighbour

7. Choose the Depth tab and set the parameters as follows:

Clearance: 10 Retract: 5 Level: -4 Depth: -1

8. Choose the Step tab. Enter 3 in the Safe Distance edit box.

9. Choose the OK button; you are prompted to select the hole location. Snap to the points
created earlier. Right-click to finish the selection; the toolpath is generated.

The next step is to drill the holes of the actual size using the 5 mm diameter drilling tool.

10. Invoke the Drill tool from the Mill Tools toolbar; the Milling Cutter dialog box
is displayed. Choose Find; the Toolstore window is displayed. Choose the Drill
button at the bottom, select the Coromant 5mm tool, and choose Select.

11. Choose the More tab and select the Drill option from the Layer drop-down list.
Choose OK in the Milling Cutter dialog box.

12. Invoke the Hole tool from the Mill toolbar; the Hole Cycle dialog box is displayed.
In the General tab, set the parameters as follows:

Strategy: Drill Plunge Feed (mm/min): 1200 Speed (RPM): 2500
Optimise Path: Closest Neighbour

13. Choose the Depth tab and set the parameters as follows:

Clearance: 10 Retract: 5 Level: -5 Depth: -10

14. Choose the Step tab and set the parameters as follows:

Cut increment: 2.5 Safe Distance: 3

15. Choose the OK button; you are prompted to select the location for the holes. Snap to the
points created earlier. Right-click to finish the selection; the toolpath is generated, as
shown in Figure 6-39.

16. Invoke the Layers window. Right-click and choose the Show All option from the shortcut
menu. The model with all the toolpaths generated is shown in Figure 6-40.

Running the EdgeCAM Simulator
1. Choose the Simulate Machining button from the Main toolbar; the Simulator

window is displayed.
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2. Choose the Start button from the Main toolbar to begin the simulation.

3. After completing the simulation, choose the Return to EdgeCAM button in the
Main toolbar to return to the Manufacture mode. The model, after simulation,
is shown in Figure 6-41.

Saving the File
1. Choose File > Save from the menu bar.

2. Enter the name of the file as c06tut01 in the File name edit box and choose the Save
button. The file will be saved in \My Documents\EdgeCAM\c06 folder.

In this tutorial, you will generate the toolpath for the model shown in Figure 6-42. The
dimensions of the model are shown in Figure 6-43. The thickness of the component is 25 mm.

  (Expected time: 1.5 hrs)

Figure 6-41  Final model after simulation

Figure 6-39  Hole toolpath generated Figure 6-40  Model with all the toolpaths

Tutorial 2
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The following steps are required to complete this tutorial:

a. Start a new EdgeCAM file.
b. Open the sketch drawn in Exercise 2 of Chapter 4.
c. Create the stock.
d. Generate the toolpaths using the facemill, roughing, profiling, and hole cycles.
e. Run the EdgeCAM simulator.
f. Save the file.

Starting a New EdgeCAM Session
1. Start a new EdgeCAM environment. EdgeCAM starts in the Design mode in the XY

environment.

2. Open the sketch drawn in the Exercise 2 of Chapter 4. Make sure the sketch is on the top
plane.

Creating the Stock
To create the stock, you need to create a plane at the Z level. Next, offset the outermost
profile and create the stock.

1. Select Top from the Select Active CPL drop-down list in the Standard toolbar.

2. Enter 5 in the Select Z Level drop-down list in the Standard toolbar.

3. Right-click in the Layers window and choose the New option. Enter Offset as the new
name for the layer.

4. Invoke the Offset tool and offset the outer profile to a distance of 5 mm. Figure 6-44
shows the profile after offsetting.

Figure 6-43  Dimensions for Tutorial 2Figure 6-42  Model for Tutorial 2



Milling Cycles-I        6-37

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r .

 D
o

 n
o

t 
co

p
y

. 
D

o
 n

o
t 

co
p

y
. 

D
o

 n
o

t 
co

p
y

. 
D

o
 n

o
t 

co
p

y
. 

D
o

 n
o

t 
co

p
y .

 V. 
V

. 
V

. 
V

. 
V i

si
t 

w
w

w
is

it
 w

w
w

is
it

 w
w

w
is

it
 w

w
w

is
it

 w
w

w
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s

5. Choose Stock/Fixture from the Design toolbar; the Stock dialog box is displayed.

6. Clear the Automatic Stock check box. Select Profile from the Shape drop-down list.

7. Select the Stock option from the Type drop-down list.

8. Enter -35 in the Depth drop-down list and choose the OK button.

9. Select the offset profile in the counterclockwise direction close to the start point of each
entity and right-click; a wireframe stock will be created around the model. The isometric
view of the model after creating the stock, is shown in Figure 6-45.

Invoking the Manufacture Mode
1. Choose the Switch to Manufacture Mode button on the top right corner of the EdgeCAM

window; the Machining Sequence dialog box is displayed.

2. Enter the sequence name as c06tut02. Select Mill from the Discipline drop-down list.
Select fanuc3x.mcp from the Machine Tool drop-down list. From the Initial CPL
drop-down list, select the Top option. Clear the Machine Datum check box and choose
the OK button; the Manufacture mode is invoked.

Generating the Facemill Toolpath
The first operation in the machining sequence is to machine the extra material in the Z
direction using the Facemill cycle.

1. Choose Tooling > Milling Cutter from the menu bar; the Milling Cutter dialog box is
displayed. Select the End mill radio button from the Tool Type area and choose the
Find button; the Toolstore window is displayed. Select the SSM-ZX-4 Flute-25 tool and
choose the Select button. Choose the OK button from the Milling Cutter dialog box.

2. Choose Mill Cycles > Face Milling from the menu bar; the Face Milling dialog box is
displayed.

Figure 6-45  Isometric view of the profile
after creating the stock

Figure 6-44  Isometric view of the profile
after offsetting the outermost profile
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3. Set the following parameters in the General tab:

Mill Type: Optimised % Stepover: 65 Angle: 0
Step Direction: Left Stock Offset: 5 Feedrate (mm/min): 400
Plunge Feed (mm/min): 1200 Speed (RPM): 2500

4. Choose the Depth tab and set the following parameters:

Clearance: 10 Level: 5
Depth: 5 Cut Increment: 1

5. Choose the Lead tab and set the following parameters:

Percentage Feed: 100 Apply To: First And Last Cut
Equal Lead Moves: Select the check box Angle: 45 Lead Length: 5
Lead Radius: Clear the edit box.

6. Choose the Links tab and set the following parameters:

Short Link Distance: 5

Short Links Area
Type: Straight Percentage Feed: 100

Long Links Area
Type: Optimised Safe Distance: 5

7. Choose the OK button; you are prompted to select the closed profiles to machine.

8. Choose the down arrow on the right of the Tool Display button on the Display toolbar
and choose Hide from the flyout.

9. Invoke the Layers window. Select the Offset and Stock layers by holding the CTRL key
and right-click. Choose the Hide option to hide these two layers.

10. Orient the profile to the top view and select the outer profile of the model. Right-click to
end the selection. The resulting face mill toolpath is shown in Figure 6-46.

Generating the Profiling Toolpath
Next, you will generate the toolpath to remove the material outside the profile using the
Profiling tool.

1. Invoke the Layers window by choosing the Layers tab below the Sequence window.
Double-click on Yes next to SSM-ZX-4 Flute to hide the toolpath.

2. Right-click in the Layers window and choose the New option. Enter Profiling as the new
name for the layer.
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3. Invoke the Endmill tool from the Mill Tools toolbar; the Milling Cutter dialog box is
displayed with the End mill radio button selected in the Tool Type area. Choose the
Find button; the Toolstore window is displayed. Select the 12mm Endmill - long series
tool and choose the Select button.

4. Choose the More tab and select the Racing Green option from the Colour drop-down
list. Select the Profiling option from the Layers drop-down list. Choose the OK button.

5. Choose Profiling from the Mill toolbar; the Profiling dialog box is displayed.

6. In the General tab, set the parameters as follows:

Model Type: Wireframe Mill Type: Conventional
NC Output Smoothing: Line Arc Tolerance: 0.01
Feedrate (mm/min): 400 Plunge Feed (mm/min): 1200 Speed(RPM): 2500

7. Choose the Depth tab and set the parameters as follows:

Clearance: 10 Level: 0 Depth: 25 Cut Increment: 1

Select the Helical check box.

Finish At Area: Select the Clearance radio button

8. Choose the Control tab and set the parameters as follows:

Corners Area: Select the Round radio button in the Strategy area.

Boundary Control Area: Select the Tool Outside radio button in the Tool Control area.
Offset: 0

9. Choose the Start/End tab and set the parameters as follows:

Plunge Point: Automatic Retract Point: Automatic Default Side: Outside

Figure 6-46  Model after generating the facemill toolpath
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Start/End Point Preference Area
Select the Longest Side radio button from the Type area
Longest Side: Straight Proportional Distance: 0.5
Clear the Start and the End edit boxes.

10. Choose the Lead tab and set the parameters as follows:

Type Area: Select the Tangential radio button.
Percentage Feed: 100 Equal Lead Moves: Select the check box

Lead In Area
Angle: 45 Length: 0 Lead Radius: 4

11. Choose the Links tab and set the parameters as follows:

Short Link Distance: 5

Short Links Area
Type: Straight Percentage Feed: 100

Long Links Area
Type: Optimised Safe Distance: 5

12. Choose OK; you will be prompted to select the profile. Set the view to the top view and
select the outer profile of the model and right-click.

13. You will notice an arrow pointing outside the profile. Right-click to accept that line to
locate the start point of the cut.

14. You are prompted to select the containment boundary. Invoke the Layers window and
double-click on No next to the Offset layer; the offset profile will be visible.

15. Select the outermost profile as the containment boundary and right-click to end the
selection.

16. EdgeCAM starts generating the toolpath and displays the progress bar at the bottom of
the EdgeCAM screen. Invoke the Layers window and double-click on No next to the
Stock layer; the Stock is displayed. The isometric view of the model, after generating the
profiling toolpath, is shown in Figure 6-47.

17. Invoke the Sequence window by choosing the Sequence tab. Select the Profiling node
and press F2. Enter the name as Outer Profile and click in the drawing area.

Generating the Roughing Toolpath
In this section, you will create a new layer in the Layers window and hide the previous
toolpath. Next, you will generate the toolpath for machining the pockets.
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1. Invoke the Layers window by choosing the Layers tab below the Sequence window.
Double-click on Yes next to Profiling to hide the toolpath.

2. Create a new layer with the name Pocket.

3. Choose the Endmill button from the Mill Tools toolbar; the Milling Cutter dialog box
is displayed with the End mill radio button selected in the Tool Type area. Choose the
Find button. In the Toolstore window, select the 10mm Endmill - short series tool and
choose the Select button.

4. Choose the More tab and select the Pocket option from the Layer drop-down list. Choose
the OK button.

5. Choose Mill Cycles > Roughing from the menu bar; the Roughing dialog box is
displayed.

6. In the General tab, set the parameters as follows:

Model type: Wireframe Mill Type: Optimised Strategy: Concentric
NC Output Smoothing: Line Arc
% Stepover: 70 Close Open Pockets: Select the check box
Stock Type: None
Feedrate (mm/min): 400 Plunge Feed (mm/min): 1200 Speed (RPM): 2500

7. Choose the Depth tab and set the parameters as follows:

Clearance: 10 Level: 0
Depth: 25 Cut Increment: 1

8. Choose the Approach tab and set the parameters as follows:

Approach Type: Ramp Ramp Angle: 45 Percentage Feed: 100
Link Method: Optimised Safe Distance: 5
Cut Increment Stand Off: 1 XY Stand Off: 1

Figure 6-47  Model after generating the profiling toolpath
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9. Choose the OK button; you are prompted to select the profile to be machined. Select
the 60 mm diameter circle and the slot profile of the model from the drawing area and
then right-click; you are prompted to select the containment boundary.

10. Select the offset profile as the containment boundary similar to the way you selected for
the Profiling cycle. Right-click to end the selection; the toolpath is generated. The
isometric view of the model, after generating the roughing toolpath, is shown in
Figure 6-48.

 11. Select the Roughing node from the Sequence window and press F2. Enter the name
Pocket and click in the graphics area.

Generating the Hole Toolpath
In this section, you will create a new layer in the Layers window and hide the previous
toolpath. The Hole toolpath will be generated in two steps. In the first step, the centre
drill will be used to mark the hole locations. Then, the drilling tool of the size of the
holes will be used to drill the final holes.

1. Invoke the Layers window by choosing the Layers tab below the Sequence window.
Double-click on Yes next to Pocket to hide the toolpath.

2. Create a new layer with the name Drill.

3. Invoke the Drill tool from the Mill Tools toolbar; the Milling Cutter dialog box
is displayed with the Drill radio button selected from the Tool Type area. Choose
Find; the Toolstore window is displayed. Choose the Centre Drill button at the
bottom and select the 3mm x 60 Centredrill - 13A F30M tool. Choose the Select
button to return to the previous dialog box.

4. Enter 3 in the Diameter edit box. Choose the More tab. Select Royal Blue from the
Colour drop-down list and the Drill option from the Layer drop-down list. Choose OK.

5. Choose the Hole button in the Mill toolbar; the Hole Cycle dialog box is
displayed.

Figure 6-48  Profile with the roughing toolpath generated
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6. In the General tab, set the parameters as follows:

Strategy: Drill Plunge Feed (mm/min): 1200 Speed (RPM): 2500
Optimise Path: Closest Neighbour

7. Choose the Depth tab and set the parameters as follows:

Clearance: 10 Retract: 5 Level: 0 Depth: -2

8. Choose the Step tab. Enter 3 in the Safe Distance edit box.

9. Choose the OK button; you are prompted to select the hole locations. Snap to the centre
point of the 20 mm diameter circles. Right-click to finish the selection; the toolpath is
generated.

The next step is to drill the holes of the actual size using the 20 mm diameter drilling
tool.

10. Invoke the Drill tool from the Mill Tools toolbar; the Milling Cutter dialog box
is displayed. Choose Find; the Toolstore window is displayed. Choose the Drill
button at the bottom and select the Coromant 20mm tool. Choose the Select
button.

11. Choose the More tab and select the Drill option from the Layer drop-down list. Choose
OK in the Milling Cutter dialog box.

12. Invoke the Hole tool from the Mill toolbar; the Hole Cycle dialog box is displayed.
In the General tab, set the parameters as follows:

Strategy: Drill Plunge Feed (mm/min): 1200 Speed (RPM): 2500
Optimise Path: Closest Neighbour

13. Choose the Depth tab and set the parameters as follows:

Clearance: 10 Retract: 5 Level: 0 Depth: -25

14. Choose the Step tab and set the parameters as follows:

Cut Increment: 2.5 Safe Distance: 3

15. Choose the OK button; you are prompted to select the locations for the holes. Snap to
the same points selected earlier. Right-click to finish the selection; the toolpath is
generated, as shown in Figure 6-49.

16. Invoke the Layers window. Right-click and choose the Show All option from the shortcut
menu. The model with the toolpaths generated is shown in Figure 6-50.
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Running the EdgeCAM Simulator
1. Choose the Simulate Machining button in the Main toolbar. If the Select

Sequence dialog box is displayed, select the sequence and choose the Add button.
Next, choose OK; the Simulator window is displayed.

2. Choose the Start button from the Main toolbar to begin the simulation.

3. After completing the simulation, choose the Return to EdgeCAM button from
the Main toolbar to return to the Manufacture mode. The model, after simulation,
is shown in Figure 6-51.

Saving the File
1. Choose File > Save as from the menu bar.

2. Enter the name of the file as c06tut02 in the File name edit box and choose the Save
button. The file will be saved in the \My Documents\EdgeCAM\c06 folder.

Figure 6-49  Hole toolpath generated Figure 6-50  Model with all the toolpaths

Figure 6-51 Model after simulation



Milling Cycles-I        6-45

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r .

 D
o

 n
o

t 
co

p
y

. 
D

o
 n

o
t 

co
p

y
. 

D
o

 n
o

t 
co

p
y

. 
D

o
 n

o
t 

co
p

y
. 

D
o

 n
o

t 
co

p
y .

 V. 
V

. 
V

. 
V

. 
V i

si
t 

w
w

w
is

it
 w

w
w

is
it

 w
w

w
is

it
 w

w
w

is
it

 w
w

w
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s

In this tutorial, you will generate the toolpath for the model shown in Figure 6-52. The
dimensions of the model are shown in Figure 6-53.      (Expected time: 2 hrs)

Tutorial 3

Figure 6-52 Model for Tutorial 3

Figure 6-53  Dimensions for Tutorial 3
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The following steps are required to complete this tutorial:

a. Start a new EdgeCAM file.
b. Draw the sketch on the top plane.
c. Create the stock.
d. Generate the toolpaths using the facemill, roughing, profiling, and hole cycles.
e. Run the EdgeCAM simulator.
f. Save the file.

Starting a File
1. Start a new file. EdgeCAM starts in the Design mode in the XY environment.

2. Draw the profile of the model in the Top plane, as shown in Figure 6-54. You do not need
to specify the depth. Draw horizontal lines from the centre of the slot. Make sure it passes
from one end to the other end of the slot. Refer to Figure 6-53.

Creating the Stock
You need to create a stock such that 5 mm of material is in excess to the actual size.

1. Choose the Stock/Fixture button from the Design toolbar; the Stock dialog box
is displayed.  Select the Automatic Stock check box and select the Box option
from the Shape drop-down list.

2. Enter 5 as the value in the X Min and X Max edit boxes, respectively.

3. Enter 5 as the value in the Y Min and Y Max edit boxes, respectively.

4. Enter 65 and 5 as the values in the Z Min and Z Max edit boxes, respectively.

5. Choose OK; a wireframe stock will be created around the model. The isometric view of
the model and the stock created is shown in Figure 6-55.

Invoking the Manufacture Mode
1. Choose the Switch to Manufacture Mode button on the top right corner of the EdgeCAM

window; the Machining Sequence dialog box is displayed.

Figure 6-54  Profile created in the top plane
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2. Enter the sequence name as c06tut03. Select Mill in the Discipline drop-down list. Select
fanuc3x.mcp in the Machine Tool drop-down list. From the Initial CPL drop-down list,
select the Top option. Clear the Machine Datum check box. Select the Absolute radio
button and choose the OK button; the Manufacture mode is invoked.

Generating the Facemill Toolpath
The first operation in the machining sequence is to machine the extra material in the Z
direction using the Facemill cycle.

1. Choose Tooling > Milling Cutter in the menu bar; the Milling Cutter dialog box is
displayed. Select the End mill radio button from the Tool Type area and choose the
Find button; the Toolstore window is displayed. Select the 80 mm x45 approach Facemill
- HTi10 tool and choose the Select button. Choose the OK button in the Milling Cutter
dialog box.

2. Choose Mill Cycles > Face Milling in the menu bar; the Face Milling dialog box is
displayed.

3. Set the following parameters in the General tab:

Mill Type: Optimised %Stepover: 65 Angle: 0
Step Direction: Left Stock Offset: 0 Feedrate (mm/min): 400
Plunge Feed (mm/min): 1200 Speed (RPM): 2500

4. Choose the Depth tab and set the following parameters:

Clearance: 15 Level: 5
Depth: 5 Cut Increment: 1

Figure 6-55  Isometric view of the profile and the stock
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5. Choose the Lead tab and set the following parameters:

Percentage Feed: 100 Apply To: Select the First And Last Cut option
Equal Lead Moves: Select the check box Angle: 45 Lead Length: 5
Lead Radius: 0

6. Choose the Links tab and set the following parameters:

Short Link Distance: 5

Short Links Area
Type: Straight Percentage Feed: 100

Long Links Area
Type: Optimised Safe Distance: 5

7. Choose the OK button; you are prompted to select the closed profiles to machine.

8. Choose the down arrow on the right of the Tool Display button on the Display toolbar
and choose Hide from the flyout to hide the tool, if it is displayed.

9. Invoke the Layer window, select the Stock layer and right-click. Choose the Hide option
to hide the layer.

10. Select the outer profile. Right-click to end the selection. The resulting facemill toolpath
is shown in Figure 6-56.

Generating the Profiling Toolpath
Next, you will generate the toolpath to remove the material outside the profile using the
Profiling tool.

Figure 6-56  The facemill toolpath generated
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1. Invoke the Layers window by choosing the Layers tab below the Sequence window.
Double-click on Yes next to 80 x45 to hide the toolpath.

2. Right-click in the Layers window and choose the New option. Enter Profiling as the new
name for the layer.

3. Invoke the Endmill tool from the Mill Tools toolbar; the Milling Cutter dialog box is
displayed with the End mill radio button selected in the Tool Type area. Choose the
Find button; the Toolstore window is displayed. Select the 12mm Endmill - long series
tool and choose the Select button.

4. Choose the More tab and enter 63 in the Flute Length edit box. Select the Profiling
option from the Layer drop-down list. Choose the OK button.

5. Choose Profiling in the Mill toolbar; the Profiling dialog box is displayed.

6. In the General tab, set the parameters as follows:

Model Type: Wireframe Mill Type: Optimised NC Output Smoothing: Line Arc
Tolerance: 0.01
Feedrate (mm/min): 400 Plunge Feed (mm/min): 1200 Speed (RPM): 2500

7. Choose the Depth tab and set the parameters as follows:

Clearance: 10 Level: 0 Depth: 60 Cut Increment: 2

Clear the Helical check box.
Finish At Area: Select the Clearance radio button.

8. Choose the Control tab and set the parameters as follows:

Corners Area: Select the Sharp radio button from the Strategy area.

Boundary Control Area: Select the Tool Centre radio button from the Tool Control
area.
Offset: 0

9. Choose the Start/End tab and set the parameters as follows:

Plunge Point: Automatic Retract Point: Automatic
Default Side: Outside

Start/End Point Preference Area
Select the Longest Side radio button from the Type area
Longest Side: Straight Proportional Distance: 0.5

10. Choose the Lead tab and set the parameters as given next.
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Type Area: Select the Tangential radio button
Percentage Feed: 100 Equal Lead Moves: Select the check box

Lead In Area
Angle: 45 LeadLength: 5

11. Choose the Links tab and set the parameters as follows:

Short Link Distance: 5

Short Links Area
Type: Straight Percentage Feed: 100

Long Links Area
Type: Optimised Safe Distance: 5

12. Choose OK; you will be prompted to select the profile. Set the view to the top and select
the outer profile of the model and right-click.

13. You will notice an arrow pointing outside the profile. Right-click to accept that line to
locate the start point of the cut; you are prompted to select the containment boundary.

14. Right-click to accept the default condition.

15. EdgeCAM displays the progress bar at the bottom and starts generating the toolpath, as
shown in Figure 6-57.

Figure 6-57  Profiling toolpath generated



Milling Cycles-I        6-51

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r .

 D
o

 n
o

t 
co

p
y

. 
D

o
 n

o
t 

co
p

y
. 

D
o

 n
o

t 
co

p
y

. 
D

o
 n

o
t 

co
p

y
. 

D
o

 n
o

t 
co

p
y .

 V. 
V

. 
V

. 
V

. 
V i

si
t 

w
w

w
is

it
 w

w
w

is
it

 w
w

w
is

it
 w

w
w

is
it

 w
w

w
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s

Generating the Roughing Toolpath
In this section, you will create a new layer in the Layers window and hide the previous
toolpath. Next, you will generate the toolpath for machining the pockets.

1. Invoke the Layers window by choosing the Layers tab below the Sequence window.
Double-click on Yes next to Profiling to hide the toolpath.

2. Create a new layer with the name Pocket.

3. Choose the Endmill button from the Mill Tools toolbar; the Milling Cutter dialog box
is displayed with the End mill radio button selected in the Tool Type area. Choose the
Find button. In the Toolstore window, select the 10mm Endmill - short series tool, and
choose the Select button.

4. Choose the More tab, enter 35 in the Flute Length edit box, and select the Pocket
option from the Layer drop-down list. Choose the OK button.

5. Choose Mill Cycles > Roughing in the menu bar; the Roughing dialog box is
displayed.

6. In the General tab, set the parameters as follows:

Model type: Wireframe Mill Type: Optimised Strategy: Concentric
NC Output Smoothing: Line Arc
%Stepover: 70 High Speed Cornering: Select the check box
Cut by Region: Select the check box
Feedrate (mm/min): 400 Plunge Feed (mm/min): 1200 Speed (RPM): 2500

7. Choose the Depth tab and set the parameters as follows:

Clearance: 10 Level: 0
Depth: 30 Cut Increment: 2

8. Choose the Approach tab and set the parameters as follows:

Approach Type: Ramp Ramp Angle: 45
Link Method: Optimised Safe Distance: 5
Optimsed: Select the radio button
Cut Increment Stand Off: 1 XY Stand Off: 1

9. Choose the OK button; you are prompted to select the profile to be machined. Select the
two rectangular profiles and their corner fillets.

10. Right-click to proceed; you are prompted to select the containment boundary. Right-click
to accept the default stock; the toolpath is generated. The top view of the model, after
creating the roughing toolpath, is shown in Figure 6-58.
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Next, you create the toolpath for the slot profile.

11. Choose the Endmill button from the Mill Tools toolbar; the Milling Cutter dialog box
is displayed with the End mill radio button selected in the Tool Type area. Choose the
Find button. In the Toolstore window, select the SSM- ZX-4 Flute - 5 tool and choose
Select.

12. Choose the More tab, enter 35 in the Flute Length edit box, and select the Pocket
option from the Layer drop-down list. Choose the OK button.

13. Choose Mill Cycles > Roughing from the menu bar; the Roughing dialog box is
displayed.  Set the parameters as you did for the previous profile and choose OK.

14. Select the slot profile and the arcs adjoining to it for the profiles to be machined and the
containment boundary as you did earlier.

Creating the Slot Toolpath
1. Invoke the Layers window and double-click Yes next to Pocket to hide the toolpath.

2. Create a new layer in the Layers window, as described earlier. Name the new layer as
Slot.

3. Invoke the T-Slot tool in the Mill Tools toolbar; the Milling Cutter dialog box is
displayed with the T-Slot radio button selected in the Tool Type area. Choose
the Find button; the Toolstore window is displayed. Select the 25.5mm x 6
thick T-Slot-13A F30M tool and choose the Select button.

4. Enter 10 in the Diameter edit box. Choose the More tab, enter 10 in the Flute Length
edit box and select the Slot option from the Layers drop-down list. Choose the OK
button in the Milling Cutter dialog box.

5. Invoke the Slot tool from the Mill toolbar; the Slot Milling dialog box is displayed.

6. In the General tab, set the parameters as follows:

Strategy: 2D Link Control: Shortest
Feedrate (mm/min): 300 Plunge Feed (mm/min): 1200 Speed(RPM): 2500

Figure 6-58  Roughing toolpath generated
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7. Choose the Depth tab and set the parameters as follows:

Clearance: 10 Retract: 5 Level: -5 Depth: -5
Finish At Area: Select the Clearance radio button

8. Choose the OK button; you will be prompted to select the profile. Select the three
horizontal lines representing the slot and right-click; arrows will be displayed at the
endpoints of all the three lines. They indicate the start point of the operation.

9. Right-click to accept the start point.

10. Three stars are displayed at the other end of the lines. They indicate the endpoint of the
operation. Right-click to accept it; the slot toolpath is generated. The front view of the
model, after generating the slot toolpath, is shown in Figure 6-59.

Generating the Hole Toolpath
In this section, you will create a new layer in the Layers window and hide the previous
toolpath. The Hole toolpath will be generated in two steps. In the first step, the centre
drill will be used to mark the hole locations. Then, the drilling tool of the size of the
holes will be used to drill the final holes.

1. Invoke the Layers window and double-click Yes next to Slot to hide the toolpath.

2. Create a new layer with the name Drill.

3. Invoke the Drill tool from the Mill Tools toolbar. The Milling Cutter dialog box
is displayed with the Drill radio button selected in the Tool Type area. Choose
Find; the Toolstore window is displayed. Choose the Centre Drill button at the
bottom and select the 3mm x 60 Centredrill - 13A F30M tool. Choose the Select
button to return to the previous dialog box.

4. Enter 3 in the Diameter edit box. Choose the More tab, enter 60 in the Flute Length
edit box, select the Drill option in the Layers drop-down list, and choose OK.

5. Choose the Hole button in the Mill toolbar; the Hole Cycle dialog box is
displayed.

6. In the General tab, set the parameters as follows:

Strategy: Drill Plunge Feed (mm/min): 1200 Speed (RPM): 2500
Optimise Path: Closest Neighbour

Figure 6-59  Front view of the profile with the slot toolpath generated
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7. Choose the Depth tab and set the parameters as follows:

Clearance: 10 Retract: 5 Level: 0 Depth: -2

8. Choose the Step tab. Enter 3 in the Safe Distance edit box.

9. Choose the OK button; you are prompted to select the hole locations. Snap to the centre
of all the circles. Right-click to finish the selection; the toolpath is generated.

The next step is to drill the holes of the drill tool of actual size.

10. Invoke the Drill tool from the Mill Tools toolbar; the Milling Cutter dialog box
is displayed. Choose Find; the Toolstore window is displayed. Choose the Drill
button at the bottom, select the Coromant 6mm tool, and choose the Select button.

11. Choose the More tab, enter 60 in the Flute Length edit box and select the Drill option
from the Layers drop-down list. Choose OK in the Milling Cutter dialog box.

12. Invoke the Hole tool from the Mill toolbar; the Hole Cycle dialog box is displayed.
In the General tab, set the parameters as follows:

Strategy: Drill Plunge Feed (mm/min): 1200 Speed (RPM): 2500
Optimise Path: Closest Neighbour

13. Choose the Depth tab and set the parameters as follows:

Clearance: 10 Retract: 2 Level: -30 Depth: -30

14. Choose the Step tab and set the parameters as follows:

Cut Increment: 2.5 Safe Distance: 3

15. Choose the OK button; you are prompted to select the locations for the holes. Snap to
the centre of the circles inside the slot profiles. Right-click to finish the selection; the
toolpath is generated.

16. Next, select Coromant 15mm and Coromant 20mm cutting tool to create the drill toolpath
for the holes in the rectangular profile. The parameters and the procedure to create the
toolpath are the same as you used for the previous hole cycle.

17. Invoke the Layers windowand right-click; the shortcut menu is displayed. Choose the
Show All option from the shortcut menu.

Running the EdgeCAM Simulator
1. Choose the Simulate Machining button from the Main toolbar. If the Select

Sequence dialog box is displayed, select the sequence and choose the Add button.
Next, choose OK; the Simulator window is displayed.
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2. Choose the Start button in the Main toolbar to begin the simulation.

3. After completing the simulation, choose the Return to EdgeCAM button from
the Main toolbar to return to the Manufacture mode. The model, after simulation,
is shown in Figure 6-60.

Saving the File
1. Choose File > Save from the menu bar.

2. Enter the name of the file as c06tut03 in the File name edit box and choose the Save
button. The file will be saved in \My Documents\EdgeCAM\c06 folder.

Answer the following questions and then compare them with the answres given at the end
of this chapter:

1. The Initial CPL parameter defines the orientation of the cutting tool. (T/F)

2. In a machining cycle, if the Level parameter is set to zero, the cut increments will be
calculated from the initial CPL. (T/F)

3. When the Optimised option is specified for the Long Links parameter, the tool retracts
up to the clearance plane after each pass. (T/F)

4. The bounding entities are used to restrict the toolpath to a particular area of the surface
to be machined. (T/F)

Figure 6-60  Model after simulation

Self-Evaluation Test
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5. The __________ button is used to switch to the Manufacture mode.

6. The __________ tool from the Solids menu is used to create geometric elements by
extracting the edges of a solid model.

7. The format of the default sequence names, allocated by EdgeCAM, when the sequence
name is not specified is __________.

8. In the Profiling cycle, the __________ option of the cutter radius compensation is used
to calculate the toolpath according to the periphery of the cutter.

9. The __________ option is used to avoid the clamps and fixtures while generating the
toolpath.

10. The Digitise option for creating a stock or a fixture enables you to extract the stock or
fixture geometry from the imported models. (T/F)

Answer the following questions:

1. The peck drilling strategy is used when the hole depth is more than three times of the
tools diameter. (T/F)

2. The None options should be selected for the Level and Depth parameters, when selecting
solids for generating the toolpaths. (T/F)

3. The parameters in the Contouring tab are used to generate toolpaths for machining the
drafted filleted pockets in the 2D wireframe geometry. (T/F)

4. Which of the following parameters, if specified, removes the material at a particular level
that cannot be removed in a single tool pass in the Profiling cycle?

(a) Offset (b) Minimum Radius
(c) Multiple Passes (d) Cut Increment

5. Which of the following hole making strategies is not available in the Hole mill cycle?

(a) Counterbore (b) Ream
(c) Bore (d) Drill

6. __________ can be defined as the nonmachining moves before and after the cut.

7. In the Roughing dialog box, select the __________ check box to remove the material left
by the previous roughing cycle.

Review Questions
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8. If you select the Helical check box in the Profiling dialog box, the tool moves in continuous
pass without going to retract plane. (T/F)

9. __________ cycle is used for engraving purposes.

10. To invoke the dialog box for editing a machining cycle, double-click on the particular
toolpath in the drawing area. (T/F)

In this exercise, you will generate the machining toolpaths for the model shown in Figure 6-61.
The dimensions of the model are shown in Figure 6-62.       (Expected Time: 1 hr)

Exercise 1

Exercises

Figure 6-61  Model for Exercise 1

Figure 6-62  Dimensions for Exercise 1
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Exercise 2
In this exercise, you will generate the machining toolpaths for the model shown in Figure 6-63.
The dimensions of the model are shown in Figure 6-64.     (Expected Time: 2 hrs)

Figure 6-63  Model for Exercise 2

Figure 6-64  Dimensions for Exercise 2
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Exercise 3
In this exercise, you will generate the machining toolpaths for the model shown in Figure 6-65.
The dimensions of the model are shown in Figure 6-66.     (Expected Time: 2 hrs)

Figure 6-65  Model for Exercise 3

Figure 6-66  Dimensions for Exercise 3
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Exercise 4
In this exercise, you will generate the machining toolpaths for the model shown in Figure 6-67.
The dimensions of the model are shown in Figure 6-68.      (Expected Time: 2 hrs)

Figure 6-67  Model for Exercise 4

Figure 6-68  Dimensions for Exercise 4
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Exercise 5
In this exercise, you will generate the machining toolpaths for the model shown in Figure 6-69.
The dimensions of the model are shown in Figure 6-70.                  (Expected Time: 2 hrs)

Figure 6-70  Dimensions for Exercise 5

Figure 6-69   Model for Exercise 5
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Answers to Self-Evaluation Test
1. T, 2. T, 3. F, 4. T, 5. Switch to Manufacture Mode, 6. Geometry, 7. Sequence 1, 8. Geometry,
9. Use Check Surface, 10. F


