
Chapter 13

Surface Evaluation 
and Painting

After completing this chapter, you will be able to:
• Evaluate curve and surface continuity.
• Create parting lines.
• Evaluate minimum and maximum curvatures.
• Check models for data transfer.
• Evaluate deviations.
• Create canvases and draw sketches in Alias Design.
• Understand layers and color schemes.
• Create, duplicate, and merge layers.
• Import and export images.

Learning Objectives
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 SURFACE EVALUATION
After creating the model, you need to evaluate different properties of the model such as con-
tinuity, curvature, contours, and so on. Surface evaluation helps you check all these properties 
to ensure that the model is fi t for data transfer. In other words, it helps you complete the data 
transfer. Surface evaluation is done by using different tools. These tools are discussed next.

 Evaluating the Continuity of Surfaces

You can evaluate the continuity of surfaces to check whether the specifi ed continuity 
has been achieved by the surfaces or not. You can specify the continuity by selecting 
the required radio button in the Surface Continuity Evaluation Options dialog 

box. To evaluate the continuity between surfaces, choose the Surface continuity button 
from the Evaluate tab in the Palette and select the common edge between two surfaces; the 
specifi ed continuity will be displayed, as shown in Figure 13-1. If the surface has achieved 
the specifi ed continuity, it will be displayed at the common edge between surfaces, refer to 
Figure 13-1. Otherwise, the deviation between the two surfaces will be displayed at the common 
edge, as shown in Figure 13-2. 

You can use different mouse buttons to view the deviation comb, adjust its sampling, or view 
information about the continuity such as gap between surfaces, radius of curvature, angle 
between normals, and so on. To view the deviation comb, click on the continuity with the 
middle mouse button; the deviation comb will be displayed, as shown in Figure 13-3. To hide 
the curvature comb, select it again using the middle mouse button. To scale the deviation 
comb, drag it using the left mouse button. To change the sampling density, drag the middle 
mouse button. Click on the continuity achieved using the right mouse button; the information 
window will be displayed, as shown in Figure 13-4.

To set the parameters of the Surface continuity tool, double-click on the Surface continuity 
button; the Surface Continuity Options dialog box will be displayed, as shown in 
Figure 13-5.

Palette: Evaluate >  Surface continuity

Figure 13-2  Deviations between surfacesFigure 13-1  Curvature continuities between 
surfaces
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The options in this dialog box are discussed next.

Find
The Find area is used to specify the type of continuity to be checked. The radio buttons in 
this area are discussed next.

Figure 13-4  Information window of the 
achieved continuity

Figure 13-3  Deviation comb on the edge

Figure 13-5  The  Surface Continuity Options dialog box
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Positional Continuity
Select this radio button to check the gap between the surfaces having positional continuity. 
The positional continuity is represented by the letter P.

Tangent Continuity
Select this radio button to check the gap between the surfaces having tangential continuity. 
The tangential continuity is represented by the letter T.

Curvature Continuity
This radio button is selected by default and is used to check the gap between the surfaces 
having curvature continuity. The curvature continuity is represented by the letter C. 
 

Check Spacing By
Continuity is evaluated at different points along the surface. The Check Spacing By area is 
used to specify how these points are spaced along the surface. The radio buttons in this area 
are discussed next.

Arc Length
Select this radio button to check or evaluate the continuity at equally spaced points along 
the surface. The spacing between these equally spaced points is specifi ed in the Distance 
Between Checks edit box. Figures 13-6 and 13-7 show the continuity evaluated with 
the lower and higher spacing values, respectively.

# Per Span
This radio button is selected by default and is used to check or evaluate the continuity in 
each span at certain points. These points are spaced based on the value specifi ed in the 
Curve Fit Checkpoints edit box of the Construction Options dialog box. This edit box 
will be displayed when you choose Tolerances > Fitting from the Construction Options 
dialog box.

Figure 13-7  Continuity evaluated with higher 
spacing value 2

Figure 13-6  Continuity evaluated with lower 
spacing value 0.7
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Locator Persistence
This check box is selected by default and is used to keep the locator persistent 
(permanent) when you exit the Surface continuity tool. The effect of the Locator Persistence 
check box can be viewed only when you select the surface edges explicitly. If you select whole 
model by dragging a pick box around it and then choose the Surface continuity tool, the 
locators will not be persistent.

Show Max. Labels
This check box is selected by default and is used to display the points that have maximum 
positional, tangential, or curvature deviation in the model, if any. These deviations occur due 
to the discontinuities (gaps or breaks) present at the common edge boundaries/edge of the 
surfaces.

Check Interior
Select this check box to evaluate and display the continuity along the multiple-knot 
isoparametric curves in the interior of the surfaces.

Show Edge Labels
Select this check box to display the symbols (P, C, and T) along the edges to indicate 
discontinuities along the edges. The blue symbols indicate the regions having minimum 
discontinuities; the red symbols indicate the regions with maximum discontinuities; and the 
green symbols indicate the regions with average discontinuities. If you evaluate surfaces with 
this check box cleared, only continuity indicator will be displayed on the edge. 

Show Comb
This check box will be available only when you select the Show Edge Labels check box. 
Select the Show Comb check box to display the comb lines for discontinuities such as gaps or 
tangent and curvature breaks. On selecting this check box, the Auto Scale check box will be 
displayed. By default, the Auto Scale check box is selected. As a result, the deviation comb is 
scaled automatically in proportion to the size of the object. 

Scale 
The Scale edit boxes will be displayed only when you clear the Auto Scale check box. These 
edit boxes are used to manually specify the scale of the deviation comb.

 Evaluating the Continuity of Curves

You can check the continuity between two curves by using the Curve continuity tool. To 
check the type of continuity between the curves, choose the Curve continuity button 
from the Evaluate tab in the Palette; you will be prompted to select the intersection 

point between the curves. Select the common endpoint of any two or more lines; AliasStudio 
will evaluate the continuity in the form of lines. If the distance between the endpoints of the 
two lines is greater than the value specifi ed in the Maximum Gap Distance edit box of the 
Continuity area in the Construction Options dialog box, a line will be drawn between the 
two endpoints with the distance displayed on it, as shown in Figure 13-8. If the curves are not 

Palette: Evaluate > Surface continuity >  Curve continuity
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tangent continuous, then tangent lines will be drawn for each curve and the angle between 
them will also be displayed, as shown in Figure 13-9. 

To set the parameters of the Curve continuity tool, double-click on the Curve continuity button; 
the Curve Continuity Options dialog box will be displayed, as shown in Figure 13-10. 

The options in this dialog box are discussed next.

Tangency Scale
This edit box is used to specify the scale of tangents of the curves. By default, 10 is displayed 
in this edit box. You can also specify this value by using the slider bar given on the right of 
this edit box. Alternatively, press the SHIFT key and drag the left mouse button to change 
the scale of tangents. 

Figure 13-9  Angle between the two tangents 
of curves

Figure 13-8  Distance between the endpoints

Figure 13-10  The  Curve Continuity Options dialog box
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Curvature Scale
This edit box is used to specify the scale of curvature lines of curves. By default, 5 is displayed 
in this edit box. You can also specify the scale of curvature lines by using the slider bar given 
on the right of this edit box. Alternatively, press the SHIFT key and then drag the right mouse 
button to change the curvature scale of the curves. Curvature lines are indicated by pink arrows 
pointing toward the intersection points of curves.

Note
The actual length of tangent/curvature lines is proportional to the product of the angle and the 
tangent/curvature scale values.

Locator Persistence
This check box is selected by default and enables the locator to be persistent (permanent). 
This implies that the locator will be displayed even after exiting the Curve continuity tool.

Simple Display
Select this check box to display a circle as the locator for continuity status. If curves are 
continuous, a green circle will be displayed as the locator for continuity. Otherwise, a red circle 
will be displayed as the locator for continuity. Figure 13-11 shows the tangent continuous curves 
with the default curve continuity locator and the simple display curve continuity locator.      

Display
This area is used to specify the type of continuity to be evaluated. The radio buttons in this 
area are discussed next.

Position
Select this radio button to evaluate positional continuity between curves. If positional 
continuity is not achieved, a line connecting endpoints will be displayed along with the 
distance mentioned on it.

Tangent
Select this radio button to evaluate tangential continuity between curves. If tangential 
continuity is not achieved, tangent lines will be drawn on the curves and the angle between 
them will also be mentioned.

Curvature
This radio button is selected by default and is used to evaluate curvature continuity between 
curves. If the tangent continuous curves are selected for evaluating curvature continuity, 
an extra locator with the deviation value will be displayed. This locator will be pointing 
toward the intersection point of curves, as shown in Figure 13-12. 
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 Creating the Parting Lines

While manufacturing a component using injection molding, sometimes the fi nal 
shape of the object is obstructed. This happens because of two reasons: under-cutting 
and out-of-draft. Under cutting occurs when the prepared cavity does not allow the 

core to be taken out. In other words, the cavity locks or retains the core inside it. Out-of-draft 
occurs when the angle on a part of surface is less than the draft angle. For these reasons, you 
may not be able to manufacture a component of required specifi cations by using injection 
molding. Therefore, you need to create parting lines on the boundaries of these undercut or 
out-of-draft components. To do so, choose the Parting line button from the Evaluate tab in 
the Palette; a manipulator will be displayed in the view windows and you will be prompted to 
select the surface(s) to evaluate. Select the surface(s) from the window and then choose the Go 
button that will be displayed at the lower right corner of the active window; parting lines will 
be created, as shown in Figure 13-13. You can change the pull direction of the mold by using 
the manipulator. On changing the pull direction of the manipulator, the curves-on-surface 
will get updated, as shown in Figure 13-14. 

Figure 13-12  Extra locator displayed at the 
intersection of curves

Figure 13-11  Default display and simple display 
locators displayed on tangent continuous curves

Palette: Evaluate >  Parting line

Figure 13-14  Updated parting linesFigure 13-13  Parting lines created on the 
revolved surface
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To set the parameters of the Parting line tool, double-click on the Parting line button; the 
Parting Line Control dialog box will be displayed, as shown in Figure 13-15.

The options in this dialog box are discussed next.

Direction Type
This area is used to specify the type of direction in which the mold is pulled away. The buttons 
in this area are discussed next.

ROTATION
This button is chosen by default and is used to specify the pull direction by specifying the 
angles along the three axes. 

VECTOR
Choose this button to specify the pull direction by selecting a vector from the window or 
by specifying the position of vector.

Pull Direction
These edit boxes are used to specify the 3D coordinates that defi ne the direction for pulling the 
object from its mold. These edit boxes are used to specify the directions in both the direction 
types, rotation and vector.

Draft Angle
This edit box is used to specify the draft angle for the object to be pulled out from the mold. You 
can also specify the draft angle by using the slider bar given on the right of this edit box.

Figure 13-15  The  Parting Line Control dialog box
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Subdivision
This edit box is used to increase or decrease the quality of the curve-on-surface that is projected 
on the surface. The range of the Subdivision edit box is 1 to 6. A higher value yields precise 
results, whereas the lower value yields poor results.

Vector/Plane
This fi eld is used to enter the name of the vector or plane to which the manipulator will be 
aligned for specifying the pull direction. You can also select the vector or plane with which 
the manipulator will be aligned. Even before selecting surfaces, you can select the vector or 
plane.

Visual
By default, this check box is cleared and is used to create a curve-on-surface as parting line. 
Select this check box to create polylines instead of curves-on-surface. These polylines can be 
used only for display purposes. You can pick these polylines, but you cannot create geometry 
on them.

Control Options
The options in this area have already been discussed in the earlier chapters.

 Evaluating the Min/Max Curvature

You can locate the points of maximum 
and minimum curvature on a surface 
or a group of surfaces. To do so, 

choose the Min/max curvature button from 
the Evaluate tab in the Palette; the points 
of maximum and minimum curvature will 
be displayed on the surface, as shown in 
Figure 13-16. Also, the Min/Max Curvature 
information box will be displayed, as shown 
in Figure 13-17. This information box 
displays the detailed information about 
curvature, radius, and type of surface.

To set the parameters of the Min/max 
curvature tool, double-click on the Min/max 
curvature button; the Min/Max Curvature 
Options dialog box will be displayed, as 
shown in Figure 13-18.

Palette: Evaluate >  Min/max curvature

Figure 13-16  Points of maximum and minimum 
curvature
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The options in the Min/Max Curvature Options dialog box are discussed next.

Mode
This area is used to specify whether curvatures will be evaluated on all objects or active objects 
only. The radio buttons in this area are discussed next.

Active
Select this radio button to evaluate the curvature on the picked/selected objects only. 

All
This radio button is selected by default and is used to evaluate the minimum and maximum 
curvatures of all surfaces.

Figure 13-17  The  Min/Max Curvature information box

Figure 13-18  The  Min/Max Curvature Options dialog box
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Curvature Type
This area is used to specify the type of curvature to be evaluated. The radio buttons in this 
area are discussed next.

Mean
Select this radio button to evaluate the mean of two principal curvatures at each point. 

Guassian
Select this radio button to evaluate the curvature that will be equal to the product of the 
two principal curvatures.

Principal Minimum
Select this radio button to evaluate minimum curvature (curvature on the smoothest 
curves on surface).  

Principal Maximum
This radio button is selected by default and is used to evaluate maximum curvature (cur-
vature on the steepest curves on surface).

 Evaluating Mass Properties

In Alias Design, you can evaluate mass properties such as volume, surface area, and 
centroid of object (surfaces, shells, or meshes) and then display their values. To 
evaluate the mass properties of an object, select the object and then choose the Mass 

Properties button from the Evaluate tab in the Palette; the Mass Properties Editor will be 
displayed. This editor displays the mass properties of the object. Figure 13-19 shows the Mass 
Properties Editor of a sphere located at the origin. Choose the Extract To File button given 
at the bottom of the Mass Properties Editor to save these mass properties in a text fi le.

Palette: Evaluate >  Mass Properties

Figure 13-19  The Mass Properties Editor
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To set the parameters of the Mass Properties tool, double-click on the Mass Properties button; 
the Mass Properties Options dialog box will be displayed, as shown in Figure 13-20.

The options in this dialog box are discussed next.

Surface Area
This check box is selected by default and is used to display the surface area of an object in 
the Mass Properties Editor. If you clear this check box, the surface area of the object will not 
be displayed.
 

Volume
This check box is selected by default and is used to display the volume of the object in the 
Mass Properties Editor. If you clear this check box, the volume of the object will not be 
displayed.

Centroid
This check box is selected by default and is used to display the centroid of the object in the 
Mass Properties Editor. If you clear this check box, the centroid of the object will not be 
displayed.

Type
The Type area is used to describe how the selected surfaces or faces will defi ne the object. 
The radio buttons in this area are discussed next.

Solid
This radio button is selected by default and assumes the picked objects as closed boundary 
or solid objects. In other words, the mass properties will be evaluated for solid object.

Figure 13-20  The Mass Properties Options dialog box



13-14                                                          Learning Autodesk Alias Design 2010

Shell Interior
Select this radio button to represent the picked object as the thin shell object. The surface 
that you select will act as the exterior of the shell enclosing the interior hollow space. The 
thickness of the shell can be specifi ed in the Thickness edit box of the Mass Properties 
Options dialog box. 

Tolerance
This edit box is used to specify the maximum distance allowed between the adjacent surfaces 
to form a closed volume or boundary. By default, this edit box displays 0.01. You can also 
change this value by using the slider given on the right of this edit box.

Thickness
The Thickness edit box will be available only when you select the Shell Interior radio button. 
This edit box is used to specify the thickness of shell. As a result, the surface area calculated 
will be the sum of the interior and exterior surface areas of the shell and the volume calculated 
will be equal to the volume of the shell, instead of the space enclosed by the shell. By default, 
the value in this edit box is 5.0 and you can change this value by using the slider given on 
the right of this edit box.

Note
If the volume displayed in the Mass Properties Editor is negative, the normals of the surfaces 
may be pointing inward. In such a case, you need to reverse the orientation of these surfaces by 
using the Reverse surface orientation tool from the Surface Edit tab of the Palette. 

Also, the surface whose mass properties need to be calculated must form a closed volume or match 
the tolerance values set in the Mass Properties Options dialog box. 

 Checking Models for Data Transfer

While importing or exporting models, there may be some data loss. This data loss 
occurs due to the problems such as discontinuity, multiple-knots, irrational geometries, 
and so on. These problems prevent the transfer of data from/to other software packages. 

To check the model to address these problems, double-click on the Check model button of 
the Evaluate tab in the Palette; the Check Model Options dialog box will be displayed. Set 
the options for checking the model and then choose the Check button given at the bottom 
of this dialog box; the Check Model Results report window will be displayed, as shown in 
Figure 13-21.

In this report window, the fi rst column shows the names of objects, and the rest of the columns 
show the problems to be checked in the model. The display of columns depends on the options 
set in the Check Model Options dialog box. If the model fails any given check, a cross mark 
enclosed in a red circle will be displayed in the corresponding columns of the report window. 
To highlight a particular checked surface or curve, select it from any of the columns in the 
Check Model Results report window.

Palette: Evaluate >  Check model
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To set the parameters of the Check model tool, double-click on the Check model button; the 
Check Model Options dialog box will be displayed, as shown in Figure 13-22. The model will 
be checked based on the parameters set in this dialog box.

Figure 13-21  The Check Model Results report window

Figure 13-22  The  Check Model Options dialog box
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The options in this dialog box are discussed next.

Check
This area is used to specify the type of geometry to be checked. The specifi ed geometry is 
displayed in the Name column of the Check Model Results report window. The radio buttons 
in this area are discussed next.

Surfaces
This radio button is selected by default and is used to check surfaces for the specifi ed 
parameters. 

Curves
Select this radio button to check curves for the specifi ed parameters. 

Both
Select this radio button to check both surfaces and curves for the specifi ed parameters. 

Objects
This area is used to specify the type of object to be checked. The specifi ed objects are displayed 
in the Name column of the Check Model Results report window. The radio buttons in this 
area are discussed next.

Visible
This radio button is selected by default and is used to check objects for the specifi ed 
parameters visible in the window.

Active
Select this radio button to check the active objects for the specifi ed parameters. 

All
Select this radio button to check all components of the model for the specified 
parameters. 

Report
This area is used to specify the type of report to be checked and displayed. The radio buttons 
in this area are discussed next.

Errors
This radio button is selected by default and is used to display only those entities that 
have errors.

All
When you select this radio button and then choose the Check button, all entities will be 
checked for errors and a report will be displayed. The report shows all entities regardless 
of whether they possess any error or not.
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Use Construction Preset
This area is used to specify the construction preset to be used while checking the model. The 
construction presets are signifi cant for specifying the tolerances, units, and so on. By default, 
the Use Current Tolerances button is chosen in this area. As a result, the current settings of 
the Construction Options window will be used for checking the model. Press and hold the left 
mouse button on the Use Current Tolerances button; a fl yout will be displayed. This fl yout will 
display all other presets available in the Construction Options window. Choose the required 
construction preset from this fl yout to check the model. You can use presets that corresponds 
to the software such as Inventor, CATIA, Pro/ENGINEER, and so on.

Check Model Parameters
This area is used to specify the model parameters to be checked. The model parameters are 
displayed as column headings in the Check Model Results report window. The options in 
this area are discussed next.

Rationals
Select this check box to check any rational geometry present in the model.

Periodics
Select this check box to check any periodic or closed geometry present in the model.

Maximum Spans
Select this check box to check if the model has spans higher than the value specifi ed in 
the edit box given on the right of this check box. By default, 200 is displayed in this edit 
box, which means Alias Design checks the objects that have number of spans greater 
than 200. You can specify new degree in this edit box after activating it by selecting the 
Maximum Spans check box.

Multiple Trim Regions
After trimming a surface, the surface may appear as a separated surface. This is not 
desirable in other CAD software packages and may confuse the user. Select the Multiple 
Trim Regions  check box to check the model for these multiple trim regions. You can 
delete these undesirable surfaces.

Multiple Knots
This check box is selected by default and is used to check if there are multiple knots in 
the model. Multiple knots cause problems such as sharp corners, discontinuities, and so 
on in objects.

Internal Tangent Discontinuity
This check box is selected by default and is used to check the model for internal tangent 
discontinuities that occur because of multiple-knots present in the object.

Non-planar curves
 This check box will be available only when you select the Curves or Both radio button 

from the Check area. Select this check box to check the model for non-planar curves.
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Product Data Quality Recommended Checks 
This area is used to specify the ckecks recommended for improving the quality of the product.  
model parameters to be performed. The model parameters are displayed as column headings 
in the Check Model Results report window. The options in this area are discussed next.

Duplicate Geometry
This area is used to check objects for duplication. The different radio buttons in this area 
are discussed next.

Off
Select this radio button to skip the checking of the model for duplicate geometry.

Copies
This radio button is selected by default and is used to check model for duplicate 
copies of curves or surfaces. If the model contains the duplicate copy of an object and 
you have selected the All radio button in the Report area, the original object will be 
displayed with the comment ‘Original’ in the corresponding row and the duplicate 
copy will be represented by a red circle with the cross mark inside it.

Duplicates Within Tolerance
Select this radio button to check the model for duplicate copies or the embedded 
objects that lie within the specifi ed tolerance. This tolerance is specifi ed in the 
Duplicate Tolerance edit box. 

Maximum Degree
Select this check box to check whether the object to be checked has degree higher than 
the degree specifi ed in the edit box given on the right of this check box. By default, 7 is 
displayed in this edit box. As a result, Alias Design will check the objects having a degree 
higher than 7. You can change the degree in this edit box after activating it by selecting 
the Maximum Degree check box.

Short Edges
This check box is selected by default and is used to check if the object has edges shorter 
than the value specifi ed in the edit box given on the right of this check box. By default, 
0.1 is displayed in this edit box, which means Alias Design will check objects for the edges 
shorter than 0.1 unit. You can specify new distance in this edit box.
   
Maximum Spans
Select this check box to check if the model has spans higher than the value specifi ed in 
the edit box given on the right of this check box. By default, 200 is displayed in this edit 
box, which means Alias Design checks the objects that have number of spans greater 
than 200. You can specify new degree in this edit box after activating it by selecting the 
Maximum Spans check box.
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Check
After setting the parameters in the Check Model Options area, you need to check the model 
for the parameters set. To do so, choose the Check button given at the bottom of this dialog 
box; the Check Model Results report window will be displayed. This report window displays 
the result of checks performed on the model.

 Evaluating the Deviations

In a model, there may be some deviation between meshes and NURBS surfaces, 
between surfaces, or between meshes. In Alias Design, you can evaluate these deviations. 
To do so, choose the Deviation map button from the Evaluate tab in the Palette; the 

buttons, Meshes, Surfaces, and Accept will be displayed at the lower right corner of the active 
window. Also, you will be prompted to click Meshes or select surfaces. Select the fi rst surface or 
a set of the surfaces or meshes from the active window; only the Accept button will be displayed 
at the lower right corner of the active window. 
Choose the Accept button; the three buttons, 
Meshes, Surfaces, and Go will be displayed 
at the lower right corner of the active window. 
Also, you will be prompted to click Surfaces 
or select meshes. Choose the Surfaces button 
and then select the second set of surfaces; 
the Go button will get activated. Choose the 
Go button; the deviation error map will be 
displayed on the selected surfaces. Also, a 
vertical color ramp (deviation ramp) will be 
displayed on the right of the active window. 
Figure 13-23 shows a deviation error map and 
a color ramp (deviation ramp)  of a model.   

As discussed earlier, the Deviation map tool shows the deviation (distance) between a set of 
surfaces and a set of meshes. To evaluate the deviation between a set of surfaces and a set 
of meshes, select the required surfaces fi rst and then switch over to meshes by choosing the 
Meshes button that will be displayed after accepting the fi rst set of surfaces. Alternatively, 
select meshes and then switch over to surfaces by choosing the Surfaces button that will be 
displayed after accepting the fi rst set of meshes. To evaluate the deviation between two sets of 
surfaces, select the set of surfaces and then choose the Surfaces button that will be displayed 
after accepting the fi rst set of surfaces. Similarly, select the set of meshes and then choose the 
Meshes button that will be displayed after accepting the fi rst set of meshes. Also, this tool 
evaluate the deviation between two sets of surfaces or two sets of meshes.  

To set the parameters of the Deviation map tool, double-click on the Deviation map button; 
the Deviation Map Control dialog box will be displayed, as shown in Figure 13-24.

The options in this dialog box are discussed next.

Palette: Evaluate >  Deviation map

Figure 13-23  Deviation error map and color 
ramp of a model
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Ramp Distance
This edit box is used to specify the maximum deviation between meshes or/and surfaces, 
which is also displayed on the color ramp or the deviation ramp. The region on the surfaces 
of the model with the deviation value greater than the specifi ed value will be displayed in red 
or in purple. 

Acceptable Distance
This edit box is used to specify the upper limit for acceptable deviation between meshes or/
and surfaces. By default, 0.1 is displayed in this edit box. The region on the surfaces of the 
model with the deviation value smaller than the specifi ed value will be displayed in green. 

Absolute Value Ramp
Select this check box to display deviation, irrespective of its direction on the color ramp or 
the deviation ramp. On selecting this check box, you can view absolute deviation values, as 
shown in Figure 13-25.

Use Bands
Select this check box to display the bands of colors instead of slowly varying colors for displaying 
the deviation in the ramp, as shown in Figure 13-26.

 

Figure 13-26  Bands showing deviation valuesFigure 13-25  Absolute deviation values

Figure 13-24  The  Deviation Map Control dialog box
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 Creating Parting Lines by Horizon

You can create curves-on-surface by using the Horizon tool. Horizon acts as a point 
in space or denotes a direction. To create curves-on-surface using this tool, choose the 
Horizon button from the Evaluate tab in the Palette; a manipulator will be displayed in 

the view windows and you will be prompted to select the surface(s) to evaluate. Select the 
surface(s) to be evaluated in the active window; the Go button will be displayed at the lower 
right corner of the active window. Choose the Go button; the curves-on-surface will be created, 
as shown in Figure 13-27. You can change the origin of horizon by using manipulator. You 
can even rotate the horizon. Note that curves-on-surface get updated when you change the 
origin of the horizon, as shown in Figure 13-28.

To set the parameters of the Horizon tool, double-click on the Horizon button; the Horizon 
Control dialog box will be displayed, as shown in Figure 13-29.

The options in this dialog box are discussed next.

Palette: Evaluate > Horizon

Figure 13-28  Modifi ed curves-on-surfaceFigure 13-27  Curves-on-surface created on a 
surface

Figure 13-29  The  Horizon Control dialog box
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Horizon Type
This area is used to specify how the horizon lines will be projected on the surface to create 
curves-on-surface. The options in this area are discussed next.

PERSPECTIVE
This button is chosen by default. As a result, the horizon as seen from a certain point in 
the space is used to create curves-on-surface on the surface. 

ORTHOGONAL
When you choose this button, the horizon as seen from a certain direction is used to create 
curves-on-surface on the surface.

View Point
These edit boxes will be available only when the PERSPECTIVE button is chosen in the 
Horizon Type area. These edit boxes are used to specify a point in the space to look at the 
picked surface. You can also specify the position of the point by using manipulator.

Point
This fi eld is used to specify the name of the point to be positioned or aligned with the horizon 
manipulator. This point acts as a view point for creating curves-on-surface. Alternatively, select 
the point to align the manipulator with; the name of the selected point will be displayed in 
this fi eld. You can even select the point and surface before invoking the Horizon tool. 

Direction Type
This area will be available only when you choose the ORTHOGONAL button from the Horizon 
Type area. This area is used to specify the direction along which the picked surface will be 
looked at. The buttons in this area are discussed next.

ROTATION
This button is chosen by default and is used to defi ne the view direction by specifying 
angles along three axes. 

VECTOR
Choose this button to defi ne the view direction by selecting a vector from the window or 
by specifying its position.

View Direction
These edit boxes will be available only when you choose the ORTHOGONAL button from 
the Horizon Type area. These edit boxes are used to specify the direction along which the 
picked surface will be looked at.

Vector
This fi eld is used to specify the name of the vector with which the manipulator will be aligned for 
specifying the view direction. Alternatively, select the required vector to align the manipulator 
with; the name of the selected vector will be displayed in this fi eld. You can even select the 
vector and surface before invoking the Horizon tool.
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Control Options
The options in this area have been discussed in earlier chapters.

 SKETCHING/PAINTING IN Alias Design
In addition to modeling, Alias Design allows you to create 2D concept design sketches.  These 
2D sketches are created in the sketching/painting environment of Alias Design and are used 
to create 3D models. Creating sketches fi rst and then creating 3D models on them helps you 
conceptualize the model iteratively. Also, you can annotate 3D models or cloud data to indicate 
problematic region for future use. 

The sketching tools vary depending upon the product of Alias Design being used. For example, 
the sketching tools available in Alias Design may be different from the sketching tools used in 
Alias Surface and Alias Automotive. Throughout this textbook, we have used the Alias Design 
product and therefore, only the tools available in this product have been used. The different 
sketching features available in Alias Design are pencils, markers, airbrushes, solidbrushes, 
erasers, sharpenbrushes, blurbrushes, smearbrushes, clonebrushes, and so on. These sketching 
features will be discussed in detail in the next chapter. 

 WORKING WITH SKETCHING/PAINTING WINDOW
You can use different sketching/painting tools and features in the sketching/painting 
environment of Alias Design. To invoke the sketching/painting environment, you need to 
customize the Alias Design interface. To do so, choose Preferences > Workfl ows > Paint from 
the menu bar. Also, the sketcher or paint tools get added in the Paint tab of the Palette and 
Shelves windows. Alternatively, press CTRL+2 to invoke the sketching environment.

After switching over to Paint workfl ow, you need to start a new fi le to sketch on. To do so, 
choose File > New from the menu bar; the confi rm message box will be displayed. Choose 
the Yes button from the confi rm message box; the New canvas dialog box will be displayed. 
Choose the OK button from this dialog box; the Paint window will be displayed, as shown in 
Figure 13-30. You can change the layout of the window by choosing the corresponding button 
in the Layouts option of the menu bar. 

Components of Sketching/Painting Window
There are different components in the Paint window that are used for sketching or painting. 
These components are discussed next.

 Canvas
The Canvas or Canvas plane is used for drawing sketches. You can create a canvas by choos-
ing File > New from the menu bar of the Paint window. The creation of the canvas will be 
discussed later in this chapter.

Note
You can create multiple canvases in an exiting fi le by choosing Canvas > New canvas from 
the menu bar. 
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 Canvas lister
The Canvas lister is used to toggle between different canvases that are displayed in the Paint 
window. Press and hold the left mouse button on the Canvas lister to display a menu. Select 
the required canvas from this menu.

 Layer lister
The Layer lister is used to select the layer to be assigned to the current canvas. Press and hold 
the left mouse button on the Layer lister to display a menu, and then select the required layer 
from this menu. The layer assigned to the canvas will be the active layer and is represented 
by the layer with the * symbol attached as the superscript. 

 Zoom factor
The Zoom factor is used to select the zoom factor to zoom in or zoom out the canvas. By 
default, the Zoom factor corresponding to the best fi t view will be chosen. You can specify any 
other Zoom factor by selecting it from the menu that will be displayed when you press and 
hold the left mouse button on the Zoom factor.

 Flip
Choose on the Flip button to toggle between canvases. You can view the canvas that lies behind 
the current or active canvas.

Figure 13-30  The  Paint window and its components
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 Look at
Choose this button to reorient and re-center the canvas in such a way that it fi ts best in the 
window. This fi tting involves automatic application of zooming, tracking, or rotation of the 
canvas.

Rotate
Press and hold the left mouse button on the Rotate button and then drag the cursor to rotate 
the canvas clockwise or counter-clockwise about its center in the Paint window.

Zoom in/out
Press and hold the left mouse button on the Zoom in/out button and then drag the cursor 
outward to zoom in the canvas. To zoom out, drag the cursor toward the center of the 
window.

Track
Press and hold the left mouse button on the Track button and then drag the cursor up, down, 
left, or right to move the canvas accordingly.

 The Paint Tab
The Paint tab in the Palette displays all sketching/painting tools used in Alias Design. These 
tools include various types of brushes, pencils, erasers, and so on.

 The Paint Edit Tab
The Paint Edit tab in the Palette displays the tools used for editing the sketched objects. These 
editing tools are used to transform images, control the brightness and contrast of images, 
deform or warp the sketched images, and so on.

 CREATING A NEW CANVAS/PAINT WINDOW 
To create a new canvas, choose File > New from the menu bar; the confi rm message box will 
be displayed. Choose the Yes button from the confi rm message box; the New canvas dialog 
box will be displayed, as shown in Figure 13-31. Choose the OK button from this dialog box; 
the paint window will be displayed. Alternatively, choose Canvas > New canvas from the 
menu bar to create a new canvas.
 
Various areas in this dialog box are discussed next.

Canvas Name
This fi eld is used to specify the name of the canvas. By default, Canvas-1 is displayed in this 
fi eld. You can enter a new name in this fi eld.

Orientation
This area is used to specify the orientation of the canvas in 3D space or XYZ space. By default, 
the Top (Default) button is chosen in this area. When you choose the OK button from the New 
canvas dialog box, the Top window will be displayed as the new canvas plane. You can choose 
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the Left, Front, Back, TopILeftIBack or TopILeftIFront button to display the corresponding 
canvas planes.

Location
This area is used to specify the location of the new canvas. By default, the Center Of Window 
button is chosen in this area. As a result, the canvas will be located at the center of the window. 
Choose the Origin button from this area to position the canvas at the origin. 

Background layer color
This area is used to specify the background color of the canvas plane. By default, the 
Transparent button is chosen in this area. Choose the Black, White, or Current Brush Color 
button to assign the corresponding color to the background of the canvas plane.

Paper Size
This area is used to specify the paper size of the canvas plane. By default, the A4 button is 
chosen in this area. You can create a canvas of other size by choosing the respective button  
from the fl yout that will be displayed when you press and hold the left mouse button on the 
A4 button. You can also specify a paper size of your own by choosing the Custom button from 
this area.

Unit
You can specify the unit for canvas size either in inches or in millimeters by choosing the 
corresponding button in the Units area. By default, the Millimeters button is chosen in this 
area.

Figure 13-31  The  New canvas dialog box
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Pixels
The Width and Height fi elds of the Pixels area are used to specify the width and height of 
the canvas in pixels.

mm/in
The Width and Height fi elds of the mm/in area are used to specify the width and height of 
the canvas in millimeters/inches. The mm/in area will be active only when you choose the 
Custom button in the Paper Size area.

Pixels Per mm/in
This edit box is used to specify the resolution for the canvas. With this edit box, you can specify 
the number of pixels per millimeter or inch.

Portrait
Select this radio button to select the vertical (portrait) orientation of the canvas.

Landscape
This radio button is selected by default and displays the horizontal (landscape) orientation 
of the canvas.

 INTRODUCTION TO CANVAS LAYERS 
A canvas may contain one or more layers. These layers act as transparent sheets arranged one 
over the other. These layers contain information about various sketches, images, shapes, and 
so on of the canvas. Creation of layers allows you to sketch different elements on different 
layers so that you can edit these layers individually without affecting other layers. Layers can 
be image layers, mask layers, or shape layers. The types of layer are discussed next.

 Image Layers
The image layers are used to sketch different parts of an object. For example, the canvas 
image of a car may have different image layers such as body, headlights, tyres, text displaying 
the registration number, and so on. You can change the background color of image layer, 
duplicate image layers, merge image layers, and so on. These features on the image layers 
will be discussed in the next chapter.

 Mask Layers
Alias Design allows you to protect the image layer from painting/sketching, erasing, and so 
on by creating a mask layer on it. A mask protects an image from clearing, blurring, dodging, 
and so on. The masked regions are displayed in red. The color difference between the masked 
and unmasked regions can be viewed only on image layers, but the effect of the mask can be 
viewed both on images and masked layers. A mask layer may contain paint or shapes. The 
mask layer containing paint is similar to an image layer, whereas a mask layer containing a 
shape is similar to a shape layer. You can create masks by using the magicwand or marquees, 
which will be discussed in the next chapter. 
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 Shape Layers
You can create precise images with the help of shapes. You can create a shape by using simple 
curves, curves-on-surface, surface edges, or a set of any of these curves. You can modify these 
shapes easily. When you modify curves, the shape gets updated automatically. If you use curves 
to create model, modifying the curves update the model as well as its sketch. A layer containing 
shapes is known as shape layer. When you create a shape, a shape layer is created automatically. 
You cannot apply paint brushes on a shape layers. If a shape layer contains more than one 
shape, you can view these shapes by expanding the shape layer in the Canvas Layer Editor 
window that will be discussed in next topic. You can duplicate, edit, delete, mirror, and fi ll a 
shape. The creation of shape layers will be discussed in the next chapter.

 ORGANIZING CANVAS LAYERS 
After creating different layers, you can organize or rearrange them by using the Canvas Layer 
Editor window. To invoke this window, choose Windows > Editors > Canvas Layer Editor 
from the menu bar. Alternatively, click on the Layer lister to display a fl yout and then choose 
the Canvas Layer Editor button from this fl yout; the Canvas Layer Editor window will be 
displayed, as shown in Figure 13-32.

 

Figure 13-32  The Canvas Layer Editor window and its components
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Different components of the Canvas Layer Editor window are discussed next.

Layer
Press and hold the left mouse button on the Layer menu to display a fl yout. The options in 
this fl yout are used for creating a new image layer, mask layer, shape layer, duplicate a layer, 
and merge layers. 

Edit
Press and hold the left mouse button on the Edit menu to display a fl yout. The options in this 
fl yout are used to edit layers such as deleting a layer, inverting or fl ipping a layer, inverting 
the marquee, and selecting shape layer.

Convert
Press and hold the left mouse button on the Convert menu to display a fl yout. The options in 
this fl yout are used to convert layers to images, masks and invisibility masks, and also convert 
the marquee to masks.

Toggle
Press and hold the left mouse button on the Toggle menu to display a fl yout. The options in 
this fl yout are used to toggle between the visibility of different layers.

Project
Press and hold the left mouse button on the Project menu to display a fl yout. The options 
in this fl yout are used to project the sketch on objects. All visible layers on the canvas can be 
projected on the object. To view the projected sketch, shade the object.

Canvas name
This edit box is used to display the name of the active canvas. The icon of the canvas is dis-
played on the left of this edit box.

Canvas selector
Click on the Canvas selector down-arrow given on the right of the Canvas name edit box to 
display a fl yout. This fl yout is used to display all canvases. These canvases can be created by 
choosing Canvas > New canvas from the menu bar. You can create as many canvases as you 
wish with help of the Canvas menu. 

Pick canvas
Click on the Pick canvas icon to pick the current canvas. 

Lookat canvas
Click on the Lookat canvas icon to position the canvas at the center of the active window ac-
cording to the size of the canvas.
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Set canvas
Click on the Set canvas icon to make it an active canvas. You can draw a sketch, import an 
image, or work with the active canvas.

Lock canvas
Click on the Lock canvas icon to lock canvas. When you lock a canvas, you cannot select any 
other canvas.

Canvas visibility
Click on the Canvas visibility icon to turn the visibility of the sketch in a canvas on or off. 
When you click on this icon, the icon gets changed.

Canvas layer name
This edit box is used to display the name of the active image layer. The icon of the image 
layer is displayed on the left of this edit box. 

Number of associated masks
The Number of associated masks icon on the right of the Canvas layer name edit box lists 
the number of masks/invisibility mask layers associated with the image layer. The Canvas 
Layer Editor window allows you to display all or the current image layer, change opacity of 
the canvas layer, or turn the visibility of canvas layers on or off. 

In addition to these components, the Canvas Layer Editor window provides you with two 
other sections. These sections help you arrange and organize different layers. These sections 
are discussed next.

Top Section
The top section of the Canvas Layer Editor window comprises of image layers, folders of image 
layers, and shapes. In this section, you can expand folders to view image layers, expand the 
shape layer to view different shapes, and turn the visibility of the selected image layer on or 
off. You can also rename the selected image layer by double-clicking on it and then entering 
a new name in the image name fi eld. The preview of the image layer is also displayed on the 
right of the image layer. 

Bottom Section
The bottom section of the Canvas Layer Editor window comprises of mask layers, invisible 
mask layers, folders of mask or invisibility mask layers. Along with these layers, this section 
has the same options as in the top section.

Construction plane editor
The Construction plane editor icon is located below the bottom section of the Canvas Layer 
Editor window. Click on this icon; the Construction Plane Editor window will be displayed, as 
shown in Figure 13-33. This window is used to manage canvases and construction planes. The 
options in this window are the same as those discussed in the Canvas Layer Editor window.
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Canvas general information
The Canvas general information icon is located below the bottom section of the Canvas Layer 
Editor window. When you click on this icon, the Canvas General Information window will be 
displayed, as shown in Figure 13-34. This window is used to control the mask or marquee, warp 
feedback colors, and change the opacity of these features. The Canvas General Information 
window also displays the name and size of the canvas. 

The other icons located below the bottom section of the Canvas Layer Editor window are used 
to create new image layers, mask layers, invisibility mask layers, delete layers, and so on.

 WORKING ON LAYERS
Alias Design allows you to create image layers, mask layers, invisibility mask layers, and so on. 
To create, duplicate, or merge layers, choose the Canvas Layer Editor button from the Layers 
lister fl yout; the Canvas Layer Editor window will be displayed. Choose the required option 
from this fl yout to get the corresponding result. Alternatively, you can create, duplicate, or 
merge layers by invoking the respective tool in the Paint Edit tab of the Palette. These tools 
are discussed next.

Figure 13-33  The Construction Plane Editor window

Figure 13-34  The Canvas General Information window
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 Creating a New Image Layer

You can create a new image layer and make it active. To do so, choose the New image 
layer button from the Paint Edit tab in the Palette; a new image layer will be created. 
You will notice that the new image layer is listed in the Layer lister of the Paint 

window. To view all image layers, click on the Layer lister; all image layers will be listed in the 
fl yout. You can activate any of the newly created image layers by choosing it from this fl yout. 
Alternatively, you can view all image layers in the Canvas Layer Editor window that will be 
displayed when you choose the Canvas Layer Editor button from the Layer lister fl yout. By 
default, the new image layers will be named as Image-1, Image-2, Image-3, and so on. To 
rename an image layer, double-click on the image name in the Canvas Layer Editor window 
and then enter a new name in it.

 Creating a New Mask Layer

You can create a new mask layer and make it active. To do so, choose the New mask 
layer button from the Paint Edit tab in the Palette; a new mask layer will be created. 
You will notice that the new mask layer is listed in the Layer lister of the Paint window. 

The new mask layer will be displayed in the bottom section of the Canvas Layer Editor window 
and can also be renamed.

 Creating a New Invisibility Mask Layer

You can create a new invisibility mask layer and make it active. To do so, choose the 
Canvas invisibility mask layer button from the Paint Edit tab in the Palette; a new 
invisibility mask layer will be created. You can notice that the new invisibility mask layer 

is listed in the Layer lister of the Paint window. The new invisibility mask layer will be displayed 
in the bottom section of the Canvas Layer Editor window and can also be renamed.

 Creating a New Canvas Folder

You can create a new canvas folder to contain canvas layers in it. All new canvas layers 
will be placed inside this folder. To do so, choose the New layer folder button from 
the Paint Edit tab in the Palette; a canvas layer folder will be created. You can notice 

that the new canvas layer folder is listed in the Layer lister of the Paint window. The canvas 
layer folder will be displayed on the top or bottom section of the Canvas Layer Editor window 
depending on the type of canvas layer it has. You can expand the canvas layer folder to view 
the list of canvas layers contained in it. You can also rename the canvas layer folder as well as 
the image layers in it.

Palette: Paint Edit > New image layer >  New mask layer

Palette: Paint Edit > New image layer >  Canvas invisibility mask layer

Palette: Paint Edit > New image layer > New layer folder

Palette: Paint Edit >  New image layer 
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 Duplicating a Layer

You can create a duplicate copy of the currently selected image layer, shape layer, or 
mask layer. To do so, choose the Duplicate layer button from the Paint Edit tab in 
the Palette; the duplicate copy of the current layer will be created over it. You can 

notice that the new duplicate layer with suffi xes 1, 2, 3, and so on is listed in the Layer lister 
of the Paint window. The duplicate layer will be displayed in the top or bottom section of the 
Canvas Layer Editor window, depending on the type of the canvas layer in it. You can also 
rename the duplicate layer.

 Merging Layers

You can merge the current canvas layer with the canvas layer beneath it. To do so, 
choose the Merge below button from the Paint Edit tab in the Palette; the current 
active canvas layer will be merged with the canvas layer beneath it and the merged 

layer will take the name of the layer with which the active layer is merged. The merged layer 
will be displayed in the top or bottom section of the Canvas Layer Editor window depending 
on the type of the canvas layer in it. You can also rename the merged layer.

 Merging the Visible Layers

You can merge all visible paint layers. To do so, choose the Merge visible layers button 
from the Paint Edit tab in the Palette; the current paint layer will be merged with all 
other visible paint layers. The merged layer will take the name of the fi rst visible paint 

layer and will be displayed in the top section of the Canvas Layer Editor window. You can 
also rename the merged layer. To prevent a paint layer from merging with other layers, turn 
its visibility off before merging the layers by using the Merge visible layers tool. To turn the 
visibility of a layer off, click on its eye icon in the Canvas Layer Editor window. 

 Merging all Layers

You can merge all image layers even if you have turned the visibility of some of the 
layers off. To do so, choose the Merge all layers button from the Paint Edit tab in 
the Palette; all image layers will be merged. The merged layer will be displayed in the 

top or bottom section of the Canvas Layer Editor window. You can also rename the merged 
layer.

 COLOR SCHEMES
In Alias Design, sketching is done by using brushes, pencils, markers, and so on. These sketching 
tools are invoked by choosing the respective buttons from the Paint tab in the Palette. These 
sketching tools will be discussed in the next chapter. If you double-click on a sketching tool, 

Palette: Paint Edit > New image layer >  Duplicate layer

Palette: Paint Edit > New image layer >  Merge below

Palette: Paint Edit > New image layer >  Merge visible layers

Palette: Paint Edit > New image layer >  Merge all layers 
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the Brush Color area in the Brush Options dialog box will enable you to select the color 
for the selected brush. Alias Design allows you to select a color in different ways, which will 
be discussed in the next chapter. Different color schemes that are used to color a model are 
discussed next.

RGB (Red, Green, Blue)
Red, blue, and green are additive primary colors. You can produce a wide range of colors by 
adding these additive primary colors in various proportions. The RGB color scheme describes 
how red, green, and blue colors are mixed with different intensities to produce colors. When 
you mix these three primary colors with their full intensity, they produce white color. When 
you mix these three primary colors at their lowest intensity, they produce black color. The 
range of additive primary colors is 0 to 255. You can adjust the RGB colors by using the Red, 
Green, and Blue sliders.

CMY (Cyan, Magenta, Yellow)
Cyan, magenta, and yellow are subtractive primary colors. These colors are the complements 
of additive primary colors that are red, green, and blue, respectively. The CMY color scheme 
describes how cyan, magenta, and yellow colors are subtracted with different intensities to 
produce different colors. The range of subtractive primary colors is 0 to 255. You can adjust 
the CMY colors by using the Cyan, Magenta, and Yellow sliders, respectively. 

HSL and HSV (Hue, Saturation, Lightness, Value)
Hue is the ability that enables you to distinguish one color from the other. Saturation enables 
you to distinguish a strong color from a weak color. Lightness enables you to distinguish 
between the light and dark colors. Value specifi es the brightness value that distinguishes a 
light color from a dark color. You can adjust the HSL or HSV by using the Hue, Saturation, 
and Lightness (Luminance), or Value slider, respectively.

The adjustment of various colors to produce different colors from different color schemes 
such as RGB, CMY, HSL, and HSV will be discussed in the Chapter 14.

 IMPORTING IMAGES

You can import an image (in jpg, tiff, or bmp format) into an existing or new canvas as a new 
image layer or a mask layer. To do so, choose File > Import > Canvas Image from the menu 
bar; the Import Image dialog box will be displayed. Select the required image and then choose 
the Select button from this dialog box; the image will be imported as a new canvas/image 
layer. You can import the selected image as an image or a mask depending on the radio button 
selected in the Import Image Options area of the Import Image dialog box. 

To change the parameters of the Canvas Image option, click on the box icon on the right of 
the Canvas Image option; the Import Image Layer Options dialog box will be displayed, as 
shown in Figure 13-35.

Menu bar: File > Import >  Canvas Image
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The options in this dialog box are discussed next.

Layer Type
This area is used to specify the type of layer to be imported. The radio buttons in this area 
are discussed next.

Image
This radio button is selected by default and is used to import the selected image as an image 
layer.

Mask(Luminance)
Select this radio button to import the image as a mask. On selecting this radio button, the 
luminance value of the image will be used as mask. 

Mask(Transparency)
Select this radio button to import the image as a mask such that its transparency value is used 
as mask.

Always create New Canvas
This check box is used to specify whether the image will be imported as a new canvas or 
will be assigned to an existing canvas. By default, this check box is cleared and enables you 
to import an image in three different ways. If there is more than one canvas and you select 
one of them, the image will be imported into the selected canvas. If none of the canvases is 
selected, the image will be imported into the active canvas. If there is no active canvas in the 
active window, the image will be imported into a new canvas that is created automatically in 
the active window. If you select the Always create New Canvas check box, the image will be 
imported as a new canvas in the active window.    

Figure 13-35  The  Import Image Layer Options dialog box
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 EXPORTING IMAGES

You can export an image or a mask layer as an image. To do so choose File > Export > Canvas 
Image/Mask Layer from the menu bar; the Export Image Layer dialog box will be displayed. 
Specify the name and location of the image/mask layer to be exported and then choose the 
Save button; the image/mask layer will be exported to the specifi ed location.

To change the parameters of the Canvas Image/Mask Layer option, click on the box icon 
given on the right of the Canvas Image/Mask layer option; the Export Image Layer Options 
dialog box will be displayed, as shown in Figure 13-36.

The options in this dialog box are discussed next.

File Type
This area is used to specify the format in which the exported image/mask layer will be saved. 
You can export images in different formats such as jpeg, tiff, and bmp.

Limit Image Size
Select this check box to specify the size of the image. On selecting this check box, two edit 
boxes will be displayed, which are discussed next.

Horizontal Size
This edit box is used to specify the size of the image in horizontal direction.

Vertical Size
This edit box is used to specify the size of the image in vertical direction.

Figure 13-36  The  Export Image Layer Options dialog box

Menu bar: File > Export >  Canvas Image/Mask Layer
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Quality Level
This area will be available only when you select the jpeg radio button from the File Type area. 
The Quality Level area is used to specify the quality of the exported image. You can choose 
the Low, High, Medium, or Maximum button to specify the quality of the exported image. 
Alternatively, you can specify the quality of the exported image by using the edit box or the 
slider bar displayed below the Quality Level area.

TUTORIALS

In this tutorial, you will import the image, as shown in Figure 13-37, and then create the 
model of a cup by using this image, as shown in Figure 13-38. Calculate the mass properties 
of the cup. Also, check the model for the problems that can affect its successful data transfer 
to other CAD packages.              (Expected time: 30 min)    

 The following steps are required to complete this tutorial: 

a. Start Alias Design and invoke the Paint mode.
b. Import the image.
c. Create the cup using the Revolve surface tool.
d. Create the handle using the Tube Surface tool.
e. Intersect the cup with the handle by using the Intersect tool.
f. Trim the unwanted surfaces from the model by using the Trim tool.
g. Evaluate the mass properties of the model by using the Mass Properties tool and then 

save these properties in a text fi le.
h. Check the model by using the Check model tool.
i. Save the fi le.

Starting Alias Design in the Paint Mode
1. Double-click on the Alias 2010 icon on your desktop; the Design window is displayed.

Tutorial 1

Figure 13-38  Model for Tutorial 1Figure 13-37  Image of the model
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2. Choose Preferences > Workfl ows > Paint from the menu bar; the Paint mode is 
invoked. Alternatively, choose press CTRL+2 to invoke the Paint mode. 

3. Choose File > New from the menu bar; the confi rm message box is displayed.

4. Choose the Yes button from the confi rm message box; the New canvas dialog box is 
displayed.

5. Choose the Left button from the Orientation area and choose the OK button from this 
dialog box; the Left [Paint] window expands and covers the entire screen.

 

Importing the Image
 After starting Alias Design in the Paint mode, you need to download the canvas image 

(c13_image_tut01) from www.cadcim.com and import it to current session of Alias Design. 

1. Paste the following link in the address bar of the Internet Explorer window and download 
the c13_image_tut01 fi le on your computer:

 http://www.cadcim.com/aliasdesign_2010/aliasdesign_2010.htm

2. Extract the contents of the zipped fi le and save the folder in aliasdesign_2010 folder. 

3. Choose File > Import > Canvas Image from the menu bar; the Import Image dialog 
box is displayed.

4. Browse to the aliasdesign_2010 folder in the Look in drop-down list.

5. Select c13_image_tut01 fi le from the list box and then choose the Select button from the 
dialog box; image gets imported into the Left [Paint] window. Figure 13-39 shows the 
imported image of the cup.

Creating the Cup
 After importing the image, you need to create the sketch that matches the model. The 

sketch is created in the Default mode.

1. Choose Preferences > Workfl ows > Default from the menu bar to switch from the Paint 
mode to the Default mode.

2. Next, choose Windows > Editors > Canvas Layer Editor from the menu bar; the Canvas 
Layer Editor window is displayed. 

3. Drag the transparency slider located on the right of the imported image (c13_image_tut01) 
downward, as shown in Figure 13-40; the transparency of the image is increased.
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4. Next, create the profi le of the cup by using different curve tools and set the pivot point 
to the start point or endpoint of the profi le, as shown in Figure 13-41.

5. Next, choose the Revolve surface button from the Surfaces tab in the Palette and revolve 
the profi le to create the cup, as shown in Figure 13-42.

Note
If the pivot point is not visible, choose WindowDisplay > Toggles > Pivots from the menu 
bar to make it visible.
 

Creating the Handle
 The handle of the cup is created by using the Tube Surface tool. Before creating the 

handle, you need to hide the revolved cup.

Figure 13-40  Changing the transparency 
of the imported image

Figure 13-39  Imported image of the model

Figure 13-41  Profi le of the cup Figure 13-42  Cup created by revolving the 
profi le
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1. Select the cup from the active window and 
then choose ObjectDisplay > Invisible 
from the menu bar; the visibility of the cup 
is turned off.

2. Create the profi le of the handle by using 
different curve tools, as shown in Figure 13-43.

3. Double-click on the Tube Surface button of 
the Surfaces tab in the Palette; the Tube 
Surface Control dialog box is displayed.

4. Select the profi le from the active window 
and enter the required value in the Radius 
edit box. Note that matches this  radius 
value must match the radiu of the handle in the imported image.

5. Choose the Recalc button; the handle is created.

6. Choose ObjectDisplay > Visible from the menu bar; the display of the cup is turned on 
and the model is displayed, as shown in Figure 13-44.

Trimming Unwanted Surfaces
 The cup and its handle may have some unwanted surface portions left in it. You need to 

intersect these objects to recognize the unwanted surface portions and then trim them.  

1. Choose Windows > Editors > Canvas Layer Editor from the menu bar; the Canvas 
Layer Editor window is displayed.

2. Choose the Canvas visibility icon on left of the c13_image_tut02 layer in the top 
section of the Canvas Layer Editor window; the visibility of the canvas containing 
the image, c13_image_tut01, is turned off. 

3. Choose Project > Intersect from the Surface Edit tab in the Palette; you are prompted 
to select the surface(s) to intersect. 

4. Select the cup that you have created; the Go button is displayed at the lower right corner 
of the active window.

5. Choose the Go button; you are prompted to select the intersecting surfaces.

6. Select the handle; the cup intersects with the handle, as shown in Figure 13-45.

Note
Depending on the initial parameters set, the model may be in the shaded or wireframe mode. In 
case, it is in the shaded mode, you need not turn off its shading.

Figure 13-43  Profi le of the handle
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7. Trim the unwanted surface portions on both the cup and the handle by using the Trim 
tool. Figure 13-46 shows the cup and its handle after trimming the unwanted surfaces. 
Figure 13-47 shows the complete model.

Note 
The model shown in Figure 13-47 has been rendered. You can display the model simply by using 
the hardware or diagnostic shading.

Evaluating Mass Properties
 After creating the model, you need to evaluate its mass properties by using the Mass 

properties tool, and then save these properties in a text fi le.

1. Select entire model and then choose the Mass properties button from the Evaluate 
tab in the Palette; the Mass Properties Editor showing the unit, area, volume, 
and centroid of the current model is displayed.

2. Choose the Extract To File button; the Save Mass Properties Data dialog box is 
displayed.

Figure 13-45  Intersection of cup with its handleFigure 13-44  Cup and its handle

Figure 13-47  Complete modelFigure 13-46  Cup and handle after trimming
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3. Specify the location and name of the text fi le to be saved. 

4. Next, choose the Save button; the mass properties are saved in the specifi ed text fi le.

Checking the Model for Problems
 The model may have some problems that may prevent successful data transfer while being 

exported to other software. You need to check these problems, if having, by using the 
Check model tool. 

1. Double-click on the Check model button in the Evaluate tab of the Palette; the 
Check Model Options dialog box is displayed.

2. Select the Both, Visible, and Errors radio buttons from the Check, Objects, and Report 
areas, respectively, in the Check Model Options dialog box.

3. Choose the Check button in this dialog box; the Check Model Results window showing 
possible problems in the model is displayed, as shown in Figure 13-48.

Note
The results obtained in the Check Model Results window may be different from the results 
shown in Figure 13-48. This window is given only for your reference.

Saving the Model
1. Save the model with the name and location given below:

 \aliasdesign_2010\c13_tutorials\c13_tut01.wire

In this tutorial, you will create the model, as shown in Figure 13-49. The side view of the model 
is shown in Figure 13-50. After creating the model, you will check its edges for continuity. 
Also, you will check the maximum and minimum curvature of different surfaces in the model 
and evaluate errors in the model that can prevent the model from successful data transfer to 
other software packages.                   (Expected time: 45 min)

Figure 13-48  The Check Model Results window for model

Tutorial 2
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 The following steps are required to complete this tutorial: 

a. Start a new wire fi le.
b. Create the base surface by using the Revolve surface tool.
c. Create the protruding surface using the Skin surface tool and then close its upper edge 

by using the Set planar tool.
d. Intersect the base surface with the protruding surface by using the Intersect tool.
e. Trim unwanted surfaces from the model by using the Trim tool.
f. Create round surfaces by using the Round tool. 
g. Check surface edges for continuity by using the Surface continuity tool.
h. Evaluate the maximum and minimum curvature on the model by using the Min/max 

curvature tool. 
i. Check the model for errors by using the Check model tool.
j. Stitch the model into one shell by using the Shell stitch tool.
k. Save the fi le. 

Starting a New Wire File
1. Choose File > New from the menu bar; a new Design wire fi le gets started and four 

windows are displayed on the screen. You can change the window display by fi rst choosing 
the Layouts option from the menu bar fi rst and then selecting the required window from 
the layer fl yout.

2. Choose Layouts > Left from the menu bar or press the F6 key; the left window expands 
and fi ts the entire screen.  

Creating the Base Surface
 You need to create the profi le of the model by using different curve tools and revolve it 

around the X-axis using the Revolve surface tool.

1. Create the profi le of the base surface in the Left window, as shown in Figure 13-51.

Figure 13-50  Side view of the modelFigure 13-49  Model for Tutorial 2
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2. Move the pivot point of the profi le to the origin of window by using the Set pivot tool.  

3. Double-click on the Revolve surface button in the Surfaces tab of the Palette; 
the Revolve Options dialog box is displayed.

4. Select the X radio button from the Revolution Axis area and enter 180 in the Sweep 
Angle edit box.

5. Choose the Go button in the dialog box and then select the profi le; the revolved base 
surface is created, as shown in Figure 13-52.

Creating the Protruding Surface
 The protruding surface is created by using the Skin surface tool. 

1. Create the profi le for the protruding surface, as shown in Figure 13-53.

2. Choose Layouts > Perspective from the menu bar or press F8; the Perspective window 
expands and fi ts the entire screen.

3. Create a duplicate copy of this profi le and scale it down. The profi le along with its duplicate 
copy is shown in Figure 13-54.

 
4. Create the protruding surface between the profi le and its duplicate copy by using the Skin 

surface tool, as shown in Figure 13-55.

5. Create the planar surface at the top edge of the skin surface by using the Set 
planar tool. The model after creating the planar surface is displayed, as shown 
in Figure 13-56.

Figure 13-52  Base surfaceFigure 13-51  Profi le of the base surface
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Intersecting the Surfaces
 You need to intersect the base surface with the skin surface by using the Intersect tool. 

The curves-on-surface generated by the intersection of these surfaces are used to trim 
the unwanted surfaces. 

1. Choose Project > Intersect from the Surface Edit tab in the Palette and then 
select the base surface; the Go button is displayed at the lower right corner of the 
active window.

2. Choose the Go button and then select the protruding surface; the surfaces intersect with 
each other and curves-on-surface are generated, as shown in Figure 13-57.

Trimming the Surfaces
 After intersecting the surfaces, you need to trim the unwanted surfaces by using the Trim 

tool. 

Figure 13-54  Profi le and its duplicate copyFigure 13-53  Profi le for the protruding surface

Figure 13-56  Planar surfaceFigure 13-55  Protruding surface
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1. Trim the unwanted surface portions on both the base surface and the protruding 
surface by using the Trim tool. Figure 13-58 shows the model after trimming the 
unwanted surfaces.

Creating Rounds
 After trimming the surfaces, you need to create rounds at intersection edges by using the 

Round tool. Also, you need to create another round between the protruding surface and 
planar surface. 

1. Choose the Round button from the Surfaces tab in the Palette and then select the 
intersecting edge; a radius manipulator is displayed at the selected edge. Also, 
the two buttons, Build and Revert, are displayed at the lower right corner of the 
active window.  

2. Adjust the radius of the round and then choose the Build button; the round is created at 
the intersection edges.

3. Similarly, create rounds between the protruding surface and the planar surface. The model 
after creating both rounds is displayed, as shown in Figure 13-59.

Note
If all edge segments are not selected at one time, modify the radius value of the selected edge 
segment. After modifying the radius value, select other edge segments and then choose the Build 
button to create a round.

Checking Edges for Continuities
 After creating the model, you need to check whether the model has achieved positional 

continuity or not. You can do so by using the Surface continuity tool. After checking the 
continuity status of edges, you can delete the continuity locators.

1. Double-click on the Surface continuity button in the Evaluate tab of the Palette; 
the Surface Continuity Options dialog box is displayed.

Figure 13-58  Model after trimming the surfacesFigure 13-57  Surfaces after intersection
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2. Select the Positional Continuity radio button from the Find area and then choose the Go 
button in the Surface Continuity dialog box.

3. Select the required edge, as shown in Figure 13-60; the continuity locator is displayed on it.  

Note
If surfaces are connected or the gap between them is in the tolerance range, the positional 
continuity locator is displayed at the selected edge. If surfaces are not connected or the gap between 
them is not beyond tolerance range, the deviation is evaluated at the selected edge.    

4. Select other edges of the model to check whether positional continuity has been 
achieved or not. The model displaying positional continuity locators at edges is shown in 
Figure 13-61.

5. Next, choose the Pick locator button from the Pick tab in the Palette and drag a pick 
box around the entire model; all continuity locators are highlighted in green.

6. Press the DELETE key; the confi rm message box is displayed.

7. Choose the Yes button from the confi rm message box; the locators are deleted from the 
model.

Evaluating Minimum and Maximum Curvatures
 After checking the continuity between edges, you need to evaluate the model for minimum 

and maximum curvatures.

1. Choose the Min/max curvature button in the Evaluate tab of the Palette; the MIN 
and MAX curvature locators are displayed on the model, as shown in Figure 13-62. 
Also, the Min/Max Curvature window is displayed.

Figure 13-60  Continuity locator displayed at 
the selected edge

Figure 13-59  Model after creating rounds
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2. This window displays details about the minimum and maximum curvatures in the U and 
V directions of the surface. Close this window after viewing the curvature results.

Checking the Model for Errors
 You can check the model for errors by using the Check model tool.

1. Double-click on the Check model button in the Evaluate tab of the Palette; the 
Check Model Options dialog box is displayed.

2. Select the Surfaces, All, and Errors radio buttons from the Check, Objects, and Report 
areas, respectively, in the Check Model Options dialog box.

3. Choose the Check button in this dialog box; the Check Model Results window showing 
all possible problems ,is displayed, as shown in Figure 13-63. 

Stitching the Surfaces
 After doing all evaluations of the model, you need to stitch the model using the Shell 

stitch tool to ensure that there is no gap anywhere in the model. 

Figure 13-63  The Check Model Results window 

Figure 13-62  Minimum and maximum 
curvature locators

Figure 13-61  Continuity locators displayed at all 
edges of the model
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Figure 13-64  Final model after stitching

1. Double-click on the Shell stitch button in the Surface Edit tab of the Palette; the 
Stitch Control dialog box is displayed. Also, the two buttons, Stitch and Next in 
the inactive state are displayed at the lower right corner of the active window.

2. Clear the Keep originals check box from 
the Stitch Control dialog box and then 
select entire model by dragging a pick 
box around it; the Stitch button gets 
activated.

3. Choose the Stitch button; all surfaces of the 
model get stitched into one shell.

4. Select entire shell and then choose the 
Multi Color button from the Shading area 
of the Control Panel, the model is shaded. 
Next, choose WindowDisplay > Toggles > 
Model from the menu bar; the model is 
displayed, as shown in Figure 13-64.

Saving the Model
1. Save the model with the name and location given below:

 \aliasdesign_2010\c13_tutorials\c13_tut02.wire

Answer the following questions and then compare them to those given at the end of this 
chapter:

1. Surface evaluation tools enable you to verify whether the created model is fi t to be exported 
to other software packages. (T/F)

2. The Min/Max Curvature information box displays a detailed information about the 
curvature, radius, and type of surface. (T/F)

3. You can save the mass properties of a model in a text fi le. (T/F)

4. You can create a new canvas in the Paint mode by choosing Canvas > New canvas from 
the menu bar. (T/F)

5. You cannot import a bmp image as a new image layer or a mask layer into an existing or 
a new canvas. (T/F)

6. To view the comb on a continuity locator, click on the continuity with the __________ 
mouse button.

Self-Evaluation Test
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Review Questions

7. The vertical color ramp is also known as __________.

8. The canvas plane is a __________ dimensional window that is used for drawing, sketching, 
and painting.

9. You can create masks by using the __________ or marquees.

10. A layer that contains shapes is known as __________.

Answer the following questions:

1. Which of the following is not a mass property?

  (a) Surface area    (b) Volume
  (c) Centroid    (d) Curvature

2. Which of the following layers is displayed in the bottom section of the Canvas Layer 
Editor window?

  (a) Shape     b) Mask
  (c) Image    (d) None of above

3. Which of the following schemes is known as the additive primary color scheme?

  (a) RGB     (b) CMY
  (c) HSL     (d) HSV

4. Which of the following entities represents the continuity status locator of curves when you 
select the Simple Display check box in the Curve Continuity Options dialog box?

  (a) Circle    (b) Rectangle
  (c) Line     (d) Ellipse

5. Which of the following tools is used to create parting lines on a model?

  (a) Horizon    (b) Check model
  (c) Mass properties    (d) Deviation map

6. The positional discontinuity in curves is represented by a line with the distance between 
two curves mentioned on it. (T/F)

7. The Mass Properties Editor displays the units and mass properties of an object. (T/F)
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8. Data is not lost while importing or exporting a model. (T/F)

9. The __________ acts as transparent sheets arranged one over the other.

10. Cyan, magenta, and yellow colors are known as  __________ primary colors.

In this exercise, you will create the model, shown in Figure 13-65. After creating the model, 
you will check it for errors. Also, you will evaluate its mass properties and save the results in 
a text fi le.         (Expected time: 30 min) 

Exercise

Exercise 1  

Figure 13-65  Model for Exercise 1
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Answers to Self-Evaluation Test
1. T, 2. T, 3. T, 4. F, 5. F, 6. middle, 7. deviation ramp, 8. two, 9. magicwand, 10. shape layer


