
Chapter 7

Editing Tools-I 

After completing this chapter, you will be able to:
• Duplicate and combine curves.
• Add a fi llet between curves.
• Add points to a curve.
• Transform a curve.
• Stretch curves.
• Break curves.
• Intersect and detach curves.
• Rebuild curves.
• Planarize curves.
• Section curves.
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 EDITING CURVES
In the previous chapter, you learned about advanced surface modeling tools. In this chapter, 
you will learn about curve and surface editing tools. These editing tools are used for editing 
the features of an object/component. Editing curves and surfaces gives you fl exibility while 
creating models with desired parameters. These editing tools are discussed next.

 DUPLICATING A CURVE

You can create a duplicate copy of an existing curve by using the Duplicate curve tool. 
To do so, choose the Duplicate curve button from the Curve Edit tab in the Palette; 
you will be prompted to select the curve(s). Select a curve from the active window; the 

duplicate copy of the selected curve will be created at the position of the original curve. You 
can move this duplicate copy of the curve to a desired location by using the Move tool of the 
Transform tab in the Palette. 

To set the parameters of the Duplicate curve tool, double-click on the Duplicate curve button; 
the Duplicate Curve dialog box will be displayed, as shown in Figure 7-1. 

The options in this dialog box are discussed next.

 Duplicate Type
The Duplicate Type area is used to specify the type of the duplicate curve that you want to 
create. The options in this area are used to create duplicate copy with increased or decreased 
curvature, spans, uniform knots, and so on. With this tool, you can also create a duplicate curve 
with knots matching the original curve’s knots. The options in this area are discussed next.

 NO REBUILD
The NO REBUILD button is chosen by default and is used to create a duplicate curve without 
changing its attributes.

 

Palette: Curve Edit >  Duplicate curve

Figure 7-1  The  Duplicate Curve dialog box
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 CURVATURE
Choose this button to create the duplicate copy of a curve such that you can control its attributes 
such as maximum number of spans, degrees, tolerance, and so on. You can add edit points 
to curve segments with high curvature. When you choose this button, you will be prompted 
to select the curve that you want to duplicate. Select the required curve; the Go button will 
be displayed at the lower right corner of the active window. Next, choose the Go button; 
the duplicate copy of the curve will be created on the original curve. As this curve is created 
exactly on the original curve, you need to transform the duplicate curve to view it, as shown 
in Figure 7-2. Based on the settings of different areas associated with this button, this curve 
differs from the original curve in the number of spans, degrees, and so on, .

 REDUCE SPANS
Choose this button to create the duplicate copy of a curve such that the number of spans in 
the duplicate curve is reduced in comparison to the original curve. Using this button, you can 
simplify the curve by removing extraneous edit points. Figure 7-3 shows the duplicate copy of 
the curve created by choosing the REDUCE SPANS button.

 DEL MULTI-KNOTS
Choose this button to create a duplicate copy of the curve by removing multi-knots, if 
present. Multi-knots are created when you attach curves of different degrees. Multi-knots are 
undesirable as they do not support the operations such as creating rail surface, performing 
boolean operations, or exporting fi les from other CAD packages.

 UNIFORM KNOTS
Choose this button to create the duplicate copy of a curve with uniform parameterization, 
as shown in Figure 7-4. In other words, the curve created by using this button has uniform 
knots. You can specify the number of spans and degree of the duplicate curve in the Number 
of Spans and Degree edit boxes, respectively. The geometry of the curve changes if the values 
are changed in these edit boxes. 

Figure 7-2  Duplicate curve Figure 7-3  Duplicate curve with reduced spans
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 MATCH KNOTS
Choose this button to create the duplicate copy of a curve such that the number of spans and 
degrees of the duplicate curve match with the number of spans and degrees of the other curve. 
On choosing this button, you will be prompted to select the curve(s) to duplicate. Select the 
required curve; you will be prompted to select the curve with which the spans and degrees 
of the duplicate curve will be matched. Select the second curve from the active window; the 
duplicate copy of the fi rst curve with the knots matching with the knots of the second curve 
will be created, as shown in Figure 7-5.

Tolerance
The amount of deviation allowed between duplicate curve and original curve is known as 
tolerance. The Tolerance edit box will be available only when you choose the CURVATURE 
or REDUCE SPANS button from the Duplicate Type area. This edit box is used to specify 
the tolerance of the duplicate copy of the curve. Alternatively, you can specify the tolerance 
by using the slider bar given on the right of this edit box. By default, 0.01 is displayed in this 
edit box. Low tolerance means the deviation between the original curve and the duplicate 
curve will be less and therefore, more points will be inserted into the duplicate curve. High 
tolerance means the deviation between the two curves will be more and the curves will not 
match properly. Also, less number of points will be inserted into the duplicate curve. 

 Max Spans Type
The Max Spans Type area is used to specify the mode of insertion of spans into the duplicate 
curve. These modes are discussed next.

 RELATIVE
This button is chosen by default and is used to create duplicate curve such that the number 
of spans in it does not exceed the numbers of spans in the original curve times the maximum 
spans factor. In other words, this button is used to control the maximum number of spans 
in the duplicate curve. The number of spans in the duplicate curve depends upon the 
specifi ed tolerance and degree. The number of spans in a duplicate curve cannot exceed 
the number of spans in the original curve.

Figure 7-4  Duplicate curve with uniform knots Figure 7-5  Duplicate curve with the knots 
matching with the knots of the second curve  
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 ABSOLUTE
Choose this button to create a duplicate curve with the number of spans equal to the 
maximum number of spans set in the Max Spans edit box. The number of spans in the 
duplicate curve depends upon the specifi ed tolerance and degree. The number of spans 
in a duplicate curve cannot exceed the maximum number of spans set in the Max Spans 
edit box.

 Max Spans Factor
This edit box will be available only when you choose the RELATIVE button from the Max 
Spans Type area. This edit box is used to specify the multiplication factor that is used to 
specify the number of spans in the duplicate curve. You can also specify the maximum spans 
factor by using the slider bar given on the right of this edit box.

 Max Spans
This edit box will be available only when you choose the ABSOLUTE button from the Max 
Spans Type area. This edit box is used to specify the maximum number of spans that a 
duplicate curve can accommodate. You can also specify the maximum number of spans by 
using the slider bar given on the right of this edit box.

 Change Degree
This check box is used to change the degree of the new duplicate curve. When you select this 
check box, the Degree edit box will be displayed. In this edit box, you can specify a new degree 
for the duplicate curve. You can also change the degree of the duplicate curve by using the 
slider bar given on the right of the Degree edit box.  

Note
The duplicate copy of a curve is created exactly on the original curve. To view changes in its 
profi le, move it to the other location. To view changes in attributes such as degrees, spans, 
parameterization, and so on, you can use the Query edit tool that will be discussed in Chapter 8.

 Number of Spans
This edit box will be available only when you choose the UNIFORM KNOTS button from the 
Duplicate Type area. This edit box is used to specify the number of spans in the duplicate 
copy of the curve. By default, 3 is displayed in this edit box. You can also change this value by 
using the slider bar given on the right of the Number of Spans edit box.

 Control Options
The Control Options area is used to control the appearance of a curve while rebuilding it. 
The options in this area are discussed next.

 Smoothing
Select this check box to smoothen the curve after rebuilding it. Drag the cursor with the left 
mouse button to smooth the rebuilt curve interactively. Press the middle or right mouse button 
to smooth or unsmooth the rebuilt curve in steps.   
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 Interactive 
Select this check box to create the duplicate copy of an arbitrary isoparametric curve on a 
surface. You can move this duplicate curve by dragging and then placing it anywhere on the 
surface before rebuilding it. You can create this type of duplicate copy on surfaces only. If you 
clear this check box, the isoparametric curve will be duplicated and placed at the position of 
the original isoparametric curve.

 MinMax Display
Select this check box to create a comb that displays the minimum, maximum, and mean 
deviations between the original and duplicate curves, as shown in Figure 7-6. If you move the 
original or duplicate curve, these deviations will change accordingly, as shown in Figure 7-7.

 Auto Recalc.
Select the Auto Recalc. check box to update a duplicate curve automatically when parameters 
in the Duplicate Curve dialog box are changed.

 Recalc.
This button will be available only when you clear the Auto Recalc. check box and change the 
settings for the duplicate curve. By default, the Auto Recalc. check box is cleared. As a result, 
the duplicate curve will not update automatically. In such a case, choose the Recalc. button 
to update the duplicate curve. 

 Undo All
The Undo All button is used to cancel the effect of the Duplicate curve tool and restores the 
original condition of the curve.

 Next
The Next button is used to create a new duplicate curve by resetting the parameters of the  
Duplicate curve tool. After choosing the Next button, specify the setting for the new curve 
to create its duplicate copy.

Figure 7-7  Deviations changed after moving 
the duplicate curve 

Figure 7-6  Minimum, maximum, and mean 
deviations between two curves
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 COMBINING CURVES

You can create a 3D curve from two curves on different planes by using the Combine 
curves tool. This tool creates a 3D curve by projecting two planar curves in 3D space. 
To create a 3D curve, choose the Combine curves button from the Curve Edit tab in 

the Palette; you will be prompted to select 
the fi rst profi le curve. Select one of the curves 
from the active window; you will be prompted 
to select the second profi le curve. Select the 
second curve; the 3D curve will be created, 
as shown in Figure 7-8. Sometimes, the 
Combine curves tool is unable to fi gure out 
the projection directions for two curves. In 
such a case, you will be prompted to specify 
the projection directions for the two planar 
curves. Also, the Combine curves tool may 
fi nd out more than one solution and create 
the corresponding number of 3D curves. 
Delete the unwanted 3D curves after you 
exit this tool.

To set the parameters of the Combine curves tool, double-click on the Combine curves button; 
the Combine Curves Options dialog box will be displayed, as shown in Figure 7-9.

The options in this dialog box are discussed next.

 Automatic Direction
This check box is selected by default and is used to fi gure out the projection direction of two 
planar curves, automatically. If this check box is cleared, you need to specify the projection 
directions for the two curves.

Palette: Curve Edit > Duplicate curve >  Combine curves

Figure 7-8  3D curve created by combining two 
curves

Figure 7-9  The  Combine Curves Options dialog box

Tip: Sometimes, the duplication of the curve fails. In such a case, you need to 
change some settings such as tolerance, number of spans, or degree in the Duplicate 
Curve dialog box. 
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Create History
This check box is selected by default and is used to save the history of the 3D curve so that it 
can be updated while editing the profi le curves.

Note
The profi le curves that are used for creating 3D curves should be planar curves. If the curves 
are non-planar, use the Curve planarize tool (discussed later in this chapter) to make them 
planar.

Even if the Automatic Direction check box is selected and the profi le curves are drawn on the 
same plane, you need to specify the projection direction of the two profi le curves manually.    

 ADDING A FILLET BETWEEN CURVES

You can add a fi llet between two intersecting or non-intersecting curves by using the 
Fillet curves tool. To invoke this tool, click and hold the left mouse button on the 
Duplicate curve button in the Palette; a fl yout will be displayed. Choose the Fillet 

curves button from this fl yout; you will be prompted to select the primary fi lleting curve. Select 
the fi rst fi lleting curve from the active window; you will be prompted to select the secondary 
fi lleting curve. Select the second curve from the active window; the fi llet with default radius 
will be created between the two selected curves. Also, the Accept button will be displayed at 
the lower right corner of the active window. Choose the Accept button to create the fi llet with 
current settings. If you want to change the radius of the fi llet, enter the required value in the 
promptline or drag the cursor before choosing the Accept button. Figures 7-10 and 7-11 show 
the lines before and after adding the fi llet, respectively.

To set the parameters of the Fillet curves tool, double-click on the Fillet curves button; the 
Curve Fillet Options dialog box will be displayed, as shown in Figure 7-12.

The options in this dialog box are discussed next.

Palette: Curve Edit > Duplicate curve >  Fillet curves

Figure 7-11  Lines after adding fi lletFigure 7-10  Lines before adding fi llet
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 Construction
The Construction area is used to specify 
the type of the fi llet to be added between 
curves. The radio buttons in this area are 
discussed next.

 Circular
This radio button is selected by default 
and is used to create a fi llet with circular 
profi le of specifi ed radius.

 Freeform 
Select this radio button to create a 
freeform fi llet between two curves, as 
shown in Figure 7-13. The fi llet will be 
created between two curves at the points 
you click. These points are known as 
contact points. You can move these contact points by dragging the locators with the left mouse 
button. These locators are displayed when you click on the second curve. The profi le of the 
fi llet curve created will depend upon the radio button selected from the Freeform Type area 
that has been discussed later in this chapter. 

 Circular+Lead 
Select this radio button to create a fi llet of circular profi le with control on its lead radius and 
knee ratio. The lead radius and the knee ratio have already been discussed in Chapter 4. 
Figure 7-14 shows the circular+lead fi llet. 

 Radius
The Radius edit box is used to specify the radius of the fi llet curve. This edit box will be available 
only when you select the Circular or Circular+Lead radio button from the Construction 
area. 

Figure 7-12  The  Curve Fillet Options dialog box

Figure 7-14  Circular+lead fi llet createdFigure 7-13  Freeform profi le fi llet created
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 Calculate
The Calculate area is used to specify the parameter that needs to be calculated. This area will 
be displayed only when you select the Circular+Lead radio button from the Construction 
area. The two radio buttons in this area are discussed next.

 Lead Radius
This radio button is used to calculate the lead radius of the fi llet curve. Select this radio button 
and then enter the required value in the Knee Ratio edit box; the lead radius value will be 
displayed automatically in the Lead Radius edit box. The radius of the fi llet curve is equal 
to lead radius times the knee ratio.

 Knee Ratio
This radio button is selected by default and is used to calculate the knee ratio of the fi llet 
curve. Enter the required value in the Lead Radius edit box; the knee ratio will be displayed 
automatically in the Knee Ratio edit box.  

 Freeform Type
This area will be available when you select the Freeform radio button from the Construction 
area of the Curve Fillet Options dialog box. Also, this area will be available when you select 
the Circular or Circular+Lead radio button after selecting the Blend Control check box. 
The radio buttons in this area are discussed next.

 Tangent
If you extend tangents at contact points on the fi llet curve, they will intersect at a point. 
Selecting the Tangent radio button enables you to create the fi llet curve that stretches in the 
direction of the point of intersection of tangents. After selecting this radio button, select the 
primary and secondary fi lleting curves; the preview of the fi llet curves will be displayed with 
curve locators. Also, the Go button will be displayed at the lower right corner of the active 
window. You can move locators placed at contact points along the profi le curves. By moving 
these locators, you can change the positions of contact points. Choose the Go button to create 
the fi llet curve.

 Blend
This radio button is selected by default and is used to create a fi llet curve by calculating the 
average position of two contact points. Unlike the tangent fi llet, the blend fi llet curve does 
not stretch outside. As a result, the blend fi llet curve will be shallower than the tangent fi llet 
curve.

 
Figures 7-15 and 7-16 show the difference between the fi llet curves created by selecting the 
Tangent and Blend radio buttons, respectively. The radii locators displayed in both fi gures 
have been created by using the Measure radius tool of the Locators tab in the Palette. The 
tools of the Locators tab will be discussed in Chapter 10.
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 Blend Control
Select this check box to change the type of fi llet after its creation. On selecting this check 
box, the Freeform Type area will be available in the Curve Fillet Options dialog box that 
has been discussed earlier. 

 Trim Curves
This check box is selected by default and is used to trim the original curves automatically 
at contact points with fi llet curve. If you clear this check box, the fi llet curve will be created 
without trimming the original curves.

 Create History
This check box is selected by default and is used to save the history of the fi llet curve so that 
it can be modifi ed later.

 ADDING POINTS TO AN EXISTING CURVE

You can extend an existing curve by adding more control points (CVs or edit points) to 
it by using the Add points tool. To add CVs to an existing curve, select the curve and 
then choose the Add points button from the Curve Edit tab in the Palette; you will 

be prompted to specify the position of the new CV. Specify the position of the new CV in the 
promptline or click in the active window. Using this tool, you can add any number of control points 
into the endpoint of an existing curve. You can add points to all types of curves except circle, 
ellipse, text, and sweep curves. You can add CVs or edit points to a curve at its endpoints only. 

To add an edit point to a curve, choose the Pick edit point button from the Pick tab in the 
Palette and then select the fi rst or last edit point of the curve; the selected edit point will get 
highlighted. Next, choose the Add points button from the Curve Edit tab in the Palette; 
you will be prompted to specify the position of the new edit point. Click in the active window 
or enter the position of the edit point in the promptline; the edit point will be added to the 
curve resulting in its extension. 

Figure 7-16  Freeform fi llet curve created 
with the Blend radio button selected

Figure 7-15  Freeform fi llet curve created 
with the Tangent radio button selected

Palette: Curve Edit >  Add points
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 TRANSFORMING A CURVE

Transforming a curve implies moving, rotating, and scaling a curve. You can transform 
a curve by using the Transform curve tool. This tool is generally used for intersecting 
the curves in rail surfaces. By moving, scaling, or rotating a curve, you can intersect it 

with other curves. To transform a curve, choose the Transform curve button from the Curve 
Edit tab in the Palette; you will be prompted to select the curve to be transformed. Select 
the required curve from the active window; the curve will get highlighted and handles will be 
displayed on it, as shown in Figure 7-17. Also, the Translate, Rotate, and Rotate & Scale buttons 
will be displayed at the lower right corner of the active window, refer to Figure 7-17. To intersect 
the selected curve with other curves, select and drag the handle to the endpoint of one of the 
curves. Make sure the Snap to CV/Edit point button is chosen from the interface screen. Next, 
choose the Rotate button from the active window; the circular manipulator (dotted circle) will 
be displayed. Click at the endpoint of the second curve; the curve intersects with the second 
curve. Figure 7-18 shows the curve after intersecting with the two curves.

Note
The second handle of the curve in Figure 7-18 has been moved by using the triangular 
manipulator.

The two methods of positioning and intersecting a curve with two rail curves are discussed 
next. 

 Rocking/Rotating
Rocking/rotating involves positioning a curve by translating and rotating it. Before rocking 
or rotating a curve, you need to intersect one of the handles with one of the curves by moving 
it. Choose the Snap to CV/Edit tool while moving a handle. Next, choose the Rotate button 
available at the lower right corner of the active window; the circular, triangular, and rotational 
manipulators will be displayed on the fi rst control handle, as shown in Figure 7-19. The 
circular manipulator is used to rotate the selected curve around the fi rst control handle. The 

Palette: Curve Edit > Add points > Transform curve

Figure 7-18  Curve after intersecting with the 
two curves

Figure 7-17  Curve selected to intersect with 
the two curves
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triangular manipulator is used to move handle 
to any position along the curve. The rotational 
manipulator is used to specify the plane of 
rotation of the curve. A dotted circle with the 
control handle as its center is also displayed in 
the active window. This circle has radius equal 
to the distance between two endpoint handles. If 
you slide the triangular handle along the curve, 
the radius of the circle will change accordingly. 
By default, the curve rotates on its own plane. 
You can change the plane of rotation by clicking 
on the required rotational handle in the window. 
Next, adjust the handle such that it intersects 
with the second curve when it is slid along the 
curve or moved along the dashed circle. Choose 
the Snap to CV/Edit point button from the 
interface while rotating the handle. 

 Dilating
This method is used to intersect the selected curve with two curves without changing its shape 
characteristics. To transform a curve by using this method, intersect one of the handles of the 
selected curve with one of the curves. Next, choose the Rotate & Scale button from the lower 
right corner of the active window and drag the second handle to the second curve. Choose the 
Snap to CV/Edit point button while rotating the handle. The change in the shape characteristics 
of the curve will be nil and can be verifi ed by checking its curvature comb.

To set the parameters of the Transform curve tool, double-click on the Transform curve button; 
the Curve Transform Options dialog box will be displayed, as shown in Figure 7-20.

The options of this dialog box have been discussed earlier in this chapter.

Figure 7-19  The rotational, circular, and 
triangular manipulators

Figure 7-20  The  Curve Transform Options dialog box
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 STRETCHING A CURVE

You can stretch or reshape an existing curve by using the Stretch curve tool. To stretch 
or reshape a curve, press and hold the left mouse button on the Add points button of 
the Curve Edit tab in the Palette; a fl yout will be displayed. Choose the Stretch curve 

button from this fl yout; you will be prompted to select the curve to stretch. Select an existing 
curve; two handles will be displayed at the endpoints of the selected curve. These handles 
consist of circular and triangular manipulators. These manipulators have been discussed 
earlier. Next, drag the handle to the required position. When you select a curve, three buttons 
will be displayed. These buttons are discussed next.

 +Handles
Choose this button to add extra handles to the curve, as shown in Figure 7-21. The number 
of handles in a curve cannot exceed the degree of the curve plus 1.

 -Handles
Choose this button to remove extra handles from the curve. The minimum number of handles 
in a curve is 2.

 Tangent On
Choose this button to place the tangent manipulator on the selected handle. This manipulator 
consists of three mutually perpendicular axes, as shown in Figure 7-22. You can change the 
direction of stretch by selecting the corresponding axis. Also, you can stretch or reduce the 
length of the curve by clicking and then dragging the cursor along the selected axis. After 
choosing the button, the button will change to Tangent Off. Choose the Tangent Off button 
to hide the manipulator. 

To change the tangency of the curve, select the square icon from the tangent manipulator and 
drag the cursor; the tangency of the curve will be modifi ed. To relocate a particular point, 
move the manipulator to that point, click on the arrow, and then drag it. To rotate the tangent 
around an axis, click on the corresponding dotted arc. To orient the tangent along an axis, 
click on the corresponding axis (dotted line).

Palette: Curve Edit > Add points >  Stretch curve

Figure 7-22  Tangent manipulatorFigure 7-21  Extra handles added to curve 
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To set the parameters of the Stretch curve tool, double-click on the Stretch curve button; the 
Stretch Curve Options dialog box will be displayed, as shown in Figure 7-23.

The options in this dialog box are discussed next.

 Parameter
This area is used to specify whether to keep parameters of handles locked or fl oating. The 
radio buttons in this area are discussed next.

 Floating
Select this radio button to move the handles such that they slide along the curve. As a result, 
the changes made in the curve while stretching it will be minimum. Note that you can change 
parameters for extra handles only. In other words, fi rst and last handles remain fi xed to their 
parameters.

 Locked
This radio button is selected by default and is used to fi x handles to their parameters while 
moving them.

 BREAKING A CURVE AT INFLECTIONS

Infl ection points on a curve are the points where curvature changes its direction. 
Infl ection points are also known as Ogees. You can split curves at infl ection points 
by using the Break curve at infl ections tool. To break a curve at its infl ection point, 

choose the Break curve at infl ections button from the Curve Edit tab in the Palette; you will 
be prompted to select the curve to be broken. Select the curve; the Go button will be displayed 
at the lower right corner of the active window. Also, the arrows pointing toward the infl ection 
points will be displayed on the selected curve, as shown in Figure 7-24. Choose the Go button; 
the curve will break at infl ection points, as shown in Figure 7-25. As a result, new curves will 
be created with infl ection points as their endpoints.

Figure 7-23  The  Stretch Curve Options dialog box

Palette: Curve Edit >  Break curve at infl ections
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 INTERSECTING AND DETACHING CURVES

In Alias Design, you can intersect selected curves and detach them into segments at 
the intersection point by using the Intersect curves and detach tool. To intersect 
and detach curves, select the curves that are crossing each other. Next, choose the 

Intersect Curves and Detach button from the Curve Edit tab in the Palette; the Go button 
will be displayed at the lower right corner of the active window. Choose the Go button; the 
curves will intersect and detach resulting in the creation of new curve segments with new CVs 
and edit points. You can move, rotate, or scale these curve segments individually. Figure 7-26 
shows two curves crossing each other and Figure 7-27 shows the curves after intersecting and 
detaching.

Figure 7-25  Curve broken at infl ection 
points

Figure 7-24  Arrows displayed at infl ection 
points on the selected curve 

Figure 7-27  Curves after intersecting and 
detaching

Figure 7-26  Curves before intersecting and 
detaching

Palette: Curve Edit > Break curve at infl ections >  Intersect curves and detach
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 REBUILDING A CURVE

The Rebuild curve tool is used to 
reconstruct an existing curve with 
different mathematical properties 

such as spans, degree, and so on. Rebuilding 
a curve is necessary for simplifying it. For 
example, you can remove multi-knots in a 
curve by rebuilding it. However, you cannot 
change the shape features of the curve by 
using this tool. To rebuild a curve, choose 
the Rebuild curve button from the Curve 
Edit tab in the Palette; you will be prompted 
to select the curve(s) to rebuild. Select the 
curve(s) from the active window; a new curve 
will be created with different mathematical 
properties. Figure 7-28 shows the original 
and rebuilt curves.
 

Note
Generally, the rebuilt curve lies on the original curve. However, you can move it to other position 
to distinguish it from the original curve, refer to Figure 7-28. The change in the mathematical 
properties of a rebuilt curve can be viewed by checking the number of spans and degrees in the 
Control Panel. Also, you may need to adjust the tolerance value for analyzing the effect of the 
Rebuild curve tool, as discussed in the Duplicate curve tool.

To set the parameters of the Rebuild curve tool, double-click on the Rebuild curve button; 
the Rebuild Curve dialog box will be displayed, as shown in Figure 7-29.

Some of the options in this dialog box are the same as those discussed in the Duplicate curve 
tool. The other options in this dialog box are discussed next.

Palette: Curve Edit >  Rebuild curve

Figure 7-29  The  Rebuild Curve dialog box

Figure 7-28  Original and rebuilt curves
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 Change Number of CVs
This check box will be available only when you choose the UNIFORM KNOTS button from 
the Rebuild Type area. This check box is used to change the number of CVs of the rebuilt 
curve. Select this check box to display the Number of Spans edit box and enter the required 
values in this edit box. You can also change the number of spans by using the slider bar given 
on the right of the Number of Spans edit box. The change in the number of spans changes 
the number of CVs in the selected curve accordingly. 

 Keep Originals
This check box is available in the Control Options area of the Rebuild Curve dialog box. This 
check box is selected by default and is used to retain the original curve after rebuilding the 
curve. If you clear this check box, only the rebuilt curve will be displayed in the window. 

 PLANARIZING A CURVE

Sometimes, points on a curve or a surface edge may lie on different planes. You 
can modify these curves and surface edges such that points lie on the same plane. 
Planarizing a curve is important for creating a planar surface or preparing these 

curves to use as profi le curves for other tools. To do so, choose the Curve planarize button 
from the Curve Edit tab in the Palette; you will be prompted to select the fi rst curve. Select 
the non-planar curve; you will be prompted to select the next curve and the Go button will be 
displayed at the lower right corner of the active window. Choose the Go button; the non-planar 
curve(s) will get planarized. 

To set the parameters of the Curve planarize tool, double-click on the Curve planarize button; 
the Curve Planarize Options dialog box will be displayed, as shown in Figure 7-30.

The options in this dialog box are discussed next.

Palette: Curve Edit >   Curve planarize

Figure 7-30  The  Curve Planarize Options dialog box
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 Default Projection Plane
This area is used to specify the projection plane of the planarized curve. The radio buttons 
in this area are discussed next.

 Best
This radio button is selected by default and is used to specify the best fi tting plane for the 
curve. On this plane, the curve gets planarized with least modifi cations.

 Axis
Select this radio button to planarize the curve on a specifi c plane, defi ned by three axes.

 User Defi ned Plane
This radio button is used to planarize a curve 
on the construction plane. To do so, select a 
curve from the active window; the Go button 
will be displayed at the lower right corner of the 
active window. Choose the Go button; you will 
be prompted to select the construction plane. 
Select the existing construction plane; the 
curve will get planarized on the construction 
plane. The creation of construction plane 
has been discussed in Chapter 3. Figure 7-31 
shows the curve projected on the construction 
plane after planarizing it.

 Lock Ends
This check box is selected by default and is used to constrain endpoints of the planarized 
curve to endpoints of the original curve. This check box will be available only when the Best 
radio button is selected from the Default Projection Plane area.

 Principal Plane
This area is used to select a projection plane specifi ed by axes. This area will be available only 
when you select the Axis radio button from the Default Projection Plane area. The three 
radio buttons available in this area are XY, YZ, and XZ. Select any of these radio buttons to 
planarize a curve on the respective planes. Figures 7-32 and 7-33 show a non-planar curve 
planarized on YZ and XY planes, respectively.

 Keep Originals
This check box is selected by default and is used to retain the original curve after planarizing 
it. If you clear this check box, only the planarized curve will be displayed in the window.

Figure 7-31  Curve projected on the construction 
plane after planarizing it
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 SECTIONING A GROUP OF CURVES

Sectioning curves include 
operations such as trimming, 
detaching, adding edit points, 

and so on. You can section a group 
of curves by using the Curve section 
tool. This tool has different options to 
section curves. You can section curves 
by trimming, segmenting, or slicing 
at specifi ed locations. These locations 
are specified by another geometry, 
parameters on curve to be sectioned, 
or distance along curve to be sectioned. 
The options for sectioning curves are 
available in the Curve Section Options 
dialog box, as shown in Figure 7-34. This 
dialog box is invoked by double-clicking 
on the Curve section button from the 
Curve Edit tab in the Palette. Different 
sectioning operations are discussed next. 

 Trimming Curves
Trimming is a process of removing parts of curves. You can trim curves by selecting the Trim 
radio button from the Sectioning Mode area of the Curve Section Options dialog box. You 
can trim a curve in different ways depending upon the radio buttons selected in the Sectioning 
Criterion area of the Curve Section Options dialog box. The methods of trimming a curve 
are discussed next. 

Palette: Curve Edit > Curve  section

Figure 7-34  The  Curve Section Options dialog box

Figure 7-33  Curve projected on XY plane after 
planarizing it

Figure 7-32  Curve projected on YZ plane 
after planarizing it
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 Trimming Curves by Specifying Intersecting Geometry
To trim a curve by specifying the intersecting geometry, select the Geometry radio button from 
the Sectioning Criterion area. Next, choose the Go button from the Curve Section Options 
dialog box; you will be prompted to select/drag-select the curve(s) to section (trim). Select the 
curves to be trimmed from the active window; the Go button will be displayed at the lower 
right corner of the active window. Also, a red arrow will be displayed on the selected curve, as 
shown in Figure 7-35. Choose the Go button; you will be prompted to select the geometry to 
section (trim) the selected curve. Select the intersecting curve; the fi rst curve will be trimmed 
at the intersection point. Note that the part of the curve on which the red arrow is displayed 
will be retained after sectioning, as shown in Figure 7-36.

 Trimming Curves by Specifying Parameters
You can trim a curve by specifying a parameter. 
To do so, select the Parameter radio button 
from the Sectioning Criterion area. Next, 
choose the Go button and select the curve to 
be trimmed; a red arrow along with a locator 
will be displayed on it. Select the locator 
and then drag it to specify the parameter. 
Alternatively, select the locator and then 
enter a value in the promptline to specify 
the parameter. Next, choose the Go button; 
the curve will get trimmed at the specifi ed 
parameter. You can continue trimming the 
curve, or exit the Curve section tool by 
choosing the Pick nothing button from the 
Pick tab in the Palette. Figure 7-37 shows the 
curves before and after trimming it.

 
 Trimming Curves by Specifying Length
You can also trim a curve by specifying its length. To do so, select the Distance radio button 
from the Sectioning Criterion area. Next, choose the Go button and select the curve to be 
trimmed; a red arrow along with a locator will be displayed on it. Select the locator and then 

Figure 7-36  Trimmed curveFigure 7-35  Arrow displayed on the selected curve

Figure 7-37  Curve before and after trimming
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drag it to specify the distance. Alternatively, select the locator and then enter a value in the 
promptline to specify the distance. Next, choose the Go button; the curve will get trimmed at 
a specifi ed distance. You can continue trimming the curve, or exit the Curve section tool by 
choosing the Pick nothing button from the Pick tab in the Palette.

 Segmenting Curves
You can detach or segment curves by selecting the Segment radio button from the Sectioning 
Mode area of the Curve Section Options dialog box. You can detach or segment curves in 
different ways depending upon the radio buttons selected from the Sectioning Criterion area 
of the Curve Section Options dialog box. The methods of segmenting a curve are discussed 
next. 

 Segmenting Curves by Specifying Intersecting Geometry
To detach a curve by specifying intersecting geometry, select the Geometry radio button from 
the Sectioning Criterion area. Next, choose the Go button from the Curve Section Options 
dialog box; you will be prompted to select/drag-select the curve(s) to section (segment). Select 
one of the curves from the active window; the Go button will be displayed at the lower right 
corner of the active window. Choose the Go button; you will be prompted to select the geometry 
to section (segment) with the selected curve. Select the intersecting curve; the fi rst curve will get 
detached (segmented) at the intersection point. Figure 7-38 shows the curve to be segmented 
and the geometry curve. Figure 7-39 shows the curve after detaching (segmenting) it.

 Segmenting Curves by Specifying Parameters
You can detach a curve at a specifi c parameter. To do so, select the Parameter radio button 
from the Sectioning Criterion area. Next, choose the Go button and select the curve to be 
detached; a locator will be displayed on it, as shown in Figure 7-40. Select the locator and then 
drag it to specify the parameter. Alternatively, select the locator and then enter the required 
value in the promptline to specify the parameter. Next, choose the Go button; the curve will 
be trimmed according to the specifi ed parameter value, as shown in Figure 7-41. You can 
continue detaching the curve, or exit the Curve section tool by choosing the Pick nothing 
button from the Pick tab in the Palette. 

Figure 7-39  Elliptical curve after detaching itFigure 7-38  Elliptical curve and geometry 
curve
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 Segmenting Curves by Specifying Length
You can also detach a curve at a specifi ed length/distance from the start point. To do so, select 
the Distance radio button from the Sectioning Criterion area. Next, choose the Go button 
and select the curve to be detached; a locator will be displayed on it. Select the locator and 
then drag it to specify the distance. Alternatively, select the locator and then enter the required 
value in the promptline to specify the distance. Next, choose the Go button; the curve will 
get detached at the specifi ed length. You can continue detaching the curve, or exit the Curve 
section tool by choosing the Pick nothing button from the Pick tab in the Palette.

 Slicing Curves
Slicing is a process in which curves are sectioned such that new curves with new edit or 
reference points are created. You can slice curves by selecting the Slice radio button from 
the Sectioning Mode area of the Curve Section Options dialog box. You can slice curves 
in different ways depending upon the radio buttons selected from the Sectioning Criterion 
area of this dialog box. Also, the slicing operation depends upon the radio buttons selected 
from the Slice Creation Mode area of the Curve Section Options dialog box. The methods 
of slicing a curve are discussed next. 

 Slicing Curves by Specifying Intersecting Geometry
To slice a curve by specifying intersecting geometry, select the Geometry radio button from 
the Sectioning Criterion area. Next, choose the Go button from the Curve Section Options 
dialog box; you will be prompted to select the fi rst curve to slice. Select one of the curves from 
the active window; you will be prompted to select the next curve to slice. Select the second 
curve; the Go button will be displayed at the lower right corner of the active window. Choose 
the Go button; you will be prompted to select the geometry to slice with the selected curve. 
Select the curve that intersects the fi rst two curves; the two curves will get sliced and a new 
curve will be created between the two curves. Figure 7-42 shows two curves before and after 
slicing them.

Figure 7-41  Curve after detaching itFigure 7-40  Locator displayed on curve
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If you select the Create Curve radio button from the Slice Creation Mode area, a new curve will 
be created between two curves at its intersection with the geometry curve, refer to Figure 7-42. 
If you select the Insert Edit Points radio button from the Slice Creation Mode area, edit points 
will be inserted at the intersection of the selected curve with the geometry curve. Figure 7-43 
shows a curve to be sliced with the geometry curve and Figure 7-44 shows an edit point inserted 
into the curve at its intersection with the geometry curve after slicing. If you select the Insert 
Points radio button from the Slice Creation Mode area, reference points will be inserted 
at the intersection of the selected curve with the geometry curve, as shown in Figure 7-45.  

 Slicing Curves by Specifying Parameters
You can slice a curve by specifying parameters. To do so, select the Parameter radio button 
from the Sectioning Criterion area of the Curve Section Options dialog box. Next, choose the 
Go button and select the curve to be sliced; a locator will be displayed on it. You can move the 
locator along the curve to change the parameter value. Select the other curve; a new locator will 
be displayed on the second curve. Select the locator and then drag it to specify the parameter. 
Alternatively, select the locator and then enter the required value in the promptline to specify 

Figure 7-45  Reference point inserted into the 
curve at its intersection with the geometry curve

Figure 7-44  Edit point inserted into the curve 
at its intersection with the geometry curve

Figure 7-43  Curves to be slicedFigure 7-42  Curves before and after slicing them
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the parameter. Next, choose the Go button; a new curve will be created between two curves at 
specifi ed parameter values. If you select the Create Curve radio button from the Slice Creation 
Mode area, a new curve will be created between two curves at specifi ed parameters. Figure 7-46 
shows the locators displayed on two lines and Figure 7-47 shows a new curve created between 
two lines at the specifi ed parameters. If you select the Insert Edit Points radio button from 
the Slice Creation Mode area, the edit point(s) will be inserted into the selected curve at the 
specifi ed parameter value, as shown in Figure 7-48. If you select the Insert Points radio button 
from the Slice Creation Mode area, a reference point will be inserted into the selected curve 
at the specifi ed parameter value, as shown in Figure 7-49.

 Slicing Curves by Specifying Length
You can also slice a curve by specifying its length. To do so, select the Distance radio button 
from the Sectioning Criterion area. Next, choose the Go button and select the curve to be 
sliced; a locator will be displayed on it. Select the locator and then drag it to specify the 
distance. Alternatively, select the locator and then enter the required value in the promptline 
to specify the distance. Select the other curve; a new locator will be displayed on the second 

Figure 7-47  New curve created between two 
curves after slicing

Figure 7-46  Locators displayed on lines

Figure 7-49  Reference point inserted in the 
ellipse at the specifi ed parameter value

Figure 7-48  Edit point inserted in the circle 
at the specifi ed parameter value
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curve. Select the locator and then drag it to specify the distance. Alternatively, select the locator 
and then enter the required value in the promptline to specify the distance. Next, choose 
the Go button; a new curve will be created between the two curves at the specifi ed length. If 
you select the Create Curve radio button from the Slice Creation Mode area, a new curve 
will be created between the two curves at the specifi ed length. If you select the Insert Edit 
Points radio button from the Slice Creation Mode area, an edit point will be inserted into 
the selected curve at the specifi ed length. If you select the Insert Points radio button from 
the Slice Creation Mode area, a reference point will be inserted into the selected curve at the 
specifi ed length.

TUTORIALS

In this tutorial, you will create the model of a web camera, as shown in Figure 7-50.                                                                                             
                (Expected time: 1 hr)

 The following steps are required to complete this tutorial: 

a. Start a new wire fi le.
b. Create the base feature by using the Revolve surface tool.
c. Turn off the visibility of the profi le used in creating the base feature by using layers.
d. Generate curves-on-surface on the base feature by using the Project tool.
e. Turn off the visibility of the curves used in creating curves-on-surface on the base feature 

by using layers.
f. Trim unwanted surface portions on the base feature by using the Trim tool.
g. Create the camera by using the Sphere tool.
h. Generate curves-on-surface on the camera by using the Project tool.

Tutorial 1

Figure 7-50  Model of a web camera for Tutorial 1
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i. Using the Trim tool, create an aperture opening and a cut feature on the camera and the 
base feature respectively.

j. Create the aperture by using the Revolve tool.
k. Create the stand by using the profi le blend tool.
l. Save the model.

Starting a New Wire File
1. Choose File > New from the menu bar; a new Design fi le gets started and four windows are 

displayed on the screen. You can change the window display by choosing the Layouts 
option from the menu bar and then selecting the required window.

Creating the Base Feature
 The base feature is created by using the Revolve surface tool. Before creating the base 

feature, you need to create a profi le for it.

1. Choose WindowDisplay > Toggles > Grid from the menu bar if the grids are not 
displayed; grids are displayed in view windows.

2. Next, choose the Keypoint Curve Toolbox button from the Curves tab in the 
Palette; the Keypoint Curves Toolbox is displayed.  

3. Choose the Line-arc button from the Keypoint Curve Toolbox and then create 
the linearc of the profi le in the Left window, as shown in Figure 7-51.

4. Choose the Arc (three point) button from the Keypoint Curve Toolbox and then 
create the arc of the profi le, refer to Figure 7-51.

5. Press and hold the left mouse button on the Duplicate curve button of the Curve Edit 
tab in the Palette; a fl yout is displayed.

6. Next, double-click on the Fillet curves button in the fl yout; the Curve Fillet 
Options dialog box is displayed.

7. Enter a suitable value in the Radius edit box of this dialog box and then choose the Go 
button; you are prompted to select the primary fi lleting curve.

8. Select linearc from the active window; you are prompted to select the secondary curve.

9. Select the three-point arc from the active window; a fi llet curve is created between the linearc 
and the three-point arc, as shown in Figure 7-52. Also, the Accept button is displayed on 
the lower right corner of the active window. 

10. Choose the Accept button to fi nish the creation of the fi llet curve.

11. To create a single profi le, choose Break curve at keypoint > Join curves from 
the Keypoint Curve Toolbox; you are prompted to select keypoints or edit points 
to join at.
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12. Select the keypoint that is common to linearc and fi llet curve; the confi rm message box 
is displayed.

13. Choose OK from this message box; the two curves are joined.

14. Similarly, join three-point arc with the fi llet curve; a single profi le is created between 
linearc, fi llet curve, and three-point arc.

15. With the single profi le selected, choose the Revolve surface button from the 
Surfaces tab in the Palette; the base feature is created, as shown in Figure 7-53.

16. Turn the visibility of grids off by choosing WindowDisplay > Toggles > Grid from the 
menu bar.

17. To exit the Revolve surface tool, choose the Pick nothing button from the Pick tab in 
the Palette.

Turning off the Visibility of the Profi le
 To turn the visibility of the joined profi le off, you need to create a layer.

1. Choose Layers > New from the menu bar; the layer L1 is displayed in the Layers bar.

2. Double-click on the layer L1 in the Layers bar; the layer text edit fi eld is displayed.

3. Enter Base Curve in this fi eld and press ENTER; the layer L1 is renamed to Base 
Curve.

4. Next, choose the Pick object button from the Pick tab in the Palette and select the profi le 
that is used in creating the base feature; the selected curve gets highlighted.

Figure 7-52  Fillet curve createdFigure 7-51  Profi le for creating the base feature
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5. Press and hold the left mouse button on the Base Curve layer; a layer fl yout is displayed.

6. Choose the Assign option from this fl yout; the profi le is assigned to the Base Curve layer.

7. Press and hold the left mouse button on the Base Curve layer to display the layer fl yout again.

8. Choose the Visible option from the layer fl yout; the visibility of the profi le assigned to 
the Base Curve layer is turned off.

Generating Curves-on-surface on the Base Feature
 Next, you need to generate curves-on-surface on the base feature. These curves-on-surface 

can be used to trim the base feature later on. 

1. Activate the Top window and choose the Plane button from the Construction tab 
in the Palette; fi ve buttons, View, Slice, 3 Pt, Geom, and World are displayed at 
the bottom of the active window.

2. Choose the View button from the active window; you are prompted to enter the center 
position or geometry position of the plane.

3. Enter 0 in the promptline; the plane along with manipulators is displayed at the origin 
of view window. Also, two buttons, Next Plane and Set Construction Plane are displayed 
at the lower right corner of the active window.

4. Drag different manipulators of the plane to change the size and position of the plane; the 
construction plane is displayed with the changed size and position, as shown in Figure 7-54. 
The elevation of the construction plane above the base feature can be viewed in the Left 
window, as shown in Figure 7-55. 

5. Next, choose the Set Construction Plane button from the active window; the plane is set 
as the construction plane.

6. Choose the Line-arc button from the Keypoint Curve Toolbox and then create 
a profi le, as shown in Figure 7-56.

Figure 7-54  Modifi ed construction planeFigure 7-53  Base feature created
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7. Choose the Circular arc button from the Keypoint Curve Toolbox and create one 
of the circular profi les, refer to Figure 7-56. 

Note
You need to use the Mirror option (Edit > Duplicate) to create other profi les.

8. Choose the Project button from the Surface Edit tab in the Palette; you are 
prompted to select surfaces or projection vector.

9. Activate the Top window by clicking on its title bar and then select the base feature; the 
Go button is displayed at the lower right corner of the active window. 

10. Choose the Go button; you are prompted to select the projecting curves or the projection 
vector.

11. Select all circles and the linearc; the Go button is displayed again at the lower right corner 
of the Top window.

12. Choose the Go button; the selected curves are projected on the base feature and 
curves-on-surface are generated, as shown in Figure 7-57.

13. Exit the Project tool by choosing the Pick object button from the Pick tab in the 
Palette.

Turning off the Visibility of the Profi le
 To turn off the visibility of the joined profi le off, you need to create a layer.

1. Choose Layers > New from the menu bar; the layer L2 is displayed in the Layers bar.

2. Double-click on the layer L2; the layer text edit fi eld is displayed.

Figure 7-56  Profi les created for generating the 
curves-on-surface

Figure 7-55  Elevation of the construction 
plane in the Left window
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3. Enter Base COS in the layer text edit fi eld and press ENTER; the layer L2 is renamed to 
Base COS.

4. Next, select the circles used in generating the curves-on-surface on the base feature; the 
selected circles get highlighted.

5. Press and hold the left mouse button on the layer Base COS; a layer fl yout is displayed.

6. Choose the Assign option from the layer fl yout; circles are assigned to the Base COS layer.

7. Press and hold the left mouse button on the layer Base COS to display the layer fl yout again.

8. Choose the Visible option from the layer fl yout; the visibility of the circles assigned to the 
Base COS layer is turned off. 

 

Trimming the Base Feature
 Next, you need to remove the unwanted portions from the base feature by using the Trim 

tool.

1. Choose the Trim button from the Surface Edit tab in the Palette; you are prompted 
to select the surfaces to trim.

2. Select the base feature from the active window; you are prompted to select more surfaces 
to trim. Also, the Keep, Discard, and Divide buttons are displayed in inactive state at the 
lower right corner of the active window. 

3. Click on the unwanted portions of the base feature; crosshairs are displayed on the base 
feature, as shown in Figure 7-58. Also, the Keep, Discard, and Divide buttons are now 
displayed in the active state. 

4. Next, choose the Discard button from the active window; the selected portions of the 
surface are trimmed, as shown in Figure 7-59.

Figure 7-57  Curves-on-surface generated on 
the base feature

Figure 7-58  Crosshairs displayed on the 
base feature
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5. Exit the Trim tool by choosing the Pick object button from the Pick tab in the Palette.

Creating the Camera
 After trimming the unwanted portions of the surface, you need to create the body of the 

camera by using the Sphere tool. To specify the location of the body of the camera, you 
need to turn the grid display on.

1. Click on the Show button given on the title bar of the Left window; a fl yout is displayed.

2. Choose the Grid option from this fl yout; grids are displayed in the Left window. 

3. Choose the Sphere button from the Surfaces tab in the Palette and create the 
body of the camera above the base feature, refer to Figure 7-60.

4. Choose the Scale button from the Transform tab in the Palette and scale the 
body of the camera with a suitable scale factor. The camera body after scaling it 
is displayed in Figure 7-61.

5. Exit the Scale tool by choosing the Pick nothing button from the Pick tab in the Palette.

Generating Curves-on-surface on the Camera
 Next, you need to generate curves-on-surface on the camera. Before generating 

curves-on-surface, you need to turn the display of base feature and grids off. 

1. Click on the Show button given on the title bar in the Left window; a fl yout is displayed.

2. Choose the Grid option from this fl yout; the display of grids in the Left window is turned off. 

3. Create a new layer and name it as the Base Feature. Now, assign the trimmed base feature 
to this layer. Turn the visibility of this layer off, as discussed earlier. 

4. Next, choose the Plane button from the Construction tab in the Palette; you are 
prompted to select the plane construction method. Also, fi ve buttons, View, Slice, 3 
Pt, Geom, and World are displayed at the lower right corner of the active window.

Figure 7-60  Body of the camera Figure 7-59  Base feature after trimming
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5. Choose the World button; you are prompted to specify the center position or the geometry 
point of the plane.

6. Click in the Left window; the plane with the manipulator is displayed. Also, the Next 
Plane and Set Construction Plane buttons are displayed at the lower right corner of the 
active window.

7. Drag and rotate the manipulator handles of the plane such that it is placed at the center 
of the sphere. Alternatively, activate the Perspective window and then drag and rotate 
the handles to keep the plane perpendicular to the linearc.

 
8. Drag the scale handles to scale the plane, as shown in Figure 7-62.

9. Next, choose the Set Construction Plane button from the active window; the reference 
plane created is set as the construction plane. 

10. Choose the Circular arc button from the Keypoint Curve Toolbox and then create 
the circular arc, as shown in Figure 7-63.

11. Next, choose the Project button from the Surface Edit tab in the Palette; you are 
prompted to select the surface.

12. Activate the Left window by clicking on its title bar and then select the camera; the Go 
button is displayed on the lower right corner of the active window.

13. Choose the Go button; you are prompted to select the projecting curves or the projection 
vector. 

14. Select the circle from the active window; the Go button is displayed again at the lower 
right corner of the active window.

15. Choose the Go button again; the circle gets projected on the body of camera and the 
curves-on-surface are generated.

Figure 7-62  Plane after moving and scaling Figure 7-61  Body of the camera scaled
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16. Similarly, activate the Top window and project the linearc on the camera; the curves-on-surface 
are generated along all four sides of the camera, as shown in Figure 7-64.

17. Choose the Pick curve-on-surface button from the Pick tab in the Palette and 
select the curves-on-surface that are generated on the top and right of the camera.

18. Next, press the DELETE key; the confi rm message box is displayed.

19. Choose the Yes button from the confi rm message box; the selected curves-on-surface are 
removed from the window, as shown in Figure 7-65.

Creating Aperture Opening and Cut Feature on the Camera
 Next, you need to create an aperture and a cut feature on the camera by using the Trim 

tool.

1. Choose the Trim button from the Surface Edit tab in the Palette; you are prompted 
to select the surface(s) to trim.

2. Select the camera; you are prompted to select more surfaces by using the SHIFT key. 
Also, you are prompted to select regions, and the Keep, Discard, and Divide buttons are 
displayed in inactive state at the lower right corner of the active window. 

3. Click on the regions defi ned inside the projected curves; now the Keep, Discard, and Divide 
buttons will be displayed in the active state at the lower right corner of the active window.

4. Choose the Discard button; the body of the camera gets trimmed and the opening of the 
aperture as well as the cut feature is created, as shown in Figure 7-66.

5. Next, exit the Trim tool by choosing the Pick object button from the Pick tab in the 
Palette.

Figure 7-64  Curves-on-surface generated on 
the camera

Figure 7-63  Circle created on the construction 
plane
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Note
You need to turn on the hardware shading of the camera for getting its realistic view. To do so, 
choose WindowDisplay > Hardware Shade from the menu bar. You may need to toggle between 
the visible and invisible states of hardware shading at different stages of tutorial.
 

Creating the Aperture
 Next, you need to create an aperture by using the Revolve surface tool. Before creating 

the revolve feature, you need to create a profi le for it.

1. Choose the Keypoint Curve Toolbox button from the Curves tab in the Palette; 
the Keypoint Curves Toolbox is displayed.  

2. Choose the Arc (three point) tool from the Keypoint Curve Toolbox and create 
the three-point arcs of the profi le in the Back window, as shown in Figure 7-67.

3. Choose the Line-arc button from the Keypoint Curve Toolbox and create the 
linearc of the profi le, refer to Figure 7-67.

4. Choose Duplicate curve > Fillet curves from the Curve Edit tab in the Palette 
and then double-click on the Fillet curves button; the Curve Fillet Options dialog 
box is displayed.

5. Enter a suitable value in the Radius edit box and then choose the Go button; you are 
prompted to select the primary fi lleting curve.

6. Select the linearc from the active window; you are prompted to select the secondary fi lleting 
curve.

7. Select the three-point arc adjacent to the linearc; a fi llet curve is created between the 
linearc and the three-point arc, as shown in Figure 7-68.

Figure 7-66  Body of the camera after trimmingFigure 7-65  Curves-on-surface removed from 
the top and right of the camera

Tip: You can create a linearc by using the Snap to Curve tool available on the 
right of the promptline. You need to snap the lower endpoint of the linearc to the 
trimmed edge on the aperture opening.   
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8.   Next, choose the Join curves button from the Keypoint Curve Toolbox; you are 
prompted to select keypoints or edit points to join at.

9. Select the keypoint that is common to linearc and fi llet curve; the confi rm message box 
is displayed.

10. Choose OK from this message box; the two curves are joined.

11. Similarly, join other curves with each other to create a single profi le.

12. Select the joined curve and then double-click on the Rebuild curve button of the 
Curve Edit tab in the Palette; the Rebuild Curve dialog box is displayed. Also, 
the Go button is displayed at the lower right corner of the active window.

13. Clear the Keep Original check box and then choose the Go button; the joined curves are 
rebuilt, as shown in Figure 7-69.

14. Choose the Next button from the Rebuild Curve dialog box and then close the dialog box.

15. Exit the Rebuild curves tool by choosing the Pick nothing button from the Pick tab in 
the Palette.

16. Choose the Set pivot button from the Transform tab in the Palette and then 
select the rebuilt curve; the selected curve is highlighted and its pivot point is 
displayed.

17. Drag the pivot point of the curve to the center of the camera.

18. Next, double-click on the Revolve surface button of the Surfaces tab in the Palette; 
the Revolve Options dialog box is displayed. 

Figure 7-68  Fillet curve created between the 
linearc and the three-point arc

Figure 7-67  Profi le for creating the aperture 
opening



Editing Tools-I            7-37

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

19. Select the Y radio button from the Revolution Axis area and then choose the Go button; 
you are prompted to select a curve.

20. Select the curve, if is not already selected; the aperture of the camera is created, as shown 
in Figure 7-70.

21. Exit the Revolve surface tool by choosing the Pick nothing button from the Pick 
tab in the Palette.

22. Choose the Pick object button from the Pick tab in the Palette and then select the profi le 
used for creating the aperture; the profi le gets highlighted.

23. Create a new layer and name it as the Aperture Curve. Assign the highlighted profi le to 
this layer and then turn the visibility of this layer off, as discussed earlier. 

Creating the Stand
 Next, you need to create the stand for the body of the camera by using the freeform blend 

tool. Before creating the stand, you need to turn on the visibility of the base feature.

1. Press and hold the left mouse button on the Base Feature layer; the layer fl yout is 
displayed.

2. Choose the Visible option from the layer fl yout; the visibility of the trimmed base feature 
assigned to the Base Feature layer is turned on. The model after turning on the display 
of the base feature is shown in Figure 7-71.

3. Select the entire model and clear the Isoparm U and V check boxes in the Display 
area of the Control Panel; the display of isoparametric curves is turned off, refer to 
Figure 7-72. 

4. Turn the shading of the model off by choosing WindowDisplay > Hardware Shade from 
the menu bar.

Figure 7-70  Aperture of the camera createdFigure 7-69  Joined curves rebuilt
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5. Choose the Arc (three point) button from the Keypoint Curve Toolbox and then 
create the profi le in the Back window, as shown in Figure 7-73. Note that the start point 
and endpoint of the arc need to be snapped to the trimmed edges of the camera and 
the base surface, respectively. Figure 7-74 shows the entire model  with the profi le. 

6. Next, double-click on the Profi le blend button of the Surfaces tab in the Palette; 
the Profi le Blend Control dialog box is displayed.

7. Press and hold the left mouse button on the TANGENT button in the Side 1 Continuity 
area; a fl yout is displayed.

8. Choose the POSITION button from this fl yout; the positional continuity is set for side 
1. 

9. Similarly, set the positional continuity for side 2 by choosing the POSITION button from 
the Side 2 Continuity area. 

10. Click on the down-arrow on the left of the Control Options area; various options are 
displayed in this area.

Figure 7-74  Model with the profi leFigure 7-73  Profi le of the profi le blend surface

Figure 7-72  Model after turning the display 
of isoparametric curves off

Figure 7-71  Model after tuning the display 
of the base feature on
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11. Select the Chain Select check box and then select the trimmed edges created by the linearc 
on the camera and the base feature; the Go button is displayed at the lower right corner 
of the active window. 

12. Select the Go button; you are prompted to select input profi le curves.

13. Select the three-point arc; the Recalc button is displayed at the lower right corner of the 
active window.

14. Choose the Recalc button; the stand of the camera is created with the continuities set, as 
shown in Figure 7-75.

15. Next, exit the Profi le blend tool by choosing the Pick nothing button from the 
Pick tab in the Palette.

16. Turn on the shading of the entire model by choosing WindowDisplay > Hardware Shade 
from the menu bar.

17. Select the stand and then clear the Isoparm U and V check boxes from the Display area 
of the Control Panel; the display of isoparametric curves is turned off and the model is 
displayed, as shown in Figure 7-76. 

Saving the Model
 To save the model, you need to create the c07_tutorials folder.

1. Choose File > Save as from the menu bar; the Save Wire dialog box is displayed.

2. Browse to the folder aliasdesign_2010 and then create a new folder, with the name 
c07_tutorials in it, as discussed in the tutorials of the earlier chapters.

Figure 7-76  Model after turning the display of 
isoparametric curves off

Figure 7-75  Stand of the camera created
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3. Enter c07_tut01 in the Object name edit box and press ENTER; Alias Design saves the 
fi le as c07_tut01.wire in the c07_tutorials project.

 The location of this fi le is given below.

 \aliasdesign_2010\c07_tutorials\c07_tut01.wire

4. Choose File > Exit from the menu bar to exit the application.

In this tutorial, you will create the model of a tyre, as shown in Figure 7-77. The front view of 
the tyre is shown in Figure 7-78.             (Expected time: 1 hr)

 The following steps are required to complete this tutorial: 

a. Start a new wire fi le.
b. Create the base feature of the tyre by using the Revolve surface tool.
c. Create the profi le of tread by using different curves.
d. Section the tread profi le by using the Curve section tool.
e. Rebuild the tread profi le by using the Rebuild curve tool.
f. Project the rebuilt tread profi le on the base feature by using the Project tool.
g. Create the tread by using the Extrude and Set planar tools.
h. Create the duplicate copies of the tread by using the Object and Mirror options in the 

Edit menu.
i. Create the tube by using the Rail surface tool.
j. Save the model and exit the application.

Note
The display of isoparms, CVs, edit points, and so on in the model shown in Figures 7-77 and 
7-78 has been turned off for getting a realistic view. 

Figure 7-78  Front view of the tyreFigure 7-77  Model of a tyre for Tutorial 2

Tutorial 2
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Starting a New Wire File
1. Choose File > New from the menu bar; a new Design wire fi le gets started and four 

windows are displayed on the screen. You can change the window display by choosing the 
Layouts option from the menu bar and then selecting the required window.

Creating the Base Feature
 The base feature is created by using the Revolve surface tool.

1. Choose WindowDisplay > Toggles > Grid from the menu bar; grids are displayed in 
the active window.

2. Choose the New CV curve button from the Curves tab in the Palette and create 
two profi les in the Left window, as shown in Figure 7-79.

3. Choose the Revolve surface button from the Surfaces tab in the Palette; you are 
prompted to select a curve to revolve.

4. Select the profi les; the base feature of the tyre is created, as shown in Figure 7-80.

Note
You need to select both profi les one after the other for creating the base feature. The tread will be 
created on the outer surface of the base feature later in this tutorial.

5. Create a new layer and name it as Base Curve. Then, assign the profi le used for creating 
the base feature to this layer. Turn the visibility of this layer off, as discussed in Tutorial 1. 
Create another layer name it as Inner Surface, and then assign the inner revolved feature 
to this layer. Turn the visibility of this layer off.

Creating the Tread Profi le
 After creating the base feature, you need to create the tread profi le.

1. Choose the New CV curve button from the Curves tab in the Palette and create 
the profi le, as shown in Figure 7-81.

Figure 7-80  Base feature of the tyre createdFigure 7-79  Profi les for creating the base feature
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Figure 7-84  Polylines for the tread profi leFigure 7-83  Lines for the tread profi le

2. Double-click on the Duplicate curve button of the Curve Edit tab in the Palette; 
the Duplicate Curve dialog box is displayed.

3. Choose the NO REBUILD button from the Duplicate Type area, if it is not chosen already, 
and then select the curve; the Go button is displayed on lower right corner of the active 
window.

4. Choose the Go button; the duplicate copy of the curve is created. Close the Duplicate 
Curve dialog box.

5. Next, choose the Move button from the Transform tab in the Palette and then 
drag the duplicate curve to a new position, as shown in Figure 7-82.

6. Choose the Keypoint Curve Toolbox button from the Curves tab in the Palette; 
the Keypoint Curves Toolbox is displayed.

7. Choose the Line button from the Keypoint Curve Toolbox and create two lines, 
as shown in Figure 7-83.

8. Choose the Polyline button from the Keypoint Curve Toolbox and create 
polylines, as shown in Figure 7-84.

Figure 7-82  Duplicate copy of the fi rst curve after 
moving it to a new position

Figure 7-81  First curve of the tread profi le 
created
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9. Press and hold the left mouse button on the Duplicate curve button; a flyout is 
displayed.

 
10. Double-click on the Fillet curves button in this fl yout; the Curve Fillet Options 

dialog box is displayed.

11. Enter 0.1 or any suitable value in the Radius edit box and then choose the Go button; 
you are prompted to select the primary fi lleting curve.

12. Select the line on the top of the profi le; you are prompted to select the secondary fi lleting 
curve.

13. Select the duplicate curve; the Accept button is displayed at the lower right corner of the 
active window.

14. Choose the Accept button; a fi llet curve is created between the line and the curve, as 
shown in Figure 7-85.

15. Similarly, create the fi llet curve between the line at the bottom of the profi le and the original 
curve. The profi le after adding fi llet curves is displayed, as shown in Figure 7-86.

Sectioning the Profi le
 After creating the profi le, you need to section it by using the Curve section tool. 

1. Double-click on the Curve section button of the Curve Edit tab in the Palette; 
the Curve Section Options dialog box is displayed.

2. Select the Segment and Geometry radio buttons from the Sectioning Mode and Sectioning 
Criterion areas, respectively.

3. Next, choose the Go button from the Curve Section Options dialog box; you are prompted 
to select/drag-select the curves(s) to section.

Figure 7-86  Profi le after adding fi llet curvesFigure 7-85  First fi llet curve created between 
the line and the curve
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4. Select the duplicate curve (curve on the right of the profi le); the confi rm message box is 
displayed.

5. Choose the Yes button from the confi rm message box; the Go button is displayed at the 
lower right corner of the active window.

6. Choose the Go button; you are prompted to select the geometry to section with.

7. Select the two polylines; the duplicate curve gets sectioned at the intersections point with 
polylines. As a result, new curve sections are created in the duplicate curve at its intersection 
with polylines, as shown in Figure 7-87.

8. Choose the Pick nothing and Pick object buttons from the Pick tab to exit the Curve 
Section tool.

9. Now, select the curve sections; the curves get highlighted.

10. Press the DELETE key; the confi rm message box is displayed. 

11. Choose the Yes button from this message box; the selected curve sections are removed from 
the profi le and the complete profi le after sectioning is displayed, as shown in Figure 7-88.

Rebuilding the Profi le
 You can rebuild the entire profile by using the Rebuild curve tool. Before 

rebuilding the profi le, you need to join curves into a single profi le.

1. Choose the Join curves button from the Keypoint Curve Toolbox; you are 
prompted to select keypoints or edit points to join at.

2. Select a keypoint, as shown in Figure 7-89; the two curves sharing this keypoint join with 
each other. 

3. Similarly, join other curves to get the profi le, as shown in Figure 7-90.

Figure 7-88  Profi le after removing curve sectionsFigure 7-87  New curve sections
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Note
The display of keypoints, edit points, CVs, and hulls of the joined profi le in Figure 7-90 has been 
turned off by using the DisplayControl window. To invoke this window, click on the box on the 
right of the Control option in the fl yout that is displayed when you choose the ObjectDisplay 
option from the menu bar.

4. Next, double-click on the Rebuild curve button of the Curve Edit tab in the 
Palette; the Rebuild curve dialog box is displayed.

5. Choose the REDUCE SPANS button from the Rebuild Type area of this dialog box, if 
not chosen already.

6. Clear the Keep Originals check box and then select the joined profi le; the profi le 
is highlighted and the Go button is displayed at the lower right corner of the active 
window.

7. Choose the Go button; the joined profi le is rebuilt, refer to Figure 7-90.

8. Next, close the Rebuild Curve dialog box.

Projecting the Rebuilt Profi le on the Base Feature
 After rebuilding the profi le, you need to project it on the base feature by using the Project 

tool.

1. Choose the Project button from the Surface Edit tab in the Palette; you are 
prompted to select the surface(s) or the projection vector.

2. Select the base feature; the Go button is displayed at the lower right corner of the active 
window.

3. Choose the Go button; you are prompted to select the projecting curves or the projection 
vector.

Figure 7-90  Joined profi le and rebuilt profi leFigure 7-89  Selected keypoint
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4. Select the rebuilt profi le; the Go button is displayed again at the lower right corner of the 
active window.

5. Choose the Go button; the selected profi le is projected on the base feature, as shown in 
Figure 7-91. Also, you will notice that the rebuilt curve is projected on the base feature at 
two positions.  

6. Choose the Pick curve-on-surface button from the Pick tab in the Palette and 
select one of the projected profi les on the base feature.

7. Next, press the DELETE key; the confi rm message box is displayed. 

8. Choose the Yes button from this message box; the selected curve-on-surface is deleted.

9. Shade the model by using the Multi Color tool of the Shading area in the Control Panel.
 

Creating the Tread
 In this section, you need to create the tread by extruding the projected curve.

1. Choose the Line button from the Keypoint Curve Toolbox and create a line, as 
shown in Figure 7-92.

2. Next, choose the Extrude button from the Surfaces tab in the Palette; you are 
prompted to select the curve(s) to extrude.

3. Select the projected curve from the base feature; the Go button is displayed at the lower 
right corner of the active window.

4. Choose the Go button; you are prompted to select the extrude path.

5. Select the line; the tread is created on the base feature, as shown in Figure 7-93.

6. Next, choose Square surface > N-sided surface from the Surfaces tab in the 
Palette; you are prompted to select the fi rst boundary curve.

Figure 7-92  Line created as extrusion pathFigure 7-91  Rebuilt profi le projected on the 
outer surface of the base feature
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7. Select the outer edge of the tread; the Go button is displayed at the lower right corner of 
the active window.

8. Choose the Go button; the tread gets capped by the n-sided surface, as shown in 
Figure 7-94.

Creating the Duplicate Copies of the Tread
 After creating the tread, you need to create its duplicate copies. 

1. Select the tread along with its n-sided cap and then choose Edit > Group from the menu 
bar; the selected objects are grouped together.

2. Choose the Set pivot button from the Transform tab in the Palette and drag the 
pivot point to the origin (0,0,0) of the base feature, if the pivot is not at the origin. 

3. Next, choose Edit > Duplicate from the menu bar; a fl yout is displayed.

4. Click on the box given on the right of the Object option in the fl yout; the Duplicate 
Object Options dialog box is displayed.

5. Enter 60 or any suitable value in the Number edit box and press ENTER.

6. Enter 0, 0, and 6(or suitable values) in the respective Rotation edit boxes and then 
choose the Go button; the duplicate copies of the grouped objects are created, as shown 
in Figure 7-95.

7. Click on the box given on the right of the layer, named Inner surface; the visibility of the 
inner revolved feature is turned on.

8. Next, select all copies of the tread including the original tread, and then choose Edit 
> Duplicate from the menu bar; a fl yout is displayed.

9. Click on the box given on the right of the Mirror option in the fl yout; the Mirror Options 
dialog box is displayed.

Figure 7-94  Tread capped by the n-sided surfaceFigure 7-93  Tread created on the base feature
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10. In the dialog box, select the XY radio button from the Mirror Across area and then choose 
the Go button; the mirror copies of all treads are created, as shown in Figure 7-96.

Creating the Central Tube
 After creating the duplicate copies of the tread, you need to create the central tube that 

passes between treads on either side.

1. Create a new layer and name it as Tread and then assign all treads and their planar caps 
to this layer. Turn off the visibility of this layer by clicking on the box given on the right 
of this layer. Also, turn off the visibility of the Inner Surface layer, as discussed earlier in 
the tutorial. 

2. Choose the Circular arc button from the Keypoint Curve Toolbox and create the 
path curve in the Top window, as shown in Figure 7-97.

3. Choose the Polyline button from the Keypoint Curve Toolbox and create the 
profi le curve in the Front window, refer to Figure 7-97. The two profi les are 
displayed in the Front window, as shown in Figure 7-98. 

Figure 7-98  Profi le curve and path curve in 
the Front window 

Figure 7-97  Profi le curve and path curve

Figure 7-96  Mirror copies of all treadsFigure 7-95  Duplicate copies of the grouped 
objects
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4. Next, double-click on the Rail surface button of the Surfaces tab in the Palette; 
the Birail I Gen. Control dialog box is displayed.

5. Choose the Advanced tab from this dialog box; the advanced options are displayed in 
the dialog box.

6. Select the 1 radio button from the Rail Curves area; the title of the dialog box changes 
to Monorail I Gen. Control.

7. Choose the PARALLEL and ON CURVE buttons from the Sweep Mode and Sweep Pivot 
areas, respectively.

8. Select the GEN. radio button from the Fixed Curve area of the Monorail I Gen. Control 
dialog box. 

9. Select the polyline and the circular arc as the generation curve and the rail curve, 
respectively; the central tube is created, as shown in Figure 7-99. Next, close the Monorail 
I Gen. Control dialog box.

10. Turn on the visibility of the Inner Surface layer and the Tread layer by clicking on the 
box given on the right of the corresponding layers.

11. Next, choose WindowDisplay > Toggles > Model from the menu bar; the display of 
isoparametric curves, CVs, and hulls is turned off and the fi nal model of the tyre is created, 
as shown in Figure 7-100.

Saving the Model
 You need to save the model created in the c07_tutorials folder with the name c07_tut02. 

As you have already created the c07_tutorials folder in Tutorial 1 and set it as the current 
project, you do not need to create another folder for saving this tutorial. 

1. Choose File > Save As from the menu bar; the Save Wire dialog box is displayed. You 
can also invoke this dialog box by pressing the ALT+S keys.

Figure 7-100  Final model of the tyreFigure 7-99  Central tube
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2. Click on the down arrow given on the right of the Go fi eld to display the list and choose 
the Current Project option from this list.

3. Enter c07_tut02 in the Object name edit box and then choose the Save button; Alias 
Design saves the fi le as c07_tut02.wire. 

 The location of this fi le is given below:

 \aliasdesign_2010\c07_tutorials\c07_tut02.wire

4. Choose File > Exit from the menu bar to close the application.

Answer the following questions and then compare them to those given at the end of this 
chapter: 

1. In the Duplicate curve tool, low tolerance indicates less deviation between the original 
curve and the duplicate curve. (T/F)

2. The MATCH KNOTS button of the Duplicate curve tool is used to create the duplicate 
copy of a curve with the number of spans and degrees matching the number of spans and 
degrees of other curve. (T/F)

3. To create a fi llet between two curves with a freeform profi le, select the Circular radio 
button from the Construction area of the Curve Fillet Options dialog box. (T/F)

4. While creating a freeform fi llet between two curves, the blended fi llet curve is shallower 
than the tangent fi llet curve. (T/F)

5. The dilating method used to transform a curve intersects the curve with the rail surface 
with change in the shape characteristics. (T/F)

.
6. You can create a curve that intersects two rail curves by using the __________ tool.

7. The number of handles in a curve cannot exceed the __________ of the curve plus 1.

8. The __________ tool is used to split curves at infl ections.

9. You can trim, __________, or slice curves by using the Curve section tool.

10. You can create a 3D curve from two planar curves by using the __________ tool.

Self-Evaluation Test
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Answer the following questions:

1. Which of the following options is used to duplicate a curve with reduction in extraneous edit 
points?

 
  (a) NO REBUILD   (b) CURVATURE
  (c) REDUCE SPANS   (d) DELETE MULTI-KNOTS

2. Which of the following radio buttons is selected to create a fi llet of circular profi le with 
control on its lead ratio and knee ratio?

  (a) Circular    (b) Profi le
  (c) Circular+Lead   (d) None of the these

3. While planarizing a curve, which of the following radio buttons is selected to specify a 
plane on which modifi cations on the curve are the least?

  (a) Best     (b) Axis
  (c) User Defi ned Plane   (d) None of the these

4. Which of the following operations is not included in the sectioning of curves?  

  (a) Trimming    (b) Detaching
  (c) Adding control points  (d) Breaking    

5. You can add points to the existing curves such as circle, ellipse, text, and sweep curves by 
using the Add points tool. (T/F)

6. While stretching a curve, you can change the parameter of extra handles, but not the 
handles displayed at its endpoints. (T/F)

7. The Create Curve radio button is selected to create a curve while slicing curves. (T/F)

8. The trimming of curves enables you to remove the part of curves that lie __________ the 
intersection point.

9. The __________ points are the points on a curve at which curvature changes its 
direction.

10. After selecting the Smoothing check box from the Duplicate Curve dialog box, you 
need to drag the cursor with the __________ mouse button to smoothen the rebuilt curve 
interactively.

Review Questions
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Figure 7-104  Other view of the modelFigure 7-103  Model of a washbasin for Exercise 2

Exercise 2 

Figure 7-102  Other view of the modelFigure 7-101  Model of a knife for Exercise 1

Create the model of a knife, as shown in Figure 7-101. Figure 7-102 shows the other view of 
the model.               (Expected time: 45 min)

Create the model of a washbasin, as shown in Figure 7-103. Figure 7-104 shows the other view 
of the model.                                                       (Expected time: 30 min)

Answers to Self-Evaluation Test
1. T, 2. T, 3. F, 4. T, 5. F, 6. Transform curve, 7. degree, 8. Break curve at infl ections, 
9. segment, 10. Combine curves

Exercises

Exercise 1 


