
Chapter 1

Introduction to Adobe 
Premiere Pro CS5.5

 Learning Objectives 
After completing this chapter, you will be able to:
• Start Adobe Premiere Pro CS5.5
• Start a new project with different settings
• Work with panels
• Work with workspace
• Understand the Source Monitor and the Program Monitor
• Change preferences
• Customize keyboard shortcuts
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Introduction
Adobe Premiere Pro is one of the most powerful real-time professional grade video editing 
applications. It has flexible, precise, and reliable editing tools. Enhanced Mercury playback 
engine allows it to deliver astounding performance on both desktops and laptops. You can use 
the roundtrip audio workflow with the Adobe Audition CS5.5 application. In addition, you 
can render a great quality video for computers, TV, smart phones, films, and tablets by using 
Adobe Media Encoder CS5.5. With this version, you can drag and drop sequences from Adobe 
Premiere Pro CS5.5 directly into Adobe Media Encoder CS5.5 and can also integrate your 
Adobe Story scripts combined with metadata into Adobe Premiere Pro CS5.5. It also supports 
previewing of Canon XF footage in the Media Browser and utilization of the camera metadata. 
Moreover, RED support is enhanced in Adobe Premiere Pro CS5.5. It now supports latest Color 
Science and Firmware for RED ONE camera such as RED Rocket and Mysterium X. 

Tutorial Description
In this tutorial, you will start Adobe Premiere CS5.5, create a new project with proper settings, 
and learn to work with the interface of Adobe Premiere CS5.5. You will also learn how to work 
with the workspace, navigate through panels, and customize keyboard shortcuts.  

Downloading Files
Before you start the tutorial, you need to download the c01_premiere_cs5.5_tut.zip and media.zip 
files from http://www.cadcim.com. The path of the files is as follows:

Textbooks > Animation and Visual Effects > Adobe Premiere Pro > Adobe Premiere Pro CS5.5: A 
Tutorial Approach

Next, navigate to the Documents folder and create a new folder with the name Adobe Premiere 
Tutorials and then extract the contents of the zipped files to \Documents\Adobe Premiere 
Tutorials.

Note
1. The path mentioned above depends on the operating system being used. 

2. The media.zip file contains all media files that are used in the tutorials of this book. Therefore, 
before proceeding with the tutorials, you need to download the media.zip file at least once. 

Starting Adobe Premiere Pro CS5.5 and a New Project
After installing Adobe Premiere Pro CS5.5 on your computer, follow the steps given below to 
start Adobe Premiere Pro CS5.5.

1.	 Choose the Start button on the taskbar to display the taskbar menu. Choose All Programs > 
Adobe > Adobe Master Collection > Adobe Premiere Pro CS5.5 from the taskbar menu, 
as shown in Figure 1-1; the Welcome to Adobe Premiere Pro dialog box is displayed along 
with the Adobe Premiere Pro CS5.5 screen, as shown in Figure 1-2. 

2.	 Choose the New Project button in the Welcome to Adobe Premiere Pro dialog box; the 
New Project dialog box is displayed, as shown in Figure 1-3.
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	 You can open the previously saved projects by choosing the Open Project button in the 
Welcome to Adobe Premiere Pro dialog box. You can also open the recently saved projects 
by choosing them from the Recent Projects list in this dialog box.

Figure 1-1  Starting Adobe Premiere Pro CS5.5 using the taskbar menu 

Note
The path for starting Adobe Premiere Pro CS5.5 depends on the operating system being used.

3.	 In the General tab of the New Project dialog box, accept the default settings in the Video 
Rendering and Playback, Video, Audio, and Capture areas. 	

4.	 Choose the Scratch Disks tab from the New Project dialog box. The options in this tab 
are shown in Figure 1-4. 
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	 The Scratch Disks tab is used to specify the location of the scratch disks. By default, the 
files are saved at \Documents\Adobe\Premiere Pro\5.5. When you edit a project, Premiere uses 
the disk space to store files required by your project. Premiere stores captured video and 
audio, preview files, and conformed audio files. It is best practice to assign a different 
disk to each asset type. It ensures real-time editing, optimized performance, and 32-bit 
floating point quality. 

Figure 1-2  The Welcome to Adobe Premiere Pro dialog box

Figure 1-3  The New Project dialog box 
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Figure 1-4  The options in the Scratch Disks tab

5.	 To specify the location of the new project, choose the Browse button on the right of the 
Location drop-down list; the Please select the destination path for your new project 
dialog box is displayed. Next, browse to the location \Documents\Adobe Premiere Tutorials 
and then choose the Select Folder button.

6.	 Type the name of the project as Chapter01 in the Name text box in the New Project dialog 
box and then choose the OK button; the New Sequence dialog box is displayed, as shown 
in Figure 1-5. Also, you are prompted to specify the settings of the new sequence in the 
new project based on the footage or video clip. In this dialog box, the Standard 48kHz 
preset is selected by default in the Available Presets area.

Note
The settings of the new sequence should match the audio and video settings of the footage. 

7.	 Make sure Sequence 01 is entered in the Sequence Name text box.

8.	 Choose the OK button; a new project screen with the new sequence is displayed, as shown 
in Figure 1-6. The new project screen consists of various panels. These panels are discussed 
in the next section.

Panels
A new project screen is filled with various panels such as the Project panel, the Timeline 
panel, the Media Browser panel, and so on, refer to Figure 1-6. Some of these panels are 
discussed next.  
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Figure 1-5  The New Sequence dialog box

Project Panel
The Project panel is used to import all media files such as videos, audios, and stills that you 
will use in the project. By default, the List View button is chosen at the bottom of the Project 
panel. As a result, the media files are displayed in a list.

1.	 Choose File > Open Project from the menu bar; the Open Project dialog box is 
displayed. In this dialog box, navigate to \Documents\Adobe Premiere Tutorials and select the 
chapter01_general.prproj file that you have downloaded from the CADCIM website. 

2.	 Choose File > Save As from the menu bar; the Save Project dialog box is displayed. 
Browse to \Documents\Adobe Premiere Tutorials. Type the name chapter01_general_02 in the 
File name text box and choose the Save button; the opened file is saved with the specified 
name, refer to Figure 1-7. 
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Note
The Tickoo Wind Turbine file is already imported and saved in the Project panel. You will 
learn more about importing media files in Chapter 2.

Figure 1-6  The new project screen displaying various panels

Figure 1-7  The chapter01_general_02 file displayed in the Premiere Pro CS5.5 screen
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3.	 Choose the Icon View button at the bottom of the Project panel; the Tickoo Wind Turbine 
file and the Sequence01 are displayed as icons.

	 When the Icon View button is chosen, you can arrange clips in the Project panel in a 
storyboard style. It helps you in quickly visualizing and assembling the sequence. Then, 
you can use the Automate to Sequence button to move the assembled storyboard to a 
sequence in the Timeline panel.

4.	 Choose the List View button from the Project panel and then select the Tickoo Wind 
Turbine media file in the Project panel; its preview is displayed at the top of the Project 
panel. Also, the details of the media file are displayed on the right of the preview screen, 
refer to Figure 1-8. You can choose the Play-Stop Toggle button to view the preview of 
the selected video clip.

 

Figure 1-8  The Project panel with various buttons

	 To view full details of the media files in the Project panel, you need to drag the slider at 
the bottom of the Project panel. Alternatively, you can increase the size of the Project 
panel to view the details.
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Tip: You can expand a panel to display it in the full screen mode. To do so, hover the 
cursor over the panel and press the accent key (`). The accent key is also referred to as back 
quote key or the tilde key. Alternatively, select the panel by clicking on it and then choose 
Window > Maximize Frame from the menubar or press SHIFT+`.

	 To delete a media file from the Project panel, select the file and then choose the Clear 
button. If you have a number of media files in the Project panel and you want to delete 
a specific media file, use the Filter Bin Content search field to search the required media 
file from the list. To do so, type the first few characters of the media file that you need to 
search in the Filter Bin Content search field; all the files starting with the typed characters 
will be displayed in a list, refer to Figure 1-9. Next, select the required file from the list 
and choose the close button displayed on the right of the Filter Bin Content field.

5.	 Choose the New Bin button; a new folder is created in the Project panel. Folders are used 
to organize media files in the Project panel. You can rename the newly created folder as 
per your requirement.

	
6.	 Choose the New Item button; a flyout is displayed, as shown in Figure 1-10. You can create 

a new sequence, a new title, and so on by using the options in this flyout.

Figure 1-9  The list showing searched 
media file

Figure 1-10  A flyout displayed on choosing the 
New Item button

	
	 A small arrow on the right of the Name column in the Project panel indicates that 

this column is selected. It also indicates that the media files or assets in the Name 
column are displayed in the alphabetical order. Click on the Name column; the 
alphabetical order of the assets in the Project panel as well as the arrow will be reversed. 
Next, select the Label column; a small arrow is displayed on its right. Now, the assets will 
be sorted according to the Label column.

	 In Adobe Premiere Pro CS5.5, the Label is a color swatch that helps you identify and 
associate the assets in the Project panel. 

	 In the following steps, you will learn how to assign a label to a media file.

7.	 Select the Tickoo Wind Turbine file in the Project panel. Choose Edit > Label from the 
menu bar; a cascading menu is displayed, as shown in Figure 1-11. 
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8.	 Choose a color of your choice from the cascading menu; the chosen label color is assigned 
to the selected clip. 

	 You can also select all media files having the same label color in the Project panel. To do 
so, select one of the media files. Next, choose Edit > Label from the menu bar; a cascading 
menu is displayed. Now, choose Select Label Group from the cascading menu. 

Figure 1-11  The cascading menu

	 In the following steps, you will learn to modify the name and color of the labels.

9.	 Choose Edit > Preferences from the menu bar; a cascading menu is displayed. Next, 
choose Label Colors from it; the Preferences dialog box is displayed with the Label 
Colors option selected in it, refer to Figure 1-12.  

Figure 1-12  The Preferences dialog box with the Label Colors option selected

	 Note that the default label colors and their names are displayed on the right, refer to 
Figure 1-12. 
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10.	 Choose the color swatch based on your requirement; the Color Picker dialog box will 
be displayed. Next, select the color of your choice and then choose the OK button; the 
selected color will be displayed on the chosen color swatch. 

11.	 Specify a new name for the new color in the text box corresponding to that color in the 
left of the color swatch. Choose the OK button in the Preferences dialog box to save the 
changes made. 

	 In the Project panel, you can select any column to sort media files. Also, you can move a 
column to replace the position of other columns.

	 Next, you will learn how to customize the columns in the Project panel.

12.	 Drag the slider at the bottom of the Project panel and move the cursor over the Media 
Duration column. 

13.	 Press and hold the left mouse button on the Media Duration column and drag the cursor 
to the left of the Label column; the Media Duration column is now placed on the left of 
the Label column, refer to Figure 1-13. 

14.	 Choose the button on the top right of the Project panel; a flyout is displayed, as shown 
in Figure 1-14.

Figure 1-14  The flyout displayedFigure 1-13  The Media Duration column  
moved to the left of the Label column

15.	 Select the Metadata Display option from the flyout; the Metadata Display dialog box is 
displayed.

16.	 Click on the arrow on the left of the Premiere Pro Project Metadata node to expand it; 
a list of all columns available in this node is displayed, as shown in Figure 1-15. 
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Figure 1-15  The Metadata Display dialog box with Premiere Pro 
Project Metadata node expanded

17.	 Select the check boxes on the left of the column names that you need to display in the 
Project panel. Also, clear the check boxes for the columns that you do not need to display 
in the Project panel.

18. Choose the OK button; the selected columns are displayed in the Project panel.

Media Browser Panel
The Media Browser panel is used to navigate the media files such as video, audio, and stills on 
your hard drive. When you navigate to the media folder that you need in the Media Browser 
panel, all media files inside that folder will be displayed on the right of the panel, as shown 
in Figure 1-16.  

Info Panel
The Info panel displays the details of the media file selected in the Project panel, refer to 
Figure 1-17.

Effects Panel
Adobe Premiere Pro CS5.5 has a variety of audio and video effects that you can use in your 
projects to make your project more appealing. All these effects are contained in the Effects 
panel and  are divided into several categories such as Presets, Audio Effects, Audio Transitions, 
Video Effects, and Video Transitions, refer to Figure 1-18. 
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Figure 1-16  The media files displayed after navigating the folder 
in the Media Browser panel

Figure 1-17  The Info panel Figure 1-18  The Effects panel

Timeline Panel
The Timeline panel is located on the lower central portion of the Adobe Premiere Pro CS5.5 
screen, refer to Figure 1-19. Every Premiere Pro project may contain one or more sequences. 
You can assemble and rearrange sequences in one or more Timeline panels. You can open a 
specific sequence on a tab in a Timeline panel or dedicate its own Timeline panel for it.

Note
To add a clip to the sequence, you need to drag it from the Project panel to the Timeline panel. 
You will learn about adding the clips to the sequence in the later chapters.
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The Current time display shows the timecode for the current frame in the Timeline panel, refer 
to Figure 1-19. To move to a different time, click over the Current time display; it will change 
into a text box. Now, enter a new time. Alternatively, move the cursor over the Current time 
display; the shape of the cursor gets changed. Now, drag the cursor to a new time.

Figure 1-19  The Timeline panel

The Time ruler is used to measure sequence time horizontally. It also displays icons for 
markers and the In and Out points of the sequence. You will learn more about these points 
and markers  in the later chapters.

The Current time indicator (CTI) specifies the current frame displayed in the Program Monitor. 
You can change the current time in the Program Monitor by dragging the CTI.

The Work area bar is located at the bottom of the Time ruler. It specifies the area of the 
sequence that you need to preview or export. 

The Viewing area bar is located just above the Time ruler. It specifies the visible part of the 
sequence in a Timeline panel. You can modify the viewing area to view the part of the sequence 
based on your requirement.

The video and audio tracks are located below the Time ruler. It displays the video and audio 
clips in the sequence. You can add, delete, or rename a track using the options displayed in 
the shortcut menu, that is displayed when you right-click on the track name.

The zoom controls are located at the bottom left of the Timeline panel. These controls are 
used to increase or decrease the visible frames within the current viewing area.
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Tools Panel
Various tools in the Tools panel are used to select, trim, and edit the clips in the sequence, 
refer to Figure 1-20. You will learn to edit the clips using these tools in the later chapters.

Figure 1-20  Various tools in the Tools panel

Working with Workspace
A workspace is an area where various panels of different sizes are located on the Adobe 
Premiere Pro CS5.5 screen. 

1.	 Choose Window > Workspace from the menu bar; a cascading menu is displayed, as 
shown in Figure 1-21.

Figure 1-21  The cascading menu displayed on choosing Workspace from the Window menu

	 By default, the Editing workspace is selected for the new project, refer to Figure 1-21. You 
can change your workspace to Audio, Color Correction, Effects, or Metalogging based 
on your requirement.

	 You can also modify the current workspace by moving the panels and changing their size 
based on your requirement. Now, you will learn how to change the location of the panels 
and modify their size.
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2.	 Move the cursor over the starting point before the panel label, refer to Figure 1-22. Now, 
click and drag it to the position where you want to place it; a light blue colored highlight 
is displayed to show the preview of the area where the panel will be placed. Release the 
mouse button to move the panel to the highlighted location.  

Figure 1-22  The cursor placed to move the panel

	 If a rectangular highlight is displayed while dragging the panel, as shown in Figure 1-23, 
then after releasing the mouse button, the panel will become an additional tab to the set 
of panels, refer to Figure 1-24. If a trapezoid highlight is displayed at the time of dragging 
the panel, as shown in Figure 1-25, then the panel will be displayed in between the existing 
panels. 

Figure 1-23  A rectangular highlight displayed while dragging

3.	 Choose Window > Workspace from the menu bar; a cascading menu is displayed. Next, 
choose the Reset Current Workspace option in the cascading menu; the Reset Workspace 
message box is displayed. Choose the Yes button; the current workspace is displayed with 
the default layout.

	 To display the additional panels, select them from the Window menu in the menu bar. To 
close a panel, choose the Close button located on the right of the panel label. To resize 
the panel, move the cursor over the boundary of the panel; the shape of the cursor gets 
changed, as shown in Figure 1-26. Now, drag the mouse button to resize the panel based 
on your requirement and release the mouse button.
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Figure 1-24  The panel displayed as an additional tab

Figure 1-25  A trapezoid highlight displayed

4.	 Choose Windows > Workspace > New Workspace from the menu bar to save your own 
workspace; the New Workspace dialog box is displayed, as shown in Figure 1-27. Type 
the name of your workspace and choose the OK button; the new workspace is added in 
the Window menu with the specified name.
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Figure 1-26  The changed shape of the cursor

Figure 1-27  The New Workspace dialog box

Source Monitor and Program Monitor
By default, the Source Monitor is located at the top center of the Adobe Premiere Pro CS5.5 
screen, refer to Figure 1-28. It is used to prepare the video and audio clips that you want to 
use in your sequence. It plays back individual clips that you will use in your sequence. In the 
Source Monitor, you can set In and Out points for a clip (audio or video), insert clip markers 
based on your requirement, and add the clip to your sequence. You can also specify the video 
or audio track of the clip in the Source Monitor. You will learn more about these features in 
the later chapters. 

The Program Monitor is placed on the top right portion of the Adobe Premiere Pro CS5.5 
screen, refer to Figure 1-29. It plays back the sequence of clips that had been assembled in 
the Timeline panel. 

The Source and Program Monitors have playback controls at their bottom. These playback 
controls are used to playback and cue the current frame of the source clip or sequence. To 
change the magnification settings of the clip displayed in the Source or Program Monitor, click 
on the arrow on the right of the Select Zoom Level button; a drop-down list is displayed, as 
shown in Figure 1-30. Next, select the magnification based on your requirement.  

Customizing Preferences
You can customize the preferences such as appearance of the screen, audio settings, capture, 
and so on in the Adobe Premiere Pro CS5.5 screen. Next, you will adjust the brightness of 
the Premiere interface.

1.	 Choose Edit > Preferences from the menu bar; a cascading menu is displayed, as shown 
in Figure 1-31.  
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Figure 1-28  The Source Monitor

Figure 1-30  The drop-down 
list  displayed on choosing the 
Select Zoom Level button 

Figure 1-29  The Program Monitor
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Figure 1-31  The cascading menu displayed

2.	 Choose the Appearance option from the cascading menu; the Preferences dialog box is 
displayed, as shown in Figure 1-32.

Figure 1-32  The Preferences dialog box

3.	 In the Brightness area, drag the slider; the brightness of the Adobe Premiere Pro CS5.5 
screen is changed.

	 You can choose the Default button to restore the appearance of the Adobe Premiere Pro 
CS5.5 screen to default.

4.	 After specifying the settings for appearance, choose the OK button.
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Tip: You can select any of the options from the Preferences dialog box and modify the 
settings based on your requirement.

Understanding and Customizing Keyboard Shortcuts
1.	 Move the cursor over a button or tool; the name of the button or tool with its keyboard 

shortcut is displayed on the tool tip, as shown in Figure 1-33.

2.	 Choose Window from the menu bar; a menu is displayed. This list displays the shortcut 
commands for some of the options, as shown in Figure 1-34.

Figure 1-33  The name and shortcut 
key displayed on the tool tip

Figure 1-34  Partial view of the Window menu displaying 
different options and their shortcuts

Note
You can select any option from the menu bar based on your requirement to view the shortcut 
commands.

3.	 Choose Edit > Keyboard Shortcuts from the menu bar; the Keyboard Shortcuts dialog 
box is displayed. By default, the Application option is selected in the drop-down list 
located below the Keyboard Layout Preset drop-down list. Also, all commands related 
to the Application option are displayed in the Command column.    

4.	 Click on the arrow on the left of the Window command in the Command column; various 
options under the Window command are displayed.

5.	 Select the Capture row; it is highlighted, as shown in Figure 1-35. Next, double-click on 
the Capture row; the edit mode is enabled.
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Figure 1-35  The Capture row highlighted

6.	 Now, press the J key on the keyboard; a warning message The Shortcut J was already in 
use by the Application > Shuttle Left command. That command will no longer have a 
keyboard shortcut is displayed at the bottom of the dialog box. 	

7.	 Make sure the edit mode is enabled for the Capture row. Next, press the CTRL+SHIFT+J 
keys. Now, choose the OK button from the Keyboard Shortcuts dialog box ; the 
CTRL+SHIFT+J keys are assigned to the Capture command.

  Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following buttons in the Welcome to Adobe Premiere Pro dialog box is used 
to create a new project?

	
		  (a) Open Project		  	 (b) Help
		  (c) New Project		 		  (d) All of the above

2.	 Which of the following panels is used to import all media files such as videos, audios, and 
stills to your project?

		  (a) Project 	 			   (b) Info
		  (c) Media Browser			   (d) Timeline

3.	 Which of the following panels is used to navigate through the media such as video, audio, 
and stills on your hard disk?

	
		  (a) Project	 			   (b) Effects
		  (c) Info					    (d) Media Browser

4.	 Which of the following panels is used to select, trim, and edit the clips in a sequence?
	
		  (a) Project	 			   (b) Tools
		  (c) Info					    (d) Media Browser
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5.	 The __________ tab in the New Project dialog box is used to specify the location of various 
types of files in Adobe Premiere Pro CS5.5.

6.	 The __________ button in the Project panel is used to display the preview of the selected 
video clip. 

7.	 The New Bin button is used to create a new folder in the Project panel to organize your 
files or assets. (T/F)

8.	 You cannot open an existing project by choosing the Open Project button in the Welcome 
to Adobe Premiere Pro dialog box. (T/F)

9.	 The Timeline panel is placed in the lower middle portion of the Adobe Premiere Pro 
CS5.5 screen. (T/F)

10.	 The Current time indicator (CTI) is used to specify the current frame displayed in the 
Source Monitor. (T/F) 

 Review Questions 
Answer the following questions:

1.	 Which of the following buttons in the Welcome to Adobe Premiere Pro dialog box is used 
to open the online help?

	
		  (a) Open Project		  	 (b) Help
		  (c) New Project		 		  (d) All of the above

2.	 Which of the following monitors is used to playback the sequence of clips that you have 
assembled in the Timeline panel?

		  (a) Source Monitor 	 		  (b) Reference Monitor
		  (c) Program Monitor			   (d) None of the above

3.	 Which of the following panels has a variety of audio and video effects that you can use in 
your projects?

	
		  (a) Effects				    (b) Info 
		  (c) Media Browser			   (d) History

4.	 Which of the following options in the menu bar is used to customize the preferences of 
Adobe Premiere Pro CS5.5? 

	
		  (a) Edit					    (b) Window 
		  (c) File		  			   (d) Title



1-24			                              Adobe Premiere Pro CS5.5: A Tutorial Approach
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

5.	 Which of the following options in the Preferences dialog box is used to set the brightness 
of the Adobe Premiere Pro CS5.5 screen?

	
		  (a) General				    (b) Media 
		  (c) Appearance		  		  (d) Capture

6.	 The Source Monitor is used to playback and prepare the video and audio clips that you 
need to use in your sequence. (T/F)

7.	 The Viewing area bar is used to specify the visible part of the sequence in the Timeline 
panel. (T/F) 

8.	 The ___________ is used to measure the sequence time horizontally.

9.	 The __________ is located at the bottom of the Time ruler and is used to specify the area 
of the sequence that you need to preview or export. 

 Exercise 

Exercise 1
Create a new project in Adobe Premiere CS5.5 as per the specifications of your video clip. 
Try to create your own workspace by dragging the panels to modify their sizes and to change 
their location. Create a new sequence in the same project.

Answers to Self-Evaluation Test
1. c, 2. a, 3. d, 4. b, 5. Scratch Disks, 6. Play-Stop Toggle, 7. T, 8. F, 9. T, 10. F.


