
Chapter 2
Introduction to ANSYS 

Workbench

Learning Objectives
After completing this chapter, you will be able to:
• Understand the types of systems.
• Understand different types of cells.
• Understand the Graphic User Interface of the Workbench window.
• Start a new project in ANSYS Workbench window.
• Add the first and subsequent analysis systems to a project.
• Set units for project.
• Use ANSYS Workbench Help.
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Introduction to ANSYS Workbench
Welcome to the world of Computer Aided Engineering (CAE) with ANSYS Workbench. If you 
are a new user, you will be joining hands with thousands of users of this Finite Element Analysis 
software package. If you are familiar with the previous releases of this software, you will be able 
to upgrade your designing skills with tremendous improvement in this latest release.

ANSYS Workbench, developed by ANSYS Inc., USA, is a Computer Aided Finite Element 
Modeling and Finite Element Analysis tool. In the Graphical User Interface (GUI) of ANSYS 
Workbench, the user can generate 3-dimensional (3D) and FEA models, perform analysis, 
and generate results of analysis. You can perform a variety of tasks ranging from Design 
Assessment to Finite Element Analysis to complete Product Optimization Analysis by using 
ANSYS Workbench. ANSYS also enables you to combine the stand-alone analysis system into 
a project and to manage the project workflow. 

The following is the list of analyses that can be performed by using ANSYS Workbench:

1. 	 Design Assessment
2. 	 Electric
3. 	 Explicit Dynamics
4. 	 Fluid Flow (CFX)
5. 	 Fluid Flow (FLUENT)
6. 	 Harmonic Response
7. 	 I.C. Engine
8. 	 Linear Buckling
9. 	 Magnetostatic
10. Modal 
11. Random Vibration
12. Response Spectrum
13. Rigid Dynamics
14. Static Structural
15. Steady-State Thermal
16. Thermal-Electric
17. Transient Structural
18. Transient Thermal

System Requirements
The following are minimum system requirements to ensure smooth functioning of ANSYS 
Workbench on your system:

Operating System: Windows 64-bit (Windows XP 64 SP2, Windows Vista 64 SP1, Windows •	
7, Windows HPC Server 2008 R2), Windows 32-bit (Windows XP SP2, Windows Vista SP1, 
Windows 7)
Platform: Intel Pentium class, Intel 64 or AMD 64•	

•	 Memory: 1 GB of RAM for all applications, 2GB for running CFX and FLUENT.
•	 DVD drive: For installing the software.
•	 Graphics adapter: Should be capable of supporting 1024x768 High Color (16-bit).
•	 Microsoft Internet Explorer 6.0 or higher
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Starting ANSYS Workbench 14.0 
To start ANSYS Workbench 14.0, choose Start > Programs/All Programs > ANSYS 14.0 > 
Workbench 14.0 from the Taskbar, refer to Figure 2-1. Alternatively, you can start ANSYS 
Workbench by double-clicking on the Workbench shortcut icon displayed on the desktop of 
your computer. After the necessary files are loaded and licenses are verified, the Workbench 
window along with the Getting Started window will be displayed on the screen, as shown in 
Figure 2-2.

Figure 2-1  Starting ANSYS Workbench using the Taskbar

The Getting Started window guides you to use the interface of ANSYS Workbench effectively. 
To close this window, choose the OK button.

Note
If you do not want the Getting Started window to be displayed the next time you start ANSYS 
Workbench, clear the Show Getting Started Message at Startup check box displayed at the 
bottom of the Getting Started window. In case, you need to display the Getting Started window 
while starting a new ANSYS Workbench session, choose Tools > Options from the Menu bar; 
the Options dialog box will be displayed. Choose Project Management from the left pane of 
the dialog box, if it is not chosen by default. Next, scroll down in the right pane and select the 
Show Getting Started Dialog check box and choose the OK button to save the changes and 
exit the dialog box.
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Figure 2-2  The Workbench window along with the Getting Started window

The Workbench window helps streamline an entire project to be carried out in ANSYS 
Workbench 14.0. In this window, one can create, manage, and view the workflow of the entire 
project created by using standard analysis systems. The Workbench window mainly consists of 
Menu bar, Standard toolbar, the Toolbox window, Project Schematic window, and the Status 
bar, refer to Figure 2-3. Various components of the Workbench window are discussed next.

Figure 2-3  The components of the Workbench window
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Toolbox Window
The Toolbox window is located on the left in the Workbench window. The Toolbox window lists 
the standard and customized templates or the individual analysis components that are used to 
create projects. To create a project, drag a particular analysis or component system from the 
Toolbox window and drop it into the Project Schematic window. Alternatively, double-click 
on a particular analysis or component system in the Toolbox window to add it to the Project 
Schematic window and to create the project.

Note
The double-click action always adds new system to the project, whereas dragging and dropping 
the system from the Toolbox window enables you to specify location of the new system in the 
Project Schematic window. Based on the specified location, you can create data sharing with 
the existing systems. You will learn more about sharing data between different systems in the 
Project Schematic window in later chapters.

The Toolbox window comprises four toolboxes: Analysis Systems, Component Systems, 
Custom Systems, and Design Exploration. The components of these toolboxes are discussed 
next.

Analysis Systems Toolbox
The Analysis Systems toolbox is displayed expanded in the Toolbox

Figure 2-4  The Analysis 
Systems toolbox displaying 
various analysis systems 
in it

 
window, by default. It contains predefined templates for different 
types of analyses that can be carried out in ANSYS Workbench 14.0. 
Each predefined template consists of all the components that are 
used to perform a particular type of analysis. For example, the 
Static Structural analysis system of the Analysis Systems toolbox 
is used to carry out the Static Structural analysis. When you add 
this system in the Project Schematic window, it contain all the 
components that are necessary to carry out the Static Structural 
analysis. Figure 2-4 shows the Analysis Systems toolbox with 
different types of analysis systems available in ANSYS Workbench. 
These analysis systems are discussed next.

Design Assessment
This analysis system is used to perform a combined solution 
for static and transient structural analyses. It also performs 
post-processing through a script using additional data 
associated with the geometry.

Electric
This analysis system is used to analyze steady-state electric 
conduction. 

Explicit Dynamics
This analysis system is used to identify the dynamic response of a component under 
stress wave propagation, or time-dependent loads or impacts. It is also used for modal 
mechanical phenomena that are highly non-linear.
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Fluid Flow (CFX)
This system allows users to carry out flow analysis of compressible and incompressible 
fluids. It is also used to analyze heat transfer in fluids. 

Fluid Flow (FLUENT)
Like Fluid Flow (CFX), Fluid Flow (Fluent) system is also used to carry out fluid flow 
analysis of compressible and incompressible fluids and their heat transfer analysis.

Harmonic Response
Harmonic response is the response of a system under a sustained cyclic load. Harmonic 
Response analysis system is used to analyze a system working under periodic or sinusoidal 
loads. This analysis helps in determining whether a particular structure will be able to 
withstand resonance, fatigue, and other effects of forced vibration.

IC Engine
This analysis system helps determine the performance of the whole system of an IC engine. 
It takes into consideration the various fluid properties, moving components, and electric 
and electronic components inside an engine. 

Linear Buckling
This analysis system is used to evaluate the buckling strength of a system under external 
loads.

Magnetostatic 
This analysis system is used to analyze the magnetic field developed due to the presence 
of a temporary or permanent magnet.

Modal
Modal analysis is the study of dynamic properties of a model, subjected to vibrations. 
Modal analysis system in ANSYS Workbench helps in determining the frequencies and 
mode shapes of a model.  

Random Vibration
This analysis is carried out to determine the reaction of a structure or a component to 
changing frequencies of vibrations. Many components experience vibrations which are 
random in nature. This analysis system is used to determine the responses of structures 
that are exposed to such varying or random vibrations.

Response Spectrum
Response Spectrum analysis system is similar to Random Vibration analysis system and 
is used after a transient analysis is done.

Rigid Dynamics
Rigid Dynamics analysis system is used to determine the response of a rigid body or a 
mechanism consisting of rigid bodies. Response of a robot mechanism is an example of 
rigid body analysis.
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Static Structural
The Static Structural analysis system is used to determine the response of a structure 
subjected to static loading conditions. The loads in this case are assumed to produce 
no or negligible time based loading characteristics. Using this type of analysis, 
displacement, stresses, and deformations of structures under static loading conditions 
can be determined.

Steady-State Thermal
Steady-state thermal analysis system is used to determine the temperature, thermal 
gradient, heat flow rates and heat fluxes under the influence of thermal loading which 
remains constant with time and are static in nature. 

Thermal-Electric
Thermal-Electric analysis system is used to simulate thermal and electric fields. 

Transient Structural
Transient Structural analysis system is used to determine responses of structures under 
the action of time dependent variables. Using this analysis, time-varying displacement, 
stresses and strains can be determined. 

Transient Thermal
Transient Thermal analysis system is used to determine the temperature and other thermal 
variables of a structure that vary over time. 

Component Systems Toolbox
By default, the Component Systems toolbox is displayed in collapsed state in the Toolbox 
window. To expand the Component Systems toolbox, click on the plus sign (+) located on 
the left of the Component Systems title bar. The components displayed in the Component 
Systems toolbox are the basic blocks of a project and form only a part of the analysis system, 
such as Geometry (used to create a model for analysis), Mesh (used to generate FEA model), 
Results (used to visualize the results of analysis in the desired form), and so on. Figure 2-5 
shows the Components Systems toolbox with various components displayed in it.

Figure 2-5  The Component 
Systems toolbox



2-8					     ANSYS Workbench: A Tutorial Approach
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Custom Systems Toolbox
By default, the Custom Systems toolbox is also displayed in collapsed state in the Toolbox. 
To expand this node, click on the plus sign (+) displayed on the left of the Custom Systems 
title bar, refer to Figure 2-6. The systems in the Custom Systems toolbox are used to carry 
out standard coupled analysis, in which the input and output data of one analysis are used 
as input for the next analysis. For example, the Pre-Stress Modal system is used carry out 
Static Structural analysis followed by a Modal analysis. Similarly, the FSI: Fluid Flow (CFX) 
-> Static Structural custom system is used to carry out a Fluid Flow analysis in CFX followed 
by a Static Structural analysis.

To add a custom system to the Project Schematic window, double-click on it in the Custom 
Systems toolbox in the Toolbox window. Figure 2-7 shows FSI: Fluid Flow (CFX) -> Static 
Structural custom system added to the Project Schematic window. This figure illustrates two 
different systems sharing the same geometry. This type of sharing is done if a single project 
requires various analysis types for the same geometry. You will learn about adding systems to 
the Project Schematic window later in this chapter. 

Figure 2-6  The Custom 
Systems toolbox

Figure 2-7  The FSI: Fluid Flow (CFX) -> Static Structural 
custom system added to the Project Schematic window

Design Exploration Toolbox
By default, the Design Exploration toolbox is displayed in collapsed state in the Toolbox 
window. Expand this toolbox by following the procedure discussed earlier. The options in 
the Design Exploration toolbox are used to explore a component, so that the design of 
the component can be further optimized by changing the design variables based on the 
performance of the product, refer to Figure 2-8. 

You can control the display of elements in the Toolbox.

Figure 2-8  The Design Exploration 
toolbox

 
To do so, choose the View All / Customize... button 
displayed at the bottom of the Toolbox window; the 
Toolbox Customization window will be displayed, as 
shown in Figure 2-9. In this window, some of the check 
boxes are selected, indicating that the corresponding 
element will be displayed in the Toolbox window. Clear 
the check box corresponding to those elements that 
you do not want to be displayed in the Toolbox 
window. 
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Figure 2-9  The Toolbox Customization window

Project Schematic Window
The Project Schematic window helps manage an entire project. It displays the workflow of 
entire analysis project. To add an analysis system to the Project Schematic window, drag the 
analysis system from the Toolbox window and drop it into the green-colored box displayed in 
the Project Schematic window, as shown in Figure 2-10 and 2-11.  Alternatively, double-click 
on an analysis system in the Toolbox window to include it in the Project Schematic window. 
You can also add an analysis system to the Project Schematic window by using the shortcut 
menu displayed on right-clicking in the Project Schematic window. The procedure of adding 
an analysis system by using the shortcut menu is discussed later in this chapter.	

Figure 2-11  The Static Structural analysis 
system open in the Project Schematic window 

Figure 2-10  Dragging the Static Structural 
analysis system into the Project Schematic 
window
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In the Project Schematic window, when you click on the down arrow available at the top 
right corner, a flyout is displayed with various options to close, float, restore, minimize, and 
maximize the Project Schematic window, refer to Figure 2-12.

Figure 2-12  Partial view of the Project Schematic window with the flyout displayed

Each time you drag and drop an analysis system or an item into the Project Schematic window, 
a system is formed. Each system, consists of cells which are used to carry out various tasks within 
a system. You can add more than one systems in the Project Schematic window by dragging 
and dropping them from the Toolbox window, as per the requirement. After adding systems 
to the Project Schematic window, you can share the data available in the cells of one system 
with the corresponding cells of another system. A common example of systems sharing same 
kind of data among various cells of different systems is shown in Figure 2-13.

Figure 2-13  Partial view of the Project Schematic window showing sharing of 
cells among two different analysis systems

 

Note
You will learn about the Project Schematic window, systems, and cells in detail later in this 
chapter.

Menu Bar
Menu bar is located on the top of the Workbench

Figure 2-14  The Menu bar

 
window and contains various options such as File, View, 
Tools, and so on. These options enable you to control 
and manage the files of the current project. Figure 2-14 
shows the Menu bar in the Workbench window. The 
options available in various menus will be discussed in detail later in this chapter. 

Standard Toolbar
The Standard toolbar is a collection of the frequently used tools in ANSYS Workbench 14.0 
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and is shown in Figure 2-15. The tools available in the Standard toolbar are also available in 
the Menu bar. 

Figure 2-15  The Standard toolbar

The various tools available in the Standard toolbar are New, Open, Save, Save As, Import, 
Reconnect, Refresh Project, Update Project, and so on. You can use these tools to create 
new projects, open existing ones, save a project, save a project to a different location with a 
different name, import a project from another source, refresh project status after changes are 
made to it, update a project to its latest status and so on.

Shortcut Menu
In ANSYS Workbench, you can invoke most of the

Figure 2-16  The shortcut menu displayed 
by right-clicking on the Geometry cell in the 
Project Schematic window  

 
tools by using a shortcut menu displayed on 
right-clicking. The shortcut menus displayed are 
context sensitive, that is, the context in the shortcut 
menus will change depending upon the place 
where you right-click to invoke it. You can 
right-click anywhere in the Workbench window to 
display a shortcut menu. Some of the options in a 
shortcut menu display an arrow on their right. This 
arrow indicates that one more menu will be 
displayed on choosing this option. Figure 2-16 
shows the shortcut menu that is displayed by 
right-clicking on the Geometry cell of the Static 
Structural system in the Project Schematic 
window.

WORKING ON a New Project
To start working on a new project, you need to add an appropriate analysis or component 
system to the Project Schematic window. 

Adding a System to a Project
After starting a new project, it is necessary to define the tasks to be carried out in ANSYS 
Workbench 14.0. To start a new analysis, you need to add an analysis system to the Project 
Schematic window, as shown in Figure 2-17. There are many ways to add a system to a project. 
They are discussed next.

Adding a System by Drag and Drop
To add a system to a project by dragging and dropping, pick the required system template 
from the Toolbox window and then drag the cursor to the Project Schematic window; the 
green rectangular area of dash lines will be displayed, representing the location where the 
picked analysis system can be dropped. Move the cursor over the green rectangular area; the 
green rectangle will convert into a red rectangle of solid lines, refer to Figure 2-17. Drop the 
system in the red box; the system will be added to the project and will be displayed in the 
Project Schematic window.
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Figure 2-17  Adding an analysis system by drag and drop

Note
After adding the first analysis system into the Project Schematic window, when you drag the 
next analysis system from the Toolbox window to add to the Project Schematic window, more 
then one green rectangular areas of dash lines will be displayed, representing the possible locations 
where you can drop analysis.

Adding a System by Double-clicking
You can also add an analysis system by double-clicking the left mouse button. To do so, 
double-click on the system that has to be added to the project; the system will be automatically 
added to the Project Schematic window.

Note
If an analysis system already exists in a project and then you double-click to add a new system, 
it will be added below the existing one.

Adding a System Using the Shortcut Menu
You can also add an analysis system by using the shortcut menu. To do so, right-click on the 
Project Schematic window; a shortcut menu will be displayed. Using this shortcut menu, you 
can add analysis, component, and custom systems to the Project Schematic window. To add an 
analysis system, choose the New Analysis Systems option from the shortcut menu; a flyout will 
be displayed. Choose the desired analysis system from the flyout to add it to the project. 

To add a new component system in the project, choose the New Component Systems option 
from the shortcut menu; a flyout will be displayed. Next, choose the desired component system 
from the flyout to add to the Project Schematic window, refer to Figure 2-18.
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Similarly, to add a new custom system or a new design exploration system into the Project 
Schematic window, choose the New Custom Systems or New Design Exploration option, 
respectively from their respective shortcut menu. Next, choose the desired option from the 
flyout to add to the Project Schematic window.

Figure 2-18  Choosing the Static Structural 
Analysis System from the shortcut menu

Tip. After a system is added to the project, it is now important to define the cells 
that are displayed in respective systems. The most common types of cells that exist 
in a system are discussed later in this chapter.

Renaming a System
After a system is added to the Project Schematic window,

Figure 2-19  Choosing the Rename 
option from the shortcut menu

 
its name will be highlighted at the bottom of the system. 
Specify a name for the system and press ENTER. You can 
also rename an existing project by double-clicking on the 
name of the current project. Alternatively, click on the black 
down-arrow displayed at the upper left corner of the 
analysis system; a flyout will be displayed. Choose the 
Rename option from this flyout, refer to Figure 2-19; the 
name of the system will be highlighted. Specify a name to 
the system. 
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Deleting a System from a Project
To delete a system from the Project Schematic window, right-click on its name displayed in 
the title bar; a shortcut menu will be displayed, refer to Figure 2-20. Choose Delete option 
from the shortcut menu; the ANSYS Workbench message box will be displayed, as shown in 
Figure 2-21. Choose the OK button from this message box; the selected system will be deleted 
from the project. Alternatively, click on the down-arrow displayed at the upper left corner of 
the system; a flyout will be displayed. Choose the Delete option from this flyout to delete the 
system from the project.

Figure 2-21  The ANSYS Workbench message boxFigure 2-20  Choosing the Delete option 
from the shortcut menu

 

Duplicating a System in a Project
To duplicate a system, select the down arrow available at the top left corner of the 
selected system; a flyout is displayed, refer to Figure 2-20. Choose the Duplicate option 

from the flyout to duplicate it.

Note
While duplicating a system, all the cells will be duplicated except the Result cell.

Saving the Current Project
Whenever you start a new analysis project, the title bar of the Workbench window 
displays Unsaved Project - Workbench. This indicates that the current project is 

not saved yet. To save the current project, choose the Save button from the Standard toolbar. 
Alternatively, choose the Save option from the File menu; the Save As dialog box will be 
displayed, as shown in Figure 2-22. You can also invoke the Save As dialog box by pressing 
the CTRL and S keys together. In this dialog box, browse to the location where you want to 
save the current project and then specify its name in the File name edit box. Next, choose the 
Save button; the project will be saved at the specified location. After saving the project, the 
title bar of the Workbench window will display the name that you have specified while saving 
the project.  
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Figure 2-22  The Save As dialog box

Note
If you have already saved the project, the Save As dialog box will not be displayed on  choosing 
the Save button.

If you want to save an opened project with a different name or at a different location, choose 
the Save As button from the Standard toolbar; the Save As dialog box will be displayed, refer 
to Figure 2-23. Specify a new name and then choose the Save button from this dialog box; the 
same project will be saved with the new name and will become the current project.

Opening A Project
To open an existing project, choose the Open button from the Standard toolbar; 
the Open dialog box will be displayed, as shown in Figure 2-23. Browse to the 

location where the project file is saved, select the *.wbpj file, and then choose the Open button 
from this dialog box. The selected project file will be opened and its name will be displayed 
on the title bar of the Workbench window. Alternatively, choose the Open option from the 
File menu.

Archiving the Project Data
If you want to move the project data from one system to another, you can archive all project 
related data in a single zip file. This zip file contains all files and folders necessary to run the 
project on another computer, such as project file (*.wbpj) and project folder (name_files). To 
archive a project, choose File > Archive from the Menu bar; the Save Archive dialog box 
will be displayed, refer to Figure 2-24. By default, name is displayed as the name of the file in 
the File name edit box, where, name is the project name of the current project. If you want to 
assign a different name to the archive file, specify it in the File name edit box. 
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Figure 2-23  The Open dialog box

Figure 2-24  The Save Archive dialog box

Next, specify the location where you want to save the archive file and choose the Save button 
from the Save Archive dialog box; the Archive Options dialog box will be displayed, as 
shown in Figure 2-25. If you do not want to include the result and the solution file or some 
imported file that has not been created in the project, clear the respective check box from 
the Archive Options dialog box. Next, choose the Archive button from this dialog box; the 
zipped archive file will be created at the specified location. Transfer this zip file to any system 
and restore the project files.
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Extracting the Archive File
To extract project files from the archived zip file,

Figure 2-25  The Archive Options dialog box

 
choose File > Restore Archive option from the 
Menu bar; the Select Archive to Restore dialog 
box will be displayed. Select the archive file to 
be restored and then choose the Open button 
from this dialog box; Save As dialog box will 
be displayed. Specify the name of the project 
and the location where you want to save the 
archive file and then choose the Save button 
from the Save As dialog box. On doing so, the 
archived files will get extracted with the 
specified name of the project to the specified location. Also, you will notice that the extracted 
project file (*.wdpj) is open in the Workbench window.

Units in ANSYS Workbench
In ANSYS Workbench, you can use any of the following predefined unit systems:

1. Metric (kg,m,s,°C,A,N,V) Unit System 
	 Mass = Kilogram (kg)		  Temperature = Degree Celsius (°C)		
	 Length = Meter (m)		  Current = Ampere (A)
	 Time = Second (s)		  Force = Newton (N)
	 Voltage = Volts (V)

2. Metric (tonne,mm,s,°C,mA,N,mV) Unit System
	 Mass = Tonne			   Temperature = Degree Celsius (°C)		
	 Length = Millimeter (mm)	 Current = Milliampere (mA)
	 Time = Second (s)		  Force = Newton (N)
	 Voltage = Millivolt (mV)

3. U.S. Customary (lb,in,s,°F,A,lbf,V) Unit System
	 Mass = Pound (lb)		  Temperature = degree Celsius (°C)		
	 Length = Inch (in)		  Current = Ampere (A)
	 Time = Second (s)		  Force = Pound (lbf)
	 Voltage = Volts (V)

4. SI (kg,m,s,K,A,N,V) Unit System
	 Mass = Kilogram (kg)		  Temperature = Kelvin (K)		
	 Length = Meter (m)		  Current = Ampere (A)
	 Time = Second (s)		  Force = Newton (N)
	 Voltage = Volts (V)

5. U.S. Engineering (lb,in,s,R,A,lbf,V) Unit System
	 Mass = Pound (lb)		  Temperature = Renkine (R)		
	 Length = Inch (in)		  Current = Ampere (A)
	 Time = Second (s)		  Force = Pound (lbf)
	 Voltage = Volts (V)



2-18					     ANSYS Workbench: A Tutorial Approach
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Metric (kg,m,s,°C,A,N,V) unit system is the default unit system that is assigned to a project. 
However, you can change the unit system for the current project or set the default unit system, 
to be assigned to any new project.

ANSYS Workbench Database and File Formats
When you save a project, a project file is created with a name name.wbpj, where name can be 
any user specified name. In addition to the project file, a folder is also created with a name 
name_files. All other files relevant to the project are automatically saved in this folder under 
various sub folders such as, dp0, user_files, and so on.

In ANSYS Workbench, various files are created with different file extensions. To view all files 
associated with the current project, choose View > Files from the Menu bar; the Files window 
will be displayed, as shown in Figure 2-26.

Figure 2-26  The Files window

 

The Files window lists all files of the current project. The information displayed in the File 
window includes the following:

Figure 2-27  The Type Filter dialog box

1. Name and extension of the files.
2. The reference of the analysis component cell with 
which the file is associated.
3. The file size and its location.

To open a folder containing the selected files, 
right-click on the corresponding cell and then 
choose the Open Containing Folder option from the 
shortcut menu displayed. To filter in any particular 
type of file extension, right-click on any cell to display 
a shortcut menu. Next, choose the File Type Filter 
option from the shortcut menu; the Type Filter 
dialog box will be displayed, as shown in Figure 2-27. 
Select the check boxes displayed on the left of the 
desired file type from the Type Filter dialog box; the 
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list displayed in the File window will change dynamically based on the selection made in the 
Type Filter dialog box. After selecting the desired file types, choose the Ok button from the 
Type Filter dialog box to exit.

The following are some of the main file extensions used in ANSYS:

*.wbpj 	 = ANSYS Workbench project database file 
*.engd 	 = Engineering Data
*.agdb 	 = DesignModeler file
*.fedb 	 = FE Modeler files
*.cmdb 	 = Meshing file
*.mechdb= Mechanical file
*.rsx 	 = Mesh Morpher 
*.ad 	 = ANSYS AUTODYN
*.dxdb 	 = Design Exploration
*.bgd 	 = BladeGen 
*.db 	 = Mechanical APDL database file 
*.cas, *.dat, *.msh = FLUENT files
*.cfx, *.def, *.res, *.mdef, and *.mres = CFX files 
*.cmdb = CFX-Mesh files

Changing the Unit Systems 
You can change the unit system being used in the current project. To do so, choose the Units 
menu from the Menu bar; a menu with various options will be displayed. Select the desired 
unit system from the menu; a tick mark will be displayed on the left of the selected unit system, 
refer to Figure 2-28. 

Figure 2-28  The Units menu

In addition to the unit systems displayed in the Units menu, you can customize to add some 
more unit systems by using the Unit Systems dialog box. To invoke this dialog box, choose 
Units > Unit Systems from the menu bar; the Unit Systems dialog box will be displayed, 
as shown in Figure 2-29. All unit systems supported by ANSYS Workbench will be displayed 
under the Unit System column in the Unit Systems dialog box. If you select a unit system 
in this column, the units used for measuring various quantities will be displayed on the right 
pane in this dialog box. 
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Figure 2-29  The Unit Systems dialog box

ANSYS Workbench supports fifteen standard unit systems. However, by default only five 
standard unit systems are displayed under the Units menu. This is because the rest of the unit 
systems are suppressed in the Unit Systems dialog box, by default. To unsuppress a unit system, 
clear the corresponding check box under the Suppress column in the Unit Systems dialog 
box. Now onward, the unsuppressed unit system will be displayed in the Units menu.   

You can change the default unit system that is assigned to a new project. To do so, select the 
radio button corresponding to the desired unit system, in the Default column in the Unit 
Systems dialog box. Now onward, the specified unit system will become the default unit system 
for new projects. Select the radio button corresponding to the desired unit system under the 
Active Project column to make it the unit system for the current project.

If the standard unit systems given in ANSYS Workbench do not suit your requirement, you 
can customize a unit system according to your requirement by using the Unit Systems dialog 
box. To do so, select the unit system that closely fits your requirement under the Unit System 
column and then choose the Duplicate button from the Unit Systems dialog box; a new unit 
system will be added under the Unit System column with the default name Custom UnitSystem. 
Rename this system. Select the newly defined unit system; the corresponding measuring units 
will be displayed on the right pane. Click on the down-arrow displayed on the right of the 
units under the Unit column; a drop-down list will be displayed with all feasible units for the 
quantity to be measured. Select the desired units from this drop-down list. You can also export 
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custom units for the use of other users or import an already saved unit system by using the 
Export or Import button, from the Unit Systems dialog box. The imported or exported unit 
system files are saved in .xml format. To delete the selected customized unit system, choose 
the Delete button from the Unit Systems dialog box.

COMPONENTS OF A SYSTEM
An item that is added from the Toolbox window to the Project Schematic window is known 
as system and the constituent elements of the system are known as cells. Each cell of a system 
plays an important role in carrying out a project and are discussed next.

Engineering Data			   Geometry			   Model/Mesh
Setup					     Solution			   Results

Engineering Data Cell
The Engineering Data cell is used to define the material to be used in the analysis. To define 
the material, double-click on the Engineering Data cell; the workspace  corresponding to 
this the Engineering Data cell will be displayed, as shown in Figure 2-30. Alternatively, you 
can also invoke the Engineering Data workspace to specify the material by right-clicking 
on the Engineering Data cell and then choosing the Edit option from the shortcut menu 
displayed.

Figure 2-30  The Engineering Data workspace

Note
When you right-click on Engineering Data cell, the Edit option will be highlighted in the 
shortcut menu. This indicates that this is the most suitable action that can be taken. You can 
select an option from the shortcut menu as per the requirement. However, when you double-click 
on the Engineering Data cell, the most suitable action will be initiated directly.
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Geometry Cell
The Geometry cell is used to create, edit, or import the geometry that is used for analysis. To 
create a geometry for analysis, double-click on the Geometry cell; the DesignModeler window 
will be displayed. Alternatively, right-click on the Geometry cell and then choose the New 
Geometry option from the shortcut menu displayed, refer to Figure 2-31. Some important 
options in the shortcut menu that are specific to the Geometry cell are discussed next. 

Figure 2-31  The shortcut menu displayed 
on right-clicking on the Geometry cell 

The New Geometry option in the shortcut menu is used to start the DesignModeler window, 
where you can create geometry. This option will only be available if you have not defined a 
geometry. The Import Geometry option is used to import any existing geometry to the current 
analysis system. You can also import the geometry created in other CAD packages. The Edit 
Geometry option will only be displayed if a geometry is already associated with the current 
analysis system. When you choose this option, the geometry opens in the DesignModeler 
window for modification. The Replace Geometry option is used to replace the existing 
geometry that is associated with the analysis system with another geometry.

Note
To exit the DesignModeler window, choose File > Close DesignModeler from the Menu bar; 
the Workbench window will be displayed.

Model Cell
The Model cell will be displayed for mechanical analysis systems and is used to discretize 
geometry into small elements, apply boundary and load conditions, solve the analysis, and so 
on. On double-clicking on this cell, the Mechanical window will be displayed. In other words, 
this cell is associated with the Mechanical window. 
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Mesh Cell
The Mesh cell will be displayed for fluid flow analysis systems and is used to mesh the geometry. 
On double-clicking on this cell, the Meshing window will be displayed. In other words, this 
cell is associated with the Meshing window.  

Setup Cell
The Setup cell is used to define the boundary conditions of an analysis system, such as loads 
and constraints. This cell is also associated with the Mechanical workspace. 

Solution Cell
The Solution cell is used to solve the analysis problem based on the conditions defined in the 
cells above the Solution cell. This cell is also associated with the Mechanical workspace. 

Results Cell
The Results cell is used to display the results of the analysis in the user specified formats. This 
cell is also associated with the Mechanical workspace.

States of a cell in an Analysis System
All cells display some visual symbols on their right to indicate their current status. This 
helps the user understand the next step in the analysis process as well as understanding the 
overall status of an analysis, refer to Figure 2-32. The explanation of these symbols is given 
in Table 2-1.

Figure 2-32  Symbols for cell status

Table 2-1  Symbols and their meaning

Symbol Meaning Function

Attention required 
symbol

indicates an immediate requirement of 
action for a cell and a user cannot proceed 
further without fixing the cell

Unfulfilled indicates that the previous cells do not 
have sufficient or appropriate data
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Up to date indicates that the cell is up-to-date and 
the data in the cell is ready to be shared 
with other cells

Refresh required indicates that the data of the previous 
cells has been changed since last update 
and you need to refresh the cell with this 
symbol, refer to Figure 2-35

Input changes pending indicates that the data of the current cell 
will change on updation, if changes are 
done in the previous cells

Update required indicates that the input data of the cell has 
been changed and the output data needs 
to be updated

Refresh failed indicates that the last refresh process for 
the cell has failed

Update failed, update 
needed

indicates that the last update process for 
the cell has failed and you need to update 
it again

Update failed, attention 
needed    

indicates that the last update process 
has failed and the cell needs immediate 
attention.

Figure 2-33 shows an analysis system in which the geometry of the analysis model has been 
changed after performing the complete analysis. Therefore, the refresh required symbol is 
displayed against the Model cell. 

Figure 2-33  The Static Structural analysis 
system with the refresh required symbol annotated

 

Refreshing and Updating a Project
Refresh is a process in which ANSYS Workbench reads the entire modified 
data. To refresh the entire project, choose the Refresh Project button 

from the Standard toolbar. Alternatively, choose Tools > Refresh Project from the Menu 
bar.
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Note
When you refresh the entire project, the output data will not be recalculated based on the 
modifications made in the project.

Update is a process in which ANSYS Workbench refreshes the input data 
and recalculates the output data. To update the entire project, choose the 

Update Project button from the Standard toolbar. Alternatively, choose Tools > Update 
Project from the Menu bar.

You can also refresh or update a particular cell by choosing the respective option from the 
shortcut menu that is displayed on right-clicking on that particular cell. These options will 
only be available in the shortcut menu if that particular cell needs refreshing or updating. 

If you refresh a particular cell, you can get information about its effect on the cells below the 
specified cell, and if needed, you can make the required changes before updating the cell. 
Refreshing a cell before updating is useful in complex analysis systems, where updating can 
take more time compared to refreshing. 

Adding Second system to a Project
The second or the subsequent system can be added in the Project Schematic window in two 
ways, either as a stand-alone system or as a connected system that shares data with the existing 
analysis system. In a project, multiple stand-alone systems are preferred in case of performing 
analysis for various components of an assembly. In this way, analysis of all components of an 
assembly can be kept and managed in a single analysis project. The connected analysis systems 
are preferred more for conducting coupled analysis, where data from the first analysis system 
can be used or shared with the next analysis system.

As discussed earlier, to add a stand-alone system, double-click on the analysis system template 
in the Toolbox window; the new analysis system will get added in the Project Schematic window 
below the existing analysis system, as shown in Figure 2-34. Alternatively, use the shortcut 
menu or the drag and drop method to add a stand-alone system to the Project Schematic 
window.

Adding Connectors
There are two ways in which you can add connectors between cells of different systems in the 
Project Schematic window. In the first method, drag the cell from one system and drop it in 
the corresponding cell of another system; connectors will be added between the systems, which 
indicates that the data is shared. In the second method, drag the system from the Toolbox 
window to the Project Schematic window and move the cursor over the cell of the existing 
system with which you want to share the data; a red rectangle will be displayed on the right of 
the existing system with text written inside the rectangle. The text will give you information 
about the cells with which the data will be shared by the new system, as shown in Figure 2-35. 
Drop the selected analysis system over the desired cell of the existing analysis system; the new 
system will be added to the right of the existing analysis system and will share data from the 
specified cells. Figure 2-36 shows a new analysis system, the Linear Buckling analysis system, 
dropped over the Solution cell of the Static Structural analysis system. Note that the new 
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system will automatically share the necessary data from the cells that are above the cell over 
which you dropped the new analysis system.

Figure 2-35  Text reference of the cells to be sharedFigure 2-34  Two stand-alone 
systems added in the Project 
Schematic window

Figure 2-36  The Linear Buckling analysis system added as a connected system 
to the Static Structural analysis system

Specifying a Geometry for Analysis
In ANSYS Workbench, geometry can be specified in two different ways. In the first method, 
you can import a geometry created by using any other solid modeling software. In the 
second method, you can create a new geometry in the DesignModeler application of ANSYS 
Workbench. The procedure to create a new geometry is described next.



Introduction to ANSYS Workbench				     2-27

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Creating a Geometry
When a new system is added in the Project Schematic window, the next step is to create the 
geometry. To create a new geometry, right-click on the Geometry cell of the system; a shortcut 
menu will be displayed, refer to Figure 2-37. Choose New Geometry from the shortcut menu; 
the status bar will display the message Starting DesignModeler. After sometime, 
the DesignModeler window along with

Figure 2-37  The shorcut menu displayed on right-clicking 
on the Geometry cell

 
the ANSYS Workbench dialog box 
will be displayed. Specify the unit of 
length in the ANSYS Workbench 
dialog box and then choose the OK 
button to close it. After the ANSYS 
Workbench dialog box is closed, the 
DesignModeler window will be 
activated, refer to Figure 2-38.

Next, in the DesignModeler window, 
create a model according to your 
design requirements by using the 
tools available in this window. These 
tools will be discussed in detail in later 
chapters. After creating the model, 
close this window. On doing so, the 
model will be automatically saved in 
the ANSYS Workbench database. Also, 
a green color check mark will be displayed on the right of the Geometry cell of the analysis 
system in the Project Schematic window, indicating that the geometry requirement is satisfied 
for the current system. 

Figure 2-38  A typical DesignModeler window
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After the geometry is specified for the analysis, you need to fulfil the requirement of other 
cells in the system. The cell types in the system are context specific and are solely dependent 
on the type of system selected. 

In a system tree, you need to update the cells from top to bottom. For example, in a Static 
Structural analysis system, you need to satisfy the requirement of the Geometry cell before 
you move to the Model cell. 

Note
The detailed procedure of working through analysis component cells in an analysis system is 
given in later chapters. 
 

Using Help in ansys workbench
In ANSYS Workbench, there are different ways in which you can access help. These methods 
are discussed next.

ANSYS Workbench Help
You can get online help and documentation while working on ANSYS Workbench. To access 
the help, choose ANSYS Workbench Help from the Help menu of the Menu bar; the 
ANSYS 14.0 Help window will be displayed, as shown in Figure 2-39.  

Figure 2-39  The ANSYS Help window

The ANSYS 14.0 Help window is divided into two parts: Navigation pane (left pane) and 
Document pane (right pane). The Navigation pane consists of the Contents, Index, and 
Search tabs and the Document pane contains the information related to the topic selected in 
the Navigation pane. When the Contents tab is selected, the list of topics covered in ANSYS 
Help is listed in the Navigation pane of the ANSYS 14.0 Help window. When a particular 
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topic is selected in the left pane, the corresponding information or help is displayed in the 
Document pane. You can open multiple help documents in the Document pane. To do so, 
choose the plus sign (+) displayed on the last tab in the Document pane; a new tab will be 
added in the Document pane, refer to Figure 2-39. Now, open a new document related to 
your topic of interest in this tab.

Apart from the ANSYS 14.0 Help window, ANSYS Workbench offers two more ways to access 
help and they are discussed next.

Quick Help
Quick Help is available for all the cells of an analysis or component system in the Project 
Schematic window. Click on the blue inclined arrow at the bottom right corner of any cell; a 
flyout will be displayed with a short description on the current status of the cell. This flyout 
contains some relevant links that when clicked, will directly open the related document in the 
ANSYS Help window, refer to Figure 2-40.

     

Context Sensitive Help
Context sensitive help lists the help topics of the ANSYS Help window, related to the currently 
active option. To open the ANSYS Help window, choose Help > Show Context Help from the 
Menu bar; the Sidebar Help window will be displayed on the right of the Project Schematic 
window, as shown in Figure 2-41. Alternatively, press the F1 key to open the Sidebar Help 
window.

Figure 2-40  The Quick Help Figure 2-41  The Sidebar Help window
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Exiting ANSYS Workbench
To exit the Workbench window, choose File > Exit from the Menu bar. If the current 
project is not saved or if you have made any changes after the project was last saved, then on 
choosing the Exit option, the ANSYS Workbench message box will be displayed, as shown in 
Figure 2-42. Choose the Yes button from this message box to save the changes made in the 
current project and exit the Workbench window. Choose the No button to discard changes 
and close the ANSYS Workbench window. Choose the Cancel button from this message box 
to cancel the exit process.

Figure 2-42  The ANSYS Workbench message box

 

Tutorial
Tutorial 1

In this tutorial, you will start ANSYS Workbench and add a new Static Structural analysis system 
to the Project Schematic window. After adding the analysis system, save the project with the 
name c02_ansWB_tut01 at the location C:\ANSYS_WB\c02\Tut01. 	  (Expected time: 15 min)	

	 The following steps are required to complete this tutorial:

a.	 Create the project folder.
b.	 Start ANSYS Workbench 14.0.
c.	 Add the Static Structural analysis system to the Project Schematic window. 
d.	 Save the project and exit the ANSYS Workbench session.

Creating the Project Folder
	 Before you start ANSYS Workbench, you need to create a project folder in which you will 

save all your projects.

1.	 Create a folder with the name ANSYS_WB at the location C:\.
	
	 You will save all your projects in the folder ANSYS_WB.
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Starting ANSYS Workbench 14.0
	 First, you need to start ANSYS Workbench and then add the analysis system to the project.

1.	 Choose All Programs > ANSYS 14.0 > Workbench 14.0 from the Start menu; the 
Workbench window along with the Getting Started window is displayed. 

The Getting Started window is displayed when ANSYS Workbench is started. The Getting 
Started window gives information about the procedure to be used for carrying out an analysis. 
When the ANSYS Workbench session is started, the Getting Started window is displayed by 
default. To stop this window from display the next time you start a new session of ANSYS 
Workbench, clear the Show Getting Started Message at Startup check box from the Getting 
Started window.

2.	 Choose OK in the Getting Started window to close the window.

3.	 Choose the Save button from the Standard toolbar; the Save As dialog box is 
displayed.	

4.	 Browse to the location C:\ANSYS_WB and then create a folder with the name c02. 

5.	 Now, create another folder with the name Tut01 under the c02 folder and then open the 
newly created folder by double-clicking on it.

6.	 Enter c02_ansWB_tut01 in the File name edit box and then choose the Save button from 
the Save As dialog box; the project is saved with the specified name.

Adding Static Structural Analysis System to the Project
	 Next, you need to add the Static Structural analysis system to the project.

1.	 Double-click on the Static Structural option displayed in the Analysis Systems toolbox in 
the Toolbox window; the Static Structural system is added to the project and is displayed 
in the Project Schematic window.

Note
The Static Structural analysis system can also be added by dragging it from the Toolbox window 
and then dropping it on the Project Schematic window. You can also add it by using the options 
in the shortcut menu that is displayed on right-clicking in the Project Schematic window. 

2.	 Once the project is added to the Project Schematic window, its name is highlighted at the 
bottom of the analysis system in blue. If it is not highlighted, double-click on the name 
and enter c02_ansWB_tut01, as shown in Figure 2-43. The analysis system is renamed.
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Figure 2-43  The Static Structural analysis system added to the project

Saving the Project and Exiting ANSYS Workbench
	 Now, you need to save the project and exit ANSYS Workbench.

1.	 Choose the Save button to save the project with the name c02_ansWB_tut01.

2.	 Choose Exit from the File menu; the current ANSYS Workbench session is closed.

 Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of this  
chapter:

1.	 You can add an analysis system to the Project Schematic window by double clicking on 
the desired component in the Analysis Systems toolbox. (T/F)

2.	 The geometry for an analysis can not be imported from an external software package. (T/F)

3.	 The Results cell is used to display the contents of an analysis system. (T/F)

4.	 If you choose an option that has 3 dots (...) on its right then a dialog box corresponding 
to that option is displayed. (T/F)

5.	 The archived project files are saved in __________ format.

6.	 To view all files related to the current project, choose __________ from the Menu bar.

7.	 Press the __________ key to open the Sidebar Help window.

8.	 In the Workbench window, you can change the units by using the options available in the 
__________ menu.
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 Review Questions
Answer the following questions:

1.	 To create a connected system for coupled analysis, double-click on an analysis system in 
the Toolbox. (T/F) 

2.	 The *.wbpj file is the default extension for the project files in ANSYS Workbench 14.0. 
(T/F)

3.	 A project consists of systems and a system  consists of cells. (T/F)

4.	 You can specify a unit system from the Menu Bar. (T/F)

5.	 The Engineering Data cell is used to define the geometry to be used in an analysis project. 
(T/F)

6. 	 Which one of the following unit systems is assigned to a project by default?
	 (a)	 Metric (kg,m,s,°C,A,N,V)
	 (b)	 SI (kg,m,s,K,A,N,V)
	 (c)	 U.S. Engineering (lbm,in,s,R,A,lbf,V)
	 (d)	 U.S. Customary (lbm,in,s,°F,A,lbf,V)

7.	 An ANSYS project file is saved with __________ extension. 

8.	 The __________ environment is used to create the geometry to be used in an analysis. 

9.	 The customized analysis systems are added under the ___________ toolbox in the Toolbox 
window.
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Exercise
Exercise 1

Start ANSYS Workbench and add a new thermal analysis system to the project, 
as shown in Figure 2-44. Save the project with the name c02_exr01 at the location 
C:\ANSYS_WB\c02\Exr.				     		    (Expected time: 10 min)

Hint: Use the Thermal-Stress analysis system displayed under the Custom Systems toolbox 
in the Toolbox. 

Figure 2-44  The Thermal-Stress analysis system added to the Project 
Schematic window

Answers to Self-Evaluation Test
1. T, 2. F, 3. F, 4. T, 5. *.zip, 6. View > Files, 7. F1, 8. Units


