Chapter 1

Introduction

Learning Objectives

After completing this chapter, you will be able to:

* Understand different modules of Autodesk Inventor.

* Understand how to open a new part file in Autodesk Inventor.
* Understand various terms used in sketching environment.

* Understand the use of various hotkeys.

* Customize hotkeys.

* Modify the color scheme in Autodesk Inventor:
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INTRODUCTION TO Autodesk Inventor 2012

Welcome to the world of Autodesk Inventor. If you are new to the world of three-dimensional
(3D) design, then you have joined hands with thousands of people worldwide who are already
working with 3D designs. If you are already using any other solid modeling tool, you will find
this solid modeling tool more adaptive to your use. You will find a tremendous reduction in
the time taken to complete a design using this solid modeling tool.

Autodesk Inventor is a parametric and feature-based solid modeling tool. It allows you to
convert the basic two-dimensional (2D) sketch into a solid model using very simple, but highly
effective modeling options. This solid modeling tool does not restrict its capabilities to the
3D solid output, but also extends them to the bidirectional associative drafting. This means
that you only need to create the solid model. Its documentation, in the form of the drawing
views, is easily done by this software package itself. You just need to specify the required view.
This solid modeling tool can be specially used at places where the concept of “collaborative
engineering” is brought into use. Collaborative engineering is a concept that allows more
than one user to work on the same design at the same time. This solid modeling package
allows more than one user to work simultaneously on the same design.

As a product of Autodesk, this software package allows you to directly open the drawings of
the other Autodesk software like AutoCAD, Mechanical Desktop, AutoCAD LT, and so on. This
interface is not restricted to the Autodesk software only. You can easily import and export the
drawings from this software package to any other software package and vice versa.

To reduce the complicacies of design, this software package provides various design
environments. This helps you capture the design intent easily by individually incorporating the
intelligence of each of the design environments into the design. The design environments that
are available in this solid modeling tool are discussed next.

Part Module

This is a parametric and feature-based solid modeling environment and is used to create
solid models. The sketches for the models are also drawn in this environment. All applicable
constraints are applied to the sketch automatically while drawing. You do not need to invoke an
extra command to apply them. Once the basic sketches are drawn, you can convert them into
solid models using simple, but highly effective modeling options. One of the major advantages
of using Autodesk Inventor is the availability of the Design Doctor. The Design Doctor is used
to calculate and describe errors, if any, in the design. You are also provided with the remedy
for removing errors such that the sketches can be converted into features. The complicated
features can be captured from this module and can later be used in other parts. This reduces
the time taken to create the designer model. These features can be created using the same
principles as those for creating solid models.

Assembly Module

This module helps you create the assemblies by assembling multiple components using
assembly constraints. This module supports both the bottom-up approach as well as the
top-down approach of creating assemblies. This means that you can insert external components
into the Assembly module or create the components in the Assembly module itself. You are
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allowed to assemble the components using the smart assembly constraints. All the assembly
constraints can be added using a single dialog box. You can even preview the components
before they are actually assembled. This solid modeling tool supports the concept of making a
part or a feature in the part adaptive. An adaptive feature or a part is the one that can change
its actual dimensions based upon the need of the environment.

Presentation Module

A major drawback of most solid modeling tools is their limitation in displaying the working of
an assembly. The most important question asked by the customers in today’s world is how to
show the working of any assembly. Most of the solid modeling tools do not have an answer to
this question. This is because they do not have proper tools to display an assembly in motion.
As aresult, the designers cannot show the working of the assemblies to their clients. In cases
where it is necessary to show the animation, they have to take the help of some other software
packages such as 3D Studio MAX or 3D Studio VIZ. However, keeping this problem in mind,
this software package provides a module called the Presentation module. In this module,
you can animate the assemblies created in the Assembly module and view their working. You
can also view any interference during the operation of the assembly. The assemblies can be
animated using easy steps.

Drawing Module

This module is used for the documentation of the parts or assemblies in the form of drawing
views. You can also create the drawing views of the presentation created in the Presentation
module. All parametric dimensions, added to the components in the Part module during the
creation of the parts are displayed in the drawing views in this module.

Sheet Metal Module

This module is used to create the sheet metal component. When you invoke a sheet metal
file, the sketching environment is active by default. You can draw the sketch of the base sheet
in this module and then proceed to the sheet metal module to convert it into the sheet metal
component.

GETTING STARTED WITH Autodesk Inventor

Install Autodesk Inventor on your system; the Autodesk Inventor Professional 2012 shortcut
icon will automatically be created on the desktop. Double-click on this icon to start the software.
You can also start Autodesk Inventor from the taskbar by choosing Start > All Programs>
Autodesk > Autodesk Inventor 2012 > Autodesk Inventor Professional 2012, as shown in
Figure 1-1.

The system will prepare for starting Autodesk Inventor by loading all required files. After all
required files have been loaded, the initial screen of Autodesk Inventor Professional 2012 will
be displayed, as shown in Figure 1-2. You can view the recent enhancement and information
related to Autodesk Inventor 2012 by choosing the buttons displayed on the Ribbon.
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Figure 1-2 Initial screen display of Autodesk Inventor Professional 2012
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To start a new part file, choose the New tool from the Launch panel of the Get Started tab in
the Ribbon; the New File dialog box will be displayed, as shown in Figure 1-3. Alternatively,
you can start a new part file by using the Quick Launch area of the Open dialog box, see
Figure 1-4. The Open dialog box can be invoked by choosing the Open button from the Get
Started tab of the Ribbon. When you start a new session of Autodesk Inventor Professional
2012, only the Start a new file button will be activated in the Quick Launch area of the Open
dialog box. Choose the Start a new file button; the New File dialog box will be displayed, refer
to Figure 1-3. Choose the Metric tab from the New File dialog box and then double-click on
the Standard (mm).ipt template to open a default metric template. As a result, a new part
file with the default name Partl.ipt will be opened and you can start working in this file. Also,
the sketching environment will be invoked, as shown in Figure 1-5. This figure also displays
various components of this screen.

[ New File EXT

Default | English | Metric | Mold Design |

@ A & G F

Sheet Metal.ipt Standard.dwg Standard.iam Standard.idw  Standard.ipn

7

Standard.ipt  Weldment.iam

Project File: | Default.ipj ~| | Projects... |
Quick Launch

@ N

Figure 1-3 The New File dialog box

It is evident from Figure 1-5 that the screen of Autodesk Inventor is quite user-friendly. Apart
from the components shown in Figure 1-5, you are also provided with various shortcut menus,
which are displayed upon right-clicking the mouse in the drawing area. The type of the
shortcut menu and its options depend on where or when you are trying to access this menu. For
example, when you are inside any command, the options displayed in the shortcut menu will
be different from the options displayed when you are not inside any command. The different
types of shortcut menus will be discussed when they are used in the textbook.
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Figure 1-5 The sketching environment of Autodesk Inventor and its main components
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Quick Access Toolbar

This toolbar is common to all design environments of Autodesk Inventor. However, some of
these options will not be available when you start Autodesk Inventor for the first time. You
need to add them using the down arrow given on the right of the Quick Access Toolbar, as
shown in Figure 1-6. Some of the important options in this toolbar are discussed next.

Fedo—M Update
Save — ———————— Color Owerride
[t Retumn

] [
Open Daown arrow
Undo Design Doctor
Print Select

Figure 1-6 The Quick Access Toolbar

Select

This tool is used to set the selection priority. If you choose the down arrow on the right of
this tool, six more tools are displayed. These tools are Select Bodies, Select Groups, Select
Features, Select Face and Edges, Select Sketch Features, and Select Wires. The Select
Bodies tool is chosen to set the selection priority to bodies. If this tool is chosen, you can select
any individual body in the model. If you choose the Select Features tool, you can select any
feature in the model. The Select Faces and Edges tool is chosen to set the priority to faces
and edges. This tool is chosen by default. As a result, you can select the faces and edges of
the features. The Select Sketch Features tool is chosen to set the priority to sketched entities.
The remaining two tools, Select Groups and Select Wires will be activated according to their
respective environments when the different groups and wires become available. There are also
other tools available in this area, which will be displayed in different modules.

Return

This tool is chosen to exit the sketching environment. Once you have finished drawing the
sketch, choose this tool to proceed to the Part module where you can convert the sketch into
a feature using the required tools.

Update/Local Update

This tool is chosen to update the design after editing.

Color Override

You can use this drop-down list to apply different types of colors or styles to the selected features
or component to improve its appearance. It is much easier to identify different components,
parts, and assemblies when proper color codes are applied to them.

RIBBON AND TABS

You might have noticed that there is no command prompt in Autodesk Inventor. The complete
designing process is carried out by invoking the commands from the tabs in the Ribbon.
The Ribbon is a long bar available below the Quick Access Toolbar. You can change the
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appearance of the Ribbon as per your need. To do so, right-click on it; a shortcut menu will
be displayed. Choose Ribbon Appearance from this shortcut menu to invoke a cascading
menu. Next, choose the required option from the cascading menu.

Autodesk Inventor provides you with different tabs while working with various design
environments. This means that the tabs available in the Ribbon while working with the Part,
Assembly, Drawing, Sheet Metal, and Presentation environments will be different.

You can also display the toolbars. To do so, choose the Customize button from the Options
panel of the Tools tab in the Ribbon; the Customize dialog box will be displayed. Choose the
Toolbars tab from this dialog box; the list of all toolbars will be displayed. Select the required
toolbar and then choose the Show button; the selected toolbar will appear on the screen.
Choose the Close button to close the Customize dialog box.

displayed at the Status Bar which is available at the lower left corner of the

Q Tip. In Autodesk Inventor Professional 2012, the messages and prompts are
N Autodesk Inventor window.

Sketch Tab

This is one of the most important tabs in the Ribbon. All tools for creating the sketches of the
parts are available in this tab. The Sketch tab is available only in the sketching environment.
The Sketch tab is shown in Figure 1-7.
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Figure 1-7 The Sketch tab

Inventor Precise Input Toolbar

Inventor provides you with the Inventor Precise Input toolbar to specify precise value. This
toolbar is used to enter the precise values for the coordinates of the sketcher entities. This
toolbar is also available in the Drawing and Assembly modules for providing precise values.
The Inventor Precise Input toolbar is shown in Figure 1-8.
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Figure 1-8 The Inventor Precise Input toolbar

Model Tab

This is the second most important tab provided in the Part module. Once the sketch is
completed, you need to convert it into a feature using the modeling commands. This tab
provides all modeling tools that can be used to convert the sketch into a feature. The tools in
the Model tab are shown in Figure 1-9.
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Figure 1-9 The Model tab

The Create 2D Sketch button in the Sketch panel of the Model tab is used to draw a 2D
sketch in the sketching environment and is chosen by default when you start a new file in the
Part module. As the first feature in most designs is a sketched feature, you can directly start
working on the sketch of the feature. Once you have completed a sketch, you can choose either
the Return button from the Quick Access Toolbar or the Finish Sketch button from the Exit
panel of the Sketch tab in the Ribbon. Whenever you need to draw the 2D sketch for another
feature, choose this button; you will be prompted to select the plane for sketching the feature.
Once you define the new sketching plane, the sketching environment will be activated.

Sheet Metal Tab

This tab provides the tools that are used to create sheet metal parts. This toolbar will be
available only when you are in the sheet metal environment. You can switch from the Modeling
environment to the Sheet Metal environment by choosing the Convert to Sheet Metal tool
from the Convert panel of the Model tab in the Ribbon. The tools in the Sheet Metal tab are
shown in Figure 1-10.
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Figure 1-10 The Sheet Metal tab

Assemble Tab

This tab will be available only when you open any assembly template (with extension .iam)
from the New File dialog box. This tab provides you all tools that are required for assembling
components. The tools in the Assemble tab are shown in Figure 1-11.
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Figure 1-11 The Assemble tab

Place Views Tab

This tab provides the tools that are used to create different views of the components. This tab
will be available only when you are in the Drafting environment. The tools in the Place Views
tab are shown in Figure 1-12.
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Figure 1-12 The Place Views tab

‘ Create ‘ Modify

Presentation Tab

This tab provides the tools that are used to create different presentation views of the
components. This tab will be available only when you open any presentation template (with
extension .zpn) in the New File dialog box. The tools in the Presentation tab are shown in
Figure 1-13.

EEEVGLLE Tools  View  Vault  Get Started =T

Create _

Figure 1-13 The Presentation tab

Tools Tab

This tab contains tools that are mainly used for setting the preferences and customizing the
Autodesk Inventor interface. This tab is available in almost all environments. The tools in the
Tools tab are shown in Figure 1-14.
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Figure 1-14 The Tools tab

View Tab

The tools in this tab enable you to the control the view, orientation, appearance, and visibility
of objects and view windows. This tab is available in almost all environments. The tools in the
View tab are shown in Figure 1-15.
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Figure 1-15 The View tab

The tools of a particular tab are arranged in different panels in the Ribbon. Some of the
panels and tools have an arrow on the right, refer to Figure 1-16. These arrows are called
down arrows. When you choose these down arrows, some more tools will be displayed as
drop-downs, see Figure 1-16.
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Figure 1-16 Move tools displayed upon choosing the down arrow on the right of a tool in

the Ribbon

Navigation Bar

The Navigation Bar is located on the right of the graphics
area and contains tools that are used to make the designing
process easier and quicker. The navigation tools also help you
to control the view and orientation of components in the
drawing window. The Navigation Bar is shown in Figure 1-17.

Browser Bar

The Browser Bar is available below the Ribbon on the left of
the drawing window. It displays all the operations performed
during the designing process in a sequence. All these
operations are displayed in the form of a tree view. You can
undock the Browser Bar by dragging it from its position to
other position. The contents of the Browser Bar are different
for different environments of Autodesk Inventor. For example,

in the Part module, it displays various operations that were used in creating the part. Similarly,
in the Assembly module, it displays all the components along with the constraints that were

used to assemble them.

4@,(

Full Navigation Wheel /
or SteeringWheel

Pan —/
Zoom All /
Free Orbit —/

View Face —//L
Customize
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UNITS FOR DIMENSIONS

In Autodesk Inventor, you can set units at any time by using the Document Settings dialog
box. You can invoke this dialog box by choosing the Document Settings tool from the Options
panel in the Tools tab. After invoking this dialog box, choose the Units tab in the dialog
box; various areas related to units will be displayed. The options in the Units area are used
to set the units. To set the unit for linear dimension, select the required unit from the Length
drop-down. Similarly, to set the unit for angular dimension, select the required unit from the
Angle drop-down. Next, choose the OK button to apply the specified settings and close the
dialog box. If you want to apply the specified settings without closing the dialog box, choose
the Apply button. If you choose the Apply button, the OK button is replaced by Close. Now,
you can choose the Close button to close the dialog box.

IMPORTANT TERMS AND THEIR DEFINITIONS

Before you proceed further in Autodesk Inventor, it is very important for you to understand
the following terms, which are widely used in this book.

Feature-based Modeling

Afeature is defined as the smallest building block that can be modified individually. In Autodesk
Inventor, the solid models are created by integrating a number of these building blocks.
Therefore, the models in Autodesk Inventor are a combination of a number of individual
features. These features understand their fit and function properly. As a result, these can be
modified, whenever required. Generally, these features automatically adjust their values, if
there is any change in their surroundings.

Parametric Modeling

The parametric nature of a software package is its ability to use the standard properties or
parameters to define the shape and size of a geometry. The main function of this property is
to derive the selected geometry to the new size or shape without considering its original size
or shape. For example, you can derive a line of 20 mm that was initially drawn at an angle
of 45 degrees to a line of 50 mm and change its orientation to 90°. This property makes the
designing process very easy. This is because now you do not need to draw the sketch to the actual
dimensions that are required. You just need to draw the sketch to some relative dimensions,
and then this solid modeling tool will drive it to the actual values you require.

Bidirectional Associativity

As mentioned earlier, this solid modeling tool does not restrict its capabilities to the 3D solid
output. It is also capable of highly effective assembly modeling, drafting, and presentations.
There exists a bidirectional associativity between all these environments of Autodesk Inventor.
This link ensures that if any modification is made in the model in any one environment, it is
automatically reflected in the other environments.

Adaptive

This is a highly effective property that is included in the designing process of this solid
modeling tool. In any design, there are a number of components that can be used in various
places with a small change in their shape and size. This property makes the part or the feature
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adapt to its environment. It also ensures that the adaptive part changes its shape and size as
soon as it is constrained to other parts. This considerably reduces the time and effort required
in creating similar parts in the design.

Design Doctor

The Design Doctor is one of the most important parts of the designing process used in the
Autodesk Inventor software. It is a highly effective tool to ensure that the entire design process
is error free. The main purpose of the Design Doctor is to make you aware of any problem in
the design. The Design Doctor works in the following three steps:

Selecting the Model and Errors in the Model
In this step, the Design Doctor selects the sketch, part, assembly, and so on and determines
the errors in it.

Examining Errors
In this step, it examines the errors in the selected design. Each of the errors is individually
examined and the required solution is provided.

Providing Solutions for Errors

This is the last step of the working of the Design Doctor. Once it has individually examined
each of the errors, it suggests solutions for them. It provides you with a list of methods that
can be utilized to remove the errors from the design.

Constraints

These are the logical operations that are performed on the selected design to make it more
accurate or define its position with respect to the other design. There are four types of
constraints in Autodesk Inventor. All these types are explained next.

Geometric Constraints

These logical operations are performed on the basic sketching entities to relate them to the
standard properties like collinearity, concentricity, perpendicularity, and so on. Autodesk
Inventor automatically applies these geometric constraints to the sketcher entities at the time
of their creation. You do not have to use an extra command to apply these constraints on to
the sketcher entities. However, you can also manually apply these geometric constraints on
to the sketcher entities. There are twelve types of geometric constraints.

Perpendicular Constraint
This constraint is used to make the selected line segment normal to another line segment.

Parallel Constraint
This constraint is used to make the selected line segments parallel.

Coincident Constraint
This constraint is used to make two points or a point and a curve coincident.
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Concentric Constraint
This constraint forces two selected curves to share the same center point. The curves that
can be made concentric are arcs, circles, or ellipses.

Collinear Constraint
This constraint forces two selected line segments or ellipse axes to be placed in the same
line.

Horizontal Constraint
This constraint forces the selected line segment to become horizontal.

Vertical Constraint
This constraint forces the selected line segment to become vertical.

Tangent
This constraint is used to make the selected line segment or curve tangent to another curve.

Equal
This constraint forces the selected line segments to become equal in length. It can also
be used to force two curves to become equal in radius.

Smooth
This constraint adds a smooth constraint between a spline and another entity so that at
the point of connection, the line is tangent to the spline.

Fix
This constraint fixes the selected point or curve to a particular location with respect to
the coordinate system of the current sketch.

Symmetric
This constraint forces the selected sketched entities to become symmetrical about a sketched
line segment, which may or may not be a center line.

Assembly Constraints

The assembly constraints are the logical operations performed on the components in order
to bind them together to create an assembly. These constraints are applied to reduce the
degrees of freedom of the components. There are four types of assembly constraints which
are discussed next.

Mate

The Mate constraint is used to make the selected faces of different components coplanar.
The model can be placed facing the same direction or the opposite direction. You can
also specify some offset distance between the selected faces.

Angle
The Angle constraint is used to place the selected faces of different components at some
angle with respect to each other.
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Tangent
The Tangent constraint is used to make the selected face of a component tangent to the
cylindrical, circular, or conical faces of the other component.

Insert
The Insert constraint forces two different circular components to share the same orientation
of the central axis. It also makes the selected faces of the circular components coplanar.

Motion Constraints

The motion constraints are the logical operations performed on the components that are
assembled using the assembly constraints. There are two types of motion constraints that are
discussed next.

Rotation
The Rotation constraint is used to rotate one component of the assembly in relation to
the other component.

Rotation-Translation
The Rotation-Translation constraint is used to rotate the first component in relation to
the translation of the second component.

Transitional Constraints

The transitional constraints are also applied on the assembled components and are used to
ensure that the selected face of the cylindrical component maintains contact with the selected
faces of the other component when you slide the cylindrical component.

UCS to UCS Constraint

This constraint is used to constrain two components together by their UCS.

Note

The motion and transitional constraints are applied on the components that have already been
assembled using the assembly constraints. Therefore, these constraints work along the degrees of
[freedom of the components that are not restricted using the assembly constraints.

Consumed Sketch
A consumed sketch is a sketch that is utilized in creating a feature using tools such as Extrude,
Revolve, Sweep, Loft, and so on.
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SELECT OTHER BEHAVIOR U

While working on the complicated models,
sometimes you may need to select the
entities that are not visible in the current
view or are hidden behind other entities. To
do so, Autodesk Inventor provides you with
the Select Other feature, which is displayed
automatically when you hover the cursor at
a point where more than one entity is
available. To select any entity, click on the
down arrow; a flyout will be displayed. Select
the desired entity from the flyout; the
selected entity will be displayed in blue.

Figure 1-18 shows the Select Other flyout /
displayed in the modelling environment.  Figure 1-18 Selecting the entities from the Select
You can use this tool in all the modes and  Other flyout

environments of Autodesk Inventor.

HOTKEYS

As mentioned earlier, there is no command prompt in Autodesk Inventor. However, you can
use the keys on the keyboard to invoke some tools. The keys that can be used to invoke the tools
are called hotkeys. Remember that the working of the hotkeys will be different for different
environments. The use of hotkeys in different environments is given next.

Part Module

The hotkeys that can be used in the Part module and their functions are given next.

Hotkey Function

E Invokes the Extrude tool
R Invokes the Revolve tool
H Invokes the Hole tool

CTRL+SHIFT+L Invokes the Loft tool
CTRL+SHIFT+S Invokes the Sweep tool
F Invokes the Fillet tool
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CTRLA+SHIFT+K | Invokes the Chamfer tool

D Invokes the Draft tool
CTRL+SHIFT+R | Invokes the Rectangular Pattern tool
CTRLA+SHIFT+O | Invokes the Circular Pattern tool
CTRL+SHIFT+M | Invokes the Mirror tool

] Invokes the Work Plane tool

/ Invokes the Work Axis tool

. Invokes the Work Point tool
CTRL+W Invokes the SteewingWheels

F6 Invokes the Home view

The following hotkeys are used in the sketching environment:

Hotkey Function

L Invokes the Line tool

C Invokes the Center Point Circle tool
D Invokes the Dimension tool

X Invokes the Trim tool

F7 Invokes the Slice Graphics tool

F8 Displays all constraints

F9 Hides all constraints

Assembly Module
In addition to the hotkeys of the part modeling tool, the following hot keys can also be used
in the Assembly module:

Hotkey

Function

Invokes the Place tool

Invokes the Create tool

Invokes the Constraint tool

Invokes the Move Component tool

Invokes the Rotate Component tool

>lal<|alZz]|~

Invokes the Analyze Interference tool

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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Drawing Module

The hotkeys that can be used in the Drawing module are given next.

Hotkey Function

B Invokes the Balloon tool

D Invokes the Dimension tool

(@) Invokes the Ordinate Set tool

F Invokes the Feature Control Frame tool

In addition to these keys, you can also use some other keys for the ease of designing. Note that
you will have to hold some of these keys down and use them in combination with the pointing
device. These hotkeys are given next.

Hotkey Function

F1 Invokes the Help command

F2 Invokes the Pan tool

F3 Invokes the Zoom tool

F4 Invokes the Free Orbit tool

F5 Previous view

SHIFT+F5 Next view

ESC Aborts the current command
SPACEBAR Invokes the recently used tool

T (In Presentation module) | Invokes the Tweak Components tool

Customizing Hotkeys

You can customize the settings of hotkeys. To do so, choose the Customize tool from the
Options panel of the Tools tab in the Ribbon; the Customize dialog box will be displayed.
Next, choose the Keyboard tab; the list of all available commands will be displayed, as shown
in Figure 1-19. The options corresponding to the Keyboard tab are discussed next.

Categories
Select the required category of command from this drop-down list; the commands related to
the selected category will be listed in the list box.

Filter

You can further shortlist the displayed commands from this drop-down list. If you select the
All option, all commands related to the selected category will be displayed. If you select the
Assigned option, then the commands to which the hotkeys are assigned will be displayed.
Similarly, if you select the Unassigned option, then the commands to which the hotkeys are
not assigned will be displayed.
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Customize (=3
Keyboard
Categories [Nl v] ' [Nl v]
Keys Command Mame Type Category Il
Q 2 Line Work Plane Work Features l—l
@ 2 Line Work Point Work Features
,ﬁ 2 Plane Work Axis Work Features
\ﬂ.\ 2 Point Work Axis Work Features
Jrin] 2-D Drawing Alias Mold Design Commands
s B 2D Sketch Alias Placed Features
@ 3 Plane Work Point Work Features
‘{fﬁ 3 Point Work Plane Work Features
B Grips 3D Grips
3D Intersection Curve Sketch
@& 3D Print Preview Management
J 3D Sketch Placed Features
3D Sketches View
About Autodesk Inventor Help i
4 B 1 o | »
[T Use default multi-character Command Aliases
Reset All Keys
Description
Copy to Clipboard
[ Import... ] [ Export... ] [ Reset All ] [ Close ]

Figure 1-19 The Customize dialog box displaying various commands in the Keyboard tab

List Box

The list box has four columns: Keys, Command Name, Type, and Category. The Key column
displays the hotkeys assigned to the commands. The name of the command, its type, and
category will be listed in the Command Name, Type, and Category columns, respectively.

To assign hotkeys to a tool, click in the Keys column that is associated to the command; an
edit box will be displayed. In this edit box, enter the shortcut key that you want to assign. To
accept the settings, click on the tick-mark provided at the right side of this edit box. Else, click
on the cross-mark provided next to the tick-mark.

Reset All Keys

The Reset All Keys button is used to remove all customized hotkeys and restore the default
hotkeys.

Copy to Clipboard
Choose this button to copy the contents of the Keyboard tab and paste them in other
document.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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Import
Choose this button to restore the customized settings from the .xml format. Note that before
importing the file, all Autodesk Inventor files must be closed.

Export
Choose this button to save the customized settings in the .xml format. Make sure that all
Autodesk Inventor files are closed before choosing this button.

Reset All
This button is used to reset all the customized settings of environments, toolbars, and menus.
Make sure that all Autodesk Inventor files are closed before choosing this button.

Close
Choose this button to close the Customize dialog box.

CREATING THE SKETCH

After starting Autodesk Inventor, you can start creating the model in —
the Part environment. But before creating the model, you need to @/ gl
create its sketch in the Sketching environment. The Sketching Create || Extrude Revolve
environment is invoked automatically when you start a new part file, | 20Sketeh[
But if you want to invoke the Sketching environment manually, choose @’ Create 20 Sketch |——
the Create 2D Sketch tool from the Sketch drop-down in the Sketch
panel of the Model tab, see Figure 1-20. On choosing this tool, the ;l/) Create 3D Sketch
sketching environment is invoked and you can create the 2D sketches.
If you choose the Create 3D sketch tool from the Sketch panel, you Figure 1-20 Tools in the
can create the 3D sketches. Sketch drop-down

MARKING MENU

Marking Menu is a type of menu that consists of some of the tools and options which are
commonly used in Autodesk Inventor software in different environments. Marking Menu
replaces the conventional right-click context menu. With this release of Inventor, the right-click
context menu is displayed below the Marking Menu. The Marking Menu consists of different
tools in different environments. For example, in the Sketching environment, the Marking
Menu consists of commonly used tools such as Create Line, Two Point Rectangle, Done [ESC],
Trim, General Dimensions, and so on. In the Modeling environment, it consists of tools and
options such as Extrude, Fillet, Hole, 2D Sketch and so on.

You can invoke a tool in Marking Menu by using two modes: Marking mode and Menu
mode. To invoke the Marking Menu using the Menu mode, right-click anywhere in the
graphic window; all menu items surrounding the cursor will be displayed. After invoking the
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Marking Menu, you can choose the desired tool or option from it. To do so, move the cursor
towards the desired tool; the tool is highlighted along with a marker ray. Next, choose the
highlighted tool to invoke it.

The other mode, Marking mode, is also known as gesture behavior. It helps you to mark a
trail and choose the desired tool. To choose a tool in the Marking mode, right-click and drag
the cursor immediately in the direction of the desired tool.

Figure 1-21 shows a Marking Menu invoked in the sketching environment and Figure 1-22
shows a Marking Menu which is invoked in the modeling environment.

{ / Create Line |
( Center Paint Circle @/’, ([T Two Paint Rectangl= |
T
( Undo <5 | ( 2k Tim |
( General Dimension I'_‘]J ( % Project Geometry )
| o Finish Sketch | ‘

Repeat Look At

4 Finish 2D Sketch
Show All Degrees of Freedom

+' Snap to Grid
Show All Constraints F8
Constraint Visibility. ..
Constraint Options...
Create Constraint >
Create Feature »

Cﬁ] Slice Graphics F7
Dimension Display >
Measure 13
Sketch Doctor
Show Al
Hide Others

£k Place Feature...

:o—j Previous View F&

{1} Home View F&
Help Topics...

Figure 1-21 Marking Menu available
in the sketching environment

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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([ Fillet )
Geexes)  (heed
((ndo <5 ) : ( fs parameters... )
Gotpwe il (Sl

I\@ Mew Sketch J

GT Repeat Extrude

ﬁ New 3D Sketch
Dimension Display
Measure

®) create Mate
Show All
Hide Others

’Q Place Feature...

:1—: Previous View F5
{a} Home View F&

rr

s

Help Topics...

Figure 1-22 Marking Menu available in
the modeling environment

Tip. You can modify the tools listed in the Marking Menu. You can also turn the
Marking Menuw feature on or off in the User Interface flyout in the View panel
in the Ribbon.

COLOR SCHEME

Autodesk Inventor allows you to use various color schemes to set the background color
of the screen and for displaying the entities on the screen. Note that this book uses the
Presentation color scheme with a single color background. To change the color scheme,
choose the Application Options tool from the Options panel of the Tools tab in the Ribbon;
the Application Options dialog box will be displayed. Choose the Colors tab to display the
predefined colors. Next, select the Presentation option from the Color scheme list box in the
Colors tab. Select 1 Color from the drop-down list in the Background area, refer to Figure 1-23.
Choose Apply to apply the color scheme to the Autodesk Inventor environment, and then
choose Close. Note that all the files you open henceforth will use this color scheme.
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Application Options (=5
Maotebook | Sketch | Part | iFeature I Assembly I Content Center
General I Save I File | Colors | Display I Hardware I Prompts I Drawing

‘
Color scheme Background
Deep Blue ’ 1 Colar - ]
Forest
High Contrast File name:
Millznnium
Presentation presentation-5.png _JQJ
Sky
Winter Day . .
Winter Night Reflection Environment
Waonderland File name:
Chrome.dds @
Highlight
Enable Prehighlight Color Theme
[] Enable Enhanced Highlighting Application Frame:
Dark VI
Interface Style: Icons: @ @ @ @ @
[Ribbon LI -
’ Import... ] [ Export... ] [ Close ] Cancel Apply

Figure 1-23 The Application Options dialog box with the required

options set in the Colors tab

Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this

chapter:

1. When you start a new session of Autodesk Inventor Professional 2012, only the Start a new

file button will be available in the Quick Launch area of the Open dialog box. (T/F)

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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The Inventor Precise Input toolbar is used to specify the precise values for the coordinates
of sketcher entities. (1/F)

The tools in the Model tab enable you to control the view, orientation, appearance, and
visibility of objects and view windows. (1/F)

You can invoke the Line tool by using the hotkey.
Press to invoke the recently used tool.
Choose the button from the Customize dialog box to restore the customized

settings in the .xml format.

Review Questions

Answer the following questions:

1.

2.

There are twelve types of geometric constraints in Autodesk Inventor. (T/F)
Design Doctor works in five steps. (1/F)
You can invoke the Trim tool by pressing the X key. (T/F)

You can use the drop-down list to apply different types of color or style to the
selected feature or component to improve its appearance. (1/F)

You can invoke the Analyze Interference tool in the Assembly module by pressing the
key.

The button is used to draw a 2D sketch in the sketching environment and is
chosen by default when you start a new file in the Part module.

Answers to Self-Evaluation Test
1.7, 2.7T, 3. F, 4. L, 5. SPACEBAR, 6. Import



