
Chapter 2

Drawing Sketches 
for Solid Models

 Learning Objectives
After completing this chapter, you will be able to:
• Start a new template fi le to draw sketches.
• Set up the sketching environment.
• Use various drawing display tools.
• Understand the sketcher environment in the Part module.
• Get acquainted with sketcher entities.
• Specify the position of entities by using dynamic input.
• Draw sketches by using various sketcher entities.
• Delete sketched entities.
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THE  SKETCHING ENVIRONMENT
Most designs created in Autodesk Inventor consist of sketched and placed features. A sketch is 
the combination of a number of two-dimensional (2D) entities such as lines, arcs, circles, and 
so on. The features such as extrude, revolve, and sweep that are created by using 2D sketches 
are known as sketched features. The features such as fi llet, chamfer, thread, and shell that are 
created without using a sketch are known as placed features. In a design, the base feature or 
the fi rst feature is always a sketched feature. For example, the sketch shown in Figure 2-1 is 
used to create a solid model, as shown in Figure 2-2. In this fi gure, the fi llets and chamfers 
are the placed features.

Figure 2-1  The basic sketch for the solid model Figure 2-2  A solid model created using the 
sketched and placed features

Once you have drawn the basic sketch, refer to Figure 2-1, you need to convert it into a solid 
model using solid modeling tools.

The sketching environment of Autodesk Inventor can be invoked at any time in the Part 
module or in the Assembly module. Unlike other solid modeling programs, here you just need 
to invoke the Create 2D Sketch tool and specify the plane to draw the sketch; the sketching 
environment will be activated. Also, when you start a new fi le in the Part module, fi rst the 
sketching environment will be activated. You can draw a sketch in this environment and then 
proceed to the part modeling environment for converting the sketch into a solid model. The 
options in the sketching environment will be discussed later in this chapter.

 The Open Dialog Box
On starting a new session of Autodesk Inventor, the initial screen will be displayed. Now, 
choose the Open tool from the Launch panel of the Get Started tab; the Open dialog box 
will be displayed, as shown in Figure 2-3. 

The options in the Open dialog box are used to create new fi les and open existing fi les. You 
can browse and select the fi le that you want to open from the list displayed in the dialog 
box. The preview of the selected fi le is displayed in the preview window located at the lower 
left portion of this dialog box, as shown in Figure 2-4. By default, you can open any fi le 
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created in Autodesk Inventor. This is because by default, the Files of type drop-down list 
displays the Autodesk Inventor Files (*.iam; *.idw; *.dwg; *.ipt; *.ipn, and *.ide) option. 
You can also open the fi les created in other solid modeling programs such as AutoCAD, 
Pro/ENGINEER, Alias, SolidWorks, NX, and so on, by selecting the respective options from 
the Files of type drop-down list. 

Figure 2-3  The Open dialog box

Figure 2-4  The Open dialog box showing the preview of the selected fi le
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In Autodesk Inventor, a project defi nes all the fi les related to a design project you are working 
on. You can create new projects or retrieve the previously created projects by choosing the 
Projects button available on the right of the Project File drop down list in the Open dialog box. 
When you choose the Projects button, the Projects dialog box will be displayed, as shown in 
Figure 2-5. All the project folders will be displayed in the upper half of the dialog box and the 
options regarding the selected project folder will be displayed in the lower half of the dialog box. 
To add another project folder to this list, choose the New button; the Inventor project wizard 
dialog box will be displayed. The New Vault Project radio button is selected by default in this 
dialog box. Choose the Next button from the Inventor project wizard dialog box. Specify the 
name of the project in the Name text box and the location in the Project (Workspace) Folder 
text box. You can also choose the Browse for project location button to specify the location 
of the project. Next, choose the Finish button. Once you have specifi ed the project folder, it 
will be added in the upper part of the dialog box and its location will be displayed. When you 
select a project, the options related to it will be shown in the lower part of the dialog box. The 
Projects dialog box with various projects is displayed, refer to Figure 2-5.

Figure 2-5  The Projects dialog box

On starting a new session in Autodesk Inventor, only the Start a new fi le button will be 
available in the Quick Launch area of the Open dialog box. Choose this button; the New 
File dialog box will be displayed, as shown in Figure 2-6. To exit the Open dialog box, choose 
the Cancel button.  
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Figure 2-6  The New File dialog box

To view help about topics, press F1; the Autodesk Inventor Help window will be displayed. 
In this window, you will fi nd help topics explaining how to use a particular tool or option of 
Autodesk Inventor.

Import DWG
In Autodesk Inventor, you can import AutoCAD fi les. To do so, choose Open > 
Import DWG from the Application Menu; the Import dialog box will be displayed. 
Browse to the desired folder and import the required AutoCAD fi le. 

Starting a New File 
In Autodesk Inventor, you can start a new fi le by choosing New from the Get Started 
tab or by choosing the New option from the Application Menu. On doing so, the 

New File dialog box will be displayed, refer to Figure 2-6. Alternatively, you can start a new 
fi le by choosing the New tool from the Quick Access Toolbar.

Note
If you invoke the New File dialog box by choosing the New tool from the Quick Access Toolbar 
or by choosing New > New from the Application Menu, only the Open button will be available 
in the Quick Launch area. You can choose the Open tool to invoke the Open dialog box and 
open an existing fi le in Autodesk Inventor.

The options in the New File dialog box are used to select a template fi le for starting a design. 
You can select a template in the Default, English, Metric, or Mould tabs. To start a new metric 
part fi le, choose the Metric tab, as shown in Figure 2-7. The templates that are available on 
choosing the Metric tab are discussed next. 
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Figure 2-7  The Metric tab of the New File dialog box

.ipt Templates 
Select any .ipt template to start a new part fi le for creating a solid model or a sheet metal 
component. When you start a new part fi le, the sketching environment will be automatically 
activated and you can directly start drawing sketches.

.iam Templates
Select any .iam template to start a new assembly fi le for assembling various parts. Similarly, 
use the Weldment.iam template to weld two different components in the Weldment module.

.ipn Templates
Select any .ipn template to start a new presentation fi le for animating the assembly. The 
Presentation module marks the basic difference between Autodesk Inventor and other design 
tools. This module allows you to animate the assemblies created in the Assembly module. For 
example, you can create a presentation in the Presentation module that shows a Drill Press 
Vice assembly in motion. 

.idw Templates
Select any .idw template to start a new drawing fi le for generating the drawing views. You can 
use the drawing templates of various standards that are provided in this tab, such as ANSI, 
ISO, DIN, GB, JIS, GOST, and BSI.

.dwg Templates
Select any .dwg template for creating AutoCAD drawing fi les. You can use the drawing 
templates of standards such as JIS, ISO, GB, DIN, BSI, and ANSI.
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The Project File drop-down list in the New File dialog box displays the active project in 
which the new fi le has been started.  The Projects dialog box can be invoked by choosing the 
Projects button from the New File dialog box.

 INTRODUCTION TO THE SKETCHING ENVIRONMENT
The initial screen appearance in the sketching environment of a Standard (mm).ipt fi le is shown 
in Figure 2-8. By default, the Ribbon is placed at the top of the graphics window, refer to 
Figure  2-8. You can move this Ribbon anywhere in the graphics window. To do so, right-click 
on the Ribbon; a shortcut menu will be displayed. Select the Undock Ribbon option from 
the shortcut menu; the Ribbon will be undocked. Now you can drag the Ribbon anywhere in 
the graphics window. It is recommended to place (dock) the Ribbon at the top of the graphics 
window so that you can use the space effi ciently. To do so, right-click on the Ribbon and choose 
Docking Position > Top from the shortcut menu. Alternatively, double-click on the title bar 
of the Ribbon to dock it.  

Figure 2-8  Initial screen appearance in the sketching environment

 SETTING UP THE SKETCHING ENVIRONMENT
It is very important to fi rst set up the sketcher environment. This has to be done before you 
start drawing a sketch. Setting up the sketcher environment includes modifying the grids of 
a drawing. It is unlikely that the designs that you want to create consist of small dimensions. 
You will come across a number of designs that are large. Therefore, before starting a drawing, 
you need to modify the grid settings. These settings will depend on the dimensions of the 
design. The process of modifying the grid settings of a drawing is discussed next.
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 Modifying the Document Settings of a Sketch
Before  sketching, you may need to modify the setting of the sketching environment as per your 
requirement. You can change the snapping distance, grid spacing, and various attributes related 
to line display of the sketching environment. You must have noticed that the drawing window 
in the sketching environment consists of a number of light and dark lines that are normal to 
each other. These normal lines are called grid lines. The grid lines help you locate an entity, 
thereby helping you to draw a sketch correctly or modify an existing sketch precisely. 

You can modify the document settings of a sketch. To do so, choose the Document Settings 
tool from the Options panel of the Tools tab; the Document Settings dialog box will be 
displayed. In this dialog box, choose the Sketch tab to display the options related to the 
sketching environment, see Figure 2-9. The options under this tab are discussed next.

Figure 2-9  The Sketch tab of the  Document Settings dialog box

Snap Spacing Area
The options under this area are used to specify the snap distances.
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X
This edit box is used to specify the snap spacing in the X direction. 

Y
This edit box is used to specify the snap spacing in the Y direction. 

Grid Display Area
The options in this area are used to control the number of major and minor lines. The minor 
lines are the light lines that are displayed inside the dark gray lines. The dark gray lines are 
called the major lines. 

snaps per minor
This spinner is used to specify the number of snap points between each minor line.

Major every minor lines
This spinner is used to specify the number of minor lines between two major lines.

Line Weight Display Options Area
The options in the Line Weight Display Options area allow you to control the line weight in 
the sketching environment. The Display Line Weights check box is selected by default and 
displays the sketches with the set line weights. If this check box is cleared, then the differences in 
the line weights will not be displayed in the sketch. The Display True Line Weights radio 
button, if selected, displays the line weights on screen as they would appear on paper when 
printed. The Display Line Weights by Range (millimeter) radio button, if selected, displays 
the line weights according to the values entered.

Note
You will have to increase the drawing display area after increasing the grid spacing. 

Tip. You can also turn off the display of the major and minor grid lines and the 
axes. To turn off the display of the grid line and the axes, choose the Application 
Options tool from the Options panel; the Application Options dialog box will 
be displayed. Next, choose the Sketch tab and clear the Grid lines, Minor grid 
lines, and Axes check boxes from the Display area.

UNDERSTANDING  THE DRAWING DISPLAY TOOLS
The drawing display tools or navigation tools are an integral part of any design software. These 
tools are extensively used during the design process. These tools are available in the Navigation 
Bar located on the right in the graphics window and in the Navigate panel of the View tab. Some 
of the drawing display tools in Autodesk Inventor are discussed next. The rest of these tools will 
be discussed in the later chapters.
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Zoom All
 Ribbon:     View > Navigate > Zoom drop-down > Zoom All 
 Navigation Bar:    Zoom fl yout > Zoom All    

The  Zoom All tool is used to increase the drawing display area to display all the sketched 
entities in the current display.

 

Zoom
 Ribbon:     View > Navigate > Zoom drop-down > Zoom 
 Navigation Bar:    Zoom fl yout > Zoom    

The  Zoom tool is used to interactively zoom in and out of the drawing view. When you 
choose this tool, the default cursor is replaced by the zoom cursor. You can zoom into 

the drawing by pressing the left mouse button and dragging the cursor down. Similarly, you 
can zoom out of the drawing by pressing the left mouse button and then dragging the cursor 
up. You can exit this tool by choosing another tool or by pressing ESC. You can also choose 
Done [ESC] from the Marking Menu, which is displayed on right-clicking. You can also zoom 
in the drawing by rolling the scroll wheel of the mouse in the downward direction. Similarly, 
you can zoom out the drawing by rolling the scroll wheel in the upward direction.

Tip. You need to increase the drawing display area by zooming out the drawing using 
the Zoom tool after increasing the grid spacing.

 Zoom Window
 Ribbon:  View > Navigate > Zoom drop-down > Zoom Window 
 Navigation Bar: Zoom fl yout > Zoom Window    

The Zoom Window tool is used to defi ne an area to be magnifi ed and viewed in the 
current drawing. The area is defi ned using two diagonal points of a box (called window) 
in the drawing window. The area inscribed in the window will be magnifi ed and 

displayed on the screen.

Tip. 1. The size of the dimension text always remains constant even if you magnify 
the area that includes some dimensions. 

2. To switch to the previous view, right-click in the drawing window and then choose 
Previous View from the shortcut menu or press the F5 key. You can restore nine 
previous views in the current sketching environment by using this option.
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Zoom Selected
 Ribbon:  View > Navigate > Zoom drop-down > Zoom Selected 
 Navigation Bar: Zoom fl yout > Zoom Selected    

When you choose the Zoom Selected tool, you will be prompted to select an entity to 
zoom. Select an entity from the drawing area; it will magnifi ed to maximum extent 
and placed at the center of the drawing window. This tool can also be invoked by 

pressing the END key.

Pan
 Ribbon:  View > Navigate > Pan 
 Navigation Bar: Pan   

The  Pan tool is used to drag the current view in the drawing window. This option is 
generally used to display the contents of the drawing that are outside the display area, 

without actually changing the magnifi cation of the current drawing. It is similar to holding 
the drawing and dragging it across the drawing window. You can also invoke the Pan tool by 
pressing and holding the middle scroll wheel of the mouse. 

Orbit
 Ribbon:  View > Navigate > Orbit drop-down > Orbit 
 Navigation Bar: Orbit fl yout > Orbit    

The Orbit tool is used to rotate a model freely about any axis. It is useful when you 
want to rotate a model to any position. It is a transparent tool as it can be invoked 

inside any other command. You can invoke this tool by choosing the Orbit tool from the 
Navigate panel in the View tab. On doing so, an arcball will be displayed. This arcball is a 
circle with four small lines placed such that they divide the arcball into quadrants. The orbit 
axis is parallel to the screen and if you rotate an object by dragging the mouse pointer outside 
the arc ball, the object will rotate about the orbit axis. Figure 2-10a shows a model and 
Figure 2-10b shows the same model rotated about the vertical axis by using the Orbit tool.
 

Note
The viewport has been adjusted for better visibility and understanding of the tool. 

Constrained Orbit 
 Ribbon:  View > Navigate > Orbit drop-down > Constrained Orbit 
 Navigation Bar: Orbit fl yout > Constrained Orbit    

The  Constrained Orbit tool is used to visually maneuver around the 3D objects to 
obtain different views. This is one of the most important tools used for advanced 3D 

viewing. Figures 2-11a and 2-11b show default view of the model and the view after one complete 
rotation, respectively. When the Constrained Orbit tool is invoked, the cursor changes and looks 
like a sphere encircled by two arc-shaped arrows. This cursor is known as the Orbit mode cursor. 
You can click and drag the mouse to rotate the model freely. You can move the Orbit mode 
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cursor horizontally, vertically, and diagonally. In this case, the axis is normal to the top and 
bottom faces of the ViewCube. This is also a transparent tool as it can be invoked inside any 
other tool.
  

Figure 2-10b   Position 2: Model rotated about 
the vertical axis

Figure 2-10a  Position 1: Default view of 
the model

Figure 2-11a Position 2: Default view of the 
model

Figure 2-11b  Position 2: Model after a 
complete rotation 

Tip. 1. Press and hold the SHIFT key and the middle mouse button to temporarily 
enter the Constrained Orbit mode. 

2. Move the mouse cursor toward the center of the orbit circle; the cursor changes 
to the Orbit mode. Next, click the left mouse button and drag; the model will move 
freely about any axis.

SKETCHING ENTITIES
Getting acquainted with the sketching entities is an important part of learning Autodesk 
Inventor. A major part of the design is created using the sketched entities. Therefore, this 
section can be considered as one of the most important sections of the book. In Autodesk 
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Inventor, the sketched entities are of two types: Normal and Construction. The normal entities 
are used to create a feature and become a part of it, but the construction entities are drawn 
just for reference and support, and cannot become a part of the feature. By default, all drawn 
entities are normal entities. To draw construction entities, choose the Construction tool from 
the Format panel of the Sketch tab. All entities drawn after choosing the Construction tool will 
be the construction entities. Deselect this tool by choosing it again to draw normal entities. 
 

POSITIONING ENTITIES BY USING DYNAMIC INPUT
With this release of Autodesk Inventor, you can specify the position of sketching entities by using 
the Dynamic Input which consists of two components: Pointer Input and the Dimension Input. 
The Pointer Input is displayed when you invoke the sketching tools such as Line, Rectangle, 
Arc, and it displays the coordinates of the current location of the cursor. As you move the 
cursor, the coordinates change dynamically. When you specify the fi rst point, the Pointer Input 
is displayed. The Pointer Input is displayed in the form of Cartesian Coordinates (X and Y). 
If you specify the second point or the subsequent points of entities, the Dimension Input will 
be displayed. The Dimension Input is displayed in the form of polar coordinates (Length 
and Angle).  

To specify the position of sketching entities dynamically, invoke the required sketching tool 
and then move the cursor in the drawing window; the location of the cursor will be displayed 
in the cartesian coordinate in the Pointer Input. Press the TAB key and enter the X and Y 
coordinate values in the Pointer Input to specify the fi rst point; you will be prompted to specify 
the endpoint or second point of the entity. Alternatively, you can specify the fi rst point of the 
entity by clicking in the drawing window. On doing so, the Pointer Input will be modifi ed to 
the Dimension Input and the polar coordinate input fi elds will be displayed. To specify the 
endpoint or second point of the entity, enter the length and angle values in the input fi elds. 
To toggle between the length and angle input fi elds, use the TAB key. If you specify input 
values by using the Dimension Input and then use the TAB key, lock icons will be displayed on 
the right of the input fi elds. The lock icons indicates that the values defi ned are constrained. 
Figure 2-12 shows the Pointer Input of a line and Figure 2-13 shows the Dimension Input of 
the endpoint of a line of length 20 mm at an angle of 45 degrees. 

Figure 2-13  Dimension input of the endpoint 
of a line of length 20 mm at 45 degrees 

Figure 2-12  Pointer input of a line

If some sketched entities exist in the drawing window and you start creating new entities in the 
drawing window, an appropriate constraint symbol will be displayed near the cursor. You can 
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control the display of the Pointer Input and Dimension Input by using the Application Options 
dialog box. This dialog box can be invoked by choosing the Application Options tool from 
the Options panel. To control the display of Pointer Input and Dimension Input, choose the 
Sketch tab in the Application Options dialog box. Clear the Enable the Heads-Up Display 
(HUD) check box from the Sketch tab and choose the OK button from this dialog box. As 
a result, the display of Pointer Input and Dimension Input will be turned off and now you 
cannot enter the input values of the entities dynamically. 

The sketcher entities in Autodesk Inventor are discussed next.

Drawing Lines
 Ribbon: Sketch > Draw > Line  

Lines are the basic and one of the most important entities in the sketching 
environment. As mentioned earlier, you can draw either normal lines or construction 
lines. A line is defi ned as the shortest distance between two points. The two points 
are the start point and the endpoint of the line. Therefore, to draw a line, you need 

to defi ne these two points. The parametric nature of Autodesk Inventor allows you to draw 
the initial line of any length or at any angle by just picking the points on the screen. After 
drawing the line, you can drive it to a new length or angle by using parametric dimensions. 
You can also create the line of actual length and angle directly by using the Inventor Precise 
Input toolbar. Both these methods of drawing the lines are discussed next. 

Drawing Lines by Picking Points in the Drawing Window
This is a very convenient method to draw lines and is used extensively while sketching. When 
you invoke the Line tool from the Draw panel; the cursor (which was initially an arrow) is 
replaced by crosshairs with a yellow circle at the intersection. Alternatively, you can choose the 
Create Line tool from the Marking Menu which is displayed when you right-click anywhere 
in the graphics window. On doing so, you are prompted to select the start point of the line 
or drag off the endpoint for the tangent arc. In addition, the coordinates of the current 
location of the cursor are displayed in the Pointer Input and also at the lower right corner 
of the Autodesk Inventor window. The point of intersection of the X and Y axes (black lines 
among grid lines) is the origin point. If you move the cursor close to the origin, it will snap to 
the origin automatically. To draw a line, specify a point anywhere in the drawing window; the 
Pointer Input will display both length and angle values as zero. Move the cursor; a rubber-band 
line will start from the specifi ed point and the length and angle values will change accordingly 
in the Pointer Input. One end of this rubber-band line is fi xed at the point specifi ed in the 
drawing window and the other end is attached to the yellow circle in crosshairs. As you move 
the cursor after specifying the start point of the line, the Pointer Input will display the length 
and angle of the current location of the line. Click at the required position in the drawing 
window. Alternatively, enter the required length and angle values in the Pointer Input to 
specify the endpoint of the line. You can use the TAB key to toggle between the length and 
angle values in the Pointer Input. 

After specifying the endpoint of the line, a line is drawn and a new rubber-band line starts. 
The start point of the new rubber-band line is the endpoint of the last line and you are again 
prompted to specify the endpoint of the line. You can continue specifying the endpoints to 
draw continuous lines. 
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When you draw entities in Autodesk Inventor, valid constraints are applied automatically to 
entities. Therefore, when you draw continuous lines, the horizontal, vertical, perpendicular, and 
parallel constraints are applied automatically to them. The symbol of the applied constraint 
is displayed on the line while drawing it. You can exit the Line tool by pressing the ESC key. 
Alternatively, you can exit the Line tool by right-clicking anywhere in the graphics window; 
a Marking Menu will be displayed. Next, choose Done [ESC] from the Marking Menu. 
Figures 2-14 and 2-15 display the Perpendicular Constraint and Parallel Constraint being 
applied to the lines while they are being drawn.  

Figure 2-14  Drawing a line using the 
Perpendicular Constraint

Figure 2-15  Drawing a line using 
the Parallel Constraint

Note
The default screen appearance in the sketcher environment has been modifi ed for clarity. To 
change the screen appearance, choose the Application Options tool from the Options panel; 
the Application Options dialog box will be displayed. Choose the Colors tab and then select 
the Presentation option from the Color scheme list box. Select 1 Color from the Background 
drop-down list. Next, choose the Apply button from the Application Options dialog box to 
change the default appearance of the screen in the sketcher environment.

Tip. While drawing a sketch, constraints are displayed dynamically and are applied 
to it. To turn off the display of these constraints, press and hold the CTRL key and 
draw the sketch.

In Inventor, you can close a sketch that has two or more than two lines. To do so, create two or 
more than two continuous lines and then right-click in the drawing window; a Marking Menu 
will be displayed. Choose the Close option from the Marking Menu; a line joining the endpoint 
of the current line and the start point of the fi rst line will be created and the sketch will be 
closed. Figure 2-16 shows the Close option being chosen from the Marking Menu to close the 
sketch and Figure 2-17 shows the closed sketch created. 
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Figure 2-17  Closed sketch createdFigure 2-16  Choosing the Close option from 
the Marking Menu 

Drawing Lines by Specifying Exact Values
This is another method of drawing lines in Autodesk Inventor. In this method, you use the 
Inventor Precise Input toolbar to defi ne the coordinates of the start point and the endpoint 
of lines. To display the Inventor Precise Input toolbar for the line, fi rst invoke the Line tool. 
Next, click on the down arrow displayed at bottom of the Draw panel in the Sketch tab; the 
Draw panel will expand. Choose the Precise Input tool from this panel. As mentioned earlier, 
the origin of the drawing lies at the intersection of the X and Y axes. The X and Y coordinates 
of this point are 0, 0. You can take the reference of this point to draw lines. There are two 
methods to defi ne the coordinates using this toolbar. Both the methods are discussed next.

Specifying Coordinates with respect to the Origin
The system of defi ning the coordinates with respect to the origin of the drawing is termed 
as the absolute coordinate system. By default, the origin lies at the intersection of the X 
and Y axes. All the points in this system are defi ned with respect to this origin. To defi ne 
the points, you can use the following four methods.

Defi ning the Absolute X and Y Coordinates. In this method, you will defi ne the X and 
Y coordinates of the new point with respect to the origin. To invoke this method, select 
the Indicate a point location by typing X and Y values option from the drop-down 
list in the Inventor Precise Input toolbar. The exact X and Y coordinates of the point 
can be entered in the X and Y edit boxes provided in this toolbar.

Defi ning the Absolute X Coordinate and the Angle from the X Axis. In this method, 
you will defi ne the absolute X coordinate of a point with respect to the origin and 
the angle that this line makes with the positive X axis. The angle will be measured 
in the counterclockwise direction from the positive X axis. To invoke this method, 
select the Specify a point using X coordinate and angle from X axis option from 
the drop-down list. The X coordinate of the new point and the angle can be defi ned 
in the respective edit boxes in the Inventor Precise Input toolbar.

Defi ning the Absolute Y Coordinate and the Angle from the X Axis. In this method, 
you will defi ne the absolute Y coordinate of a point with respect to the origin and 
the angle that this line makes with the positive X axis. To invoke this method, select 
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the Specify a point using Y coordinate and angle from X axis option from the 
drop-down list. The Y coordinate of the new point and the angle can be defi ned in 
the respective edit boxes in the Inventor Precise Input toolbar.

Specifying the Distance from the Origin and the Angle from the X Axis. In this 
method, you will defi ne the distance of the point from the origin and the angle that 
this line makes with the X axis. To invoke this method, select the Specify a point using 
distance from the origin and angle from X axis option from the drop-down list. The 
distance and the angle can be defi ned in the respective edit boxes.

Specifying Coordinates with respect to the Last Point
This system of specifying the coordinates with respect to the previous point is termed as 
the relative coordinate system. Note that this system of defi ning the points cannot be used 
for specifying the fi rst point (the start point of the line). All absolute coordinate methods 
for specifying a point with respect to the origin can also be used with respect to the last 
specifi ed point by choosing the Precise Delta button along with the respective method. 
This button will be available only after you specify the start point of the fi rst line.

Note
While drawing continuous lines, when you move the cursor close to the start point of the fi rst 
line, the yellow circle changes to green and the cursor snaps to the start point. On selecting the 
point at this stage the loop will be closed and you will exit the current line chain.

To draw centerlines, fi rst choose the Centerline tool from the Format panel and then create 
the line. Alternatively, select the required entities from the drawing window and then choose the 
Centerline tool; the selected entities will become centerlines.  

 Restarting a Line
To restart a line, right-click and choose Restart from the Marking Menu. The start point of 
the line is canceled and you are prompted to select the start point of the line.

 Drawing Circles
In Autodesk Inventor, you can draw circles using two methods. You can draw a circle by defi ning 
the center and the radius of the circle or draw a circle that is tangent to three specifi ed lines. 
Both these methods of drawing the circle are discussed next.

Drawing Circles by Specifying the Center Point and Radius
 Ribbon: Sketch > Draw > Circle drop-down > Circle Center Point  

This is the default method of drawing circles. In this method, you    

Figure 2-18  Tools in the 
Circle drop-down

need to defi ne the center point and radius of a circle. To draw a 
circle using this method, choose the Circle Center Point tool from 
the Draw panel, see Figure 2-18; you will be prompted to select 
the center of the circle. Specify the center point of the circle in 
the drawing window; you will be prompted to specify a point on 
the circle. Click at the required location in the drawing window to 
specify a point on the circumference of the circle. This point will 
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defi ne the radius of the circle. Alternatively, enter the required value in the Pointer Input to 
specify the diameter of the circle. You can also specify the center and the radius using the 
Inventor Precise Input toolbar. You can exit the circle command by choosing Done [ESC]. 
Figure 2-19 shows a circle drawn by using the center and the radius.

Drawing Circles by Specifying  Three Tangent Lines
 Ribbon: Sketch > Draw > Circle drop-down > Circle Tangent  

This is the second method of drawing circles and is used to draw a circle  tangent to 
three selected lines. To draw a circle using this method, choose the Circle Tangent 
tool from the Draw panel, see Figure 2-18; you will be prompted to select the fi rst, 
second, and third line, sequentially. As soon as you specify the third line, a circle 

tangent to all the three specifi ed lines will be drawn, as shown in Figure 2-20.

Figure 2-19  Circle drawn using the center 
point and the radius of the circle

Figure 2-20  Circle drawn using three tangent 
lines

 Drawing Ellipses
 Ribbon: Sketch > Draw > Ellipse  

To draw an ellipse, choose  the Ellipse tool from the Draw panel; you will be 
prompted to specify the center of the ellipse. Select a point to specify the center 

of the ellipse; you will be prompted to specify the fi rst axis point. Specify a point to defi ne 
the fi rst axis of the ellipse; you will be prompted to

Figure 2-21  An ellipse drawn in the 
sketching environment

 
select a point on the ellipse. Select a point on the 
ellipse; the ellipse will be created. You can also 
specify these points using the Inventor Precise 
Input toolbar. However, remember that you 
cannot use the relative options for defi ning the 
points of the ellipse. Therefore, if you use the 
Inventor Precise Input toolbar for drawing the 
ellipse, all the values will be specifi ed from the 
origin. However, you can redefi ne the origin by 
choosing the Precise Redefine button and 
placing it at the point that you want to defi ne as 
the origin. Figure 2-21 shows an ellipse. 
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 Drawing Arcs
Autodesk Inventor provides three methods for drawing arcs. These methods are discussed 
next.

Drawing an Arc by Specifying Three Points
 Ribbon: Sketch > Draw > Arc drop-down > Arc Three Point  

This is the default method of drawing arcs. To create an

Figure 2-22  Tools in the 
Arc drop-down

arc with three points, choose the Arc Three Point tool 
from the Draw panel, see Figure 2-22, and then 

specify three points.  The fi rst point is the start point of the arc, 
the second point is the endpoint of the arc, and the third point 
is a point on the arc. You can defi ne these points by specifying 
them in the drawing window or by using the Inventor Precise 
Input toolbar. You can also use the Pointer Input for specifying 
the second and the third point of the arc. Figure 2-23 shows 
an arc drawn using this method.

Drawing an Arc Tangent to an Existing Entity
 Ribbon: Sketch > Draw > Arc drop-down > Arc Tangent  

This method is used to draw an arc that is tangent to an existing open entity. The 
open entity can be an arc or a line. To draw an arc using this method, choose the Arc 
Tangent tool from the Draw panel (see Figure 2-22); you will be prompted to select 
the start point of the arc. The start point of the arc must be the start point or endpoint 

of an existing open entity. Once you specify the start point, a rubber-band arc will start from 
it. Note that this arc is tangent to the selected entity. Now, you will be prompted to specify the 
endpoint of the arc. Click on the drawing window to specify the endpoint of the arc. 
Alternatively, enter the radius and the angle values in the Pointer Input to specify the endpoint 
of the arc. Here, it is very important to mention that the Inventor Precise Input toolbar or 
the Pointer Input cannot be used to select the start point of this arc. However, you can use this 
toolbar to specify the endpoint of this arc. Figure 2-24 shows an arc drawn tangent to the 
line.

Figure 2-24  Drawing the tangent arcFigure 2-23  Drawing the three points arc
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Drawing Tangent/Normal Arcs Using the Line Tool
You can also draw a tangent or a normal arc when you are inside the Line tool. At least a line 
or an arc should be drawn before drawing an arc using this method. To draw an arc using the 
Line tool, draw a line or an arc and then invoke the Line tool. When you are prompted to 
select the start point of the line, move the cursor close to the point from where you want to 
start the tangent or normal arc; the yellow circle in the cursor turns green. Select the point at 
this stage; the green circle in the cursor turns gray. Press the left mouse button and drag the 
mouse; four construction lines appear at the start point displaying the normal and tangent 
directions. If you drag along the tangent direction, a tangent arc is drawn. But if you drag 
along the normal direction, an arc normal to the selected entity is drawn.

Drawing an Arc by Specifying the Center, Start, and Endpoint
 Ribbon: Sketch > Draw > Arc drop-down > Arc Center Point  

This method is used to draw an arc by specifying the center point, start point, and 
endpoint of the arc. To draw an arc using this method, choose the Arc Center Point 
tool from the Draw panel (see Figure 2-22). On doing so, you will be prompted to 
specify the center point of the arc. Once you specify the center point of the arc, you 

will be prompted to specify the start point and then the endpoint of the arc, see Figure 2-25. 
You can also specify the start point and endpoint of the arc by using the Pointer Input. In case 
of start point, you need to specify the radius and angle of the arc from the center point. 
Whereas, in case of endpoint, you need to specify the arc length in terms of angle value. You 
can use the TAB key to toggle between the input values of the Pointer Input. As you defi ne 
the center point and the start point, the radius of the arc will be defi ned automatically. So, 
the third point is just used to defi ne the arc length. An imaginary line is drawn from the cursor 
to the center of the arc. The point at which the arc intersects the imaginary line will then be 
taken as the endpoint of the arc, see Figure 2-26. You can also use the Inventor Precise Input 
toolbar to specify these three points of the arc. 

Figure 2-25  The arc created by specifying 
the center point, start point, and endpoint

Figure 2-26  The imaginary line created 
while drawing the center point arc
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 Drawing Rectangles
In Autodesk Inventor, rectangles can be drawn by using two methods that are discussed 
next.

Drawing Rectangles by Specifying Two Opposite Corners
 Ribbon: Sketch > Draw > Rectangle drop-down > Rectangle Two Point  

This is the default method used to draw a rectangle

Figure 2-27  Tools in the 
Rectangle drop-down

specifying its two opposite corners. To draw a rectangle 
by using this method, choose the Rectangle Two Point 

tool from the Draw panel, see Figure 2-27; you will be prompted 
to specify the fi rst corner of the rectangle and the Pointer Input 
will be displayed. Click at the required location to specify the 
fi rst corner of the rectangle. Once you specify the fi rst corner, 
you will be prompted to specify the opposite corner of the 
rectangle and the Pointer Input will be modifi ed. Click to specify 
the second corner or enter the length and height of the rectangle 
in the Pointer Input. Figure 2-28 shows a rectangle drawn using 
the Rectangle Two Point tool.

Drawing Rectangles by Specifying Three Points on a Rectangle
 Ribbon: Sketch > Draw > Rectangle drop-down > Rectangle Three Point  

You can draw a rectangle by specifying its three points. In this method, the fi rst two 
points are used to defi ne the length and angle of one of the sides of the rectangle 
and the third point is used to defi ne the length of the other side. To create a rectangle 

by using this method, choose the Rectangle Three Point tool from the Draw panel of the 
Sketch tab, see Figure 2-27; you will be prompted to specify the fi rst corner of the rectangle. 
Once you specify it, you will be prompted to specify the second corner of the rectangle. Both 
these corners are along the same direction. As a result, you can use these points to defi ne the 
length of one side of the rectangle. After specifying the second corner, you will be prompted 
to specify the third corner. This corner is used to defi ne the length of the other side of the 
rectangle. Note that if you specify the second corner at a certain angle, then the resultant
rectangle will also be inclined. You can also specify the fi rst, second, and third points of the 
rectangle by using the Pointer Input. In case of second point, you need to specify the length and 
angle of rectangle in the input value fi elds of the Pointer Input. Whereas, in case of endpoint, 
you need to specify the height of the rectangle. You can use the TAB key to toggle between 
the input values of the Pointer Input. You can also specify the three points for drawing the 
rectangle using the Inventor Precise Input toolbar. Figure 2-29 shows an inclined rectangle 
drawn by using the Three Point Rectangle tool.
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Figure 2-28  Drawing a rectangle using two points Figure 2-29  Drawing the three-point 

rectangle at an angle

Drawing Polygons
 Ribbon: Sketch > Draw > Polygon  

The polygons drawn in Autodesk Inventor are regular

Figure 2-30  The  Polygon 
dialog box

 
polygons. A regular polygon is a multi-sided 

geometric fi gure in which the length of all sides and the angle 
between them are the same. In Autodesk Inventor, you can draw a 
polygon with the number of sides ranging from 3 to 120. When 
you invoke the Polygon tool, the Polygon dialog box will be 
displayed, as shown in Figure 2-30, and you will be prompted to 
select the center of the polygon. The options in this dialog box are 
discussed next. 

 Inscribed
This is the fi rst button in the Polygon dialog box and is chosen by default. This option is 
used to draw an inscribed polygon. An inscribed polygon is the one that is drawn inside an 
imaginary circle such that its vertices touch the circle. Once you have specifi ed the polygon 
center, you will be prompted to specify a point on the polygon. In case of an inscribed polygon, 
the point on the polygon specifi es one of its vertices, see Figure 2-31.

 Circumscribed
This is the second button in the Polygon dialog box and is used to draw a circumscribed 
polygon. A circumscribed polygon is the one that is drawn outside an imaginary circle such 
that its edges are tangent to the imaginary circle. In case of a circumscribed polygon, the point 
on the polygon is the midpoint of one of the polygon edges, see Figure 2-32.

Number of Sides
This edit box is used to specify the number of sides of the polygon. The default value is 6. 
You can enter any value ranging from 3 to 120 in this edit box.
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Note
The rectangles and polygons are a combination of individual lines. All the lines can be separately 
selected or deleted. However, when you select one of the lines and drag, the entire rectangle or 
polygon will be considered as a single entity. As a result, the entire object will be moved or stretched.

Figure 2-32  Drawing a fi ve-sided 
circumscribed polygon

Figure 2-31  Drawing a six-sided inscribed 
polygon

 Placing Points
 Ribbon: Sketch > Draw > Point  

In Autodesk Inventor, you can place the sketched points in a sketch using the Point 
tool. To place a point, choose the Point tool from the Draw panel; you will be 

prompted to select the center point. Specify the center point; a point will be placed. You can 
specify the location of a point in the sketch by picking a point from the graphics window or 
by entering the value in the Inventor Precise Input toolbar.

 Creating Fillets
 Ribbon: Sketch > Draw > Fillet/Chamfer drop-down > Fillet  

Filleting is defi ned as the process of rounding

Figure 2-34  The  2D 
Fillet dialog box

Figure 2-33  Tools in the Fillet/
Chamfer drop-down

 
the sharp corners of a sketch. This is done to 

reduce the stress concentration in the model. Using the 
Fillet tool, you can round the corners of the sketch by 
creating an arc tangent to both the selected entities. The 
portions of the selected entities that comprise the sharp 
corners are trimmed when the fi llet is created. When you 
invoke this tool from the Fillet/Chamfer drop-down, refer 
to Figure 2-33, the 2D Fillet dialog box will be displayed 
with the default fi llet radius, as shown in Figure 2-34, and 
you will be prompted to select the lines or the arcs to be 
fi lleted. If you have already created some fi llets, their radius 
values will be stored as preset values. You can select these 
preset values from the list that is displayed when you choose 
the arrow provided on the right of the edit box.
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You can create any number of fi llets of similar or dissimilar radii. If the Equal button in the 2D 
Fillet dialog box is chosen, the dimension of the fi llet will be placed only on the fi rst fi llet and 
not on the other fi llets created by using the same sequence, see Figure 2-35. On modifying the 
dimension of the fi rst fi llet, all instances of fi llet will be modifi ed. To create fi llets of independent 
radii values, deactivate the Equal button before creating fi llets. The fi llets thus created will 
show individual dimensions, see Figure 2-36. As a result, you can modify the dimension of one 
fi llet without affecting the other. You can fi llet two parallel or perpendicular lines, intersecting 
lines or arcs, non-intersecting lines or arcs, and a line and an arc.

Figure 2-35  Rectangle fi lleted using the same 
radius with the Equal button chosen

Figure 2-36  Rectangle fi lleted using different 
radii with the Equal button deactivated

 Creating Chamfers
 Ribbon: Sketch > Draw > Fillet/Chamfer drop-down > Chamfer  

Chamfering is defined as the process of

Figure 2-37  The  2D Chamfer 
dialog box

 
beveling the sharp corners of a sketch. This is 

the second method of reducing stress concentration. To 
chamfer sketched entities, choose the Chamfer tool from 
the Draw panel (see Figure 2-33); the 2D Chamfer dialog 
box will be displayed, as shown in Figure 2-37. Also, you will 
be prompted to select the lines to be chamfered. Select the 
lines; the chamfer will be created. The options in the 2D 
chamfer dialog box are discussed next.

 Create Dimensions
The Create Dimensions button is chosen to show the dimensions of the chamfer on 
the sketch. When you chamfer two lines, the dimensions of the chamfer are shown in 
the sketch. If you choose this button again, the chamfer dimensions will not be 

displayed in the sketch when you create another chamfer.

Equal
The Equal button is chosen to create multiple chamfers with the same parameters. 
This button is enabled only if the Create Dimensions button is chosen.
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 Equal Distance 
The Equal Distance button is chosen to

Figure 2-38  Chamfer with dimension values

 
create an equal distance chamfer. The 
distance of the vertex along the two 

selected edges is the same. As a result, a 45-degree 
chamfer is created using this method. The 
distance value is specifi ed in the Distance edit 
box. If the Create Dimension button is chosen, 
two dimensions of the same value will be shown 
in the sketch, as shown in Figure 2-38.
 

 Unequal Distances
The Unequal Distances button is chosen 
to create a chamfer with two different 
distances. The distance values are specifi ed in the Distance1 and Distance2 edit 

boxes. The distance value specifi ed in the Distance1 edit box is measured along the edge 
selected fi rst. Similarly, the value in the Distance2 edit box is measured along the edge selected 
next. Figure 2-39 shows a chamfer created by using the Unequal Distances method.

Distance and Angle
The Distance and Angle button is chosen to create a chamfer by specifying a distance 
and an angle. On choosing this button, the distance needs to be specifi ed in the 
Distance edit box and the angle in the Angle edit box. The specifi ed angle is measured 

from the fi rst edge selected to chamfer, see Figure 2-40.

Figure 2-40  The distance and angle chamfer 
created

Figure 2-39  The unequal distances chamfer 
created

Tip. 1. If multiple chamfers are created with same values, the dimension value is 
displayed only at the fi rst instance. At the remaining chamfers, the dimension will 
be displayed as fx of the value, which means the function of the original value.

2. You can also select the vertex to create a fi llet or chamfer. The two entities forming 
the selected vertex will be fi lleted or chamfered using the current parameters.
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Drawing Splines
 Ribbon: Sketch > Draw > Spline drop-down > Spline  

To draw a spline, choose the Spline tool from the Draw

Figure 2-41  Tools in 
the Spline drop-down

panel, see Figure 2-41; you will be prompted to specify 
the fi rst point of the spline. Specify the start point; you will be 
prompted to specify the next point of the spline. This process will 
continue until you terminate the spline creation. To end the spline at 
the current point, double-click in the drawing window or right-click 
to display the Marking Menu and choose Create. Note that if you 
choose Done [ESC] from the Marking Menu, the spline will not be 
drawn. You can also end the spline creation by pressing the ENTER 
key. Note that after creating a spline, the square and diamond points will be displayed on the 
spline along with the tangent handles, as shown in Figure 2-42. You can drag these square 
and diamond points to modify the shape of the spline. Figure 2-43 shows a spline drawn 
tangent to a line. To exit the command, press the ESC key on the keyboard or choose 
Done [ESC] from the Marking Menu.

Figure 2-43  A spline drawn tangent to a lineFigure 2-42  A spline drawn by specifying different 
points

You can undo the last drawn spline segment while drawing a spline. This can be done by 
choosing the Back option from the Marking Menu which is displayed when you right-click 
anywhere in the graphics window. You can also draw a spline tangent to an existing entity. To 
draw the tangent spline, select the point where the spline should be tangent. Next, hold the 
left mouse button and drag it; a construction line will be drawn, displaying the possible tangent 
directions for the spline. Drag the mouse in the required direction to draw the tangent spline 
and release the left mouse button. Figure 2-44 shows a spline drawn by specifying different 
points and Figure 2-45 shows a spline drawn tangent to an existing line. 
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Tip. Autodesk Inventor allows you to invoke the last used tool by right-clicking anywhere 
in the drawing window. For example, create a line using the Line tool. If you want to 
create another line, right-click anywhere in the drawing window and choose the Repeat 
Line option from the Marking Menu displayed. Alternatively, you can invoke the last 
used tool by pressing the SPACEBAR key.

Creating a Smooth Curve between Two Existing Curves
 Ribbon: Sketch > Draw > Spline drop-down > Bridge Curve  

In Autodesk Inventor, you can create a smooth (G2) continuous curve between two 
existing curves. The existing curves can be arcs, lines, splines, or projected curves. 

To create a smooth curve, choose the Bridge Curve tool from the Draw panel (see Figure 2-41); 
you will be prompted to select the curves one after the other. Select the two curves; a smooth 
G2 continuous curve, known as bridge curve, will be created between the selected curves. The 
profi le of the bridge curve depends on the position where two existing curves are selected. 
Figure 2-44 shows the point of selection of two curves and the resulting bridge curve. Figure 2-45 
shows different points of selection of the same curve and the resulting bridge curve.   

Figure 2-45  Bridge curve created between 
curves at different selection points

Figure 2-44  Bridge curve created between 
curves at the selection points

DELETING SKETCHED ENTITIES
To delete the sketched entity, fi rst ensure that no drawing tool is active. If it is, press the ESC 
key. Now, select the entity you want to delete using the left mouse button and then right-click 
to display the Marking Menu. Choose the Delete option from this Marking Menu. You can 
also press the DELETE key to delete the selected entities. To delete more than one entity, you 
can use a window or a crossing. The methods used to delete entities are discussed next.

 Deleting Entities by Using a Window
A window is defi ned as a box created by pressing and holding the left mouse button and 
dragging the cursor from the left to the right in the drawing window. The window has a 
property that all the entities that lie completely inside the window will be selected. The box 
defi ned by the window consists of continuous lines. All the selected entities will be displayed 
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in cyan color. After selecting the entities, right-click and choose Delete from the Marking 
Menu or press the DELETE key to delete all the selected entities. 

 Deleting Entities by Using a Crossing
A crossing is defi ned as a box created by pressing and holding down the left mouse button 
and dragging the cursor from the right to the left in the drawing window. The crossing has a 
property that all entities that lie completely or partially inside the crossing or the entities that 
touch the crossing will be selected. The box defi ned by the crossing consists of dashed lines. 
Once the entities are selected, right-click and choose Delete from the Marking Menu. 

Tip. You can add or remove an entity from the selection set by pressing the SHIFT 
or the CTRL key and then selecting the entity by using the left mouse button. If the 
entity is already in the current selection set, it will be removed from the selection 
set. If not, it will be added to set.

FINISHING A SKETCH
After creating the required sketch, you need to save it. But before you save the sketch, you 
need to fi nish the sketch and come out of the sketching environment. To do so, choose the 
Finish Sketch tool from the Exit panel of the Sketch tab; the sketch will be fi nished and 
you will switch to the Home view. You can also exit the sketch environment by choosing the 
Finish Sketch option from the Marking Menu. The Home view enables you to view and create 
the modeling features with ease. After switching to the Modeling environment, you can save 
the document.
 

TUTORIALS
Although Autodesk Inventor is parametric in nature yet, in this chapter you will use the 
Inventor Precise Input toolbar and the Dynamic Input method to draw objects. This is to 
make you comfortable with various drawing options in Autodesk Inventor. From the next 
chapter onward, you will use the parametric feature of Autodesk Inventor to size or draw the 
entities as per the desired dimension values.

Although the sketches for the tutorials in this chapter are to be drawn on the other sketching 
planes, you will draw them on the default XY plane. In the later chapters, you will learn how 
to change a sketching plane.

Tutorial 1
In this tutorial, you will draw the sketch of the model shown in Figure 2-46. The sketch to 
be drawn is shown in Figure 2-47. Do not dimension it, as the dimensions are given only for 
reference.          (Expected time: 30 min)



Drawing Sketches for Solid Models      2-29

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 2-47  Sketch of the modelFigure 2-46  Model for Tutorial 1

 The following steps are required to complete this tutorial: 

a. Start a new Autodesk Inventor session and then start a new metric part fi le.
b. Invoke the Line tool and draw the sketch by specifying the coordinates of the points in 

the Dynamic Input.
c. Save the sketch with the name Tutorial1 and close the fi le.

Starting Autodesk Inventor
1. Start Autodesk Inventor by double-clicking on its shortcut icon on the desktop of 

your computer. Alternatively, choose Start > All Programs > Autodesk > Autodesk 
Inventor 2012 > Autodesk Inventor Professional 2012 from the taskbar; a new session 
of Autodesk Inventor is started. 

2. Choose the New tool from the Launch panel of the Get Started tab; the New File  
dialog box is displayed. 

3. Choose the Metric tab and then double-click on the Standard (mm).ipt icon to 
start a standard metric template; a new metric standard part fi le is started in the 
Sketching environment. 

 
 The major and minor grid lines are also displayed in the drawing window, along with the 

X and Y axes.

Note
You can also open a standard metric template by selecting Standard.ipt from the Default tab 
of the New File dialog box.

Drawing the Sketch 
 As mentioned earlier, Autodesk Inventor is parametric in nature. Therefore, you can draw 

the sketch from any point in the drawing window. In this tutorial, Dynamic Input has been 
used to enter dimensions while drawing the sketch.
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1. Choose the Line tool from the Draw panel in the Sketch tab. Alternatively,  choose  
the Line tool from the Marking Menu that is displayed on right-clicking in the 
drawing / graphics window. On doing so, you are prompted to select the fi rst point 
of the line. Next, choose Precise Input from the Draw panel in the Sketch tab; the Inventor 
Precise Input toolbar is displayed. Double-click on the title bar of this toolbar to dock it. 
If you want, you can also leave this toolbar fl oating on the screen.

 Initially, the Precise Input button is not enabled. This button is enabled only when you 
invoke a sketching tool. Since all initial settings are confi gured, you can now start drawing 
the sketch.

 When you invoke the Line tool, the cursor is replaced by the drawing cursor that has a 
yellow circle at the intersection of crosshairs. When you move the crosshair in the drawing 
window, this circle snaps to the point that is closer to it. Also, coordinates of the current 
location of the cursor are also displayed at the status bar.

2. To specify the fi rst point, enter 0 in both the X and Y edit boxes of the Inventor Precise 
Input toolbar and then press ENTER; you are prompted to specify the endpoint of the 
line.

3. In the Inventor Precise Input toolbar, enter -3 and 3 in the X and Y edit boxes, respectively 
and then press ENTER to defi ne the endpoint of the line. On doing so, the fi rst line of 
the sketch is drawn and you are prompted to select the endpoint of the line. Also, click 
and drag the left mouse button to create a tangent arc. You can check for the Autodesk 
Inventor prompts on the lower left side of the status bar.

 
 You will notice that the line is very small because the dimensions of the sketch are very 

small and the drawing display area is large. Therefore, you need to modify the drawing 
display area by using the drawing display tools. To modify this area, you can use the Zoom 
tool. 

Tip. You can use the TAB key to switch from the X edit box to the Y edit box and 
vice versa in the Inventor Precise Input toolbar.

4. Choose the Zoom tool from the Navigation Bar; the drawing cursor is changed  
to an arrow cursor.

5. Move the cursor to the top of the drawing window, press and hold the left mouse button 
and then drag the cursor downward. Stop dragging the cursor once you notice that the 
display is adjusted.

6. Right-click to display the shortcut menu, and then choose Done [ESC] to exit the Zoom 
tool. 

7. Again, right-click in the graphics window and then choose Done [ESC] from the Marking 
Menu to exit the Line tool. Also, close the Inventor Precise Input toolbar.
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8. Invoke the Line tool again. From this step onward, you will use the Dynamic Input to 
create lines in this tutorial. 

 
 Select the end point of the fi rst line that was created with the help of Inventor Precise 

Input toolbar. Move the cursor toward left and enter 0.5 in the length input fi eld and 180 
in the angle input fi eld. Use the TAB key to toggle between the input fi elds.

Note
In case, at any point of time the Dynamic Input is not visible in the graphics window, make sure 
that the Line tool is the current selection. If you do not see the Dynamic Input fi elds, invoke 
the Line tool again and click on the end point of the last line created by using the Dynamic 
Input.

9. Now you need to create the third line between points 3 and 4, refer to Figure 2-48. To do 
so, move the cursor downward in the graphics window. Enter 3 in the length input fi eld, 
press TAB to switch to the angle input fi eld and enter 90; a line is created between the 
points 3 and 4. 

Figure 2-48  Sketch for Tutorial 1

10. Move the cursor toward left in the graphics window. Enter 2 in the length input fi eld, 
press TAB to switch to the angle input fi eld and enter 90 in it; a line is created between 
points 4 and 5, refer to Figure 2-48.  

11. Move the cursor downward in the graphics window. Enter 1 in the length input fi eld, press 
TAB and enter 90 in it; a line is created between points 5 and 6, refer to Figure 2-48.

12. Move the cursor toward the right in the graphics window. Enter 3 in the length input 
fi eld, press TAB and enter 90 in the angle input fi eld; a line is created between points 6 
and 7.

13. Move the cursor downward in the graphics window. Enter 0.75 in the length input fi eld, 
press TAB and enter 90 in the angle input fi eld; a line is created between points 7 and 
8, refer to Figure 2-48.

14. Move the cursor toward the right in the graphics window. Enter 0.5 in the length input 
fi eld, press TAB and enter 90 in the angle input fi eld; a line is created between points 8 
and 9, refer to Figure 2-48.
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15. Move the cursor upward in the graphics window. Enter 0.25 in the length input fi eld,  
press TAB and enter 90 in the angle input fi eld; a line is created between points 9 and 
10, refer to Figure 2-48.

16. Move the cursor toward the right in the graphics window. Enter 4 in the length input 
fi eld, press TAB and enter 90 in the angle input fi eld; a line is created between points 10 
and 11, refer to Figure 2-48.

17. Move the cursor downward in the graphics window. Enter 0.25 in the length input fi eld, 
press TAB and enter 90 in the angle input fi eld; a line is created between points 11 and 
12, refer to Figure 2-48.

18. Move the cursor toward the right in the graphics window. Enter 0.5 in the length input 
fi eld, press TAB and enter 90 in the angle input fi eld; a line connecting points 12 and 13 
is created, refer to Figure 2-48.

19. Move the cursor upward in the graphics window. Enter 0.75 in the length input fi eld, press 
TAB and enter 90 in the angle input fi eld; a line connecting points 13 and 14 is created, 
refer to Figure 2-48.

20. Move the cursor toward the right in the graphics window. Enter 3 in the length input 
fi eld and 90 in the angle input fi eld; a line connecting points 14 and 15 is created, refer 
to Figure 2-48.

21. Move the cursor upward in the graphics window. Enter 1 in the length input fi eld, press 
TAB and enter 90 in the angle input fi eld; a line connecting points 15 and 16 is created, 
refer to Figure 2-48.

22. Move the cursor toward the left in the graphics window. Enter 2 in the length input fi eld, 
press TAB and enter 90 in the angle input fi eld; a line connecting points 16 and 17 is 
created, refer to Figure 2-48.

23. Move the cursor upward in the graphics window. Enter 3 in the length input fi eld, press 
TAB and enter 90 in the angle input fi eld; a line connecting points 17 and 18 is created, 
refer to Figure 2-48.

24. Move the cursor toward left in the graphics window. Enter 0.5 in the length input fi eld, 
press TAB and enter 90 in the angle input fi eld; a line connecting points 18 and 19 is 
created, refer to Figure 2-48.

25. Now, to close the geometry, click on the point number 1 that you created with the help 
of Inventor Precise Input toolbar. 

26. Next, right-click in the graphics window and choose the Done [ESC] from the Marking 
Menu displayed to exit the Line tool. Next, close the Inventor Precise Input toolbar. 
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Note
The method of applying additional constraints and using them to fully constrain the sketch will 
be discussed in Chapter 3. 

Saving the Sketch
 Remember that you cannot save a sketch in the sketching environment. This is because 

the sketching environment is just a part of the Part module in Autodesk Inventor. This 
environment is used only for drawing the sketches of features. Therefore, you need to 
exit the sketching environment to save the sketch for further use. The sketches in the Part 
module are saved in the .ipt format.

1. Right-click in the graphics window and then choose the Finish Sketch button from the 
Marking Menu displayed; the Sketching environment is closed and you switch to the 
Home view of the part modeling environment. Also, notice that the Model tab is activated 
in place of the Sketch tab. The options in the Model tab are used to create features. The 
options under this tab will be discussed in later chapters.

2. Choose Save from the Quick Access Toolbar; the Save As dialog box is displayed. 

3. Create a new folder with the name Inventor_2012 in the C drive of your computer. In this 
folder, create a folder with the name c02.

 
4. Enter Tutorial1 as the fi le name in the File name edit box, refer to Figure 2-49, and then 

choose the Save button from the Save As dialog box to save the sketch.

Figure 2-49  The Save As dialog box

5. Choose Close > Close from the Application Menu to close this fi le.
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Tutorial 2
In this tutorial, you will draw the sketch for the model shown in Figure 2-50. The sketch to 
be drawn is shown in Figure 2-51. Do not dimension it, as the dimensions are given only for 
reference.           (Expected time: 30 min)

Figure 2-51  Dimensioned sketch for Tutorial 2Figure 2-50  Model for Tutorial 2

 The following steps are required to complete this tutorial:

a. Start a new metric standard part fi le.
b. Draw the outer loop by specifying the length and angle lines by using the Dynamic 

Input method.
c. Draw the inner closed loop by using the Dynamic Input method, refer to Figure 2-53.
d. Save the sketch with the name Tutorial2.ipt and close the fi le.

Starting a New File
1. Choose the New tool from the Launch panel of the Get Started tab to display the New 

File dialog box. In this dialog box, choose the Metric tab and then double-click on the 
Standard (mm).ipt icon to start a standard metric template.

Drawing the Sketch
 As evident from Figure 2-51, the sketch consists of two nested loops: inner loop, and outer 

loop. While extruding a nested loop, the inner loop can be subtracted from the outer 
loop. In this way, a cavity will be created automatically in the model when you extrude the 
sketch. This reduces the time and effort required in creating the inner cavity as another 
feature. Therefore, you can draw both the loops together for this tutorial.

1. Choose the Line tool from the Draw panel. Next, move the cursor and click when  
the cursor displays -40 and -25 in the Pointer Input or press the TAB key and 
then enter the X and Y coordinate values in the Pointer Input. As you specify the 
fi rst point, you are prompted to specify the endpoint of the line and the Pointer Input is 
changed to Dimension Input. 
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2. Enter 80 in the length input fi eld of the Dimension Input and press the TAB key; the 
angle input fi eld becomes active. Enter 0 and then press ENTER; the fi rst line is created 
and the Dimension Input is displayed again.

3. Move the cursor up and then enter 10 in the length input fi eld of the Dimension Input. 
Next, press the TAB key and enter 90 in the angle input fi eld and then press ENTER; 
the second line is created and the Dimension Input is displayed again. 

4. Move the cursor toward the left and then enter 15 in the length input fi eld. Next, press 
the TAB key and enter 90 in the angle input fi eld. Then, press ENTER; the third line is 
created and the Dimension Input is displayed again. 

5. Move the cursor up and then enter 30 in the length input fi eld. Next, press the TAB key 
and enter 90 in the angle input fi eld. Then, press ENTER; the fourth line is created and 
the Dimension Input is displayed again. 

6. Move the cursor toward the right and then enter 15 in the length input fi eld. Next, press 
the TAB key and enter 90 in the angle input fi eld. Then, press ENTER; the fi fth line is 
created and the Dimension Input is displayed again.  

7. Move the cursor up and then enter 10 in the length input fi eld. Next, press the TAB key 
and enter 90 in the angle input fi eld. Then, press ENTER; the sixth line is created and 
the Dimension Input is displayed again. 

8. Move the cursor toward the left and then enter 80 in the length input fi eld. Next, press 
the TAB key and enter 90 in the angle input fi eld. Then, press ENTER; the seventh line 
is created and the Dimension Input is displayed again.

9. Move the cursor down and then enter 10 in the length input fi eld. Next, press the TAB 
key and enter 90 in the angle input fi eld. Then, press ENTER; the eighth line is created 
and the Dimension Input is displayed again. 

10. Move the cursor toward the right and then enter 15 in the length input fi eld. Next, press 
the TAB key and enter 90 in the angle input fi eld. Then, press ENTER; the ninth line is 
created and the Dimension Input is displayed again.

11. Move the cursor down and then enter 30 in the length input fi eld. Next, press the TAB 
key and enter 90 in the angle input fi eld. Then, press ENTER; the tenth line is created 
and the Dimension Input is displayed again.

12. Move the cursor toward the left and then enter 15 in the length input fi eld. Next, press 
the TAB key and enter 90 in the angle input fi eld. Then, press ENTER; the eleventh line 
is created and the Dimension Input is displayed again.   

13. Move the cursor down and then enter 10 in the length input fi eld. Next, press the TAB 
key and enter 90 in the angle input fi eld. Then, press ENTER; the twelfth line is created 
and the Dimension Input is displayed again. 
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14. Right-click to display the Marking Menu and choose Done [ESC] from it to exit the Line 
tool. The sketch of the outer loop is shown in Figure 2-52. You need to arrange the position 
of dimensions in the sketch by dragging them to view the sketch clearly.

 Next, you need to draw the inner loop. You can draw the loop by using the Two Point 
Rectangle tool. 

15. Choose the Rectangle Two Point tool from Sketch > Draw > Rectangle drop-down; you 
are prompted to specify the fi rst corner of the rectangle. 

16. Press the TAB key and then enter -15 and -10 in the Pointer Input. Alternatively, move the 
cursor and click when the cursor displays -15 and -10 in the Pointer Input. As you click to 
specify the fi rst corner, you are prompted to specify the opposite corner of the rectangle 
and the Pointer Input is changed to Dimension Input.  

17. Move the cursor diagonally upward in the right direction and enter 30 and 20 in the 
horizontal and vertical input fi elds of the Dimension Input, respectively and then press 
ENTER. 

18. Next, right-click on the graphics window; a Marking Menu is displayed. Choose Done  [ESC] 
from the Marking Menu; the sketch is created, as shown in Figure 2-53. 

Figure 2-53  Completed sketch for Tutorial 2Figure 2-52  Sketch of the outer loop

Note
The angular dimensions have not been shown in Figures 2-52 and 2-53 for clarity of sketches. 
You can control the display of the linear and angular dimensions of the sketch by using the Sketch 
tab of the Application Options dialog box. This dialog box is displayed when you choose the 
Application Options tool from the Tools panel. In the Sketch tab of the Application Options 
dialog box, choose the Settings button; the Heads-Up Display Settings dialog box is displayed. 
Clear the Create dimensions when inputting dimension value check box in the Persistent 
Dimensions area of the Heads-Up Display Settings dialog box and then choose OK. Next, 
choose the Apply and Close buttons from the Application Options dialog box to turn off the 
visibility of the dimension during sketching. 
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Saving the Sketch
 Next, you need to save the sketch. As mentioned earlier, you cannot save the sketch in the 

sketching environment. First, you need to exit the sketching environment and then save it.

1. Choose the Finish Sketch button from the Exit panel; the sketching environment is closed 
and you are switched to the Home view of the part modeling environment.

2. Choose the Save tool and save the sketch with the name Tutorial2 at the location given 
below:

 C:\Inventor_2012\c02

3. Choose Close > Close from the Application Menu to close this fi le.

Tutorial 3
In this tutorial, you will draw the sketch for the model shown in Figure 2-54. The sketch of 
the model is shown in Figure 2-55. Do not dimension the sketch as the dimensions are given 
only for reference.                                                            (Expected time: 30 min)

Figure 2-55  Sketch for Tutorial 3Figure 2-54  Model for Tutorial 3

 The following steps are required to complete this tutorial:

a. Start a new metric standard part fi le.
b. Draw the sketch by using the Arc and Line tools, refer to Figure 2-55.
c. Save the sketch with the name Tutorial3 and close the fi le.
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Starting a New File
1. Choose the New tool from the Launch panel of the Get Started tab to invoke the New 

File dialog box.

2. Start a new metric standard part fi le by double-clicking on Standard (mm).ipt in the 
Metric tab.

Drawing the Sketch
 The upper arc of the sketch can be drawn by specifying the center point, start point, and 

endpoint of the arc. Therefore, you need to use the Center Point Arc tool to draw this arc.

1. Choose the Arc Center Point tool from Sketch > Draw > Arc drop-down; you are 
prompted to specify the center of the arc. 

2. Press the TAB key and enter 0 in the X coordinate edit fi eld of the Dynamic Input. Next, 
press TAB and enter 15 in the Y coordinate edit fi eld and press ENTER to specify the 
center of the arc; the center of the arc is created and you are prompted to specify the start 
point of the arc.

3. Enter 12 in the length input fi eld. Next, press TAB and enter 180 in the angle input fi eld 
of the Dynamic Input and press ENTER.

 The fi rst point on the arc is defi ned. Now you need to specify the endpoint of the arc.

4. As you are trying to draw the upper arc, you need to move the mouse cursor in the 
counter-clockwise direction and enter 180 in the angle input fi eld. The upper arc is 
drawn.

 Next, you need to draw lines in the sketch.

5. Choose the Line tool from the Draw panel; you are prompted to specify the start 
point of the line. 

 It is evident from Figure 2-57 that the lines start from the endpoints of the arc. 

6. Move the cursor close to the start point of the arc; the yellow circle snaps to the endpoint 
of the arc and turns green. The change in color of the circle indicates that the cursor has 
snapped to the endpoint of the arc. Press the left mouse button to select this point as the 
start point of the line. 

 
7. Move the cursor toward the left in the graphics window. Enter 12 in the length input fi eld, 

press the TAB key and then enter 180 in the angle input fi eld in the Dynamic Input; the 
line between points 2 and 3 is created. Refer to Figure 2-56 for point numbers. 
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8. Move the cursor downward in the graphics window. Enter 30 in the length input fi eld 
and 90 in the angle input fi eld in the Dynamic Input; a line between points 3 and 4 is 
created. 

9. Move the cursor toward the right in the 

Figure 2-56  Sketch showing different points for 
Tutorial 3

 
graphics window. Enter 12 in the  length 
input fi eld and 90 in the angle input 
fi eld of the Dynamic Input; a line is 
created between points 4 and 5. 

 You now need to draw the lower arc of 
the sketch. You can use the Line tool to 
draw the arc.

10. Move the cursor close to the endpoint 
of the last line until the yellow circle 
snaps to that point. When the yellow 
circle snaps to the endpoint, it turns 
gray. Now, press and hold the left mouse 
button and drag the mouse through a small distance in the upward direction. On doing 
so, four imaginary lines are displayed, showing the four directions in which you can draw 
the arc. 

11. As you need to draw the arc normal to the line, drag the cursor vertically upward along the 
vertical imaginary line to a small distance and then drag the cursor toward the right.

12. Press and hold the left mouse button, drag the cursor close to the right endpoint of the 
upper arc; the cursor snaps to the endpoint of the arc and turns green. Now, move the 
cursor vertically downward. 

  As you move the cursor downward, you will notice a point where both the vertical and 
horizontal imaginary lines intersect each other, see Figure 2-57. This point is the endpoint 
of the lower arc. The cursor automatically snaps to that point. Do not release the left mouse 
button until the entire process is completed.

13. When the cursor snaps to the intersection of the imaginary lines, release the mouse button 
to complete the lower arc.
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Figure 2-57  Use of the temporary tracking option to draw an arc

Note
1. In Figure 2-56, the major and minor grid lines and the triad have not been displayed for 
a better display of the sketch and the imaginary lines.

2. While using the temporary tracking option to draw lines, you do not need to press and hold 
the left mouse button and drag it. You just need to click once to select the endpoint of the line 
after you get the intersection point of the imaginary lines.

 Next, you need to draw the remaining lines to complete the sketch.

14. Move the cursor toward the right in the graphics window. Enter 12 in the length input 
fi eld and 0 in the angle input fi eld in the Dynamic Input; a line between points 7 and 8 
is created.

15. Move the cursor upward in the graphics window. Enter 30 in the length input fi eld and 90 
in the angle input fi eld in the Dynamic Input; a line between points 8 and 9 is created.

16. Move the cursor toward the left in the graphics window. Enter 12 in the length input fi eld 
and 90 in the angle input fi eld in the Dynamic Input; a line between points 9 and 10 is 
created.

17. Exit the Line tool.
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 The fi nal sketch for Tutorial 3 is shown in Figure 2-58.

Figure 2-58  Final sketch for Tutorial 3

Saving the Sketch
1. As it is not possible to save the fi le in the sketching environment, therefore you need to exit 

the sketching environment and then save the fi le. To save the fi le, right-click anywhere in 
the graphics window; the Marking Menu will be displayed. Choose Finish Sketch option 
from the Marking Menu; the sketching environment is closed and you switch to the Home 
view of the part modeling environment.

2. Choose the Save button from the Quick Access Toolbar and save this sketch with the 
name Tutorial3 at the location given below:

 C:\Inventor_2012\c02

3. Choose Close > Close from the Application Menu to close this fi le.

Tutorial 4
In this tutorial, you will draw the basic sketch of the revolved solid model shown in Figure 2-59. 
The sketch that you will draw for creating this revolved solid is shown in Figure 2-60. Do not 
dimension the sketch as the dimensions are given only for reference.  Use the Dynamic Input 
to draw the feature.         (Expected time: 30 min)
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Figure 2-60  Sketch for the revolved modelFigure 2-59  Revolved model for Tutorial 4

 The following steps are required to complete this tutorial:

a. Start a new metric standard part fi le.
b. Invoke the Line tool and draw the sketch with the help of Dynamic Input. 
c. Save the sketch with the name Tutorial4 and close the fi le.

Starting a New File
1. Choose the New tool from the Quick Access Toolbar to display the New File dialog 

box. 

2. Choose the Metric tab to display the standard metric templates. Double-click on 
Standard (mm).ipt to start a new metric part fi le.

Drawing the Sketch
1.  Choose the Line tool from the Draw panel in the Sketch tab or  from the Marking  

Menu. On doing so, you are prompted to select the fi rst point of the line to be 
created. In the Dynamic Input, press TAB and enter 0 in the X co-ordinate fi eld. 
Next, press TAB and enter 0 in the Y coordinate fi eld and press ENTER. 

2. Now you need to draw line 1. Move the cursor toward the left and enter 22 in the length 
input fi eld and enter 180 in the angle input fi eld of the Dynamic Input; line 1 is drawn.

3. Move the cursor upward in the graphics window. Next, enter 4 in the length input fi eld, 
press TAB and enter 90 in the angle input fi eld; line 2 is drawn, as shown in Figure 2-61.

4. Move the cursor toward the left in the graphics window. Next, enter 14 in the length 
input fi eld, press TAB and enter 90 in the angle input fi eld in the Dynamic Input; line 3 
is drawn. 
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Figure 2-61  Sketch after drawing the lines

5. Move the cursor upward in the graphics window. Next, enter 6 in the length input fi eld, 
press TAB and enter 90 in the angle input fi eld in the Dynamic Input; line 4 is drawn.

6. Move the cursor toward the left in the graphics window. Next, enter 8 in the length input 
fi eld, press TAB, and enter 90 in the angle input fi eld in the Dynamic Input; line 5 is 
drawn.

7. Move the cursor upward in the graphics window. Next, enter 6 in the length input fi eld, 
press TAB, and enter 90 in the angle input fi eld in the Dynamic Input; line 6 is drawn.

8. Move the cursor toward the right in the graphics window. Next, enter 40 in the length 
input fi eld, press TAB, and enter 90 in the angle input fi eld; line 7 is drawn.

9. Move the cursor upward in the graphics window. Next, enter 9 in the length input fi eld, 
press TAB, and enter 90 in the angle input fi eld; line 8 is drawn.

10. Move the cursor toward the left in the graphics window. Next, enter 16 in the length input 
fi eld, press TAB, and enter 90 in the angle input fi eld; line 9 is drawn.

11. Move the cursor upward in the graphics window. Next, enter 5 in the length input fi eld, 
press TAB, and then enter 90 in the angle input fi eld; line 10 is drawn.

12. Move the cursor toward the right in the graphics window. Next, enter 20 in the length 
input fi eld, press TAB, and enter 90 in the angle input fi eld; line 11 is drawn.

13. Move the cursor downward in the graphics window. Next, enter 30 in the length input 
fi eld and 90 in the angle input fi eld; line 12 is drawn.

14. The initial  sketch is drawn. Exit the Line tool by choosing Done [ESC] from the Marking 
Menu. 
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Drawing the Fillets
1. Choose the Fillet tool from Sketch > Draw > Fillet/Chamfer drop-down; the

2D Fillet dialog box is displayed with some default value of fi llet radius. Enter 
1.5 in the Radius edit box of this dialog box. Do not press ENTER.

2. Select line 8 and then line 9, refer to Figure 2-61; a fi llet is created between these lines 
and the radius of the fi llet is displayed in the sketch.

3. Similarly, select lines 7 and 8 and then lines 4 and 5 to create a fi llet between these lines. 
Next, right-click, and then choose Done [ESC] from the Marking Menu to exit the Fillet 
tool after creating all fi llets. 

 As all lines are fi lleted with the same radius value, the radius of the fi llet is not displayed 
on other fi llets. This completes the sketch. The fi nal sketch for this tutorial after 
fi lleting all sketches is shown in Figure 2-62.

Figure 2-62  Final sketch after fi lleting

Note
In Figures 2-61 and 2-62, the display of axes and grids have been turned off for a better visibility 
of the lines of the sketch.

Saving the Sketch
1. Choose the Finish Sketch button from the Marking Menu.

2. Choose the Save button from the Quick Access Toolbar and save this sketch with the 
name Tutorial4 at the location given below:

 C:\Inventor_2012\c02

3. Choose Close > Close from the Application Menu to close this fi le.



Drawing Sketches for Solid Models      2-45

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

 Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of 
this chapter:

1. Most designs created in Autodesk Inventor are a combination of sketched features and 
placed features. (T/F)

2. Whenever you start a new fi le in the Part module, the sketching environment is invoked 
by default. (T/F)

3. You cannot turn off the display of grid lines. (T/F)

4. You cannot draw an arc while the Line tool is active. (T/F)

5. In Autodesk Inventor, the two types of sketching entities that can be drawn are __________ 
and __________.

6. In the sketching environment, the __________ tool is used to place a sketch point or a 
center point.

7. Filleting is defi ned as the process of __________ the sharp corners and sharp edges of 
models.

8. You can toggle between the length and angle input fi elds by using _____________ key.

9. You can use _____________ toolbar to precisely enter coordinates of the points in the 
graphics window.

10. You can also delete sketched entities by pressing the __________ key.

11. In Autodesk Inventor, rectangles are drawn as the combination of __________ entities.

12. You can undo the last drawn spline segment when you are still inside the spline drawing 
option by choosing __________ from the Marking Menu displayed.

13. You can exit the Line tool by pressing the _____________ key or by choosing ___________ 
from the ________________ Menu.

 Review Questions
Answer the following questions:

1. In most designs, generally the fi rst feature or the base feature is the placed feature. 
(T/F)

2. You can invoke the options related to sheet metal parts from the .ipt fi le. (T/F)
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3. You can change the current project directory and the project fi les by choosing Projects 
from the Open dialog box. (T/F)

4. You can specify the position of entities dynamically by using the Dynamic Input. (T/F)

5. In Autodesk Inventor, you can save a fi le in the sketching environment. (T/F)

6. In Autodesk Inventor, you can start a new fi le by using the Open dialog box. (T/F) 

7. Which of the following tools in the Tools tab is used to invoke additional toolbars?

  (a) Application Options  (b) Customize
  (c) Document Setting  (d) None of these

8. Which of the following drawing display options is used to interactively zoom in and out 
a drawing?

  (a) Zoom All   (b) Pan
  (c) Zoom   (d) Zoom Window

9. Which of the following keys is used to restore the previous view?

  (a) F5    (b) F6
  (c) F7    (d) F4

10. Which of the following drawing display options prompts you to select an entity whose 
magnifi cation has to be increased?

  (a) Zoom   (b) Pan
  (c) Zoom Selected  (d) None of these

Exercises

Exercise 1
Draw the basic sketch of the model shown in Figure 2-63. The sketch to be drawn is shown in 
Figure 2-64. Do not dimension it, as the dimensions are given only for reference.   
                 (Expected time: 30 min)



Drawing Sketches for Solid Models      2-47

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 2-64  Sketch for Exercise 1Figure 2-63  Model for Exercise 1

Exercise 2
Draw the basic sketch of the model shown in Figure 2-65. The sketch to be drawn is shown in 
Figure 2-66. Do not dimension it, as the dimensions are given only for reference.
              (Expected time: 45 min)

Figure 2-66  Sketch for Exercise 2Figure 2-65  Model for Exercise 2
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Exercise 3
Draw the sketch of the model shown in Figure 2-67. The sketch to be drawn is shown 
in Figure 2-68. Do not dimension it, as the dimensions are given only for reference.
                                                                                                 (Expected time: 45 min)

Figure 2-68  Sketch for Exercise 3Figure 2-67  Model for Exercise 3

Answers to Self-Evaluation Test
1. T, 2. T, 3. F, 4. F, 5. normal, construction, 6. Point, 7. rounding, 8. TAB, 9. Inventor Precise 
Input, 10. DELETE, 11. individual, 12. Back, 13. ESC, Done [ESC], Marking


