
Default Objects
and Patch Grids

 Learning Objectives
After completing this chapter, you will be able to:
• Use the Mirror tool
• Use the Align tool
• Create AEC extended objects
• Create doors
• Create windows
• Create patch grids
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Introduction
In this chapter, you will learn to create the default objects and patch grids in Autodesk 3ds 
Max. Also, you will learn to use the Mirror and Align tools while modeling the objects with 
the help of various primitives and default objects. 

Mirror Tool
  Menu bar:	 Tools > Mirror	  
  Main Toolbar:	Mirror		

The Mirror tool is used to mirror or clone the selected 
object about the center of the current coordinate 
system. You can also move the object while mirroring 

its orientation. To mirror an object, select it and invoke the 
Mirror tool from the Main Toolbar; the Mirror: Screen 
Coordinates dialog box will be displayed, as shown in 
Figure 4-1. Set the parameters in this dialog box and choose 
the OK button to mirror the objects. The two areas in this 
dialog box are discussed next.

Mirror Axis Area
Select the X, Y, Z, XY, YZ, or ZX radio button in the Mirror 
Axis area to define the direction of the object while mirroring. 
The value in the Offset spinner defines the distance of the 
mirrored object from the original one. Figure 4-1  The Mirror: Screen 

Coordinates dialog box

Clone Selection Area
The Clone Selection area is used to define the type of clone created by the Mirror tool. 
By default, the No Clone radio button is selected in this area. As a result,  the selected object 
is mirrored but not retained. Select the Copy radio button to retain the selected object after 
mirroring. You can also change the position of the copied object by entering the required value 
in the Offset spinner in the Mirror Axis area. Select the Instance radio button to mirror the 
selected object as an instance. Select the Reference radio button to mirror the selected object 
as reference of the selected object.

An instance is a type of clone in which the changes are reflected when they are made in the 
original object. Also, if you make any change in the instanced object, then it will transfer to 
the original object.  

A reference object is similar to an instance object with the only difference that the changes 
made in the reference object are not reflected in the original object.  
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Align Tool
  Menu bar:	 Tools > Align > Align	  
  Main Toolbar:	Align 			    
  Keyboard:	 ALT+A			 

The Align tool enables you to align the current object with the target object. To align 
an object using the Align tool, select the current object and then invoke the Align tool 
from the Main Toolbar; the align cursor attached to a pair of crosshairs will be 

displayed, as shown in Figure 4-2. Move the cursor over the target object and click on it; the 
Align Selection (X) dialog box will be displayed, as shown in Figure 4-3. Here, X refers to the 
name of the target object. You need to use the options in the Align Selection (X) dialog box 
to align the objects. Various areas and options in this dialog box are discussed next. 

Figure 4-2  The align cursor in the Top viewport Figure 4-3  The Align Selection 
(Sphere001) dialog box

Align Position Area 
You can select the check box(es) in this area to specify the axis along which you want to align 
the object. You can also select all the check boxes simultaneously. By default, all the check 
boxes are selected.

Current Object/Target Object Area
The Minimum, Center, Pivot Point, or Maximum radio button in the Current Object and 
Target Object areas can be selected to specify different points on the current and target objects 
to be used for alignment. 

Note 
You should try different combinations of axes in the Align Position area. Also, try using different 
options in the Current Object and Target Object areas to notice the difference.
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AEC Extended Primitives
In Autodesk 3ds Max, there are some default objects such as trees, railings, walls, and so on. 
These objects can be used to make a scene more realistic and are known as AEC extended 
objects. All AEC extended objects can be created dynamically using the mouse or by entering 
the parameters in the Keyboard Entry rollout.

To create an AEC extended object, you need to choose Create > Geometry in the Command 
Panel; the Standard Primitives option will be displayed by default in the drop-down list. 
Select the AEC Extended option from the drop-down list and activate the viewport in which 
you want to create the objects. Next, invoke the corresponding tool from the Object Type 
rollout. In this section, you will learn to create and modify the AEC extended objects using 
various tools available in the Object Type rollout. 

Creating a Foliage  
  Menu:		 	 Create > AEC Objects > Foliage		   
  Command Panel:	 Create > Geometry > AEC Extended > 	  
			   Object Type rollout > Foliage		

To create a foliage or a tree, activate the viewport in which you 
want to create it. Then, invoke the Foliage tool from the Object 
Type rollout; the Name and Color, Keyboard Entry, Favorite 
Plants, and Parameters rollouts will be displayed, as shown in 
Figure 4-4. 

In the Favorite Plants rollout, select one of the trees, and 
then double-click on it; the selected tree will be displayed in 
the viewports. One of the sample trees is shown in Figure 4-5. 
Alternatively, you can create a tree by dragging it from the Favorite 
Plants rollout to the desired location in the viewport. Also, you 
can select one of the trees from the Favorite Plants rollout and 
then click in the viewport at the desired location to place it. You 
need to invoke the Zoom Extents All tool to view the entire tree 
in the viewports.

Various rollouts used to create and modify the tree are discussed 
next.

Note
The options in the Name and Color rollout are the same for all AEC extended objects.

The Keyboard Entry rollout is used to create various objects by entering the parameters using 
the keyboard. The method of creating these objects is the same as discussed earlier in Chapter 2. 
However, the railing object cannot be created using the keyboard, therefore, it does not have the 
Keyboard Entry rollout.  

Figure 4-4  Various rollouts 
to create a tree
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Favorite Plants Rollout
The Favorite Plants rollout has a palette consisting of a list of default trees to create them in 
the viewport. By default, the Automatic Materials check box is selected. It is used to assign 
the default material to the trees. If you clear this check box and create a tree, then the tree 
created will not show any material. Also, the default color will be displayed in it. Choose the 
Plant Library button below the Automatic Materials check box; the Configure Palette dialog 
box will be displayed. This dialog box is used to give information such as Name, Scientific 
Name, Type, Description, and Faces about all the default trees in the Favorite Plants rollout. 
You can also use this dialog box to remove or add a particular plant from the palette in the 
Favorite Plants rollout. To do so, select the name of a plant from the Configure Palette dialog 
box and choose the Remove from Palette button; the no option will be displayed in the Fav. 
row, and the selected plant will not be displayed in the Favorite Plants rollout. Similarly, to 
display a plant in the Favorite Plants rollout, select the name of the plant from the Configure 
Palette dialog box, and then choose the Add to Palette button; the no option will be replaced 
by the yes option in the Fav. row. Next, choose the OK button to save the changes. 

Note
To modify the default material of the trees, you need to use the Material Editor tool, which will 
be discussed in detail in the later chapters.

Parameters Rollout
The options in this rollout are used to modify the tree created using the Foliage tool. To do 
so, select the tree and choose the Modify tab in the Command Panel; the Parameters rollout 
will be displayed, as shown in Figure 4-6. Enter a new value in the Height spinner to modify 
the height of the tree. The value in the Density spinner varies from 0.0 to 1.0 and is used 
to set the amount of leaves and flowers in the tree. The value in the Pruning spinner varies 
from 0.0 to 1.0 and is used to remove the branches of the tree based on the value entered in 
this spinner, refer to Figures 4-7 and 4-8. 

Figure 4-5  A tree created using the Foliage tool Figure 4-6  The Parameters rollout
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Figure 4-7  A tree with the 0 value 
in the Pruning spinner

Figure 4-8  A tree with the 0.5 value 
in the Pruning spinner

Choose the New button to view the variation in the placement of leaves, branches, and the 
angle of trunk of the selected plant. When you choose the New button the value in the Seed 
spinner changes accordingly, showing the possible variation in the selected tree. The other areas 
in the Parameters rollout are discussed next. 

       
       Show Area

The options in this area are used to display leaves, trunk, fruits, branches, flowers, and 
roots. Select the check boxes to display the corresponding parts of a tree. 

Note
In the Show area, some options will not be available for some trees. For example, if you select a 
tree that does not have flowers, the Flowers check box will not be available.  

Viewport Canopy Mode Area
The options in this area are used to display the plant in the canopy mode in the viewports. 
The canopy of a plant is a type of covering area which covers the outermost parts of the 
tree such as leaves, branches, and trunk. Select the When Not Selected radio button to 
display the tree in the canopy mode in the viewport, if the tree is not selected. Select the 
Always radio button to display the tree always in the canopy mode, whether it is selected 
or not. Select the Never radio button to display the tree in a simple mode.

Level-of-Detail Area
This area is used to define how a tree will be displayed at the time of rendering. Select the 
Low radio button to display the lowest detail of a tree. It renders the tree in the canopy 
mode, as shown in Figure 4-9. Select the Medium radio button to render the tree with less 
number of faces in the branches and trunk, as shown in Figure 4-10. By default, the High 
radio button is selected. It is used to render the tree with all its faces in the branches and 
trunk. It will provide the highest detail of a tree, as shown in Figure 4-11.   
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Figure 4-11  The tree with high 
level of detail at rendering  

Figure 4-9  The tree with low 
level of detail at rendering

Figure 4-10  The tree with medium 
level of detail at rendering 

Creating a Railing
  Menu bar:	 	 Create > AEC Objects > Railing		   
  Command Panel:	 Create > Geometry > AEC Extended > 	  
			   Object Type rollout > Railing		

To create a railing, activate the viewport in which you want to create it. Then, invoke the Railing 
tool from the Object Type rollout; the Name and Color, Railing, Posts, and Fencing rollouts 
will be displayed, as shown in Figure 4-12. Now, press and hold the left mouse button on the 
left side of the viewport and then drag the cursor to the right side to specify the length of the 
railing. Release the left mouse button to set the length. Now, move the cursor up to specify 
the height of the railing and click on the screen; the railing will be created in the viewports, as 
shown in Figure 4-13. You may need to use the Zoom Extents All tool from the Main Toolbar 
to view the entire railing. 

Various rollouts used to modify the railing are discussed next.

Railing Rollout
The Pick Railing Path button is used to create railing paths using the splines. You can create the 
splines using the tools placed in Create > Shapes in the Command Panel. You will learn more 
about these tools in the later chapters. To create a railing according to the railing path or the 
spline, first create a spline and a railing in the viewport. Next, select the railing and choose 
the Modify tab in the Command Panel. Then, choose the Pick Railing Path button in the 
Railing rollout and move the cursor over the spline in the viewport; the pick cursor will be 
displayed and it will prompt you to pick the spline to create a railing according to the spline 
as path. Next, click on the spline; a railing will be created. Now, set a value in the Segments 
spinner to specify the number of segments in the railing. Select the Respect Corners check 
box to put the corners in the railing to match the corners of the railing path. The Segments 
spinner and the Respect Corners check box will be activated only if you create a railing 
using the railing path. The value in the Length spinner specifies the length of the railing. 
The areas in the Railing rollout are discussed next.

Top Rail Area
The top rail is the topmost part of the railing, refer to Figure 4-13, and the options in 
this area are used to modify the top rail. The Profile drop-down list is used to define 
the cross-section shape of the top rail. Select the Round or the Square option from 
the drop-down list to make the top rail round or square, respectively. Select the none 
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option to remove the top rail from the railing. The values entered in the Depth, Width, 
and Height spinners specify the depth, width, and height of the top rail, respectively, 
refer to Figure 4-14. 

Figure 4-14  The railing with different 
dimensions

Figure 4-12  Partial view of various 
rollouts to create a railing

Figure 4-13  The railing with different parts labeled

Lower Rail(s) Area   	
The lower rail is placed below the top railing, refer to Figure 4-13, and the options  
in this area are used to modify the lower rail of the railing. The Profile drop-down 
list is used to define the shape of the cross-section of the lower rail. The value in 
the Depth spinner specifies the depth of the rail, whereas the value in the Width spinner 
specifies the width of the lower rail. Choose the Lower Rail Spacing button on the left 
side of the Lower Rail(s) area; the Lower Rail Spacing dialog box will be displayed, as 
shown in Figure 4-15. In this dialog box, select the Count check box, if it is not already 
selected. The value in the spinner on the right of this check box specifies the number of 
lower rails in the railing. Choose the Close button to close the dialog box.  
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Posts Rollout
The posts are the left and right supports of the railing, 
refer to Figure 4-13, and the options in this rollout are 
used to modify them. Most of the options in this rollout 
are the same as those discussed in the Lower Rail(s) area 
of the Railing rollout, except the Extension spinner. The 
value in the Extension spinner is used to extend the posts 
of the railing from the bottom of the top rail, as shown 
in Figure 4-16.

Figure 4-15  The Lower Rail 
Spacing dialog box

Fencing Rollout
The fencing is placed in between the posts of the railing, 
refer to Figure 4-13, and the options in this rollout are 
used to modify it. The options in the Type drop-down list 
define the type of fencing in the railing. If you select the 
(none) option in the Type drop-down list, the fence will 
not be displayed and the options in the Picket and Solid 
Fill areas will become inactive. If you select the Pickets 
option in the Type drop-down list, then the pickets will be 
displayed in between the posts, as shown in Figure 4-17. Also, the Picket area will be activated 
in this rollout. If you select the Solid Fill option in the Type drop-down list, then the solid 
box type shape will be displayed in between the posts, as shown in Figure 4-18. Also, the Solid 
Fill area will be activated. The areas in the Fencing rollout are discussed next.

Figure 4-16  The railing with the extension 
in the posts

Figure 4-17  The railing with the Picket 
type of fencing

Picket Area 
You need to select the Pickets option from the Type drop-down list to activate this area. 
The Profile, Depth, Width, and Extension options in this area are the same as those 
discussed in the Posts rollout. The value in the Bottom Offset spinner is used to set the 
height of the picket from the bottom of the railing, refer to Figure 4-19.
 
Solid Fill Area
Select the Solid Fill option from the Type drop-down list to activate this area. The value 
in the Thickness spinner is used to set the thickness of the solid fill. The value in the 
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Top Offset spinner is used to set the distance of the solid fill from the bottom of the top 
railing. The value in the Bottom Offset spinner is used to set the distance of the solid 
fill from the bottom of the railing. The value in the Left Offset spinner is used to set the 
distance of the solid fill from the left post. The value in the Right Offset spinner is used 
to set the distance of the solid fill from the right post, refer to Figure 4-20.

Figure 4-18  The railing with the 
Solid Fill type of fencing

Figure 4-19  The Bottom Offset in the 
Picket fencing

Figure 4-20  Various offsets in the Solid Fill 
fencing

Creating a Wall
  Menu bar:	 	 Create > AEC Objects > Wall		   
  Command Panel:	 Create > Geometry > AEC Extended > 	  
			   Object Type rollout > Wall	  	

To create a wall, activate the Top viewport and then invoke the Wall tool from the Object Type 
rollout; the Name and Color, Keyboard Entry, and Parameters rollouts will be displayed, as 
shown in Figure 4-21. Now, in the Parameters rollout, set the width and height by entering values 
in the Width and Height spinners, respectively. Next, click on the left of the Top viewport 
to create the starting point of the wall. Drag the cursor to the right to define the length of 
the wall and then click on the screen. Now, right-click to exit the command; a wall segment 
will be created, as shown in Figure 4-22. If you want to create another segment of the wall in 
continuation, then you need to repeat the same procedure as followed for the first segment 
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without right-clicking. Next, to create a closed wall, click on the starting point of the first wall 
segment; the Weld Point? dialog box will be displayed, as shown in Figure 4-23. Choose the 
Yes button in this dialog box; a closed wall will be displayed, as shown in Figure 4-24. Next, 
right-click to exit the command. 

Figure 4-21  Various rollouts 
to create a wall

Figure 4-22  A wall segment 

Figure 4-23  The Weld Point? dialog box

Figure 4-24  A closed wall

Various rollouts used to modify the wall are discussed next.
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Keyboard Entry Rollout
This rollout is used to create a wall by entering the parameters in the Keyboard Entry rollout. 
To do so, expand the Keyboard Entry rollout. Enter the values in the X, Y, and Z spinners to 
specify the position of the starting point of the wall segment in the viewport along the axes of 
the home grid or a grid object. Now, choose the Add Point button to add a point. Repeat the 
same procedure to create another segment. Next, choose the Close button to create a closed 
wall. Choose the Finish button to end the creation of the wall. When you choose the Pick 
Spline button, you will be prompted to select a spline in the viewport to create a wall along 
with the spline as a path. You can create a spline using the tools given in Create > Shapes > 
Splines in the Command Panel. You will learn about these tools in the later chapters.

Parameters Rollout
In this rollout, enter the values in the Width and Height spinners to define the width and 
height of the wall, respectively. The Justification area in the Parameters rollout is discussed 
next.

Justification Area
The options in this area are used to align the wall at its baseline. The baseline is the line 
between the front and back sides of a wall and it is equal to the thickness of the wall. By 
default, the Center radio button is selected in this area and is used to align the wall at the 
center of its baseline. Select the Left radio button to align the wall at the left edge of its 
baseline. Select the Right radio button to align the wall at the right edge of its baseline.

Edit Object Rollout
Select the wall and choose the Modify tab in the Command Panel; 
the Edit Object rollout will be displayed, as shown in Figure 4-25. 
Choose the Attach button; it will become active and you will be 
prompted to select another wall in the viewport to attach it with 
the selected wall. When you select another wall, it will automatically 
take the same material as that of the selected wall. Choose the 
Attach Multiple button; the Attach Multiple dialog box will be 
displayed, containing the list of all walls in the viewport. Select the 
multiple walls that you want to attach from the list by holding the 
CTRL key and then choose the Attach button; multiple walls will 
be attached to the selected wall. Figure 4-25  The Edit 

Object rollout

Creating Doors
In Autodesk 3ds Max, there are three tools to create the default doors. These tools are Pivot, 
Sliding, and BiFold. You can use these doors while creating houses, offices, rooms, and so 
on. To invoke the tools for creating doors, choose Create > Geometry in the Command 
Panel; the Standard Primitives option will be displayed in the drop-down list. Select the 
Doors option from the drop-down list and activate the viewport in which you want to create 
the doors. Next, invoke the corresponding tool from the Object Type rollout. In this section, 
you will learn to create and modify different types of doors using various tools available in 
the Object Type rollout. 
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Creating a Pivot Door  
  Menu bar:	 	 Create > AEC Objects > Pivot Door			    
  Command Panel:	 Create > Geometry > Doors > Object Type rollout > Pivot	

The pivot door is jointed or hinged only on one side and the door swings on this side. To 
create the pivot door, invoke the Pivot tool from the Object Type rollout; the Name and 
Color, Creation Method, Parameters, and Leaf Parameters rollouts will be displayed, as 
shown in Figure 4-26. 

Activate the Top viewport and press and hold the left mouse button on the left of the viewport. 
Now, drag the cursor to the right of the viewport and release the left mouse button to define 
the width. Next, move the cursor up or down to define the depth of the door and click on the 
screen to set the depth. Now, again move the cursor up or down to define the height of the door. 
Click on the screen; the pivot door will be created in all viewports, refer to Figure 4-27. 

Figure 4-26  Partial view of various 
rollouts to create a pivot door

Figure 4-27  A pivot door 
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Various rollouts used to create and modify the pivot door are discussed next.

Creation Method Rollout
The options in this rollout are used to creating the pivot door dynamically. You can create the 
pivot door using any of the two methods discussed next.

Width/Depth/Height 
To create the door using this method, make sure the Width/Depth/Height radio button 
is selected. Now, first you need to define the width and depth of the door, and then you 
need to move the cursor to define the height, as discussed earlier while creating the pivot 
door dynamically. 

Width/Height/Depth 
To create the door using this method, you need to select the Width/Height/Depth radio 
button. Now, first you need to specify the width and height of the door, and move the 
cursor to specify the depth. To do so, press and hold the left mouse button on the left 
side of the viewport, drag the cursor to the right of the viewport to specify the width of 
the pivot door, and release the left mouse button. Next, move the cursor up to define the 
height of the door and click on the screen to set the height. Next, move the cursor up or 
down to specify the depth of the door. Click on the screen; the pivot door will be created 
in all viewports. 

Parameters Rollout
The options in this rollout are used to modify the pivot door. Select the pivot door and choose 
the Modify tab in the Command Panel; the Parameters and Leaf Parameters rollouts will 
be displayed. Enter the new values in the Height, Width, and Depth spinners to modify the 
height, width, and depth of the pivot door, respectively. Select the Double Doors check box 
to create two pivot doors, one on the left and other on the right, as shown in Figure 4-28. 
Select the Flip Swing check box to change the direction of swing of the door. Select the Flip 
Hinge check box to change the placement of the joint or the hinge of the pivot door on 
the opposite side. When you select the Double Doors check box, the Flip Hinge check box 
becomes inactive. The value in the Open spinner is used to specify the amount in degree to 
which the door will open, refer to Figure 4-29. The Frame area in the Parameters rollout is 
discussed next.

Frame Area
The options in this area are used to modify the frame of the pivot door. By default, the 
Create Frame check box is selected. If you clear the Create Frame check box, then the 
other options in this area will become inactive. Also, the frame will not be displayed in the 
door. Enter the values in the Width and Depth spinners to specify the width and depth of 
the frame of the pivot door. The value in the Door Offset spinner specifies the location 
of the door in reference to the frame. 
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Figure 4-28  A double pivot door Figure 4-29  An opened double door 

Leaf Parameters Rollout
This rollout is used to modify the leaf of a door. Set a new value 
in the Thickness spinner to modify the thickness of the leaf 
of the door. Enter a new value in the Stiles/Top Rail spinner 
to modify the frame of the door leaf on the top, left, and 
right side, as shown in Figure 4-30. Set a value in the Bottom 
Rail spinner to modify the frame at the bottom of the door 
leaf. The value in the # Panels Horiz spinner specifies the 
horizontal panels on the leaf of the door. The value in the # 
Panels Vert spinner specifies the vertical panels on the leaf of 
the door, refer to Figure 4-30. The value in the Muntin spinner 
is used to specify the width of the gap between the panels of 
the door leaf. The Panels area in the Leaf Parameters rollout 
is discussed next. Figure 4-30  A door with the 

glass panels

Panels Area
The options in this area are used to modify the panels on the door leaf. The three radio 
buttons in this area are discussed next.

None 
Select the None radio button; the panels will not be displayed in the door leaf. 

Glass
Select the Glass radio button to create the glass panels, refer to Figure 4-30. Also, 
the Thickness spinner will be activated. It is used to set the thickness of the glass panel. 
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Beveled
Select the Beveled radio button to create the beveled panels, 
as shown in Figure 4-31. When you select the Beveled radio 
button, the options under this radio button will be activated. 
The Bevel Angle spinner is used to define the angle between 
the outer surface of the door and the panel surface. The 
Thickness 1 spinner is used to define the outer thickness 
of the panel. The Thickness 2 spinner is used to define the 
thickness of the starting point of the bevel. The Middle Thick 
spinner is used to define the inner thickness of the panel. The 
Width 1 spinner is used to define the width of the starting 
point of the bevel and the Width 2 spinner is used to define 
the inner width of the panel. Figure 4-31  A door with 

the beveled panels 

Creating a Sliding Door
  Menu:		 	 Create > AEC Objects > Sliding Door				     
  Command Panel:	 Create > Geometry > Doors > Object Type rollout > Sliding	

A sliding door has two door components, one is fixed, whereas 
the other slides or moves over the fixed component to open. To 
create a sliding door, invoke the Sliding tool from the Object Type 
rollout; the Name and Color, Creation Method, Parameters, and 
Leaf Parameters rollouts will be displayed.
 
Now, to create the sliding door, follow the same procedure as you 
did for the pivot door; a sliding door will be created, as shown 
in Figure 4-32. 

The options in the Name and Color, Creation Method, Parameters, 
and Leaf Parameters rollouts are the same as discussed in the 
pivot door. However, some options in the Parameters rollout are 
different and these are discussed next.

Figure 4-32  A sliding door

Select the Flip Front Back check box to choose the component that you want to place in 
the front. Select the Flip Side check box to change the fixed component to the sliding 
component.    

Creating a BiFold Door
  Menu:		 	 Create > AEC Objects > BiFold Door				     
  Command Panel:	 Create > Geometry > Doors > Object Type rollout > BiFold	

The bifold door has two door components and two joints in it. To create the bifold door, 
invoke the BiFold tool from the Object Type rollout; the Name and Color, Creation Method, 
Parameters, and Leaf Parameters rollouts will be displayed in the Command Panel. Now, 
create a bifold door dynamically using the same method as discussed for creating the pivot 
door; a bifold door will be created, as shown in Figure 4-33. 
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The options in the Name and Color, Creation Method, Parameters, 
and Leaf Parameters rollouts are the same as those discussed in 
the pivot door. 

Creating Windows
In Autodesk 3ds Max, there are six tools to create different types 
of default windows such as Awning, Casement, and so on. You can 
use these windows at various places for architectural designs. 

To invoke these tools for creating the windows, choose Create > 
Geometry in the Command Panel; the Standard Primitives option 
will be displayed in the drop-down list. Now, select the Windows 
option from this drop-down list; various tools will be displayed 
in the Object Type rollout. In this section, you will learn to create various types of windows 
using these tools.

Creating an Awning Window   
  Menu:		 	 Create > AEC Objects > Awning Window				     
  Command Panel:	 Create > Geometry > Windows > Object Type rollout > Awning	

An awning window has one or more cases that are jointed at its top. To create an awning 
window, invoke the Awning tool from the Object Type rollout; the Name and Color, Creation 
Method, and Parameters rollouts will be displayed, as shown in Figure 4-34. 

Activate the Top viewport and press and hold the left mouse button on the left side of the 
viewport, drag the cursor to the right side to specify the width of the window, and release the 
left mouse button. Next, move the cursor up or down to define the depth of the window and 
click on the screen. Now, move the cursor up or down to specify the height of the window. 
Click on the screen; the awning window will be created in all viewports, refer to Figure 4-35. 
The options in the Name and Color and Creation Method rollouts are the same for all 
windows as those discussed in the pivot door.

Parameters Rollout
The options in this rollout are used to modify the awning window. To do so, select the awning 
window and choose the Modify tab in the Command Panel; the Parameters rollout will be 
displayed. Enter new values in the Height, Width, and Depth spinners to modify the height, 
width, and depth of the awning window, respectively. The areas in the Parameters rollout are 
used to modify the window. These areas are discussed next.

Frame
The options in this area are used to modify the frame of the window, refer to Figure 4-35. 
Enter a value in the Horiz. Width spinner to set the width of the horizontal (top and 
bottom) frames of the window. Enter a value in the Vert. Width spinner to set the width of 
the vertical (left and right) frames of the window. Similarly, enter a value in the Thickness 
spinner to set the overall thickness of the frame of the window.  

Figure 4-33  A bifold door
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Figure 4-34  Partial view of various rollouts 
to create an awning window

Figure 4-35  An awning window

Glazing
The Thickness spinner in this area is used to set the thickness of the glaze or the glass 
of the window, refer to Figure 4-35.

Rails and Panels
This area is used to modify the panel of the window. Enter a value 
in the Width spinner to set the width of the fence in the panel. 
Enter a value in the Panel Count spinner to set the number of 
panels in the window, as shown in Figure 4-36.

Open Window
The Open spinner in this area is used to open the window. Its 
value will be in percentage. Figure 4-36  An awning 

window with two panels

Creating a Casement Window
  Menu bar:	 	 Create > AEC Objects > Casement Window			    
  Command Panel:	 Create > Geometry > Windows > Object Type rollout > Casement	

A casement window has one or more cases that are jointed on the sides. To create the casement 
window, invoke the Casement tool from the Object Type rollout; the Name and Color, Creation 
Method, and Parameters rollouts will be displayed. Create a casement window dynamically 
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using the same method as discussed for creating the awning window. A casement window is 
shown in Figure 4-37. 

Parameters Rollout
The options in this rollout are the same as those discussed in the Awning tool, except the 
Casement and Open Window areas. These areas are discussed next.

Casements Area
This area is used to modify the panel of the window. Enter a value in the Panel Width 
spinner to set the width of the fence in the panel. By default, the One radio button is 
selected to create one panel in the window. If you want to create two panels in the window, 
as shown in Figure 4-38, you need to select the Two radio button.

Figure 4-37  A casement window Figure 4-38  A casement window 
with two panels

Open Window Area
The Open spinner in this area is used to open the window. Its value will be in percentage. 
Select the Flip Swing check box to swap the swinging of the panel of the window.

Creating a Fixed Window
  Menu bar:	 	 Create > AEC Objects > Fixed Window				     
  Command Panel:	 Create > Geometry > Windows > Object Type rollout > Fixed	

A fixed window cannot be opened. To create a fixed window, activate the viewport and invoke 
the Fixed tool from the Object Type rollout; the Name and Color, Creation Method, and 
Parameters rollouts will be displayed. 
Now, activate the Top viewport and follow the same method as discussed for creating the 
awning window; a fixed window will be created, as shown in Figure 4-39. 

Parameters Rollout
The options in this rollout are the same as those discussed in the Awning tool, except the 
Rails and Panels area. This area is discussed next.
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Rails and Panels Area
This area is used to modify the panel of the window. Enter a value in the Width spinner to 
set the width of the fence in the panel. Set a value in the #Panels Horiz spinner to define 
the number of horizontal divisions in the panel. Similarly, set a value in the #Panels Vert 
spinner to define the number of vertical divisions in the panel, as shown in Figure 4-40.

Figure 4-39  A fixed window Figure 4-40  A fixed window with 
horizontal and vertical divisions 

  

Creating a Pivoted Window
  Menu bar:	 	 Create > AEC Objects > Pivoted Window				     
  Command Panel:	 Create > Geometry > Windows > Object Type rollout > Pivoted	

A pivoted window has only one panel that is jointed in the middle of the frame. When you 
open this window, it will swing around the horizontal axis. To create a pivoted window, activate 
the viewport and invoke the Pivoted tool from the Object Type rollout; the Name and Color, 
Creation Method, and Parameters rollouts will be displayed. Now, follow the same method 
as discussed while creating the awning window; a pivoted window will be created, as shown 
in Figure 4-41. 

Parameters Rollout
Most of the options in this rollout are the same as discussed in the Awning tool, except the 
Rails and Pivots areas. These areas are discussed next.

Rails Area 
This area is used to modify the panel of the window. Enter a value in the Width spinner 
to set the width of the fence in the panel. 

Pivots Area
When you open the window, by default it rotates about the horizontal axis. To rotate the 
window about the vertical axis, select the Vertical Rotation check box; it will be rotated, 
as shown in Figure 4-42.
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Figure 4-42  A pivoted window 
rotated around the vertical axis 

Figure 4-41  A pivoted window 
rotated around the horizontal axis 

Creating a Projected Window
  Menu bar:	 	 Create > AEC Objects > Projected Window			    
  Command Panel:	 Create > Geometry > Windows > Object Type rollout > Projected	

A projected window has three panels in which the top one 
remains still, and the other two swing in the opposite direction. 
To create a projected window, activate the viewport and invoke 
the Projected tool from the Object Type rollout; the Name 
and Color, Creation Method, and Parameters rollouts will be 
displayed. Now, follow the same method as discussed while 
creating the awning window; a projected window will be created, 
as shown in Figure 4-43.

Figure 4-43  A projected 
window

Parameters Rollout
Most of the options in this rollout are the same as discussed in 
the Awning tool, except the Rails and Panels area. This area is 
discussed next.

Rails and Panels Area
This area is used to modify the panel of the window. Set the value in the Width spinner 
to specify the width of the fence in the panel. Set the value in the Middle Height spinner 
to define the height of the middle panel relative to the frame of the window. Similarly, set 
the value in the Bottom Height spinner to define the height of the bottom panel relative 
to the frame of the window. 

Creating a Sliding Window
  Menu bar:	 	 Create > AEC Objects > Sliding Window				     
  Command Panel:	 Create > Geometry > Windows > Object Type rollout > Sliding	

A sliding window has two panels in which one remains still and the other one slides to open. To 
create a sliding window, activate the viewport and invoke the Sliding tool from the Object Type 
rollout; the Name and Color, Creation Method, and Parameters rollouts will be displayed. 
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Now, create a sliding window dynamically using the same method as discussed while creating 
the awning window; a sliding window will be created, as shown in Figure 4-44.
 
Parameters Rollout
Most of the options in this rollout are the same as those discussed in the Awning tool, except 
the Rails and Panels and Open Window areas. These areas are discussed next.

Rails and Panels
This area is used to modify the panel of the window. Set the value in the Rail Width 
spinner to set the width of the fence in the panel. Set the value in the #Panels Horiz 
spinner to define the number of horizontal divisions in the panel. Set the value in the 
#Panels Vert spinner to define the number of vertical divisions in the panel. Select the 
Chamfered Profile check box to chamfer the fence between the panels, as shown in 
Figure 4-45. 

Open Window
The Open spinner in this area is used to open the window and its value will be in percentage. 
By default, the Hung check box is selected. As a result, the panel slides in the vertical 
direction. Clear the Hung check box to slide the panel in the horizontal direction, refer 
to Figure 4-46.

Figure 4-45  The sliding window 
with two horizontal and vertical 
chamfered divisions

Figure 4-44  The 
sliding window

Figure 4-46  The sliding window 
with the horizontal sliding

Creating Stairs
In Autodesk 3ds Max, there are four tools to create different types of default stairs such as 
LType Stair, Spiral Stair, and so on. To invoke these tools, choose Create > Geometry in the 
Command Panel; the Standard Primitives option will be displayed in the drop-down list. Now, 
select the Stairs options from the drop-down list; various tools will be displayed in the Object 
Type rollout. In this section, you will learn to create various types of stairs using these tools.
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Creating L-type Stairs   
  Menu bar:	 	 Create > AEC Objects > L-Type Stair				     
  Command Panel:	 Create > Geometry > Stairs > Object Type rollout > LTypeStair	

The L-type stairs have two stairways that are jointed at right angles to each other. To create 
the L-type stairs, invoke the LType Stair tool from the Object Type rollout; the Name and 
Color, Parameters, Carriage, Railings, and Stringers rollouts will be displayed, as shown in 
Figure 4-47. 

Now, activate the Top viewport. Press and hold the left mouse button on the left side of the 
viewport, drag the cursor to the right side of the viewport to specify the length of the first 
stairway of the stair, and then release the left mouse button. Next, move the cursor up or down 
at right angle to define the length of the second stairway of the stair and then click on the 
screen. Now, move the cursor up to specify the overall height of the stair and then click on 
the screen; the L-type stairs will be created in all viewports, as shown in Figure 4-48. 

Various rollouts used to create and modify the L-type stairs are discussed next.

Figure 4-48  The L-type open stairsFigure 4-47  Partial view of various 
rollouts to create L-type stairs

Parameters Rollout
The options in this rollout are used to modify the L-type stairs. To do so, select the L-type stairs 
and choose the Modify tab in the Command Panel; the Parameters, Carriage, Railings, and 
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Stringers rollouts will be displayed. The Parameters rollout has a number of areas to modify 
the stairs. These are discussed next.

Type Area
The options in this area are used to define the type of stairs. By default, the Open radio 
button is selected, and therefore the stairs with open steps are created, as shown in 
Figure 4-48. Select the Closed radio button to create the stairs with closed steps, as shown 
in Figure 4-49. Select the Box radio button to create a support for the steps of the stairs, 
as shown in Figure 4-50.      

Figure 4-50  The L-type box stairsFigure 4-49  The L-type closed stairs

 

Generate Geometry Area
The options in this area are used to modify the stairs by incorporating the geometry 
shapes. Select the Stringers check box to create the left and right support for the steps 
of the stairs. Select the Carriage check box to create support for the steps of the stairs. 
Select the Left and Right check boxes in the Handrail group to create the left and right 
handrails, as shown in Figure 4-51. On selecting the Left and Right check boxes in the 
Rail Path group, a path will be created on the left and right of the stairs, as shown in 
Figure 4-52. By using these paths, you can insert the default railings for stairs. To do 
so, invoke the Railing tool from Create > Geometry > AEC Extended > Object Type 
rollout. In the Railing rollout, choose the Pick Railing Path button and move the cursor 
over the path that is created while selecting the Left and Right check boxes in the Rail 
Path of the stairs; the cursor will get changed and prompts you to select the path. Select 
one of the rail paths in the viewport; the default railing will be displayed. Next, modify 
the default railings as discussed earlier in the Railing tool.

Layout Area
The options in this area are used to modify the dimensions of the stairs. Enter a value 
in the Length 1 spinner to set the length of the first stairway. Similarly, enter a value in 
the Length 2 spinner to set the length of the second stairway. The value in the Width 
spinner is used to set the width of the overall steps in the stairs. Enter a value in the Angle 
spinner to set the angle between the second stairway and the landing of the stairs. Enter 
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a value in the Offset spinner to set the distance from the second stairway to the landing 
of the stairs. 

Figure 4-51  The L-Type stairs with handrails, 
carriage, and stringers

Figure 4-52  The L-Type stairs with rail paths

Rise Area
There are three spinners in this area. These spinners are controlled by choosing the buttons 
available on their left side. When you choose one of the buttons, the spinner on the right 
side of that button becomes inactive. You can modify only two spinners at a time. Enter 
a value in the Overall spinner to define the height of stairways. The Riser Ht spinner is 
used to set the height of the risers in the stairs. The Riser Ct spinner is used to set the 
number of risers in the stairs. The riser is the gap between the steps in a stairways.

Steps Area
Enter a value in the Thickness spinner to modify the thickness of the steps of the stairs. 
This spinner is activated only if the Open radio button is selected in the Type area. Select 
the check box on the left side of the Depth spinner; the Depth spinner will become active. 
Set a value in the Depth spinner to modify the depth of the steps of the stairs.

Carriage Rollout
To activate the options in this rollout, make sure the Carriage check box in the Generate 
Geometry area of the Parameters rollout is selected. In the Parameters area of the Carriage 
rollout, enter a value in the Depth spinner to set the depth of the carriage. Enter a value 
in the Width spinner to set the width of the carriage. Choose the Carriage Spacing button 
just below the Width spinner; the Carriage Spacing dialog box will be displayed. Select the 
Count check box, if it is not already selected. The value in the spinner on the right side of the 
Count check box specifies the number of carriages in the stairs. Set the required value and 
then choose the Close button to close the dialog box. The Spring from Floor check box in 
this rollout is used to control the starting point of the carriage from the floor.   
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Railings Rollout
To activate the options in this rollout, you need to select one of the Handrail check boxes in 
the Generate Geometry area of the Parameters rollout. Enter a value in the Height spinner 
to set the height of the railing from the steps of the stairs. The Offset spinner is used to set 
the offset of the railing from the ends of the steps. The value in the Segments spinner is used 
to set the number of segments in the railing. More the number of segments, smoother will be 
the railing. The value in the Radius spinner is used to set the radius of the railing. 

Stringers Rollout
To activate the options in this rollout, you need to select the Stringers check box in the 
Generate Geometry area of the Parameters rollout. Enter a value in the Depth spinner to 
set the distance of the stringers from the floor. The value in the Width spinner is used to 
set the width of the stringers. The Offset spinner is used to set the distance of the stringers 
from the steps. The Spring from Floor check box is used to control the starting point of the 
stringers from the floor.  

Creating Spiral Stairs   
  Menu bar:	 	 Create > AEC Objects > Spiral Stair				     
  Command Panel:	 Create > Geometry > Stairs > Object Type rollout > Spiral Stair	

The spiral stairs have a spiral shaped staircase. To create the spiral stairs, invoke the Spiral 
Stair tool from the Object Type rollout; the Name and Color, Parameters, Carriage, Railings, 
Stringers, and Center Pole rollouts will be displayed. To create the spiral stairs dynamically, 
activate the Top viewport. Next, click on a point in the viewport to specify the center of the 
spiral stair, hold the left mouse button, and drag downward to specify the radius and width. 
Release the left mouse button and move the cursor up or down to specify the overall rise in 
the height. Then, click on the screen; the spiral stairs will be created in all viewports. Different 
types of spiral stairs are shown in Figures 4-53, 4-54, and 4-55. 

Figure 4-53  The spiral 
stairs

Figure 4-55  The spiral 
box stairs

Figure 4-54  The closed spiral 
stairs

Note
The options in the Carriage, Railings, and Stringers rollouts are the same for the Spiral, 
Straight, and UType stairs as discussed in the L-type stairs. 
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Parameters Rollout
In this rollout, the Type, Rise, and Steps areas are the same as discussed in the LType Stair 
tool. But, the Generate Geometry and Layout areas are different and these areas are discussed 
next.

Generate Geometry
The options in this area are used to modify the stairs by incorporating the geometry shapes. 
Select the Stringers check box to create the left and right supports for the steps of the 
stairs. Select the Carriage check box, if it is not already selected, to create support for the 
steps of the stairs. Select the Center Pole check box to create a pole at the center of the 
stairs, refer to Figure 4-53. Select the Inside and Outside check boxes in the Handrail 
area to create the handrails on both sides. The Inside and Outside check boxes in the 
Rail Path area are used to create a path on the left and right sides of the stairs. 

Layout
The options in this area are used to modify the dimensions of the stairs. Select the CCW 
radio button, if it is not already selected, to rotate the stairs in the counterclockwise 
direction. Select the CW radio button to rotate the stairs in the clockwise direction. Enter a 
value in the Radius spinner to set the radius of the spiral stairs. Enter a value in the Revs 
spinner to set the number of revolutions of the stairs. The value in the Width spinner is 
used to set the width of the spiral stairs. 

Center Pole Rollout
To activate the options in this rollout, you need to select the Center Pole check box in the 
Generate Geometry area of the Parameters rollout. In the Parameters area of the Center 
Pole rollout, set a value in the Radius spinner to set the radius of the center pole. Set the 
value in the Segments spinner to set the number of segments of the center pole. Select the 
check box on the left side of the Height spinner to activate it and set the value in this spinner 
to define the height of the pole.

Creating Straight Stairs   
  Menu bar:		  Create > AEC Objects > Straight Stair				     
  Command Panel:	 Create > Geometry > Stairs > Object Type rollout > Straight Stair	

The straight stairs have only one stairway. To create the straight stairs, activate the Top 
viewport and invoke the Straight Stair tool from the Object Type rollout; the Name and 
Color, Parameters, Carriage, Railings, and Stringers rollouts will be displayed.

Now, press and hold the left mouse button on the left side of the viewport, drag the cursor 
to the right side of the viewport to specify the length of the stairs, and release the left mouse 
button. Next, move the cursor up or down to define the width of the stairs and click on the 
screen to set the width. Next, move the cursor up or down to specify the height of the stairs. 
Click on the screen; the straight stairs will be created in all viewports, as shown in Figure 4-56. 
You can also create the closed and box straight stairs in the same way as described in the L-type 
stairs, refer to Figures 4-57 and 4-58.
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Parameters Rollout
In this rollout, all areas are same as discussed in the LType Stair tool, except the Layout area  
and this area is discussed next.

Figure 4-57  The straight 
closed stairs

Figure 4-58  The straight 
box stairs

Figure 4-56  The straight 
stairs

Layout Area
The options in this area are used to modify the dimensions of the stairs. The value in the 
Length spinner is used to set the length and the value in the Width spinner is used to 
set the width of the stairs.    

Creating U-Type Stairs   
  Menu bar:		  Create > AEC Objects > U-Type Stair				     
  Command Panel:	 Create > Geometry > Stairs > Object Type rollout > UTypeStair	

The U-type stairs have two stairways parallel to each other in U shape. To create the U-type  
stairs, activate the Top viewport and invoke the UType Stair tool from the Object Type 
rollout; the Name and Color, Parameters, Carriage, Railings, and Stringers rollouts will be 
displayed.

Next, press and hold the left mouse button on the left side of the viewport, drag the cursor to 
the right side to specify the length of the stairs, and release the left mouse button. Now, move 
the cursor up to define the width of the stairs and the distance between the two stairways. Click 
on the screen to set the width. Next, move the cursor up or down to specify the rise of the 
stairs. Click on the screen; the U-type stairs will be created in all viewports. Different U-type 
stairs are shown in Figures 4-59, 4-60, and 4-61.



Default Objects and Patch Grids		         4-29

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 4-59  The U-type stairs Figure 4-60  The U-type 
closed stairs

Figure 4-61  The U-type box 
stairs

Creating Patch Grids 
The patch grids are 2D objects that are used to create 3D surfaces. To invoke the tools for 
creating the 3D surfaces, choose Create > Geometry in the Command Panel; the Standard 
Primitives option will be displayed in the drop-down list. Now, select the Patch Grids option 
from the drop-down list; the Quad Patch and Tri Patch tools will be displayed in the Object 
Type rollout. In this section, you will learn to create the path grids using these tools. 

Creating a Quad Patch
  Menu bar:	 	 Create > Patch Grids > Quad Patch	  
  Command Panel:	 Create > Geometry > Patch Grids > 	  
			   Object Type rollout > Quad Patch		

You can create a quad patch using the Quad Patch tool. It has 36 visible rectangular faces. 
Each rectangular face is divided into two triangular faces, therefore, in all it has 72 triangular 
faces. To create a quad patch, activate the Top viewport and invoke the Quad Patch tool from 
the Object Type rollout; the Name and Color, Keyboard Entry, and Parameters rollouts will 
be displayed, as shown in Figure 4-62.

Creating the Quad Patch Dynamically
To create the quad patch dynamically, press and hold the left mouse button on the upper 
left side of the Top viewport and drag the cursor to the lower right side of the viewport to 
specify the length and width of the patch. Release the left mouse button; the quad patch will 
be created in all viewports, refer to Figures 4-63 and 4-64. 

Note
The Keyboard Entry rollout is used to create the quad patch and tri patch by entering the 
parameters using the keyboard. The method of creating these patch grids using this rollout is 
the same as discussed earlier.

To view the faces in the quad patch or the tri patch, you need to convert them into editable mesh 
about which you will learn in the later chapters. 
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Figure 4-62  Various rollouts 
to create a quad patch

Figure 4-63  The quad patch

Figure 4-64  The quad patch with rectangular 
and triangular faces in the Top viewport

The Parameters rollout is used to modify the quad patch is discussed next.

Parameters Rollout
This rollout is used to modify the quad patch. To do so, select the quad patch and choose the 
Modify tab in the Command Panel; the Parameters rollout will be displayed. Set the new 
values in the Length and Width spinners to modify the length and width. Similarly, enter 
a value in the Length Segs spinner to specify the number of segments along the length of 
the patch. And, enter a value in the Width Segs spinner to specify the number of segments 
along the width of the patch.

Note
The value 1 in the Length Segs and Width Segs spinners specifies 36 rectangular faces in 
a quad patch. If you increase the number of segments, then the number of faces will also be 
increased accordingly. 
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Creating a Tri Patch
  Menu bar:	 	 Create > Patch Grids > Tri Patch						      
  Command Panel:	 Create > Geometry > Patch Grids > Object Type rollout > Tri Patch	

The object created using the Tri Patch tool is very similar to the object created using the 
Quad Patch tool. It also has 72 visible triangular faces. To create a tri patch, activate the Top 
viewport and invoke the Tri Patch tool from the Object Type rollout; the Name and Color, 
Keyboard Entry, and Parameters rollouts will be displayed, as shown in Figure 4-65.

Next, press and hold the left mouse button on the upper left side of the viewport, drag the 
cursor to the lower right side of the viewport to specify the length and width of the patch, 
and release the left mouse button; the tri patch will be created in all viewports, refer to 
Figures 4-66 and 4-67. 

The Parameters rollout is used to modify the tri patch is discussed next.

Parameters Rollout
This rollout is used to modify the tri patch. To do so, select the tri patch and choose the Modify 
tab in the Command Panel; the Parameters rollout will be displayed. Set the new values in the 
Length and Width spinners to modify the length and width of the tri patch, respectively. 

Figure 4-65  Various rollouts to 
create a tri patch

Figure 4-66  The tri patch

Figure 4-67  The tri patch with triangular faces in 
the Top viewport
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Note
You cannot increase the number of segments in a tri patch. 

Tutorial 1
In this tutorial, you will create a nature scene, as shown in Figure 4-68, using the AEC extended 
objects and the standard primitives. 				      (Expected time: 15 min)	

	 The following steps are required to complete this tutorial:  

a.	 Set the project folder.
b.	 Create the floor.
c.	 Create railings.
d.	 Create trees.
e.	 Change the background color at rendering.
f.	 Render the scene for the final output. 
g.	 Save the file.  
	

Figure 4-68  Model for Tutorial 1

Setting the Project Folder
	 Before starting a new file, it is recommended that you set the project folder.

1.	 Set the project folder with the name c04_tut1 in the 3dsmax folder as discussed in Tutorial 1 
of Chapter 2.

Creating the Floor
	 Start Autodesk 3ds Max and reset it as discussed in the earlier chapters; a new screen 

with default settings is displayed. Next, you need to use the Plane tool from Standard 
Primitives to create the floor of the scene.

1.	 Activate the Top viewport. Choose Create > Geometry in the Command Panel; the 
Standard Primitives option is displayed in the drop-down list. Invoke the Plane tool from 
the Object Type rollout.
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2.	 In the Keyboard Entry rollout, set the values as given below:

  	 Length: 1485.0		  Width: 1605.15

3.	 Choose the Create button in the Keyboard Entry rollout; a plane is displayed in all 
viewports. Now, invoke the Zoom Extents All tool or press the Z key to display the entire 
plane in the viewports.

4.	 In the Name and Color rollout, enter floor and press ENTER; the plane is named as 
floor.

5.	 Use the color swatch to modify the color of the floor to green.   

6.	 Activate the Perspective viewport and set the view using the Zoom and Orbit tools, as 
shown in Figure 4-69.

Figure 4-69  The floor after using the Zoom and Orbit tools 

Creating Railings
	 You need to use the Railing tool from AEC Extended to create railings around the 

floor.

1.	 Choose Create > Geometry in the Command Panel; a drop-down list is displayed below 
the Geometry button. Select the AEC Extended option from the drop-down list and then 
invoke the Railing tool from the Object Type rollout.

2.	 Activate the Top viewport and invoke the Maximize Viewport Toggle tool or press 
the ALT+W keys to maximize the Top viewport. 
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3.	 Move the cursor to the upper left corner of the floor, press and hold the left mouse button, 
and drag the cursor to the upper right corner of the floor to specify the length of the 
railing. Release the left mouse button to set the length, and then move the cursor up to 
specify the height of the railing. Click on the screen; a railing is created. Next, invoke the 
Maximize Viewport Toggle tool; the railing is displayed in all viewports.

4.	 In the Name and Color rollout, enter railing01 and press ENTER.

5.	 Use the color swatch to modify the color of the railing01 and enter the values given 
below:  

	 Red: 177		  Green: 88		  Blue: 26

6.	 Make sure the railing01 is still selected. Choose the Modify tab in the Command Panel; 
the Railing, Posts, and Fencing rollouts are displayed.

7.	 In the Railing rollout, set the values as given below:

  	 Length: 1400.0		
	
	 Top Rail area
	 Profile: Round	 Depth: 10.0	
	 Width: 3.0		  Height: 100.0 

	 Lower Rail(s) area
	 Profile: Round	 	 Depth: 4.0	
	 Width: 3.0		
	
8.	 Choose the Lower Rail Spacing button in the Lower Rail(s) area; the Lower Rail  

Spacing dialog box is displayed. Make sure the Count check box is selected. Next, 
set the value 3 in the spinner on the right side of the Count check box and choose 
the Close button; the railing is displayed in all viewports, as shown in Figure 4-70.

9.	 In the Posts rollout, set the values as given below:
	
	 Profile: Round	 	 Depth: 7.0	
	 Width: 5.0			   Extension: 2.0
	
10.	 Choose the Post Spacing button in the Post rollout; the Post Spacing dialog box is 

displayed. Make sure the Count check box is selected. Then, set the value 4 in 
the spinner on the right side of the Count check box and choose the Close 
button.

11.	 In the Fencing rollout, select (none) from the Type drop-down list.

Note
If you want to add fencing in the railing, then select the type of fencing from the Type drop-down 
list and set the parameters in the respective area. 
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Figure 4-70  The railing01 displayed in all viewports 

12.	 Make sure the railing01 is selected in the Top viewport. Now, invoke the Select and Move 
tool from the Main Toolbar and align the railing manually, as shown in Figure 4-71.  

Figure 4-71  The railing01 in all viewports after aligning it in the Top viewport
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 	 Next, you need to create one more railing.

13.	 Activate the Top viewport and invoke the Railing tool. Create one more railing at the 
right angle of the railing01 using the same method as discussed for creating the railing01, 
refer to Figure 4-72.

Note
When you create another railing, all dimensions of the railing01, except the Length and Height, 
will be taken automatically.

14.	 In the Name and Color rollout, enter railing02 and press ENTER.

15.	 Assign the same color to the railing02 as was assigned to the railing01. 

16.	 Make sure the railing02 is selected. Next, choose the Modify tab in the Command Panel; 
the Railing, Post, and Fencing rollouts are displayed.

17.	 In the Railing rollout, set the values as given next:

  	 Length: 600.0
	
	 Top Rail area
	 Height: 100.0

18.	 Invoke the Select and Move and Select and Rotate tools and align the railing02 in all 
viewports, as shown in Figure 4-72.	

Figure 4-72  The railing02 in all viewports after alignment
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	 Next, you need to create another railing.

19.	 Invoke the Railing tool and activate the Top viewport. Create another railing starting from 
the endpoint of railing02 using the same method as discussed earlier.

20.	 In the Name and Color rollout, enter railing03 and press ENTER; the railing is named 
as railing03.

21.	 Assign the  same color to the railing03 as was assigned to the railing01. 

22.	 Make sure the railing03 is selected. Choose the Modify tab in the Command Panel; the 
Railing, Posts, and Fencing rollouts are displayed.

23.	 In the Railing rollout, set the values as given below:

  	 Length: 600.0
	 Top Rail area
	 Height: 100.0

24.	 Invoke the Select and Move tool and make sure the railing03 is aligned in all viewports, 
as shown in Figure 4-73.

Figure 4-73  The railing03 starting from the endpoint of railing02 after alignment

25.	 Activate the Top viewport and select the railing03. Invoke the Select and Rotate tool, 
move the cursor over the Z-axis and rotate it to -45 degrees in the clockwise direction, as 
shown in Figure 4-74.
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Figure 4-74  The railing03 rotated in the Top viewport

Note
While rotating the railing03, invoke the Angle Snap Toggle tool from the Main Toolbar to 
measure the angle of rotation in increments.  

	 Now, you need to create the fourth railing.

26.	 Activate the Top viewport and create another railing starting from the endpoint of 
railing03.

27.	 In the Name and Color rollout, enter railing04 and press ENTER.

28.	 Assign the same color to the railing04 as was assigned to the railing01. 

29.	 Make sure the railing04 is selected. Choose the Modify tab in the Command Panel; the 
Railing, Post, and Fencing rollouts are displayed.

30.	 In the Railing rollout, set the values as given below:

  	 Length: 310.0
	
	 Top Rail area
	 Height: 100.0

31.	 Make sure the railing04 is aligned in all viewports, as shown in Figure 4-75.
	
32.	 Next, invoke the Select By Name tool; the Select From Scene dialog box is displayed. 

Now, select the railing02, railing03, and railing04 and choose the OK button; the railings 
are selected in the viewports.   

33.	 Invoke the Mirror tool from the Main Toolbar; the Mirror: Screen Coordinates dialog box 
is displayed. In the Mirror Axis area of this dialog box, select the X radio button. In the 
Offset spinner, set the value -990. In the Clone Selection area, select the Copy radio button 
and choose the OK button; one copy of all railings created earlier is displayed and they 
are automatically named as railing005, railing006, and railing007, refer to Figure 4-76. 
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Figure 4-75  The railing04 created from the endpoint of railing03 and aligned in all viewports

34.	 Adjust the view in the Perspective viewport using the tools in the viewport navigation 
controls, refer to Figure 4-76.

Figure 4-76  The railings displayed in all viewports
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Creating Trees
	 Next, you need to use the Foliage tool from AEC Extended to create the trees.

1.	 Choose Create > Geometry in the Command Panel; a drop-down list is displayed below 
the Geometry button. Select the AEC Extended option from the drop-down list and then 
invoke the Foliage tool from the Object Type rollout.

2.	 Activate the Top viewport. In the Favorite Plants rollout, select the Generic Palm tree 
and double-click on it; the tree is created and displayed in all viewports. 

Note
If the Generic Palm tree is not displayed in the palette of the Favorite Plants rollout, then 
choose the Plant Library button on the bottom of the rollout; the Configure Palette dialog box is 
displayed. Select the Generic Palm tree and double-click on it; the yes option is displayed in the 
Fav. row indicating that the tree will be available in the palette. Next, choose the OK button.

3.	 In the Name and Color rollout, enter tree01 and press ENTER; the tree is named as 
tree01.

4.	 Make sure the tree01 is still selected. Choose the Modify tab in the Command Panel; the 
Parameters rollout is displayed.

5.	 In the Parameters rollout, set the following parameters:

  	 Height: 300.0		
	
	 Use the default values for other options.

6.	 In the Top viewport, invoke the Select and Move tool and move the tree01 toward the 
railing01 in all viewports, as shown in Figure 4-77.	

7.	 Next, create multiple copies of the tree01 in the Top viewport and align them using the 
Select and Move tool, as shown in Figure 4-78.

Changing the Background Color in the Final Output
1.	 Change the background color to light blue for the final output as discussed in Tutorial 1 

of Chapter 2, using the following parameters:

	 Red: 145 		  Green: 241		  Blue: 244



Default Objects and Patch Grids		         4-41

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 4-77  Alignment of the tree01 in all viewports 

Figure 4-78  Multiple copies of tree01 created and aligned in all viewports
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Rendering the Scene for the Final Output
1.	 Activate the Perspective viewport. 

2.	 Invoke the Render Production tool from 
the Main Toolbar; the Perspective, frame 
0, Display Gamma:2.2, RGBA Color16 
Bits/Channel (1:1) dialog box is displayed, 
showing the final output of the scene at one 
frame, refer to Figure 4-79.

Figure 4-79  The final output at rendering

3.	 Close this window.

	 You can view the final rendered image 
of this model by downloading the file 
c 0 4 _ 3 d s m a x _ 2 0 1 2 _ re n d e r. z i p  f ro m 
http://www.cadcim.com. The path of the file is 
as follows:

	
	 Textbooks > Animation and Visual Effects > 3ds Max > Autodesk 3ds Max  2012: A Comprehensive 

Guide

Saving the File
1.	 Save the file with the name c04tut1.max as discussed in earlier chapters. The location of 

this file is given below:

	 \Documents\3dsmax\c04_tut1\scenes

Tutorial 2
In this tutorial, you will create a scene, as shown in Figure 4-80, using the AEC extended 
objects and the standard primitives. 				      (Expected time: 15 min) 

Figure 4-80  Model for Tutorial 2
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	 The following steps are required to complete this tutorial:  

a.	 Set the project folder.
b.	 Create the floor.
c.	 Create railings.
d.	 Create the room.
e.	 Create the window.
f.	 Create the door.
g.	 Create trees.
h.	 Change the background color at rendering.
i.	 Render the scene for the final output. 
j.	 Save the file.  	

Setting the Project Folder
	 Before starting a new file, it is recommended that you set the project folder.

1.	 Set the project folder with the name c04_tut2 in the 3dsmax folder as discussed in Tutorial 1 
of Chapter 2.

Creating the Floor
	 Start Autodesk 3ds Max and reset it as described earlier; a new screen with default settings 

is displayed. Next, you need to use the Plane tool from Standard Primitives to create the 
floor of the scene.

1.	 Activate the Top viewport and choose Create > Geometry in the Command Panel; the 
Standard Primitives option is displayed in the drop-down list. Invoke the Plane tool from 
the Object Type rollout.

2.	 In the Keyboard Entry rollout, set the values as given below:

  	 Length: 1100.0			   Width: 1200.0

3.	 Choose the Create button from the Keyboard Entry rollout; a plane is created in all 
viewports. Invoke the Zoom Extents All tool to display the entire plane in all viewports.

4.	 In the Name and Color rollout, enter floor and press ENTER; the plane is named as 
floor.

5.	 Modify the color of the floor by entering the values as given below:

	 Red: 61		  Green: 135		  Blue: 6
 
6.	 Activate the Perspective viewport and press the G key to hide grids in it. Also, set the view 

using the Zoom and Orbit tools, as shown in Figure 4-81.
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Figure 4-81  The floor in the Perspective viewport

Creating Railings
	 Next, you need to use the Railing tool from AEC Extended to create railings around the 

floor.

1.	 Activate the Top viewport and create a railing starting from the upper left corner of the 
floor to its upper right corner.

2.	 In the Name and Color rollout, enter railing01 and press ENTER.

3.	 Use the color swatch and change the color of the railing01 by entering the values as given 
below:

	
	 Red: 177		  Green: 88		  Blue: 27

4.	 Make sure the railing01 is still selected. Choose the Modify tab in the Command Panel; 
the Railing, Post, and Fencing rollouts are displayed.

5.	 In the Railing rollout, set the values as given below:

  	 Length: 1200.0		
	
	 Top Rail area
	 Profile: Round	 Depth: 15.0	
	 Width: 13.0		 Height: 100.0 

	 Lower Rail(s) area
	 Profile: Round	 Depth: 7.0		  Width: 7.0		

6.	 Choose the Lower Rail Spacing button in the Lower Rail(s) area; the Lower Rail Spacing 
dialog box is displayed. Select the Count check box and set the value 3 in the spinner on 
the right side of the Count check box and choose the Close button.
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7.	 In the Posts rollout, set the values as follows:
	
	 Profile: Round	 Depth: 10.0		
	 Width: 5.0		  Extension: 0.0
	
	 Choose the Post Spacing button in the Post rollout; the Post Spacing dialog box is 

displayed. Select the Count check box and set 5 in the spinner on the right of the Count 
check box and choose the Close button.

8.	 In the Fencing rollout, set the following parameter:
	
	 Type: (none)	

9.	 Invoke the Select and Move tool and align the railing01 in all viewports, as shown in 
Figure 4-82. 	

Figure 4-82  The railing01 in all viewports after alignment

10.	 Next, create the other railings to surround the floor using the same dimensions except for 
the length. Also, activate the Perspective viewport and set the view using the Pan, Zoom, 
and Orbit tools, as shown in Figure 4-83.
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Figure 4-83  The railings displayed in all viewports 

Creating the Room 
	 You need to use the Wall tool from AEC Extended to create the walls of the room.

1.	 Activate the Top viewport. Choose Create > Geometry in the Command Panel; a 
drop-down list is displayed below the Geometry button. Select the AEC Extended option 
from the drop-down list and then invoke the Wall tool from the Object Type rollout.

2.	 In the Parameters rollout of the wall, set the values as given below:

	 Width: 5.0		  Height: 230.0 

3.	 Next, click on the upper left side of the Top viewport to specify the starting point of the 
wall, drag the cursor on the right side to define the length, and then click on the screen; 
a wall segment is created. Then, create another segment of the wall in continuation at 
the right angle of the first segment. Repeat the same procedure to create the wall in a 
rectangular shape, refer to Figure 4-84. Now, click on the starting point of the first wall 
segment; the Weld Point? message box is displayed. Choose the Yes button to weld the 
end points of the wall. Next, right-click to end the creation of the wall.
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Note
You can modify the wall using the tools in the Select and Scale flyout in the Main Toolbar.

4.	 In the Name and Color rollout, enter wall and press the ENTER key.

5.	 Use the color swatch and change the color of the wall by entering the values given 
below:

	
	 Red: 248		  Green: 231		  Blue: 120

6.	 Invoke the Select and Move tool and align the wall in all viewports, as shown in 
Figure 4-84.

Figure 4-84  The wall displayed in all viewports 

7.	 Next, select Standard Primitives from the drop-down list below the Geometry button. 
Invoke the Box tool from the Object Type rollout to create the roof of the wall.

8.	 Activate the Top viewport and create a box. 

9.	 In the Name and Color rollout, enter roof and press the ENTER key.

10.	 Change the color of the roof by entering the values as given below:  

	 Red: 143		  Green: 225		  Blue: 87

11.	 In the Parameters rollout, set the values in the Length and Width spinners to cover the 
upper portion of the wall, refer to Figure 4-85. Set the value 5.0 in the Height spinner.
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Figure 4-85  The roof of the wall in all viewports after alignment

12.	 Invoke the Select and Move tool and align the roof at the top of the wall in all viewports, 
refer to Figure 4-85.

13.	 Activate the Front viewport and make sure the roof is selected.

14.	 Invoke the Mirror tool from the Main Toolbar; the Mirror: Screen Coordinates dialog 
box is displayed. In the Mirror Axis area of this dialog box, select the Y radio button. 
In the Offset spinner, set the value 0. In the Clone Selection area, select the Copy radio 
button and choose the OK button; the roof001 is displayed at the top of the roof.

15.	 In the Name and Color rollout, modify the name as roof fencing.

16.	 Use the color swatch to change the color of the roof fencing by entering the values as given 
below:

	 Red: 243		  Green: 93		  Blue: 47

	 Make sure the roof fencing is still selected. 

17.	 Invoke the Select and Uniform Scale tool from the Main Toolbar and right-click  
on it; the Scale Transform Type-In dialog box is displayed. Now, in the 
Offset: Screen area, set the value 105 and press ENTER; the roof fencing is scaled, 
as shown in Figure 4-86. Close this dialog box.

	 Next, you need to create fencing for the corners of the wall.
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Figure 4-86  The roof fencing after scaling in the Front viewport 

18.	 Activate the Top viewport and invoke the Box tool. In the Keyboard Entry rollout, set 
the values as given below:

  	 X: -300 		  Length: 6.0		  Width: 1.0	 	 Height: 290.207 

Note
You may need to adjust the height of the box, if you have modified the size of the wall earlier.  

19.	 Next, choose the Create button; a box is displayed in all viewports. 

20.	 In the Name and Color rollout, enter fc01 and press ENTER; the box is named as fc01.

21.	 Assign the same color to the fc01 that was assigned to the roof fencing.

22.	 Invoke the Maximize Viewport Toggle tool to maximize the Top viewport.               

23.	 Invoke the Zoom Region tool and drag a selection box around the roof fencing and 
the lower left corner of the wall to zoom in the selected portion of the Top viewport. 
Next, invoke the Select and Move tool and align the fc01 with the wall, as shown 
in Figure 4-87.

24.	 Next, make sure the fc01 is selected in the Top viewport and invoke the Select and Rotate 
tool. Now, press and hold the SHIFT key, move the cursor over the Z-axis, and rotate it 
until the value in the Z spinner in the coordinate display becomes 90; the copy of fc01 
gets rotated and it is automatically named as fc002.  
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25.	 Invoke the Select and Move tool and align the fc002 with the wall, as shown in 
Figure 4-88.  

Figure 4-87  The fc01 in the Top viewport 
after alignment

Figure 4-88  The fc002 in the Top viewport 
after alignment

26. Next, select fc01 and fc002 simultaneously by holding the CTRL key and group them as 
fencing01.

27. Select the fencing01 and create three copies of it. The copies are automatically named as 
fencing002, fencing003, and fencing004. Now, align them at the corners of the wall using 
the Select and Rotate and Select and Move tools, refer to Figure 4-89.  Also, you can use 
the Zoom tool to view the corners of the wall.  

28.	 Next, invoke the Maximize Viewport Toggle tool to view the four viewports, as shown in 
Figure 4-89.  

Figure 4-89  The fencing at the four corners of the wall in all viewports
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Note
You can also use the Mirror tool to create copies of fencing01. 

Creating the Window
	 You need to use the Awning tool to create a window.

1.	 Choose Create > Geometry in the Command Panel; a drop-down list is displayed. Select 
the Windows option from the drop-down list and then invoke the Awning tool from the 
Object Type rollout.

2.	 Activate the Top viewport. Press and hold the left mouse button on the left of the viewport, 
drag the cursor to the right to specify the width of the window, and then release the left 
mouse button. Next, move the cursor up to define the depth of the window, and then click 
on the screen. Now, move the cursor up to specify the height of the window and then click 
on the screen; an awning window is created in all viewports.

3.	 In the Name and Color rollout, enter window and press ENTER; the window is named 
as window.

4.	 Use the color swatch to change the color of the window by entering the following values:  

	 Red: 135			   Green: 59			   Blue: 8  

5.	 Make sure the window is still selected. Choose the Modify tab in the Command Panel; the 
Parameters rollout is displayed.

6.	 In the Parameters rollout, set the values as given below:

  	 Height: 148.826 	 	 Width: 106.116 		 	 Depth: 10.0
	
	 Frame area
	 Horiz. Width: 8.94	 	 Vert. Width: 8.94 	 	 Thickness: 0.5
	
	 Glazing area	 		
	 Thickness: 0.25

	 Rails and Panels area
	 Width: 14.554		  Panel Count: 3
	
	 Open Window area
	 Open: 25

	 You may need to adjust the height, length, and width of the window according to the wall 
size in your scene.

 
7.	 Next, align the window on the left of the wall in all viewports, as shown in Figure 4-90.
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Figure 4-90  The window in all viewports after alignment

Creating the Foot Support
	 Next, you need to create a box primitive to create the foot support.

1.	 Activate the Top viewport and create a box. 

2.	 In the Parameters rollout, set the values as given below:

  	 Length: 157.098		  Width: 135.743		 Height: 10.0

3.	 In the Name and Color rollout, enter foot support and press ENTER.

4.	 Use the color swatch to change the color of the foot support by entering the following 
values:  

	 Red: 241		  Green: 249		  Blue: 200

5.	 Align the foot support with the front side of the wall in all viewports, as shown in 
Figure 4-91. 

Creating the Door
	 You need to use the Pivot tool from Doors to create a door.

1.	 Choose Create > Geometry in the Command Panel; a drop-down list is displayed below 
the Geometry button. Select the Doors option from the list and invoke the Pivot tool from 
the Object Type rollout.
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Figure 4-91  The foot support in all viewports after the alignment

2.	 Activate the Top viewport. Press and hold the left mouse button on the left of the viewport, 
drag the cursor to the right to specify the width of the door, and release the left mouse 
button. Next, move the cursor up to define the depth of the door, and then click on the 
screen. Next, move the cursor up again to specify the height of the door and click on the 
screen; the pivot door is created in all viewports.

3.	 In the Name and Color rollout, enter door as the name of the pivot door and assign it 
the same color that was assigned to the window.

4.	 Make sure the door is still selected. Choose the Modify tab in the Command Panel; the 
Parameters and Leaf Parameters rollouts are displayed.

5.	 In the Parameters rollout, set the values as given below:

  	 Height: 200.0 	 	 Width: 120.341 		 Depth: 12.0
	 Select the Flip Swing check box.
	 Open: 30
	
	 Frame area
	 Make sure the Create Frame check box is selected.	
	 Width: 2.0		  	 Depth: 1.0	 	 Door Offset: 0.0

	 You may need to set the height and width of the door according to the size of the wall in 
your scene.
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6.	 In the Leaf Parameters rollout, set the values as given below:

  	 Thickness: 2.0 	 	 Stiles/Top Rail: 10.0 	 Bottom Rail: 20.0
	 # Panels Horiz: 3		  # Panels Vert: 4		 Muntin: 3.265

	 Panels area			
	 Select the Beveled radio button and set the values as given below:

	 Bevel Angle: 45.0		  Thickness 1: 9.46	 Thickness 2: 10.0
	 Middle Thick: 3.0		  Width 1: 3.0		  Width 2: 3.0
	
7.	 Next, align the door in all viewports, as shown in Figure 4-92.

Figure 4-92  The door in all viewports after alignment

Note 
You need to apply the boolean command on the wall to see inside the room through the window 
and the door. You will learn about this in the later chapters.

Creating the Trees
	 You need to use the Foliage tool from AEC Extended to create the trees.

1.	 Choose Create > Geometry in the Command Panel; a drop-down list is displayed. Select 
the AEC Extended option and invoke the Foliage tool from the Object Type rollout.

2.	 Activate the Top viewport. Select the Banyan tree from the Favorite Plants rollout and 
double-click on it; a tree is displayed in all viewports.
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3.	 In the Name and Color rollout, enter tree01 as the name of the tree.

4.	 Make sure the tree01 is still selected. Choose the Modify tab in the Command Panel; the 
Parameters rollout is displayed.

5.	 In the Parameters rollout, set the values as given below:

  	 Height: 120.0	
	
	 Level-of-Detail area 	 	
	 Select the Medium radio button.
	
	 Use the default values for other options.

6.	 Invoke the Select and Move tool and align the tree01 in the Top viewport, as shown in 
Figure 4-93.	

Figure 4-93  The tree01 displayed in all viewports after alignment

	 Now, you need to create another tree. 

7.	 Activate the Top viewport. Choose the Create tab in the Command Panel and make sure 
the Foliage tool is invoked. Now, select the American Elm tree from the Favorite Plants 
rollout and double-click on it; the tree is displayed in all viewports.

8.	 In the Name and Color rollout, enter tree02 as the name of the new tree created.
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9.	 Choose the Modify tab in the Command Panel; the Parameters rollout is displayed.

10.	 In the Parameters rollout, set the values as given below:

  	 Height: 300.0

	 Use the default values for other options.

11.	 Invoke the Select and Move tool and align the tree02 in all viewports, refer 
to Figure 4-94.

                                                                                                                                                      
        

Figure 4-94  The tree02 in all viewports after the alignment

  	

Changing the Background Color in the Final Output
1.	 Change the background color to light blue for the final output, as discussed in Tutorial 1 

of Chapter 2, using the following parameters:

	 Red: 145 		  Green: 241		  Blue: 244

Rendering the Scene for the Final Output
1.	 Activate the Perspective viewport. 

2.	 Invoke the Render Production tool from the Main Toolbar; the Perspective, frame 0, 
Display Gamma: 2.2, RGBA Color16 Bits/Channel (1:1) window is displayed. This dialog 
box shows the final output of the scene at one frame, refer to Figure 4-95.

3.	 Close this window.
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Figure 4-95  The final output of the scene at rendering

	 You can view the final rendered image of this model by downloading the file 
c04_3dsmax_2012_render.zip from http://www.cadcim.com. The path of the file is as follows:

	
	 Textbooks > Animation and Visual Effects > 3ds Max > Autodesk 3ds Max  2012: A Comprehensive 

Guide

Saving the File
1.	 Save the file with the name c04tut2.max as discussed in earlier chapters. The location of 

this file is given below:

	 \Documents\3dsmax\c04_tut2\scenes

 Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following tools is a part of the AEC Extended objects?
	
		  (a) Foliage		  		  (b) Railing
		  (c) Wall		 			   (d) All of these

2.	 Which of the following tools is used to create doors?
	
		  (a) Awning		  		  (b) Bifold
		  (c) Projected	 			   (d) Fixed
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3.	 Which of the following tools is used to create windows? 

		  (a) Pivot		  		  (b) Railing		
		  (c) Casement 				    (d) Bifold	

4.	 Which of the following tools is used to create stairs?
	
		  (a) Straight Stair	 		  (b) UType Stair
		  (c) None of these			   (d) Both (a) and (b)

5.	 To activate the Align tool, you need to press the __________ keys.

6.	 The __________ button in the Favorite Plants rollout of  the Foliage tool in AEC Extended 
is used to give information about all the default trees. 

7.	 You can increase the number of lower rails in the railing by entering the value in the 
___________ spinner of the __________ dialog box.

8.	 The Mirror tool is used to clone an object about the center of the current coordinate 
system. (T/F)

9.	 You can change the default material of the plants that you create using the tools given in 
Create > Geometry > AEC Extended > Foliage > Favorite Plants rollout. (T/F)

10.	  The Align tool is used to align the current object with the target object. (T/F)

 Review Questions
Answer the following questions:

1.	 Which of the following tools is used to create patch grids? 

		  (a) Tri Patch	 			   (b) Tetra Patch
		  (c) Both (a) and (b)			   (d) None of these

2.	 Which of the following tools is used to create spiral stairs?

		  (a) LType Stair				    (b) Straight stair
		  (c) UType Stair				   (d) None of these

3.	 Which of the following rollouts is used to modify the panels of the doors?

		  (a) Name and Color	 		  (b) Parameters
		  (c) Leaf Parameters			   (d) Creation Method

4.	 An instance of an object is a clone in which the changes are reflected when they are made 
in the original object. (T/F)
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5.	 To invoke the Tri Patch tool, you need to choose Create > Geometry > AEC Extended 
from the drop-down list in the Command Panel. (T/F)

6.	 You can create default trees in the viewports by invoking the Foliage tool from the AEC 
Extended drop-down list. (T/F)

7.	 You cannot increase the number of segments in a quad patch object. (T/F)

8.	 The object created using the Quad Patch tool has__________ rectangular and __________ 
triangular faces.

9.	 When you select the stair in the viewport and choose the Modify tab in the Command 
Panel, the __________, __________, __________, and __________ rollouts are displayed.

10.	 The object created using the Tri Patch tool has__________ triangular faces.

 Exercises

Exercise 1
Start Autodesk 3ds Max 2012 and then perform the following operations:

1.	 Choose Create > Geometry in the Command Panel; a drop-down list will be displayed. 
Select  the AEC Extended option from the drop-down list. 

2.	 Invoke the Foliage tool from the Object Type rollout, create different default plants given 
in the Favorite Plants rollout, and then notice the difference. Also, try to modify the plants 
using different options given in the Parameters rollout.   

3.	 Invoke the Railing tool and create a railing. In the Railing, Posts, and Fencing rollouts, 
try using different options and notice the difference.

4.	 Choose Create > Geometry in the Command Panel; a drop-down list will be displayed. 
Select Doors from the drop-down list. Create different type of doors using the Pivot, 
Sliding, and BiFold tools in the Object Type rollout. Choose the Modify tab in the 
Command Panel, and in the Parameters rollout of each door, set different values in the 
Open spinner to notice the difference. 

5.	 Choose Create > Geometry in the Command Panel; a drop-down list will be displayed. 
Select Windows from the drop-down list. Create different type of windows using the 
tools in the Object Type rollout. Choose the Modify tab in the Command Panel, and in 
the Parameters rollout of window, set different values in the Open spinner to notice the 
difference.
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6.	 Choose Create > Geometry in the Command Panel; a drop-down list will be displayed. 
Select Stairs from the drop-down list. Create different type of stairs using the tools in the 
Object Type rollout and notice the difference in the stairs.

7.	 Choose Create > Geometry in the Command Panel; a drop-down list will be displayed. 
Select Patch Grids from the drop-down list. Create different patches using the Quad 
Patch and Tri Patch tools in the Object Type rollout and notice the difference.

Exercise 2
Create the model shown in Figure 4-96 using the dimensions of your choice. You can view the 
final rendered image of this model by downloading the file c04_3dsmax_2012_render.zip from 
http://www.cadcim.com. The path of the file is as follows:		    (Expected time: 15 min)

	
Textbooks > Animation and Visual Effects > 3ds Max > Autodesk 3ds Max 2012: A Comprehensive 
Guide 	         	   			    		   	   

Figure 4-96  Model for Exercise 2

Answers to Self-Evaluation Test
1. d, 2. b, 3. c, 4. d, 5. ALT+A, 6. Plant Library, 7. Count, Lower Rail Spacing 8. T, 9. T, 
10. T


