
Particle Systems             
and Space Warps-II

 Learning Objectives
After completing this chapter, you will be able to:
• Use Deflector space warps
• Use Geometric/Deformable space warps
• Use Modifier-Based space warps 
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Introduction
In continuation with the last chapter, in this chapter also you will learn about different space 
warps. Besides, you will learn about different parameters of the particle systems and its 
usage.

Categories of Space Warps
There are five categories of space warps, Forces, Deflectors, Geometric/Deformable, 
Modifier-Based, and Particles & Dynamics. You have learned about the Forces category in 
Chapter 13. The most commonly used categories of space warps are discussed next.

Deflectors 
The tools in the Deflectors category are used to create the space warps that reflect or refract the 
particles colliding with them. Some of the space warps in this category are discussed next.

Deflector Space Warp
  Menu bar:	 	 Create > SpaceWarps > Deflectors > Deflector		   
  Command Panel:	 Create > Space Warps > Deflectors >		   	  
			   Object Type rollout > Deflector 				  

The deflector space warp is planar in shape and it is used to deflect the particles generated 
by the particle system that collide with it, as shown in Figure 14-1.

Figure 14-1  The particles affected by the Deflector space warp

  

To create a deflector space warp, invoke the Deflector tool from Create > Space Warps > 
Deflectors > Object Type rollout in the Command Panel; the Name and Color, Supports Objects 
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of Type, and Parameters rollouts will be displayed. Activate the suitable viewport. Now, press 
and hold the left mouse button and drag the cursor to create the deflector space warp; the 
deflector space warp icon will be displayed in all viewports, refer to Figure 14-1. Next, bind 
the deflector space warp icon with the particle system using the Bind to Space Warp tool in 
the viewport. Also, set the parameters in the Parameters rollout to generate the desired effect. 
The Parameters rollout is discussed next.     

Note
1. The size and position of the deflector icon affect the particles of a particle system.  

2. The Supports Objects of Type rollout is the same for all space warps as discussed in 
Chapter 13.

Parameters Rollout
The options in this rollout are used to set the effect of the deflector 
space warp on the particle system, refer to Figure 14-2. Make sure 
that the deflector space warp is selected in the viewport. Choose 
the Modify tab in the Command Panel; the Supports Objects of 
Type and Parameters rollouts will be displayed.

Figure 14-2  The 
Parameters rollout for 
the deflector space warp

In the Parameters rollout, set the value in the Bounce spinner to 
control the speed at which the particles bounce off the deflector 
space warp. By default, the value in the Bounce spinner is 1.0 
and the particles bounce off the deflector with the same speed 
at which they strike. As you decrease the value in this spinner, 
the speed of the particles at which they bounce off the deflector 
gets reduced. Set the value in the Variation spinner to vary the particle bounce specified 
in the Bounce spinner. Set the value in the Chaos spinner to create variation in the angle 
of reflection of the particles. Set the value in the Friction spinner to specify the amount 
in percentage by which the speed of the particles slows down when they move across the 
deflector surface. On setting a value more than 0 in the Inherit Vel spinner, the motion 
of the deflector affects the particles. Set the value in the Width and Length spinners to 
specify the width and length of the deflector icon in the viewport.

Tip: To get an effect similar to the particles reflected from an irregular surface, you need to 
set a higher value in the Chaos spinner.

SDeflector Space Warp
  Menu bar:	 	 Create > SpaceWarps > Deflectors > SDeflector	  
  Command Panel:	 Create > Space Warps > Deflectors > 		   
			   Object Type rollout > SDeflector			 

The SDeflector space warp is similar to the deflector space warp. The only difference is that 
the SDeflector space warp is spherical in shape, as shown in Figure 14-3. It is used to deflect 
the particles that are generated by the particle system and collide with it.
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Figure 14-3  The particles affected by the SDeflector space warp

To create SDeflector space warp in a scene, you need to invoke the SDeflector tool from Create 
> Space Warps > Deflectors > Object Type rollout in the Command Panel; the Name 
and Color, Supports Objects of Type, and Basic Parameters rollouts will be displayed. The 
method of creating the SDeflector space warp and the options in the rollouts are the same as 
those discussed in the deflector space warp.

UDeflector Space Warp
  Menu bar:	 	 Create > SpaceWarps > Deflectors > UDeflector	  
  Command Panel:	 Create > Space Warps > Deflectors > 		   
			   Object Type rollout > UDeflector			 

The UDeflector space warp is known as the universal deflector. You can use any object in the 
scene as a deflector using this type of space warp, refer to Figure 14-4. 

To create the UDeflector space warp, invoke the UDeflector tool from Create > Space Warps > 
Deflectors > Object Type rollout in the Command Panel; the Name and Color, Supports 
Objects of Type, and Basic Parameters rollouts will be displayed. Activate the suitable viewport. 
Now, press and hold the left mouse button and drag the cursor to create the UDeflector space 
warp; the UDeflector space warp icon will be displayed in all viewports, as shown in Figure 14-4. 
Next, bind the UDeflector space warp with the particle system in the viewport using the Bind 
to Space Warp tool. In the Basic Parameters rollout of the UDeflector space warp, choose 
the Pick Object button and select the object in the viewport that you want to create as a 
deflector object. Note that the object should be in front of the particle system. Also, set the 
parameters in the Particle Bounce area of the Basic Parameters rollout to generate the desired 
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effect. The options in the Particle Bounce area of the Basic Parameters rollout are the same 
as discussed in the Parameters rollout of the deflector space warp, refer to Figure 14-5. 

Figure 14-4  The particles affected by the UDeflector space warp

Figure 14-5  The Basic Parameters 
rollout of the UDeflector space warp
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POmniFlect Space Warp
  Menu bar:	 	 Create > SpaceWarps > Deflectors > POmniFlect		  
  Command Panel:	 Create > Space Warps > Deflectors > 			    
			   Object Type rollout > POmniFlect				 

The POmniFlect space warp is very much similar to the deflector space warp. However, it 
consists of additional options such as spawning, refraction, and so on.

To create the POmniFlect space warp, invoke the POmniFlect tool from Create > Space Warps 
> Deflectors > Object Type rollout in the Command Panel; the Name and Color, Supports 
Objects of Type, and Parameters rollouts will be displayed. Activate the suitable viewport. 
Now, press and hold the left mouse button and drag the cursor to create the POmniFlect 
space warp; the POmniFlect space warp icon will be displayed in all viewports, as shown in 
Figure 14-6. Next, bind the POmniFlect space warp with the particle system using the Bind to 
Space Warp tool. Also, set the parameters in the Parameters rollout to generate the desired 
effect. The Parameters rollout is discussed next.

Figure 14-6  The particles affected by the POmniFlect space warp

Parameters Rollout
The options in this rollout are used to set the effect of the POmniFlect space warp on the 
particle system, refer to Figure 14-7. The areas in this rollout are discussed next.

Timing Area
The options in this area are used to specify the frame at which the deflector will start and 
end affecting the particles. Set the values in the Time On and Time Off spinners to specify 
the start and end frame number of the deflection effect, respectively. 
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Reflection Area  
Set the value in the Reflects spinner to specify the number of particles affected by the 
space warp in terms of percentage, as shown in Figure 14-8. The other options in this area 
are the same as those discussed earlier in the deflector space warp. 

Figure 14-8  The particles refracted and 
reflected by the space warp

Figure 14-7  Partial view of 
the Parameters rollout

Refraction Area      
The options in this area are used to specify the number of particles in percentage that will 
be refracted when they pass through the deflector, as shown in Figure 14-8. Set the value 
in the Pass Vel spinner to specify the speed of the particles refracted by the space warp. 
Set the value in the Variation spinner to vary the speed of particles in percentage. Set 
the value in the Distortion spinner to control the angle of refraction. Set the value in the 
Diffusion spinner to specify the angle at which all refracted particles will be scattered. 

Common Area  
The options in this area are the same as those discussed earlier in the Parameters rollout 
of the deflector space warp. 

Spawn Effects Only Area
The options in this area are used to affect the particles that are set to spawn on collision. 
Also, these options affect the particles that are neither reflected nor refracted by the 
space warp. Set the value in the Spawns spinner to specify the percentage of particles 
that will be affected by the spawn effects. The other options in this area are the same as 
those discussed earlier.
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Display Icon Area   
Set the value in the Width and Height spinners in this area to define the width and height 
of the POmniFlect icon in the viewport. 

Note
The SOmniFlect and UOmniFlect space warps are similar to the POmniFlect space warp. The 
only difference is that the SOmniFlect space warp is spherical in shape and the UOmniFlect 
space warp can make any object in the viewport as a space warp object. 

Geometric/Deformable Space Warps
The tools in the Geometric/Deformable category are used to create the space warps that 
deform the mesh objects. Some of the space warps in this category are discussed next.

FFD(Box) Space Warp
  Menu bar:	 	 Create > SpaceWarps > Geometric/Deformable > FFD(Box)    	  
  Command Panel:	 Create > Space Warps > Geometric/Deformable > 		   
			   Object Type rollout > FFD(Box)					   

The FFD(Box) space warp is used to deform an object by adjusting the control points of a 
lattice box. It is similar to the FFD modifier that has already been discussed in Chapter 10.

To create the FFD(Box) space warp, invoke the FFD(Box) tool from Create > Space Warps 
> Geometric/Deformable > Object Type rollout in the Command Panel; the Name and 
Color, Supports Objects of Type, and FFD Parameters rollouts will be displayed. Activate the 
suitable viewport. Now, press and hold the left mouse button and drag the cursor in the same 
way as you create a box from standard primitives; a box-shaped lattice with control points or 
FFD(Box) will be displayed, refer to Figure 14-9. Next, bind the FFD(Box) space warp with 
the object in the viewport that you want to modify using the Bind to Space Warp tool and 
set the position of the lattice box accordingly. Then, choose the Modify tab in the Command 
Panel and select the Control Points sub-object level in the modifier stack; the control points 
of the lattice will be displayed in the viewport. Now, adjust the position of the control points 
to modify the bound object, refer to Figure 14-10. Also, you need to modify the options in the 
FFD Parameters rollout. The options in the FFD Parameters rollout are the same as discussed 
in the FFD Parameters rollout of the FFD Modifiers in Chapter 10.   

Figure 14-9  The FFD(Box) Figure 14-10  The control points moved to 
modify the shape of the bound object
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Note
The FFD(Cyl) space warp is similar to the FFD(Box) space warp with the only difference that 
the FFD(Cyl) is cylindrical in shape.

Wave Space Warp
  Menu bar:	 	 Create > SpaceWarps > Geometric/Deformable > Wave	  
  Command Panel:	 Create > Space Warps > Geometric/Deformable > 	  
			   Object Type rollout > Wave				  

The wave space warp is used to create a linear wave in space and affects the objects that are 
bound to it. It is also used to create the wavy effect in the objects.

To create a wave space warp, invoke the Wave tool from Create > Space Warps > Geometric/
Deformable > Object Type rollout in the Command Panel; the Name and Color, Supports 
Objects of Type, and Parameters rollouts will be displayed. Activate the suitable viewport. 
Now, press and hold the left mouse button and drag the cursor to define the wavelength, and 
release the mouse button. Then, move the cursor up or down to define the amplitude of the 
waves; the wave space warp icon will be displayed, as shown in Figure 14-11. Next, bind the 
wave space warp icon with the object to which you want to apply the wave effect; the object will 
display the wave effect, as shown in Figure 14-12. Now, set the parameters in the Parameters 
rollout, which is discussed next.  

Note
The number of segments on the object must be high to get the best effect of the wave space 
warp.

Figure 14-11  The space warp icon for 
the wave space warp

Figure 14-12  The effect of the wave space 
warp

Parameters Rollout
The options in this rollout are used to modify the wave effects, refer to Figure 14-13. The 
areas in this rollout are discussed next.
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Wave Area 
Set the values in the Amplitude 1 and Amplitude 2 spinners 
to specify the wave amplitude along the X and Y axes of the 
wave space warp object, respectively. Set the value in the Wave 
Length spinner to define the distance between the crests of the 
waves. Set the value in the Phase spinner to offset the phase of 
the wave from its origin. The value in the Decay spinner is used 
to decrease the amplitude of the waves as its distance increases 
from the center of the wave space warp.

Figure 14-13  The 
Parameters rollout

Display Area    
Set the value in the Sides spinner to specify the number of 
segments across the width of the wave. Set the value in the 
Segments spinner to specify the number of segments across the 
length of the wave. Set the value in the Divisions spinner to specify 
the size of the wave icon without affecting the wave effect. 

Select the object that is affected by the wave space warp and choose the Modify tab; 
the Flexibility spinner will be displayed in the Parameters rollout. Set the value in this 
spinner to specify how much the object will be affected by the wave space warp. 

Ripple Space Warp
  Menu bar:	 	 Create > SpaceWarps > Geometric/Deformable > Ripple	      	  
  Command Panel:	 Create > Space Warps > Geometric/Deformable >		   
			   Object Type rollout > Ripple					   

The ripple space warp is similar to the wave space warp. The main difference is that the ripple 
space warp is used to create circular and concentric waves, as shown in Figure 14-14.   

To create a ripple space warp, invoke the 
Ripple tool from Create > Space Warps > 
Geometric/Deformable > Object Type rollout 
in the Command Panel; the Name and Color, 
Supports Objects of Type, and Parameters 
rollouts will be displayed. Activate the suitable 
viewport, press and hold the left mouse button, 
drag the cursor to define the wavelength, and 
release the mouse button. Now, move the cursor 
up or down to define the amplitude of the waves; 
the ripple space warp icon will be displayed. 
Next, bind the ripple space warp icon with the 
object in which you want to apply the ripple 
effect; the object will display the ripple effect, 
as shown in Figure 14-14. 

Figure 14-14  The effect of the ripple space 
warp

Now, set the parameters in the Parameters rollout. These parameters are the same as discussed 
in the wave space warp. 
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Note
There are some other space warps in this category like displace and conform space warps. The 
effect of the displace space warp is similar to the Displace modifier discussed in Chapter 10. 
The effect of the conform space warp is similar to the Conform compound object. 

Bomb Space Warp
  Menu bar:	 	 Create > SpaceWarps > Geometric/Deformable > Bomb	      	  
  Command Panel:	 Create > Space Warps > Geometric/Deformable > 		   
			   Object Type rollout > Bomb					   

The bomb space warp is used to explode the objects into their individual faces, as shown in 
Figure 14-15.  

To create a bomb space warp, first create an object that you want to explode. Next, invoke the 
Bomb tool from Create > Space Warps > Geometric/Deformable > Object Type rollout in 
the Command Panel; the Name and Color, Supports Objects of Type, and Bomb Parameters 
rollouts will be displayed. Next, click in the viewport to create the bomb space warp; the bomb 
space warp icon will be displayed, as shown in Figure 14-16. Now, bind the bomb space warp 
with the object to be exploded, and then set the parameters in the Bomb Parameters rollout 
to generate a realistic effect. You need to drag the time slider to view the effect of the bomb 
space warp. The Bomb Parameters rollout is discussed next. 

Bomb Parameters Rollout
The options in this rollout are used to modify the bomb effect on the object, refer to 
Figure 14-17. The areas in this rollout are discussed next. 

Figure 14-17  The Bomb 
Parameters rollout

Figure 14-15  The effect of the bomb 
space warp at one frame

Figure 14-16  The icon of the 
bomb space warp icon

Explosion Area
Set the value in the Strength spinner to specify the strength of the force to explode the 
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object. Set the value in the Spin spinner to specify the rate of rotation of the fragments 
in revolutions per second. Select the Falloff On check box; the Falloff spinner will get 
activated. Also, a yellow gizmo will be displayed in the viewport. The value in the Falloff 
spinner is used to define the extents of the effect of the bomb space warp. The fragments 
that will be outside the yellow gizmo are affected by the gravity settings of the space 
warp.

Fragment Size Area   
The options in this area are used to define the size of the fragments in the bomb space 
warp. Set the value in the Min spinner to specify the minimum number of faces per 
fragment that will be generated by explosion. Set the value in the Max spinner to specify 
the maximum number of faces per segment that will be generated by explosion.  

General Area                   
Set the value in the Gravity spinner to specify the acceleration in the fragments due 
to gravity along the world Z-axis. Set the value in the Chaos spinner to bring random 
variation in the explosion. The value in the Detonation spinner is used to define the 
frame at which the explosion effect will start. Set the value in the Seed spinner to specify 
the random numbers generated for explosion.   

Modifier-Based Space Warps
The tools in the Modifier-Based category are used to create the space warps that generate the 
effects similar to the object modifiers. However, the modifier-based space warps do not have 
the sub-object levels. The Modifier-Based space warps are used when you want to assign the 
effects to a group of objects. Some of the space warps in this category are discussed next.                    

Skew Space Warp
  Menu bar:	 	 Create > SpaceWarps > Modifier-Based > Skew		   
  Command Panel:	 Create > Space Warps > Modifier-Based >		   
			   Object Type rollout > Skew				  

The effect of the skew space warp is similar to the skew modifier. It is used to offset the 
geometry of an object uniformly in any of the three axes. 

To create a skew space warp, invoke the Skew tool from Create > Space Warps > 
Modifier-Based > Object Type rollout in the Command Panel; the Name and Color, Gizmo 
Parameters, and Parameters rollouts will be displayed. Activate the suitable viewport and create 
the space warp in the viewport as you create a box primitive; a gizmo will be displayed, as shown 
in Figure 14-18. Next, bind the space warp gizmo with the object in the viewport that you want 
to skew, and then set the parameters in the Parameters rollout to get the desired skew effect, 
refer to Figure 14-19. The Gizmo Parameters and Parameters rollouts are discussed next. 

Note 
The space warp icon for the Modifier-Based space warps such as Twist, Bend, and so on is 
the same for all space warps.
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Gizmo Parameters Rollout
The options in this rollout are used to modify the dimensions of the space warp icon 
in the viewport, refer to Figure 14-20. Set the values in the Length, Width, and Height 
spinners in the Gizmo Size area to specify the length, width, and height of the space warp 
icon, respectively. Set the value in the Decay spinner in the Deformation area to decay 
the effect of the space warp on the bound object gradually.

Figure 14-18  The box shaped space warp gizmo displayed in all viewports 

Figure 14-19  The effect of the skew space warp Figure 14-20  The Gizmo Parameters rollout

Note
The options in the Gizmo Parameters rollout are the same for all the modifier-based 
space warps. 
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Parameters Rollout
The options in this rollout are used to modify the skew effect, refer 
to Figure 14-21. The areas in this rollout are discussed next.

Skew Area
The value in the Amount spinner is used to define an angle 
to skew the object from its vertical plane. Set the value in the 
Direction spinner to specify the direction of the skew.

Skew Axis Area  
Select the X, Y, or Z radio button to specify the axis to be 
skewed. 

Figure 14-21  The 
Parameters rolloutStretch Space Warp

  Menu bar:	 	 Create > SpaceWarps > Modifier-Based > Stretch	  
  Command Panel:	 Create > Space Warps > Modifier-Based > 		   
			   Object Type rollout > Stretch				  

The effect of the stretch space warp is similar to the stretch modifier. It is used to stretch the 
geometry of an object along the specified axis. 

To create a stretch space warp, invoke the Stretch tool from Create > Space Warps > 
Modifier-Based > Object Type rollout in the Command Panel; the Name and Color, Gizmo 
Parameters, and Parameters rollouts will be displayed. Activate the suitable viewport and create 
the space warp in the viewport as you create a box primitive; a box gizmo will be displayed. 
Next, bind the space warp gizmo with the object in the viewport that you want to stretch, and 
then set the parameters in the Parameters rollout to get the desired stretch effect, refer to 
Figure 14-22. The Parameters rollout is discussed next. 

Parameters Rollout
The options in this rollout are used to modify the stretch effect, refer to Figure 14-23. The 
areas in this rollout are discussed next.

Figure 14-22  The effect of the stretch space warp Figure 14-23  The Parameters rollout
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Stretch Area
Set the value in the Stretch spinner to specify the amount of stretch on the object. Set the 
value in the Amplify spinners to adjust the stretch effect on the object.

Stretch Axis Area  
Select the X, Y, or Z radio button to specify the axis in which the bound object will be 
stretched. 

Tutorial 1
In this tutorial, you will create a scene with the animated fountains, as shown in 
Figure 14-24. 						         	   (Expected time: 60 min)
	

Figure 14-24  Model for Tutorial 1

The following steps are required to complete this tutorial:

a.	 Set the project folder.
b.	 Download the files.
c.	 Create the ground.
d.	 Assign the camera.
e.	 Create the fountain wall.
f.	 Create the water surface.
g.	 Assign materials.
h.	 Create fountains.
i.	 Create plants, park benches, and railings.
j.	 Create lights.
k.	 Create the environment of the scene.
l.	 Render the scene for the final output. 
m.	 Save the file.  

Setting the Project Folder
1.	 Set the project folder with the name c14_tut1 in the 3dsmax folder as discussed in earlier 

chapters.
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Downloading the Files
Before starting the tutorial, you need to download the c14_3dsmax_2012_tut.zip file from 
http://www.cadcim.com. The path of the file is as follows:
	
	 Textbooks > Animation and Visual Effects > 3ds Max > Autodesk 3ds Max 2012: A Comprehensive 

Guide  
	
	 Extract the contents of the zipped file and copy the files Grass.jpg, bricks.jpg, and water.jpg  

at the location \Documents\3dsmax\c14_tut1\sceneassets\images. 

Creating the Ground
	 To create the ground, you first need to create a plane: 

1.	 Activate the Top viewport. Choose Create > Geometry in the Command Panel; the 
Standard Primitives option is displayed in the drop-down list below the Geometry button. 
Invoke the Plane tool from the Object Type rollout; various rollouts are displayed in the 
modify panel.  

2.	 Expand the Keyboard Entry rollout and set the parameters as given below:

	 Length: 3000.0		  Width: 3000.0

3.	 Choose the Create button; a plane is created in all viewports. Invoke the Zoom Extents 
All tool; the plane is zoomed and displayed in all viewports properly.

4.	 Modify the name of the plane to ground. 

Assigning the Camera
1.	 Activate the Front viewport. Choose Create > Cameras in the Command Panel; the 

Standard option is displayed in the drop-down list. Invoke the Free tool from the Object 
Type rollout.

2.	 Click on the middle point of the ground in the Front viewport; a free camera is displayed 
in all viewports. It is automatically named as Camera001.

3.	 Align the Camera001 in all viewports, as shown in Figure 14-25, and press the C key in the 
Perspective viewport to view the camera view.  

Creating the Fountain Wall   
	 To create the fountain wall, you need to create a tube. 

1.	 Activate the Top viewport. Choose Create > Geometry in the Command Panel; the 
Standard Primitives option is displayed in the drop-down list. Invoke the Tube tool from 
the Object Type rollout; various rollouts are displayed in the modify panel.   
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Figure 14-25  The Camera001 aligned in all viewports

2.	 Expand the Keyboard Entry rollout and set the parameters as given below:

	 Inner Radius: 379.328          Outer Radius: 313.33          Height: 100.424

3.	 Choose the Create button; a tube is created in all viewports.

4.	 In the Parameters rollout, set the values as given below:

	 Height Segments: 10	 Sides: 32

5.	 Modify the name of the tube to fountain wall.	

6.	 Position the Camera001 in the Left viewport using the Select and Move and Select and 
Rotate tools to view the scene in the Camera001 viewport, as shown in Figure 14-26.  

Creating the Water Surface
	 Now, you need to create a cylinder to create the water surface.

1.	 Activate the Top viewport. Invoke the Cylinder tool from Standard Primitives; various 
rollouts are displayed in the modify panel.

2.	 Expand the Keyboard Entry rollout and set the parameters as given below:

	 Radius: 306.624		  Height: 93.0
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Figure 14-26  The scene after aligning the Camera001 in all viewports 

3.	 Choose the Create button; a cylinder is created in all viewports, as shown in 
Figure 14-27.   

Figure 14-27  The cylinder for creating the water surface

4.	 Modify the name of the cylinder to water01 and right-click in the viewport to exit the 
current command. 
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	 Next, you need to apply the materials to the objects to make them look realistic. 

Assigning the Materials
1.	 First, select the ground in the viewport and invoke the Compact Material Editor tool; the 

Material Editor dialog box is displayed. 

2.	 Select the 01-Default sample slot and modify its name in the Material Name text box to 
ground material. 

	 Next, you need to assign a map to the selected sample slot.

3.	 In the Blinn Basic Parameters rollout, choose the Diffuse map button on the right side 
of the Diffuse color swatch; the Material/Map Browser dialog box is displayed. Select the 
Bitmap map from the Maps > Standard rollouts and choose the OK button; the Select 
Bitmap Image File dialog box is displayed. Select the Grass.jpg image and choose the 
Open button; the selected image is displayed in the selected sample slot. Also, various 
rollouts are displayed to modify the coordinates of the map.    

4.	 In the Coordinates rollout, set the value 5 in the U Tiling and V Tiling spinners. 

5.	 Make sure that the ground is selected in the viewport and then choose the Assign Material 
to Selection button; the ground material is assigned to the ground in the viewport. Also, 
choose the Show Shaded Material in Viewport button to display the assigned material 
in the viewport.

	
	 Next, you will assign a material to the fountain wall. 

6.	 Select the 02-Default sample slot in the Material Editor dialog box. Modify its name in 
the Material Name text box to fountain wall material.

7.	 In the Blinn Basic Parameters rollout, choose the Diffuse map button on the right side 
of the Diffuse color swatch; the Material/Map Browser dialog box is displayed. Select the 
Bitmap map from the Maps > Standard rollouts and choose the OK button; the Select 
Bitmap Image File dialog box is displayed. Select the bricks.jpg image and choose the 
Open button; the selected image is displayed in the sample slot. Also, various rollouts are 
displayed to modify the coordinates of the map.    

8.	 In the Coordinates rollout, set the value 10 in the U Tiling and V Tiling spinners. Next, 
choose the Go to Parent button to go back to the parent level.

9.	 Expand the Maps rollout and select the Bump check box to make it available for the 
material. Choose the Bump map button that is labeled as None; the Material/Map Browser 
dialog box is displayed. Select the Bitmap map from the Maps > Standard rollouts and 
choose the OK button; the Select Bitmap Image File dialog box is displayed. Browse to 
the same image (bricks.jpg) that you have used for the Diffuse map and choose the Open 
button. 
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10.	 In the Coordinates rollout, set the value 10 in both the U Tiling and V Tiling spinners. 
Next, choose the Go to Parent button to go back to the parent level; the name of the 
selected image is displayed over the Bump map button. 

11.	 In the Bump spinner, set the value 100.  	

12.	 Make sure that the fountain wall is selected in the viewport. Choose the Assign Material 
to Selection button; the fountain wall material is assigned to the fountain wall in the 
viewport. Also, choose the Show Shaded Material in Viewport button to display the 
assigned material in the viewport.

	
	 Next, you need to apply the UVW Map modifier to the fountain wall to display the map 

properly.

13.	 Select the fountain wall in the viewport. Choose the Modify tab in the Command Panel. 
In the Modifier List drop-down list, select the UVW Map modifier; the UVW Mapping 
is displayed in the modifier stack. Also, the Parameters rollout is displayed to modify the 
parameters of the modifier.

14.	 In the Parameters rollout, set the values as given below:

	 Mapping Area
	 Select the Spherical radio button.
	 Length: 456.88		  Width: 456.88		     Height: 456.88
	
	 Next, you need to assign a material to water01. 

15.	 Select the 03-Default sample slot in the Material Editor dialog box. Modify its name in 
the Material Name text box to water01 material.

16.	 Choose the Material Type button that is currently labeled as Standard; the Material/Map 
Browser dialog box is displayed. Select the Architectural material from the Materials > 
Standard rollouts and choose the OK button; the Standard material is replaced by the 
Architectural material now. Also, various rollouts are displayed to modify the Architectural 
material. 

17.	 In the Templates rollout, select the Water option from the drop-down list. 

18.	 In the Physical Qualities rollout, choose the Diffuse Color color swatch and enter the 
following values in the Color Selector: Diffuse dialog box:

	 Red: 195		  Green: 242		  Blue: 246

19.	 Choose the Diffuse Map button that is labeled as None; the Material/Map Browser dialog 
box is displayed. Select the Bitmap map from the Maps > Standard rollouts and choose 
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the OK button; the Select Bitmap Image File dialog box is displayed. Select the water.jpg 
image and choose the Open button; the selected image is displayed in the sample slot. 

20.	 Choose the Go to Parent button to go back to the previous level. In the Physical Qualities 
rollout, set the value in the Shininess spinner to 85.0.

21.	 Select water01 in the viewport and choose the Assign Material to Selection button in 
the Material Editor dialog box; the water01 material is assigned to the water01 in the 
viewport. Also, choose the Show Shaded Material in Viewport button to display the 
assigned material in the viewport.

22.	 Next, activate the Camera001 viewport and invoke the Render Production tool to view 
the maps and materials assigned to the objects. The water01 displays the reflection 
of the ground material, as shown in Figure 14-28. Therefore, you need to create 
another water surface. 

23.	 Activate the Front viewport and select water01. Choose Edit > Clone from the menu bar; 
the Clone Options dialog box is displayed. Select the Copy radio button in the Object 
area and make sure that water002 is displayed in the Name text box. Choose the OK 
button; the water002 is displayed at the same location as water01. 

24.	 Choose the Modify tab in the Command Panel and set the values in the Parameters 
rollout as given below:

	 Radius: 306.624	 Height: 11.0

	 The water002 is displayed at the bottom of the fountain wall. Next, you need to assign a 
material to it.

25.	  Select the 04-Default sample slot in the Material Editor dialog box. Modify its name in 
the Material Name text box to water002 material.

26.	 In the Blinn Basic Parameters rollout, choose the Diffuse color swatch and modify the 
color by entering the values as given below:

	 Red: 195		  Green: 242		  Blue: 246

27.	 Make sure that water002 is selected in the viewport and choose the Assign Material to 
Selection button; the material is assigned to water002. Also, choose the Show Shaded 
Material in Viewport button to display the assigned material in the viewport. Close the 
Material Editor dialog box.

28.	 Next, activate the Camera001 viewport and invoke the Render Production tool; the objects 
are displayed, as shown in Figure 14-29. 
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Figure 14-28  The objects displayed at 
rendering after assigning the materials 

Figure 14-29  The objects displayed at rendering 
after creating the water002 surface 

Creating Fountains
	 To create the fountains, you need to create the super spray particle system.

1.	 Activate the Top viewport and choose Create > Geometry from the Command Panel; 
the Standard Primitives option is displayed by default in the drop-down list. Select the 
Particle Systems option in the drop-down list and then invoke the Super Spray tool from 
the Object Type rollout.

2.	 In the Top viewport, press and hold the left mouse button, drag the cursor from one point 
to another, and release the left mouse button; the emitter is created for the super spray 
particle system. Align the emitter at the middle of the water01 in all viewports, as shown 
in Figure 14-30.

3.	 Modify the name of the particle system to fountain01. Also, modify the color by entering 
the values as given below:

	 Red: 154			   Green: 215 		  Blue: 229 
	
	 Next, you need to set the parameters in different rollouts.

4.	 Choose the Modify tab in the Command Panel; various rollouts are displayed. In the 
Basic Parameters rollout, set the values as given below:

	 Particle Formation Area
	 Off Axis: 0.0	 	 Spread: 7.0
	 Off Plane: 0.0		  Spread: 90.0

	 Display Icon Area
	 Icon Size: 50.0 

	 Viewport Display Area	
	 Make sure that the Ticks radio button is selected.  
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Figure 14-30  The emitter aligned in all viewports

Note
The icon size of the particle system does not affect the particles. However, the small size provides 
more room to work in the viewport.

5.	 In the Particle Generation rollout, set the values as given below:

	 Particle Quantity area
	 Make sure that the Use Rate radio button is selected and set the value 80 in the spinner 

below this radio button. 

	 Particle Motion Area
	 Speed: 12.0
	
	 Particle Timing Area
	 Emit Start: 10		  Emit Stop: 100
	 Display Until: 100		  Life: 75

	 Particle Size Area
	 Size: 5.0 
	 Use the default values for other options.

6.	 In the Particle Type rollout, set the values as given below:

	 Particle Type area
	 Make sure that the Standard Particles radio button is selected. 
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	 Standard Particles area
	 Select the Tetra radio button.

7.	 Activate the Camera001 viewport and choose the Play Animation button; the particles 
start moving towards the vertical axis.

	 Next, you need to increase the number of frames for the animation. 

8.	 Choose the Time Configuration button at the bottom of the 3ds Max screen; the Time 
Configuration dialog box is displayed. 

9.	 In the Animation area, choose the Re-scale Time button; the Re-scale Time dialog box 
is displayed. In the New area, set the value 500 in the Length spinner and choose the OK 
button. Next, choose the OK button in the Time Configuration dialog box to close it.   

10.	 Activate the Camera001 viewport and choose the Play Animation button; the particles 
start moving towards the vertical axis, as shown in Figure 14-31. Also, align the Camera001 
in the viewports, as shown in Figure 14-31.

Figure 14-31  The particles at a frame after choosing the Play Animation button

Note
When you change the values in the Re-scale Time dialog box, the values in the Particle 
Timing area of the Particle Generation rollout also get changed.     

	 Notice that the particles are moving in the upward direction. To bring them downward, 
you need to apply the gravity space warp to the particle system. 
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11.	 Activate the Top viewport. Choose Create > Space Warps in the Command Panel; the 
Forces category is displayed in the drop-down list. Invoke the Gravity tool from the Object 
Type rollout.

12.	 Press and hold the left mouse button, drag the cursor in the Top viewport, and then release 
the left mouse button; the gravity space warp icon is displayed in all viewports.

13.	 Next, choose the Modify tab in the Command Panel and set the values in the Parameters 
rollout as given below: 

	 Force Area
	 Strength: 0.13

	 Use the default values for other options.

14.	 Select fountain01 in any viewport and invoke the Bind to Space Warp tool from  
the Main Toolbar. Now, bind the fountain01 with the gravity space warp icon; the 
direction of particles is changed, as shown in Figure 14-32. Invoke the Select 
Object tool to exit the Bind to Space Warp command.

Figure 14-32  The particles after applying the gravity space warp

Note
You can vary the size and position of the gravity space warp icon as it does not affect the particles 
of the particle system.      
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	 After applying the gravity space warp, the particles start moving downward but they go 
under the ground, refer to Figure 14-33. To avoid this, you need to apply a deflector space 
warp to the particle system.

15.	 Activate the Top viewport. Make sure that Create > Space Warps is selected in the 
Command Panel. Select the Deflectors category in the drop-down list below the Space 
Warps button. Invoke the Deflector tool from the Object Type rollout.

16.	 In the Top viewport, press and hold the left mouse button, drag the cursor from one 
point to another, and then release the left mouse button; the deflector space warp icon is 
displayed in all viewports.

17.	 Select fountain01 in any viewport and invoke the Bind to Space Warp tool from the Main 
Toolbar. Now, bind the fountain01 with the deflector space warp icon.

18.	 Invoke the Select and Move tool and select the deflector space warp icon. 

19.	 Choose the Modify tab in the Command Panel and set the values in the Parameters 
rollout as given below: 

	 Bounce: 0.2		 	 Friction: 1.0	
	 Width: 2500	 	 Length: 2500

	 Use the default values for other options.

20.	 Align the deflector space warp icon in the Top viewport, as shown in Figure 14-33. As you 
align the deflector space warp icon, the position of the particles also changes.  

	 After colliding with the deflector space warp, some of the particles of the fountain01 start 
moving outward, as shown in Figure 14-33. Therefore, you need to modify the settings of 
the fountain01. 

21.	 Select the fountain01 in the viewport and choose the Modify tab in the Command Panel. 
In the modifier stack, select the Super Spray option; various rollouts are displayed in the 
modify panel. 

22.	 Expand the Particle Spawn rollout and select the Die After Collision radio button in 
it. As a result, the particles will die after colliding with the deflector space warp icon, as 
shown in Figure 14-34.

23.	 Activate the Camera001 viewport and invoke the Render Production tool; the scene is 
displayed at rendering, as shown in Figure 14-35. 

	 Next, to make the fountain01 realistic, you need to apply the Motion Blur rendering effect 
to it. 
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Figure 14-33  The particles after applying the deflector space warp

Figure 14-34  The particles after modifying the settings
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24.	 Select the fountain01 in any viewport and right-click on it; a quad menu is displayed. 
Choose the Object Properties option; the Object Properties dialog box is displayed. 
Next, select the Image radio button in the Motion Blur area; the Multiplier spinner is 
activated in this area. Set the value 8.0 in this spinner and choose the OK button to exit 
the dialog box.      

25.	 Activate the Camera001 viewport and invoke the Render Production tool; the scene is 
displayed, as shown in Figure 14-36.

Figure 14-35  The scene at rendering Figure 14-36  The scene at rendering 
after applying the motion blur effect

	 Next, you need to create other fountains. 

26.	 Select the fountain wall and invoke the Zoom Extents All Selected tool. 

27.	 Select the fountain01 in the Top viewport and create its four copies. They are automatically 
named as fountain002, fountain003, fountain004, and fountain005. Next, align them in the 
Top viewport, as shown in Figure 14-37. 

Note
All copied fountains are bound to the gravity and deflector space warps.

	 Next, to generate some variations in fountain002, fountain003, fountain004, and fountain005, 
you need to create another gravity space warp.

28.	 First, select the fountain002 in any viewport. In the modifier stack, select the Gravity 
Binding (WSM) option and choose the Remove modifier from the stack button; the 
Gravity Binding (WSM) option is deleted.              	

29.	 Repeat the above step (step 28) for fountain003, fountain004, and  fountain005. 

30.	 Now, in the Top viewport, create a gravity space warp icon using the Gravity tool from 
the Forces category. It is automatically named as Gravity002. Bind it with the fountain002, 
fountain003, fountain004, and fountain005 using the Bind to Space Warp tool. 
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Figure 14-37  The four copies of the fountain01 after alignment

Tip: Before binding the Gravity002 space warp with the fountain002, fountain003, 
fountain004, and fountain005, move the time slider to frame 0. It will help you to bind 
the fountains easily.     

31.	 Invoke the Select and Move tool, select the Gravity002 space warp, and choose the Modify 
tab in the Command Panel. In the Parameters rollout, set the value 0.3 in the Strength 
spinner.

32.	 Choose the Go to End button in the animation 
playback controls and render the Camera001 
viewport; the scene is displayed, as shown in 
Figure 14-38.     	

Creating Plants, Park Benches, 
and Railings
1.	 Create the plants of your choice by invoking the 

Foliage tool from Create > Geometry > AEC 
Extended > Object Type rollout.

Figure 14-38  The scene at rendering2.	 Create railings all around the ground by invoking 
the Railing tool from Create > Geometry > 
AEC Extended > Object Type rollout.
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3.	 Create the park benches as discussed in Tutorial 2 of Chapter 2 and align them, as shown 
in Figure 14-39. 

Figure 14-39  The plants, railings, and park benches in the scene after the alignment 

	 Next, you need to assign lights to the scene.

Creating Lights
	 First, you need to create lights for the fountains in the scene.

1.	 Select the fountain wall in a viewport and invoke the Zoom Extents All Selected tool.

2.	 Activate the Top viewport and invoke the Omni tool from Create > Lights > Standard 
> Object Type rollout. Click in the Top viewport to create the omni light and align it in 
all viewports, as shown in Figure 14-40. It is automatically named as Omni01.	

3.	 Next, make sure that the Omni01 is selected and choose the Modify tab in the Command 
Panel.

4.	 Expand the Intensity/Color/Attenuation rollout and choose the color swatch at the extreme 
right of the Multiplier spinner; the Color Selector: Light Color dialog box is displayed. 
Enter the values given next to modify the color of the light. 

	 Red: 196		  Green: 241		  Blue: 243

	 Choose the OK button to close the dialog box.
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Figure 14-40  The Omni01 light in all viewports after the alignment

5.	 In the General Parameters rollout, choose the Exclude button; the Exclude/Include 
dialog box is displayed. Exclude the park benches and plants from the light effect.	

6.	 Next, create three copies of the Omni01 light in the Top viewport and align them, as shown 
in Figure 14-41. Also, make sure that the park benches and plants are excluded from the 
effect of the copied lights. 

Figure 14-41  All omni lights aligned in the 
Top viewport 

Note
You can exclude or include objects from the light effect depending on the effects to be generated 
in the scene. 	
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	 Next, create the lights for the entire scene.

7.	 Invoke the Zoom Extents All tool and activate the Top viewport. 

8.	 Invoke the Zoom All tool and zoom out in any viewport, except the Camera001 viewport, 
till all objects are displayed to half of their size, refer to Figure 14-42.

9.	 Invoke the Omni tool. In the Top viewport, click at the upper-right and lower-left corners 
to create two more omni lights. Align them in all viewports, as shown in Figure 14-42. 	
     

           

Figure 14-42  The omni lights in all viewports after the alignment

You can also create more lights depending on the scene’s requirement.

10.	 Choose the Go to End button in the animation playback controls and render the Camera001 
viewport; the scene is displayed, as shown in Figure 14-43.     

	

Creating the Environment for the Scene 
1.	 Create the environment for the scene as discussed in Tutorial 2 of Chapter 12. 

2.	 Choose the Go to End button in the animation playback controls. Render the Camera001 
viewport; the scene is displayed with the stars in the sky, as shown in Figure 14-44.

Rendering the Scene for the Final Output
	 To view the final output of the scene including the animation of fountains, you need to 

render the scene.
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Figure 14-43  The scene at rendering after 
assigning the lights

Figure 14-44  The scene with the environment 
at rendering 

1.	 Invoke the Render Setup tool from the Main Toolbar; the Render Setup: Default 
Scanline Renderer dialog box is displayed. The Common tab is chosen by default. 

2.	 Set the values in the Render Setup: Default Scanline Renderer dialog box as discussed 
in Tutorial 1 of Chapter 12 and choose the Render button; the Camera001, frame and 
the Rendering dialog boxes are invoked, and they display the rendering process. 

3.	 After the completion of rendering, the final output of the animation is saved in the *.avi 
format at a location specified by you. You can view the final output of the animation by 
opening the corresponding avi file.  

	 You can view the final rendered sequence by downloading the c14_3dsmax_2012_render.zip 
file from http://www.cadcim.com. 

Saving the File
1.	 Save the file with the name c14tut1.max as discussed in earlier chapters. The location of 

this file is given below:

	 \Documents\3dsmax\c14_tut1\scenes

Tutorial 2
In this tutorial, you will create a scene displaying smoke rising from an incense stick, as shown 
in Figure 14-45. 					        	   (Expected time: 45 min)

The following steps are required to complete this tutorial:

a.	 Set the project folder.
b.	 Create the scene.
c.	 Create smoke.
d.	 Assign the material to the smoke.
e.	 Create lights.



14-34				                Autodesk 3ds Max 2012: A Comprehensive Guide
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

f.	 Create the environment.
g.	 Render the scene for the final output. 
h.	 Save the file.   

Figure 14-45  Model for Tutorial 2

Setting the Project Folder
1.	 Set the project folder with the name c14_tut2 in the 3dsmax folder as discussed in earlier 

chapters.

Creating the Scene
	 In this section, first you need to create a floor and then assign material to it.

1.	 Invoke the Plane tool from Standard Primitives in the Command Panel and create a 
plane in the Top viewport. Set the values in the Parameters rollout as given below:

	 Length: 1239.908		  Width: 1957.291

2.	 Modify the name of the plane to floor. 

3.	 Now, press the M key; the Material Editor dialog box is displayed. 

4.	 Select the 01-Default sample slot and modify its name in the Material Name text box to 
floor material. 

	 Next, you need to assign a map.

5.	 In the Blinn Basic Parameters rollout, choose the Diffuse map button on the right side 
of the Diffuse color swatch; the Material/Map Browser dialog box is displayed. Select 
the Checker map from the Maps > Standard rollouts and choose the OK button; the 
selected map is displayed in the sample slot. Also, the rollouts are displayed to modify 
the coordinates of the map.    

6.	 In the Coordinates rollout, set the value 5 in both the U Tiling and V Tiling spinners. 
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7.	 Make sure that the floor is selected in the viewport and then choose the Assign Material to 
Selection button; the floor material is assigned to the floor in the viewport. Also, choose 
the Show Shaded Material in Viewport button to display the assigned material in the 
viewport. Close the Material Editor dialog box.

	 Next, you need to create a stand for the incense stick.

8.	 Invoke the Line tool from Create > Shapes 
> Splines > Object Type rollout in the 
Command Panel. Create a line in the Front 
viewport, as shown in Figure 14-46. 

9.	 Create an incense stick stand by applying the 
Lathe modifier to the line as discussed earlier in 
Tutorial 1 of Chapter 7. Note that before applying 
the Lathe modifier, you need to adjust the pivot 
point according to the shape you want to create. 
Now, assign a material of your choice to the 
incense stick stand.  Figure 14-46  A line for creating the 

incense stick stand

10. 	Create a free camera in the Front viewport.

11.	 Now, create an incense stick using the Capsule tool from Extended Primitives in the 
Command Panel. Set its parameters according to scene’s requirement. Align it in all 
viewports with the incense stick stand, as shown in Figure 14-47. Also, align the free camera in 
all viewports, as shown in Figure 14-47. Then, press the C key in the Perspective viewport 
to view the camera view.  	

Figure 14-47  The incense stick stand and the free camera aligned in all viewports
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Creating Smoke
	 To create the smoke, you need to create the super spray particle system.

1.	 Select the incense stick stand and invoke the Zoom Extents All Selected tool.

2.	 Activate the Top viewport and invoke the Super Spray tool from Create > Geometry > 
Particle Systems > Object Type rollout in the Command Panel.  	

3.	 In the Top viewport, press and hold the left mouse button, drag the cursor from one 
point to another, and release the left mouse button; an emitter is created. Now, align the 
emitter in all viewports using the Select and Move and Select and Rotate tools, as shown 
in Figure 14-48.	

Figure 14-48  The emitter for super spray particle system aligned in all viewports

4.	 Modify the name of the particle system to smoke. 

5.	 Increase the number of frames in the track bar to 300 as discussed in Tutorial 1 of this 
chapter. 

	
	 Next, you need to set the parameters of the smoke by using different rollouts.

6.	 Make sure that the smoke is selected in the Modify tab in the Command Panel; various 
rollouts are displayed.
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7.	 In the Basic Parameters rollout, set the values as given next.

	 Particle Formation Area
	 Off Axis: 0.0	 Spread: 4.0
	
	 Viewport Display Area
	 Select the Dots radio button.  

8.	 In the Particle Generation rollout, set the values as given below:

	 Particle Quantity Area
	 Make sure that the Use Rate radio button is selected. Next, set the value 30 in the spinner 

located below this radio button. 

	 Particle Motion Area
	 Speed: 1.5
	
	 Particle Timing Area
	 Emit Start: 30		  Emit Stop: 300
	 Display Until: 300		  Life: 225

	 Particle Size Area
	 Size: 2.5 			   Variation: 30
	 Grow For: 90		  Fade For: 30
	
9.	 In the Particle Type rollout, set the values as given below:

	 In the Particle Types area, make sure that the Standard Particles radio button is 
selected. 

	 Standard Particles Area
	 Select the Facing radio button.

10.	 In the Rotation and Collision rollout, set the values as given below:

	 Spin Time: 60		  Variation: 20.0
		
11.	 Activate the Camera001 viewport and choose the Play Animation button; the particles 

start moving in a single direction, as shown in  Figure 14-49. 

	 Next, you need to create the wind space warp to generate variation in the motion of 
particles. 
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12.	 Activate the Left viewport and invoke the 
Wind tool from Create > Space Warps 
> Forces > Object Type rollout in the 
Command Panel.

13.	 Press and hold the left mouse button and drag 
the cursor in the Left viewport; the wind space 
warp icon is displayed.

Figure 14-49  The particles in the Camera001 
viewport at one frame  

14.	 Align the wind space warp icon in all viewports 
using the Zoom All and Pan View tools, refer 
to Figure 14-50. 

Figure 14-50  The wind space warp icon aligned in all viewports 

15.	 Choose the Modify tab in the Command Panel and set the values in the Parameters 
rollout of the wind space warp as given below: 

	 Force Area
	 Strength: 0.03

	 Wind Area
	 Turbulence: 0.03		  Frequency: 0.1		  Scale: 0.2

	 Use the default values for other options.
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16.	 Select smoke in any viewport, invoke the Bind to Space Warp tool from the Main Toolbar, 
and then bind the smoke with the wind space warp icon; the direction of the particles is 
changed, as shown in Figure 14-51. Invoke the Select Object tool to exit the command.

Figure 14-51  The smoke after binding with the wind space warp in all viewports

	 Next, you need to create the drag space warp to adjust the velocity of the smoke 
particles.

17.	 Activate the Top viewport and invoke the Drag tool from Create > Space Warps > Forces 
> Object Type rollout in the Command Panel.

18.	 Press and hold the left mouse button and drag the cursor in the Top viewport; the drag 
space warp icon is displayed.

19.	 Align the drag space warp icon in all viewports using the Zoom All and Pan View tools, 
refer to Figure 14-52. 

20.	 Choose the Modify tab in the Command Panel and set the values in the Parameters 
rollout of the drag space warp as given below: 

	 Timing Area
	 Time On: 0		 Time Off: 300
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	 Damping Characteristics Area
	 Select the Cylindrical Damping radio button and set the values as given below:

	 Radial: 3.0		  Tangential: 1.0		  Axial: 2.0

Figure 14-52  The drag space warp icon aligned in all viewports 

21.	 Select smoke in any viewport, invoke the Bind to Space Warp tool from the Main Toolbar, 
and then bind the it with the drag space warp icon; the velocity of particles is changed, 
as shown in Figure 14-53.

Assigning the Material to the Smoke
1.	 First, select smoke in any viewport and press the M key; the Material Editor dialog box is 

displayed.

2.	 Select a sample slot to which no material has been assigned and modify its name in the 
Material Name text box to smoke material. 

3.	 In the Shader Basic Parameters rollout, make sure that the Blinn option is selected in 
the drop-down list. Select the Face Map check box.

4.	 In the Blinn Basic Parameters rollout, choose the Diffuse color swatch and set the white 
color. 
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Figure 14-53  The smoke after binding with the drag space warp icon in all viewports

5.	 In the Self-Illumination area of the Blinn Basic Parameters rollout, select the Color 
check box; the spinner on its right side is replaced with a color swatch. Modify the color 
using the color swatch by entering the values as given below:  

	 Red: 215		  Green: 197 		  Blue: 174

6.	 Set the value 0 in the Opacity spinner. Choose the button on the right of the Opacity 
spinner; the Material/Map Browser dialog box is displayed. Select the Gradient map from 
the Maps > Standard rollouts and choose the OK button; various rollouts are displayed 
to modify the Gradient map. 

7.	 In the Gradient Parameters rollout, set the value 1.0 in the Color 2 Position spinner. In 
the Gradient Type group, select the Radial radio button.    

8.	 Choose the Go to Parent button to go back to the parent level.

9.	 Expand the Maps rollout and set the value 3 in the Opacity spinner.

10.	 Make sure that smoke is selected in the viewport and choose the Assign Material to 
Selection button; the smoke material is assigned to the smoke in the viewport. Close the 
Material Editor dialog box.

11.	 Choose the Go to End button from the animation playback controls and render the 
Camera001 viewport; the scene is displayed, as shown in Figure 14-54.
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	 Next, you need to create the lights for the 
scene. 

Figure 14-54  The scene at rendering

Creating Lights
1.	 Invoke the Zoom Extents All tool.

2.	 Activate the Top viewport and invoke the Omni 
tool from Create > Lights > Standard > 
Object Type rollout. Click on the lower left and 
upper right corners to create two omni lights. 

3.	 Next, align the omni lights in all viewports, as 
shown in Figure 14-55.

Figure 14-55  The omni lights aligned in all viewports 

Creating the Environment 
1.	 Modify the color of the environment as discussed earlier by entering the values as given 

below: 

	 Red: 102		  Green: 102		
Blue: 102
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2.	 Choose the Go to End button in the animation 
playback controls and render the Camera001 
viewport. The scene is displayed with the 
modified color in the environment, as shown 
in Figure 14-56.

Figure 14-56  The scene at rendering after 
modifying the color of the environment

Rendering the Scene for the 
Final Output
1.	 To view the final output of the scene including 

the animation of smoke, render the scene as 
discussed in Tutorial 1 of Chapter 12.

2.	 After the completion of rendering, the final 
output of the animation is saved in the *.avi 
format at a location specified by you. You can view the final output of the animation by 
opening the corresponding avi file.  

	 You can view the final rendered sequence by downloading the c14_3dsmax_2012_render.zip 
file from http://www.cadcim.com.

Saving the File
1.	 Save the file with the name c14tut2.max as discussed in earlier chapters. The location of 

this file is given below:

	 \Documents\3dsmax\c14_tut2\scenes

 Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of this 
chapter:
                                                                                                                                                                          
1.	 Which of the following is a category of space warps in Autodesk 3ds Max?
	
		  (a) Forces				    (b) Deflectors
		  (c) Modifier-Based	 		  (d) All of these

2.	 Which of the following tools is used to create a space warp under the Forces category?

		  (a) Path Follow 		 		  (b) Gravity 		
		  (c) Both of the above			   (d) None of the above 	

3.	 Which of the following space warps is used to twist the object?

		  (a) Bend				    (b) Taper		
		  (c) Twist				    (d) Skew
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4.	 Which of the following categories of space warps is used to deform the mesh objects?
	
		  (a) Forces				    (b) Deflectors
		  (c) Geometric/Deformable	 	 (d) All of these

5.	 The tools in the Deflectors category are used to create the space warps that reflect or 
refract the particles colliding with them. (T/F)	

6.	 The tools in the Modifier-Based category are used to create the space warps that generate 
the effects similar to the object modifiers. (T/F)

7.	 The size and position of the deflector icon does not affect the particles of a particle system. 
(T/F)

8.	 You can use any object in the scene as a deflector using the __________ space warp.

9.	 The __________ space warp is used to stretch the geometry of an object along the 
specified axis. 

10.	 The ___________ space warp is used to offset the geometry of an object uniformly in any 
of the three axes. 

 Review Questions
Answer the following questions:

1.	 Which of the following space warps is used to deform an object by adjusting the control 
points of a lattice box? 

		  (a) FFD(Box)				    (b) FFD(Cyl)
		  (c) Both of the above			   (d) None of the above

2.	 Which of the following space warps is used to explode an object into fragments?

		  (a) Bomb				    (b) Wave
		  (c) Ripple				    (d) PBomb

3.	 Which of the following space warps is used to create the wavy effect in the objects? 

		  (a) Wave				    (b) Displace
		  (c) Ripple				    (d) Bomb
	
4.	 Which of the following tools in the Deflector category is used to create the spherical space 

warp icon?

		  (a) Deflector	 			   (b) SDeflector
		  (c) POmniFlect				   (d) UDeflector
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5.	 The ripple space warp is similar to the wave space warp. (T/F)

6.	 The FFD(Cyl) space warp is similar to the FFD(Box) space warp with the only difference 
that the FFD(Cyl) space warp is cylindrical in shape. (T/F)

7.	 The bomb space warp is used to explode a particle system. (T/F)

8.	 The __________ space warp is used to create the wavy effects in the objects that are bound 
to it. 

9.	 The __________ space warp is used to create the circular and concentric waves in the 
objects.

10.	 The __________ space warp is used to explode the objects into their individual faces.

 Exercises

Exercise 1
Start Autodesk 3ds Max 2012 and then perform the following operations:

1.	 Invoke the Super Spray tool from Create > Geometry > Particle Systems > Object 
Type rollout and create a super spray particle system icon in the Top viewport. Adjust 
the view in the Perspective viewport. Set the values in the Off Axis Spread and Off Plane 
Spread spinners in the Basic Parameters rollout. Also, set the values in the Particle 
Timings area of the Particle Generation rollout. Modify the size of the particles in the 
Size spinner. In the Particle Type rollout, select the MetaParticles radio button and 
render the Perspective viewport. Next, select the Standard radio button and render the 
Perspective viewport. Now, notice the difference.              

2.	 In the Load/Save Presets rollout, select an option from the Saved Presets area and choose 
the Load button. Now, render the Perspective viewport and notice the difference in the 
type of particles displayed. 

3.	 Invoke the Push tool from Create > Space Warps > Forces > Object Type rollout. 
Create the push space warp icon in the Top viewport. Next, bind the push space warp 
with the particle system. Modify the parameters of the push space warp and notice the 
difference.    

4.	 Create a sphere in the Top viewport. Next, invoke the Bomb tool from Create > Space 
Warps > Geometric/Deformable > Object Type rollout and create a bomb space warp 
icon in the Top viewport. Now, bind the bomb space warp icon to the sphere and notice 
the effect. Next, change the position of the bomb space warp icon in any viewport and 
notice the difference. 
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5.	 Create a plane in the Top viewport and increase the number of segments in it. Next, invoke 
the Ripple tool from Create > Space Warps > Geometric/Deformable > Object Type 
rollout and create a ripple space warp icon in the Top viewport. Now, bind the ripple 
space warp icon to the plane and notice the effect. Next, modify the parameters of the 
ripple space warp in the Parameters rollout and notice the difference.  

Exercise 2
Create an animated scene in which an object falls into the sea and floats on it, thus creating 
wavy effect in the water, as shown in Figure 14-57. You can view the final rendered image of 
this scene by downloading it from http://www.cadcim.com.	                (Expected time: 15 min)	
		     		    
Hint:

1.	 Use the Ripple tool in the Geometric/Deformable category of space warps.

Exercise 3
Create an animated scene displaying the rainy effect, as shown in Figure 14-58. You can view 
the final rendered image of this scene by downloading it from http://www.cadcim.com.		
			      	                                                       (Expected time: 15 min)

Hint:

1.	 Use the spray particle system to create the rain effect.

Figure 14-57  Model for Exercise 2 Figure 14-58  Model for Exercise 3

Answers to Self-Evaluation Test
1. d, 2. c, 3. c, 4. c, 5. T, 6. T, 7. F, 8. UDeflector, 9. stretch, 10. skew  


