
Chapter 3

Working with Symbols 
and Instances

 Learning Objectives 
After completing this chapter, you will be able to:
• Create new symbols
• Edit the symbols and instances
• Create and edit button symbols
• Import Adobe Photoshop files in Flash
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Introduction
In Flash, you can create movies of small file size. One way to keep the file size small is to create 
symbols. There are three categories of symbols in Flash namely graphics, buttons, and movie 
clips. Once a symbol is created in a Flash document, it is automatically saved in its library and 
can be used later in any of the Flash documents. 

The graphic symbols are the basic category of symbols. These symbols are generally used for 
static images. They do not support ActionScript, filters, or blending modes. 

The button symbols are used to create buttons for interactivity. A button symbol contains four 
keyframes. Each keyframe is used to define the behavior when the mouse pointer interacts 
with the button symbol. You can apply filters, blending modes, and color effects to the button 
symbols. These symbols require ActionScript to perform an action.

The movie clip symbols are the most powerful symbols in Flash and are generally used for 
animation. A movie clip symbol contains its own independent Timeline. You can add an 
animation to the movie clip Timeline as you do in the main Timeline and play both the 
animations simultaneously, making complex animations simpler. You can also apply filters, 
color effects, and blending modes to a movie clip and its instances. An instance is the copy 
of a symbol located in the Stage or inside a symbol. In addition, you can use ActionScripts to 
control movie clips and make them respond to the user.

Creating Symbols
In Flash, you can create symbols in two ways. They are discussed next.

1.	 Create a new Flash document. Next, choose Insert > New Symbol from the menubar; 
the Create New Symbol dialog box will be displayed. In this dialog box, specify a name 
for the symbol in the Name text box and select the required symbol type from the Type 
drop-down list. Next, choose the OK button; the symbol-editing mode will be displayed. 
In this mode, you can draw or import the graphics in the symbol.

2.	 Select an object or existing graphic in the Stage that you need to convert into a symbol. 
Next, choose Modify > Convert to Symbol from the menubar; the Convert to Symbol 
dialog box will be displayed. Next, specify a name for the symbol in the Name text box 
and select the required symbol type from the Type drop-down list. Then, choose the OK 
button; the selected object or graphic will be converted into a symbol and will be saved 
in the document library.

Downloading Files
Before you start the tutorials, you need to download the c03_flash_cs5.5_tut.zip file from 
http://www.cadcim.com. The path of the file is as follows:

	 Textbooks > Animation and Visual Effects > Flash > The Adobe Flash Professional CS5.5: A 
Tutorial Approach
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Next, navigate to the Documents folder and create a new folder with the name Flash_Projects 
and then extract the contents of the zipped file to \Documents\Flash_Projects.

 Tutorial 1 

In this tutorial, you will create and edit a graphic symbol and its instances.
								          (Expected time: 15 min)
The following steps are required to complete this tutorial:

a.	 Open the Flash document.
b.	 Convert the shape into a graphic symbol.
c.	 Create and edit the instance of the symbol.
d.	 Edit the symbol.
e.	 Break the link of the instance from its symbol.

Opening the Flash Document
In this section, you will open the Flash document.

1.	 Choose File > Open from the menubar; the Open dialog box is displayed.

2.	 Choose Documents > Flash_Projects > c03_tut > c03_tut_01 > c03_tut_01_start.fla. 
Next, choose the Open button from the dialog box; the Flash document is displayed, as 
shown in Figure 3-1.

Figure 3-1  The c03_tut_01_start.fla document displayed
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Converting the Shape into a Graphic Symbol
In this section, you will convert the object into a graphic symbol. 

1.	 Choose the Selection Tool from the TOOLS panel. Next, marquee select the circular shape 
in the Stage and choose Modify > Convert to Symbol from the menubar; the Convert to 
Symbol dialog box is displayed, as shown in Figure 3-2.

2.	 In the Convert to Symbol dialog box, type cricket ball as the name of the symbol in the 
Name text box and then select Graphic from the Type drop-down list, refer to Figure 3-2. 
Next, choose the OK button; the graphic symbol with the name cricket ball is created and 
saved in the Library and an instance of it is created in the Stage, as shown in Figure 3-3. 

	 When you convert a shape or graphic into a symbol, its instance is created in the Stage 
and the symbol itself is placed inside the LIBRARY panel.

	 The graphic symbols are the basic category of symbols. These symbols are generally used 
to convert still images or objects into symbol.

	

Figure 3-2  The Convert to Symbol dialog box

Note
Select the cricket ball symbol in the LIBRARY panel to view it in the Item preview window if 
it is not selected, as shown in Figure 3-3. The Item preview window displays the selected symbol 
in the LIBRARY panel. The Library in Flash stores all the files such as bitmaps, graphics, 
sound files, and the video clips that you import. It also stores the symbols that are created in a 
Flash document.  	

Figure 3-3  The cricket ball symbol displayed in the 
Item preview window of the LIBRARY panel
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Creating and Editing the Instance of the Symbol
In this section, you will create and edit the instances of the cricket ball symbol. 

1.	 Click on the cricket ball symbol icon ( ) in the LIBRARY panel and drag it to the Stage; 
the second instance of the cricket ball symbol is created in the Stage. Alternatively, drag 
the cricket ball symbol from the Item preview window of the LIBRARY panel to the Stage 
to create its instance.

2.	 Place the second instance below the first instance in the Stage. 

3. 	 Choose the Selection Tool from the TOOLS panel and select the first instance of the cricket 
ball; the properties of the instance are displayed in the PROPERTIES panel.

4.	 In the COLOR EFFECT area of the PROPERTIES 

Figure 3-4  The Alpha slider in the 
COLOR EFFECT area

panel, select Alpha from the Style drop-down list; 
the Alpha slider is displayed in the COLOR 
EFFECT area, as shown in Figure 3-4. 

5.	 Set the value of the Alpha slider to 55. Alternatively, 
enter 55 in the Alpha edit box and notice the 
change in the transparency of the first instance, 
as shown in Figure 3-5. 

6.	 Choose the Selection Tool from the TOOLS panel 
and select the second instance in the Stage; the 
properties of the instance are displayed in the 
PROPERTIES panel.

7.	 In the COLOR EFFECT area of the PROPERTIES 
panel, select Brightness from the Style drop-down 
list; the Bright slider is displayed in the COLOR EFFECT area. Next, set the value of 
Bright slider to -60; the instance of the symbol turns dark, as shown in Figure 3-6.

Figure 3-5  The first instance Figure 3-6  The second instance

Note
You can create any number of instances of a symbol and change their respective properties from 
the PROPERTIES panel without affecting the other instances. To edit a symbol’s property, 
double-click on the symbol in the LIBRARY panel to enter the symbol-editing mode.

	 The Advanced option in the Style drop-down list is used to change the RGB values of an 
object. These options are discussed in the later chapters.
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Editing the Symbol
In this section, you will edit the cricket ball symbol in the symbol-editing mode.

1.	 Double-click on the icon of the cricket ball graphic symbol ( ) in the LIBRARY panel to 
enter into the symbol-editing mode. Alternatively, double-click on the cricket ball graphic 
symbol image in the Item Preview window of the LIBRARY panel; the cricket ball graphic 
symbol is displayed in the Stage with its Timeline in the symbol-editing mode, refer to 
Figure 3-7.

Tip: You can also edit a symbol by choosing Edit > Edit Symbols from the menubar or by 
pressing CTRL+E.

Figure 3-7  The cricket ball graphic symbol in the symbol-editing mode

2.	 Select the upper fill of the cricket ball graphic symbol and choose the Color button 
located at the upper left corner of the PROPERTIES panel; the COLOR panel 
is displayed. 

3.	 In this panel, double-click on the left pointer of the gradient definition bar; a flyout is 
displayed. In this flyout, enter #FFFFFF in the Hex edit box and press the ENTER key. 
Next, double-click on the right pointer; a flyout is displayed. In this flyout, enter #000000 
in the Hex edit box and press the ENTER key. Figure 3-8 displays the selected fill and its 
gradient definition bar.

 
4.	 Repeat Step 2 for the middle and lower fills of the cricket ball. Next, marquee select the 

entire stroke of the border of the cricket ball using the SHIFT key; the Shape properties 
are displayed in the PROPERTIES panel. 
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5.	 In the FILL AND STROKE area of the PROPERTIES panel, choose the Stroke color 
swatch; a flyout is displayed. In this flyout, enter #000000 in the Hex edit box and press 
the ENTER key. Notice that the changes that you make to the symbol also affect the 
instances of the symbol in the Stage. The ball will turn black in the LIBRARY panel and 
in the Stage, refer to Figure 3-9.

Figure 3-9  The cricket ball 
symbol after changing the color

Figure 3-8  The gradient definition bar of the upper fill inside 
the cricket ball symbol

6.	 Click on Scene 1 to return to the main Timeline.

Breaking the Link of the Instance from its Symbol
In this section, you will break the link of the cricket ball instance from its symbol.

1.	 Choose the Selection Tool from the TOOLS panel and select the first instance of cricket 
ball symbol in the Stage.

2.	 Choose Modify > Break Apart from the menubar or press CTRL+B; the first instance 
of cricket ball is delinked from its symbol. The instance is now an independent object and 
is no longer linked to the symbol. Now, you can modify the symbol without affecting the 
instance or vice-versa.

3.	 Double-click on the icon of the cricket ball graphic symbol ( ) in the LIBRARY panel to 
enter into the symbol-editing mode. 

4.	 Choose the Selection Tool from the TOOLS panel and select the upper fill of the  
ball. Next, choose the Color button located at the upper left corner of the 
PROPERTIES panel; the COLOR panel is displayed. 

5.	 In this panel, double-click on the right pointer of the gradient definition bar; a flyout is 
displayed. In this flyout, enter #0000CC in the Hex edit box and press the ENTER key; 
the color of the cricket ball graphic symbol in the LIBRARY panel is changed, as shown 
in Figure 3-10. 
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6.	 Click on Scene 1 to return to the main Timeline; the color of the second instance is 
changed as it is still linked to the symbol. The first instance remains unchanged as it is 
no more linked to the symbol, refer to Figure 3-11.

Figure 3-10  Displaying the change in color of 
the cricket ball graphic symbol

Figure 3-11  The first instance without 
any change

7.	 Save the flash file with the name c03tut1 at the location Documents > Flash_Projects > 
c03_tut > c03_tut_01. 

8.	 Press CTRL+ENTER to view the final output of the instance and the symbol. You can also 
view the final rendered image of the instance by downloading the file c03_flash_cs5.5_rndr.
zip from http://www.cadcim.com. The path of the file is mentioned at the beginning of the 
chapter.

 Tutorial 2                                                             
In this tutorial, you will create a button symbol, as shown in Figure 3-12 and then define its 
states.						       	   	   (Expected time: 20 min)
				           

Figure 3-12  The button symbol

			 

The following steps are required to complete this tutorial:

a.	 Create a new Flash document.
b.	 Create a shape.
c.	 Convert the shape into a button symbol.
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Creating a New Flash Document
In this section, you will create a new Flash document.

1.	 Choose File > New from the menubar; the New Document dialog box is displayed. 

2.	 In the New Document dialog box, choose ActionScript 3.0 from the General tab and 
then choose the OK button; a new Flash document is displayed.

Creating a Shape
In this section, you will create the shape of the button symbol. 

1.	 Choose the Rectangle Primitive Tool from the TOOLS panel. 

2.	 Choose the Color button located at the upper left of the PROPERTIES panel; the   
COLOR panel is displayed. In this panel, select the fill style as Linear gradient 
from the Color type drop-down list. 

3.	 Draw a rectangle in the Stage; the tool properties are displayed in the PROPERTIES 
panel. 

4.	 In the RECTANGLE OPTIONS area of the PROPERTIES panel, enter 7 in the Rectangle 
corner radius edit box and press the ENTER key; the shape of the corners is changed, 
as shown in Figure 3-13. 

Figure 3-13  Changing the shape of the corners of the rectangle

5.	 Choose the Gradient Transform Tool from the TOOLS panel and click on the fill of the 
rectangle in the Stage; the gradient transform bars are displayed around the fill. 

6.	 Move the cursor over the rotation handle of the gradient transform bar located at the upper 
right corner of the bars and drag the cursor to the left to rotate the gradient transform 
bars to approximately 90 degrees, as shown in Figure 3-14. 
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7.	 Move the cursor over the arrow located on the gradient transform bar; the shape of the 
cursor changes to a double-headed arrow indicating that now you can scale the fill. Next, 
drag the cursor inward and scale the gradient fill to 50%, as shown in Figure 3-15. The 
rectangular shape of the button symbol is created in the Stage.

Figure 3-15  Scaling the gradient fillFigure 3-14  Rotating the gradient fill

 

Converting the Shape into a Button Symbol
In this section, you will convert the rectangle into a button symbol and edit it. 

1.	 Double-click on Layer 1 (default layer name) in the TIMELINE panel and rename it as 
Buttons. 

2.	 Choose the Selection Tool from the TOOLS panel and select the rectangle in the Stage. 
Next, choose Modify > Convert to Symbol from the menubar or press the F8 key; the 
Convert to Symbol dialog box is displayed.

3.	 In the Convert to Symbol dialog box, type Home in the Name text box and select Button 
from the Type drop-down list. Next, choose the OK button; a button symbol with the 
name Home is created and saved in the Library.

Note
In Flash, when you create a new button or convert a shape into a button symbol, a new Timeline 
is created for the corresponding button symbol, which is visible only in the button symbol’s editing 
mode. To make the Timeline visible, double-click on that button symbol.

4.	 Double-click on the icon of the Home button symbol icon ( ) in the LIBRARY panel to 
enter the editing mode. Alternatively, choose Edit > Edit Symbols from the menubar. 
Figure 3-16 shows the editing mode of the Home button symbol.

Note
Figure 3-17 shows the Timeline of the button symbol. This Timeline contains four frames that 
define the different states of the button symbol. The Up frame is used to define the appearance 
of the button when the cursor is not placed over it. Flash automatically places the original 
button symbol in the Up frame.
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Figure 3-16  Symbol-editing mode of the Home button symbol

Figure 3-17  The Timeline of the Home button symbol

5.	 In the TIMELINE panel, select the Over frame. Next, press the F6 key or choose Insert > 
Timeline > Keyframe from the menubar; a keyframe is inserted in the blank frame. 

	 The Over frame of the button symbol is used to define the appearance of the symbol when 
the mouse pointer is over it.

Note
The keyframe is a frame that represents a new symbol instance in the Timeline. You can also 
add the ActionScript code to the keyframe to control certain actions in a document.

6.	 Choose the Selection Tool from the TOOLS panel and select the rectangle in the 
Stage. 

7.	 Choose the Color button located at the upper left corner of the PROPERTIES 
panel; the COLOR panel is displayed. In the COLOR panel, double-click on the 
right pointer of the gradient definition bar; a flyout is displayed. In this flyout, 
enter #999999 in the Hex edit box and press the ENTER key. Now, click in the blank 
area of the Stage to deselect the fill.

8.	 Select the Down frame and press the F6 key to insert a keyframe. Next, select the fill of 
the rectangle in the Stage. 
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9.	 Choose the Color button; the COLOR panel is displayed. In the COLOR panel, 
double-click on the right pointer of the gradient definition bar; a flyout is displayed. In 
this flyout, enter #333333 in the Hex edit box and press the ENTER key. 

	 The Down frame of the button symbol is used to define the appearance of the button 
when the user clicks on it.

10.	 Select the Hit frame and press the F6 key to insert a keyframe. Choose the Rectangle Tool 
from the TOOLS panel; the properties of this tool are displayed in the PROPERTIES 
panel. In the FILL AND STROKE area of the PROPERTIES panel, choose the Stroke 
color swatch; a flyout is displayed. In this flyout, enter #000000 in the Hex edit box and 
press the ENTER key. 

11.	 Choose the Fill color swatch; a flyout is displayed. In this flyout, enter #0000CC in the 
Hex edit box. 

12.	 In the Stage (symbol-editing mode in the Scene area), create a rectangle covering the 
rectangle of the button symbol, as shown in Figure 3-18.  

	 The Hit frame of the button symbol represents the area of the screen that will respond to 
the click and the rectangle created in this frame defines the clickable area of the button.

Note
The hit area is not visible in the Stage and in the preview window.

Figure 3-18  Rectangle in the Hit frame



Working with Symbols and Instances		         3-13

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

13.	 Press CTRL+ENTER; the preview window is displayed showing the Home button instance. 
Move the mouse pointer over the Home button instance to see its Over state and click 
on it to see its Down state. Figures 3-19 and 3-20 show the Over and Down states of the 
Home button instance, respectively.

Figure 3-19  The Over state of the 
button symbol

Figure 3-20  The Down state of the 
button symbol

	 Notice that the rectangle you created in the Hit frame is not visible in the preview window. 
Click anywhere in the preview window except on the hit area (rectangle) you created in 
the Hit frame; the button symbol shows no change. 

14.	 Close the preview window to return to the Flash document.

15.	 Double-click on the Home button instance in the Stage. 

16.	 In the TIMELINE panel, select the Hit frame; the rectangle in the Stage is selected.

17.	 Choose the Selection Tool from the TOOLS panel and click on the rectangle; the Shape 
properties are displayed in the PROPERTIES panel. 

18.	 In the POSITION AND SIZE area of the PROPERTIES panel, set the value of W to 300 
and the value of H to 200. Next, set the value of X to -105 and the value of Y to -88; the 
rectangle is positioned and resized, as shown in Figure 3-21.
 

Figure 3-21  Increasing the dimensions of the rectangle in the Flash document
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19.	 Press CTRL+ENTER; the preview window is displayed showing the Home button. In the 
preview window, move the cursor over the hit area of the button and notice the changes 
in it. 

	 By increasing the dimensions of the rectangle in the Hit frame, you can define the hit 
area of the button symbol (instance). The appearance of the button changes even when 
you place the cursor over and click on the hit area and not merely clicking on the symbol 
itself.

20.	 Save the flash file with the name c03tut2 at the location Documents > Flash_Projects > 
c03_tut > c03_tut_02. 

21.	 Press CTRL+ENTER to view the final output of the button symbol. You can also view 
the final rendered file of the button symbol by downloading the file c03_flash_cs5.5_rndr.
zip from http://www.cadcim.com. The path of the file is mentioned at the beginning of the 
chapter.

 Tutorial 3                                                             
In this tutorial, you will convert the objects into movie clip symbols and apply Glow filter on 
them, as shown in Figure 3-22.				      	   (Expected time: 10 min)

Figure 3-22  The Glow filter applied on movie clips symbols

The following steps are required to complete this tutorial:

a.	 Open the Flash document.
b.	 Convert the shapes into the movie clip symbols.
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Opening the Flash Document
In this section, you will open the Flash document required for this tutorial.

1.	 Choose File > Open from the menubar; the Open dialog box is displayed. In this dialog 
box, choose Documents > Flash_Projects > c03_tut > c03_tut_03 > c03_tut_03_start.
fla. Next, choose the Open button; the Flash document is displayed, as shown in 
Figure 3-23.

Figure 3-23  The c03_tut_03_start.fla document displayed

 

Converting the Shapes into Movie Clip Symbols
In this section, you will convert the shapes into movie clips symbols.

1.	 Select the Moon layer in the TIMELINE panel; the circle (moon) behind the clouds is 
selected in the Stage. 

2.	 Press the F8 key; the Convert to Symbol dialog box is displayed. In this dialog box, type 
moon_mc as the symbol name in the Name text box and select Movie Clip as the symbol 
type from the Type drop-down list. Next, choose the OK button; the moon shape is 
converted into a movie clip symbol with the name moon_mc.

3.	 Expand the FILTERS area in the PROPERTIES panel. At the bottom of the
FILTERS area, choose the Add filter button; a flyout is displayed, showing various 
filters, as shown in Figure 3-24. 
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Figure 3-24  The flyout displayed on choosing the Add filter button

4.	 Choose Glow from this flyout; the Glow area with various properties is displayed in the 
FILTERS area displaying Glow properties, as shown in Figure 3-25. 

5.	 In the Glow area, set the Blur X and Blur Y values to 50 and Strength value to 150. 

6.	 Click on the swatch on the right to Color; a flyout is displayed. In this flyout, enter 
#FFFFFF in the Hex edit box and press the ENTER key. 

7.	 Select High from the Quality drop-down list. After setting these values, you will notice the 
glow effect displayed around the circle (moon) in the Stage, as shown in Figure 3-26.

 

Figure 3-25  The Glow area Figure 3-26  The effect of the Glow filter 
on the moon

8.	 In the TIMELINE panel, select the Stars layer; the dots (stars) are selected in the 
Stage. 
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9.	 Press the F8 key; the Convert to Symbol dialog box is displayed. In this dialog box, type 
the symbol name as stars in the Name text box and select Movie Clip as the symbol type 
from the Type drop-down list; the dots are converted into a movie clip symbol with the 
name stars.

10. 	At the bottom of the FILTERS area, choose the Add filter button; a flyout is displayed 
showing various filters. In this flyout, choose Glow; the Glow area is displayed in the 
FILTERS area. 

11.	 In the Glow area, set the Strength value to 150. Click on the swatch on the right of Color; 
a flyout is displayed. In this flyout, enter #FFFFFF in the Hex edit box and press the 
ENTER key. 

12.	 Select High from the Quality drop-down list; the glow effect is displayed around the dots 
in the Stage, as shown in Figure 3-27.

Figure 3-27  The glow effect on dots

13.	 Save the flash file with the name c03tut3 at the location Documents > Flash_Projects > c03_tut > 
c03_tut_03. 

14.	 Press CTRL+ENTER to view the final output of the tutorial. You can also view the final 
rendered file of the tutorial by downloading the file c03_flash_cs5.5_rndr.zip from http://
www.cadcim.com. The path of the file is mentioned at the beginning of the chapter.

 Tutorial 4                                                             
In this tutorial, you will import Adobe Photoshop artwork into Flash.  				  
								          (Expected time: 10 min)
The following steps are required to complete this tutorial:
								      
a.	 Create a new Flash document.
b.	 Import Photoshop file.
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Creating a New Flash Document
In this section, you will create a new Flash document.

1.	 Choose File > New from the menubar; the New Document dialog box is displayed. 

2.	 In the New Document dialog box, choose ActionScript 3.0 from the General tab and 
then choose the OK button; a new Flash document is displayed.

Importing the Photoshop File
To create a complex artwork, you may prefer other applications such as Adobe Illustrator 
and Adobe Photoshop. In this section, you will learn to import artwork created in Adobe 
Photoshop to Flash. 

1.	 Choose File > Import to Stage from the menubar; the Import dialog box is displayed. 
In this dialog box, choose Documents > Flash_Projects > c03_tut > Resources > 
shapes.psd; the Import “shapes.psd” to Stage dialog box is displayed, as shown in 
Figure 3-28.

Figure 3-28  The Import “shapes.psd” to Stage dialog box

2.	 From the Check Photoshop layers to import area of the Import “shapes.psd” to Stage 
dialog box, select the check boxes corresponding to the layers that you want to import; 
the selected layers will be imported to the Flash document, as shown in Figure 3-29. 
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3.	 In the Check Photoshop layers to import area of the Import “shapes.psd” to Stage 
dialog box, select Flash Layers from the Convert layers to drop-down list and then select 
the Place layers at original position check box located below the drop-down list. Next, 
choose the OK button; every object created in separate layers in Photoshop is placed in 
the same manner in Flash with name of the layers as Shape 1, Shape 2, Shape 3 and so 
on, as shown in Figure 3-29.

Figure 3-29  The selected layers imported in the Flash document

4.	 Save the flash file with the name c03tut3 at the location Documents > Flash_Projects > c03_tut > 
c03_tut_04. 

5.	 Press CTRL+ENTER to view the final output. You can also view the final rendered file 
of the tutorial by downloading the file c03_flash_cs5.5_rndr.zip from http://www.cadcim.com. 
The path of the file is mentioned at the beginning of the chapter.

Table 3-1 displays various file formats that can be imported in Flash 8 or later versions.

    
Table 3-1  The file formats that can be imported in Flash

File Type Extension

Adobe Photoshop .psd

Adobe Illustrator .ai

AutoCAD .dxf

Bitmap .bmp

GIF and animated GIF .gif

JPEG .jpg
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PNG .png

Flash Player 6/7 .swf

Enhanced Windows Metafile .emf

Windows Metafile .wmf

FutureSplash Player .spl

Video for Flash .flv, f4v

WAV sound .wav

MP3 sound .mp3

3GPP/3GPP2 for mobile devices .3gp, .3gpp, .3gp2

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 The __________, __________, and __________ are the three categories of symbols in 
Flash.

2.	 The __________ window displays the selected symbol in the LIBRARY panel.

3.	 An __________ is a copy of a symbol. 

4.	 The __________ symbols are generally used for animating static images.

5.	 The __________ symbols are used to create buttons for interactivity.

6.	 A button symbol contains its own independent Timeline. (T/F)

7.	 The Over state of a button symbol is used to define the appearance of the button when 
the cursor is placed over it. (T/F)

8.	 You can apply blending modes and filters on a graphic symbol. (T/F)
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 Review Questions 
Answer the following questions:

1.	 Which of the following combinations of the shortcut keys is used for apply the Break Apart 
command?

		  (a) CTRL+C				    (b) CTRL+B
		  (c) CTRL+G				    (d) CTRL+U

2.	 Which of the following is the shortcut keys is used for inserting a keyframe?

		  (a) F2					     (b) F4
		  (c) F8					     (d) F6

3.	 The __________ area of a button symbol is not visible in the Stage and in the preview 
window.

4.	 __________, __________, __________, and __________ are the four states of a button 
symbol.

5.	 The __________ represents a new symbol instance in the Timeline.

6.	 The __________ state of a button symbol represents how the button will appear when the 
user clicks on it.

7.	 The __________ command is used to delink the instance from its symbol.

 Exercises 

 Exercise 1                                                                   
Create the buttons for a website, as shown in Figure 3-30, using various drawing and editing 
tools, functions, and button symbol frames. You can view the final rendered file of the buttons 
by downloading the file c03_flash_cs5.5_exr.zip from http://www.cadcim.com. The path of the file 
is as follows:							        

	 Textbooks > Animation and Visual Effects > Flash > The Adobe Flash Professional CS5.5: A 
Tutorial Approach		                 

						                       	   (Expected time: 20 min)

Figure 3-30  The buttons for website
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 Exercise 2                                                                   
Create a night scene, as shown in Figure 3-31, using various tools, functions, and filters. You 
can view the final rendered file of the tutorial by downloading the file c03_flash_cs5.5_exr.zip 
from http://www.cadcim.com. The path of the file is mentioned in Exercise 1.	  		
					      		                 (Expected time: 40 min)

Figure 3-31  The night scene

Answers to Self-Evaluation Test
1. graphic, button, movie clip, 2. Item preview, 3. instance, 4. graphic, 5. button, 6. F, 7. T, 
8. F


