
Chapter 1

Exploring NukeX 7 
Interface 

 Learning Objectives 
After completing this chapter, you will be able to:
• Start The Foundry NukeX
• Get familiar with the NukeX interface
• Understand the functions of nodes in NukeX
• Load, save, and close NukeX scripts
• Set projects for composition
• Load image sequences into NukeX
• Understand proxies
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INTRODUCTION
Welcome to the world of Nuke, an Academy Award® winning compositing software application. 
Nuke, a production-proven visual effects tool, is used to composite images, multiple stills, 3D 
renders, and image sequences into a artwork. Its state-of-the-art image processing technology 
delivers unparalleled speed on very complex compositing challenges. It has been used to create 
stunning images for feature films, such as Avatar, Alice in Wonderland, District 9, Transformers, 
Pirates of the Caribbean, Resident Evil, Quantum of Solace, and so on. Nuke comes in three 
versions: Nuke, NukeX, and Nuke PLE (Personal Learning Edition). NukeX has all features 
of Nuke with an integrated 3D camera tracker, depth map generator, projection solver, noise 
removal system, planar tracker, 3D particles system, automatic lens distortion correction tools, 
and FurnaceCore. The PLE version is free but the output on rendering and in the Viewer shows 
watermark placed on them. In this textbook, you will learn about the features and capability 
of NukeX in detail. 

STARTING The Foundry NukeX 7
You can start NukeX from the taskbar or by using the shortcut icon placed on your desktop. To 
start NukeX from the taskbar, choose Start > All Programs > The Foundry > Nuke 7.0v4 > 
NukeX 7.0v4, as shown in Figure 1-1; two windows will be displayed on the computer screen, 
the NukeX 7.0v4 command window and the NukeX interface window, as shown in Figures 1-2  
and 1-3, respectively.

Figure 1-1  Starting NukeX 7 from the taskbar
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Figure 1-2  The NukeX 7.0v4 command window

Figure 1-3  The default NukeX interface window

EXPLORING NukeX INTERFACE
The main interface window of NukeX consists of various components such as panes, panels, 
toolbar, and menu bar, refer to Figure 1-4. These components are discussed next.

Menu Bar
The menu bar is located at the top of the NukeX interface. The options in the File menu are 
used to perform disk operation commands and import scripts. The Edit menu contains editing 
commands, preferences, and project settings. The Layout menu contains options for saving 
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and accessing the layout schemes. The Layout menu also consists of options for showing the 
Curve Editor panel and the full screen toggle command. The options in the Viewer menu 
are used to create and connect viewers. The Render menu contains various render commands 
to render the output. The Help menu contains commands to access documentation, release 
notes, mailing lists, and tutorials. The options in the Cache menu are used to cache files as 
well as for clearing the disk cache and buffers.

Figure 1-4   The various components of the NukeX interface

Panes
The default NukeX interface consists of Nodes toolbar pane, the Viewer pane, the Node 
Graph/Curve Editor/Dope Sheet pane and the Properties Bin. The tabs inside the panes are 
called panels. By default, the Node Graph/Curve Editor/Dope Sheet pane is displayed at the 
lower left corner of the NukeX interface, the Viewer pane is located at the upper left corner, 
and the Properties Bin pane at the right. The Nodes toolbar pane is located on the left of 
the NukeX interface and the menu bar is located at its top. The options in the Nodes toolbar 
are used to add nodes to the Node Graph panel. The Node Graph panel is used to build a 
network of nodes to create a composite. The Node Graph is also known as DAG (Directed 
Acyclic Graph). The Curve Editor and Dope Sheet panels are used to refine the animation 
curves and keyframes. The Properties Bin pane is used to adjust the controls of the nodes. 
The Viewer pane is used to preview the output of the nodes. You can also add the Script 
Editor and Progress Bar panels to the panes. The Script Editor panel is used to execute the 
Python commands, whereas the Progress Bar panel is used to display the progress bars. The 
process of adding a panel to a pane will be discussed later in this chapter.
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You can modify the position and size of the panes. You can also add or remove panels from 
the panes. Various methods to modify the arrangement of the panes and panels are discussed 
next.

Changing the Size of a Pane
To change the size of a pane, place the cursor on the divider line between the panes; the shape 
of the cursor will change, as shown in Figure 1-5. Next, drag the cursor to resize the pane as 
required and then release the mouse button.

Figure 1-5   The changed shape of the cursor

Splitting a Pane
To split a pane, choose the Checkerboard button located at the upper left corner of the  
pane; the Content menu will be displayed, as shown in Figure 1-6. Next, choose Split 
Vertical or Split Horizontal from the menu to split the pane vertically or horizontally. Figure 1-7 
shows the horizontally split Node Graph/Graph Editor/Dope Sheet pane. To restore the 
default layout, press SHIFT+F1.

Adding Panel to a Pane
To add a new panel to a pane, choose the Checkerboard button and then choose the desired 
option such as Script Editor or New Viewer from the Content menu displayed. 

Tip: To cycle through the panels in a pane, use the CTRL+T keys.

Closing a Panel
To close a panel, click on the Close (x) button located on the top right corner of the panel or 
choose the Close Tab option from the Content menu. 

Floating a Pane or Panel
To float a pane or a panel, choose the Float Pane or Float Tab option from the Content 
menu.

Tip: You can dock or undock the panels from the NukeX interface. To undock a panel, press 
CTRL and then click on the label of the panel name; a floating window will be displayed. 
Alternatively, you can drag the panel outside the borders of the main NukeX window. To 
dock the floating panel back to the pane, drag the panel name label over the pane; an orange 
line will appear at the top of the pane and then release the mouse button to dock the panel 
back to the pane. 
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Figure 1-6  The Content menu displayed on choosing 
the Checkerboard button

Figure 1-7  The Node Graph/Curve Editor/Dope Sheet pane split horizontally

Note 
In NukeX, you can save and restore upto 6 layouts. To save a layout, choose Layout > Save 
Layout # from the menu bar. To restore a layout, choose Layout > Restore Layout # from 
the menu bar.  Here, the # symbol represents the layout number.

Nodes Toolbar 
The Nodes toolbar is located on the left of the NukeX interface. All nodes can be accessed from 
it. By default, this toolbar contains 17 buttons. When you choose a button from this toolbar, 
a menu containing a list of nodes associated with that button will be displayed. The functions 
of these buttons and their corresponding nodes are discussed next.

Image
This button is used to access the Read and Write nodes, miscellaneous NukeX elements 
and Viewer nodes. Brief description of these nodes is given next.
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Read: This node is used to load an image from the disk. 
Write: This node is used to write the output of all upstream nodes connected to it.
UDIM Import: This node is used to import a set of texture patches that follow the 
UDIM numbering scheme.
Constant: This node is used to produce a constant color image.
CheckerBoard: This node is used to generate a checkerboard image which can be 
used as a placeholder for a texture or background.
ColorBars: This node is used to generate the SMPTE (Society of Motion Picture and 
Television Engineers) color bar test pattern.
ColorWheel: This node is used to generate a color wheel image.
CurveTool: This node is used to create an animation curve. This curve can be used 
to control the size and position of the black areas, exposure changes, and luminance 
in a sequence.
Viewer: This node is used to display the render output of the process node in the 
Viewer panel.

Draw
This button is used to access the rotoscopy, grain, lens flare, and vector based nodes. 
The nodes under this button are discussed next.

Roto: This node is specifically used for rotoscopy. It is used to create Bezier and 
B-Spline roto shapes.
RotoPaint: This node is similar to the Roto node with the only difference that by 
using the RotoPaint node, you can perform tasks such as rig removal, dustbusting, 
and garbage removal.
Dither: This node is used to add random noise to an image to hide the quantization 
effects.
DustBust: This node is used to remove dust or scratches from the images. It clones 
multiple areas from a source to a destination.
Grain: This node is used for adding synthetic grain to a footage.
ScannedGrain: This node is used to apply the actual scans of the film grain to the 
input image to replicate the grain of the scanned film stock.
Glint: This node is used to create star-shaped points around the brighter points in 
an image.
Grid: This node is used to draw a grid of horizontal and vertical lines.
Flare: This node is used to simulate the lens flare effect.
LightWrap: This node is used to wrap the light from the background onto the 
foreground object.
MarkerRemoval: This node is used to remove tracking markers from a footage by 
using the roto shapes.
Noise: This node is used to apply various types of seamless noise to the image, based 
on the perlin noise algorithm.
Radial: This node is used to generate a radial gradation ramp.
Ramp: This node is used to generate a gradient ramp. However, its usage is obsolete 
now.
Rectangle: This node is used to generate a solid color rectangle shape.
Sparkles: This node is used to generate sparkles or rays.
Text: This node is used to add text overlays on the images.
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Time
This button is used to access time management nodes. The nodes under this button 
are discussed next.

Add 3:2 pulldown: This node is used to convert a 24fps film to 29.97fps interlaced 
video.
Remove 3:2 pulldown: This node is used to remove a 3:2 pull-down from the input 
image.
AppendClip: This node is used to append one clip to another. It can be used to join 
the clips, add transitions between clips, and slip edit the clips.
FrameBlend: This node is used to interpolate frames by blending the frame that 
precede and follow it.
FrameHold: This node is used to return a constant frame from the input. If the frame 
increment is set to a non zero values, this node will return every nth frame.
FrameRange: This node is used to set a range of frames.
Kronos: This node is a retime node and used to slow down or speed up the image 
sequence.
OFlow: This node is used to slow down or speedup the input footage. Additionally, 
you can add the motion blur to an image or enhance the motion blur already applied 
to an image.
Retime: This node is used to change the timing of the input clip. You can use this 
node to slow down, speed up, and reverse frames in an input image.
TemporalMedian: This node is used to remove grain from the footage by calculating 
the median of the current frame, the frame before, and the frame after the current 
frame.
TimeBlur: This node is used to generate temporal motion blur. 
NoTimeBlur: This node is used to avoid unwanted computations in blur 
operations.
TimeEcho: This node is used to generate echo like effects by merging a range of 
frames into a single frame.
TimeOffset: This node is used to move the input clip forward or backward in time.
TimeWarp: This node is used to change the timing of the input clip.
TimeClip: This node is used to move the input image forward or backward in time.
VectorGenerator: This node is used to produce images containing motion vector 
field.
	

Channel
This button is used to access channel management nodes. The nodes under this 
button are discussed next.

Shuffle: This node is used to rearrange up to eight channels in a data stream.
ShuffleCopy: This node is used to reorder up to eight channels from two inputs. Also, 
it is used to copy channels between data streams.
Copy: This node is used to replace channels in the B input with channels from the 
A input.
ChannelMerge: This node is used to merge two channels. The result of the merge 
operation is saved in the selected output channel.
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Add: This node is used to add a channel to an image.
Remove: This node is used to remove channels from an image.

Color
This button is used to access color correction nodes. The nodes under this button are 
discussed next.

Math (Add): This node is used to offset values of a channel.
Math (Multiply): This node is used to multiply values of a channel by a factor.
Math (Gamma): This node is used to apply a constant gamma value to a set of 
channels.
Math (ClipTest): This node is used to create zebra stripes for the colors that are 
outside the specified range.
Math (ColorMatrix): This node is used to transform a color channel. It multiplies 
the RGB colors by an arbitrary 3x3 matrix. 
Math (Expression): This node is used to reference pixels in other channels by using 
C like syntax expressions.
OCIO (OCIO CDLTransform): This node is used to apply an ASC CDL (American 
Society of Cinematographers Colors Decesion List) grade based on the OpenColorIO 
library.
OCIO (OCIO ColorSpace): This node is similar to the regular ColorSpace node but 
it is based on the OpenColorIO library.
OCIO (OCIO Display): This node is used to apply a colorspace conversion to an 
image sequence.
OCIO (OCIO FileTransform): This node is used to load a colorspace conversion 
from a file and then apply it using the OpenColorIO library.
OCIO (OCIO LogConvert): This node is used to convert compositing log data to 
scene linear data.
3D LUT (CMSTestPattern): This node is used to generate calibration patterns for 
color management.
3D LUT (GenerateLUT): This node is used to generate color management lookup 
tables.
3D LUT (Vectorfield - Apply 3D LUT): This node is used to transform the input 
colors based on the 3D vectors.
Clamp: This node is used to clamp all channels to the 0-1 range.
ColorLookup: This node is used to make gamma, gain, and contrast adjustments to 
an input image using the lookup tables.
Colorspace: This node is used to convert images from one color space into 
another.
ColorTransfer: This node is used to change the color of an image to match the color 
of another image.
ColorCorrect: This node is used to adjust the ranges of shadows, midtones, and 
highlights of an input image.
Crosstalk: This node is used to add or remove crosstalk or bleeding between color 
channels.
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Exposure: This node is used to adjust the exposure of the input footage.
Grade: This node is used to define the black and white points by sampling pixels 
from the Viewer.
Histogram: This node is used to plot the incoming image as a histogram. It also 
allows tonal range corrections.
HistEQ: This node is used to equalize the histogram of an image.
HueCorrect: This node is used to make precision adjustments to the levels of saturation 
in the range of hues.
HueShift: This node is used to transform the colorspace of an image by using the 
CIE XYZ colorspace.
HSVTool: This node is used to adjust the HSV components of an input image.
Invert: This node is used to invert values of a channels.
Log2Lin: This node is used to perform the log2lin or lin2log conversion used by 
Cineon files.
PLogLin: This node is used to convert the logarithmic color space to linear color 
space based on a single gray point.
MinColor:  This node is used to calculate the difference between the darkest value in 
the input image and the target value, thus, the darkest pixel becomes the value.
Posterize: This node is used to reduce the color resolution of an image.
RollOffContrast: This node is used to implement a contrast curve with a smooth 
falloff equally across all channels.
Saturation: This node is used to change the saturation of the incoming image data.
Sampler: This node is used to convert the scanline of pixel data into a lookup 
curve.
SoftClip: This node is used to compress the high dynamic range imagery into the 
0-1 range.
Toe: This node is used to lift the black levels without much affecting the whites in 
the input image.
TrueLight: This node is used to preview the final look of the film on the monitor 
display. This technology was developed by Filmlight.

Filter
This button is used to access the blur and sharpen nodes. The nodes under this button 
are discussed next.

Blur: This node is used to apply blur to an image using various filter algorithms.
Bilateral: This node is used to smoothen the images while preserving their edges.
BumpBoss: This node is used to produce an emboss effect by overlapping the A 
input with the B input.
Convolve: This node is used to create custom filter effects using the user specified 
filter images.
Defocus: This node is used to apply the defocus effect on an image using the disc 
filter. 
DegrainBlue: This node is used to reduce noise in the blue channel.
DegrainSimple: This node is used to reduce noise in the red, green, and blue 
channels.
DirBlur: This node is used to apply various types of directional blur effects.
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Denoise: This node is used to remove noise from the input image without losing 
image quality.
EdgeBlur: This node is used to apply blur to the edges within the matte.
EdgeDetect: This node is used to detect the edges of an image and blur them.
Emboss: This node is used to produce the emboss effect by offsetting the original 
input.
Erode (fast): This node is used to erode or dilate RGBA channels. It applies the Box 
Morphological filter.
Erode (filter): This node is similar to the Erode(fast) but it is computational 
intensive. You can improve the erode quality using the options available in the filter 
drop-down. 
Erode (blur): This node is used to erode or dilate RGBA channels by using blur.
Glow: This node is used to generate the glow effect.
GodRays: This node is used to produce godrays, lighting, and blur effects.
Laplacian: This node is used to blur the image and then subtract the original 
image from the blurred image.
LevelSet: This node is used to create high quality dilate or unpremultiply 
operations.
Matrix: This node is used to apply a custom convolution matrix onto an image.
Median: This node is used to remove the single pixel noise without compromising 
the quality of the input image.
MotionBlur: This node is used to add blur based on the movement of the object in 
the scene.
MotionBlur2D: This node is used to output UV vectors for the VectorBlur node.
MotionBlur3D: This node is used to output the UV vectors that can be used to run the 
vector blur operator to produce multi-blur. It is specifically used for camera moves.
Sharpen: This node is used to sharpen the specific channels using the laplacian.
Soften: This node is used to produce the same effect as that of the Sharpen node, with 
the only difference being that the Laplacian effect is added to the original.
VectorBlur: This node is used to generate the motion blur by blurring each pixel 
into a straight line.
VolumeRays: This node is used to create ray lighting effects.
ZSlice: This node is used to select a slice from the input image by using the Z-Depth 
channel.
ZDefocus: This node is used to blur the image using the depth map channel.

Keyer
This button is used to access the matte extracting nodes. The nodes under this button 
are discussed next.

Difference: This node is used to produce the difference between two images as a 
matte.
HueKeyer: This node is used to calculate the hue of the incoming image and then 
uses the amount lookup curve to define the value to output in the alpha channel.
IBKGizmo: This node is used to generate matte by using the processed screen 
image (clean plate).
IBKColour: This node is used to process the screen image to be used with the 
IBKGizmo node.
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Keyer: This node is used to pull the key from an image. It is a simple keyer.
Primatte: This node is used to pull the key from an image using the 3D RGB color 
space.
Keylight: This keyer is an advanced blue and green screen keyer.
Ultimatte: This node is used to pull the key from an image. It is an advanced 
keyer developed by Ultimate Corporation. It preserves fine details such as hair and 
smoke.

Merge
This button is used to access various merge nodes. The nodes under this button are 
discussed next.

AddMix: This node uses the alpha of the A input to index two color correction lookup 
curves. The first input is used to multiply the A input, the second input is used to 
multiply the B input, and the results are added together.
KeyMix: This node is used to layer two images using a roto shape or an image as 
mask.
ContactSheet: This node is used to generate a contact sheet for all its inputs.
CopyBBox: This node is used to copy the bounding box from the A input onto the 
B stream.
CopyRectangle: This node copies a rectangle from the A input. It can be used to limit 
an effect to a specific area of the image.
Dissolve: This node is used to cross dissolve images with the help of weighted average 
of the two inputs.
LayerContactSheet: This node is used to generate a contact sheet from all channel 
sets.
Merge: This node is used for a pixel-by-pixel merge operation between input 
images.
Merges (Plus): This node is similar to the Merge node. In this node, the operation 
option is set to plus by default. It merges images together using the A+B compositing 
algorithm.
Merges (Matte): This node is similar to the Merge node. In this node, the operation 
option is set to matte by default.
Merges (Multiply): This node is similar to the Merge node. In this node, the operation 
option is set to multiply by default. It merges images together using the AB, A if A<0 
and B<0 compositing algorithm.
Merges (In): This node is similar to the Merge node. In this node, the operation 
option is set to in by default.
Merges (Out): This node is similar to the Merge node. In this node, the operation 
option is set to out by default. It merges images together using the A(1-b) compositing 
algorithm where b is the alpha value from the B input.
Merges (Screen): This node is similar to the Merge node. In this node, the operation 
option is set to screen by default. It merges images together using the A+B-AB if A 
or B ≤1, otherwise max(A,B) compositing algorithm.
Merges (Max): This node is similar to the Merge node. In this node, the operation 
option is set to max by default.
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Merges (Min): This node is similar to the Merge node. In this node, the operation 
option is set to min by default. It merges images together using the min(A,B) 
compositing algorithm.
Merges (Absminus): This node is similar to the Merge node. In this node, the 
operation option is set to difference by default. It merges images together using the 
abs(A-B) compositing algorithm.
Merge Expression: This node is used to perform mathematical operations on 
channels using TCL expressions.
Switch: This node is used to switch between any numbers of inputs.
TimeDissolve: This node is used to dissolve two input data streams, starting the 
dissolve at the in frame and ending at the out frame.
Premult: This node is used to multiply all channels by the alpha channel.
UnPremult: This node is used to divide all channels by the alpha channel.
Blend: This node is used to blend images by creating weighted average of all 
inputs.
ZMerge: This node is used to merge images based on the Z channel.

Transform
This button is used to access transformation nodes. The nodes under this button are 
discussed next.

Transform: This node is used to reposition, scale, and move an image in the 2D 
space.
TransformMasked: This node is similar to the Transform node. However, it also 
provides controls for assigning a mask to protect certain areas of the frame from 
being transformed.
Card3D: This node is used to transform an image as it was printed on a flat card and 
placed in front of the camera. It gives you an additional z-axis for transformations 
that the Transform node does not provide.
AdjustBBox: This node is used to expand or crop the edges of the bounding box.
BlackOutside: This node is used to add black pixels outside an edge to the bounding 
box.
CameraShake: This node is used to add random camera shake including the motion 
blur.
Crop: This node is used to crop an image.
CornerPin: This node is used to map the four corners of an image sequence using 
the information taken from the tracking data.
SphericalTransform: This node is used to convert an environment map into another 
type of environment map from the HDR images.
IDistort: This node is used to distort an image based on UV channels.
LensDistortion: This node is used to apply or remove simple lens distortion. This 
node is only available in NukeX.
Mirror: This node is used to flip the image around the center of the format image 
area.
Position: This node is used to move the input by an integer number of pixels.
Reformat: This node is used to convert one image format (width/height) into 
another image format.
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Reconcile3D: This node is used to project a user-specified 3D point through a 
connected camera onto the screen space.
Points3D: This node is used to extract 3D coordinates of 2D points. 
PlanarTracker: This node is used to track surfaces that lie in a plane on the input 
image. It is only available in NukeX.
Tracker: This node is used to track a 2D motion with the in-built match-move 
functions.
TVIScale: This node is used to scale an image by a factor of two.
GridWarp: This node is used to transfer image information from a bezier grid to 
another bezier grid.
SplineWarp: This node is used to transform a source image from its original shape 
into a deformed image using multiple Bezier or B-spline curves.
Stabilize: This node is used to remove the unwanted camera movement in the image 
sequence.
STMap: This node is used to move pixels in an image.
Tile: This node is used to create the titled copies of the input image.

3D
This button is used to access 3D compositing nodes. The nodes under this button are 
discussed next.

Axis: This node is used to define a 3D transformation axis to the scene to which you 
can parent other objects.
Geometry (Card): This node is used to create a plane.
Geometry (Cube): This node is used to generate a 3D cube.
Geometry (Cylinder): This node is used to generate a 3D cylinder.
Geometry (DepthToPoints): This node is a gizmo that contains the DepthToPosition 
and PositionToPoints nodes. It is used to generate a 3D point cloud using a depth 
pass and 3D camera.
Geometry (ModelBuilder): This node is used to create 3D models from 2D images.
Geometry (PointCloudGenerator): This node is used to analyze an input image 
sequence and generate a point cloud using the CameraTracker node. This node is 
only available in NukeX.
Geometry (PositionToPoints): This node is used to generate a 3D point cloud from 
an input image, such as a position pass.
Geometry (PoissonMesh): This node is used to generate a mesh using a dense point 
cloud. This node is only available in NukeX.
Geometry (Sphere): This node is used to generate a 3D sphere.
Geometry (ReadGeo): This node is used to import a geometry.
Geometry (WriteGeo): This node is used to write the geometry to an external file.
Lights (Light): This node is used to create light and it has three light types: point, 
directional, and spot.
Lights (Point): This node is used to create a point light that emits light in all 
directions.
Lights (Direct): This node is used to emit light in one direction.
Lights (Spot): This node is a point in 3D space that emits a cone-shaped light in a 
given direction.
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Lights (Environment ): This node is used to produce light from the HDR image.
Lights (Relight ): This node is used to relight an image using the 3D lights if the 
image contains the normal and point position passes.
Modify (TransformGeo): This node is used to transform the input image in 3D 
space.
Modify (MergeGeo): This node is used to merge all input geometries into one 
geometry.
Modify (CrosstalkGeo): This node is used to offer direct global control over each of 
the vertices on geometry using the crosstalk curves.
Modify (DisplaceGeo): This node is used to modify the shape of  the geometry based 
on an image.
Modify (GeoSelect): This node is used to select individual vertices on a 3D object.
Modify (LookupGeo): This node is used to modify the shape of the 3D geometry 
using the lookup curves.
Modify (LogGeo): This node moves the XYZ position of the points by raising a value 
to a power.
Modify (Normals): This node is used to adjust the normals of the object.
Modify (ProceduralNoise): This node is used to modify objects using Perlin noise.
Modify (RadialDistort): This node is used to warp the points to create a pin-cushion 
like distortion.
Modify (Triliniear): This node warps points by using the trilinear interpolation 
lattice.
Modify (UVProject): This node is used to specify the UV coordinates for an object.
Modify (RenderMan-ModifyRIB): This node is used to insert RIB statements into 
the script.
Shader (ApplyMaterial): This node is used to apply a material/shader to a geometry 
by using the mat input.
Shader (BasicMaterial): This node is used to apply the basic emissive, diffuse, and 
specular materials to the geometry.
Shader (Displacement): This node is used to apply displacement mapping. It adds 
geometrical details to the surface of an object.
Shader (FillMat): This node is used to add a constant color into the selected 
material channels.
Shader (MergeMat): This node is used to combine the multiple project 3D shaders.
Shader (BlendMat): This node is used to blend the pixels colored by the material 
with the background pixels.
Shader (Project3D): This node is used to project an input image through camera 
onto the 3D object. 
Shader (Diffuse): This node is used to shade an image using the diffuse lambertian 
lighting calculations.
Shader (Emission): This node is used to simulate emissive lighting such as light 
emitting from a lamp.
Shader (Phong): This node is used to create accurate shading and highlights using 
the phong shading algorithm.
Shader (Specular): This node is used to apply specular lighting to a selected color 
layer.
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Shader (Displacement): This node is similar to the DisplaceGeo node but it only 
displaces those parts of the geometry which are visible at any given moment, thus 
saving the render time.
Shader (UVTile): This node is used to modify the coordinates of a UV patch while 
projecting textures onto an object.
Shader (RenderMan - Reflection): This node is used to apply reflection to a 
surface.
Shader (RenderMan - Refraction): This node is used to apply refraction to a 
surface.
Camera: This node is used to define a projection to be used by a 3D renderer. It adds 
a camera to the scene.
CameraTracker: This node is used to create a virtual camera whose movement is 
same as that of the original camera.
DepthGenerator: This node is used to generate a depth map from the input 
image.
DepthToPosition: This node is used to create a position pass from a depth map and 
3D camera.
ProjectionSolver: This node is used to solve a camera for a set of known 3D points. This 
node is only available in NukeX.
Scene: This node is used to group more than one piece of geometry, lights, and camera.
ScanlineRender: This node is used to render a scene.
RenderMan (PrmanRender): This node works with Pixar’s RenderMan to generate 
quality output. This node is only available in NukeX.

Particles
This button is used to access the particles nodes. The nodes under this button are 
discussed next.

ParticleEmitter: This node is used to emit particles.
ParticleBounce: This node is used to make 3D particles bounce off a 3D shape.
ParticleCurve: This node is used to apply a curve to particle controls such as size or 
mass.
ParticleDirectionalForce: This node is used to apply a directional force to the 
particles.
ParticleDrag: This node is used to apply drag to the particles to change their speed 
gradually.
ParticleExpression: This node is used to adjust the properties of the particles using 
expressions.
ParticleMerge: This node is used to merge multiple particle sets into one stream.
ParticleMotionAlign: This node is used to align a particle stream to the direction of 
their motion.
ParticleGravity: This node is used to apply gravity to the particles.
ParticleLookAt: This node is used to create a 3D point on which all particles look at 
the specified range.
ParticlePointForce: This node is used to attract or repel the particles to form a point 
in 3D space.
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ParticleSpeedLimit: This node is used to restrict particles to a specified minimum 
and maximum speed.
ParticleSpawn: This node is used to emit particles from other particles.
ParticleTurbulence: This node is used to apply noise to the particle movement, thus 
dispersing the particles in 3D space.
ParticleVortex: This node is used to apply a circular force to the particles to attract 
them to an imaginary line.
ParticleWind: This node is used to apply a wind force to the particles.
ParticleSettings: This node is used to control the number of calculation steps taking 
place per animation frame.
ParticleToGeo: This node is used to create a 3D geometry for particles in the specified 
channels.

Deep
This button is used to access the deep pixels nodes. The nodes under this button 
are discussed next.

DeepColorCorrect: This node is used to color correct the deep images.
DeepCrop: This node is used as a regular Crop node to crop the deep images inside 
or outside the crop box. Also, it can be used to crop the deep data in front of or behind 
certain planes in depth.
DeepExpression: This node is used to apply TCL expressions to the deep data.
DeepFromFrames: This node is used to copy multiple frames from the input 2D 
image to sample a single deep frame.
DeepFromImage: This node is used to convert a standard image to a deep image.
DeepHoldout: This node is used to remove or fade out samples in the main input 
that are occluded by samples in the holdout input.
DeepMerge: This node is used to merge samples from multiple deep images.
DeepRead: This node is used to load deep images from the disk.
DeepRecolor: This node is used to merge the color input and the depth input.
DeepReformat: This node is similar to the Reformat node for deep images.
DeepSample: This node is used to pick samples from the deep image.
DeepToImage: This node is used to flatten a deep image.
DeepToPoints: This node is used to transform the deep pixel samples into points in 
3D space, so that a point cloud is formed.
DeepTransform: This node is used to reposition the deep data.
DeepWrite: This node is used to write deep data to files.

Views
This button is used to access the views and stereoscopic view nodes. The nodes under 
this button are discussed next.
 
Stereo (Anaglyph): This node is used to make an anaglyph image out of inputs.
Stereo (MixViews): This node is used to mix two views together.
Stereo (SideBySide): This node is used to put the left and right views of the input 
next to each other.
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Stereo (ReConverge): This node is used to shift convergence so that any selected 
point appears at screen depth when viewed with 3D glasses.
JoinViews: This node is used to join the left and right views to make stereo output.
OneView: This node is used to take one view from input for processing.
ShuffleViews: This node is used to swap the left and right views in the script.
Split and Join: This node can be used to split the view to apply processing to one 
view only. You can join them together later on.

MetaData
This button is used to access the metadata management nodes. The nodes under this 
button are discussed next.

ViewMetaData: This node is used to view the metadata of input.
CompareMetaData: This node is used to compare the metadata of two inputs.
ModifyMetaData: This node is used to alter the metadata being passed through the 
tree.
CopyMetaData: This node is used to copy metadata from one image to another.
AddTimeCode: This node is used to add a timecode to metadata.

ToolSets
This button is used to access the toolset management nodes. The nodes under this 
button are discussed next.

Create: This node is used to add a toolset to the toolbar.
Particle: This node is used to access various toolsets such as P_DustHit, P_FogBox, 
P_RainBox, P_SnowBox, P_Sparks, P_Streaky, P_Trail, P_VolumetricLight, and 
P_Waveform to create various particle effects.
Delete: This node is used to delete the toolset created earlier.

Other
This button is used to access the script and viewer management nodes. The nodes 
under this button are discussed next.

	 Assert: This node is used to test the validity of a user-specified TCL expression.
AudioRead: This node is used to import the audio file and view it in the Curve Editor 
panel. Then, you can line the audio file with your composition.
Backdrop: This node is used to visually group nodes in the Node Graph panel.
DiskCache: This node is used to cache the data stream to hard drive.
Dot: This node is used to make bends. The input data passed through this node 
remains unchanged.
Input: This node is used to add an input arrow to a group.
Output: This node is used to add an output arrow to a group.
NoOp: This node is used to pass data stream unchanged through itself.
PostageStamp: This node displays a very small thumbnail of the image in the Node 
Graph panel.
Group: This node is a nesting container for a group of nodes.
Precomp: This node is used to read a precomp script.
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StickyNote: This node is used to add a sticky note to the Node Graph panel.
All plugins: This option is used to display a menu that lists all nodes and plugins 
including unsupported nodes, if any.

FurnaceCore
This button is used to access the Furnace plugin nodes. The nodes under this button 
are discussed next.
F_Align: This node is used to calculate the positions of 4 corner pins so that each frame 
in one shot is aligned with the corresponding frame in a second reference shot.
F_DeFlicker2: This node is used to remove flicker from an image.
F_MatchGrade: This node is used to analyze two clips and it attempts to make their 
color range look the same.
F_ReGrain: This node is used to add grain to a sequence.
F_RigRemoval: This node is used to remove foreground elements from an image 
sequence.
F_Steadiness: This node is used to calculate a four-corner pin using Global Motion 
Estimation (GME) on a clip so that all the frames in a clip are locked to a single 
frame.
F_WireRemoval: This node is used to digitally remove wire from a clip.

MANAGING PROJECT FILES 
NukeX is a production-proven node based compositing software. A NukeX project consists 
of a network of operators called nodes. These nodes are connected together to read, process, 
and manipulate images and then generate the final output. NukeX project files are called 
scripts. In this section, you will learn about opening, saving, and closing the scripts. Also, you 
will learn about various project settings that need to be done in a script. 

To understand the concepts explained in this chapter, you need to download c01_nuke_7_prt.zip 
file from www.cadcim.com, as the concepts have been explained using the files contained in 
this zipped file. The path of the file is as follows: Textbooks > Animation and Visual Effects > 
NukeX > The Foundry NukeX 7 for Compositors. Now, navigate to the Documents folder and create 
a new folder with the name Nuke_Projects. Extract the contents of the downloaded zip file to 
\Documents\Nuke_Projects.

Note 
1. Every tutorial zip file that you download from the CADCIM website contains the folder 
Media_Files. This folder contains all media files related to the chapter. 

2. Make sure that the QuickTime is installed on your system.

Opening Scripts
The default extension of a NukeX script file is .nk. To open a NukeX script, follow the steps 
given below:

1.	 Choose File > Open from the menu bar; the Script to open dialog box is displayed, as 
shown in Figure 1-8.
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Figure 1-8  The Script to open dialog box

2.	 Choose Home from the Navigation Controls section of the dialog box, refer to 
Figure 1-9. In the Directory List section, choose Documents > Nuke_Projects > 
c01_prt > c01_prt_01.nk. Next, choose the Open button; the selected NukeX script is 
displayed in the NukeX window.

Note 
Now onwards, the path to the Nuke_Projects folder will be referred to as Home > Documents > 
Nuke_Projects throughout this textbook.

Saving Scripts
To save the changes made in the script, choose File > Save from the menu bar. To save and 
upgrade to the next version, choose File > Save New Version from the menu bar. The autosave 
feature of NukeX is used to make automatic backup of the scripts. The autosave and Save 
New Version options are discussed next.

Autosaving a Script
The autosave feature is a very useful option for recovering script files in case the system 
crashes. The default extension of an autosave script is .autosave. To set the autosave options, 
choose Edit > Preferences from the menu bar; the Preferences dialog box will be displayed, 
as shown in Figure 1-10. By default, the autosave filename field is set to [firstof [value root.
name] [getenv NUKE_TEMP_DIR]/].autosave. As a result, the autosave files are saved in the 
same folder as the script files. If you enter 300 in the force autosave after field, the script is 
forced autosaved after 5 minutes.

The autosave after idle for field is used to specify the time after which the script will be 
autosaved, if the mouse is not moved or a key is not pressed. The default value of this field 
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is 5 seconds. The force autosave after field is used to specify the time after which the script 
will be force autosaved. 

Figure 1-9   The Navigation Controls and Directory List sections in the  
Script to open dialog box

Figure 1-10  Partial view of the Preferences dialog box

Choose the Save Prefs button to save the preferences and then the Close (x) button to close 
the Preferences dialog box.
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Note
1. The autosave function references the script file to create the backup. Therefore, you must save 
the script file first.

2. If you exit NukeX without saving the changes made in the script and a backup file is 
available for that script, the Restore autosave file message box will be displayed on reopening 
the script next time, refer to Figure 1-11. 

Figure 1-11  The Restore autosave file message box

Tip: To turn off the automatic backup, set the autosave after idle for and force autosave 
after fields to zero.

Saving New Version
You can also save different versions of your script by using the Save New Version option. To 
save the first version, save the script with the name name_of_script_v1.nk by choosing File > 
Save As from the menu bar. To save the next updated version of the script, choose File > 
Save New Version from the menu bar or press ALT+SHIFT+S. On doing so, the script will 
be saved with the name name_of_script_v2.nk. If you press ALT+SHIFT+S again, the file will 
be saved with the name name_of_script_v3.nk.

Tip: 1. If you are not sure about the path of the script you are working on, press Q; the 
Current Info message box will be displayed with the path and the name of the script 
displayed in it.

2. If you are not sure about the function of a shortcut key, choose Help > Key Assignments 
from the menu bar; the Nuke key assignments message box will be displayed. From this 
message box, you can check all commands and shortcuts associated with them.

Closing a Script
To close a NukeX script, choose File > Close from the menu bar; a message box will be 
displayed prompting you to save the unsaved changes, if any. In the message box, choose the 
Yes button to save the changes made; the No button to discard the changes; and the Cancel 
button to exit it. NukeX is relaunched, if you choose the Yes or No button from the message 
box.

Note
Choosing File > Close from the menu bar or pressing CTRL+W is a quick way to clear the 
memory used by the NukeX script. This command reloads the init.py and menu.py files which 
are used to configure NukeX.
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SPECIFYING PROJECT SETTINGS
Before you start working on a new script, you need to specify the project settings. To specify 
the project settings, you need to follow the steps given below:

1.	 Choose File > Open from the menu bar; the Script to open dialog box will be displayed. 
Next, choose Home > Documents > Nuke_Projects > c01_prt > c01_prt_01.nk from 
the dialog box. Choose the Open button from the Script to open dialog box.

2.	 Choose Edit > Project Settings from the menu bar or place the cursor over the Node 
Graph/Curve Editor/Dope Sheet pane and press S; the Project Settings properties panel 
will be displayed with the Root tab chosen, as shown in Figure 1-12.

Figure  1-12   Partial view of the Project Settings properties panel

Tip: If the mouse pointer is on the Viewer pane and you press S, the Viewer# properties 
panel will be displayed instead of the Project Settings panel. 

3.	 In the Root tab, the name of the script file is already displayed in the name field. Click on 
the folder icon located on the right of the project directory field; the root:Select file(s) 
dialog box will be displayed, as shown in Figure 1-13. In this dialog box, choose Home > 
Documents > Nuke_Projects > c01_prt  and  then choose the Open button to define 
the selected directory as the project directory, refer to Figure 1-13.
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Figure 1-13   The root: Select file(s) dialog box

4.	 To set the duration of the project, enter the required values in the two fields corresponding 
to the frame range parameter in the Project Settings properties panel.

	 The resolution of the footage used in this script is 1280 x 720 pixels (HD format). Therefore, 
24 is displayed in the fps field, as it is the default frame rate for the HD format.

5.	 Select the 1280x720 option from the full size format drop-down, as shown in Figure 1-14. 
Next, choose File > Save from the menu bar to save the script. 

Figure 1-14  Partial view of the full size format drop-down

	 The options in the full size format drop-down are used to set the format of the project. 
By default, the 2K_Super_35(full-ap) 2048x1556 option is selected in this drop-down.

LOADING IMAGE SEQUENCES
To start compositing, you need to import still images or image sequences for the background 
and foreground elements. To import an image sequence, follow the steps given next:

1.	 Choose File > New from the menu bar; a new blank script file will be displayed in the 
NukeX interface.
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2.	 Choose the Image button from the Nodes toolbar; the Image 
menu will be displayed. Next, choose Read from the menu, refer to 
Figure 1-15; the Read File(s) dialog box will be displayed, as shown 
in Figure 1-16. 

3.	 In this dialog box, choose Home from the Navigation Controls section of 
the dialog box. Next, choose Documents > Nuke_Projects > c01_prt > 
Media_Files > 100_4172.MOV from Directory List section and then 
choose the Open button; the Read1 node will be inserted in the Node 
Graph panel, as shown in Figure 1-17.

4.	 Select the Read1 node in the Node Graph panel and then press 1; the 
selected footage will now be displayed in the Viewer1 panel, as shown 
in Figure 1-18. You will notice that the Read1 node is connected to 
the Viewer1 node in the Node Graph panel, refer to Figure 1-19.

Figure 1-16  The Read File(s) dialog box

Figure 1-17   The Read1 node inserted in the Node Graph panel

Figure 1-15  The 
Image menu
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Figure 1-18   The footage displayed in the Viewer1 panel

Figure 1-19   The Read1 node connected to the Viewer1 node

Note
1. To open multiple files at a time, select the desired files using the CTRL key and then choose 
the Open button from the Read File(s) dialog box.

2. By default, NukeX adds alpha channel to an image sequence, if the sequence has RGB 
channels but no alpha channel.

3. NukeX converts the native colorspace format of an input image into linear colorspace which 
is the native colorspace format of NukeX. However, you can select the required colorspace from 
the colorspace drop-down of the Read node properties panel.

5.	 Select the Read1 node in the Node Graph panel and press DEL to delete it from the 
Node Graph panel.

	 Next, you will import a TIFF sequence into the script.

6.	 Open the Windows Explorer and browse to \Documents\Nuke_Projects\c01_prt\Media_Files\
Cube_Occlusion; the image sequence will be displayed in the Windows Explorer, as shown 
in Figure 1-20. You will notice that in the Window Explorer, TIFF files from 1 to 89 are 
displayed.



Exploring NukeX 7 Interface		         1-27

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 1-20  The image sequence displayed in the Windows Explorer

7.	 Insert a Read node to the Node Graph panel, as described in Step 2. In the Read file(s) 
dialog box, choose Home > Documents > Nuke_Projects > c01_prt > Media_Files > 
Cube_Occlusion. 

	 You will notice that the sequences check box is selected at the bottom left corner of 
the dialog box. As a result, NukeX gathers the images and displays them as a group, 
cubeOcclusion.#.tif 1-89, as shown in Figure 1-21. 

Figure 1-21   The gathered sequence displayed in the Read File(s) dialog box

8.	 Select cubeOcclusion.#.tif 1-89 in the Directory List section of the dialog box and then choose 
the Open button to import the sequence. Notice in the Read1 node properties panel, the 
default frame range 1-89 will be displayed, refer to Figure 1-22.
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Figure 1-22   The Read1 node properties panel displaying the frame range

Note
1. You will notice a symbol # in the name of the gathered sequence. It is called as frame number 
variable. It indicates that number is in 1-digit increment format. For a 4-digit increment format, 
such as cubeOcclusion0001.tif, the frame number variable would be ####. 

2. To load a single image from the Windows Explorer, drag and drop the image into the Node 
Graph panel, refer to Figure 1-23. To import an image sequence, drag and drop the folder that 
contains the image sequence into the Node Graph panel, refer to Figure 1-24.

Figure 1-23  Dragging an image from the Windows Explorer

WORKING WITH PROXIES
The Proxy modes are used for the proxy scaling of a footage to speed up the rendering process 
and the display calculations. You can specify global proxy settings in the Project Settings 
panel. You can also enable the proxy mode for an individual image sequence by using the 
Read node. To set up proxy formats, you need to follow the steps given next:
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Figure 1-24  Dragging a folder from the Windows Explorer

1.	 Choose File > Open from the menu bar; the Script to open dialog box will be 
displayed. Next, choose Home from the Navigational Controls section of the dialog 
box. In the Directory List section, choose Documents > Nuke_Projects > c01_prt > 
c01_prt_01.nk. Next, choose the Open button; the selected NukeX script will be displayed 
in the NukeX window.

2.	 Choose Edit > Project Settings from the menu bar; the Project Settings panel will be 
displayed in the Properties Bin with the Root tab chosen. Select the proxy mode check 
box in this panel. 

3.	 Select 1280x720 from the full size format drop-down.

4.	 Select format from the proxy mode drop-down.

5.	 Select new from the proxy format drop-down; the New format dialog box will be displayed. 
Type HDNew in the name field. Set the values 640 and 360 in the file size w (width) and 
file size h (height) fields, respectively, refer to Figure 1-25. Next, choose the OK button; 
a new format will be created.

	 You will notice in the Viewer1 panel that HDNew is displayed as the new format. Also, 
the toggle proxy mode button is activated, as shown in Figure 1-26.

Tip: Press CTRL+P on your keyboard to toggle proxy mode.

6.	 Select scale from the proxy mode drop-down; the proxy scale field will be displayed. 
Next, set the value of the proxy scale field to specify the factor by which you want to scale 
the dimensions of the images.
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Figure 1-25  The New Format dialog box

Figure 1-26  The toggle proxy mode button activated

Proxy Settings in the Read Node
Proxies can be specified in the Read node properties panel by using the proxy field. To set 
the proxy options in the Read node, you need to follow the steps given next:

1.	 Choose File > New from the menu bar to create a new script. Next, choose the Image 
button on the Nodes toolbar; the Image menu will be displayed. Choose Read from the 
menu or press R; the Read File(s) dialog box will be displayed. In this dialog box, choose 



Exploring NukeX 7 Interface		         1-31

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Home > Documents > Nuke_Projects > c01_prt > Media_Files > 100_4172.MOV and 
then choose the Open  button; the Read1 node is inserted in the Node Graph panel.

2.	 Select the Read1 node in the Node Graph panel and press 1 to connect the Read1 node 
to the Viewer1 node; the output of the Read1 node will be displayed in the Viewer1 
panel. 

3.	 In the Read1 node properties panel, click on the folder icon located on the right of 
the proxy field; the Read1: Select file(s) dialog box will be displayed. In this dialog 
box, choose Home > Documents > Nuke_Projects > c01_prt  > Media_Files > 
100_4172_PROXY.mov and then choose the Open button; NukeX will use the proxy file 
to speed up the rendering process and display calculations. 

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following combination of shortcut keys is used to cycle though the tabs in a 
pane?

		  (a) CTRL+T				    (b) CTRL+S
		  (c) ALT+P				    (d) CTRL+P

2.	 Which of the following combination of shortcut keys is used to invoke the Preferences 
dialog box?

		  (a) SHIFT+P				    (b) SHIFT+S
		  (c) SHIFT+J				    (d) CTRL+S

3.	 NukeX is a __________ based compositing software application.

4.	 The Read node is used to _________ image sequences into a script.

5.	 In NukeX, you can save and restore up to __________ layouts.

6.	 The saved project files in NukeX are called __________ files.

7.	 The __________ shortcut key is used to insert the Read node in the Node Graph panel.

8.	 The W shortcut key is used to insert the Write node in the Node Graph panel. (T/F)

9.	 By default, NukeX adds alpha channel to an image. (T/F)

10.	 NukeX converts all imported sequences to its native linear colorspace. (T/F)
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 Review Questions 
Answer the following questions:

1.	 Which of the following shortcut keys is used to open the Project Setting panel?

		  (a) J					     (b) S
		  (c) L					     (d) P

2.	 Which of the following combination of shortcut keys is used to toggle the proxy mode?

		  (a) CTRL+P				    (b) CTRL+S
		  (c) CTRL+K				    (d) CTRL+M

3.	 Which of the following combination of shortcut keys is used to save and upgrade to the 
next version of the script?

		  (a) ALT+SHIFT+S			   (b) ALT+SHIFT+J
		  (c) ALT+SHIFT+U			   (d) ALT+SHIFT+K

4. 	 The Grain node is used to add __________ grain to a footage.
				  
5.	 __________ are used to speed up rendering and display calculations.		
	
6.	 The __________ and __________ files are used to configure NukeX.

7.	 The __________ node is used to make precision adjustments to the levels of saturation in 
a range of hues.

8.	 The Node Graph is also known as __________. 

9.	 The __________ panel is used to build a network of nodes.

10.	 The __________ option from the Content menu is used to split a pane horizontally.

11. 	You need to press and hold CTRL and then click on a node tile to display its properties 
panel in a floating window. (T/F)

12.	 You can load image sequences into NukeX by using the Windows Explorer. (T/F)

Answers to Self-Evaluation Test
1. a, 2. b, 3. node, 4. load, 5. six, 6. script, 7. R, 8. T, 9. T, 10. T


