
Chapter 2

Exploring
Viewer Nodes 

 Learning Objectives 
After completing this chapter, you will be able to:
• Work with the Viewer panel
• Navigate in the Viewer panel
• Add a Viewer node to the Node Graph panel
• Connect a process node to a Viewer node
• Display multiple channels in the Viewer panel
• Work with timeline controls
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INTRODUCTION
In this chapter, you will learn about the Viewer nodes. The Viewer nodes are used to display 
the output of the process nodes as well as to generate the display data stream. Unlike the 
process nodes, these nodes do not alter the input data stream. You can place as many nodes 
as you want in the NukeX script. Also, you can use multiple Viewer nodes to view the output 
of different process nodes. You can connect up to ten process nodes to a single Viewer node. 
This feature can be used to generate the output before and after data processing and then 
compare and analyze them.

In this chapter, you need  to download the c02_nuke_7_prt.zip file from www.cadcim.com as the 
concepts have been explained using the files contained in it. The path of the zip file is as 
follows: Textbooks > Animation and Visual Effects > NukeX > The Foundry NukeX 7 for Compositors. 
Next, you need to extract the contents of the zipped file to \Documents\Nuke_Projects.

ADDING AND CONNECTING VIEWER NODES
You can add a Viewer node to the Node Graph panel by using any one of the following two 
methods:

1.	 Choose File > New from the menu bar; a new script will be 
displayed in the NukeX interface. By default, the Viewer1 
node will be displayed in the Node Graph panel. Select the 
Viewer1 node in the Node Graph panel and then press 
DEL to remove this node. Next, choose Viewer > Create 
New Viewer from the menu bar or press CTRL+I; the 
Viewer1 node will be inserted in the Node Graph panel. 

2.	 Choose the Image button from the Nodes toolbar; the 
Image menu will be displayed. Next, choose Viewer from 
the menu, refer to Figure 2-1; the Viewer2 node will be 
inserted in the Node Graph panel. 

	 Once the Viewer node has been added to the Node Graph 
panel, you can quickly connect up to ten process nodes 
to different ports available on this node. To do so, you need to follow the steps given 
below:

1.	 Choose File > Open from the menu bar; the Script to open dialog box will be displayed. 
Now, choose Home > Documents > Nuke_Projects > c02_prt >  c02_prt_01.nk from 
the dialog box. Next, choose the Open button; the script file will be displayed in the 
NukeX window with the Grain2_1 node connected to the Viewer1 node. 

2.	 Select the Blur1 node in the Node Graph panel and then press 2; the Blur1 node will be 
connected to the port number 2 of the Viewer1 node, as shown in Figure 2-2.

3.	 To connect the Grade1 node to the Viewer1 node, select the Grade1 node in the Node 
Graph panel and then press 3. Similarly, to connect the Read1 node to the Viewer1 node, 
press 4, refer to Figure 2-3.

Figure 2-1  The Image menu
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Figure 2-2  The Blur1 node connected to 
the port number 2 of the Viewer1 node

Figure 2-3  All four nodes connected 
to the Viewer1 node

	 To cycle through the views, place the cursor on the Viewer panel. Next, press the UP or 
DOWN arrow to quickly cycle through the views. Alternatively, you can press the numbers 
(0, 1-9) corresponding to the port number of the Viewer# node to cycle through the 
viewers. 

Note
To connect a process node to the 10th port of the Viewer# node, press 0.

NAVIGATING IN THE VIEWER PANEL
In this section, you will learn about the navigational controls used in NukeX. You can navigate 
in the Viewer panel in the following ways: 

1.	 Press and hold the middle mouse button and then drag the cursor over the Viewer panel 
to pan the frame. Alternatively, press and hold ALT and drag the cursor over the Viewer 
panel.

2.	 Press the middle mouse button or press F to recenter the frame in the Viewer panel.

3.	 Place the cursor over that area of the frame which you want to zoom in and then press 
+ (PLUS) to increase the zoom level. You can keep on pressing this symbol until the 
desired zoom level is achieved. Alternatively, select the desired zoom level from the Zoom 
drop-down located at the top right corner of the Viewer panel, refer to Figure 2-4. 

4.	 Place the cursor over that area of the frame which you want to zoom out, and then press  
- (MINUS) to decrease the zoom level. You can keep on pressing this symbol until the 
desired zoom level is achieved. Alternatively, choose the desired scale factor from the Zoom 
drop-down located at the top right corner of the Viewer panel, as shown in Figure 2-4.
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5.	 Press CTRL+1 to restore the zoom factor to full resolution.

6. 	 Press H to fill the Viewer panel with a frame.

7.	 Press accent (`) to toggle the visibility of the floating Viewer 
panel.

Tip: You can also zoom in or zoom out the Viewer panel by pressing and holding 
ALT+MMB and then dragging the cursor to the right or left.

WORKING WITH VIEWER CONTROLS
The Viewer controls are used to navigate in the timeline, select channels, adjust the zoom scale 
factor, toggle proxy mode, adjust gamma and gain of the display, choose camera, create wipes, 
and set the Viewer process methods. Some of the Viewer controls are discussed next.

Channel Sets, Channel List, and Channel Display Style
The options in the Channel Sets drop-down are used to define a set of color channels to 
be displayed in the Viewer panel. By default, rgba is selected in this drop-down, refer to 
Figure 2-5. The options in the Channel List drop-down are used to define the channel that 
will be displayed when the A key is pressed. By default, NukeX displays the alpha channel 
(rgba.alpha) when the A key is pressed. However, you can select any of the available channels 
from the Channel List drop-down. The options in the Channel Display Style drop-down, 
located next to the Channel List drop-down, are used to set the style of the selected channel 
of the node. 

Figure 2-5  The Channel Sets, Channel List, and Channel Display Style 
drop-downs

Figure 2-4  Partial view 
of the Zoom drop-down
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The alpha channel can be displayed as the red overlay at the top of the RGB channels. To do 
so, you need to follow the steps given below:

1.	 Choose File > Open from the menu bar; the Script to open dialog box will be displayed. 
Next, choose Home > Documents > Nuke_Projects > c02_prt > c02_prt_02.nk and 
then choose the Open button; the script file will be displayed in the NukeX window.

2.	 Select Matte overlay from the Channel Display Style drop-down. Alternatively, hover the 
cursor over the Viewer1 panel and then press M; the alpha channel will be displayed as 
a red overlay on the top of the RGB channels, as shown in Figure 2-6.

By default, RGB is selected in the Channel Display Style drop-down. You can select the R, G, B 
or A option from this drop-down to display the red, green, blue, or alpha channel, respectively. 
To display a single channel, click on the Channel Display Style drop-down and select channels to 
be displayed. Alternatively, you can hover the cursor on the Viewer panel and then press R, G, 
B, or A to display the red, green, blue, or alpha channels, respectively in the Viewer panel. 

Figure 2-6  The original RGB channels (left) and red overlay 
(right) on the top of the RGB channels

To display multiple channels from different inputs of the Viewer panel, follow the steps given 
below:

1.	 Choose File > Open from the menu bar; the Script to open dialog box will be displayed. 
Choose Home > Documents > Nuke_Projects > c02_prt > c02_prt_03.nk from the 
dialog box and then choose the Open button; the script file will be displayed in the NukeX 
window.

2.	 Select the Grain2_1 node from the Node Graph panel and then press 1; the Grain2_1 node 
will be connected to port number 1 of the Viewer1 node and its output will be displayed 
in the Viewer1 panel. Next, press and hold SHIFT and select R from the Channel Display 
Style drop-down, refer to Figure 2-7; the Viewer1 panel will display the red channel. 

3.	 Select the Blur1 node in the Node Graph panel and then press 2; the Blur1 node will 
be connected to the port number 2 of the Viewer1 node and its output will be displayed 
in the Viewer1 panel. Next, press SHIFT and select B from the Channels Display Style 
drop-down, refer to Figure 2-7; the Viewer1 panel will display the blue channel.
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Figure 2-7  Selecting R (red) and B (blue) channels from the Channel Display Style 
drop-down

4.	 Now, to toggle between the Viewer1 node inputs, click in the empty area of the Node 
Graph panel and then press 1 and 2 repeatedly. You will notice that the Viewer1 panel 
displays the red and blue channels, respectively, as shown in Figures 2-8 and 2-9.

Figure 2-8  The red channel displayed in the Viewer1 panel

Figure 2-9  The blue channel displayed in the Viewer1 panel

downrez
Every Viewer panel has a downrez drop-down, refer to Figure 2-10. The options 
in the downrez drop-down are used to reduce the resolution of the Viewer panel. 
This helps in switching between various lower display resolutions for faster display 
calculations. Reducing display resolution of the Viewer panel results in faster display of high 
resolution sequences, without affecting the actual rendered output.
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To lower the display resolution of the Viewer panel, you need to follow the 
steps given next.

1.	 Choose File > Close from the menu bar to close the active script.

2.	 Choose File > Open from the menu bar; the Script to open dialog box 
will be displayed. Choose Home > Documents > Nuke_Projects > 
c02_prt > c02_prt_03.nk and then choose the Open button; the script 
file will be displayed in the NukeX window.

3.	 Select the Grain2_1 node in the Node Graph panel and press 1; the 
Grain2_1 node will be connected to port number 1 of the Viewer1 node 
and its output will be displayed in the Viewer1 panel. 

4.	 Select 8 from the downrez drop-down; the resolution of the display will change to 1/8th 
of the active resolution, refer to Figure 2-11.

Figure 2-11  The Viewer1 panel displaying image at full and 1/8th of the active resolution

gamma and gain
The gamma and gain sliders are used to adjust the gamma and gain of the displayed image in 
the Viewer panel, refer to Figure 2-12. You can alter the display data stream without affecting 
the rendered output by changing values on these sliders. Generally, these controls are used 
to fill holes in mattes. The gain toggle and gamma toggle buttons are used to switch between 
the default values of the sliders (1) and the last adjustment made. 

Figure 2-12  The gamma and gain sliders

Figure 2-13 shows an image with the gain and gamma field values set to 0.6 and 1.6, respectively. 
The Zebra-Stripe button located on the top right corner of the Viewer panel is used to apply 
stripes to all the pixels that lie beyond the 0 to 1 range, as shown in Figure 2-14.

Figure 2-10  
The downrez 
drop-down
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Figure 2-13  The image with gamma and gain values set to 0.6 and 1.6

Figure 2-14  The out of range pixels displayed as zebra stripes

Pause
The Pause button is used to stop the Viewer panel from updating each time the changes  
are made to a NukeX script. If this button is active, the Viewer panel displays the last 
rendered frame. To activate the auto updating, choose this button again. Alternatively, 
press P to toggle automatic updates on and off. The button which is located on immediate 
left of the Pause button is used to force NukeX to recalculate the image. Alternatively, 
you can press U to recalculate the image.

Timeline
Timeline controls are used to play back image sequences, set frame range, set playback speed, 
jump to a specific frame, and generate flipbook previews, refer to Figure 2-15. The timeline 
also displays the keyframes that are created during animation. The Viewer panel shows the 
frame range defined in the Project Settings panel. If no frame range is defined, NukeX sets 
the frame range of the first image sequence that it reads.
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Navigating in the Timeline
You can also pan and zoom in the timeline just as in the Viewer# panel. To do so, hold 
ALT+LMB and then drag the timeline; the option in the Timeline range drop-down will 
change to Custom, refer to Figure 2-16. To change the zoom scale of the timeline, hold 
ALT+MMB and then drag the cursor to the left or the right. Alternatively, you can use the 
mouse wheel to change the zoom scale of the timeline.

Figure 2-15  The timeline controls

Figure 2-16  The scaled timeline

Adjusting the Playback Range
You can  adjust the playback range of the Viewer panel. To do so, press CTRL and then drag 
the orange playback range markers on the timeline to define the first and last frames of the 
footage. The frame_range_lock button located on the extreme right of the timeline is used to 
toggle between the new playback range and the visible timeline range, refer to Figure 2-17.

Figure 2-17  The playback range

The fps field displays the playback speed as specified in the project settings. NukeX attempts 
to maintain this speed, however, it might vary depending on the resolution of the footage 
and hardware configuration.

Jumping to a Specific Frame
You can also jump to a specific frame. To do so, choose File > Goto Frame from the menu 
bar; the Goto Frame dialog box will be displayed. Alternatively, press ALT+G to invoke the 
Goto Frame dialog box. Next, enter the desired frame number in the Frame field and then 
choose the OK button.
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Setting the Playback Mode
You can set the playback mode by using the End of playback range behavior button located 
next to the Playback rate field, refer to Figure 2-15. It is a toggle button which is used to switch 
between the three modes: Loop, Stop, and Bounce. These modes define the behavior of the 
playback when the time marker reaches the end of the timeline. 

Loop: By default, this button is active. As a result, the sequence is looped. 

Stop: This button is used to play the sequence to the head or tail of the playback 
range.

Bounce: This button is used to play the sequence repeatedly back and forth.

Synchronizing Viewport Playback
The Lock/Unlock button is used to toggle the synchronized playback of the Viewer# 
panel. By default, all Viewer panels are locked. Therefore, if you change the current 
frame in a Viewer panel, all other Viewer panels will display the changed current frame 
number.

Creating Flipbook Previews
The Flipbook this viewer button is used to generate the flipbook preview of the selected  
time range. On choosing this button; the Flipbook dialog box will be displayed, as 
shown in Figure 2-18. Next, specify the values as required in this dialog box and then choose 
the OK button; the Progress dialog box will be displayed, refer to Figure 2-19. This dialog 
box will disappear once the progress percentage reaches 100 and then the FrameCycler 
window will be displayed, refer to Figure 2-20. Next, preview the sequence in the FrameCycler 
window.

Figure 2-18  The Flipbook dialog box
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Figure 2-19  The Progress dialog box

Figure 2-20  The FrameCycler window

Playback performance
The Playback performance button, refer to Figure 2-15, is used to stop redrawing GUI 
every frame during the Viewer playback. As a result, frames playback rate is optimized when 
playing from the RAM cache. It stops redrawing of all knobs, postage stamps, autolabels, 
Curve Editor, and Dope Sheet. On choosing this button again, NukeX updates the GUI to 
the current frame. 

You can also toggle this button by selecting the optimize Viewer during playback check box 
from the Viewer tab of the Viewer# node properties panel. You can view the Viewer# node 
properties panel by hovering the cursor over the Viewer# panel and then pressing S. You 
can make this feature default for all the Viewer panels. To do so, choose Edit > Preferences 
from the menu bar; the Preferences dialog box will be displayed. In this dialog box, select  
the optimize Viewer during playback check box from the Viewers tab.

DISPLAYING IMAGE PIXELS INFORMATION
The pixel value indicator is located at the bottom of the Viewer panel, as shown in Figure 2-21. 
It displays information about the pixel on which the cursor is placed.  You can follow the 
methods given next to sample a single pixel or a range of pixels:
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•	 Press and hold CTRL and click on the Viewer panel to sample a single pixel from the 
Viewer panel.

• 	 Press and hold CTRL+SHIFT and then drag the cursor to the Viewer panel to sample 
a region; a red rectangle will be drawn on the Viewer panel and pixels will be sampled 
within that region.

• 	 Press and hold CTRL+ALT and then click on the Viewer panel to sample a single pixel 
from the node’s input.

• 	 Press and hold CTRL+ALT+SHIFT and then drag on the Viewer panel to sample a 
region from the node’s input.

Figure 2-21  The pixel value indicator

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following combinations of shortcut keys is used to add a Viewer node to the 
Node Graph panel?

		  (a) CTRL+I				    (b) CTRL+S
		  (c) ALT+P				    (d) CTRL+K
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2.	 Which of the following shortcut keys is used to toggle viewer automatic updates on and 
off?

		  (a) P					     (b) L
		  (c) L					     (d) Y

3.	 Which of the following shortcut keys is used to toggle the visibility of the floating Viewer 
panel? 

		  (a) Accent (`)				    (b) Comma (,)
		  (c) V					     (d) CTRL+V

4.	 Which of the following drop-downs are used to define a set of color channels to be displayed 
in the Viewer panel?

		  (a) Channel List				   (b) Channel Sets
		  (c) Channel Display Style		  (d) Viewer

5.	 You can quickly cycle through the views by placing the cursor on the Viewer panel and 
then pressing the __________ or __________ arrow key.

6.	 The options in the __________ drop-down are used to select the zoom level of the Viewer# 
panel.

7.	 You can reset the timeline zoom/pan changes by clicking the middle mouse button. 
(T/F)

8.	 You can connect up to 9 process nodes to the ports of the Viewer node. (T/F)

9.	 The downrez drop-down in the Viewer controls is used to scale down the resolution of 
the Viewer# panel. (T/F)

 Review Questions 
Answer the following questions:

1.	 Which of the following shortcut keys is used to superimpose the alpha channel over the 
RGB channels?

		  (a) M					     (b) K
		  (c) G					     (d) H

2.	 Which of the following shortcut keys is used to fill the Viewer panel with a frame?

		  (a) H					     (b) L
		  (c) P					     (d) CTRL+P



2-14				                                 The Foundry NukeX 7 for Compositors
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

3.	 You can zoom in or zoom out in the Viewer# panel by pressing and holding  ALT+MMB  
and then dragging the cursor to the _________ or __________.

4.	 The options in the __________ drop-down are used to set channel to be displayed when 
the A key is pressed.

5.	 You can change the zoom scale of the timeline by pressing and holding __________ and 
the middle mouse button and then dragging the cursor to the left or the right.

6.	 You can jump to a specific frame by choosing __________ from the menu bar or by pressing 
__________.

7.	 The U key is used to recalculate the viewer display. (T/F)

Answers to Self-Evaluation Test
1. a, 2. a, 3. a, 4. b, 5. UP, DOWN, 6. downrez, 7. T, 8. F, 9. T


