
Chapter 3

Building 
Node Network

 Learning Objectives 
After completing this chapter, you will be able to:
• Add a node in the Node Graph panel
• Connect a node with other nodes
• Select, edit, replace, rename, group, and clone nodes
• Enhance the workflow using the Precomp, Backdrop, and Dot nodes
• Premultiply images using the Premult node
• Understand Properties Bin and properties panels
• Understand common node controls in the properties panels
• Use the Image nodes
• Merge images using the Merge node
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INTRODUCTION
Nodes are the building blocks of  a NukeX script. A node in NukeX is represented by a button 
like shape with its name displayed on it. NukeX has a node-based interface in which complex 
processes are built up by connecting nodes to form a tree (or flow) called process tree, refer to 
Figure 3-1. A process tree (node network) is an efficient way to manipulate images to create the 
desired effects. You can start a NukeX script by importing images by using the Read nodes, 
connecting them with other process nodes, and then finally rendering the scene to get the 
output. 

Figure 3-1  A simple process tree

In this chapter, you will learn to connect, add, select, replace, edit, clone, de-clone, group, and 
rename the nodes. Also, you will create the first composition using the Merge node.

INSERTING AND MANIPULATING NODES
You can insert a node in the Node Graph panel by using the Nodes toolbar, the TAB menu, 
the shortcut menu, or shortcut keys. All these methods are discussed next.

Inserting Nodes Using the Nodes Toolbar
To insert a node using the Nodes toolbar, choose the required category button from it and 
then choose the node from the menu displayed. Figure 3-2 shows the nodes available in the 
Image menu. The chosen node will be inserted in the Node Graph panel, refer to Figure 3-3. 
You will notice that whenever you insert a new node in the Node Graph panel, its properties 
panel will be displayed in the Properties Bin, refer to Figure 3-4.

Tip: You can insert the last chosen node from the Nodes toolbar by clicking the category 
button with the middle-mouse button.

To view the output of the inserted node in the Viewer# panel, make sure the node is selected 
in the Node Graph panel. Next, press 1; the Output connector of the selected node will be 
connected to the port 1 of the Viewer# node, refer to Figure 3-5.
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Figure 3-2  The Image 
menu displayed on choosing 
the Image button

Figure 3-3  The Constant1 node inserted 
in the Node Graph panel on choosing 
Constant from the Image menu

Figure 3-4  The Constant1 node properties panel displayed on 
inserting the Constant1 node in the Node Graph panel

Figure 3-5  The Constant1 node connected 
to the port 1 of the Viewer1 node

Inserting Nodes Using the Shortcut Menu
To insert a node using the shortcut menu, right-click on the Node Graph panel; a shortcut 
menu will be displayed. Choose the required category from it; a cascading menu will be 
displayed, refer to Figure 3-6. Choose the required node from the cascading menu to insert 
it in the Node Graph panel.
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Figure 3-6  Partial view of the Draw cascading menu

Note
If a node is selected in the Node Graph panel, then on adding a new node, it will be automatically 
connected to the selected node. Else, it will remain as a free floating node.

Inserting Nodes Using the TAB Menu
To insert a node using the TAB menu, hover the cursor over the Node Graph panel and then 
press TAB; the TAB menu will be displayed. Next, type the first few characters of the name of 
the node to be inserted in the TAB field; NukeX will display all the nodes whose names begin 
with the typed characters, refer to Figure 3-7. You can use the UP or DOWN arrow key to 
navigate through the menu. Next, select the required node in the TAB menu and then press 
ENTER; the selected node will be inserted in the Node Graph panel.

Tip: To reinsert the last node from the TAB menu, press TAB followed by ENTER.                                                            

Figure 3-7  The nodes displayed in the TAB 
menu on typing bl in the TAB menu field

Inserting Nodes Using the Shortcut Keys
To insert a node using the shortcut keys, click on the Node Graph panel to make it active and 
then press the shortcut key corresponding to the node that you need to add. The shortcut keys 
corresponding to the nodes are displayed in the category menus. These menus are displayed 
when you choose the category button from the Nodes toolbar. Figure 3-2 shows the shortcut 
keys R and W corresponding to the Read and Write nodes, respectively.
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WORKING WITH NODE CONNECTIONS
Once you add nodes to the Node Graph panel, you need to establish the connections between 
nodes to form a network. Most of the nodes have the Input, Output, and Mask connectors. 
These connectors determine the order in which the data stream is passed through the nodes. 
Figure 3-8 shows the connectors on the Blur1 node. Some nodes such as Merge has two input 
connectors: A and B. Figure 3-9 shows the connectors of a Merge node. 

Figure 3-8  Connectors on a Blur1 
node

Figure 3-9  The Merge1 node with 
two input connectors

Disconnecting Nodes
To disconnect a node, press and hold the left mouse button on the head or tail of the connecting 
arrow and then drag the cursor to an empty area of the Node Graph panel. Alternatively, you 
can select the node and then press CTRL+D.

Reconnecting Nodes
To reconnect a node, press and hold the left mouse button on the head or tail of the connecting 
arrow of the node that you want to connect. Now, drag the cursor to the center of the node to 
which you need to make the connection and then release the left mouse button; a connection 
will be established between the two nodes. Alternatively, select the node (lower in the hierarchy) 
that you want to connect and then press and hold SHIFT. Next, select the node that you need 
to connect and then press Y; a connection will be established between the two nodes.

Extracting Nodes
To extract a node, select the node that you need to extract from the node network and then 
choose Edit > Extract from the menu bar; the selected node will be extracted from the node 
network and will be placed as a free floating node in the Node Graph panel. Alternatively, 
you can press CTRL+SHIFT+X to extract the node. Figure 3-10 shows the Grade2 node 
extracted from the node network.
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Swapping Inputs of Nodes
Some nodes like Merge have two inputs: A and B. To swap the A input with the B input, make 
sure that the Merge node is selected in the Node Graph panel and then choose Edit > Node > 
Swap A - B from the menu bar. Alternatively, you can press SHIFT+X to swap the inputs. 
Figures 3-11 and 3-12 show the default and swapped inputs, respectively.

Figure 3-10  The extracted Grade2 
node

Figure 3-11  The default A and B inputs

Starting a New Branch from a Node
To create a new branch from a node, select the node from which you want to create a new 
branch. Next, press and hold SHIFT and then add a new node using the Nodes toolbar, TAB 
menu, shortcut menu, or the shortcut key. Figure 3-13 shows two branches originating from 
the Blur3 node.

Figure 3-12  The swapped inputs Figure 3-13  The branches originating 
from the Blur3 node

Duplicating the Connecting Arrow
To duplicate the connecting arrow, press and hold SHIFT and then drag the head of the 
output connecting arrow; a duplicate connection pipe will be displayed. Next, drop the pipe 
onto the node that you want to connect. This will duplicate the connecting arrow without 
affecting the original connection. Figure 3-14 shows a duplicate output arrow connected to 
the Grade2 node from the Blur2 node.
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Figure 3-14  Duplicating a connecting arrow

SELECTING NODES
When you select nodes in the Node Graph panel, the 
selected nodes are displayed in a light yellow color. Various 
methods of selecting the nodes are discussed next.

To select a single node, click on the node once. To select 
multiple nodes, press and hold SHIFT and then click 
on each node that you need to select. Alternatively, you 
can draw a marquee selection around the nodes to be 
selected. All the nodes that lie within the marquee will 
be selected, as shown in Figure 3-15. To invert a selection, choose Edit > Invert Selection 
from the menu bar.

To select all upstream nodes, press and hold CTRL while dragging a node; all upstream nodes 
that feed data to the dragged node will be selected, refer to Figure 3-16. Next, click once in 
the empty workspace to clear the selection.

Figure 3-16  All upstream nodes selected on dragging the ColorCorrect1 node with CTRL 
held down

To select all downstream and upstream nodes connected to a node, click once on the node 
and then choose Edit > Select Connected Nodes from the menu bar. Alternatively, you can 
press CTRL+ALT+A to select all nodes connected to the selected node, refer to Figure 3-17. 
To select all nodes, choose Edit > Select All from the menu bar. Alternatively, press CTRL+A 
to select all nodes in a script.

Tip: Press and hold CTRL+SHIFT and then click to select one or more nodes without 
clearing the selection made earlier. 

To select a node by its name, choose Edit > Search from the menu bar; the Nuke dialog box 
will be displayed, as shown in Figure 3-18. Type the name of the node in the search field and 

Figure 3-15 Selecting the nodes by 
drawing a marquee selection



3-8				                                 The Foundry NukeX 7 for Compositors
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

then choose the OK button; the node will be selected in the Node Graph panel. Also, the 
selected node will be centered in the visible workspace area. You can also use wild cards to 
select nodes by the name. You can use asterisks for multiple alphanumeric search strings and 
question marks for representing a single character search. 

Figure 3-17  All upstream and downstream nodes connected to the Blur5 
node selected in the Node Graph panel

Figure 3-18  The Nuke dialog 
box

You can also select nodes based on their color, class, and label. For example, to select nodes 
based on the color, select a node and then choose Edit > Select Similar > Color from the 
menu bar; all nodes having the same color will be selected in the Node Graph panel.

REPLACING NODES
To replace a node, select the node in the Node Graph panel that you need to replace. Next, 
press and hold CTRL and create new node using the Nodes toolbar, shortcut menu, or the 
TAB menu; the selected node will be replaced by the new node.

Tip: To replace a node with the TAB menu, select the node in the Node Graph panel that 
you need to replace. Next, press TAB and then type first few characters of the name of the 
node. Next, press and hold CTRL and then select the new node from the TAB menu. If 
you are using a hotkey, you cannot replace nodes using this method.

RENAMING NODES
To rename a node, double-click on the node; its properties panel will be displayed. Next, in 
the properties panel, type the new name in the name field and then press ENTER, refer to 
Figures 3-19 and 3-20. Alternatively, you can rename a node by selecting it in the Node Graph 
panel and then pressing N; a text box will appear on the node. Next, type the new name in 
the text box and then press ENTER to rename the node.
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the Grade1 node properties panel

Figure 3-20  The Grade1 node renamed to myGrade

EDITING NODES
Standard shortcut keys (CTRL+C, CTRL+V, and CTRL+X) are used to perform editing 
operations on the nodes. To copy a node in the memory, select the node and then choose 
Edit > Copy from the menu bar. Next, click on the empty area of the workspace to deselect 
any selected node and then choose Edit > Paste from the menu bar; an exact copy of the 
selected node is created in the Node Graph panel.

Note
When you paste nodes, NukeX automatically connects them to the node that is selected before 
the paste command.

You can also copy nodes to the files. To do so, select the node that you need to copy in the 
Node Graph panel. Next, choose File > Export Nodes As Script from the menu bar; the 
Export Nodes As Script dialog box will be displayed, refer to Figure 3-21. 

Figure 3-21  The Export Nodes As Script dialog box
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Next, navigate to the folder where you want to save the script and then enter name of the 
script in the pathname field. Next, choose the Save button. NukeX will save the selected node 
as a script with the specified name. Start Notepad and open the saved script in it to view its 
content. Figure 3-22 shows the content of the ColorCorrect node script opened in Notepad 
application.

Figure 3-22  The Color Correct node script displayed in 
Notepad

You can import the saved script files in NukeX as a node. To do so,  choose File > Import Script 
from the menu bar; the Import Script dialog box will be displayed, as shown in Figure 3-23. 
Next, navigate to the folder where you have saved the script and then select the script file. 
Next, choose the Open button from the dialog box; the selected script file will be imported 
in the Node Graph panel. 

Figure 3-23 The Import Script dialog box

To cut the node from the Node Graph panel, select the node and then choose Edit > Cut 
from the menu bar; NukeX will remove the selected node from the script and write it to the 
memory. Next, select the node that you want to connect with the node in the memory. Choose 
Edit > Paste from the menu bar; NukeX will insert nodes to the Node Graph panel from 
the memory.
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To create a duplicate node, select the node in the Node Graph panel and then choose Edit > 
Duplicate from the menu bar or press ALT+C. A duplicate of the selected node will be created 
in the Node Graph panel. To delete a node, select the node in the Node Graph panel and 
then choose Edit > Erase from the menu bar or press DELETE; the selected node will be 
removed from the Node Graph panel. To disable or enable a node, select the node that you 
want to disable or enable in the Node Graph panel and then choose Edit > Node > Disable/
Enable from the menu bar.

Tip: To toggle between enable and disable modes of a node, press D.

CLONING NODES
Clones are used to maintain consistency throughout the script. Cloned nodes inherit the values 
of their parent nodes maintaining an active link with them. 

Note
You cannot clone gizmos used in NukeX even if they are user created or built-in.

To clone a node, select the node in the Node Graph panel. Next, choose Edit > Clone from 
the menu bar or press ALT+K; NukeX will create a clone of the selected node and maintain 
an active link with the parent node. A clone indicator (C) will be displayed on both the nodes 
and they also share the same name. To declone nodes, select them and then choose Edit > 
Declone from the menu bar or press ALT+SHIFT+K; NukeX will declone the selected 
nodes and remove the active link. Two nodes can be forced to be clones in a script. To do so, 
select first node. Next, press and hold SHIFT and then select the second node. Next, choose 
Edit > Force Clone from the menu bar or press CTRL+ALT+SHIFT+K; NukeX will make 
the first node as forced clone of the second node. 

GROUPING NODES
You can group (visually organize) nodes in the Node Graph panel using the Backdrop node 
or the Group node. The Backdrop node is used to visually organize areas of the Node Graph 
panel. The Group node is used to group several nodes into a single node, and the group 
node thus created acts as a container for these nodes. The Backdrop and Group nodes are 
discussed next.

Grouping Nodes Using the Backdrop Node
To group nodes using the Backdrop node in the Node Graph panel, choose the Other button 
from the Nodes toolbar; the Other menu will be displayed. Next, choose Backdrop from the 
menu; the BackdropNode# will be inserted in the Node Graph panel, refer to Figure 3-24. 
In the Node Graph panel, drag the triangle on the lower right corner of the Backdrop node 
to increase its size, as required. Next, press and hold the left mouse button over the title of the 
box and then drag the node and slip it under the nodes that you need to visually organize, 
refer to Figure 3-25. Next, click on the empty area of the Node Graph panel and then drag 
the title of the Backdrop# node. You will notice that nodes grouped using the Backdrop  
node move together with it. 
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Figure 3-24  The BackdropNode1 node inserted in the Node Graph panel

Figure 3-25  The Grade1, Blur2, and ColorCorrect2 nodes 
visually grouped using the BackdropNode1 node

To display the properties panel of the Backdrop node, double-click on it in the Node Graph 
panel. To change the color of the Backdrop node, choose the tile_color button from the
BackdropNode# properties panel; the BackdropNode#.title_color window will be 
displayed. Next, select the color as required. To change the name of the Backdrop node, 
enter the new name in the name field of the Backdrop node properties panel. To delete the 
Backdrop node and the nodes it contains, click once on the title of the node and then press 
DELETE. To delete only the Backdrop node, CTRL+click on the title of the node and then 
press DELETE.

Grouping Nodes Using a Group Node
To group nodes using the Group node, select the nodes that you need to group, refer to 
Figure 3-26. If you want to replace the original nodes with the Group node, choose Edit > 
Node > Group > Collapse to Group from the menu bar or press CTRL+G; the Group# 
node will be inserted in the Node Graph panel. Also, a new panel will be displayed with the 
name Group# Node Graph, refer to Figure 3-27. 
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Figure 3-26  Selecting the nodes in the Node Graph panel

Figure 3-27  The Group1 node and the Group1 Node Graph panel

To expand (ungroup) a group, select the Group# node in the Node Graph panel and then 
choose Edit > Node > Group > Expand Group from the menu bar or press CTRL+ALT+G. 
To open the Node Graph panel for the group, select the Group# node in the Node Graph 
panel and then choose Edit > Node > Group > Open Group Node Graph from the menu 
bar or press CTRL+ENTER, refer to Figure 3-28. Alternatively, you can press the show 
button in the Group# node properties panel.     

To keep the selected nodes in the Node Graph panel, choose Edit > Node > Group > Copy 
Node To Group from the menu bar or press CTRL+ALT+SHIFT+G; a free floating Group# 
node will be created in the Node Graph panel along with a separate Group# Node Graph 
panel, refer to Figure 3-29. 

ENHANCING WORKFLOW
Some nodes in the Other category of the Nodes toolbar are used to enhance the workflow. 
The StickyNote node is used to add notes to the Node Graph panel. The notes can be text 
or HTML markup. Generally, they are used as annotations to other nodes in the Node Graph 
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panel. You can use the Dot node to make bends in the connecting pipes. It helps you in 
organizing your script better. The PostageStamp node is used to display a thumbnail render 
of the output at the current frame. This node does not alter the data stream. The nodes used 
to enhance the workflow are discussed next.

Figure 3-28  The Group1 Node Graph panel displayed

Figure 3-29  A floating Group1 node created

Using the StickyNote Node
The StickyNote node is used to add annotation to nodes in the Node Graph panel. To add 
a note to the Node Graph panel, click on the area of the Node Graph panel where you need 
to add a note. Next, choose the Other button from the Nodes toolbar; the Other menu will 
be displayed. Now, choose StickyNote from the menu; the note will be displayed in the Node 
Graph panel, as shown in Figure 3-30. To change the note text, enter new text in the label 
field of the StickyNote# node properties panel. You can also enter HTML markup such as 
<b> your_note_text_here </b> for note to appear in bold or <i> your_note_text_here </i> for 
note to appear in italics in the Node Graph panel. You can also add an image to your note. 
To do so, use <img src=”your_logo.png”/> HTML markup.
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Note
The commonly used image formats can be used for the logo but using the png format is highly 
recommended. Also, you need to save the image files in the plug-in path directory (C:\Program 
Files\Nuke7.0v4\plugins) in order to make images appear on the notes. 
	

Figure 3-30  A note displayed in the Node Graph panel

Using the Precomp Node
The Precomp node is similar to the Group node. However, its contents are stored in an separate 
NukeX script file. It helps in breaking a large script into smaller process trees. The Precomp 
node enhances the workflow and speeds up the rendering process. In this case, NukeX has 
to process a single image input instead of all nodes used to create the precomp. This node 
enhances the workflow where one user can work on the main comp while other can work on 
sub-comps that can be edited independent of the main comp. 

To add a Precomp node, select the nodes that you want to include in the separate script and 
then choose the Other button from the Nodes toolbar; the Other menu will be displayed. 
Next, choose Precomp from the menu; the Precomp Nodes dialog box will be displayed, as 
shown in Figure 3-31.

Figure 3-31  The Precomp Nodes dialog box

Note
If you do not select a node while creating a Precomp node, the Precomp Nodes dialog box will 
not be displayed. However, you can add link to an existing script file to the empty Precomp node 
by using the file parameter from the Precomp# node properties panel.

In this dialog box, click on the folder icon corresponding to the Precomp script path 
parameter; the panelNode: Replace Precomp#_v01.nk dialog box will be displayed. Next, 
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browse to the location where you want to save the precomp .nk script. Enter a name in the 
pathname name field for the precomp and then choose the Open button. Now, click on the 
folder icon corresponding to the Precomp render path parameter; the panelNode: Replace 
Precomp#.####.exr dialog box will be displayed. In this dialog box, browse to the location 
where you need to save the render of the precomp. Enter a name in the pathname field for 
the render file and then choose the Open button. 

Note
By default, the precomp script is saved at the location where the main script exists. If you have 
not saved the main script, the precomp script is saved in the main directory.

Select the channels that you need to include in the precomp from the Channels drop-down of 
the Precomp Nodes dialog box. Select the desired option from the Original nodes drop-down. 
The options in this drop-down are used to determine the behavior of the selected nodes. Select 
the add backdrop option from this drop-down to add a backdrop behind the precomped 
nodes. Select the delete option from the drop-down to delete the precomped nodes. Select  
the no change option from the drop-down to retain its existing state. 

Now, choose the delete option from the Original nodes drop-down and then choose the OK 
button from the Precomp Nodes dialog box;  the Group Output dialog box will be displayed.  
In this dialog box, select the node that will work as output. Next, choose the OK button to close 
the dialog box. NukeX automatically creates a Write and an Output node in the precomp. 
On rendering, if NukeX cannot find any Write or Output node in the precomp, it produces 
an error in the precomp.

Note
1. You should render the image in the .exr format as it is capable of storing hash value. NukeX 
uses hash value to match the changes between the incoming node tree and the rendered file. If hash 
values do not match, NukeX notifies you about the mismatch. If you are using any other format 
than .exr, you will not get this notification and there is a risk of using out-of-date render file. 

2. It is recommended that you set the project settings in the main comp. The precomp uses project 
settings of the main comp. If you open the precomp in a separate instance of NukeX and change 
its project settings, the change will have no effect on the main comp when it is loaded into the 
main comp.

Tip: To display hash value of a node, select the node in the Node Graph panel and press 
I; a window with information about node, including the hash value, will be displayed, 
refer to Figure 3-32.

Rendering a Precomp Node
Create a Precomp node as discussed earlier. In the Precomp tab of the Precomp# node 
properties panel, choose the Render button; the Execute dialog box will be displayed, as shown 
in Figure 3-33. Specify the frame range that you need to render in the frame_range_string 
field located next to the Frame range drop-down and then choose the OK button to close 
the dialog box. On doing so, the Progress window will be displayed showing the rendering 
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progress. It will automatically close once the rendering process completes. When the rendering 
process finishes, the read file for output check box in the Precomp tab of the Precomp node 
properties panel will be automatically selected. As a result, NukeX will read image sequence 
rather than calculating output of the precomp. You will also notice that the Precomp# node 
in the Node Graph panel has turned green. Also, the label (Read) will be displayed on it, 
refer to Figure 3-34. In case NukeX generates error on opening the rendered output, you can 
select the response from the missing frames drop-down. This drop-down has four options, 
namely error, black, checkerboard, and read input.

Figure 3-32  A window displaying hash value of the Grade1 node

Figure 3-33  The Execute dialog box

Figure 3-34  The green colored Precomp1 node with 
the Read label on it
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Viewing and Editing a Precomp Script
To view and edit a precomp script, choose the Open button in the Precomp node properties 
panel. On doing so, a new NukeX session will be launched and the precomp will be loaded in 
it. If you are using version numbers in the Write node, make sure to choose Edit > Node > 
Filename > Version Up from the menu bar; the version number of the file will be increased by 
one. For example, the myPrecomp_v01_###.exr will change to myPrecomp_v02_###.exr. Now 
render the Write node. Next, choose File > Save New Version from the menu bar or press 
ALT+SHIFT+S; the script will be saved with a new version. Fox example, the myPrecomp_v01.nk 
script will change to myPrecomp_v02.nk.

Reloading a Revised Precomp Script
To reload a revised precomp script, load the main comp. Next, in the Precomp tab of the 
Precomp# node properties panel, make sure the name of the script in the file field matches 
with the current name of the precomp script. Next, choose the Reload button to reload the 
revised precomp into the main comp.

Using the Dot Node
The Dot node is used to create bends in the arrows connecting nodes. This node helps in 
organizing the node network in the Node Graph panel. To create a bend in the connecting 
arrows, select the node after which you need the Dot node to appear and then choose Dot 
from the Other menu; the Dot# node will be displayed in the Node Graph panel, refer to 
Figure 3-35. Next, drag the Dot# node as required.

Figure 3-35  The connecting pipe between the Grade1 and Write1 nodes 
bent using the Dot node

Tip
1. You can use the . (period) key to add a Dot node.

2. You can also add a Dot node to an existing connection by using the CTRL key. To do 
so, press and hold the CTRL key; a yellow diamond shape will appear on the connecting 
arrow. Next, click on the shape to insert a Dot node on the connecting arrow.
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INDICATORS ON NODE
NukeX displays some indicators on nodes depending on the operation you are performing 
on them. These indicators are discussed next.

The node’s effect is masked.

The wide rectangles indicate the channels processed by the node. The narrow 
rectangles indicate the channels that are not altered by the node.

The node is disabled. The data stream will pass through the node unaffected.

The node is disabled using an expression.

The node is cloned. 

The fields of the node are animated over time.

One or more of the node fields are being affected by an expression.

One or more views in the node’s controls are split off.

A multi-view project is opened and you have split off views in the node’s control.

The node is not at its full effect. The node’s effect is mixed with the original.
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WORKING WITH PROPERTIES PANELS
The properties panels are used to define the parameters of the nodes. When you add a node 
to the Node Graph panel, its properties panel automatically appears in the Properties Bin. 
Figure 3-36 shows the Blur1 node properties panel. Many properties panels contain several 
tabs, as shown in Figure 3-37.

Figure 3-36  The Blur1 node properties panel

Figure 3-37  The Read1 node properties panel with tabs

If the properties panel is not open for a node, you can use any of the following methods to 
open it:

•	 Double-click on the node in the Node Graph panel.

•	 Press and hold CTRL and then click on the node in the Node Graph panel.

•	 Select the node in the Node Graph panel and then press ENTER.

•	 Press and hold CTRL+ALT and then click on the node to open a properties panel in a 
floating window, refer to Figure 3-38.
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Figure 3-38  Floating Blur1 node properties panel

You can set the number of properties panels that can be opened at a time in the Properties 
Bin. To do so, enter the number in the Max panels field located at the top left corner of the 
Properties Bin. To lock the Properties Bin and have all new properties panels appear in 
floating windows, choose the Lock Existing panels button from the Properties Bin. To empty 
the Properties Bin, choose the Remove all panels button from the Properties Bin, refer to 
Figure 3-39.

Figure 3-39  The Properties Bin

Tip: Press and hold ALT and then choose the Close (x) button of any of the panels to close 
all properties panels in the Properties Bin. Press and hold CTRL and then click on Close 
(x) button to close all properties panels except the one that is clicked.

Standard Node Controls
There are some standard node controls that appear on all nodes. These node controls are 
discussed next:

This button is used to hide or show the tabs of the node. It also hides or shows the node’s 
controls in the Viewer# panel.

This button is used to place the node at the center of the Node Graph panel.
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This button is used to center one of the node’s inputs in the Node Graph panel.

This button is used to create/load a saved node preset.

This field is used to enter a new name for the node.

This button is used to change the color of the node tile in the Node Graph panel.

This button is used to change the color used for the node’s controls in the Viewer# 
panel.

This button is used to undo the last change made to the node.

This button is used to redo the last change made to the node.

This button is used to revert all changes made after the properties panel was opened.

This button is used to display a help tool tip for the selected node.

This button is used to float a properties panel. Choose this button again to dock the 
properties panel back in the Properties Bin.

This button is used to close the properties panel. 

Three more buttons appear on a floating properties panel, refer to Figure 3-38. These buttons 
are discussed next:

This button is used to revert any changes made after the properties panel was 
opened.

This button is used to revert any changes made after the properties panel was 
opened and it also closes the properties panel. If you choose this button right 
after a node is created, the node is deleted from the Node Graph panel.

This button is used to close the properties panel.
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Node Tab
This tab is found on the properties panel of every node, refer to Figure 3-40.  The parameters 
in this tab are discussed next.

Figure 3-40  Parameters in the Node tab 

label
This field is used to add comments about the node. You can use basic HTML markup in this 
field. 

font
The options in this drop-down are used to change the font of the text displayed on the node. 
The bold and italic buttons are used to bold or italicize text displayed on the node.

note_font_size
This field is used to change the size of the text displayed on the node.

color
This button is used to change the color of text displayed on the node in the Node Graph 
panel.

hide input
This check box is used to hide the incoming pipe of the node.

cached
This check box is used to keep the output data of the node in the memory so that it can be 
read quickly.



3-24				                                 The Foundry NukeX 7 for Compositors
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

disable
This check box is used to disable or activate the node.

always in dope sheet
By default, the node will be displayed in the Dope Sheet panel when its properties panel is 
open. On selecting this check box, the node always opens in the Dope Sheet panel.

bookmark
When this check box is selected, the node is shown in the bookmark list.

postage stamp
This check box is used to display a thumbnail render of node’s output on its tile in the Node 
Graph panel.

static frame
This field is used to specify the frame number to be used for generating the postage stamp.

Working with Properties Panel Controls
NukeX gives you various types of controls to edit values in the properties panel, refer to 
Figure 3-41. These controls are discussed next.

Figure 3-41  The parameter controls in the ColorCorrect1 
node properties panel

Fields
You can enter values directly in the input fields or use arrow keys (UP and DOWN) to increase 
or decrease the values. When arrow keys are used, the change in the value of the field depends 
on the initial position of the cursor. For example, if the current value of the field is 125.25 
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and you need to change it to 126.25; place your cursor after 2 and press UP ARROW once. 
Now, if you press DOWN ARROW twice, new field value will be 124.25. You can also enter 
expressions into the fields. Additionally, you can enter formulae in the input fields for quick 
calculations. For example, if you enter 1280/2 in a field and then press ENTER, NukeX will 
return a value of 640. 

Tip: You can also increase or decrease field values using the mouse wheel. To do so, place 
the cursor in the field and then scroll mouse wheel. If the mouse wheel is not available then 
press and hold ALT and drag the field values.

Sliders
To set a value with the slider, drag the slider knob as required or click on the scale located 
beneath the slider. To reset a slider to its default value, press and hold CTRL and click on 
the slider.

Channels
By default, NukeX uses single value for the R, G, B, and A channels. For example, if in 
the ColorCorrect1 node properties panel you set the gain field value to 1.2, this value will 
simultaneously affect the R, G, B and A channels, refer to Figure 3-42. You can choose the 
field’s Channel chooser button to switch between single and multiple values. As a result, an 
array of input fields will be displayed for editing channel values individually. The number on 
the button indicates the number of input fields available, refer to Figure 3-43.

Figure 3-42  The value 1.2 applied to all channels in 
the gain field of the ColorCorrect1 properties panel

Pick color from the viewer
The Pick color from the viewer button is used to input the color values. To pick the color from 
the Viewer# panel, choose the Pick color from viewer button; an eyedropper will be activated. 
Next, CTRL+click on the Viewer# panel to sample a color. To sample a color from the node’s 
input while viewing its output, press and hold CTRL+ALT and click on the Viewer# panel. 
Press and hold SHIFT+LMB and drag the cursor on the Viewer# panel to sample a region 
instead of a point. As a result, a red rectangle will be drawn on the Viewer# panel and the 
sample color will be the average of the pixels inside that rectangle. Choose the button again 
to lock the selected color to prevent unwanted color sampling.
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Figure 3-43  Separate r, g, b, and a channels displayed 
for the gain field of the ColorCorrect1 properties panel

Color wheel
On choosing the field’s Color wheel button, the color picker window will be displayed along 
with the color sliders and color wheel. The color sliders and color wheel in this window are 
used to set the precise color values. To make sliders horizontal in this window, resize the 
dialog box. When the size of the window is wide enough, sliders are placed horizontally, refer 
to Figure 3-44.

Figure 3-44  The color picker window displayed on choosing the 
Color wheel button from the properties panel of the Grade1 node

To change the slider set displayed in the color picker window, choose TMI (Temperature, 
Magenta/Green, Intensity), HSV (Hue, Saturation, Value), or RGB (Red, Green, Blue) button 
from the color picker window, refer to Figure 3-44. To enable dynamic colors for the sliders 
background, choose the Dyn button. Choose the Show the color wheel button to cycle through 
color wheel states, the color wheel, and square, refer to Figure 3-45. Choose the color swatch 
button to show or hide the color swatches in the color picker window, refer to Figure 3-46.

Drag the white triangle located at the edge of the color wheel to adjust the hue, refer to 
Figure 3-47. Drag the white circle located inside the color wheel to adjust the saturation, refer 
to Figure 3-47.
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Figure 3-45  The color wheel states

Figure 3-46  Color swatches displayed in the color picker window on choosing the 
color swatch button

Figure 3-47  Controls on the color wheel

To affect only the hue of the selected color, press and hold CTRL and then drag the white 
triangle of the color wheel. Similarly, press and hold the SHIFT key and drag the white circle 
to change only the saturation, refer to Figures 3-48 and 3-49.
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Figure 3-48  Changing only the hue values

Figure 3-49  Changing only the saturation values

You can also zoom and pan inside the color wheel. To zoom in or out in the color wheel, press 
and hold ALT and then drag the cursor up or down using the middle mouse button. To pan in 
the color wheel, press and hold ALT and then drag the cursor on it. To reset the zoom or pan 
operation, press the middle mouse button on the color wheel. The slider labels on the color 
wheel window are used to increment color values precisely, refer to Figure 3-50. To increase 
the value by 0.01, right click on the label. To decrease the value by 0.01, left-click on the label. 
If you want to change the value by 0.1 or 0.001, use SHIFT or ALT. To open another color 
picker window while keeping the previously opened color picker window open, CTRL+click 
on the another parameter’s color picker button.

Figure 3-50 The slider labels

WORKING WITH THE METADATA
Metadata is data within the data. It is information such as original bit depth, width, height, and 
so on of an image which is embedded in it. NukeX reads the embedded metadata information 
and passes it down to the process tree. You can change the metadata information in NukeX and 
also embed the new metadata to an image. You can access metadata nodes from the Metadata 
menu which is displayed on choosing the MetaData button from the Nodes toolbar. In this 
section, you will learn how to view, edit, and render the metadata.
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Viewing Metadata
To view the metadata embedded to an image, select the node whose metadata you want to 
view and then choose the MetaData button from the Nodes toolbar; the MetaData menu will 
be displayed. Next, choose ViewMetaData from the menu; the ViewMetaData# node will be 
inserted in the Node Graph panel. You can view the metadata information in the ViewMetaData 
tab of the ViewMetaData# properties panel, as shown in Figure 3-51.

Figure 3-51  The metadata information displayed in the 
ViewMetaData1 node properties panel

To filter the metadata list, you can use the search metadata for field in the ViewMetaData# 
node properties panel. To do so, enter a filter criteria in this field; the filtered information 
will be displayed in the ViewMetaData tab of the properties panel of the node. Fox example, 
if you enter input in the search metadata for field and then press ENTER; the keys and 
values having the word input will be displayed in the properties panel, refer to Figure 3-52. 
By default, filtering is done for both keys and values. However, you can limit it to keys or 
values by selecting the keys only or values only option from the within drop-down of the 
ViewMetaData# properties panel.

Tip: The keys can be referenced while writing expressions.

Note
1. While viewing the metadata information of a QuickTime file, the ViewMetaData node does 
not display the gamma or bit depth, refer to Figure 3-53.

2. If you add the ViewMetaData node after the Merge node having two inputs A and B, you 
can specify the input whose metadata will flow downstream. To do so, select the A or B option 
in the metadata from drop-down in the Merge tab of the Merge node properties panel. You 
will learn about the Merge node later in this chapter.
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Figure 3-52  The filtered metadata list displayed for key 
input

Figure 3-53  The metadata of a QuickTime file displayed in the 
ViewMetaData# node properties panel

Comparing Metadata
To compare metadata between the two inputs, add the CompareMetaData node from the 
MetaData menu and then connect the nodes that you need to compare with the A and B inputs 
of the CompareMetaData# node, refer to Figure 3-54. On doing so, the CompareMetaData 
node will display a list of keys where there is difference in the metadata of the two input 
images, refer to Figure 3-55.
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Figure 3-54  The Read1 and Read2 nodes connected to the 
CompareMetaData1 node

Figure 3-55  The CompareMetaData1 node displaying 
difference in the keys of the two input images

Adding Metadata
To add metadata, select the node whose metadata you need to add and then choose the 
ModifyMetaData node from the MetaData menu; the ModifyMetaData# node will be 
connected with the selected node and its properties panel will be displayed. In this properties 
panel, choose the + button from the ModifyMetaData tab; a placeholder will be created in 
the metadata box, refer to Figure 3-56. 

Next, double-click on the first cell under the key column header; the Pick metadata key 
dialog box will be displayed, refer to Figure 3-57. Enter a new name in the field located at 
the bottom of the dialog box and then choose the OK button. Now, double-click on the first 
cell under the value column header and then enter the value in it; the new key and its value 
will now flow downstream.
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Figure 3-56  The ModifyMetaData1 node properties panel

Figure 3-57  The Pick metadata key dialog box

Editing Metadata
To edit metadata, in the ModifyMetaData# node properties panel, choose the + button; a 
placeholder will be created in the metadata box, refer to Figure 3-56. Next, double-click on the 
first cell under the key column header; the Pick metadata key dialog box will be displayed, 
refer to Figure 3-57. In this dialog box, first select the key that you need to edit and then 
choose the OK button. Now, edit the value(s) and key(s) as required.

Removing Metadata
To remove metadata, choose the + button in the ModifyMetaData# node properties panel; a 
placeholder will be created in the metadata box. Next, double-click on the cell under action to 
display a flyout and then choose remove from the flyout. Invoke the Pick Metadata key dialog 
box, as discussed earlier. Select the keys to be removed from the dialog box and then choose 
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the OK button; the selected key will be removed from the metadata. To cancel an existing 
action choose the - (minus) button from the ModifyMetaData node properties panel.

Note
When you delete a key from the metadata, it only affects the ModifyMetaData node calculations. 
It does not alter the embedded metadata in the input images.

Copying MetaData
To copy metadata from one input to another, choose the CopyMetaData node from the 
MetaData menu; the CopyMetaData# node will be inserted in the Node Graph panel and 
its properties panel will be displayed with the CopyMetaData tab chosen by default, as shown 
in Figure 3-58. 

Figure 3-58  The CopyMetaData1 node properties panel

The CopyMetaData# node has two inputs: Image and Meta. The Image input is used to 
connect to the image whose output you need to pass down. The Meta input is used to connect 
to the node whose metadata you need to copy to the output. 

Once connections are made with a node in the Node Graph panel, choose the desired option 
from the metadata from drop-down of the CopyMetaData# node properties panel. By default, 
the Image+Meta option is selected in this drop-down. This option is used to add metadata 
from the Meta input to the metadata of the Image input. When the Meta only option is 
selected, NukeX only uses the metadata from the Meta input. The function of Meta+Image 
option is opposite to the Image+Meta option. The Image only option is used to take the 
metadata of the input image. 

There are two areas in the CopyMetaData tab of the CopyMetaData# node properties panel: 
Meta filtering and Image filtering. The options in these areas are used to filter the metadata 
taken from the two inputs of the node. Fox example, if you enter input in the copy only field 
of the Meta filtering area and then press ENTER; the keys and values having the word input 
will be copied from the Meta input. By default, filtering is applied to both keys and values. 
However, you can limit it to only keys or values. To do so, select the desired option from the 
within drop-down. Similarly, you can filter the metadata from the Image input by setting the 
desired options in the Image filtering area.
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Adding a Timecode to Metadata
To add a timecode to the metadata, choose the AddTimeCode node from the MetaData menu; 
the AddTimeCode1 node will be inserted in the Node Graph panel and then its properties 
panel will be displayed with the AddTimeCode tab chosen in the Properties Bin, as shown 
in Figure 3-59.

Figure 3-59  The AddTimeCode1 properties panel

By default, timecode is set to 01:00:00:00 in the start code field of the properties panel, refer 
to Figure 3-59, which is timecode on the first frame. The value in the fps field is controlled by 
the fps value set in the Project Settings panel. If you need to manually set the fps value, clear 
the get FPS from metadata check box; the fps field will be enabled. Next, enter the desired 
value in the fps field. If you need to set different start frame than the first frame, select the 
use start frame? check box and then enter new value in the start frame field.

Rendering Metadata
To render the metadata, place the Write node at the desired place in the script and then set the 
required options in the Write node properties panel. NukeX only writes metadata information 
in the following formats: EXR, CIN, JPEG, and DPX. Select the format of file from the file 
type drop-down; the metadata option related to the file format will be displayed in the Write 
node properties panel. Next, set the option as required and then render the Write node.

COMPOSITING IMAGES
The compositing of images implies combining multiple images to create a single seamless 
image. The nodes in the merge category are used to composite two or more images. Most 
commonly used nodes in this category are discussed next.

Merge Node
The Merge node combines two input images based on the transparency (alpha channel) using 
various algorithms. The alpha channel is used to determine which pixels of the foreground 
image will be used for the composite. This node takes three inputs: A, B, and mask. The A 
input is used to connect foreground image to the Merge node. This image merges with the 
image that is connected to the B input. When you connect an image to the A input of the 
Merge node, an additional A input will be displayed on it, refer to Figure 3-60. Each input is 
named in the order it was connected with other nodes, A1, A2, A3, and so on. It means that 
you can connect as many images as you need on the A side of a Merge node. NukeX copies 
data from the A input to the B input. If you disconnect the node connected to the A input,  
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the data stream will still flow down as NukeX will use the B input. The mask input is used to 
connect a node to use as a mask. 

The Merge node connects multiple images using various algorithms such as multiply, overlay, 
screen, and so on. To add a Merge node to the workspace, press the M key; the Merge# node 
will be inserted in the Node Graph panel and its properties panel will be displayed with the 
Merge tab chosen in the Properties Bin, refer to Figure 3-61. The options available in the 
Merge tab of the Merge# node properties panel are discussed next. 

Figure 3-60  Additional input A displayed on the Merge1 node 

Figure 3-61  The Merge# node properties panel

operation
The options in the operation drop-down are used to set the algorithm to be used for merging 
the images. By default, the over algorithm is selected in this drop-down. It layers the image 
sequence connected to the A input over the image sequence connected to the B input according 
to the alpha channel present in the A input.

Tip: To see the math formula for a particular merge algorithm, place the cursor over the 
operation drop-down; a tooltip will be displayed. This tooltip contains the information 
about the mathematics behind a merge operation. 
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When the Video colorspace check box located next to the operation drop-down is selected, 
NukeX converts all colors to the default 8-bit colorspace before compositing and then outputs 
them in linear colorspace. You can change the default colorspace for 8-bit files from the 
Project Settings panel. To do so, hover the mouse over the workspace and then press S; the 
Project Settings panel will be displayed. In this panel, choose the LUT tab; the Default LUT 
settings area will be displayed. Next, select the desired option from the 8-bit files drop-down, 
refer to Figure 3-62. 

Figure 3-62  Partial view of the LUT tab of the 
Project Settings panel

On selecting the alpha masking check box located next to the Video colorspace check box, 
the image is processed according to the PDF/SVG spec. According to this spec, that the input 
image remains unchanged if the other composited image has zero alpha. The calculation 
applied to the alpha will be according to the following formula: a+b-a*b. If this check box is 
cleared, the formula applied to alpha will be same as that applies to other channels.

Note
This check box will be disabled when it does not affect the operation selected from the operation 
drop-down or PDF/SVG.

set bbox to
The options in this drop-down are used to set the bounding box. The bounding box defines 
the area of the frame that is having valid image data. It is used to speed up the processing. By 
default, full image area is the bounding box of the input image but if you crop a particular input, 
the bounding box will be reduced to the cropped area. The default option in this drop-down 
is union, the other three are: intersection, A, and B. These options are discussed next.

union
The union option combines the two bounding boxes from the A and B inputs. It resizes 
the output bounding box to fit the two input bounding boxes completely. 

intersection
When you select the intersection option, the output bounding box will be the overlapping 
area of the two input bounding boxes.
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A
Select the A option to use the bounding box from the A input.

B
Select the B option to use the bounding box from the B input.

metadata from
The options in this drop-down are used to specify the node whose metadeta will flow down 
the process tree.

A channels
The options in the first A channels drop-down are used to specify which channels from the 
A input will be merged with the B input. The options in the second A channels drop-down 
are used to specify additional channel (alpha) to be merged with the B input. If you select 
none from the first A channels drop-down, the output of the A input will be black or zero. 
You can select check boxes on the right of the first A channels drop-down to select individual 
channels.

B channels
The options in the first B channels drop-down are used to specify which channels from the B 
input will be merged with the A input. The options in the second B channels drop-down are 
used to specify additional channel (alpha) to be merged with the A input. You can select the 
check boxes on the right of the first B channels drop-down to select individual channels.

output
The options in the first output drop-down are used to specify the output channels after the 
merge operation. The options in the second output drop-down are used to specify an additional 
output channel (alpha) after the merge operation. You can select the check boxes on the right 
of the first output drop-down to select individual channels.

Note
There are four check boxes on the right of the A channels, B channels, and output drop-downs, 
namely red, green, blue, and Enable channel, refer to Figure 3-63. You can use these check 
boxes to keep or remove the channels from the merge calculations, as required. When the Enable 
channel check box is selected, the channels selected from the drop-down placed on the right of this 
check box are enabled. This check box is available in the properties panels of many nodes.

also merge
The options in the first also merge drop-down are used to specify the channels that will 
be merged in addition to the channels specified from the A channels and B channels 
drop-downs. The options in the second also merge drop-down are used to specify the additional 
channel (alpha) to be merged. You can select the check boxes on the right of the first also 
merge drop-down to select individual channels. These check boxes appear when you select 
option other than none in the first also merge drop-down.
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Figure 3-63  The Enable channel check boxes displayed in 
the Merge1 properties panel

mask
The Enable channel check box located on the left of the mask drop-down is selected when 
you connect a mask to the mask input of the Merge node or select a channel from the mask 
drop-down. The options in this drop-down are used to select the channel that will be used as 
mask. When the inject check box is selected, NukeX copies the mask input to the predefined 
mask.a channel. The injected mask can be further used downstream in the process tree. By 
default, the merge is limited to the non-black areas of the mask. When you select the invert 
check box, the mask channel will be inverted and now merge will be limited to the non-white 
areas of the mask. The fringe check box is used to blur the edges of the mask.

mix
The mix parameter is used to blend the two merged inputs. When the value of this parameter 
is set to 0, only the B input will be displayed in the Viewer# panel. The full merge will be 
displayed when the value for this parameter is set to 1 which is the default value.

Premult Node
The Permult node is used to premultiply the input image. This node multiplies the rgb 
channels of the input image with its alpha channel. The alpha channel is used to determine 
which pixels of the foreground input image will be visible in the final composite. An input 
image that is not premultiplied is referred to as straight or unpremultiplied. If the black 
areas in the alpha channel are not black in the color channels, then the image is considered 
as Straight. Generally, most 3D rendered images are premultiplied. The Merge node expects 
premultiplied images so you should use the Premult node before any merge operation if input 
image is not premultiplied. This helps in removing artifacts such as fringes around a masked 
object. While color-correcting a premultiplied image, you should first connect an Unpremult 
node to the image and then perform color-correction. Next, connect a Premult node to get 
back to original premultiplied state for the merge operations.  To add a Premult node to the 
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Node Graph panel, select Premult from the Merge menu of the Nodes toolbar; the Premult# 
node will be inserted in the Node Graph panel and its properties panel will be displayed with 
the Premult tab chosen in the Properties Bin, refer to Figure 3-64. The options available in 
the Premult tab of the Premult# node properties panel are discussed next.

Figure 3-64  The Premult1 node properties panel

multiply
The options in the first multiply drop-down are used to set the channels (generally rgb) to be 
multiplied with the alpha channel. To select the individual channels, you can select the check 
boxes available on the right of the multiply drop-down. The options in the second multiply 
drop-down are used to set the additional channel to be multiplied with the alpha channel. 

by
If you select the Enable channel check box located on the left of the by drop-down, the channel 
set in it (generally alpha) is multiplied with the channels set using the multiply drop-downs. 
The invert check box is used to invert the output of the alpha channel.

Unpremult Node
The Unpremult node is used to divide the rgb channels of the input image by its alpha. 
To add a Unpremult node to the Node Graph panel, select Unpremult from the Merge 
menu; the Unpremult# node will be inserted in the Node Graph panel and its properties 
panel will be displayed with the Unpremult tab in the Properties Bin, refer to Figure 3-65. 
The options available in the Unpremult tab of the Unpremult# node properties panel are 
discussed next.

Figure 3-65  The Unpremult1 node properties panel
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divide
The options in the first divide drop-down are used to set the channels (generally rgb) to be 
divided with the alpha channel. To select the individual channels, you can select the check boxes 
available on the right of the divide drop-down. The options in the second divide drop-down 
are used to set an additional channel to be divided with the alpha channel. The function of  
the by and invert check boxes is same as discussed in the Premult node.

WORKING WITH IMAGE NODES
Before you start compositing, you need to import image or image sequence to the Node 
Graph panel using the Read node. You can also generate images using NukeX nodes such 
as the Constant node. Once you load an image in the Node Graph panel, you can view the 
output of the Read node using the Viewer node. The Write node is used to write the output of 
all upstream nodes to the disk. All these nodes can be added using the Image menu which is 
displayed on choosing the Image button from the Nodes toolbar. The commonly used nodes 
in the Image menu are discussed next.

CheckerBoard
This node is used to generate a checkerboard image that can be used in place of a texture or 
background, refer to Figure 3-66. To add a CheckerBoard node to the Node Graph panel, 
choose CheckerBoard from the Image menu; the CheckerBoard# node will be inserted in the 
Node Graph panel and its properties panel will be displayed with CheckerBoard tab chosen 
in the Properties Bin, refer to Figure 3-67. The options available in the CheckerBoard tab 
of the CheckerBoard# node properties panel are discussed next.

Figure 3-66  The checkerboard pattern displayed in the Viewer1 panel

format
The options in this drop-down are used to set the format of the image that the CheckerBoard 
node generates. This setting is dependent on the format set in the Project Settings panel.

size
This parameter is used to set the size of the checkerboard boxes in pixels.
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Note
On enabling the proxy mode, the size of the boxes is rounded to the nearest pixel. Therefore, the 
output of the CheckerBoard node may look different than its full resolution output.

Figure 3-67  The CheckerBoard1 properties panel

color 0
The color 0 parameter is used to set the color of the boxes from the bottom left corner. The 
color specified using this parameter starts at (0,0) and then affects every alternate box and 
row. Similarly, color 1, color 2, and color 3 start at (1,0), (1,1), and (0,1), respectively and 
affect every alternate box and row. Figure 3-68 shows output of the CheckerBoard1 node 
with the color 0, color 1, color 2, and color 3 parameters set to red, green, blue, and yellow 
colors, respectively.

Figure 3-68  The output of the CheckerBoard1 node

line color
This parameter is used to set the color of the outline of the boxes.
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line width
This parameter is used to set the width of the outline of the boxes in pixels. Figure 3-69 shows 
the output of the CheckerBoard1 node with line color set to red and line width to 10. 

Figure 3-69  The output of the CheckerBoard node displayed on 
changing the values of the line color and line width parameters

centerline color
This parameter is used to set the color of center lines on the checkerboard.

centerline width
This parameter is used to set the width of the center lines in pixels. Figure 3-70 shows the 
output of the CheckerBoard1 node on setting the centerline width parameter to 10.

Constant Node
This node is used to generate a constant color image. To add the Constant node to the Node 
Graph panel, choose Constant from the Image menu; the Constant# node will be inserted 
in the Node Graph panel and its properties panel will be displayed with the Constant tab 
chosen in the Properties Bin, refer to Figure 3-71. The options available in the Constant tab 
of the Constant# node properties panel are discussed next. 

channels
The options in the first channels drop-down are used to select the channels that will be included 
in this node and will be affected by it. You can select individual channels by selecting the check 
boxes placed on the right of the drop-down. The option in the second channels drop-down 
corresponding are used to select an additional channel that will be affected by this node.
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Figure 3-70  The output of the CheckerBoard node displayed  
on changing the value of the centerline width parameter

Figure 3-71  The Constant1 node properties panel

color
This parameter is used to set the output color of the Constant node.

format
The options in this drop-down are used to set the format of the image that the Constant 
node generates. By default, the option selected in this drop-down is the format specified in 
the Project Settings panel.

frame range
The two fields corresponding to the frame range parameter are used to set the first and last 
frames of the frame range for animating the output of the Constant node.

Viewer Node
This node is used to view the output of connected process nodes in the Viewer panel. This 
node does not affect the data stream, it just displays the output. You can insert as many Viewer 
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nodes as you need in a script. To add the Viewer node to the Node Graph panel, choose 
Viewer from the Image menu or press CTRL+I. You can connect upto ten process nodes to 
a single Viewer node. To cycle through the views, put the cursor on the Viewer# panel. Next, 
press the UP or DOWN arrow to quickly cycle through the views. Alternatively, you can press 
the numbers (0, 1-9) corresponding to the port number of the Viewer# node. Figure 3-72 
shows the Blur1 node connected to the port 2 of the Viewer1 node. Figure 3-73 shows the 
Viewer1 node connected to the four process nodes. 

Figure 3-72  The Blur1 node 
connected to the port number 2 of 
the Viewer1 node

Figure 3-73  All four nodes 
connected to the Viewer1 node

Read Node
This node is used to load images from the disk. This node converts all imported images to 
the native 32-bit linear RGB workspace. It supports file formats such as Cineon, TIFF, PSD, 
OpenEXR, HDRI, RAW Camera data, and so on. To add a Read node to the Node Graph 
panel, choose Read from the Image menu or press R; the Read File(s) dialog box will be 
displayed. In this dialog box, navigate to the desired file and then choose the Open button; 
the Read# node will be inserted in the Node Graph panel and its properties panel will be 
displayed with the Read tab chosen in the Properties Bin, as show in Figure 3-74. Various 
options available in the Read# node properties panel are discussed next. 

Read Tab
The options available in this tab are used to read files from the disk, set format, set proxy and 
proxy format, set frame range, and colorspace. These options are discussed next.

file
This parameter displays the path of the file which is loaded using the Read# node. 
To change the file, you can click on the folder icon located next to this parameter; the 
Read#:Replace dialog box will be displayed. Next, navigate to the desired file and then 
choose the Open button to replace the file. 
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Figure 3-74  The Read1 node properties panel

cache locally
The options in this drop-down are used to set the option for the local caching in a specified 
folder. Local caching helps in faster reloading of the files. To set the location of the folder 
for local cache, choose Edit > Preferences from the menu bar; the Preferences dialog 
box will be displayed. In this dialog box, you can set the local cache folder by modifying 
the localise to parameter value. Next, choose the Save Prefs button to save the changes 
made and then close the dialog box. The cache locally drop-down has three options, 
namely auto, always, and never.

format
The options in this drop-down are used to set the size and pixel aspect ratio of the loaded 
image. By default, NukeX matches it with the size and pixel aspect information stored in 
the header of the loaded image.

proxy
This parameter is used to set path for the proxy file. Generally, a proxy file is a low res 
version of the full res file and is used when proxy mode is on and the required resolution 
is less than or equal to the size of the file.

proxy format
The options in the proxy format drop-down are used to select the size and aspect ratio 
of the proxy file.

frame range
The fields corresponding to the frame range parameter are used to set the first and last 
frames of the image sequence. There are two drop-downs corresponding to the frame 
range parameter. These drop-downs are used to set the behavior of the Read# node 
while calculating the frames outside the range specified for the fields. By default, hold is 
selected in these two drop-downs. As a result, NukeX holds the first and last frames for 
out of range frames specified by the first and last fields. Other three options available 
are loop, bounce, and black. The loop option is used to continuously loop the sequence 
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for out of range frames. The bounce option is used to loop the sequence repeatedly back 
and forth for out of range frames. The black option is used to replace out of range frames 
with black frames.

frame 
The options in the frame drop-down are used to set the frame mode. By default, the 
expression option is selected in this drop-down. You can enter an expression in the field 
located next to this drop-down. If the start at option is selected, the playback will not start 
until the playhead reaches the frame specified in the frame field. If you select the offset 
option, the frame displayed will be offset by the value specified in the field located next 
to the frame drop-down.

original range
The fields corresponding to the original range parameter are used to set the original 
frame range of the loaded images.

missing frames
The options in the on_error drop-down corresponding to the missing frame parameter 
are used to specify the action needed to be taken if the Read node encounters any error 
in loading the frames. By default, the error option is selected in the missing frame drop-
down. As a result, NukeX displays No Such file or directory error message in the Viewer 
panel. If the black option is selected from the drop-down, the missing frame is filled with 
the black color. When the Checkerboard option is selected from this drop-down, the 
missing frame is filled with a checkerboard pattern. The nearest frame option from this 
drop-down is used to replace the missing frame by the nearest frame in the sequence. 
The reload button is used to re-read images from the disk. 

colorspace
The options in the colorspace drop-down are used to specify the lookup table (LUT) 
that is used to convert values that NukeX uses internally. By default, the default option 
is selected in this drop-down. As a result, NukeX collects information from the header of 
the image. When the premultiplied check box is selected and alpha channel is available 
in the input image, NukeX first divides the color channels with the alpha channel before 
converting the colorspace and then multiply it with the alpha channel. This helps in 
removing artifacts from the input images. If you select the raw data check box, NukeX 
does not convert the data. 

Sequence Tab
The options in this tab are used to import a sequence script. These options are discussed 
next.

import sequence
This button is used to import a sequence script. This script builds a frame sequence list from 
an EDL file. On choosing this button, the Sequence File dialog box will be displayed. 

Next, you need to navigate to the script and then choose the Open button to import the 
script.
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frame sequence
This field is used to access multiple sequences using the single read node where the 
naming of sequences does not follow the numeric sequence. 

timecode
This parameter is used to display the timecode if it is included in the image. It displays 
timecode of the last opened file.

edge code
This parameter is used to display the edge code if it is in the image. It displays the edge 
code of the most recently opened image.

RENDERING
Rendering is a process in which the result of all the upstream nodes is calculated and then 
saved to the disk. Generally, the Write node is placed at the end of the process tree to render 
the final output of the composition. However, you can place it anywhere in the tree as it has 
both the input and output connectors. The uses of the Write node and naming convention 
of the rendered sequence are discussed next.

Write Node
The Write node supports multiple file formats such as Cineon, OpenEXR, TIFF, and so on. To 
add a Write node to the Node Graph panel, select the last node in the process tree and then 
choose Write from the Image menu; the Write# node will be connected with the selected node 
in the Node Graph panel and its properties panel will be displayed with the Write tab chosen in 
the Properties Bin, refer to Figure 3-75. The options available in the Write# node properties 
panel are discussed next. 

Figure 3-75  The Write1 node properties panel
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Write Tab
The options in this tab are used to specify the render settings. These options are discussed 
next.

channels
The options in the first channels drop-down are used to select the channels that the 
Write node will write. You can include individual channels in the output by selecting 
the check boxes placed at the right of the first channels drop-down. The options in the 
second channels drop-down are used to select an additional channel (alpha) that the 
Write node will write. 

file
This parameter is used to define the path and name of the file. To do so, click on the 
folder icon corresponding to this parameter; the Write1: Select file(s) dialog box will be 
displayed. In this dialog box, navigate to the folder where you want to save the file and 
then enter the name of the file in the pathname field. Next, choose the Save button to 
close the dialog box.

proxy
The Write node executes all renders at full or proxy resolution depending on the currently 
active state. If proxy mode is enabled then you can toggle between resolutions using the 
CTRL+P keys. The proxy parameter is used to specify the path and name of the proxy 
file.

frame
The function of the frame parameter is same as that of the frame parameter of the Read 
node. 

colorspace
The function of the colorspace parameter is same as that of the colorspace parameter 
of the Read node.

views
The options in this drop-down are used to select the view to be rendered.

file type
The options in this drop-down are used to set the type of file to be rendered. On selecting 
any option from this drop-down, more file specific parameters appear on the Write node 
properties panel. Figure 3-76 shows additional parameters in the Write node properties 
panel on selecting tiff from the file type drop-down.

render order
When multiple Write nodes are available in the script and are rendered together, then 
their rendering order is determined by the value specified in the field corresponding to 
this parameter. Choose the Render button to start the rendering process.
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Figure 3-76  Additional parameters displayed in the 
Write1 node properties panel

frame range
By default, the fields corresponding to the frame range parameter are disabled. Select 
the limit to range check box to enable them. When this check box is enabled, the Write  
node will only execute frames within the range specified in the fields. For frames outside 
the specified range, the Write node will act as if it is disabled.

read file
By default, the read file check box is cleared. Select this check box; the missing frames 
parameter will be enabled. The function of this parameters is same as that of the Read 
node. On selecting this check box, the Write node ignores its input. The output of the 
node comes from the rendered file. 

Python Tab
The options in this tab are used to automatically execute the Python functions when some 
events occur in a script. These options are discussed next.

before render
This parameter is used to run functions before rendering starts.

before each frame
This parameter is used to run functions prior to starting rendering of each individual 
frame.

after each frame
This parameter is used to run functions after rendering is done in each frame. These 
functions are not called if render aborts. 
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after render
This parameter is used to run functions after rendering of all frames is done.

Rendered Sequences
In NukeX, you can render a file in two ways: by creating a single file such as .MOV or by 
rendering a sequence. When you render a sequence (recommended) such as tiff, one tiff 
image is created per frame and that image is identified by the frame number. For example, 
render file of the frame 31 will be something like name_of_file.00031.tiff. To get padding in 
the rendered sequence, you need to specify a padding structure. For frame numbers, you 
can either use # for each digit or use printf-style formatting such as %04d. Here, 04 means 
number of digits to be used. To get a naming conventions such as name_of_file.00031.tiff  you 
can use name_of_file.#####.tiff or name_of_file.%05d.tiff padding structure.

TUTORIALS
Before you start the tutorials, you need to download the c03_nuke_7_tut.zip file from 
www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > 
NukeX > The Foundry NukeX 7 for Compositors. Next, you need to extract the contents of the 
zip file. To do so, navigate to the Documents folder and extract the contents of the downloaded 
zip file to \Documents\Nuke_Projects.

 Tutorial 1
In this tutorial, you will use a simple A on B algorithm to composite a footprint. Figures 3-77 
through 3-82 show the f1.png to f6.png images. These images will be used to composite the 
footprint, as shown in Figure 3-83.                                                    (Expected time: 40 min)

Figure 3-77  The f1.png image Figure 3-78  The f2.png image

Figure 3-79  The f3.png image Figure 3-80  The f4.png image
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Figure 3-81  The f5.png image Figure 3-82  The f6.png image

Figure 3-83  The footprint composite

The following steps are required to complete this tutorial:

a. 	 Set the project.
b. 	 Import the images.
c. 	 Merge images with background.
d.	 Render and save the script.

Setting the Project
As the resolution of the image used in this tutorial is NTSC 720x480, you need to set the 
project accordingly.

1. 	 Choose File > New or press CTRL+N; a new NukeX screen is displayed. Next, choose 
File > Save from the menu bar; the Save script as dialog box is displayed. In this dialog 
box, navigate to \Documents\Nuke_Projects\c03_tut and then append c03_tut01 to the path 
displayed in the pathname field. Next, choose the Save button to save the script.

2.	 Hover the cursor over the Node Graph panel and press S; the Project Settings panel is 
displayed in the Properties Bin. Make sure the Root tab is chosen in it. Next, select new 
from the full size format drop-down, refer to Figure 3-84; the New format dialog box is 
displayed, as shown in Figure 3-85. In this dialog box, set the values of the parameters as 
given next:

	 name: NTSC720x480		  file size w: 720		  file size h: 480
	 pixel aspect: 0.91
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Figure 3-84  Partial view of the full size format drop-down

Figure 3-85  The New format dialog box

	 Next, choose the OK button to close the dialog box. You will notice that new format created 
is displayed in the full size format drop-down as well as in the Viewer1 panel.

Importing the Images
In this section, you will import images from f1.png to f6.png and then bookmark the Nuke_Projects 
folder for quick access.

1.	 Choose the Image button from the Nodes toolbar; the Image menu is displayed. Next, 
choose Read from this menu; the Read File(s) dialog box is displayed. In this dialog box, 
choose Home > Documents > Nuke_Projects.
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	 Next, you need to bookmark the Nuke_Projects directory. This will help to navigate to this 
directory with a single click when you import another image.

2.	 Right-click on the left pan of the Read Files(s) dialog box; a shortcut menu is displayed. 
Next, choose Add from the shortcut menu; the Edit favorite dialog box is displayed, as 
shown in Figure 3-86.

Figure 3-86  The Edit favorite dialog box

3.	 Change the name of the bookmark in the Name field or use the default name. Next, 
select the script browser, geo browser, misc browser, font browser, and python browser 
check boxes and then choose the OK button; a new entry Nuke_Projects is displayed in the 
directory list on the left of the Read File(s) dialog box.

4.	 Choose c03_tut > Media_Files > footprint. Notice that the sequences check box is selected 
by default at the lower left area of the dialog box. As a result, all six files are displayed as 
a single entry in the Directory List section of the dialog box. Clear the sequences check 
box; all six files are displayed as separate entries. Next, select f1.png and choose the 
Open button; the Read1 node is inserted in the Node Graph panel. Also, the Read1 node 
properties panel is displayed in the Properties Bin.

5.	 In the Read tab of the Read1 node properties panel, select the premultiplied check box, 
refer to Figure 3-87.

6.	 Similarly, import all other five images (f2.png to f6.png) to bring them to the Node Graph 
panel. Figure 3-88 displays all the Read nodes in the Node Graph panel.

Merging Images with Background
In this section, you will merge the footstep images with the background. The background will 
be created using the CheckerBoard node.

1.	 Click on the empty area of the Node Graph panel to deselect the selected node if any. 
Next, choose the Image button from the Nodes toolbar; the Image menu is displayed. 
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Choose CheckerBoard from the menu; the CheckerBoard1 node is inserted in the Node 
Graph panel and its properties panel is displayed in the Properties Bin, as shown in 
Figure 3-89.

Figure 3-87  The premultiplied check box selected in the Read1 
node properties panel

Figure 3-88  Images imported in the Node Graph panel

Figure 3-89  The CheckerBoard1 node properties panel

2.	 In the CheckerBoard tab of the CheckerBoard1 node properties panel, set the values of 
the parameters as given next:

	 size: 16			   centerline width: 0
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3.	 Click on an empty area of the Node Graph panel and press M; the Merge1 node is inserted 
in the Node Graph panel.

4.	 Press and hold the left mouse button on the B input of the Merge1 node and then drag 
the cursor to the CheckerBoard1 node; a connection between the CheckerBoard1 and 
Merge1 nodes is established.

5.	 Press and hold the left mouse button on the A input of the Merge1 node and drag the 
cursor to the Read1 node to establish a connection between the two nodes, refer to 
Figure 3-90. You will notice that an additional A input is created on the Merge1 node.

	 Next, you need to display the effect of the merge operation. 

6.	 Select the Merge1 node in the Node Graph panel and then press 1; the output is displayed 
in the Viewer1 panel, as shown in Figure 3-91.

Figure 3-90  The Merge1 node 
connected to the Read1 and 
CheckerBoard1 nodes

Figure 3-91  The output of the Merge1 node

7.	 Similarly, connect all the remaining Read# nodes to the Merge1 node, refer to 
Figure 3-92.

Rendering and Saving the Script
In this section, you will render the script using the Write node.

1.	 Make sure the Merge1 node is selected in the Node Graph panel and then press W; the 
Write1 node is connected to the Merge1 node and its properties panel is displayed in the 
Properties Bin.

2.	 In the Write tab of the Write1 node properties panel, click on the folder icon corresponding 
to the file parameter; the Write1: Select file(s) dialog box is displayed. In this dialog box, 
navigate to \Documents\Nuke_Projects\c03_tut\Render and then append c03_tut1_rndr.jpeg 
to the path displayed in the pathname field. Next, choose the Save button. 
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Figure 3-92  All the Read# nodes connected to the Merge1 node

	 You will notice jpeg is automatically selected in the file type drop-down and some additional 
parameters are displayed in the Write1 node properties panel. The additional file type 
specific parameters are displayed when you select different file types from the file type 
drop-down.

3.	 Enter 1 in the quality field. This will set the jpeg output quality to maximum.

4.	 Choose the Render button; the Render dialog box is displayed. In this dialog box, accept 
the default values and then choose the OK button; the Progress window is displayed. 
This window will be automatically closed on completion of the rendering process. Next, 
navigate to \Documents\Nuke_Projects\c03_tut\Render using Windows Explorer and then 
double-click on the c03_tut1_rndr.jpeg to view the rendered output.

5.	 Choose File > Save from the menu bar to save the script.

 Tutorial 2
In this tutorial, you will apply various merge algorithms to clouds.png and skyfog.jpeg. Figures 3-93 
and 3-94 show the clouds.png and skyfog.jpeg, respectively. Figures 3-95 and 3-96 show the result 
after using the color-dodge and hard-light algorithms, respectively.
								          (Expected time: 45 min)
 
The following steps are required to complete this tutorial:

a.	 Set the project.
b. 	 Import images.
c.	 Merge images.
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Figure 3-93  The clouds.png image Figure 3-94  The skyfog.jpeg image

Figure 3-95  The output of the 
color-dodge algorithm

Figure 3-96  The output of the 
hard-light algorithm

Setting the Project
As the resolution of images used in this tutorial is PAL 768x576, you need to set the project 
accordingly. In this section, you will specify the project settings.

1. 	 Choose File > New or press CTRL+N; a new NukeX screen is displayed.

2. 	 Choose File > Save from the menu bar; the Save script as dialog box is displayed. In this 
dialog box, navigate to \Documents\Nuke_Projects\c03_tut and then append c03_tut02 to the 
path displayed in the pathname field. Next, choose the Save button to save the script.

3.	 Hover the cursor over the Node Graph panel and press S; the Project Settings panel is 
displayed in the Properties Bin. Make sure the Root tab is chosen in it. Next, in the panel, 
select new from the full size format drop-down; the New format dialog box is displayed. 
In this dialog box, set the values of the fields as given below:

	 name: PAL768x576		 file size w: 768		  file size h: 576
	 pixel aspect: 1.333

	 Next, choose the OK button to close the dialog box. You will notice that new format created 
is displayed in the full size format drop-down as well as in the Viewer1 panel.
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Importing Images
In this section, you will import the clouds.png and skyfog.jpeg images in the script.

1. 	 Choose the Image button from the Nodes toolbar; the Image menu is displayed. Next, 
choose Read from this menu; the Read File(s) dialog box is displayed. In this dialog box, 
choose Home > Documents > Nuke_Projects > c03_tut > Media_Files > clouds.png and 
then choose the Open button; the Read1 node is inserted in the Node Graph panel.

Note
In the Read File(s) dialog box, you can quickly jump to the Nuke_Projects folder by clicking 
on the Nuke_Projects bookmark created in Tutorial 1.

2.	 Import skyfog.jpeg in the script as discussed above. Now, the Read2 node is inserted in the 
Node Graph panel, as shown in Figure 3-97. 

Figure 3-97  The Read# nodes in the Node Graph panel

Merging Images
In this section, you will create a composite using the imported images.

1.	 Select the Read1 node in the Node Graph panel. Next, press and hold SHIFT and then 
select the Read2 node and then press M; the Merge1 node is inserted in the Node Graph 
panel and connections are established between the Read nodes and the Merge1 node, 
refer to Figure 3-98.

	 By default, the first node you selected in the Node Graph panel is connected to the A 
input of the Merge node whereas the second node is connected to the B input. You can 
swap the A and B inputs of a Merge node by first selecting it in the Node Graph panel 
and then pressing SHIFT+X.

2.	 Select the Merge1 node in the Node Graph panel and press 1; the output of the merge 
operation is now displayed in the Viewer1 panel.
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Figure 3-98  The Merge1 node in the Node Graph panel

	 In the Merge tab of the Merge1 node properties panel, over is selected by default in the 
operation drop-down, refer to Figure 3-99. It layers the A input over the B input according 
to the alpha of the A input. The formula used to combine pixels by the over algorithm is 
A+B(1-a). Figures 3-100 to 3-107 show the output of various merge algorithms.

Figure 3-99  The Merge1 node properties panel

Figure 3-100  The output of the 
over algorithm

Figure 3-101  The output of the 
average algorithm
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Figure 3-102  The output of the 
color-dodge algorithm

Figure 3-103  The output of the 
hard-light algorithm

Figure 3-104  The output of the 
multiply algorithm

Figure 3-105  The output of the 
overlay algorithm

Figure 3-106  The output of the 
screen algorithm

Figure 3-107  The output of the 
soft-light algorithm

3.	 In the Merge tab of the Merge1 node properties panel, select soft-light from the operation 
drop-down. Next, select the Video colorspace check box; colors are converted to default 
8-bit colorspace before doing the composite and then the results are converted back to 
linear, refer to Figure 3-108.

4.	 Next, clear the Video colorspace check box.

Note
The alpha and other channels (except rgb) are merged without colorspace conversion. The default 
colorspace for monitor, 8-bit files, and 16-bit files is sRGB.
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Figure 3-108  The output of the Merge1 node

5.	 Select the alpha masking check box; the output of the merge operation is displayed 
according to the PDF/SVG spec, refer to Figures 3-109 and 3-110.

Figure 3-109  The output of the merge 
operation before selecting the alpha 
masking check box

Figure 3-110  The output of the merge 
operation after selecting the alpha 
masking check box

Note
The alpha masking check box is only enabled for those algorithms which make no difference to 
the output, for example, the soft-light algorithm.

6.	 Enter 0.7 in the mix field. 

	 Next, you will modify the metadata.

7.	 Select the Read2 node in the Node Graph panel and then press TAB; the TAB menu is 
displayed. Enter crop in the TAB menu field and then press ENTER; the Crop1 node is 
inserted between the Read2 and Merge1 nodes, as shown in Figure 3-111.

8.	 In the Crop tab of the Crop1 node properties panel, set the values, as shown in 
Figure 3-112. 
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Figure 3-111  The Crop1 node inserted in the Node Graph panel

Figure 3-112  The Crop1 node properties panel

9.	 In the Merge tab of the Merge1 node properties panel, select B from the set bbox to and 
metadata from drop-downs. Figure 3-113 shows the new bounding box.

Figure 3-113  The new bounding box displayed in the Viewer1 panel

	 Next, you will modify the metadata.
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10.	 Select the Merge1 node in the Node Graph panel and then choose the MetaData button 
on the Nodes toolbar; the MetaData menu is displayed. Next, choose ModifyMetaData 
from the menu; the ModifyMetaData1 node is inserted between the Merge1 and Viewer1 
nodes, as shown in Figure 3-114.

Figure 3-114  The ModifyMetaData1 node in the Node Graph panel

11.	 In the ModifyMetaData tab of  the ModifyMetaData1 node properties panel, choose the 
+ button; a placeholder is inserted in the metadata box.

12.	 Now, double-click on the first cell under the key column header; the Pick metadata key 
dialog box is displayed. In this dialog box, select input/height and then choose the OK 
button; the input/height key is displayed in the first cell under the key column header.

13.	 Double-click on the first cell under the value column header; the cell is converted into a 
field. Next, enter 500 in this field and then press ENTER, refer to Figure 3-115.

Figure 3-115  Keys and values displayed in the ModifyMetaData1 node properties panel

14.	 Repeat the process described in steps 11 through 13 to add the input/width key in the 
metadata box and assign it a value of 500, refer to Figure 3-115.
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15.	 Make sure the ModifyMetaData1 node is selected in the Node Graph panel and then 
choose the MetaData button; the MetaData menu is displayed. Next, choose ViewMetaData 
from the menu; the ViewMetaData1 node is inserted between the ModifyMetaData1 and 
Viewer1 nodes in the Node Graph panel.

	 Note that the ViewMetaData tab of the ViewMetaData1 node properties panel that the 
input/height and input/width keys display a value of 500, as shown in Figure 3-116.

Figure 3-116  The ViewMetaData1 node properties panel

16.	 Choose File > Save from the menu bar to save the script. 

	 Next, you need to render the script. For rendering, refer to Tutorial 1.

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following shortcut keys is used to open the Project Settings panel when 
cursor is over the Node Graph panel?

		  (a) M					     (b) K
		  (c) S					     (d) R

2.	 Which of the following shortcut keys is used to add the Grade node to the Node Graph 
panel?

		  (a) G					     (b) Y
		  (c) T					     (d) N
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3.	 To extract a node from a node network, choose __________ from the Edit menu.

4.	 To toggle between enable and disable modes of a node, press _________ .

5.	 The Checkerboard node is used as a _________ for a texture or a background.

6.	 The default colorspace for monitor, 8-bit files, and 16-bit files is __________ .

7. 	 You can select all connected nodes in a node network by pressing __________.

8.	 You can rename a node in the Node Graph panel by pressing __________.

9.	 Press __________ to swap between the A and B inputs of a Merge node. 

10.	 To select all nodes in a script, choose __________ from the menu bar.

11.	 To duplicate a selected node, press __________ .

12.	 Choose Edit > Node > Disable/Enable from the menu bar to enable or disable nodes.  
(T/F)

13.	 The options in the metadata from drop-down are used to specify which input’s node data 
is passed down the node tree. (T/F)

14.	 If a node is selected in the Node Graph panel then on adding a new node, the new node 
will be automatically connected to the selected node. (T/F)

15.	 Wildcards cannot be used in a search string while searching a node by its name. (T/F)

16.	 You can select nodes based on their color, class, and label. (T/F)

 Review Questions 
Answer the following questions:

1.	 Which of the following shortcut keys is used to add the ColorCorrect node to the Node 
Graph panel?

		  (a) W					     (b) C
		  (c) E					     (d) V

2.	 Which of the following combinations of shortcut keys is used to remove the input connector 
of the selected node?

		  (a) CTRL+D				    (b) ALT+K
		  (c) ALT+M				    (d) CTRL+P
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3.	 Which of the following combinations of shortcut keys is used to clone a node?

		  (a) ALT+D				    (b) ALT+K
		  (c) ALT+M				    (d) ALT +P

4.	 Which of the following combinations of shortcut keys is used to force clone a node?

		  (a) CTRL+ALT+D			   (b) CTRL+ALT+SHIFT+K
		  (c) ALT+SHIFT+M			   (d) SHIFT+K

5.	 Which of the following combinations of shortcut keys is used to group nodes?

		  (a) CTRL+G				    (b) CTRL+ALT+G
		  (c) ALT+G				    (d) SHIFT+G

6.	 Which of the following combinations of shortcut keys is used to expand a group?

		  (a) CTRL+G				    (b) CTRL+ALT+G
		  (c) ALT+SHIFT+G			   (d) SHIFT+G

7. 	 To select multiple nodes, press and hold __________ while clicking on the nodes.

8.	 To select all upstream, nodes press and hold __________ while dragging on a node.

9.	 Most of the nodes have input, output, and mask connectors. (T/F)

10.	 You can enter HTML markup while creating a note using the Sticky Note node. (T/F)	

11.	 Press and hold ALT and then click on the Close(x) button of any of the panels to close all 
the properties panels in the Properties Bin. (T/F)

12.	 The M key is used to add the Merge node in the Node Graph panel. (T/F)

13.	 The bounding box is used to speed up processing time. (T/F)

14.	 A node can be exported as a NukeX script. (T/F)

15.	 The mix field in the Merge node properties panel is used to mix the result of the Merge 
node and its input. (T/F)

Answers to Self-Evaluation Test
1. c, 2. a, 3. Extract, 4. D, 5. placeholder, 6. sRGB, 7. CTRL+ALT+A, 8. N, 9. SHIFT+X, 
10. Edit > Select All, 11. ALT+C, 12. T, 13. T, 14. T, 15. F, 16. T


