
Chapter 5

Advanced Dimensioning  
Techniques and 

Base Feature Options

  Learning Objectives 
After completing this chapter, you will be able to:
• Fully defi ne a sketch.
• Dimension the true length of an arc.
• Create solid base extruded features.
• Create thin base extruded features.
• Create solid base revolved features.
• Dynamically rotate the view to display the model in all directions.
• Apply materials to models.
• Change the appearance of models.
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In this chapter, you will learn about the  advanced dimensioning techniques that are used to 
dimension the sketches. In SolidWorks, you can apply all possible relations and dimensions 
to a sketch by using a single tool. Also, you will learn about the tools that are used to convert 
a sketch into a base feature of a model in the Part environment. 

TUTORIALS
Tutorial 1

In this tutorial, you will create the model shown in Figure 5-1. The sketch of the model is 
shown in Figure 5-2. First, you will draw the sketch of the model and make it fully defi ned 
by applying the required relations and dimensions in the sketching environment. Next, you 
will convert the sketch into a model by extruding it in two directions. The parameters for 
extruding the sketch are given next.

Direction 1
Depth = 10 mm
Draft angle = 35 degrees

Direction 2
Depth = 15 mm
Draft angle = 0 degree

After creating the model, you will turn on the option to display shadows and also apply Alloy 
Steel (SS) material to the model. Additionally, you will determine the mass properties of the 
model.          (Expected time: 30 min)

Figure 5-1  Solid Model for Tutorial 1 Figure 5-2  Sketch of the model
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The following steps are required to complete this tutorial:

a. Create the sketch of the model using the sketching tools, refer to Figures 5-3 through 
5-14.   

b. Apply dimensions to the sketch and make it fully defi ned, refer to Figure 5-15.
c. Invoke the Extruded Boss/Base tool and convert the sketch into a model, refer to 

Figures 5-30 through 5-33.
d. Display the shadow of the model, refer to Figure 5-35. 
e. Assign materials to the model, refer to Figure 5-36.
f. Determine the mass properties of the model, refer to Figure 5-37.

Drawing the Sketch 
1. Start SolidWorks and then invoke a new Part document. Next, choose the Sketch button 

from the Sketch CommandManager and then select the Front Plane as the sketching 
plane to invoke the sketching environment.

As evident from Figure 5-2, the sketch of the model is symmetric about its centerline, 
therefore, you need to draw it with the help of a mirror line. 

2. Increase the display of the drawing area by using the Zoom In/Out tool and invoke 
the Centerline tool from the Line fl yout of the Sketch CommandManager.

3. Move the line cursor to a location whose coordinates are close to -102 mm, 0 mm, and 0 
mm and specify the start point of the centerline at this point.

4. Move the line cursor horizontally toward the right and specify the endpoint of the centerline 
when the length of the line shows a value close to 204.

5. Exit the Centerline tool.

6. Choose the Zoom to Fit button from the View (Heads-Up) toolbar to fi t the sketch 
into the drawing area.

7. Choose the  Centerpoint Arc Slot button from the Slot fl yout; the arrow cursor is 
replaced by the arc cursor and the Slot PropertyManager is displayed.

8. Move the arc cursor close to the origin. Click to specify the center point of the slot, when the 
cursor snaps to the origin. Next, move the cursor toward the right and below the horizontal 
axis and click when the arc cursor displays a value close to 69, refer to Figure 5-3.  
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9. Move the arc cursor in a counterclockwise direction. Click to specify the endpoint of the 
arc slot when the value of the angle above the arc cursor is close to 60 degrees; a reference 
slot is attached to the cursor. Specify a point in the drawing area where the value of the 
width of the slot is close to 26 mm, refer to Figure 5-4.

Figure 5-4  The sketch after drawing the slotFigure 5-3  Specifying the start point of the slot

10. Choose the Add Relation button from the Display/Delete Relations fl yout; the 
Add Relations PropertyManager is invoked. 

11. Right-click in the drawing area and then choose the Clear Selections option from the 
shortcut menu to clear selections from the selection set. Select the centerline and the 
coordinate point of the slot, as shown in Figure 5-5; the Coincident button is highlighted 
in bold in the Add Relations rollout of the Add Relation PropertyManager. This indicates 
that the coincident relation is the most appropriate relation for the selected entities.

12. Choose the Coincident button from the Add Relations PropertyManager.

13. Choose the OK button from the Add Relations PropertyManager or choose OK from 
the confi rmation corner. The sketch after applying the coincident relation is shown in 
Figure 5-6. 

Figure 5-6  The sketch after applying the 
coincident relation

Figure 5-5  The centerline and the coordinate 
point to be selected 

 Next, you need to make the centerline as the mirror line and draw the sketch on the upper 
side of the mirror line. On doing so, the same sketch is refl ected on the other side of the 
mirror line.
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14. Choose Tools > Sketch Tools > Dynamic Mirror from the SolidWorks menus and select 
the centerline; the centerline is converted into a mirror line.

15. Invoke the  Line tool from the Sketch CommandManager. Next, move the cursor 
to the point whose coordinates are close to -61, 0, and 0 and then click to specify 
the start point of the line.

16. Move the cursor vertically upward and draw a line of length close to 7.

17. Move the cursor toward the left at an angle of 166-degree with the horizontal axis. Refer 
to the Parameters rollout of the PropertyManager for the angle measurement. Next, click 
to specify the endpoint of the line where the length of the line is close to 30; the mirrored 
entities are created on the other side. 

18. Move the cursor vertically upward and specify the endpoint of the vertical line where the 
length of the line above the line cursor displays a value close to 10. 

19. Move the cursor horizontally toward right and specify the endpoint where the length of 
the line above the line cursor displays a value close to 42.ss

20. Move the cursor downward at an angle of 285-degree, refer to the Parameters rollout 
of the PropertyManager for angle measurement. Next, specify the endpoint of the line 
where the length is close to 15. The sketch after drawing the inclined line is shown in 
Figure 5-7. 

21. Move the cursor horizontally toward the right and specify the endpoint when the line 
cursor snaps to the left arc of the slot, refer to Figure 5-8. Next, exit the Line tool.

Figure 5-8  Sketch after creating the horizontal 
lines

Figure 5-7  Sketch after drawing the inclined line

22. Choose the Circle button from the Sketch CommandManager.

23. Move the cursor to the endpoint of the slot and specify the center point of the circle when 
the center point is highlighted. Next, move the cursor horizontally toward the right and 
click the left mouse button when the radius of the circle above the circle cursor is close to 
7.5. Figure 5-9 shows the sketch after drawing circles.



5-6          SolidWorks 2012: A Tutorial Approach
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

24. Right-click in the drawing area and then choose Recent Commands > Dynamic Mirror 
Entities to exit the Dynamic Mirror tool.

25. Invoke the  Circle tool again from the Sketch CommandManager.

26. Move the cursor to the origin and click to specify the center point of the circle when cursor 
snaps to the origin. Next, move the cursor horizontally toward the right and click the left 
mouse button when the radius of the circle above the circle cursor shows a value close to 
6.5.

27. Similarly, create one more circle of radius 19 approximately, with its center point at 
the origin. The sketch after drawing the required slot, circles, and lines is shown in 
Figure 5-10.

Figure 5-10  Sketch after drawing slots, 
circles, and lines

 Figure 5-9  Sketch after drawing two circles

 Trimming Unwanted Entities
 After drawing the sketch, you need to trim some of the unwanted sketched entities using 

the Trim Entities tool.

1. Choose the Trim Entities button from the Sketch CommandManager to invoke 
the Trim PropertyManager.

2. Choose the Trim to closest button from the Options rollout of the PropertyManager, if 
it is not chosen by default; the select cursor is replaced by the trim cursor.

3. Select the entities to be trimmed, refer to Figure 5-11; the entities are dynamically trimmed. 
Next, exit the tool.

Note
While trimming the unwanted sketches of the slot, the SolidWorks 2012 message box is displayed 
with the message This trim operation will destroy the slot entity. Do you want to continue?. 
Choose the OK button to continue the trimming operation.

 As the trim operation destroys the slot entities, you need to apply the tangent and symmetric 
relations to them.
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4. Apply the tangent and symmetric relations to the slot entities by using the Add Relations 
PropertyManager, refer to Figure 5-12. Also, make sure that the center points of both the 
circles that having diameter 15 mm merge with the center points of the arcs of the slot.

Figure 5-12  Relations to be applied to the 
slot entities

Figure 5-11  The entities to be trimmed 

 Filleting Sketched Entities
 Next, you need to fi llet the sketched entities. Fillets are generally added to avoid the stress 

concentration at sharp corners.

1. Choose the Sketch Fillet button from the Sketch CommandManager; the Sketch Fillet 
PropertyManager is displayed. Next, set the value 5 in the Radius spinner of the 
PropertyManager.

2. Select the set of entities one by one to apply fi llet, refer to Figure 5-13. Next, exit the 
Sketch Fillet tool. Figure 5-14 shows the sketch after applying fi llets of radius 5 mm.

Figure 5-14  Sketch after fi lleting the 
sketched entities

Figure 5-13  The entities to be fi lleted 

 Adding Dimensions to the Sketch
 Next, you need to apply dimensions to the sketch and fully defi ne it.  

1. Choose the Smart Dimension button from the Sketch CommandManager; the 
arrow cursor is replaced by the dimension cursor.
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2. Select the construction arc of the slot that is displayed as a construction entity; a radius 
dimension is attached to the cursor. Move the cursor away from the sketch toward the 
right and place the dimension; the Modify dialog box is displayed.

3. Enter 69 in the Modify dialog box and press ENTER, refer to Figure 5-15.

4. Select the upper arc of the slot; a radius dimension is attached to the cursor. Move the 
cursor away from the sketch toward the right and place the dimension.

5. Enter 13 in the Modify dialog box and press ENTER, refer to Figure 5-15.

6. Select the origin and the start point of the construction arc of the slot; a dimension is 
attached to the cursor. Next, select the endpoint of the construction arc; an angular 
dimension is attached to the cursor. Place the angular dimension outside the sketch.

Tip. In SolidWorks, you can also apply angular dimensions to an arc by using the Smart 
Dimension tool. To do so, you need to select two endpoints and the center point of the 
arc. 

7. Enter 60 as the value of the angular dimension in the Modify dialog box and press ENTER, 
refer to Figure 5-15.

8. Select the upper right circle; a diameter dimension is attached to the cursor. Place the 
dimension outside the sketch.

9. Enter 15 as the value of the diameter dimension in the Modify dialog box and press 
ENTER, refer to Figure 5-15.

10. Select the upper right horizontal line and the lower right horizontal line that coincides 
with the trimmed circle; a vertical dimension is attached to the cursor. Move the cursor 
vertically upward and click to place the dimension.

11. Enter 20 in the Modify dialog box and press ENTER, refer to Figure 5-15

12.  Select the circle at the origin; a diameter dimension is attached to the cursor. Move the 
cursor upward and place the dimension outside the sketch.

13. Enter 13 as the value of the diameter dimension in the Modify dialog box and press 
ENTER.

14. Select the outer trimmed circle and place the radius dimension outside the sketch.

15. Enter 19 as the value of the radial dimension in the Modify dialog box and press 
ENTER.

16. Select the upper right inclined line; a dimension is attached to the cursor. Next, select 
the upper left horizontal line; an angular dimension is attached to the cursor. Place the 
dimension above the upper left horizontal line, refer to Figure 5-15.
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17. Enter 75 as the value of the angular dimension in the Modify dialog box and press 
ENTER.

18. Select the origin and the lower endpoint of the lower right inclined line. Move the cursor 
vertically downward and place the dimension. Enter 49 in the Modify dialog box and 
press ENTER, refer to Figure 5-15.

19. Select the origin and the middle left vertical line, refer to Figure 5-15. Move the cursor 
vertically downward and place the dimension below the previously placed dimension.

20. Enter 61 in the Modify dialog box and then press ENTER.

21. Select the origin and the lower endpoint of the outer left vertical line, refer to Figure 5-15. 
Move the cursor vertically downward and place the dimension below the last placed 
dimension.

22. Enter 90 in the Modify dialog box and then press ENTER.

23. Select the upper left and lower left inclined lines, refer to Figure 5-15; an angular dimension 
is attached to the cursor. Move the cursor horizontally toward the left and place the 
dimension.

24. Enter 28 as the value of the angular dimension in the Modify dialog box and then press 
ENTER.

25. Select the upper left and the lower horizontal lines; a linear dimension is attached to the 
cursor. Move the cursor horizontally toward the left and place the dimension.

26. Enter 50 in the Modify dialog box and then press ENTER.

27. Select the lower endpoint of the upper left vertical line and the upper endpoint of the 
lower left vertical line; a linear dimension is attached to the cursor. Move the cursor 
horizontally toward the left and click to place the dimension.

28. Enter 30 in the Modify dialog box and then press ENTER.

29. Add the remaining dimensions to the sketch and make it a fully defi ned sketch. Figure 5-15 
shows the fully defi ned sketch.

Tip. In SolidWorks, you can also fully defi ned a sketch by applying the required relations and 
dimensions to it automatically using the Fully Defi ne Sketch tool. To fully defi ne a sketch, 
draw the sketch using the standard sketching tools. Next, choose the Fully Defi ne Sketch 
button from the Display/Delete Relations fl yout in the Sketch CommandManager; the 
Fully Defi ne Sketch PropertyManager will be displayed. You can also right-click and choose 
the Fully Defi ne Sketch option from the shortcut menu to display this PropertyManager. 
Using this PropertyManager, you can make all the entities of a sketch or selected entities of 
a sketch fully defi ned by selecting the respective option from the PropertyManager.
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Figure 5-15  Sketch after applying all relations and dimensions

 Extruding the Sketch
 After creating the sketch, you need to convert it into a base feature. To do so, you need to 

invoke the  Extruded Boss/Base tool and extrude the sketch using the parameters given 
in the tutorial description.

1. Choose the Features tab from the CommandManager to display the  Features 
CommandManager tools.

The Features CommandManager provides all the modeling tools that are used in feature-based 
solid modeling.

2. Choose the Extruded Boss/Base button from the Features CommandManager; 
the sketch is automatically oriented to the  trimetric view and the  Boss-Extrude 
PropertyManager is displayed, as shown in Figure 5-16. 

Figure 5-16  The Boss-Extrude PropertyManager
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Figure 5-17  Preview of the feature being extruded

 Also, you will notice that the preview of the 
base feature is displayed in the temporary 
shaded graphics with the default values, 
refer to Figure 5-17. Additionally, an 
arrow will appear in front of the sketch. 
Note that the closed loops that are 
available inside the outer loop of the 
sketch are automatically subtracted from 
the outer loop while extruding it, refer to 
Figure 5-17.

The Extruded Boss/Base tool is used to add 
material to the area defi ned by a sketch. 

3. Make sure that the Sketch Plane option is selected in the  Start Condition drop-down list 
of the From rollout in the Boss-Extrude PropertyManager. 

In the Boss-Extrude PropertyManager, the Sketch Plane option is selected by default in the 
Start Condition drop-down list of the From rollout. Therefore, the resulting extrude feature 
will start from the sketching plane on which the sketch is drawn. This option is mostly used 
while creating the extrude feature, refer to Figure 5-17. In SolidWorks, you can also select 
the Surface/Face/Plane, Vertex, and Offset options from the Start Condition drop-down 
list of the From rollout. The Surface/Face/Plane option is used to start the extrude feature 
from a selected surface, face, or a plane, instead of the plane on which the sketch is drawn. 
Figure 5-18 shows the sketch to be extruded and the face to be selected as the face to start 
extrusion. Figure 5-19 shows the resulting extrude feature created on the selected face up to 
a specifi ed depth. 

Figure 5-18  Sketch to be extruded and the reference 
face selected

Figure 5-19  Resulting extruded feature

The  Vertex option of the Start Condition drop-down list is used to specify a vertex as a reference 
for starting the extrude feature. Figure 5-20 shows the sketch to be extruded and the vertex to 
be selected as a reference to start the extrude feature. Figure 5-21 shows the resulting extruded 
feature created on the selected vertex to the defi ned depth.
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Figure 5-20  Sketch to be extruded and a reference 
vertex to be selected

Figure 5-21  Resulting extruded feature

The  Offset option of the Start Condition drop-down list is used to start the extrude feature at 
an offset distance from the plane on which the sketch is drawn. Figure 5-22 shows the preview 
of a sketch drawn on the front plane and being extruded using the Offset option. Figure 5-23 
shows the resulting extruded feature created at an offset distance from the sketching plane.

Figure 5-22  Sketch being extruded using the Offset 
option

Figure 5-23  Resulting extruded feature

4. Make sure that the  Blind option is selected in the  End Condition drop-down list of the 
Direction 1 rollout of the Boss-Extrude PropertyManager.

The End Condition drop-down list of the Direction 1 rollout in the PropertyManager is 
used to defi ne the termination of extrude features in one direction from the sketching plane. 
Note that the Blind option is selected by default in this drop-down list and is used to defi ne 
the termination of the extrude features by specifying the depth of extrusion. The depth of 
extrusion is specifi ed in the Depth spinner of the PropertyManager. The other options of this 
drop-down list are discussed next.
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Mid Plane
The  Mid Plane option of the End Condition drop-down list is used to create a feature 
by extruding the sketch equally in both the directions of the plane on which the sketch 
is drawn. 

Up To Vertex
The  Up To Vertex option of the End Condition drop-down list is used to defi ne the 
termination of a feature at a virtual plane that is parallel to the sketching plane and passes 
through the selected vertex. The vertex can be a point on an edge, a sketched point, or 
a reference point. Figure 5-24 shows a sketch drawn on a plane at an offset distance and 
Figure 5-25 shows the model in which the sketch is extruded up to the selected vertex.

Figure 5-25  Sketch extruded using the Up To 
Vertex option

Figure 5-24  Sketch drawn on a plane created 
at an offset distance and the vertex to be selected

Up To Surface
The  Up To Surface option of the End Condition drop-down list is used to defi ne the 
termination of a feature up to a selected surface or face. Figure 5-26 shows the sketch 
drawn at an offset distance and the surface to be selected. Figure 5-27 shows the resulting 
feature extruded up to the selected surface.

Figure 5-27  Sketch extruded using the Up 
To Surface option

Figure 5-26  Sketch drawn on a plane created at 
an offset distance and the surface to be selected
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Offset From Surface
The  Offset From Surface option is used to defi ne the termination of a feature on a virtual 
surface that is created at an offset distance from the selected surface.

Up To Body
The  Up To Body option is used to defi ne the termination of the extruded feature to 
another body. Figure 5-28 shows the sketch for the extruded feature and a body up to 
which the sketch will be extruded. Figure 5-29 shows the resulting feature.

Figure 5-29  Sketch extruded using the Up To 
Body option

Figure 5-28  Sketch to be extruded and the body to 
be selected for the extrude feature

Up To Next
The  Up To Next option is used to extrude the sketch from the sketching plane to the 
next surface that intersects the feature. This option will be available in the End Condition 
drop-down list only after you create a base feature.

Through All
The  Through All option is used to extrude the sketch from the sketching plane to all the 
existing geometric entities. This option will be available in the End Condition drop-down 
list only after you create a base feature.

5. Set the value of the Depth spinner to 10 mm. 

Tip. In SolidWorks, you can also extrude a sketch to a blind depth by dragging the feature 
dynamically using the mouse. To do so, move the mouse to the arrow displayed in the preview; 
the move cursor will be displayed and the color of the arrow will also be changed. Left-click 
once on the arrow; a scale will be displayed. Now, move the cursor; the value of the depth 
of extrusion will change dynamically on this scale as you move the cursor. Left-click again 
to specify the termination of the extruded feature. 

6. Choose the  Draft On/Off button from the Direction 1 rollout of PropertyManager 
to enable the Draft Angle spinner.
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The Draft On/Off button is used to specify a draft angle while extruding a sketch. Applying a 
draft angle results in tapering of the resulting feature. By default, the feature will be tapered 
inward. However, if you want to taper the feature outward, you need to select the Draft outward 
check box that is displayed below the Draft Angle spinner. 

7. Set the value of the  Draft Angle spinner to 35 mm; the preview of the feature is modifi ed, 
as shown in Figure 5-30. 

 These are the settings for direction 1. Next, you need to specify the settings for 
direction 2.

8. Select the Direction 2 check box to invoke the Direction 2 rollout. As soon as you invoke 
the Direction 2 rollout, another arrow is displayed in the preview of the feature. Also, 
the material is added along the second direction with the default depth value, refer to 
Figure 5-31.

Figure 5-31  Preview of the extrude feature 
after invoking the Direction 2 rollout

Figure 5-30  Preview of the extrude feature after 
applying the draft angle

The  Direction 2 rollout is used to extrude a sketch with different values in the second direction 
of the sketching plane. You can expand this rollout by selecting the check box available in its 
title bar. This check box will not be enabled, if the Mid Plane option is selected in the End 
Condition drop-down list of the Direction 1 rollout. The options available in the Direction 
2 rollout are similar to the options in the Direction 1 rollout.

9. Choose the  Draft On/Off button in the Direction 2 rollout to turn it off, if it is on. This 
is because you do not require the draft angle in the second direction.

10. Set 15 in the  Depth spinner of the Direction 2 rollout as the depth in the second 
direction. 

11. Choose the OK button to create the feature or choose OK from the confi rmation corner. 
The feature is created and its name is displayed in the FeatureManager Design Tree.
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The  FeatureManager Design Tree that is available on the left side of the drawing area is one 
of the most important components of SolidWorks screen. It contains information about the 
default planes, materials, lights, and all other features that are added to a model. When you 
add features to a model using the modeling tools, the added features are also displayed in the 
FeatureManager Design Tree. It stores and displays all features in hierarchical manner.

 It is recommended that you change the view to isometric after creating the feature to view 
it properly.

12. Choose the  View Orientation button from the View (Heads-Up) toolbar; the View 
Orientation fl yout is displayed, refer to Figure 5-32. Next, choose the Isometric button 
from it. The isometric view of the resulting solid model is shown in Figure 5-33.

Figure 5-32  The View Orientation fl yout Figure 5-33  Resulting extruded feature

The tools available in the View Orientation fl yout are used to change the view orientation as 
per the predefi ned standard views. This fl yout also provide tools to display a model in two 
or four viewports. 

Displaying the Shadow
 As mentioned in the tutorial description, you need to display the shadow of the model, 

if it is not displayed by default. You can turn on the display of the shadow using the 
View (Heads-Up) toolbar.

1. Choose  View Settings from the View (Heads-Up) toolbar; the View Setting fl yout is 
displayed, refer to Figure 5-34. Next, choose the  Shadows In Shaded Mode button 
from this fl yout to display the model with shadow, as shown in Figure 5-35. 

Figure 5-34  The View Setting fl yout
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Figure 5-35  Model with the display of shadow turned on

 Assigning Materials to the Model
 As mentioned in the tutorial description, you need to apply Alloy Steel (SS) material to 

the model. When you apply material to a model, the physical properties such as Density, 
Young’s modulus, and so on of the selected material are assigned to the model. As a result, 
when you calculate the mass properties of the model, they will be based on the physical 
properties of the material applied.

1. Choose Edit > Appearance > Material from the SolidWorks menus; the  Material dialog 
box is displayed. Alternatively, right-click on the Material <not specifi ed> option in the 
FeatureManager Design Tree and select Edit Material from the shortcut menu to invoke 
the Material dialog box.

The Material dialog box displays the list of all materials available in the  material library of 
SolidWorks. A number of material families are available in the left area of the Material dialog 
box. When you click on the (+) sign located on the left of a material family, it displays a list 
of all materials under that family. 

Figure 5-36  Model after assigining the Alloy Steel 
(SS) material

2. Select Alloy Steel (SS) from the list of 
materials available in the Steel family; 
all the properties of the Alloy Steel (SS) 
material are displayed on the right side 
of the dialog box.

3. Choose the Apply button from the 
Material dialog box and then choose 
the Close button to exit. The model, 
after assigning the material, is shown in 
Figure 5-36.
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 Determining the Mass Properties of the Model
 After assigning the material to the model, you need to calculate the mass properties of 

the model.

1. Choose the  Mass Properties tool from the Evaluate CommandManager; the 
Mass Properties dialog box with the mass properties of the current model is 
displayed, as shown in Figure 5-37.

The Mass Properties tool is used to determine the mass properties of the part or assembly that 
is available in the current session. Note that this tool will not be enabled, if there is no solid 
model available in the current session. The mass properties include density, mass, volume, 
surface area, center of mass, principal axes of inertia and principal moments of inertia, and 
moments of inertia.

Figure 5-37  The Mass Properties dialog box
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Saving the Model
1. Choose the Save button from the Menu Bar to invoke the Save As dialog box. Next, browse 

to \Documents\SolidWorks Tutorials and create a new folder with the name c05.

2. Enter c05_tut01 as the name of the model in the File name edit box of the Save As dialog 
box and then choose the Save button. The model is saved at the location \Documents\
SolidWorks Tutorials\c05.

3. Choose File > Close from the SolidWorks menus to close the document.

Tutorial 2
In this tutorial, you will open the sketch drawn in Tutorial 2 of Chapter 2. Then you will 
apply the required relations and dimensions to the sketch to make it fully defi ned. You will 
also determine the section properties of the sketch and convert it into a revolve feature by 
revolving the sketch through an angle of 270 degrees, as shown in Figure 5-38.      
          (Expected time: 45 min)

Figure 5-38  Model for Tutorial 2

 The following steps are required to complete this tutorial:

a. Open Tutorial 2 of Chapter 2, refer to Figure 5-41.
b. Save this document in the c05 folder with a new name.
c. Apply required relations and dimensions to the sketch, refer to Figures 5-40 through 

5-42.
d. Determine the section properties of the sketch, refer to Figure 5-43.
e. Invoke the Revolved Boss/Base tool and revolve the sketch through an angle of 270 

degrees, refer to Figure 5-44.
f. Change the current view to isometric view and then save the document.
g. Save the model.
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Opening Tutorial 2 of Chapter 2
As the required document is saved in the c02 folder, fi rst you need to open it in SolidWorks 
2012.

1. Choose the Open button from the SolidWorks menus; the Open dialog box is 
displayed. 

The Open tool is used to open an existing SolidWorks part, assembly, or drawing document. 
You can also import fi les from other applications saved with standard fi le formats by using 
this tool.

2. Browse to the SolidWorks Tutorials folder and then double-click on the c02 folder. 

3. Select the c02_tut02.sldprt document and then choose the Open button from the dialog 
box to open the selected part in the current session of SolidWorks. 

 As the sketch was saved in the sketching environment in Chapter 2, it opens in the sketching 
environment.

Saving the Document in c05 Folder
 When you open a document of some other chapter, it is recommended that you fi rst save 

the document with some other name in the folder of the current chapter (document) 
before modifying it. This ensure that the original document of the other chapter is not 
affected if any modifi cations are made in the current document.

1. Choose the File > Save As from the SolidWorks menus; the Save As dialog box is 
displayed.

2. Browse to \SolidWorks Tutorials\c05 folder and then enter c05_tut02 as the new name of 
the document in the File name edit box and then choose the Save button to save the 
document.

 The document is saved with the new name and is now displayed in the drawing area, as 
shown in Figure 5-39.

Applying Relations and Dimensions
 As mentioned earlier, some of the relations are automatically applied to a sketch while 

drawing.

1. Apply the horizontal relation to the horizontal lines and vertical relation to the vertical 
lines of the sketch, if they are not applied automatically while drawing the sketch. You 
can apply relations by using the Add Relations PropertyManager or the pop-up toolbar 
that will be displayed after selecting the entity.  

2. Apply the equal relation to those entities of the sketch that are of same length, refer to 
Figure 5-40.
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Figure 5-39  Sketch displayed in the drawing area Figure 5-40  Equal relations to be applied

3. Invoke the Smart Dimension tool from the Sketch CommandManager and apply the 
linear diameter dimensions to the sketch, as shown in Figure 5-41. 

 Next, you will apply the horizontal ordinate dimensions to the sketch by using the 
Horizontal Ordinate Dimension tool. You can also use the Smart Dimension tool for 
applying remaining dimensions to the sketch to make it fully defi ned.    

4. Choose the  Horizontal Ordinate Dimension button from the Smart Dimension 
fl yout in the Sketch CommandManager.

The Horizontal Ordinate Dimension tool is used to dimension the horizontal distance of the 
selected entities from the specifi ed datum.  

Note
When you apply an ordinate dimension, the Modify dialog box will not be displayed to modify 
the dimension value. In this case, to modify dimensions, fi rst you need to place all the ordinate 
dimensions, exit the tool, and then double-click on the dimensions and modify the values.

5. Select the upper right vertical line of the sketch as the datum entity from where the 
remaining entities are to be measured; the dimension value 0 is attached with the 
cursor. 

6. Move the cursor vertically upward to a small distance and place the dimension by clicking 
the left mouse button, refer to Figure 5-42.

7. Select the other vertical entities of the sketch to apply the ordinate dimensions, refer to 
Figure 5-42. The fully defi ned sketch after applying the required relations and dimension 
is shown in Figure 5-42.

 Determining the  Section Properties of the Sketch
 As mentioned in the tutorial description, you need to determine the section properties 

of the sketch.

1. Click on the Evaluate tab available in the CommandManager to invoke the Evaluate 
CommandManager. 
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Figure 5-41  Sketch after applying the linear 
diameter dimensions

Figure 5-42  Sketch after applying the horizontal 
ordinate dimensions

2. Choose the  Section Properties button from the Evaluate CommandManager; the Section 
Properties dialog box is displayed, as shown in Figure 5-43. Also, a 3D triad is placed at 
the centroid of the sketch. 

 The Section Properties dialog box displays the section properties of the sketch such as 
the area, centroid relative to sketch origin, centroid relative to the part origin, moment 
of inertia, polar moment of inertia, angle between principle axes and sketch axes, and 
principle moment of inertia.

Figure 5-43  The Section Properties dialog box
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The Section Properties tool enables you to determine the section properties of the sketch 
in the sketching environment. You can also determine the section properties of the selected 
planar face in the Part mode or in the Assembly mode by using this tool. 

Note
The section properties of closed sketches with non-intersecting closed loops can only be determined 
by using the Section Properties tool. 

 Revolving the Sketch
 Now, you need to convert the sketch into a revolve feature by revolving it through an angle 

of 270 degrees around the horizontal centerline. 

1. Choose the Features tab from the CommandManager to display the Features 
CommandManager. 

2. Choose the  Revolved Boss/Base button from the Features CommandManager; 
the sketch is automatically oriented in the trimetric view and the Revolve 
PropertyManager is displayed. As the sketch has two centerlines, SolidWorks 
cannot determine which one of them has to be used as an axis of revolution. 
As a result, you are prompted to select the axis of revolution.

3. Select the horizontal centerline, which has been used to create linear diameter dimensions, 
as the axis of revolution; the preview of a complete revolved feature in temporary shaded 
graphics is displayed in the drawing area. If the preview of the model is not displayed 
properly in the current view, you need to fi t the view of the model into the drawing 
area. 

4. Choose the Zoom to Fit button from the View (Heads-Up) toolbar or press the F 
key on the keyboard to fi t the preview of the model into the drawing area.

5. In the Direction 1 rollout, select the Blind option in the Revolve Type drop-down list, if it 
is not selected by default. Set the value of the Direction 1 Angle spinner to 270 and click 
anywhere on the screen; the preview of the revolved model is modifi ed accordingly. 

Note
In SolidWorks, you can specify the start and end conditions for a revolve feature similar to that 
of an extrude feature.

 Note that if the horizontal centerline is drawn from left to right, then the direction of 
revolution has to be reversed to get the required model. You can reverse the direction of 
revolution by choosing the Reverse Direction button that is available at the left side of 
the Revolve Type drop-down list in the PropertyManager. 
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Tip. In SolidWorks, the right-hand thumb rule is followed for determining the direction 
of revolution. This rule states that if the thumb of the right hand points in the direction of 
the axis of revolution, the direction of the curled fi ngers will determine the default direction 
of revolution. 

6. Choose the OK button from the Revolve PropertyManager; the revolved feature is 
created. 

7. Choose the View Orientation button from the View (Heads-Up) toolbar; a fl yout is 
displayed. Choose the Isometric option from the fl yout to orient the model to isometric 
view. The isometric view of the fi nal revolved model is shown in Figure 5-44. 

Figure 5-44  Final model for Tutorial 2

Saving the Model
 As the name of the document was specifi ed at the beginning, now you need to choose the 

Save button to save the document.

1. Choose the Save button from the Menu Bar to save the model. If the SolidWorks warning 
box is displayed, choose Yes from it to rebuild the model before saving. The model is 
saved at the location \Documents\SolidWorks Tutorials\c05

2. Choose File > Close from the SolidWorks menus to close the document.

Tutorial 3
In this tutorial, you will create the model shown in Figure 5-45. The sketch of the model is 
shown in Figure 5-46. First you will draw the outer loop of the sketch of the model and make it 
fully defi ned by applying the required relations and dimensions in the sketching environment. 
Next, you will convert that outer loop of the sketch into a thin extruded model by adding 
thickness of 3 mm in the inward direction. The depth of extrusion is 20 mm. After creating 
the model, add a color of your choice to it.     (Expected time: 45 min)
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The following steps are required to complete this tutorial:

a. Create the sketch of the model. Apply the required relations and dimensions to make the 
sketch fully defi ned, refer to Figure 5-47.   

b. Invoke the Extruded Boss/Base tool and convert the sketch into a thin extrude feature, 
refer to Figure 5-48.

c. Apply color to the model, refer to Figure 5-50.
d. Save the model.

Figure 5-45  Solid Model for Tutorial 3 Figure 5-46  Sketch of the model

Drawing the Sketch 
 As mentioned in the tutorial description, you will fi rst draw the outer loop of the sketch 

and then convert it into a thin extrude feature.

1. Start SolidWorks and then invoke a new Part document. Next, choose the Sketch button 
from the Sketch CommandManager and then select the Front Plane as the sketching 
plane to invoke the sketching environment.

2. Draw the outer loop of the sketch by using the sketching tools and apply the required 
relations and dimensions to it, refer to Figure 5-47.

Figure 5-47  Sketch of the outer loop
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 Creating Thin Extrude Feature 
 Now, you will convert the sketch into a thin extruded feature by adding thickness of 3 mm 

in the inward direction and depth of 20 mm.

1. Choose the Features tab from the CommandManager to display the Features 
CommandManager. 

2. Choose the Extruded Boss/Base button from the Features CommandManager; 
the sketch is automatically oriented in the trimetric view and the Boss-Extrude 
PropertyManager is displayed. Also, the preview of the extrude feature is 
displayed in the drawing area with the default values.

3. Select the Mid Plane option from the End Condition drop-down list; the preview of 
the extrude feature is modifi ed and the material is added to both sides of the sketching 
plane. 

The Mid Plane option is used to create a feature by extruding the sketch equally in both 
the directions of the plane on which the sketch is drawn. If the total depth of the extruded 
feature is 30 mm, it will be extruded 15 mm toward the front and 15 mm toward the back of 
the sketching plane.

4. Set the value of the Depth spinner to 20 mm.

 As it is evident from Figure 5-45 that the model is a thin extrude feature, therefore you 
need to invoke the Thin Feature rollout of the PropertyManager to add the thickness 
inward direction in the sketch.  

5. Select the check box available on the title bar of the  Thin Feature rollout; the Thin Feature 
rollout is invoked and the preview of the extrude feature is changed to thin extrude feature 
using the default values. 

The thin extruded features can be created using a closed or an open sketch. If the sketch is a 
closed sketch, the thickness will be specifi ed inside or outside the sketch to create a cavity inside 
the feature. However, if the sketch is an open sketch, the thickness will be specifi ed below or 
above the sketch. Also, if the sketch to be extruded is an open sketch, the Thin Feature rollout 
will be invoked automatically on invoking the Extrude PropertyManager.  

6. Make sure that the One-Direction option is selected in the Type drop-down list of the 
Thin Feature rollout.

The options provided in the Type drop-down list are used to specify the method used for 
defi ning the thickness of the thin feature. The One-Direction option of this drop-down list is 
used to add the thickness to one side of the sketch. The Mid-Plane option is used to add the 
thickness equally on both sides of the sketch and the Two-Direction option is used to create 
a thin feature by adding different thicknesses on both sides of a sketch.
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7. Set the value of thickness in the Thickness spinner to 3; the preview of the feature is 
modifi ed and the thickness of 3 mm is added in the outward direction. 

 
 Now, you need to reverse the direction of thickness toward the inward direction.

8. Choose the Reverse Direction button available on the left of the Type drop-down 
list to reverse the direction of thickness.

9. Choose the OK button from the Boss-Extrude PropertyManager; the thin extruded feature 
is created, refer to Figure 5-48. Next, change the orientation of the model to an isometric 
view by choosing the Isometric button from the View Orientation fl yout. The isometric 
view of the model after adding thickness and extrusion depth is shown in Figure 5-48.

Figure 5-48  Model after adding thickness and extrusion depth 

Adding Color to the Model
 As mentioned in the tutorial description that after completing the model, you need to 

add color of your choice to it.

1. Choose Edit > Appearance > Appearance from the SolidWorks menus; the  color 
PropertyManager is displayed on the left side of the drawing area, as shown in Figure 5-49. 
Ensure that the Select Part button is chosen and the name of the part is displayed in the 
Selected Entities area of the Selected Geometry rollout in the PropertyManager. 

 Note that, as soon as the color PropertyManager is invoked, the  Appearance,  Scenes, 
 and Decals task pane is also displayed on the right-side of the drawing area. 

In the color PropertyManager, the Selected Geometry rollout has fi ve buttons on its left, 
namely Select Part, Select Faces, Select Surfaces, Select Bodies, and Select Features. These 
buttons are used as fi lters for making a selection to assign the color to a model. For example, 
if you want to assign a color to the face of the model, clear all existing selections from the 
Selected Entities area and then choose the Select Faces button from the Selected Geometry 
rollout. This allows you to select only faces of the model. 
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2. Select a color from the Color rollout of the PropertyManager; the selected color is displayed 
in the Color display area of the Color rollout. You can also set the required color using 
the Pick to Color display area. 

 Alternatively, you can use the Red Component of Color, Green Component of Color, 
and Blue Component of Color spinners to set the color. The color selected in this rollout 
will be applied to the selected part, features, faces, or bodies.

3. Choose the OK button from the PropertyManager; the selected color is applied to the 
model. Figure 5-50 shows the fi nal model.

Figure 5-49  The color 
PropertyManager

Figure 5-50  The fi nal model for Tutorial 3

Saving the Model
 Now, you need to save the model in the c05 folder.

1. Save the model in the c05 folder with the name c05_tut03. The model is saved at the 
location \Documents\SolidWorks Tutorials\c05

 
2. Choose File > Close from the SolidWorks menus to close the document.
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SELF-EVALUATION TEST
Answer the following questions and then compare them to those given at the end of this 
chapter:

1. In SolidWorks, a sketch is revolved using the Boss-Extrude PropertyManager. (T/F)

2. You can also specify the depth of extrusion dynamically in the preview of the extruded 
feature. (T/F)

3. In SolidWorks, the right-hand thumb rule is followed for determining the direction of 
revolution. (T/F)

4. You can invoke the drawing display tools such as Zoom to Fit even if the preview of a 
model is displayed on the screen. (T/F)

5. The __________ tool enables you to determine the mass properties of the part or assembly 
that is available in the current session.

6. The __________ button of the Boss-Extrude PropertyManager is used to taper the 
feature.

7. Which of the following tools is used to apply the horizontal ordinate dimensions?

  (a) Smart Dimension   (b) Horizontal Ordinate Dimension
  (c) Horizontal Dimension  (d) Hor Ordinate Dimension

8. The __________ check box is used to create a feature with different values in both directions 
of the sketching plane.

9. The thin extruded feature can be created using a  ___________ or an ___________  
sketch.

10. The ___________ tool is used to reverse the direction of material.

REVIEW QUESTIONS
Answer the following questions:

1. When you invoke the Extruded Boss/Base tool or the Revolved Boss/Base tool, the view 
is automatically changed to a __________.

2. The thin extruded features are created by invoking the __________ rollout of the 
PropertyManager.

3. The Section Properties tool is available in the __________ CommandManager.
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4. The __________ option is used to defi ne the termination of a feature on a virtual surface 
created at an offset distance from the selected surface.

5. In SolidWorks, you can change the appearance of a model by assigning color to it. (T/F)

6. In SolidWorks, you can display the drawing area in multiple viewports. (T/F)

7. If you clear the Draft outward check box of the Boss-Extrude PropertyManager; the 
feature will be tapered outward. (T/F)

8. Which of the following tools is used to determine the section properties of the sketch?

  (a) Properties    (b) Sec Properties
  (c) Section Properties   (d) None

9. In which of the following features can you convert an open sketch?

  (a) Thin feature    (b) Solid feature
  (c) Both     (d) None of these

10. Which of the following tools is used to make a sketch fully defi ned in SolidWorks?

  (a) Fully Defi ne Sketch   (b) Smart Dimension
  (c) Both     (d) None of these

EXERCISES
Exercise 1

Create the model shown in Figure 5-51. The dimensions of the model are shown in Figure 5-52. 
The extrusion depth of the model is 35 mm.      (Expected time: 30 min)

Figure 5-51  Model for Exercise 1 Figure 5-52  Dimensions of the model for 
Exercise 1
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Exercise 2
Create the model shown in Figure 5-53. The dimensions of the model are shown in Figure 5-54. 
The angle of revolution about the axis is 180 degrees.     (Expected time: 25 min)

Figure 5-53  Model for Exercise 2 Figure 5-54  Dimensions of the model for 
Exercise 2

Exercise 3
Create the model shown in Figure 5-55. The dimensions of the model are shown in Figure 5-56. 
After creating the model, apply the copper material to it. Also, determine the mass properties 
of the model.            (Expected time: 35 min)

Figure 5-55  Model for Exercise 3 Figure 5-56  Dimensions of the model for 
Exercise 3
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Exercise 4
Create the model shown in Figure 5-57. The dimensions of the model are shown in 
Figure 5-58.           (Expected time: 30 min)

Figure 5-57  Model for Exercise 4 Figure 5-58  Dimensions of the model for 
Exercise 4

Answers to Self-Evaluation Test
1. F, 2. T, 3. T, 4. T, 5. Mass Properties, 6. Draft On/Off, 7. Horizontal Ordinate Dimension, 
8. Direction 2, 9. closed, open, 10. Reverse Direction


