
Chapter 1

Getting Started with 
Autodesk Alias Design

After completing this chapter, you will be able to:
• Understand the basic concepts of surfacing.
• Know system requirements for Alias Design 2012.
• Get familiar with Alias Design 2012 interface.
• Get familiar with Alias Design view windows and workfl ows.
• Use Marking menus, Viewing Panel, and hotkeys.
• Use snapping tools.
• Customize shelves.
• Use the Object Lister and the Scene Block Diagram window.
• Open, save, and close fi les in Alias Design.
• Change preferences in Alias Design.
• Change color schemes.

Learning Objectives
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 INTRODUCTION TO Alias Design
Welcome to the world of Computer Aided Industrial Designing (CAID) with Alias. If you are 
a new user of this software package, you will be joining thousands of users who are using this 
creative and conceptual design software package. If you are familiar with the previous releases 
of this software, you will be able to upgrade your designing skills with tremendously improved 
release of Alias.

Alias Design, a product of Autodesk Inc. USA, is a complete set of interactive surfacing and 
concept-based design software. Alias meets all requirements of industries based on industrial 
design workfl ow. This software provides you with a complete set of tools that are required for 
conceptual design of surfaces and their realization into real world surface models. You can 
communicate your design intent to this software by sketching, building the model, and then 
evaluating it to realize your design. Alias provides you the fl exibility in taking design decisions 
and prevents design from being modifi ed or lost during the engineering phase. This software 
also enables the designers and engineers to collaborate with each other to help ensure that 
aesthetics and functional requirements of design are taken care of. Alias provides you with the 
specialized design tools to meet the specifi c design requirements that are listed below:

1. Concept Exploration: The concept is explored through sketching or painting, editing, 
and modifying images. The concept exploration also involves creating sketches and then 
importing 3D CAD data to make sure the designs are feasible.

2. Design Modeling: Design modeling is an iterative process that involves application of 
modeling tools to sculpt a 3D model. This process also includes editing 3D models by 
using the advanced modeling techniques so that the specifi ed requirements of the project 
are met.

3. Visualization and Communication: This concept involves analyzing the concepts and the 
model to provide feedback to help you understand the design intent. Feedback is given in 
the form of shading, rendering, and animation. You can use this feedback to communicate 
better ideas to the software to get the best possible design solution.

4. Precision Surface Modeling: In this phase of design, you can create a high quality 
surface model by using the advanced surface creation tools. These tools enable you to 
maintain continuity and alignment between different parts of the model. Also, you can 
render high quality surface models in less time.

5. Reverse Engineering: Reverse engineering involves effective handling of scanned data 
such that it can be extracted properly. The extracted data enables you to evaluate the shape 
information of the model. If you modify the physical model, the digital data corresponding 
to that model is updated accordingly. 

6. Productive Environment: Alias Design provides the intuitive user interface (UI) that 
helps you work quickly and effi ciently. You can even customize the user interface to suit 
the workfl ow that you are using for the design process.
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7. Process Integration: It involves exchanging digital design data with CAD software while 
maintaining the design integrity at engineering stage. You can use CAD translators to 
convert the data into the industry-standard data formats such as IGES, STEP, DXF, DES, 
and so on. The design data of a model created in Alias can be exchanged to other software 
packages such as CATIA, Pro/ENGINEER, and SolidWorks. You can even prevent the 
potential problems that can occur while transferring the data into these CAD software 
packages.

 BASIC TERMS USED IN Alias Design
Before you start working with Alias Design, you need to know the basic terms used in this 
software. Getting acquainted to these terms will help you easily accustom to the software. 
As you go through this book, you will know about these terms in detail as well as learn their 
applications. A brief description of these terms is given next.

 Point
A point is a location defi ned in three-dimensional space. A point can be located by specifying 
three spatial coordinates. A point has no size or unit, but it specifi es the location.

 Curve
A curve is a line that deviates from straightness with smooth and continuous transition. A curve 
represents data in the space. A curve can be represented by nonparametric or parametric 
equation. The nonparametric equation of a curve relates coordinates directly with each other. 
For example, the equation of a circle of radius 1 unit and center (0,0) in nonparametric form 
is expressed as  

 x2+y2=1

The parametric equation of a curve expresses coordinates of the curve in terms of another 
variable known as parameter. For example, the equation of a circle in the parametric form is 
expressed as 

 x=Cos t, y=Sin t

where x and y are the coordinates of the points on the curve and are the functions of the 
parameter t.

 Surface
A collection of points in three-dimensional space is known as a surface. A surface can be 
defi ned as the locus of points that satisfy a constraint equation in the form of  F (X, Y, Z)=0. 
The parametric form of a surface is expressed as

 x=X(u,v)
 y=Y(u,v)
 z=Z(u,v)

where X, Y, and Z are the functions of two parameters, u and v. 
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The simplest form of a surface is the plane surface. Other examples of surfaces are cylinders, 
spheres, cubes, and so on.

 REPRESENTATION OF CURVES
Curves are categorized into different types based on their representation. The types of curves 
are discussed next.

 Cubic Spline
Cubic spline is a curve that passes through a number of data points and is based on 
interpolation technique. Cubic spline curves have global control characteristics; therefore, when 
you modify a single data point, the shape of the entire curve is modifi ed, which sometimes is 
not desired. As a result, cubic splines are not popular in design applications.

 Bezier Curve
Bezier curves were developed by French Engineer, Pierre Bezier at Ranault Automobile 
Company to design automobile bodies. These curves blend at joints and are completely defi ned 
by four consecutive points (x0, y0), (x1, y1), (x2, y2), and (x3, y3). A Bezier curve passes through 
the fi rst and fourth points only, but the second and third points defi ne the slope of the curve at 
end points. You can change the direction of the curve at joints by specifying the positions of the 
second and third points. The limitation of Bezier curves is that when you modify the position 
or shape of one point, it affects the entire curve rather than that local point. Bezier curves are 
generally used in computer graphics to produce curves that are smooth on all scales. 

 B-Spline Curves
B-Spline curves provide another effective method to generate curves. B-Splines were developed 
for ship building. In addition to the characteristics of bezier curves, B-Splines enjoy some 
other unique advantages. These curves, unlike the Bezier or Cubic spline, provide local 
control by using control points. This means that modifying one control point affects only 
that part of the curve that lies near the control point. You can also add more control points 
without affecting the degree of curve. In other words, the degree of curve is independent of 
the number of control points.

 NURBS
NURBS, an acronym for Non-Uniform Rational B-Splines, encompasses all characteristics 
of the Bezier and B-spline curves. Non-uniform refl ects the parametric nature of the curve, 
which allows you to have multi-knots in it. In a NURBS curve, a local vertex is defi ned by a set 
of four-dimensional control points. A NURBS curve is expressed in homogenous space as
                    
 P=(Wixi, Wiyi, Wizi, Wi)

where x
i
, y

i
, and z

i
 are the coordinates of a particular point and W is the weight associated with 

each control point. The weight can be viewed as an extra shape parameter.
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 REPRESENTATION OF SURFACES
Surfaces are designed in patches in which each patch corresponds to a rectangular array of data 
points in u-v space. Surfaces are categorized into different types based on their representation. 
The types of surfaces are discussed next.

 Bicubic Surface
A parametric bicubic surface connects four corner data points and uses a bicubic equation. The 
characteristics of a bicubic surface are same as that of bicubic curve. The control characteristics 
of a bicubic surface are global.

 Bezier Surface
Bezier surface is an extension of bezier curves in two parametric directions, u and v. A Bezier 
surface consists of control points that are set in an order to build a topological surface. The 
characteristics of a Bezier surface are same as that of Bezier curve.

 B-Spline Surface
B-Spline surface is an extension of B-Spline curves. The degree of surface is independent of 
control points. You can control B-Spline surfaces locally. The characteristics of a B-Spline 
surface are same as that of B-Spline curve.

 NURBS Surface
A NURBS surface is an extension of NURBS curve. The NURBS surface consists of two 
parametric directions, u and v. The NURBS surface can be defi ned by its order, weighted 
control points, and a knot vector.  A knot vector defi nes the sequence of parameter values that 
specify how and where the control points affect the NURBS surface. The order of the surface 
specifi es the number of nearby control points that affect a given control point in the surface. 
The characteristics of a NURBS surface are same as that of NURBS curve.

 Autodesk Alias PRODUCTS
Autodesk Alias family provides a range of products to meet unique creative requirements of 
the entire industrial design workfl ow. These products cater to various needs of industries. 
Alias provides you with the following products:

 Autodesk Alias Design
Autodesk Alias Design is a complete concept design package. Using this package, you can create 
and communicate design concepts by using sketches, illustrations, visualization, animation, 
rendering, prototyping, data sharing, and so on. In this book, you will be working on the 
Alias Design product.

 Autodesk Alias Automotive
Autodesk Alias Automotive is used for creating automotive design and styling, 3D modeling, 
rendering, and data integration. It enables you to realize your fi nal product from concept 
sketches through Class-A surfacing. 
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 Autodesk Alias Surface
This product of Autodesk Alias is used to develop Class-A surfaces by using the most sophisticated 
technical features of the software such as reverse engineering, real-time diagnostics, scan-data 
processing, and so on. This product provides you with a set of tools to attain a high level of 
quality, precision, and accuracy required in automotive styling.

 SYSTEM REQUIREMENTS
The system requirements to install Alias Design on your system as well as to ensure smooth 
functioning of this product are as follows: 

• System Unit: An Intel Pentium Core2Duo, AMD Opteron work station running Microsoft 
Windows Vista 32 and 64 bit; Microsoft Windows XP Professional SP 2 or later; Windows 
XP Professional x64 edition SP1or later. 

• Memory: 2 GB of RAM (4 GB or higher recommended)
• Hard disk: 3 GB for installation 
• Internal/External drives: A DVD drive or a shared DVD drive accessed through a network 

mapped drive for the software installation.
• Display: A graphic color display compatible with the selected platform-specifi c graphic 

adapter. The minimum recommended monitor size is 17 inches.
• Graphics card: ATI FireGL, ATI OpenGL, NVIDIA graphics card with minimum of 256 

MB video memory. (512 MB or higher video memory strongly recommended) 
• Mouse: A three button mouse.

 STARTING Alias Design 2012
To start Alias Design 2012, choose Start > Programs (or All Programs) > Autodesk 
> Alias 2012 > Alias 2012, as shown in Figure 1-1. Alternatively, double-click on its shortcut 
icon on the desktop of your computer; the Autodesk Alias Design 2012 window will be 
displayed momentarily, as shown in Figure 1-2. As Alias Design gets started, a Design screen 
is displayed, as shown in Figure 1-3. In addition to the Design screen, the LearningMovies 
window is displayed. This window enables you to view the short movie clips related to the 
basic commands used in Alias Design. The commands include creating objects such as curves, 
surfaces, and primitives, transforming objects, selecting objects, and so on. Figure 1-4 shows 
different components of the Alias Design screen. In this fi gure, the display of grids has been 
turned off for better visibility of screen components. 

Select the Don’t show again check box from the LearningMovies window and close the 
window. As a result, next time when you start a new session of Alias Design, this window will 
not open automatically. However, you can invoke this window manually by choosing Help > 
Learning Movies from the menu bar or by choosing the Learning movies button from the 
Control Panel.    
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Figure 1-1  Starting Alias Design 2012 from the taskbar

Figure 1-2  The Autodesk Alias Design 2012 window



1-8            Learning Autodesk Alias Design
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 1-3  Initial screen of the Alias Design 2012 interface

Alias Design 2012 INTERFACE
The initial screen of the Alias Design 2012 interface is shown in Figure 1-4. The components 
of the Alias Design 2012 interface are title bar, Palette, Shelves window, menu bar, promptline, 
Layer bar, and Control Panel. The Shelves window, Control Panel, and Palette may or may 
not be visible when you start Alias Design 2012 for the fi rst time. They can be made visible 
by choosing the Windows option from the menu bar and choosing the required option from 
the menu. Various components of the Alias Design 2012 screen/interface are discussed next.

 Menu Bar
The menu bar is located at top of the interface screen of Alias Design interface, as shown in 
Figure 1-5. It contains different menus that have options to control Alias Design programs 
such as preferences, layouts, objects, and views. When you click a menu, a fl yout showing 
different options is displayed. 
 

Promptline
The promptline is located below the menu bar. It displays instructions for the currently 
selected tool, error messages that occur while using a tool, numeric feedback, and the input 
that you key in.

 Promptline History
The Promptline History icon is located on the left of the promptline. When you click on this 
icon, a list of promptline messages will be displayed in the Promptline History window, as 
shown in Figure 1-6. The Promptline History window is essential in case you want to know 
all promptline messages that you may not view in the promptline.
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Figure 1-4  Different components of the Alias Design 2012 interface screen

Figure 1-5  The menu bar
 

Figure 1-6  The Promptline History window

Layer Bar
The Layer bar is located below the promptline. You can create a new layer, assign one or more 
objects to a new layer, select a layer, set the current layer as an active layer, or delete a layer. 
It is used to organize, assign, and manage objects on the screen. You can view the options 
associated with a layer in the Layers fl yout that is displayed on choosing Layers from the menu 
bar, as shown in Figure 1-7. The options in the Layer bar are discussed in the next chapter.

 Work Area 
The work area or window area includes all windows of the interface screen. It occupies maximum 
space of the interface window. When you start Alias Design for the fi rst time, the view windows 
will be displayed. These view windows are used to display entities in orthographic or perspective 
views. The view windows will be discussed later in the chapter.
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 Palette
By default, the Palette is displayed on the left of the interface screen.   

Figure 1-7  The Layers 
fl yout

Figure 1-8 shows the Palette. You can move it to any position on the 
interface screen by clicking on the title bar and then dragging it. If 
the Palette is not displayed by default, you can invoke it by choosing 
Windows > Palette from the menu bar. Alternatively, you can choose 
the Palette button from the Menu Shortcut tab of the Control 
Panel to invoke the Palette. The Palette contains tools for creating, 
editing, and manipulating objects. These tools are displayed on 
expanding the Palette. The Palette can be expanded by choosing 
the tabs in it. The partial view of the expanded Palette is shown in 
Figure 1-9.

 Control Panel
By default, the Control Panel is displayed on the right of the interface 
screen, refer to Figure 1-4. If it is not already displayed, you can invoke 
it by choosing Windows > Control Panel from the menu bar. This 
panel has different modes that control modeling, visualization, and 
painting. This panel be used as a combination of the Shelves window, tools, shading, and 
display controls to provide a focussed workfl ow. It also contains some learning tools and menu 
shortcuts that are used to invoke respective tools quickly. You can also customize the Control 
Panel by inserting tools or the whole tab from the Palette and the Shelves window so that you 
can select the tools from the Control Panel. 

Figure 1-8  The Palette Figure 1-9  The partial view 
of the expanded Palette 
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 Shelves Window 
By default, the Shelves window, as shown in Figure 1-10, is located 

Figure 1-10  The Shelves 
window

at the bottom of the interface screen. You can move this window to 
any position by clicking and then dragging. You can change the 
position of the Shelves window in the interface screen. To do so, 
choose Preferences > Interface from the menu bar; a cascading 
menu will be displayed. Click on the box on the right of the Palette/
Shelves Layout option in the fl yout; the Palette/Shelves Layout 
dialog box will be displayed. Next, select the required radio button 
from the Shelf Position area of the dialog box to specify the new 
position for the Shelves window. This window is also used to change 
the position of the Palette. If the Shelves window is not displayed, 
you can invoke it by choosing Windows > Shelves from the menu 
bar. 
 

Status Bar
The status bar is displayed at the bottom of the interface window. 
The status bar displays the status of the current or active tool. Also, 
it displays the function of the tool. 

 HISTORY VIEW
The History View window shows the stepwise procedure of creating 
a model or a feature, as shown in Figure 1-11. The History View 
window can be invoked by choosing Windows > Information > 
History View from the menu bar. You can view the objects and 
the operations used in creating the model by viewing this window. 

 Alias Design WINDOWS/LAYOUTS
When you start Alias Design for the first time, four   

Figure 1-11  The History View 
window

                       
windows/layouts are displayed on the interface screen, refer 
to Figure 1-3. Each of these windows occupies a quarter of 
the interface screen. The size, position, and number of 
windows can be changed according to your need. Though, 
all the four windows are visible on the screen interface yet 
you can work only in one window at a time. The window in 
which you are currently working is called active window and 
it is highlighted in a white border. You can activate a window 
by clicking on its title bar.

 Types of Window
There are three types of windows in Alias Design: Orthographic, Perspective, and Paint. 
These windows are discussed next.
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 Orthographic Window
As the name suggests, the orthographic window shows two-dimensional view of the object 
in three different views. These views are top, front, and right. You can zoom and pan the 
orthographic views.

 Perspective Window
In this window, you can see the 3D view of the model. You can zoom, rotate, and pan a model in 
the perspective view. You can control the perspective view in better way by using the ViewCube. 
The ViewCube will be discussed later in this chapter.

 Paint Window
This window is used for viewing canvases and overlays. This window is not visible when you 
create a new fi le. You can make this window visible by choosing Layouts > Paint from the 
menu bar or by pressing the F3 key. You can resize, zoom, pan, and tilt or rotate the Paint 
window. You can close the Paint window by choosing the Close box given on top left corner 
of the window.   

 Navigating the Windows
You can control the camera views in Alias Design to get the best possible view. The three 
options to do so are track (pan), dolly (zoom), and tumble (rotate). The SHIFT and ALT keys 
with the mouse buttons play important roles in performing these tasks. These options are 
discussed next.

 Track (Pan)
The track (pan) option is used to move the scene or view for better visibility. Tracking is done 
by pressing the SHIFT and ALT keys and then dragging the middle mouse button to track 
up, down, left, and right.

 Dolly (Zoom)
The dolly (zoom) option is used to increase or decrease the size of the scene. You can dolly a 
scene or view by pressing the SHIFT and ALT keys and then dragging the right mouse button. 
Dragging the right mouse button upward zooms in the scene or view, whereas dragging the 
button downward zooms out the scene or view.

 Tumble (Rotate)
The tumble (rotate) option is used to rotate or tilt the scene or view to get better orientation 
of the model. Tumbling is done only in the Perspective window. It is done by pressing the 
SHIFT and ALT keys and then dragging the left mouse button.

 Controlling the Window Display
In Alias Design, you can rearrange, resize, move, and close windows. You can also control the 
display of windows as well as their numbers. These operations are discussed next.
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 Arranging Windows
By default, four windows will be displayed on starting a new fi le in Alias    

Figure 1-12  The 
Layouts menu

Design. These windows occupy equal space on the interface screen. But, 
you can change the number, position, and display of these windows by using 
the options in the Layouts menu. Choose Layout from the menu bar; the 
Layouts menu will be displayed, as shown in Figure 1-12. This menu shows 
various options to select a window or windows. You can also use hotkeys to 
toggle between different windows. Hotkeys will be discussed later in this 
chapter.

 
 Resizing a Window
You can change the size of a window by using the resize arrows located at 
each corner of the window, as shown in Figure 1-13. To resize a window, drag 
the resize arrow diagonally upward or downward by using the left mouse 
button. The size of the window increases or decreases depending upon the 
direction of movement of the cursor and the window selected for resizing. 
You can click on the Maximize box given at top right corner of each window 
to resize the window to its maximum. After clicking on this box, the active window fi lls the 
entire space of the interface screen. This allows you to work in a single window. You can move, 
close, and resize the windows by using the controls located on the borders of the windows. The 
controls of the windows are Close box, Title bar, Maximize box, Show, ViewCube, and Resize 
corners. The Close box control is used to close a window. The Title bar displays the name of the 
window such as top, front, right, and perspective. The Title bar also displays the controls such 
as Rotate, Zoom in/out, and Track. The Maximize box control is used to display the window 
in the entire interface screen. The Resize corners control is used to increase or decrease the 
size of the window depending upon the direction used for dragging. The ViewCube is used to 
control the view of the object in the Perspective window and is discussed later in this chapter. 
Figure 1-13 shows the Perspective window with the controls mentioned above.

Figure 1-13  The Perspective window showing different controls
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Note
The grid display has been turned off and the background color of the window has been changed 
to white for clear visibility of controls. You can toggle the grid display on or off by choosing 
WindowDisplay > Toggles > Grid from the menu bar. The background color of the window is 
changed by using the User Colors dialog box. To invoke this dialog box, choose Preferences > 
Interface > User Colors from the menu bar. The options in the User Colors dialog box will 
be discussed later in this chapter.

 Moving a Window
You can move a window anywhere on the interface screen. To move a window, click on the 
title bar of the window and then drag it to the desired position. The window will be snapped 
to the new location. When you do so with other windows, the windows get stacked one above 
the other. The stacking of windows is called overlapping. To activate a window from the stack, 
click on it; the required window will come to the front of the interface screen. You can reset 
these disorganized windows to the default layout by choosing Layouts from the menu bar and 
then choosing the required option from it.

Note
If you choose Layouts > All Windows from the menu bar, a cascading menu will be displayed. 
The options in the cascading menu enable you to view the windows arranged in different patterns 
such as all windows, front/perspective, top/perspective, right/perspective, sketchpad, and so on.

 Creating a User-defi ned Layout
You can create a user-defi ned layout in Alias Design. In a user-defi ned layout, you can arrange 
different windows and resize them as per your requirement. You can save a user-defi ned layout 
and retrieve it. To create a user-defi ned layout, you need to close all windows/layouts from 
the interface by clicking on the Close boxes of the respective windows. Next, choose a window 
from the Layouts menu; the chosen window will be displayed. Next, click on the Maximize 
box to reduce the size of the window. You can also drag corners to resize the window. Click and 
drag the title bar of the window to place it at the required position, as shown in Figure 1-14.

Similarly, invoke other layouts and then rearrange and reposition them according to your 
requirement; a user-defi ned layout is displayed, as shown in Figure 1-15. After creating the 
layout, you need to save it. To do so, choose Layouts > User Windows > Save Current Layout 
from the menu bar; the Save Windows dialog box will be displayed. Browse to the required 
location folder and then enter the name in the Object name edit box. Next, choose the Save 
button; the user-defi ned layout will be saved at the specifi ed location. You can use this layout to 
create your models and designs. To retrieve a saved layout, choose Layouts > User Windows 
> Retrieve Layout from the menu bar; the Restore Windows dialog box will be displayed. 
Browse to the folder where the required layout is saved. Next, select the layout and then choose 
the Open button from the dialog box; the selected layout will be retrieved. 

Note
The default layout has been used throughout this textbook. The default layout consists of the 
Top, Perspective, Left, and Back windows sharing the same amount of space in the interface.
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 USING MARKING MENUS
Marking menus enable you to invoke different tools. Marking menus contain fewer tools than 
the Shelves window and the Palette, but they help you invoke tools faster. Marking menus do 
not appear by themselves. To display these menus, press the SHIFT and CTRL keys and click 
a mouse button. It is recommended not to use Marking menus unless you are an advanced 
user of Alias Design. You should continue to use the tools from the Palette or the Shelves 
window till you get familiar with them. The mouse buttons work in coordination with the 
SHIFT and CTRL keys. 

Figure 1-14  The Front window after resizing and repositioning

Figure 1-15  A user-defi ned layout



1-16            Learning Autodesk Alias Design
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

By default, tools in Marking menus are grouped into three categories based on the mouse 
button used for invoking them. Marking menus displayed by using the left mouse button are 
used as selection tools, whereas Marking menus displayed by using the middle mouse button 
are used as translation tools. Similarly, marking menus displayed by using the right mouse 
button are used as display control tools. The selection procedure of different Marking menus 
is discussed next. 

Press and hold the SHIFT and CTRL keys and then press the left mouse button; the tools used 
for the selection of entities will be displayed radially along the cursor, as shown in Figure 1-16. 
Press and hold the SHIFT and CTRL keys and then press the middle mouse button; the tools 
used for translation will be displayed, as shown in Figure 1-17. Similarly, use the right mouse 
button with the SHIFT and CTRL keys pressed to view the tools that are used for displaying 
entities, as shown in Figures 1-18. To invoke a tool from any of these Marking menus, drag the 
cursor on the required tool; a dark thick line will be displayed and the tool will be highlighted 
in blue. Figure 1-19 shows the Curves tool being invoked by using the Marking menus.

Figure 1-17  Marking menus displayed on 
pressing the middle mouse button

Figure 1-16  Marking menus displayed on 
pressing the left mouse button

Figure 1-19  Invoking the Curves tool by 
using the Marking menu

Figure 1-18  Marking menus displayed on 
pressing the right mouse button
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You can edit Marking menus to rearrange the tools contained in them. To do so, choose the 
<Edit Marking Menu> option from Marking menus that are displayed with the left mouse 
button; the MarkingMenus editor will be displayed, as shown in Figure 1-20. The tools in 
this editor are grouped under three tabs: Selection, Translation, and Display. To view tools 
grouped under a tab, choose the respective tab from the MarkingMenus editor. You can 
rearrange tools within the three tabs of the MarkingMenus editor. To do so, drag the required 
tool from one of these tabs with the middle mouse button and then drop it in another tab. You 
can also invoke the MarkingMenus editor by choosing Preferences > Interface > Marking 
Menus from the menu bar.

Figure 1-20  The MarkingMenus editor

 VIEWING PANEL
In Alias Design, the Viewing Panel is not available by default. Therefore, you    

Figure 1-21  The 
default Viewing 
Panel

 
need to set the preference for displaying it. To do so, choose the Preferences 
option from the menu bar; a fl yout will be displayed. Choose the box icon 
on the right of the General Preferences option in the fl yout; the General 
Preferences dialog box will be displayed. From this dialog box, choose the 
Viewing tab and then choose the VIEW PANEL option in the View Control 
area. The Viewing Panel only appears in the Perspective window. This 
panel allows you to switch from the perspective view to a user-defi ned or a 
default view of the model. To display this panel, activate the Perspective 
window and then press the SHIFT and ALT keys. The Viewing Panel remains 
displayed as long as you keep the SHIFT and ALT keys pressed. Figure 1-21 
shows the default Viewing Panel. To expand this panel, click on the Open/
Close bookmark section icon; the Bookmark section will be displayed. 
Figure 1-22 shows different options in the Viewing Panel which are discussed next.

 Preset View Area
The Preset view area contains arrows that are used to display front, back, top, bottom, and side 
views of the model. The four diagonal arrows in this area represent three-quarter view of the 
model. To display a view, click on the corresponding arrow in this area. The top or bottom 
view is displayed by choosing the top or bottom view icon located at the center of this option.

 Look At
Click on this icon to orient and center the object in such a way that it fi ts best in the view 
window. The view obtained by clicking on the Look At icon involves automatic application of 
zooming, tracking, or rotation of the canvas.
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Figure 1-22  The expanded Viewing Panel 

 Plane view
Choose this button to use the construction plane as the ground (view) plane. On doing 
so, the views will behave like orthographic views. The preset views will track and dolly like 
orthographic views.
 

 Perspective
This check box is selected by default and is used to display preset views as perspective views. 
The preset views will track and dolly like the perspective view.
 

 Bookmarks
The Bookmarks button is used to create a user-defi ned view and save it in the Viewing Panel. 
To do so, modify the current view by using various display controls such as dolly, track, tumble, 
and so on. Next, click on the New option in the Bookmarks area; a bookmark will be created 
and saved in the Bookmark section. You can create any number of user-defi ned views and 
then save them. You can delete, add, toggle between the existing bookmarks by clicking on 
the Edit option. When you click on the Edit option, the Bookmarks lister will be displayed, 
as shown in Figure 1-23. The use of different buttons in this  is discussed next.

Figure 1-23  The BookMarks lister

 New Bookmark
To create a new bookmark, change the view in the active window according to your 
requirements. Next, choose the New Bookmark button from the BookMarks lister; a 
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new bookmark will be created. The function of the New Bookmark button is similar to the 
function of the New option in the Bookmarks section of the Viewing Panel.

 Prev Bookmark 
Choose the Prev Bookmark button to switch to the previous bookmark from the current 
bookmark. The current bookmark will be highlighted in green outline.

 Next Bookmark
Choose the Next Bookmark button to switch to the next bookmark from the current 
bookmark.

 Toggle Camera Only Mode
This button is used to toggle between the display states of the model in the current 
bookmark. While creating a bookmark, the current camera view and the display settings 
such as hardware shading and diagnostic shading of a model are captured. You can 

toggle between these two settings by using the Toggle Camera Only Mode button. By default, 
the camera view and the display setting are captured in the current bookmark. As a result, the 
view as well as the shading of an object is displayed when you click on the current bookmark. 
If you choose the Toggle Camera Only Mode button again, the current bookmark will switch 
to the camera mode only. 

 Cycle Bookmark                       
The Cycle Bookmark button is    

Figure 1-24  The Cycle Bookmarks Option dialog 
box

 
used to display bookmarks in 
cyclic manner. On choosing this 

button, the available bookmarks will be 
displayed one after the other at specifi ed 
intervals. You can stop the cyclic display 
of bookmarks by clicking anywhere in the 
window. To change the cycle time of 
displaying bookmarks, double-click on 
the Cycle Bookmark button; the Cycle 
Bookmark Option dialog box will be 
displayed, as shown in Figure 1-24. By 
default, 2 is displayed in the Bookmark cycle time edit box. Enter a new value in this edit 
box to change the cycle time of bookmarks. You can also repeat the cyclic display of bookmarks 
by selecting the Repeat cycles check box from this dialog box.

 Publish Bookmark
Choose the Publish Bookmark button to print the current bookmark as an image fi le. 
On choosing this button, the Publish Bookmark dialog box will be displayed. Browse 
to the location of the bookmark to be published in the Save in drop-down list and 

enter the name in the Object name edit box. Next, choose the Save button; the bookmark 
will be published at the specifi ed location. You can change the fi le type of the bookmark to 
be published by using the Publish Bookmark Options dialog box, as shown in Figure 1-25. 
You can invoke this dialog box by double-clicking on the Publish Bookmark button from the 
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BookMarks lister. You can use this dialog box to specify the size and quality of image of the 
published bookmark. 

Delete Bookmark 
To delete a bookmark from the BookMarks lister; activate the bookmark by selecting 
it; the selected bookmark will be highlighted in green outline. Next, choose the Delete 
Bookmarks button from the BookMarks lister; the selected bookmark will be deleted.

 

Figure 1-25  The Publish Bookmark Options dialog box

 Bookmarks
Bookmark icons display the bookmarks that have been created. By default, bookmarks are 
named as BM, BM#2, BM#3, and so on. To change the name of a bookmark, press and hold 
the CTRL key and then double-click on the required bookmark icon; the confi rm message 
box will be displayed. In the confi rm message box, enter a new name in the Enter Tool Label 
fi eld and then choose the OK button; the bookmark will be renamed. The active (selected) 
bookmark is displayed in green outline. 

You can select multiple bookmarks with the CTRL key. An active bookmark is highlighted in 
light-green border, whereas the other selected bookmarks are highlighted with white-border. 
You can delete, move, and rename a bookmark. You can also create different shelves of 
bookmarks. The creation of shelves will be discussed later in the chapter. 
 

ViewCube
Autodesk Alias Design 2012 provides you with an option to change the view of a model freely 
in 3D space. This option is called ViewCube. The ViewCube is a 3D navigation tool that allows 
you to switch between the standard and isometric views in single click. By default, the ViewCube 
is displayed at the top right corner of the Perspective window. If it is not displayed, you can 
display it by setting the options in the General Preferences as discussed in the Viewing Panel. 
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By default, the ViewCube is displayed in inactive state, as shown in Figure 1-26. When you 
move the cursor closer to the ViewCube, it gets activated, refer to Figure 1-26. The faces, 
vertices, and edges of the ViewCube are known as clickable areas (hotspots). If you place the 
cursor on any clickable area (hotspot), the area will be highlighted. Click in the required area 
to orient the model such that the clicked area and the model become parallel to the screen. 
You can switch to the top, front, back and other views by clicking on the corresponding faces 
in the ViewCube. If you press and drag the left mouse button on the ViewCube, you will get a 
visual feedback of the current viewpoint of the model. The House icon provided near the top 
left corner of the ViewCube is used to switch to the home view or perspective view. If you click 
on the down arrow given near the lower right corner of the ViewCube, a shortcut menu will 
be displayed, as shown in Figure 1-27. The options in this shortcut menu are discussed next.

Figure 1-26  Inactive and active states of the 
ViewCube

Figure 1-27  The shortcut menu

 

Orthographic
Choose this option to display the model in the orthographic view.

 Perspective
Choose this option to display the model in the perspective view.

 Perspective with Ortho Faces
Choose this option to display the model in orthographic projection when one of the faces of 
the ViewCube is active. 

Options
This option is used to specify the options related to the display of the ViewCube. This option 
is discussed in detail later in this chapter.       

If you press the SHIFT+ALT keys in the Perspective window, a NavBar will be displayed, as 
shown in Figure 1-28. Most of the options in the NavBar are the same as those discussed in 
the ViewCube. The remaining options are discussed next.
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Figure 1-28  The NavBar and its components

 Camera Based Tumble       
This option allows you to dolly, track, 
and tumble the view by using the 
SHIFT+ALT keys along with different 
mouse buttons. The dolly, track, and 
tumble operations have already been 
discussed in this chapter. 

 Object Based Tumble(Azimuth/
Elevation)
This option allows you to dolly, track, 
and revolve the view by using the 
SHIFT+ALT keys along with different mouse buttons. This option allows you to change 
the Azimuth/Elevation of a view by using the left mouse button. You can also twist the view 
by dragging the right mouse button horizontally.

 View Twist
This option will be available only when you choose the Camera Based Tumble option 
from the NavBar. Choose this option and then drag the cursor with the left mouse button; 
the view will be twisted in the perspective view.

 View Azimuth/Elevation
This option will be available only when you choose the Camera Based Tumble option 
from the NavBar. Choose this option and then drag the cursor with the left mouse button; 
the view will be revolved in the perspective view. Note that the view revolves differently 
with different mouse buttons.

You can set the parameters of the ViewCube. To do so, choose the Option option from the 
fl yout that is displayed on choosing the down arrow given near the lower right corner of the 
ViewCube; the ViewCube Options dialog box will be displayed, as shown in Figure 1-29. The 
options in this dialog box are discussed next.

Figure 1-29  The ViewCube Options dialog box
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 On-screen position
This area is used to specify the position of the ViewCube in the Perspective window. By default, 
the Top Right button is chosen in this area. As a result, the ViewCube is displayed on the top 
right corner of the Perspective window. You can change the position of the ViewCube to top 
left, bottom right, or bottom left by choosing the corresponding button in this area.

 ViewCube size
This area is used to specify the size of the ViewCube in the Perspective window. You can 
change the size of the ViewCube to tiny, small, large, normal, or automatic size by choosing 
the respective button from this area. 

 Inactive opacity
This edit box is used to specify the opacity of the inactive ViewCube. Alternatively, you can drag 
the slider bar given at the right of this edit box to change the opacity of the inactive ViewCube.

 Keep scene upright
This check box is selected by default and is used to keep the scene upright.

 Snap to closest view
Select this check box to snap the viewpoint of the scene/window to one of the fi xed views while 
dragging the scene. Note that the viewpoint snaps to the fi xed view that is angularly closer to it. 

 Reset
This button is located at the bottom of the ViewCube Options dialog box. This button is used  
to reset the settings of the dialog box to default values.

 Save
This button is used to save the current setting of the ViewCube in the ViewCube Options 
dialog box.

 Exit
Choose this button to exit the ViewCube Options  dialog box without saving the current settings.

 Go
Choose this button to exit the ViewCube Options dialog box and to apply the current settings 

to the ViewCube.  

 SNAPPING TOOLS
Snapping restricts or constrains the movement/placement of objects and points to the specifi ed 
locations or paths. The locations or paths are defi ned by grid points, curve, edges, edit points, 
or control vertices. There are three snapping tools in Alias Design. These snapping tools are 
displayed on the right of the promptline. These tools allow you to toggle snap modes on and 
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off. Snapping works in coordination with the middle and right mouse buttons. Different snap 
modes are discussed next.

 Snap to CV/Edit Point
You can snap a current object or a tool to the nearest CVs, edit points, pivot points, 
or locators by using the Snap to CV/Edit Point tool. To invoke this tool, click on the 
Snap to CV/Edit Point button given on the right of the promptline on the interface 

screen. You can also invoke this snapping tool by pressing the CTRL key before selecting any 
tool.  

 Snap to Grid
You can use the Snap to Grid tool to snap the current object or the tool to the nearest 
grid point or grid intersections. To invoke this tool, click on the Snap to Grid button 
on the interface screen. You can also invoke this tool by pressing the ALT key before 

selecting any tool.

 Snap to Curve                                            
You can snap the current object or the tool to the nearest curves,      

Figure 1-30  The Snap 
Options dialog box

edges, or curves-on-surface by using the Snap to Curve tool. 
To invoke this tool, click on the Snap to Curve button from 

the interface screen. You can also invoke this tool by pressing and 
holding the ALT and CTRL keys before selecting any tool. 

You can control different parameters of curve snapping by using the 
Snap Options dialog box, as shown in Figure 1-30. To invoke this 
dialog box, click on the arrow given on the right of the Snap to Curve 
button. The options in this dialog box are discussed next.

 Snap Divisions
This edit box is used to specify snap divisions on the curve. Snap divisions are displayed as 
snappable locations (light blue line segments on the curve). By default, this edit box displays 
1 and assumes the curve as one segment with snappable points displayed at endpoints of the 
curve. If you enter 3 in this edit box, the snappable points will be displayed at 1/3rd and 2/3rd 
of the curve length in addition to endpoints. Similarly, entering 4 in this edit point will display 
snappable points at 1/4th, 2/4th, and 3/4th of the curve length in addition to endpoints. You 
can snap the current tool to these snappable locations.

 Snap to Center
Select this check box to snap the current object or the tool to the center of the bounding box 
of the curve. When you select this check box and click on the curve, the center of the bounding 
box of the curve, represented by a + sign surrounded by a small circle, will be displayed near 
the curve. If you move the cursor in proximity of the center of the bounding box, the current 
tool will be snapped to it.
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 Pivot
Select this check box to snap the current object or the tool to the pivot point of the curve. When 
you select this check box and click on the curve, the pivot point of the curve will be displayed. 
If you move the cursor in proximity of the pivot point, the current tool will be snapped to it.

 Projected Intersections
Select this check box to snap the current object or the tool to intersection points between the 
curves in orthographic or perspective views even if the curves do not intersect with each other. 
Intersection points are represented by pink cross marks. 

 True Intersections
This check box is selected by default and is used to snap the current object or tool to intersection 
points of curves, curves-on-surface, surface edges, isoparametric curves, and trim edges. 
If you to want to snap with the True Intersections check box selected, you must intersect 
curves with each other. You can also snap a new curve-on-surface to the intersection of two 
curves-on-surface on a single surface. You will learn about curves-on-surface, isoparametric 
curves, and surface edges in later chapters.

 WORKFLOWS IN Alias Design
Alias Design provides you different working   

Figure 1-31  Invoking workfl ows from 
the Preferences menu

environments such as painting, modeling, and 
visualization. These environments are known as 
workflows. You can invoke these workflows by 
choosing Preferences > Workfl ows from the menu 
bar and then choosing the required option from 
the fl yout displayed, as shown in Figure 1-31. By 
default, the Default workfl ow is chosen from the 
fl yout. However, you can choose other workfl ows 
from this menu to suit your requirements. Each 
workfl ow contains different set of tools that are 
used in different applications. You can even 
customize workf lows according to your 
requirements. Workfl ows used in Alias Design 2012 
are discussed next.

 Default
The Default workfl ow is suitable for general work, painting, rendering, and animation. This 
workfl ow displays all tools in menus, Marking menus, Palette, Shelves window, and Control 
Panel. You can invoke this workfl ow by choosing Preferences > Workfl ows > Default from 
the menu bar. The shortcut keys for invoking the Default workfl ow are CTRL+1. 

 Paint
This workfl ow is suitable for sketching (painting) and creating 2D works. It displays the 
sketch-related tools in menus, Marking menus, Palette, Shelves window, and Control Panel. 
You can invoke this workfl ow by choosing Preferences > Workfl ows > Paint from the menu 



1-26            Learning Autodesk Alias Design
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

bar. The shortcut keys for invoking the Paint workfl ow are CTRL+2. In this workfl ow, the 
display of grids is turned off.

 Modeling
This workflow is suitable for 3D modeling. It displays the modeling-related tools in 
menus, Marking menus, Palette, Shelves window, and Control Panel. In this workfl ow, the 
number of tools related to painting, rendering, and animation are reduced or hidden to 
facilitate the modeling operations easily. To invoke this workfl ow, choose Preferences > 
Workfl ows > Modeling from the menu bar. The shortcut keys for invoking the Modeling 
workfl ow are CTRL+3. In this workfl ow, the display of grids is turned on.

 Visualize
This workfl ow is suitable for rendering objects. The Visualize workfl ow displays the rendering 
related tools in menus, Marking menus, Palette, Shelves window, and Control Panel. In this 
workfl ow, the number of tools related to painting, modeling, and animation are reduced 
or hidden to facilitate the rendering processes easily. To invoke this workfl ow, choose 
Preferences > Workfl ows > Visualize from the menu bar. The shortcut keys for invoking the 
Visualize workfl ow are CTRL+4. In this workfl ow, the display of grids is turned on.

 UNDERSTANDING SYMBOLS IN MENU, PALETTE, AND 
SHELVES WINDOW
When you choose an option from the menu bar, a menu with the associated        

Figure 1-32  The 
WindowDisplay 
menu showing symbols

 
commands or tools is displayed. You can choose any option from the 
menu depending upon the task you want to perform. These options 
have symbols beside them, as shown in Figure 1-32. One more symbol 
is given at top left corner of some tools in the Shelves window and the 
Palette. The function of these symbols is discussed next.

This symbol indicates that the associated option or tool has 
an option window, dialog box, or an editor. You can open the 
associated option window, dialog box, or editor by clicking on 

this symbol. You can change the settings (parameters) of the 
corresponding option by using these option windows, dialog boxes, 
or editors. This symbol is also located at top left corner of tools in the 
Palette and the Shelves window. To open the associated option window, 
dialog box, or editor from the Palette and the Shelves window, 
double-click on the tool/button. Alternatively, press the SHIFT key 
along with the left or right mouse button. 

This symbol indicates that the selected option has another associated cascading menu 
displaying sub-options in it. To open the associated cascading menu, click on this 
symbol. Next, choose the required sub-option from this cascading menu.

This symbol indicates that the selected tool has a submenu. This symbol is seen at top 
right corner of tools in the Shelves window and the Palette. Press and hold the left or 
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right mouse button on the tool to display the submenu. Next, select the required tool from 
this submenu. You will learn more about these symbols and their associated tools in later 
chapters.

 HOTKEYS
Hotkeys are the shortcut keys that allow you to invoke tools or choose different options from 
menu bar. You can use hotkeys to speed up your task. There are some default hotkeys that have 
been assigned to some tools and options in the menu bar. For example, the function key F8 is 
the hotkey for displaying the Perspective window. You can also assign a new hotkey for these 
tools and options in the menu bar. To do so, choose Preferences > Interface > Hotkeys/Menu 
Editor from the menu bar; the Hotkeys / Menus Editor will be displayed. Click on a down 
arrow in any of the options given under the Function Titles area; a new fl yout will be displayed 
with different options in it. Next, click on the down arrow in any of the options in this rollout; 
the dialog box will expand, as shown in Figure 1-33. To assign a new hotkey to a tool/option, 
check the box given on the right of any options under the Default Workfl ow Short Menu 
Display area. Next, enter a new hotkey in the edit box given under the HotKey Defi nes area 
and choose the Apply button; the confi rm message box will be displayed. Choose the Don’t 
Switch button from the confi rm message box; the hotkey will be assigned to the respective 
tool/option. To change the default hotkey, delete the assigned hotkey and then enter a new 
hotkey. You will get familiar with hotkeys in later chapters.

Figure 1-33  The expanded Menu/Hotkeys Editor 
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Note
If you choose the Switch button from the confi rm message box, menus in the menu bar will 
display short menus when you choose them. The menus displayed will not appear in the expanded 
form. Select the don’t show again check box from the confi rm message box if you do not want 
the confi rm message box to be displayed the next time you assign a hotkey.

 CREATING CUSTOMIZED SHELVES
In Alias Design, a tool is invoked from the Palette or the Shelves window. Invoking a particular 
tool from the Palette or the Shelves window activates the tool and allows you to proceed 
further with that tool. Alias Design provides you with a better option to invoke a tool without 
using the Palette or the Shelves window. You can create customized shelves and use them to 
invoke tools. These shelves are created in the Shelf area of the Control Panel. The procedure 
to create your shelf for the Sphere tool in the Shelf area is discussed next.

1. Choose Windows > Control Panel from the menu bar; the Control Panel will be 
displayed on the right of the interface screen. 

2. Next, drag an existing shelf from the Control Panel using the middle mouse button and 
drop it on the Delete icon at the top right corner of the interface screen; the existing shelf 
will be deleted. 

3. Create a new shelf in the Control Panel. To do so, press and hold the left mouse button 
on the Shelf button in the Control Panel; the Shelf fl yout will be displayed, as shown 
in Figure 1-34. Choose the New option from this fl yout; the confi rm message box will 
be displayed, as shown in Figure 1-35. In the confi rm message box, enter the new name 
(Surface) in the Shelf Name edit box and choose the OK button; a new shelf with the 
entered name will be displayed. 

Figure 1-34  The 
Shelf fl yout

Figure 1-35  The confi rm message box

4. Choose Windows > Palette from the menu bar; the Palette will be displayed. Next, expand 
the Surfaces tab by clicking on it. Drag the Sphere tool to the newly created shelf (Surface) 
by using the middle mouse button; the Sphere tool will be added to the new (Surface) 
shelf, as shown in Figure 1-36.
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Similarly, you can add tools to the Control Panel from the Shelves window. You can even place 
entire tool tab from the Shelves window in the Control Panel. To remove a tool or a tab from 
the shelves of the Control Panel, drag the tool or the tab by using the middle mouse button 
and drop it on the Delete icon.
 

Note
While dragging the tool icon from the Shelves window or the Palette, the tool icon will not be 
displayed. Only tool tip will be displayed on top of the cursor.

 OBJECT LISTER WINDOW
Like any other modeling software, Alias Design keeps the track record of all features of a 
model or a scene in hierarchical order. This record is kept in the Object Lister window. This 
window allows you to locate an object and its duplicate copy. You can also group and ungroup 
objects using the Object Lister window. While modeling a complex shape, it is diffi cult to 
pick an object from the view windows. In such a case, you can pick objects from the Object 
Lister window. This window is also used to view hidden objects. However, you cannot pick 
hidden objects from the Object Lister window. To invoke the Object Lister window, choose 
Windows > Object Lister from the menu bar; the Object Lister window will be displayed, 
as shown in Figure 1-37.

Figure 1-37  The Object Lister windowFigure 1-36  The Sphere tool 
added to the Surface shelf

The default Object Lister window will not display    

Figure 1-38  The expanded Object Lister 
window

   
the hierarchical structure of model in scene. To 
display this structure, click on the + sign on the left 
of the DefaultLayer node; the DefaultLayer node 
will expand and display different groups and nodes. 
These groups and nodes will be displayed in 
compressed state. Click on the + sign on the left 
of these nodes to expand them; the hierarchical 
structure showing tools, objects, and features used 
in modeling will be displayed. To view the structure 
of the Object Lister window and its associated 
nodes and groups simultaneously, press the SHIFT 
key and then click on the + sign in the DefaultLayer 
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node. The expanded Object Lister window for a model is shown in Figure 1-38. The options 
in the Object Lister window are discussed next.

Show
This option is used to specify the way you want the items to be listed in the Object Lister 
window.  You can list items as layers or simple objects.

 Categories
This option will be available only when you choose the By Layer option from the Show shortcut 
menu. The Categories option allows you to display objects of all layers, selected layers, or 
reference layers. Also, this option enables you to control the visibility of layers through the 
Layer Categories window that will be displayed when you choose the Editor option from the 
shortcut menu. 

 +/- All
Choose this button to expand or collapse the node. This button allows you to toggle between 
the expanded and collapsed node states.

 Search & Pick
You can pick objects by entering their names in the Search & Pick fi eld. The names entered 
are case-sensitive. 

 Scroll Up/Down Arrows
The default size of the Object Lister window cannot show always all features of the model. 
To view the picked objects that are not visible in the default size Object Lister window, Alias 
Design 2010 provides you the Scroll Up and Scroll Down arrows on the right of the Object 
Lister window. Click on the Scroll Up arrow to view the lowest picked object at the top of the 
Object Lister window. Click on this arrow once more to view the next picked object. Similarly, 
click on the Scroll Down arrow to view the highest picked object at the bottom of the Object 
Lister window. Click on this arrow once more to view the next picked object.       

 DIFFERENT STATES OF NODE
The information about objects, features, and tools that have been used are stored in nodes in 
the Object Lister window. Depending on the object, tool, and features, nodes in the Object 
Lister window may be displayed in different states. You can expand or compress these node 
states. The node states are discussed next.

 Grouped
This node state is represented by an orange block in the Object Lister window. If you 
expand a grouped node, its individual members will be displayed. This node state represents 
the grouping of several objects.
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 Instanced
This node state is represented by a white cube in the Object Lister window. Sometimes, you 
may need to create a duplicate copy of an object as an instance. This duplicate copy is displayed 
as an instance in the instanced node. This instance acts as a reference for an existing geometry 
in view windows. The duplication of objects will be discussed in Chapter 5. 

 Compressed
Sometimes, the Object Lister window displays many nodes and gets crowded. You can collapse 
some nodes of the Object Lister window into a single node. This node state is known as the 
compressed node state. In this state, all nodes collapse into a single node. You can click on 
the + sign given on the left of the compressed node to expand it again. 

 Invisible
If you want to make objects invisible, use the invisible node state. In this state, the text 
corresponding to nodes appears in gray. To make an object or a feature invisible, select it from 
the Object Lister window; a shortcut menu will be displayed. By default, the Visible option 
is displayed in the shortcut menu with a tick mark on the left. Choose the Visible option; the 
tick mark disappears and the nodes turn invisible. When you switch over to invisible node, 
the tick mark disappears. You can view properties of the object in the Information Window 
that will be displayed when you choose the Properties option from the shortcut menu.

 Templated
The templated node state represents the objects that are visible but cannot be picked or 
transformed. The templated objects are highlighted in pink when they are activated. In the 
inactive state, the templated objects are highlighted in grey.

 SCENE BLOCK DIAGRAM (SBD)
The Scene Block Diagram (SBD) is another way to display the internal structure of a model 
or an object in view windows. To view the internal structure of a model, choose Utilities > 
SBD > Open SBD Window from the menu bar; the Scene Block Diagram window will be 
displayed. The Scene Block Diagram window is a view window like an orthographic window 
or the Perspective window. It displays the internal structure of a model or an object as a 
graphical representation rather than a visual representation in the window. Figure 1-39 shows 
the Scene Block Diagram window of a cone. 

Figure 1-39  The Scene Block Diagram window of a cone



1-32            Learning Autodesk Alias Design
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

The Scene Block Diagram window of a model displays all objects such as curves, surfaces, 
lights, cameras, transformations, groups, and so on in the form of nodes. The main components 
or objects in this window are known as DAG (Directed Acyclic Graph). The brown nodes in 
the Scene Block Diagram window are known as positioning nodes. The positioning nodes 
represent the transformation applied to the geometry below them. The blue nodes in this 
window are known as geometry nodes and represent the internal structure of the model or 
object. These nodes also represent the objects that are without construction history. The green 
nodes represent the objects that have construction history. Control vertices, edit points, and 
other features of internal structure of a geometry do not have separate nodes. They are stored 
as part of internal information of the object. The camera and lights are displayed in light blue 
nodes. You can notice that the top level objects represent top nodes and are placed at the top 
of the SBD window. The object or component nodes of the model are grouped under the top 
level nodes. The geometry nodes representing the internal structure of objects are given below 
the component nodes. Different types of geometry in an object are represented by different 
symbols. The SBD window is used to pick individual components of a model or an object. 
You can hide nodes under a picked node. To do so, pick a node and then choose Utilities > 
SBD > Compress SBD from the menu bar; the nodes under the picked node will be hidden. 
The hidden nodes are represented by two brown rectangles, one inside the other. To display 
the hidden nodes again, pick the hidden nodes and then choose Utilities > SBD > Expand 
SBD from the menu bar; the hidden nodes are displayed again in the SBD window. Like the 
Object Lister window, the SBD window is also used to view the hidden objects. However, you 
cannot pick the hidden objects in this window. 

 STARTING A NEW FILE
To start a new fi le, choose File > New from the menu bar; the confi rm message box will be 
displayed, as shown in Figure 1-40. This message box will ask you whether the objects, shades, 
and so on need to be deleted before starting a new session. Choose the Yes button; a new wire 
fi le will be started. 

Figure 1-40  The confi rm message box

 OPENING AN EXISTING FILE
To open an existing fi le, choose File > Open from the menu bar; the Open dialog box will be 
displayed, as shown in Figure 1-41. Browse to the location of the fi le to be opened by using the 
Look in drop-down list; a list of all fi les and folders in the specifi ed location will be displayed 
in the list box given below it. Double-click on the folder containing the fi le to be opened; all 
fi les in the folder will be listed in the list box. Select the required wire fi le from this list box 
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and choose the Open button from the Open dialog box. Alternatively, you can enter the name 
of the fi le to be opened in the Object name edit box. The File Types drop-down list is used 
to specify the type of fi le to be opened. You can open image fi les (bmp, jpeg, tiff, als), wire 
fi les (wire), or modeling fi les (stp, prt, igs, and so on) by using the File Types drop-down list. 
You can also preview the fi les selected in the Preview window by selecting the Preview check 
box in the Open dialog box. 

You can set different options for opening fi les in different formats such as WIRE, IGES, STEP, 
STL, OBJ, and so on. To do so, choose the File option from the menu bar; a fl yout will be 
displayed. Click on the box given on the right of the Open option; the Open File Options 
window will be displayed, as shown in Figure 1-42. By default, all check boxes in the Wire 
Options area are selected. When you choose the Open File button from this window; the 
features associated with the selected fi le such as windows, cameras, lights, shaders, and so on 
will be displayed in the opened fi le. To open an existing fi le without some or all these features, 
clear the corresponding check boxes in the Wire Options area. Similarly, you can set options 
for other fi le formats while opening an existing fi le.  

Figure 1-41  The Open dialog box
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OPENING RECENT FILES
You can also open the recently used or saved fi les in Alias Design 2012. To do so, choose 
File > Open Recent from the menu bar; a cascading menu showing all recently used fi les as 
well as their locations will be displayed. Choose the required fi le from the cascading menu; 
the confi rm message box will be displayed. Choose the Yes button from this message box; 
the selected fi le will open. To delete the history of all recently used or saved fi les, choose the 
Clear History option from the fl yout.

 SAVING FILES
You can save your fi le or store your data in Alias Design 2012 and retrieve it later. To do so, 
choose File > Save from the menu bar. If you are saving the fi le for the fi rst time by using the 
Save option, the Save Wire dialog box will be displayed, as shown in Figure 1-43. 

Browse to the location of the fi le to be saved by using the Save in drop-down list; a list of all fi les 
and folders in the specifi ed location will be displayed. Double-click on the folder in which you 
want to save the fi le; all fi les in the folder will be listed in the list box. Enter the name of the 
fi le in the Object name edit box and then choose the Save button from the Save Wire dialog 
box. You can also preview the fi le to be saved in the Preview window by selecting the Preview 
check box in the Save Wire dialog box. The options in this dialog box are discussed next.

Figure 1-42  The partial view of the Open File Options window
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 Save in
The Save in drop-down list is used to specify the location for saving the fi les. 

 Go
This drop-down list is used to specify the directory for saving the fi le. You can specify default 
path, current project, or any other directory as saving directory. You can use the options in 
the Project drop-down list to create directories. The Project drop-down list discussed next.

 Project
This drop-down list is used to create a project directory. The project directory helps you organize 
your fi les systematically and retrieve the required fi les easily. To create a new project directory, 
select the New Project option from the Project drop-down list. Next, specify the location in 
the Save in drop-down list and create a new folder in the list box. You can create a new folder 
by choosing the Create New Folder button and then renaming it with a meaningful name. 
Alternatively, create a new folder by choosing New > Folder from the shortcut menu that is 
invoked by right-clicking inside the list box. Next, select this folder and then select the Set 
Current option from the Project drop-down list; the confi rm message box will be displayed. 
Choose the OK button from the message box; a project directory will be created and set as 
the current directory. Enter the name of the fi le in the Object name edit box and choose the 
Save button; the fi le will be saved in the directory created. Next time, if you want to save a 
fi le in this directory, select Current Project from the Go drop-down list and enter the name 
of the fi le in the Object name edit box. Next, choose the Save button from the Save Wire 
dialog box; the fi le will be saved. 

 Go To Last Folder Visited
Choose this button to move to the folder that you visited last. On choosing this button, 
you can navigate through the current and last folders.

 Up one Level
Choose this button to move one level up the current directory. On choosing this button, 
you can navigate through different directories.

 Create New Folder
Choose this button to create a new folder in the list box. When you choose this button, 
a folder with the name New Folder will be displayed in the list box. Click outside this 
folder to keep this name or rename it as per your requirement. 

 View Menu
Choose this button to display a fl yout. The options in this fl yout are used to view fi les 
and folders of the list box with an arrangement. You can arrange these fi les and folders 
in the form of thumbnails, tiles, icons, list, or with details by choosing the corresponding 

options in the fl yout.  
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 Object name
This drop-down list is used to specify the same of the fi le to be saved. If you select an existing 
fi le from the list box; its name will be displayed in the Object name drop-down list. You can 
overwrite the selected fi les by choosing the Save button.

Figure 1-43  The Save Wire dialog box

 Preview
By default, the Preview check box is selected and displays the preview of the model or the 
scene in the Preview window. If this check box is cleared, you cannot preview the model.

 Save
After specifying the location and name of the fi le, choose the Save button to save the fi le.

 Cancel
Choose this button to exit the Save Wire dialog box without saving the fi le.
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 Saving the File with a New File Name/Format
You can change the fi le name/format of an already saved fi le by using the Save As option. To 
save a fi le with a different name, choose File > Save As from the menu bar; the Save Wire 
dialog box will be displayed. Rename the fi le, specify the location of the fi le to be saved, and 
choose the Save button; the fi le will be saved. The options in this dialog box are the same 
as those discussed in the Save Wire dialog box of the Save option. With the Save As option, 
you can save fi les in different formats such as WIRE, IGES, STEP, OBJ, and so on. To do so, 
choose the File option from the menu bar; a fl yout will be displayed. Click on the box given 
on the right of the Save as option; the Save All Options window will be displayed, as shown 
in Figure 1-44. The options in this window are discussed next.

 Basic Save Options
This area is used to specify the fi le formats for saving the fi les. The File Formats area is used 
to specify the format of the fi le to be saved. By default, the WIRE button is displayed in the 
File Formats area.  As a result, fi les will be saved in the wire format. Press and hold the left 
mouse button on the WIRE button; a fl yout displaying all fi le formats will be displayed. 
You can choose the IGES, OBJ, UGS NX, CATIA V5, STEP, or other button to specify the 
corresponding fi le formats. 

Figure 1-44  The Save All Options window

 Wire Options
This area is used to specify various options associated with the wire fi le format. Changing the 
fi le format by using the File Formats area changes this area as well. For example, if you choose 
the STEP button from the File Formats area, the Wire Option area will be replaced by the 
STEP Options area displaying the options associated with the STEP format.

 Cancel
Choose this button to exit the Save All Options window without saving any change. 

 Save
Choose this button to exit the Save All Options window with the changes saved in it.
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 PRINTING THE OUTPUT
After creating a model, you can preview, print, and send output to a printer. To do so, choose 
File > Print from the menu bar; the Print Preview dialog box will be displayed, as shown in 
Figure 1-45. The options in this area are discussed next.

 Preview Window
The Preview window displays the print preview of the model in orthographic windows. It 
occupies maximum space in the Print Preview dialog box.

 Mode
The Mode button enables you to specify the mode of printing that may include orthographic 
views, canvas view, or entire content of the window. Press and hold the left mouse button on 
this button; a fl yout will be displayed. The options in this fl yout are discussed next.

 Print Window
When you choose this button; the model in the Top window will be displayed in the 
Preview window by default. You can change the view in the Preview window by choosing 
the required view from the Reset View button in the Print Preview dialog box. If a canvas is 
present in the view window, its preview will be displayed in the Preview window. Also, if the 
model is shaded, its shaded preview will be displayed. 

Figure 1-45  The Print Preview dialog box
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 Print Canvas
Choose this button to display the preview of the canvas, if it is present in the view window. 
Only the preview of the canvas will be displayed. 

Print Plot
This button is chosen by default and is used to display the preview of orthographic windows. 
However, the shaded geometry will not be displayed in the Preview window.

 Setup
Choose this button to display the Print Setup dialog box, as shown in Figure 1-46. You can 
also invoke this dialog box by choosing File > Print Setup from the menu bar. This dialog 
box provides you with different tabs that enable you to change the settings for output, printer, 
paper specifi cations, information about the model, and so on. The options in the Print Setup 
dialog box are discussed next.

 Figure 1-46  The Print Setup dialog box

Output
This tab is chosen by default. The options in this tab are used to specify the settings for the 
output of the print. The options in this tab are also used to specify printer, output style, color, 
number of copies to be printed, and so on.
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Paper
Choose this tab to display the options related to paper specifi cations. Using these options, 
you can change the paper standard, size, orientation, and so on.

Info
Choose this tab to display the information box related to the output. Using the options of 
this tab, you can control the display of title box, name of the company, drawing number, its 
scale, date, fi le name, and so on.

Viewing
Choose this tab to show the options related to the display of objects in the output. Using 
the options of this tab, you can control the display of objects, scaling of objects, layout style, 
image, and so on.

Drawing
Choose this tab to show the options related to drawing display. Using the options of this tab, 
you can control the display of grids, rulers, borders, crop marks, locators, and so on.

 Hidden Line
Choose this tab to display the options related to the hidden line display.

If you choose the Print Window or Print Canvas option from the menu displayed on choosing 
the Mode button in the Print Preview dialog box; the options in the Print Setup dialog box 
will change, as shown in Figure 1-47. The options in this area are discussed next.

Figure 1-47  The Print Setup dialog box

 Print Setup
The Print Setup button is used to specify the settings for the output of the print. On choosing 
this button, the Print dialog box will be displayed. The options in this dialog box are also used 
to specify printer, output style, color, number of copies to be printed, and so on. 
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 Page Setup
The Page Setup button is used to specify the settings of the paper. On choosing this button, 
the Page Setup dialog will be displayed. Using the options in this dialog box, you can change 
the paper’s standard, size, orientation, margins, and so on.

 Orientation
This area is used to specify the orientation of the output. You can set the orientation to portrait 
or landscape by selecting the corresponding radio button from this area.

 Image Size and Position
The options in this area are used to specify the size and position of the output image. By default, 
the Fit to Page check box is selected in this area. As a result, the output image will fi t to the 
current page size. If you clear this check box, the Height, Width, and Center Image options 
will be enabled. With these options, you can specify the user-defi ned size of the output image. 

After specifying the settings in the Print Preview and Print Setup dialog boxes, choose the 
Print button from the Print Preview dialog box to print the output.

 EXITING THE APPLICATION
To exit or quit the current session of Alias    

Figure 1-48  The confi rm message box

 
Design, choose File > Exit from the menu 
bar; the confirm message box will be 
displayed, as shown in Figure 1-48. To exit 
Alias Design after saving the fi le, choose the 
Save button from the confi rm message box; 
the Save Wire dialog box will be displayed. 
The options in this dialog box have been 
discussed earlier. After specifying the 
location and name of the fi le, choose the 
Save button; the current session of Alias 
Design will be closed. To exit the session 
without saving the fi le, choose the Don’t 
Save button from the confi rm message box; the current session will be closed. Choose the 
Cancel button from the confi rm message box to exit the confi rm message box. Alternatively, 
you can exit the current session of Alias by pressing ALT+E keys.

 CONTROLLING THE DISPLAY OF WINDOWS
In Alias Design, you can control the display of view windows. The methods of controlling the  
display of the view window are discussed next.

 Controlling the Display of the Title Bar
You can turn the visibility state of the title bar in the active window on or off. By default, the 
visibility state of the title bar is turned on. As a result, this bar is displayed on top of each 
view window. To turn its visibility state off, choose WindowDisplay > Title Bar from the 
menu bar. To change the options for displaying the title bar, click on the box on the right of 
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the Window Title Bar option; the Title Bar Options dialog box will be displayed, as shown 
in Figure 1-49. You can control the display of the title bar in all windows or current (active) 
window by selecting the corresponding button in the Toggle Type area of this dialog box.

Figure 1-49  The Title Bar Options dialog box

 Toggling the Window Components
Alias Design provides you with another option    

Figure 1-50  The Toggles cascading menu

   
to toggle the visibility state of window components. 
To toggle the visibility state of window 
components on or off, choose WindowDisplay > 
Toggles from the menu bar; the Toggles 
cascading menu will be displayed, as shown in 
Figure 1-50. Choose the required option from 
this cascading menu to turn off or on the visibility 
of the corresponding window component. For 
example, if you choose the Grid option from the 
Toggles cascading menu; the visibility of grid will 
be toggled on or off based on the initial state of 
grid. Similarly, choose another option from this 
cascading menu to toggle between the visibility 
states of the corresponding window component. 
You can set options for these components by 
clicking on the box given on their right. You can 
also toggle the visibility states of components in the active window without affecting other 
windows. To do so, click on the Show button given on the title bar of the active window; a 
fl yout showing different components of the corresponding window will be displayed. Choose 
the required component from the fl yout to turn its visibility state on/off.

 Controlling the Display of Window Components
By default, components of the view window such as grids, pivots, locators, guidelines, cameras, 
lights, and so on will be displayed in view windows. Sometimes, you may need to turn the 
visibility of these components off. To do so, choose WindowDisplay > Show from the menu 
bar; the visibility of the mentioned components will be turned off. You can even control the 
display of these components individually without affecting other components. To do so, click 
on the box given on the right of the Show option; the Show Options option box will be 
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displayed, as shown in Figure 1-51. Now, specify components according to your requirement 
and then choose the Go button; the visibility of the specifi ed components will be turned off. 
The options in the Show Options option box are discussed next.     

Mode
By default, the SHOW button is chosen in this area. As a result,    

Figure 1-51  The Show 
Options option box

            
the components whose check boxes are selected will be displayed 
and the components whose check boxes are cleared will be hidden. 
If you choose the TOGGLE button in the Mode area, the visibility 
of the components whose check boxes are selected will be toggled 
on or off. 

All
You can select or clear the check boxes given under the All button 
automatically by choosing this button.

None
Choose the None button to clear all check boxes automatically so 
that components are not displayed in view windows. You can turn 
the display of components on or off by selecting or clearing the 
corresponding check boxes manually.

 CHANGING PREFERENCES IN Alias 
Design
The change in preferences allows you to customize the Alias Design 
interface. You can change workfl ows, display of menus, hotkeys, 
Palettes, Shelves window, colors, and so on. You can also save, load, 
and retrieve options and set preferences. The different options to change preferences in Alias 
Design 2012 are discussed next.

 Setting Preferences in Alias
To set preferences in Alias Design according to your requirements, choose the Preferences 
option from the menu bar; a fl yout will be displayed. Next, click on the box given on the right 
of the General Preferences option; the General Preferences window will be displayed, as 
shown in Figure 1-52. There are ten tabs in this window that are discussed next.

Interface
The Interface tab is chosen by default and allows you to set tool icons in the Palette, Shelves 
window, and Control Panel to different sizes. By using the options in this tab, you can control 
the display of tool icon labels, tooltips, title bar, and status bar.

Input
When you choose this tab, the options related to the input provided to Alias Design will be 
displayed. These options are used to control the keyboard entry mode, view modes, display 
of the Pick chooser menu, and so on.
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Figure 1-52  The General Preferences window

Viewing
When you choose this tab, the options that control the view of the objects and windows will be 
displayed. By using these options, you can specify the option for view control such as ViewCube 
and Viewing Panel, view transition time, dolly options, view step angles, and so on.

 Model Windows
When you choose this tab, the options related to modeling windows will be displayed. These 
options are used to control the display of axis triad, title bar transparency, direction of 
coordinate system, and so on. You can control the display of transform guides and dynamic 
display box that appear while moving an object. You will learn about the method of moving 
an object in the next chapter.

Modeling
When you choose this tab, the options related to modeling will be displayed. These options 
are used to specify the number of the guidelines displayed in the view windows. You can assign 
name or number to layers according to your requirements by using this tab. 

Paint
When you choose this tab, the options related to sketching will be displayed. These options 
are used to control the paint display quality, brush stamp preview, paint cursor, cursor outline, 
and so on. You can change the default size of canvas by using this tab.
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 Visualization
On choosing this tab, the options related to the visualization of objects will be displayed. These 
options are used to control the size of shader sample thumbnails. You can specify a location 
for the shader library to be used for applying shaders by suing this tab.

 Animation
When you choose this tab, the options related to the animation of objects will be displayed. 
These options are used to specify the bone style.

System
When you choose this tab, the options related to different fi le locations will be displayed. 
These options are used to change the type of fi le browser so that the next time you import, 
export, or save the fi le, the selected browser will be opened to specify the fi le location. You 
can specify the location for MSave, Help, Library, Dumpster folders/directories, and so on. 
If Alias wire fi le closes abnormally, it will be saved in the MSave fi le location.

Miscellaneous
The options in this tab are used to control the number of undo actions performed and the 
memory allocated to these undo actions. You can locate and load plug-ins into the Alias Design 
system by using this tab. 

 Setting Construction Options In Alias Design
Sometimes you may need to open/import an object created in Alias Design into other CAD 
packages such as SolidWorks, Pro/ENGINEER, CATIA, and so on. Alias Design allows you 
to set the construction options of an object so that it can be opened/imported into other 
CAD package with set units, tolerances, fonts, scale factors, and so on. To do so, choose 
Preferences > Construction Options from the menu bar; the Construction Options window 
will be displayed, as shown in Figure 1-53. You can set different options by using the options 
Construction Options window. The options in this window are discussed next.

Construction Presets
The Construction Presets area is used to specify the settings of the selected profi le for its best 
compatibility with Alias Design 2012. The options in this area are discussed next.

 Profi le List
 You can create an object with the default settings of a specifi c CAD profi le by selecting it 

from the Profi le list given below the Copy and Delete buttons. Note that you cannot edit 
default settings of a specifi c CAD profi le. However, if you want to edit settings of a CAD 
profi le, select it and then choose the Copy button from the Construction Options window; 
the copied CAD profi le will be listed in the Profi le list. Next, modify the settings of the 
copied CAD profi le. If you want to delete the copied settings of a CAD profi le, select the 
copied profi le and then choose the Delete button from the Construction Options window.
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Figure 1-53  The Construction Options window

Units
The Units area is used to set units for the user-defi ned or the copied CAD profi le. Click on the 
down arrow given on the right of this area to display different areas, which are discussed next.

Linear
 Click on the Linear down arrow to display the linear unit specifi cation that is set for the 

user-defi ned or copied CAD profi le. You can specify the scale factor, main units, sub units, 
and so on related to linear units.

Angular
 Click on the Angular down arrow to display the angular unit specifi cation that is set for 

the user-defi ned or copied CAD profi le. You can specify the scale factor, main units, sub 
units, and so on related to linear units.

 Tolerances
The Tolerances area is used to specify different tolerances for the user-defi ned or copied 
CAD profi le. Click on the down arrow given on the right of this area to display different areas, 
which are discussed next.
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Fitting
 Click on the Fitting down arrow to display fi tting specifi cations that are set for the 

user-defi ned or copied CAD profi le. In other words, the Fitting option allows you to specify 
permissible distances upto which curves and surfaces can be considered to be occupying 
the same place. You can specify curve fi t distance, curve fi t checkpoints, and maximum 
surface spans.

Continuity
 Click on the Continuity down arrow to display continuity specifi cations that are set for 

the user-defi ned or copied CAD profi le. In other words, the Continuity options allow you 
to specify permissible distances upto which curves and surface can be considered to be 
just touching each other. You can specify maximum gap distance, continuity angle, and 
continuity curvature.

Topology
 Click on the Topology down arrow to display topology specifi cations that are set for the 

user-defi ned or copied CAD profi le. The Topology Distance option allows you to specify 
the distance that determines the adjacency of surfaces. 

 Curve On Surface / Trim
 Click on the Curve On Surface / Trim down arrow to display specifi cations related to 

curves-on-surface and trimmed edges. You can specify the maximum deviation that is 
allowed between curves-on-surface and trimmed edges. You can also specify the maximum 
gap between the endpoints of various curves-on-surface to consider them continuous for 
the trimming operation.

 Rational Flags
The Rational Flags area allows you to use rational geometry for creating curves, surfaces, 
advanced surfaces, and primitives in the user-defi ned profi le or copied CAD profi le. Generally, 
the rational geometry is slower and harder to model. You need to use these options, only if 
required. The options in this area are discussed next.

Primitives
 Select this check box to create primitives using rational geometry.

 Fillets/Rounds
 Select this check box to create fi llets/rounds using rational geometry.

 Curves/Surfaces
 Select this check box to create all surfaces other than primitives, fi llets, and rounds using 

rational geometry.

Fonts
Click on the down arrow given on the right of the Fonts area to display different options. 
These options are used to specify the attributes related to fonts used in the user-defi ned or 
copied CAD package. You can specify the default modeling text size and text display mode.
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 COLOR SCHEMES
In Alias Design, you can use various color schemes as the background color of view windows. 
Also, you can use these color schemes to display different feature in it. By default, colors are 
assigned to modeling windows, active modeling features, inactive modeling features, and user 
interface. To change color schemes, choose Preferences > Interface > User Colors from 
the menu bar; the User Colors editor with four areas will be displayed. Click on the down 
arrow given on the right of the Active Modeling Colors area to display various features used 
in modeling with their default colors schemes, as shown in Figure 1-54. 

Choose the Color swatch box given on the right of any feature in the User Colors editor to 
display the Color editor. Select the required color from the Color editor; the color will be 
assigned to selected or active object. You can specify color for active control vertices, active 
edit points, active meshes, and so on by using the respective Color swatch boxes. Similarly, you 
can specify colors for inactive objects, inactive control vertices, inactive edit points, inactive 
meshes, view windows, templates, locators, grids, and so by using the options in the User 
Colors editor. You can also specify color for different objects, elements, and so on by using 
the slider bars on their right. You can create a color scheme that can be stored and retrieved 
later according to your requirements. Create a color scheme and then press and hold the left 
mouse button on the File button; a fl yout will be displayed. Choose the Store button from this 
fl yout; the Save Colors dialog box will be displayed. Specify name and location of the color 
scheme and the choose the Save button; the color scheme will be saved. To restore or retrieve 
color schemes, choose the Retrieve button from the File fl yout; the Retrieve Colors dialog 
box will be displayed. Specify the location and name of the color scheme that needs to be 
retrieved and then choose the Open button; the color scheme will be retrieved. Similarly, you 
can undo, redo, or reset the changes made in color schemes. To do so, press and hold the left 
mouse button on the Edit button; a fl yout will be displayed. Choose the corresponding button 
from the fl yout. The User Interface Colors area is used to specify the color of the cursor in 
view windows. 

Note
1. Throughout this book, we have used white, blue, and dark red colors for the background, 
inactive object, and active object, respectively. 

2. Every time you switch between workfl ows, the color schemes also change. However, you can 
store a color scheme in one workfl ow and then retrieve it in another workfl ow, so that you can 
work in one color scheme.

3. The topics discussed briefl y in this chapter will be covered in detail in later chapters. 
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Figure 1-54  The User Colors editor
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Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of this 
chapter: 

1. Work area or window area occupies the maximum space in Alias Design interface. (T/F)

2. You can customize tools by inserting them into the Control Panel. (T/F)

3. You can invoke the Paint window by pressing the F8 key. (T/F)

4. Alias Design allows you to display bookmarks in a cyclic manner. (T/F)

5. You cannot assign a hotkey to an existing hotkey. (T/F) 

6. Like the Object Lister window, the Scene Block Diagram window also displays the 
__________ of a model or an object in view windows.

7. Creation of __________ helps you organize fi les systematically.

8. The __________ dialog box enables you to change the settings for output, printer, paper 
specifi cations, information about model, and so on. 

9. Press the __________ keys to exit the current session of Alias Design.

10. The Viewing Panel appears in the __________ window. 

Answers to Self-Evaluation Test
1. T, 2. T, 3. F, 4. T, 5. F, 6. internal structure, 7. project directories, 8. Print Setup, 9. ALT+E, 
10. Perspective


