
Chapter 3

Adding Constraints 
and Dimensions to 

Sketches 

After completing this chapter, you will be able to:
• Add geometric constraints to a sketch.
• Control the constraint inference.
• View and delete constraints from a sketch.
• Dimension a sketch.
• Modify the dimensions of a sketch.
• Measure distances, angles, loops, and areas in a sketch.

Learning Objectives
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Adding Geometric Constraints To A Sketch 
Constraints are applied to the sketched entities to define their size and position with respect 
to other elements. Also, they are useful for capturing the design intent. As mentioned in 
Chapter 1, there are twelve types of geometric constraints that can be applied to the sketched 
entities. These constraints restrict their degrees of freedom and make them stable. Most of these 
constraints are automatically applied to the entities while drawing. However, sometimes you 
may need to apply some additional constraints to the sketched entities. These constraints are 
discussed next.

Perpendicular Constraint
 Ribbon:	 Sketch > Constrain > Perpendicular Constraint  

The Perpendicular Constraint forces the selected entity to become perpendicular to 
the specified entity. The entities to which the constraints can be applied are lines and  
ellipse axes. To apply this constraint, choose the Perpendicular Constraint tool from 

the Constrain panel of the Sketch tab; you will be prompted to select the first line or an ellipse 
axis. After selecting the first entity, you will be prompted to select the second line or ellipse 
axis. On selecting the second entity, the selected entities will become perpendicular. Figure 3-1 shows 
two lines before and after adding this constraint. In Autodesk Inventor 2013, you can also 
apply the Perpendicular Constraint between two arcs.

Parallel Constraint
 Ribbon:	 Sketch > Constrain > Parallel Constraint	

The Parallel Constraint forces the selected entity to become parallel to the specified 
entity. The entities to which this constraint can be applied are lines and ellipse axes. 
To apply this constraint, choose the Parallel Constraint tool from the Constrain 

panel of the Sketch tab; you will be prompted to select the first line or an ellipse axis. After 
you select an entity, you will be prompted to select the second line or an ellipse axis. On 
selecting the second entity, the two entities will become parallel. Figure 3-2 shows two lines 
before and after adding this constraint.

Figure 3-1  Applying the Perpendicular 
Constraint

Figure 3-2  Applying the Parallel Constraint
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Tangent Constraint
 Ribbon:	 Sketch > Constrain > Tangent  

The Tangent Constraint forces the selected line segment or curve to become tangent 
to another curve. To apply this constraint, choose the Tangent tool from the Constrain 
panel of the Sketch tab; you will be prompted to select the first curve. After you select 

the first curve, you will be prompted to select the second curve. The curves that can be selected 
are lines, circles, ellipses, or arcs. Figures 3-3 and 3-4 show the Tangent constraint applied 
between line and circle and between ellipse and arc respectively.

Figure 3-3  Applying the Tangent Constraint
between line and circle

Figure 3-4  Applying the Tangent Constraint 
between ellipse and arc

Coincident Constraint
 Ribbon:	 Sketch > Constrain > Coincident Constraint  

The Coincident Constraint forces two points or a point and a curve to become 
coincident. To apply this constraint, choose the Coincident Constraint tool from the 
Constrain panel of the Sketch tab; you will be prompted to select the first curve or 

point. After you select the first curve or point, you will be prompted to specify the second 
curve or point. Note that either the first or the second entity selected should be a point. The 
points include sketch points, endpoints of a line or an arc, or center points of circles, arcs, or 
ellipses.

Concentric Constraint
 Ribbon:	 Sketch > Constrain > Concentric Constraint  

The Concentric Constraint forces two curves to share the same location of center 
points. The curves that can be made concentric include arcs, circles, and ellipses. 
When you invoke this constraint, you will be prompted to select the first arc, circle, or 

ellipse. After making the first selection, you will be prompted to select the second arc, circle, 
or ellipse. Select the second entity to be made concentric with the first entity.



3-4	             					                 Autodesk Inventor for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Note
If you apply a constraint that over-constrains a sketch, the Autodesk Inventor Professional - Create 
Constraint message box will be displayed, informing that adding this constraint will 
over-constrain the sketch, see Figure 3-5. A sketch is said to be over-constrained if the number 
of dimensions or constraints in it exceeds the number that can be applied to the sketch.

Figure 3-5  The Autodesk Inventor Professional - Create Constraint message box 

Collinear Constraint
 Ribbon:	 Sketch > Constrain > Collinear Constraint  

The Collinear Constraint forces the selected line segments or ellipse axes to be placed 
in the same line. When you invoke this constraint, you will be prompted to select the 
first line or ellipse axis. After making the first selection, you will be prompted to select 

the second line or ellipse axis. Select the entity to be made collinear with the first entity.

Tip. To select an ellipse axis, move the cursor close to the ellipse. Depending on 
whether the cursor is close to the major axis or the minor axis, the particular axis 
will be highlighted. When the required axis is highlighted, select it using the left 
mouse button.

Horizontal Constraint
 Ribbon:	 Sketch > Constrain > Horizontal Constraint  

The Horizontal Constraint forces the selected line segment, ellipse axis, or two points 
to become horizontal, irrespective of their original orientation. When you invoke this 
constraint, you will be prompted to select a line, an ellipse axis, or the first point. If 

you select a line or an ellipse axis, it will become horizontal. If you select a point, you will be 
prompted to select the second point. The points, in this case, can also include the center 
points of arcs, circles, or ellipses.

Vertical Constraint
 Ribbon:	 Sketch > Constrain > Vertical Constraint  

The Vertical Constraint is similar to the Horizontal Constraint, with the difference 
that this constraint forces the selected entities to become vertical.
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Tip. You can use the Horizontal or Vertical constraint to line up arcs, circles, 
or ellipses in the same horizontal or vertical direction by selecting their center 
points.

Equal Constraint
 Ribbon:	 Sketch > Constrain > Equal  

The Equal Constraint can be used for line segments or curves. If you select two line 
segments, this constraint will force the length of one of the selected line segments to 
become equal to the length of the other selected line segment. In case of curves, this 

constraint will force the radius of one of the selected curves to become equal to that of the 
other selected curve. Note that if the first selection is a line, the second selection also has to 
be a line. Similarly, if the first selection is a curve, the second selection also has to be a 
curve.
	

Fix Constraint
 Ribbon:		 Sketch > Constrain > Fix  

This constraint is used to fix the orientation or location of the selected curve or point 
with respect to the coordinate system of the current drawing. If you apply this 
constraint to a line or an arc, you cannot move them from their current locations. 

However, you can change their length by selecting one of their endpoints and then dragging 
it. If you apply this constraint to a circle or an ellipse, you cannot edit either of these entities 
by dragging. Once you apply this constraint to an entity, its color changes from black to 
blue.
 

Symmetric Constraint
 Ribbon:		 Sketch > Constrain > Symmetric  

This constraint is used to force two selected sketched entities to become symmetrical 
about a single sketched line segment. On invoking this constraint, you will be prompted 
to select the first sketched entity. Note that you can select only one entity at a time to 

apply this constraint. Once you have selected the first sketched entity, you will be prompted 
to select the second sketched entity. Select the second sketched entity; you will be prompted 
to select the symmetry axis. Select the symmetry axis (an axis about which the selected 
entities need to be symmetric); the second selected entity will become symmetric to the first 
entity. After you have applied this constraint to one set of entities, you will again be prompted 
to select the first and second sketched entities. However, this time you will not be prompted 
to select the line of symmetry. The last line of symmetry will be automatically selected to add 
this constraint. Similarly, you can apply this constraint to other entities. 

If the line of symmetry is different for applying the symmetric constraint to different entities in 
the sketch, you will have to restart the process of applying this constraint by right-clicking and 
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then choosing the Restart option from the Marking Menu. This is because the first symmetry 
line is used to apply this constraint to all the sets of entities you select. However, if you restart 
applying this constraint, you will be prompted to select the line of symmetry again.

Smooth Constraint
 Ribbon:	 Sketch > Constrain > Smooth (G2)  

This constraint is used to apply curvature continuity between a spline and an entity 
connected to it. The entities that can be selected to apply this constraint include a 
line, arc, or another spline. Note that these entities should be connected to the 
spline.

Note
In this release of Autodesk Inventor, you can apply the Perpendicular, Tangent and Smooth 
(G2) constraints between different type of splines. 

Viewing the Constraints Applied to a Sketched 
entity
 Ribbon:	 Sketch > Constrain > Show Constraints  

You can view all constraints that are applied to the entities of a sketch by choosing 
the Show Constraints tool from the Constrain panel. When you invoke this tool and 
move the cursor close to any sketched entity, it will

Figure 3-6  The constraint boxes 
showing the constraints applied to 
the entities

 
be highlighted and boxes will be displayed after a pause. 
These boxes show the symbols of all constraints that are 
applied to the entity. The symbols of the constraints will 
be highlighted in yellow box. Select the entity to retain the 
constraint box; the constraint box will be displayed with 
the constraints in a white background. Figure 3-6 shows 
the constraint boxes along with the constraints applied to 
the lines. You can move this box by selecting it and 
dragging. To close a box, choose the cross (X) on the 
extreme right of the box. In the case of Coincident 
Constraint, the constraint applied on a point is highlighted 
in yellow, instead of a box. To view symbols, move the cursor 
over the highlighted yellow point; the yellow point will be 
highlighted in red border and the symbols will be displayed 
in boxes, refer to Figure 3-6.

If you move the cursor close to a constraint in the constraint box, it will be highlighted in yellow 
and the entities to which the constraint is applied are highlighted in red. For example, if you 
take the cursor close to the perpendicular constraint, the vertical line will also be highlighted 
along with the horizontal line, suggesting that the horizontal line is perpendicular to the 
vertical line.
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Tip. You can also display the constraints applied to all entities in the drawing. To 
display all constraints, choose the Show All Constraints button from the bottom 
of the graphics Window; separate boxes will be displayed showing the constraints 
on all entities. Similarly, to hide all constraints, choose the Hide All Constraints 
button from the bottom of the graphics window.

Controlling Constraints and applying them 
automatically while sketching
 Ribbon:	 Sketch > Constrain Drop-down > Constraint Options 

You can control and select the constraints that need to be applied automatically as 
well as select the geometry to which they will be applied. The tools and the procedure 
of selecting the constraints and the geometry are discussed next.

Selecting Constraints
By default, all possible constraints are applied automatically on the sketching entities while 
drawing the sketches. However, you can also specify the constraints that need to be applied 
automatically and the geometry to which they will be applied while sketching. To do so, choose 
the Constraint Options tool from the Constrain drop-down of the Sketch tab; the Constraint 
Options dialog box will be displayed, as shown in Figure 3-7. The options in this dialog box 
are discussed next.

Figure 3-7  The Constraint Options dialog box

Selection for Constraint Inference Area
In this area, nine types of constraints and two buttons are available. All constraints in this area 
are selected by default. However, if you need to clear all the constraints, choose the Clear All 
button. You can manually select or clear the required constraint by selecting the corresponding 
check box provided on the right of the constraint symbols. The selected constraints will be 
applied automatically to the geometry while sketching. 
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Scope of Constraint Inference Area
 Ribbon:	 Sketch > Constrain Drop-down > Constraint Persistence  

This area is used to set the geometry to which constraint is applied while drawing. By 
default, the All Geometry check box is selected to apply the constraint to all the active 
sketches. If you clear this check box, the Select button will be activated automatically. 

You can use this button to select the geometry to which the constraints will be applied.

Applying Constraints
To apply the constraints selected in the Constraint Options dialog box, you need to choose 
the Constraint Persistence button from the Constrain panel. This is a toggle button and if 
you choose it, the Constraint Inference button will be activated and all the constraints selected 
earlier in the Constraint Options dialog box will be applied to the sketches while drawing 
them. You can also switch off the inference of the constraint by choosing this button again.

Deleting Geometric Constraints
Autodesk Inventor allows you to delete the constraints applied to the selected entities. To 
delete constraints, first you need to invoke the constraint box by using the Show Constraints 
tool. Once the constraints are displayed, exit the Show Constraints tool by pressing the ESC 
key. Next, move the cursor over the constraint that you want

Figure 3-8  Choosing the Delete   
option from the Marking Menu

 
to delete; it will be highlighted in yellow. Click the left mouse 
button to select the constraint; a red box will appear around 
the constraint. Next, move the cursor away and right-click, 
and then choose Delete from the Marking menu, see 
Figure 3-8. The selected constraint will be deleted and 
removed from the constraint box. Similarly, you can delete 
all unwanted constraints from the sketch.

Note
The total number of constraints and dimensions required to fully constrain a sketch is displayed 
at the lower right corner of the drawing window.

Tip. When you move the cursor close to the constraint in the constraint box, its 
references will be highlighted in the sketch. For example, if you move the cursor over 
the Perpendicular constraint, the lines on which this constraint is applied will be 
highlighted. This allows you to confirm that the constraint selected is correct.

Adding Dimensions to Sketches
 Ribbon:	 Sketch > Constrain > Dimension	  

After drawing a sketch and adding constraints to it, dimensioning is the next most 
important step in creating a design. As mentioned earlier, Autodesk Inventor is a 
parametric solid modeling package. The parametric property ensures that irrespective 

of its original size, the selected entity is driven by the specified dimension value. Therefore, 
whenever you modify or apply dimension to an entity, it is forced to change its size with respect 
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to the specified dimension value. The type of dimension to be applied varies according to the 
type of entity selected. For example, if you select a line segment, linear dimensions will be 
applied and if you select a circle, diameter dimensions will be applied. Note that all these 
types of dimensions can be applied using the same dimensioning tool. To edit the dimension, 
double-click on the dimension; the Edit Dimension edit box will be displayed, see 
Figure 3-9. Enter the desired value in the edit box to modify it. This edit box is used to 
modify the dimensions of an entity. The selected entity will be driven to the dimension value 
defined in this edit box.You can enter a new value for the dimension or choose the button on 
the right of this edit box to accept the default value.

If you do not want to edit the dimensions after they have been placed, invoke the Dimension 
tool and then right-click to display the Marking Menu, refer to Figure 3-10. Clear the check 
mark on the left of the Edit Dimension option by choosing it again. When you place a 
dimension now, the Edit Dimension edit box will not be displayed. To edit the dimension 
value in this case, click on it after placing, if the Dimension tool is still active. If the tool is not 
active, double-click on the dimension; the Edit Dimension edit box will be displayed. Enter 
the new dimension value in this toolbar. The dimensioning techniques available in Autodesk 
Inventor are discussed next.

Figure 3-10  Choosing Edit 
Dimension from the Marking Menu

Figure 3-9  The Edit Dimension 
edit box

Linear Dimensioning
The linear dimensions are defined as the dimensions that specify the shortest distance between 
two points. You can apply linear dimensions directly to a line or select two points or entities to 
apply the linear dimension between them. The points that you can select include the endpoints 
of lines, splines, or arcs, or the center points of circles, arcs, or ellipses. You can dimension a 
vertical or a horizontal line by directly selecting it. As soon as you select it, the dimension will 
be attached to the cursor. You can place the dimension at any desired location. If the priority 
for editing the dimensions is set, the Edit Dimension toolbar will be displayed as soon as you 
place the dimension. To place the dimension between two points, select the points one by 
one. After selecting the second point, right-click to display the Marking menu, as shown in 
Figure 3-11. In this menu, choose the dimension type. 
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Figure 3-11  Marking Menu displaying 
various options to dimension two points

If you choose Horizontal, the horizontal dimension will be placed between the two selected 
points. If you choose Vertical, the vertical dimension will be placed between the two selected 
points. If you choose Aligned, the aligned dimension will be placed between the two selected 
points. Figure 3-12 shows the linear dimensioning of lines and Figure 3-13 shows the linear 
dimensioning of two points.

Figure 3-13  Linear dimensioning of two pointsFigure 3-12  Linear dimensioning of lines

You can also apply a horizontal or vertical dimension to an inclined line, see Figure 3-14. To 
apply these dimensions, select the inclined line and then right-click; a Marking Menu similar 
to the one shown in Figure 3-11 will be displayed. In this menu, choose Horizontal to place 
the horizontal dimension and Vertical to place the vertical dimension.
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Figure 3-14  Linear dimensioning of an inclined line

Aligned Dimensioning
The aligned dimensions are used to dimension the lines that are not parallel to the X or 
Y-axis. This type of dimension measures the actual distance of the aligned lines or the lines 
drawn at a certain angle. To apply the aligned dimension, select the inclined line and then 
right-click; a Marking Menu will be displayed, refer to Figure 3-11. Choose the Aligned option 
from the Marking Menu; the aligned dimension of the selected line will be attached to the 
cursor. Next, click in the drawing window to specify the location of the aligned dimension. You 
can also apply the aligned dimension between two points. The points include the endpoints 
of lines, splines, or arcs or the center points of arcs, circles, or ellipses. To apply the aligned 
dimension between two points, invoke the Dimension tool. Next, select the two points and 
right-click; a Marking Menu will be displayed. Choose the Aligned option from the Marking 
Menu. Figures 3-15 and 3-16 show the aligned dimensions applied to various objects.

Figure 3-16  Aligned dimension between two pointsFigure 3-15  Aligned dimension of a line
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Angular Dimensioning
The angular dimensions are used to dimension angles. You can select two line segments or 
use three points to apply the angular dimensions. You can also use angular dimensioning to 
dimension an arc. All these options of angular dimensioning are discussed next.

Angular Dimensioning Using Two Line Segments 
You can directly select two line segments to apply angular dimensions. To do so, invoke the 
Dimension tool of the Constrain tab from the Ribbon. You can also invoke General Dimension 
from the Marking Menu and then select a line segment using the left mouse button. Instead 
of placing the dimension, select the second line segment. Next, place the dimension to 
measure the angle between the two lines. While placing the dimension, you need to be careful 
about the point where you place the dimension. This is because depending on the location 
of the placement of dimension with respect to the lines, the vertically opposite angles will 
be displayed. Figure 3-17 shows the angular dimension between two lines and Figure 3-18 
shows the dimension of the vertically opposite angle between two lines. Also, depending on 
the location of the dimension, the major or minor angle value will be displayed. Figure 3-19 
shows the major angle dimension between two lines and Figure 3-20 shows the minor angle 
dimension between the same set of lines.

Figure 3-17  Angular dimensioning Figure 3-18  Vertically opposite angle

Figure 3-20  Minor angle dimensionFigure 3-19  Major angle dimension
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Angular Dimensioning Using Three Points
You can also apply angular dimensions using three points. Remember that the three points 
should be selected in the clockwise or counterclockwise sequence. The points that can be used 
to apply the angular dimensions include the endpoints of lines or arcs, or the center points of 
arcs, circles, and ellipses. Figure 3-21 shows angular dimensioning using three points.
 
Angular Dimensioning of an Arc
You can use angular dimensions to dimension an arc. In case of arcs, the three points 
are the endpoints and the center point of the arc. Note that the points should be 
selected in the clockwise or counterclockwise sequence, but the center point should 
always be the second selection point. Figure 3-22 shows the angular dimensioning of an arc. 
In Autodesk Inventor 2013, you can also assign angular dimensions to an arc by the Marking 
menu. To do so, invoke the Dimension tool. Then select the arc and right-click; a Marking 
menu will be displayed. Choose Dimension Type from the Marking menu; a cascading menu 
will be displayed, choose Arc Length from the cascading menu before placing the dimension 
on the graphics window, refer to Figure 3-23. Figure 3-24 shows the angular dimensioning of 
an arc by marking menu. 

Figure 3-22  Angular dimensioning of an arcFigure 3-21  Angular dimensioning using 
three points

Figure 3-24  Angular dimensioning of an arcFigure 3-23  Angular dimensioning using 
Marking menu
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Diameter Dimensioning
Diameter dimensions are applied to dimension a circle or an arc to specify its diameter. In 
Autodesk Inventor, when you select a circle to dimension, the diameter dimension is applied 
to it by default. If you select an arc to dimension it, the 

Figure 3-25  Marking menu to apply 
a diameter dimension to an arc

radius dimension will be applied to it. You can also apply 
the diameter dimension to an arc. To do so, invoke the 
Dimension tool and then select the arc. Next, right click 
to display the Marking menu, as shown in Figure 3-25. 
From the Marking menu, choose Dimension Type; a 
cascading menu is displayed. Choose Diameter from this 
menu to apply the diameter dimension. Figure 3-26 shows 
a circle and an arc with diameter dimensions.

Figure 3-26  Diameter dimensioning of a circle and an arc

Radius Dimensioning
Radius dimensions are applied to dimension an arc or a circle to specify its radius. As mentioned 
earlier, by default, circles are assigned diameter dimensions and arcs are assigned radius 
dimensions. However, you can also apply the radius 

Figure 3-27  Marking menu to apply a 
radius dimension to an arc

dimension to a circle. To do so, invoke the 
Dimension tool and then select the circle. Next, 
right-click to display the Marking menu, as shown 
in Figure 3-27. From the Marking menu, choose 
Dimension Type; a cascading menu is displayed. 
Choose Radius from this menu to apply the radius 
dimension. Figure 3-28 shows an arc and a circle 
with radius dimensions.
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Figure 3-28  Radius dimensioning of a circle and an arc

Linear Diameter Dimensioning
Linear diameter dimensioning is used to dimension the sketches of the revolved components. 
The sketch for a revolved component is drawn using simple sketcher entities. For example, 
if you draw a rectangle and revolve, it will result in a cylinder. Now, if you dimension the 
rectangle using the linear dimensions, the same dimensions will be displayed when you 
generate the drawing views of the cylinder. Also, the same dimensions will be used while 
manufacturing the component. But these linear dimensions will result in a confusing situation in 
manufacturing. This is because while manufacturing a revolved component, the dimensions 
have to be specified as the diameter of the revolved component. The linear dimensions will 
not be acceptable in manufacturing a revolved component. To resolve this problem, the 
sketches for the revolved features are dimensioned using the linear diameter dimensions. 
These dimensions display the distance between the two selected line segments as a diameter, 
that is, double the original length. For example, if the original dimension between two entities 
is 10 mm, the linear diameter dimension will display it as 20 mm. This is because when you 
revolve a rectangle with 10 mm width, the diameter of the resultant cylinder will be 20 mm. 
In this type of dimension, if you select two lines, the line selected first will act as the axis of 
revolution for the sketch and the line selected last will result in the outer surface of the revolved 
feature. It means the line selected last will be the one that will be dimensioned. But, if one of 
these lines is a centerline drawn by choosing the Centerline tool from the Format panel, the 
centerline will be considered as the axis of revolution.

To apply linear diameter dimensions, invoke the Dimension tool;

Figure 3-29  Choosing the 
Linear Diameter option 

 
you will be prompted to select the first geometry to dimension. 
Select the first line; you will be prompted to select the second 
geometry to dimension. Select the second line with reference to 
which you want to apply the linear diameter dimensions. If the 
first line selected is a centerline, the linear diameter dimension 
will be displayed. Else, right-click and then choose Linear 
Diameter from the Marking Menu, see Figure 3-29. You will notice 
that the distance between the two lines is displayed as twice the 
distance. Also, the dimension value is preceded by the Ø symbol, indicating that it is a linear 
diameter dimension. Figures 3-30 and 3-31 show the use of linear diameter dimensioning.
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Figure 3-30  Selecting elements for linear
diameter dimension

Figure 3-31  The linear diameter dimension

Tip. After invoking the Dimension tool, as you move the cursor close to the sketched 
entities, a small symbol will be displayed close to the cursor. This symbol displays 
the type of dimension that will be applied. For example, if you select a line, the 
linear dimensioning or aligned dimensioning symbol will be displayed. If you 
move the cursor close to another line after selecting the first, the symbol of angular 
dimensioning will be displayed. These symbols help you in determining the type of 
dimensions that will be applied.

In Autodesk Inventor, the ellipses are dimensioned as half of the major and minor 
axes distances. To dimension an ellipse, invoke the Dimension tool and then select 
the ellipse. Now, if you move the cursor in the vertical direction, the axis of the 
ellipse along the X-axis will be dimensioned in terms of its half length. Similarly, 
if you move the cursor in the horizontal direction, the axis of the ellipse along the 
Y axis will be dimensioned equal to its half-length.

To distinguish whether the dimension applied to an arc or a circle is a radius or a 
diameter, try to locate the number of arrowheads in the dimension. If there are two 
arrowheads in the dimension and the dimension line is placed inside the circle or 
the arc, it is a diameter dimension. The radius dimension has one arrowhead and 
the dimension line is placed outside the circle or the arc.

setting the scale of a Sketch
In Autodesk Inventor 2013, if you change the current length of an entity by changing 
its dimension value, all the other entities of the sketch gets modified proportionally 
or scaled accordingly. Note that this will be applicable only if no other dimension is applied 
to the sketch. As you apply the second dimension to the sketch, the sketch will not be scaled 
proportionally, on changing the dimension value. Figure 3-32 shows the sketch without any 
dimension and Figure 3-33 shows the sketch scaled automatically after applying the first 
dimension to it.
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Figure 3-32  Sketch on the graphics screen Figure 3-33  Sketch resized after editing the  
first dimension 

Creating Driven Dimensions
 Ribbon:	 Sketch > Format > Driven Dimension  

This toggle button is used to switch between the driven dimension and the sketch 
(driving) dimension. A dimension is called as a sketch (driving) dimension, if it 
forces an entity to change its length and orientation. A driven dimension is the one 

whose value depends on the value of the sketch (driving) dimension. The driven dimensions 
are enclosed within parenthesis and display the current value of the sketched geometry. This 
value cannot be modified. If you change the value of the sketch (driving) dimension, the 
value of the driven dimension will change automatically, as shown in Figures 3-34 and 3-35. 
All dimensions applied after choosing the Driven Dimension button will be the driven 
dimensions. To convert sketch (driving) dimensions into driven dimensions, select the required 
sketch (driving) dimension and choose the Driven Dimension button from the Format 
panel.  

Figure 3-35  Modified driving dimension and 
dynamically updated driven dimension 

Figure 3-34  Driving dimension and driven 
dimension in a sketch
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Understanding the Concept of Fully-Constrained 
Sketches
A fully-constrained sketch is the one whose all entities are completely constrained to their 
surroundings using constraints and dimensions. In a fully-constrained sketch, all degrees 
of freedom of the sketch are constrained. A fully-constrained sketch cannot change its size, 
location, or orientation unexpectedly. Whenever you draw a sketched entity, it will turn black 
in color. If you add dimensions and constraints to fully constrain the sketch, the entities 
will turn blue. There is one more method to understand whether the sketched entities are 
fully-constrained or not. In this method, you need to right-click on the sketched entity and 
choose the Display Degrees of Freedom option from the Marking Menu displayed; the entities 
will display the available degrees of freedom such as horizontal, vertical, angular, or rotational. 
Alternatively, click on the Show All Degrees of Freedom toogle button available at the bottom 
of the graphics window to display the degrees of freedom. Note that while creating the base 
sketch in Autodesk Inventor, you need to dimension it with respect to a fixed point to fully 
constrain it. To do so, you can fix the sketch with the origin, which is already fixed by default. 
You can control the visibility of this origin. To hide this point, choose the Application Options 
button from the Tools tab; the Application Options dialog box will be invoked. Choose the 
Sketch tab and then clear the Autoproject part origin on sketch creation check box. Next, 
close the dialog box.

Tip. In Autodesk Inventor 2013, a fully-constrained sketch is displayed by  
symbol in the Browser Bar, when you switch to the Part module.

Measuring Sketched Entities
Autodesk Inventor allows you to measure various parameters of the sketched entities. The 
parameters that you can measure are distances, angles, loops, and area. Measuring these 
parameters is discussed next.

Measuring Distances
 Ribbon:	 Tools > Measure > Distance  

Autodesk Inventor allows you to measure the length of a line segment, radius of an arc, diameter 
of a circle, minimum distance between two entities, or coordinates of a point. All these distances 
can be measured by using the Distance tool from the Measure panel. On invoking this tool, 
the Measure Distance dialog box will be displayed and you will be prompted to select the 
first item. The name of the Measure Distance dialog box is modified depending upon the 
type of entities selected to be measured. The methods of measuring distances between various 
entities are discussed next.

Tip. To restart measuring the distances, right-click in the graphics window to display 
a shortcut menu and then choose Restart; you will be prompted to select the first 
element to be measured. Alternatively, choose the right arrow displayed next to the 
display box in the Measure Distance dialog box and then choose Restart option 
from the flyout displayed.
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Measuring the Length of a Line Segment
When you invoke the Distance tool, the Measure Distance

Figure 3-36  The Length dialog box 
displaying the length of a line segment 

 
dialog box will be displayed and you will be prompted to 
select the first entity. Select a line segment; the Measure 
Distance dialog box will be changed to the Length dialog 
box and the length of the selected line segment will be 
displayed in this dialog box, see Figure 3-36.	

Measuring the Distance between a Point and a Line Segment
To measure the distance between a point and a line

Figure 3-37  The Minimum Distance 
dialog box displaying the distance between 
the lines 

segment, invoke the Distance tool and then select the 
point. The Measure Distance dialog box will be 
modified to the Position dialog box, which shows the 
X, Y, and Z coordinates of the point, and you will be 
prompted to select the next entity. Select the line; the 
Position dialog box will change to the Minimum 
Distance dialog box. This dialog box will display the 
minimum distance between the point and the line, 
and the length of the line, see Figure 3-37.

Measuring the Coordinates of a Point
To measure the coordinates of a point with respect to the current coordinate system, invoke 
the Distance tool; you will be prompted to select the first element. Select the point whose 
coordinates you want to know. The selectable points

Figure 3-38  The Position dialog box 
displaying the coordinates of a point

include the endpoints of lines, arcs, or splines, center 
point of arcs, circles, or ellipses, or hole centers. If you 
select a hole center or the center point, the Measure 
Distance dialog box will change into the Position 
dialog box and the X, Y, and Z coordinates of the selected 
point with respect to the current coordinate system will 
be displayed, see Figure 3-38. However, if you select an 
endpoint, the coordinates will be specified in the Measure 
Distance dialog box.

Measuring the Distance between Two Points
To measure the distance between two points, invoke the

Figure 3-39  The Minimum 
Distance dialog box

 
Distance tool and then select the first point; the coordinates 
of the selected point will be displayed in the Position dialog 
box. You will be prompted to select the second element. Select 
the second point; the Position dialog box will be changed to 
the Minimum Distance dialog box. This dialog box will display 
the distance between the two points. This dialog box will also 
display the coordinates of the second point. You will also notice 
the Delta X, Delta Y, and Delta Z values in this dialog box, 
see Figure 3-39. These values are the distances between the 
two selected points along the X, Y, and Z axes.
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Tip. In Autodesk Inventor 2013, you can also measure distance between the 
midpoint of a linear segment and midpoint of a circular arc.

Measuring the Radius of an Arc or the Diameter of a Circle
You can also measure the radius of an arc or the diameter of a circle by using the Distance 
tool. When you invoke this tool, the Measure Distance dialog box will be displayed and you 
will be prompted to select the first item. If you select an arc or move the cursor over the arc, 
this dialog box will be momentarily changed to the Radius dialog box and will display the 
radius of the arc, see Figure 3-40. If you select a circle or move the cursor over the circle, 
this dialog box will momentarily change into the Diameter dialog box and will display the 
diameter of the circle, see Figure 3-41. Note that if you select an arc or a circle, you will not 
be prompted to select the second element because you cannot calculate any value other than 
their radius or diameter.

Figure 3-40  The Radius dialog 
box displaying the radius of the arc 

Figure 3-41  The Diameter dialog box 
displaying the diameter of the circle

Measuring Angles
 Ribbon:	 Tools > Measure > Angle  

To measure an angle, right-click in the drawing window and choose Measure > Measure Angle 
from the Marking menu; the Measure Angle dialog box will be displayed. Alternatively, choose 
the Angle tool from the Measure panel. This tool is used to measure the angle between two 
line segments or among three points. Both these methods for measuring angles are discussed 
next.

Measuring the Angle between Two Lines
To measure the angle between two lines, invoke the Angle tool; the Measure Angle dialog 
box will be displayed and you will be prompted to select the first

Figure 3-42  The Angle dialog 
box displaying the angle between 
two lines

 
item. Select the first line; you will be prompted to select the 
second line. Select the second line; the Measure Angle 
dialog box will change momentarily into the Angle dialog 
box and the angle between the selected line segments will 
be displayed, refer to Figure 3-42.

Measuring the Angle Using Three Points
You can also measure the angle using three points. When you invoke the Angle tool, you will 
be prompted to select the first item. Select the first point; you will be prompted to select the 
next point. After you select the second point, you will again be prompted to select the next 
point. Select the third point. Once you have selected the three points, Autodesk Inventor 
draws imaginary lines between the first and second points as well as between the second and 
third points. The angle between these two imaginary lines will be measured and displayed in 
the dialog box, as shown in Figures 3-43 and 3-44.
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Figure 3-44  Angle between imaginary linesFigure 3-43  Selecting three points

Tip. Autodesk Inventor allows you to switch from one measuring tool to another. 
This is done using the flyout that is displayed on choosing the arrow on the right of 
the dialog box of any measuring tool. When you choose this arrow, the flyout will 
be displayed with the options for invoking other measuring tools.

Measuring Loops
 Ribbon:	 Tools > Measure > Loop  

Autodesk Inventor allows you to measure closed loops. To measure closed loops, right-click 
in the drawing window and choose Measure > Measure Loop from the Marking menu; 
the Measure Loop dialog box will be displayed. Alternatively, choose the Loop tool from 
the Measure panel; you will be prompted to select a face or a loop. Select the loop to be 
measured; the Measure Loop dialog box will be momentarily changed to the Loop Length 
dialog box and the measurement will be displayed in it. Figure 3-45 shows the Measure Loop 
dialog box with the measurement of a loop.

Measuring the Area
 Ribbon:	 Tools > Measure > Area  

To measure the area of closed loops, right-click in the drawing window and choose Measure > 
Measure Area from the Marking Menu; the Measure Area dialog box will be displayed and 
you will be prompted to select a face or a loop. Select the closed loop to measure the area; 
the Measure Area dialog box will be momentarily changed to the Area dialog box and the 
area of the loop will be displayed in it. Figure 3-46 shows the Area dialog box with the area 
of a closed loop.

Figure 3-45  The Measure Loop 
dialog box

Figure 3-46  The Area dialog box
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Tip. You can also measure the loop or the area defined by the face of an existing 
feature. You will learn more about features in the later chapters.

Adding Linear Measurements
 Marking Menu:	 Measure > Measure Distance  

You can calculate the total measurement of several linear measurements by adding their 
values. To do so, invoke the Distance or Angle tool. Next, select the geometry or the distance 
to be measured; the measurement will be displayed in the Measure Distance dialog box. 
Next, click the arrow on the right side of the display box; a flyout will be displayed. Choose 
the Add to Accumulate option from the flyout and choose the same arrow again; the same 
flyout will be displayed. Choose the Restart option from the flyout. Next, choose another 
measurement and follow the same procedure until you add all the desired measurements. 
Then, click on the arrow and choose the Display Accumulate option from the flyout; the sum 
of the measurements will be displayed in the dialog box.

Clearing Accumulated Dimensions
On choosing the Clear Accumulate option, you can clear all the accumulated measurements 
and reset the sum to zero. This option is located below the Add to Accumulate option.

Evaluating Region Properties
 Ribbon:	 Tools > Measure > Region Properties  

This tool is used to evaluate the properties of the closed loop sketch such as area, perimeter, 
and also display the region properties of the sketch such as Area and Moment of Inertia by 
taking measurements from the sketch coordinate system. To invoke this tool, right-click in 
the drawing window and choose Measure > Region Properties from the Marking menu; the 
Region Properties dialog box will be displayed, as shown in Figure 3-47. Alternatively, invoke 
the Region Properties tool by choosing the Region Properties tool from the Measure panel. 
The options in this dialog box are discussed next.

Selections
When you invoke the Region Properties dialog box, this option is chosen by default and you 
will be prompted to select one or more closed sketch loops. Select one or more closed sketch 
loops from the drawing window.
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Figure 3-47  The Region Properties dialog box

Dual Units
You can select the required unit of measurement from this drop-down list to display the results 
of measurements in the selected unit. You can view the results in two different units.

Calculate
After setting the options in the Selections and the Dual Units area, choose the Calculate 
button; the results will be displayed in the display box. In case you add or remove a closed loop 
in the Selections area or change the unit in the Dual Units drop-down list, the recalculation will 
occur and the updated results will be displayed in the display box.

Tutorials
From this chapter onward, you will use the parametric feature of Autodesk Inventor for 
drawing and dimensioning the sketches. The following tutorials will explain the method of 
drawing sketches with some arbitrary dimensions and then driving them to the dimension 
values required in the model.

Tutorial 1
In this tutorial, you will draw the sketch shown in Figure 3-48. This sketch is the same as the 
one drawn in Tutorial 2 of Chapter 2. After drawing the sketch, you will add the required 
constraints and then dimension it. 			     	   (Expected time: 30 min)
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Figure 3-48  Dimensioned sketch for Tutorial 1

The following steps are required to complete this tutorial:

a.	 Start a new metric standard part file and invoke the Sketching environment.
b.	 Draw the initial sketch by using the Line and Two point rectangle tools, refer to 

Figure 3-49.
c.	 Add the required constraints and dimensions to complete the sketch, refer to 

Figure 3-51.
d.	 Dimension the sketch by using the origin to fully constrain it, refer to Figure 3-52.
e.	 Save the sketch with the name Tutorial1 and then close the file.

Starting a New File and Invoking the Sketching Environment
	 Start Autodesk Inventor and then invoke the Sketching environment by selecting the 

sketching plane.

1.	 Start Autodesk Inventor by double-clicking on its shortcut icon on the desktop of your 
computer or by using the Start menu.

2.	 Choose the New tool from the Quick Access Toolbar and start a new metric standard 
part file by using the Metric tab of the New File dialog box.

Note
If the Welcome dialog box is displayed by default on invoking the Autodesk Inventor, you can 
also choose the New button from it.

3.	 Choose the Create 2D Sketch button from the Sketch panel of the 3D Model tab; the 
default planes are displayed and you are prompted to select the sketching plane.

4.	 Select the XY plane as the sketching plane from the graphics window; the Sketching 
environment is invoked and the XY Plane becomes parallel to the screen. Alternatively 
you can select XY plane from the Browser Bar. 



Adding Constraints and Dimensions to Sketches				          3-25

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Drawing the Initial Sketch
1.	 Using the Line tool and the Two point rectangle tool, draw the required sketch similar 

to the one shown in Figure 3-48. You do not need to draw the sketch to the exact length. 
Use the temporary tracking option for drawing the sketch. For your reference, all lines in 
the sketch are numbered, see Figure 3-49. 

Note that in this sketch, the display of the X and Y axes has been turned off.

Adding Constraints to the Sketch
	 It is evident from Figure 3-49 that some of the lines need to be of the same length. For 

example, lines 1 and 7, lines 2 and 6, lines 8 and 12, and so on need to be of the same 
length. You can do so by using two options. In the first option, you can assign dimensions 
to all these lines. However, this will increase the number of dimensions in the sketch. In 
the second option, you can apply constraints that will force the lines to maintain an equal 
length. You can apply the Equal constraint to all lines that have the same length. This 
constraint will relate the length of one of the lines with respect to the other. Now, if you 
dimension any one of the related lines, all other lines related to it will be forced to acquire 
the same dimension value. The Equal constraint is applied in pairs. 

Figure 3-49  Initial sketch drawn using the 
sketching tools 

1.	 Choose the Equal tool from the Constrain panel of the Sketch tab to invoke the  
Equal constraint. 

	 When you invoke this constraint, you are prompted to select the first line, circle, or arc.

2.	 Select line 2; the color of this line is changed to blue and you are prompted to select the 
second line, circle, or arc. Select line 6; the Equal constraint is applied to lines 2 and 6. 
Again, you are prompted to select the first line, circle, or arc. Select line 6 as the first line 
and then line 8 as the second line.

	 While applying any of these constraints, if the Autodesk Inventor 2013 - Create Constraint 
warning message box is displayed, choose Cancel to exit that box.
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3.	 Similarly, select lines 8 and 12, 1 and 7, 3 and 5, 5 and 9, 9 and 11. The Equal constraint 
is applied to all these pairs of lines. Next, right-click in the drawing window, and then 
choose Cancel (ESC) from the Marking Menu displayed.

4.	 If needed, apply the Horizontal and Vertical constraints to the horizontal and vertical 
lines of the sketch, respectively.

Dimensioning the Sketch
	 Once all the required constraints have been applied to the sketch, you can dimension it. 

As mentioned earlier in this chapter, when you add dimensions to a sketch and modify 
their values, an entity is forced to the specified dimension values. 

Note
On applying the first dimension to the sketch and editing it, the whole scale of the sketch is 
modified accordingly.

1.	 Choose the Dimension tool from the Constrain panel of the Sketch tab. Alternatively, 
right-click anywhere in the graphics window and then choose General Dimension from 
the Marking Menu displayed. Select line 1, refer to Figure 3-49.

	 As soon as you move the cursor close to line 1, it turns red and a small symbol is displayed, 
indicating that a linear dimension will be applied to this line. It is important to modify the 
value of the dimension after it is placed so that geometries are driven to the values that 
you require. Therefore, after selecting line 1, right-click to display the Marking Menu. In 
this menu, choose Edit Dimension. If it has already been chosen, press ESC once. This 
ensures that the Edit Dimension toolbar is displayed whenever you place the dimension. 
This toolbar allows you to modify the dimension value. 

2.	 Place the dimension below line 1; the Edit Dimension toolbar is displayed. Enter 80 as 
the length of line 1 in this toolbar and then choose the check mark on the right of this 
toolbar. 

	 You will notice that the length of this line is modified to 80 units. Also, the length of line 7 
is modified because of the Equal constraint.

3.	 As the Dimension tool is still active, you are prompted again to select the geometry 
to dimension. Select line 2 and place the dimension on the left of this line; the 
Edit Dimension toolbar is displayed. Change the length of this line to 10 in this 
toolbar and press ENTER.  

	 You will notice that the length of lines 6, 8, and 12 is also forced to 10 units. This is because 
the Equal constraint has been applied to all these lines.

4.	 Select line 4 and place it along the previous dimension. Modify the dimension value in 
the Edit Dimension toolbar to 30 and press ENTER. Notice that the length of line 10 is 
also modified.
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5.	 Select line 16 and place the dimension outside the sketch on the right. Modify the 
dimension value in the Edit Dimension toolbar to 20 and press ENTER.

6.	 Select line 15 and place the dimension outside the sketch on the top. Modify the dimension 
value to 30 in the Edit Dimension toolbar and press ENTER.

7.	 Now, to dimension the distance between lines 4 and 14, select them one by one. Place the 
dimension outside the sketch on the top and then change the dimension value to 10 in 
the Edit Dimension toolbar and press ENTER.

8.	 Similarly, select lines 16 and 10 to dimension the distance between these two lines and place 
the dimension outside the sketch on the top. Change the dimension value to 10 in the Edit 
Dimension toolbar and press ENTER. You will notice that the length of lines 5, 9, 3, and 
11 is automatically adjusted because the Equal constraint has been applied to them.

9.	 To locate the inner rectangle vertically from the outer loop, select lines 1 and 13, and then 
place the dimension on the right of the sketch. Next, modify the dimension value in the 
Edit Dimension toolbar to 15 and press ENTER. 

	 With this, you have applied all the required constraints and dimensions to the sketch. Now 
the sketch is ready to be converted into a feature. If you try to add more constraints or 
dimensions to this sketch, the Autodesk Inventor Professional - Create Linear Dimension 
error message box will appear, informing that adding this dimension will over-constrain 
the sketch, see Figure 3-50. If you still want this dimension to be displayed, choose the 
Accept button from this message box, the dimension will be added as a driven dimension. 
A driven dimension is placed inside parentheses and is not used during the manufacturing 
process. This dimension is used only for reference. Note that you cannot edit the value 
of a driven dimension. The sketch after applying all dimensions and constraints should 
look similar to the one shown in Figure 3-51.

Figure 3-50  The Autodesk Inventor Professional message box

	 Even after adding all dimensions, the color of entities in the sketch is still black. This is 
because the sketch is not fully constrained. In order to fully constrain the sketch, you need 
to constrain it with respect to the origin which is already fixed by default. 	

10.	 Choose the Coincident Constraint tool from the Constrain panel of the Sketch 
tab; you are prompted to select the first curve or point.
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11.	 Select the intersection point of lines 1 and 2, which is the lower left vertex of the sketch; 
you are prompted to select the second curve or point.

12.	 Select the origin; the entire sketch shifts itself such that the lower left vertex of the sketch 
is now at the origin. In spite of its shift, the sketch is not completely visible in the drawing 
window.

13.	 Choose the Zoom All tool from the Navigation Bar > Zoom flyout to make the sketch fit 
into the drawing window. You will notice that all entities in the sketch turn blue, indicating 
that the sketch is fully constrained. Next, press ESC to exit the Coincident Constraint 
tool. 

	 Figure 3-52 shows the fully constrained sketch for Tutorial 1.

Figure 3-52  Fully constrained sketch for 
Tutorial 1

Figure 3-51  Sketch after adding dimensions

Saving the Sketch
1.	 Choose the Finish Sketch button from the Exit panel of the Sketch tab to exit the sketching 

environment. Alternatively, choose Finish Sketch from the Marking Menu to exit the 
sketching environment.   

2.	 Choose the Save tool from the Quick Access Toolbar or Application Menu and save the 
sketch with the name Tutorial1 at the location given below:

	 C:\Inventor_2013\c03

3.	 Choose Close > Close from the Application Menu to close the file.

Tutorial 2
In this tutorial, you will draw the sketch shown in Figure 3-53. This sketch is the same as the one 
drawn in Tutorial 4 of Chapter 2. After drawing it, you will apply the required constraints and 
dimensions to fully constrain it.	    				      (Expected time: 30 min)



Adding Constraints and Dimensions to Sketches				          3-29

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 3-53  Sketch for Tutorial 2

	 The following steps are required to complete this tutorial:

a.	 Start a new metric standard part file.
b.	 Invoke the Sketching environment and draw the initial sketch by using the Line tool, refer 

to Figure 3-54. 
c.	 Add Linear Diameter dimensions to the sketch by using the Dimension tool.
d.	 Apply Coincident Constraint between the origin and lower left vertex of the sketch to 

make it a fully constrained sketch, refer to Figure 3-55.
e.	 Add fillets, save the sketch with the name Tutorial2.ipt, and then close the file.

Starting a New File and Invoking the Sketching Environment
1.	 Choose the New tool from the Quick Access Toolbar and start a new metric standard 

part file by using the Metric tab of the New File dialog box.

2.	 Choose the Create 2D Sketch button from the Sketch panel of the 3D Model tab; the 
default planes are displayed and you are prompted to select the sketching plane.

3.	 Select the YZ plane as the sketching plane from the graphics window; the Sketching 
environment is invoked and the YZ Plane becomes parallel to the screen. Alternatively 
you can select YZ plane from the Browser Bar.

Tip. Autodesk Inventor allows you to invoke the drawing display options even 
when a sketching environment tool is active. This is done using the combination of 
hot keys and the left mouse button. For example, if the Dimension tool is active, 
you can use the Pan option by holding the F2 key and then pressing the left mouse 
button and dragging the cursor. Similarly, you can dynamically zoom in and 
out the sketch by holding the F3 key and then pressing the left mouse button and 
dragging the cursor.
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Drawing the Initial Sketch
1.	 Draw the initial sketch, as shown in Figure 3-54, using the Line tool. The lines in the 

sketch are numbered for your reference.

Dimensioning and Constraining the Sketch
	 The dimensions shown in Figure 3-53 are linear dimensions. As the sketch is for a revolved 

feature, you need to add linear diameter dimensions to it. It is recommended that you 
first apply all dimensions and then add fillets to the sketch. This is because the size of a 
sketch is generally changed after dimensioning. Before adding dimensions to a revolved 
section, it is important to determine which line segment of the sketch will act as the axis 
for revolving the sketch. If you refer to Figure 2-58 in Chapter 2, you will notice that line 
1 acts as the axis to revolve the sketch for the model. Therefore, while applying linear 
diameter dimensions, line 1 should be selected first.

1.	 Choose the Dimension tool from the Constrain panel of the Sketch tab; you are 
prompted to select the geometry to be dimensioned. Right-click to display the 
Marking Menu, and then choose Edit Dimension from it, if it has not already been 
chosen. If it has already been chosen, press the ESC key once to exit the Marking 
Menu. 

2.	 Select line 1; you are prompted again to select the geometry to be dimensioned. Select 
line 3 and then right-click; a Marking Menu is displayed. From this menu, choose Linear 
Diameter. 

	 You will notice that the linear dimension is twice the actual length, which means that the 
distance between line 1 and line 3 is 4, but will be displayed as 8 in the linear diameter 
dimension. Also, the dimension value is preceded by the Ø symbol, indicating that it is a 
linear diameter dimension. 

Figure 3-54  Lines numbered in the sketch

3.	 Place the dimension on the left of the sketch; the Edit Dimension toolbar is displayed. 
	 Figure 3-53 shows the value to be specified as 4 because the linear diameter dimensions 

are placed twice the original length.
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4.	 Enter 8 in the Edit Dimension toolbar and press ENTER; the vertical distance between 
lines 1 and 3 is automatically adjusted to the value entered.

5.	 As the Dimension tool is still active, you are prompted again to select the geometry 
to be dimensioned. Select lines 1 and 5 and then right-click; a Marking Menu is 
displayed. Choose Linear Diameter from the Marking Menu; the linear dimension is 
changed to the linear diameter dimension. Place the dimension on the left of the previous 
dimension. Next, modify its value in the Edit Dimension toolbar to 20 and press ENTER.

6.	 Select lines 1 and 7. Right-click to display the Marking Menu, and then choose Linear 
Diameter from it. Place the dimension on the left of the previous dimension and change 
its dimension value in the Edit Dimension toolbar to 32. Next, press ENTER.

Tip. Sometimes while dimensioning a sketch, some existing dimensions move from the 
location where they have been placed. In this case, you need to exit the Dimension 
tool and then drag the existing dimensions back to their original locations. To 
resume dimensioning, invoke the Dimension tool again.

7.	 Select lines 1 and 9, and then right-click; a Marking Menu is displayed. In the Marking 
Menu, choose Linear Diameter. Place the dimension on the right of the sketch and change 
its value in the Edit Dimension toolbar to 50 and then press ENTER.

8.	 Select lines 1 and 11, and then right-click to display the Marking Menu. In this menu, 
choose Linear Diameter. Place the dimension on the right of the previous dimension and 
change its value in the Edit Dimension toolbar to 60 and then press ENTER. 

	 Now, you need to add linear dimensions to the sketch.

9.	 Select lines 12 and 8, and then place the dimension above the sketch. Modify its value in 
the Edit Dimension toolbar to 5 and press ENTER.

10.	 Select line 11 and then place the dimension above the previous dimension. Modify its 
value in the Edit Dimension toolbar to 20 and press ENTER.

11.	 Select line 1 and then place the dimension below the sketch. Modify its value in the Edit 
Dimension toolbar to 22 and press ENTER.

12.	 Select lines 12 and 4, and then place the dimension below the previous dimension. Modify 
its value in the Edit Dimension toolbar to 36 and press ENTER.

13.	 Select lines 12 and 6, and then place the dimension below the previous dimension. Modify 
its value in the Edit Dimension toolbar to 44 and press ENTER.

	 With this, all dimensions have been added to the sketch. However, entities in the sketch 
are still displayed in black, indicating that the sketch is not fully constrained. Therefore, 
you need to add more dimensions or constraints to make the sketch fully constrained. 
In this sketch, add the Coincident Constraint to the origin and the intersection point of 
lines 1 and 2.
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14.	 Invoke the Coincident Constraint tool; you are prompted to select the first curve 
or point. Select the intersection point of lines 1 and 2, which is the lower left 
vertex of the sketch; you are prompted to select the second curve or point. 

15.	 Next, select the origin; the entire sketch shifts from its original location and is relocated 
such that the lower left vertex of the sketch now lies at the origin. Also, all entities in the 
sketch are displayed in blue, indicating that the sketch is fully constrained. 

Note
If the entities of the sketch are not fully constrained, you need to apply the Vertical Constraint 
to the vertical lines on the right of the sketch.

16.	 Choose the Zoom All tool from the Navigation Bar > Zoom flyout to fit the sketch into 
the drawing window. The fully constrained sketch after adding all dimensions is shown 
in Figure 3-55.

Figure 3-55  Fully constrained sketch for Tutorial 2

Adding Fillets to the Sketch
	 After dimensioning the sketch, you need to add fillets to it. 

1.	 Choose the Fillet tool from Sketch > Draw > Fillet/Chamfer drop-down; the 2D Fillet 
dialog box is displayed. In this dialog box, set the value of fillet to 1.5. Now, select lines 8 
and 9; the fillet is automatically added between these two lines and the dimension of the 
fillet is displayed.

2.	 Similarly, select lines 4 and 5 as well as lines 7 and 8 to add fillets between these lines. Exit 
the 2D Fillet dialog box. The final sketch after adding fillets is shown in Figure 3-56.
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Figure 3-56  Fully dimensioned sketch after adding fillets

Note
To modify the radius of the fillet, double-click on it; the Edit Dimension toolbar is displayed. 
Modify the value in this toolbar and press ENTER.

Saving the Sketch
1.	 Choose the Finish Sketch button from the Exit panel of the Sketch tab to exit the sketching 

environment. 

2.	 Save this sketch with the name Tutorial2 at the location C:\Inventor_2013\c03.

3.	 Choose Close > Close from the Application Menu to close the file.

Tutorial 3
In this tutorial, you will draw the sketch for the model shown in Figure 3-57. After drawing 
the sketch, you will add the required constraints to it and then dimension it. The dimensioned 
sketch required for this model is shown in Figure 3-58. The solid model shown in Figure 3-57 is 
only for reference.					           	   (Expected time: 30 min)

The sketch shown in Figure 3-58 is the combination of multiple closed loops: the outer loop 
and inner circles. As the numbers of loops increase, so does the complexity of the sketch. This 
is because the numbers of constraints and dimensions in a sketch increase in case of multiple 
loops. Now, to draw sketches without using the Dynamic Input, it is recommended that you 
first draw the outer loop of the sketch and then add constraints and dimensions to it. This is 
because once the outer loop has been constrained and dimensioned, the inner circles can be 
constrained and dimensioned easily with reference to the outer loop. 
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Figure 3-58  Dimensioned sketch of the modelFigure 3-57  Model for Tutorial 3

	

The following steps are required to complete this tutorial:

a.	 Start a new metric template and draw the outer loop of the sketch, refer to Figure 3-59.
b.	 Invoke the Sketching environment and add the required dimensions and constraints to 

the outer loop, refer to Figure 3-61.
c.	 Draw inner circles and add constraints and dimensions to them, refer to Figure 3-62.
d.	 Save the sketch with the name Tutorial3.ipt and close the file.

Starting a New File and Invoking the Sketching Environment
1.	 Choose the New button from the Quick Access 

Figure 3-59  Profile with geometries 
numbered

Toolbar and start a new metric standard part file 
using the Metric tab of the New File dialog 
box.

2.	 Choose the Create 2D Sketch button from the 
Sketch panel of the 3D Model tab; the default 
planes are displayed and you are prompted to 
select the sketching plane.

3.	 Select the XY plane as the sketching plane from 
the graphics window; the Sketching environment 
is invoked and the XY Plane becomes parallel to 
the screen. Alternatively, you can select XY plane 
from the Browser Bar.

Drawing the Outer Loop
1.	 To draw the outer loop, invoke the Line tool from Draw panel in the Sketch tab, as shown 

in Figure 3-59. 

	 You can draw the tangent arcs while using the Line tool. This can be done by invoking 
the Line tool and by pressing the left mouse button and then dragging it in the required 
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direction. Move the cursor close to the endpoint of the last line until the yellow circle snaps 
to that point. When the yellow circle snaps to the endpoint, it turns gray.  Next, press and 
hold the left mouse button and drag the mouse through a small distance in the upward 
direction. Refer to Tutorial 3 of Chapter 2 to learn more about drawing this type of arc. 

	 For your reference, all geometries in the sketch are numbered. You will draw inner holes 
in the sketch after dimensioning the outer loop.

Note
The outer loop that you created in the previous step might be different from the one shown in 
Figure 3-59. You can find the missing constraints by following the next step and apply constraints 
accordingly.

Adding Constraints to Sketched Entities
	 As evident from Figure 3-59, some of the constraints such as tangent and equal are missing 

in the sketch. The sketch shown in Figure 3-59 may not be symmetrical and all the lines 
in the sketch may not be tangent to the arcs. Therefore, you need to add these missing 
constraints manually to the sketch to complete it. You can choose the Show Constraint 
soption from the Marking menu that is displayed when you right-click on an entity.  

 
1.	 In Figure 3-59, the Tangent constraint is missing between line 1 and arc 10. To add this 

constraint between the line and the arc, choose the Tangent tool from the Constrain 
panel of the Sketch tab; you are prompted to select the first curve. Select arc 10 as the 
first curve; you are prompted to select the second curve. Select line 1 as the second curve. 
Similarly, add this constraint to all places in the sketch wherever it is missing.

	 The geometries 5 and 7, and 3 and 9 are the lines that must be of equal length. Also, the 
geometries 2 and 10, and 4 and 8 are the arcs that must be of equal radii. Therefore, you 
need to add the Equal constraint between the respective pairs of all these geometries. 

2.	 Choose the Equal tool from the Constrain panel of the Sketch tab.		     

3.	 Select line 5 as the first line and then line 7 as the second line to apply the Equal constraint 
to them; you are prompted again to select the first entity. 

4.	 Select line 3 and then line 9 to apply the Equal constraint to them; you are prompted to 
select the first entity again.

5.	 Select arc 2 and then arc 10 to apply the Equal constraint to them. Applying this constraint 
to arcs or circles forces their radii or diameters to be equal.

6.	 Similarly, apply the Equal constraint to arc 4 and arc 8. 

7.	 Apply the Coincident Constraint between the center point of arc 4 and line 5, 
and the center point of arc 8 and line 7, if it is not applied automatically. 
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8.	 Choose the Coincident Constraint tool from the Constrain panel; you are prompted to 
select the first curve or point.

9.	 Select the origin; you are prompted to select the second curve or point.

10.	 Select the center point of arc 6; the entire sketch moves to make the origin coincident 
with the center point of the arc. The sketch after applying all constraints is shown in 
Figure 3-60.

Figure 3-60  The sketch after applying all 
constraints

Note
The shape of the sketch that you have drawn may be a little different at this stage because of 
the difference in specifying points while drawing the sketch. However, once all dimensions are 
applied, the shape of the sketch will be the same. Also, you may need to add vertical constraint 
to lines 5 and 7 and horizontal constraint to line 1 to fully constrain the sketch.

Dimensioning the Sketch
1.	 Choose the Dimension tool from the Constrain panel of the Sketch tab. Next, 

right-click to display the Marking Menu. In the Marking Menu, choose Edit 
Dimension if the check mark is not available on the left of the Edit Dimension option. 
If it shows the check mark, press the ESC key once to exit the Marking Menu. On doing 
so, you are prompted to select the geometry to be dimensioned. Select line 1 and place 
the dimension below the sketch. Modify the value of this dimension in the Edit Dimension 
toolbar to 20.	

2.	 Select arc 4 and place the dimension on the left of the sketch; the radius dimension of 
the sketch is placed. Modify the dimension value in the Edit Dimension toolbar to 7.5. 
The size of arc 8 is also modified because of the Equal constraint applied between these 
two entities.

Note
As discussed in the previous tutorial, you may need to use the combination of hot keys to zoom 
or pan the model.
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3.	 Select arc 2 and place the radius dimension on the left of the sketch. Modify the dimension 
value in the Edit Dimension toolbar to 10 and press ENTER. The size of arc 10 is also 
modified because of the Equal constraint applied between these two entities.

4.	 Select line 5 and then line 7, and then place the dimension above the sketch. Modify the 
value of this dimension in the Edit Dimension toolbar to 15 and press ENTER.

5.	 Select line 7 and place the dimension on the right of the sketch. Modify the value of this 
dimension in the Edit Dimension toolbar to 20 and press ENTER.

6.	 Select the upper endpoint of line 7 and select line 1, and then place the dimension on 
the right of the previous dimension. Modify the value of this dimension to 40 and press 
ENTER. Next, exit the Dimension tool.

	
	 With this, all dimensions have been applied to the sketch (see Figure 3-61), except the 

horizontal dimension between the center points of arcs 4 and 6 or arcs 8 and 6. The need 
of these dimensions depends on the constraints and dimensions assumed while drawing the 
sketch. If the sketch gets over-constrained, the Autodesk Inventor Professional message 
box is displayed. Choose Cancel from the message box. In this case, the dimension has 
already  been assumed.

Drawing Circles	
	 Once all the required dimensions and constraints have been applied to the sketch, you 

need to draw circles. Figure 3-58 indicates that circles are concentric with arcs 2 and 10. 

1.	 To draw concentric circles, choose the Circle Center Point tool from the Draw panel; 
you are prompted to select the center of the circle. Move the cursor close to the center 
of arc 2. Specify the center point when the cursor snaps to the center point of arc 2 and 
turns green. Next, move the cursor away from the center and specify a point to size the 
circle.

2.	 Similarly, draw the other circle taking the reference of the center of arc 10. 

Adding Constraints to Circles	
	 As both the circles have the same diameter, you can apply the Equal constraint to them. 

So, you need to apply the dimension to just one of them. On applying the dimension, 
the other circle will automatically be forced to the specified diameter value because of the 
Equal constraint. 

1.	 Invoke the Equal constraint from the Constrain panel. Select the first circle and then the 
second circle to apply the Equal constraint.	

Dimensioning the Circles
1.	 Choose Dimension from the Constrain panel and select the left circle. Place the 

dimension on the left of the sketch. In the Edit Dimension toolbar, change the 
value of the diameter of the circle to 8 and press ENTER. 
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	 Notice that the size of the right circle is automatically modified to match the dimension of 
the left circle. This is because the Equal constraint is applied between the two circles. 
The final sketch for Tutorial 3 after drawing and dimensioning circles is shown in 
Figure 3-62.

Figure 3-61  Dimensioned sketch for Tutorial 3 Figure 3-62  The final dimensioned sketch 
for Tutorial 3

Saving the Sketch
1.	 Choose the Return tool from the Quick Access Toolbar to exit the sketching 

environment. Save this sketch with the name Tutorial3 at the location given 
below:

	 C:\Inventor_2013\c03

Note
If the Return tool is not available in the Quick Access Toolbar, you need to add this 
tool to the toolbar. To do so, choose the down arrow on the right of the Quick Access Toolbar; 
a flyout is displayed. Next, choose the Return option from the flyout.

2.	 Choose Close > Close from the Application Menu to close the file.

Tutorial 4
In this tutorial, you will draw the sketch of the model shown in Figure 3-63. The dimensions of the 
sketch are shown in Figure 3-64. After drawing the sketch, add constraints and then dimension 
it. The solid model is given for reference only.	    		    (Expected time: 30 min)
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Figure 3-63  Model for the sketch of Tutorial 4 Figure 3-64  The final dimensioned sketch 
for Tutorial 4

	 The following steps are required to complete this tutorial:

a.	 Start a new metric standard part file.
b.	 Invoke the Sketching environment and draw the outer loop of the sketch.
b.	 Add the required dimensions and constraints to the sketch.
c.	 Add the inner circle to the sketch and dimension it.
d.	 Save the sketch with the name Tutorial4.ipt and close the file.

Starting a New File and Invoking the Sketching Environment
1.	 Choose the New tool from the Quick Access Toolbar to display the New File dialog box. 

Start a new metric standard part file from the Metric tab of this dialog box.
 
2.	 Choose the Create 2D Sketch button from the Sketch panel of the 3D Model tab; the 

default planes are displayed and you are prompted to select the sketching plane.

3.	 Select the XZ plane as the sketching plane from the graphics window; the Sketching 
environment is invoked and the XZ Plane becomes parallel to the screen. Alternatively, 
you can select XZ plane from the Browser Bar.

Drawing the Outer Loop
1.	 Choose Line from the Draw panel of the Sketch tab to draw the outer loop, as shown 

in Figure 3-65. As mentioned earlier, you should draw the inner loop after drawing and 
dimensioning the outer loop. This is because once the outer loop is dimensioned, you 
can draw the inner loop by taking the reference of the outer loop. 

	 You can draw the arc while the Line tool is active. You can also use the temporary tracking 
option to draw this sketch. For your reference, the geometries in the sketch are numbered, 
see Figure 3-65. 
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Figure 3-65  Initial sketch with the geometries 
numbered

Adding Constraints to the Outer Loop
1.	 Add the Equal constraint to lines 1 and 9, lines 2 and 8, lines 3 and 5, lines 5 and 7, and 

lines 4 and 6. 

2.	 Add the Perpendicular Constraint to lines 2 and 3, and lines 7 and 8.

3.	 Add the Horizontal Constraint to the lower endpoints of lines 4 and 6. 

4.	 Add the Tangent constraint to lines 1 and 9 with arc 10, if it is missing.

Dimensioning the Outer Loop
1.	 Choose the Dimension tool from the Constrain panel of the Sketch tab; you are 

prompted to select the geometry to dimension. Select line 9 and place the 
dimension on the left of the sketch. Modify the dimension value in the Edit Dimension 
toolbar to 25 and press ENTER.

2.	 Select the center of the arc and then the lower endpoint of line 6. Place the dimension on 
the left of the previous dimension. Modify the dimension value in the Edit Dimension 
toolbar to 60 and press ENTER.

3.	 Select line 3 and then right-click to display the Marking Menu. Choose Aligned from the 
Marking Menu and then place the dimension below the sketch. Modify the dimension 
value in the Edit Dimension toolbar to 12.5 and press ENTER. 

	 Notice that the length of lines 5 and 7 is also modified because of the Equal constraint.

4.	 Select lines 1 and 2 and then place the angular dimension on the right of the sketch. 
Modify the value of the angular dimension in the Edit Dimension toolbar to 135 and 
press ENTER.

5.	 Select arc 10 and then place the radius dimension above the sketch. Modify the value of 
the radius of the arc in the Edit Dimension toolbar to 15 and press ENTER. 
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	 With this, the required dimensions have been applied to the outer loop. Even after adding 
all dimensions, the color of entities in the sketch is still black. 

6. 	 Select the origin. Now, you can use the origin to fully constrain the initial sketch.

7.	 Choose the Coincident Constraint tool from the Constrain panel; you are prompted to 
select the first curve or point.

8.	 Select the center of the arc; you are prompted to select the second curve or point.

9.	 Select the origin. The entire sketch shifts itself such that the center of arc of the sketch is 
at the origin. After the sketch is shifted to the new place, it may not be visible completely 
in the drawing window.

10.	 Choose the Zoom All tool from the Navigation Bar > Zoom flyout to fit the sketch into 
the drawing window. You will notice that all entities in the sketch turn blue, indicating 
that the sketch is fully constrained. Press the ESC key to exit the Coincident Constraint 
tool. 

Drawing the Circle
1.	 Choose Circle Center Point from the Draw panel of the Sketch tab; you are prompted 

to select the center of the circle. 

2.	 Move the cursor close to the center of the arc; the cursor snaps to the center point and 
turns green. Select this point as the center of the circle and then move the cursor away 
from the center to size the circle. Specify a point to give it an approximate size.

Dimensioning the Circle
1.	 Choose Dimension from the Constrain panel of the Sketch tab and select the circle. Place 

the diameter dimension below the arc dimension. Enter 25 in the Edit Dimension toolbar 
and then press ENTER. This completes the sketch for Tutorial 4. The final dimensioned 
sketch is shown in Figure 3-66.	

Saving the Sketch
1.	 Choose the Finish Sketch option from the Exit panel of the Sketch tab to exit the sketching 

environment. Alternatively choose the Finish Sketch option from the Marking menu to 
exit the sketching environment 

	
2.	 Save the sketch with the name Tutorial4 at the location given below:
	
	 C:\Inventor_2013\c03
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Figure 3-66  The final dimensioned sketch for Tutorial 4

3.	 Choose Close > Close from the Application Menu to close the file.

Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 The Perpendicular Constraint forces a selected entity to become perpendicular to a 
specified entity. (T/F)

2.	 The Coincident Constraint can be applied to two line segments. (T/F)

3.	 The Collinear Constraint can only be applied to line segments. (T/F)

4.	 If an unnecessary constraint is applied to a sketch, Autodesk Inventor displays a message 
box informing that adding this constraint will over-constrain the sketch. (T/F)

5.	 The __________ nature of Autodesk Inventor ensures that a selected entity is driven to a 
specified dimension value irrespective of its original size.

6.	 When you select a circle to be dimensioned, the __________ dimension is applied to it by 
default.

7.	 The __________ dimension has one arrowhead and is placed outside a circle or an arc.

8.	 The __________ dimension displays the distance between two selected line segments in 
terms of diameter and the distance shown is twice the original length.

9.	 The __________ tool is used to measure the radius of an arc.
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10.	 A ___________ constrained sketch is the one whose all entities are completely constrained 
to their surroundings using constraints and dimensions.

 Review Questions 
Answer the following questions:

1.	 You cannot apply the Concentric Constraint between a point and a circle. (T/F)

2.	 You can use the Horizontal Constraint or the Vertical Constraint to line up arcs, circles, 
or ellipses in the same horizontal or vertical direction. (T/F)

3.	 You can view all or some of the constraints applied to a sketch. (T/F)

4.	 There are twelve types of geometrical constraints that can be applied to sketched entities. 
(T/F)

5.	 The linear dimensions are the dimensions that define the shortest distance between two 
points. (T/F)

6.	 A sketch where the number of dimensions or constraints exceeds the required number of 
dimensions or constraints in a sketch is called

		  (a) Fully-constrained		  (b) Under-constrained
		  (c) Over-constrained		  (d) None of these

7.	 To which of the following toolbars does the Measure Distance toolbar change when you 
invoke the Distance tool and select two lines?

		  (a) Length			   (b) Distance
		  (c) Minimum Distance		  (d) None of these

8.	 Which of the following dimensions is applied to the arc by default whenever you select an 
arc to be dimensioned?

		  (a) Radius			   (b) Diameter
		  (c) Linear	 		  (d) Linear Diameter

9.	 In addition to lines, which of the following entities can be selected to apply the Collinear 
constraint?

		  (a) Arc				    (b) Circle
		  (c) Ellipse			   (d) Ellipse axis
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10.	 Which of the following combination of entities cannot be used to apply the Tangent 
constraint?

		  (a) Line, line			   (b) Line, arc
		  (c) Circle, circle			  (d) Arc, circle

Exercises

Exercise 1
Draw the sketch of the model shown in Figure 3-67. The sketch to be drawn is shown in 
Figure 3-68. After drawing the sketch, add the required constraints to it and then dimension 
it.								        (Expected time: 30 min)

								          

Figure 3-68  Sketch for Exercise 1Figure 3-67  Model for Exercise 1

  Exercise 2
Draw the sketch of the model shown in Figure 3-69. The sketch to be drawn is shown in 
Figure 3-70. After drawing the sketch, add the required constraints to it and then dimension it.
								          (Expected time: 30 min)
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Figure 3-70  Sketch for Exercise 2Figure 3-69  Model for Exercise 2

Exercise 3
Redraw the sketch of Exercise 1 of Chapter 2. After drawing the sketch, add the required 
constraints to it and then dimension it. The dimensioned sketch is shown in Figure 3-71.  		
  								          (Expected time: 30 min)

Exercise 4
Redraw the sketch of Exercise 2 of Chapter 2. After drawing the sketch, add the required 
constraints to it and then dimension it. The dimensioned sketch is shown in Figure 3-72.	     	
  	   							         (Expected time: 30 min)

Figure 3-71  Dimensioned sketch for Exercise 3 Figure 3-72  Dimensioned sketch for Exercise 4
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Exercise 5

Draw the sketch of the model shown in Figure 3-73. The sketch to be drawn is shown in 
Figure 3-74. After drawing the sketch, add the required constraints to it and then dimension it.
								          (Expected time: 30 min)

Figure 3-74  Sketch for Exercise 5Figure 3-73  Model for Exercise 5

Exercise 6

Draw the sketch of the model shown in Figure 3-75. The sketch to be drawn is shown in 
Figure 3-76. After drawing the sketch, add the required constraints to it and then dimension it.
								          (Expected time: 30 min)

Figure 3-76  Sketch for Exercise 6Figure 3-75  Model for Exercise 6

Answers to Self-Evaluation Test
1. T, 2. F, 3. F, 4. T, 5. parametric, 6. diameter, 7. radius, 8. linear diameter, 9. Measure 
Distance, 10. fully


