
Chapter 2
 

Introduction to 
Autodesk 3ds Max 

2012
 Learning Objectives 
After completing this chapter, you will be able to:
• Start a new scene in Autodesk 3ds Max 2012
• Understand the Autodesk 3ds Max screen components
• Understand various selection techniques
• Understand time slider and animation controls
• Use controls for creating or modifying the objects
• Use hotkeys in Autodesk 3ds Max
• Customize hotkeys
• Customize the colors of elements
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IntroductIon 
Welcome to the world of Autodesk 3ds Max, an advanced application that is used to create 
still or animated 3D models and objects. With the help of this application, you can create 
realistic scenes by modifying objects, applying maps and materials to have the reference, 
assigning environment, adding lights and cameras, and so on. Before working with Autodesk 
3ds Max, you should have the basic knowledge of various tools and commands available 
in this software. In this chapter, you will learn the basic features of Autodesk 3ds Max.

GettInG Started WIth autodesk 3ds Max 2012            
First, you need to install Autodesk 3ds Max 2012 on your system. On installing the software, the 
Autodesk 3ds Max 2012 shortcut icon will automatically be created on the desktop. Double-click 
on this icon to start Autodesk 3ds Max. Alternatively, you can start Autodesk 3ds Max from the 
Start menu. To do so, choose Start > All Programs > Autodesk > Autodesk 3ds Max 2012 > 
Autodesk 3ds Max 2012, as shown in Figure 2-1. On doing so, the system will prepare to start 
Autodesk 3ds Max 2012 by loading all required files. 

Figure 2-1  Starting Autodesk 3ds Max 2012 using the Start menu

If you are running Autodesk 3ds Max for the first time, the Autodesk Customer 
Involvement Program dialog box will be displayed, as shown in Figure 2-2, and you will be 
prompted to join the Customer Involvement Program (CIP). Select the Yes, I would like to 
participate in CIP radio button and then choose the OK button to join the CIP. Else, select 
the No, thanks radio button. On joining the CIP, Autodesk will gather product feature usage 
and system information every day from your system to analyze trends and patterns. This 
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entire information helps Autodesk to improve its product. You can also invoke the Autodesk 
Customer Involvement Program dialog box by choosing Help > Customer Involvement 
Program from the menu bar. 

Figure 2-2  The Autodesk Customer Involvement Program dialog box

After all required files are loaded, the 3ds Max interface will be displayed along with the 
Welcome to 3ds Max dialog box, as shown in Figure 2-3. The Welcome to 3ds Max dialog box 
will display the video tutorials that help you to learn the basic working environment of the 
software. To start a tutorial, choose one of the buttons available on the left in this dialog box; 
the corresponding tutorial will be displayed in a separate window on the screen. Also, you can 
create a new file, open an existing file or a recently created file using this dialog box. Choose 
the Close button in the Welcome to 3ds Max dialog box to close it. 

StartInG a neW Scene In autodesk 3ds Max 
To start a new scene in Autodesk 3ds Max, choose the Application button at the top left 
corner of the interface; the Application menu will be displayed. Next, choose New > New 
All from the Application menu; a new scene will be displayed in the 3ds Max interface. The 
new scene will clear all contents of the current scene. Alternatively, press the CTRL+N keys; 
the New Scene dialog box will be displayed, as shown in Figure 2-4. By default, the New All 
radio button is selected in this dialog box. It is used to clear all the contents in the current 
scene and open a new scene. Choose the OK button; a new scene will be displayed. 

You can also reuse the objects from the current scene in the new file. To do so, select the Keep 
Objects radio button in the New Scene dialog box. However, on selecting this radio button, 
all the animation keys and links between the objects will be cleared. To keep the objects and 
the links between them, select the Keep Objects and Hierarchy radio button. However, in this 
case, the animation keys will be deleted. Before starting a new scene in Autodesk 3ds Max, it 
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is recommended that you reset Autodesk 3ds Max and start afresh. By doing so, you will be 
able to reset all the settings for the new scene. To reset Autodesk 3ds Max, choose Reset from 
the Application menu; the 3ds Max message box will be displayed, as shown in Figure 2-5. 
Choose the Yes button; the Autodesk 3ds Max will be reset. 

Figure 2-3  The Welcome to 3ds Max dialog box

Figure 2-5  The 3ds Max message boxFigure 2-4  The New Scene dialog box

autodesk 3ds Max 2012 Screen coMponentS
The 3ds Max interface screen consists of different components, as shown in Figure 2-6. These 
components are discussed next.
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Figure 2-6  Different screen components of Autodesk 3ds Max interface

Menu Bar
The menu bar, as shown in Figure 2-6 is located just below 
the title bar and contains various drop-down. Some of the 
pull-down menus are standard window menus such as Edit 
and Help, and others are 3ds Max pull-down menus such as 
Create, Modifiers, Animation, Graph Editors, Rendering, 
Customize, and so on. The title of each pull-down menu 
indicates the purpose of commands in the menu. When you 
choose one of the menu titles, Autodesk 3ds Max displays 
the corresponding pull-down menu. Each menu consists of 
a collection of commands. In a pull-down menu, the dots 
after a command indicate that a dialog box will be displayed 
on choosing that command. An arrow next to a command 
indicates that a cascading menu will be displayed on placing 
the cursor on that command. For some of the commands in 
the pull-down menus, the keyboard shortcuts are available on 
their right side, as shown in Figure 2-7.   

application Menu
The Application menu is used to manage the files created in 3ds Max. To display this menu, 
choose the Application button on the top left of the 3ds Max screen, as shown in Figure 2-8. 
The menu comprises of the most commonly used file management options. In 3ds Max 2012, 
the Send to option is added which provides interoperability with Autodesk applications such 

Figure 2-7  The keyboard shortcuts 
for some commands
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as Softimage, MotionBuilder, and Mudbox. When you choose Send to from the Application 
menu, a cascading menu is displayed. It consists of options: Send to Softimage, Send to 
MotionBuilder, and Send to Mudbox. Choose the desired option from the cascading menu; 
a submenu will be displayed with the options Send as New Scene, Update Current Scene, 
Add to Current Scene, and Select Previously Sent Objects. You can choose the option from 
this menu as per your requirement.

The Recent Documents area on the right of the menu provides a complete  
information about the files that were previously saved in 3ds Max. You can change 
the size of the icons of the recent documents. To do so, choose the Icon or Image Display 
button from the Application menu, refer to Figure 2-8; a drop-down list will be displayed, as 
shown in Figure 2-9. Select the icon size from the drop-down list to change the size of the 
icons of the recent documents. 

Figure 2-8  Choosing the Icon or Image Display 
button from the Application menu

Figure 2-9  The icon or image 
display drop-down list

You can also use the keyboard shortcuts to work with the Application menu. To do so, press 
ALT+F; the Application menu will be displayed with all shortcuts, as shown in Figure 2-10. 
Next, press the shortcut key based on your requirement; the corresponding command will 
be executed. However, if you click again on the Application menu after pressing the ALT+F 
keys, the Application menu will not display the shortcuts. You can repeat the process to view 
the shortcuts again.

Quick access toolbar
The Quick Access Toolbar comprises of the most commonly used file management buttons, 
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as shown in Figure 2-11. These buttons are also available in the Application menu. Apart from 
the commonly used buttons, the Quick Access Toolbar contains the Redo Scene Operation 
and Undo Scene Operation buttons.  

Figure 2-10  The Application menu with the 
keyboard shortcuts

Figure 2-11  The Quick Access Toolbar

toolbars
In Autodesk 3ds Max, there are various commands available in 
toolbars as buttons or tools. By default, only the Main Toolbar will 
be displayed on Autodesk 3ds Max screen. However, you can display 
other toolbars such as Snaps, Axis Constraints, Extras, MassFX 
Toolbar, and so on in the 3ds Max screen. Also, you can move, resize, 
and undock them based on your requirements. To display these 
toolbars, right-click in the blank area on the Main Toolbar; a shortcut 
menu will be displayed with the names of all the toolbars, as shown 
in Figure 2-12. Next, choose the name of the required toolbar; the 
chosen toolbar will be displayed on the screen. Also, you can hide any 
of the displayed toolbars by choosing its name from the shortcut menu. 
The Main Toolbar provides quick access to many tools and dialog boxes 
such as Select and Link, Unlink Selection, Select Object, Material 
Editor, and so on. This toolbar is docked just below the menu bar. You 
will learn more about the tools available in various toolbars in the later 
chapters.

Figure 2-12 Displaying 
the shortcut menu with 
the names of all the 
toolbars
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command panel 
By default, the Command Panel is docked on the right of the 
3ds Max screen. There are six tabs in the Command Panel 
namely: Create, Modify, Hierarchy, Motion, Display, and 
Utilities, as shown in Figure 2-13. Most of the 3ds Max modeling 
and animation tools are placed in these tabs. The tools in the 
Command Panel are used to create, modify, and animate the 
objects. Each tab has several rollouts to create or modify the 
objects. You can collapse or expand these rollouts. The six tabs 
in the Command Panel are discussed next:   

The Create tab is chosen by default. The tools in the 
Create tab are used to create objects, cameras, lights, 
and so on.

The Modify tab is used to modify the selected objects in 
the viewport by modifying the parameters, applying 
various modifiers, and editing the editable objects such 
as editable mesh or editable poly.

The Hierarchy tab is used to control the links in the hierarchy, joints, and inverse 
kinematics.

The Motion tab is used to control the animation controllers.

The Display tab is used to hide and unhide the objects in the viewport.
 

The Utilities tab is used to access various utility programs.
        

note
You can undock the Command Panel and Main Toolbar and place them anywhere on 
the screen. To do so, move the cursor on top of the Main Toolbar to relocate it; the cursor 
will change into an arrow with two overlapping rectangles. Now, press and hold the left 
mouse button and drag the Main Toolbar to the desired location. Double-click on the 
Main Toolbar to dock it back to its default position. 

Viewports       
When you start Autodesk 3ds Max, you are provided with a default interface. This interface 
consists of four equally sized viewports surrounded by tools and controls, refer to Figure 2-6. 
These viewports are labeled as Top, Front, Left, and Perspective. The viewports in Autodesk 
3ds Max are used to create 3D scenes. Also, they enable you to view a scene from different 
angles. When you create an object in the viewport, the Top, Front, and Left viewports will 
display the top, front, and left orthographic views of the object, respectively. You can modify 
the size of the viewports by dragging the intersection of the viewports. To restore the original 
size, right-click on the intersection of the dividing lines; a shortcut menu will be displayed, as 

Figure 2-13  The Command 
Panel 
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shown in Figure 2-14. Choose the Reset Layout option from the shortcut menu; the default 
size of the viewports will be displayed.      

Figure 2-14  The Reset Layout option displayed

Among the four viewports, one will be highlighted in yellow border, indicating that it is the 
active viewport. Note that only one viewport can be activated at a time. To activate another 
viewport, you need to click on it. You can also activate a viewport by right-clicking on it. On 
doing so, the selection state of the objects will be maintained.  

On the bottom left corner of each viewport, there is a world-space tripod, as shown in 
Figure 2-15. The world-space tripod has three axes, X, Y, and Z, which are displayed in red, 
green, and blue colors, respectively. The tripod always refers to the world coordinate system, 
regardless of the local coordinate system. The ViewCube is placed on the top right corner of 
the viewport, as shown in Figure 2-15. The ViewCube provides visual feedback of the current 
orientation of the viewport. 

Figure 2-15  The world space tripod and grids in the Perspective viewport
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note
The ViewCube will not be visible in the viewport for camera, light, or activeshade.

It is important to note that the local coordinate system defines the local position of an object 
in a scene. Whereas, the world coordinate system uses fixed axes to define the position of all 
objects in the world space.  

Each viewport has a grid placed in it, refer to Figure 2-15. It is like a graph paper in which 
all the lines intersect each other at right angles. You can modify the spacing in the grids. The 
grids in all viewports act as an aid to visualize the spacing and distance while creating objects. 
Also, they provide a construction plane to create and align the objects. You can also use the 
grids as a reference system while using the snap controls to align the objects. To hide the grid 
in the viewport, press the G key.

On the top left corner of each viewport, there are three viewport labels: General viewport 
label, Point of view (POV) viewport label, and Shading viewport label, as shown in Figure 2-16. 
When you click on any of the viewport labels, the corresponding shortcut menu will be 
displayed, as shown in Figure 2-17. The options in these shortcut menus are used to modify 
various aspects of the active viewport. You can activate or disable the active viewport by using 
the options in the General viewport label menu. Choose the Configure Viewports option from 
this menu; the Viewport Configuration dialog box will be displayed. Various commands in this 
dialog box can be used to configure the viewports. You already know that four equally sized 
viewports are displayed on the screen. However, you can change the viewport configuration 
based on your requirement. To change the basic configuration of the viewports, choose the 
Layout tab in the Viewport Configuration dialog box, as shown in Figure 2-18. In the Layout 
tab, you can specify the division method of the viewports. There are 14 types of configurations 
displayed on the top in the dialog box. Select the required configuration and then choose 
the OK button; the viewports will be displayed according to the configuration that you have 
selected in the Viewport Configuration dialog box.  

Figure 2-16  The viewport labels in the Front 
viewport

Figure 2-17  The shortcut menu displayed 
on clicking the POV viewport label
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Figure 2-18  The Layout tab of the Viewport Configuration dialog box

note
The viewport configuration specifies how the viewports will be arranged on the screen.

You can change the default viewport to any other viewport type available, such as Bottom, 
Right, and so on, by using the options in the POV viewport label menu. To do so, click on 
the POV viewport label; a shortcut menu will be displayed. Choose the name of the viewport 
that you want to display. 

You can also use the Shading viewport label menu for defining the type of shadings displayed 
in the viewport. The different shading types are: Realistic, Shaded, Consistent Colors, 
Wireframe, Edged Faces, Bounding box, Hidden Line, and so on. However, some of these 
shading types are available in the cascading menu of the Stylized option, refer to Figure 2-19. 
These shading types are Graphite, Color Pencil, Ink, and so on.  You can choose any option 
to change the shading.
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Figure 2-19  Displaying the different shading types available in the Stylized 
cascading menu

Status Bar
There are various tools in the status bar that provide information of the scene and the active 
command, as shown in Figure 2-20. The prompt line, which is located at the bottom of the 
screen, displays information of the active command or tool. On top of the status bar, a text box 
known as the status line is available. This status line displays the number of currently selected 
objects (current selection set). The Selection Lock Toggle tool on the right side of the status 
bar is used to lock the selection set. The coordinate display/transform type-in area displays the 
X, Y, and Z coordinates of the cursor or the currently selected object. The coordinate display/
transform type-in area can also be used to enter transform values while moving, scaling, or 
rotating the selected object(s).

The grid setting display area is placed on the right of the coordinate display area. It displays the 
size of the grid. The time tag area located below the grid setting display area, is used to assign 
the text labels at any point of time during the animation. Click on the time tag area; the Add 
Tag and Edit Tag options will be displayed. Use these options to add or edit the text labels 
at any point of time during the animation. 

Figure 2-20  The status bar
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Viewport navigation controls
There are various tools available at the bottom right corner of the Autodesk 3ds Max screen. 
These tools are known as viewport navigation controls and they are used to control the display 
and navigation of the viewport. The tools displayed in the viewport navigation controls depend 
on the viewport selected. For example, if the Camera viewport is selected, its corresponding 
tools will be displayed in the viewport navigation control. 

Note that some of the tools mentioned below are available in a flyout which will be displayed 
when you click on the arrow located on the lower right corner of the tool icon. The viewport 
navigation tools are discussed next.

Zoom tool
The Zoom tool is used to increase or decrease the view size of the active viewport. You 
can zoom in a view by pressing the left mouse button and dragging the cursor up. 
Similarly, you can zoom out by pressing the left mouse button and then dragging the 
cursor down.

Zoom all
The function of the Zoom All tool is the same as the Zoom tool with the only difference 
that this tool zooms the display in all four viewports simultaneously. 

Zoom extents
 The Zoom Extents tool is used to view all objects in the active viewport.

Zoom extents Selected
The Zoom Extents Selected tool is used to view all selected objects in the active 
viewport.

Zoom extents all
 The function of the Zoom Extents All tool is  the same as the Zoom Extents tool with 

the only difference that this tool is used to view all objects in all viewports.

Zoom extents all Selected
The function of the Zoom Extents All Selected tool is the same as the Zoom Extents 
Selected tool with the only difference that this tool is used to view all selected objects 
in all viewports.

Zoom region  
The Zoom Region tool is used to define the area to be magnified and view this area 
in the current viewport. The area to be magnified is specified by a rectangle created 
by dragging the cursor. 

Field-of-View
The Field-of-View tool is available only in the Perspective and Camera viewports. It 
is used to change the field of view of the scene in these viewports. The greater 
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the Field-of-View of a camera, the better will be the visibility of scene, and vice-versa.

pan View
The Pan View tool is used to pan the scene in the viewport. This tool enables you to 
display the contents that are outside the display area of the viewport, without changing  
the current viewport.

Walk through
The Walk Through tool is available in Perspective and Camera viewports only. It allows 
you to navigate through these viewports. On invoking this tool, the cursor changes 
into a circle with a dot at its center. Press and hold the left mouse button to navigate 

in the active viewport. Alternatively, invoke this tool and then press the arrow keys to navigate 
through the viewport. On pressing the arrow key, the cursor shows a directional arrow indicating 
the navigation direction.

orbit
The Orbit tool is used to rotate the viewport around its view center. Rotating the view 
enables you to see the three-dimensional (3D) view of the objects in the Perspective 

viewport. You can rotate the Top, Front, and Left viewports as well. But in such cases, the 
respective viewport becomes the Orthographic viewport.

orbit Selected
The function of the Orbit Selected tool is the same as the Orbit tool with the only 
difference that it is used to rotate the viewport about the center of the current 
selection. 

orbit Subobject
The function of the Orbit SubObject tool is the same as the Orbit tool with the only 
difference that it is used to rotate the viewport about the center of the current sub-object 
selection. 

Maximize Viewport toggle
The Maximize Viewport Toggle tool is used to maximize the active viewport so that 
you can view only active viewport in place of all four viewports. 

Selection techniques
In Autodesk 3ds Max, you can select objects using various tools such as Select Object, Select 
by Name, Select and Move, and so on. These tools are discussed next.

Select object tool
  Quad Menu: Select   
  Main Toolbar: Select Object       
  Keyboard: Q  

The Select Object tool is used to select one or more objects in the viewport. To select 
an object, choose this tool and place the cursor over the object; the cursor will convert 
into a selection cursor. Next, press the left mouse button; the objects will be selected. 
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To select more than one object at a time, hold the CTRL key and click on the objects that you 
want to add to the selection. To remove an object from the selection set, hold the ALT key 
and click on the object that you want to remove from the selection.

Select by name tool
  Menu bar: Edit > Select By > Name  
  Main Toolbar: Select by Name                  
  Keyboard: H      

The Select by Name tool is used to select an object by its name from the list of objects 
present in the Select From Scene dialog box. When you invoke the Select by Name 
tool from the Main Toolbar, the Select From Scene dialog box will be displayed, 

showing the list of the components/objects in the scene, as shown in Figure 2-21. Now, select 
a component from the list and then choose the OK button to select the component in the scene. 
Alternatively, you can double-click on the object name in the list to select it. You can also 
select more than one object by holding the CTRL key. The buttons at the top of the dialog 
box are used to filter the objects in the list.

Figure 2-21  The Select From Scene dialog box

Select and Move tool
  Quad Menu:  Move    
  Main Toolbar: Select and Move   
  Keyboard: W   

The Select and Move tool is used to select and move objects in the viewport. You can 
move an object by selecting it and then dragging the mouse along the X, Y, or Z axis. 
You can also move an object in the XY, YZ, or ZX plane. To move an object along one 

of the axes, invoke Select and Move tool and then select the object; all axes will be displayed. 
Move the cursor over the axis along which you want to move the object, press the left mouse 
button, and then drag the cursor. Similarly, to move the object in one of the planes, place the 
cursor over that plane displayed between the two axes; the plane will be highlighted in yellow. 
Next, press the left mouse button and drag the cursor.
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Select and rotate tool
  Quad Menu:  Rotate     
  Main Toolbar: Select and Rotate  
  Keyboard: E   

The Select and Rotate tool is used to 
rotate an objects in the viewport along the 
X, Y, or Z axis. To rotate the object along 

one of the axes, invoke the Select and Rotate tool, 
and then select the object; a rotate gizmo will be 
displayed along the X, Y, and Z axes. Next, move 
the cursor over the axis along which you want to 
rotate the object. Now, press the left mouse button, 
and then drag the cursor. When you rotate the 
object, a transparent slice will be displayed, 
showing you the visual representation of the 
direction and the degree of rotation, as shown in 
Figure 2-22. Also, you can view the degree of rotation in the X, Y, and Z axes in the coordinates 
displayed at the bottom of the screen.

Select and Scale tools
  Quad Menu:  Scale    
  Main Toolbar: Select and Scale  
  Keyboard: R   

There are three types of tools that are used to scale an object. These tools are available in the 
Select and Scale flyout and are discussed next.

Select and uniform Scale  
The Select and Uniform Scale tool is used to scale 
the objects proportionally along the three axes. 
To scale an object uniformly along all the three 

axes, invoke the Select and Uniform Scale tool from the 
Main Toolbar and select the object; the scale gizmo will 
be displayed, as shown in Figure 2-23. Move the cursor to 
the center of the gizmo and make sure its central portion 
is highlighted, refer to Figure 2-23. Next, drag the cursor 
up or down to scale the selected object. You can also 
perform non-uniform scaling using this tool. For example,  
to scale the object along Z-axis, move the cursor over the 
Z-axis, as shown in Figure 2-24, and then drag the cursor. 
Similarly, you can perform non-uniform scaling along the 
XY, YZ, or ZX plane. For example, to scale the object along 
YZ plane move the cursor over the YZ plane, as shown in 
Figure 2-25. Next, drag that particular plane.

Figure 2-22  The circular gizmo in the Top 
viewport while rotating the object

Figure 2-24  Selecting the 
Z-axis for non-uniform scaling 

Figure 2-23  The scale gizmo for 
uniform scaling  
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Select and non-uniform Scale 
The Select and Non-uniform Scale tool is used to 
scale an object non-uniformly along a particular axis 
or plane. To scale an object, invoke the Select and 

Non-uniform Scale tool from the Select and Scale flyout, 
and then select the object. Move the cursor over the axis 
along which you want to scale the object and drag the 
cursor to modify the shape of the object. Similarly, you can 
perform the non-uniform scaling along the XY, YZ, or ZX 
plane. You can also perform uniform scaling in the same manner, as described in the 
Select and Uniform Scale tool.   

Select and Squash 
The Select and Squash tool is used to select and squash the object along the 
selected axis. To squash an object along one of the axes, invoke the Select and 
Squash tool and select the object. Move the cursor over the axis along which you 

want to squash it. Next, drag the cursor. Similarly, you can squash the selected object along 
the XY, YZ, or ZX plane. To do so, move the cursor over the plane and drag the cursor 
to squash the object along that plane.

note
By default, the color of the X,Y, and Z axes of the transform gizmos is red, green, and blue, 
respectively. When you move the cursor over any of these axes, the axis gets activated and turns 
yellow. You can see the colors of these axes at the bottom left corner of each viewport or while 
selecting an object using the Select and Move, Select and Rotate, or Select and Scale tool. 
Figures 2-26, 2-27, and 2-28 show the move gizmo, the rotate gizmo, and the scale gizmo, 
respectively.

Figure 2-26  The move gizmo Figure 2-27  The rotate gizmo Figure 2-28  The scale gizmo

axis constraints toolbar
The buttons in the Axis Constraints toolbar are used to specify the axis or plane along 
which the transformation would take place. The Axis Constraints toolbar is not displayed 
by default on the interface. To display it, right-click in the blank area on the Main Toolbar; 
a shortcut menu will be displayed. Choose Axis Constraints from the shortcut menu; the 
Axis Constraints toolbar will be displayed on the screen, as shown 
in Figure 2-29. Now, choose one of the buttons available in the Axis 
Constraints toolbar to perform the transformation along the selected 
axis. You can also use the F5, F6, and F7 function keys to invoke the 
X, Y, and Z constraints, respectively. To toggle between the XY, YZ, 
and XZ axes, you can use the F8 function key. 

Figure 2-29  The Axis 
Constraints toolbar

Figure 2-25  Selecting the YZ 
plane for non-uniform scaling 
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time Slider and animation playback controls
Autodesk 3ds Max provides various options to animate an object that you create in it. To do 
so, you need to be familiar with the animation playback controls and the time slider. These 
controls enable you to play, pause, and stop an animation. They are available at the lower 
right corner of the Autodesk 3ds Max screen and are discussed briefly.

time Slider
The time slider displays the current frame and the total number 
of frames in the current  time segment, refer to Figure 2-30. 
You can view the animation at each frame by dragging the time 
slider. The time segment is the total range of frames that you 
can access using the time slider. By default, it ranges from 0 to 
100. You can set the range using the Time Configuration dialog 
box, about which you will learn in the later chapters. 

playback controls
The tools in the animation playback controls are displayed on the left side of the viewport 
navigation controls, as shown in Figure 2-31. These tools are used to control the animation in 
the active viewport only. Also, you can set the total number of frames, animation length, and 
other settings of the animation using these tools.

The Play Animation button is used to play or start the animation in the active viewport. 
When you click on this button, it turns into a stop button.

The Stop animation button is used to stop the animation. 

The Go to Start button is used to set the time slider at the first frame of the active time 
segment.

The Go to End button is used to set the time slider at the last frame of the active time 
segment.

The Previous Frame button is used to move the time slider to the previous frame in 
the reverse direction. You can view the current frame on the time slider when it moves 
from one frame to another.

The Next Frame button is used to move the time slider to the next frame one frame 
at a time in the forward direction.

time controls 
In Autodesk 3ds Max, different types of tools 
are available at the bottom of the screen to 
control animation and its time settings, refer 
to Figure 2-31. You have already learned 
about the time slider and the animation 
playback controls in the previous section. The 
other controls are discussed next.

Figure 2-31  The time control tools

Figure 2-30  The time slider
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toggle auto Key Mode  
The Toggle Auto Key Mode button that is labeled as Auto Key is chosen to turn on 
and off the auto key animation mode. When you choose the Toggle Auto Key Mode 
button, it turns red. Also, the background of the time slider and the border of the active viewport 
turns red, indicating that you are in the animation mode. Now, if you make any changes in 
the object, the changes will be keyframed in the time slider. 

To animate using the Toggle Auto Key Mode button, first you need to make sure that the 
object to be animated is selected in the viewport. Choose the Go to Start button to set the time 
slider to the first frame. Next, choose the Toggle Auto Key Mode button to turn on the auto 
key animation mode; the Toggle Auto Key Mode button will turn red. Now, drag the time 
slider to a frame other than 0 and animate the selected object by modifying its parameters or 
by transforming it; a keyframe will be created on that frame and at frame 0 on the track bar 
below the time slider. Again, move the time slider to another frame and change the parameters. 
You can continue this process until you get all the keyframes in a sequential order for your 
animation. Next, choose the Toggle Auto Key Mode button again to turn it off. Choose the 
Play Animation button to view the animation of the selected object in the current viewport.   

toggle Set Key Mode
The Toggle Set Key Mode button that is labeled as Set Key is chosen to turn on and 
off the set key animation mode. In this mode, you need to set keys for the animation 
of the selected object by choosing the Set Keys button on the left side of the Toggle Set Key 
Mode button. 

To perform the animation using the Toggle Set Key Mode button, select the object in the 
viewport in which you want to create the animation. Choose the Go to Start button to set the 
time slider to the first frame. Next, choose the Toggle Set Key Mode button to turn on the 
set key animation mode; the button will turn red. Choose the Set Keys button; it will flash 
red color and a keyframe will be set for the current position of the selected object. Now, drag 
the time slider to set a frame other than 0 and animate the selected object. Again, choose 
the Set Keys button; it will flash red color and another keyframe will be set on the track bar 
on the changed position. You can continue this process until you get all the keyframes in a 
sequential order for your animation. Then, choose the Toggle Set Key Mode button to turn 
it off. Also, choose the Play Animation button to view the animation of the selected object in 
the current viewport. 

note
When you choose the Toggle Set Key Mode button and transform an object, the keyframe will 
be set only if you choose the Set keys button.

current Frame (Go to Frame)
The Current Frame (Go To Frame) spinner shows the current frame number at which the 
time slider is positioned. While animating your scene, if you want to go to another frame, you 
can enter the frame number directly in the Current Frame (Go To Frame) spinner. As you 
drag the time slider, the value in the Current Frame (Go To Frame) spinner gets changed 
automatically according to its position. 
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Key Mode toggle
By default, the Key Mode Toggle button is not activated. If activated, it allows you to jump 
between the keyframes directly. To understand the function of this button, you need to select 
the animated object in the viewport. Next, choose the Key Mode Toggle button; it will turn 
blue and the Previous Frame and Next Frame buttons in the animation playback controls 
will be replaced with the Previous Key and Next Key buttons, refer to Figures 2-32 and 2-33. 
Choose the Previous Key or Next Key button to move the time slider from one keyframe to 
the other.

Figure 2-32  Animation playback controls 
before choosing the Key Mode Toggle button

Figure 2-33  Animation playback controls after 
choosing the Key Mode Toggle button

time configuration
The Time Configuration button is used to set the length of an 
animation by defining the number of frames in the track bar. It 
is also used to set the frame rate, time display, and so on. To set 
these parameters, choose the Time Configuration button; the 
Time Configuration dialog box will be displayed, as shown in 
Figure 2-34. You need to use the options in this dialog box to set 
the animation length, frame rate, and time display. The options 
in this dialog box are discussed next.

Frame rate area
The radio buttons in this area are used to set a particular frame 
rate for the animation in frames per second. By default, the 
NTSC radio button is selected. The FPS spinner is used to 
manually set the frame rate of the animation.

time display area
The radio buttons in this area are used to display the method 
of time in the time slider. By default, Frames radio button is 
selected.

playback area
The Playckback area is used to set the playback speed of the animation. By default, the Real 
Time check box is selected in this area. You can select one of the radio buttons such as 1/4x 
or 1/2x, and so on in the Speed group to define the speed of the playback animation. If you 
clear the Real Time check box, then the Speed group will be deactivated and the Direction 
group will be activated. The radio buttons in the Direction group are used to define the 
direction of the playback animation. The Active Viewport Only check box is selected by 
default and is used to play the animation only in the active viewport. If you clear this check 
box, then the animation will be played simultaneously in all the viewports. The Loop check 
box is also selected by default and is used to repeatedly play the animation repeatedly.     

 Figure 2-34  The Time 
Configuration dialog box
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animation area
The options in this area are used to set the length of animation. The default values in the 
spinners of this area specify the number of frames for the animation. Set the values in the 
Start Time and End Time spinners to specify the current time segment in the time slider. The 
current time segment is the total range of frames that you can access using the time slider. 
Set the value in the Length spinner to specify the total number of frames in the current time 
segment or the length of the animation. The value in the Frame Count spinner specifies the 
number of frames that will be rendered. The value in the Current Time spinner specifies 
the current frame number at which the time slider is positioned. Choose the Re-scale Time 
button; the Re-scale Time dialog box will be displayed. You can specify the options in this 
dialog box to change the existing time segment to a new time segment.  

track Bar
The track bar lies between the time slider and the status bar, refer to Figure 2-35. It displays 
a timeline along with the frame numbers. 

Figure 2-35  Partial view of the track bar and the time slider

track View
  Menu bar:   Graph Editors > Track View - Curve Editor  
    Graph Editors > Track View - Dope Sheet  
  Main Toolbar:   Curve Editor (Open)    

The track view is used to view and edit the animation keys in the scene. The track view 
uses two different modes, Curve Editor and Dope Sheet. In the Track View - Curve 
Editor window, as shown in Figure 2-36 the animation is displayed as the function 

curves on a graph. In the Track View -  Dope Sheet window, the animation is displayed as a 
spreadsheet of keys, as shown in Figure 2-37. 

Figure 2-36  The Track View - Curve Editor window

To edit the animation of an object using Curve Editor, select the animated object and invoke 
the Curve Editor (Open) tool from the Main Toolbar; the Track View - Curve Editor dialog 
box will be displayed, refer to Figure 2-37. The pull-down menus on the top of this dialog box 
are used to choose different options to edit the animation. The hierarchy on the left side of 
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this dialog box displays all the objects of the scene. To view the sub-options in this tree, you 
need to click on the plus sign(+). The edit window on the right of the hierarchy tree is used 
to edit the animation of the objects using the tangent handles available on the keys found on 
the curves. 

To edit the animation of an object using Track View -  Dope Sheet window, select the animated 
object and choose Graph Editors > Track View - Dope Sheet from the menu bar; the Track 
View - Dope Sheet window will be displayed, refer to Figure 2-37. In this window, you can 
view all the keys in a spreadsheet form. You need to select the keys and edit them according 
to the animation.

Figure 2-37  The Track View - Dope Sheet window

tip: You can also invoke Track View - Curve Editor in place of the track bar. To do
so, choose the Open Mini Curve Editor button on the left side of the track bar.   

rendering an animation
  Menu bar:    Rendering > Render Setup  
  Main Toolbar:    Render Setup    
  Keyboard:    F10    

Rendering is a process of generating a photorealistic scene. It shows the lighting 
effects, materials applied, background, and other settings that are set for the scene. 

To render the animated scene, invoke the Render Setup tool; the Render Setup: Default Scanline 
Renderer dialog box will be displayed, as shown in Figure 2-38. The Common tab is chosen 
by default in this dialog box. In the Common tab, set the parameters in the different rollouts 
and make sure that the Production radio button is selected on the bottom of this dialog box. 
Also, in the View drop-down list, select the viewport that you want to render. Next, choose the 
Render button; the Perspective, frame 0, Display Gamma:2.2, RGBA Color 16 Bits/Channel 
(1:1) dialog box and the Rendering dialog box will be invoked, displaying the rendering 
process, as shown in Figure 2-39. Various rollouts in the Common tab of the Render Setup: 
Default Scanline Renderer dialog box are discussed next. 
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Figure 2-38 The Render Setup: 
Default Scanline Renderer dialog 
box

Figure 2-39  The Rendering dialog box

common parameters rollout
There are different types of renderers to render a scene in Autodesk 3ds Max such as mental 
ray Renderer, VUE File Renderer, and so on. The options in this rollout are used to set the 
common parameters for all types of renderers. The commonly used areas in this rollout are 
discussed next.

time output area 
This area is used to set the number of frames that you want to render. By default, the Single 
radio button is selected that enables you to render only a single frame. To render the animation, 
you need to select the Active Time Segment or Range radio button. This radio button renders 
all the frames in the current time segment. Select the Range radio button to specify a range 
of frames for rendering. To do so, enter the start and end frame numbers in the spinners 
given on the right of this radio button. The Frames radio button allows you to render the 
frame numbers or frame range of your choice. To do so, select this radio button and enter the 
required frame number or range in the text box given on the right of this radio button. 

output Size area
This area is used to define the size of the rendered image. Choose one of the default 
buttons such as, 320x240, 640x480, 720x486, or 800x600 to define the size of the output 
window; the corresponding values will be displayed in the Width and Height spinners. You 
can also set the values manually in the Width and Height spinners to define the size. You can 
also select the standard resolution formats from the Custom drop-down list.



2-24                                       Character Animation: A Tutorial Approach
E

va
lu

at
io

n 
C

op
y.

 D
o 

no
t r

ep
ro

du
ce

. F
or

 in
fo

rm
at

io
n 

vi
si

t w
w

w
.c

ad
ci

m
.c

om

options area
The check boxes in this area are selected to include the render effects in the final output such 
as atmospheres, lighting effects, and so on.   

advanced Lighting area
The check boxes in this area are selected to use options for advanced lighting or computing 
render effects.

Bitmap performance and Memory options area
This area is used to decide whether Autodesk 3ds Max will use the full resolutions maps or 
the proxies of the maps at rendering. To assign the render settings, you need to choose the 
Setup button in this area; the Global Settings and Defaults for Bitmap Proxies dialog box 
will be displayed. The Global Settings and Defaults for Bitmap Proxies dialog box is used 
to set create and proxy versions of the bitmaps used in materials.

render output area 
This area is used to specify a file where the rendered animation can be saved. To do so, 
choose the Files button; the Render Output File dialog box will be displayed. Enter the 
name of the file in the File name text box and then select AVI file (.avi) from the Save as type 
drop-down list. Next, choose the Save button; the AVI File Compression Setup dialog box 
will be displayed. Use the default settings and choose the OK button; the Save File check 
box will get selected and the path of the file will be displayed just below the Files button in 
the Render Output area.

assign renderer rollout
This rollout is used to set renderer for the scene. 
The Production option is used to assign a 
renderer for the graphics. The Material Editor 
option is used to assign a renderer for the sample 
slots in the Material Editor dialog box. The 
ActiveShade option is used to assign a renderer 
for the lighting effects in the scene, as shown  in 
Figure 2-40.

To assign a renderer, choose the Choose Renderer button on 
the right of the options given in Assign Renderer rollout; the 
Choose Renderer dialog box will be displayed, as shown in 
Figure 2-41. Select a renderer and choose the OK button; the 
name of the selected renderer will be displayed in the text box 
on the right of the selected option. Choose the Save as Defaults 
button in the Assign Renderer rollout to save the settings as 
default for further use. 

note
If you install any additional renderer plug-ins in Autodesk 
3ds Max, the renderer types will be added in the Choose 
Renderer dialog box.

Figure 2-40  The Assign Renderer rollout

Figure 2-41 The Choose 
Renderer dialog box
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previewing an animation
If a scene has a large number of objects, lights, and special effects, it may take a long to render 
the final animation. To check the accuracy of animation, Autodesk 3ds Max allows you to 
preview the animation in low resolution. Note that in the preview rendering, only the diffuse 
color maps are displayed. Therefore, it takes lesser time to render. You can have a look at your 
animation before the final rendering. 

To create a preview animation, choose Tools 
> Views - Grab Viewport > Create Animated 
Sequence File from the menu bar; the Make 
Preview dialog box will be displayed, as shown 
in Figure 2-42. Alternatively, choose Create 
Preview > Create Animated Sequence File 
from the General viewport label to invoke the 
Make Preview dialog box. Set the parameters 
for different options in this dialog box and 
select the scene that you want to render from 
the Render Viewport drop-down list which 
is located at the bottom of the dialog box. 
Next, choose the Create button; the Video 
Compression dialog box will be displayed. 
The Video Compression dialog box will be 
only displayed if you choose the Microsoft 
Video 1 button. Use the default settings 
and choose the OK button; the rendering of 
the preview will start. Once the preview has 
been created, it will automatically start in the 
Windows Media Player. 

To view the last preview animation, choose 
Tools > Views - Grab Viewport > View 
Animated Sequence File from the menu 
bar; the animation will start playing in the 
Windows Media Player. Alternatively, choose 
Create Preview > View Animated Sequence 
File from the General viewport label, as shown 
in Figure 2-43.

renderInG eFFectS 
The Rendering effects are special effects, 
assigned to a scene. These effects are visible 
only at rendering. To assign a rendering 
effect to a scene, choose Rendering > 
Effects from the menu bar; the Environment and Effects dialog box will be displayed, as 
shown in Figure 2-44. The Effects tab is chosen by default. In the Effects rollout of this tab, 
choose the Add button; the Add Effect dialog box will be displayed, as shown in Figure 2-45. 
Select any of the rendering effect from the list given in this dialog box and then choose the 

Figure 2-42  The Make Preview dialog box

Figure 2-43  The flyout and the cascading menu of 
the General viewport label
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OK button; the selected rendering effect will be displayed in the Effects text area of the Effects 
rollout. Also, the rollouts related to the selected effect will be displayed in the Environment 
and Effects dialog box. Next, set the parameters for the selected rendering effect in these 
rollouts and close the dialog box. Now, render the final scene; the rendering effects will be 
displayed in the final rendered image.

Figure 2-44  The Environment and 
Effects dialog box

Figure 2-45  The Add Effect dialog box

underStandInG controLS
In Autodesk 3ds Max, there are some special controls that can be used for creating or modifying 
the objects in the viewports. These controls are discussed next.

Flyout
A flyout is an icon-based menu that contains the tools having similar type of functions. 
Figure 2-46 shows the Snap Toggle flyout. The buttons having a small triangle at their 
lower-right corner contain a flyout. Press and hold such a button; a flyout will be displayed, 
refer to Figure 2-47.

Figure 2-46  The Snap Toggle flyout Figure 2-47  Displaying the flyout on choosing the small 
triangle
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right-click Menus
In Autodesk 3ds Max, the right-click menus provide quick access to the commonly used 
commands that are related to the current selection of an object. When you right-click on an 
object, a quad menu is displayed, as shown in Figure 2-48. Some of the options in the quad 
menu have an arrow on their right side. If you move the mouse on these options, a cascading 
menu will be displayed. But, if you right-click in the viewport, a shortcut menu will be displayed, 
refer to Figure 2-48.  

Snaps Settings
Snaps restrict the movement of the cursor to a specific part of an object or grid. There are four 
buttons available for snap settings in the Main Toolbar: Snaps Toggle, Angle Snap Toggle, 
Percent Snap Toggle, and Spinner Snap Toggle. If you right-click on the Snaps Toggle, Angle 
Snap Toggle, or Percent Snap Toggle button, the Grid and Snap Settings dialog box will be 
displayed, as shown in Figure 2-49. In the Snaps tab, you can select the different points in an 
object or grid where the cursor will snap to. You can turn the snap command on and off by 
pressing the S key or by selecting the Snaps Toggle button.

If you choose and hold the Snaps Toggle button, a flyout will be displayed. This flyout 
contains the 2D Snap, 2.5 Snap, and 3D Snap tools, which can be invoked to snap the 
cursor. 

Figure 2-49   The Grid and Snap 
Settings dialog box

Figure 2-48  Displaying the shortcut menu and cascading 
menu

units Setup 
The units setup in Autodesk 3ds Max is used to specify the units that help in measuring the 
geometry in a scene. You can change the settings for units by using the Customize pull-down 
menu. To do so, choose Customize > Units Setup from the menu bar; the Units Setup dialog 
box will be displayed, as shown in Figure 2-50. By default, the Generic Units radio button 
is selected in this dialog box. Select any other radio button as per the requirement from the 
Display Unit Scale area of this dialog box and then choose the OK button; the limits in all 
spinners in Autodesk 3ds Max will be modified accordingly.
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Setting Grid Spacing
To set the spacing between the visible grids in the 
viewports, choose Tools > Grids and Snaps > Grid 
and Snap Settings from the menu bar; the Grid 
and Snap Settings dialog box will be displayed. In 
the Home Grid tab, as shown in Figure 2-51. Set 
the value in the Grid Spacing spinner to specify 
the size of the smallest square of the grid. The 
value in the spinners will be measured in the units 
that you specify in the units setup. Set the value in 
the Major Lines every Nth Grid Line spinner to 
specify the number of squares between the major 
lines in the grid. Set the value in the Perspective 
View Grid Extent spinner to specify the size of 
the home grid in the Perspective viewport. Note 
that the default grid displayed in the viewports 
on starting Autodesk 3ds Max is known as the 
home grid.

In the Dynamic Update area, the Active Viewport 
radio button is selected by default. It is used 
to update the settings of the active viewport 
as per the settings in the Home Grid tab. Select the 
All Viewports radio button to update all viewports 
simultaneously according to the new values that 
you have set in the spinners of the Grid and Snap 
Settings dialog box.   
      

hotKeyS
In Autodesk 3ds Max, you can use the keys on the 
keyboard to invoke some of the tools. These keys 
are known as the hotkeys. You can work faster 
and more efficiently using the hotkeys. The major 
hotkeys and their functions are listed next.

Main toolbar
The hotkeys that can be used to invoke the tools 
from the Main Toolbar are given next.

    H      Invokes the Select by Name tool

    S      Invokes the tools from the Snaps Toggle button

    A      Invokes  the Angle Snap Toggle tool

    CTRL+SHIFT+P      Invokes the Percent Snap Toggle tool

    M      Invokes the Material Editor tool

    SHIFT+Q      Invokes the Quick Render tool

Figure 2-51  The Home Grid tab 
chosen in the Grid and Snap Settings 
dialog box

Figure 2-50  The Units Setup dialog box
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Viewport navigation controls
The hotkeys that can be used to invoke the tools in the viewport navigation controls are given 
next.

ALT+CTRL+Z Performs the action of the Zoom Extents tool

ALT+W Invokes the Maximize Viewport Toggle tool

ALT+Z Invokes  the Zoom tool

CTRL+W Invokes the Zoom Region tool

CTRL+P Invokes the Pan tool

Scroll the middle mouse button Zooms in or out the active viewport

CTRL+R Invokes the Orbit tool

SHIFT+Z Used to undo the Zoom or Pan command actions

ALT+ press and hold the middle 
mouse button and move the mouse

Performs the actions of the Orbit tool

The following hotkeys are used to change the POV viewport labels:

V Invokes the viewport quad menu

T Invokes the Top viewport

F Invokes the Front viewport

L Invokes the Left viewport

P Invokes the Perspective viewport

B Invokes the Bottom viewport

U Invokes the Orthographic viewport

 

animation playback controls
The hotkeys that can be used to invoke the tools in the animation playback controls are given 
next.

N Invokes the Toggle Autokey Mode tool

Home Invokes the Go To Start button

End Invokes the Go To End button

/ (backslash) Invokes the Play Animation button

ESC Invokes the Stop Animation button

, (comma) Invokes the Previous Frame button

. (period) Invokes the Next Frame button
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cuStoMIZInG the hotKeyS
In Autodesk 3ds Max, you can create your own keyboard shortcuts. To do so, choose 
Customize > Customize User Interface from the menu bar; the Customize User Interface 
dialog box will be displayed, as shown in Figure 2-52. 

Figure 2-52  The Customize User Interface dialog box 

In this dialog box, the Keyboard tab is chosen by default. In this tab, select a command from 
the Group and Category drop-down lists; the list of the categories in the selected group will 
be displayed just below the Category drop-down list. Now, select one of the actions from the 
list and then enter the key that you want to assign to the selected action in the Hotkey text 
box. Next, choose the Assign button; the key is assigned to the selected action.

cuStoMIZInG the coLorS oF the uSer InterFace
Autodesk 3ds Max allows you to modify the colors of the software interface. You can 
modify the colors for almost every element in the interface. To modify the colors, choose 
Customize > Customize User Interface in the menu bar; the Customize User Interface dialog 
box will be displayed. Choose the Colors tab. Next, select the category of the interface element 
from the Elements drop-down list; the list of the corresponding elements will be displayed just 
below the Elements drop-down list. Now, select one of the elements from the list and choose 
the color swatch on the right of the Elements drop-down list; the Color Selector dialog box 
will be displayed. Select a new color and choose the OK button to close the Color Selector 
dialog box. 

You can reset the new color to the default one. To do so, choose the Reset button at the 
bottom of the Customize User Interface dialog box; the Revert Color File message box 
will be displayed, as shown in Figure 2-53. Choose the Yes button; the default color will be 
displayed in the color swatch.
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Figure 2-53  The Revert Color File message box

heLp preFerenceS
When you choose Help > Autodesk 3ds Max Help from the menu bar; the 3ds Max help will 
be displayed from the Autodesk website. If you want to open the help from the local drive, 
you need to download it from http://usa.autodesk.com/adsk/servlet/item?id=16755719&siteID=1
23112&linkID=10809867 and then install it. Next, restart 3ds Max. Choose Customize > 
Preferences from the menu bar; the Preference Settings dialog box will be displayed. Choose 
the Help tab in this dialog box, refer to Figure 2-54. Select the Local Computer/ Network 
radio button from the Help Location area and then choose the OK button to exit the dialog 
box. Now, you can access the help from local drive.

Figure 2-54  The Help tab in the Preference Settings dialog box 

3ds MaX oVerVIeW
3ds Max deals with varied aspects of modeling, animation, rendering, and so on. These aspects 
are discussed next.
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Modeling
In 3ds Max, there are four types of modeling methods: NURBS, Patch Modelling, Mesh 
Modelling, Poly Modelling. Before modeling an object, you first need to visualize it in 3D 
and then you need to examine it to determine the method of modelling to be used. Your 
visualization and approach towards the object will guide you to judge the method of modeling 
that you want to use for creating the object. The various types of modelling methods are 
discussed next.

nurBS
The NURBS (Non-Uniform Rational Basis Splines) curves and surfaces are used to create 
complex 3D models. The NURBS objects use the mathematical calculations to create accurate 
complex 3D objects from 2D splines.

nurBS curves
 The NURBS curves are similar to the shape objects and are used to create complex surfaces 

for creating 3D models. You can use the NURBS curves to create 3D surfaces using modifier 
such as Lathe and Extrude. Also, you can loft the NURBS curves to create loft objects. In 
Autodesk 3ds Max, there are two types of NURBS curves, Point Curve and CV Curve. 

 
 nurBS surfaces
 The NURBS surfaces are the base of the NURBS model. The NURBS models can be 

created by modifying NURBS surfaces at advanced level. In Autodesk 3ds Max, there are 
two types of NURBS surfaces: Point Surface and CV Surface.

editable Mesh
You can modify most of the objects at advanced level by converting them into editable mesh. 
However, the open splines such as line, arc, and so on cannot be converted into editable mesh. 
The editable mesh provides you the sub-object levels of an object. These sub-object levels help 
you to select the sub-objects of an object in the viewport. You need to move, rotate, and scale 
these sub-objects to modify the shape of the object.   

You can convert an object into editable mesh by using one of the following methods:

1. Create an object and select it in the viewport. Next, right-click on the object; a quad menu 
will be displayed. Choose the Convert To: option; a cascading menu will be displayed, 
as shown in Figure 2-55. Choose Convert to Editable Mesh; the object will be converted 
into editable mesh.

2. Create an object and select it in the viewport. Choose the Modify tab in the Command 
Panel; the modifier stack will be displayed in the modify panel. In the modifier stack, 
right-click on the name of the tool; a shortcut menu will be displayed, as shown in 
Figure 2-56. Choose the Editable Mesh option from the shortcut menu; the object will 
be converted into editable mesh.
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Figure 2-56  The shortcut 
menu in the modifier stack

Figure 2-55  The cascading menu after right-clicking on the 
object

editable poly
To modify an object with editable poly is similar to modifying an object with the editable mesh. 
The only difference is that the editable poly works with advance tools, meant for polygonal 
mesh editing. To work with editable poly, you need to convert the object into editable poly. 
To convert an object into editable poly, you need to use one of the following methods:

1. Create an object and select it in the viewport. Next, right-click on the object; a quad menu 
will be displayed. Choose the Convert To: option; a cascading menu will be displayed. 
Choose the Convert to Editable Poly option; the object will be converted into editable 
poly.

  
2. Create an object and select it in the viewport. Choose the Modify tab in the Command 

Panel; the modifier stack will be displayed in the modify panel. In the modifier stack, 
right-click on the name of the tool which you have used to create the object; a shortcut menu 
will be displayed. Choose the Editable Poly option; the object will be converted into 
editable poly.

3. Create an object and select it in the viewport. Next, move the cursor over the Polygon 
Modeling panel in the Graphite Modeling Tools tab; a flyout will be displayed, as shown 
in Figure 2-57. Choose the Convert to Poly option; the selected object will be converted 
into editable poly.

note
When you convert an object into editable poly, various panels will be displayed in the Graphite 
Modeling Tools tab, such as Edit, Geometry (All), Subdivision, and so on.
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Figure 2-57  A flyout displayed after moving the cursor over the Polygon 
Modeling panel

Modifiers 
The modifiers are used to modify or edit an object in an advance and realistic way. You can 
apply more than one modifier to an object. The modifiers can also be used to modify the object 
at sub-object levels. There are three categories of modifiers in the Modifier List drop-down 
list: Selection Modifiers, WORLD-SPACE MODIFIERS, and OBJECT-SPACE MODIFIERS. 
The most commonly used modifiers in these three categories are discussed next: 

Mesh Select Modifier
The Mesh Select modifier is used to pass the sub-object selections of the selected object to 
subsequent modifiers in the modifier stack. 

displace Modifier
The Displace modifier is used to deform the shape of an object by displacing the vertices. 
You can distort the object either by using the gizmo of the modifier or by using the bitmap 
image.

extrude Modifier
The Extrude modifier is used to convert a 2D spline into a 3D object. It provides thickness 
and depth to a spline.

Face extrude Modifier
This modifier is used to extrude the selected faces along their normals. A normal is an invisible 
line coming straight out of the centre of the face at 90 degree angle.

Lattice Modifier
The Lattice modifier is used to convert the segments, edges, or shape of an object into 
wireframes or cylindrical struts.
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Material Modifier
The Material modifier is used to assign the material ID to the object or the sub-objects. 
The material ID of an object is a value given to specify the sub-material that will be applied 
to it from the Multi/Sub-Object material. You can apply different materials to the selected 
sub-objects by assigning different material IDs.

noise Modifier
The Noise modifier is used to generate the disturbances on the surface of an object to create 
irregular surfaces. It can also be used to animate the water or wavy surfaces.  

twist Modifier
The Twist modifier is used to produce the swirling effect on an object. 

Lathe Modifier
The Lathe modifier is a shape modifier and is used to create a 3D object by rotating a shape 
about an axis. The direction of the axis of revolution depends on the pivot point of the 
shape.      
                  
MeshSmooth Modifier
The MeshSmooth modifier is used to produce smoothness in 3D mesh objects.

tessellate Modifier
The Tessellate modifier is used to subdivide the faces of an object. It provides smoothness at 
curved surfaces for rendering.     

push Modifier
The Push modifier is used to push an object inward or outward along the normals of its 
faces.                               

normal Modifier
The Normal modifier is used to flip the normals of an object without applying an Editable Mesh 
Modifier.    

edit Mesh Modifier
Applying the Edit Mesh modifier to an object is the same as converting the object into 
editable mesh. The Edit Mesh modifier and the editable mesh object provides the same 
edting tools for different sub-object levels to modify the object at an advanced level. The 
main difference is that you can retain the object creation parameters and then use them to 
edit the object, even after applying the Edit Mesh modifier. Note that you cannot animate 
the sub-objects of an object after applying the Edit Mesh modifier. 

uVW Map Modifier
The UVW Map modifier is used to adjust the mapping coordinates on an object. It is used to 
control the appearance of mapped and procedural materials on the surface of an object.
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FFd (Free-Form deformation) Modifiers
The FFD modifiers are used to deform objects by creating a box around them. This box is 
made up of lattice and control points. You can deform an object using these control points 
and lattice. There are five different types of FFD modifiers: FFD 2x2x2, FFD 3x3x3, FFD 
4x4x4, FFD(box), and FFD(cyl), refer to Figures 2-58 through 2-60. 

The different types of FFD modifiers are based on the number of control points. The FFD 
2x2x2 modifier provides a lattice box with two control points on each of its edge. Similarly, 
FFD 3x3x3 and FFD 4x4x4 modifiers provide the lattice boxes with three and four control 
points on each of their edge, respectively.  The FFD(box) and FFD(cyl) modifiers are used with 
the box-shaped and cylinder-shaped objects. In these modifiers, you can adjust the number 
of control points in the lattice box in the Parameters rollout.

Figure 2-58  The FFD 2x2x2 modifier 
applied to the object

Figure 2-59  A box object with the 
FFD(box) modifier applied

Figure 2-60  A cylindrical object with 
the FFD(cyl) modifier applied

texturing
Texturing gives a realistic look to an object. In Autodesk 3ds Max, there are two types of material 
editors, Slate Material Editor and Compact Material Editor. The Slate Material Editor is 
mostly used to design the materials of your choice. It uses nodes and connection wires to 
graphically display the design of the materials created by you. The Compact Material Editor 
is more useful when you just need to apply the materials to the objects that have already been 
designed. To create a new material, press the M key; the Slate Material Editor dialog box will 
be displayed, as shown in Figure 2-61. Next, if you choose Modes > Compact Material Editor 
from the material editor menu bar; the Material Editor dialog box will be displayed, as shown 
in Figure 2-62. The title bar of the Material Editor dialog box displays the number and name 
of the current material, which gets changed depending on the material that you select. 
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Figure 2-61  The Slate Material Editor dialog box

 

Figure 2-62  Partial view of the Material Editor 
dialog box

Lighting
In Autodesk 3ds Max, lights are used to illuminate the scene and make it more realistic. They 
are also used to create the sources of illumination such as street lights, flashlights, and so 
on. There are two main categories of lights: Standard and Photometric. In these categories, 
different types of lights are available. You need to select one or more lights based on the 
requirement of a scene. The Photometric lights provide more realistic lighting effects but they 
are more complex than the Standard lights. Also, they use the light energy values to create a 
realistic scene. 
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animation
Animation brings life to an object. To animate an object, you need to define different positions, 
rotations, and scaling of the object at different key points in the time slider. These defined 
points are known as keyframes. The keys between the frames consist of the information about 
the actions performed in an animation. When you play an animation, a series of frames are 
displayed quickly one after another and the object seems to be moving. In Max, there are 
various types of animation. These will be discussed in later chapters.

particle Systems
In Autodesk 3ds Max, the particle systems are used to create an object 
that generates particles. These particles are used to simulate snow, 
dust, rain, and so on. You can also animate the particles in a particle 
system. To create a particle system, choose Create > Geometry in 
the Command Panel; a drop-down list will be displayed below the 
Geometry button. Select Particle Systems from the drop-down list; 
the Object Type rollout containing various types of tools to create 
the particle system will be displayed, as shown in Figure 2-63. 

Space Warps
In Autodesk 3ds Max, the space warps objects cannot be rendered 
and are used to affect the motion and appearance of other objects. 
They can generate special effects such as blowing wind, flowing 
waves, and so on in the animation. There are five categories of 
space warps: Forces, Deflectors, Geometric/Deformable, Modifier-Based, and Particles & 
Dynamics.

Systems
In Autodesk 3ds Max, a system is an object set that consists of objects, linkages, and 
controllers. These systems help you to simplify the complex animations. There are four types 
of systems: Bones, Ring array, Sunlight, Daylight, and Biped. These will be discussed in 
later chapters.

rigid Body dynamics
A rigid body is an object which does not deform when it collides with another object. You can 
convert an object into three types of rigid bodies using the MassFX Toolbar. This toolbar is a 
new feature added in 3ds Max 2012. It consists of options for converting an object into rigid 
bodies, various types of constraint helpers, and simulation controls. 

constraints
Constraints are used to restrict the movement of rigid bodies in the simulation. Various types 
of constraints are available in the Constraint flyout, such as rigid constraint, slide constraint, 
hinge constraint, and so on. These constraints are used to make the two rigid bodies work 
together. A constraint links two rigid bodies together or links a single rigid body to a fixed 
point in global space. The constraints develop a hierarchical relationship in which the child 
object must be a dynamic rigid body, while the parent object can be a dynamic or a kinematic 
rigid body, or can be a point in the global space. 

Figure 2-63  Various tools 
displayed to create particle 
systems 
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note
For the printing purpose, this textbook will use the white background. However, for a better 
understanding and a clear visualization at various places, this textbook will follow other color 
schemes as well.  In addition, the shaded type of shading is used throughout the book in all screen 
captures. Moreover, at some places in figures, grids will be hidden for better understanding and 
visualization.

In some tutorials, you have been instructed to browse the images and max files from the 
CADCIM website. Therefore, before starting the tutorials, download the images and max files 
from http://www.cadcim.com. The path of the file is as follows:

Textbooks > Animation and Visual Effects > Character Animation > Character Animation: A 
Tutorial Approach (Using 3ds Max)

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1. Which of the following tools is used to improve the performance of a viewport in a complex 
scene by temporarily decreasing the visual fidelity of some of the objects?

 
  (a) Progressive Display   (b) Snaps Toggle flyout
  (c) Mirror    (d) All of these

2. Which of the following tabs should be chosen to control the animation controllers? 

  (a) Motion     (b) Display
  (c) Hierarchy    (d) None of these

3. Which of the following dialog boxes is used to set the spacing in the grids, displayed in 
the viewports?

 
  (a) Customize User Interface  (b) Grid and Snap Settings 
  (c) Units Setup    (d) All of these

4. Which of the following combinations of keys is used to invoke the pan tool?
 
  (a) CTRL+P    (b) SHIFT+Z
  (c) CTRL+A    (d) CTRL+W

5. The __________ is located at the bottom of the screen and displays the information about 
the active command or tool.

6. The __________ dialog box displays video tutorials which help in learning the basic working 
environment of the software.
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7. Most of the 3ds Max modeling and animation tools can be invoked from the tabs located 
in the Command Panel. (T/F)

8. The default interface of Autodesk 3ds Max consists of three equal viewports that are 
surrounded by tools and commands. (T/F)

9. In Autodesk 3ds Max, you can modify the color of almost every element in the interface. 
(T/F)

10. The tools in the animation playback controls are used to control the display of a viewport. 
(T/F) 

 Review Questions 
Answer the following questions:

1. Which of the following hotkeys is used to invoke the Stop Animation button?

  (a) HOME    (b) END
  (c) ESC     (d) N

2. The __________ provides visual feedback of the current orientation of the viewport.

3. The __________ displays the current frame and the total number of frames in the current 
line segment.

4. The __________ is located between the time slider and the status bar. 

5. The __________ tool located on the right of the status bar is used to lock a selection set. 

6. In Autodesk 3ds Max, the __________ objects cannot be rendered and are used to affect 
the motion and appearance of other objects. 

7. ____________ are used to restrict the movement of rigid bodies in simulation.

8. The __________ modifier is used to produce a swirling effect on an object. 

9. Snapping restricts the movement of the cursor to a specific part of an object or grid. 
(T/F)

10. The options in the General viewport label menu are used for defining the type of shadings 
displayed in the viewport. (T/F)

answers to Self-evaluation test
1. a, 2. a, 3. b, 4. a, 5. prompt line, 6. Welcome to 3ds Max, 7. T, 8. F, 9. T, 10. F


