
Chapter 2

Drawing Sketches for 
Solid Models

Learning Objectives
After completing this chapter, you will be able to:
• Understand the need of Sketch task environment.
• Start NX and create a new file in it.
• Invoke different NX environments.
• Understand the need of datum planes.
• Create three fixed datum planes.
• Create sketches in Sketch task environment.
• Create sketches in Modeling environment.
• Use various drawing display tools.
• Understand different selection filters.
• Select and deselect objects.
• Use various sketching tools.
• Use different snap point options.
• Delete sketched entities.
• Exit the Sketch task environment.
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The Sketch Task Environment
Most designs created in NX consist of sketch-based features and placed features. A sketch is 
a combination of numbers of two-dimensional (2D) entities such as lines, arcs, circles, and so 
on. The features such as extrude, revolve, and sweep that are created by using 2D sketches 
are known as sketch-based features. The features such as fillet, chamfer, thread, and shell 
that are created without using a sketch are known as placed features. In a design, the base 
feature or the first feature is always a sketch-based feature. For example, the sketch shown in 
Figure 2-1 is used to create the solid model shown in Figure 2-2. In this model, the fillets and 
the chamfers are the placed features.

Figure 2-1  Profile for the sketch-based feature of 
the solid model shown in Figure 2-2

Figure 2-2  Solid model created using the 
sketch-based and placed features 

To create sketch-based features, invoke the Sketch task environment and draw the sketch. 
Exit the Sketch task environment and then use the solid modeling tools to convert the sketch 
into a feature.

You can also create sketches directly in the Modeling environment by using the tools available 
in the Direct Sketch toolbar located at the bottom of the drawing window.

Unlike other solid modeling software packages where you need to use separate files 
for starting different environments, NX uses only a single type of file to start different 
environments. In NX, files are saved in the .prt format and all the environments required to 
complete a design can be invoked in the same .prt file. For example, you can draw sketches 
and convert them into features, assemble other parts with the current part, and generate 
drawing views in a single .prt file.

Starting NX 8.5
 Taskbar:	 Start > All Programs (or Programs) > Siemens NX 8.5 > NX 8.5	

You can start NX 8.5 by double-clicking on its shortcut icon on the desktop of your computer. 
Alternatively, choose Start > All Programs (or Programs) > Siemens NX 8.5 > NX 8.5 from 
the taskbar to start NX 8.5, refer to Figure 2-3.
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The default initial screen of NX 8.5 is shown in Figure 2-4. This screen displays information 
about NX 8.5, which helps you learn more about NX 8.5. You can also view other information 
by moving the cursor over the topics displayed on the left of the NX 8.5 screen.

Figure 2-3  Starting NX 8.5 from the taskbar

Figure 2-4  The default initial screen of NX 8.5

Tip: It is advised to read the information on the default initial screen of NX whenever 
you start a new session. This information will help you learn additional things 
about NX.
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Starting a New Document in NX 8.5
 Menu bar:	 File > New 		   
 Toolbar:	 Standard > New		

To start a new file, choose the New button from the Standard toolbar or choose File 
> New from the menu bar; the New dialog box will be displayed, as shown in 
Figure 2-5.

Figure 2-5  The New dialog box

The various tabs and options in this dialog box are discussed next.

Templates Rollout
In the New dialog box, templates are grouped together under various environment types such 
as Modeling, Drawing, Simulation, Manufacturing, Inspection, and Mechatronics Concept 
Designer. The template files related to these environments are available in their respective tabs. 
These files are used whenever you start a new file. These template files provide a predefined 
set of tools with specified environment. This saves a lot of time in setting environment and 
displaying tools according to your requirements.

Model Tab
By default, this tab will be chosen and the modeling templates will be displayed in the Templates 
rollout. Some of the important modeling templates are discussed next.
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Model 
By default, the Model template will be selected. This template is used to start a new part file 
in the Modeling environment for creating solid and surface models. 

Assembly
The Assembly template is used to start a new assembly file in the Assembly environment for 
assembling various parts of the assembly.

Shape Studio 
The Shape Studio template is used to start a new part file in the Shape Studio environment for 
creating advanced surface models.

NX Sheet Metal 
The NX Sheet Metal template is used to start a new file in the NX Sheet Metal environment for 
creating sheet metal models.

Blank
The Blank template is used to start a new file in the Gateway environment. The 
Gateway environment allows you to examine the geometry and drawing views created. You 
cannot modify a model in the Gateway environment. However, you can invoke any environment 
of NX from it. 

Drawing Tab
This tab is used to specify the template for a drawing. These templates are contained in the 
Templates rollout and are used to start a new drawing file in the Drafting environment for 
generating the drawing views. These templates are arranged according to the sheet size (A0, 
A1, A2, A3, and A4) in the Drawing tab. 

Units
The Units drop-down list is used to filter the templates as per the unit. The options in this 
drop-down list are discussed next.

Millimeters
If you select the Millimeters option, the templates only with the millimeters unit will be 
displayed in the Templates area.

Inches
If you select the Inches option, the templates only with the inches units will be displayed in 
the Templates area.

All
Select this option to display all the templates (with both millimeters and inches units).
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New File Name Rollout
This rollout is used to specify the name and location to save the file. The options in this rollout 
are discussed next.

Name
Enter the name of the new file in the Name text box. Alternatively, choose the button on the 
right side of the Name text box; the Choose New File Name dialog box will be displayed. 
Type the name in the File name edit box. Also, to specify the location to save the new file, 
browse the folder where you need to save the file and choose the OK button. However, there 
is a separate option to specify the location, which is discussed next.

Folder
Specify the location to save the new file in the Folder text box. Alternatively, choose the button 
on the right side of the Folder text box; the Choose Directory dialog box will be displayed. 
Next, browse the folder where you want to save the file and choose the OK button.

Note
It is recommended that you create a folder with the name NX 8.5 in the primary drive of your 
computer and then create individual folder for each chapter within the NX 8.5 folder. Now, 
you can save the part files of all chapters in their respective folders. This will ensure a better 
organization of the part files that you create.

In this textbook, the Model template has been used for starting a new file for illustrations.

After specifying all required options in the New dialog box, choose the OK button; the new 
file will start in the specified environment. Figure 2-6 shows the default initial screen of a new 
file invoked by using the Model template.

Figure 2-6  Default initial screen of a new part file
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Invoking Different NX Environments
You can invoke any NX environment in the same part file at any time. To invoke different 
environments, choose the Start button from the Standard toolbar; a flyout will be displayed, 
as shown in Figure 2-7. Choose the environment that you want to invoke from this flyout.

Figure 2-7  Flyout showing different environments of NX

Creating Three Fixed Datum Planes (XC-YC, 
YC-ZC, XC-ZC)
 Menu bar:	 Insert > Datum/Point > Datum Plane 	  
 Toolbar:	 Feature > Datum Plane			 

You can select the datum coordinate system plane (XC-YC, YC-ZC, or XC-ZC) from 
the drawing window to create the base feature. You can also create three 
fixed datum planes (YC-ZC, XC-ZC, and XC-YC) first and then use one of them to 
start the Sketch task environment. To create three fixed datum planes, choose Insert 

> Datum/Point > Datum Plane from the menu bar. Alternatively, choose the Datum Plane 
tool from the Feature toolbar; the Datum Plane dialog box will be displayed, as shown in 
Figure 2-8. Next, select the YC-ZC plane option from the drop-down list in the Type rollout; 
the preview of the plane will be displayed in the drawing window. Choose the Apply button; 
the YC-ZC plane will be created.

Similarly, select the XC-ZC plane and XC-YC plane option from the drop-down list in the 
Type rollout to create the XC-ZC and XC-YC planes, respectively. Figure 2-9 shows the three 
fixed datum planes created.
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Figure 2-9  Three fixed datum planesFigure 2-8  The Datum Plane dialog box

Tip: By default, some of the tools are not available in the toolbars. However, you 
can customize the toolbars to add these tools. To customize the toolbars, choose the 
black arrow at the bottom of the vertical toolbar or on the right of the horizontal 
toolbar. When you choose this arrow, a cascading menu will be displayed. Choose 
Add or Remove Buttons from the cascading menu; another cascading menu will 
be displayed with the names of a few toolbars. Move the cursor over the name of 
the toolbar in which you need to add more tools; another cascading menu will be 
displayed with all the tools that can be added to the selected toolbar. Note that all 
the tools that are currently available in the toolbar will have a check mark on their 
left. Select the name of the tools which you want to add to the toolbar; the selected 
tools will be added at the end of the toolbar.

Displaying the WCS (Work Coordinate System)
 Toolbar:	 Utility > WCS drop-down > Display WCS (Customize to add)  

The display of WCS (Work Coordinate System) is important in selecting the planes 
for drawing sketches. When you start a new file, by default, the display of WCS is 
turned on. It is recommended to keep the display of WCS turned on while 

drawing sketches and creating features.

If the display of WCS is turned off, then to turn it on, choose the Display WCS button from 
the WCS drop-down in the Utility toolbar; the WCS will be displayed at the origin of the 
drawing window. Figure 2-10 shows the WCS with the datum coordinate system hidden for 
better visualization. The Display WCS button is the toggle button. Choose this button again 
to turn off the display of WCS.

 

Figure 2-10  The WCS (Work Coordinate System)
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CREATING SKETCHES
In NX, you can create sketch of a feature by using two methods. In the first method, you need 
to invoke the Sketch task environment for creating the sketch and in the second method, you 
can directly create a sketch in the modeling environment by using the Direct Sketch toolbar. 
Both these methods are discussed next. 

Creating Sketches in the Sketch task Environment
 Toolbar:	 Feature > Sketch in Task (Customize to add)	

As mentioned earlier, the base feature or the first feature in a design is always a 
sketch-based feature. The profiles of the sketch-based features are defined by using 
a sketch. Therefore, to create the base feature, first you need to create a sketch. 

In NX, you can create a sketch by using the datum coordinate system plane (XC-YC, YC-ZC, 
or XC-ZC), any reference plane, or the existing face of the model.

To create a sketch, choose the Sketch in Task button from the Feature toolbar; the Create 
Sketch dialog box will be displayed, as shown in Figure 2-11. Also, you will be prompted to 
select an object for the sketch plane or to select a sketch axis to orient in the prompt area above 
the drawing window. The options in the various rollouts of the Create Sketch dialog box are 
discussed next. 

Type Rollout
The options in this rollout are used to specify whether you want to draw the sketch on 
existing plane or on a temporary plane defined on the path.

On Plane
By default, this option will be selected from the drop-down list. It is used to specify the 
existing plane, face, or datum coordinate system plane as a sketching plane.

On Path
Select this option from the drop-down list to specify the sketch plane on the existing path. 
The temporary sketch plane will be created perpendicular to the path selected.

Depending on the option selected from the drop-down list, the Create Sketch dialog box 
will be modified. The various rollouts in the modified dialog box for both the options are 
discussed next.

On Plane Options
By default, the rollouts related to the On Plane option will be displayed in the Create Sketch 
dialog box, refer to Figure 2-11. The rollouts in this dialog box are discussed next.
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Figure 2-11  The Create Sketch dialog box

Sketch Plane Rollout
The options in this rollout are used to specify the sketch plane by different methods. The 
options in this rollout are as follows:

Plane Method
This drop down list provides various options to select the sketch plane. Some of these 
options are discussed below.

Inferred: By default, this option is selected in the Plane Method drop-down list. It allows 
you to select the existing plane and planar faces.

  
Existing Plane: Select this option to specify the existing plane or face as the sketch 
plane.

Create Plane: Select this option to create a new datum plane and use it as the current 
sketch plane. As you select this option, the Specify Plane area is displayed in the Sketch 
Plane rollout. The options in the Specify Plane area are used to create a datum plane. 
The options to create a datum plane are discussed in later chapter. 

Create Datum CSYS: Select this option to create a new datum coordinate system.

Reverse Direction
The Reverse Direction button in the Sketch Plane rollout is used to reverse the 
direction of the sketching plane.

Sketch Orientation Rollout
The options in this rollout are used to specify the horizontal or vertical reference for the 
sketch. The sketching plane gets orientated according to the specified references. The 
options in this rollout are discussed next.
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Reference
Select the required option (Horizontal or Vertical) from the Reference drop-down list to 
specify the reference for the sketch.

Select Reference
This button is used to specify the horizontal or vertical reference by selecting the existing 
planar face, edge, datum axis, or datum plane. The sketching plane gets oriented according 
to the specified reference. The horizontal and vertical constraints will be added to the 
sketch with respect to the specified reference direction.

Reverse Direction
The Reverse Direction button in the Sketch Orientation rollout is used to reverse 
the direction of reference specified (horizontal or vertical).

Sketch Origin Rollout
The options in this rollout are used to specify the origin point of the sketch. The options 
in this rollout are discussed next.

Specify Point
The options in this area are used to select the origin point of the sketch plane. You can 
select a point on the sketch plane to specify it as the origin of the sketch. You can also use 
the Point Dialog button or the Inferred Point drop-down list available in the Specify 
Point area to create or locate a point. 

Settings Rollout
The options in this rollout are used to specify additional settings while selecting a sketch. 
The options in this rollout are discussed next.

Create Intermediate Datum CSYS
This check box is selected by default. As a result, an intermediate datum coordinate system 
is created and is associated to the sketch plane. Also, when you delete the sketch plane, 
sketch will be not deleted.

Associative Origin 
This check box is used to associate the origin point of the sketch to the sketch plane. 
This check box is available only when the Create Intermediate Datum CSYS check box 
is selected.  

Project Work Part Origin
This check box is used to create the sketch in absolute world coordinate system. 

On Path Options
Select this option from the drop-down list in the Type rollout to create a sketching plane on a 
selected path; the rollouts related to the On Path option will be displayed in the Create Sketch 
dialog box, as shown in Figure 2-12. The options in these rollouts are discussed next.
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Figure 2-12  Rollouts displayed when the 
On Path option is chosen

Path Rollout
The Curve button in this rollout is used to select the path. The path may be a  
curve or the edge of an existing solid body.

Plane Location Rollout
The options in this rollout are used to specify the location of the sketch plane along the 
path in terms of arc length or point. These options are discussed next.

Location
This drop-down list contains different options to specify the location of the sketch plane 
along the path. These options are as follows:

Arc Length
This option allows you to specify the sketch plane distance from the start point of path. 
Enter the distance in the Arc Length edit box.

Note
The nearest endpoint of the selected path will be considered as the start point of the path. 
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% Arc Length
This option allows you to specify the distance of the sketch plane in terms of the percentage 
of arc length from the start point of path. Enter the % value in the % Arc Length edit 
box.
		
Through Point
This option allows you to specify the sketch plane by picking a point on the path. You can 
use Point Dialog button or Inferred Point drop-down list to create or locate a point. 

Plane Orientation Rollout
The options in this rollout are used to specify the direction of the sketch plane with respect 
to the selected path. These options are discussed below:

Orientation
This drop-down list contains different options to specify the direction of the sketch plane. 
These options are discussed next.

Normal to Path: This option allows you to orient the sketch plane normal to the selected 
path.

Normal to Vector: This option allows you to orient the sketch plane normal to the specified 
vector. You can use the Vector Dialog button or the Inferred Vector drop-down list to 
create or specify the vector.

Parallel to Vector: This option allows you to specify the sketch plane parallel to the 
specified vector. You can use the Vector Dialog button or the Inferred Vector drop-down 
list to create or specify the vector.

Through Axis: This option aligns the sketch plane so that it passes though the specified axis. 
Specify the axis using the Vector Dialog button or the Inferred Vector drop-down list.

Reverse Plane Normal
The Reverse Plane Normal button is used to reverse the direction of sketch 
plane.

Sketch Orientation Rollout
The options in this rollout are used to specify the reference for a sketch. The sketching 
plane will be orientated according to the specified reference. The options in this rollout 
are discussed next.

Method
The options in this drop-down list are used to specify references for the orientation of a 
sketch. These options are discussed next.

Automatic
The Automatic option is selected by default in this drop-down list. This option allows 
you to select the horizontal reference by using the Select Horizontal Reference button. 
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Specify the horizontal reference for the sketch; the sketching plane will be oriented based 
on the specified reference.

Note
In the Automatic option, if you select an existing curve as a path, the sketch will be oriented 
using the curve parameters and if you select an existing edge as a path, the sketch will be oriented 
relative to face.

Relative to Face
This option allows you to orient a sketch with respect to a selected face. 

Use Curve Parameters
This option allows you to orient a sketch by using curve parameters.

Reverse Direction 
The Reverse Direction button in this rollout is used to reverse the direction of the 
specified reference.

All the options in the Create Sketch dialog box have already been discussed. Now, for 
illustration purpose, select the On Plane option from the drop-down list. By default, the 
XC-YC plane will be selected. Next, choose the OK button from the Create Sketch dialog box; 
the Sketch task environment will be invoked, refer to Figure 2-13. Now, you can create sketch 
by using the different sketching tools.

Figure 2-13  The default screen display of the Sketch task environment of NX 8.5

Tip: If the toolbar icons appear large, you can reduce their size. To do so, right-click 
on any toolbar to display the shortcut menu and then choose the Customize option at 
the bottom; the Customize dialog box will be displayed. Choose the Options tab and 
then select the Extra Small (16) radio button from the Toolbar Icon Size area.
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Creating Sketches in the Modeling Environment
In this version of NX, you can create a sketch directly in the Modeling environment. To do so, 
choose the Sketch button from the Direct Sketch toolbar that is available at the bottom of the 
drawing window, refer to Figure 2-6; the Create Sketch dialog box will be displayed and you 
are prompted to select a sketching plane. The options in this dialog box are same as discussed 
earlier. Select the required sketching plane from the drawing window and start creating the 
sketch by using the tools that are available in the Direct Sketch toolbar. To finish the sketch, 
you need to choose the Finish Sketch button from the Direct Sketch toolbar.

You can also select the required sketching tool directly from the Direct Sketch toolbar for 
creating the sketch. To do so, select a tool from the Direct Sketch toolbar and then select the 
required plane on which the sketch is to be created or a planar face of the existing 3D model. 
After specifying the required sketching plane, you can start creating the sketch.  

Note
The Direct Sketch toolbar will be available when you are in Modeling environment, NX Sheet 
Metal environment, or Drafting environment.

Sketching Tools
Most of the tools required to draw a sketch are available in the Direct Sketch toolbar located 
at the bottom of the drawing window in the Modeling environment. The same tools are also 
available in the Sketch task environment. These tools are discussed next in the context of the 
Sketch task environment.

By default, some of the tools are not available in the toolbar. However, you can customize the 
toolbars to add these tools. You will learn more about customizing the toolbars later in this 
chapter.

Drawing Sketches Using the Profile Tool
 Menu bar:	 Insert > Curve > Profile	  
 Toolbar:	 Sketch Tools > Profile	

By default, the Profile tool is invoked in the Sketch tools toolbar, when you invoke 
the Sketch task environment. The Profile tool is the most commonly used tool to 
draw sketches in NX. This tool allows you to draw continuous lines and tangent/

normal arcs. When you invoke this tool, the Profile dialog box will be displayed, as shown 
in Figure 2-14. 

Figure 2-14  The Profile 
dialog box
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Also, the dynamic input boxes are displayed below the cursor and you are prompted to select 
the first point of the line or press and drag the left mouse button to begin the arc creation. 
The dynamic input boxes allow you to enter the coordinates or the length and angle of the 
line. The methods of creating lines and arcs using this tool are discussed next.

Note
The Profile tool is also available in the Direct Sketch toolbar. As a result, you can also create 
sketch in the Modeling environment by using the Profile tool. 

Drawing Lines
The option to draw straight lines is active by default when you invoke the Profile tool. 
This is because the Line button is chosen by default in the Profile dialog box. NX 
allows you to draw lines using two methods. These methods are discussed next.

Drawing Lines by Entering Values
In this method of drawing lines, you can enter the coordinate values or the length and 
angle of the line. The values are entered in the dynamic input boxes available below the 
cursor when you invoke the Profile tool. After you have entered the coordinates of the 
start point of the line, a rubber-band line will be displayed between the cursor and the 
specified point. Also, you will be prompted to select the second point of the line. On 
specifying the start point of the line, the dynamic input boxes will change into the length 
and angle modes, as shown in Figure 2-15.

This happens because the Parameter Mode button is automatically chosen in the Profile 
dialog box. As you move the cursor in the drawing window, the length and angle of the 
line is modified, based on the relative position of the cursor with respect to the point 
specified earlier in the dynamic input boxes. You can draw a line by specifying its length 
and angle in these boxes. 

Figure 2-15  Drawing a horizontal line

Note
After specifying the start point of the line, if you choose the Coordinate Mode button from the 
Profile dialog box, the coordinate mode option for specifying the endpoint of the line will be 
restored.

The line drawing process does not end after you specify the second point of the line. 
Instead, another rubber-band line starts with its start point at the endpoint of the last line 
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and the endpoint attached to the cursor. You can repeat the above-mentioned process to 
draw a chain of continuous lines.

After drawing a line, you will notice that it is dimensioned automatically. This happens 
because the Continuous Auto Dimensioning tool is chosen by default in the Sketch Tools 
toolbar. You will learn more about dimensioning and constraints in the later chapters. 

Tip: You can toggle between the two dynamic input boxes by pressing the TAB key. 
Note that once you specify a value in one of the boxes and press the TAB key; the 
second dynamic input box will be activated. Specify the value in the second box 
and then press the ENTER key or the TAB key to register the values and draw the 
line using these values.

Drawing Lines by Picking Points in the Drawing Window
This is the most convenient method of drawing lines and is extensively used in sketching. 
The parametric nature of NX ensures that irrespective of the length of the line that is 
drawn, you can modify it to the required values using dimensions. To draw lines using this 
method, invoke the Profile tool and pick a point in the drawing window; a rubber-band 
line appears. Specify the endpoint of the line by picking a point in the drawing window; 
another rubber-band line will appear with the start point as the endpoint of the last line 
and the endpoint attached to the cursor. You can continue specifying the endpoints of 
the lines to draw a chain of continuous lines. 

While drawing a line, you will notice that some symbols are displayed on the right of the 
cursor. For example, after specifying the start point of the line, if you move the cursor in 
the horizontal direction, an arrow pointing toward the right will be displayed, refer to 
Figure 2-15. This arrow is the symbol of the Horizontal constraint that is applied to the 
line. This constraint will ensure that the line you draw is horizontal. These constraints 
are automatically applied to the sketch while drawing. You will learn more about the 
constraints in the later chapters. 

Note
While drawing lines, you can disable the constraints temporarily by pressing the ALT key.

Drawing Arcs
The option to draw arcs can be activated by choosing the Arc button in the Profile 
dialog box. Alternatively, you can press and hold the left mouse button and drag the 
cursor to invoke the arc mode. Generally, the arcs that are drawn by using this tool 

are in continuation with lines. Therefore, the start point of the arc is taken as the endpoint of 
the last line. As a result, when you invoke the arc mode, you need to specify only the endpoint 
of the arc.

When you draw an arc in continuation with lines, you will notice that a circle with four quadrants 
will be displayed at the start point of the arc, as shown in Figure 2-16. This symbol is called 
the quadrant symbol and it helps you in defining whether you need to draw a tangent arc or 
a normal arc. This symbol also helps you in specifying the direction of the arc. 
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Figure 2-16  Quadrant symbol displayed while drawing an arc 
using the Profile tool

As evident from Figure 2-16, there are four quadrants in the quadrant symbol. The movement 
of the cursor in these quadrants will determine whether the arc will be tangent to the line 
or normal to the line. To draw a tangent arc, move the cursor to the start point of the arc 
and then move it in the quadrants along the line through a small distance; the tangent arc 
appears. Now, move the cursor to size the arc, refer to Figure 2-16.

To draw a normal arc, move the cursor through a small distance in the quadrant normal to 
the line; the normal arc appears. Move the cursor to size the arc, as shown in Figure 2-17. 
As you invoke the arc mode, the current dynamic input boxes change into the Radius and 
Sweep Angle input boxes. These boxes allow you to specify the radius and the sweep angle 
to draw the arc.

Figure 2-17  Drawing the normal arc

Tip: To restart drawing lines using the Profile tool or to break the sequence of 
continuous lines, press the ESC key once. 

Press the ESC key twice to exit the tool. Alternatively, right-click on the drawing 
area and choose the OK option from the shortcut menu.

Note
If you are not drawing the arc in continuation with a line or an arc, this tool will work similar 
to the Arc by 3 Points tool, which is discussed later in this chapter.
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Using Help Lines to Locate Points
You will notice that when a sketching tool is active while drawing sketches, some dotted lines 
are displayed from the keypoints of the existing entities. The keypoints include endpoints, 
midpoints, center points, and so on. These dotted lines are called the help lines. If the help 
lines are not displayed automatically, move the cursor to the keypoints and then move the 
cursor away; the help lines will be displayed. The help lines are used to locate the points with 
reference to the keypoints of the existing entities. Figure 2-18 shows the use of the help lines 
to locate the start point of a new line. You can temporarily disable the help lines by pressing 
the ALT key. 

Figure 2-18  Using the help lines to locate a point

Drawing Individual Lines
 Menu bar:	 Insert > Curve > Line	  
 Toolbar:	 Sketch Tools > Line	

NX also allows you to draw individual lines. This can be done using the Line tool. 
The working of this tool is similar to the working of the line mode of the Profile 
tool. The only difference is that this tool allows you to draw only one line. As a result, 

after you specify the endpoint of the line, no rubber-band line is displayed. Instead, you are 
prompted to specify the first point of the line. You can specify the first point and the second 
point of the lines by picking points on the screen or by entering values in the dynamic input 
boxes. You can use this tool to draw as many individual lines as required.

Note
The Line tool is also available in the Direct Sketch toolbar. As a result, you can also create 
sketch in the Modeling environment by using the Line tool. 

Drawing Arcs
 Menu bar:	 Insert > Curve > Arc    
 Toolbar:	 Sketch Tools > Arc      

NX allows you to draw arcs using two methods. These methods can be activated by 
choosing their respective buttons from the Arc dialog box that will be displayed when 
you invoke the Arc tool. The methods of drawing arcs are discussed next.
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Drawing Arcs Using Three Points
In this method, you can draw an arc by specifying its start point, endpoint, and a point 
on the arc. When you invoke the Arc tool, this method is activated by default and you 
will be prompted to specify the start point of the arc. You can specify the start point 

by clicking in the drawing window or by entering the coordinates in the dynamic input boxes. 
After specifying the start point of the arc, you will be prompted to specify the endpoint. You 
can also specify the radius of the arc by entering its value in the dynamic input box. 

Note that the next prompt will depend on how you specify the endpoint. If you specify the 
endpoint of the arc by clicking a point in the drawing window, you will be prompted to select a 
point on the arc and the Radius dynamic input box will be displayed. However, if you specify 
the radius of the arc in the dynamic input box after specifying the start point, then you will be 
prompted to specify the endpoint of the arc. You can click anywhere in the drawing window 
to draw the arc. Figure 2-19 shows a three-point arc being drawn by specifying two endpoints 
and a point on the arc.

Tip: While drawing an arc by specifying its three points, if the start point is at the 
endpoint of an existing entity, the resultant arc can be drawn tangent to the selected 
entity. To do this, while defining the point on the arc, move the cursor such that the 
resulting arc is tangent to the selected entity.

Figure 2-19  Drawing a three-point arc

Drawing an Arc by Specifying its Center Point and Endpoints
In this method, you can draw an arc by specifying its center point, start point, and 
endpoint. To invoke this method, choose the Arc by Center and Endpoints button 
from the Arc dialog box; you will be prompted to specify the center point of the arc. 

Specify the center point of the arc by clicking in the drawing area or by entering coordinates 
in the dynamic input boxes. On doing so, you will be prompted to specify the start point of 
the arc. After specifying the start point of the arc, you will be prompted to specify the 
endpoint of the arc. Note that when you specify the start point of the arc after specifying the 
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center point, the radius of the arc will automatically be defined. Therefore, the endpoint is 
used only to define the arc length. Figure 2-20 shows an arc being drawn using this method.

Tip: After specifying the center point of the arc, you can also specify its radius and 
the sweep angle in the dynamic input boxes. In this case, you will be prompted to 
specify the start point and then the endpoint of the arc. The endpoint will define 
the direction of the arc.

Figure 2-20  Drawing an arc by specifying its center, start, and end points

Drawing Circles
 Menu bar:	 Insert > Curve > Circle	  
 Toolbar:	 Sketch Tools > Circle	

In NX, you can draw circles using two methods. These methods can be activated by 
choosing their respective buttons from the Circle dialog box that are displayed when 
you invoke the Circle tool. The methods of drawing circles are discussed next.

Drawing a Circle by Specifying the Center Point and Diameter
This is the default and most widely used method of drawing circles. In this method, 
you need to specify the center point of a circle and a point on the circumference of 
the circle. The point on the circumference of the circle defines the radius or the 

diameter of the circle. To draw a circle using this method, choose the Circle by Center and 
Diameter button from the Circle dialog box; you will be prompted to specify the center point 
of the circle. Specify the center point of the circle in the drawing window. Next, you will be 
prompted to specify a point. Specify a point to define the radius. Alternatively, you can enter 
the value of the diameter in the dynamic input box. Figure 2-21 shows a circle being drawn 
by using this method.
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Figure 2-21  A circle drawn using the Circle by Center and Diameter method

Tip: After specifying the center point of the circle, if you specify the value of diameter 
in the dynamic input box, the circle of the specified diameter will be created. Also, 
the preview of the circle of the same diameter will be attached to the cursor. Now, 
you can place multiple copies of the circle by specifying the center point.

Drawing a Circle by Specifying Three Points
In this method, the circle is drawn by specifying three points on circumference. To 
invoke this method, choose the Circle by 3 Points button from the Circle dialog box; 
you will be prompted to specify the first point of the circle. This point is actually the 

first point on the circumference of the circle. After specifying the first point, you will be 
prompted to specify the second point of the circle. On specifying these two points, small 
reference circles will be displayed on these two points, as shown in Figure 2-22. Now, specify 
the third point, which is a point on the circle. You can also enter its diameter value in the 
Diameter input box. This completes the creation of the circle.

Figure 2-22  Circle drawn by using the 
3 Points method

Drawing Rectangles
 Menu bar:	 Insert > Curve > Rectangle	  
 Toolbar:	 Sketch Tools > Rectangle	

In NX, you can draw rectangles using three methods. These methods can be used 
by choosing their respective buttons from the Rectangle dialog box. To invoke this 
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dialog box, choose the Rectangle button from the Direct Sketch toolbar. The three methods of 
drawing rectangles are discussed next.

Drawing Rectangles by Specifying Corners
The By 2 Points method is used to draw a rectangle by specifying the diagonally 
opposite corners of rectangle. When you invoke the Rectangle tool, the By 2 Points 
button will be chosen by default in the Rectangle Method area of the Rectangle dialog 

box. Also, you will be prompted to specify the first point of the rectangle. This point will work 
as one of the corners of the rectangle. After specifying the first point, you will be prompted 
to specify the point to create the rectangle. This point will be diagonally opposite to the point 
that you have specified earlier. You can click anywhere on the screen to specify the second 
corner or enter the width and height of the rectangle in the dynamic input boxes. Figure 2-23 
shows a rectangle being drawn by using the By 2 Points method.

Figure 2-23  Rectangle being drawn by using the By 2 Points method

Tip: If you specify the width and height of a rectangle in the dynamic input boxes 
after specifying the first point, the preview of the rectangle with the specified width 
and height will be attached to the cursor. Now, you need to specify a point to define 
the direction of rectangle.  

Drawing Three Points Rectangles
You can draw a three points rectangle by choosing the By 3 Points button from the 
Rectangle dialog box. In this method, you can draw a rectangle using three points. 
The first two points are used to define the length and angle of one of the sides of the 

rectangle and the third point is used to define the height of the rectangle. When you invoke 
this tool, you will be prompted to specify the first point of the rectangle. Once you specify the 
first point, you will be prompted to specify the second point of the rectangle. Both these 
corners are along the same direction. Therefore, these points define the length and orientation 
of the rectangle. Note that if you specify the second point at a certain angle, the resulting 
rectangle will also be at an angle. After specifying the second point, you will be prompted to 
specify a point to create the rectangle. This point is used to define the height of the rectangle. 
After specifying the first point, you can also specify the height, width, and the angle of the 
rectangle in the dynamic input boxes. Figure 2-24 shows an inclined rectangle drawn by using 
the By 3 Points method.
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Figure 2-24  Inclined rectangle drawn by using the 
By 3 Points method

Tip: After specifying the first point of a rectangle, you can toggle between the By 2 
Points and By 3 Points buttons by dragging the left mouse button. 

Drawing Centerpoint Rectangles
You can draw a centerpoint rectangle by choosing the From Center button in the 
Rectangle dialog box. In this method, you can draw a rectangle using three points. 
However, the first point is taken as the center of the rectangle in this case. When you 

invoke this tool, you will be prompted to specify the center point of the rectangle. Once you 
specify the center point, you will be prompted to specify the second point of the rectangle. 
Both these points are along the same direction. Therefore, these points  define the width of 
the rectangle. Note that if you specify the second point at a certain angle, the resulting rectangle 
will also be at an angle. After specifying the second point, you will be prompted to specify a 
point to create the rectangle. This point is used to define the height of the rectangle. 

Placing Points
 Menu bar:	 Insert > Datum/Point > Point	  
 Toolbar:	 Sketch Tools > Point		

In NX, you can place points by clicking in the drawing window. To place a point, 
choose the Point button from the Sketch Tools toolbar; the Sketch Point dialog box 
will be displayed, refer to Figure 2-25 and you will be prompted to select a point. 

Click in the drawing window; the point will be placed at the specified location. Also, the 
horizontal and vertical dimensions between the point and the origin point of the sketch will 
be displayed. You can edit these dimensions to change the location of the point. 

You can also place a point by using the Point dialog box. To invoke this dialog box, choose the 
Point Dialog button from the Sketch Point dialog box; the Point dialog box will be displayed, 
refer to Figure 2-26 and you will be prompted to select the object to infer point. This dialog 
box contains four main rollouts, Type, Point Location, Output Coordinates, and Offset. The 
options in these rollouts are discussed next.
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Type Rollout
This rollout has a drop-down list from which you can select a method to specify the 
location for the resulting point. Click on the drop-down list; the options for placing a point 
will be displayed. These options are discussed next.

Inferred Point
This option is selected by default. This option allows you to place a point in the 
drawing window. However, if there are some entities in the drawing window, then this 
option helps you to select the keypoints of the entity. For example, if there are a few lines 
in the drawing window, then this option helps you to select the endpoints or the midpoints 
of the lines.

Figure 2-25  The Sketch Point dialog box Figure 2-26  The Point dialog box

Cursor Location
This option allows you to place a point at a location where you will click the cursor in the 
drawing window. If the Cursor Location option is selected, then the other entities in the 
drawing window will not be considered. 

Existing Point
This option allows you to select the points that are already placed in the drawing window. 
As a result, you can place new point on top of the existing point.

End Point
This option allows you to place the point at the endpoint of the existing lines, arcs, or 
splines.
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Control Point
This option allows you to place the point at the control point of the existing sketched 
entities. The control points include the endpoints and midpoints of lines or arcs, center 
points of circles, ellipses, control points of splines, and so on.

Intersection Point
This option allows you to place the point at the intersection point of the two existing 
sketched entities. To do so, select the Intersection Point option from the drop-down 
list in the Type rollout; you will be prompted to select the first and second intersecting 
entities. Specify the two intersecting entities in the drawing area; a point will be placed 
at the intersection point of the two existing entities.

Arc/Ellipse/Sphere Center
This option allows you to place the point at the center of an existing arc, circle, ellipse, 
or sphere.

Angle on Arc/Ellipse
This option allows you to place the point on the circumference of the selected arc, circle, or 
ellipse such that the resulting point is at the specified angle with respect to X-axis. When 
you choose this option, the Point dialog box will be modified and you will be prompted 
to select an arc or ellipse. Select the arc or ellipse in the drawing; the point will be placed 
on the circumference of the selected entity. Next, enter the angle value for the point in 
the Angle edit box of the Angle on Curve rollout.

Quadrant Point
This option allows you to place the point at the quadrant of a circle, arc, or an ellipse. The 
point will be placed at the quadrant that is closest to the current location of the cursor.

Point on Curve/Edge
This option allows you to place the point on the selected curve or edge. The location of 
the point is defined in terms of its curve parameter percentage from the start point of 
the curve. When you select the Point on Curve/Edge option, the Point dialog box will be 
modified and you will be prompted to select the curve to specify the point location. Click 
anywhere on the curve or the edge; you will be prompted to specify the curve parameter 
percentage. Next, enter the distance of the point in the Arc Length edit box of the 
Location on Curve rollout.

Point on Face
This option allows you to place the point on the selected face. The location of the point 
is defined by specifying values in the U Parameter and V Parameter edit boxes. The U 
Parameter edit box is used to specify the horizontal position of the point, where as the V 
Parameter is used to specify the vertical position of the point. The values of these edit boxes 
must be between 0.0 and 1.0. As value of the U Parameter edit box increases, the position of 
the point shifts from right to left; and if the value of the V Parameter edit box increases, 
the position of the point shifts from bottom to top. Note that this option will be available 
only when you invoke the Point dialog box by choosing Insert > Datum/Point > Point 
from the menu bar in the modeling environment.
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Between Two Points
This option allows you to create a point between two existing points or between two 
keypoints of an entity. When you select this option from the Type drop-down list, the 
Point dialog box will be modified and you will be prompted to select object to infer point. 
Select the first point from the drawing window; you will be prompted again to select object 
to infer point. Select the second point; a point will be created between the two selected 
points. You can change the location of this point by entering the percentage value in the 
%Location edit box of the Location Between Points rollout.

By Expression
This option allows you to specify a point expression by using the X, Y, and Z coordinates. 
When you select this option from the Type drop-down list, the Point dialog box will be 
modified with new rollouts such as Choose Expression, Output Coordinates, and Offset. 
The Choose Expression rollout is used to display the point expression created already 
in the part. To create a new expression, choose the Create Expression button; the 
Expressions dialog box will be displayed. Enter the name of the point expression in the 
Name edit box, and then edit the point formula as per your requirement in the Formula 
edit box. Once you have edited the values of the X, Y, and Z coordinates in the Formula 
edit box, the Accept Edit button will be available. Choose the Accept Edit button and 
then choose the OK button from this dialog box; the Point dialog box will be displayed. 
The newly created point expression will be listed in the Expression list area of the Choose 
Expression rollout. Select the point expression from the list and then choose the OK 
button from the Point dialog box; a point will be created with the specified coordinates 
in the expression.  
  

Point Location Rollout
This rollout is used to select a point and will not be available for the Intersection Point, Angle 
on Arc/Ellipse, Point on Curve/Edge, and Point on Face options.

Output Coordinates Rollout
This rollout is used to enter the X, Y, and Z coordinates to specify the location of the point.  
Also, you can specify or determine the 3D location of the points using this rollout. You can 
specify the point relative to the Work Coordinate System (WCS) or Absolute Coordinate System 
by selecting their respective radio buttons.

Offset Rollout
This rollout is used to create a point at a specified distance from a pre-selected point. You can 
select an option to specify the distance of the required point from the Offset Option drop-down 
list in this rollout. The options in this drop-down list are discussed next.

Rectangular
	 This option allows you to create a point by specifying its X, Y, Z coordinates with respect 

to the pre-selected point in the Delta X, Delta Y, and Delta Z edit boxes, respectively.
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Cylindrical
	 This option allows you to create a point according to the cylindrical coordinate system 

with respect to the pre-selected point by specifying the radius, angle, and Z direction in 
the Radius, Angle, and Delta Z edit boxes, respectively.

Spherical
	 This option allows you to create a point according to the spherical coordinate system with 

respect to the pre-selected point by specifying the Radius, Angle 1, and Angle 2 in their 
respective edit boxes.

Along Vector
	 This option allows you to create a point along the specified vector direction at a distance 

specified in the Distance edit box.

Along Curve
	 This option allows you to create a point on the specified curve. The distance of the point 

on arc can be specified by entering the Arc Length or Percentage value in the respective 
edit box.

Drawing Ellipses or Elliptical Arcs
 Menu bar:	 Insert > Curve > Ellipse				        
 Toolbar:	 Sketch Tools > Conic > Ellipse (Customize to add)   

In NX, you can draw ellipses or elliptical arcs by using the Ellipse tool. To invoke 
this tool, choose Insert > Curve > Ellipse option from the menu bar; the Ellipse 
dialog box will be displayed, as shown in Figure 2-27. Also, you will be prompted to 

select a point to specify the center point of the ellipse. Select the Point Dialog button from 
the Center rollout; the Point dialog box will be displayed, refer to Figure 2-26. Using the 
Point dialog box, you can define the center point of ellipse. Alternatively, you can define the 
center point of the ellipse by selecting the required option from the drop-down list available 
on the right of the Point Dialog button. After defining the center point by using the Point 
dialog box, choose the OK button from it; the Ellipse dialog box will be displayed again. Also, 
the preview of the ellipse will be displayed. Next, specify the major and the minor radii of the 
ellipse in the Major Radius and Minor Radius edit boxes in the Ellipse dialog box, respectively. 
If you want to draw an elliptical arc, clear the Closed check box in the Limits rollout; the 
Ellipse dialog box will be modified and the Start Angle and End Angle edit boxes for the arc 
will appear in it. You can specify the start and end angles in their respective edit boxes. 
Figure 2-28 shows the parameters related to an ellipse and Figure 2-29 shows the 
parameters related to an elliptical arc. If you want to retain the complement of the elliptical 
arc, choose the Complement button below the End Angle edit box in the Limits rollout; the 
preview of the complement of the elliptical arc will be displayed. Figure 2-30 shows an elliptical 
arc and Figure 2-31 shows the complement of the elliptical arc. Note that Figure 2-28 shows 
an inclined ellipse. To create an inclined ellipse, you need to enter rotation angle in the 
Angle edit box of the Rotation rollout. The specified angle value will be measured with respect 
to X-axis in the counterclockwise direction.
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Figure 2-27  The Ellipse dialog box

Figure 2-28  Parameters related to an ellipse

Figure 2-29  Parameters related to an elliptical arc

Figure 2-31  Complement of the elliptical arc 
shown in Figure 2-29

Figure 2-30  An elliptical arc

Tip: Sometimes while placing points or drawing an ellipse, some red cross marks are 
displayed on the screen. To remove them, refresh the screen by pressing the F5 key.
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Drawing Conics
 Menu bar:	 Insert > Curve > Conic			    
 Toolbar:	 Sketch Tools > Conic (Customize to add)	

The Conic tool allows you to create a conic section in the Sketch task environment 
using three points. The first two points define the endpoints of the conic and the 
third point defines the apex of the conic. Also, you need to specify the projective 

discriminant value, termed as rho value. To invoke the Conic tool, choose Insert > Curve > 
Conic from the menu bar; the Conic dialog box will be displayed, as shown in Figure 2-32. 
In this dialog box, you can specify the start point and endpoint of the conic using the options 
in the Limits rollout. After specifying the start point and the endpoint of the conic, you need 
to specify the apex of the conic as the third point. Specify the apex of the conic by using the 
options in the Specify Control Point area of the Control Point rollout. Next, enter the Rho 
value in the Value edit box. This Rho value will define the exact shape of conics.

Figure 2-32  The Conic dialog box

If 0 < Rho < 0.5, then conics of elliptical shape will be created.
If Rho = 0.5, then conics of parabolic shape will be created.
If 0.5 < Rho < 1, then conics of hyperbolic shape will be created.

Figure 2-33 shows conics with different Rho values.

Figure 2-33  Conics with different Rho values
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Drawing Studio Splines
 Menu bar:	 Insert > Curve > Studio Spline			    
 Toolbar:	 Sketch Tools > Studio Spline (Customize to add)	

This tool allows you to create studio splines for creating free form features. When 
you invoke this tool, the Studio Spline dialog box will be displayed, as shown in 
Figure 2-34. The various rollouts in this dialog box are discussed next.

Figure 2-34  The Studio Spline dialog box

Type Rollout
This rollout contains different methods and options to create studio splines. They are discussed 
next.

Type drop-down list
There are two methods of drawing studio splines. The options to invoke these methods 
are available in the Type drop-down list. The methods of drawing a studio spline are 
discussed next.

Through Points
This is the default method of drawing splines. In this method, you can specify 
continuous points in the drawing area by clicking the left mouse button. These points 
will act as the defining points of the spline. While drawing a spline, you can move 
these points to change the shape of the spline, and then continue drawing the spline. 
Figure 2-35 shows a spline being drawn by using this method. 

By Poles
If you use this method, the points that you specify in the drawing window act as the 
poles of the spline. Figure 2-36 shows a spline being drawn by using this method. 
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Remember that the display of poles is automatically removed when you finish drawing 
the spline.

Point Location / Pole Location Rollout
The options in this rollout are used to specify the spline point or pole location. You can use 
the Point Constructor button to create or locate a point. 
 

Figure 2-36  Drawing a spline by using the By 
Poles method

Figure 2-35  Drawing a spline by using the 
Through Points method

Parameterization Rollout
The options in this rollout are used to specify the parameters of the spline.

Degree Spinner
The Degree spinner is used to specify the degree of a spline. Figures 2-37 and 2-38 show 
splines of various degrees. Note that the degree of a spline cannot be more than the 
number of poles used to draw it.

Figure 2-38  Spline of degree 4Figure 2-37  Spline of degree 2

Single Segment
This check box is available only with the By Poles method and is used to create a single 
segment spline. However, you can specify as many numbers of poles as you require. If you 
select this check box, the Closed check box will not be activated.

Matched Knot Position
This check box is available only with the Through Points method and is used to create 
a spline by matching the position of the defining points with the knots. In this case, the 
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knots are placed only at the places where the defining points are specified. If you select 
this check box, the Closed check box will not be available.

Closed
This check box is available for both the methods and is used to create closed splines. 
Figure 2-39 shows a closed spline.

Figure 2-39  A closed spline

Filleting Sketched Entities
 Menu bar:	 Insert > Curve > Fillet	  
 Toolbar:	 Sketch Tools > Fillet	

Filleting is defined as the process of rounding the sharp corners of a profile to reduce 
the stress concentration. Fillets are created by removing the sharp corners and 
replacing them by round corners. In NX, you can create a fillet between any two 

sketched entities. You can also create a fillet using three sketched entities.

To create fillets, invoke the Fillet tool; the  Fillet dialog box will be displayed, as shown in 
Figure 2-40. Also, you will be prompted to select or drag the cursor over curves to create a 
fillet.

The Radius dynamic input box will be displayed below the cursor. You do not need to 
necessarily specify the fillet radius in advance. Instead, you can select the two entities to fillet 
and then move the cursor to define the radius of the fillet. Figure 2-41 shows the preview of a 
fillet being created between two lines. In this case, the radius value is not defined in advance. 
As a result, as you move the cursor, the fillet radius is modified dynamically. The Fillet dialog 
box is divided into two areas, Fillet Method and Options.
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Figure 2-41  Preview of a fillet being created 
between two lines

Figure 2-40  The Fillet dialog box

Fillet Method
The first button in this area is the Trim button and is chosen by default. As a result, the 
sharp corner will automatically be trimmed after filleting, as shown in Figure 2-42. If you 
choose the Untrim button, the sharp corner will not be trimmed after filleting, as shown in 
Figure 2-43. 

Figure 2-43  Sharp corner before and after 
filleting using the Untrim button

Figure 2-42  Sharp corner before and after 
filleting using the Trim button

Tip: Ideally, the profiles created with the fillet may not give the desired result when 
used to create features. Therefore, they should be avoided in the sketch. 

Options Area
The Delete Third Curve button in this area is useful if you are creating a fillet by using 
three entities. While using this option, the middle entity should be selected last. This button 
ensures that if the fillet is tangent to the middle entity then the middle entity is automatically 
deleted, as shown in Figure 2-44. If this button is deactivated, the middle entity will not be 
deleted, as shown in Figure 2-45. The Create Alternate Fillet button in this area will show all 
alternative solutions for the fillet. It is recommended that this button should be turned off.
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Figure 2-45  The entity before and after filleting 
with the third curve retained

Figure 2-44  The entity before and after 
filleting with the third curve deleted

Tip: In NX, you can create fillets by simply dragging the cursor across the entities 
that you need to fillet. For example, if you need to fillet two lines, invoke the Fillet 
tool and drag the cursor across them; the corner of these two lines will be filleted. 
The radius of the fillet will depend on how far you dragged the mouse from the 
corner.

When you fillet two entities, if there is more than one solution for fillet, then the 
best solution will be displayed by default. If you want to view the alternate solution, 
press the PAGE UP key.

The Drawing Display Tools
The drawing display tools are an integral part of any solid modeling tool. They enable you to 
zoom, pan, and rotate the drawing so that you can view it clearly. The drawing display tools 
in NX are located in the View toolbar and are discussed next.

Note
As most of the drawing display tools are transparent tools, you can use these tools at any time 
without exiting the other tool you are working with.

Fitting Entities in the Current Display
 Menu bar:	 View > Operation > Fit	  
 Toolbar:	 View > Fit		

The Fit tool enables you to modify the drawing display area such that all entities in 
the drawing fit in the current display. You can also use the CTRL+F keys to fit the 
entities in the current display.

Zooming an Area
 Toolbar:	 View > Zoom	

The Zoom tool allows you to zoom in to a particular area by defining a box around 
it. When you choose this tool, the default cursor is replaced by the magnifying glass 
cursor and you will be prompted to drag the cursor to indicate the zoom rectangle. 

Specify a point on the screen to define the first corner of the zoom area. Next, hold the left 
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mouse button and drag the cursor. Now, release the left mouse button to specify another point 
to define the opposite corner of the zoom area. The area defined inside the rectangle will be 
zoomed and displayed on the screen.

You can also zoom in or out a drawing by specifying a scale value. To do so, choose View 
> Operation > Zoom from the menu bar; the Zoom View dialog box will be displayed, as 
shown in Figure 2-46. Specify a scale value in the Scale edit box. In addition to that, you can 
also use the Half Scale, Double Scale, Reduce 10%, and Increase 10% buttons to zoom in 
or out of the drawing.

Figure 2-46  The Zoom View dialog box

Dynamic Zooming
 Toolbar:	 View > Zoom In/Out    

The Zoom In/Out tool enables you to dynamically zoom in or out of the drawing. 
When you invoke this tool, the default cursor is changed into a magnifying glass cursor 
with a ‘+’ and a ‘-’ sign at the center of the cursor. To zoom in, press and hold the left 

mouse button in the drawing  window and then drag the cursor down. Similarly, to zoom out, 
press and hold the left mouse button and drag the cursor upward.

Panning Drawings
 Toolbar:	 View > Pan    

The Pan tool allows you to dynamically pan drawings in the drawing window. When 
you invoke this tool, the cursor is replaced by a hand cursor and you are prompted to 
drag the cursor to pan the view. Press and hold the left mouse button in the 

drawing window and then drag the mouse to pan the drawing. 

Tip: In NX, you can also display the Selection MiniBar and the View shortcut 
menu by right-clicking in the drawing area. The Selection MiniBar is the compact 
version of the Selection bar. 
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Fitting View to Selection
 Toolbar:	 View > Fit View to Selection    

This tool zooms the display such that the selected entity fits in the current display 
area. This tool is available only when an entity is selected in the drawing window.

Restoring the Original Orientation of the Sketching Plane
 Menu bar:	 View > Orient View to Sketch	  
 Toolbar:	 Sketch > Orient View to Sketch	

Sometimes while using the drawing display tools, you may change the orientation of 
the sketching plane. The Orient View to Sketch tool restores the original orientation 
that was active when you invoked the Sketch task environment. This tool is available only 

in the Sketch task environment.

Setting Selection Filters in the Sketch Task 
Environment
NX provides you with various object selection filters in the Sketch task environment. These 
filters allow you to define the type of entities you want to select. All these filters are available 
in the Selection Bar on the upper left corner of the drawing window. Some of these filters 
are discussed next.

Type Filter
The Type Filter drop-down list is used to specify the type of entity to be selected as filter 
type. By default, the No Selection Filter option is selected, refer to Figure 2-47. This option 
allows you to select any entity from the drawing window. These entities include curves, 
points, dimensions, symbols, sketch constraints, and so on. Select the required entity from 
the Type Filter drop-down list. Now, you can select only the specified entity from the 
drawing window.

Figure 2-47  The Type Filter drop-down list

Selection Scope
This drop-down list allows you to filter the selection from the entire assembly, workpart only, 
or from the active sketch only. Select the required option from the Selection Scope drop-down 
list. 

General Selection Filters
This flyout provides the detailed filter options. The options in the General Selection 
Filters flyout shown in Figure 2-48, are discussed next. 
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Figure 2-48  The General 
Selection Filters flyout

Detailed Filtering
This option is used to filter the selection using layers, types of entity, display attributes, and 
detailed types of entity. Select the Detailed Filtering option in the General Selection Filter 
flyout; the Detailed Filtering dialog box will be displayed. In this dialog box, you can specify 
layers, types of entity, detailed types of entity, and display attributes to be filtered.

Color Filter
This option allows you to filter the selection using a specific color. Only the entities in the 
specified color will be selected.

Layer Filter
This drop-down list allows you to filter the selection using a specific layer. You need to select 
the layer from the Layer Filter drop-down list and the entities in this layer can only be selected. 
By default, the All option is selected, which allows to select the entities from all the layers.

Reset Filters
This tool is used to reset all filtering options defined in the General Selection Filters 
flyout and the Type Filter drop-down list to their default states. 

Allow Selection of Hidden Wireframe
This tool allows you to select the hidden wireframe geometries such as curves and 
edges. 

Deselect All
When you choose this tool, all currently selected entities deselected.

Deselect Last
When you choose this tool, the last selected entity is deselected.

Find in Navigator
This tool is used to highlight the selected entities in the Part or Assembly Navigator and 
will be activated only when you select an entity. Select the entities that you want to 
highlight in the Part or Assembly Navigator and choose the Find in Navigator tool 
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in the Selection Bar. Next, choose the Part Navigator tab from the Resource Bar to view the 
highlighted entities. 

Selecting Objects
After setting the selection filters, you can select objects in the drawing window of NX. When 
there is no tool active, the select mode will be invoked. In this mode, you can select  individual 
sketched entities from the drawing window by clicking on them. To select multiple entities, 
you can use the following two methods: 

Rectangle 
If you choose this tool from the Selection Bar and drag the cursor in the drawing 
window, temporary rectangle will be created according to the movement of the cursor. 
Also, all objects lying completely within the temporary rectangle will get selected.    

Lasso 
If you choose this tool from the Selection Bar and drag the cursor in the drawing 
window, a temporary free form curve will be created according to the movement of 
the cursor. Also, all objects lying completely within the free form curve will get 

selected.     

Deselecting Objects
By default, the selected objects are displayed in orange color. If you want to deselect 
the individual objects from the selection, press and hold the SHIFT key and click on it; the 
entity will be deselected. If you want to deselect all the selected entities, press the ESC key. 
Alternatively, press and hold the SHIFT key and drag a box around the entities; all entities 
that lie completely inside the box will get deselected. Also, you can choose the Deselect All 
tool from the Selection Bar to deselect all the selected entities. 

Using Snap Points Options While Sketching
While drawing a sketch, you will notice that the cursor automatically snaps to some keypoints 
of the sketched entities. For example, if you are specifying the center point of a circle and you 
move the cursor close to the endpoint of an existing line, the cursor snaps to the endpoint of 
the line and changes its shape to the snap cursor. Also, the endpoint snap symbol is displayed 
below the cursor. This suggests that the endpoint of the line has been snapped and if you click 
now, the center point of the circle will coincide with the endpoint of the line.

NX allows you to control these snap settings using the snap points options in the Selection 
Bar, as shown in Figure 2-49. In this bar, some tools are chosen, by default. You can choose 
more tools to turn on the respective snapping option.
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Figure 2-49  Buttons used for snap settings

Deleting Sketched Entities 
 Menu bar:	 Edit > Delete				     
 Toolbar:	 Standard > Delete  (Customize to add)	

You can delete the sketched entities by selecting them and pressing the DELETE key. 
You can also choose the Delete button from the Standard toolbar to delete the sketched 
entities. If you select the entities and then choose the Delete button, the selected 

entities will be deleted. However, if you choose this button without selecting any sketched 
entity, the Delete Sketch Object dialog box will be displayed, as shown in Figure 2-50. You 
can  now select the entities to be deleted and then choose the OK button in this dialog box. 
To close the dialog box, choose the Back or Cancel button.

Figure 2-50  The Delete Sketch Object dialog box

Exiting the sketch Task environment
 Toolbar:	 Sketch> Finish Sketch	

After drawing the sketch, you need to exit sketching the Sketch task 
environment to convert the sketch into a feature. To exit sketching the Sketch 

task environment, choose the Finish Sketch button from the Sketch Tools toolbar. Alternatively, 
right-click in the drawing area and select the Finish Sketch option from the shortcut menu. 
When you exit the Sketch task environment, the Modeling environment is invoked and the 
current view is changed to the Trimetric view.

Tutorials
As mentioned in the introduction, NX is parametric in nature. Therefore, you can draw a sketch 
of any dimensions and then modify its size by changing the values of dimensions. However, 
in this chapter, you will use the dynamic input boxes to draw the sketch of exact dimensions. 
This will help you in improving your sketching skills.



Drawing Sketches for Solid Models				                                                       2-41

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Tutorial 1                                                                    
In this tutorial, you will draw a profile for the base feature of the model shown in Figure 2-51. 
The profile to be drawn is shown in Figure 2-52. 			    (Expected time: 30 min)
	
	 The following steps are required to complete this tutorial:

a.	 Start a new file.
b.	 Select the XC-YC plane as the sketching plane and invoke the Sketch task environment.
c.	 Draw the sketch of the model by using the Profile and Rectangle tools.
d.	 Finish the sketch and save the file.

Figure 2-52  Sketch for Tutorial 1Figure 2-51  Model for Tutorial 1

Starting NX 8.5 and Opening a New File
	 First, you need to start NX 8.5 and then open a new file.

1.	 Choose the Start button at the lower left corner of the screen to display a menu with 
additional options. Next, choose All Programs (or Programs) > Siemens NX 8.5 > 
NX 8.5 to start NX 8.5. Alternatively, double-click on NX 8.5 shortcut icon on the desktop 
of your computer.

2.	 To start a new file, choose the New button from the Standard toolbar or choose 
File > New from the menu bar; the New dialog box is displayed.

3.	 Select the Model template from the Templates rollout.

4.	 Enter c02tut1 as the name of the document in the Name text box of the dialog box.

5.	 Choose the button on the right of the Folder text box; the Choose Directory 
dialog box is displayed.

	 It is recommended that you create a folder with the name NX8.5 in the hard drive of 
your computer and then create separate folders for each chapter inside it for saving the 
tutorial files of this textbook.
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6.	 In this dialog box, browse to NX 8.5/c02 folder and then choose the OK button twice; a 
new file is started in the Modeling environment.

Invoking the Sketch Task Environment in the Modeling Environment
	 The base sketch of this model will be created on the XC-YC plane. Therefore, you need 

invoke the Sketch task environment using this plane.

1.	 Choose the Sketch in Task tool from the Feature toolbar; the Create Sketch 
dialog box is displayed. By default, the XC-YC plane is selected.

2.	 Choose the OK button from the Create Sketch dialog box; the Sketch task environment 
is invoked and the sketching plane is oriented parallel to the screen.

Drawing the Outer Profile of the Sketch
	 The outer profile of the sketch consists of lines and can be drawn by using the Profile 

tool. 

1.	 By default, the Profile tool is invoked and the Profile dialog box is displayed. The Line 
button is active, by default in this dialog box. Also, the dynamic input boxes are displayed 
below the line cursor.

2.	 Move the cursor close to the origin; the coordinates of the point are displayed as 0,0 in 
the dynamic input boxes. Click to specify the start point of the line at this point.

	 As you move the cursor on the screen, the line stretches and its length and angle values 
are modified dynamically in the dynamic input boxes.

3.	 Enter 80 in the Length dynamic input box and press the TAB key. Next, enter 0 in the 
Angle dynamic input box and press the ENTER key.

	 You will notice that a driving dimension is applied to the line which is created by specifying 
the value. You will learn more about dimensions in Chapter 3.

4.	 Choose the Fit button from the View toolbar to fit the sketch into the drawing window.

5.	 Move the cursor away from the end point of the last line and then enter 10 as the length 
and 90 as the angle in the Length and Angle dynamic input boxes, respectively. Press the 
ENTER key.

6.	 Enter 15 as the length and 180 as the angle in the Length and Angle dynamic input 
boxes, respectively. Press the ENTER key.

7.	 Enter 30 as the length and 90 as the angle in the Length and Angle dynamic input boxes, 
respectively. Press the ENTER key.

8.	 Enter 15 as the length and 0 as the angle in the Length and Angle dynamic input boxes, 
respectively. Press the ENTER key.
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9.	 Enter 10 as the length and 90 as the angle in the Length and Angle dynamic input boxes, 
respectively. Press the ENTER key.

10.	 Enter 80 as the length and 180 as the angle in the Length and Angle dynamic input 
boxes, respectively. Press the ENTER key.

11.	 Enter 10 as the length and -90 as the angle in the Length and Angle dynamic input boxes, 
respectively. Press the ENTER key.

12.	 Enter 15 as the length and 0 as the angle in the Length and Angle dynamic input boxes, 
respectively. Press the ENTER key.

13.	 Enter 30 as the length and -90 as the angle in the Length and Angle dynamic input boxes, 
respectively. Press the ENTER key.

14.	 Enter 15 as the length and 180 as the angle in the Length and Angle dynamic input 
boxes, respectively. Press the ENTER key.

15.	 Enter 10 as the length and -90 as the angle in the Length and Angle dynamic input boxes, 
respectively. Press the ENTER key.

16.	 Press the ESC key twice to exit the Profile tool. The outer profile of the sketch is shown 
in Figure 2-53.

Figure 2-53  Outer profile of the sketch

Drawing the Rectangle
	 Next, you need to draw the inner profile, which is a rectangle. You can use the By 2 Points 

option of the Rectangle tool to draw the rectangle.

1.	 Choose the Rectangle button from the Sketch Tools toolbar; the Rectangle 
dialog box is displayed and the By 2 Points button is chosen by default in this 
dialog box.
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2.	 Enter 25 and 15 as the coordinates of the first point of the rectangle in the XC and YC 
dynamic input boxes, respectively. Next, press the ENTER key.

3.	 Enter 30 and 20 as the width and height of the rectangle in the Width and Height dynamic 
input boxes, respectively. Next, press the ENTER key. The preview of the rectangle is 
displayed, but it is not actually drawn yet. As you move the cursor in the drawing window, 
the rectangle also moves.

4.	 Move the cursor close to the top right corner of the drawing window and then click to 
draw the rectangle. 

5.	 Press the ESC key to exit the tool. The final sketch for Tutorial 1 is shown in 
Figure 2-54.

Figure 2-54  Final sketch for Tutorial 1

Finishing the Sketch and Saving the File
	 NX allows you to save the sketch file in the Sketch task environment.

1.	 Choose the Save button from the Standard toolbar to save the sketch.

2.	 Choose the Finish Sketch button from the Sketch toolbar; the 
Modeling environment is invoked.

3.	 Choose File > Close > Selected Parts from the menu bar; the Close Part dialog box is 
displayed.

4.	 Select the name of the current file from the list area in the Part rollout and then choose 
the OK button to close the current file.

Tutorial 2
In this tutorial, you will draw a sketch for the model shown in Figure 2-55. The sketch to be 
drawn is shown in Figure 2-56.					       (Expected time: 30 min)
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Figure 2-56  Sketch for Tutorial 2Figure 2-55  Model for Tutorial 2

	 The following steps are required to complete this tutorial:

a.	 Start NX and then start a new file.
b.	 Invoke the Sketch task environment by using the XC-ZC plane as the sketching plane.
c.	 Draw the outer loop of the profile by using the Profile tool.
d.	 Fillet the sharp corners of the outer loop by using the Fillet tool.
e.	 Draw circles by using the centers of fillets to complete the profile.
f.	 Finish the sketch and save the file.

Starting NX 8.5 and Starting a New File
	 First, you need to start NX 8.5 and then start a new file. 

1.	 Choose the Start button at the lower left corner of the screen to display a menu. Next, 
choose All Programs (or Programs) > Siemens NX 8.5 > NX 8.5 to start NX 8.5. 
Alternatively, double-click on NX 8.5 shortcut icon on the desktop of your computer. 

2.	 To start a new file, choose the New button from the Standard toolbar or choose 
File > New from the menu bar; the New dialog box is displayed.

3.	 Select the Model template from the Templates rollout.

4.	 Enter c02tut2 as the name of the document in the Name text box of the dialog box.

5.	 Choose the button on the right side of the Folder text box; the Choose Directory 
dialog box is displayed.

6.	 In this dialog box, browse to NX 8.5/c02 folder and then choose the OK button twice; the 
new file is started in the Modeling environment.
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Invoking the Sketch task Environment in the Modeling Environment
	 The base sketch of this model will be created on the XC-ZC plane. Therefore, you need 

to invoke the Sketch task environment using this plane.

1.	 Choose the Sketch in Task tool from the Feature toolbar; the Create Sketch 
dialog box is displayed. 

2.	 Select the XC-ZC plane from the drawing window.  

3.	 Choose the OK button from the Create Sketch dialog box; the Sketch task environment 
is invoked and the sketching plane is oriented parallel to the screen.

Drawing Lines of the Outer Loop
	 You will draw the lines of the outer loop by using the line mode of the Profile tool. The 

line will start from the origin, which is the point where the XC-YC, YC-ZC, and ZC-XC 
planes intersect. The coordinates of the origin are 0,0,0. In the current view, the origin 
is the intersection point of the two planes displayed as the horizontal and vertical lines.

	 By default, the Profile tool is invoked and the Profile dialog box is displayed. The Line 
button is chosen by default in the dialog box. Also, the dynamic input boxes are displayed 
below the line cursor.

1.	 Move the cursor close to the origin; the coordinates of the point are displayed as 0,0 in 
the dynamic input boxes. Next, click to specify the start point of the line.

	 The point you specified is selected as the start point of the line and the endpoint is attached 
to the cursor. As you move the cursor on the screen, the line stretches and its length and 
angle values are modified dynamically in the dynamic input boxes. Next, you need to 
specify the endpoint of this line and the points to define the remaining lines. This will be 
done by using the Length and Angle dynamic input boxes.

2.	 Enter 200 in the Length dynamic input box and press the TAB key. Next, enter 0 in the 
Angle dynamic input box and press the ENTER key. 

3.	 Choose the Fit button from the View toolbar to fit the sketch into the drawing window. 
Since the Line tool is still active, therefore you are prompted to specify the second point 
of the line.

4.	 Enter 90 in the Length dynamic input box and press the TAB key. Next, enter 90 in the 
Angle dynamic input box and press the ENTER key; a vertical line of 90 mm is drawn.

5.	 Choose the Fit button again to fit the drawing into the current display.

6.	 Move the cursor away from the end point of the last line and then enter 40 in the Length 
dynamic input box and press the TAB key. Next, enter -180 in the Angle dynamic input 
box and press the ENTER key; a horizontal line of 40 mm is drawn.
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7.	 Move the cursor away from the end point of the last line and then enter 40 in the Length 
dynamic input box and press the TAB key. Next, enter -90 in the Angle dynamic input 
box and press the ENTER key; a vertical line of 40 mm is drawn downward.

8.	 Move the cursor away from the end point of the last line and then enter 120 in the Length 
dynamic input box and press the TAB key. Next, enter 180 in the Angle dynamic input 
box and press the ENTER key; a horizontal line of 120 mm is drawn.

9.	 Move the cursor vertically upward; a rubber-band line is displayed with its starting point 
at the endpoint of the previous line and the endpoint attached to the cursor.

10.	 Move the cursor once toward the vertical line of 40 mm drawn earlier and then move it 
back to the vertical direction from the start point of this line. When the line is vertical, 
the vertical constraint symbol is displayed.

11.	 Move the cursor vertically upward until the horizontal help line is displayed from the top 
endpoint of the vertical line of 40 length. Note that at this point, the value of the length 
in the Length dynamic input box is 40 and the value of the angle is 90. Click to specify 
the endpoint of this line.

12. Move the cursor horizontally toward the left and make sure that the horizontal constraint 
symbol is displayed. Click to specify the endpoint of the line when the vertical help line is 
displayed from the vertical plane. If the help line is not displayed, move the cursor once 
on the vertical plane and then move it back.

13.	 Move the cursor vertically downward to the origin. If the first line is not highlighted 
in yellow, move the cursor over it once and then move it back to the origin; the 
cursor snaps to the endpoint of the first line.

14.	 Click to specify the endpoint of the line when the vertical constraint symbol is displayed. 
Choose the Fit button to fit the sketch into the drawing window.

15.	 Press the ESC key twice to exit the Profile tool. The sketch after drawing the lines is shown 
in Figure 2-57.

Figure 2-57  Sketch after drawing the lines

Filleting Sharp Corners
	 Next, you need to fillet sharp corners so that no sharp edges are in the final model by 

using the Fillet tool.
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1.	 Choose the Fillet button from the Sketch Tools toolbar; the Create Fillet 
dialog box is displayed. 

	 In this tutorial, the lower left and lower right corners are filleted with a radius of 15 mm and 
the remaining corners are filleted with a radius of 10 mm.

2.	 Enter 15 in the Radius dynamic input box and press the ENTER key. 

3.	 Move the cursor over the lower left corner of the sketch; the two lines comprising this 
corner are highlighted in yellow. Click to select this corner; a fillet is created at the lower 
left corner.

4.	 Similarly, move the cursor over the lower right corner and click to select it when the two 
lines that form this corner are highlighted in yellow.

	 Next, you need to modify the fillet radius value and fillet the remaining corners.

5.	 Enter 10 in the Radius dynamic input box and press the ENTER key.

6.	 Select the remaining corners of the sketch one by one and fillet them with a radius of 
10.

 
7.	 Right-click, and then select the OK option from the shortcut menu to exit the Fillet tool. 

The fillets are created, refer to Figure 2-58.

Figure 2-58  Sketch after creating fillets

Drawing Circles
	 Finally, you need to draw circles to complete the sketch. The circles will be drawn by using 

the Circle tool. Use the center points of the fillets as the center points of the circles. 

1.	 Choose the Circle button from the Sketch Tools toolbar; the Circle 
dialog box is displayed. By default, the Circle by Center and Diameter button 
is chosen in this dialog box. Also, you are prompted to select the center of the 
circle.



Drawing Sketches for Solid Models				                                                       2-49

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

2.	 Move the cursor towards the center point of the lower left fillet; the cursor snaps to the 
center point of the arc. Also, the center point snap symbol is displayed above the dynamic 
input boxes.

3.	 Click when the cursor snaps to the center point of the fillet to specify the center point of 
the circle.

4.	 Enter 15 in the Diameter dynamic input box and press the ENTER key; a circle of the 
specified diameter is drawn at the specified center point. Also, another circle of 15 diameter 
is attached to the cursor.

5.	 Move the cursor towards the center point of the lower right fillet; the cursor snaps to the 
center point of the arc and the center point snap symbol is displayed above the dynamic 
input box.

6.	 Click when the cursor snaps to the center point of the arc; the circle is drawn at the 
specified location.

Note
If you select an incorrect point as the center point of the circle by mistake, you can remove the 
unwanted circle by choosing the Undo button from the Standard toolbar.

7.	 Exit the Circle tool by pressing the ESC key twice.

	 This completes the sketch of the model for Tutorial 2. The final sketch for Tutorial 2 is 
shown in Figure 2-59.

Figure 2-59  Final sketch for Tutorial 2

Finishing the Sketch and Saving the File
	 NX allows you to save the sketch file in the Sketch task environment. 

1.	 Choose the Fit button to fit the sketch into the drawing window.

2.	 Choose the Save button from the Standard toolbar to save the sketch.

3.	 Choose the Finish Sketch button from the Sketch toolbar; the Modeling environment is 
invoked. 
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4.	 Choose File > Close > Selected Parts from the menu bar; the Close Part dialog box is 
displayed.

5.	 Select the name of the current file from the list area in the Part rollout and then choose 
the OK button to close the current file.

Note
For better visualization, the background color of graphics in this textbook is set to white. To 
change the background color, choose Preferences > Background from the menu bar; the Edit 
Background dialog box is displayed. Select the Plain radio button from both the Shaded Views 
and Wireframe Views areas. Next, choose the Plain Color swatch; the Color dialog box is 
displayed. In this dialog box, select the white color and choose the OK button twice to exit the 
Edit Background dialog box.

Tutorial 3
In this tutorial, you will draw the profile of the model shown in Figure 2-60. The profile to be 
drawn is shown in Figure 2-61. 		      	                             (Expected time: 30 min)

Figure 2-61  Sketch for Tutorial 3Figure 2-60  Model for Tutorial 3

	 The following steps are required to complete this tutorial:

a.	 Start a new file.
b.	 Select the YC-XC plane as the sketching plane and invoke the Sketch task environment.
c.	 Draw the sketch of the model by using the Profile tool.
d.	 Finish the sketch and save the file.

Starting a New File
	 If you continue working after completing Tutorial 2, you do not need to open a new session 

of NX. You can start a new part file by selecting the Model template from the New dialog 
box.

1.	 To start a new file, choose the New button from the Standard toolbar or choose File > 
New from the menu bar; the New dialog box is displayed.

2.	 Select the Model template from the Templates rollout.
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3.	 Choose the button on the right of the Name text box; the Choose New File Name 
dialog box is displayed.

4.	 In this dialog box, browse to NX 8.5/c02 and then enter c02tut3 in the File name edit box. 
Next, choose the OK button twice; the new file is started in the Modeling environment.

Starting the Sketch in the Modeling Environment
	 The base sketch of this model will be created on the YC-ZC plane. Therefore, you need 

to invoke the Sketch task environment using this plane.

1.	 Choose the Sketch button from the Direct Sketch toolbar; the Create Sketch dialog box is 
displayed. 

2.	 Select the YC-ZC plane from the drawing window. Note that the Z-axis direction of the 
sketching plane points toward the front side of the sketching plane and the direction of 
Y-axis is upward. 

3.	 Choose the OK button from the Create Sketch dialog box to start the sketch.

4.	 Choose View > Orient View to Sketch option from the menubar; the sketching plane is 
oriented parallel to the screen.

Drawing the Sketch
	 The sketch that you need to draw consists of multiple lines and two arcs. All these entities 

can be drawn by using the Line and Arc options of the Profile tool. 

1.	 Choose the Profile tool from the Direct Sketch toolbar; the Profile dialog box is 
displayed. The Line button is activated, by default, in this dialog box. Also, the dynamic 
input boxes are displayed below the line cursor.

2.	 Move the cursor close to the origin; the coordinates of the point are displayed as 0,0 in 
the dynamic input boxes. Click to specify the start point of the line at this point.

	 The point you specified is selected as the start point of the line and the endpoint is attached 
to the cursor. As you move the cursor on the screen, the line stretches and its length and 
angle values are modified dynamically in the dynamic input boxes.

	 Next, you need to specify the endpoint of this line and the points to define the remaining 
lines. This will be done by using the Length and Angle dynamic input boxes. 

3.	 Enter 12 in the Length dynamic input box and press the TAB key. Next, enter 0 in the 
Angle dynamic input box and press the ENTER key. The first line is drawn and the 
rubber-band line is displayed with the start point at the endpoint of the previous line and 
the endpoint attached to the cursor. Now, you need to invoke the arc mode because the 
next entity to be drawn is an arc.
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4.	 Choose the Arc button from the Object Type area of the Profile dialog box to invoke the 
arc mode.

	 A rubber-band arc is displayed with the start point fixed at the endpoint of the last line 
and the endpoint attached to the cursor. Also, the quadrant symbol is displayed at the 
start point of the arc. 

5.	 Move the cursor to the start point of the arc and then move it vertically upward through 
a small distance. Next, move the cursor toward the right; you will notice that a normal 
arc starts from the endpoint of the last line.

6.	 Enter 12 in the Radius dynamic input box and press TAB key. Next, enter 180 in the 
Sweep Angle dynamic input box and press the ENTER key.  

	 The preview of the resulting arc is displayed, but the arc is still not drawn. To draw the arc, 
you need to specify a point on the screen with the values mentioned in the dynamic input 
boxes. 

7.	 Move the cursor horizontally toward the right and click when the preview of the required 
arc is displayed. The arc is drawn and the line mode is invoked again.

8.	 Enter 12 as the length and 0 as the angle in the Length and Angle dynamic input boxes, 
respectively, and then press ENTER key. Choose the Fit button from the View toolbar to 
fit the sketch into the drawing window.

9.	 Enter 30 as the length and 90 as the angle in the Length and Angle dynamic input boxes, 
respectively, and then press ENTER key.

10.	 Move the cursor horizontally toward the left. Make sure that the horizontal constraint 
symbol is displayed. Click to specify the endpoint of the line when the vertical help line 
is displayed from the endpoint of the arc.

	 Next, you need to draw the arc by invoking the arc mode.

11.	 Choose the Arc button from the Profile dialog box to invoke the arc mode; a rubber-band 
arc is displayed with its start point fixed at the endpoint of the last line. 

12.	 Move the cursor to the start point of the arc and then move it vertically downward through 
a small distance. When the normal arc appears, move the cursor toward the left.

13.	 Move the cursor over the lower arc once and then move it toward the left, refer to the 
Figure 2-62.

	 A horizontal help line is displayed originating from the center of the arc being drawn. 
At the point where the cursor is vertically in line with the start point of the lower arc, the 
vertical help line appears from the start point of the lower arc, refer to the Figure 2-62.
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Figure 2-62  Horizontal and vertical help lines 
displayed to define the endpoint of the arc

14.	 Click to define the endpoint of the arc when the horizontal and vertical help lines are 
displayed. The arc is drawn and the line mode is invoked again.

15.	 Enter 12 as the length and 180 as the angle in the Length and Angle dynamic input 
boxes, respectively, and then press ENTER key.

16.	 Move the cursor to the first line and then move it to the start point of this line; the cursor 
snaps to the start point of the line.

17.	 Click to define the endpoint of this line when the cursor snaps to the start point of the 
first line.

18.	 Press the ESC key twice to exit the Profile tool. The final sketch of the model is shown in 
Figure 2-63.

Figure 2-63  Final sketch for Tutorial 3

Finishing the Sketch and Saving the File
	 NX allows you to save the sketch file in the Sketch task environment.

1.	 Choose the Save button from the Standard toolbar to save the sketch.
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2.	 Choose the Finish Sketch button from the Sketch toolbar; the Modeling environment is 
invoked. 

3.	 Choose File > Close > Selected Parts from the menu bar; the Close Part dialog box is 
displayed.

4.	 Select the name of the current file from the list area in the Part rollout and then choose 
the OK button to close the current file.

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Most of the designs created in NX consist of sketch-based features and placed features. 
(T/F)

2.	 When you invoke the Sketch task environment, the Profile tool is invoked by default. 
(T/F)

3.	 You can use the dynamic input boxes to specify the exact values of sketched entities. 
(T/F)

4.	 The Sketch in Task button is chosen to invoke the Sketch task environment. (T/F)

5.	 You can restore the original orientation of the sketching plane by using the __________ 
tool in the Sketch toolbar.

6.	 You can invoke the arc mode within the Profile tool by choosing the __________ button 
from the Profile dialog box.

7.	 You can fillet corners in a sketch by using the __________ tool. 

8.	 You can draw an elliptical arc by using the __________ tool.

9.	 If you choose the __________ button from the Rectangle dialog box, it will enable you to 
draw a centerpoint rectangle.

10.	 You can exit the Sketch task environment by choosing the __________ button from the 
Sketch toolbar.
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 Review Questions 
Answer the following questions:

1.	 Which of the following dialog boxes is displayed when you choose the New button from 
the Standard toolbar to start a new file?

		  (a) New Part File			   (b) New Item
		  (c) File New	 			   (d) Part File

2.	 Which of the following tools in NX is used to create conics?

		  (a) General Conic			   (b) Conic 
		  (c) Round 				    (d) None

3.	 Which mode is automatically invoked from the Profile dialog box when you specify the 
start point of a line?

		  (a) Coordinate Mode			   (b) Angle Mode
		  (c) Parameter Mode			   (d) None

4.	 In NX, how many methods are used to start a new file?

		  (a) 1					     (b) 2 
		  (c) 3 					     (d) 5

5.	 Which of the following options is available in the Studio Spline dialog box along with the 
By Poles option to draw splines?

		  (a) No Poles		  		  (b) From Poles
		  (c) From Points 				   (d) Through Points

6.	 The files in NX are saved with .prt extension. (T/F)

7.	 You can select entities by dragging a box around them. (T/F)

8.	 You can set the selection mode to select only the sketched entities. (T/F)

9.	 In NX, you can create fillets by simply dragging the cursor across the entities that you 
want to fillet. (T/F)

10.	 In NX, you cannot draw a rectangle from its center. (T/F)
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 Exercises 

Exercise 1
Draw a sketch for the base feature of the model shown in Figure 2-64. The sketch to be drawn 
is shown in Figure 2-65. 					      	   (Expected time: 30 min)

Figure 2-65  Sketch for Exercise 1Figure 2-64  Model for Exercise 1

Exercise 2
Draw a sketch for the base feature of the model shown in Figure 2-66. The sketch to be drawn 
is shown in Figure 2-67.               				      (Expected time: 30 min)

Figure 2-67  Sketch for Exercise 2Figure 2-66  Model for Exercise 2

Answers to Self-Evaluation Test
1. T, 2. T, 3. T, 4. T, 5. Orient View to Sketch, 6. Arc, 7. Fillet, 8. Ellipse, 9. From Center, 
10. Finish Sketch


