
Chapter 3
 

Adding Geometric and  
Dimensional 

Constraints to 
Sketches

Learning Objectives
After completing this chapter, you will be able to:
• Understand the concept of under-constrained, fully-constrained, and over-constrained       	
    sketches.
• Understand different types of dimensions.
• Measure the distance value between entities in a sketch.
• Measure the angle between entities.
• Understand different types of geometric constraints.
• Configure settings for applying constraints automatically while sketching.
• Force additional geometric constraints to sketches.
• View and delete geometric constraints from sketches.
• Animate a fully-constrained sketch.
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Constraining Sketches
In the previous chapter, you learned to draw sketches. You must have noticed that the dimensions 
are applied automatically to the sketches when they are drawn but the dimensions are updated 
when you drag the sketched entities. Therefore, these dimensions do not constrain the sketch. 
In this chapter, you will learn to completely constrain the sketches to restrict their degrees of 
freedom to make them stable. The stability ensures that the size, shape, and location of the 
sketches do not change unexpectedly with respect to the surrounding. Therefore, it is always 
recommended to constrain the sketches. The first step is to apply the geometrical constraints 
to the sketch. Some of the constraints are automatically applied to sketches while drawing 
them. After applying the geometrical constraints, you need to add dimensional constraints 
using the tools in the Sketch Tools toolbar.

Concept of Constrained Sketches
After drawing and applying the constraints, the sketch can attain any one of the following 
three stages:

1. Under-Constrain
2. Fully-Constrain
3. Over-Constrain

These stages are described next.

Under-Constrain
An under-constrained sketch is the one in which all degrees of freedom of each entity are 
not completely defined using the geometric and dimensional constraints. The elements 
of the sketch that are displayed in maroon color are under-constrained. You need to 
apply additional constraints to them in order to constraint their degree of freedom. The 
under-constrained sketches tend to change their position, size, or shape unexpectedly. 
Therefore, it is necessary to fully define the sketched elements. Figure 3-1 shows an 
under-constrained sketch.

Fully-Constrain
The fully-constrained sketch is the one in which all degrees of freedom of each element are 
defined using the geometric and dimensional constraints. As a result, the sketch cannot 
change its position, shape, or size unexpectedly. These dimensions can change only if they are 
modified deliberately by the user. The elements of a fully-constrained sketch are displayed in 
dark green color. Figure 3-2 shows a fully-constrained sketch.

Over-Constrain
An over-constrained sketch is the one in which some additional constraints are applied. 
The entities that are affected due to over-constraining are displayed in magenta color. 
The over-constrained dimensions and constraints are displayed in red color. It is always 
recommended to delete additional constraints and make the sketch fully-constrained before 
exiting the Sketch task environment. Figure 3-3 shows an over-constrained sketch.
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Figure 3-2  A fully-constrained sketchFigure 3-1  An under-constrained sketch

Figure 3-3  An over-constrained sketch

While applying the geometric and dimensional constraints, the status area of the Status 
Bar displays the number of constraints needed to fully constrain the sketch. After fully 
constraining the sketch, you will be informed in the status area of the Status Bar that the 
sketch is fully constrained. 

Also, if the sketch is over-constrained, you will be informed that the sketch contains over 
constrained geometry. In this case, you need to remove one or more constraints applied.

Degree of Freedom Arrows
The degree of freedom arrows are displayed on the points that are free to move (under-constrain), 
refer to Figure 3-4. Note that the degree of freedom arrows will be displayed only when you 
choose any constraining tool (geometrical or dimensional). These tools are discussed later 
in this chapter.

Figure 3-4  The degree of freedom arrows displayed on points

The direction of arrow at a particular point indicates that you need to constrain the movement 
along that direction. When you constrain a point, NX will remove the degree of freedom arrows. 
The sketch will be fully-constrained only when all the arrows disappear. The horizontal and 
vertical arrows indicate that the point is free to move in the X and Y directions, respectively.
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Various geometric and dimensional constraint tools used to fully-constrain the sketch are 
discussed next.

Dimensioning sketches
After creating a sketch, you need to apply different types of dimensions (dimensional 
constraints) to it. The purpose of dimensioning is to control the size of the sketch and to 
place it with reference to some other entity. As discussed earlier, by default, sketched entities 
are dimensioned automatically while drawing a sketch. However, the automatically applied 
dimensions do not constrain the sketch. Therefore, you need to lock the automatically applied 
dimensions to fully constrain the sketch. The method of locking the automatically applied 
dimensions is discussed later in this chapter. Also, sometime you may need to add additional 
dimensions to the sketch to fully constrain it.  The Inferred Dimensions tool from the Sketch 
Tools toolbar is used to dimension the entities manually. You can also apply the dimensions 
listed below by using their respective tools. 

1.	 Horizontal Dimensions
2.	 Vertical Dimensions
3.	 Parallel Dimensions
4.	 Perpendicular Dimensions
5.	 Angular Dimensions
6.	 Diameter Dimensions
7.	 Radius Dimensions
8.	 Perimeter Dimensions

   Note
As the Continuous Auto Dimensioning tool is chosen by default in the Sketch  
Tools toolbar, the sketched entities will be dimensioned automatically.

The procedure of locking the automatically applied dimensions is discussed next.
  

Locking the Automatically Applied Dimensions of the 
Sketch
As discussed earlier, when you draw a sketch, some dimensions are automatically applied to it. 
However, these dimensions do not constrain the sketch as they get modified when you drag 
the sketched entities. To lock a dimension of the sketch, you need to double-click on it. On 
doing so, an edit box will be displayed. Enter the required value in the edit box and press 
ENTER; the dimension will be locked and displayed in blue color.

NX is a parametric software and therefore, in this software you can modify the dimension 
created any time by entering the Sketch task environment. The methods of applying various 
dimensions are discussed next.
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Applying Horizontal Dimensions
 Menu bar:	 Insert > Dimensions > Horizontal				     
 Toolbar:	 Sketch Tools > Inferred Dimensions > Horizontal Dimension	

The Horizontal Dimension tool is used to apply a horizontal dimension between 
any two points. Even if you select an entity with a slant angle, the dimension will 
always be applied horizontally between the endpoints of the object selected. To 
apply the horizontal dimension, choose Inferred Dimensions > Horizontal Dimension  

from the Sketch Tools toolbar; the Dimensions dialog box will be displayed and you will be 
prompted to select an object to be dimensioned or select a dimension to be edited. Select the 
object to be dimensioned; the horizontal dimension of the selected object will be attached to 
the cursor. Next, you need to place it at the required location. Place the dimension above or 
below the selected object by pressing the left mouse button inside the drawing window; an 
edit box will be displayed. Enter the required value in this edit box, and then press ESC. 
Figure 3-5 shows the horizontal dimensioning of lines.

Figure 3-5  The horizontal dimension created 
for a horizontal line and an inclined line

Note
If you are creating a sketch in the Modeling environment, you can apply horizontal dimension 
by choosing the Horizontal Dimension tool from the Direct Sketch toolbar. 

Applying Vertical Dimensions
 Menu bar:	 Insert > Dimensions > Vertical					      
 Toolbar:	 Sketch Tools > Inferred Dimensions > Vertical Dimension		

The Vertical Dimension tool is used to apply vertical dimension between any two 
points. Even if you a select linear object with a slant angle, the dimension between 
the endpoints of the selected object will always be applied vertically. To apply the 
vertical dimension to an object, choose Inferred Dimensions > Vertical Dimension 

from the Sketch Tools toolbar; the Dimensions dialog box will be displayed and you will be 
prompted to select an object to be dimensioned or select a dimension to be edited. Select an 
object; the vertical dimension of the selected object will be attached to the cursor. Place the 
dimension to the left or right of the selected object by pressing the left mouse button in the 
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drawing window; an edit box will be displayed. Enter the required value in this edit box, and 
then press ESC. Figure 3-6 shows the vertical dimensioning of lines.

Figure 3-6  The vertical dimension created 
for a vertical line and an inclined line

Note
If you are creating a sketch in the Modeling environment, you can apply vertical dimension by 
choosing the Vertical Dimension tool from the Direct Sketch toolbar. 

In the figures, some of the dimension properties such as decimal places and labels have been 
modified for better display of dimensions. To modify the dimension label, choose Task > Sketch 
Style from the menu bar; the Sketch Style dialog box will be displayed. In this dialog box, select 
the Value option from the Dimension Label drop-down list. Next, choose the OK button; the 
dimensions will be modified. Alternatively, choose Preferences > Sketch from the menu bar; 
the Sketch Preferences dialog box will be displayed. In this dialog box, choose the Sketch Style 
tab; the Sketch Preferences message box will be displayed. Choose OK. Next, in the Dimension 
Label drop-down list of the Sketch Preferences dialog box, select the Value option, and then 
choose the OK button; the dimensions will be modified.

Applying Parallel Dimensions
 Menu bar:	 Insert > Dimensions > Parallel					      
 Toolbar:	 Sketch Tools > Inferred Dimensions > Parallel Dimension		

The Parallel Dimension tool is used to measure the actual distance of a line (straight 
or inclined). You can apply dimension either by selecting a line or by selecting 
points, endpoints, or center points. To apply the parallel dimension, choose Inferred 

Dimensions > Parallel Dimension from the Sketch Tools toolbar; the Dimensions dialog 
box will be displayed and you will be prompted to select an object to be dimensioned or select 
a dimension to be edited. Select the objects between which the dimension has to be applied; 
the dimension will be attached to the cursor. Place the dimension at the desired location by 
clicking the left mouse button; an edit box will be displayed. Enter the required value in this 
edit box, and then press ESC. Figures 3-7 and 3-8 show the parallel dimension applied to the 
sketches.
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Figure 3-8  The parallel dimension applied to 
a sketch

Figure 3-7  The parallel dimension applied to a 
sketch

Note
If you are creating a sketch in the Modeling environment, you can apply parallel dimension by 
choosing the Parallel Dimension tool from the Direct Sketch toolbar. 

Applying Perpendicular Dimensions
 Menu bar:	 Insert > Dimensions > Perpendicular				     
 Toolbar:	 Sketch Tools > Inferred Dimensions > Perpendicular Dimension	

The Perpendicular Dimension tool is used to create the perpendicular 
dimension between a linear object and a point. It is mandatory that any one of the 
objects selected must be a linear object. To create the perpendicular dimension, 
choose Inferred Dimensions > Perpendicular Dimension from the Sketch Tools 

toolbar; the Dimensions dialog box will be displayed and you will be prompted to select an 
object to be dimensioned or select a dimension to be edited. Select the objects between which 
the dimension needs to be applied and then place the dimension. As soon as you place the 
dimension, an edit box will be displayed. Enter the required value in this edit box, and then 
press ESC. Figure 3-9 shows the perpendicular dimension applied to a sketch.

Figure 3-9  The perpendicular dimension 
applied between the objects
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Applying Angular Dimensions
 Menu bar:	 Insert > Dimensions > Angular				     
 Toolbar:	 Sketch Tools > Inferred Dimensions > Angular Dimension	

The Angular Dimension tool is used to apply an angular dimension. Whenever an 
angular dimension is applied using the Angular tool, the angle is always measured 
in the counterclockwise direction. To create an angular dimension, choose Inferred 
Dimensions > Angular Dimension from the Sketch Tools toolbar; the 

Dimensions dialog box will be displayed and you will be prompted to select an object to be 
dimensioned or select a dimension to be edited. Select the objects between which the angular 
dimension needs to be applied and then place the dimension. Figure 3-10 shows different 
types of angular dimensions applied to a sketch.

Figure 3-10  Angular dimensions applied between the objects

Applying Diameter Dimensions
 Menu bar:	 Insert > Dimensions > Diameter					     
 Toolbar:	 Sketch Tools > Inferred Dimensions > Diameter Dimension	

The Diameter Dimension tool is used to apply diameter dimension to an arc or a 
circle. Generally, diameter dimensions are applied to circles. To apply diameter 
dimension, choose Inferred Dimensions > Diameter Dimension from the Sketch 
Tools toolbar; the Dimensions dialog box will be displayed and you will be prompted 

to select an arc to be dimensioned or a dimension to be edited. Select the object to be 
dimensioned and then place the dimension. As soon as you place the dimension, an edit box 
will be displayed. Enter the required value in this edit box, and then press ESC. Figure 3-11 
shows the diameter dimension applied to a circle and Figure 3-12 shows the diameter dimension 
applied to an arc.
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Figure 3-12  The diameter dimension applied 
to an arc

Figure 3-11  The diameter dimension applied 
to a circle

Applying Radius Dimensions
 Menu bar:	 Insert > Dimensions > Radius				     
 Toolbar:	 Sketch Tools > Inferred Dimensions > Radius Dimension	

The Radius Dimension tool is used to apply the radius dimension to an arc or a 
circle. Generally, radius dimensions are applied to arcs. To apply radius dimension, 
choose Inferred Dimensions > Radius Dimension from the Sketch Tools toolbar; 
the Dimensions dialog box will be displayed and you will be prompted to select an 

arc to be dimensioned or a dimension to be edited. Select the object to be dimensioned and 
then place the dimension. As soon as you place the dimension, an edit box will be displayed. 
Enter the required value in this edit box, and then press ESC. Figure 3-13 shows the radius 
dimension applied to a circle and Figure 3-14 shows the radius dimension applied to an 
arc.

Figure 3-14  The radius dimension applied to an 
arc

Figure 3-13  The radius dimension applied to 
a circle
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Applying Perimeter Dimensions
 Menu bar:	 Insert > Dimensions > Perimeter					     
 Toolbar:	 Sketch Tools > Inferred Dimensions > Perimeter Dimension	

The Perimeter Dimension tool is used to apply the circumferential or perimeter 
dimension. After applying the perimeter dimension, all dimensions of the 
selected objects are locked. To apply the perimeter dimension, choose Inferred 
Dimensions > Perimeter Dimension from the Sketch Tools toolbar; the Perimeter 

Dimensions dialog box will be displayed and you will be prompted to select lines or arcs to 
apply the perimeter dimension. Select the object and then choose the OK button from this 
dialog box; the perimeter dimension will be applied to the selected object. Note that this 
dimension will not be displayed in the drawing window. 

You can also apply the perimeter dimension to a closed sketch. To do so, invoke the Perimeter 
Dimensions dialog box and then select all entities of the closed sketch one by one. Next, choose 
the OK button from the Perimeter Dimensions dialog box; the dimension will be applied to 
the sketch. Now, if you modify the dimension of any one of the entities, the dimension of other 
entities will also be modified such that the total perimeter of the sketch remains the same. 

Applying Dimensions by Using the Inferred Dimensions 
Tool
 Menu bar:	 Insert > Dimensions > Inferred Dimensions			    
 Toolbar:	 Sketch Tools > Inferred Dimensions > Inferred Dimensions	

The Inferred Dimensions tool is used to apply all the dimension types discussed 
above. A dimension is applied based on the object selected and the location of the 
cursor. For example, if you select an arc, the radial dimension will be applied. 
Similarly, if you select a circle, the diameter dimension will be applied. Select an 

inclined line and move the cursor parallel to that line; a parallel dimension will be applied. 
If you move the cursor vertically upward or downward, a horizontal dimension will be 
applied. Similarly, if you move the cursor in the horizontal direction (right or left), a vertical 
dimension will be applied.

It is recommended that you use this tool to apply dimensions as it saves the time required 
for selecting various dimensioning tools. To apply inferred dimensions, choose the Inferred 
Dimensions button from the Sketch Tools toolbar; the Dimensions dialog box will be displayed 
and you will be prompted to select the object to be dimensioned or a dimension to be edited. 
According to the selection procedure adopted while selecting objects, the dimensions will be 
applied. Figure 3-15 shows the radial and linear dimensions created.
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Figure 3-15  The radial and linear dimensions created by using the Inferred Dimensions tool

Editing the Dimension Value and Other Parameters
To edit a dimension that has already been placed, double-click on it; an edit box will 
be displayed. Enter a value in this edit box and then press ESC.

You can also edit a dimension that has already been placed by using the Dimensions dialog 
box. To do so, invoke the Dimensions dialog box by choosing the Inferred Dimensions button 
from the Sketch Tools toolbar. Next, choose the Sketch Dimensions Dialog button from the 
Dimensions dialog box; the Dimensions dialog box will be modified, as shown in Figure 3-16. 
From the list box of this dialog box, select the dimension that you want to modify; the Current 
Expression area will be enabled. Note that the edit box on the right of this area displays the 
dimension value of the selected dimension. You can enter a new dimension value in the edit 
box and press the ESC key.

Figure 3-16  The modified 
Dimensions dialog box
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You can also modify the value of the dimension dynamically by using the Value sliding bar in 
the Current Expression area. The first drop-down list below the Value sliding bar provides 
the options for placing the arrows with respect to the dimension line. The second drop-down 
list provides the options for placing the leader on the left or the right. The Fixed Text Height 
check box allows you to maintain the dimension text at a constant size when you zoom in or 
out a sketch. If you clear this check box, NX scales the dimension text as well as the sketch 
geometry. The Create Reference Dimension check box is used to create the reference 
(non-driving) dimensions. The Create Alternate Angle check box is used to calculate the 
maximum dimension between the sketch curves. Next, choose the Close button to reflect the 
changes. You can choose the Remove Highlighted button to delete the dimension selected from 
the list box. You can also apply a dimension by choosing the dimension buttons available 
above the list box in the Dimensions dialog box.

Animating a Fully-Constrained Sketch
 Menu bar:	 Tools > Constraints > Animate Dimension		   
 Toolbar:	 Sketch Tools > Animate Dimension (Customize to Add)	

The Animate Dimension tool is used to animate a sketch by selecting any one of 
the dimensions as the driving dimension from the same sketch. Generally, this type 
of animation is used while creating basic mechanisms and links. When a dimension 
from a fully constrained sketch is animated, the whole sketch gets mechanized by 

the possible movements. The dimension selected from the sketch for animating is known as 
the driving dimension. To animate a fully constrained sketch, choose the Animate Dimension 
button from the Sketch Tools toolbar; the Animate dialog box will be displayed, as shown in 
Figure 3-17, and you will be prompted to select a dimension to animate. The dimensions that 
are applied to the sketch are listed in the list box of the same dialog box. You can select the 
driving dimension directly from the sketch or from the list box. After selecting the driving 
dimension, enter the lower limit value for the dimension inside the Lower Limit edit box. 
Similarly, enter the upper limit value for the dimension inside the Upper Limit edit box. The 
selected dimension will be animated between the lower and upper limits specified. You can 
also divide an animation cycle into a number of steps and then animate the design. The 
number of steps per cycle should be entered inside the Steps/Cycle edit box. To display the 
dimension applied during the animation, select the Display Dimensions check box. For 
example, a fully constrained sketch from which the driving dimension is selected is shown in 
Figure 3-18. Figure 3-19 shows the sketch while animating. Note that at an instance, only one 
dimension can be selected as the driving dimension. If the sketch is not fully constrained, an 
undesired animation may occur.
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Figure 3-17  The Animate dialog box 

Figure 3-19  The sketch being animatedFigure 3-18  Driving dimension selected from the 
sketch

Measuring the Distance Value between objects 
in a sketch
 Menu bar:	 Analysis > Measure Distance	  
 Toolbar:	 Utility > Measure Distance	

While sketching, you may need to measure the dimension of various sketched entities. 
To do so, choose the Measure Distance button from the Utility toolbar; the 
Measure Distance dialog box will be displayed, as shown in Figure 3-20. Using this 

dialog box, you can measure the distance value between sketched entities through a number 
of methods. The methods for measuring the dimension of various sketched entities are 
discussed next.

You can also modify the value of the dimension dynamically by using the Value sliding bar in 
the Current Expression area. The first drop-down list below the Value sliding bar provides 
the options for placing the arrows with respect to the dimension line. The second drop-down 
list provides the options for placing the leader on the left or the right. The Fixed Text Height 
check box allows you to maintain the dimension text at a constant size when you zoom in or 
out a sketch. If you clear this check box, NX scales the dimension text as well as the sketch 
geometry. The Create Reference Dimension check box is used to create the reference 
(non-driving) dimensions. The Create Alternate Angle check box is used to calculate the 
maximum dimension between the sketch curves. Next, choose the Close button to reflect the 
changes. You can choose the Remove Highlighted button to delete the dimension selected from 
the list box. You can also apply a dimension by choosing the dimension buttons available 
above the list box in the Dimensions dialog box.

Animating a Fully-Constrained Sketch
 Menu bar:	 Tools > Constraints > Animate Dimension		   
 Toolbar:	 Sketch Tools > Animate Dimension (Customize to Add)	

The Animate Dimension tool is used to animate a sketch by selecting any one of 
the dimensions as the driving dimension from the same sketch. Generally, this type 
of animation is used while creating basic mechanisms and links. When a dimension 
from a fully constrained sketch is animated, the whole sketch gets mechanized by 

the possible movements. The dimension selected from the sketch for animating is known as 
the driving dimension. To animate a fully constrained sketch, choose the Animate Dimension 
button from the Sketch Tools toolbar; the Animate dialog box will be displayed, as shown in 
Figure 3-17, and you will be prompted to select a dimension to animate. The dimensions that 
are applied to the sketch are listed in the list box of the same dialog box. You can select the 
driving dimension directly from the sketch or from the list box. After selecting the driving 
dimension, enter the lower limit value for the dimension inside the Lower Limit edit box. 
Similarly, enter the upper limit value for the dimension inside the Upper Limit edit box. The 
selected dimension will be animated between the lower and upper limits specified. You can 
also divide an animation cycle into a number of steps and then animate the design. The 
number of steps per cycle should be entered inside the Steps/Cycle edit box. To display the 
dimension applied during the animation, select the Display Dimensions check box. For 
example, a fully constrained sketch from which the driving dimension is selected is shown in 
Figure 3-18. Figure 3-19 shows the sketch while animating. Note that at an instance, only one 
dimension can be selected as the driving dimension. If the sketch is not fully constrained, an 
undesired animation may occur.
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Figure 3-20  The Measure Distance dialog box

Measuring the Distance between Two Objects in a Sketch
By default, the Distance option is selected in the Type drop-down list of the Measure 
Distance dialog box. Therefore, you are prompted to select the objects to measure the length 
or distance between them. Using this option, you can measure the distance between any two 
linear and inclined entities of a sketch. Select the start point; a ruler will be displayed, as 
shown in Figure 3-21. This ruler stretches along with the cursor. Now, move the cursor and 
specify the endpoint; the distance measured will be displayed in the display box, as shown 
in Figure 3-22.

Figure 3-22  The distance value displayed in the 
display box

Figure 3-21  The ruler displayed after selecting 
the start point

Note
You can also measure the distance between two objects by using the Simple Distance 
tool. To do so, choose the Simple Distance tool from the Simple Measure drop-down 
in the Utility toolbar. The procedure to measure the distance is same as discussed 
previously.
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Measuring the Projected Distance between Two Objects
To measure the distance between two objects along a predefined projected direction, select the 
Projected Distance option from the Type drop-down list in the Measure Distance dialog box; 
the dialog box will be modified and you will be prompted to select the objects to infer vector. 
Select the object or use the Inferred Vector drop-down list to specify the direction of projection. 
You can also specify the direction of projection by using the Vector Dialog button. Once you 
have specified the direction of projection, you will be prompted to select the start point or the 
first object to measure the distance. Select the start point; a ruler will be displayed, as shown 
in Figure 3-23, and you will be prompted to select the second point or the second object to 
measure the distance. Select the second point to measure the distance; the measured distance 
value will be displayed in the display box. Figure 3-24 shows the distance value displayed in 
the display box.

Figure 3-24  The distance value displayed in the 
display box

Figure 3-23  The ruler locked to the specified 
projection direction

Measuring the Screen Distance between Two Objects  
The screen distance is the distance between any two objects in a particular orientation on the 
screen. To measure the screen distance between two objects, select the Screen Distance option 
from the Type drop-down list in the Measure Distance dialog box; you will be prompted to 
select the start point or the first object to measure the distance. Select the first object; a ruler 
will be displayed, as shown in Figure 3-25, and you will be prompted to select the second point 
or the second object to measure the distance. Select the second object; the distance value 
between the two objects selected for the particular view or orientation will be displayed in the 
display box, as shown in Figure 3-26. Note that if you measure the distance between two same 
objects by changing the orientation, the distance value will also be changed.

Figure 3-26  The distance value displayed on 
the display box

Figure 3-25  The ruler displayed after selecting the 
first object



3-16								               NX 8.5 for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Measuring the Length of an Arc or a Line
To measure the length of an arc or a line, select the Length option from the Type drop-down 
list in the Measure Distance dialog box; you will be prompted to select the curve or the edge. 
Select an object (an arc or a line); the length of the selected object will be displayed instantly 
in the display box, as shown in Figures 3-27 and 3-28. Note that if you continue selecting the 
entities, the total arc length displayed will be the sum of the arc lengths of all the selected 
entities.

Figure 3-28  The arc length measurement 
displayed for an arc

Figure 3-27  The length measurement displayed 
for a line

Note
You can also measure the length of an arc or a line by using the Simple Length 
tool that is available in the Simple Measure drop-down of the Utility toolbar. The 
procedure to measure the length is same as discussed above.

Measuring the Angle Between Entities
 Menu bar:	 Analysis > Measure Angle	

After creating a sketch, sometimes you may need to measure the angle between entities. 
To do so, choose  Analysis >Measure Angle from the menu bar; the Measure Angle 
dialog box will be displayed, as shown in Figure 3-29. Using this dialog box, you can 

measure the angle values between the sketched entities. There are three methods to measure 
the angle, and they are discussed next.

Measuring the Angle Value Using the By Objects Option
The By Objects option is used to measure the angle value subtended between any two 
selected objects. By default, this option is selected in the Type drop-down list of the Measure 
Angle dialog box and you are prompted to select the first object for the angle measurement. Select 
the first object; an arrow will appear on the selected object, as shown in Figure 3-30, and you 
will be prompted to select the second object for the angle measurement. Select the second 
object; the selected object will be highlighted and an arrow will be displayed on it. Note that 
the angle value is always subtended between the directions of arrows displayed on the two 
objects selected. After you select the second object, the angular ruler will be displayed along 
with the angle value in the display box, refer to Figure 3-30.
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Figure 3-29  The Measure Angle dialog box

Note
You can also measure the angle between two objects by using the Simple Angle tool 
that is available in the Simple Angle tool from the Simple Measure drop-down in 
the Utility toolbar. The procedure to measure the angle is same as discussed above.

Figure 3-30  The angular measurement displayed 
using the By Objects option

Measuring the Angle Value Using the By 3 Points Option
The By 3 Points  option  is  used to measure the angle value subtended between three selected 
points. To measure the angle value by using this option, select the By 3 Points option from 
the Type drop-down list in the Measure Angle dialog box; you will be prompted to select the 
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start point for the angle measurement. Select the start point; you will be prompted to select 
the second point for the angle base line. Select the second point; you will be prompted again 
to select the third point to measure the angle. On selecting the third point, the angle value 
along with the angular ruler will be displayed in the display box, refer to Figure 3-31.

Measuring the Angle Value Using the By Screen Points 
Option
The By Screen Points option is used to measure the angle value between the three selected 
points for a particular orientation on the screen. The angle displayed between the selected 
objects is always subtended with respect to the view point (the point from which you are viewing 
the objects). To measure the angle value using this method, select the By Screen Points option 
from the Type drop-down list. You will be prompted to select the start point for the angle 
measurement. Select the start point; you will be prompted to select the second point for the 
angle base line. Select the second point; you will be prompted to select the third point to 
measure the angle. Select the third point; the angle value enclosed between the three points 
will be displayed in a display box along with the angular ruler. Figure 3-32 shows a sketch 
that was used to measure the angle using this method. However, in this figure, the view of the 
sketch is modified. As a result, the angle measurement has been modified on the basis of the 
current orientation of the view.

Figure 3-31  The angle measured using the By 
3 Points option

Figure 3-32  The angular measurement displayed 
using the By Screen Points option

Geometric Constraints
Geometric constraints are the logical operations that are performed on the sketched 
entities to relate them to the other sketched entities using the standard properties such 
as collinearity, concentricity, tangency, and so on. These constraints reduce the degrees of 
freedom of the sketched entities and make the sketch more stable so that it does not change 
its shape and location unpredictably at any stage of the design. All geometric constraints have 
separate symbols associated with them. These symbols can be seen on the sketched entities 
when the constraints are applied to them. In the Sketch task environment of NX, you can add 
eleven types of geometric constraints. Some of these constraints are added automatically while 
sketching. Additionally, you can add more constraints to the sketch manually. These are 
explained next. 
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Applying Additional Constraints Individually	           
 Menu bar:	 Insert > Geometric Constraints		   
 Toolbar:	 Sketch Tools > Geometric Constraints	

In NX, you can apply additional constraints manually by using the Geometric 
Constraints tool in the Sketch Tools toolbar. To apply constraints, invoke the 
Geometric Constraints tool; the Geometric Constraints dialog box will be 
displayed, as shown in Figure 3-33. Select the required  constraint from the 

Constraint rollout of the dialog box and then select the entities from the drawing area to 
apply the selected constraint.

Note
By default, only few constraints are available in the Constraint rollout of the Geometric 
Constraints dialog box. You can customize to add or remove the constraints from the Constraint 
rollout. To do so, click on the down arrows located at the bottom of the dialog box; the Settings 
rollout will be displayed. Select the check boxes next to the required constraints; the constraints 
will be displayed in the Constraints rollout.

In NX, you can also apply constraints directly without invoking the Geometric Constraints 
dialog box. To do so, select the entities from the drawing area; a contextual toolbar will be 
displayed with all possible constraints that can be applied to the selected entities. Select the 
required constraint from the contextual toolbar; the selected constraint will be applied to the 
selected entities. 

Various constraints that can be applied to the sketched entities in NX are discussed next.

Figure 3-33  The Geometric Constraints dialog box

Fixed Constraint
The Fixed constraint is used to fix some of the characteristics of the geometry. To 
apply this constraint, choose the Fixed button from the Constraint rollout of the 
Geometric Constraints dialog box. Next, select the entity to be fixed from the drawing 

area; the selected entity will be fixed. Alternatively, you can apply the fixed constraint using 
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the contextual toolbar. To do so, select an entity from the drawing area; the contextual toolbar 
will be displayed with the possible constraints that can be applied to the selected entity. Next, 
choose the Fixed option from the contextual toolbar, refer to Figure 3-34; the selected entity 
will be fixed.

Figure 3-34  Applying the Fixed constraint to an entity

The characteristics of the geometry after applying the Fixed constraint depend on the type 
of geometry selected. Following are some of the examples of Fixed constraint:

1.	 If you apply this constraint to a point, the point will be fixed and cannot be moved.

2.	 If you apply this constraint to a line, its angle will be fixed; however, you can move and 
stretch the line.

3.	 If you apply this constraint to the circumference of a circular arc or an elliptical arc, the 
radius of the arc and the location of the center point will be fixed. However, you can 
change the arc-length.

Fully Fixed Constraint
This constraint is same as the Fixed constraint with the only difference being that this 
constraint fixes all characteristics of a geometry. For example, if you apply this 
constraint to a line, the line will be fully-constrained and it cannot be moved or 

stretched. To apply this constraint, choose the Fully Fixed button from the Constraint rollout and  
then select the entity; the selected entity will be fully fixed.

Horizontal Constraint
The Horizontal constraint forces the selected line segment to become horizontal, 
irrespective of its original orientation. To apply this constraint, choose the Horizontal 
button from the Geometric Constraints dialog box and then select the entity; the 

selected line segment will be forced to become horizontal.

Vertical Constraint
The Vertical constraint is similar to the Horizontal constraint with the only difference 
that this constraint will force the selected line to become vertical.



Adding Geometric and Dimensional Constraints to Sketches			          3-21

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Coincident Constraint
The Coincident constraint forces two or more keypoints to share the same location. 
The keypoints that can be used to apply this constraint include the endpoints, center 
points, control points of splines, and so on. To apply this constraint, invoke the 

Geometric Constraints tool and then choose the Coincident button from the Constraint 
rollout. Next, select the keypoints of the sketched entities that are to be made coincident. 
Figure 3-35 shows the endpoints of the two lines selected to be made coincident and Figure 3-36 
shows the lines after applying constraint.

Figure 3-36  The sketch after applying the 
Coincident constraint

Figure 3-35  The endpoints of the first
and second entities selected

Point On Curve Constraint
The Point On Curve constraint is used to place a selected keypoint on a selected curve 
or line. As a result, the selected point always lies on the selected curve. To apply this 
constraint, invoke the Geometric Constraints tool and then choose the Point On 

Curve button from the Constraint rollout; you will be prompted to select the entities to be 
constrained. First, select a point such as the endpoint or the center point. Next, select a curve; 
the point will be placed on the curve. Figure 3-37 shows a sketch before applying this constraint 
and Figure 3-38 shows a sketch after applying this constraint.

Figure 3-38  The resulting sketch after applying 
the Point On Curve constraint

Figure 3-37  The reference elements selected from 
the entity to apply the Point On Curve constraint
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Midpoint Constraint
NX provides you with an extension of the Point on Curve constraint, which is the 
Midpoint constraint. This constraint forces the selected point to be placed in line with 
the midpoint of the selected curve. Note that this constraint is available only when 

the selected curve is an open entity such as a line segment or an arc. Also, it is important to 
note that you need to select the curve anywhere other than at its endpoints.

Parallel Constraint
 The Parallel constraint forces a set of selected line segments or ellipse axes to become 

parallel to each other. To apply this constraint, invoke the Geometric Constraints 
tool and then choose the Parallel button from the Constraint rollout; you will be 

prompted to select the objects to constrain. Select the set of line segments or ellipses; the 
selected line segments or axes of the ellipse will become parallel to each other. Figure 3-39 
shows two line segments before and after applying this constraint.

Figure 3-39  Applying the Parallel constraint

 

Perpendicular Constraint
The Perpendicular constraint forces a set of selected line segments or ellipse axes to 
become normal to each other. Figure 3-40 shows two line segments before and after 
applying this constraint.

Figure 3-40  Sketch before and after applying the Perpendicular constraint
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Tangent Constraint
The Tangent constraint forces the selected line segment or curve to become tangent 
to another curve. To apply this constraint, invoke the Geometric Constraints tool and 
then choose the Tangent button from the Constraint rollout; you will be prompted 

to select the entities to be constrained. Select a line and a curve or select two curves; the 
selected line or curve will become tangent to the other selected curve. Figures 3-41 and 3-42 
show the use of the Tangent constraint.

Figure 3-41  Sketch before and after applying 
the Tangent constraint

Figure 3-42  Sketch before and after applying 
the Tangent constraint

Note
By default, symbols of all constraints are not displayed in the sketch. You can turn on the 
display of constraints using the Display Sketch Constraints tool, which is discussed later in 
this chapter.
 

Equal Length Constraint
The Equal Length constraint forces the length of the selected line segments to become 
equal. To apply this constraint, invoke the Geometric Constraints tool and then choose 
the Equal Length button from the Constraint rollout. Next, select the line segments 

that you want to make equal in length; the selected line segments will become equal in 
length.

Equal Radius Constraint
The Equal Radius constraint forces the selected arcs or circles to become equal in 
radius. To apply this constraint, invoke the Geometric Constraints tool and then 
choose the Equal Radius button from the Constraint rollout. Next, select the arcs or 

circles that you want to make equal in radii; the selected arcs or circles will become equal in 
radii.

Concentric Constraint
This constraint is used to force two curves to share the same location of the  center 
points. The curves that can be made concentric include arcs, circles, and ellipses. The 
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ellipses can be made concentric with a circle or an arc also. Figure 3-43 shows two circles before 
and after adding this constraint.

Figure 3-43  Sketch before and after applying the Concentric constraint

Collinear Constraint
This constraint forces the selected line segments to be placed along the same line.

Constant Length Constraint
The Constant Length constraint makes the length of the selected line segments 
constant. As a result, you will not be able to modify the length of the line by using the 
dimension constraints or by dragging. 

Constant Angle Constraint
The Constant Angle constraint makes the angle between the selected line segments 
constant. As a result, you will not be able to modify the angle between the lines by 
using the dimension constraints or by dragging. 

Slope of Curve Constraint
The Slope of Curve constraint will force the slope of the spline at the selected control 
point to become equal to the slope of the selected line, arc, or spline segment.

Uniform Scale Constraint
The Uniform Scale constraint ensures that if you modify the distance between the 
endpoints of a spline, the entire spline will be scaled uniformly.

Non-Uniform Scale Constraint
The Non-Uniform Scale constraint ensures that if you modify the distance between 
the endpoints of a spline, it will be scaled non-uniformly and it appears to stretch. 

Point On String
The Point On String constraint is used to place a selected keypoint on a projected 
curve or line. As a result, the selected point always lies on the projected curve. 
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Applying Symmetry constraint
In NX, you can make two selected entities symmetric about a line by using the Make 
Symmetric tool. To make two entities symmetric, invoke the Make Symmetric tool 
from the Sketch Tools toolbar; the Make Symmetric dialog box will be displayed 
and you will be prompted to select the first object. Select the first object; you will 

be prompted to select the second object. Select the second object; you will be prompted to 
select a line or plane as the centerline. After selecting the centerline, you will notice that the 
selected objects have become symmetric about the centerline. Also, the selected centerline 
has converted into a reference element. This is because the Make Reference check box is 
selected by default in the dialog box. Next, choose the Close button; the Make Symmetric 
dialog box will be closed.

Applying Automatic Constraints to a Sketch
 Menu bar:	 Tools > Constraints > Auto Constrain	  
 Toolbar:	 Sketch Tools > Auto Constrain  		

The Auto Constrain tool allows you to apply the possible constraints automatically 
to the entire sketch. This tool is mainly used when you import geometry from 
another CAD system. To apply automatic constraints, choose the Auto Constrain 
button from the Sketch Tools toolbar; the Auto Constrain dialog box will be 

displayed, as shown in Figure 3-44. The options in this dialog box are discussed next.

Figure 3-44  The Auto Constrain 
dialog box
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Curves to Constrain Rollout
This rollout is used to select a line, a circle, or a curve to which constraints will be applied. 
Select the sketched entities to which the constraints are to be applied. As you select the sketched 
entities, the Apply and OK buttons of this dialog box will be enabled.

Constraints to Apply Rollout
This rollout consists of various check boxes for major geometric constraints in NX. You can 
select the check boxes of the constraints that should be applied to the sketch. After selecting 
all the required check boxes of the constraints, choose the Apply button and then exit from 
the dialog box by choosing the Cancel button. After you exit the Auto Constrain dialog box, 
all possible constraints from the selected constraints will be applied to the sketch. Also, this 
rollout contains the options to set and clear all the geometric constraint check boxes. These 
options are discussed next.

Set All
If you choose this button, the check boxes of all constraints will be selected. As a result, 
all the possible constraints will be automatically applied to the sketch after you exit this 
dialog box.

Clear All
If you choose this button, the check boxes of all constraints will be cleared.

Settings Rollout
This rollout provides the options to set the tolerance for applying the constraints. Note that 
this rollout is hidden by default. To view this rollout, click on the down arrows at the bottom 
of the Auto Constrain dialog box. The options in this rollout are discussed next. 

Distance Tolerance
In this edit box, you can specify the maximum distance between the endpoints of two 
entities to be considered for applying the Coincident constraint.

Angle Tolerance
In this edit box, you can specify the angle tolerance value that will control whether the 
Horizontal, Vertical, Parallel, and Perpendicular constraints should be applied to the lines 
in the sketch after you exit the Auto Constrain dialog box. For example, if the deviation 
of lines from the X and Y axes is more than that specified value in this edit box, the 
Horizontal and Vertical constraints will not be applied to them.

Apply Remote Constraints
This check box is selected to apply constraints between the objects that are separated by a 
distance or angle more than the value entered in the Distance Tolerance and the Angle 
Tolerance edit boxes.
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Controlling Inferred Constraints Settings
 Menu bar:	 Tools > Constraints > Inferred Constraints and Dimensions	  
 Toolbar:	 Sketch Tools > Inferred  Constraints and Dimension		

As mentioned earlier, some of the constraints and dimensions are automatically 
applied to the sketched entities while they are being sketched. These settings are 
controlled by the Inferred Constraints and Dimensions tool. When you invoke 

this tool, the Inferred Constraints and Dimensions dialog box will be displayed, as shown in 
Figure 3-45.

Figure 3-45  The Inferred Constraints and Dimensions dialog box

This dialog box displays all constraints that are available in NX. You can select the check box 
corresponding to those constraints that should be applied automatically to the sketch while 
the sketch is being drawn.

If you select the  Create Dimensions for Typed Values check box, then the dimensions of the 
entities created by entering the values inside the input boxes will be displayed.

The Auto Dimensioning Rules area in the Dimensions Inferred while Sketching rollout 
displays rules for applying auto dimensions to the sketch. You can modify the order of these 
rules by using the Move up and Move down buttons.
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Showing All Constraints in a Sketch
 Menu bar:	 Tools > Constraints > Display Sketch Constraints		   
 Toolbar:	 Sketch Tools > Display Sketch Constraints		

By default, all the constraints that are applied to the sketch are not displayed 
automatically. For example, constraints such as Concentric, Coincident, and so on 
are displayed by default. However, constraints such as Parallel, Perpendicular, and 

so on are not displayed by default. You can turn on the display of these constraints by using 
the Display Sketch Constraints button. This is a toggle button and when you turn it on, it 
remains on until you turn it off. With this tool turned on, you can continue working with the 
other sketching tools.

Showing/Removing Constraints
 Menu bar:	 Tools > Constraints > Show/Remove Constraints	  
 Toolbar:	 Sketch Tools > Show/Remove Constraints		

If you want to temporarily highlight or permanently delete the constraints applied 
to the sketch, you can use the Show/Remove Constraints tool. When you invoke 
this tool, the Show/Remove Constraints dialog box will be displayed, as shown in 
Figure 3-46. The options in this dialog box are discussed next.

Figure 3-46  The Show/Remove Constraints dialog box
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List Constraints for Area
This area provides three radio buttons, which are discussed next.

Selected Object
Selecting this radio button ensures that the constraints applied only to the currently 
selected entity are listed in the list box in the Show Constraints area. For example, when 
you select a sketched entity from the drawing window, the constraints applied to that entity 
are listed in the list box in the Show Constraints area. If you select another sketched entity, 
the constraints applied to the previously selected entity are removed and the constraints 
applied to the entity selected now are listed.

Selected Objects
This radio button is used to list the constraints applied to more than one entity. You can 
select any number of entities by picking them from the graphics window or by creating 
a temporary rectangle around them by dragging the cursor. The constraints applied to 
all selected entities will be listed in the list box in the Show Constraints list box. You can 
select a constraint from this list box to highlight it in the drawing window.

All In Active Sketch
This radio button is selected to list the constraints applied to all the sketched entities in 
the current sketch.

Constraint Type Drop-down List
The Constraint Type drop-down list is used to select the type of constraints that are to be listed. 
By default, the All option is selected from this drop-down list. As a result, all constraints that 
are applied to the sketch are listed. However, you can select a particular type of constraint 
from this drop-down list. By doing so, you can ensure that only the specified type of constraint 
applied to the selected entity is highlighted. Below this drop-down list, there are two radio 
buttons and they are discussed next.

Include
This radio button ensures that the specified types of constraints selected from the 
Constraint Type drop-down list are included for listing in the dialog box.

Exclude
This radio button ensures that the specified type of constraints selected from the 
Constraint Type drop-down list are excluded for listing in the dialog box.

Show Constraints Area
The options in this area are discussed next.

Drop-down List
The drop-down list in the Show Constraints area allows you to specify whether you want 
to display the explicit constraints, the inferred coincident constraints, or both. Explicit 
constraints such as horizontal, vertical, midpoint, and so on are those constraints that are 
applied by the user while drawing the sketch, whereas, the Inferred coincident constraints 
such as coincident are those constraints that are applied automatically. For displaying 
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the explicit constraints, you need to select the Explicit option, whereas for the inferred 
constraints, you need to select the Inferred option. If you select the Both option from the 
drop-down list, both types of constraints will be listed in the dialog box.

List Box
The constraints applied to the sketch are listed in this list box based on the specified 
selections. If you select a constraint from this list box, the sketched entities related to the 
constraints are highlighted in the graphics window. You can scroll the selection intent 
upward or downward over the constraints listed by choosing the Step Up The List or the 
Step Down The List buttons, respectively.

Remove Highlighted
When you choose this button, the selected constraints in the list box are deleted.

Remove Listed
Choosing this button deletes only the constraints that are listed in the list box. For example, if 
you have listed only the inferred constraints, they will be deleted and the explicit constraints 
will be retained. You can view them by listing the explicit constraints.

Information
This button is used to open a new window, which provides the information about the constraints 
listed in the Show/Remove Constraints dialog box.

Converting a Sketch Entity or Dimension into a Reference 
Entity or reference dimension
 Menu bar:	 Tools > Constraints > Convert To/From Reference	  
 Toolbar:	 Sketch Tools > Convert To/From Reference	

The Convert To/From Reference tool in the Sketch Tools toolbar is used to covert 
or retain the reference property of a sketched entity or a dimension. Generally, 
reference elements are created for assigning the axis of revolution or for applying 
dimensions with reference to an entity. To convert any of these sketched entities or 

dimensions into a reference element, choose the Convert To/From Reference button from 
the Sketch Tools toolbar; the Convert To/From Reference dialog box will be displayed, as 
shown in Figure 3-47. 

By default, the Reference Curve or Dimension  radio button is selected and you are prompted 
to select the entity or dimension. Select one or more objects, or dimensions. Next, choose the 
OK button from the dialog box to convert the selected objects or dimensions into reference 
elements or dimensions.
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Figure 3-47  The Convert To/From 
Reference dialog box

To make the reference elements or dimensions active, choose the Active Curve or Driving 
Dimension radio button from the dialog box and select the reference elements or dimensions. 
Next, choose the OK button.

Note
You can also convert geometric entities into reference entities and vice-versa, without opening 
the Convert To/From Reference dialog box. Select the entities to be converted from the 
drawing window and then choose the Convert To/From Reference button from the Sketch Tools 
toolbar; the selected geometric entities will be converted into reference entities and vice-versa.

Tutorials
From this chapter onward, you will use Sketch constraints and parametric dimensions to 
complete the model.

Tutorial 1
In this tutorial, you will draw the profile of the model shown in Figure 3-48. The profile is 
shown in Figure 3-49. The profile should be symmetric about the origin. Also, you will use 
the parametric dimensions to complete the sketch.		    (Expected time: 30 min)                                                                                                 

Figure 3-49  Sketch for Tutorial 1Figure 3-48  Model for Tutorial 1
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	 The following steps are required to complete this tutorial:

a. 	 Start a new file and invoke the Sketch task environment.
b. 	 Draw the outer profile of the sketch using the Profile tool.
c.	 Add the geometric constraints to the outer loop and modify its dimensional constraints.
d.	 Draw a rectangle inside the outer loop using the Rectangle tool.
e.	 Add dimensions to the rectangle to complete the sketch.
f.	 Save the sketch and close the file.

Starting a New File and Invoking the Sketch Task Environment
1.	 Start a new file by using the Model template. 

2. 	 Choose the New button from the Standard toolbar; the New dialog box is displayed. 
Next, select the Model template from the Templates rollout, and then enter c03tut1 as 
the name of the document in the Name text box.

3. 	 Choose the button on the right of the Folder text box; the Choose Directory dialog box 
is displayed. Next, browse to the C:\NX 8.5\c03, and then choose the OK button twice; 
the new file is started in the Modeling environment. 

4.	 Invoke the Sketch task environment by using the XC-ZC plane as the sketching plane. 

Note
You can also start a sketch directly by choosing the Sketch button from the Direct Sketch toolbar 
available at the bottom of the drawing window, and then select the XC-ZC plane. In this case, 
you can invoke the sketch, dimension, and constraint tools from the Direct Sketch toolbar.

Drawing the Outer Loop and Adding Sketch Constraints
	 If the sketch consists of more than one closed loop, it is recommended that you draw the  

outer loop first and then add all the required Sketch constraints and dimensions to it. 
This makes it easier to draw and dimension the inner loops. Next, you need to draw the 
inner loop.

1.	 By default, the Profile tool from the Sketch Tools toolbar is chosen and you are prompted 
to select the first point of the line or press and drag the left mouse button to begin with 
the arc creation. 

2.	 Draw the sketch around the origin following the sequence shown in Figure 3-50. The sketch 
is unsymmetrical at this stage. But, after adding the Sketch constraints and modifying the 
dimensions, it will become symmetrical. You can use the help lines to draw the sketch. For 
your reference, the sequence in which the lines need to be drawn in the sketch is indicated 
by numbers.
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Figure 3-50  The outer loop of the profile and the 
sequence in which lines have to be drawn

Note
The dimensions shown in Figure 3-50 are automatically applied while drawing the sketch. 
However, those dimensions are not driving dimensions. They will change when you drag or 
move a sketched entity. In order to make them driving dimensions, you need to modify them. You 
will learn to modify these dimensions later in this tutorial.

	 Next, you need to apply the geometric constraints and modify dimensions. But before you 
do that, it is recommended that you turn on the display of constraints, if it is not already 
on.

3.	 Choose the Display Sketch Constraints button from the Sketch Tools toolbar 
to view the constraints applied to the sketch.

4.	 Next, choose the Geometric Constraints button from the Sketch Tools toolbar; 
the Geometric Constraints dialog box is displayed and you are prompted to 
select curves to create constraints.

5. 	 Choose the Equal Length button from the Geometric Constraints dialog box and 
then select lines 1 and 7. The symbol for the equal length constraint is displayed 
on both sketch members, indicating that this constraint is applied between the 
two selected entities.

6.	 Similarly, apply the equal length constraint between lines 8 and 6, 6 and 2, 2 and 12, 12 
and 8, 3 and 11, 9 and 5, and 10 and 4. Next, exit the dialog box.

	 Now, you need to make this sketch symmetric about horizontal and vertical datum axes.

7.	 Choose the Make Symmetric tool from the Sketch Tools toolbar; the Make Symmetric 
dialog box is displayed and you are prompted to select the first object to apply 
symmetry.

8.	 Select line 2; you are prompted to select the second object. Select the line 12; you are 
prompted to select the centerline. 
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9.	 Select the vertical axis as the centerline; line 2 and 12 are made symmetric about vertical 
axis. Next, choose the Close button from the Make Symmetric dialog box to close it.

10.	 Similarly, make the lines 1 and 7 symmetric about the horizontal axis. The sketch after 
applying  constraints to all these entities is shown in Figure 3-51.

Figure 3-51  The outer profile after adding constraints

Adding Dimensions to Sketch Members
	 Next, you need to add the dimensions to the sketch. As mentioned earlier, when you add 

dimensions to the sketch and modify their values, the entity is forced by the specified 
dimension value to maintain this modification. Before you start dimensioning the sketch, 
you need to modify some dimension display options.

1.	 Choose Task > Sketch Style from the menu bar; the Sketch Style dialog box is displayed. 
Select the Value option from the Dimension Label drop-down list. Next, choose the OK 
button to exit this dialog box.

2.	 Choose the Inferred Dimensions button from the Sketch Tools toolbar; you are
prompted to select an object to dimension or the dimension to edit.

3.	 Select the line 1; the current dimension of the line 1 is attached to the cursor. Now, you 
need to place the dimension at the required location. Click the left mouse button below 
the line 1 to place the dimension, refer to Figure 3-52. As you place the dimension, an 
edit box is displayed. Enter 80 in the edit box and press ENTER. Next, choose the Fit 
button from the View toolbar.

Tip: Instead of adding the dimensions to the sketch, you can also modify the 
automatically applied dimensions by double-clicking on them. On doing so, an edit 
box will be displayed. Enter the required value in the edit box and press ENTER; 
the dimensions will be locked and displayed in blue color.

4.	 Select line 2 and place the dimensions on the left of the sketch. Enter 10 in the edit 
box displayed and press ENTER.
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5.	 Select line 4 and place the dimension on the left of the sketch. Next, modify the dimension 
value to 30 and press ENTER.

6. 	 Select line 5 and place the dimension below the line. Next, modify the dimension value 
to 15 and press ENTER.

	 When you place the dimensions, they generally scatter all around the sketch. It is a good 
practice to arrange them properly.

7.	 Exit the Inferred Dimensions tool by pressing the ESC key twice and then drag the 
dimensions to place them properly around the sketch, refer to Figure 3-52.

Figure 3-52  The outer profile after adding the required dimensions

Drawing the Inner Loop and Adding the Dimensions
	 Next, you need to draw the rectangular profile inside the outer loop.

1.	 Choose the Rectangle button from the Sketch Tools toolbar; the Rectangle dialog box is 
displayed.

2.	 Choose the From Center button from the Rectangle dialog box; you are prompted to 
specify the center of the rectangle.

3.	 Select origin as the center of the rectangle; you are prompted to specify the second point 
of the rectangle.

4.	 Move the cursor horizontally toward right and click to specify the second point; you are 
prompted to select the third point to create the rectangle.

5.	 Move the cursor vertically upward and click to specify the third point; the rectangle is 
created, as shown in Figure 3-53. Press ESC to exit the tool.
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Figure 3-53  The sketch after drawing the inner 
loop and turning on the display of constraints

6.	 Double-click on the horizontal dimension of the rectangle; a dynamic edit box is displayed. 
Modify the value of the dimension to 30 and press ENTER. Next, drag and place the 
dimension above the sketch.  

7.	 Similarly, double-click on the vertical dimension of the rectangle and modify the value 
of the dimension to 20. Next, press ESC. Next, place the dimension on the right of the 
sketch, refer to Figure 3-54.

Figure 3-54  The resulting sketch after adding the required dimensions and constraints

Saving the File
1.	 Exit the Sketch task environment by choosing the Finish Sketch button from the Sketch  

toolbar. Next, choose the Save button from the Standard toolbar to save the sketch. Note 
that the name and location of the document had already been specified when you started 
the new file.

2.	 Choose File > Close > All Parts from the menu bar to close the file.
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Tutorial 2
In this tutorial, you will create the profile for the model shown in Figure 3-55. The profile is 
shown in Figure 3-56. You will use the geometric and dimensional constraints to complete this 
sketch.  						                             (Expected time: 30 min)

Figure 3-56  Sketch for Tutorial 2Figure 3-55  Model for Tutorial 2

	 The following steps are required to complete this tutorial:

a.	 Start a new file in NX and invoke the Sketch task environment.
b.	 Draw the sketch using the Profile tool.
c.	 Add the geometric and dimensional constraints to the sketch.
d.	 Save the sketch and close the file.

Starting a New File in NX and Invoking the Sketch Task Environment
1. 	 Start a new file with the name c03tut2.prt using the Model template and specify its location 

as C:\NX 8.5\c03.

2.	 Turn on the display of  WCS by choosing the Display WCS button from the WCS drop-down 
in the Utility toolbar, if it is not already displayed.

3.	 Invoke the Sketch task environment by using the XC-YC plane as the sketching plane. 

Drawing the Sketch
1.	 By default, the Profile button is chosen in the  Sketch Tools toolbar. Draw the outer profile 

of the sketch, refer to Figure 3-57. You can draw the first line with exact dimension and 
then draw the remaining sketched entities with dimension values close to the required 
dimension values. Note that the start point of the line 1 is at the origin.

Note
In Figure 3-57, the temporary dimensions are hidden for the clarity of the view. To hide the 
temporary dimensions, choose the Show and Hide button from the Utility toolbar; the Show 
and Hide dialog box is displayed. In this dialog box, select the minus sign (-) from the Drafting 
Annotations row; all the temporary dimensions are hidden.
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	 Note that after drawing the first line, you may need to modify the drawing display area 
by using the Fit button from the View toolbar.

2.	 Next, choose the Circle button from the  Sketch Tools toolbar. Move the cursor over the 
arc that is numbered 3 in Figure 3-57; the center point of the arc is highlighted.

Note
If the center of the arc is not highlighted, choose the Arc Center button from the 
Selection Bar.

3.	 After the center point gets highlighted, move the cursor over it and press the left mouse 
button to specify the center point of the circle. Now, move the cursor away from the 
center point and specify the diameter of the circle by clicking the left mouse button or 
by entering the diameter value in the diameter input box. The circle is created, refer to 
Figure 3-57.

Figure 3-57  The sequence to be followed for drawing the sketch

Adding Constraints to the Sketch
1.	 Choose the Geometric Constraints button from the Sketch Tools toolbar; the Geometric 

Constraints dialog box is displayed.

2.	 Choose the Horizontal button from the Geometric Constraints dialog box and select 
line 1 to apply the horizontal constraint, if this constraint has not already been applied. 
Similarly, apply the Horizontal constraint to lines 5, 7, and 9.

3.	 Similarly, apply the Vertical constraint to lines 6 and 10, if this constraint has not 
already been applied.

4.	 Choose the Concentric button from the Geometric Constraints dialog box. 
Next, select the circle and arc 3 from the drawing area to apply the Concentric 
constraint.

5.	 Choose the Equal Length button from the Geometric Constraints dialog box 
and select lines 1 and 5 to apply the Equal Length constraint.

6.	 Similarly, apply the Equal Length constraint between lines 2 and 4, 6 and 10, and 7 and 
9. 
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	 The sketch after applying all constraints is shown in Figure 3-58. 

Figure 3-58  The sketch displayed after adding the required constraints

Modifying Dimensions of the Sketch
	 Next, you need to modify the dimensions of the sketch. 

1.	 Double-click on the dimension of line 5; a dynamic edit box is displayed. Modify the value 
of the dimension to 40 and press ENTER. Next, drag and place the dimension above the 
line, refer to Figure 3-58.  

2.	 Double-click on the dimension of line 7; a dynamic edit box is displayed. Modify the value 
of the dimension to 20 and press ENTER. Next, drag and place the dimension below the 
line, refer to Figure 3-58.  

3.	 Double-click on the dimension of the arc 8; a dynamic edit box is displayed. Modify the 
value of the dimension to 10 and press ENTER. 

4.	 Double-click on the dimension of the arc 3; a dynamic edit box is displayed. Modify the 
value of the dimension to 10 and press ENTER. 

	 Next, you need to add some dimensions which are not added automatically.

5.	 Choose the Inferred Dimensions button from the  Sketch Tools toolbar.          

6.	 Select line 6 and the center point of the circle. Place the dimension above the sketch and 
modify the dimension value to 80. Press the ENTER key.

7.	 Select line 6 and place the dimension on the left of the sketch. Next, modify the dimension 
value to 20 and press ENTER.

8.	 Select the circle and place the dimension, refer to Figure 3-58. Next, modify the dimension 
value to 12 and press ENTER.

9.	 Choose the Fit button from the View toolbar.
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	 The final sketch after adding the required dimensions is shown in Figure 3-59.

Figure 3-59  The final sketch after adding the required dimensions

Saving the File
1.	 Choose the Save button from the Standard toolbar to save the sketch. Note that the name 

and the location of the document had already been specified when you started the new 
file.

2.	 Exit the Sketch task environment and then choose File > Close > All Parts from the 
menu bar to close the file.

Tutorial 3
In this tutorial, you will create the profile for the revolved model shown in Figure 3-60. The 
profile is shown in Figure 3-61. You will use the geometric and dimensional constraints to 
complete this sketch.				    		    (Expected time: 30 min)

Figure 3-60  Model for Tutorial 3 Figure 3-61  Sketch for Tutorial 3
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	 The following steps are required to complete this tutorial:

a.	 Start a new file in NX and invoke the Sketch task environment.
b.	 Draw the required profile of the sketch using the Profile tool.
c.	 Add the geometric and dimensional constraints to the sketch.
d.	 Save the sketch and close the file.

Starting a New File in NX and Invoking the Sketch Task Environment
1. 	 Start a new file with the name c03tut3.prt using the Model template and specify its location 

as C:\NX 8.5\c03.

2.	 Turn on the display of WCS by choosing the Display WCS button from the WCS drop-down 
in the Utility toolbar.

3.	 Invoke the Sketch task environment using the XC-ZC plane as the sketching plane. 

Drawing the Sketch
	 It is recommended that you create the first sketch member with the exact measurement 

by entering the value in the edit box displayed. After creating the first sketch member, 
you can create the other sketch members by taking the first entity as the reference. After 
creating the entire sketch, you can modify the values by using the dimensions tool. 

1.	 By default, the Profile button is chosen in the  Sketch Tools toolbar and you are prompted 
to specify the first point of the line. Specify the start point of the line at the origin. Next, 
move the cursor horizontally toward the right and enter 60 in the Length edit box and 
0 in the Angle edit box. Next, press ENTER. 	

2.	 Follow the sequence given in Figure 3-62 for drawing the sketch. Draw the other entities 
of the sketch. For better understanding, the sketch has been numbered and temporary 
dimensions have been hidden.

Figure 3-62  The sequence for drawing the profile

Adding Geometric Constraints to the Sketch
	 After completing the sketch, you need to apply constraints to it.
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1.	 Choose the Geometric Constraints button from the  Sketch Tools toolbar; the Geometric 
Constraints dialog box is displayed. Choose the Vertical button from this dialog box 
and select line 8 to apply the vertical dimension, if it is not applied automatically, while 
drawing the sketch.

2.	 Similarly, apply the horizontal constraint to lines 1, 3, and 7, if this constraint is not 
applied automatically.

3.	 Apply the vertical constraint to line 6, if it is not applied automatically.                 

4.	 After applying the constraints, choose the Display Sketch Constraints button from 
the Sketch Tools toolbar, if it is not already chosen. The resulting sketch is shown in 
Figure 3-63.

Figure 3-63  The resulting sketch displayed after adding the constraints

Modifying Dimensions of the Sketch
	 Next, you need to modify the dimensions of the sketch. 

1.	 Double-click on the dimension of line 6; a dynamic edit box is displayed. Modify the value 
of the dimension to 40 and press ENTER. Next, drag and place the dimension on the 
right of the sketch, refer to Figure 3-64. 

	 Next, you need to add some dimensions which are not added automatically.

2.	 Choose the Inferred Dimensions button from the  Sketch Tools toolbar; the 
Dimensions dialog box is displayed.

3.	 Select line 8 and then place the dimension on the left of the sketch; an edit box with 
the default value is displayed. Enter 150 in this edit box and press the ENTER key; the 
dimension value is modified, refer to Figure 3-64.

4.	 Select line 5 and then place the dimension on the right of the sketch. Next, modify the 
dimension value to 30 and press the ENTER key, refer to Figure 3-64.

5.	 Select line 7 and place the dimension above the sketch. Next, modify the dimension value 
to 35 and press ENTER, refer to Figure 3-64.
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6.	 Select line 2 and then line 1; an angular dimension is attached to the cursor. Move the cursor 
outside the sketch toward the right and click the left mouse button to place the dimension. 
Next, modify the dimension value to 117 and press ENTER, refer to Figure 3-64.

7.	 Select lines 3 and 4; an angular dimension is attached to the cursor. Move the cursor 
inside the sketch and place the dimension. Next, modify the dimension value to 77 and 
press ENTER, refer to Figure 3-64. 

8.	 Select the lower endpoint of line 4 and then select line 8; the dimension value is attached 
to the cursor. Place the dimension value below the sketch and then modify this value to 
40. Next, press ENTER.

9.	 Select line 2 and place the dimension on the right of the line. Next, modify the dimension 
value to 12 and press ENTER, refer to Figure 3-64. Press the ESC key twice.

10.	 Choose the Fit button from the View toolbar. The resulting sketch after adding all 
dimensions is shown in Figure 3-64.

Note
In Figure 3-64, the display of constraints is turned off to get a better display of dimensions. You 
can turn off the display of constraints by choosing the Display Sketch Constraints button. 
Note that it is a toggle button.

Figure 3-64  The completed sketch displayed after adding the required constraints and dimensions

Saving the File
1.	 Choose the Save button from the Standard toolbar to save the sketch. Note that the name 

and location of the document has already been specified when you started the new file.

2.	 Exit the Sketch task environment and choose File > Close > All Parts from the menu 
bar to close the file.
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 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 In NX, you can add all types of geometric constraints by using the Geometric Constraints 
tool in the Sketch Tools toolbar. (T/F)

2.	 The Auto Constrain tool allows you to apply all possible geometric constraints automatically 
to the entire sketch. (T/F)

3.	 The Inferred Dimensions tool in the Sketch Tools toolbar is used to add all possible 
dimension types. (T/F)

4.	 In NX, the Diameter Dimension tool is used to add the diameter dimension to the sketch 
members. (T/F)

5.	 The ________ constraint is used to force two curves to share the same location of the  
center points. 

6.	 The ________ tool is used to dimension the radius of an arc. 

7.	 The ________ tool is used to measure the distance between two objects.

8.	 The ________ tool is used to animate a fully constrained sketch.

9.	 The ________ option in the Measure Distance dialog box is used to measure the distance 
between the objects with respect to a view point.

10.	 The ________ tool is used to show all constraints applied to a sketch.

 Review Questions 
Answer the following questions:

1.	 Which one of the following tools is used to apply geometric constraints to a sketch?

		  (a)  Geometric Constraints		  (b) Automatic Constraints
		  (c)  Inferred Dimensions		  (d) None of these

2.	 Which one of the following tools is used to add a radial dimension to a sketch?

		  (a)  Radius				    (b) Automatic Constraints
		  (c)  Inferred Dimensions		  (d) None of these
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3.	 Which one of the following tools is used to make the endpoints of selected 
objects coincident?

		  (a)  Coincident  			   (b) Concentric
		  (c)  Horizontal		                            (d) None of these

4.	 Which one of the following tools is used to apply the constant length constraint between 
sketch members?

		  (a)  Equal Length		              (b) Automatic Constraints
		  (c)  Vertical		                           (d) None of these

5.	 Which one of the following tools is used to apply a parallel dimension to a sketch 
member?

		  (a)  Parallel				    (b) Automatic Constraints
		  (c)  Inferred Dimensions		  (d) None of these

6.	 Which one of the following tools is used to convert a sketch member into a reference 
element?

		  (a)  Convert To/From Reference          	 (b) Automatic Constraints
		  (c)  Geometric Constraints    		  (d) None of these

7.	 While measuring an angular dimension, you can display a major or minor dimension. 
(T/F)

8.	 The Sketch Tools toolbar contains all tools required to draw a sketch. (T/F)

9.	 The Sketch tool in the Feature toolbar is used to enter the Sketch task environment. 
(T/F)

10.	 The Finish Sketch tool in the Sketch toolbar is used to exit the Sketch task environment. 
(T/F)

 Exercises 

Exercise  1
Draw the base sketch of the model shown in Figure 3-65. The sketch to be drawn is shown in 
Figure 3-66. Use the geometric and dimensional constraints to complete this sketch.
                                                                                                           (Expected time: 15 min)
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Figure 3-66  Sketch for Exercise 1Figure 3-65  Model for Exercise 1

Exercise  2
Draw the base sketch of the model shown in Figure 3-67. The sketch to be drawn is shown in 
Figure 3-68. Use the geometric and dimensional constraints to complete this sketch. 		
						       		    (Expected time: 15 min)

Figure 3-68  Sketch for Exercise 2Figure 3-67  Model for Exercise 2

Answers to Self-Evaluation Test
1. T, 2. T, 3. T, 4. T, 5. Concentric, 6. Radius, 7. Measure Distance, 8. Animate Dimension, 
9. Screen Distance, 10. Display Sketch Constraints


