
Chapter 2

Creating Network
of Tools

 Learning Objectives 
After completing this chapter, you will be able to:
• Load a footage
• View the output of a tool
• Set the frame format for the composition
• Color-correct the footage
• Connect and disconnect connections between tools
• Merge multiple images
• Save and render a composition
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INTRODUCTION
Fusion is a node-based compositing application. Compositing is an art of combining multiple 
images to create a single image. In this chapter, you will learn to create, save, and render a 
composition. You will also learn how to load and merge the images. A Fusion composition 
consists of a network of nodes called tools. These tools are connected through pipes to form 
a composition. You can connect or disconnect pipes easily by using various methods which 
are discussed later in this chapter. 

In this chapter, you will also learn about Bins where you can store references, compositions, 
and large quantity of data across the network. You can also access tools from this folder. 

TUTORIALS
Before you start the tutorials of this chapter, you need to download the c02_fusion_6.3_tut.zip 
file from http://www.cadcim.com. The path of the file is as follows:

	 Textbooks > Animation and Visual Effects > Fusion > The eyeon Fusion 6.3: A Tutorial Approach

Next, you need to extract the contents of the zip file. To do so, navigate to the Documents 
folder and then create a new folder with the name Fusion_6.3. Next, extract the contents of 
the downloaded zip file to the Fusion_6.3 folder. 

 Tutorial 1                                                               
In this tutorial, you will create a composition and then render it. The final output of the 
composition is shown in Figure 2-1.		                              (Expected time: 20 min)

Figure 2-1  The final output of the composition
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The following steps are required to complete this tutorial:

a.    Create a new composition.
b.	 Load the footage.
c.	 View the output of the tools in Display Views.
d.	 Color-correct the footage.
e.	 Resize the footage.
f.	 Prepare the composition for rendering.
g.	 Save and Render the composition.

Creating a New Composition
In this section, you will create a new composition. 

1.  	 Choose File > New from the menubar; a new composition is displayed in the Fusion 
screen, as shown in Figure 2-2.

Figure 2-2  The new composition displayed in the Fusion screen

	 Before you start working on the composition, you need to set the frame format, frame 
rate, and other parameters of the composition.

2.   Choose File > Preferences from the menubar; the Preferences dialog box is displayed, 
as shown in Figure 2-3. 

3.	 In this dialog box, select Frame Format from the Composition# preferences tree; various
	 frame format settings are displayed on the right of the Preferences dialog box. Next, 

select the Pal / SECAM (D1) option from the Default format drop-down list and then 
choose the Save button to save the changes made.

Note
If you generally work in a particular frame format, you can set it in the Global and new comp 
defaults preferences tree of the Preferences dialog box. As a result, the next time when you 
create a new composition, Fusion will inherit the preference settings for the new composition 
from the global preferences. 
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Figure 2-3  The Preferences dialog box

Loading the Footage
Image or image sequences are loaded into Fusion by using the Loader tool. In this section, 
you will load the footage in the Flow area. 

1.	 Choose the LD button from the toolbar; the Loader1 tool is inserted in the Flow
area and the Open File dialog box is displayed, refer to Figure 2-4.

2.	 In this dialog box, choose Documents > Fusion_6.3 > c02_tut > c02_tut_01 > 
Media_Files > beach clip.mov. Next, choose the Open button; the Loader1 tool is 
inserted in the Flow area, as shown in Figure 2-5. 

Viewing the Output of the Tools in the Display Views
In this section, you will view the output of the tools in the Display Views.

1.	 Make sure the Loader1 tool tile is selected in the Flow area and press 1; the footage is 
displayed in the left Display View. Similarly, press 2 to display the footage in the right 
Display View.

Note
You can create additional Display Views to view the output of the tools. To do so, choose 
Window > New View from the menubar; the View1 window is displayed, as shown in Figure 2-6. 
Now, to display the footage in the new display view, press 3 or drag and drop the Loader1 tool 
tile in the View1 window.
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Figure 2-4  The Open File dialog box 

Tip: 1. You can also drag and drop the loader tools into the Display Views to view the 
output of the tools. Alternatively, you can click the black dots available at the bottom left 
corner of the tool tile to display the footage in the left, right, and additional views that you 
have created, refer to Figure 2-7.

2. If you choose the third dot in the tool tile, Fusion will display the output in full screen 
mode. Press Esc to exit this mode.

Figure 2-5 The Loader1 tool 
inserted in the Flow area

Figure 2-6  The View1 window

Figure 2-7 The black dots displayed on the lower-left area of the tool tile
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Color-Correcting the Footage
In this section, you will color-correct the footage by using the Color Corrector tool. 

Figure 2-8  The ColorCorrector1 
tool control window

1. 	 Click in the empty space of the Flow area to deselect 
the selected tool tile, if any. Choose the Fit button from 
the left Display View toolbar to fit the image into the 
left Display View.

2.   	Choose Tools > Color > Color Corrector from the 
menubar; the ColorCorrector1 tool is inserted in 
the Flow area and its properties are displayed in the 
control window on the right of the interface, refer to 
Figure 2-8.

  
3. 	 Click on the red output node of the Loader1 tool 

and drag the cursor over the orange input node of 
the ColorCorrector1 tool; a pipe is drawn between 
the Loader1 and ColorCorrector1 tools to make 
connection between them.

Note 
To break the connection between two tools, click on the 
connecting arrow head and drop it into an empty space 
of the Flow area.

4.  	 Select the ColorCorrector1 tool tile from the Flow area 
and press 2; the output of the ColorCorrector1 tool is 
displayed in the right Display View. Next, choose the 
Fit button from the right Display View toolbar to fit 
the image into the right Display View.

5.  	 In the control window of the ColorCorrector1 tool, set the values of the parameters as 
follows:

	 Tint: 0.33	 			   Strength: 0.072

	 Master - RGB - Contrast: 1.05	 Master - RGB - Gain: 1.15

	 Notice the change in the colors of the footage in the right Display View.

Resizing the Footage
In this section, you will resize the footage by using the Resize tool. 

1.	 Make sure the ColorCorrector1 tool tile is selected in the Flow area and then 
choose the Bins button from the toolbar; the Bins window is displayed. Expand 
Library on localhost in the left pane of the Bins window by clicking on the plus 
sign placed before it. 
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2.	 Expand the Tools node and then select the Transform node from the left pane in the 
Bins window; the tools under the Transform category are displayed in the right pane. 
Double-click on the Resize tool in the Bins window; the Resize1 tool is connected to the 
ColorCorrector1 tool and its properties are displayed in the control window. Next, close 
the Bins window.

Note
You can also drag and drop tools from the Bins window to the Flow area and then make 
connections between the tools based on your requirement.

2.	 Press 2; the output of the Resize1 tool is displayed in the right Display View. 

3.	 In the control window of the Resize1 tool, set the values of the parameters as follows:

	 Width: 360				    Height: 288

	 After entering the values in the Resize1 tool control window, the output of the tool is 
displayed, refer to Figure 2-9.

Figure 2-9  The Resize1 tool in the Flow area and its output in the right Display View

Preparing the Composition for Rendering
In this section, you will prepare the composition for rendering. 

1.	 Make sure the Resize1 tool tile is selected in the Flow area and then right-click on it; a 
shortcut menu is displayed. Choose Insert Tool > I/O > Saver from the shortcut menu; 
the Saver1 tool is inserted in the Flow area and the Save File dialog box is displayed.

2.	 Choose Documents > Fusion_6.3 > c02_tut > c02_tut_01 from the dialog box. Select 
Quick Time Movies (*.mov; *.qt) from the File Type drop-down list. Next, enter 
beach clip1 in the File Name edit box. Next, choose the Save button, refer to Figure 2-10. 

3. 	 Choose the Format tab in the Saver1 tool control window and select Sorenson Video 3 
or H.264 from the Compression drop-down list. Next, move the Quality slider to 100,

	 refer to Figure 2-11.
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Saving and Rendering the Composition                                       
In this section, you will save and render the composition. You 

Figure 2-11  The Saver1 tool control 
window

can also view the final render of the composition by 
downloading the file c02_fusion_6.3_rndr.zip from 
http://www.cadcim.com. The path of the file is given at the 
beginning of the chapter.

1. 	 Choose File > Save from the menubar; the Save File 
dialog box will be displayed. In this dialog box, choose 
Documents > Fusion_6.3 > c02_tut > c02_tut_01 
and then enter c02tut1 in the File Name edit box. 
Next,  choose the Save button to close the dialog box 
and save the composition.

2.   Choose File > Start Render from the menubar; the 
Render Settings dialog box is displayed, as shown in Figure 2-12.

3. 	 Choose the Start Render button; the rendering process is started. On completion of 
rendering, a message box is displayed with the information about the frame range rendered 
and the time taken to render the frame range, as shown in Figure 2-13. Next, choose the 
OK button to close the message box.

Tip: You can also open the Render Settings dialog box by pressing F12 or by choosing the 
green Render button available in the Time Ruler.

Figure 2-12  The Render Settings dialog box
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Figure 2-13  The message box informing about the 
completion of the rendering process

4.	 Navigate to /Documents/Fusion_6.3/c02_tut/c02_tut_01 and double-click on the 
beach clip1.mov file to view the final rendered output, refer to Figure 2-1.

 Tutorial 2                                                                    
In this tutorial, you will composite three images to create a single image. The final output 
of the composition is shown in Figure 2-14.                                     (Expected time: 25 min)

Figure 2-14  The final output of the composition

The following steps are required to complete this tutorial:

a.    Set the frame format.
b.	 Download and import images.
c.	 Resize images.
d.    Color-correct the image.
e.	 Merge images.
f. 	 Prepare the composition for rendering.
g.	 Save and Render the composition.
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Setting the Frame Format
In this section, you will set the frame format for the composition.

1.	 Choose File > New from the menubar; a new composition is displayed in the Fusion 
screen.

2.	 Choose File > Preferences from the menubar; the Preferences dialog box is displayed.

3.	 In this dialog box, select Frame Format from the Composition# preferences tree; various
	 frame format settings are displayed on the right of the Preferences dialog box. Next, 

select the NTSC (Square Pixel) option from the Default format drop-down list and then 
choose the Save button to save the changes made.

4.	 In the Time Ruler area, enter 0 in the Global End Time edit box.

Downloading and Importing the Images
In this section, you will download the images and import them to the composition.

1.	 Open the link http://www.sxc.hu/photo/1252649; an image is displayed.

2.	 Download the image to /Documents/Fusion_6.3/c02_tut/c02_tut_02/Media_Files and save it 
with the name sunset.jpg.

Note
Footage Courtesy: Colin Broug (http://www.sxc.hu/profile/ColinBroug).

3.	 Choose the LD button from the toolbar; the Open File dialog box is displayed, 
refer to Figure 2-4. Next, choose Documents > Fusion_6.3 > c02_tut > 
c02_tut_02 > Media_Files > sunset. jpg from the dialog box; the Loader1 tool is 
inserted in the Flow area, refer to Figure 2-15. 

4.	 Press 1; the output of the Loader1 tool is displayed in the left Display View. Choose the 
Fit button from the left Display View toolbar to fit the image into the left Display View.

5. 	 Click in the empty space of the Flow area to deselect the Loader1 tool tile. Import tree.png 
from the location specified in step 3; the Loader2 tool is inserted in the Flow area, refer 
to Figure 2-15. 

6.	 Press 2; the output of the Loader2 tool is displayed in the right Display View. Next,
choose the Fit button from the right Display View toolbar to fit the image in the 
right Display View.

7.	 In the control window of the Loader2 tool, choose the Import tab and then select the 
Post-Multiply by Alpha check box, refer to Figure 2-16; the transparency is displayed in 
the Display View. 

	 When you select the Post-Multiply by Alpha check box, the color values of the pixels are 
multiplied by their alpha values, thereby producing clear transparency.
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Figure 2-15  The Loader1 and Loader2 tools 
inserted in the Flow area

Figure 2-16  Choosing the Import tab 
from the Loader2 tool control window

Resizing the Images
In this section, you will resize the images.

1.	 Select the Loader1 tool tile from the Flow area and then choose the Rsz button
from the toolbar; the Resize1 tool is inserted in the Flow area and a connection 
between Loader1 and Resize1 tools is established.

2.	 Select the Loader2 tool tile from the Flow area and then choose the Rsz button
from the toolbar; the Resize2 tool is inserted in the Flow area and a connection 
between the Loader2 and Resize2 tools is established.

3.	 Set the values of the Width and Height parameters in the Resize1 and Resize2 tool control 
windows to 640 and 480, respectively.

Color-Correcting the Image
In this section, you will color-correct the tree image. 

1.  	 Select the Resize2 tool tile from the Flow area and then choose Tools > Color > 
Color Corrector from the menubar; the ColorCorrector1 tool is inserted in the Flow 
area and a connection between the ColorCorrector1 and Resize2 tools is established.

2.	 Make sure the ColorCorrector1 tool tile is selected in the Flow area and then press 2; the 
output of the ColorCorrector1 tool is displayed in the right Display View. 

3.	 In the control window of the ColorCorrector1 tool, set the values of the parameters as 
follows:

	 Master - RGB - Gain: 0.18	 Master - RGB - Brightness: -0.64
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4.	 Choose the Suppress button in the ColorCorrector1 tool control window; the Suppress 
color wheel is displayed. In this color wheel, move the circles corresponding to yellow 
and green colors to the center of the color wheel, refer to Figure 2-17. Alternatively, you 
can set the values of the parameters as follows:

		
	 Yellow: 0.039		  Green: 0

Figure 2-17  The Suppress color 
wheel in the control window

Merging the Images
In this section, you will merge the images.

1.	 Click on the red output node of the ColorCorrector1 tool and then drag the cursor to the 
red output node of the Resize1 tool; the Merge1 tool is inserted in the Flow area and a 
connection between the Resize1, ColorCorrector1, and Merge1 tools is established. 

Note
If you click on the red output node of a tool and then drag the cursor to the red output node of 
another tool, the Merge tool will appear automatically and pipes will be drawn between the tools. 

2.	 Press 2; the output of the Merge1 tool is displayed in the right Display View. 

3.	 In the Merge1 tool control window, enter 1.49 in the Size edit box.
 
4.	 Click in the empty space of the Flow area to deselect the selected tool tile, if any. Choose the 

LD button from the toolbar; the Open File dialog box is displayed, refer to Figure 2-4. In 
this dialog box, choose Documents > Fusion_6.3 > c02_tut > c02_tut_02 > Media_Files > 
man standing.png; the Loader3 tool is inserted in the Flow area. 

5.	 Press 1; the output of the Loader3 tool is displayed in the left Display View. 

6.	 In the control window of the Loader3 tool, choose the Import tab and then select the 
Post-Multiply by Alpha check box. 
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7.	 Make sure the Loader3 tool tile is selected in the Flow area. Next, choose the Rsz 
button from the toolbar; the Resize3 tool is inserted in the Flow area and a 
connection between the Loader3 and Resize3 tools is established.

8.	 Click in the empty space of the Flow area to deselect the selected tool tile, if any. Choose 
the Mrg button from the toolbar; the Merge2 tool is inserted in the Flow area. Click on the  
red output node of the Merge1 tool and then drag the cursor to the orange node of the 
Merge2 tool to connect these tools. Similarly, connect the red output node of the Resize3 
tool to the green node of the Merge2 tool. Next, press 2; the output of the Merge2 tool 
is displayed in the right Display View. 

9.	 In the control window of the Merge2 tool, set the values of the parameters as follows:

	 Center
	 X: 0.54			   Y: 0.26

	 Size: 0.21

10.	 Make sure the Merge2 tool tile is selected in the Flow area and then choose the CC
button from the toolbar; the ColorCorrector2 tool is inserted in the Flow area and 
a connection between the Merge2 and ColorCorrector2 tools is established. Next, press 
2; the output of the ColorCorrector2 tool is displayed in the right Display View. 

11.	 In the ColorCorrector2 tool control window, set the values of the parameters as follows:

	 Tint: 0.11		  Strength: 0.28		  Master - RGB - Gain: 0.92

 	 After entering the values, the output of the ColorCorrector2 tool is displayed in the right 
Display View, as shown in Figure 2-18.

Figure 2-18  The output of the ColorCorrector2 tool
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12. 	Click in the empty space of the Flow area to deselect the selected tool tile, if any. Choose 
Tools > Blur > Blur from the toolbar; the Blur1 tool is inserted in the Flow area.

13.	 Click on the red output node of the ColorCorrector2 tool and then drag the cursor to 
the orange input node of the Blur1 tool; a pipe is drawn between the ColorCorrector2 
and Blur1 tools to represent the connection between them. 

14.	 Press 1; the output of the Blur1 tool is displayed in the left Display View. 

15.	 In the control window of the Blur1 tool, enter 1.05 in the Blur Size edit box.

Preparing the Composition for Rendering
Next, you will prepare the composition for rendering. 

1.	 Make sure the Blur1 tool tile is selected from the Flow area. Choose the SV button from 
the toolbar; the Save File dialog box is displayed, as shown in Figure 2-19. 

Figure 2-19  Partial view of the Save File dialog box displayed on choosing the SV button

2.	 Choose Documents > Fusion_6.3 > c02_tut > c02_tut_02 from the dialog box. Select 
JPEG Files (*.jpg; *.jpeg) from the File Type drop-down list. Next, enter composite1 .jpg in 
the File Name edit box. Next, choose the Save button, refer to Figure 2-10. 

3.   Choose the Format tab in the Saver1 tool control window and move the Quality slider 
to 100.

Saving and Rendering the Composition
In this section, you will save and render the composition. You can also view the final render of 
the composition by downloading the file c02_fusion_6.3_rndr.zip from http://www.cadcim.com. The 
path of the file is given at the beginning of the chapter.

1. 	 Choose File > Save from the menubar; the Save File dialog box will be displayed. In this 
dialog box, choose Documents > Fusion_6.3 > c02_tut > c02_tut_02 and then enter 
c02tut2 in the File Name edit box. Next, choose the Save button to close the dialog box 
and save the composition.

2.	 Choose the Render button from the Time Ruler available below the Flow area, refer to 
Figure 2-20; the Render  Settings dialog box is displayed. Next, choose the Start Render 
button; the rendering process starts. On completion of rendering, the c02tut2.comp 
message box is displayed. Next, choose the OK button to close the message box.
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Figure 2-20  The Time Ruler showing the Render button

3.	 Navigate to /Documents/Fusion_6.3/c02_tut/c02_tut_02 and double-click on the composite1.jpg 
file to view the final rendered output.

Using the Undo and Redo Commands in Fusion
In Fusion, you can use the Undo and Redo commands to undo and redo the steps performed 
earlier. To undo a step, choose Edit > Undo from the menubar or press CTRL + Z. To redo 
a step, choose Edit > Redo from the menubar or press CTRL+Y. You can also delete tools 
by first selecting them and then pressing DEL.

General HotKeys
In Fusion, you can invoke some of the commands by using hotkeys. The main hotkeys and 
their functions are given next.

Hotkey Function

CTRL+ N Creates a new composition

CTRL + O Opens an existing composition

CTRL + S Saves the composition

CTRL + Z Used to undo the last action performed

CTRL+ Y Used to redo the last action performed

CTRL + X or SHIFT+DEL Cuts the selected item in the clipboard

CTRL + C Copies the selected tools in the clipboard

CTRL + G Creates a group of selected tools

CTRL + V Pastes the selected tools from the clipboard

[ Moves forward one frame on the timeline

] Moves backward one frame on the timeline

ALT + [ Advances to the next keyframe

ALT + ] Moves back to the previous keyframe

Function Keys 
The function keys are used to perform various functions. The main function keys and their 
functions are given next.

Key Function

F1 Displays the help for the selected tool

F2 Renames the selected tools

F4 Maximizes and restores the selected area
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F5 Activates the Flow area in the Work area

F6 Activates the Console area in the Work area

F7 Activates the Timeline area in the Work area

F8 Activates the Spline area in the Work area

F11 Activates the Modifiers area in the Control area

F12 Displays the Render Settings dialog box

Display Views Keys
These keys are used to view the composition in different channels. These keys and their 
functions are given next.

Key Function

R Displays the red channel in the selected Display View

G Displays the green channel in the selected Display View

B Displays the blue channel in the selected Display View

A Displays the alpha channel in the selected Display View

Z Displays the Z channel in the selected Display View

C Displays full color image in the selected Display View

V Displays the selected sub views in the Display View

SHIFT + V Swaps the content of the Display View and sub view

CTRL + L Locks the Display View

CTRL + Q Toggles quad view in the selected Display View

CTRL + K Toggles the Show Controls button

CTRL + G Toggles the display of guides

SHIFT + H Toggles the display of handles on spline keypoints

, (comma) Switches the view to use the A image buffer

. (period) Switches the view to use the B image buffer

/ Switches the view so that it shows both the A and B buffers and 
enables splitwipe

Flow Area Keys
These keys are used to perform various functions in the Flow area. These keys and their 
functions are given next.

Key Function

CTRL + F Displays the Find tools dialog box

CTRL + L Toggles the lock mode of the selected tool

V Toggles the display of the navigator
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Spline Area Keys
These keys are used to perform various functions in the Spline area. These keys and their 
functions are given next.

Key Function

S Smoothens the curve of the selected points on a spline 
or polyline

V Reverses the selected keyframes on a spline

CTRL + drag Copies the selected points on a spline

Time Ruler Keys
These keys are used to perform functions in the Time Ruler area. These keys and their 
functions are given next.

Key Function

CTRL + SHIFT+ double-click Sets the render range to the slider 
range

CTRL + Drag Sets the render range to frames enclosed 
by dragging mouse

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following combination of shortcut keys is used to group tools?
		
		  (a) CTRL+H				    (b) CTRL+V
		  (c) CTRL+G				    (d) CTRL+Z

2.	 Which of the following shortcut keys is used to maximize and restore the selected area?

		  (a) F5					     (b) F8
		  (c) F9					     (d) F4

3.	 The ___________ and __________ numeric keys are used to view the output of the tools 
in the primary Display Views.

4.	 The ___________ button in the toolbar is used to load an image or video sequence.

5.	 The ___________ shortcut key is used to rename a tool.

6.	 The ___________ button in the toolbar is used to add the Color Corrector tool to the 
Flow area.
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7.	 The __________ is an art of combining multiple images to create a new image.

8.	 The __________ window is used to store references, composition, and various other data 
across the network.

9.	 The Merge tool is used to combine background and foreground images together. (T/F)

10.	 You can undo the last step performed by using the CTRL + Y keys. (T/F)

 Review Questions 
Answer the following questions:

1.	 Which of the following colors is used to represent the output node of a tool?

	 (a) Green			   (b) Orange
	 (c) Red				    (d)None of these

2.	 Which of the following keys is used to smoothen the points on a spline?	
	 (a) R				    (b) S
	 (c) A				    (d) O

3.	 Which of following combination of shortcut keys is used to break the connection between 
tools?

	 (a) CTRL + DEL		  (b) SHIFT + DEL
	 (c) ALT + DEL			   (d) None of these

4.	 The Suppress parameters in the Color Corrector tool control window are used to 
__________ the color of an image.

5.	 The Merge tool is represented as __________ button on the toolbar. 

6.	 A Fusion composition consists of a network of nodes called tools. These tools are connected 
through _________.

7.	 The _________ button in the Time Ruler is used to start the rendering process. 

8.	 The _________ shortcut key is used to lock the Display View.

9.	 On pressing the F12 key, the Render Settings dialog box is displayed. ( T/F)

10.	 You can save the composition by using the CTRL + Z keys. (T/F)

Answers to Self-Evaluation Test
1. c, 2. d, 3. 1, 2, 4. LD, 5. F2, 6. CC, 7. compositing, 8. Bins, 9. T, 10. F


