
                  Chapter 3
					   

				    Creator Tools

 Learning Objectives 
After completing this chapter, you will be able to: 
• Create a composition using Creator tools
• Create a basic animation
• Create and animate text 
• Create the sky and clouds effects
• Create the plasma effect
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INTRODUCTION
Creator tools are used to create backgrounds, noise patterns, and various other types of effects. 
In this chapter, you will learn to create some basic effects. Also, you will learn to animate 
objects in Fusion.

TUTORIALS
The compositions created in this chapter can be downloaded from http://www.cadcim.com. These 
compositions are contained in the c03_fusion_6.3_tut.zip file. The path of the file is as follows:

	 Textbooks > Animation and Visual Effects > Fusion > The eyeon Fusion_6.3 : A Tutorial Approach

 Tutorial 1
In this tutorial, you will create a rolling ball animation by using the Background tool. The 
ball animation pose at frame 12 is shown in Figure 3-1.                    (Expected time: 30 min) 

Figure 3-1  The ball animation pose at frame 12

The following steps are required to complete this tutorial:

a.	 Set the frame format.
b. 	 Create a new background.
c.	 Create a wooden plank.
d. 	 Create the shadow of the wooden plank.
e. 	 Create the base of  the wooden plank.
f.  	 Create a ball.
g. 	 Animate the ball, the wooden plank, and the wooden plank shadow.

Setting the Frame Format
In this section, you will specify the frame format settings.

1.	 Choose File > New from the menubar; a new composition is displayed in the Fusion 
screen.

2.	 Choose File > Preferences from the menubar; the Preferences dialog box is displayed.

3.	 In this dialog box, select Frame Format from the Composition# preferences tree; various
	 frame format settings are displayed on the right of the Preferences dialog box. 
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4.	 Choose the New button from the right pane in the Settings area of the Preferences dialog 
box; the Enter a name for the new image format dialog box is displayed. Next, enter 
2048x1556 in the edit box and then choose the OK button.

5.	 In the Settings area, enter 2048 and 1556 in the Width and Height edit boxes, 
respectively. 

6.	 Enter 24 in the Frame rate edit box. Next, choose the Save button to save the changes 
made.

Creating a New Background
In this section, you will create a background for the composition. 

1. 	 Choose the BG button from the toolbar; the Background1 tool is inserted in the  
Flow area.

	 The Background tool is used to generate solid color and gradient images.

2.	 Press 1; the output of the Background1 tool is displayed in the left Display View. Next, 
choose the Fit button from the left Display View toolbar to fit the image in the left Display 
View.

3.	 In the Background1 tool control window, choose the Pick button; the Color dialog box 
is displayed. In this dialog box, select the white color swatch from the Basic Colors area 
and then choose the OK button; the white color output is displayed in left Display View.

	 By default, the Solid Color button is chosen in the Color tab of the Background1 tool 
control window. To use two or more colors, you can choose the Horizontal, Vertical, Four 
Corner, or Gradient button. If you choose the Gradient button, a green line appears in 
the Display View. You can change the appearance of the gradient in the Display View by 
dragging the either end of the green line. You can also define your custom gradient by 
adding keys to the gradient ramp.

Creating a Wooden Plank
In this section, you will create a wooden plank by using the Background tool. 

1.  	 Click in the empty space of the Flow area to deselect the selected tool tile, if any. Choose 
the BG button from the toolbar; the Background2 tool is inserted in the Flow area. Next, 
press F2; the Rename Tool dialog box is displayed. Enter WoodenPlank1 in the edit box 
and then choose the OK button.

2.	 In the control window of the WoodenPlank1 tool, choose the Vertical button; the Top 
and Bottom areas are displayed in the Color tab. Parameters in these areas are used to 
specify two colors for the vertical gradient. Enter the following values in the Top area:

	 R:  0.5			   G: 0.25		
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3.   	Select the WoodenPlank1 tool tile in the Flow area. Press 1; the output of the WoodenPlank1 
tool is displayed in the left Display View. 

4.	 Make sure the WoodenPlank1 tool tile is selected in the Flow area and then choose
the Add a Rectangle Mask button from the left Display View toolbar; the Rectangle1 
tool is inserted in the Flow area and gets automatically connected to the purple effect 
mask node of the WoodenPlank1 tool.

Note
An effect mask is an animatable shape that can be used to restrict an effect to a specific area 
of an image. You can attach any number of masks to a tool. Effect masks are connected to the 
purple effect mask node of a tool.

5.	 Make sure the Rectangle1 tool tile is selected in the Flow area. Next, specify the parameters 
in the control window of the Rectangle1 tool as follows:

	 Center
	 Y: 0.26

	 Width:  0.72	 	 Height: 0.016

6.   	Click on the red output node of the WoodenPlank1 tool and then drag the cursor to 
the red output node of the Background1 tool; the Merge1 tool is inserted in the Flow 
area and a connection between the Background1, WoodenPlank1, and Merge1 tools is 
established, refer to Figure 3-2. 

7.	 Press 2; the output of the Merge1 tool is displayed in the right Display View, refer to 
Figure 3-2.  Next, choose the Fit button from the right Display View toolbar to fit the 
image in the Display View.

8.	 In the Merge1 tool control window, enter the value of the Center parameter as follows:

	 Center			 
	 Y: 0.49

	 After entering the value, the output of the Merge1 tool is displayed in the right Display 
View. 

	 Next, you will create the left corner of the wooden plank.

9.	 Select the Rectangle1 tool tile from the Flow area and then choose the Add a
Rectangle Mask button from the left Display View toolbar; the Rectangle2 tool is 
created in the Flow area.
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10.	 In the Rectangle2 tool control window, select Add from the Paint Mode drop-down list 
and then set the parameters as given next.

	 Center
	 X: 0.23			   Y: 0.27		  	

	 Width: 0.03			  Height: 0.03

Figure 3-2  The Merge1 tool in the Flow area and its output 
displayed in the right Display View

	 Next, you will create the right corner of the wooden plank.

11.	 Make sure the Rectangle2 tool tile is selected from the Flow area and then choose
the Add a Rectangle Mask button from the left Display View toolbar; the Rectangle3 
tool is inserted in the Flow area and a connection between the Rectangle2 and 
Rectangle3 tools is established.

12.	 In the Rectangle3 tool control window, select Add from the Paint Mode drop-down list 
and then specify the parameters as follows:

	
	 Center
	 X: 0.75			   Y: 0.27			 

	 Width: 0.03			  Height: 0.03

	 After setting the parameters, the output of the Merge1 tool is displayed in the right Display 
View, as shown in Figure 3-3.
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Figure 3-3  The output of the Merge1 tool

Creating the Shadow of the Wooden Plank
In this section, you will create the shadow of the wooden plank. 

1. 	 Select the WoodenPlank1 tool tile from the Flow area. Next, press and hold CTRL and 
then select the Rectangle1 tool tile.

2.	 Choose Edit > Copy from the menubar. To paste copied tools, choose Edit > Paste from 
the menubar; two new tools with the name Rectangle1_1 and WoodenPlank1_1 are 
inserted in the Flow area.

3.	 Press F2 to rename the WoodenPlank1_1 tool as WoodenPlankShadow1 and Rectangle1_1 
tool as Rectangle4.

4.	 Click on the red output node of the Rectangle4 tool and drag the cursor to the purple 
node of the WoodenPlankShadow1 tool; a connection between the Rectangle4 and 
WoodenPlankShadow1 tools is established.

5.	 Click on the red output node of the WoodenPlankShadow1 tool and drag the cursor to 
the red output node of the Merge1 tool; the Merge2 tool is inserted in the Flow area and 
a connection is established between the Merge2, WoodenPlankShadow1, and Merge1 
tools. 

6.	 Press 2; the output of the Merge2 tool is displayed in the right Display View.

7.	 In the Merge2 tool control window, enter the value of the Center parameter as follow:
	
	 Center
	 Y: 0.456
	  
8.	 Select the Rectangle4 tool tile from the Flow area and enter 0.02 in the Soft Edge edit 

box of the Rectangle4 tool control window.
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	 After entering the values, the output of the Merge2 tool is displayed in the right Display 
view, as shown in Figure 3-4.

Figure 3-4  The Merge2 tool in the Flow area and its output displayed in the right Display View

Creating Base of the Wooden Plank
In this section, you will create base of the wooden plank.

1. 	 Select the WoodenPlank1 tool tile from the Flow area and press CTRL+C. Next, click 
in the empty space of the Flow area and then press CTRL+V. Rename the pasted tool 
as Base1. Choose the Add a Rectangle Mask button from the left Display View toolbar; 
the Rectangle5 tool is inserted in the Flow area and a connection between the Base1 and 
Rectangle5 tools is established.

2.	 Click on the red output node of the Base1 tool and then drag the cursor to the red output 
node of the Merge2 tool; the Merge3 tool is inserted in the Flow area and a connection 
between the Base1, Merge2, and Merge3 tools is established.

3.	 Press 2; the output of the Merge3 tool is displayed in the right Display View.

4.	 Select the Rectangle5 tool tile from the Flow area. In the control window, set the parameters 
as follows:

	 Center 				  
	 X: 0.23		  Y: 0.3

	 Width: 0.016	 Height: 0.02



3-8		                                                   The eyeon Fusion 6.3: A Tutorial Approach
E

va
lu

at
io

n 
C

op
y.

 D
o 

no
t r

ep
ro

du
ce

. F
or

 in
fo

rm
at

io
n 

vi
si

t w
w

w
.c

ad
ci

m
.c

om

5.	 Select the Merge3 tool tile from the Flow area. In the control window, set the parameters 
as follows:

	 Center
	 X: 0.77	 		  Y: 0.447	

6.  	 Select the Base1 tool tile from the Flow area and press CTRL+C. Next, click in the empty 
space of the Flow area and then press CTRL+V. Next, press F2 to rename the pasted tool 
as Base2. 

7.	 Select the Rectangle1 tool tile from the Flow area and press CTRL+C. Next, click on 
the empty space of the Flow area and then press CTRL+V. Rename the pasted tool as 
Rectangle6. 

8. 	 Click on the red output node of the Base2 tool and drag the cursor to the red output node 
of Merge3 tool; the Merge4 tool is inserted in the Flow area and a connection between 
the Merge3, Base2, and Merge4 tools is established.

9.	 Press 2; the output of the Merge4 tool is displayed in the right Display View.

10.	 Click on the red output node of Rectangle6 tool and drag the cursor to the purple node 
of the Base2 tool; a connection between the Rectangle6 and Base2 tools is established.

11.	 Select the Rectangle6 tool tile from the Flow area. In the control window, set the parameters 
as follows:

	
	 Center
 	 Y: 0.198
	
	 Width: 0.033		  Height: 0.067

	 Corner Radius: 0.56

12.	 Select the Merge4 tool tile from the Flow area. In the control window, set the parameters 
as follows:

	 Center	 		
	 Y: 0.508		
	
	 After entering the values, the output of the Merge4 tool is displayed in the right Display 

View, as shown in Figure 3-5.
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Figure 3-5  The output of the Merge4 tool is displayed in the right Display View

Creating the Ball
In this section, you will create a ball.

1. 	 Click in the empty space of the Flow area to deselect the selected tool tile, if any.
Next, choose the BG button from the toolbar; the Background2 tool is inserted in 
the Flow area. Next, rename the Background2 tool as Ball.

2.	 Press 1; the output of the Ball tool is displayed in the left Display View.

3. 	 In the Ball tool control window, choose the Gradient button; controls corresponding to 
the Gradient button are displayed. Next, choose the Radial button and then specify the 
parameters as follows:  

	 Start	 	
	 X: 0.69				    Y: 0.69
	
	 End		
	 X: 0.33				    Y: 0.31	

4.	 Click on the first key of the Gradient ramp to select it and set the following values: 
	
	 R: 0.4 				    Position: 0.51	 			 

5.	 Click on the last key of the Gradient ramp to select it and set the following values:
	
	 R: 0				     G: 0			    B: 0

6.	 Click on the red output of the Ball tool and then drag the cursor to the red output of the 
Merge4 tool; the Merge5 tool is inserted in the Flow area and a connection between the 
Ball, Merge4, and Merge5 tools is established. 

7.	 Press 2; the output of the Merge5 tool is displayed in the right Display View.
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8.  	 Select the Ball tool tile from the Flow area and then choose the Add an Ellipse Mask  
tool from the left Display View toolbar; the Ellipse1 tool is connected to the Ball 
tool. 

9.	 In the Ellipse1 tool control window, enter 0.01 in the Soft Edge edit box. 

10.	 Select the Merge5 tool tile from the Flow area and then set the parameters of the Merge5 
tool in the control window:

	 Center
	 X: 0.88	 				    Y: 0.68
	
	 Size: 0.15

	 After entering the values, the output of the Merge5 and Ball tools is shown in the Display 
Views, as shown in Figure 3-6. 

Figure 3-6  The output of the Merge5 and Ball tools

Animating the Ball, the Wooden Plank, and the Wooden 
Plank Shadow	
In this section, you will animate the ball by using the Transform tool.

1. 	 Select the Ball tool tile from the Flow area and choose Tools > Transform > 
Transform from the menubar or choose the Xf button from the toolbar; the 
Transform1 tool is inserted in the Flow area and the Transform1 tool is connected 
to the Ball and Merge5 tools.

2.	 In the Time Ruler area, enter 50 in the Render End Time edit box.

Note
In Fusion, you can animate the controls. When you animate a control in Fusion, it gets connected 
to an animation curve. The animation curves are made of splines. By default, bezier spline type is 
used during animation. You can change the default spline type from the Preferences dialog box. 
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	 Next, you will animate the Center control of the Transform1 tool. 

3.	 In the control window of the Transform1 tool, set the following parameters:

	 Center
	 X: 2.57		  Y: 0.86

4.	 Right-click on the Center control; a shortcut menu is displayed. Choose the Animate 
option from the shortcut menu; a keyframe is added at frame 0.

Note
Keyframes are automatically updated when the values of a control are changed. If a keyframe 
exists on that particular frame, it will be updated; otherwise a new keyframe will be created. To 
set a keyframe without changing the value of the control, right-click on the control; a shortcut 
menu is displayed. Next, choose the Set Key from the shortcut menu.

Tip: To move the CTI forward or backward frame by frame, press the [ or ] key. To play 
the animation, press SPACEBAR, and to stop the animation, press SPACEBAR again.

5.	 Now, create keyframes by using the values given next.

Frame Center X Center Y

10 -0.35 -1.9

20 -1.9 -0.6

30 -3.87 -2

40 -5.01 -1.15

50 -5.77 -2.34

	 When you add keyframes to an animation curve, a green spline with control points is 
displayed in the Display View. You can modify the animation curve interactively by moving 
the control points or by adjusting the spline handles, refer to Figure 3-7.

  Note
	Select all the control points in the Display View and press SHIFT+S to make the spline smooth.
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Figure 3-7  The Transform1 tool animation spline displayed in the right Display View

6. 	 Select the WoodenPlank1 tool tile from the Flow area and then choose the Xf button from 
the toolbar; the Transform2 tool is inserted in the Flow area and a connection between 
the WoodenPlank1 and Merge1 tools is established.

7.	 Enter 0 in the Current Time edit box; the current time indicator (CTI) moves to the 
beginning of the timeline.

8.	 Right-click on the Angle control; a shortcut menu is displayed. Choose the Animate option 
from the shortcut menu; a keyframe is added at frame 0.

9.	 Animate the Angle control of the Transform2 tool by using the values given next.

Frame Angle

10 0

12 -2.28

20 -2.71

30 3.23

40 1.9

Animating the Shadow of the Wooden Plank	
In this section, you will animate the shadow of the wooden plank.

1.	 Click in the empty space of the Flow area to deselect the selected tool tile, if any. Next, 
copy the Transform2 tool and rename it as Transform3 in the Flow area. 
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2.	 Press and hold SHIFT and then drag the Transform3 tool tile. Next,  drop Transform3 
tool tile over the pipe between the Merge2 and WoodenPlankShadow1 tools; the 
pipe is highlighted. The Transform3 tool is inserted between the Merge2 and 
WoodenPlankShadow1 tools. Next, press SPACEBAR to play the animation. 

	 Figure 3-8 displays the network of tools of the final composition.

Figure 3-8  The network of tools displayed in the Flow area

 

	 Now, save the composition with the name c03tut1 at the location Documents > Fusion_6.3 > 
	 c03_tut > c03_tut_01. Next, you need to render the composition. For rendering, refer 

to Tutorial 1 of Chapter 2. The output of the composition at frame 12 is shown in 
Figure 3-1. You can also view the final render of the composition by downloading the 
c03_fusion_6.3_rndr.zip from http://www.cadcim.com. The path of the file is mentioned at 
the beginning of the chapter.   

 Tutorial 2
In this tutorial, you will create and animate text by using the Text+ tool. The final output of 
the composition at frame 80 is shown in Figure 3-9.	                 (Expected time: 25 min)

Figure 3-9  The final output of the composition at frame 80
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The following steps are required to complete the tutorial:

a.	 Set the frame format.
b. 	 Create the text.
c.	 Create the shadow of the text.
d.	 Add more text.
e.	 Create borders around the text.
f.	 Prepare the text to render.

Setting the Frame Format
In this section, you will specify the frame format settings.

1.	 Choose File > New from the menubar; a new composition is displayed in the Fusion 
screen.

2.	 Choose File > Preferences from the menubar; the Preferences dialog box is displayed.

3.	 In this dialog box, select Frame Format from the Composition# preferences tree; various
	 frame format settings are displayed on the right of the Preferences dialog box. 

4.	 Select the HDTV 1080 option from the Default Format drop-down list and then choose 
the Save button to save the changes made.

Creating the Text
In this section, you will create the text by using the Text+ tool.

1. 	 Choose the Txt+ button from the toolbar; the Text1 tool is inserted in the Flow 
area.

2.	 Press 1; the output of the Text1 tool is displayed in the left Display View. Next, choose 
the Fit button on the left Display View toolbar to fit the image in the Display View.

3.	 In the Text1 tool control window, set the parameters as follows:

	 Styled Text: eyeon Fusion 		  Font: Impact

4.	 Select the Underline check box to underline the text. 

	 Next, you will scramble the text.

5.	 In the Text1 tool control window, right-click in the Styled Text area; a shortcut menu 
is displayed. Next, choose the TextScramble option from the menu; the TextScramble 
modifier is applied to the Text1 tool.

6.	 Choose the Modifiers tab in the control window. Next, click on the triangle located on 
the left of the modifier’s title bar to expand the TextScramble on Text1: Styled Text. Set 
the value of the Randomness control to 1.61. 

7.	 Enter eEyYeEoOFfUuSsIOonN in the Substitute Chars text box.
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8.	 In the Time Ruler area, enter 80 in the Render End Time edit box, refer to Figure 3-10.

Figure 3-10  The Timeline view

9.	 Right-click on the Randomness control; a shortcut menu is displayed. Choose the Animate 
option from the shortcut menu; a keyframe is added at frame 0.

10.	 Animate the Randomness control by using the values given in the table below:

Frame Randomness

0 1.61

30 1.61

50 0

11.	 Enter 0 in the Current Time edit box; the current time indicator (CTI) moves to the 
beginning of the timeline. 

12.	 Choose the Tools tab in the control window and then choose the Layout tab. Right-click 
on the Center control; a shortcut menu is displayed. Choose the Animate option from 
the shortcut menu; a keyframe is added at frame 0. 

13.	 Animate the Center control by using the values given in the table below:

Frame Center X Center Y

0 0.5 0.5

20 0.5 0.5

30 0.5 0.86

14.	 Enter 0 in the Current Time edit box; the current time indicator (CTI) moves to the 
beginning of the timeline. 

15.	 Choose the Text tab and then right-click on the Size control; a shortcut menu is displayed. 
Next, choose the Animate option from the shortcut menu; a keyframe is added at frame 0.

16.	 Animate the Size control by using the values given in the table below:

Frame Size

0 0.037

10 0.09

20 0.14

30 0.17
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	 Next, you will create the background for the text and change the color of the text.

17.	 Choose the Layout tab and then choose the Pick button; the Color dialog box is displayed, 
as shown in Figure 3-11. Choose the white color swatch from the dialog box and then 
choose the OK button.

Figure 3-11  The Color dialog box

18.	 To change the color of the text, choose the Shading tab. In this tab, the 1 button is chosen 
by default. Choose the Pick button in the Color area; the Color dialog box is displayed. 
Move the ramp slider to black color and then choose the OK button.

Creating the Shadow of the Text
In this section, you will create the shadow of the text.

1.	 Make sure the Text1 tool tile is selected from the Flow area. In the control window, choose 
the Shading tab and then choose the 3 button. Next, select the Enabled check box.

2.	 Enter 0.63 in the Opacity edit box.

Adding More Text
In this section, you will add more text to the composition.

1. 	 Click in the empty space of the Flow area to deselect the selected tool tile, if any. Choose 
Tools > Creator > Text+ from the menubar; the Text2 tool is inserted in the Flow area.

2.	 Press 2; the output of the Text2 tool is displayed in the right Display View. Next, choose 
the Fit button from the right Display View toolbar to fit the image in the Display View.

3.	 In the Text2 tool control window, set the parameters as follows:
 
	 Styled Text: .Compositing			   Font: Impact

4.	 Choose the Shading tab in the Text2 tool control window and then set the text color to 
black, as discussed earlier. 

5.	 Choose the 3 button from the Shading tab and then select the Enabled check box; the 
black shadow is added to the text. Next, enter 0.63 in the Opacity edit box. 
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6.	 Choose the Text tab in the Text2 tool control window and animate the Size control by 
using the values given in the table below:

Frame Size

0 0

23 0

30 0.08

7.	 Choose the Layout tab in the Text2 tool control window and animate the Center controls 
by using the following values given in the table below:

Frame Center X Center Y

0 0.5 0.47

30 0.5 0.65

8.	 Click in the empty space of the Flow area to deselect the selected tool tile, if any. 
Choose the Mrg button from the toolbar; the Merge1 tool is inserted in the Flow 
area.

9.	 Click on the red output node of the Text1 tool and then drag the cursor to the orange 
node of the Merge1 tool. Next, click on the red output node of the Text2 tool and drag 
the cursor to the green node of the Merge1 tool; a connection between the Text1, Text2, 
and Merge1 tools is established.

10.	 Press 2; the output of the Merge1 tool is displayed in the right Display View.

11.	 Click in the empty space of the Flow area and then choose the Txt+ from the toolbar; 
the Text3 tool is inserted in the Flow area. 

12.	 Click on the red output node of the Text3 tool and then drag the cursor to the red output 
node of the Merge1 tool; the Merge2 tool is inserted in the Flow area and a connection 
between the Merge1, Merge2, and Text3 tools is established.

13. 	In the Text3 tool control window, set the parameters as follows:
		
	 Styled Text: .Keying		  Font: Impact

14.	 Choose the Shading tab and then change the color of the text to black, as discussed earlier. 
Next, choose the 3 button and then select the Enabled check box to enable black shadows. 
Next, enter 0.63 in the Opacity edit box.

15.	 Choose the Text tab and animate the Size control by using the values  given in the table 
below:

Frame Size

0 0

30 0

50 0.08
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16.	 Click in the empty space of the Flow area to deselect the selected tool tile, if any. Choose 
the Txt+ button from the toolbar; the Text4 tool is inserted in the Flow area.

17.	 Click on the red output node of the Text4 tool and then drag the cursor to the red output 
node of the Merge2 tool; the Merge3 tool is inserted in the Flow area and a connection 
between the Merge2, Merge3, and Text4 tools is established.

18.	 Press 2; the output of the Merge3 tool is displayed in the right Display View.

19.	 Select the Text4 tool tile in the Flow area. In the control window of the Text4 tool, set 
the parameters as follows:

	
	 Styled Text: .Motion Tracking	 Font: Impact

20.	 Choose the Shading tab and then change the color of text to black. Next, choose the 3 
button and then select the Enabled check box to enable black shadows.

21.	 Choose the Text tab in the control window and animate the Size control by using the 
values  given in the table below:

Frame Size

0 0

50 0

70 0.08

22.	 Select the Merge3 tool tile from the Flow area and enter 0.35 in the Y edit box of the 
Center control in the control window.

Creating Borders Around the Text 
 In this section, you will create borders around the text.

1. 	 Click in the empty space of the Flow area to deselect the selected tool tile, if any.

2.	 Choose the BG button from the toolbar; the Background1 tool is inserted in the Flow 
area.

3.	 Press 1; the output of the Background1 tool is displayed in the left Display View.

4.	 Choose the Add a Rectangle Mask button from the left Display View toolbar; the 
Rectangle1 tool gets automatically connected to the effect mask node of the Background1 
tool. 

5.	 Enter 0.015 in the Width edit box of the Rectangle1 tool control window.

6.	 Click on the red output node of the Background1 tool and then drag the cursor to the 
red output node of the Merge3 tool; the Merge4 tool is inserted in the Flow area.
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7.	 Press 2; the output of the Merge4 tool is displayed in the right Display View.

8.	 Enter 0.006 in the X edit box of the Center control in the Merge4 tool control window.

9.	 Copy the Background1 and Rectangle1 tools; the Background1_1 and Rectangle1_1 
tools are inserted in the Flow area.

10.	 Click on the red output node of the Background1_1 tool and then drag the cursor to the 
red output node of the Merge4 tool; the Merge5 tool is inserted in the Flow area.

11.	 Press 2; the output of the Merge5 tool is displayed in the right Display View.

12.	 Enter 0.996 in the X edit box of the Center control in the Merge5 tool control window.

	 After entering the values, the output of the Merge5 tool is displayed at frame 50 in the 
right Display View, as shown in Figure 3-12. Figure 3-13 displays the network of tools used 
for creating the final composition.

Figure 3-12  The output of the Merge5 tool at frame 50

	 Now, save the composition with the name c03tut2 at the location Documents > Fusion_6.3 > 
	 c03_tut > c03_tut_02. Next, you need to render the composition. For rendering, refer 

to Tutorial 1 of Chapter 2. You can also view the final render of the composition by 
downloading the c03_fusion_6.3_rndr.zip from http://www.cadcim.com. The path of the file 
is mentioned at the beginning of the chapter.
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Figure 3-13  All tools used in the composition displayed in the Flow area

 

 Tutorial 3 
In this tutorial, you will create clouds by using the Fast Noise tool and then merge clouds 
with the image of sea bridge. The final output of the composition is shown in Figure 3-14. 
                                                                                                         (Expected time: 20 min)

Figure 3-14  The final output of the composition

The following steps are required to complete this tutorial:

a.	 Set the frame format.
b.	 Download and import the image.
c.	 Create the clouds.
d.	 Merge the images of clouds and sea bridge.
e.	 Add perspective to the image.
f.	 Create the shadows of the clouds.
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Setting the Frame Format 
In this section, you will specify the frame format settings.

1.	 Choose File > New from the menubar; a new composition is displayed in the Fusion 
screen.

2.	 Choose File > Preferences from the menubar; the Preferences dialog box is displayed.

3.	 In this dialog box, select Frame Format from the Composition# preferences tree; various
	 frame format settings are displayed on the right of the Preferences dialog box. Make sure 

2K Full Aperture (Super 35) is selected in the Default format drop-down list and then 
choose the Save button to save the changes made.

4.	 In the Time Ruler area, enter 48 in the Render End Time edit box.

Downloading and Importing the Image
In this section, you will download the image and import it to the composition.

1.	 Open the following link: http://www.sxc.hu/photo/1327985; an image is displayed.

2.	 Download the image at the location /Documents/Fusion_6.3/c03_tut/c03_tut_03/Media_Files and 
save it with the name 1327985.jpg.

3.	 Open the 1327985.jpg image in the Photoshop application and erase sky from it. Now, 
save the file in TGA format with the name seabridge.tga at the location specified in step 2.

Note
Footage Courtesy: Peter Mazurek (http://www.sxc.hu/profile/mazwebs)

4.	 Choose the LD button from the toolbar; the Open File dialog box is displayed. In the 
dialog box, choose Documents > Fusion_6.3 > c03_tut > c03_tut_03 > Media_Files > 
seabridge.tga and then choose the Open button; the Loader1 tool is inserted in the 
Flow area. In the Loader1 tool control window, choose the Import tab and then select 
the Post-Multiply by Alpha check box.

5.	 Press 1; the output of the Loader1 tool is displayed in the left Display View. Next, choose 
the Fit button from the left Display View toolbar to fit the image in the left Display View.

Creating the Clouds
 In this section, you will create the clouds.

1.	 Click in the empty space of the Flow area and then choose Tools > Creator > FastNoise 
from the menubar; the FastNoise1 tool is inserted in the Flow area.

2.	 Press 2; the output of the FastNoise1 tool is displayed in right Display View. Next,  
choose the Show Checker Underlay button from the Display View toolbar to enable 
transparency in the right Display View. Next, choose the Fit button from the right 
Display View toolbar to fit the image in the right Display View.
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3.	 In the FastNoise1 tool control window, choose the Color tab. Next, choose the Pick button 
from the Color1 area; the Color dialog box is displayed. In this dialog box, specify the 
following values and then choose the OK button to close the dialog box, refer to Figure 3-15.

	 Red: 175			   Green: 185		  Blue: 250

Figure 3-15  Selecting color from the Color dialog box

4.	 In the FastNoise1 tool control window, choose the Noise tab

Figure 3-16  The FastNoise1 
tool control window

 
and set the parameters as given next; refer to Figure 3-16.

	 Detail: 3.71				   Scale: 5.54
	 	
	 Seethe: 0.07			   Seethe Rate: 0.10

	 The Detail parameter is used to enhance the level of 
detailing in the noise pattern. The larger the value of 
this parameter, better will be result but render time will 
increase. The Scale parameter is used to define the scale 
of the noise pattern. The Seethe parameter is used to 
produce drifting effects such as drifting fog. The Seethe 
Rate parameter determines the rate at which the noise 
changes in each frame.

Merging the Images of Clouds and Sea bridge
In this section, you will merge the images.

1.	 Click in the empty space of the Flow area to deselect the selected tool tile, if any. 
Next, choose the Mrg button from the toolbar; the Merge1 tool is inserted in the 
Flow area.

2.	 Click on the red output node of FastNoise1 tool and then drag the cursor to the orange 
node of Merge1 tool. Next, click on the red output node of the Loader1 tool and then 
drag the cursor over the green node of the Merge1 tool. Next, press 2; the output of the 
Merge1 node is displayed in the right Display View.
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Adding Perspective to the Image
In this section, you will add perspective to the image.

1.	 Select the FastNoise1 tool tile from the Flow area. Next, choose Tools > Transform > 
DVE from the menubar; the DVE1 tool is inserted in the Flow area and a connection 
between the DVE1 and FastNoise1 tools is established. 

2.	 In the DVE1 tool control window, choose the YZX button from

Figure 3-17  The DVE1 
tool control window

 
the Rotation Order area and then set the parameters as given 
next, refer to Figure 3-17.

	 Center
	 Y: 0.012
	
	 Z Move: 0.57			   Z Pivot: 0.25

	 X Rotation: 66.6			   Perspective: 0.94

Creating the Shadows of the Clouds
In this section, you will create animated shadows of the clouds on 
the ground.

1.	 Select the FastNoise1 tool tile in the Flow area and then press 
CTRL+C. Next, click on the empty space of the Flow area to deselect the FastNoise1 
tool tile and then press CTRL+V; the FastNoise1_1 tool is inserted in the Flow area.

2.	 Click on the red output node of the FastNoise1_1 tool and then drag the cursor to the 
red output node of the Merge1 tool; the Merge2 tool is inserted in the Flow area and a 
connection between the FastNoise1_1, Merge1, and Merge2 tools is established.

3.	 Press 2; the output of the Merge2 tool is displayed in the right Display View.

4.	 Select the FastNoise1_1 tool tile in the Flow area and then choose Tools > Transform > 
DVE from the menubar; the DVE2 tool is inserted between the FastNoise1_1 and Merge2 
tools in the Flow area, as shown in Figure 3-18.

5.	 In the DVE2 tool control window, enter the values of the parameters as follows:

	 Center
	 Y: -0.17
	
	 Z Move: 0.68		  Z Pivot: 0.0623		  X Rotation: -52
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Figure 3-18  The DVE2 tool inserted between the FastNoise1_1 and 
Merge2 tools

6.	 Select the Merge2 tool tile from the Flow area and select Soft Light from the Apply Mode 
drop-down list in the control window.

	 Now, save the composition with the name c03tut3 at the location Documents > Fusion_6.3 > 
	 c03_tut > c03_tut_03. Next, you need to render the composition. For rendering, refer to 

Tutorial 1 of Chapter 2. The output of the composition is shown in Figure 3-14. You can 
also view the final render of the composition by downloading the c03_fusion_6.3_rndr.zip 
from http://www.cadcim.com. The path of the file is mentioned at the beginning of the 
chapter. 

 Tutorial 4 
In this tutorial, you will create the plasma effect. The final output of the composition at frame 
160  is shown in Figure 3-19.                                                                     (Expected time: 20 min)

Figure 3-19  The final output of the composition at frame 160
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The following steps are required to complete this tutorial:

a.	 Set the frame format.
b.	 Create the plasma effect.

Setting the Frame Format 
In this section, you will specify the frame format settings.

1.	 Choose File > New from the menubar; a new composition is displayed in the Fusion 
screen.

2.	 Choose File > Preferences from the menubar; the Preferences dialog box is displayed.
 
3.	 In this dialog box, select Frame Format from the Composition# preferences tree; various
	 frame format settings are displayed on the right of the Preferences dialog box. Make sure 

2K Full Aperture (Super 35) is selected in the Default format drop-down list and then 
choose the Save button to save the changes made. 

4.	 In the Time Ruler area, enter 300 in the Render End Time edit box.

Creating the Plasma Effect
In this section, you will create plasma effect using the Plasma tool.

1.	 Choose Tools > Creator > Plasma from the menubar; the Plasma1 tool is inserted in 
the Flow area. 

2.	 Press 1; the output of the Plasma1 tool is displayed in the left Display view. Next,	
choose the Fit button from the left Display View toolbar to fit the image in the left Display 
View.

 
3.	 Choose the Show Checker Underlay button in the left Display View toolbar to view

the output without transparency in the left Display View.

4.	 Select the Plasma1 tool tile from the Flow area, if it is not already selected. Now, animate 
the  Scale control in the Circles tab to create the keyframes by using the values given in 
the table below:

Frame Scale

0 10

50 10

100 8.3

150 6.4

200 4.5

250 2.6

300 0.8
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5.	 Animate the  Scale control in the Circle1 and Circle3 areas in the Circles tab by using 
the values given next.

Frame Circle 1- Scale Circle 3 - Scale

0 0.26 4.85

50 0.26 4.85

100 0.34 4.82

150 0.45 4.85

200 0.56 4.85

250 0.67 4.85

300 0.72 4.85

6.	 In the Circle4 area, make sure that the Type 2 button is chosen and then enter 0.27 in 
the Scale edit box.  

	 The final output of the Plasma1 tool at frame 280 is shown in Figure 3-20.

Figure 3-20  The final output of the Plasma1 tool at frame 280

	 Now, save the composition with the name c03tut4 at the location Documents > Fusion_6.3 >
	 c03_tut > c03_tut_04. Next, you need to render the composition. For rendering, refer 

to Tutorial 1 of Chapter 2. The output of the composition at frame 280 is shown in 
Figure 3-20. You can also view the final render of the composition by downloading 
the c03_fusion_6.3_rndr.zip from http://www.cadcim.com. The path of the file is mentioned 
at the beginning of the chapter.
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 Tutorial 5  
In this tutorial, you will create a daylight time-lapse simulation by using the real-world data. 
The final output of the composition at frame 20 is shown in Figure 3-21.

(Expected time: 20 min)

Figure 3-21 The final output of the composition at frame 20

The following steps are required to complete this tutorial:

a.	 Set the frame format.
b.	 Download and import the image.
c.	 Create the daylight time-lapse simulation.
d.	 Create the reflection of sky.

Setting the Frame Format
In this section, you will specify the frame format settings.

1.	 Choose File > New from the menubar; a new composition is displayed in the Fusion 
screen.

2.	 Choose File > Preferences from the menubar; the Preferences dialog box is displayed.
 
3.	 In this dialog box, select Frame Format from the Composition# preferences tree; various
	 frame format settings are displayed on the right of the Preferences dialog box. Make 

sure 2K Full Aperture (Super 35) is selected in the Default format drop-down list and 	
then choose the Save button to save the changes made.

Downloading and Importing the Image
In this section, you will download image and import it to the composition.

1.	 Copy the seabridge.tga file that you have created in Tutorial 3 at the location /Documents/
Fusion_6.3/c03_tut/c03_tut_05/Media_Files.
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2.	 Choose the LD button from the toolbar; the Open File dialog box is displayed. In the 
dialog box, choose Documents > Fusion_6.3 > c03_tut > c03_tut_05 > Media_Files > 
seabridge.tga and then choose the Open button; the Loader1 tool is inserted in the 
Flow area. In the Loader1 tool control window, choose the Import tab and then select 
the Post-Multiply by Alpha check box.

3.	 Press 1; the output of the Loader1 tool is displayed in the left Display View. Next, choose 
the Fit button from the left Display View toolbar to fit the image in the left Display View.

4.	 To hide the transparency of the image, choose the Show Checker Underlay button 
from the left Display View toolbar.

	 The output of the Loader1 tool is displayed in the left Display View, as shown in Figure 3-22.

Figure 3-22  The output of the Loader1 tool

Creating the Daylight Time-lapse Simulation
In this section, you will create a daylight simulation based on the real-word data.

1.	 Make sure the Loader1 tool is selected in the Flow area and then choose Tools > 
Transform > Resize from the menubar; the Resize1 tool is inserted in the Flow area and 
a connection is established between the Loader1 and Resize1 tools.

2.	 Make sure the Resize1 tool is selected in the Flow area and then choose Tools > 
Creator > DaySky from the menubar; the DaySky1 and Merge1 tools are inserted in the 
Flow area and a connection is established between the Resize1, Merge1, and DaySky1 
tools, as shown in Figure 3-23.

3.	 Make sure the Merge1 tool tile is selected in the Flow area and then press 2; the output of 
the Merge1 tool is displayed in the right Display View. Next, choose the Fit button from 
the right Display View toolbar to fit the image in the right Display View.
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Figure 3-23  The DaySky1 tool inserted in the Flow area

4.	 Select the DaySky1 tool tile in the Flow area and press 1; the output of the DaySky1 tool 
is displayed in the right Display View.

5.	 In the control window of the DaySky1 tool, choose the Image tab and then enter 1556 
in the Height edit box. 

6.	 Select the Merge1 tool tile in the Flow area and then press CTRL+W to swap the 
background and foreground inputs of the Merge1 tool. After entering the values, the 
output of the DaySky1 and Merge1 tools is displayed, as shown in Figure 3-24.

Figure 3-24  The output of the DaySky1 and Merge1 tools

7.	 Make sure the DaySky1 tool tile is selected in the Flow area and then choose Tools > 
Transform > Transform from the menubar; the Transform1 tool is inserted in the Flow 
area and a connection is established between the DaySky1, Transform1, and Merge1 
tools.

8.	 In the Transform1 tool control window, enter 1.03 in the Y edit box of the Center control; 
the horizon line meets with the sea.

9. 	 Select the DaySky1 tool tile from the Flow area. Next, choose the Controls tab and then 
select 5 from the Day drop-down list. Similarly, select August from the Month drop-down 
list in the Date and Time area.

10.	 In the Location area, enter 25.47 and 80.7 in the Latitude and Longitude edit boxes, 
respectively. 
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	 The latitude and longitude used here are of Miami beach.

11.	 Choose the Advanced tab and enter 1.1 in the Brightness edit box of the Horizon area.
	
	 Next, you will animate the Time control.

12.	 In the Time Ruler area, enter 0 and 96 in the Render Start Time and Render End Time 
edit boxes, respectively.

13.	 Choose the Controls tab and then animate the Time control in the Date and Time area 
to create the keyframe by using the values given in the table below:

Frame Time

0 5

96 17

Creating the Reflection of the Sky
In this section, you will create reflection of the sky.

1.	 Click on the empty space of the Flow area and then choose Tools > Transform > DVE 
from the menubar; the DVE1 tool is inserted in the Flow area.

2.	 Click on the red output node of the Transform1 tool and then drag the cursor to the 
orange node of the DVE1 tool; a connection between the Transform1 and DVE1 tools is 
established.

3.	 Click on the red output node of the DVE1 tool and then drag the cursor to the red output 
node of the Merge1 tool; the Merge2 tool is inserted in the Flow area and a connection 
between the Merge1, Merge2, and DVE1 tools is established.

4.	 Press 2; the output of the Merge2 tool is displayed in the right Display View.

5.	 Select the DVE1 tool tile from the Flow area. In the DVE1 tool control window, specify 
the parameters as follows:

	 Center
	 Y: 0.57

	 Z Move: 1.05		  X Rotation: 144.76		  Perspective: 0.5

6.	 Select the Merge2 tool tile from the Flow area and select Hue from the Apply Mode 
drop-down list and then enter 0.67 in the Blend edit box. Figure 3-25 displays the final 
output of the composition at frame 20.
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	 Now, save the composition with the name c03tut5 at the location Documents > Fusion_6.3 > 
c03_tut > c03_tut_05. Next, you need to render the composition. For rendering, refer 
to Tutorial 1 of Chapter 2. The output of the composition at frame 20 is shown in 
Figure 3-21. You can also view the final render of the composition by downloading the 
c03_fusion_6.3_rndr.zip from http://www.cadcim.com. The path of the file is mentioned at 
the beginning of the chapter.

Figure 3-25 The final output of the composition at frame 20

 

	

 Self-Evaluation Test 

Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following combination of shortcut keys is used to copy the tools?
		  	
		  (a) CTRL+Z			   (b) CTRL+C
		  (c) CTRL+Y			   (d) CTRL+X

2.	 Which of the following keys is used to play the animation?

		  (a) ENTER			   (b) SHIFT
		  (c) CTRL			   (d) SPACEBAR

3.	 The __________ tools category is used to create new backgrounds, noise, and many more 
effects in the composition.
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4.	 __________ is the process of giving motion to an object.

5.	 The __________ tool is used to rotate, scale, and move the objects in a scene.

6.	 You can choose the Xf button from the toolbar to transform elements in the composition. 
(T/F)

 Review Questions 
Answer the following questions:

1.	 To create a shadow of the text, you have to choose the _________ button from the Shading 
tab and then select the _________ check box.

2.   	The _________ tool is used to create circular shapes, thereby generating a plasma like 
effect. 

3.	 The __________ tool is used to create a procedural sky pattern based on a specific time 
and location on earth.

4.	 To play the animation forward or backward frame by frame, press the _________ or 
__________ key.

5.	 Perspective can be added to the input image by using the _________ tool.

Answers to Self-Evaluation Test
1. b, 2. d, 3. Creator, 4. Animation, 5. Transform, 6. T


