
Template• 

Plot Size• 

Layout• 

Template Files (*.dwt)• 

LTSCALE• 

Viewport• 

Drawing Scale• 

DIMSCALE• 

STARTUP • 

TEXTSIZE• 

 KEY TERMS

 CHAPTER OBJECTIVES
After completing this chapter, you will be able to:
• Create template drawings.
• Load template drawings using dialog boxes and the Command line.
• Do an initial drawing setup.
• Customize drawings with layers and dimensioning specifi cations.
• Customize drawings with layouts, viewports, and paper space.

Chapter 1
Template Drawings
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 CREATING  TEMPLATE DRAWINGS
One way to customize AutoCAD is to create template drawings that contain initial drawing 
setup information and if desired, visible objects and text. When the user starts a new drawing, 
the settings associated with the template drawing are automatically loaded. If you start a new 
drawing from the scratch, AutoCAD loads default setup values. For example, the default limits 
are (0.0,0.0), (12.0,9.0) and the default layer is 0 with white color and a continuous linetype. 
Generally, these default parameters need to be reset before generating a drawing on the computer 
using AutoCAD. A considerable amount of time is required to set up the layers, colors, linetypes, 
lineweights, limits, snaps, units, text height, dimensioning variables, and other parameters. 
Sometimes, border lines and a title block may also be needed.

In production drawings, most of the drawing setup values remain the same. For example, the 
company title block, border, layers, linetypes, dimension variables, text height, LTSCALE, and 
other drawing setup values do not change. You will save considerable time if you save these values 
and reload them when starting a new drawing. You can do this by creating template drawings that 
contain the initial drawing setup information confi gured according to the company specifi cations. 
They can also contain a border, title block, tolerance table, block defi nitions, fl oating viewports in 
the paper space, and perhaps some notes and instructions that are common to all drawings.

 STANDARD TEMPLATE DRAWINGS
AutoCAD comes with standard template drawings like Acad.dwt, Acadiso.dwt, Acad3D.dwt, 
Acadiso3D.dwt, Acad -named plot styles.dwt, AcadISO -named plot styles.dwt, and so on. The iso template 
drawings are based on the drawing standards developed by ISO (International Organization for 
Standardization). When you start a new drawing with STARTUP system variable set to 1, the 
Create New Drawing dialog box will be displayed. To load the template drawing, choose the 
Use a Template button; the list of standard template drawings is displayed. From this list, you 
can select any template drawing according to your requirements. If you want to start a drawing 
with the default settings, select the Start from Scratch button in the Create New Drawing dialog 
box. The following are some of the system variables, with the default values that are assigned 
to the new drawing.

System Variable Name  Default Value
CHAMFERA  0.0000
CHAMFERB  0.0000
COLOR  Bylayer
DIMALT  OFF
DIMALTD  2
DIMALTF  25.4000
DIMPOST  None
DIMASO  ON
DIMASZ  0.1800
FILLETRAD  0.0000
GRID  0.5000
GRIDMODE  0
ISOPLANE  Top
LIMMIN  0.0000,0.0000
LIMMAX  12.0000,9.0000
LTSCALE  1.0
MIRRTEXT  0 (Text not mirrored like other objects)
TILEMODE  1 (OFF)

EXAMPLE 1               Advance Setup Wizard
Create a drawing template using the  Advanced Setup wizard displayed on  invoking the Use a 
Wizard button. You can use the following specifi cations and save it with the name proto1.dwt.
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Units Engineering with precision 0’-0.00”
Angle Decimal degrees with precision 0
Angle Direction Counterclockwise
Area 144’x96’ 

Step 1: Setting the  STARTUP system variable 
Set the value of the STARTUP system variable to 1 to show the Startup dialog box. To do so, 
start AutoCAD using the default template. Enter STARTUP at the Command prompt; you will 
be prompted to enter the new value for startup. Enter 1 in the command prompt; the STARTUP 
system variable is set to 1. Next, choose the New tool from the Quick Access toolbar to display 
the Create New Drawing dialog box. Choose the Use a Wizard button and choose the Advanced 
Setup option, as shown in Figure 1-1. Choose OK. The Units page of the Advanced Setup dialog 
box is displayed, as shown in Figure 1-2.

Figure 1-1  The Advanced Setup wizard in the Create New 
Drawing dialog box

Step 2: Setting the units of the drawing fi le 
Select the Engineering radio button. Select 0’-0.00” precision from the Precision drop-down list 
if it is not selected by default, refer to Figure 1-2, and then choose the Next button; the Angle 
page of the  Advanced Setup dialog box is displayed.

Figure 1-2  The Units page of the  Advanced Setup dialog box
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Step 3: Setting the angle measurement system 
In the Angle page, select the  Decimal Degrees radio button and select 0 from the Precision 
drop-down list, as shown in Figure 1-3. Choose the Next button; the  Angle Measure page of 
the Advanced Setup dialog box is displayed.

Figure 1-3  The Angle page of the Advanced Setup dialog box

 

Step 4: Setting the horizontal axis for angle measurement 
In the Angle Measure page, select the East radio button. Choose the Next button to display 
the  Angle Direction page.

Step 5: Setting the angle measurement direction and drawing area
Select the Counter-Clockwise radio button and then choose the Next button. The Area page 
is displayed. Specify the area as 144’ and 96’ by entering the value of the width and length as 
144’ and 96’ in the Width and Length edit boxes and then choose the Finish button. Use the 
All option of the ZOOM command to display new limits on the screen. 

Step 6: Saving the drawing as template fi le
Now, save the drawing as proto1.dwt using the Save tool from the Quick Access toolbar. You 
need to select AutoCAD Drawing Template (*dwt) from the Files of type drop-down list and 
enter proto1 in the File name edit box in the Save Drawing As dialog box. Next, choose the 
Save button; the Template Options dialog box will be displayed on the screen, as shown in 
Figure 1-4. Enter the description about the template in the Description edit box and choose 
the OK button. Now, the drawing will be saved as proto1.dwt on the default drive.  

Note
To customize only the units and area, you can use the Quick Setup option in the Create New 
Drawing dialog box.
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Figure 1-4  The Template Options dialog box

EXAMPLE 2          Start from Scratch Option
Create a drawing template using the following specifi cations. The template should be saved 
with the name proto2.dwt.

Limits                                18.0,12.0
Snap                                  0.25
Grid                                   0.50
Text height                        0.125
Units                                 3 digits to the right of decimal point

 Decimal degrees
 2 digits to the right of decimal point
 0 angle along positive X axis (east)
 Angle positive if measured counterclockwise

Step 1: Starting a new drawing
Start AutoCAD and choose Start from Scratch button from the Create New Drawing dialog box. 
From the Default Settings area, select the Imperial (feet and inches) radio button, as shown in 
Figure 1-5. Choose OK to open a new fi le.

Figure 1-5  The Start from Scratch button of the  Create 
New Drawing dialog box
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Step 2: Setting limits, snap, grid, and text size
The LIMITS command can be invoked by entering LIMITS at the Command prompt.

Command: LIMITS
Reset Model space limits:
Specify lower left corner or [ON/OFF] <0.0000,0.0000>: �
Specify upper right corner <12.0000,9.0000>: 18,12

After setting the limits, the next step is to expand the drawing display area. Use the ZOOM 
command with the All option to display new limits on the screen.

Now, right-click on the Snap Mode or Grid Display button in the Status Bar to display a shortcut 
menu. Choose the Settings option from the shortcut menu to display the Drafting Settings 
dialog box. Choose the Snap and Grid tab. Enter 0.25 and 0.25 in the Snap X spacing and 
Snap Y spacing edit boxes in Snap Spacing area, respectively. Enter 0.5 and 0.5 in the Grid X 
spacing and Grid Y spacing edit boxes, respectively. Then, choose OK. 

Note
You can also use SNAP and GRID commands to set these values.

The size of the text can be changed by entering TEXTSIZE at the Command prompt.

Command: TEXTSIZE
Enter new value for TEXTSIZE <0.2000>: 0.125

Step 3: Setting units
Choose the Units tool from Application Menu > Drawing Utilities > Units or enter UNITS at 
the Command prompt to invoke the Drawing Units dialog box, as shown in Figure 1-6. In the 
Length area, select Decimal from the Type drop-down list and select 0.000 from the Precision 
drop-down list. In the Angle area, select Decimal Degrees from the Type drop-down list and 
0.00 from the Precision drop-down list. Also make sure the Clockwise check box in the Angle 
area is not selected.

Figure 1-6  The  Drawing Units dialog box
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Choose the Direction button from the Drawing Units dialog box to display the  Direction Control 
dialog box (Figure 1-7) and then select the East radio button. Exit both the dialog boxes.

Figure 1-7   The Direction Control dialog box

Step 4: Saving the drawing as template fi le
Now, save the drawing as proto2.dwt using the Save tool from the Quick Access toolbar. You need 
to select AutoCAD Drawing Template (*dwt) from the Files of type drop-down list and enter 
proto2 in the File name edit box in the Save Drawing As dialog box. Next, choose the Save 
button; the Template Options dialog box will be displayed on the screen. Enter the description 
about the template in the Description edit box and choose the OK button. The drawing will be 
saved as proto2.dwt on the default drive. You can also save this drawing to some other location by 
specifying other location from the Save in drop-down list of the Save Drawing As dialog box.

 LOADING A TEMPLATE DRAWING
You can use the template drawing to start a new drawing fi le. To use the preset values of the 
template drawing, start AutoCAD or choose the New tool from the Quick Access toolbar. The 
dialog box that appears will depend on whether you have set the STARTUP system variable to 
1 or 0. If you have set this value as 1, the  Create New Drawing dialog box will appear. Choose 
the Use a Template option. All templates that are saved in the default Template directory will 
be shown in the Select a Template list box, see Figure 1-8. If you have saved the template in any 
other location, choose the Browse button. The Select a template fi le dialog box will be displayed. 
You can use this dialog box to browse the directory in which the template fi le is saved.

Figure 1-8  Default templates in the Create New Drawing dialog box
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If you have set the STARTUP system variable to 0, the  Select template dialog box appears 
when you choose the New tool. This dialog box also displays the default Template folder and 
all template fi les saved in it, see Figure 1-9. You can use this dialog box to select the template 
fi le that you want to open.

Figure 1-9  The Select template dialog box that appears while starting a new drawing 
fi le, when the value of STARTUP variable is set to 0

Using any of the previously mentioned dialog boxes, select the proto1.dwt template drawing. 
AutoCAD will start a new drawing that will have the same setup as that of the template drawing 
proto1.dwt.

You can have several template drawings, each with a different setup. For example, PROTOB for 
a 18” X 12” drawing, PROTOC for a 24” X 18” drawing. Each template drawing can be created 
according to user-defi ned specifi cations. You can then load any of these template drawings, as 
discussed previously.

    CUSTOMIZING DRAWINGS WITH LAYERS AND 
DIMENSIONING SPECIFICATIONS
Most production drawings need multiple layers for different groups of objects. In addition to 
layers, it is a good practice to assign different colors to different layers to control the line width 
at the time of plotting. You can generate a template drawing that contains the desired number 
of layers with linetypes and colors according to your company specifi cations. You can then use 
this template drawing to make a new drawing. The next example illustrates the procedure used 
for customizing a drawing with layers, linetypes, and colors.

EXAMPLE 3     Template with Title Block & Layers
Create a template drawing proto3.dwt that has a border and the company’s title block, as shown 
in Figure 1-10. 
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Figure 1-10  The template drawing for Example 3 

This template drawing will have the following initial drawing setup:

Limits 48.0,36.0
Text height 0.25
Border line lineweight 0.012”
Ltscale 4.0

DIMENSIONS
Overall dimension scale factor 4.0
Dimension text above the extension line                                                                                                                                       
Dimension text aligned with dimension line

LAYERS
Layer Name Line Type  Color
0  Continuous  White
OBJ Continuous  Red
CEN Center  Yellow
HID Hidden  Blue
DIM Continuous  Green
BOR Continuous  Magenta

Step 1: Setting limits, text size, polyline width, polyline, and linetype scaling
Start a new drawing with default parameters by selecting the Start from Scratch option in the 
Create New Drawings dialog box. In the new drawing fi le, use the AutoCAD commands to set 
up the values as given for this example. Also, draw a border and a title block, as shown in Figure 
1-10. In this fi gure, the hidden lines indicate drawing limits. The border lines are 1.0 units inside 
the drawing limits. For border lines, increase the lineweight to a value of 0.012”. 

Use the following procedure to produce the prototype drawing for Example 3.

1. Invoke the  LIMITS command by entering LIMITS at the Command prompt. The prompt 
sequence is given next.

Command: LIMITS
Reset Model space limits: 



1-10 Customizing AutoCAD 2013

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Specify lower left corner or [ON/OFF] <0.0000,0.0000>: �
Specify upper right corner <12.0000,9.0000>: 48,36

2. Increase the drawing display area by choosing the All option of the ZOOM command.

3. Enter TEXTSIZE at the Command prompt to change the text size.

Command: TEXTSIZE
Enter new value for TEXTSIZE <0.2000>: 0.25

4. Next, draw the border using the RECTANGLE tool. The prompt sequence to draw the 
rectangle is:

Command: Choose the RECTANGLE tool from the Draw panel
Specify fi rst corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: 1.0,1.0
Specify other corner point or [Area/Dimensions/Rotation]: 47.0,35.0

5. Now, select the rectangle and change its lineweight to 0.012”. Make sure that the Show/
Hide Lineweight button is chosen in the Status Bar.

6. Enter LTSCALE at the Command prompt to change the linetype scale.

Command: LTSCALE
Enter new linetype scale factor<Current>: 4.0

Step 2: Setting dimensioning parameters
You can use the  Dimension Style Manager dialog box to set the dimension variables. Click the 
inclined arrow displayed on the Dimensions panel title bar in the Annotate tab; the Dimension 
Style Manager dialog box will be displayed, as shown in Figure 1-11.

Figure 1-11  The  Dimension Style Manager dialog box

 

You can also invoke this dialog box by entering DIMSTYLE at the Command prompt. Choose 
the New button from the Dimension Style Manager dialog box; the Create New Dimension 
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Style dialog box will be displayed. Specify the new style name as MYDIM1 in the New Style 
Name edit box, as shown in the Figure 1-12 and then choose the Continue button. The New 
Dimension Style:MYDIM1 dialog box is displayed.

Figure 1-12  The  Create New Dimension Style 
dialog box 

Specifying Overall dimension scale factor
To specify a dimension scale factor, choose the Fit tab of the New Dimension Style: MYDIM1 
dialog box. Set the value in the Use overall scale of as 4 in the Scale for dimension features 
area, as shown in Figure 1-13.

Figure 1-13  The Fit tab of the New Dimension Style: MYDIM1 dialog box

Placing the dimension text over the dimension line
In the Fit tab of the New Dimension Style: MYDIM1 dialog box. Select the Over dimension 
line, with leader radio button from the  Text placement area.
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Dimensioning text aligned with the dimension line
In the Text Alignment area of the Text tab of the New Dimension Style: MYDIM1 dialog box, 
select the Aligned with dimension line radio button and then choose the OK button.

Setting the symbols and arrows
From the Arrowheads area of the Symbols and Arrows tab in the  New Dimension Style: 
MYDIM1 dialog box, you can select different types of arrows from the First, Second, and Leader 
drop-down lists. You can also set the size of the arrows in the Arrow size spinner.  

Setting the dimension line type
The options in the Dimension lines area and Extension lines area of the Lines tab in the New 
Dimension Style: MYDIM1 dialog box are used for selecting different types of dimension 
lines.

Setting the  new dimension style to current
A new dimension style with the name MYDIM1 is shown in the Styles area of the Dimension 
Style Manager dialog box. Select this dimension style and then choose the Set Current button 
to make it the current dimension style. Choose the Close button to exit this dialog box.

Step 3:  Setting layers
Choose the Layer Properties tool from the Layers panel or choose the Layer tool from the 
Format  menu bar to invoke the Layer Properties Manager dialog box. Choose the New Layer 
button in the Layer Properties Manager dialog box and rename Layer1 as OBJ. Choose the 
color swatch of the OBJ layer to display the Select Color dialog box. Select the Red color and 
choose OK; the red color is assigned to the OBJ layer. Again, choose the New Layer button in 
the  Layer Properties Manager dialog box and rename the Layer1 as CEN. Choose the linetype 
swatch to display the Select Linetype dialog box. 

If different linetypes are not already loaded, choose the Load button to display the Load or 
Reload Linetypes dialog box. Select the CENTER linetype from the Available Linetypes area 
and choose OK; the Select Linetype dialog box will reappear. Select the CENTER linetype 
from the Loaded linetypes area and choose OK. Choose the color swatch to display the Select 
Color dialog box. Select the Yellow color and choose OK; the color yellow and linetype center 
will be assigned to the layer CEN. 

Similarly, different linetypes and different colors can be set for different layers mentioned in 
the statement of this example, as shown in Figure 1-14.

Figure 1-14  The   Layer Properties Manager dialog box

Step 4: Adding title block 
Next, add the title block and the text, as shown in Figure 1-10. After completing the drawing, save 
it as proto3.dwt. You have created a template drawing (proto3) that contains all the information 
given in Example 3.
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 CUSTOMIZING A DRAWING WITH  LAYOUT
The Layout (paper space) provides a convenient way to plot multiple views of a 
three-dimensional (3D) drawing or multiple views of a regular two-dimensional (2D) drawing. 
It takes quite some time to set up the viewports in the model space with different vpoints and 
scale factors. You can create prototype drawings that contain predefi ned viewport settings, with 
vpoint and the other desired information. If you create a new drawing or insert a drawing, the 
views are automatically generated. The following example illustrates the procedure for generating 
a prototype drawing with paper space and model space viewports:

EXAMPLE 4         Template with Layouts
Create a drawing template, as shown in Figure 1-15, with four views in Layout3 (Paper space) that 
display front, top, side, and 3D views of the object. The plot size is 10.5 by 8 inches. The plot 
scale is 0.5 or 1/2” = 1”. The paper space viewports should have the following vpoint settings:

 Viewports Vpoint View
 Top right 1,-1,1 3D view
 Top left 0,0,1 Top view
 Lower right 1,0,0 Right side view
 Lower left 0,-1,0 Front view

Figure 1-15  Paper space with four viewports

Start AutoCAD and create a new drawing. Use the following commands and options to set 
various parameters:

Step 1: Creating a new layout
First, you need to create a new layout using the LAYOUT command. You can also choose New 
Layout tool from the Quick View Layouts panel which is available on choosing the Quick View 
Layouts button in the Status Bar. A new layout is automatically created with the default name. 
Alternatively, you can also use the LAYOUT command to create a new layout. The Command 
prompt that is displayed is given next.

Command: LAYOUT
Enter layout option [Copy/Delete/New/Template/Rename/SAveas/Set/?] <set>: N
Enter new Layout name <Layout3>: �
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Step 2: Specifying the page setup for the new layout
Next, choose the new layout (Layout3) tab. The new layout (Layout3) will be displayed with 
the default viewport. Delete this existing viewport. Invoke the Page Setup Manager dialog box 
from the shortcut menu that will by displayed when you right click on the Quick View Layouts 
button in the Status Bar and choose the Modify button to modify the default page setup. In the 
Page Setup - Layout3 dialog box, select the required printer from the Printer/plotter area. In 
this example, HP LaserJet 4000 has been used. 

Now, from the Paper size area, select the paper size that is supported by the selected plotting 
device. In this example, the paper size is A4. Choose the OK button to accept the settings and 
return to the Page Setup Manager dialog box. Choose the Close button to close the  Page Setup 
Manager dialog box.

Step 3: Creating new layer for the viewports object
Next, you need to set up a layer with the name VIEW for viewports object and assign it green 
color. Invoke the Layer Properties Manager dialog box. Choose the New Layer button and 
rename the Layer1 as VIEW. Choose the color swatch of the VIEW layer to display the Select 
Color dialog box. Select the color Green and choose the OK button. This color will be assigned 
to View layer. Also, make the VIEW layer current and then exit the Layer Properties Manager 
dialog box.

Step 4: Creating viewports
To create four viewports, choose the 4 Viewports tool from View > Viewports in the menu bar 
or enter MVIEW command at the Command prompt. The following is the prompt sequence 
when you invoke the  MVIEW command.

Command: Choose the 4Viewports tool from View > Viewports in the menu bar
Specify corner of viewport or
[ON/OFF/Fit/Shadeplot/Lock/Object/Polygonal/Restore/LAyer/2/3/4] <Fit>: _4
Specify fi rst corner or [Fit] <Fit>: 0.25,0.25
Specify opposite corner: 10.25,7.75

Step 5: Setting the required viewpoint in all layers  
Choose the PAPER button in the Status Bar to activate the model space or enter  MSPACE at 
the Command prompt.

Command: MSPACE (or MS)

Make the lower left viewport active by clicking on it. Next, you need to change the viewpoints of 
different paper space viewports using the VPOINT command. To invoke this command, choose 
the Viewpoint tool from View > 3D Views in the menu bar or enter VPOINT at the Command 
prompt. The viewpoint values for different viewports are given in the statement of Example 4. To 
set the view point for the lower left viewport the Command prompt sequence is given next. 

Command: Choose the Viewpoint tool from View > 3D Views in the menu bar
Current view direction:  VIEWDIR= 0.0000,0.0000,1.0000
Specify a view point or [Rotate] <display compass and tripod>: 0,-1,0

Similarly, use the VPOINT command to set the viewpoint of the other viewports.

Note
You can also use the ViewCube or the SteeringWheel to orient the view in any viewport.
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Make the top left viewport active by selecting a point in the viewport and then use the ZOOM
command to specify the paper space scale factor to 0.5. The ZOOM command can be invoked 
by choosing View > Zoom > Scale from the Application Menu or by entering ZOOM at the 
Command prompt. The Command prompt sequence is given next.

Command: ZOOM
Specify corner of window, enter a scale factor (nX or nXP), or
[All/Center/Dynamic/Extents/Previous/Scale/Window/Object] <real time>: 0.5XP

Now, make the next viewport active and specify the zoom scale factor. Do the same for the 
remaining viewports.

Step 6:  Creating border line
Use the MODEL button in the Status Bar to change to paper space and then set a new layer 
PBORDER with yellow color. Make the PBORDER layer current, draw a border, and if needed, a 
title block using the PLINE command. You can also change to paper space by entering   PSPACE 
at the Command prompt.

The PLINE command can be invoked by choosing the Polyline tool from the Draw menu or 
by choosing the Polyline tool from the Draw panel. The  PLINE command can also be invoked 
by entering PLINE at the Command prompt. While specifying the coordinate values for the 
PLINE command, make sure that the Dynamic Input button is turned off in the Status Bar.

Command: Choose the Polyline tool from the Draw panel
Specify start point: 0,0
Current line-width is 0.0000
Specify next point or [Arc/Halfwidth/Length/Undo/Width]: 0,8.0
Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: 10.5,8.0
Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: 10.5,0
Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: C

Step 7: Saving and testing the template fi le
The last step is to choose the Model tab (or change the  TILEMODE to 1), if not already active 
and save the prototype drawing as template. To test the layout that you just created, make the 
3D drawing, as shown in Figure 1-19 or make any 3D object. Switch to Layout 3 tab; you will fi nd 
four different views of the object (Figure 1-16). If the object views do not appear in the viewports, 
use the PAN commands to position the views in the viewports. You can freeze the VIEW layer so 
that the viewports do not appear on the drawing. You can plot this drawing from the Layout3 
with a plot scale factor of 1:1 and the size of the plot will be exactly as specifi ed.

Figure 1-16  Four views of a 3D object in paper space
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CUSTOMIZING DRAWINGS WITH VIEWPORTS
In certain applications, you may need multiple model space viewport confi gurations to display 
different views of an object. This involves setting up the desired viewports and then changing the 
viewpoint for different viewports. You can create a prototype drawing that contains a required 
number of viewports and the viewpoint information. If you insert a 3D object in one of the 
viewports of the prototype drawing, you will automatically get different views of the object without 
setting viewports or viewpoints. The following example illustrates the procedure for creating a 
prototype drawing with a standard number (four) of viewports and viewpoints.

EXAMPLE 5       Template with Viewports
Create a prototype drawing with four viewports, as shown in Figure 1-17. The viewports should 
have the following viewpoints:

 Viewports Vpoint View
 Top right 1,-1,1 3D view
 Top left 0,0,1 Top view
 Lower right 1,0,0 Right side view
 Lower left 0,-1,0 Front view

Figure 1-17  Viewports with different viewpoints

Step 1 
Start AutoCAD and create a new drawing from scratch.

Step 2
Setting viewports in Model tab
Viewports and corresponding viewpoints can be set with the  VPORTS command. You can also 
choose the New Viewports tool from View > Viewports in the menu bar or choose the Named 
tool from View > Model Viewports panel to display the Viewports dialog box, as shown in 
Figure 1-18. Select Four: Equal from the Standard viewports area. In the Preview area four 
equal viewports are displayed. Select 3D from the Setup drop-down list. The four viewports 
with the different viewpoints will be displayed in the Preview area as Top, Front, Right and SE 
Isometric. Top represents the viewpoints as (0,0,1), Front represents the viewpoints as (0,-1,0), 
Right represents the viewpoints as (1,0,0) and SE Isometric, represents the viewpoints as (1,-1,1) 
respectively. Choose the OK button. Save the drawing as proto5.dwt. You can also set the type 
of visible style of the model in each individual viewports by selecting each viewport and setting 
the visible style in the Visible Style drop-down list of the Preview area.
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Viewports and viewpoints can also be set by entering - VPORTS and  VPOINT at the Command 
prompt, respectively.

Figure 1-18  The   Viewports dialog box

Step 3
Start a new drawing and draw the 3D tapered block, as shown in Figure 1-19.

Figure 1-19  3D tapered block

Step 4 
Again, start a new drawing, TEST, using the prototype drawing proto5.dwt. Make the top right 
viewport current and then insert or create a drawing, refer to Figure 1-19. Four different views 
will be automatically displayed on the screen, as shown in Figure 1-20.

Note
The method of creating 3D models is discussed in Chapter 25 (Getting Started with 3D) of 
AutoCAD: A Problem-Solving Approach: 2013 and beyond textbook by Prof. Sham Tickoo.
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Figure 1-20  Different views of a 3D tapered block

  CUSTOMIZING DRAWINGS ACCORDING TO PLOT SIZE 
AND DRAWING SCALE
For controlling the plot area, it is recommended to use layouts. You can make the drawing of any 
size, use the layout to specify the sheet size, and then draw the border and title block. However, 
you can also plot a drawing in the model space and set up the system variables so that the plotted 
drawing is according to your specifi cations. You can generate a template drawing according to 
plot size and scale. For example, if the scale is 1/16” = 1’ and the drawing is to be plotted on a 
36” by 24” area, you can calculate drawing parameters like limits,  DIMSCALE, and  LTSCALE 
and save them in a template drawing. This will save considerable time in the initial drawing setup 
and provide uniformity in the drawings. The next example explains the procedure involved in 
customizing a drawing according to a certain plot size and scale. 

Note
You can also use the paper space to specify the paper size and scale.

EXAMPLE 6      Template with Plot Size and Drawing Scale
Create a drawing template (PROTO6) with the following specifi cations:

Plotted sheet size 36” by 24”   (Figure 1-21)
Scale 1/8” = 1.0’
Snap 3’
Grid 6’
Text height 1/4” on plotted drawing
Linetype scale Calculate
Dimscale factor Calculate
Units Architectural
 Precision, 16-denominator of the smallest fraction
 Angle in degrees/minutes/seconds
 Precision, 0d00’
 Direction control, base angle, east
 Angle positive, if measured counterclockwise
Border Border should be 1” inside the edges of the plotted drawing
 sheet, using PLINE 1/32” wide when plotted (Figure 1-21)
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Figure 1-21  Border of the template drawing

Step 1: Calculating limits, text height, linetype scale, dimension scale, and polyline 
width
In this example, you need to calculate some values before you set the parameters. The limits of 
the drawing depend on the plotted size of the drawing and its scale. Similarly, LTSCALE and 
DIMSCALE depend on the plot scale of the drawing. The following calculations explain the 
procedure for fi nding the values of limits, ltscale, dimscale, and text height.

Limits
 Given:
 Sheet size   36” x 24”
 Scale       1/8” = 1’
              or 1” = 8’

 Calculate:
 X Limit
 Y Limit
 Since sheet size is 36” x 24” and scale is 1/8”=1’
 Therefore, X Limit = 36 x 8’ = 288’
   Y Limit = 24 x 8’ = 192’

Text height
 Given:
 Text height when plotted = 1/4”
 Scale                        1/8” = 1’

 Calculate:
 Text height
 Since scale is 1/8” = 1’
                  or 1/8” = 12”
                   or   1” = 96”
 Therefore, scale factor = 96
            Text height  = 1/4” x 96
                                = 24” = 2’
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Linetype scale and dimension scale
 Known:
 Since scale is 1/8” = 1’
                  or 1/8” = 12”
                   or   1” = 96”

 Calculate:
 LTSCALE and DIMSCALE
 Since scale factor = 96
 Therefore, LTSCALE = Scale factor = 96
 Similarly, DIMSCALE = 96
 (All dimension variables, like DIMTXT and DIMASZ, will be multiplied by 96.)

Polyline Width
 Given:
 Scale is  1/8” = 1’

 Calculate:
 PLINE width
 Since scale is 1/8” = 1’
                  or    1” = 8’
                  or    1” = 96”

 Therefore,
 PLINE width = 1/32 x 96
                       = 3”

After calculating the parameters, use the following AutoCAD commands to set up the drawing and 
save the drawing as proto6.dwt.

Step 2: Setting units
Start a new drawing and enter UNITS at the Command prompt to display the  Drawing Units 
dialog box. Select Architectural from the Type drop-down list in the Length area. Select 
0’-01/16” from the Precision drop-down list. Make sure the Clockwise check box in the Angle 
area is not selected. Select Deg/Min/Sec from the Type drop-down list and select 0d00’ from 
the Precision drop-down list in the Angle area. Now, choose the Direction button to display 
the Direction Control dialog box. Select the East radio button, if it is not selected, in the Base 
Angle area and then choose the OK button twice to close both the dialog boxes. 

 
Step 3: Setting limits, snap and grid, textsize, linetype scale, dimension scale, 
dimension style and pline
To set limits, enter LIMITS at the Command prompt.

Command: LIMITS
Specify lower left corner or [ON/OFF] <0’-0”,0’-0”>:0,0
Specify upper right corner <1’-0”,0’-9”>: 288’,192’

Invoke the All option of the ZOOM command to increase the drawing display area.

Right-click on the  Snap Mode or  Grid Display button in the Status Bar to invoke the shortcut 
menu. In the shortcut menu, choose Settings to display the Drafting Settings dialog box. In 
this dialog box, enter 3’  in both the Snap X spacing and Snap Y spacing edit boxes. Similarly, 
enter 6’ in both the Grid X spacing and Grid Y spacing edit boxes. Then, choose OK.
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You can also set these values by entering  SNAP and  GRID at the Command prompt.

The size of the text can be changed by entering  TEXTSIZE at the Command prompt.

Command: TEXTSIZE
Enter new value for TEXTSIZE <current>: 2’  

To set the LTSCALE, choose the Other option from Home > Properties > Linetype drop-down 
list, or choose the Linetype option from the Format menu bar, or enter LINETYPE at the 
Command prompt; the Linetype Manager dialog box will be invoked. Choose the Show details 
button; the Linetype Manager dialog box will be expanded. Now, specify the Global scale factor 
as 96 in the Global scale factor edit box. Choose the OK button to accept the changes and exit 
the Linetype Manager dialog box. 
 
You can also change the scale of the linetype by entering LTSCALE at the Command prompt.

Choose the inclined arrow displayed on the Dimensions panel title bar from the Annotate 
tab to invoke the Dimension Style Manager dialog box, refer to Figure 1-11. Choose the New 
button from the Dimension Style Manager dialog box to invoke the Create New Dimension 
Style dialog box. Specify the new style name as MYDIM2 in the New Style Name edit box and 
then choose the Continue button. The New Dimension Style: MYDIM2 dialog box will be 
displayed. Choose the Fit tab and set the value in the Use overall scale of spinner to 96 in the 
Scale for dimension features area. Now, choose the OK button to display the Dimension Style 
Manager dialog box. Choose Close button to exit the dialog box.

You can invoke the PLINE command by choosing the Polyline tool from the Draw panel or 
entering PLINE at the Command prompt. While specifying the coordinate values for the PLINE 
command, make sure that the  Dynamic Input button is turned off in the Status Bar.

Command: Choose the Polyline tool from the Draw panel
Specify start point: 8’,8’
Current line-width is 0’-0”
Specify next point or [Arc/Halfwidth/Length/Undo/Width]: W
Specify starting width<0’-0”>: 3
Specify ending width<0’-3”>: �
Specify next point or [Arc/Halfwidth/Length/Undo/Width]: 280,0
Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: 0,184
Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: -280,0
Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: C

Now, save the drawing as proto6.dwt.

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1. The template drawings are saved in the __________ format.

2. To use a template fi le, select the __________ option in the Create New Drawing dialog 
box.

3. To start a drawing with the default setup, select the __________ option in the Create 
New Drawing dialog box.
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4. If the plot size is 36” x 24”, and the scale is 1/2” = 1’, then X Limit = __________ and Y 
Limit = __________.

5.  __________ command is used to set up a viewport in the paper space.

 Review Questions 
Answer the following questions:

1. The default value of DIMSCALE is __________.

2. The default value of DIMTXT is __________.

3. The default value of SNAP is __________.

4.  Architectural units can be selected by using the __________ command or the __________ 
command.

5. The three standard template drawings that come with AutoCAD software are __________ , 
__________ , and _________.

6. If the plot size is 24” x 18”, and the scale is 1:20, the X Limit = __________ and Y Limit = 
__________.

7. If the plot size is 200 x 150 and limits are (0.00,0.00) and (600.00,450.00), the LTSCALE 
factor = __________. 

8. __________ provides a convenient way to plot multiple views of a 3D drawing or multiple 
views of a regular 2D drawing.

9. You can use the __________ command to change to paper space.

10. You can use AutoCAD’s __________ command to change to model space.

11. The values that can be assigned to TILEMODE are __________ and __________.

12. In the model space, if you want to reduce the display size by half, the scale factor you enter 
in the ZOOM > Scale option is __________.

EXERCISE 1              Template with Limits
Create a drawing template (protoe1.dwt) with the following specifi cations:

Units                       Architectural with precision 0’-0 1/16
Angle                       Decimal Degrees with precision 0
Base angle         East
Angle direction      Counterclockwise
Limits                    48’ x 36’

EXERCISE 2      Template with Limits, Text Height, & Units
Create a drawing template (protoe2.dwt) with the following specifi cations:
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Limits 36.0,24.0
Snap 0.5
Grid 1.0
Text height 0.25
Units Decimal
 Precision 0.00
 Decimal degrees
 Precision 0
 Base angle, East
 Angle positive if measured counterclockwise

EXERCISE 3   Template with Layers, LTSCALE, & DIMSCALE
Create a drawing template (protoe3.dwt) with the following specifi cations:

Limits 48.0,36.0
Text height 0.25
PLINE width 0.03
LTSCALE 4.0
DIMSCALE 4.0
Plot size 10.5 x 8

LAYERS
Layer Name Line Type Color
0 Continuous White
OBJECT Continuous Green
CENTER Center Magenta
HIDDEN Hidden Blue
DIM Continuous Red
BORDER Continuous Cyan

EXERCISE 4 Relative Rectangular and Absolute Coordinates
Create a prototype drawing (protoe4.dwt) with the following specifi cations:

Limits   36.0,24.0
Border 35.0,23.0
Grid 1.0
Snap 0.5
Text height 0.15
Units Decimal (up to 2 places)
LTSCALE 1
Current layer Object

LAYERS
Layer Name Linetype Color
0 Continuous White
Object Continuous Red
Hidden Hidden Yellow
Center Center Green
Dim Continuous Blue
Border Continuous Magenta
Notes Continuous White
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This prototype drawing should have a border line and a title block, as shown in Figure 1-22.

Figure 1-22  Prototype drawing

EXERCISE 5     Template with Plot Sheet Size & Title Block
Create the template drawing shown in Figure 1-23 with the following specifi cations and save it 
with the name protoe5.dwt:

Plotted sheet size 36” x 24”   (Figure 1-23)
Scale 1/2” = 1.0’
Text height 1/4” on plotted drawing
LTSCALE 24
DIMSCALE 24
Units Architectural
 32-denominator of smallest fraction to display
 Angle in degrees/minutes/seconds
 Precision 0d00”00”
 Angle positive if measured counterclockwise
Border Border is 1-1/2” inside the edges of the plotted drawing sheet, using
 the PLINE 1/32” wide when plotted.

Figure 1-23  Drawing for Exercise 5
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EXERCISE 6   Template with Title Block & Dimension Style
Create the prototype drawing, as shown in Figure 1-24 with the following specifi cations (the 
name of the drawing is protoe6.dwt):

Plotted sheet size 24” x 18” (Figure 1-24)
Scale 1/2”=1.0’
Border The border is 1” inside the edges of the plotted 
 drawing sheet, using the PLINE 0.05” wide when 
 plotted (Figure 1-24)
Dimension text over the dimension line
Dimensions aligned with the dimension line
Calculate overall dimension scale factor
Enable the display of alternate units      
Dimensions to be associative.

Figure 1-24  Prototype drawing

EXERCISE 7  Creating & using Template for Generating Drawing

Create the template with the necessary specifi cations to draw the Articulated Rod shown in 
Figure 1-25, with the following specifi cations. 

Limits   36.0,24.0
Border 35.0,23.0
Grid 1.0
Snap 0.5
Text height 0.15
Units Decimal (up to 2 places)
LTSCALE 1
Current layer Object

LAYERS
Layer Name Linetype Color
0 Continuous White
Object Continuous Red
Hidden Hidden Yellow
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Center Center Green
Dim Continuous Blue
Border Continuous Magenta
Notes Continuous White

Also, use this template and the layers created in it to draw the views of the Articulated Rod.

Figure 1-25  Views and dimensions of the Articulated Rod

Answers to Self-Evaluation Test
1. .dwt,  2. Use a Template, 3. Start from Scratch, 4. 72”,48”, 5. MVIEW. 


