
Chapter 2

Working with Graphics 
and Text

 Learning Objectives 
After completing this chapter, you will be able to:
• Create vector graphics using drawing tools
• Modify the shape and size of the selected objects
• Adjust contours in a graphic
• Add layers to the Timeline
• Apply color to an object
• Use Deco Tool
• Create and edit curves
• Create and edit text
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Introduction
Graphics is a representation of a two-dimensional image in binary format as a sequence of 
ones and zeros. It includes both vector and raster images. Vector graphics are the images 
produced by using geometrical primitives such as points, lines, curves, and shapes. These 
graphics are produced on the basis of mathematical equations, such as a circle that includes 
the information of radius. You can create and animate vector graphics in Flash. Vector graphics 
have two advantages. The first is that the file size is small and it is downloaded faster and less 
hard drive space is utilized to save the file. The second advantage is that the image can be 
scaled to any size without affecting the image quality. In Flash, you can create and animate 
vector graphics. The other type of graphics is raster graphics. Raster graphics are the images 
produced by an array of pixels. Each pixel carries Color information, therefore, they are 
relatively large files.

TUTORIALS 
Before you start the tutorials, you need to download the c02_flash_cs6_tut.zip file from 
http://www.cadcim.com. The path of the file is as follows:

	 Textbooks > Animation and Visual Effects > Flash > The Adobe Flash Professional CS6: A Tutorial 
Approach

Next, navigate to the Documents folder and create a new folder with the name Flash_Projects 
and then extract the contents of the zipped file to \Documents\Flash_Projects.

Note
The tutorial zip file that you have downloaded from the CADCIM website contains a folder 
Resources. This folder contains all resources related to this chapter.

 Tutorial 1                                                             
In this tutorial, you will create the vector graphic of a honey bee using the drawing tools in 
Flash CS6, as shown in Figure 2-1.				      (Expected time: 30 min)

Figure 2-1  The vector graphic of honey bee



Working with Graphics and Text		         2-3

E
va

lu
at

io
n 

C
op

y.
 D

o 
no

t r
ep

ro
du

ce
. F

or
 in

fo
rm

at
io

n 
vi

si
t w

w
w

.c
ad

ci
m

.c
om

The following steps are required to complete this tutorial:

a.	 Create a new Flash document.
b.	 Create the face of honey bee.
c.	 Create the body of honey bee.
d.	 Create the wings of honey bee.
e.	 Create the antennae of honey bee.

Creating a New Flash Document
In this section, you will create a new Flash document.

1.	 Choose File > New from the menubar; the New Document dialog box is displayed. 

2.	 In the New Document dialog box, choose ActionScript 3.0 from the General tab and 
then choose the OK button; a new Flash document is displayed. By default, the Essentials 
workspace is active in the Flash document. 

Creating the Face of Honey Bee
In this section, you will create the face of honey bee using Oval Tool and other editing tools 
from the Tools panel.

1.	 Choose Oval Tool from the Tools panel; the properties of this tool are displayed in the 
Properties panel. 

2.	 In the FILL AND STROKE area of the Properties panel, choose the Stroke color swatch; 
a flyout is displayed. In this flyout, enter #000000 in the Hexadecimal edit box and press 
the ENTER key. 

3.	 Choose the Fill color swatch; a flyout is displayed. In this flyout, enter #FFFF00 in the 
Hexadecimal edit box and press the ENTER key. Note that the Hexadecimal edit box is 
also called Hex edit box.

Note
In this textbook, colors will be referred by their hexadecimal values.

Tip: You can choose color for the stroke and fill from the Stroke color and Fill color swatches 
in the Tools panel. Alternatively, in the Properties panel, expand the FILL AND STROKE 
area, and then use the Stroke color and Fill color swatches to choose the color. In these 
panels, select the required color by using the color picker or enter the color value manually 
in the Hexadecimal edit box, refer to Figure 2-2. You can also use the Color and Swatches 
panels to apply color, refer to Figure 2-3. To display the Color panel, choose Window > 
Color from the menubar or press ALT+SHIFT+F9. To display the Swatches panel, choose 
Window > Swatches from the menubar or press CTRL+F9.
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Figure 2-2  Entering the color values in the Hexadecimal edit box

Figure 2-3  The Color and Swatches panels

Note
The fill and stroke are independent of each other, therefore, you can modify or delete either of 
them without affecting the other.

4.	 Press and hold the SHIFT key and drag the cursor to draw a circle. Make sure the 
Object Drawing option in the Options section of the Tools panel is disabled.

Note
When a drawing tool is in the Object Drawing mode, the stroke and fill of an object are not 
separate elements and the shapes that overlap in the same layer do not alter one another if you 
move them apart, reposition, or rearrange them, refer to Figures 2-4 and 2-5.
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Figure 2-5  The behavior of the objects when the Object Drawing mode is enabled

5.	 Choose Selection Tool and double-click on the circle to select it. In the POSITION AND 
SIZE area of the Properties panel, set the value of X to 225 and the value of Y to 38. 
Next, set the W (width) and H (height) values to 100; the circle is positioned and resized 
in the Stage.

	 X and Y are the coordinates that define the position of an object in the Stage. Next, you 
will create eyes of honey bee.

Note
By double-clicking on the fill of an object, you can modify both fill and stroke, whereas by single 
click, you can modify only the fill of the object.

6.	 Choose Oval Tool from the Tools panel; the properties of this tool are displayed in the 
Properties panel. In the FILL AND STROKE area of the Properties panel, choose the 
Stroke color swatch; a flyout is displayed. In this flyout, enter #000000 in the Hex edit 
box and then press the ENTER key. 

7.	 Choose the Fill color swatch; a flyout is displayed. In this flyout, enter #330033 in the 
Hex edit box. Now, create a small vertical oval in the blank area of the Stage. Choose 
Selection Tool and double-click on the oval to select it. In the Properties panel, set the 
W (width) and H (height) values to 10 and 26, respectively. 

Note
To set the value of a particular parameter, click in the edit box and then enter the required  
value. Alternatively, move the cursor over the default value; the shape of the cursor will 
change into a hand icon called the scrubber. Now, drag the cursor to change the 
value.
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8.	 Choose Selection Tool from the Tools panel and select the oval. Next, press and hold the 
ALT key and drag the oval; a copy of the oval is created, refer to Figure 2-6.

Note
To create a copy of an object in Flash, select the object using Selection Tool. Next, press and 
hold the ALT key and drag the object. Alternatively, select the object and choose Edit > Copy 
and then choose Edit > Paste in Center from the menubar.

9.	 Marquee select both the ovals using Selection Tool and position them inside the circle as 
the eyes of honey bee, as shown in Figure 2-7. 

	

Figure 2-6  The copy of the oval Figure 2-7  The eyes placed on the face 
of honey bee

	 Next, you will create the cheeks of honey bee.

10.	 Choose Oval Tool from the Tools panel. In the FILL AND STROKE area of the 
Properties panel, choose the Stroke color swatch; a flyout is displayed. In this 
flyout, choose the No Color button located on the upper right side of this flyout. 

11.	 Choose the Fill color swatch; a flyout is displayed. In this flyout, enter #FF9999 in the 
Hex edit box and press the ENTER key. 

12.	 Create a small horizontal oval in the blank area of the Stage and then select it using 
Selection Tool. In the POSITION AND SIZE area of the Properties panel, set the W 
(width) and H (height) values of the oval to 21 and 7, respectively.              

13.	 Create a copy of the oval using the ALT key. 

14.	 Using Selection Tool, position the ovals on the face as the cheeks of honey bee, as shown 
in Figure 2-8. 
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Figure 2-8  The face of Honey Bee with cheeks

	 Next, you will create the mouth of honey bee.

15.	 Choose Oval Tool from the Tools panel; the properties of this tool are displayed in the 
Properties panel. In the FILL AND STROKE area of the Properties panel, choose the 
Stroke color swatch; a flyout is displayed. In this flyout, choose the No Color button. 

16.	 Choose the Fill color swatch; a flyout is displayed. In this flyout, enter #000000 in the Hex 
edit box and press the ENTER key. Create a horizontal oval. Next, you need to change 
the shape of the oval to make it appear like mouth. In Flash, Selection Tool can also be 
used to push and pull the lines and corners of a shape to refine its contours. 

17.	 Choose Selection Tool and then move the cursor to the upper edge of the oval; a small 
curve is displayed below the cursor indicating that the curvature can be changed, refer to 
Figure 2-9.

18.	 Click on the curvature and drag it inward; the curvature of the shape bends inward, thereby 
turning into mouth shape. Now, select the mouth using Selection Tool and place it below 
the cheeks, as shown in Figure 2-10. 

Figure 2-10  The face of honey bee 
after placing the mouth

Figure 2-9  The cursor with the curve
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Creating the Body of Honey Bee
In this section, you will create the body of honey bee using Line Tool and Paint Bucket 
Tool.

1.	 Choose Line Tool from the Tools panel; the properties of this tool are displayed in the 
Properties panel. In the FILL AND STROKE area of the Properties panel, choose the 
Stroke color swatch; a flyout is displayed. In this flyout, enter #000000 in the Hex edit 
box and press the ENTER key. 

2.	 In the FILL AND STROKE area of the Properties panel, enter 3 in the Stroke edit box. 
Next, press and hold the SHIFT key and draw a vertical line segment (stroke) in the blank 
area of the Stage.

	 The outline of an object is called stroke.

3.	 Choose Selection Tool. Next, Place the cursor 

Figure 2-11  Changing the curvature of the 
stroke

over the stroke and drag it to the left; the 
curvature bends outward, as shown in 
Figure 2-11.

4.	 Select the line segment using Selection Tool 
and create a copy of the line segment using 
the ALT key. Next, select the copy of the line 
segment and choose Modify > Transform > 
Flip Horizontal from the menubar; the copied 
line segment is flipped horizontally and 
placed.

5.	 Marquee select the upper portion of the line segments using Selection Tool and delete 
it by pressing the DEL key, refer to Figure 2-12.

6.	 Marquee select both the line segments and position them appropriately below the face 
using Selection Tool, as shown in Figure 2-13.

Figure 2-12  Deleting the upper 
portion of the line segments

Figure 2-13  The honey bee after 
placing the line segments

7.	 Choose Line Tool from the Tools panel; the properties of this tool are displayed in the 
Properties panel. In the FILL AND STROKE area of the Properties panel, enter 3 in 
the Stroke edit box.
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8.	 Draw four horizontal line segments on the body of honey bee, as shown in Figure 2-14. Next, 
change the curvature of the line segments using Selection Tool, refer to Figure 2-15. 

 

Figure 2-15  Changing the curvature 
of horizontal line segments

Figure 2-14  The horizontal line 
segments

9.	 Choose Paint Bucket Tool from the Tools panel; the properties of this tool are displayed 
in the Properties panel and the options are displayed in the Options section of the Tools 
panel.  

10.	 In the Properties panel, choose the Fill color swatch; a flyout is displayed. In this flyout, 
enter #330033 in the Hex edit box and press the ENTER key. 

11.	 In the Options section of the Tools panel, choose the Gap Size button; a flyout is displayed, 
as shown in Figure 2-16. In this flyout, choose the Close Large Gaps option, refer to 
Figure 2-17.

Figure 2-16  Choosing the Gap Size button 
in the Options section of the Tools panel

Figure 2-17  Choosing the Close Large 
Gaps option

12.	 Click in the first horizontal section of the body; the color is filled in this section. Choose 
the Fill color swatch; a flyout is displayed. In this flyout, enter #FFFF00 in the Hex edit 
box and press the ENTER key. Next, apply the color in the second horizontal section. 
Make sure there are no open areas left between the intersection points of one or more 
line segments as the fill can only be applied in the enclosed areas. 

13.	 Apply the color in the other remaining sections as discussed in Steps 9 and 10, refer to 
Figure 2-18.
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Creating the Wings of Honey Bee 
In this section, you will create the wings of honey bee in a new layer.

1.	 Choose the New Layer button in the Timeline panel; a new layer is created. Next, 
double-click on the default layer name and rename it as wings, as shown in Figure 2-19. 
Next, rename Layer 1 as face and body.

2.	 Choose Oval Tool from the Tools panel; the properties of this tool are displayed in the 
Properties panel. In the FILL AND STROKE area of the Properties panel, choose the 
Stroke color swatch; a flyout is displayed. In this flyout, enter #000000 in the Hex edit 
box and press the ENTER key. 

Note
You can hide the body and face of honey bee by hiding the face and body layer in the Timeline 
panel. To do so, turn off the Show or Hide All Layers option of the face and body layer, as 
shown in Figure 2-20.

Figure 2-20  Hiding the face and body 
layer in the Timeline panel

Figure 2-19  Naming the layers in 
the Timeline panel

3.	 Choose the Fill color swatch; a flyout is displayed. In this flyout, choose the No Color 
button. In the POSITION AND SIZE area of the Properties panel, enter 3 in the Stroke 
edit box and draw a horizontal oval in the wings layer, refer to Figure 2-21.

4.	 Choose Selection Tool and select the oval. Next, create a copy of the oval by using the 
ALT key. 

5.	 Select the copied oval and choose Free Transform Tool from the Tools panel; the oval is 
enclosed inside the transform bounding box. Next, place the cursor on the upper right 
transform point and drag it inward; the size of the oval is reduced, refer to Figure 2-21. 
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6.	 Select the original oval and choose Free Transform Tool from the Tools panel. Place the 
cursor around any transform point outside the transform bounding box; the cursor is 
changed to a rotating arrow icon. Now, rotate the oval anti clockwise approximately to  40 
degrees, refer to Figure 2-22. Similarly, using Free Transform Tool rotate the copied oval 
clockwise approximately to 30 degrees to get the shape of a wing. Click in the Pasteboard 
to deselect Free Transform Tool.

Figure 2-21  Resizing the oval Figure 2-22  Rotating the ovals

 

7.	 Choose the small oval using Selection Tool and place it on the large oval. Next, click 
anywhere in the Pasteboard such that none of the body parts is selected. Now, delete 
the stroke of the large oval that is overlapping the small oval, as shown in Figure 2-23. 
Figure 2-24 shows the final shape of the ovals after deleting the stroke.

 

Figure 2-23  Selecting the 
stroke that is to be deleted

Figure 2-24  The ovals 
after deleting the stroke

8.	 Marquee select the entire wing and create a copy of the wing using the ALT key, refer to 
Figure 2-25. Next, select the copy of the wing using Selection Tool. Now, choose Modify > 
Transform > Flip Horizontal from the menubar; the wing is flipped horizontally, as shown 
in Figure 2-26. 

9.	 Drag the face and body layer above the wings layer in the Timeline panel; the wings are 
placed behind the body, refer to Figure 2-27. 
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the wing

Figure 2-26  The copy of the 
wing flipped horizontally

Figure 2-27  The wings 
placed behind body

Creating the Antennae of Honey Bee
In this section, you will create the antennae of honey bee in the face and body layer.

1.	 Select the face and body layer. Choose Line Tool from the Tools panel. In the POSITION 
AND SIZE area of the Properties panel, enter 3 in the Stroke edit box. In the face and 
body layer, draw a line segment on the head of the honey bee. 

2.	 Change the curvature of the line segment using Selection Tool, as shown in 
Figure 2-28.

3.	 Choose Oval Tool from the Tools panel; the tool properties are displayed in the Properties 
panel. 

4.	 In the FILL AND STROKE area of the Properties panel, choose the Stroke color swatch; 
a flyout is displayed. In this flyout, enter #000000 in the Hex edit box and press the 
ENTER key. Next, choose the Fill color swatch; a flyout is displayed. In this flyout, enter 
#FFFF00 in the Hex edit box and press the ENTER key. 

5.	 Create a small circle anywhere in the Stage. Place the circle on the tip of the line segment 
using Selection Tool, as shown in Figure 2-29.

Figure 2-28  Changing the curvature 
of the line segment

Figure 2-29  Placing the circle on the tip 
of the line segment
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6	 Select the antenna using  Selection Tool. Next, make a copy of the antenna using the ALT 
key and then flip it horizontally by choosing Modify > Transform > Flip Horizontal 
from the menubar. You can select multiple objects using the SHIFT key.

7.	 Position the antennae at appropriate places using the Selection Tool. Figure 2-30 shows 
the complete honey bee.

Figure 2-30  The honey bee

8.	 Save the flash file with the name c02tut1 at the location \Documents\Flash_Projects\c02_tut\c02_
tut_01. 

9.	 Press CTRL+ENTER to view the final output of the vector graphic honey bee. You can also 
view the final rendered image of the honey bee by downloading the file c02_flash_cs6_rndr.zip 
from http://www.cadcim.com. The path of the zipped file is mentioned at the beginning of 
the chapter.

 Tutorial 2                                                             
In this tutorial, you will create an ad banner with the name ‘The Coffee Shop’, as shown in 
Figure 2-31.							         (Expected time: 30 min)

 

Figure 2-31  The ad banner with the name ‘The Coffee Shop’
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The following steps are required to complete this tutorial:

a.	 Create a new Flash document.
b.	 Set the width and height of the Stage.
c.	 Create a coffee bean.
d.	 Create a decorative pattern using Deco Tool.
e.	 Download the images.
f.	 Use bitmaps as fill.
g.	 Insert text using Text Tool.

Creating a New Flash Document
In this section, you will create a new Flash document.

1.	 Choose File > New from the menubar; the New Document dialog box is displayed. 

2.	 In the New Document dialog box, choose ActionScript 3.0 from the General tab and 
then choose the OK button; a new Flash document is displayed.  

Setting the Width and Height of the Stage
In this section, you will set the width and height of the Stage to define the exact area required 
for creating ‘The Coffee Shop’ ad banner.

1.	 Click in the Stage; the Document properties are displayed in the Properties panel.  

2.	 In the PROPERTIES area of the Properties panel, choose the Edit document properties 
button, as shown in Figure 2-32; the Document Settings dialog box is displayed, refer to 
Figure 2-33.

3.	 Enter the values 600 (width) and 250 (height) in the Dimensions edit boxes of the 
Documents Settings dialog box and choose the OK button, refer to Figure 2-33.

Figure 2-32  Choosing the Edit document properties button
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Figure 2-33  Setting the dimensions in the Documents Settings dialog box

Creating a Coffee Bean 
The shape of the coffee bean is roughly an oval shape. You will start creating coffee bean by 
drawing an oval.

1.	 Choose Oval Tool from the Tools panel. In the FILL AND STROKE area of the Properties 
panel, choose the Stroke color swatch; a flyout is displayed. In this flyout, choose the No 
Color button. 

2.	 Choose the Fill color swatch; a flyout is displayed. In this flyout, enter #663300 in the 
Hex edit box and press the ENTER key. Then, draw an oval anywhere in the Pasteboard, 
as shown in Figure 2-34.

3.	 Select half of the oval shape using Selection Tool, refer to Figure 2-35 and then press the 
DEL key; the selected fill is deleted. 

 

Figure 2-35  Selecting half of the oval shapeFigure 2-34  Creating an oval shape 



2-16	                                                 Adobe Flash Professional CS6: A Tutorial Approach
E

va
lu

at
io

n 
C

op
y.

 D
o 

no
t r

ep
ro

du
ce

. F
or

 in
fo

rm
at

io
n 

vi
si

t w
w

w
.c

ad
ci

m
.c

om

4.	 Select the semi-oval shape.  

5.	 Choose the Color button to display the Color panel.

6.	 Select the Linear gradient fill style from this

Figure 2-36  Selecting  Linear gradient 
from the Color type drop-down list

Color type drop-down list; the gradient definition 
bar is displayed at the bottom of the Color panel, 
as shown in Figure 2-36. The pointers below the 
bar indicate the colors in the Linear Gradient 
fill.

 
	 The Linear gradient fill style is used to blend 

colors on a linear path. 

7.	 Double-click on the left pointer below the gradient 
definition bar; a flyout is displayed, as shown in 
Figure 2-37. Next, enter #000000 in the Hex 
edit box of the flyout and press the ENTER key. 
Similarly, double-click on the right pointer; a 
flyout is displayed. Next, enter #663300 in the 
Hex edit box and press the ENTER key; a linear 
gradient fill is applied to the semi-oval shape.

8.	 Select the semi-oval shape and make a copy to create the second half of the coffee bean. 
Next, flip it horizontally by choosing Modify > Transform > Flip Horizontal from the 
menubar. Position it next to the first semi-oval shape of the coffee bean, as shown in 
Figure 2-38.

9.	 Choose Lasso Tool from the Tools panel; the properties of this tool are displayed in the 
Properties panel. 

10.	 Select the outlines of the inner edges of the coffee bean using Lasso Tool, refer to 
Figure 2-39. Next, press the DEL key; the selected fill of the inner edges is deleted, refer 
to Figure 2-40.  

Figure 2-37  The flyout displayed on 
double-clicking the left pointer

Figure 2-38  Positioning semi-ovals to create 
coffee bean
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Figure 2-39  Selecting the outlines of the 
inner edges of the coffee bean

Figure 2-40  The coffee bean after deleting 
the outlines of the inner edges

11.	 Now, you need to fill the color in the gap between the coffee beans. To do so, 
choose Brush Tool from the Tools panel; the properties of this tool are displayed 
in the Properties panel. In the FILL AND STROKE area of the Properties 
panel, choose the Fill color swatch; a flyout is displayed. In this flyout, enter 
#090400 in the Hex edit box and press the ENTER key. In the Options section 
of the Tools panel, choose the Brush Mode button; a flyout is displayed. In this 
flyout, choose the Paint Behind mode. 

12.	 Choose the Brush size button in the Options section of the 

Figure 2-41  Choosing the 
largest size of the brush

Tools panel; a flyout containing different sizes of the brush 
is displayed. In this flyout, choose the largest size of the brush, 
as shown in Figure 2-41. 

13.	 Move the cursor over the gap between the coffee beans, press 
and hold the left mouse button, and then drag the cursor over 
the gap. Next, release the mouse button; the fill automatically 
shifts behind the coffee bean as the Paint Behind mode of 
Brush Tool was selected.

	 The Paint Behind mode of Brush Tool is used to paint the 
blank area of the Stage while leaving the strokes and the fills unaffected in the same layer, 
refer to Figure 2-42.

Figure 2-42  The Paint Behind mode of the Brush Tool
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14.	 Select the coffee bean and then create a copy of it. Next, rotate the coffee bean by using 
Free Transform Tool and position it, refer to Figure 2-43. 

	 Next, you will convert the coffee beans into a graphic symbol because it will be used later 
to create a decorative pattern by using Deco Tool. Note that Deco Tool only selects the 
symbols and not the shape.

15.	 Select coffee beans using Selection Tool and then choose Modify > Convert to Symbol from 
the menubar; the Convert to Symbol dialog box is displayed, as shown in Figure 2-44. 

Figure 2-43  Rotating and 
positioning the coffee bean

Figure 2-44  The Convert to Symbol dialog box

16.	 In this dialog box, type coffee beans as the name of the symbol in the Name text box. 
Next, select Graphic as the symbol type from the Type drop-down list and then choose 
the OK button; a graphic symbol named coffee bean is saved in the Library panel. You can 
now delete the coffee bean instance from the Stage as it is saved in the Library panel.

	 The Library panel in Flash stores all the media files such as bitmaps, graphics, sound 
files, and video clips that you import and symbols that you create in a Flash document. 
By default, the Library panel is located next to the Properties panel in the Essentials 
workspace. Alternatively, choose Window > Library from the menubar to display the 
Library panel.

	 Next, you will create a decorative pattern using Deco Tool.

	 Before creating the decorative pattern, you will draw a layout of the ad banner and divide 
it into sections. 

17.	 Choose Rectangle Tool from the Tools panel; the properties of this tool are displayed in 
the Properties panel. 

18.	 In the FILL AND STROKE area of the Properties panel, choose the Stroke color swatch; a 
flyout is displayed. In this flyout, enter #000000 in the Hex edit box and press the ENTER 
key. Next, choose the Fill color swatch; a flyout is displayed. In this flyout, choose the No 
Color button and enter 1 in the Stroke edit box. 
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19.	 Draw a rectangle with the dimensions equal to the dimensions of the Stage. Now, choose 
Line Tool and draw line segments to divide the rectangle into sections. Figure 2-45 shows 
the ad banner layout with the sections named to provide you an idea of positioning the 
images and text. 

Figure 2-45  The layout for ‘The Coffee Shop’ ad banner

Creating Decorative Pattern Using Deco Tool
In Flash, you can create complex patterns and decorations easily and quickly by using Deco 
Tool. It is one of most dynamic and smarter tools of Flash. It is used to create drawing objects 
and animations using preset symbols and objects or custom symbols in the Library. In Flash CS6, 
the Deco Tool has been improved and new functions and shapes have been added to it. 

1.	 Choose Paint Bucket Tool from the Tools panel; the properties of this tool are displayed 
in the Properties panel. In the FILL AND STROKE area of the Properties panel, choose 
the Fill color swatch; a flyout is displayed. In this flyout, enter #E07E33 in the Hex edit 
box and press the ENTER key. Then, click in the Drawing section of the ad banner layout 
in the Stage; the color is applied in this section, refer to Figure 2-46. 

Figure 2-46  The color applied in the Drawing section

2.	 Choose Deco Tool from the Tools panel; the properties of the tool are displayed in the 
Properties panel. In this panel, select Vine Fill from the DRAWING EFFECT drop-down 
list. Next, choose the Edit button on the right of the Flower option; the Select Symbol 
dialog box is displayed, as shown in Figure 2-47. In this dialog box, select the coffee beans 
graphic symbol and choose the OK button.
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Figure 2-47  Selecting the coffee beans graphic symbol in the Select Symbol dialog box

3.	 In the DRAWING EFFECT area of the Properties panel, click on the Color swatch below 
the Edit button of the Leaf option; a flyout is displayed. In this flyout, enter #FFFFFF 
in the Hex edit box and press the ENTER key.

4.	 In the ADVANCED OPTIONS area, click on the color swatch located on the right of the 
Branch angle option; a flyout is displayed. In this flyout, enter #FFFFFF in the Hex edit 
box and press the ENTER key, refer to Figure 2-48.

Note
It is recommended not to keep the size of the coffee beans large because it will exceed the defined 
bitmap section.

5.	 Move the cursor in the Drawing section of the layout and then click; the Vine Fill pattern 
is spread in the Drawing section, as shown in Figure 2-49.

Figure 2-48  The ADVANCED 
OPTIONS area

Figure 2-49  The Vine Fill pattern 
in the Drawing section
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Downloading the Images
In this section, you will download the images.

1.	 Download the images used in this tutorial from the following links and then save them 
with the names: cafe latte.jpg, cup.jpg, and beans.jpg, respectively at the location /Documents/
Flash_Projects/c02_tut/Resources.

	 http://www.sxc.hu/photo/1287441, http://www.sxc.hu/photo/1289296, and http://www.sxc.hu/
photo/1097233

Note
Footage Courtesy: Gareth Weeks (http://www.sxc.hu/profile/garwee), ilker (http://www.sxc.
hu/profile/ilco), Rob Owen-Wahl (http://www.sxc.hu/profile/lockstockb)

Using Bitmaps as Fill
In this section, you will use bitmaps as fill. 

1.	 Choose Paint Bucket Tool from the Tools panel. Next, choose the Color button; the Color 
panel is displayed. In the Color panel, select Bitmap fill from the Color type drop-down 
list; the Import to Library dialog box is displayed.

2.	 In the Import to Library dialog box, choose Documents > Flash_Projects > c02_tut > 
Resources > cup.jpg. Next, choose the Open button; the selected image is displayed in 
the Color panel as bitmap swatch, refer to Figure 2-50.

3.	 In the Color panel, choose the Import button; the Import to Library dialog box is 
displayed. In this dialog box, browse to the location Documents > Flash_Projects > c02_tut > 
Resources folder and import cafe latte.jpg, and beans.jpg. These images are displayed in the 
Color panel as bitmap swatches, as shown in Figure 2-50, and are saved in the Library 
panel, as shown in Figure 2-51.

Figure 2-50  The bitmap swatches Figure 2-51  The Library panel
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4.	 In the Color panel, choose the Fill color button. 

Figure 2-52  Choosing bitmaps as fill

Next, click on the cup.jpg swatch using the color 
picker, as shown in Figure 2-52. Next, move the 
cursor in the Bitmap 1 section in the Stage and 
click; the cup.jpg image is applied as fill in this 
section.

5.	 For the Bitmap 2 section, choose the cafe latte.jpg 
swatch in the Color panel. 

6.	 For the Bitmap 3 section, choose the beans.jpg swatch in the Color panel. 

	 If the images that are used as the fill for Bitmap sections do not fit properly, then you 
need to resize the bitmap fill. To resize a bitmap fill, for example the cafe.latte fill, choose 
Gradient Transform Tool from the Tools panel and click on the cafe.latte fill in the Stage; 
the gradient bounding box with transform handles is displayed around the cafe.latte 
fill. Move the cursor over the arrow located at the middle bottom handle of the gradient 
bounding box; the cursor changes to a double-headed arrow. Drag the double-headed 
arrow outward to fit the cafe.latte fill, refer to Figure 2-53. Figure 2-54 shows the complete 
view of Bitmap sections.

Figure 2-53  Scaling the cafe latte.jpg using 
Gradient Transform Tool

Figure 2-54  The Bitmap sections

 

Inserting Text Using Text Tool
Now, you need to add text to complete this ad banner. In Flash CS6, there are two text options: 
Classic Text and Text Layout Framework ( TLF ). You will learn more about Text Layout 
Framework in the later chapters. Here, you will use Classic Text to write the name on the ad 
banner, “The Coffee Shop”. 
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1.	 Choose Insert > Timeline > Layer from the menubar; a new layer is created. Next, 
rename the new layer as Text. Alternatively, you can choose the New Layer button in the 
Timeline panel to create a new layer.

2.	 Choose Text Tool from the Tools panel; the properties of Text Tool are displayed in the 
Properties panel. In this panel, select Classic Text from the Text engine drop-down list. 
Next, select Static Text from the Text type drop-down list, refer to Figure 2-55.

3.	 Make sure the orientation of the text is horizontal. If it is not horizontal, change it to 
horizontal by using the Change orientation of text drop-down list in the Properties panel, 
refer to Figure 2-55.

Figure 2-55  Text Tool options in the Properties panel

 

4.	 In the CHARACTER area of the Properties panel, choose the Gill Sans Ultra Bold font 
from the Family drop-down list. Next, set the font size to 30 in the Size edit box. Next, 
choose the swatch located on the right to Color; a flyout is displayed. In this flyout, enter 
#000000 in the Hex edit box.

5.	 Click in the Stage; the text box is displayed. In this text box, type The Coffee Shop. Next, 
choose Selection Tool and position the text at the center of the Text section, as shown in 
Figure 2-56.

Figure 2-56  The Coffee Shop ad banner

 

6.	 Save the flash file with the name c02tut2 at the location \Documents\Flash_Projects\c02_tut\ 
c02_tut_02. 
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7.	 Press CTRL+ENTER to view the final output of the ad banner. You can also view the 
final rendered image of the ad banner by downloading the file c02_flash_cs6_rndr.zip from 
http://www.cadcim.com. The path of the zipped file is mentioned at the beginning of the 
chapter.

Hot keys
In Flash, you can use the keyboard shortcuts to invoke the commonly used commands. The 
shortcut keys are referred as hot keys. With the help of these keys, you can work faster and 
more efficiently. The most important keys and their functions are listed below.

Hot keys and their function

Key Function

CTRL+N Creates a new document

CTRL+O Opens the existing Flash file

CTRL+W Closes the active Flash file

CTRL+S Saves the active Flash file

CTRL+Z To undo the last step

CTRL+Y To redo the last step

Hot keys for invoking Tools

Key Tool

V Selection Tool

A Subselection Tool

Q Free Transform Tool

F Gradient Transform Tool

W 3D Rotation Tool

G 3D Translation Tool

L Lasso Tool

P Pen Tool

= Add Anchor Point Tool
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- Delete Anchor Point Tool

C Convert Anchor Point Tool

T Text Tool

N Line Tool

R Rectangle Tool and Rectangle Primitive Tool

O Oval Tool and Oval Primitive Tool

Y Pencil Tool

B Brush Tool and Spray Brush Tool

U Deco Tool

M Bone Tool and Bind Tool

K Paint Bucket Tool

S Ink Bottle Tool

I Eyedropper Tool

E Eraser Tool

H Hand Tool

Z Zoom Tool

Some Important Hot keys

Keys Function

CTRL+R Imports elements to the Stage

CTRL+F8 Creates new symbols

F8 Converts objects to symbols

CTRL+B Breaks apart elements

CTRL+G Groups elements

CTRL+SHIFT+G Ungroups elements

CTRL+ENTER Tests the movie

CTRL+U Opens preferences settings
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 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following options of the Brush Tool is used to paint behind the strokes and 
fills in the same layer?

		  (a) Paint Fills				    (b) Paint Behind
		  (c) Paint Selection			   (d) Paint Inside

2.	 The __________ key helps you draw a perfect circle while using Oval Tool.

3.	 The __________ graphics are produced by using geometrical primitives such as points, 
lines, curves, and shapes. 

4.	 The __________ option provides a platform for colors to blend on the linear path.

5.	 The __________ option is used to apply bitmap images as a fill.

6.	 The Linear gradient option is used to create linear gradient strokes. (T/F)

7.	 You can create a new symbol by pressing CTRL+R. (T/F)

8.	 You can close the active Flash file by pressing CTRL+W. (T/F)

9.	 L is the shortcut key for invoking Lasso Tool. (T/F)

10.	 CTRL+ENTER is used to test a movie. (T/F)

 Review Questions 
Answer the following questions:

1.	 Which of the following combinations of shortcut keys is used for creating a new 
document?

		  (a) CTRL+N				    (b) CTRL+B
		  (c) CTRL+G				    (d) CTRL+U
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2.	 __________ and __________ are the two text options in Flash CS6.

3.	 __________ is the shortcut key for invoking Free Transform Tool.

4.	 The __________ option is used to snap objects along the edges of other objects.

5.	 __________ is the shortcut key for invoking 3D Rotation Tool.

6.	 __________ is the shortcut key for invoking Rectangle Tool and Rectangle Primitive 
Tool.

7.	 You can ungroup the elements by pressing CTRL+G. (T/F)

8.	 D is the shortcut key for invoking Deco Tool. (T/F)

 Exercise 

 Exercise 1                                                                   
Using various tools, create the ad banner for ‘The Flower Shop’, as shown in Figure 2-57. You 
can view the final rendered image of the banner by downloading the file c02_flash_cs6_exr.zip 
from http://www.cadcim.com. The path of the file is as follows:

	 Textbooks > Animation and Visual Effects > Flash > The Adobe Flash Professional CS6: A Tutorial 
Approach 

(Expected time: 30 min)
 Download the bitmaps used in this exercise from the following links:

http://www.sxc.hu/photo/1340073 (Courtesy: http://www.sxc.hu/profile/alex27)
http://www.sxc.hu/photo/1338574 (Courtesy: http://www.sxc.hu/profile/Roxanne727)
http://www.sxc.hu/photo/1284438 (Courtesy: http://www.sxc.hu/profile/robby_m)
http://www.sxc.hu/photo/1077716 (Courtesy: http://www.sxc.hu/profile/bjearwicke) 
http://www.sxc.hu/photo/1323129 (Courtesy: http://www.sxc.hu/profile/misscheeky) 
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Figure 2-57  The ad banner with the name ‘The Flower Shop’

Answers to Self-Evaluation Test
1. Paint Behind, 2. SHIFT, 3. vector, 4. Linear Gradient, 5. Bitmap fill, 6. F, 7. F, 8. T, 9. T, 
10. T


