
Chapter 1

Introduction to 
CATIA V5-6R2012

 Learning Objectives 
After completing this chapter, you will be able to:
• Understand the benefits of using CATIA V5.
• Understand various workbenches of CATIA V5.
• Understand important terms and definitions used in CATIA V5.
• Understand the system requirements to install CATIA V5.
• Understand the functions of the mouse buttons.
• Understand the use of Hot Keys.
• Modify the color scheme in CATIA V5.
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Introduction To CATIA V5-6R2012
Welcome to CATIA (Computer Aided Three Dimensional Interactive Application). As a 
new user of this software package, you will join hands with thousands of users of this high-end 
CAD/CAM/CAE tool worldwide. If you are already familiar with the previous releases, you can 
upgrade your designing skills with the tremendous improvement in this latest release.

CATIA V5, developed by Dassault Systemes, France, is a completely re-engineered, 
next-generation family of CAD/CAM/CAE software solutions for Product Lifecycle Management. 
Through its exceptionally easy-to-use and state-of-the-art user interface, CATIA V5 delivers 
innovative technologies for maximum productivity and creativity, from the inception concept 
to the final product. CATIA V5 reduces the learning curve, as it allows the flexibility of using 
feature-based and parametric designs.

CATIA V5 provides three basic platforms: P1, P2, and P3. P1 is for small and medium-sized 
process-oriented companies that wish to grow toward the large scale digitized product definition. 
P2 is for the advanced design engineering companies that require product, process, and 
resource modeling. P3 is for the high-end design applications and is basically for Automotive 
and Aerospace Industry, where high quality surfacing or Class-A surfacing is used. 

The subject of interpretability offered by CATIA V5 includes receiving legacy data from the 
other CAD systems and from its own product data management modules. The real benefit is 
that the links remain associative. As a result, any change made to this external data gets notified 
and the model can be updated quickly.

The latest application launched by Dassault Systemes in the family of CATIA is CATIA V6. 
This application is based entirely on a database PLM Structure and is used for creating the 
business processes to get the work done in a production environment. For the users of CATIA 
V5, the transition from CATIA V5 to V6 is one of the requirements. For this purpose, Dassault 
Systemes has released a version of CATIA which supports the file format of both CATIA V5 as 
well as CATIA V6, named as CATIA V5-6R2012. Also, all the features in Part Design, Generative 
Surface Design, and  Sketcher, related to 3D parametric geometry creation are preserved so 
that they can be used in both CATIA V5 and CATIA V6.  

CATIA V5 Workbenches
CATIA V5 serves the basic design tasks by providing different workbenches. A workbench is 
defined as a specified environment consisting of a set of tools that allows the user to perform 
specific design tasks. The basic workbenches in CATIA V5 are Part Design, Wireframe 
and Surface Design, Assembly Design, Drafting, Generative Sheetmetal Design, DMU 
Kinematics, and FreeStyle. These workbenches are discussed next.

Part Design Workbench
The Part Design workbench is a parametric and feature-based environment in which you can 
create solid models. The basic requirement for creating a solid model in this workbench is a 
sketch. The sketch for the features is drawn in the Sketcher workbench that can be invoked 
within the Part Design workbench. You can draw the sketch using the tools in this workbench. 
While drawing a sketch, some constraints are automatically applied to it. You can also apply 
additional constraints and dimensions manually. After drawing the sketch, exit the Sketcher 
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workbench and convert it into a feature. The tools in the Part Design workbench can be used 
to convert the sketch into a sketch-based feature. This workbench also provides other tools to 
apply the placed features, such as fillets, chamfers, and so on. These features are called the 
dress-up features. You can also assign materials to the model in this workbench.

Wireframe and Surface Design Workbench
The Wireframe and Surface Design workbench is also a parametric and feature-based 
environment, and is used to create wireframe or surface models. The tools in this workbench are 
similar to those in the Part Design workbench with the only difference that the tools in this 
environment are used to create basic and advanced surfaces. 

Assembly Design Workbench
The Assembly Design workbench is used to assemble the components using the 
assembly constraints available in this workbench. There are two types of assembly design 
approaches:

1.	 Bottom-up
2.	 Top-down

In the bottom-up approach of the assembly design, the components are assembled together 
to maintain their design intent. In the top-down approach, components are created inside 
the assembly in the Assembly Design workbench. You can also assemble an existing assembly 
to the current assembly. The Space Analysis toolbar provides the Clash analysis tool that 
helps in detecting clash, clearance, and contact between components and subassemblies.

Drafting Workbench
The Drafting workbench is used for the documentation of the parts or assemblies created 
earlier in the form of drawing views and their detailing. There are two types of drafting 
techniques:

1.	 Generative drafting
2.	 Interactive drafting

The generative drafting technique is used to automatically generate the drawing views of 
the parts and assemblies. The parametric dimensions added to the component in the Part 
Design workbench during its creation can be generated and displayed automatically in the 
drawing views. The generative drafting is bidirectionally associative in nature. You can also 
generate the Bill of Material (BOM) and balloons in the drawing views.

In interactive drafting, you need to create the drawing views by sketching them using the 
normal sketching tools and then adding the dimensions.

Generative Sheetmetal Design Workbench
The Generative Sheetmetal Design workbench is used for the designing the sheet metal 
components. Generally, the solid models of the sheet metal components are created to generate 
the flat pattern of the sheet, study the design of the dies and punches, study the process plan 
for designing, and the tools needed for manufacturing the sheet metal components.
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DMU Kinematics Workbench
The DMU Kinematics workbench is used to design mechanisms by adding joints between 
the components. It also allows you to simulate and analyze the working of the mechanisms 
dynamically.   

FreeStyle Workbench
The FreeStyle workbench is used to manipulate and refine an existing surface. In addition, 
you can create independent surfaces and analyze the surfaces using the tools available in this 
workbench. 

System Requirements
The system requirements to ensure the smooth running of CATIA V5-6R2012 on your system 
are as follows:

•	 System unit: An Intel Pentium 4 or Xeon-based workstation running Microsoft 2000 
Professional Edition, Windows Vista or Windows 7.

•	 Memory: 512 MB of RAM (minimum). 
•	 Disk drive: 4 GB Disk Drive space (Minimum recommended size)
•	 Internal/External drives: A CD-ROM drive for installing programs.
•	 Display: A graphic color display compatible with the selected platform-specific graphic 

adapter. The minimum recommended monitor size is 17 inches.
•	 Graphics adapter: A graphics adapter with a 3D OpenGL accelerator with a minimum 

resolution of 1024x768 pixels for Microsoft Windows workstations and 1280x1024 
for UNIX workstations.

GETTING STARTED WITH CATIA V5-6R2012
Install CATIA V5-6R2012 on your system and then start it by double-clicking on its shortcut 
icon on the desktop of your computer. You can also choose Start > All Programs > CATIA 
> CATIA V5-6R2012 from the taskbar to start the program, as shown in Figure 1-1.

After the system has loaded all required files to start CATIA V5-6R2012, a new product file, 
with the default name Product1 will start automatically, as shown in Figure 1-2.

Close this file by choosing File > Close from the menu bar. Figure 1-3 shows the screen that 
appears after closing the initial Product file.
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Figure 1-1  Starting CATIA V5-6R2012 from the taskbar

Figure 1-2  The initial screen that appears after starting CATIA V5-6R2012
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IMPORTANT TERMS AND DEFINITIONS
Some important terms and definitions used in CATIA V5-6R2012 are discussed next. 

Feature-based Modeling
A feature is defined as the smallest building block that can be modified individually. A model 
created in CATIA V5 is a combination of a number of directly or indirectly related individual 
features. You can modify these features any time during the design process. If a proper 
design intent is maintained while creating the model, then these features automatically adjust 
according to the change occurred in their surroundings. This provides greater flexibility to 
the design.

Parametric Modeling
The parametric nature of a software package is defined as its ability to use the standard 
properties or parameters in defining the shape and size of a geometry. The main function of  
this property is to transform the selected geometry to a new size or shape without considering 
its original dimensions. You can change or modify the shape and size of any feature at any 
stage of the design process. This property makes the designing process very easy. For example, 
consider the design of the body of a pipe housing shown in Figure 1-4. 

To change the design by modifying the diameter of the holes and their number on the front, 
top, and bottom faces, you have to simply select the feature and change the diameter and the 
number of instances in the pattern. The modified design is shown in Figure 1-5.

Figure 1-3  The screen that appears after closing the initial Product file
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Figure 1-4  Body of a pipe housing Figure 1-5  Modified body of a pipe housing

Bidirectional Associativity
As mentioned earlier, CATIA V5 has different workbenches such as Part Design, Assembly 
Design, Drawing, and Generative Sheetmetal Design, and so on. The bidirectional associativity 
that exists between all these workbenches ensures that any modification made in the model 
in any of the workbenches of CATIA V5, reflects automatically and immediately in other 
workbenches also. For example, if you modify the dimension of a part in the Part Design 
workbench, the change will reflect in the Assembly Design and Drawing workbenches also. 
Similarly, if you modify the dimensions of a part in the drawing views generated in the Drawing 
workbench, the changes will reflect in the Part Design and Assembly Design workbenches also. 
Consider the drawing views of the pipe housing shown in Figure 1-6. When you modify the 
model in the Part Design workbench, the changes are reflected in the Drawing workbench 
automatically. Figure 1-7 shows the drawing views of the pipe housing after increasing the 
diameter and number of holes at the top flange.

CATPart
CATPart is a file extension associated with all those files that are created in the Sketcher, Part 
Design, Generative Sheetmetal Design, and Wireframe and Surface Design workbenches 
of CATIA V5.

CATProduct
CATProduct is a file extension associated with all those files that are created in the Assembly 
Design workbench of CATIA V5.

CATDrawing
CATDrawing is a file extension associated with all those files that are created in the Drafting 
workbench of CATIA V5.

Specification Tree
The Specification tree displays all the operations carried out on the part in a sequence. 
Figure 1-8 shows the Specification tree that appears when you start a new file under the Part 
Design workbench.



1-8			                 			                       CATIA for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 1-6  The drawing views of the pipe housing before modifications

Figure 1-7  The drawing views of the pipe housing after modifications

Compass
The compass is used to manipulate the orientation of parts, assemblies, or sketches. You 
can also orient the view of the parts and assemblies. The compass is shown in Figure 1-9. By 
default, it appears on the top right corner of the geometry area.

Figure 1-9  The compassFigure 1-8  The Specification tree that 
appears on starting a new CATPart file 



Introduction to CATIA V5						                        1-9

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Constraints
Constraints are the logical operations that are performed on the selected element to define 
its size and location with respect to the other elements or reference geometries. There are 
two types of constraints in CATIA V5. The constraints in the Sketcher workbench are called 
geometric constraints and are used to precisely define the size and position of the sketched 
elements with respect to the surroundings. The assembly constraints available in the Assembly 
Design workbench are used to define the precise position of the components in the assembly. 
These constraints are discussed next.

Geometric Constraints
Geometric constraints are the logical operations performed on a sketched elements to define 
their size and position with respect to the other elements. These are two methods to apply 
geometric constraints, automatic and manual. While drawing the sketch, some constraints 
are automatically applied to it. For applying constraints manually, you need to invoke the 
Constraints Defined in Dialog Box tool and select the appropriate check box.

The constraints in the Sketcher workbench are discussed next.

Distance
This constraint is used to apply a distance dimension between any two selected entities.

Length
This constraint is used to apply a linear dimension to the selected line.

Angle
This constraint is used to apply an angular dimension between any two selected lines.

Radius / Diameter
This constraint is used to apply a radius or diameter dimension to the selected circular 
entity.

Semimajor axis
This constraint is used to apply a dimension to the major axis of the selected ellipse.

Semiminor axis
This constraint is used to apply a dimension to the minor axis of the selected ellipse.

Symmetry
This constraint is used to force the selected sketched entities symmetrical about an axis. 
A line segment can be used as an axis.

Midpoint
This constraint forces a selected point to be placed on the midpoint of the selected line.

Equidistant point
This constraint forces a selected point to be placed at an equal distance from any two 
preselected points.
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Fix
This constraint is used to fix a selected entity in terms of its position with respect to the 
coordinate system of the current sketch.

Coincidence
This constraint is used to make two points, two lines, a point and a line, or a point and 
a curve coincident.

Concentricity
This constraint is used to make two circles, two arcs, an arc and a circle, a point and a 
circle, or a point and an arc concentric.

Tangency
This constraint is used to force the selected line segment or curve to become tangent to 
another curve.

Parallelism
The Parallelism constraint is used to force any two selected line segments to become 
parallel to each other. The selected line segments can be axes also.

Perpendicular
The Perpendicular constraint is used to force any two selected line segments to become 
perpendicular to each other. The selected line segments can be axes also.

Horizontal
The Horizontal constraint forces the selected line segment to become horizontal.

Vertical
The Vertical constraint forces the selected line segment to become vertical.

Assembly Constraints
The constraints in the Assembly Design workbench are the logical operations performed 
to restrict the degrees of freedom of a component and to define its precise location and 
position with respect to the other components in the assembly. The constraints in this 
workbench are discussed next.

Coincidence
This constraint is used to force two selected entities to coincide with each other. The 
selected entities can be central axes of circular components, two adjacent or opposite 
faces, or two adjacent planes.

Contact
This constraint is used to force two selected faces to maintain contact with each other.

Offset
This constraint is used to place two different selected faces, planes, or central axes at a 
distance with respect to each other.



Introduction to CATIA V5						                        1-11

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Angle
This constraint is used to place two selected entities at an angle with respect to each other. 
These entities can be the central axes of circular components, two faces, two planes, a 
combination of an axis and a face, a plane and a face, or an axis and a plane.

Fix
This constraint fixes the position of the selected part in the 3D space.

Fix Together
This constraint fixes the position of two different selected parts with respect to each 
other.

Quick
The Quick Constraint tool is used to apply the most appropriate constraint to the 
elements in the current selection set. You can set the priority depending on which CATIA 
V5 will perform the constraint selection.

PartBody
The PartBody is the default body in the Part Design workbench. All solid features, such as 
pad, pocket, shaft, and so on are placed inside it. Other bodies that will be inserted under the 
Part Design workbench will be named as Body.2, Body.3, and so on.

Geometrical Set
The geometrical set is defined as a body that includes the newly created planes, surfaces, 
wireframe elements, and reference elements.

Wireframe
The wireframe construction elements aid in creating surfaces. They generally consist of points, 
lines, and arcs, and are used as substitutes of entities drawn in the Sketcher workbench.

Surface
Surfaces are geometric features which have no thickness. They are used to create complex 
shapes that are difficult to make using solid features. After creating a surface, you can assign 
a thickness to it to convert it into a solid body.

Feature
A feature is defined as a basic building block of a solid model. The combination of various 
features results in a complete model. In the Part Design workbench of CATIA V5, the features 
are of the following four types:

1.	 Sketch-Based Features
2.	 Dress-Up Features
3.	 Transformation Features
4.	 Surface-Based Features
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Reframe on
Sometimes, a feature, a body, or a sketch may not be visible in the available space of the 
geometry area. The Reframe on option, available in the contextual menu, is used to view the 
particular selection in the available display space.

Center Graph
The Center graph option, available in the contextual menu, is used to bring the selected 
feature, body, or sketch in the Specification tree to the middle left portion of the geometry area.

UNDERSTANDING THE FUNCTIONS OF THE MOUSE 
BUTTONS in catia
To work in CATIA V5 design workbenches, it is necessary that you understand the functions 
of the mouse buttons. The efficient use of these buttons, along with the CTRL key on the 
keyboard, can reduce the time required to complete the design task. The different combinations 
of the CTRL key and mouse buttons are listed next:

1.	 The left mouse button is used to make a selection by dragging a window or by simply 
selecting a face, surface, sketch, or object from the geometry area or from the Specification 
tree. For multiple selections, press and hold the CTRL key and select the entities using 
the left mouse button.

2.	 The right mouse button is used to invoke the contextual (shortcut) menu after selecting 
an element or invoking a tool.

3.	 Press and hold the middle mouse button and drag the mouse to pan the view of the model 
on the screen.

4.	 Press and hold the middle mouse button and then click the right mouse button once 
to invoke the Zoom mode. Now, drag the mouse up to zoom in the view of the model. 
Similarly, drag it down to zoom out the view of the model. You can also invoke the zoom 
tool by first pressing and holding the CTRL key and then pressing and holding the middle 
mouse button. Now, release the CTRL key and drag the cursor to zoom in and out of the 
view of the model. Figure 1-10 shows how to use a three-button mouse to zoom in and 
zoom out functions.

Figure 1-10  Using the three-button mouse to perform the 
zoom in and zoom out operations
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5.	 Press and hold the middle mouse button. Then, press and hold the right mouse button or 
left mouse button to invoke the Rotate mode. Next, drag the mouse to dynamically rotate 
the view of the model in the geometry area and view it from different directions. You can 
rotate the model in the geometry area by pressing and holding the middle mouse button 
and then pressing  and holding the CTRL key. Next, drag the cursor to rotate the view of 
the model. Figure 1-11 shows how to use the three-button mouse to perform the rotate 
operation.

Note
It is assumed that a three-button mouse is configured on your system.

Figure 1-11  Using the three-button mouse to perform the rotate operation

TOOLBARS
CATIA V5 offers a user-friendly design environment by providing specific toolbars to each 
workbench. Therefore, it is important that you get acquainted with various standard toolbars and 
buttons that appear in the workbenches of CATIA V5. These toolbars are discussed next.

Standard Toolbar
This toolbar is common to all workbenches of CATIA V5. Figure 1-12 shows the Standard 
toolbar.

Figure 1-12  The Standard toolbar
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The tools in this toolbar are used to start a new file, open an existing file, save a file, and 
print the current document. These buttons are also used to cut and place the selection on 
a temporary clipboard, copy a selection, paste the content from the clipboard to a selected 
location, undo, redo, and invoke the help topics. The What’s This? button provides help on 
the toolbar icons.

Status Bar
The status bar, which is located at the bottom of the CATIA V5 window, comprises of three 
areas, as shown in Figure 1-13. These areas are discussed next.

Figure 1-13  The status bar

 

Current Information or Dialog Box
The Current Information or Dialog Box area displays the current information about the 
selected feature or current tool.

Power Input Field Bar
The Power Input Field bar lets you invoke the commands and enter the data or value that 
can be directly associated with the feature.

Note
In case an incorrect command is entered in the Power Input Field bar, a Power input 
message dialog box appears, indicating the unknown command or syntax error. Choose the 
OK button from this dialog box.

To launch any command using the Power Input Field bar, the general syntax of command will 
be C: <name of the command>. For example, to start a new file, enter C: New.

Tip. As entering commands in the Power Input Field box is a tedious process. It is 
recommended that you invoke the tools from the toolbars or menu bar instead of using the 
Power Input Field bar. 

Dialog Box Display Button
Choosing the Dialog Box Display button will turn on or off the display of the current dialog 
box.

Part Design Workbench Toolbars
You can invoke the Part Design workbench by choosing the New button from the Standard 
toolbar and selecting Part from the New dialog box displayed. Alternatively, you can choose 
Start > Mechanical Design > Part Design from the menubar. The toolbars in the Part Design 
workbench are discussed next. 
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View Toolbar
The buttons in the View toolbar, shown in Figure 1-14, are used for manipulating the view of the 
model using the tools such as pan, zoom, normal viewing about a planar surface, face or plane, 
defining a render style, and so on. The View toolbar is available in all the workbenches.

Note
Buttons such as Fly Mode, Normal View, Isometric View, View Mode, and Rotate are 
not available in the Drafting workbench. For all other workbenches discussed in this book, the 
function of the View toolbar is the same.

Figure 1-14  The View toolbar

Select Toolbar
The Select tool is invoked from the Select toolbar to select a particular object or sketch. When 
you invoke the Select tool, it prompts you to select an object or a tool. By default, the Select tool 
remains active, until another tool or object is selected. Figure 1-15 shows the Select toolbar.

Sketcher Toolbar
The Sketcher button in the Sketcher toolbar is used to invoke the Sketcher workbench. You can 
also invoke it from the main menu bar by choosing Start > Mechanical Design > Sketcher. 
Figure 1-16 shows the Sketcher toolbar.

After choosing the Sketcher button, select a plane, or a planar face to invoke the Sketcher 
workbench. The toolbars in the Sketcher workbench are discussed next. 
												          
		

Figure 1-15  The Select toolbar Figure 1-16  The Sketcher toolbar



1-16			                 			                       CATIA for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Profile Toolbar
The tools in the Profile toolbar are used to draw the sketches. It is one of the most important 
toolbars in the Sketcher workbench. Figure 1-17 shows the buttons that are available in this 
toolbar.

Figure 1-17  The Profile toolbar

Constraint Toolbar
The tools in the Constraint toolbar are used to apply constraints to the geometric entities, and 
assign dimensions to a drawn sketch. You can make a sketch fully defined by using the tools 
from this toolbar. A fully defined sketch is known as an Iso-constraint sketch and is discussed 
in the later chapters. Figure 1-18 shows the buttons in the Constraint toolbar.

Figure 1-18  The Constraint toolbar

Operation Toolbar
The tools in the Operation toolbar are used to edit the drawn sketches. Figure 1-19 shows the 
buttons in the Operation toolbar.

Figure 1-19  The Operation toolbar

Sketch tools Toolbar
The tools in the Sketch tools toolbar are used to set the sketcher settings such as setting the 
snap, switching between the standard and construction elements, and so on. Figure 1-20 shows 
the buttons in the Sketch tools toolbar.
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Figure 1-20  The Sketch tools toolbar

Once the basic sketch is complete, you need to convert it into a feature. Choose the Exit 
workbench button from the Workbench toolbar and switch back to the Part Design 
workbench.

The remaining toolbars of the Part workbench are discussed next.

Sketch-Based Features Toolbar
The tools in this toolbar are used to convert a sketch drawn in the Sketcher workbench into 
a feature. Figure 1-21 shows the buttons in the Sketch-Based Features toolbar.

Figure 1-21  The Sketch-Based Features toolbar

Dress-Up Features Toolbar
The tools in the Dress-Up Features toolbar are used to apply the dress-up features such as fillet, 
chamfer, shell, and so on. Figure 1-22 shows the buttons in the Dress-Up Features toolbar.

Figure 1-22  The Dress-Up Features toolbar
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Measure Toolbar
The tools in the Measure toolbar are used to measure a single item, measure the distance 
between two geometries, or calculate the mass properties of the object. Figure 1-23 shows the 
buttons in the Measure toolbar.

Figure 1-23  The Measure toolbar

Transformation Features Toolbar
The tools in the Transformation Features toolbar are used to apply the transformation 
features to the parts such as moving, mirror, pattern, and so on. Figure 1-24 shows the buttons in 
the Transformation Features toolbar.

Figure 1-24  The Transformation Features toolbar

Dynamic Sectioning Toolbar
The tool in the Dynamic Sectioning toolbar is used to visualize the 3D section view of a part 
at a position specified by using a section plane. Figure 1-25 shows the Dynamic Sectioning 
toolbar.

Apply Material Toolbar
The tool in the Apply Material toolbar is used to assign a material to the part body. 
Figure 1-26 shows the Apply Material toolbar.

Figure 1-26  The Apply Material toolbarFigure 1-25  The Dynamic Sectioning toolbar

Surface-Based Features Toolbar
The tools in the Surface-Based Features toolbar are used to perform surface-based 
operations on part bodies or to convert a surface body into a solid body. Figure 1-27 shows 
the tools in the Surface-Based Features toolbar.
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Wireframe and Surface Design Workbench Toolbars
You can invoke the Wireframe and Surface Design workbench from the main menu bar by 
choosing Start > Mechanical Design > Wireframe and Surface Design. The toolbars in the 
Wireframe and Surface Design workbench are discussed next.

Surfaces Toolbar
The tools in the Surfaces toolbar are used to create surfaces. Figure 1-28 shows the Surfaces 
toolbar.

Figure 1-28  The Surfaces toolbar

Operations Toolbar
The tools in the Operations toolbar are used for surface editing operations. Figure 1-29 shows 
the tools in the Operations toolbar.

Figure 1-29  The Operations toolbar

Wireframe Toolbar
The tools in the Wireframe toolbar are used to create the 2D or 3D curve using points, lines, 
and splines. User-defined planes can also be created by choosing the Plane button from this 
toolbar. You will learn about creating a user-defined plane in the later chapters. Figure 1-30 
shows the tools in the Wireframe toolbar.
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Figure 1-30  The Wireframe toolbar

Assembly Design Workbench Toolbars
You can invoke the Assembly Design workbench by choosing the New button from the 
Standard toolbar and then selecting Product from the New dialog box. Alternatively, you can 
choose Start > Mechanical Design > Assembly Design from the menubar. The toolbars in 
the Assembly Design workbench are discussed next.

Product Structure Tools Toolbar
The tools in the Product Structure Tools toolbar are used to insert an existing part or 
assembly in the current product file. You can also create a new assembly or part inside the 
Product file using the tools in this toolbar. Figure 1-31 shows the buttons in the Product 
Structure Tools toolbar.

Figure 1-31  The Product Structure Tools toolbar

Constraints Toolbar
The Constraints toolbar is used to apply constraints to the components of the assembly 
to restrict degrees of freedom (DOFs) of the component with respect to the surroundings. 
Figure 1-32 shows the Constraints toolbar.

Figure 1-32  The Constraints toolbar
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Move Toolbar
The tools in this toolbar are used to perform tasks such as moving and snapping the parts 
or exploding an assembly in the Assembly Design workbench. Figure 1-33 shows the Move 
toolbar.

Figure 1-33  The Move toolbar

Space Analysis Toolbar
The tools in the Space Analysis toolbar are used to check any interference and clash in the 
assembly, create a section of the assembly, and perform the distance analysis. Figure 1-34 shows 
the buttons in the Space Analysis toolbar.

Figure 1-34  The Space Analysis toolbar

Drafting Workbench Toolbars
To invoke the Drafting workbench, choose the New button from the Standard toolbar and select 
the Drawing option from the New dialog box. Choose the OK button in the New Drawing 
dialog box. Alternatively, choose Start > Mechanical Design > Drafting from the menubar 
to invoke this workbench. The toolbars in Drafting workbench are discussed next.

Drawing Toolbar
The tools in the Drawing toolbar are used to insert a new sheet, create a new view, and so on. 
Figure 1-35 shows the Drawing toolbar.

Figure 1-35  The Drawing toolbar

Views Toolbar
The tools in the Views toolbar are used to generate orthographic, section, detail, or clipped 
view for a solid part or assembly. Figure 1-36 shows the Views toolbar.
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Figure 1-36  The Views toolbar

Generation Toolbar
The tools in the Generation toolbar are used to generate dimensions and assign balloons to 
the assembly drawings. Figure 1-37 shows the Generation toolbar.

Figure 1-37  The Generation toolbar

Other toolbars in the Drafting workbench are similar to those discussed in the Sketcher 
workbench. The tools in these toolbars are discussed in the later chapters.

You will notice a down arrow at the bottom right corner of the buttons in most of the toolbars. 
When you choose this arrow, a flyout will appear. Figure 1-38 shows the flyout that appears 
when the down arrow of the Point button is chosen from the Geometry Creation toolbar.

Note
The flyout, which appears on choosing the down arrow, becomes an independent toolbar if 
you click on the line available on its top, refer to Figure 1-38. This line can be on the top or left 
of the flyout, depending on whether the flyout is horizontal or vertical.

Generative Sheetmetal Toolbars
This workbench can be invoked by choosing Start > Mechanical Design > Generative 
Sheetmetal Design from the menu bar. The toolbars in the Generative Sheetmetal Design 
are discussed next.

Walls Toolbar
The tools in the Walls toolbar are used to create different types of walls. Figure 1-39 shows 
the Walls toolbar.
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Figure 1-38  The drop-down that appears 
when a down arrow is clicked

Figure 1-39  The Walls toolbar

Swept Walls Toolbar
The tools in the Swept Walls toolbar are used to create sweep features. These features are 
created by sweeping a profile along the spline. Figure 1-40 shows the Swept Walls toolbar.

Figure 1-40  The Swept Walls toolbar

Stamping Toolbar
The tools in the Stamping toolbar are used to create different types of stamping features. 
Figure 1-41 shows the Stamping toolbar.

Figure 1-41  The Stamping toolbar
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DMU Kinematics Toolbars
This DMU Kinematics workbench can be invoked by choosing Start > Digital Mockup > 
DMU Kinematics from the menu bar. The toolbars in the DMU Kinematics environment 
are discussed next.

DMU Kinematics Toolbar
The tools in the DMU Kinematics toolbar are used to create mechanisms and simulate the 
mechanism. Figure 1-42 shows the DMU Kinematics toolbar.

Figure 1-42  The DMU Kinematics toolbar

Kinematics Joints Toolbar
The tools in the Kinematic Joints toolbar are used to create different type of joints in the 
mechanism. Figure 1-43 shows the Kinematic Joints toolbar.

Figure 1-43  The Kinematics Joints toolbar

FreeStyle Toolbars
The FreeStyle workbench can be invoked by choosing Start > Shape > FreeStyle from the 
menubar. The toolbars in the FreeStyle environment are discussed next.

Surface Creation Toolbar
The tools in the Surface Creation toolbar are used to create surfaces by using different surface 
creation tools. Figure 1-44 shows the Surface Creation toolbar.
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Figure 1-44  The Surface Creation toolbar

Shape Modification Toolbar
The tools in the Shape Modification toolbar are used to modify the shape of surfaces. 
Figure 1-45 shows the Shape Modification toolbar.

Figure 1-45  The Shape Modification toolbar

Operations Toolbar
The tools in the Operations toolbar are used to perform various operations on a surface 
like trimming, untrimming, fragmentation, and so on. Figure 1-46 shows the Operations 
toolbar.

Figure 1-46  The Operations toolbar
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Hot Keys
CATIA V5 is more popularly known for its icon driven structure. However, you can use the 
keys of the keyboard to invoke some tools. These keys are called as hot keys. Some hot keys 
along with their functions are listed in the table given next.			                          	
	
	 Hot Key    			   Function

	 CTRL+Z			   Invokes the Undo tool

	 CTRL+Y			   Invokes the Redo tool

	 CTRL+S			   Saves the current document

	 ALT+ENTER			   Invokes the Properties tool

	 CTRL+F			   Invokes the Search tool

	 CTRL+U		   	 Invokes the Update tool

	 SHIFT+F2			   Invokes the Specification Overview tool

	 F3				    Toggles the display of the Specification tree

	 SHIFT+F1			   Invokes the What’s This? tool

	 F1				    Invokes the CATIA V5 Help tool
		
	 CTRL+D			   Invokes the Fast Multi-Instantiation tool in the
					     Assembly Design workbench

	 ALT + F4	 	 	 Exits CATIA V5

	 ALT + F8	 	 	 Opens the Macros dialog box on screen

	 ALT + F11			   Opens the Launch V.B.A message box on screen

	 CTRL+C			   Copies the selected feature

	 CTRL+V			   Pastes the copied feature

	 CTRL+X	 	 	 Cuts the selected feature

	 ALT + E			   Opens the Edit menu
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	 ALT + F			   Opens the File menu

	 ALT + H			   Opens the Help menu 

	 ALT + I			   Opens the Insert menu 

	 ALT + V			   Opens the View menu 

	 ALT + S			   Opens the Start menu 

	 ALT + ENTER			  Opens the properties of selected objects

	 CTRL + N			   Opens the New dialog box 

	 CTRL + O			   Opens the File selection window

	 CTRL + P			   Prints document 

Color Scheme
CATIA V5 allows you to use various color schemes as the background screen color, as well as 
to display the entities on the screen. To change the color scheme, choose Tools > Options 
from the menu bar; the Options dialog box will be displayed. Choose General > Display 
option from the left pane of the Options dialog box; the tabs corresponding to this selection 
will be displayed on the right in the Options dialog box. Choose the Visualization tab and 
select the White color from the Background drop-down list. Choose OK to apply the scheme 
to the CATIA V5 environment. Note that all files that you open henceforth will use this color 
scheme. The default color of the sketched elements is white, therefore, you need to change the 
colors of the sketch elements to black. To change the default color, invoke the Options dialog 
box and expand the Mechanical Design branch from the left of this dialog box. Next, expand 
the Sketcher branch and choose Black from the Default color of the elements drop-down 
list. Choose the OK button from the Options dialog box. All sketches drawn after setting this 
option will be displayed in black.

To distinguish between a plane and a background, you need to change the default color 
of the planes. To do so, select the plane and right-click to invoke the shortcut menu. 
Select the Properties option from it; the Properties dialog box is displayed. Choose the 
Graphic tab and then select the Black color from the drop-down list in the Lines and 
Curves area. Choose the OK button to apply the scheme to the CATIA V5 environment. 
Similarly, change the color of the remaining two planes. Figure 1-47 shows the Graphic tab 
of the Properties dialog box.
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Note
If you change the background color of the screen to White, then you will have to change color of 
all the planes, every time you open a new file. The planes include the default xy, yz, and zx planes 
and also the planes that will be created while developing the design. As it is very cumbersome to 
perform this activity every time, it is recommended that you do not change the background color 
of the CATIA V5 environment. 

For the purpose of printing, this book will follow the white background of the CATIA V5 
environment. However, for better understanding and clear visualization at various places, this 
book will follow other color schemes too.

Figure 1-47  The Properties dialog box with Graphic 
tab chosen
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Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 The Part Design workbench is a parametric and feature-based environment in which you 
can create solid models. (T/F)

2.	 A solid model created in CATIA V5 is an integration of a number of features. (T/F)

3.	 Generative drafting is a process of generating drawing views of an existing part or assembly 
created earlier. (T/F)

4.	 By default, the compass is located on the left side of the CATIA V5 window. (T/F)

5.	 The______________ property ensures that any modification done in a model in any one 
of the workbenches of CATIA V5 is automatically reflected in the other workbenches 
immediately.

6.	 The ______________ constraint forces two selected arcs, circles, a point and an arc, a point 
and a circle, or an arc and a circle to share the same center point.

7.	 The ______________ constraint is used to make two points, a point and a line, or a point 
and an arc coincident. 

8.	 The _________ constraint is used to force the selected sketched entities to become symmetrical 
about an axis.

9.	 To ___________the view of the model, you need to press and hold the middle mouse 
button and drag the mouse.

10.	 _____________ are the logical operations that are performed on the selected element to 
define its size and location with respect to the other elements or reference geometries.

Review Questions
Answer the following questions:

1.	 The model created in the Part workbench can be edited in the Wireframe and Surface 
Design workbench. (T/F)

2.	 Features created in FreeStyle workbench do not have a history. (T/F)
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3.	 The View toolbar is available in all the workbenches. (T/F)

4.	 In the FreeStyle workbench, the tools available in the __________ toolbar are used to 
create surfaces.  

5.	 In the Assembly workbench, the tools in the____________ toolbar are used to insert an 
existing part or assembly in the current product file.

Answers to Self-Evaluation Test
1. T, 2. T, 3. T, 4. F, 5. Bidirectional Associativity, 6. Concentric, 7. Coincident, 8. Symmetry, 
9. Pan, 10. Constraints


