
Chapter 1

Introduction to  
Creo Parametric 2.0

After completing this chapter, you will be able to:
• Understand the advantages of using Creo Parametric.
• Understand the bidirectional associative property.
• Know the system requirements of Creo Parametric.
• Learn various important terms and defi nitions in Creo Parametric.
• Learn various important options in the File menu.
• Understand the importance of Model Tree.
• Understand the functions of mouse buttons.
• Learn the use of default toolbars.
• Customize the Ribbon.
• Understand the functions of browser.
• Understand the use of Appearance Gallery.
• Understand the rendering stages in Creo Parametric.
• Change the color scheme of the background in Creo Parametric.

Learning Objectives
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 INTRODUCTION TO Creo Parametric 2.0
Welcome to Creo Parametric. If you are a new user of Creo Parametric software package, 
you are going to join hands with thousands of users of this high-end CAD/CAM/CAE tool 
worldwide. If you are a user of the previous releases of this software, you are going to upgrade 
your designing skills because of the tremendous improvement in this latest release such as 
Flexible modeling, Freestyle modeling, and so on. Also, the interface of Creo Parametric is 
very user friendly. You will fi nd a tremendous reduction in the time taken to complete a design 
using this solid modeling tool. 

Creo Parametric is a powerful software used to create complex designs with  great precision. The 
design intent of a three-dimensional (3D) model or an assembly is defi ned by its specifi cation 
and its use. You can use the powerful tools of Creo Parametric to capture the design intent 
of a complex model by incorporating intelligence into the design. Once you understand the 
feature-based, associative, and parametric nature of Creo Parametric, you can appreciate its 
power as a solid modeler. 

To make the designing process simple and quick, this software package has divided the steps 
of designing into different modules. This means each step of the designing is completed in a 
different module. For example, generally a design process consists of the following steps:

• Sketching using the basic sketch entities.
• Converting the sketch into features and parts.
• Assembling different parts and analyzing them.
• Documenting parts and the assembly in terms of drawing views.
• Manufacturing the fi nal part and assembly.

All these steps are divided into different modes of Creo Parametric namely, the Sketch mode, 
Part mode, Assembly mode, Drawing mode, and Manufacturing mode. 

Despite making various modifi cations in a design, the parametric nature of this software 
helps preserve the design intent of a model with tremendous ease. Creo Parametric allows 
you to work in a 3D environment and calculates the mass properties directly from the created 
geometry. You can also switch to various display modes like wireframe, shaded, hidden, and no 
hidden at any time with ease as it does not affect the model but changes the only appearance 
of the model. The solid models rendering in Creo Parametric is of much better quality than 
earlier releases.  

 FEATURE-BASED NATURE
Creo Parametric is a feature-based solid modeling tool. A feature is defi ned as the smallest 
building block and a solid model created in Creo Parametric is an integration of a number of 
these building blocks. Each feature can be edited individually to bring in the desired change 
in the solid model. The use of feature-based property provides greater fl exibility to the parts 
created. For example, consider the part shown in Figure 1-1. It consists of one counterbore 
hole at the center and six counterbore holes around the Bolt Circle Diameter (BCD). 
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Now, consider a case where you need to change all the outer counterbore holes to drill holes 
keeping the central counterbore hole and the BCD for the outer holes same. Also, you need 
to change the number of holes from six to eight. In a nonfeature-based software package, 
you need to delete the entire part and then create a new part as per the new specifi cations. 
Whereas, Creo Parametric allows you to make this modifi cation by just modifying some values 
in the same part, see Figure 1-2. This shows that the solid parts created in Creo Parametric 
are a combination of various features that can be modifi ed individually at any time.

Figure 1-1  Model displaying the counterbore holes Figure 1-2  Model after making the modifi cations

 BIDIRECTIONAL ASSOCIATIVE PROPERTY
There is a bidirectional associativity between all modes of Creo Parametric. The bidirectional 
associative nature of a software package is defi ned as its ability to ensure that if any modifi cations 
are made in a particular model in one mode, then those modifi cations are also refl ected in 
the same model in other modes. For example, if you make any change in a model in the 
Part mode and regenerate it, the changes will also be highlighted in the Assembly mode. 
Similarly, if you make a change in a part in the Assembly mode, after regeneration, the change 
will also be highlighted in the Part mode. This bidirectional associativity also correlates the 
two-dimensional (2D) drawing views generated in the Drawing mode and the solid model 
created in the Part mode of Creo Parametric. This means that if you modify the dimensions 
of the 2D drawing views in the Drawing mode, the change will be automatically refl ected 
in the solid model and also in the assembly after regeneration. Likewise, if you modify the 
solid model in the Part mode, the changes will also be seen in the 2D drawing views of that 
model in the Drawing mode. Thus, bidirectional associativity means that if a modifi cation is 
made to one mode, it changes the output of all the other modes related to the model. This 
bidirectional associative nature relates the various modes in Creo Parametric.

Figure 1-3 shows the drawing views of the part shown in Figure 1-1, generated in the Drawing 
mode. The views show that the part consists of a counterbore hole at the center and six 
counterbore holes around it.
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Figure 1-3  Drawing views of the model before modifi cations

Now, when the part is modifi ed in the Part mode, the modifi cations are automatically refl ected 
in the Drawing mode, as shown in Figure 1-4. The views in this fi gure show that all outer 
counterbore holes are converted into drilled holes and the number of holes is increased from 
six to eight. 

Figure 1-5 shows the Crosshead assembly. It is clear from the assembly that the diameter of the 
hole is more than what is required (shown using dotted lines). In an ideal case, the diameter 
of the hole should be equal to the diameter of the bolt.

The diameter of the hole can be changed easily by opening the fi le in the Part mode and 
making the necessary modifi cations in the part. This modifi cation is refl ected in the assembly, as 
shown in Figure 1-6. This is due to the bidirectional associative nature of Creo Parametric. 

Since all modes of Creo Parametric are interrelated, it becomes very easy to modify your 
model at any time.

 PARAMETRIC NATURE
Creo Parametric is parametric in nature, which means that the features of a part become 
interrelated if they are drawn by taking the reference of each other. You can redefi ne 
the dimensions or the attributes of a feature at any time. The changes will propagate 
automatically throughout the model. Thus, they develop a relationship among themselves. 
This relationship is known as the parent-child relationship. So if you want to change the 
placement of the child feature, you can make alterations in the dimensions of the references 
and hence change the design as per your requirement. The parent-child relationship will be 
discussed in detail while discussing the datums in later chapters.
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Figure 1-4  Drawing views of the model after modifi cations

Figure 1-5  Diameter of the hole and the bolt in the Crosshead assembly
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Figure 1-6  Model after modifying the diameter of the hole

 SYSTEM REQUIREMENTS
The system requirements for Creo Parametric are given below.

1. Operating System: Windows XP Professional Edition, XP Professional x64 Edition, Windows 
7 (Professional, Ultimate, and Enterprise Editions) or later.

2. Monitor: 1280 x 1024 (or higher) resolution support with 32-bit or more.

3. Processor: 3.0 GHz minimum (Core 2 Duo or higher, as recommended). 

4. Memory: 2GB RAM minimum (3GB RAM or higher, as recommended).

5. Hard disk space: 3.0GB minimum (4.0GB or higher, as recommended).

6. An ethernet adapter interface card or network card.

7. Microsoft approved 3-button mouse.

8. Microsoft Internet Explorer 8.0 or later.

9. A certifi ed and supported graphics card.
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 GETTING STARTED WITH Creo Parametric
Once you have installed Creo Parametric on your system, there are two options to start it.  The 
fi rst option is to choose the Start button at the lower left corner of the screen and then choose 
All Programs > PTC Creo > Creo Parametric 2.0, as shown in Figure 1-7.

The second option to start Creo Parametric is by double-clicking on its shortcut icon on the 
desktop of the computer. Note that the icon will be created on the desktop only if the option 
for displaying the icon on the desktop is selected while installing the software.

Figure 1-7 Figure 1-7  Starting Creo Parametric from the Start menu Starting Creo Parametric from the Start menu

Figure 1-8 shows the screen that appears when you start Creo Parametric.

IMPORTANT TERMS AND DEFINITIONS
Some important terms that will be used in this book while working with Creo Parametric are 
discussed next.

 Entity
An element of the section geometry is called an entity. The entity can be an arc, line, circle, 
point, conic, coordinate system, and so on. When one entity is divided at a point, then the 
total number of entities are said to be two.

 Dimension
It is the measurement of one or more entities.
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Constraint
Constraints are logical operations that are performed on the selected geometry to make it 
more accurate in defi ning its position and size with respect to the other geometry.

Figure 1-8 Figure 1-8  Initial screen appearance after starting Creo Parametric Initial screen appearance after starting Creo Parametric

 Parameter
It is defi ned as a numeric value or a word that defi nes a feature. For example, all dimensions 
in a sketch are parameters. The parameters can be modifi ed at any time.

 Relation
A relation is an equation that relates two entities. 

 Weak Dimensions and  Weak Constraints
Weak dimensions and weak constraints are temporary dimensions or constraints that appear  
in light blue  light blue color. These are automatically applied to the sketch. They are removed from the 
sketch without any confi rmation from the user. The weak dimensions or the weak constraints 
should be changed to strong dimensions or constraints if they seem to be useful for the sketch. 
This only saves an extra step of dimensioning the sketch or applying constraints to it.

 Strong Dimensions and  Strong Constraints
Strong dimensions and strong constraints appear in dark blue color. These dimensions and 
constraints are not removed automatically. All dimensions added manually to a sketch are 
strong dimensions.
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Tip: When several strong dimensions or constraints confl ict, Creo Parametric makes 
the constraints and dimensions appear in blue box, and prompts you to delete one 
or more of them.

File MENU OPTIONS
The options that are displayed when you choose File from the menu bar are discussed next.

 Select Working Directory
A working directory is a directory on your system where you can save the work done in the 
current session of Creo Parametric. You can set any directory existing on your system as the 
working directory. Before starting the work in Creo Parametric, it is important to specify the 
working directory. If the working directory is not selected before saving an object fi le, then 
the object fi le will be saved in a default directory. This default directory is set at the time of 
installing Creo Parametric. If the working directory is selected before saving the object fi les 
that you create, it becomes easy to organize them. In Creo Parametric, the working directory 
can be set in two ways:

 Using the Navigator
When you start a Creo Parametric session, the navigator is displayed on the left of the drawing 
area. This navigator can be used to select a folder and set it as the    

Figure 1-9  Shortcut menu

 
working directory. To do so, click on the Folder Tree node 
displayed at the bottom of the navigator; the expanded Folder 
Tree area will be displayed. Browse to the required location using 
the nodes available with the folders and select the desired 
folder. The selected folder will become the working directory for 
the current session. Alternatively, right-click on the folder that 
you need to set as the working directory; a shortcut menu will 
be displayed, as shown in Figure 1-9. Choose the Set Working 
Directory option from this shortcut menu to set the selected 
folder as the working directory. To make a new folder, choose 
the New Folder option from the shortcut menu.

Using the Select Working Directory Dialog Box
To specify a working directory, choose File > Manage Session > Set Working Directory from 
the menu bar; the Select Working Directory dialog box will be displayed, as shown in 
Figure 1-10. Using this dialog box, you can set any directory as the working directory. 

Choose the arrow at the upper left corner of the Select Working Directory dialog box; a fl yout 
will be displayed; as shown in Figure 1-11. This fl yout displays some of the drives present on 
your computer along with the Favorites folder. The Favorites folder contains all directories 
that you saved as favorites. The procedure to save the favorite directories will be discussed 
later. When the Select Working Directory dialog box is invoked by default, it displays the 
contents of the default directory. However, you can change the default directory that appears 
every time you open this dialog box. Various options in the Select Working Directory dialog 
box are discussed next.
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 File name
 The File name edit box displays the name of the directory selected in the Select Working 

Directory dialog box. You can select a directory using the fl yout, as discussed earlier or 
by entering the path of any existing directory 
in this edit box.

  Type
 The Type drop-down list has two options, 

Directories and All Files (*). If you select the 
Directories option, all directories present get 
listed, and if you select the All Files (*) option, 
then all fi les along with the directories are listed 
in the dialog box.

  Organize
 When you choose the Organize button from the Select Working Directory dialog box, 

a fl yout will be displayed. The options in this fl yout are used to create a new directory or 
rename an existing directory. You can also cut, copy, paste, and delete the existing folders 
using the options in the fl yout. Moreover, you can add any existing folder in the Common 
Folders by using the Add to common folders option in this fl yout, refer to Figure 1-12.

Figure 1-10  The Select Working Directory dialog box  

Figure 1-11  The fl yout with some drives
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Figure 1-12  The Organize 
fl yout

 When you choose the Views button from the Select Working 
Directory dialog box, a fl yout will be displayed. The options 
in this fl yout are discussed next.

  
List. The List option is used to view the contents of the     
current folder or drive. These include fi les and folders 
in the form of a list.

Details. The Details option is used to view the contents 
of the current folder or drive in the form of a table, which 
displays the name, size, and date on which it was last modifi ed.

 Tools
 When you choose the Tools button from the Select Working Directory dialog box, a fl yout 

will be displayed, as shown in Figure 1-13. The options in this fl yout are discussed next.

Address Default. When you select this option, the 
‘Look In’ Default dialog box will be displayed. 
Figure 1-14 shows this dialog box with the options in 
the drop-down list. If you select the Default option 
from the drop-down list and then invoke the File 
Open dialog box, it will display the directory that is 
set as default. If you select the Working Directory 
option from the drop-down list and then invoke the 
File Open dialog box, it will display the working directory that is set. If you select the 
In Session option and then invoke the File Open dialog box, the File Open dialog 
box will open with the In Session folder selected by default. Similarly, you can set the 
Pro/Library as the working directory.

Up One Level. The Up One Level option 

Figure 1-14  The ‘Look In’ Default dialog 
box with options in the drop-down list

allows you to move one level up in the 
directory. Choose this option; a directory 
that is one level above the current 
directory will be displayed. Alternatively, 
press ALT+Up arrow keys or BACKSPACE
key to move one level up. You can also 
choose the arrow button on the left of the 
required directory in the address bar to 
display all folders in it. 

Tip: The Select Working Directory dialog box has some of the properties of the 
Microsoft Windows operating system. You can set the working directory using this 
dialog box by browsing through directories and folders. You can also rename a fi le, 
directory, or a folder in this dialog box. Alternatively, you can create a new directory 
using this dialog box.

Figure 1-13  The Tools fl yout
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 Add to Favorites. The Add to Favorites option allows you to add the folders in the 
Favorites folder.

Remove from Favorites. The Remove from Favorites option allows you to remove 
the folders from the Favorites folder. This option is not enabled by default. To enable 
this option, you fi rst need to add the folder in the Favorites folder using the Add to 
Favorites option.  

Sort By. In the Select Working Directory dialog box, the Directories option in the 
Type drop-down list is displayed by default. From this drop-down list, if you select 
the All Files option and then choose the Tools button; a fl yout will be displayed with 
the Sort By option.

The Sort By option is used to list all fi les in the directory in an order to facilitate 
the process of searching a fi le. When you choose the Sort By option, a cascading 
menu is displayed. In the cascading menu, there are two options, Model Name and 
Markup/Instance Name. If you choose the Model Name option, the fi le list will be 
sorted out alphabetically by the model name in the Select Working Directory dialog 
box. The Markup/Instance Name option sorts out the fi le list by specifi c markups or 
instance names in the Select Working Directory dialog box. 

  Common Folders and Folder Tree
 The Common Folders and Folder Tree tabs are available on the left of the Select Working 

Directory dialog box. The Common Folders contains folders such as Desktop, My 
Documents, Computer, Working Directory, and Favorites. You can add more folders 
in the Common Folders by using the Add to common folders option available in the 
Organize fl yout. 

 The Folder Tree contains all the drives available on your computer along with their 
contents. You can also set the working directory by using the Folder Tree. By default, the 
Folder Tree is in the collapsed state. To expand it, you need to click on the node that is 
available on the left of the Folder Tree. The Working Directory and Favorites folders 
available in the Common Folders are discussed next.

 Working Directory. This folder is used when you have already set the working 
directory. You may browse through the directories in the Select Working Directory 
dialog box, but when you choose this folder, the directory selected previously as the 
working directory is displayed in the list box.

Favorites. This folder is used to save the location of the directories that are to be used 
frequently. You just need to specify the working directory to be used frequently and 
save its location by selecting the Favorites folder.

If you want to select one of the favorite working directories, then select the Favorites 
folder from the Common Folders; the list of all directories that were saved as favorites 
will be displayed in the list box. Select the required favorite directory and choose OK; 
the selected favorite directory will be set as the current working directory. 



Introduction to Creo Parametric 2.0                         1-13

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Note
An object in Creo Parametric is defi ned as a fi le that is created using any of its modes such as 
Part, Drawing, Sketch, and so on.

New NNeeww 
To create a new object, choose the New tool from the Data group of the Home tab in 
the Ribbon or choose the New tool from the Quick Access toolbar; the New dialog 
box will be displayed, as shown in Figure 1-15. This dialog box displays various modes 

available in Creo Parametric. In this dialog box, by default, the Part mode radio button is 
selected and the default name of the object fi le is displayed in the Name edit box. You can 
also enter a new name for the object fi le. Note that the name must not contain a special 
character.

When you select the Part, Assembly, or Manufacturing radio button in this dialog box, the 
subtypes of the respective modes will be displayed under the Sub-type area of this dialog 
box.

Accept the default settings in the New dialog box by choosing the OK button; the default 
template will be loaded. To load a template other than the default one, clear the Use default 
template check box and then choose the OK button; the New File Options dialog box will 
be displayed, as shown in Figure 1-16. Using this dialog box, you can select the predefi ned 
templates or create a user-defi ned template. You can also open an empty template provided 
in the New File Options dialog box. In this case, you need to create the datum planes and 
the coordinate systems manually. 

Figure 1-15  The  New dialog box Figure 1-16  The  New File Options dialog box
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If, the measuring units for creating models is inches, select inlbs_part_solid from the list in 
the Template area and then choose OK from the New File Options dialog box. On doing so, 
the three default datum planes and a coordinate system will be displayed in the drawing area. 
Also, the Model Tree will appear on the left of the screen, as shown in Figure 1-17. 

 
Figure 1-17  The initial screen appearance after entering the Part mode

Open
The Open button is used to open an existing object fi le. When you choose the Open 
option from the File menu or choose the Open button from the Quick Access toolbar, 
the File Open dialog box will be displayed, as shown in Figure 1-18. The selected 

working directory will be displayed in it. Note that the Preview area is not displayed by default. 
To view the Preview area, choose the Preview button. Most of the options in this dialog box 
are same as discussed in the Select Working Directory dialog box. The rest of the options in 
this dialog box are discussed next.

Tools
On choosing this button, a fl yout will be displayed. The options available in this fl yout are 
same as the options discussed in the Tools button of the Select Working Directory dialog box, 
except the All Versions and Show Instances options. These two options are discussed next.   
  
 All Versions

This option, when selected, displays all versions of an object fi le. In Creo Parametric, 
the fi le once saved will generate a new version of it with an extension 1. An object fi le is 
not copied on another object fi le but a new version of it is created. Therefore, every time 
you save an object using the Save option, a new version of it is created on the disk in the 
current working directory.
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 Show Instances
The Show Instances option, when selected, displays all instances of the object fi le. Select the 
required fi le and then select the Show Instances option from the Tools fl yout; all the instance 
of the selected fi le will be displayed.

File name
In the File name edit box, you can enter the name of the existing object fi le that you want 
to open.

Type
The Type drop-down list contains the file formats of various modes available in 
Creo Parametric. It also contains many other file formats that can be imported in 
Creo Parametric. These fi le formats include IGES, SET, STEP, DWG/DWF, Medusa, Inventor, 
Parasolid, Rhino, and so on. 

By default, the Creo Files option is selected in this drop-down list. As a result, you can open 
the fi les created in any mode of Creo Parametric. However, if you select a specifi c mode from 
this drop-down list, only the fi les of the corresponding mode will be displayed. For example, 
if you select Part in the drop-down list, then only the .prt fi les will be displayed. This makes 
the selection and opening of the fi les easy.

Figure 1-18  The File Open dialog box with the Preview area

 Preview
The Preview button is used to preview the model before opening it. On choosing this button, 
you can preview the selected model in the File Open dialog box. You can zoom, pan and 
rotate the model in the preview. Also, you can change the appearance (shaded, wireframe, 
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no hidden, and hidden line) of the model, switch the model between the orthographic and 
perspective views, change the orientation type (dynamic, anchored, delayed, velocity, fl y 
through, and standard) of the model, set the number of frames per second, and refi t the 
preview in the preview screen.

Note
Assembly fi les with the fi le extension .asm can also be previewed by using the Preview button. If 
you are not able to see preview of the assembly fi les in the preview area, then choose the Refresh 
button on the upper right of the File Open dialog box to resize the assembly according to the 
preview area.

There is no Command prompt in Creo Parametric. However, you are provided with prompts in 
the message area. Whenever you have to enter a numerical value or text, a Message Input 
Window will be displayed in the message area. 

 In Session
The In Session folder is available in the Common Folders on the upper left of the File Open 
dialog box. When you choose the In Session folder, all the object fi les that are in the current 
session will be displayed in the display area. The object fi les that you open in Creo Parametric in 
the current session are stored in its temporary memory. This temporary memory is stored in a 
folder named In Session. Once you exit Creo Parametric, the contents of this folder are deleted 
automatically. However, the original fi les are not removed from their actual location.
 

Erase
As discussed earlier, all fi les opened in a session of Creo Parametric are saved in the temporary 
memory. There are three options to erase objects in the temporary memory: Erase Current, 
Erase Not Displayed, and Erase Unused Model Reps. These options are available in the 
Manage Session fl yout in the File menu. The options that are displayed in this fl yout are 
discussed next.

Tip: Suppose you open an assembly that has a component named Nut. Close the 
assembly and now open another assembly that has a component named Nut. Now, 
there are chances that the second assembly you choose to open may open with the Nut 
that was present in the previous assembly. This is because the component with the fi le 
named Nut was already present in the memory of Creo Parametric (in session).

To avoid this error of assemblies, you should erase the fi les in the current session of 
Creo Parametric before opening the next assembly.

 Erase Current         

Figure 1-19  The Erase Confi rm 
message box

The Erase Current option is used to erase the fi le opened 
and displayed in the drawing area. On choosing this 
option, the Erase Confi rm message box will be displayed, 
prompting you to confi rm the erasing of the fi le, as shown 
in Figure 1-19.
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Erase Not Displayed
The Erase option is used to delete the fi les stored in the temporary memory. To do so, choose 
File > Manage Session > Erase Not Displayed from the menu bar; the Erase Not Displayed 
dialog box will be displayed, as shown in Figure 1-20. The fi les that are not open in the current 
session will be displayed in this dialog box. Choose the OK button

Figure 1-20  The Erase Not 
Displayed dialog box

 
from this dialog box to remove these.

Erase Unused Model Reps
This option is used to removes the unused simplified 
representations from the In Session folder. When you choose 
this option from the File menu, a message box will be displayed 
with the message that all the objects which were not displayed 
have been erased.

 Delete
There are two options to delete fi les permanently from the hard 
disk. These options are available in the Manage File fl yout in the 
File menu. The options in this fl yout are discussed next.

 Delete Old Versions
This option is used to delete all old versions of the current fi le. When you choose the Old 
Versions option, you are prompted to enter the name of the object fi le of which the old 
versions have to be deleted. When the Message Input Window is displayed, enter the object 
fi le name in this window. All versions of that fi le will be deleted from the hard disk except 
the latest version.

Delete  All Versions
This option is  used to delete all versions including the current fi le from the hard disk. When 
you choose the All Versions option, a warning is displayed stating that performing this 
function can result in the loss of data. This option is chosen when the fi le is opened and is 
displayed in the drawing area.

Note
If there are simplifi ed representations in the memory, then Object Erase menu will be displayed. 
Choose the Current Obj option if you want to delete object fi les only or you can choose the 
Simpfl d Reps option if you want to delete the representations only.

 Play Trail File
The Play Trail File option is used to recover data in case of a program crash or if you exit 
the session without saving the data. While working in Creo Parametric, a fi le called trail.txt 
is created in its default working directory that would be similar to C:\Users\Public\Documents\. 
The fi le trail.txt contains all the working steps used in the last session. 

To retrieve the data, open the fi le trail.txt in Notepad. If there is more than one such fi le in the 
directory open the latest one. Scroll to the end of this fi le and change the Activate ‘UI Message 
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Dialog’ from ‘yes’ to ‘no’, as shown in Figure 1-21. Save this fi le by choosing File>Save As 
with another name like crash.txt and exit.

Figure 1-21  Modifi ed trail.txt fi le using Notepad

Now, restart Creo Parametric and choose the Play Trail File option from Manage Session. 
Select the fi le crash.txt from the Open dialog box and then choose the Open button; Creo 
Parametric will repeat every step you made in the last session and restore the data.

 Save
The Save option is used to save the objects present in the In Session folder or an 
object in the drawing area. When you choose the Save option from the File menu or 
the Save button from the Quick Access toolbar, the Save Object dialog box will be 

displayed. Also, the name of the current object will be displayed in the Model Name edit box. 
Choose the OK button from the Save Object dialog box to save the object.

 Save a Copy
The Save a Copy option is used to save a copy of the current object in the same working 
directory or in some other directory. When you choose this option from the File > Save As, 
the Save a Copy dialog box will be displayed. Now, you need to specify the new name of the 
object fi le to be saved as a copy and the name of the target directory in the Save a Copy dialog 
box. You can browse through the directories and select the target directory. The fi le will be 
saved in the selected directory.

Using this option, you can also export a fi le in other fi le formats such as Inventor fi le, pdf, 
ACIS, Wavefront fi le, and so on. After specifying the name of the new fi le and the target 
directory, choose the fi le format in which you want to export the fi le from the Type drop-down 
in the Save a Copy dialog box.

 Save a Backup
The Save a Backup option in the Save As fl yout is used to create a backup copy of an object 
fi le in the memory. When you choose this option, the Backup dialog box will be displayed, 
as shown in Figure 1-22. 

In the Model Name edit box of the Backup dialog box, the name of the fi le for which you 
want to create a backup is displayed. In the Backup To edit box, the name of the directory is 
specifi ed where the object will be saved as a backup. If you create the backup of an assembly 
or a drawing object, Creo Parametric will save all its dependent fi les in the specifi ed directory. 
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If you create the backup of a drawing fi le in a different directory, then the part fi le of the 
drawing will also be created automatically in the same directory where backup of the drawing 
fi le is created.

Figure 1-22  The  Backup dialog box

 Rename                 

Figure 1-23  The  Rename dialog box

 
The Rename option in the Manage File fl yout of the 
File menu is used to rename the currently active object 
on the screen. To rename an object, choose this option; 
the Rename dialog box will be displayed, as shown in 
Figure 1-23. Specify the new name of the object in the 
New Name edit box and choose OK. 

 MANAGING FILES
As discussed earlier, a new fi le is generated whenever you save an object. The number of fi les 
generated are directly proportional to the number of times you save that object. So, these 
fi les occupy a lot of disk space. The latest version of the object is of use and should be stored. 
Latest version refers to the highest number that is suffi xed with the fi le name of that object. 
The rest of the fi les called old versions should be deleted from the hard disk, if they are not 
required. 
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Note
To save disk space, you should keep deleting the old versions of a fi le. This is done using the 
File > Manage File > Delete Old Versions option from the menu bar. 

 MENU MANAGER
The Menu Manager contains a set of menus and submenus cascaded in it. It is displayed for 
some particular tasks only. For example, if you choose Operations > Feature Operations 
from the Ribbon, the Menu Manager will be displayed with options to reorder, copy, move, 
or mirror features. Note that the display of the menus depends on the task chosen.

While using the Menu Manager, always complete the option selected by choosing Done or 
Done Sel after the current task is over. This is important when you are in the Drawing mode 
of Creo Parametric. If you are directly selecting one option after another, then it is easy to 
loose track of commands or options in the Menu Manager.

 MODEL TREE         

Figure 1-24  Partial view of the 
Model Tree 

 
The Model Tree stores and displays all features in a 
chronicle. You can select any desired feature of a model 
or an assembly from the Model Tree and apply different 
operations on the selected feature. You can also select the 
feature by right-clicking on it; a shortcut menu will be displayed. 
Move the cursor on the shortcut menu and choose the required 
option from it by using the left mouse button.

When you create a new object fi le, the Model Tree appears and is 
attached to the drawing area by default as shown in Figure 1-24. 
Therefore, the drawing area becomes small. You can hide the 
Model Tree by choosing the Toggle the display of navigation 
area button available below the Model Tree. The Model Tree 
can slide in or slide out, thus increasing or decreasing the  
drawing area. It can also be stretched horizontally to cover the 
drawing area. 

Note
In Creo Parametric, most of the features are created using the Dashboard. The Dashboard is 
displayed below the Quick Access toolbar and it contains all the options to complete the related 
operations on the model.

Tip: By looking at the Model Tree, you can understand the method and approach used 
to create the model. Using the Model Tree, you can modify the features of a model. 
Generally, when you import a model from a different fi le format in Creo Parametric, 
you do not get features of the model in the Model Tree and therefore, you will not 
be able to modify it.
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UNDERSTANDING THE FUNCTIONS OF THE MOUSE 
BUTTONS
While working with Creo Parametric, it is important to understand the function of the three 
buttons of the mouse to make an effi cient use of this device. The various combinations of the 
keys and three buttons of the mouse are listed below:

1. Figure 1-25 shows the functions of the left mouse button. The left mouse button is used 
to make a selection. Using CTRL+left mouse button, you can add or remove items from 
the selection set. 

2. Figure 1-26 shows the functions of the right mouse button. The right mouse button is used 
to invoke the shortcut menus and to query select the items. When you bring the cursor on 
an item, it is highlighted in cyan color. Now, if you hold the right mouse button, a shortcut 
menu is displayed. Choose the Pick From List option from the shortcut menu; the Pick 
From List dialog box will be displayed. You can make selections from this dialog box.

Figure 1-26  Functions of the right mouse buttonFigure 1-25  Functions of the left mouse button

3. Figure 1-27 shows the functions of the middle mouse button in the 3D mode. The middle 
mouse button is used to spin the model in the drawing area and view it from different 
directions.

 The CTRL+middle mouse button is used to dynamically zoom in and out the view. When 
you press and hold the CTRL+middle mouse button and move the cursor up, the view is 
reduced, and you zoom out. When the mouse is moved down, the view is enlarged, and  
you zoom in.

 When you use CTRL+middle mouse button and move the mouse horizontally, the model 
is rotated about a point that is specifi ed as center.

 The SHIFT+middle mouse button is used to pan the object on the screen.
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4. Figure 1-28 shows the functions of the middle mouse button in the 2D mode (sketcher 
environment and Drawing mode). It is used to place dimensions in the drawing area. It 
is also used to confi rm an option or to abort the creation of an entity. 

 The middle mouse button is used to pan view in the Sketch mode and the Drawing 
mode.

Figure 1-28  Functions of the middle mouse 
button in the Sketch mode

Figure 1-27  Functions of the middle mouse 
button in the 3D mode

Note
When you spin the model with the Spin Center ON, the model is rotated about the spin center. 
If the spin center is turned off, then the model is rotated about the cursor. 

RIBBON
Before you start working on Creo Parametric, it is very important for you to understand the 
default Ribbon and tools in the main window. Figure 1-29 shows various default screen 
components in Creo Parametric. The Ribbon is composed of a series of groups, which are 
organized into tabs depending on their functionality. The groups in the Ribbon that initially 
appear on the screen are shown in Figure 1-29. You will notice that all the tools in the groups 
are not enabled. These buttons will be enabled only after you create a part or open an existing 
fi le but the tools that are required for the current session are already enabled. As you proceed 
to enter one of the modes provided by Creo Parametric, you will notice that the tools required 
by that mode are enabled. Additionally, to make the designing easy and user-friendly, this 
software package provides you with a number of groups. Different modes of Creo Parametric 
display different groups. Some of the frequently used groups are shown in Figure 1-29.

 TOOLBARS
In Creo Parametric, there are two toolbars, Quick Access and In-graphics. The toolbar on 
the top of the window is called the Quick Access toolbar and the toolbar on the top of the 
drawing area is called the In-graphics toolbar. 
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Figure 1-29  Default screen components 

In-graphics Toolbar
The In-graphics toolbar, shown in Figure 1-30,

Figure 1-30  The In-graphics toolbar

 
has ten buttons by default. The fi rst button is 
Refi t, which is used to fi t a model on the screen. 
The other buttons are Zoom In and Zoom Out, 
which are used to enlarge or diminish the model 
view, respectively. The Repaint button is used for 
repainting the screen, which helps in removing 
any temporary information from the drawing 
area. You can change the display style by using 
the Display Style drop-down. Using the Named 
Views button, you can change the view.

The next drop-down is Datum Display Filters. 
Using the options in this drop-down, you can 
toggle the display of datums to on/off. You can 
toggle the display of annotations to on/off using 
the Annotation Display button. The last button 
in this toolbar is Spin Center, which is used to toggle the visibility of the spin center on/off. 

 File Menu
The File menu contains options shown in Figure 1-31. These options are used to create a 
new fi le, save a fi le,  print the current fi le, or open an existing fi le. Various other options are 
also available in the menu to manage the current session and fi les. The Options tool is also 



1-24        Creo Parametric for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

available in the File menu. When you choose this tool, the Creo Parametric Options dialog box 
is displayed. Using this dialog box, you can confi gure various parameters of Creo Parametric. 
You can also customize the Ribbon interface.

Figure 1-31  The File menu

 Customizing the Ribbon
To customize the ribbon, choose Options from the File menu; the Creo Parametric Options 
dialog box will be displayed. Select the Customize Ribbon option from the left area of the dialog 
box; the dialog box will be modifi ed. Now, choose Commands Not in the Ribbon option from 
the Choose commands from drop-down in the right area of the dialog box. Next, choose the 
New Group or New Tab button from the dialog box depending on the requirement; the new 
group or tab will be added in the list box below the Customize the Ribbon drop-down in the 
dialog box. Now, choose the button to be added in the new group from the list box available 
below the Choose commands from drop-down and then choose the Add>> button from the 
dialog box; the selected button will be added to the group, refer to Figure 1-32.
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Figure 1-32  Customizing the Ribbon

Creo Parametric  Help
When you choose the Creo Parametric Help button, the Creo Parametric Help dialog box 
will be displayed and you will be prompted to enter the Username and Password. The help 
database is accessible only to the users who have customer account with PTC. 

Command  Search   

Figure 1-33  The command search box

     
The Command Search button is available 
at the top right corner of the program 
window. When you choose this button, the 

search box is displayed, as shown in Figure 1-33. 
You need to enter the fi rst few letters of the 
command to be searched in the box. When you 
enter the fi rst letter in the search box, a list of 
commands starting from that letter will be 
displayed. You can invoke any command by 
selecting it from the list, or you can enter the 
next letter to refi ne your search. On moving the 
cursor on any of the commands in the list, the command will get highlighted in the application 
window as shown in Figure 1-34. Also the path of the command will be displayed below the 
cursor.
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Figure 1-34  Command Search function 

 LearningConnector Button
The LearningConnector button is used to access 200+ video tutorials provided by PTC. 
When you choose this button, the LearningConnector window will be displayed as shown in 
Figure 1-35. When you invoke any tool from the Ribbon, the tutorial corresponding to that 
tool will be displayed in the LearningConnector window.

Figure 1-35  Creo Parametric 2.0 screen with LearningConnector window displayed
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Figure 1-36  Partial view of the navigator

Note
If you want to change the predefi ned unit system, 
choose File > Prepare > Model Properties from 
the menu bar to display the Model Properties 
dialog box. In this dialog box, click on the change 
on the right of the Units option in the Materials 
head; the Units Manager dialog box will be 
displayed with the System of Units tab chosen. 
Next, select the desired unit system from the list 
box and then choose the Set button; the Changing 
Model Units message box will be displayed. 
Choose the OK button from the message box; the 
new unit system will be set and displayed with the 
red arrow on the left.

 NAVIGATOR     
The navigator is present on the left of the drawing 
area and can slide in or out of the drawing area. To 
make the navigator slide in or out, you need to select 
the Toggle the display of navigation area button 
on the bottom left corner of the program window. A 
partial view of the navigator is shown in Figure 1-36. 
It has the following functions:

1. When you browse fi les using the navigator, the 
browser expands and the fi les in the selected 
folder are displayed in the browser.

2. When you open a model, the Model Tree is displayed in the navigation area. 

3. The buttons on the top of the navigator are used to display different items in the navigation 
area. The Model Tree button is used to display the Model Tree in the navigation area. 
This button is available only when a model is opened. The Folder Browser button is used 
to display the folders that are in the local system. The Favorites button is used to display 
the contents of the Personal Favorites folder. 

4. Any other location, if available on your system, can also be accessed by using the 
navigator.

 Creo Parametric BROWSER
The Creo Parametric Browser is present on the right of the navigator. It can slide in and 
out of the navigator by using the Toggle the display of Creo Parametric browser button at 
the bottom left corner of the application window. You can also stretch the browser window 
horizontally. When the Creo Parametric session starts, the browser is displayed on the screen. 
The browser has two tabs. The homepage is linked to ptc.com, by default, and the other tab 
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is linked to the online resources of PTC. You can add more tabs in it, switch between tabs, 
and view the browsing history similar to any other internet explorer. The main advantage of 
using this browser is that you can work on the Creo Parametric fi les and navigate through 
the browser, simultaneously. Figure 1-37 shows the browser with some part fi les displayed in 
it. You can also browse to the required folder, change the display of fi les to thumbnails for 
previewing the fi le, dynamically view the models in a pop-up window, or drag and drop the 
selected fi le into the Creo Parametric window. 

The functions of the browser are listed next. 

1. It is used to preview the Creo Parametric fi les and browse the fi le system.

2. A Creo Parametric fi le can be opened by using the browser by double-clicking on the fi le 
or by dragging it to the drawing area. When you open a fi le using the browser, the model 
is displayed on the screen and the browser is closed automatically.

3. You can access the Creo Parametric user community site.

4. You can connect to your client’s computer and jointly work with them using the 
browser.

Figure 1-37  Creo Parametric browser 
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 APPEARANCE GALLERY
A new library of appearances and real world materials have been added in Creo Parametric. 
You can also add shadows and refl ections to the background. This is useful while rendering 
with a background image. This gives a realistic view to the model.

The Appearance Gallery button is available in the Appearance group of the Render tab in 
the Ribbon. It is used to assign different colors to the model and change its appearances. To 
change the appearance of the model, click on the down arrow beside the Appearance Gallery 
button; a palette will be displayed, as shown in Figure 1-38. Select the required appearance 
from the palette; the Select box will be displayed. Select the entities from the drawing area 
whose appearance you want to change; the appearance of the entities will change. You can 
assign a desired appearance to the entire model or to the individual face of the model, or 
entire assembly or individual component of an assembly. Various areas and options in the 
palette are discussed next.

Search                    
This option is used for searching a specifi c appearance you need. To search an appearance, 
type a keyword related to the appearance to be searched in the Search text box and press 
ENTER; all the appearances matching with the keyword will be searched from all the system 
libraries and they will be displayed in the palette. For example, if you type glass in the text 
box, then ptc-glass will be displayed in the My Appearances area and the Glass library is 
displayed in the Library area.

Figure 1-38  Appearance Gallery

View Options        
You can set the display of the appearance icons in the 
palette by using the View Options fl yout. These options will 
be available when you click on the button at the top-right 
corner of the palette. The icons can be displayed as small 
thumbnails, large thumbnails, names and thumbnails, or 
only names. To do so, invoke the View Options fl yout and 
then choose the required option from it. Choose Rendered 
Samples from the fl yout to view the rendered icons of 
appearances. In this fl yout, the Show Tooltips option is 
chosen by default. As a result, tooltips are always displayed 
for appearances.

Clear Appearance
This option is used to remove the selected appearance from 
the model. To do so, select the appearance and then choose 
this option. Alternatively, fi rst choose this option and then 
select the appearance to be removed from the model.

To remove all appearances assigned to a model, click on 
the black arrow displayed besides the Clear Appearance 
button; a fl yout will be displayed. Next, choose the Clear 
All Appearances option from this fl yout.
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My Appearance
The My Appearance area displays all appearances stored in the startup directory. You can 
also add new appearances to the palette, edit the existing appearance, or delete the selected 
appearance in the Appearance area. To do so, right-click on the appearance icon and then 
choose the required option from the shortcut menu displayed. Note that you cannot delete 
the active appearance.

Model
The Model area consists of the appearances stored and used in an active model. You can edit 
the selected appearance, add new appearances, or select the objects to apply the selected 
appearance by using the shortcut menu as discussed in the My Appearance area.

Figure 1-39  The Appearance Editor

Library            
This area displays the predefined appearances in 
the current library. The library contains appearances 
from the System library and the Photolux library. 
Appearances in the library are grouped in various 
classes such as metals, glass, wood, and so on, based on 
their similar characteristics. The name of the current 
library is displayed on the right of the Library head. 
To assign appearances from other libraries, click on 
the library name; a fl yout will be displayed with a tree 
list of classes and libraries. Browse through the tree 
and select the required library; all appearances in the 
selected library will be listed. From the list displayed, 
you can assign an appearance to the model as well as 
create a new appearance, as discussed earlier.

More Appearances  
Choose the More Appearances button; the Appearance 
Editor will be displayed, as shown in Figure 1-39. The 
Appearance Editor provides options for editing the 
appearance and advanced rendering, thereby providing 
much more realistic images. 

Using the Appearance Editor, you can edit the name, 
description, and keywords of the selected appearance, 
except the default one. The advanced options are given 
under two tabs, Basic and Map. The Basic tab provides 
with various classes and sub-classes of appearances. By 
default, Generic is selected in the Class drop-down list. 
However, you can select the required class and their sub-classes. Also, the properties related 
to selected class such as color, illumination, refl ection, transparency, glossiness, and so on are 
displayed in the Properties area. These properties can be modifi ed by adjusting the sliders 
given next to them. 
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The Map tab allows you to defi ne and apply texture such as wood, fabrics, metals, and so on 
to the model. You can preview the changes made to the model on changing the settings in 
the Appearance Editor.

Edit Model Appearances
Choose this button; the Model Appearance Editor will be displayed. In this editor, all 
appearances used in the model will be displayed along with their properties. The Model 
Appearance Editor is same as Appearances Editor. Using this editor, you can modify the 
properties such as color, texture, shine, and gloss of the model. 

Appearances Manager
Choose this button to display the Appearances Manager window. The Appearances Manager 
window displays two panels. The left panel displays the palette with appearances and libraries 
and the right panel displays the editor with the properties of the active appearance. You can 
set the required values in the Appearances palette and the Appearances Editor. Also, you 
can open an existing library fi le, add and save your own textured fi le. 

 RENDERING IN Creo Parametric
Rendering is a process of generating two-dimensional image of a three-dimensional scene or 
an object to make it more realistic. A rendered image makes it easier to visualize the shape and 
size of 3D object as compared to a wireframe or a shaded image. Rendering also helps you 
express your design intent to other people. You need to alter environments, lights, textures, 
and so on to get a high quality rendered image.Generally, the rendering process includes the 
following stages:

Loading a File
The fi rst step is to load a solid model or an assembly to be rendered.

Applying Appearances 
Next step is to apply the appearances to the model. You can do so by using the Appearance 
Gallery, which has already been discussed.

Applying Scenes 
After applying the appearances, you need to apply scenes to the model. Scenes are predefi ned 
render settings that include lights, rooms, and environmental effects. To set scenes, choose 
the Scene tool from the Scene group of the Render tab in the Ribbon; the Scenes dialog box 
will be displayed, as shown in Figure 1-40. Using this window, you can apply the predefi ned 
settings, edit the current settings, create new scenes, copy a scene, and save the scenes for 
future use. To apply a scene to the model, double-click on the required scene from the Scene 
Gallery area of the Scenes window.
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Figure 1-40  The Scenes dialog box

Creating the Rendering Room
A room sets the stage for rendering the model. The room can be cylindrical or rectangular. 
To create a rendering room, choose the Room tab from the Scenes window. Using the options 
in the Room tab, you can apply appearances to the wall, ceiling, and fl oor of the room, set 
the room orientation with respect to the model, adjust the size of the room and create a 
background to the room, if required.
 

Defi ning Lights
The next step is to defi ne the lighting effects on the model. Adding lights to the model, 
illuminates the model from various angles. To add lights, choose the Lights tab from the 
Scenes window. You can create a light source as well as position them by using the options in 
the Lights tab. 

Shadows are enabled as soon as you add lights to the model. The direction of shadows cast 
by a light bulb, spot light, skylight, or environment type of lights is towards the center of the 
room.
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Adding Effects
Finally, you can add the surrounding effects such as refl ection, tone mapping, background, 
and depth of fi eld. The tone of the image or scene can be set as per the presets such as Studio 
Settings, Indoor Settings, and Outdoor Settings.

Setting the Perspective View
You can set the perspective view of the model that can be used for rendering the model. To 
do so, choose the Perspective view button from the Perspective group in the Render tab 
of the Ribbon. To set the desired angle, invoke the Perspective dialog box by choosing the 
Perspective Settings button from the Perspective group in the Render tab of the Ribbon. 
Using this dialog box, you can adjust the perspective view settings such as Walk Through, 
Fly Through, From To, and Follow Path. You can also adjust the amount of perspective for 
viewing the model by adjusting the eye distance and the focal length.

Rendering the Model
The last step is to render the model. To render the model, choose the Render Setup button 
from the Setup group in the Render tab of the Ribbon; the Render Setup window will be 
displayed. Set the required rendering options in this window. Next, you need to render the 
model with specifi ed settings. To do so, choose the Render Window button from the Render 
group in the Render tab of the Ribbon. If required, modify the render settings and render 
the model again. 

Note
You can toggle between the display of the rendering effects on the model by choosing the Shading 
button from the Display Style drop-down in the In-graphics toolbar.

 COLOR SCHEME USED IN THIS BOOK
Creo Parametric allows you to use various color schemes for the background screen color and 
for displaying the entities on the screen. This textbook will follow the white background of Creo 
Parametric environment for the purpose of printing. However, for better understanding and 
clear visualization at various places, this book will follow other color schemes too. To change 
the color scheme of the background screen, choose File > Options from the menu bar; the 
Creo Parametric Options window will be displayed. Select the System Colors category from 
the left pane of this window. Next, click on the node adjacent to the Graphics category of the 
Colors area in the right pane of this window; different object names will be displayed with color 
drop-downs adjacent to them, refer to Figure 1-41. Choose white color from the Background 
drop-down in this category and choose the OK button to apply the color. 
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Figure 1-41  The System Colors category in the Creo Parametric Options dialog box


