
Chapter 2

Creating Sketches

After completing this chapter, you will be able to:
• Start a new part file
• Draw a line, rectangle, ellipse, circle, arc, point, and spline 
• Create fillets
• Work with guides
• Write text in working environment
• Trim and mirror the sketched entities
• Measure a sketch entity
• Work with display filters

Learning Objectives
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introduction
Almost all the models design in Creo Direct consist of datums, sketched features, and placed 
features. For creating datums and placed features, you do not need to draw sketches. However, 
to create a sketched feature, it is necessary to draw or import its two-dimensional (2D) sketch. 
In Creo Direct, there is no separate sketch environment for creating sketches. You can draw 
sketches directly in the Part environment. The sketch created in the Part mode can be saved 
in the *.prt, *.igs, *.neu, *.stp, or *.zip format. After creating the sketch, you can easily create 
the required feature without switching to any other mode. 

To create any sketch in the Part mode of Creo Direct, certain basic steps have to be followed. 
The following points outline the steps to draw a sketch in the Creo Direct.

1. Starting a New Part File
As discussed earlier, you can create sketches in the Part mode of Creo Direct, as there is no 
separate sketching environment. Therefore to create sketches, first you need to invoke the 
Part mode. 

2. Specifying the Plane for Sketching
By default, the Top plane is selected for sketching. However, you can select any other default 
plane: Right and Front for creating sketch. In addition to the default planes Front, Right, and 
Top, in Creo Direct, you can create additional reference plane as per your requirement. You will 
learn more about selecting planes and creating new reference datum planes in Chapter 4.

3. Sketching the Section Geometry 
The different sketcher tools available in the Part mode can be used to sketch the required 
section geometry. 

4. Measuring the Sketch
You can measure a sketch by using the measuring tools available in the Measure drop-down 
of the Info group in the Home tab. You can measure the sketch in terms of length, diameter, 
angle, and so on.
 

Starting a New Part File
To start a new Creo Direct Part file, choose New from the File menu or choose the New button 
from the Data group in the Home tab of Ribbon; the New dialog box will be displayed with two 
buttons in the Type area. To start a new file in the Part mode, select the Part button from the 
dialog box, if not already chosen, refer to Figure 2-1; a default name of the part file appears 
in the Name edit box. You can change the part name as required. 

You can also change the template file to setup the drawing units. To do so, clear the Use 
default template check box and choose the OK button; the New File Options window will 
be opened. You can select the required template file for the drawing and then choose the OK 
button from the dialog box; the part mode will be invoked with the Home tab chosen in the 
Ribbon, as shown in Figure 2-2.
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Figure 2-1  The New dialog box

Figure 2-2  Initial screen displayed in the Part mode

The navigator is displayed on the left of the drawing area. In the navigator, the Model 
Tree tab is activated by default. You can hide the Model Tree by choosing the Toggle 
the display of the navigation area button available at the bottom left corner of the window.

Once the part mode of Creo Direct is invoked, you can draw sketches for creating the sketched 
features by using the sketching tools available in the Home tab of the Ribbon. The tools 
available for creating sketches in the Home tab are discussed next. 
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Sketching the section geometry
In the Part environment, by default, the Home tab is chosen in the Ribbon. The Sketch and 
Info groups of the Home tab contain tools to draw and measure sketch entities. In this section, 
you will learn to draw and measure sketch entities by using these tools.

Drawing a Line
In Creo Direct, there are two tools that can be used to draw lines: Line/Arc Chain and Tangent 
tool. These tools are available in the Line drop-down in the Sketch group of the Home tab 
in the Ribbon. The Line/Arc Chain tool is used to draw a continuous chain of lines, arcs, or 
combination of lines and arcs by specifying points in the drawing area. The Tangent tool is 
used to create a line tangent to any arc or circle. The procedure to create lines by using these 
tools is discussed next.

Drawing a Line Using the Line/Arc Chain tool
  Ribbon:  Home > Sketch > Line > Line/Arc Chain    

The following steps explain the procedure to create lines by using the Line/Arc Chain 
tool available in the Line drop-down:

1.	 Choose the Line/Arc Chain tool; the line tool will be invoked and a dynamic input edit 
boxes will be displayed attached to the cursor. Also, you will be prompted to specify the 
start point of the line to be created. 

2.	 Specify the X and Y coordinates value of the point location where you want to specify the 
start point of the line. Note that after entering the X value in the X dynamic input edit 
box, you need to press the DOWN key from the keyboard to switch to Y edit box. You can 
also left click in the drawing area to directly specify the point. 

	 As soon as you specify the start of the line, a rubber-band line appears from the selected 
point with the other end attached to the cursor and you will be prompted to specify the 
second point of the line. Note that the X and Y edit boxes of the dynamic input will be 
changed to Length and Angle edit boxes.

3.	 Specify the length and angle of the line to be created in the Length and Angle edit boxes 
of the dynamic input, respectively. On specifying the length and angle value, the line will 
be created and displayed in the drawing area. 

	 As soon as you specify the second point of the line by defining its length and angle, a 
rubber-band line is still appears from the specified point with the other end attached to 
the cursor and you will be prompted to specify the third point of the line. In this way, you 
can keep on creating continuos chain of lines by specifying their length and angle values 
in the dynamic edit boxes.

Note
While drawing the sketch entities in Creo Direct, the symbols of guides will be displayed along 
with the entity being drawn. These symbols help you to specify the creation point for the entity, 



Creating Sketches								                   2-5

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

by displaying the respective guide. For example, after specifying the start point of the line when 
you move the cursor horizontally toward the right or left, the symbol of horizontal guide will be 
displayed along with the rubber band line. Similarly, when you move the cursor vertically upward 
or downward, the symbol of vertical guide will be displayed. In order words, in Creo Direct, the 
guides will be displayed to the entities while drawing them. You will learn more about different 
type of guides later in this chapter.

	 You can also invoke the arc mode and create arcs by using the Line/Arc Chain tool. To 
invoke the arc mode while creating lines, press the S key. Once the arc mode invoked, 
specify the end point of the arc. Figure 2-3 shows a combination of lines and arcs created 
by using the Line/Arc Chain tool.

4.	 Press the middle mouse button to end the line creation. 

Note
If you draw a single line, the color of the line drawn will be green. If you draw multiple lines, 
the color of all the lines drawn will be orange.

After drawing a line(s), when you press the middle mouse button to end the line creation, the 
line(s) drawn is highlighted in green color. In the Part environment, the green color of an entity 
indicates that it is selected. If you press the DELETE key, the selected entity will be erased from 
the drawing area. 

Drawing a Line Using the Tangent Tool
  Ribbon:  Home > Sketch  > Line > Tangent    

The Tangent tool is used to draw a line tangent to entities such as arc, ellipse, circle, 
or a combination of these. To draw a tangent using this tool follow the steps given 
next:

1.	 Choose the Tangent tool from the Line drop-down in the Sketch group; you will be 
prompted to select the start point on an arc or circle.

2.	 Select the entity to specify the start point; a rubber-band line will be attached with the 
cursor. As soon as you specify the second point, a line tangent to the arc will be drawn.
Figure 2-4 shows a tangent line created by using the Tangent tool.  

Figure 2-4  The tangent line created by using 
the Tangent tool

Figure 2-3  The line created by using the Line/
Arc Chain tool
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Note
By default, Top plane is selected as the sketch part. Therefore, when you create any sketch or 
sketch entities, it will be drawn on the Top Plane, by default. However, you can select any plane 
other than default plane for creating sketch by selecting them from the Navigator Tree.

Creating a Rectangle
In Creo Direct, there are three tools available in the Rectangle drop-down that can be used to 
draw different types of rectangles: the Corner, Slant, and Center. The procedures to create 
various types of rectangles are given next.

Creating a Corner Rectangle
  Ribbon:  Home > Sketch > Rectangle > Corner  

You can create a rectangle by specifying two diagonally opposite corners. First corner 
point is the starting point of the rectangle and the second corner point is the end point 
of the rectangle. To create a rectangle by using the Corner tool, you need to follow the 
steps given below: 

1.	 Invoke the Corner tool from the Rectangle drop-down; you will be prompted to select two 
points as corners of the rectangle. Click to specify the first point; you will be prompted to 
specify the second point. Also, the cursor will be attached to the opposite corner of the 
box.

Figure 2-5  The rectangle created by using 
the Corner tool

2.	 Move the cursor to any non-collinear 
desired location in the drawing area and 
then click to specify the second point for the 
diagonal of the rectangle. Figure 2-5 shows 
the rectangle created by using the Corner 
tool.

Creating a Slant Rectangle
  Ribbon:  Sketch > Rectangle > Slant   

You can create an inclined rectangle by using the Slant tool. To do so, you need to 
follow the steps given next.

1.	 Invoke the Slant tool from the Rectangle drop-down; you will be prompted to select 
two points to indicate the first side of the rectangle. Click to specify the first point; a 
red rubber-band line will be displayed with the cursor attached to its end point.

2.	 Specify the second point to create the first side of the rectangle; you will be prompted to 
specify the end point.

3.	 Move the cursor in the perpendicular direction in the drawing area and then click to 
specify the end point for creating rectangle.
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Creating a Center Rectangle
  Ribbon:  Sketch  > Rectangle > Center   

You can create a rectangle by specifying its center and a corner using the Center tool. 
To create a rectangle by using the Center tool, you need to follow the steps given 
next:

1.	 Invoke the Center tool from the Rectangle drop-down available in the Sketch group; you 
will be prompted to specify the center point of the rectangle. Click to specify the center 
point; a red rubber-band box appears with the cursor attached to the end point of the 
diagonal of the rectangle.

2.	 Click at desired point to create the rectangle.

	 Figure 2-6 and 2-7 show the rectangles created by using the Slant and Center tools, 
respectively.

Figure 2-6  The rectangle created with slant 
side using the Slant tool

Figure 2-7  The rectangle created using the 
Center tool

Drawing a Circle
You can draw circles by using the Center and Point, Concentric, 2-Point, 3-Point, and 
Tangent tools. These tools are available in the Circle drop-down in the Sketch group. The 
steps to create a circle by using these tools are given next.

Drawing a Circle Using the Center and Point Tool
  Ribbon:  Sketch > Circle > Center and Point    

The Center and Point tool is used to draw a circle by specifying the center of the 
circle and a point on its circumference. To draw a circle using the Center and Point 
tool, follow the steps given next.  

1.	 Choose the Center and Point tool; you will be prompted to select the center of the 
circle.
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2.	 Click in the drawing area to specify the center of the circle; you will be prompted to select a 
point on the circumference of the circle. Also, an orange rubber-band circle will be displayed 
with the its center at the specified point and the cursor attached to its circumference.

3.	 Move the cursor to specify the size of the circle. Click at a desired point to complete the 
creation of the circle; you will be prompted again to select the center of the circle. 

4.	 Repeat steps 2 and 3 if you want to draw more circles, else press the middle mouse button 
to abort the process.

Drawing a Circle Using the Concentric Tool
  Ribbon:  Sketch > Circle > Concentric    

To draw a circle using the Concentric tool, follow the steps given next:

1.	 Choose the Concentric tool from the Circle drop-down in the Sketch group; you will 
be prompted to select an arc to determine the center. You can select an arc or a circle to 
specify the center point.

2.	 Click on an arc or a circle; the center point of the circle will be defined as the center point 
of the selected arc or circle. Move the mouse and click at the required location to specify 
the radius of the circle to be drawn.

3.	 To finish the process of creating circle, press the middle mouse button.

Drawing a Circle Using the 2-Point Tool

  Ribbon:  Sketch  > Circle > 2-Point    

To draw a circle using the 2-Point tool, follow the steps given next:

1.	 Choose the 2-Point tool from the Circle drop-down; you will be prompted to specify the 
first point on the circumference of the circle.

2.	 As you specify the first point, an orange rubber-band circle will be attached to the circle 
and you will be prompted to select the second point. Move the mouse and click to specify 
the second point; a circle is drawn and you will be prompted again to select the first point 
on the circle to draw the next circle.

3.	 You can press the middle mouse button to finish the process of creating the circle. 

Drawing a Circle Using the 3-Point Tool

  Ribbon:  Sketch > Sketching > Circle > 3-Point    

To draw a circle using the 3-Point tool, follow the steps given next:
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1.	 Choose the 3-Point tool from the Circle drop-down; you will be prompted to specify the 
first point on the circumference of the circle.

2.	 Click to specify the first point at the desired location in the drawing area; you will be 
prompted to select the second point on the circumference of the circle. Move the cursor 
and click to specify the second point in the drawing area.

3.	 As you specify the second point, an orange rubber-band circle will be displayed with the 
cursor attached to it and you are prompted to specify it. Move the cursor to specify the 
third point on the circumference of the circle the circle and click to specify the third point; 
a circle is drawn and you are prompted again to select the first point on the circle to draw 
the next circle.

4.	 You can press the middle mouse button to finish the process of creating the circle. 

Drawing a Circle Using the Tangent Tool
  Ribbon:  Sketch > Circle > Tangent    

The Tangent tool is used to draw a circle tangent to two or three existing entities. This 
tool references other entities to draw a circle. The circle created using this tool 
is drawn irrespective of the points selected on the entities. To draw a circle using the 

Tangent tool between three entities, follow the steps given next:

1.	 Choose the Tangent tool from the Circle drop-down; you will be prompted to select the 
start location on an arc, circle, or line.

2.	 Select the first entity; the color of the selected entity changes to green and you will be 
prompted to select the second location on an arc, circle, or line. Select the second tangent 
entity; you will be prompted to select the third location on an arc, circle, or line. Select 
the third tangent entity; a circle tangent to these three entities is drawn. Note that you 
can click in the screen to specify the third point if you are creating arc tangent to two 
entities.

3.	 To end the process of circle creation, press the middle mouse button.

Drawing a Construction Entities
  Ribbon:  Sketch > Construction Mode    

A construction entity is an entity that is used

Figure 2-8  Construction circle defining 
BCD

 
to align entities, create diametrical or 
radial dimensions, and to reference the 

entities. For example, in the sketch of a flange, 
centers of the circles lie on a particular bolt circle 
diameter (BCD) that is defined using a construction 
circle, refer to Figure 2-8. 
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To create a construction entity, choose the Construction Mode toggle button and then draw 
an entity using the tools available in the Sketch group; the entity will appear dotted in green 
color, indicating that it is a construction entity. 

Drawing an Ellipse
You can draw an ellipse by using the Center & Axis, and 2-Point tools. These tools are 
available in the Ellipse drop-down in the Sketch group. The methods to create an ellipse by 
using these tools are given next.

Drawing an Ellipse Using the 2-Point Tool
  Ribbon:  Sketch > Ellipse >  2-Point   

To draw an ellipse using the 2-Point tool, follow the steps given next:

1.	 Choose the 2-Point tool from the Ellipse drop-down; you will be prompted to select the 
start point of the major axis of the ellipse.

2.	 Click in the drawing area to specify the start point of the major axis; you will be prompted 
to specify the endpoint of the major axis. 

3.	 Click in the drawing area to specify the endpoint; an orange rubber-band ellipse will be 
displayed with the cursor. Also, you will be prompted to select a point on the minor axis 
to define the ellipse.

4.	 Click to specify the point; an ellipse will be created. You can press the middle mouse 
button to end the creation of the ellipse.

Drawing an Ellipse Using the Center & Axis Tool

  Ribbon:  Sketch > Ellipse > Center & Axis    

To draw an ellipse using the Center and Axis tool, follow the steps given next:

1.	 Choose the Center & Axis tool from the Ellipse drop-down; you will be prompted to 
specify the center of the ellipse.

2.	 Click at the desired location in the drawing area to specify the center point; you will be 
prompted to select the endpoint of the major axis of the ellipse. Click in the drawing area to 
specify the point; an orange rubber-band ellipse will be displayed attached with the cursor. 
Move the cursor in the drawing area to specify the size of the ellipse.

3.	 Specify the endpoint on the minor axis of the ellipse; the ellipse will be drawn. 

Drawing an Arc
There are four tools available in the Arc drop-down in the  Sketch group to draw an arc. The 
procedures to draw arcs using these tools are discussed next.
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Drawing an Arc Using the 3-Point / Tangent End Tool
  Ribbon:  Sketch > Arc > 3-Point / Tangent End    

The 3-Point / Tangent End tool is used to draw arcs tangent to an existing entity at 
the endpoint. You can also draw an arc using this tool by defining three points in the 
drawing area. The steps to draw these arcs are discussed next.

1.	 Choose the 3-Point / Tangent End tool from the Arc drop-down; you will be prompted 
to select the start point of the arc.

2.	 Specify three points in the drawing area to draw an three point arc. 

	 If you want to draw an tangent arc using this tool, atleast one sketch entity should be 
available in the drawing area. To do so, invoke this tool, select the endpoint of the 
existing entity. As you select the endpoint, the Target symbol appears at the endpoint of 
the entity, refer to Figure 2-9. This target symbol is green colored and divided into four 
quadrants. 

	 To draw a tangent arc, move the cursor along a tangent direction through a small distance; 
a rubber-band arc appears with one end attached to the specified endpoint and the other 
end attached to the cursor. Next, specify the second point; a arc tangent to the existing 
entity is created.

	 To draw a normal arc using this tool, when the Tangent symbol displayed, move the cursor 
through a small distance in the direction normal to the line, a dotted line displayed and 
you will be prompted to specify the second point of the arc. Click to specify the second 
point; the preview of the normal arc displayed, refer to Figure 2-10 and you will be 
prompted to specify third point. Specify the third point; a normal arc will be created, 
refer to Figure 2-10.

	

Figure 2-9  The Target symbol appears after 
selecting the endpoint of the entity

Figure 2-10  Cursor moved out of the Target 
symbol along the tangent direction
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3.	 Once you are done with creating three point arc, tangent arc, or normal arc using this 
tool, press the middle mouse button to exit the arc creation.

Drawing an Arc Using the Center and Ends Tool
  Ribbon:  Sketch  > Arc > Center and Ends    

To draw an arc using the Center and Ends tool, follow the steps given next:

1.	 Choose the Center and Ends tool from the Arc drop-down; you will be prompted to select 
the center of the arc.

2. 	 Click to specify the center point for the arc in the drawing area; an orange colored center 
mark will appear at that point and you will be prompted to select the start point of the 
arc. As you move the cursor, a dotted circle appears attached to the cursor.

3.	 Specify the start point of the arc on the circumference of the dotted circle; a red rubber-band 
arc will appear from the start point. The length of this arc will change dynamically as you 
move the cursor and you will be prompted to select the endpoint of the arc.

4.	 Move the cursor to specify the size the arc and then click to specify the endpoint of the 
arc; an arc will be drawn between the two specified points.

 
Drawing an Arc Using the Tangent Tool
  Ribbon:  Sketch  > Arc > Tangent  

The Tangent tool is used to draw an arc that is tangent to two or three selected entities. 
To draw an arc between three entities using the Tangent tool, follow the steps given 
next:

1.	 Choose the Tangent tool from the Arc drop-down; you will be prompted to select the start 
point on an arc, circle, or line.

2.	 As soon as you select the first entity, the color of the selected entity will change to green 
and you will be prompted to select the second location on an arc, circle, or line.

3.	 On selecting the second location, you will be prompted to select the third location on 
arc, circle, or line. Select the third entity; an arc is drawn tangent to the three selected 
entities. 

	 Note that you can click on the screen to specify the third point if you are creating an arc 
tangent to two entities. You can continue drawing arcs or press the middle mouse button 
to abort arc creation.
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Drawing an Arc Using the Concentric Tool
  Ribbon:  Sketch > Arc > Concentric  

The Concentric tool is used to draw an arc concentric to an existing arc or circle. To 
draw an arc using the Concentric tool, follow the steps given next:

1.	 Choose the Concentric tool from the Arc drop-down; you will be prompted to select an 
arc to determine the center of the arc to be created. 

2.	 Select an entity; a dotted circle will appear on the screen and you will be prompted to 
select the start point of the arc. Click to specify the start point; an orange rubber-band arc 
will appear with one end attached to the start point. As you move the cursor, the length 
of the arc will change and you will be prompted to select the endpoint of the arc.

3.	 Click to specify the endpoint; the arc will be created concentric to the arc or circle 
selected. 

You can continue drawing another arc or end the arc creation by pressing the middle mouse 
button.

Placing a Point 
  Ribbon:  Sketch  > Point     

Points are used to specify locations. You can use a point as reference for creating 
other geometric elements. Points can also be used for dimensioning the vertices that 
are removed while applying fillets. To draw a point using the Point tool, follow the 
steps given next:

1.	 Choose the Point tool from the Sketch group; you will be prompted to select a location 
for the point.

2.	 As you click to select the location of the point, the point will be placed at that location in 
the drawing area.

Creating a Spline
  Ribbon:  Sketch > Spline   

To draw a spline, choose the Spline tool from the Sketch group. The steps to create 
a spline are discussed next.

1.	 Choose the Spline tool from the Sketch group; you will be prompted to specify the location 
for spline.

2.	 Use the left mouse button to specify the start point for the spline. Similarly, specify 
additional points in the graphics window; a spline will be drawn passing through all 
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specified points. Press the middle mouse button to end the creation of spline. All points 
through which the spline passes are called interpolation points.

Creating Fillets
  Ribbon:  Edit Sketch > Fillet  

A fillet is the arc formed at the intersection of two lines, a line and an arc, or two arcs. 
It is controlled by the radius or diameter dimension of the fillet. The circular fillet 
thus created is an arc with its endpoints tangent to the two lines. The procedure to 
create a fillet is discussed next:

1.	 Choose the Fillet tool from the Edit Sketch group of the Home tab; you will be prompted 
to select the first entity.

2.	 Click on the entity to select as the first entity; you will be prompted to specify the final 
entity.

3.	 Click on the entity to select as the final entity; a fillet will be created between the entities 
selected.

Figure 2-11 shows two unjoined lines and Figure 2-12 shows the circular fillet created between 
them.
 

Figure 2-12  Fillet created between the two unjoined 
lines

Figure 2-11  Two unjoined lines

Figure 2-13 shows two lines that join at a point and Figure 2-14 shows the circular fillet created 
at the joint. The corner is automatically deleted.
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Figure 2-14  Filleted cornerFigure 2-13  Two lines joining at a point

WORKING WITH guideS
Guides are the symbols that are displayed while creating the

Figure 2-15  The Aids dialog box

 
sketches. By using the guides, you can place and orient an 
entity with respect to other entity while creating the 
sketches. For example, while creating a line, if a line 
becomes parallel to another line, Creo Direct displays the 
parallel guide symbol on both the lines. Now, if you confirm 
the line creation, the line is drawn parallel to the other 
line. 

Types of Guides
There are various types of guides in Creo Direct such 
as Vertical, Horizontal, Tangent, and so on, refer to 
Figure 2-15. 

While creating the sketch, the guides will be displayed by 
default. You can toggle the display of guides by using the 
check boxes available in the Aids dialog box. To invoke the 
dialog box, click on the inclined arrow  available in the 
right side of the Aids group of the View tab; the Aids dialog 
box will be displayed, refer to Figure 2-15. Now, you can 
toggle the display of guides by using these check boxes. You can also select the Show guides 
check box to enable or disable the display of all the guides.

Tip: 1. You can specify the decimals value for the precision by entering the value of  decimals 
in the Decimal edit box of the Precision panel group.

2. You can lock the guides while creating the sketches. To do so, press the L key while 
creating the sketch; the guides of the entity will be locked. To unlock the guides, press the 
L key again.   
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Writing text in the sketcher environment
  Ribbon:  Sketch  > Text     

There are various instances when a designer needs to write text on the model, for example, 
to create a label, model number, company name, and so on. In Creo Direct, you can write this 
text in the sketcher environment. 

In the sketcher environment, the text is written using the Text tool available in the 
Sketch group. The following steps explain the procedure to write text in the sketcher 
environment:

Figure 2-16  The Text dialog box

1.	 Choose the Text tool from the expanded 
Sketch group; you will be prompted to select 
the start point of line.

2.	 Click to specify the start point; you will 
be prompted to select the second point 
of line to determine the text height and 
orientation. 

3.	 To write the text upright, the second point 
should be above the start point and in a 
straight line. If the second point is below 
the start point, the text will be written  down 
from right to left. Click to specify the second 
point; the Text dialog box will be displayed, 
as shown in Figure 2-16.

	 After specifying the second point, a 
construction line will be drawn with height 
equal to the distance between the two points. 
The height and orientation of the text depends on the height and angle of the construction 
line, created by specifying two points. If the construction line is drawn at an angle, then 
the text is written at that angle.

4.	 Enter the text in the Text line edit box, which can be up to 79 characters. As you enter 
the text, the text will be displayed dynamically in the graphics window. You can choose 
the desired font of the text from the Font drop-down list. The aspect ratio and the slant 
angle of the text can be controlled by using the slider bars.

Figure 2-17  The text created

5.	 Choose the OK button from the Text 
dialog box to exit it.

	 Figure 2-17 shows the text created by 
specifying the text height as 6.  
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Creating A Reference Coordinate System 
The Coordinate System is created based on the selected geometry. The Csys tool 
in the Engineering group is used to create a coordinate system that will act as a 
reference for dimensioning. You can dimension the splines using the 

coordinate system. Thus, it provides you the flexibility to modify the spline points by specifying 
different coordinates with respect to the coordinate system.

Also, it is used in the Assembly mode of Creo Direct. You will learn more about Assembly mode 
in later chapters. The following steps explain the procedure to create a coordinate system:

1.	 Choose the Csys tool from the Engineering group; you will be prompted to select a 
location for the coordinate system. 

2.	 Click to place the coordinate system at the 

Figure 2-18  The default coordinate system displayed 
after using the Csys tool

desired location on the geometry or on 
the plane; a preview of coordinate system 
with dashboard will be displayed, refer to 
Figure 2-18. You can change the direction 
of the axes by using the options available 
in the Direction 1 and Direction 2 
drop-downs. You can also create 
Coordinate System by selecting two 
edges. After creating the Coordinate 
System, press the middle mouse button 
to exit the tool.

Editing the sketcheD 
entities
While creating a design, there are a number of places where you need to remove the unwanted 
and extended entities. You can do this by using the trimming tools that are available in the 
Edit Sketch group. These tools are discussed next.

Trim Segment
  Ribbon:  Edit Sketch > Trim Segment  

This tool is used to trim the entities that extend beyond the point of intersection. It 
is also used to delete the selected entities. After choosing the Trim Segment tool, 
when you move the cursor over an entity, the entity will be highlighted in green color. 

Now, if you click on line entity, the highlighted entity will be trimmed. 
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Corner
  Ribbon:  Edit Sketch > Corner     

The Corner tool is used to trim two entities at their corners. When you trim entities 
using this option, the portion from where you select the entities is retained and the 
other portion is trimmed. To trim entities using this tool, follow the steps discussed 
next:

1.	 Choose the Corner tool from the Edit    

Figure 2-19  Trimming the lines 

Sketch group; you will be prompted to 
select two entities to be trimmed. 

2.	 Click to select the two entities on the 
sides that you want to retain after the 
trimming action. These two entities must 
be intersecting entities. The entities are 
trimmed from the point of intersection, 
refer to Figure 2-19.

Tip: You can also join two entities by extending them. To do so, choose the Corner 
tool and select the two entities that you want to join; the two entities will get joined 
at a point.

Divide
  Ribbon:  Edit Sketch > Divide     

The Divide tool is used to divide an entity into a number of parts or entities by 
specifying points on it. To do so, follow the steps given next:

1.	 Choose the Divide tool from the Edit Sketch group; you will be prompted to specify a 
point on entity to be divided.

2.	 Click to select the entity such as line, spline, and so on, at the point where you want to 
divide it; the entity is divided into two different entities. They can now be treated as two 
separate entities.

3.	 Similarly, you can break other entities like circles or arcs into several small entities.

Mirror
  Ribbon:  Edit Sketch > Mirror     

The Mirror tool is used to mirror sketched geometries about a line and thus helps in 
saving the time required to create the sketched entities. To mirror the sketched entity, 
follow the steps given next:
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1.	 Select the entities that you want to mirror, refer to Figure 2-20; the selected entities turn 
green in color.

2.	 Choose the Mirror tool from the Edit Sketch group; you will be prompted to select the 
line about which you want to mirror. Select the line, refer to Figure 2-20; the selected 
entities will be mirrored about the line, refer to Figure 2-21. 

Figure 2-20  Selecting the entities to be mirror 
about the mirror line

Figure 2-21  Sketch after mirroring the 
geometries

Measuring the basic entities
You can measure the sketched entities by using the measuring tools. Procedures to measure 
the sketch are given below.

Measuring the length
  Ribbon:  Info > Measure > Length  

You can measure the length of the sketched entity by using the Length tool. To do so, 
choose the Length tool from the Measure drop-down in the Info group; you will be 

prompted to select the references for length analysis. When you select a line as reference whose 
length to be measure; the length of the line will be displayed in a box attached to the line, 
refer to Figure 2-22. 

Measuring the Angle
  Ribbon:  Info > Measure > Angle  

To measure the angle between two entities, choose the Angle tool from the Measure 
drop-down in the Info group; you will be prompted to select the references for angle 

analysis. Now, hold the CTRL key and select two lines for reference between which you want 
to measure angle. As you select the lines, the angle will be displayed in a box attached to the 
line, as shown in Figure 2-23. 
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Figure 2-23  Angular measurementFigure 2-22  Linear measurement

Measuring the Diameter
  Ribbon:  Info > Measure > Diameter  

For diameter measurement, choose the Diameter tool from the Measure drop-down in 
the Info group; you will be prompted to select the references for diameter analysis. 

When you select the circle as reference, the diameter of a circle will be displayed in a box with 
arrow attached with the circle, as shown in Figure 2-24. Note that you can not measure the 
diameter of circle while creating it. 

Measuring the Distance
  Ribbon:  Info > Measure > Distance  

The Distance tool is used to measure the distance between the two entities of a sketch. 
To measure a sketch using this option, follow the steps given next:

1.	 Choose the Distance tool from the Measure drop-down; you will be prompted to select 
the references for measuring the distance. 

2.	 Hold the CTRL key and then click on the entities. The color of the entities changes from 
orange to green and the distance between them will be displayed in a box, as shown in 
Figure 2-25.

Figure 2-24  Diameter measurement Figure 2-25  Distance measurement 
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Measuring the Area
  Ribbon:  Info > Measure > Area  

To measure the area of a closed section, choose the Area tool from the Measure drop-down 
in the Info group; you will be prompted to select the references for area analysis. Now, 

select all the entities that define a region by pressing the CTRL key; the measurement will be 
displayed in a box with an arrow attached to the entity, as shown in Figure 2-26. 

Measuring the Volume
  Ribbon:  Info > Measure > Volume  

To measure the volume of solid body, choose the Volume tool from the Measure 
drop-down in the Info group; you will be prompted to select the references for volume 

analysis. Now, select the body whose volume is to be measured; the volume measured will be 
displayed in a box attached to the entity, as shown in Figure 2-27. 

Figure 2-27  Volume measurementFigure 2-26  Area measurement 

Generating the Summary
  Ribbon:  Info > Measure > Summary  

You can use the Summary tool to get the summary of the measurements related to an 
entities selected. To do so, choose the Summary tool from the Measure drop-down in 

the Info group; you will be prompted to select references for summary analysis. Select the 
surfaces whose summary to be generated. If you select a surface, the summary related to 
measurements will be displayed, as shown in Figure 2-28.

Measuring Mass Properties
  Ribbon:  Info > Measure > Measure Mass Properties  

By using the Measure Mass Properties tool, you can get the mass properties of an object 
such as density, volume, center of gravity, moment of inertia, and so on. To do so, choose 

the Measure Mass Properties tool available in the Measure drop-down of the Info group in 
the Home tab; the mass properties of the selected object will be displayed, as shown in 
Figure 2-29.
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Figure 2-28  The information displayed after 
using the Summary tool

Figure 2-29  The information displayed after 
using the Measure Mass Properties tool

Note
You will learn about creating 3D objects in later chapters.

Clearing all selections
You can remove all the measurements by using the Clear all selection tool. This tool 
will be available in the Measure toolbar only when you choose a measuring tool. This 

tool is used to remove all measurements from the entity. To remove the measurements, choose 
the Clear all selections tool; all the measurements will be removed.

Drawing display options
While working with complex sketches, sometimes you need to increase the display of a particular 
portion of a sketch so that you can work on the minute details of the sketch. For example, while 
drawing the sketch of a piston and you need to work on the minute details of the grooves of 
the piston rings. To work on these minute details, you will have to enlarge the view of these 
grooves. You can enlarge or reduce the view of the drawing using various drawing display tools 
provided in Creo Direct. These tools are available in the In-Graphics toolbar. Some of these 
drawing display options are discussed next. The remaining drawing display options will be 
discussed in the later chapters.

Zoom In
This tool is available in the In-Graphics toolbar and is used to enlarge the view of the 
drawing on the screen. After choosing the Zoom In tool from the In-Graphics toolbar, 
you will be prompted to define a box. The area that you will enclose inside the box 

will be enlarged and displayed in the drawing area. Note that when you enlarge the view of 
the drawing, the original size of the objects is not changed. To exit the Zoom tool, right-click 
in the drawing area.

Zoom Out
This tool is available in the In-Graphics toolbar and is used to reduce the view size 
of the drawing on the screen, thus increasing the drawing display area. Each time you 
choose this button, the display size of the entity in the drawing area is reduced. 



Creating Sketches								                   2-23

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Note
Scrolling the mouse down will zoom in and scrolling it up will zoom out the view. 1.	
Alternatively, when you use CTRL+middle mouse button and drag the mouse upward, the 
sketch is zoomed out and when you drag the mouse downward, the sketch is zoomed in.

Use SHIFT+middle mouse button to pan the model.2.	

Refit
This tool is available in the In-Graphics toolbar. It is used to reduce or enlarge the 
view such that all entities that form the sketch are fitted inside the current display. 
Note that the dimensions may not necessarily be included in the current display.

Repaint
While working with complex sketches, some unwanted temporary information is 
retained on the screen. It may include the shadows of the deleted sketched entities, 
dimensions, and other information. This unwanted information can be removed from 
the drawing area by using the Repaint tool available in the In-Graphics toolbar.

Sketcher Display Filters
While working with the sketches, sometimes you need to disable the display of some of the 
sketcher components such as grids, precision panel, and so on. You can disable or enable their 
display using the options available in the Grid group of the View tab. Also, you can modify 
the grid settings. The options available in the Grid group are discussed next. 

Grid
  Ribbon:  View > Grid > Grid    

You can use the Grid tool to set the parameters of grids on the screen. When you 
choose this tool, the Grid Settings dialog box will be displayed, as shown in Figure 2-30. 
The options available in this dialog box are explained next.

Grid Type               
The options in this area are used to set the type of grids. There are two radio buttons available in 
this area. When you choose the Cartesian radio button, the display of grids will be rectangular. 
When you choose the Polar radio button, the display of grids will be circular. 

Grid Spacing
The options in this area are used to specify the spacing between grid lines. There are two 
radio buttons available in this area. When you choose the Dynamic radio button, the spacing 
between both X and Y direction is symmetrical. But, if you choose the Static radio button, you 
can specify the spacing values in the X Spacing and Y Spacing edit boxes.
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Figure 2-30  The Grid Settings dialog box

Grid Orientation
The options in this area are used to set the orientation of grids with respect to an active plane. 
You can specify the value of orientation by setting the values in the Angle edit box. 

Disp Grid
  Ribbon:  View > Grid > Disp Grid    

You can use this check box to enable or disable the view of the grid. Sometimes you may not 
be able to see the grid as it becomes very dense. To see the grid in such cases, you need to 
zoom in the screen to see grid.
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Tutorials
Tutorial 1

In this tutorial, you will draw the sketch of the model shown in Figure 2-31. The sketch is 
shown in Figure 2-32. The dimensions are given for the reference only.				  
		       						        (Expected time: 30 min)

Figure 2-32  Sketch of the modelFigure 2-31  Model for Tutorial 1

	 The following steps are required to complete this tutorial:

a.	 Start Creo Direct session.
b.	 Set the working directory and create a new part file.
c.	 Draw lines by using the Line/Arc Chain tool, refer to Figure 2-34.
d.	 Draw circles, refer to Figures 2-35.
e.	 Save the sketch and close the file.

Starting Creo Direct
	 Start Creo Direct by double-clicking on the Creo Direct 2.0 icon on the desktop of your 

computer. Alternatively, choose Start > All Programs > PTC Creo > Creo Direct 2.0 
from the taskbar.

Setting the Working Directory
	 After the Creo Direct session is started, first set the working directory where you will save 

the work done in the current session. You can also set an existing directory on your system 
as the working directory. Since it is the first tutorial of this chapter, you also need to create 
a folder with the name c02.

1.	 Choose the Select Working Directory option from the Manage Session flyout of the File 
menu; the Select Working Directory dialog box is displayed. Alternatively, you can select 
the Select Working Directory button from the Data group in the Home tab to open the 
Select Working Directory dialog box.

2.	 In the dialog box, browse to C:\CreoDirect2.0 folder in the Select Working Directory dialog 
box, refer to Figure 2-33. If the CreoDirect2.0 folder does not exist, create this folder before 
setting the working directory.
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Figure 2-33  The CreoDirect2.0 folder selected in the Select 
Working Directory dialog box

3.	 Choose the Organize button from the top of the Select Working Directory dialog box to 
display the flyout. Choose the New Folder option from the flyout; the New Folder dialog 
box is displayed.

4.	 Enter c02 in the New Directory edit box and choose OK from the New Folder dialog 
box; a new folder named c02 is created at C:\CreoDirect2.0.

5.	 Choose OK from the Select Working Directory dialog box to set the working directory to 
C:\CreoDirect2.0\c02; the message Successfully changed to C:\CreoDirect2.0\c02 directory 
is displayed in the message area. 

Starting a New Object File 
1.	 Choose the New tool from the Quick Access Toolbar or press CTRL+N; the New  

dialog box is displayed. In this dialog box, select the Part button from the Type 
area; the default name of the file appears in the Name edit box.

2.	 Enter c02tut01 in the Name edit box and choose the OK button; the Part mode is 
invoked.

     	 When the Part mode is invoked, the Model Tree is displayed on the left of the drawing 
area.

3.	 Choose the Toggle the display of the navigation area button available at the bottom 
left corner of the screen to close the Model Tree. On closing the tree, the drawing 
area is increased.
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Creating the Sketch
1.	 Choose the Line/Arc Chain tool from the Line drop-down available in the Home

tab; the cursor is changed to dynamic input cursor with X and Y coordinates 
values of the current location of the cursor displaced in it. Note that as you move 
the cursor the coordinate values will be modified accordingly.

2.	 Choose the Sketch Plan View tool from the In-graphics toolbar to make the 
sketching plane parallel to the screen.

3.	 Specify 6 in the X edit box of the dynamic input. 

4.	 Next, press the down key; the Y edit box is activated. Specify 3 in the Y edit box and press 
ENTER; the start point of the line is specified and one end of the line is attached to the 
cursor.

5.	 After specifying the coordinates, press ENTER; the start point of the line is specified and 
one end of the line is attached to the cursor. 

6.	 Move the cursor vertical downward; a symbol of vertical guide is displayed. 

7.	 Specify 3 as the length of the line in the dynamic input. Next, press ENTER; the vertical 
line of length 3 is created.  

8.	 Move the cursor horizontally toward the left; a symbol of horizontal guide is displayed. 

9.	 Specify 12 as the length of the line in dynamic input and press ENTER.

10.	 Move the cursor vertically upward in the drawing area; a vertical rubber-band line extends 
with it. Notice that at a particular point where the length of the left vertical line is equal to 
the length of the right vertical line, the L guide symbol is displayed on both the vertical 
lines.  

11.	 When the L guide symbol appears on the vertical line, click to specify the endpoint of the 
vertical line. The rubber-band line is still attached to the cursor. Press the middle mouse 
button to end the line creation, refer to Figure 2-34.

12.	 Choose the Center and Point tool from the Circle drop-down of the Sketch group in  
the Home tab; you will be prompted to specify the center of circle.

13.	 Specify the coordinates as 0, 7 in the X and Y edit boxes of the dynamic input as the center 
of the circle; you will be prompted to specify the radius of circle.

14.	 Specify the radius of circle as 2.5 in the dynamic input; the circle is created. 

15.	 Similarly, create the other circle with centerpoint and radius values as 0, 7 and 4, 
respectively. Figure 2-35 shows the two circles created. 
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Figure 2-34  Line created with the center point 
of the sketch

Figure 2-35  Two circles of radii 
2.5 and 4

16.	 Choose the Line/Arc Chain tool from the Sketch group of the Home tab; you are prompted 
to specify the start point of the line. 

17.	 Click on the point created in step 5; you will be prompted to specify the next point of the 
line. 

18.	 Hover the cursor on the circle of radius 4 and click when the tangent symbol appears; the 
tangent line is created. 

19.	 Similarly, draw the other tangent line, refer to Figure 2-36.

20.	 Choose the Trim Segment tool available in the Edit Sketch group of the Home tab; you 
are prompted to select entities to trim.

21.	 Select the unwanted entiities to trim; the sketch of the model is created, as shown in 
Figure 2-37.

Figure 2-36  Tangent lines created Figure 2-37  Sketch of the model created after 
trimming the unwanted entities
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Saving the Sketch
1.	 Choose the Save tool from the Quick Access Toolbar; the Save Object dialog 

box is displayed with the name of the sketch that you had entered earlier.

2.	 Choose the OK button; the sketch is saved.

3.	 After saving the sketch, choose the Close button from the Quick Access 
Toolbar.  

Tutorial 2
In this tutorial, you will draw the sketch for the model shown in Figure 2-38. The sketch is 
shown in Figure 2-39. For your reference, all entities in the sketch are labeled alphabetically.	
		      						          (Expected time: 30 min)

Figure 2-39  Sketch of the modelFigure 2-38  Model for Tutorial 2

	 The following steps are required to complete this tutorial:

a.	 Set the working directory and create a new part file.
b.	 Draw the sketch, refer to Figure 2-39.
c.	 Save the sketch and close the file.

Setting the Working Directory
	 The working directory was selected in Tutorial 1, therefore you do not need to select the 

directory again. But, if a new session of Creo Direct is started, you need to set the working 
directory again by following the steps given next.

1.	 Open the Navigator (if it is in collapsed state) by clicking on the Toggle the display  
of the navigation area button on the bottom left corner of the Creo Direct main 
window; the Navigator is displayed. At the bottom of the Navigator, the Folder Tree 
is displayed in the Folder Browser tab. Click on the Folder Tree button; the Folder Tree 
expands.
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2.	 Click on the right arrow adjacent to the CreoDirect2.0 folder in the Navigator; the contents of 
the CreoDirect2.0 folder are displayed.

3.	 Now, right-click on the c02 folder; a shortcut menu is displayed. From the shortcut menu, 
choose the Set Working Directory option; the working directory is set to c02.

4.	 Close the Navigator by clicking on the Toggle the display of the navigation area button 
located at the bottom left corner of the main window; the Navigator slides in.

Starting a New Object File 
1.	 Choose the New tool from the Quick Access Toolbar; the New dialog box is 

displayed. Select the Part button from the Type area of the New dialog box; the 
default name of the sketch appears in the Name edit box.

2.	 Enter c02tut02 in the Name edit box and choose OK; the sketcher environment of the 
Part mode is invoked.

Drawing the Sketch
	 The sketch in Figure 2-38 consists of only lines. For understanding, all the lines in the 

sketch are labeled alphabetically.

1.	 Choose the Line/Arc Chain tool from the Line drop-down of the Sketch group; 
you are prompted to specify the start point of the line. 

2.	 Choose the Sketch Plan View tool from the In-graphics toolbar to make the 
sketching plane parallel to the screen.

3.	 Specify 360 in the X edit box of the dynamic input. 

4.	 Next, press the down key; the Y edit box is activated. Specify 0 in the Y edit box and press 
ENTER; the start point of the line is specified and one end of the line is attached to the 
cursor.

5.	 After specifying the coordinates, press ENTER; the start point of the line is specified and 
one end of the line is attached to the cursor. 

6.	 Next, move the cursor horizontally in left direction to create the line A, refer to Figure 2-32. 
You will notice that as you move the cursor, the horizontal guide symbol is displayed with 
the line. Move the cursor toward the left and enter 360 for specifying the endpoint of the 
line.

7.	 Next, move the cursor vertically upward so that the vertical guide appears on the line. 
Enter 360 in the dynamic input to specify the endpoint of line B; the line B is created.

8.	 Move the cursor to the right direction in the drawing area and enter 100 in the dynamic 
input to specify the endpoint of line C.  
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9.	 Now, to draw line D, move the cursor in vertical downward direction and enter 50 in the 
dynamic input to specify the endpoint of line D. 

10.	 Next, move the cursor in the South-West, you will notice that in the dynamic input the 
Length and angle edit boxes will be displayed. 

11.	 Press the SPACE key two times; the Length and Angle edit boxes will be changed to X 
and Y coordinate edit boxes. 

12.	 Specify the value of X and Y coordinates as 50, 281 and press ENTER; the line E is 
created. 

13.	 Move the cursor in vertical downward direction and specify the length of line as 231; the 
line F is created.

14.	 Move the cursor in horizontally right direction and specify the length of line as 140; the 
line G is created.

15.	 Move the cursor in vertically upward direction and specify the length of line as 231; the 
line H is created.

16.	 Next, move the cursor in North-West direction, you will notice that in the dynamic input 
the Length and angle edit boxes will be displayed. 

17.	 Press the SPACE key two times; the Length and Angle edit boxes will be changed to X 
and Y coordinate edit boxes. 

18.	 Specify the value of X and Y coordinates as 140, 310 and press ENTER; the line I is 
created. 

19.	 Move the cursor in vertically upward direction and specify the length of line as 50; the 
line J is created.

20.	 Move the cursor in horizontally right direction and specify the length of line as 100; the 
line K is created.

21.	 Move the cursor in vertically downward direction and specify the length of line as 310; 
the line L is created.

22.	 Move the cursor in horizontally right direction and specify the length of line as 120; the 
line M is created. 

23.	 Next, move the cursor in vertically downward direction and specify the length of line as 
50; the line N is created.
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Saving the Sketch
	 Now, you need to save the sketch because you may need the sketch to create a 3D 

model.

1.	 Choose the Save button from the Quick Access Toolbar; the Save Object dialog 
box is displayed with the name that you had specified earlier.

2.	 Choose the OK button; the sketch is saved.

Tutorial 3
In this tutorial, you will draw the sketch of the model shown in Figure 2-40. The sketch is 
shown in Figure 2-41.						         (Expected time: 30 min)

Figure 2-41  Sketch of the modelFigure 2-40  Model for Tutorial 3

	

The following steps are required to complete this tutorial:

a.	 Set the working directory and create a new part file.
b.	 Draw the sketch using sketcher tools, refer to Figure 2-42.
c.	 Apply fillets at two corners of the sketch, refer to Figure 2-44.
d.	 Save the sketch and exit the Sketch mode.

Setting the Working Directory
	 The working directory was selected in Tutorial 1, and therefore there is no need to select 

the working directory again. But if a new session of Creo Direct is started, then you have 
to set the working directory again by following the steps given next.

1.	 Open the Navigator by clicking on the Toggle the display of the navigation area button 
on the left corner of the Creo Direct window; the Navigator slides out. In the Navigator, 
the Folder Tree is displayed at the bottom. Click on the black arrow that is available at 
the right-side of the Folder Tree; the Folder Tree expands.

2.	 Click on the node adjacent to the CreoDirect2.0 folder in the Navigator to display the 
context of this folder.
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3.	 Now, right-click on the c02 folder to display a shortcut menu. From this shortcut menu, 
choose the Set Working Directory option; c02 is set as the working directory.

4.	 Close the Navigator by clicking on the Toggle the display of the navigation area button; 
the Navigator slides in.

Starting a New Object File
1.	 Start a new object file in the Part mode. Name the file as c02tut3.

Drawing the Sketch
1.	 Choose the Line/Arc Chain tool from the Line drop-down of the Sketch group; 

you are prompted to specify the start point of the line. 

2.	 Choose the Sketch Plan View tool from the In-graphics toolbar to make the 
sketching plane parallel to the screen.

3.	 Specify -240 in the X edit box of the dynamic input. 

4.	 Next, press the down key; the Y edit box is activated. Specify 55 in the Y edit box and 
press ENTER; the start point of the line is specified and one end of the line is attached 
to the cursor.

5.	 After specifying the coordinates, press ENTER; the start point of the line is specified and 
one end of the line is attached to the cursor.

6.	 Next, move the cursor in vertical downward direction and enter 55 in the dynamic input. 
to specify the second point.

7.	 Next, move the cursor in horizontally right direction and enter 480 in the dynamic input 
to specify the third point.

8.	 Next, move the cursor in upward direction and enter 55 in dynamic input to specify the 
fourth point. Next, join the fourth and first point of the sketch.

9.	 Choose the Center and Point tool from the Circle drop-down of the Sketch group in  
the Home tab; you are prompted to specify the center of the circle.

10.	 Specify the coordinates for center of the circle as 0,101; you will be prompted to specify 
the radius of the circle.

11.	 Specify the radius of the circle as 28; the circle is created. Similarly, create the other circle 
with center point and radius as 0,101 and 65, respectively. 
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12.	 Choose the Tangent tool from the Line

Figure 2-42  Tangents created

drop-down of the Sketch group in the 
Home tab; you are prompted to select the 
entity to which the tangent line is to be 
drawn.

13.	 Click on the circle of radius 65; the dynamic 
input is displayed with Length and Angle 
edit boxes. Also, a tangent symbol is 
displayed with the point specified.

14.	 Move the cursor in the vertical downward 
direction and join the horizontal line; the 
tangent line is created. 

15.	 Similarly, create the other tangent line, refer to Figure 2-42.

16.	 Choose the Trim Segment tool available in the Edit Sketch group of the Home tab and 
trim the unwanted entities, as shown in Figure 2-43.

17.	 Choose the Fillet tool available in the Edit Sketch group of the Home tab; you are prompted 
to select reference entities to create the fillet.

18.	 Apply fillet to the corners of the sketch with fillet radius as 15. Figure 2-44 shows the 
sketch of the model after applying the fillet.

Figure 2-43  Sketch after trimming the unwanted 
entities

Figure 2-44  Sketch of the model after creating 
the fillets

Saving the Sketch
	 Now, you can save the sketch because you may need the sketch to create a 3D model.

1.	 Choose the Save button from the Quick Access Toolbar; the Save Object dialog 
box is displayed with the name of the sketch that you had entered earlier.

2.	 Choose the OK button; the sketch is saved.
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3.	 After saving the sketch, choose the Close button from the Quick Access 
Toolbar.  

Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 When you draw a sketch, the guides are also displayed by default. (T/F)

2.	 In Creo Direct, you can create lines that are tangent to two circles. (T/F)

3.	 You can edit the sketch entities from the Model Tree. (T/F)

4. 	 You can measure the number of sketch entities at a time. (T/F)

5.	 While drawing a circle, first you need to specify its diameter. (T/F)

6.	 The Trim tool lies in the__________ group of the Ribbon.

7.	 A sketch can be modified by changing its __________. 

8.	 The Model Tree is on by default when you enter the Part mode. (T/F)

9.	 In the Part mode, the tangent guide is represented by a __________ symbol. 

10.	 The file created in the Part mode is saved with a __________ file extension.

Review Questions
Answer the following questions:

1.	 You can dynamically modify the geometry of a sketch. (T/F)

2.	 You can use the Rectangle button from the Sketch group to draw a square. (T/F)

3.	 The tools available in the ___________ group are used to measure on entity manually.

4.	 You cannot undo a previous operation in the sketcher environment. (T/F)
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Exercises

Exercise 1 
In this exercise, you will draw the sketch of the model shown in Figure 2-45. The sketch is 
shown in Figure 2-46.                                                                  	     (Expected time: 30 min)

Figure 2-46  Sketch of the modelFigure 2-45  Solid model for Exercise 1

                                                                                     

Exercise 2
In this exercise, you will draw the sketch of the model shown in Figure 2-47. The sketch is 
shown in Figure 2-48.                                                                        (Expected time: 30 min)

Figure 2-48  Sketch of the modelFigure 2-47  Solid model for Exercise 2
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Exercise 3
In this exercise, you will draw the sketch of the model shown in Figure 2-49. The sketch is 
shown in Figure 2-50.                                                                        (Expected time: 30 min)

Figure 2-49  Solid model for Exercise 3 Figure 2-50  Sketch of the model

Exercise 4
In this exercise, you will draw the sketch of the model shown in Figure 2-51. The sketch is 
shown in Figure 2-52.                                                                        (Expected time: 30 min)

Figure 2-51  Solid model for Exercise 4 Figure 2-52  Sketch of the model
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Exercise 5
In this exercise, you will draw the sketch of the model shown in Figure 2-53. The sketch is 
shown in Figure 2-54.                                                                        (Expected time: 30 min)

Figure 2-53  Solid model for Exercise 5 Figure 2-54  Sketch of the model

Exercise 6
In this exercise, you will draw the sketch of the model shown in Figure 2-55. The sketch is 
shown in Figure 2-56.                                                                        (Expected time: 30 min)

Figure 2-55  Solid model for Exercise 6 Figure 2-56  Sketch of the model

Answers to Self-Evaluation Test
1. F, 2. F, 3. T, 4. T, 5. F, 6. Edit Sketch, 7. dimensions, 8. T, 9. T, 10. .prt


