
Chapter 3

Creating Base 
Features

After completing this chapter, you will be able to:
• Create Extrude feature
• Create Revolve feature
• Create Sweep feature
• Understand nested sketches

Learning Objectives
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Introduction
When you create a model in the Part mode, the base feature is the first solid feature to be 
created. To create a base feature, you need to enter the Part mode. While creating the base 
feature of a model, the designer must be careful in specifying the attributes, so as to create 
correct features on it. This helps a designer to save time and effort. The base feature is created 
using the datum planes. In the Part mode, there are three datum planes available in the Model 
Tree by default. The datum planes that are available in the Creo Direct are discussed next.   

The default datum planes
Generally, the three default datum planes act as the first feature in the Part mode. These 
datum planes are used to create the base feature. Also, they are used to draw a 2D sketch and 
then convert it into a 3D model by using the feature creation tools. 

Note
Although it is said that the three datum planes act as the first feature in the Part mode, in the 
Model Tree, the RIGHT, TOP, and FRONT datum planes appear as three separate features. 
If you delete any one of them, only that datum plane is deleted. By default, the TOP plane is 
selected as sketching plane.

These three default datum planes are mutually perpendicular to each other. They are not 
referenced to each other and are individual features. When a solid model is created, these 
datum planes adjust their size as per the size of the model. You can create as many datum 
planes as required. The creation of additional datum planes is discussed in Chapter 4.

Selection Processes
Before proceeding to the base feature creation, you need to learn about

Figure 3-1  The Select 
drop-down list

 
the selection processes which can be used for base feature creation.  
You can select an entity by using the options available in the Select 
drop-down list of the Selection group in the Home tab, as shown in 
Figure 3-1. There are two options available in the Select drop-down 
list. These options are discussed next.

Select (with default)
This option is selected by default in the Select drop-down list. As a result, on selecting an 
entity, a live toolbar is displayed with the corresponding option. For example, if you select a 
closed sketch, the options displayed in the live toolbar will be extrude, revolve, and sweep.

Select (no default)
If this option is selected, the live toolbar will not be displayed on selecting an entity. In this 
case, you need to choose a tool from the Ribbon to perform the desired operation.
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Creating base features
In Creo Direct, you can create a base feature by using the Extrude, Revolve, and Sweep tools. 
These tools are available in the Shape group of the Home tab. You can also invoke these tools 
by using the Select (with default) tool available in the Selection group of the Home tab. The 
procedure to create base features is discussed next.

Creating Extrude Features
To extrude a sketch, choose the Select (with default) tool available in the Selection group 
of the Home tab; you will be prompted to select an entity to operate on. Select a sketch; the 
live toolbar will be displayed with the Extrude tool selected in it, refer to Figure 3-2. Also, a 
linear dragger with extrude depth value will be displayed, refer to Figure 3-3. Now, you can 
specify the extrude depth by using the dragger or by entering extrude depth value in the 
edit box displayed on double-clicking on the value displayed in the graphic area. Specify an 
extrude depth and then press the middle mouse button; the extrude feature will be created. 
Figure 3-4 shows the extrude feature created. The options available in the live toolbar are 
discussed next.

Figure 3-2  The live toolbar

Figure 3-3  Linear dragger with extrude depth 
value

Figure 3-4  The extrude feature created 

Solid Geometry
The Solid Geometry option is selected by default and is used to create a solid by 
adding material to the section. Note that if you select a sketch for extrusion using this 
option, then the sketch should be a single closed loop. 
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Surface Geometry
The Surface Geometry option is used to create a surface by adding material to the 
section. Using this option, you can create surface models. In this case, the sketch that 
is drawn for the surface model need not be a closed loop. 

Remove Material
The Remove Material option is available in the Extrude live toolbar only after the 
base feature is created. This is because this option is used to remove the material from 
an existing feature. Therefore, when you create a base feature, this button is not 

available. The use of this option is explained in later chapters.

Capped Ends
The Capped Ends option is used to create the surface feature that is closed at both the 
ends. When you choose this option, the surface model will be created with its end faces 
capped.

Material Side
The Material Side option is available only when you choose the Remove Material 
option. This option is used while creating the second feature or removing the material. 
It toggles the direction of material removal. 

Extrude Taper
The Extrude Taper option is used to add a taper to the entity being extruded. If you 
select this option, an angular dragger will be displayed, as shown in Figure 3-5. Now, 
you can specify the taper value by using this dragger or by entering a new value in the 

edit box that is displayed on double-clicking on the taper value displayed in the graphic area. 
Note that you can also provide taper in opposite direction by providing a negative value for 
taper or by dragging the dragger in opposite direction. Figure 3-6 shows the extruded feature 
with tapered surfaces created.

Figure 3-5  The angular dragger with soft 
dimensions

Figure 3-6  Extruded feature with tapered 
surfaces

Complete Sketch
This button is available in the Sketch group of the Home tab. It is used to exit the 
sketch environment.
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Figures 3-7, 3-8, and 3-9 show the sections and their respective extruded features.

Figure 3-7  The I-section extruded to a certain depth

Figure 3-9  Model created using the Extrude 
tool

Figure 3-8  Model created using the Extrude 
tool

Note
You can also invoke the Extrude tool from the Shape group of the Home tab. This method is 
generally used when the Select (no default) tool is selected in the Select drop-down of the Select 
group. The procedure to create the extrude feature is same as explained above.  

Creating Revolve Features
Some of the points to be kept in mind while creating a revolve feature are given next.

1.	 If the revolve feature is a solid feature, then the section drawn should be a closed one 
so that the revolved feature can be created as solid.

2.	 You need to draw a centerline to complete the sketch of the revolved feature, or select an 
axis of the coordinate system, an existing straight curve, or an edge of an existing feature 
as the axis of revolution.
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3.	 The section should be drawn on one side of the centerline.

To revolve a sketch, choose the Select (with default) tool available in the Selection group of 
the Home tab; you will be prompted to select the entity to operate on. Select the sketch to be 
revolved; an angular dragger with default values will be displayed. By default, the Extrude 
tool is chosen in the live toolbar. Choose the Revolve tool; the options related to revolve will be 
displayed in the live toolbar, as shown in Figure 3-10. Now, specify the centerline by selecting 
an edge, line, or an axis; the angular dragger will be displayed, as shown in Figure 3-11. Now, 
you can specify the angular value by using the dragger or by entering a value in the edit box 
displayed on double-clicking on the value displayed along the dragger. Figure 3-12 shows the 
revolved feature after specifying the values. The options available in the live toolbar are similar 
to the Extrude. Figures 3-13 and 3-14 show two examples of revolving a sketch.

Figure 3-10  The live toolbar

Figure 3-11  Angular dragger displayed after 
specifying the centerline

Figure 3-12  The revolve feature created

Figure 3-13  Example 1 Figure 3-14  Example 2
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Note
You can also invoke the Revolve tool from the Shape group of the Home tab. This method is 
generally used when the Select (no default) tool is selected in the Select drop-down of the Select 
group. The procedure to create the revolve feature is same as explained above.

Creating Sweep Features
To sweep a sketch, choose the Select (with default) tool available in the Selection group of the 
Home tab; you will be prompted to select the entity to operate on. Select a sketch to sweep; a 
dragger with default values will be displayed. By default, the Extrude tool is chosen. Choose 
the Sweep tool from the live toolbar; the options related to sweep will be displayed in the live 
toolbar, as shown in Figure 3-15 and you will be prompted to select an entity to define the 
trajectory. Select the spline curve as a trajectory, refer to Figure 3-16; the preview of the sweep 
feature will be displayed. Note that the trajectory should intersect the plane of the section. 
Now, you can specify the sweep value by using the dragger or by entering a value in the edit 
box displayed on double-clicking on the original value. Next, click anywhere in the empty 
area of the screen; the sweep feature will be created. Figures 3-16 and 3-17 show the sketch 
and sweep features created.

Figure 3-15  The live toolbar

Figure 3-17  Shaded image of the sweep featureFigure 3-16  Section swept along the sketched 
trajectory

The options available in the live toolbar are discussed next. 

Normal to Trajectory
This option is used to make the sweep section normal to the trajectory of sweep. 
Figure 3-18 shows the preview displayed after selecting the Normal to Trajectory 
option.
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Constant Normal
This option is used to make the sweep section parallel to the plane in which the sketch 
is created. Figure 3-19 shows the preview of sweep displayed after selecting the Constant 
Normal option. 

Figure 3-18  Sweep section normal to the 
trajectory

Figure 3-19  Sweep section parallel to the plane

Constant Normal Direction
This option will become active when you select the Constant Normal option. This 
option is used to select a new reference plane with which you need to make sweep 
feature parallel. Figures 3-20 and 3-21 show the previews of the sweep feature with two 

different planes selected as reference.

Figure 3-20  Section swept along the sketched 
trajectory

Figure 3-21  Section swept along the sketched 
trajectory

Full
This option is used to sweep the sketch to the entire length of a closed sketch. 
Figures 3-22 and 3-23 show the previews of sweep feature before and after using the 
Full option. Alternatively, you can use drag handle to drag the length of sweep.
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Figure 3-22  Section swept along the sketched 
trajectory

Figure 3-23  Section swept along the sketched 
trajectory

Note
You can also invoke the Sweep tool from the Shape group of the Home tab. This method is 
generally used when the Select (no default) tool is selected in the Select drop-down of the 
Selection group. The procedure to create the sweep feature is same as explained above.

Rest of the options available in the live toolbar are similar as discussed while creating extrude 
features.

Tip: The following points should be remembered while creating a sweep feature:

1.	 Similar to other sketched features, the trajectory of the sweep feature is also 
sketched after selecting a sketching plane.

2.	 At bends in a trajectory, the radius of the bend should be proportionate to the 
cross-section to be swept to avoid overlapping. If the section size is large and 
the radius of the curve or bend is small, overlapping takes place and the sweep 
feature will not be created. Therefore, make sure that the ratio of the size of the 
section to the size of the trajectory is appropriate.

Nesting of Sketches
In the sketch of a single feature, if you draw multiple closed loops one inside the other, it is called 
nesting of sketches. These sketches are drawn in the sketcher environment. Figure 3-24 shows 
a nested sketch in which two circles are created on the base profile. Figure 3-25 shows the 
resultant extruded feature. The advantages of nesting the sketches is that the number of 
features used to create a model is reduced. For example, in Figure 3-25, the model has two 
features. The base feature is the base plate and the second feature are the holes in the model. 
But, when you nest the two sketches to create the model, you used only one feature to create 
the model. Also, there is a disadvantage of nested sketch. In nesting, since the two features 
on the model are combined into one feature, therefore there is no flexibility in editing the 
features of a model.
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Figure 3-24  Nested sketch Figure 3-25  Solid model of the sketch

Note
After understanding the advantages and disadvantages of nesting the sketches, it is recommended 
to divide a model into separate features. Draw all features as individual features so that the 
created model is flexible. However, it depends on the need of the designer and the approach of 
creating the model. 

Tutorials
Tutorial 1

In this tutorial, you will create the model shown in Figure 3-26. The dimensions of the model 
are shown in Figure 3-27.			    		    (Expected time: 30 min)

	 The following steps are required to complete this tutorial:

a.	 Set the working directory and create a new object file in the Part mode.
b.	 First examine the model and then determine the type of protrusion for the model.	

Select the sketching plane for the model and orient it parallel to the screen.
c.	 Draw the sketch by using the sketching tools, refer to Figures 3-28.
d.	 Create the model by extruding the sketch, refer to Figure 3-30.

Setting the Working Directory
	 After starting Creo Direct session, the first task is to set the working directory. A working 

directory is a directory on your system where you can save the work done in the current 
session of Creo Direct. You can set any existing directory on your system as the working 
directory.

1.	 Choose the Manage Session > Select Working Directory from the File menu; the Select 
Working Directory dialog box is displayed. Browse to the C:\CreoDirect-2.0 folder.

2.	 Choose the Organize button from the Select Working Directory dialog
box; a flyout is displayed. Choose the New Folder option from the flyout; 
the New Folder dialog box is displayed.  
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Figure 3-27  The front and right views of the 
model with dimensions

Figure 3-26  The isometric view of the model

3.	 Enter c03 in the New Directory edit box and choose OK from the New Folder dialog 
box. Now, you have created a folder named c03 in C:\CreoDirect-2.0. 

4.	 Next, choose OK from the Select Working Directory dialog box; the working directory 
is set to C:\CreoDirect-2.0\c03.

Starting a New Object File
	 Solid models are created in the Part mode of Creo Direct. The file extension for the files 

created in this mode is .prt.

1.	 Choose the New option from the File menu; the New dialog box is displayed. The Part 
button is chosen by default in the Type area of the New dialog box.

2.	 Enter the file name as c03tut1 in the Name edit box and choose the OK button. The TOP 
plane is displayed in the drawing area, by default. Also, the Model Tree appears on the 
left of the drawing area in the Navigator.

3.	 Close the Model Tree by choosing the Toggle the display of the navigation area 
button available at the right edge of the Navigator. Now, the drawing area is 
increased.

Drawing the Sketch
	 You need to draw the sketch of the solid model that will be extruded later to create the 

3D model.

1.	 Choose the Sketch Plan View button from the In-graphics toolbar to make the sketching 
plane parallel to the screen.
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2.	 Choose the Line/Arc Chain tool from the Line drop-down of the Sketch group in 
the Home tab; you are prompted to specify the first point of line.                	                  

3.	 Specify 0 in the X edit box of the dynamic input. 

4.	 Next, press the down key; the Y edit box is activated. Specify 0 in the Y edit box and press 
ENTER; the start point of the line is specified and one end of the line is attached to the 
cursor.

 
5.	 Move the cursor horizontally towards the left direction and specify the length of line as 

400.

6.	 Move the cursor in the vertical upward direction and specify the length of line as 300.

7.	 Move the cursor horizontally towards the right direction and specify the length of line as 
400.

Figure 3-28  Sketch created

8.	 Move the cursor in the vertical downward 
direction and specify the length of line as 
100.

9.	 Move the cursor horizontally towards the 
left direction and specify the length of line 
as 100.

10.	 Move the cursor horizontally towards the 
left direction and press S. Next, move the 
cursor in the vertical downward direction 
and specify the arc length and angle for 
the arc as 100 and 270, respectively.

11.	 Next, move the cursor horizontally towards the right direction and specify the length of 
line as 100.

12.	 Move the cursor in vertical downward direction and specify the length of line as 100. 
Figure 3-28 shows the sketch created.

Extruding the Sketch
1.	 Choose the Extrude tool available in the Shape group of the Home tab; you are prompted 

to select a sketch region to extrude.

2.	 Select the sketch, refer to Figure 3-28; the preview of the extrude with default extrude 
value is displayed, as shown in Figure 3-29. Also, the live toolbar is displayed. You can 
orient the model by using the middle mouse button. 
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3.	 Double-click on the extrude value; a edit box is displayed. 

4.	 Specify the value of extrude as 200 in the edit box and press ENTER. Next, click anywhere 
in the empty area of the screen; the extrude feature is created, as shown in Figure 3-30.

Figure 3-29  Preview of the extrude displayed with 
the live toolbar

Figure 3-30  The extrude feature created

Saving the Model and Closing the File
1.	 Choose the Save option from the File menu or choose the Save button from the Quick 

Access Toolbar; the Save Object dialog box is displayed with the name of the object file 
that you have specified earlier in the Model Name edit box of the dialog box. 

2.	 Choose the OK button from the Save Object dialog box to save the file. 

3.	 Choose File > Close from the File menu to close the file.

Note
You can also change the current name of the file before saving it by choosing the Rename option 
from the Manage File flyout in the File menu. On doing so, the Rename dialog box will be 
displayed. Enter the required name of the file in the New Name edit box and then choose the 
OK button to accept the new name.
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Tutorial 2
In this tutorial, you will create the model shown in Figure 3-31. The dimensions of the model 
are shown in Figure 3-32.					     (Expected time: 30 min)

Figure 3-31  The isometric view of the solid 
model

Figure 3-32  Different views of the solid model

     	

The following steps are required to complete this tutorial:

a.	 Create a new object file in the Part mode.
b.	 First examine the model and then determine the type of protrusion required for the 

model. Next, select the sketching plane for the model.
c.	 Draw the sketch for the revolved feature and a centerline to revolve it, refer to 

Figure 3-33.
d.	 Revolve the sketch, as shown in Figure 3-35.
e.	 Save the model and exit the environment.

Setting the Working Directory
	 The working directory was selected in Tutorial 1; therefore, there is no need to select it 

again. But if you are starting a new session of Creo Direct, you need to set the working 
directory again by following the steps given below.

1.	 Open the Navigator by choosing the Toggle the display of the navigation area  button 
at the bottom left corner of the main window of Creo Direct; the Navigator slides out. In 
the Navigator, choose the Folder Browser tab; the Folder Tree is displayed at the bottom. 
Click on the black arrow on the right of the Folder Tree; the Folder Tree expands.

2.	 Click on the node adjacent to the CreoDirect-2.0 folder in the Navigator; the contents of 
the CreoDirect-2.0 folder are displayed.

3.	 Now, right-click on the c03 folder to display a shortcut menu. Choose the Set Working 
Directory option from the shortcut menu; the working directory is set to c03.
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4.	 Close the Model Tree by choosing the Toggle the display of the navigation area  
button available at the right edge of the Navigator.    			          

Starting a New Object File
1.	 Open a new object file in the Part mode and then name the file as c03tut2. The default 

datum plane is displayed in the drawing area. 

2.	 If the datum planes are not displayed by default then turn on the display of datum planes 
by using the Plane Display button from the Datum Display Filters drop-down in the 
In-graphics toolbar.

Drawing the Sketch
	 Now, you need to draw the sketch of the revolved feature. The sketch to be drawn is the 

cross-section of the revolved feature, which will be revolved about the centerline.

1.	 Choose the Sketch Plan View button from the In-graphics toolbar to make the sketching 
plane parallel to the screen.

 
2.	 Choose the Line/Arc Chain tool from the Line drop-down of the Sketch group in 

the Home tab; you are prompted to specify the first point of line.
	
3.	 Specify 0 in the X edit box of the dynamic input. 

4.	 Next, press the down key; the Y edit box is activated. Specify 0 in the Y edit box and press 
ENTER; the start point of the line is specified and one end of the line is attached to the 
cursor.

5.	 Move the cursor in vertical upward direction and specify the length of line as 500.

6.	 Move the cursor horizontally towards the left direction and specify the length of line as 
300.

7.	 Move the cursor in the vertical downward direction and specify the length of line as 
100.

8.	 Move the cursor horizontally towards the right direction and specify the length of line as 
200.

9.	 Move the cursor in the vertical downward direction and specify the length of line as 
200.

10.	 Move the cursor horizontally towards the left direction and specify the length of line as 
400. 

11.	 Move the cursor in the vertical downward direction and specify the length of line as 
100. 
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12.	 Move the cursor horizontally towards the right direction and specify the length of line as 
300. Next, move the cursor in vertical downward direction and specify the length of line 
as 100. 

13.	 Move the cursor horizontally towards the

Figure 3-33  Sketch created

 
right direction and specify the length of 
line as 200. 

	 Figure 3-33 shows the  sketch created for 
creating the revolved feature.

Revolving the Sketch
1.	 Choose the Revolve tool available in the 

Shape group of the Home tab; you are 
prompted to select a sketch region to 
revolve.

2.	 Select the sketch, refer to Figure 3-33; you 
are prompted to select the axis or straight 
edge for axis of rotation.

3.	 Select the edge of sketch as centerline, refer to Figure 3-33; the preview of the revolve 
feature is displayed with default revolve value, as shown in Figure 3-34. Also, the live 
toolbar is displayed. You can use the middle mouse button to orient the model.

4.	 Double-click on the angle value; a edit box is displayed. 

5.	 Specify the angle for revolve as 360 in the edit box and press ENTER. Next, click anywhere 
in the empty area of the screen; the revolve feature is created, as shown in Figure 3-35. 

Figure 3-34  Preview of the revolve feature 
displayed

Figure 3-35  Revolve feature created
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Saving the Model
1.	 Choose the Save option from the File menu or choose the Save button from the Quick 

Access Toolbar; the Save Object dialog box is displayed with the name of the object file 
specified earlier.

2.	 Choose the OK button to save the file.

Closing the Current Window
	 The given model is completed and is also saved. Now, you can close the current 

window.

1.	 Choose File > Close from the menu bar.

Note
If you need to view the Model Tree of the model that you have created, then you need to open it. 
To do so, choose the Toggle the display of the navigation area button on the bottom left corner 
of the screen; the Model Tree is displayed. To close the Model Tree, choose the button again.

Tutorial 3

In this tutorial, you will create the model shown in Figure 3-36. The dimensions of the sketch 
are shown in Figure 3-37. 					       (Expected time: 30 min)
              							             	
	 The following steps are required to complete this tutorial:

a.	 Create a new object file in the Part mode.
b.	 First examine the model and then determine the type of protrusion for the model. 
c.	 Draw the sketch by using the sketching tools, refer to Figure 3-38.
d.	 Extrude the model, refer to Figure 3-40.
e.	 Save the model and close the file.

Figure 3-36  The isometric view of the model Figure 3-37  Front and bottom views of the model
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	 The working directory was selected in Tutorial 1, and therefore, you do not need to select 
the working directory again. But if a new session of Creo Direct is started, then set the 
working directory using the Navigator.

Starting a New Object File
1.	 Open a new object file in the Part mode and then name it as c03tut3. 

	 If the default datum plane is not turned off in the previous tutorial, they will appear in 
the drawing area. If the datum plane is not displayed, then turn them on by using the 
Plane Display button.

Drawing the Sketch
     In this section, you need to draw the sketch for the extruded model using the sketcher 

tools. 

1.	 Choose the Sketch Plan View button from the In-graphics toolbar to make the sketching 
plane parallel to the screen. 

2.	 Choose the Line/Arc Chain tool; you are prompted to specify the first point of line.

3.	 Specify 0 in the X edit box of the dynamic input. 

4.	 Next, press the down key; the Y edit box is activated. Specify 0 in the Y edit box and press 
ENTER; the start point of the line is specified and one end of the line is attached to the 
cursor.

5.	 Move the cursor horizontally towards the left direction and specify the length of line as 
1000.

6.	 Move the cursor in the vertical upward direction and specify the length of line as 200.

7.	 Move the cursor horizontally towards the right direction and specify the length of line as 
200.

8.	 Move the cursor in the vertical upward direction and press S. 

9.	 Next, move the cursor horizontally towards the right direction and specify the length and 
angle of arc as 600 and 0, respectively.

10.	 Move the cursor horizontally towards the right direction and specify the length of line as 
200.

11.	 Move the cursor in the vertical downward direction and specify the length of line as 200; 
refer to Figure 3-38.  
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Figure 3-38  Sketch of the thin extruded model

Extruding the Sketch
1.	 Choose the Extrude tool available in the Shape group of the Home tab; you are prompted 

to select the sketch region to extrude.

2.	 Select the sketch, refer to Figure 3-38; the preview of the extrude feature is displayed, as 
shown in Figure 3-39. Also, the live toolbar is displayed

3.	 Double-click on the extrude value; a edit box is displayed.

4.	 Specify the value as 300 in the edit box and press ENTER. Next, click anywhere in the 
empty area of the screen; the extrude feature is created, as shown in Figure 3-40.

Figure 3-40  The extrude feature createdFigure 3-39  Preview of the extrude feature 
displayed
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Saving the Model
1.	 Choose the Save option from the File menu or choose the Save button from the Quick 

Access Toolbar; the Save Object dialog box is displayed with the name of the object file 
specified earlier.

2.	 Choose the OK button to save the file.

Closing the Current Window
	 The given model is completed and is also saved. Now, you need to close the current 

window.

1.	 Choose File > Close from the menu bar.

Tutorial 4

In this tutorial, you will create the model shown in Figure 3-41. The dimensions of the sketch 
are shown in Figure 3-42. 					       (Expected time: 30 min)
              							             
	 The following steps are required to complete this tutorial:

a.	 Create a new object file in the Part mode.
b.	 First examine the model and then determine the type of protrusion for the model. 
c.	 Draw the sketch by using the sketching tools, refer to Figure 3-43.
d.	 Create the Sweep feature, refer to Figures 3-44 and 3-45.
e.	 Save the model and close the file.

Figure 3-41  The isometric view of the model Figure 3-42  Drawing views of the model with 
dimensions

	 The working directory was selected in Tutorial 1, and therefore, you do not need to select 
the working directory again. But if a new session of Creo Direct is started, then set the 
working directory using the Navigator as discussed earlier.
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Starting a New Object File
1.	 Open a new object file in the Part mode and then name it as c03tut4. 

	 If the default datum plane is not turned off in the previous tutorial, they will appear in the 
drawing area. If the datum plane is not displayed, turn them on by using the Plane Display 
button.

Drawing the Sketch
1.	 Choose the Sketch Plan View button from the In-graphics toolbar to make the sketching 

plane parallel to the screen. 

2.	 Choose the Center & Ends tool from the Arc drop-down of the Sketch group in the Home 
tab; you are prompted to specify the first point for creating an arc.

3.	 Specify 500 in the X edit box of the dynamic input. 

4.	 Next, press the down key; the Y edit box is activated. Specify 0 in the Y edit box and press 
ENTER; the start point of the line is specified and one end of the line is attached to the 
cursor.

5.	 Move the cursor horizontally towards the left direction and specify the radius and angle 
for the first point as 500 and 180, respectively.

6.	 Move the cursor in the vertical upward direction and specify the angle as 90 to specify the 
second point.

7.	 Next, select the Select (no default) option from the Select drop-down list of the Selection 
group in the Home tab to exit the sketcher environment.

8.	 Choose the Center and Point tool from the Circle drop-down of the Sketch group in the 
Home tab; you are prompted to define the plane for sketching.

9.	 Select the FRONT option from the Planes drop-down list of the Model Tree; the Front 
plane is selected for sketching. Next, choose the Sketch Plan View button from the 
In-graphics toolbar to make the sketching plane parallel to the screen.

10.	 Specify 0 in the X edit box of the dynamic input. 

11.	 Next, press the down key; the Y edit box is activated. Specify 0 in the Y edit box and press 
ENTER; the start point of the line is specified and one end of the line is attached to the 
cursor.

12.	 Next, specify the radius of circle as 150 in the dynamic input. 
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13.	 Similarly, create the another circle with start point as 0, 0 and radius value of 125. 

14.	 Exit the sketcher environment and choose the Standard Orientation button from 
the In-graphics toolbar. Figure 3-43 shows the sketch created for creating the sweep 
feature. 

 
Creating the Sweep feature
1.	 Choose the Sweep tool available in the Shape group of the Home tab; you are prompted 

to select the sketch region to sweep.

Figure 3-43  Sketch created

2.	 Select the region between two circles 
to define the sketch region, refer to 
Figure 3-43; you are prompted to select the 
line or spline to define the trajectory.

3.	 Select the arc to define the trajectory, 
refer to Figure 3-43; the preview of sweep 
with the default sweep value is displayed, 
as shown in Figure 3-44. Also, the live 
toolbar and dragger are displayed. 

4.	 Drag the dragger to the full length of 
trajectory.

5.	 Next, click anywhere in the empty area of 
the screen; the sweep feature is created, as shown in Figure 3-45.

Saving the Model
1.	 Choose the Save option from the File menu or choose the Save button from the Quick 

Access Toolbar; the Save Object dialog box is displayed with the name of the object file 
specified earlier.

2.	 Choose the OK button to save the file.

Closing the Current Window
	 The given model is completed and is also saved. Now, you need to close the current 

window.

1.	 Choose File > Close from the menu bar.
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Figure 3-44  Preview of the sweep created Figure 3-45  Sweep feature created

 Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 All features created in the Part mode are called the base features. (T/F)

2.	 You can extrude a sketch in Creo Direct to both sides of the sketching plane symmetrically. 
(T/F)

3.	 You can create a sweep feature using a closed section and a closed trajectory. (T/F)

4.	 The __________ button is chosen by default when the live toolbar is displayed.

5.	 The __________ button in the live toolbar is used to create a thin revolved model.

6.	 After you exit the sketcher environment, the __________ appear on the model to 
dynamically modify the extrusion depth or the angle of revolution.

7.	 The Revolve tool revolves the sketched section about a __________ through the specified 
angle.

8.	 The Sweep option extrudes a section along a __________.

9.	 The cross-section of a swept feature remains __________ throughout the sweep.
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Review Questions

Answer the following questions:

1.	 Which of the following groups in the Home tab contains the Extrude tool?

		  (a) Edit				   (b) Engineering
		  (c) Shape			   (d) Selection

2.	 How many datum planes are displayed by default when you enter the Part mode?

		  (a) 4				    (b) 3
		  (c) 1				    (d) None of these

3.	 The revolved section should have a centerline. (T/F)

4.	 A revolved section can be drawn on both sides of a centerline. (T/F)

Exercises

Exercise 1

Create the model shown in Figure 3-46. The dimensions of the model are shown in 
Figure 3-47. 						                     (Expected time: 20 min)

Figure 3-46  The isometric view of the model Figure 3-47  The front and right views of the 
model
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Exercise 2
Create the model shown in Figure 3-48. The dimensions of the model are shown in 
Figure 3-49. 							         (Expected time: 30 min)

Figure 3-49  The front view of the modelFigure 3-48  The isometric view of the model

Exercise 3
Create the model shown in Figure 3-50. The dimensions of the model are shown in 
Figure 3-51. 							         (Expected time: 30 min)

Figure 3-50  The isometric view of the model Figure 3-51  The front view of the model
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Exercise 4
Create the model shown in Figure 3-52. The dimensions of the model are shown in 
Figure 3-53. 							         (Expected time: 30 min)

Figure 3-52  The isometric view of the model Figure 3-53  The front view of the model

Exercise 5
Create the model shown in Figure 3-54. The dimensions of the model are shown in 
Figure 3-55. 							         (Expected time: 30 min)

Figure 3-54  The isometric view of the model Figure 3-55  The front view of the model

Answers to Self-Evaluation Test
1. F, 2. T, 3. T, 4. Extrude as solid, 5. Thicken Sketch, 6. handles, 7. geometric centerline. 8. trajectory, 
9. constant


